Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Example: Configuring Frame Relay over MPLS

    The script provided in this section is one way to configure Frame Relay services over MPLS. Explanation notes are provided within the script. You must change the script for your specific configuration.

    The topology example shown in Figure 1 further explains the configuration script.

    Note: The route interface command is used toward the end of the configuration script. You can substitute the mpls-relay command, depending on the tunneling method best for your environment.

    Figure 1: Sample Frame Relay over MPLS Configuration

    Sample Frame Relay over MPLS Configuration
    hostname "host 1"
    exception protocol ftp anonymous null
    !--------------------------------------------------------------------------
    !Configure CT3 interfaces in slot 4 for Frame Relay.
    !--------------------------------------------------------------------------
    !
    controller t3 4/0
     no shutdown
     clock source internal module
     cablelength 5
     t1 1 clock source internal module
     t1 1/1 timeslots 1-24 speed 64
     t1 2 clock source internal module
     t1 2/1 timeslots 1-24 speed 64
    !
    controller t3 4/1
     no shutdown
     clock source internal module
     cablelength 5
     t1 1 clock source internal module
     t1 1/1 timeslots 1-24 speed 64
     t1 2 clock source internal module
     t1 2/1 timeslots 1-24 speed 64
    !--------------------------------------------------------------------------
    !Create virtual router default.
    !--------------------------------------------------------------------------
    virtual-router default
    interface loopback 0
      ip address 222.9.1.1 255.255.255.255
    !--------------------------------------------------------------------------
    !Configure Frame Relay interfaces.
    !--------------------------------------------------------------------------
    interface serial 4/0:1/1
     encapsulation frame-relay ietf
    interface serial 4/0:1/1.1
    frame-relay interface-dlci 17 ietf
    !
    interface serial 4/0:2/1
     encapsulation frame-relay ietf
    interface serial 4/0:2/1.1
    frame-relay interface-dlci 12 ietf
    !
    interface serial 4/1:1/1
     encapsulation frame-relay ietf
     frame-relay intf-type dce
    interface serial 4/1:1/1.1
    frame-relay interface-dlci 17 ietf
    !
    interface serial 4/1:2/1
     encapsulation frame-relay ietf
     frame-relay intf-type dce
    interface serial 4/1:2/1.1
    frame-relay interface-dlci 12 ietf
    !--------------------------------------------------------------------------
    !Create virtual router two. Configure MPLS.
    !--------------------------------------------------------------------------
    virtual-router two
    
    mpls
    mpls ldp tar send list 222.9.1.3
    
    interface loopback 0
      ip address 222.9.1.2 255.255.255.255
      ip router isis
    
    interface atm 2/0
     atm clock inter mod
    interface atm 2/0.1
     atm pvc 1 1 11 aal5snap
     ip address 10.10.11.2 255.255.255.0
     ip router isis
     mpls
     mpls ldp
    router isis
     net 47.0005.80FF.F800.0000.0000.0004.0000.F209.0202.00
     mpls traffic-eng router-id loopback 0
     mpls traffic-eng level-1
     metric-style wide
    !--------------------------------------------------------------------------
    !Create virtual router three. Configure MPLS.
    !--------------------------------------------------------------------------
    virtual-router three
    
    mpls
    mpls ldp tar send list 222.9.1.2
    
    interface loopback 0
      ip address 222.9.1.3 255.255.255.255
      ip router isis
    
    interface atm 2/0.2
     atm pvc 2 1 12 aal5snap
     ip address 10.10.12.3 255.255.255.0
     ip router isis
     mpls
     mpls ldp
    
    router isis
     net 47.0005.80FF.F800.0000.0000.0004.0000.F209.0303.00
     mpls traffic-eng router-id loopback 0
     mpls traffic-eng level-1
     metric-style wide
    !--------------------------------------------------------------------------
    !Create virtual router four.
    !--------------------------------------------------------------------------
    virtual-router four
    
    interface loopback 0
      ip address 222.9.1.4 255.255.255.255
    
    !--------------------------------------------------------------------------
    !Create virtual router five. Configure MPLS.
    !--------------------------------------------------------------------------
    
    virtual-router five
    
    mpls
    
    interface loopback 0
      ip address 222.9.1.5 255.255.255.255
      ip router isis
    
    interface atm 2/1.1
     atm pvc 1 1 11 aal5snap
     ip address 10.10.11.5 255.255.255.0
     ip router isis
     mpls
     mpls ldp
    
    interface atm 2/1.2
     atm pvc 2 1 12 aal5snap
     ip address 10.10.12.5 255.255.255.0
     ip router isis
     mpls
     mpls ldp
    
    router isis
     net 47.0005.80FF.F800.0000.0000.0004.0000.F209.0505.00
     mpls traffic-eng router-id loopback 0
     mpls traffic-eng level-1
     metric-style wide
     !--------------------------------------------------------------------------
     !Create MPLS tunnel from VR three to VR two. Route Frame Relay traffic via MPLS tunnel.
     !--------------------------------------------------------------------------
     vir three
    
     interface tunnel mpls:3
     tunnel destination 222.9.1.2
    
     interface serial 4/1:2/1.1
     route interface tunnel mpls:3 45
    
     vir two
    
     interface tunnel mpls:2
     tunnel destination 222.9.1.3
    
     int ser 4/1:1/1.1
     route interface tunnel mpls:2 45
    

    Published: 2014-08-18