Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

 
 

Scenario A: Upgrade of Ubuntu 16.04 to Ubuntu 18.04

  • Begin by disabling the apache2 and netrounds-callexecuter services:

  • Stop all Paragon Active Assurance services:

  • Take backups of Paragon Active Assurance product data.

    Note:

    This is the backup procedure described in the Lifecycle Management Guide, chapter Backing Up Product Data, only more briefly worded.

    Run these commands:

    Note:

    The pg_dump command will ask for a password which can be found in /etc/netrounds/netrounds.conf under "postgres database". The default password is "netrounds".

    Note:

    For a large-scale setup (> 50 GB), making a tarball of the RRD files might take too long, and taking a snapshot of the volume can be a better idea. Possible solutions for doing this include: using a file system that supports snapshots, or taking a snapshot of the virtual volume if the server is running in a virtual environment.

  • Check the integrity of the database using the supplied script netrounds_2.35_validate_db.sh.
Warning:

If this script outputs warnings, do not attempt the database migration procedure described below. Contact Juniper support by filing a ticket at https://support.juniper.net/support/requesting-support (supplying the output from the script) to have the problems with the database resolved before you proceed with the upgrade.

  • Take backups of the Control Center configuration files:

    • /etc/apache2/sites-available/netrounds-ssl.conf
    • /etc/apache2/sites-available/netrounds.conf
    • /etc/netrounds/netrounds.conf
    • /etc/netrounds/probe-connect.conf
    • /etc/netrounds/restol.conf
    • /etc/netrounds/secret_key
    • /etc/netrounds/test-agent-gateway.yaml
    • /etc/openvpn/netrounds.conf

    For example:

  • Upgrade Ubuntu to version 18.04. A typical upgrade procedure is as follows (adapted from https://wiki.ubuntu.com/BionicBeaver/ReleaseNotes):

    • To upgrade on a server system:
      • Install update-manager-core if it is not already installed.
      • Make sure the Prompt line in /etc/update-manager/release-upgrades is set to 'lts' (to ensure that the OS is upgraded to the 18.04, the next LTS version after 16.04).
      • Launch the upgrade tool with the command sudo do-release-upgrade.
      • Follow the on-screen instructions. As far as Paragon Active Assurance is concerned, you can keep the defaults throughout. (It may of course happen that you need to make different choices for reasons unrelated to Paragon Active Assurance.)
  • Once Ubuntu has been upgraded, reboot the system. Then perform the following steps:

  • Upgrade PostgreSQL.

    • Update PostgreSQL database files from version 9.5 to version 10:

    • Remove the outdated version of PostgreSQL:

  • Update Paragon Active Assurance packages.

    • Compute the checksum for the tarball containing the new Control Center version and verify that it is equal to the SHA256 checksum provided on the download page:

    • Unpack the Control Center tarball:

    • Install new Control Center packages:

  • Remove the obsolete packages:

    Note:

    It is vital to remove these packages.

  • Run the database migration:

    Note:

    Before doing the migration, you must ensure that the database integrity check described above completes without error.

    The ncc migrate command takes considerable time to execute (many minutes). It should print the following (details omitted below):

  • (Optional) Update the ConfD package if you need ConfD:

  • Compare the previously backed-up configuration files with the newly installed ones, and manually merge the contents of the two sets of files (they should remain in the same locations).

  • Enable the apache2, kafka, and netrounds-callexecuter services:

  • Start Paragon Active Assurance services:

  • To activate the new configuration, you also need to run:

  • Install new Test Agent repositories:

  • Since support for Test Agent Lite was dropped in version 2.35, you should remove the old Test Agent Lite packages if you have them installed: