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About This Guide

Use this guide to understand the Paragon Planner web UI where you can simulate and analyze various
network scenarios without affecting your live network. This guide documents the features that are
supported in the Paragon Planner web UI.
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Paragon Planner Overview

IN THIS SECTION

Key Features and Use Cases  |  2

Benefits of Paragon Planner  |  3

Juniper’s Paragon Automation suite of applications includes Paragon Planner, which helps network
operators to effectively plan and design their network.

Paragon Planner is a network modeling tool that enables offline visualization of network resources and
provides detailed architectural planning of the production networks. Paragon Planner allows you to
simulate network changes and other traffic scenarios without affecting the live network. Paragon
Planner helps you forecast the effect of network changes and assess the network for potential failure
scenarios.

NOTE: Support for Paragon Planner web application is a Beta feature in the Paragon Automation
Release 21.3.

Key Features and Use Cases

Key features and use cases of Paragon Planner include:

• Automatically construct network topologies by using data snapshots of live networks (obtained from
Paragon Pathfinder) or source data from stored network configuration files and other sources.

• Perform capacity planning to determine whether there is sufficient capacity or if more capacity
should be added, and which links can be pruned without compromising resiliency.

• Analyze traffic loads to determine accurate link utilization for failure simulation.

• Validate network changes (in a safe, virtual environment) before deployment.

• Run what-if scenarios to anticipate the impact of any network change.

• Create and model VPNs, simulate VPN routing, and generate VPN traffic.
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• Simulate multicast flows based on user-defined multicast groups and demands.

• Design and simulate MPLS traffic engineering (MPLS-TE) and label-switched path (LSP) routing.

• Assess network resiliency against different failure scenarios and analyze how traffic is rerouted and
its effect on network links.

• Ensure service-level agreement (SLA) compliance by a modeling class of service (CoS) classes and
policies and queuing schemes. (You can define application flows based on CoS to enable the
modeling of voice over IP (VoIP) or video on demand (VOD) traffic.)

• Model and analyze BGP routing.

• Hardware inventory.

• Network integrity checks.

Benefits of Paragon Planner

• Lower CapEx and OpEx (hardware and maintenance costs) by using Paragon Planner's tariff-based
design, MPLS LSP, and segment routing traffic engineering (SR-TE) features for effective utilization of
the network, and superior design optimization.

• Quickly diagnose performance problems by using flow analysis, congestion detection and analysis,
peak utilization analysis, and multicast simulation features.

• Optimize plans for future network growth (to meet business needs) by using capacity planning and
data forecasting.

• Avoid problems and mitigate risk by assessing the network using Planner’s resiliency analysis, fiber
cut analysis, and so on.

• Validate new services, equipment, and technologies before they are rolled out.

RELATED DOCUMENTATION

Paragon Planner Web UI Overview  |  6
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Understand Differences between Paragon
Pathfinder and Planner

This topic explains key differences between Paragon Pathfinder and Paragon Planner, two applications
that belong to the Paragon Automation suite of applications:

• Paragon Pathfinder (formerly NorthStar Controller) is a traffic engineering solution that simplifies and
automates provisioning, management, and monitoring of segment routing and IP/MPLS flows across
large networks.

• Paragon Planner (formerly NorthStar Planner) is a network modeling tool that can be used for offline
visualization and detailed architectural planning of any production network.

Table 1 on page 4 lists the key differences between the two applications.

Table 1: Differences between Paragon Pathfinder and Paragon Planner

Paragon Pathfinder Paragon Planner

Paragon Pathfinder enables you to monitor your live
network. and any changes that you make in Pathfinder
are propagated to your live network.

Paragon Planner is an offline modeling application,
which means that changes that you make in Planner do
not affect your live network.

Pathfinder can connect to the live network because of
the connectivity between Pathfinder and the live
network.

Planner has no capability to connect to the network
because there's no connectivity between Planner and
the network.

In Pathfinder, there's only one live network model. In Planner, you can have one or more offline network
models, which means you can analyze and compare
impact of different design changes or failure scenarios.
However, the changes are not propagated into the live
network.
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Table 1: Differences between Paragon Pathfinder and Paragon Planner (Continued)

Paragon Pathfinder Paragon Planner

In Pathfinder, the network model is based on the
traffic-engineering database, which is based on the
current (real time) status of the network.

For example, if you configure a link that later goes
down, the down status of the link is reflected in the
traffic-engineering database, but not in the router's
configuration.

The network models that we use in Planner are from
archives and collections in Pathfinder, which means
that Planner relies on data from Pathfinder.

Planner builds the model of the network using router
configuration files. Therefore, Planner displays an
intent-based model (configuration) with some
supplemental live information from Pathfinder, such as
initiated label-switched paths (LSPs), which are not
available in the router's configuration.

In Pathfinder, any changes you make to the network
model affects the live network.

Planner allows you to run what-if scenarios, which
allow you to make changes to the network model and
see the effect of those changes, without affecting the
live network.

In Pathfinder, you can perform a maintenance event
simulation. You define a maintenance event by
specifying what happens, for example, a router goes
down or a link fails. Then, based on that event, you
simulate what happens to the live LSPs and traffic
demands.

In Planner, you can run failure simulations (for example,
fail a link or a router) and analyze the impact on traffic
demand or LSP tunnels.

The network topology map shows live node status, link
utilization, and LSP paths.

The network topology map shows simulated or
imported data for nodes, links, and LSP paths.

Network information table shows live status of nodes,
links, and LSPs.

Network information table shows simulated or
imported data for nodes, links, and LSPs.

Discover nodes, links, and LSPs from the live network
by using Path Computation Element (PCE) protocol
(PCEP), BGP-LS,or NETCONF.

Import and parse router configuration, or add nodes,
links, and LSPs for network modeling.

Provision LSPs directly to the network. Add and stage LSPs to the offline model for simulation.
However, you cannot provision LSPs to the live
network.

Create or schedule maintenance events to reroute
LSPs around the impacted nodes and links.

Create or schedule simulation events to analyze the
network model from failure scenarios.
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Table 1: Differences between Paragon Pathfinder and Paragon Planner (Continued)

Paragon Pathfinder Paragon Planner

Dashboard reports show the current status of and key
performance indicators (KPIs) for the live network.

Report manager provides extensive reports for
simulation and planning.

Collects real-time interface traffic or delay statistics,
and stores the data for querying and for displaying in
charts.

Import interface data or aggregate archived data to
generate historical statistics for querying and
displaying in charts.

Accessing Web Planner

You can launch the Paragon Planner web application from within the Paragon Automation GUI.

Navigate to Planning > Paragon Planner page from the left-navigation menu of the Paragon Automation
GUI to launch the Paragon Planner in a new tab.

NOTE: For information on how to log in to Paragon Automation, see Single Sign-On Overview
and Accessing the Paragon Automation GUI in the Paragon Automation User Guide.

Paragon Planner Web UI Overview

IN THIS SECTION

Network Browser View  |  7

Topology View  |  8

Simulation View  |  10

Once you have logged into the Paragon Automation, you can access the Paragon Planner GUI by
selecting Planning > Paragon Planner.
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The Paragon Planner Network Browser opens in a new tab displaying the Sessions page.

The Paragon Planner Web Application UI has the following main views:

• "Network Browser" on page 7

• "Topology" on page 8

• "Simulation" on page 10

Network Browser View

Paragon Planner's Network Browser has the following tabs on the left-navigation menu:

• Sessions Tab—A session is like an instance of a network. In the session, you can make changes to the
network, view reports, and run failure simulations. For more information, see "About the Sessions
Page" on page 12.

• Network Models Tab:

• Saved Network Models—Network models that are stored in the Planner database are displayed
here. You can start a session or view existing sessions for a network model. You can also import a
network model. For more information, see "About the Saved Network Models Page" on page 14
and "Import Network Using Saved Network Models" on page 16.

• Pathfinder Archives—An archive is a snapshot of a network model. You can generate network
archives from the Paragon Automation Task Scheduler (Administration > Task Scheduler) using the
Network Archive task, after which, the archives are visible in the Pathfinder Archives tab. For
more information, see "About the Pathfinder Archives Page" on page 18.

• Pathfinder Collections—A collection is a group of configuration files of the devices in your
network. You can generate collections from the Paragon Automation Task Scheduler
(Administration > Task Scheduler) using the Device Collection task when Store Collection for
Planner field is selected. This task collects the configuration files from the network elements like
routers and saves the files to the database. After this task is executed successfully, the collections
are visible in the Pathfinder Collections tab. You can then build a network model by importing the
files in the collection. For more information, see "About the Pathfinder Collections Page" on page
19.

• Specification Files—You can migrate your entire existing data directory from your application
server to Paragon Automation. In the specification files, Paragon Planner uses spec. files which
can be used to build a new network model. For more information, see "About the Specification
Files Page" on page 21.

7



NOTE: You can tag the network model as a favorite using the Star icon on the top-right corner
on the topology page. Favorites are displayed in the Favorites tab in the left-navigation of the
Network Browser.

Topology View

Once you start a session for a network model, you will be directed to the Topology Page.

Figure 1: Planner Topology Page

The Planner Topology is the main work area for any network model that you load into the system. It
displays important link and node properties. Links are color-coded according to utilization.

The topology page has the following main sections:

• Left navigation menu with network topology and failure simulation options.

• Customizable topology map displayed at the center. The topology map is a graphical representation
of the baseline network. For more information, see "Interactive Planner Map Features" on page 31.

• A top menu bar that displays important network details and enables you to customize the topology
map. For more information, see "Top Menu Bar Overview" on page 50.
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• A side menu bar that provides the following:

• Zooming options:

• Zoom to Fit—Center and adjust the size of the topology map in the page.

• Zoom In (Plus icon)—Enlarge the topology map size.

• Zoom out (Minus icon)—Reduce the topology map size.

• Path Trace—View current path between two nodes.

1. When you select the Path Trace icon, a message appears in the upper left corner of the
topology map window, prompting you to select a source node on the topology map.

2. When you select your desired source node on the map, you are prompted to select a
destination node.

3. Once you select your desired destination node, the Path window opens on the right displaying
the current routes (links) between the selected nodes. You can click on each link displayed to
zoom in on it on the map.

You can select Highlight Path to highlight the path between the source and destination on the
map in yellow. You can also click Hide Unrelated Nodes/Links to hide all the nodes/links
unrelated to the current path, from the topology map. Once you have hidden the unrelated
nodes/links, you can view the entire network by selecting Show All Nodes/Links.

• Topology Settings— Allows you to customize any network element (nodes, links, or tunnels), and
provides general map settings like animations or map theme. For more information, see

• Network information table at the bottom displaying detailed information about the different network
elements within the following tabs:

• Node

• Link

• Tunnel

• Demand

• Interface

• SRLG/Facility

For more information, see "Network Information Table Overview" on page 52.

• Legend—Click on the Legend graphic at the right to customize the topology map colors based on any
of the following options from the Legend Settings list:

9



• Demand Utilization—Displays the planned link utilization. Planned utilization is the percentage of
the link bandwidth used by the demands you input into the network.

• Demand Peak Utilization—Displays the highest (or worst case) link utilization experienced by each
link, depending on the rerouting of demand/flow traffic after any single failure simulation.

• Demand CoS Utilization—Displays the normal and peak utilization calculated based on demand
routing.

• Measured Link Utilization—Displays the measured interface traffic on a node.

• Planner Node Load—Displays the planned traffic on a node.

You can move the arrows to the left or right on the color slider bar to customize the colors for the
different utilization percentages. You can also click on the individual colors on the color bar to choose
a different color for the display.

Simulation View

Simulation allows you to design and run failure simulations on your network model. This enables you to
test the network’s resiliency and discover worst-case scenarios. You can design a simulation that uses a
single, double, or triple exhaustive failure combinations for a network element of your choice. For more
information, see "About the Failure Simulation Page" on page 77.

RELATED DOCUMENTATION

Paragon Planner Overview  |  2
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Understand How You Can Get a Network Model into
Planner

You can use any of the following methods to get a network model in Planner from the Network Browser:

• From the Task Scheduler (Administration > Task Scheduler) page in Paragon Automation (Pathfinder):

• Add and run a new Device Collection task that collects the configuration data from the devices in
your network. Select the Store Collection to Planner field while creating this task. Once the task
completes, the collection is listed in the Pathfinder Collection page. Select a collection and use
the Import wizard to create a new network model from that collection, after which it is listed it in
the Saved Network Models page. You can then start a planning session for the selected network
model from the Saved Network Models page.

• Add and run a new Network Archive task that archives the data collected from your network.
Select Archive Network Data After Processing while creating this task. Once the task completes,
the archive is listed in the Network Archive page. Since the network archive is a snapshot of the
live network from Paragon Pathfinder, you can directly start a planning session for the selected
archive from the Network Archives page.

• From the Import wizard on the Saved Network Models page, you can import a new network using
the routers/switches configuration, OSPF/ISIS/TED databases, or using by specification (spec) files.

RELATED DOCUMENTATION

About the Saved Network Models Page  |  14

About the Pathfinder Archives Page  |  18

About the Pathfinder Collections Page  |  19

About the Sessions Page

IN THIS SECTION

Tasks You Can Perform  |  13
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This page lists information about ongoing planning sessions. A session is like an instance of a network.
You can think of it as your working directory. When you start a session, you can make changes to the
network, view reports, and run failure simulations on your network topology. When you’re finished with
your work, you can close the session with or without saving. You can attach (or detach) an existing
session for a network model to quickly open up the planner topology page and resume your previous
work. This is much faster than starting a new session every time you want to work on your planner
network. If you save it, it then becomes available in the Network Models > Saved Network Models page.

When you first access the Paragon Planner, the Sessions page will be empty. When you start a session
for a network model, the session related information will appear on this page.

You can log out of Planner or close your browser without explicitly closing your session; the session will
be available for you to resume your work when you log back in because it is still active on the server.
This can save you considerable loading time when you start work again.

Tasks You Can Perform

• Attach Session—Attaches the session for the network model and opens up the Planner topology view
where you can configure the network.

• Detach Session—Detaches the session for the network model. You might have to detach a session to
attach the session back again to open up the Planner topology.

• Group by—Select Model from the list to group sessions based on the network model it is associated
with or select None (default).

• From the More list, you can:

• View details about existing sessions—Click the Details icon when you hover over the session
name or select More > Detail. The Network Details pane appears on the right displaying the
network element names, tunnel, and hop counts.

• Download Model—Click More > Download Model to compress all the network model related files
and download it as a tar.gz file to your local machine.

• Share Session—Click More > Share.. to give access to the session with specific users. By default,
only the user that had started the session can attach and share access to that session.

The Shared Access page appears.

To share or give access to a user:

1. From the Usernames field, select one or more users that you want to give access to.

2. From the list on the right of the Usernames field, select Can Attach.

13



3. Click Add Users.

The user is displayed under Current Users.

4. Click Save once you have completed giving the required access to each user added.

NOTE: To remove access to a user, select Remove from the permissions list next to the
user's name on the Share Access page .

• Edit the session description—Select the session and click the Edit (pencil) icon. In the Description
field, you can enter a text description for the session and click OK. The description is updated and
is displayed on the Sessions page.

• Delete a session—Select the session and click the Delete (trashcan) icon. On the confirmation
message, click Yes. The session is terminated and is removed from the Sessions page.

• Show/Hide Columns—Choose to show or hide a specific column in the table.

Hover over the More Options (vertical ellipsis) > Show/Hide Columns and select the Column-
Name check box of the columns you want to display in the table.

• Reset Preference—Reset the displayed columns to the default set of columns for each tab in the
table.

Hover over the More Options (vertical ellipsis) and select Reset Preference.

• Sort Entries—Click the column name to highlight the up and down arrows next to the column
name, to sort the table entries in ascending or descending order.

RELATED DOCUMENTATION

Paragon Planner Web UI Overview  |  6

About the Saved Network Models Page

IN THIS SECTION

Tasks You Can Perform  |  15
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You can view, download, edit, delete, or share network models that are already saved in the Paragon
Planner database from the Saved Network Models page (Network Models > Saved Network Models).

To save a network model if you wish to work on it again later, on the Planner Topology page, from the
Actions list in the top menu bar, click Save Network or Save Network As. The saved network models are
then listed on the Saved Network Models page. This is the easiest way to build your own repository of
different network models.

You can also import a collection from which you can create a network model. Once the collection import
is successful, the new network model is listed on the Saved Network Models page.

Tasks You Can Perform

• Start Session—Click Start Session to start a new session associated with the selected network model.
You will be redirected to the Topology page where you can configure your network.

• View Sessions—Click View Sessions to see all the sessions associated with the selected network
model on the Sessions page.

• Import Network—Click Import to import your data files that can be converted to a Paragon Planner
network model. For more information, see "Import Network Using Saved Network Models" on page
16.

• From the More list, you can:

• View details about existing network models—Click the Details icon when you hover over the
network model name or select More > Detail. The Session Details pane appears on the right
displaying the network element names, tunnel, and hop counts.

• Download Model—Click More > Download Model to compress all the network model-related files
and download it as a tar.gz file to your local machine.

• Share Network Model—Select the network model and click More > Share.. to give access or share
the network model information with specific users. The user's permission level to view or edit the
network model after attaching to it is determined by the share permission selected here.

The Shared Access page appears.

To share or give access to a user:

1. From the Usernames field, select one or more users that you want to give access to

2. From the list on the right, select one of the following permissions for the user:

• Can view: This option allows the user to only view the network model.
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• Can edit: This option allows the user to view and edit the network model.

3. Click Add Users.

The user is displayed under Current Users.

4. Click Save once you have completed giving the required access to each user added.

NOTE: To remove access to a user, select Remove from the permissions list next to the
user's name on the Share Access page.

• Edit the network model description—Select the network model and click the Edit (pencil) icon. In
the Description field, you can enter a text description for the network model and click OK. The
description is updated and is displayed on the Saved Network Models page.

• Delete a network model—Select one or more network models and click the Delete (trashcan) icon.
On the confirmation message, click Yes. The network model is deleted and is removed from the
Saved Network Models page.

• Show/Hide Columns—Choose to show or hide a specific column in the table.

Hover over the More Options (vertical ellipsis) > Show/Hide Columns and select the Column-
Name check box of the columns you want to display in the table.

• Reset Preference—Reset the displayed columns to the default set of columns for each tab in the
table.

Hover over the More Options (vertical ellipsis) and select Reset Preference.

• Sort Entries—Click the column name to highlight the up and down arrows next to the column
name, to sort the table entries in ascending or descending order.

RELATED DOCUMENTATION

Interactive Planner Map Features  |  31

Import Network Using Saved Network Models

The network import option enables you to import data files that can be converted to a network model.

1. Select Network Models > Saved Network Models.
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The Saved Network Model page appears.

2. Select Import.

The Import Network page appears.

3. Configure the fields as described in Table 2 on page 17.

NOTE: Fields marked with asterisk (*) are mandatory.

4. Click Add.

A confirmation message appears stating that the network import was successful and is available in
the Saved Network Models page.

Table 2: Fields on the Import Network Page

Field Description

Import Type Select one of the following types of import:

• Specs (this is the easiest way to import a network as the spec file is
easily parsed by Paragon Planner)

• Router and Switches (router configuration files)

• OSPF/ISIS Database

• TED Database

NOTE: When you select Routers and Switches, OSPF/ISIS Database, or
TED database as the Import Type, you have the option to select various
optional advanced settings or to ignore one or more IP addresses/ERX
interfaces. For more information, see Import Network Wizard in the
Paragon Planner Desktop Application User Guide.

Network Name Enter a name for the network. Only “ _ - . : > < (symbols) are allowed.
Character limit is be 255.

Description Enter a description for the network.

Import from File Click Browse and navigate to the .tar or tar.gz file that you want to
import.
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RELATED DOCUMENTATION

About the Saved Network Models Page  |  14

About the Pathfinder Archives Page

IN THIS SECTION

Tasks You Can Perform  |  18

You can view information about networks archived from Paragon Pathfinder on the Pathfinder Archives
(Network Models > Pathfinder Archives). An archive is a snapshot of the live network in Pathfinder.

To archive a network from Paragon Pathfinder, you must add and run a Network Archive task. For more
information, see Add a Device Collection Task in the Paragon Automation User Guide. The number of
archives generated depends on the frequency selected during the task creation.

NOTE: Ensure that you select the Archive Network Data After Processing field when you create
the network archive task. Once this task completes, the collection is listed in Pathfinder Archives
page in Paragon Planner.

Tasks You Can Perform

• Start Session—Click Start Session to start a new session associated with the selected network
archive. You will be redirected to the Topology page where you can configure your network.

• From the More list, you can view details about existing network archives—Click the Details icon
when you hover over the archive name or select More > Detail. The Archive Details pane appears on
the right.

• Show/Hide Columns—Choose to show or hide a specific column in the table.

Hover over the More Options (vertical ellipsis) > Show/Hide Columns and select the Column-Name
check box of the columns you want to display in the table.

18



• Reset Preference—Reset the displayed columns to the default set of columns for each tab in the
table.

Hover over the More Options (vertical ellipsis) and select Reset Preference.

• Sort Entries—Click the column name to highlight the up and down arrows next to the column name,
to sort the table entries in ascending or descending order.

RELATED DOCUMENTATION

Paragon Planner Web UI Overview  |  6

About the Pathfinder Collections Page

IN THIS SECTION

Tasks You Can Perform  |  19

You can view or delete collections that are imported from Pathfinder in the Pathfinder Collections
(Network Models > Pathfinder Collections) page. You can import a new network using from the selected
collection.

To import a collection from Pathfinder, you must add and run a Device Collection task to collect
configuration data for all or selected devices in your network. For more information, see Add a Device
Collection Task in Paragon Automation User Guide. After this task completes, the collection is listed in
Pathfinder Collections page. You can then import the collection to build a network model.

NOTE: Ensure that you select the Store Collection to Planner field while creating the network
archive task.

Tasks You Can Perform

You can perform the following tasks from this page:

19



• Import a collection. For more information, see "Import Network from Collection" on page 20.

• Group By—Select Task from the list to group collections based on the device collection task
associated with it or select None (default).

• From the More list, you can view details about existing collections—Click the Details icon when you
hover over the collection name or select More > Detail. The Collection Details pane appears on the
right displaying information about devices associated with the collection (IP address, Management IP
address, and Hostname) and general collection details.

• Delete a collection—Select the collection and click the Delete (trashcan) icon. On the confirmation
message, click Yes. The collection is deleted and is removed from the Pathfinder Collections page.

• Show/Hide Columns—Choose to show or hide a specific column in the table.

Hover over the More Options (vertical ellipsis) > Show/Hide Columns and select the Column-Name
check box of the columns you want to display in the table.

• Reset Preference—Reset the displayed columns to the default set of columns for each tab in the
table.

Hover over the More Options (vertical ellipsis) and select Reset Preference.

• Sort Entries—Click the column name to highlight the up and down arrows next to the column name,
to sort the table entries in ascending or descending order.

RELATED DOCUMENTATION

Paragon Planner Web UI Overview  |  6

Import Network from Collection

The import network option enables you to import data files that can be converted to a network model.

1. Select Network Models > Pathfinder Collections.

The Pathfinder Collections page appears.

2. Select the collection you wish to import and click Import.

The Import Network page appears.

3. Configure the fields as described in Table 3 on page 21.
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NOTE: Fields marked with asterisk (*) are mandatory.

4. Click Add.

A confirmation message appears stating that the network import was successful and is available in
the Saved Network Models page.

Table 3: Fields on the Import Network Page

Field Description

Import Type Automatically selected as Collection Table.

Network Name Enter a name for the network. Only “ _ - . : > < (symbols) are allowed.
Character limit is be 255.

Description Enter a description for the network.

Advanced > Options (Optional) Select the advanced settings. You can also ignore one or more
IP addresses or ERX interfaces by entering the required values in the
Ignore IP Address and Ignore ERX interfaces respectively.

About the Specification Files Page

IN THIS SECTION

Specification File Overview  |  22

Migrate Data from NorthStar to Paragon Automation  |  28

A specification file is a text file that specifies all the network input files to be loaded for the network
model.
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NOTE: Ensure that you perform data migration first as per the procedure described in "Migrate
Data from NorthStar to Paragon Automation" on page 28.

Specification files (spec) are used by the Planner to determine which input directories and files to load
for the network. You can migrate your entire existing NorthStar data directory from your application
server to Paragon Automation. For more information on specification files, see "Specification File
Overview" on page 22.

Within the specification file, navigate and select the required spec. file. A File Details pane appears on
the right. Click Start Activity to create session for the network model.

Specification File Overview

You can read or navigate to the files within the specification file folder. Table 4 on page 22 mentions
these file categories and lists the individual files present in it.

Table 4: Spec File Categories

Type of Files File Names

Backbone Files bblink, demand, domainfile, facility, graphcoord, group, muxloc,
newdemand, nodeparam, owner, site, srvcprofile, and srvctype. See Table
5 on page 23.

Cost Files custrate and usercost. See Table 6 on page 25.

Control Files admincost, fixlink, linkdist, nodeweight, and rsvbwfile. See Table 6 on
page 25

Traffic Files devicedir, egress, ingress, t_trafficload, trafdir, trafficload, and
tunneltrafdir. See Table 7 on page 26.

Access Design Files chanbank, offckt, offgraphcoord, offloc, and offsitek.

Discrete Event Simulation tfxdata and tfxpattern. See Table 8 on page 26.

Device-Specific Files aclist, bgplink, bgpnode, bgpobj, intfmap, junospolicy, policymap, route,
tbit, tunnel, and vpn . See Table 9 on page 27.
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Table 5 on page 23 describes the network backbone files that specify how the network is represented.

Table 5: Spec File Backbone Files List

File Description

bblink The bblink file contains backbone link information for the network.
Each link entry is defined by a link name [optional], From_Location,
To_Location, vendor, number of links, and link type. A vendor may be
specified as DEF (default) if it is not known.

demand The demand file contains user traffic requirements. A demand is
defined by an ID, From_Location, To_Location, Bandwidth, Type,
Priority, and Preempt Priority.

domainfile The domainfile contains the definitions for domain elements. Domain
elements are defined by ID, name, and color to be used in the Map
window. If OSPF is present in the network, this file is used to define
OSPF areas.

facility The facility file defines the links or nodes or both associated with a
facility. In this file, the first field defines the facility name. The
subsequent fields specify the node IDs or link names associated with
that facility, delimited by tabs, spaces, or commas. All elements
associated with a facility should be specified on the same line.
Whenever more than one line is needed to specify the elements, a
backslash, '\', must be used to indicate that the element list is
continued on the next line. The facility feature does not check the
validity of the nodes and/or links listed in the facility file. Duplicate
links and/or nodes are also duplicated in the facility. Nodes may be
specified either by their node ID or node name. If both are used in the
same facility, then that node is duplicated. Nodes which are not in the
mux file and links not in the bblink file are ignored.

graphcoord The graphcoord file is used to position nodes at coordinates different
from their true geographic location. This is helpful when multiple
nodes have the same NPANXX location or are located in close
proximity to each other. You can move the nodes by selecting and
dragging them to the desired location. The pricing information does
not change because the change is only to the graphical representation
and not a physical change.

group The group file defines the grouping of nodes in the network topology.
Discs are painted on the Standard map around grouped nodes.
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Table 5: Spec File Backbone Files List (Continued)

File Description

muxloc Muxloc specifies the file containing switch information such as name,
ID, NPANXX, latitude, longitude, vertical, or horizontal. This
information is used to determine location placement in the map
window as well as for link pricing.

newdemand The newdemand file allows you to specify an additional file
containing user traffic requirements besides the demand file. The
purpose is to reduce your effort in manually modifying the existing
demand file, and/or having multiple versions. In addition, the
newdemand file is often used in theoretical "What if..." situations in
determining capacity planning for the current network state.

nodeparam The nodeparam file allows you to define specific information on a
per-node basis such as the hardware type, vendor, or model.

owner The owner file facilitates identifying the ownership of nodes and
demands. Ownership should be specified in either the muxloc or
demand files.

site The site file specifies site information. The site file is used to define
nodes in the same physical location such as a building or campus.

service profile The service profile file lists the service types and the percentage that
are in each service profile.

service type The service type file lists service types (for example, FTP, TELNET)
and their descriptions (for example, owner, min. and max. bandwidth,
type, pri, pre).

Table 6 on page 25 describes the cost and control files which are used to assign tariffs and implement
link controls.
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Table 6: Cost and Control Files

File Description

custrate The custrate file is used to assign tariffs for links used in the network to
approximate the total cost of the network. You can specify the parameters from
which these tariffs are calculated using the modify custom rate and custom rate
class windows.

usercost The usercost file is used to define the cost for links according to the end nodes,
vendor, and link type.

admincost The admincost file contains rules to set each link default admin weight/metric
according to attributes such as link type, mileage, and the hardware type and sites
of the endpoints.

fixlink The fixlink file specifies information for links that cannot be removed from the
backbone topology. For varying reasons, a customer might have a group of links in
the backbone that cannot be removed (even if it is optimal to do so). In this case,
during the optimization phase of the design, links from the fixlink file are not
modified. Note that the bblink file might be used for the fixlink file if the current
topology cannot be changed.

linkdist The linkdist file is used to define link distance values on a node pair basis. Link
distances can be used to bias path routing by assigning either a higher or lower
weight to a node pair. If a linkdist file is not specified or a particular link’s metric is
not defined, and the Admin Weight routing method is specified in the design
options of the Path Placement tab, the default link distance value is assigned.

nodeweight The nodeweight file is used to restrict the creation of links at particular nodes
during design by assigning to the node a penalty for adding links or the maximum
bandwidth capacity for links. This file can also be used to restrict the transit demand
bandwidth at a node if the hardware model supports path configuration for
demands.

Every entry in the nodeweight file consists of four fields: node ID or name, node
weight (link penalty for design), maximum bandwidth capacity (to carry links), and
transit demand bandwidth limit. Fields are separated by spaces or tabs. A node
weight is required if maximum link bandwidth capacity is to be specified.

rsvbwfile The rsvbwfile is used to define reserved bandwidth for links between specific node
pairs. Reserved bandwidth is specified as a fixed bandwidth (fixfat) plus a
percentage of the link bandwidth (fatpct).

25



Table 7: Traffic Files

File Description

egress The egress file contains egress traffic of the network interfaces load. Egress traffic
specifies traffic that is going out of the network interfaces. This data is used for
calculating link utilization and load.

ingress The ingress file contains ingress traffic of the network interfaces load. Ingress
traffic specifies traffic that is going into the network interfaces. This data is used
for calculating link utilization and load.

trafdir, tunneltrafdir The trafdir file identifies the location of the daily interface traffic directories
repository.

The tunneltrafdir file identifies the location of the tunnel traffic directories
repository.

trafficload, t_trafficload The trafficload file allows you to import measured bandwidth utilization based on
data collected from the network. Traffic loads for each PVC can be specified over
the time intervals for which the data was collected.

The t_trafficload file (IP/MPLS only) is similar to the trafficload file, but for LSP
tunnels (layer 2 instead of layer 3).

Table 8: Discrete Event Simulation

File Description

tfxdata The trafficdata file allows you to define each demand by specifying multiple
packets and packet sizes. Although this requires you to have a reasonable
knowledge of the traffic, more accurate network simulation results can be
obtained in this manner.

tfxpattern The trafficpattern file allows you to define several class types based on traffic
characteristics. Each traffic type may be specified in terms of four parameters:
number of messages, duration (seconds), message size (bits), and frame size
(bytes).

Table 9 on page 27 describes the device specific files that contain the definitions for various types of
devices.
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Table 9: Device-Specific Files

Field Description

aclist The aclist file (Router only) contains information about access rules such as access
lists, distribute lists, and filter lists.

bgplink The bgplink file (Router only) contains the definitions for BGP neighbors.

bgpnode The bgpnode file (Router only) contains the definitions for BGP speakers.

bgpobj The bgpobj file (Router only)contains information about BGP neighbors and is
stored in binary format to speed up performance. Note: If you want to manually
edit bgpnode and bgplink, comment out this entry before reloading the network.

intfmap The intfmap file (Router only) contains information about router interfaces,
including the node, interface, IP address, status, bandwidth, VPN-list, and other
details.

policymap The policymap file (Router only) contains information about CoS Policies on each
router.

tbit The tbit file (Router only) stores names for the tunnel attributes (otherwise
referred to as admin group for Juniper Networks).

tunnel The tunnel file (Router only) contains information about LSP tunnels.

vpn The vpn file (Router only) contains information about Virtual Private Network
details such as vrf, route distinguisher, route target, and protocols.

RELATED DOCUMENTATION

https://www.juniper.net/documentation/en_US/northstar6.2.1/topics/reference-general/ipmpls-file-
backbone.html
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Migrate Data from NorthStar to Paragon Automation

IN THIS SECTION

Migrate NorthStar Planner Data  |  28

Use the steps described in this topic to migrate date from NorthStar to Paragon Automation.

NOTE: Ensure that both the NorthStar and Paragon Automation setups are up and running.

Migrate NorthStar Planner Data

If you want to use saved NorthStar Planner models on the NorthStar application server file system in
Paragon Automation, copy the models using the following steps:
1. Log in to the NorthStar server.

2. Use scp and copy the directory (/opt/northstar/data/specs) where your Planner models are saved to
the Paragon Automation primary node (/root/ns_specs). For example:

[root@ns1-site1-q-pod21 specs]# ls -l /opt/northstar/data/specs
total 8
drwx------ 2 root root 4096 Sep 16 08:18 network1
drwx------ 2 root root 4096 Sep 16 08:18 sample_fish

[root@ns1-site1-q-pod21 data]# [root@ns1-site1-q-pod21 ~]# scp -r /opt/northstar/data/specs 
@10.xx.xx.153:/root/ns_specs
The authenticity of host '10.xx.xx.153 (10.xx.xx.153)' can't be established.
ECDSA key fingerprint is SHA256:haylHqFfEuIEm8xThKbHJhG2uuTpT2xBpC2GZdzfZss.
ECDSA key fingerprint is MD5:15:71:76:c7:d2:2b:0d:fe:ff:0d:5f:62:7f:52:80:fe.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '10.xx.xx.153' (ECDSA) to the list of known hosts.
bblink.x                                                                                      
               100% 3893     2.2MB/s   00:00
bgplink.x                                                                                     
               100%  140     9.6KB/s   00:00
bgpnode.x                                                                                     
               100%  120    56.5KB/s   00:00
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bgpobj.x                                                                                      
               100% 4888     1.8MB/s   00:00
cosalias.x                                                                                    
               100%  385   180.4KB/s   00:00
custrate.x                                                                                    
               100% 1062   184.0KB/s   00:00
demand.x                                                                                      
               100%  104KB   2.1MB/s   00:00
dparam.x                                                                                      
               100%   11KB   2.5MB/s   00:00
...

3. Log in to the Paragon Automation primary node.

4. Copy the /root/ns_specs folder to the NorthStar Planner pod at /opt/northstar/data/specs using the
kubectl command. For example:

root@pa-primary:~# ls -l /root/ns_specs
total 8
drwx------ 4 root root 4096 Sep 16 01:41 network1
drwx------ 4 root root 4096 Sep 16 01:41 sample_fish

root@pa-primary:~# kubectl cp /root/ns_specs  northstar/$(kubectl get po -n northstar -l 
app=ns-web-planner -o jsonpath={..metadata.name}):/opt/northstar/data/specs -c ns-web-planner

5. Verify that the NorthStar Planner models are copied inside the NorthStar Planner pod at /opt/
northstar/data/specs/ns_specs.

root@pa-primary:~/ns_specs# kubectl exec -it $(kubectl get po -n northstar -l app=ns-web-
planner -o jsonpath={..metadata.name}) -c ns-web-planner -n northstar -- ls -l /opt/northstar/
data/specs/ns_specs
total 8
drwx------ 2 root root 4096 Sep 16 08:18 network1
drwx------ 2 root root 4096 Sep 16 08:18 sample_fish

RELATED DOCUMENTATION
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Interactive Planner Map Features
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The Paragon Planner map is interactive (similar to Topology page in Paragon Automation) which means
you can use several features within the map to customize the map and the network information table.
The topology map is the main work area for any network model you load into the system. Links are
color-coded according to utilization. The map uses a geographic coordinate reference system.

Path analysis can be performed in the topology window. The path function displays detailed path
information between any two nodes found in the network based on factors such as routing method
used, reserved and actual bandwidth allocation, link distance, or over subscription.

For information about network information table, see "Network Information Table Overview" on page
52.

Right-click Functions

You can right-click a node, node group, link, or blank space on the topology map to access context-
specific menus.

Table 10 on page 32 describes the options that are displayed when you right-click any where on the
topology map.
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Table 10: Right-Click Options for Blank Space on the Topology Page

Option Description

Grouping

You can view, group, or ungroup the nodes in a node group.

Nodes & Groups Displays the nodes and node groups in the topology. You can select a
particular node group to be displayed on the topology map.

Auto Grouping Enables you to specify the criteria that are used to automatically group nodes.
For more information, see "Auto Grouping Nodes" on page 46.

Group Selected Nodes Groups the selected nodes. For more information, see "Group Nodes" on page
45.

Ungroup Selected Nodes Ungroups the nodes from the selected group. For more information, see
"Ungroup Nodes" on page 48.

Ungroup All Ungroups the nodes in all groups.

Select All Nodes Selects all the nodes on the topology map. This option is a shortcut to using
the Shift+left-click option to create a selection box around all nodes or
individually shift-clicking on all nodes.

Show All Nodes and Links Restores the topology map so that it includes all the nodes and links in the
network, as opposed to a filtered subset.

Save to Default Map Layout Saves the current layout as the default. Selecting this option does not change
the name of the default in the Manage Layouts page.

Layout

Manage Map View Save, load, or edit the current topology map. For more information, see
"Manage Layouts" on page 48.
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Table 10: Right-Click Options for Blank Space on the Topology Page (Continued)

Option Description

Distribute All Nodes Select multiple nodes on the topology map and redistribute them to improve
visual clarity or for personal preference. Distributes all the nodes in the map,
pushing elements away from each other and minimizing overlap.

Distribute Selected nodes Forces the selected elements away from each other and minimizes overlap.

Circle selected nodes Arranges the selected nodes in a roughly circular pattern, with the nodes and
links separated adequately.

Straighten selected nodes Aligns the selected nodes in a linear pattern.

Reset by Coordinates Resets the map to display the nodes based on their configured coordinates
(latitude and longitude).

NOTE: You can reset the distribution of the nodes on the topology map
according to geographical coordinates if you have set the latitude and
longitude values of the nodes. It can be useful to have the country map
backdrop displayed when you use this distribution model.

Import from Import a layout from a CSV or GeoJSON file. For more information, see https://
geojson.org/.

Export to Export a layout to a CSV or GeoJSON file.
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Table 10: Right-Click Options for Blank Space on the Topology Page (Continued)

Option Description

Node Label Select one of the following options to label the nodes on the topology map:

• Name

• Hostname

• IP address

• IPv6 Address

• IP, SID

• ISIS System ID

• OS version

• OSPF ref BW

• SID

• Type

• Hide Label—Hides all the labels for the network elements on the topology
map
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Table 10: Right-Click Options for Blank Space on the Topology Page (Continued)

Option Description

Link Label Select one of the following options to label the links on the topology map:

• Name

• Node Name
A::Z

• Interface
A::Z

• IP A::Z

• IP, SID A::Z

• TE Metric
A::Z

• Bandwidth
A::Z

• Delay A::Z

• Interface Util
A::Z

• ISIS1 Metric
A::Z

• ISIS2 Metric
A::Z

• Measured
Delay A::Z

• OSPF Metric
A::Z

• Packet Loss
Metric A::Z

• RSVP Bandwidth A::Z

• RSVP Util A::Z

• RSVP Live Util A::Z

• Shape BW A::Z

• SID A::Z

• SRLG

• TE Admin Group A::Z

• Hide Label

Favorites

Add Selected Nodes to
Favorites

Select nodes on the topology map and designate them as favorites.

Remove Selected Nodes from
Favorites

Removes the nodes that you select on the topology map from the Favorites
tab.

Clear Favorites Clears all the existing favorite nodes.

Highlight Favorites Highlights only the favorite nodes on the topology map.

Show only Favorites Displays only the favorite nodes on the topology map.
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Table 10: Right-Click Options for Blank Space on the Topology Page (Continued)

Option Description

Hide Favorites Hides all the favorite nodes on the topology map.

Subview Filters the network elements on the topology map based on Node Type,
Autonomous System (AS) number, OSPF Area, ISIS Area, or Layer. For more
information about these options, see Table 11 on page 36.

Table 11: Subview Options

Options Description

Node Type Select the node types from the list.

AS Assign a color to represent each AS number that is configured on the topology map.

From the AS pane, you can select or clear AS numbers by selecting or clearing the
corresponding check boxes. Only nodes corresponding to the selected AS numbers are
displayed in the topology map.

ISIS Area Assign a color to represent each IS-IS area identifier that is configured on the topology map.
The area identifier is the first three bytes of the ISO network entity title (NET) address.

From the ISIS area pane, you can select or clear ISIS area identifiers by selecting or clearing
the corresponding check boxes. Only nodes corresponding to the selected area identifiers are
displayed in the topology map.

OSPF Area Assign a color to represent each OSPF area that is configured on the topology map. NONE
shows the color assigned to routers that have no OSPF area configured.

From the OSPF Areas pane, select or clear OSPF areas by selecting or clearing the
corresponding check boxes. Only nodes corresponding to the selected OSPF areas are
displayed in the topology map.

Layer Include or exclude individual layer information in the topology map.

From the Layers list, select the layers (IP, Transport, or both) that you want to display. If you
are not using the Multilayer feature, the Layers list contains only IP.
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Table 12 on page 37 describes the right-click options for a node or selected node group on the
topology map.

Table 12: Right-Click Options for Nodes or Node Groups

Option Description

Filter in Node Table Filters the nodes that are displayed in the network information table to display the
selected nodes or node groups only.

Tunnels

Tunnels On or Thru Node Opens a new tab in the network information table to show only those tunnels that
meet the On or Thru Node criteria.

Tunnels Starting at Node Opens a new tab in the network information table to show only those tunnels that
start at the selected node.

Tunnels Ending at Node Opens a new tab in the network information table to show only those tunnels that
end at the selected node.

Tunnels Passing Through
Node

Opens a new tab in the network information table to display only those tunnels
that pass through the selected node.

Demands

Demands on Thru Node Opens a new tab in the network information table to show only those demands
that start at the selected node.

Demands Starting At Node Opens a new tab in the network information table to show only those demands
that end at the selected node.

Demands Ending At Node Opens a new tab in the network information table to show only those demands
that end at the selected node.

Demands Passing through
Node

Opens a new tab in the network information table to display only those demands
that pass through the selected node.
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NOTE: For the description of other right-click options, see Table 10 on page 32.

Table 13 on page 38 describes the right-click options for a link on the topology map.

Table 13: Right-Click Options for Links

Option Function

Filter in Link Table Filters the tunnels that are displayed in the network information table to display
only the selected link.

Tunnels On or Thru Link Opens a new tab in the network information table to show only those tunnels that
meet the On or Thru Link criteria.

NOTE: For the description of other right-click options, see Table 10 on page 32.

Topology Settings

You can access the Topology Settings pane by clicking the Settings icon in the Topology menu bar
located at the upper right corner of the Topology Page.

Table 14 on page 39 describes the tabs on the Topology Settings pane.
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Table 14: Topology Settings Options

Tab Description

Nodes You can perform the following tasks:

• Change the labels of all the nodes on the topology map by selecting an option from the
Label list.

• After you select a label, click the toggle button to view:

• Background shadow of node labels

• Pseudo node label

• Only favorite node labels

• Isolated nodes

• Overload bit marker
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Table 14: Topology Settings Options (Continued)

Tab Description

Links You can perform the following tasks:

• Change the labels of all the links on the topology map by selecting an option from the
Label list.

• Click the toggle button to:

• Show or hide the link down markers

• Represent down links as a dashed line

• Represent a link line of width in proportion to the interface speed

• Draw parallel links as a curve: Toggle the button to draw parallel links between two
nodes as a curve, so that the parallel links do not overlap and appear separately (as
curves) on the topology map. If the parallel links between two nodes are drawn as
straight lines, they would overlap on the topology map (as a bundle).

• Show utilization max instead of Average within bundle: Toggle this button to display
the maximum utilization value (in red) instead of the average utilization value for
parallel links. For example, if there are two parallel links between two nodes and
one link has 10% utilization and the other has 20% utilization, and you want to
draw the link as a straight line between the nodes, you can choose which utilization
value should be displayed: 15% (average) or 20% (maximum) value.

• Wrap links as Great Arcs: Distinguishes links that would have to wrap around the world
map.
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Table 14: Topology Settings Options (Continued)

Tab Description

Figure 2: Example: Wrap Links as Great Arcs

• Hide Partially Visible links: Hides any link whose end nodes are outside the visible area.
This is useful for focusing on a subset of a large network.

NOTE: The topology map does not display more than a certain number of node or link labels,
even if the topology settings call for labels to be displayed. This can be improved by reducing
the number of elements displayed by panning or zooming which will re-enable the label
display.
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Table 14: Topology Settings Options (Continued)

Tab Description

Tunnels You can perform the following tasks:

• Click the toggle button to draw a path as a curve, which might improve network
visualization.

Figure 3 on page 42 shows both curved and straight lines for the same path.

Figure 3: Example: Curved and Straight Line Path Depiction

• Click the toggle button to draw a path through layers if the network includes transport
layers.
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Table 14: Topology Settings Options (Continued)

Tab Description

General You can perform the following tasks:

• Click the toggle button to:

• Enable animation while calculating the topology layout.

• Show or hide zoom slider: A vertical slider is displayed on the topology menu bar on the
top right corner of the topology window.

• Enable or disable to zoom to selected node: With this option enabled, when you click
the node entry in the network information table (the Node tab), the topology
automatically centers the view on that selected node.

• Select a Label Size: Select one of the following values as the font size for the node and link
labels:

• 8

• 10

• 12

• 14

• 16

• 18

• 20

• Apply Opacity effects: Move this slider to select the percent opacity for unhighlighted
topology map elements. Example below shows 100% and 20% opacity for comparison.
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Table 14: Topology Settings Options (Continued)

Tab Description

Figure 4: Example: Opacity Effects
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Table 14: Topology Settings Options (Continued)

Tab Description

Map You can perform the following tasks:

• Select a Light or Dark theme for the topology map.

Example below shows an example of the light and dark map styles.

Figure 5: Example: Light and Dark Map Styles

• Show Graticules: Displays graticules (a grid of lines that is parallel to the meridians of
longitude and the parallels of latitude) and labeling of major populated places.

• Show World Map: You can select the type of map (based on color or labeling) to be
displayed on the Topology page. Based on your selection, the topology map is updated
immediately. You can select one of the following options:

• PathFinder—Displays the topology on the greyscale world map.

• PathFinder No Labels—Displays the topology on the world map without highlighting
the city or country names.

• Thunderforest Atlas—Displays the topology map on a colored world map with city and
country names highlighted.

Group Nodes

You can represent a collection of nodes on the topology map as a single entity called node groups.
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To create a node group:

1. Click Network > Topology.

The Topology page is displayed with the topology map at the center and the network information
table at the bottom of the page.

2. Select the nodes on the topology map by holding down the Shift key and left mouse button and
dragging the mouse to create a rectangular selection box. All elements within the box are selected.

3. Right-click and select Grouping > Group Selected Nodes.

The Group Selected Nodes window appears.

4. Enter a name in the Group Name field.

NOTE: The group name should be alphanumeric and unique. It cannot be the same as any
node ID or hostname.

5. Click OK.

The selected nodes are grouped and displayed as a single entity on the topology with a new Node
Group icon highlighted in yellow.

The new group name is displayed in the Grouping > Nodes & Groups page when you right-click
anywhere on the screen.

On the Nodes & Groups page, you can control how the group is displayed in the topology map. You
can uncheck the Group Name checkbox to hide the node group on the topology map. When you
expand a group in the Nodes & Groups list, the nodes are displayed individually on the map. When
you collapse a group in the Nodes & Groups list, only the group name appears on the topology map
represented by an icon.

NOTE: You can also double-click the Group Node icon to view the nodes separately on the
topology map.
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Auto Grouping Nodes

Auto Grouping option enables you to use multiple rules in sequence to group nodes.
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To auto group nodes:

1. Click Network > Topology.

The Topology page is displayed with the topology map at the center and the network information
table at the bottom of the page.

2. Select the nodes on the topology map by holding down the Shift key and left mouse button and
dragging the mouse to create a rectangular selection box. All elements within the box are selected.

3. Right-click and select Grouping > Auto Grouping.

Auto grouping pane is displayed on the right.

4. Hover over the Add list and select a rule type from one of the following:

• AS

• ISIS Area

• OSPF Area

• Site

• Regular Expression: Add a more specific rule by using regular expressions to group nodes by
Hostname, IP address, or Type. You can find the first match for any case-sensitive expression.

NOTE:

• You can create one rule for each rule type.

• The Edit (pencil icon) function is only available for Regular Expression rules.

• You can change the order of the rules by clicking on a rule by selecting Up or Down from
the Move list to reposition the rule in the list.

• You can also select the check box (at the bottom of the page) to apply auto-grouping to
the nodes that you have selected on the topology map. By default, this is disabled.

5. Click Submit.

NOTE: To delete a rule, select the rule and click the Delete (trash can) icon. On the
confirmation message, click Yes.
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Ungroup Nodes

Nodes that are part of a node group are displayed as a single entity (node group icon) on the topology
map. To view these nodes as discrete entities on the topology map, you must ungroup the nodes from
the node group.

To ungroup nodes from an existing node group:

1. Click Network > Topology.

The Topology page is displayed with the topology map at the center and the network information
table at the bottom of the page.

2. Right-click on the node group and select Grouping > Ungroup Selected Nodes. Alternatively, you can
double-click the node group icon (highlighted in yellow) to ungroup the nodes on the topology map.

The nodes within the node group are ungrouped and are visible as separate nodes on the topology
map. The node group is removed from the Nodes & Groups page (right-click anywhere on the
Topology map and select Grouping > Nodes & Groups).
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Manage Layouts

From the Map View page, you can save topology map layouts, quickly load them to the topology map,
edit the saved layouts, or delete saved layouts.

To save a map layout so you can quickly load it into the topology map:

1. Click Network > Topology.

The Topology page is displayed with the topology map at the center and the network information
table at the bottom of the page.

2. Right-click on the topology map and select Layout >Manage Map View.

The Manage Map View pane is displayed on the right.

3. Click Save.

4. Enter a name for the current layout.

5. Enter a description for the current layout.

6. Specify whether the saved layout is to be shared with all operators (shared) or is to be available only
to you (private).
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7. Click Save.

The current layout is saved and listed on the Map View table.

NOTE: You can also right-click a blank part of the topology map pane and select Save Default
Map Layout to save the current layout as your default. This action saves the current layout as
your default, but does not change the name of the default map layout in the Manage Layouts
window.

Table 15 on page 49 describes the functions you can perform on the saved layouts.

Table 15: Map View Window Buttons

Button Functions

Load Load the selected layout to the topology map.

Edit • Edit the name of the selected layout by clicking Edit > Rename. In the New Name field, enter
the new name of the selected layout and click OK.

• Edit the description of the selected layout by clicking Edit > Change Description. In the New
Description field, enter the new description for the selected layout and click OK.

• Set the selected layout as default by clicking Edit > Set to default.

NOTE: The default layout is displayed you log in to Paragon Automation for the first time.

Delete Select a layout from the list and click the delete (trash can) icon. On the confirmation message,
click Yes. The layout is deleted and removed from the Map View list.

NOTE: You can also show/hide columns in the table by clicking the More Options (vertical
ellipsis) icon and selecting the specific tabs you want to display.
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Top Menu Bar Overview

The top menu bar on the Topology (Network > Topology) page of the Paragon Planner displays:

• Name of the network model open currently

• Protocol that the network is using

• Selected Layer (Layer 3 or Tunnel Layer)—You can hover over this option to switch between layers.
Layer 3 is the default. The topology map is updated based on your selection.

• Selected mode (Design or Simulation)—You can hover over this option to switch between the modes.
In the Design mode, you can perform demand and tunnel path design, rerouting, sizing; and network
resizing, optimization and analysis. For more information on simulation mode, see No Link Title or
Paragon Planner User Guide.

• Action drop-down list where you can:

• View network summary—Click Show Network Summary to open the Summary pane on the right
displaying the network elements count, tunnel count with bandwidth information and hope count
in the network.

• Save Network—Saves your work to the Planner database.

• Save Network As—Saves a copy of the network model to the Planner database with the name you
specify. On the Save A Network Model page, enter a name for the network model and an optional
description. The saved model is then available on the Saved Network Models page.

• Detach Session—Detaches the network from your current working session.

• Close Session—Deletes the session that you currently have open from the database. The entry is
removed from the Sessions page. This is similar to deleting the session from the Sessions page
directly by clicking the Delete (trash can) icon.

NOTE:

• Click the refresh icon to update the network model topology based on the latest
information received from the server.

• The lock symbol indicates communication with the server. The symbol might turn red or
orange if any action is pending from the server side.
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Simulation Mode Overview

From the top menu bar on the Planner Topology page, you can select the Simulation mode to specify the
nodes or links you want to fail for the simulation run. You can see how the failure impacts link utilization,
and demand/tunnel routing. Subsequent failures can also be performed by continuing the simulation
using a different set of failed elements. Once the simulation is run, you can view the link changes, tunnel
changes, and demand changes reports.

From the Simulation mode, you can:

• Fail a node—In the network information table, in the Fail column, click Operation to select the node
for failure. Click Run. The node is marked with a red 'F' on the topology map to indicate its failure.
The network information table is updated with the failed node details.

• Fail a link—In the network information table, in the Fail column, click Operation to select the link for
failure. Click Run. The link is grayed out on the map and marked with a red ‘F’ symbol to indicate its
failure. The network information table is updated with the failed link details.

NOTE: From the More list, you can view the link, tunnel, and demand changes reports
generated after failing a node or link. You can also click Download to download the report as
a CSV file to your system.

• Reset Simulation—Click Reset Simulation to revert back to the initial network state. All links and
nodes are set to active and all demands are routed according to the state at which the simulation
mode was entered.
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Network Information Table Overview

IN THIS SECTION
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Add a Node  |  55
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Add a Link  |  58
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Interface Tab Overview  |  74

SRLG/Facility Tab Overview  |  75

The network information table at the bottom of the Planner Topology has tabs across the top which
change according to the tab you select. Within the tables, each row represents an element. When you
select one or more elements in the table, the corresponding elements are highlighted in the topology
map.

The network information table displays detailed information about each network element in the
following tabs:

• Node—View node information and add, edit, or delete nodes in the network. For more information,
see "Add a Node" on page 55 or "Edit and Delete Nodes" on page 56.

• Link—View link information and add, edit, or delete links in the network. For more information, see
"Add a Link" on page 58 and "Edit and Delete Links" on page 60.
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• Tunnel—View tunnel information and add, edit, or delete tunnels in the network. For more
information, see "Add a Single Tunnel" on page 61, "Add Multiple Tunnels" on page 63 and "Edit
and Delete Tunnels" on page 65.

• Demand—View information about user-created demands in the network. For more information, see
"About the Demand Tab" on page 67.

• Interface—View information about various interfaces (such as IPv4, MAC, and VRF) in the network.
For more information, see "Interface Tab Overview" on page 74.

• SRLG/Facility—View information about shared risk link group (SRLG) or Facilities and add, edit, or
delete them. For more information, see "SRLG/Facility Tab Overview" on page 75.

• Filter Entries—Filter the table entries by adding new filtering criteria.

Hover over the Filter (funnel) icon and select Add Filter. On the Add Criteria page, select the filtering
criteria from the Field and Condition list, and enter the text to be compared in the Value field. Click
Add.

The filtered table entries are listed and the filter criteria name is displayed above the table column
names.

You can click the cross (X) icon (next to the filter name) to remove the filtering criteria.

NOTE:

• You can add multiple filtering criteria. Once you add the multiple filtering criteria, you can
select the And condition to display the entries matching all the filtering criteria or select
the Or condition to display the entries matching any one of the filtering criteria.

• Quick filter: Save the filtering criteria as quick filters. Once you have added all the filtering
criteria, you can save a particular criteria or multiple criteria for future use by clicking Save.

On the Save Filter window, enter a name for the filter, optionally toggle the Set as Default
button if you want to use this filtering criteria by default, and click OK.

The saved filters are displayed under Quick Filters when you hover over the Filter (funnel)
icon. You can then apply these saved filters to the table entries.

• Show/Hide Columns—Choose to show or hide a specific column in the table.

Hover over the More Options (vertical ellipsis) > Show/Hide Columns and select the Column-Name
check box of the columns you want to display in the table.

• Reset Preference—Reset the displayed columns to the default set of columns for each tab in the
table.
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Hover over the More Options (vertical ellipsis) and select Reset Preference.

• Sort Entries—Click the column name to highlight the up and down arrows next to the column name.
Sort the table entries in ascending or descending order of that column by clicking the up or down
arrow respectively.

NOTE:

• Click on the refresh icon at the bottom-left corner of the network information table to
manually refresh the table entries.

• Click the Display list (bottom-right corner of the table) to select the number of row (50,
100, 200, or 500 entries) visible on the table.

About the Node Tab

IN THIS SECTION

Tasks You Can Perform  |  54

You can add, edit, or delete nodes from the Node tab of the network information table on the Topology
(Network > Topology) page. You can also view detailed information about each node.

Tasks You Can Perform

• Add a node—See "Add a Node" on page 55.

• Edit node properties and delete nodes—See "Edit and Delete Nodes" on page 56.

• From the More list, you can:

• View details of a node—Select the node and click Show Detail.

Alternatively, hover over a node and click the details icon or right-click a node and select Show
Detail.

The Node-Node Name page appears, displaying details such as node coordinates, IP address, host
name, layer name, and node type.
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• Filter the selected node on the Topology Map. Only the selected node is displayed.

• Zoom in to the selected node on the Topology Map.

• Download node information—View detailed information about all the nodes displayed in the
topology by clicking Download. You can choose to open the comma-separated values (CSV) file by
using Excel or other applications, or save the file to your local system.

Add a Node

To add a new node to your network:

1. Click Network > Topology.

The Topology page is displayed with the topology map at the center and the network information
table at the bottom of the page.

2. On the Node tab, click the Add (+) icon.

The Add Node page appears on the right.

3. Configure the node parameters as per Table 16 on page 55.

NOTE: Fields marked with asterisk (*) are mandatory.

4. Click Add.

A confirmation message is displayed stating that the add node request is sent successfully. The new
node is displayed under the Node tab and is updated on the topology map.

Table 16: Fields on the Add Node Page

Field Descriptions

Properties

Name Enter a unique name for the node.

IPv4 Enter an IPV4 address for the node.

IPv6 Enter an IPv6 address for the node.
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Table 16: Fields on the Add Node Page (Continued)

Field Descriptions

Longitude Enter the longitude value of the node. Longitudes range from -180 to 180.

NOTE:

• Positive longitudes are east of the Prime Meridian and negative values (precede with
a minus sign) are west of the Prime Meridian.

• You can either enter the values directly or use the up and down arrows to increment
or decrement the values.

Latitude Enter the latitude value of the node. Latitudes range from -90 to 90.

NOTE:

• Positive values of latitude are north of the equator and negative values (precede with
a minus sign) are south of the equator.

• You can either enter the values directly or use the up and down arrows to increment
or decrement the values.

Hardware Select the required hardware vendor from the list.
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Edit and Delete Nodes

IN THIS SECTION

Edit Node Parameters  |  57

Delete Nodes  |  57
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Edit Node Parameters

To edit node properties:

1. Click Network > Topology.

The Topology page is displayed with the topology map at the center and the network information
table at the bottom of the page.

2. On the Node tab, select the node you want to edit.

3. Click the edit (pencil) icon.

The Edit Node page appears.

4. Edit the fields as described in Table 16 on page 55.

5. Click Edit.

A confirmation message is displayed stating that the edit node request is sent successfully.

Delete Nodes

To delete a node from the topology:
1. Click Network > Topology.

The Topology page appears.

2. On the Node tab, select the node that you want to delete.

3. Click the delete (trash can) icon.

A confirmation message appears.

4. Click Yes.

The node is deleted from the topology map and is removed from the network information table.

About the Link Tab

IN THIS SECTION

Tasks You Can Perform  |  58

You can add, edit, or delete links from the Link tab of the network information table on the Topology
(Network > Topology) page. You can also view detailed information about each node.
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Tasks You Can Perform

• Add a link—See "Add a Link" on page 58.

• Edit link properties and delete link—See "Edit and Delete Links" on page 60.

• From the More list, you can:

• View details of a link—Select the link and click Show Detail.

Alternatively, hover over a link and click the details icon or right-click a link and select Show
Detail.

The Link-Link Name page appears, displaying interface details such as node, IP address, interface
name, link utilization and bandwidth details.

• Filter the selected link on the Topology Map. Only the selected node is displayed.

• Zoom in to the selected link on the Topology Map.

• Download link information—View detailed information about all the links displayed in the topology
by clicking Download. You can choose to open the comma-separated values (CSV) file by using Excel
or other applications, or save the file to your local system.

Add a Link

To add a link in the topology map:

1. Click Network > Topology.

The Topology page is displayed with the topology map at the center and the network information
table at the bottom of the page.

2. On the Link tab, click the Add (+) icon.

The Add Link page appears.

3. Configure the link fields as per the Table 17 on page 59.

NOTE: Fields marked with asterisk (*) are mandatory.

4. Click Add.

A confirmation message appears stating that the request is successfully submitted. The new link is
displayed under the Link tab.
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Table 17: Fields on the Add Link Page

Field Description

Properties

Name Enter a name for the link.

Node A Click the Node A list and select the name of the ingress (source) node from the
list.

Node Z Click the Node Z list and select the name of the egress (destination) node from
the list.

Type Select the type of link you want to add from the list.

Bandwidth AZ and ZA Enter the bandwidth (in bps) for each direction (Node A to Z and from Z to A). You
must enter a number immediately followed by K (Kbps), M (Mbps), or G (Gbps).
For example, 10M signifying 10 Mbps.

NOTE: If you enter a value without units, bps is applied.

Protocols Select one or more protocols that you want to enable on the link. You can also
enable any of the protocols listed in the Protocols table by toggling the respective
button. If you do enable any of these protocols, you have the option to specify
additional tunnel metrics (per direction; AZ and ZA) by clicking on the empty
space under the metric. Once you are done adding the metric values, click the tick
icon.
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Edit and Delete Links

IN THIS SECTION

Edit Link Parameters  |  60

Delete Links  |  60

Edit Link Parameters

1. Click Network > Topology.

The Topology page is displayed with the topology map at the center and the network information
table at the bottom of the page.

2. On the Link tab, select the link that you want to edit.

3. Click the edit (pencil) icon.

The Edit Link page appears.

4. Edit the fields as per Table 17 on page 59.

5. Click Edit.

A confirmation message is displayed stating that the request was submitted successfully.

Delete Links

1. Click Network > Topology.

The Topology page appears displaying the network information table at the bottom.

2. On the Link tab, select the link that you want to delete.

3. Click the delete (trash can) icon.

A confirmation message appears.

4. Click Yes.

The link is deleted from the topology map and is removed from the network information table.
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About the Tunnel Tab

IN THIS SECTION

Tasks You Can Perform  |  61

You can use the Tunnel tab in the network information table on the Topology (Network > Topology) to
view and manage tunnels (label-switched paths or LSPs) in the network.

Tasks You Can Perform

• Add a single tunnel. See "Add a Single Tunnel" on page 61.

• Add multiple tunnels. See "Add Multiple Tunnels" on page 63.

• Edit or delete multiple tunnels. See "Edit and Delete Tunnels" on page 65.

• From the More list, you can:

• View details of a tunnel—Select the tunnel and click Show Detail.

Alternatively, hover over a link and click the details icon or right-click on a link and select Show
Detail.

The Tunnel-Tunnel Name page appears, displaying from/to node details and tunnel planned
properties.

• Edit All—You can edit tunnel parameters such as Planned Bandwidth, Setup, and Hold for all the
tunnels in the topology by selecting More > Edit All. See "Edit and Delete Tunnels" on page 65..

• Delete All—You can delete all the tunnels in the topology by selecting More > Delete All. On the
confirmation page, click Yes. A confirmation message is displayed stating that the delete all
request is sent. All tunnels are removed from the network information table.

Add a Single Tunnel

To add a single tunnel:

1. Select Network > Topology.

The Topology page appears displaying the network information table at the bottom.
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2. In the Tunnel tab, select Add > Tunnel.

The Add Tunnel page appears.

3. Complete the configuration on each tab according to the guidelines in No Link Title.

NOTE: Fields marked with an asterisk (*) are mandatory.

4. Click Add.

A confirmation message appears on the top of the page, indicating that a provision tunnel request is
successfully created.

The tunnel then appears in the Tunnel tab of the network information table and is updated on the
Topology map.

Table 18: Fields on the Add Tunnel Page

Field Description

Name Enter a unique name for the tunnel.

Node A From the list, select the node that you want to use as the ingress node.

Node Z From the list, select the node that you want to use as the egress node.

Planned Bandwidth Specify the planned bandwidth (along with valid units, with no space between
the bandwidth and units) for the tunnel.

If you specify a value without units, bps is applied.

Valid units are:

• B or b (bps)

• M or m (Mbps)

• K or k (Kbps)

• G or g (Gbps)
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Table 18: Fields on the Add Tunnel Page (Continued)

Field Description

Setup Specify the setup priority for the tunnel traffic.

Priority levels range from 0 (highest priority) through 7 (lowest priority). The
default is 7, which is the standard MPLS tunnel definition in Junos OS.

Based on the setup priority, the PCE determines whether a new tunnel can be
established, by preempting an existing tunnel. The existing tunnel can be
preempted if the setup priority of the new tunnel is higher than that of the
existing tunnel and the preemption releases enough bandwidth for the new
tunnel.

Hold Specify the hold priority for the tunnel traffic.

Priority levels range from 0 (highest priority) through 7 (lowest priority). The
default is 7, which is the standard MPLS tunnel definition in Junos OS.

Based on the hold priority, the PCE determines whether the tunnel can be
preempted or not. If the hold priority for a tunnel is higher, it is unlikely for
the tunnel to be preempted.
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Add Multiple Tunnels

You can provision multiple tunnels at once in the network topology from the Add Multiple Tunnels page.

To provision multiple tunnels:

1. Select Network > Topology.

The Topology page appears.

2. In the Tunnel tab, select Add > Multiple Tunnels.

The Add Multiple Tunnels page appears.

3. Complete the configuration on each tab according to the guidelines in No Link Title.
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NOTE: Fields marked with an asterisk (*) are mandatory.

4. Click Add.

A confirmation message appears on the top of the page, indicating that an add tunnel request was
successfully created.

The tunnels then appear in the Tunnel tab of the network information table on the Topology page.

Table 19: Fields on the Add Multiple Tunnels Page

Field Description

Properties

ID Prefix Specify a prefix to be applied to the names of all the tunnels that are created.

Node A List Select one or more nodes to be part of the Node A list.

For a full mesh tunnel to be created, you can specify the same nodes for Node A and Node Z
by clicking the Copy Node Z List link (that is located above the list). All the nodes that you
specify in the Node Z List are added to the Node A List.

Node Z List Select one or more nodes to be part of the Node Z list.

For a full mesh tunnel to be created, you can specify the same nodes for Node Z and Node A
by clicking the Copy Node A List link (that is located above the list). All the nodes that you
specified in the Node A List are added to the Node Z List.

Planned
Bandwidth

Specify the planned bandwidth (along with valid units, with no space between the bandwidth
and units) for the tunnel. If you specify a value without units, bps is applied.

Valid units are:

• B or b (bps)

• M or m (Mbps)

• K or k (Kbps)

• G or g (Gbps)

Examples: 50M, 1000b, 25g.
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Table 19: Fields on the Add Multiple Tunnels Page (Continued)

Field Description

Setup Specify the setup priority for the tunnel traffic.

Priority levels range from 0 (highest priority) through 7 (lowest priority). The default is 7, which
is the standard MPLS tunnel definition in Junos OS.

Based on the setup priority, the PCE determines whether a new tunnel can be established, by
preempting an existing tunnel. The existing tunnel can be preempted if the setup priority of
the new tunnel is higher than that of the existing tunnel and the preemption releases enough
bandwidth for the new tunnel.

Hold Specify the hold priority for the tunnel traffic.

Priority levels range from 0 (highest priority) through 7 (lowest priority). The default is 7, which
is the standard MPLS tunnel definition in Junos OS.

Based on the hold priority, the PCE determines whether the tunnel can be preempted or not. If
the hold priority for a tunnel is higher, it is unlikely for the tunnel to be preempted.
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Edit and Delete Tunnels

SUMMARY

You can edit or delete a single tunnel, multiple
tunnels, or all tunnels. Editing or deleting all tunnels
is helpful in completing these tasks quickly as there
are usually many tunnels in a network that would
paginate across multiple pages in the network
information table.
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Edit Tunnel Parameters

To edit the parameters configured for a tunnel:

1. Select Network > Topology.

The Topology page appears displaying the network information table at the bottom.

2. In the Tunnel tab, select the tunnel for which you want to edit the parameters, and click the Edit
(pencil) icon.

The Edit Tunnel page appears, displaying the same fields that are presented when you add a tunnel.

NOTE: You can edit tunnel parameters such as Planned Bandwidth, Setup, and Hold for all the
tunnels in the topology by selecting More > Edit All. On the Edit All Tunnels page, enter the
values for the parameters that you want to edit and click Edit. A confirmation message is
displayed stating that the edit multiple tunnel request is sent.

3. Modify the parameters as needed. Based on the type of tunnel that you selected, see "Add a Single
Tunnel" on page 61 or "Add Multiple Tunnels" on page 63 for more information on these parameters.

4. Click Edit to save your changes.

You are returned to the Topology page, where a confirmation message appears on the top of the
page, indicating that an edit tunnel change request was successfully created. The tunnel parameters
are then updated.

Delete Tunnels

To delete one or more tunnels:

1. Select Network > Topology.

The Topology page appears displaying the network information table at the bottom of the page.

2. In the Tunnel tab, select the tunnels that you want to delete, and click the Delete (trashcan) icon.

An alert message appears, asking you to confirm the delete operation.

NOTE: You can delete all the tunnels in the topology by selecting More > Delete All. On the
confirmation page, click Yes. A confirmation message is displayed stating that the delete all
request is sent. All tunnels are removed from the network information table.

3. Click OK.

You are returned to the Topology page, where a confirmation message appears, indicating that the
delete tunnel change request was successfully created. The selected tunnels are then deleted.
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About the Demand Tab

IN THIS SECTION

Tasks You Can Perform  |  67

You can view detailed information about the user-created demands in the network from the Demand
tab in the network information table.

Tasks You Can Perform

• Add a demand—See "Add a Single Demand" on page 68.

• Add multiple demands—See "Add Multiple Demands" on page 70.

• Download demand information—To view detailed information of all the demands displayed in the
network information table, click Download. You can choose to open the comma-separated values
(CSV) file with Excel or other applications, or save the file to your local system.

• From the More list, you can perform the following tasks:

• View details of a demand—To view details of a demand, select the demand and click Show Detail.

Alternatively, hover over a demand and click the details icon that appears. You can also right-click
on a demand and select Show Detail.

The Demand-Demand Name page appears, displaying the details, such as From Node, To Node,
and Planned Properties of the demand.

• Edit all demands—To edit properties (Planned Bandwidth, Setup, and Hold) of all the demands in
the network, click Edit All.

The Edit All Demands page appears. Edit the parameters as required and click Edit. A confirmation
message appears on the top of the page, indicating that the edit multiple demands request is sent
successfully. The updated parameters are then displayed in the Demand tab of the network
information table.

• Delete all demands—To delete all demands in the network, click Delete All. A confirmation
message appears on the top of the page, indicating that all demands are deleted.

• Edit one or more demands—See "Edit and Delete Demands" on page 72.

• Delete one or more demands—See "Edit and Delete Demands" on page 72.
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Add a Single Demand

You can add demands in your network to perform a what-if analysis of traffic flow in the network.

To add a single demand:

1. Select Network > Topology.
The Topology page is displayed with the topology map at the center and the network information
table at the bottom of the page.

2. In the Demand tab, select Add > Demand.
The Add Demand page appears on the right side of the page.

3. Configure the demand parameters as explained in Table 20 on page 68.

NOTE: Fields marked with an asterisk (*) are mandatory.

4. Click Add.
A confirmation message is displayed on top of the page, indicating that the add demand request is
sent successfully. You can then view this demand in the Demand tab of the network information
table.

Table 20: Fields on the Add Demand Page

Field Description

Properties

Name Enter a unique name for the demand.

The name can contain only alphanumeric characters
and some special characters (greater than (<), less than
(<), colon (:), underscore (_), and hyphen (-)).

Node A From the list, select the name of the ingress (source)
node of the demand.

Node Z From the list, select the name of the egress
(destination) node of the demand.

68



Table 20: Fields on the Add Demand Page (Continued)

Field Description

Planned Bandwidth Specify the planned bandwidth (along with valid units,
with no space between the bandwidth and units) for
the demand.

If you specify a value without units, bps is applied.

Valid units are:

• B or b (bps)

• M or m (Mbps)

• K or k (Kbps)

• G or g (Gbps)

Setup Specify the setup priority for the demand.

Priority levels range from 0 (highest priority) through 7
(lowest priority), which is the default.

Based on the setup priority, the PCE determines
whether a new demand can be established, by
preempting an existing demand. The existing demand
can be preempted if the setup priority of the new
demand is higher than that of the existing demand and
the preemption releases enough bandwidth for the
new demand.

Hold Specify the hold priority for the demand.

Priority levels range from 0 (highest priority) through 7
(lowest priority), which is the default.

Based on the hold priority, the PCE determines
whether the demand can be preempted or not. If the
hold priority for a demand is higher, the demand may
not be preempted.
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Add Multiple Demands

You can add multiple demands at a time to perform a what-if analysis of traffic flow in the network.

To add multiple demands:

1. Select Network > Topology.
The Topology page is displayed with the topology map at the center and the network information
table at the bottom of the page.

2. In the Demand tab, select Add > Multiple Demands.
The Add Multiple Demands page appears on the right side of the page.

3. Configure the demand parameters as explained in Table 21 on page 70.

NOTE: Fields marked with an asterisk (*) are mandatory.

4. Click Add.
A confirmation message appears on the top of the page, indicating that the add multiple demands
request is sent successfully. You can then view the new demands in the Demand tab of the network
information table.

Table 21: Fields on the Add Multiple Demands Page

Field Description

Properties

ID Prefix Specify the prefix that is automatically added to the
names of the demands.

For example, if you specify the ID prefix as xyz, the
demand name is assigned as xyz_Node A_Node Z.
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Table 21: Fields on the Add Multiple Demands Page (Continued)

Field Description

Node A List From the list, select one or more ingress (source) nodes
of the demand. To select all the ingress nodes, select
Select All.

To create meshed demands, you must specify the same
nodes for Node A and Node Z by clicking the Copy
Node Z List link. All the nodes that you specify in the
Node Z List are added to the Node A List.

Node Z List From the list, select one or more egress (destination)
nodes of the demand. To select all the egress nodes,
select Select All.

To create meshed demands, you must specify the same
nodes for Node A and Node Z by clicking the Copy
Node A List link. All the nodes that you specify in the
Node A List are added to the Node Z List.

Planned Bandwidth Specify the planned bandwidth (along with valid units,
with no space between the bandwidth and units) for
the demands.

If you specify a value without units, bps is applied.

Valid units are:

• B or b (bps)

• M or m (Mbps)

• K or k (Kbps)

• G or g (Gbps)
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Table 21: Fields on the Add Multiple Demands Page (Continued)

Field Description

Setup Specify the setup priority for the demands.

Priority levels range from 0 (highest priority) through 7
(lowest priority), which is the default.

Based on the setup priority, the PCE determines
whether a new demand can be established, by
preempting an existing demand. The existing demand
can be preempted if the setup priority of the new
demand is higher than that of the existing demand and
the preemption releases enough bandwidth for the
new demand.

Hold Specify the hold priority for the demands.

Priority levels range from 0 (highest priority) through 7
(lowest priority), which is the default.

Based on the hold priority, the PCE determines
whether the demand can be preempted or not. If the
hold priority for a demand is higher, the demand may
not be preempted.
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Edit and Delete Demands
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Delete Demands  |  73

You can edit the parameters of one or more demands to suit your network requirements. You can also
delete one or more demands when you no longer need them.

Edit Demand Parameters

To edit the parameters configured for one or more demands:
1. Select Network > Topology.

The Topology page is displayed with the topology map at the center and the network information
table at the bottom of the page.

2. In the Demand tab, do one of the following:

• Select the demand for which you want to edit the parameters, and click the Edit (pencil) icon.

The Edit Demand page appears, displaying the same fields as the Add Demand page. See "Add a
Single Demand" on page 68 for more information on these parameters.

• Select multiple demands for which you want to edit the parameters, and click the Edit (pencil)
icon.

The Edit Multiple Demands page appears, displaying the same fields as the Add Multiple
Demands page. See "Add Multiple Demands" on page 70 for more information on these
parameters.

3. Modify the parameters as needed.

4. Click Edit to save your changes.
You are redirected to the Topology page, where a confirmation message appears on the top of the
page, indicating that the edit demand request is sent successfully. You can then view the updated
parameters in the Demand tab of the network information table.

Delete Demands

To delete one or more demands:
1. Select Network > Topology.

The Topology page appears displaying the network information table at the bottom of the page.

2. In the Demand tab, select the demands that you want to delete, and click the Delete (trash can) icon.
An alert message appears, asking you to confirm the delete operation.

3. Click OK.
You are returned to the Topology page, where a confirmation message appears, indicating that the
selected demands are deleted.
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Interface Tab Overview

IN THIS SECTION

Tasks You Can Perform  |  74

You can view detailed information about interfaces associated with different nodes in the topology map
from the Interfaces tab.

Interfaces cannot be added, modified, or deleted from the network information table.

Tasks You Can Perform

• Download interface information—Click Download to download detailed information about all the
existing interfaces in the topology in CSV format.

• From the More List, you can:

• View detailed information about the interface by clicking Show Detail or click the Details icon
displayed next to the interface name when you hover over it. A pop-up appears displaying the
traffic and protocol details about the selected interface.

• Reload the network—When there is a large number of interfaces, you can click Reload to clear the
interface back-end cache and reload the data (table entries) from the database.
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SRLG/Facility Tab Overview

IN THIS SECTION

Tasks You Can Perform  |  75

Shared Link Risk Group (SRLG) information can be received from BGP-LS or Transport controller,
whenever a path optimization occurs or whenever some event triggers rerouting. The information from
these sources is merged and displayed on the UI. You cannot add, edit, or delete SRLGs from the SRLG/
Facility tab of the network information table on the Planner Topology (Network> Topology) page.

Tasks You Can Perform

• View details about the SRLG/Facility by clicking the details icon when you hover over the SRLG/
facility name or click More > Show Detail.
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About the Failure Simulation Page

IN THIS SECTION

Tasks You Can Perform  |  78

The Simulation menu enables you to run various failure scenarios which helps to analyze and evaluate a
networks' resiliency.

By default, Paragon Planner simulation mimics the actual hardware. However, you can also adjust
simulation parameters for experimentation or to simulate “what-if” scenarios.

You can design a simulation to fail any or all of following network elements:

• Nodes

• Links

• Site

• SRLG/Facility

• Parallel Links

NOTE: The failure simulation scenario is based on the layer mode that you select from the Utility
bar in the Topology page (Network > Topology). When you run a failure simulation in Tunnel
Layer mode, all demands are ignored. This reduces the simulation run time. When you run a
failure simulation in Layer 3 mode, all the demands are included in the simulation.

Planner provides the following failure simulation types:

• Single—Fails all the network elements of a given type one at a time.

• Exhaustive Node Failure: Exhaustively fails every single node in the network.

• Exhaustive Link Failure: Exhaustively fails every single link in the network.

• Exhaustive Site Failure: Exhaustively fails all sites in the network. A site file is required to define
nodes within the same site. Nodes that are not grouped within a site are considered sites by
themselves.
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• Exhaustive SRLG/Facility Failure: Fails all facilities in the network. A facility file is required to
define node and trunk facility associations.

• Exhaustive Parallel Links Failure: Exhaustively fails all links between all node pairs.

• Double or Triple (Multiple):

For an exhaustive double failure simulation, two elements are failed at once. For example, if you
select Node and Link for a Double exhaustive failure, the simulation would then fail all node and
node, node and link, and link and link combinations. An exhaustive triple failure fails three elements
at once.

Tasks You Can Perform

You can perform the following tasks:

• Run a new failure simulation. For more information, see "Add a Simulation Event" on page 79.

• Delete an existing failure simulation—Select the failure simulation and click the Delete (trashcan)
icon. On the confirmation message, click Yes. The simulation is removed from this page.

• From the More list, select More > Detail to view information about existing simulations.

• Show/Hide Columns—Choose to show or hide a specific column in the table.

Hover over the More Options (vertical ellipsis) > Show/Hide Columns and select the Column-Name
check box of the columns you want to display in the table.

• Reset Preference—Reset the displayed columns to the default set of columns for each tab in the
table.

Hover over the More Options (vertical ellipsis) and select Reset Preference.

• Sort Entries—Click the column name to highlight the up and down arrows next to the column name,
to sort the table entries in ascending or descending order.
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Add a Simulation Event

To add a new exhaustive simulation event and view the generated simulation reports:
1. Select Simulation > Failure Simulation.

The Failure Simulation page appears.

2. Click the Add (+) icon.

The Run Failure Simulation Page appears.

3. Configure the fields as per Table 22 on page 79.

NOTE: Fields marked with asterisk (*) are mandatory.

4. Click Run.

The failure simulation details are listed on the Failure Simulation page.

To view the generated simulation reports, click on the Details icon when you hover over the
simulation name or click More > Detail. On the Simulation Details page, under the Files tab, click on
the view link next to each report to view the selected report-name in a new page. Click Download to
download the report-name to your local system as a CSV file. For more information, see View
Maintenance Reports in the Paragon Automation User Guide.

Table 22: Fields on the Run Failure Simulation Page

Field Description

Failure Type From the list, select one of the following types of failure:

• Single

• Double

• Triple

NOTE: The default exhaustive failure combination is Single.

Cases to Simulate Select one of the following:

• All: To simulate all possible failure combinations
exhaustively

• Custom Count: To randomly simulates a specified number
of failures. If you select this option, specify the number in
the Count field.
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Table 22: Fields on the Run Failure Simulation Page (Continued)

Field Description

Failure Elements From the list, select one or more of the following network
elements on which you wish to run the exhaustive failure
simulation:

• Nodes

• Links

• Site

• SRLG/Facility

• Parallel Links

NOTE: No network elements are selected by default. You must
select at least one network element type.

Description Enter a text description for this simulation.

Reports

Report ID Report ID is automatically populated.

NOTE: You can also enter a specific text Report ID. But, if you
use the same ID for multiple simulations, the reports will be
overwritten by the results from the latest simulation.
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Table 22: Fields on the Run Failure Simulation Page (Continued)

Field Description

Optional Report Select any of the following optional reports that you want
generated after the simulation:

• Demand Over Tunnel Utilization:

Generates report of the demand traffic on each tunnel

• Demand on Oversubscribed Link

• Detailed Reroute: Reports detailed information on demands
that rerouted during the failure simulation.

• Peak Group Transit Statistics: Reports the maximum
number and bandwidth of demands in the network

• Include events in Peak Link Utilization:

In the Peak Link Utilization report, information is provided
regarding the event triggering the peak link utilization,
indicating which failure type triggered the peak link
simulation (for example, node, link, or facility) and the name
of the element. With this option unchecked, the simulation
event is reported only for the planned period (based on the
demand file) and worst failure scenario among the periods
of the traffic load file. If this option is checked, the
simulation event is also displayed for all of the individual
periods (up to 24).

Advanced
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Table 22: Fields on the Run Failure Simulation Page (Continued)

Field Description

Reroute Behavior Select one of the following routing method to be used for the
simulation:

• Default only—Routing without fast reroute.

• Fast Reroute only:

Fast Reroute is used to protect MPLS traffic engineering
tunnels during node or link failures. It accomplishes this
with SONET-like restoration times by locally repairing the
tunnels at the point of failure, using backup tunnels that
bypass the failure while waiting for the head-end routers to
establish a new tunnel. The short restoration times are
especially desirable for real-time applications such as voice
over IP, which often cannot tolerate high delays.

• Default with Fast Reroute (default)
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View Demand Changes Reports

You can generate and view the demand changes report to know how the simulated failure impacts the
traffic demand. This report is generated when you simulate the failure of nodes or links.
To access the demand changes report, select Simulation from the top menu bar of the Topology page. In
the network information table that appears, select Demand Changes from the More list.

You can also click Download to download the report as a comma-separated values (CSV) file to your
system.

Table 23 on page 84 explains the fields displayed in the demand changes report.

Table 23: Demand Changes Report

Field Description

Name The name of the demand.

Node A The name of the ingress (source) node of the demand.

Node Z The name of the egress (destination) node of the
demand.

New Path The routing path of the demand obtained after
simulation.

Orig Path The routing path of the demand before simulation.

New Path Cost The changed cost associated with the routing path
after simulation.

Orig Path Cost The cost associated with the routing path before
simulation.

Path Cost Change The difference between the cost associated with the
routing path after simulation and the cost associated
with the routing path before simulation.

New # Hops The number of hops associated with the demand after
simulation.
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Table 23: Demand Changes Report (Continued)

Field Description

Orig # Hops The number of hops associated with the demand
before simulation.

# Hops Change The difference between the number of hops associated
with the demand after simulation and the number of
hops associated with the demand before simulation.

New Delay The delay (in milliseconds) associated with the demand
after simulation.

Orig Delay The delay (in milliseconds) associated with the demand
before simulation.

Delay Change% The percentage change in the delay associated with
the demand after simulation and the delay associated
with the demand before simulation.

New BW The bandwidth associated with the demand after
simulation.

Original BW The bandwidth associated with the demand before
simulation.
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