Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

 

Editing Apps in the Editor

 

Edit and create files and folders in the app editor tab, which is created on the JSA console.

When you install a new app, the Hello World development tab that includes the editor is added to the Console, and a second tab shows the Hello World app in normal installed mode without the editor.

The following diagram shows the first Hello World app tab without the editor, and the Hello World - Custom Tab Development tab that includes the editor on JSA.

Figure 1: Hello World Tabs
Hello World Tabs
  1. To edit files in the app folder,

    double-click a file, or right click to view the File Edit menu.

  2. To create files and folders, save files, and close files, click File, and then select an option from the menu.
  3. To search for files in the app folder navigation, type the file name in the search box, and then click the search icon to search for your file.
  4. Copy or move files from one folder to folder in the app folder navigation.
    1. To copy a file from one folder to another folder, select the file and press the CTRL key, and then use your mouse to drag the file to the destination folder.

    2. To move a file from one folder to another folder, select the file by using your mouse, and drag the file to the destination folder.

  5. To upload files to the app folder, use any of the following three ways to open the Upload File screen:
    • Click >File > Upload, and then drag a file in the box, or browse to a file.

    • In the app folder navigation, select a folder, and then right-click to open the Upload File screen.

    • In the app folder navigation, select a folder, and then drag a file over the folder to open the Upload File screen.

  6. To deploy an app or export an app, click the Actions menu and choose one of the following options:
    • Click Actions > Deploy App >in Development Mode to deploy and upgrade the current app in development mode.

      When you make changes, such as editing the manifest or other files, you deploy and upgrade the app in development mode to apply your changes. The app version in the manifest file increments when you deploy an app.

      When you deploy your app in development mode, you have the option to save a copy of the current app in .zip format.

    • Click Actions > Deploy App > in Live Mode to view the app in JSA.

      Before, you deploy the app in Live Mode, it's good practice to save your app locally, otherwise you can't access your changes after the app is deployed because the editor tab is removed.

      The development mode tab that includes the App Editor is removed from the Console when you deploy the app in Live Mode. If you want to edit the app again, you must export it as a .zip file so that you can import it to JSA and edit it at a later time.

    • Click Actions > Export App > as Zip to save your app in a local folder.

      The app is saved as an archive (.zip) file, which you can import as an existing app later. The .zip file that you export is not an app extension that can be installed by using the Extensions Management tool on the Admin tab.

      When you export the app, the app version in the manifest displays in the export dialog box. When you change the version that appears in the export dialog box, the app version in the manifest file version is changed to the same version.

    • Click Actions > Delete App to delete the app that you're editing. The app is removed from the JSA console.

      Note

      If you make changes to the app, ensure that you export the app so that your changes are saved in the exported zip file and you can install the app again later. The File > Save function saves the session only in JSA, and does not write to the compressed file, so these changes are lost because the app files are removed when you delete the app.