Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

 

Use Python 2.7 in Your App

 

Use environmental variables to make your app use Python 2.7 instead of Python 2.6.

This feature was introduced in JSA 2014.8.r9 patch.

This feature was introduced in JSA 7.3.0 Patch 2 (7.3.0.20170620100024) SFS.

Add the following environmental variables to the manifest file to instruct the app to use Python 2.7:

"environment_variables":[ { "name":"PATHSTART", "value":"\/usr\/local\/bin" } ],

The following manifest file example includes the environment variables that make the app use Python 2.7.

{ "environment_variables":[ { "name":"PATHSTART", "value":"\/usr\/local\/bin" } ], "console_ip":"10.11.12.13", "configuration_pages":[ { "required_capabilities":[ "ADMIN" ], "description":"Application Development", "text":"Develop Applications", "url":"bootstrapper" } ], "name":"Application Development", "log_level":"debug", "description":"Application for installing other applications in Development-mode.", "resources":{ "memory":200 }, "version":"1.0.2", "uuid":"ae1c83d0-be94-11e5-a837-0800200c9a66", "app_id":1006 }