Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?


IP/MPLSView Server Installation Frequently Asked Questions


I am getting errors during installation related to the SSL Certificate.

The error message might look like the following

# ./status_mplsview

To fix this problem, you should install Java patches from the following website: Select the appropriate OS version and hardware type.

I am getting errors such as “/usr/ucb/whoami: not found” and “test: argument expected.”

Certain basic commands are necessary for the installation program to work. These error messages might appear if only the core operating system is installed and default commands are not installed.

After installing the activation key, I get the following error message: "Password for IP/MPLSView is either missing or expired!".

Please do the following to verify whether you have the correct installation of the IP/MPLSView password file:

  1. Change directory to the /u/wandl/db/sys directory:
    cd /u/wandl/db/sys
  2. View the contents of the npatpw file and verify there is no extra character or typing error:
    cat npatpw

The NPAT server does not start up properly because the default NPAT port is in use.

If you have an IP/MPLSView client window open, closing it might free up the port. Then you can use the startup_mplsview command. Otherwise, try using the following command:

$ /u/wandl/bin/startup_mplsview [port_number]

To find which ports are in use, you can use the /usr/bin/netstat -a command on the server.

I see an error similar to this: “Error: please check whether the server is running on and, if so, please CHECK whether the port number is 7000.”

To check if the server is running, log into that server and use the /u/wandl/bin/status_mplsview command. This gives you a port number. Use the /u/wandl/bin/startup_mplsview port_number command to change the port number, substituting port_number with an unused unreserved port number. To see a list of used port numbers, use the /usr/bin/netstat -a command on the server side.

I chose the wrong port value 334 by accident and that caused some problems. I got the message: Error! : mySQL not detected. How can I change the port?

To change the port:

cd /u/wandl/bin

After I completed installation on the server, I ran the startup script for IP/MPLSview. However, the DGS server still says it is not running. How do I fix this?

First, check the log file in the /u/wandl/log/dgs.log.0 directory and the dgs.msg file. If the dgs.msg file displays: Got error 134 from table handler appears in the dgs.log, then the problem is most likely in the database tables.

To repair the database, use the following commands (note that mysql must be running):

$ cd /u/wandl/thirdparty/mysql
$ bin/mysqlcheck -r -uroot -pwandlroot -S /u/wandl/data/mysql/data/mysql.sock mplsview

Check the output to see if the database tables are repaired. Next, restart the DGS server by using the following:

$ cd u/wandl/bin
$ .dgs start ../db/config/dgs.xml

When I run startup_mplsview, I get the message “Only root may start NPAT server”.

The permissions of some of the files in the bin folder might have been corrupted. To fix this problem use the following commands as the root user in the IP/MPLSView bin directory:

# chmod 4750 .npat .stopnpat
# chown root .npat .stopnpat

When I run status_mplsview, I get the warning message “Task Server detected, but not fully initialized”. What’s wrong?

The Task Manager might take a while to fully deploy. Wait a few minutes and check again.

I cannot view the online help or wWeb interface.

Verify status using the /u/wandl/bin/status_mplsview command. If you just started up the server, wait another 5 minutes, as the Web server takes time to initialize. Then rerun the /u/wandl/bin/status_mplsview command. If you see the Web server ERROR: Unable to connect to web server! error message, change directory to the /u/wandl/bin directory and use the following commands:

$ . ./
$ ./ stop
$ ./ start

Although I installed a new version of IP/MPLSView, it seems like I am still using the old version.

In some cases, the existing server is not properly shut down, or there is a conflict with a previous installation of IP/MPLSView. In this case, you can try the using the ps -ef | grep mysql, ps -ef | grep securit, ps -ef | grep java, and ps -ef | grep server commands. To ensure the listed processes, if any, are from IP/MPLSView, check the path listed and see if it includes a directory in which IP/MPLSView is installed. If so, then use the kill -9 pid1 pid2... command, substituting pid1 pid2... with the process IDs found in the previous two commands. You might also want to close any currently running clients from previous installations. Afterward, try restarting IP/MPLSView using the above command.

To avoid running into this problem, be sure to stop any old IP/MPLSView programs that might be running on the same system using the /u/wandl/bin/stop_mplsview command.

I changed my machine’s IP address and can no longer access the Web.

Use the /u/wandl/bin/ script and change the IP address wherever it is listed. Check the /u/wandl/bin/ file to make sure the IP addresses have properly been updated. Then shut down and restart the IP/MPLSView server using the stop_mplsview and startup_mplsview commands.

I am getting the MySQL Installation Error “Creating database tables ...Error: installation of mysql failed. Please check the log for details: $WANDL_HOME/log/instmysql.log”.

Perform the following steps:

  1. Stop IP/MPLSView using the /u/wandl/bin/stop_mplsview command.
  2. Use the ps -ef|grep mysql command and then kill any stray mysql processes using the kill -TERM <pid> or kill -9 <pid> command, substituting <pid> with the process IDs returned by the ps command.
  3. Change directories.
    cd /u/wandl/bin
  4. Use the setup script. (Note the space after the dot: .<space>./
    . ./
  5. Enter the exact command as follows in a single line:
    ./mysql_install_db --defaults-file=$WANDL_HOME/db/config/my.cnf --basedir=$WANDL_HOME/thirdparty/mysql --ldata=$WANDL_HOME/data/mysql/data >> $WANDL_HOME/log/instmysql.log 2>&1
  6. Kill any processes that persist.
    ps -ef|grep mysql
    kill -TERM <pid>
  7. Start MPLSView again.

Use the /u/wandl/bin/ script to repair tables in the case of a shutdown that happened without using the stop_mplsview command, for example due to a power failure.