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About the Documentation

• Documentation and Release Notes on page xi

• Documentation Conventions on page xi

• Documentation Feedback on page xiii

• Requesting Technical Support on page xiv

Documentation and Release Notes

To obtain the most current version of all Juniper Networks
®
technical documentation,

see the product documentation page on the Juniper Networks website at

https://www.juniper.net/documentation/.

If the information in the latest release notes differs from the information in the

documentation, follow the product Release Notes.

Juniper Networks Books publishes books by Juniper Networks engineers and subject

matter experts. These books go beyond the technical documentation to explore the

nuances of network architecture, deployment, and administration. The current list can

be viewed at https://www.juniper.net/books.

Documentation Conventions

Table 1 on page xii defines notice icons used in this guide.
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Table 1: Notice Icons

DescriptionMeaningIcon

Indicates important features or instructions.Informational note

Indicates a situation that might result in loss of data or hardware damage.Caution

Alerts you to the risk of personal injury or death.Warning

Alerts you to the risk of personal injury from a laser.Laser warning

Indicates helpful information.Tip

Alerts you to a recommended use or implementation.Best practice

Table 2 on page xii defines the text and syntax conventions used in this guide.

Table 2: Text and Syntax Conventions

ExamplesDescriptionConvention

To enter configuration mode, type the
configure command:

user@host> configure

Represents text that you type.Bold text like this

user@host> show chassis alarms

No alarms currently active

Represents output that appears on the
terminal screen.

Fixed-width text like this

• A policy term is a named structure
that defines match conditions and
actions.

• Junos OS CLI User Guide

• RFC 1997,BGPCommunities Attribute

• Introduces or emphasizes important
new terms.

• Identifies guide names.

• Identifies RFC and Internet draft titles.

Italic text like this

Configure themachine’s domain name:

[edit]
root@# set system domain-name
domain-name

Represents variables (options for which
you substitute a value) in commands or
configuration statements.

Italic text like this
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Table 2: Text and Syntax Conventions (continued)

ExamplesDescriptionConvention

• To configure a stub area, include the
stub statement at the [edit protocols
ospf area area-id] hierarchy level.

• Theconsoleport is labeledCONSOLE.

Represents names of configuration
statements, commands, files, and
directories; configurationhierarchy levels;
or labels on routing platform
components.

Text like this

stub <default-metricmetric>;Encloses optional keywords or variables.< > (angle brackets)

broadcast | multicast

(string1 | string2 | string3)

Indicates a choice between themutually
exclusive keywords or variables on either
side of the symbol. The set of choices is
often enclosed in parentheses for clarity.

| (pipe symbol)

rsvp { # Required for dynamicMPLS onlyIndicates a comment specified on the
same lineas theconfiguration statement
to which it applies.

# (pound sign)

community namemembers [
community-ids ]

Encloses a variable for which you can
substitute one or more values.

[ ] (square brackets)

[edit]
routing-options {
static {
route default {
nexthop address;
retain;

}
}

}

Identifies a level in the configuration
hierarchy.

Indention and braces ( { } )

Identifies a leaf statement at a
configuration hierarchy level.

; (semicolon)

GUI Conventions

• In the Logical Interfaces box, select
All Interfaces.

• To cancel the configuration, click
Cancel.

Representsgraphicaluser interface(GUI)
items you click or select.

Bold text like this

In the configuration editor hierarchy,
select Protocols>Ospf.

Separates levels in a hierarchy of menu
selections.

> (bold right angle bracket)

Documentation Feedback

We encourage you to provide feedback, comments, and suggestions so that we can

improve the documentation. You can provide feedback by using either of the following

methods:

• Online feedback rating system—On any page of the Juniper Networks TechLibrary site

at https://www.juniper.net/documentation/index.html, simply click the stars to rate the

content, anduse thepop-up formtoprovideuswith informationabout your experience.

Alternately, you can use the online feedback form at

https://www.juniper.net/documentation/feedback/.
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• E-mail—Sendyourcommentsto techpubs-comments@juniper.net. Includethedocument

or topic name, URL or page number, and software version (if applicable).

Requesting Technical Support

Technical product support is available through the JuniperNetworksTechnicalAssistance

Center (JTAC). If you are a customer with an active J-Care or Partner Support Service

support contract, or are covered under warranty, and need post-sales technical support,

you can access our tools and resources online or open a case with JTAC.

• JTAC policies—For a complete understanding of our JTAC procedures and policies,

review the JTAC User Guide located at

https://www.juniper.net/us/en/local/pdf/resource-guides/7100059-en.pdf.

• Product warranties—For product warranty information, visit

http://www.juniper.net/support/warranty/.

• JTAC hours of operation—The JTAC centers have resources available 24 hours a day,

7 days a week, 365 days a year.

Self-Help Online Tools and Resources

For quick and easy problem resolution, Juniper Networks has designed an online

self-service portal called the Customer Support Center (CSC) that provides youwith the

following features:

• Find CSC offerings: https://www.juniper.net/customers/support/

• Search for known bugs: https://prsearch.juniper.net/

• Find product documentation: https://www.juniper.net/documentation/

• Find solutions and answer questions using our Knowledge Base: https://kb.juniper.net/

• Download the latest versions of software and review release notes:

https://www.juniper.net/customers/csc/software/

• Search technical bulletins for relevant hardware and software notifications:

https://kb.juniper.net/InfoCenter/

• Join and participate in the Juniper Networks Community Forum:

https://www.juniper.net/company/communities/

• Open a case online in the CSC Case Management tool: https://www.juniper.net/cm/

Toverify serviceentitlementbyproduct serial number, useourSerialNumberEntitlement

(SNE) Tool: https://entitlementsearch.juniper.net/entitlementsearch/

Opening a Casewith JTAC

You can open a case with JTAC on theWeb or by telephone.

• Use the Case Management tool in the CSC at https://www.juniper.net/cm/.

• Call 1-888-314-JTAC (1-888-314-5822 toll-free in the USA, Canada, and Mexico).
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For international or direct-dial options in countries without toll-free numbers, see

https://www.juniper.net/support/requesting-support.html.
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CHAPTER 1

Introduction

This IP/MPLSView Java-based Graphical User Interface Reference provides detailed

information for the NPAT (Network Planning and Analysis Tools) and IP/MPLSView

applications. Other NPAT and IP/MPLSView documents include:

• Getting Started Guide: Installation instructions, system requirements, administrative

details, and frequently asked questions/troubleshooting.

• Training Guide: Tutorial-based instruction on performing tasks with the Graphical User

Interface or command line.

• File Format Reference: Contains input file formats and explanations of output files.

• Router Feature Guide: Provides details about router-specific features such as MPLS,

BGP, VPN

• Management and Monitoring Guide: Provides instructions on performing IP/MPLSView

data collection and live network tasks for router networks.

Chapter 1 contains:

• Key IP/MPLSView Software Features on page 18

• IP/MPLSView Power Features on page 19

• Supported Hardware on page 19
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Key IP/MPLSView Software Features

IP/MPLSView is an integrated software package that addresses backbone topological

design and simulation, as well as maintenance issues using TDMmultiplexers, Routers,

FrameRelayswitchesandATMswitches.Several hardwaredevicesarecurrentlymodeled.

DescriptionFeature

• The impact of adding new demands, or traffic, can be analyzed in a network model before they
are placed onto the real network. The software determines whether there is sufficient available
capacity in the network and recommend places where capacity should be added.

• A network can be automatically designed based on end-to-end traffic requirements, starting from
an existing set of backbone trunks (“Incremental Design”) or from scratch (“Green-field Design”).
Using powerful heuristic algorithms, IP/MPLSView can evaluate whether trunks can be pruned
from the network without compromising diversity constraints. Trunks can be optimally added to
ensureall traffic isplacedunderanysingleelement failure (“DiversityDesign”). Potential bottlenecks
are also easily detected. Further analysis capabilities include load balancing and end-to-end delay
and loss calculations.

Capacity Planning
Backbone Design, and
Diversity Design

Exhaustive single, double, or triple element failures, interactive or customizable scripted failure
scenarios can be simulated to analyze and evaluate a networks' resiliency.

Failure Simulation

• Hardware-specific device models have been developed by through close working relationships
with the major device vendors. This ensures the accuracy and precision of the model, as well as
the support of many device-specific features.

• IP/MPLSView includes various data extraction tools to convert network data (for example, router
configuration files) into a format readable by IP/MPLSView.

Hardware-Specific
Device Library

For an existing backbone network, the optimal layout or path assignment can be determined which
satisfies all demand constraints. Demand constraintsmay includemedia preferences, diverse paths,
hardware bandwidth overhead calculations, and delay/hop constraints. In the case of routers, tunnel
constraints may include link attributes/colors and capacity. Available paths can be found even when
the actual hardware fails to find a path. If the hardware switch supports user-specified paths, then
paths found using the model can be downloaded to the real network.

Path Assignments

IP/MPLSView can help reduce private line leasing costs (monthly recurring and non-recurring
components) by producing designs that satisfy user requirements and constraints whilemaintaining
aminimal cost. You can specify your own pricing tables which are then integrated into IP/MPLSView
suite toprice out lines. This is usedextensively in theprogram's heuristic least-cost design algorithms.
The savings reaped normally translate to a quick return on investment.

Tariffs

As with all modules, detailed reports are generated to help you to quickly assess and summarize
network-relateddata.These reports include trunkpricing, trunkutilization, anddemandpaths.Reports
can be generated in text format, CSV (comma separated) format, or web-friendly HTML.

Detailed Design and
Analysis Reports

Detailed topology views allow you to view your network nodes and links. These can be placed by
geographical location, rearranged by hand, or automatically rearranged in a format that distributes the
points to make the network easier to view. Panned utilization, link vendors and other attributes can be
viewed by color; hardware devices are represented by various icons. Links can be labelled by a number
of attributes including linkmetrics. Fromthe topologymap, popupmenuscanbeaccessedby right-clicking
on nodes or links, providing quick targeted access to information about the selected network element.

Detailed Topology
Views
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IP/MPLSView Power Features

DescriptionFeature

Packet-by-packet simulation is available for Frame Relay and Router device models, giving
statistics on queueing delays and packet loss ratios.

Discrete Event Simulation

Partitioned or structured networks, including PNNI, are supported by IP/MPLSView.
Device-specific support of domains is also correctly modeled.

Domain/Structured Networks

Analysis of real traffic load per demand can be loaded into the software model to obtain a
more accurate link utilization for failure simulations. IP/MPLSView can domulti-period load
and performance analyses.

Traffic Load Analysis

Any number of nodes and/or links can be grouped together in a facility for failure scenarios
and reporting options.

Facility Feature

The class of service feature allows you to classify traffic into four classes, including the strict
priority class.With this feature, the accuracy of the IP/MPLSView’s Design and Discrete Event
Simulation modules are greatly improved, as the software takes into account all the details
of class-based weighted fair queueing (CBWFQ) in its routing process.

Class of Service (CoS) Feature

The customer tariff feature allows you to specify various tariff classes and their rates for the
network. Each node is associated with a particular tariff class. All links would then be priced
according to its service and the classes of the nodes it connects.

Customer Tariff

Thepathdiversity design featureallowsyou toconfiguredemands (or tunnels) on link-disjoint,
site-disjoint, or facility-disjoint paths.

Path Diversity Design

Supported Hardware

Generic hardware devices include ATM, Frame Relay, IP router, optical transport, voice,

andTDM.Apartial listof supporteddevicesare listedbelowgroupedbyhardwarevendor.

The hardware vendors you canmodel in IP/MPLSView depend on your license file.

Alcatel

• ATM/7670/7470/5620 or PNNI-based routing

• 7750 Service Router

Cisco Systems

• Routers: IOS and IOS-XR-based devices such as 7500, GSR12000, and CRS-1

• MPLS/Tag Switching (MPLS-TE, GB-TE)

• PIX Firewall

• LightStream 1010

• IGX 8400, BPX 8600, and MGX 8800

• ONS 15454, 15327, 15000 (optical transport)
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ECI Telecom LTD

• T::DAX

Force10

• Force10 Router

Foundry

• NetIron IMR, XMR Series

Huawei

• NE and AR Core Routers

IBM

• Nways 2220

Juniper Networks

• Routers: Junos OS and JunosE-based devices such as E- (including ERX 700, 1400),

MX Series, J Series, M Series, T Series

• NetScreen Firewall

Lucent Technologies (Ascend Communications)

• B-STDX

• CBX 500, GX 550

Marconi

• ForeRunner ASX, TNX

net.com

• Micro20,IDNX20/70/90

• Promina 100/200/400/800

• FrameXpress, CellXpress, SCLX

• SCREAM 50/100

• STM

Nortel

• Multiservice Switch 6400/7400/15000/20000
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• MPE 9000 Series

Riverstone

• RS Router Family

Sycamore

• SN3000, SN16000, SN16000SC

Tellabs

• 8800Multi-Service Router Series

RAD

• Megaplex Series, IPmux Series

21Copyright © 2018, Juniper Networks, Inc.

Chapter 1: Introduction



Copyright © 2018, Juniper Networks, Inc.22

IP/MPLSView Java-based Graphical User Interface Reference



CHAPTER 2

Documentation Conventions

Following are the documentation conventions used in IP/MPLSView.

• Document Conventions on page 23

• Keyboard, Window, and Mouse Terminology and Functionality on page 23

• The Keyboard on page 24

• The Mouse on page 24

• Informational Notes, Cautions, andWarnings on page 25

• Changing the Size of aWindow on page 25

• Moving aWindow on page 25

• For Further Information on page 25

Document Conventions

• Keyboard keys are represented in brackets; for example, <Enter>.

• Window titles, field names, menu name, menu options, and Graphical User Interface

buttons are represented by a bold font.

• Command line text is indicated by the use of a constant width type.

Keyboard,Window, andMouse Terminology and Functionality

• Window. Any framed screen that appears on the interface.

• Cursor. The symbol marking the mouse position that appears on the workstation

interface. The cursor symbol changes; for example, in most cases, it is represented as

an arrow; in a user-input field, the cursor symbol is represented as a vertical bar.

• Click. Refers to single clicking (pressing and releasing) amouse button. Used to select

(highlight) items in a list, or to press a button in a window.

• Double-click. Refers to two, quick clicks of a mouse button.

• Highlight. The reverse-video appearance of an itemwhen selected (via amouse click).

• Pop-upmenu. Themenu displayed when right-clicking in or on a specific area of a

window. Move the cursor and click the mouse button to make a selection.
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• Pull-downmenu. The MainWindowwindowmenus on the tool bar. Move the cursor

and click the mouse button to make a selection.

• Radio button. An indented or out-dented button that darkens when selected.

• Check box. A square box inside of which you click to alternately check or uncheck the

box; a check mark symbol is displayed inside the box when it is “checked.” The check

mark symbol disappears when the box is “unchecked.”

• Navigation. When you type text into a field, use the <Tab> key or the mouse to move

to the next logical field. Click inside a field using the mouse to move directly to that

field.

Gray or Grayed-out. A button or menu selection is described as gray or grayed-out

when it is inactive or inaccessible.

NOTE: In the documentation, mouse buttonmeans left mouse button
unless otherwise stated.

The Keyboard

The cursor keys located on the lower two rows of this keypad perform cursor movement

functions for the window cursor. They are labeledwith four directional arrows on the key

caps. IP/MPLSViewmakes use of these keys for cursor movement within files.

The following keys or key combinations can be used in the except where noted:

• Click on a file then hold down the <Shift> key while clicking on another file to select

the file first clicked on and all files in between.

• Click on a file and then hold down the <Ctrl> keywhile clicking on another file to select

the file first clicked on and the file next clicked on without selecting any of the files in

between. You can continue to <Ctrl>-click to select additional, single files.

TheMouse

The following terms describe operations that can be performed with the mouse.

• Point. Position amouse pointer (cursor) on an object.

• Click. Quickly press and release the left mouse button without moving the mouse

pointer.

• Right-click.Quicklypressand release the rightmousebuttonwithoutmoving themouse

pointer.

• Double-click. Quickly click a mouse button twice in succession without moving the

mouse pointer.

• Press.Holddown themousebutton. (Unlessotherwise specified, the leftmousebutton

is implied.)
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• Release. Release amouse button after it has been pressed.

• Drag. Move themouse while a mouse button is pressed and an item is selected.

Informational Notes, Cautions, andWarnings

Informational notes are special notes placed in a document to alert you of an important

point.

NOTE: This is an informational note.

Instanceswhere there is the possibility of inconvenience, temporary loss of functionality,

unwanted data loss, or other undesirable outcomes are indicated as Caution notes.

CAUTION: This is a caution-type note.

AWarning note indicates very important informationwhich needs tobe followed toavoid

risk of permanent hardware or software damage or personal injury.

WARNING: This is a warning-type note.

Changing the Size of aWindow

You can change the size of windows (with some exceptions such as dialog boxes) by

pointing to a border or corner of thewindow’s frame, pressing the leftmouse button, and

dragging the window’s frame until the window has reached the desired size. You also

can click on theminimize, maximize, and exit buttons in the upper right-hand portion of

the window:

Moving aWindow

Youcanmoveawindowbypressingyourmousedownwhenyourpointer isonawindow’s

top border. Keep your mouse’s left button pressed down and drag the selected window

to the place of your choice. When you are satisfied, release the mouse button.

For Further Information

For more detailed information, refer to the subsequent chapters in this document.
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CHAPTER 3

MainWindow

This chapter explains the functions of the main window, the workspace fromwhich all

IP/MPLSViewwindows are launched or opened. In addition, it discusses the File menu

of the menu bar. Below is a diagram of the main window displayed when a network is

launched.

• MainWindowOverview on page 27

MainWindowOverview

Figure 1: TheMainWindow

Themain window consists of the following elements: Menu, Toolbar, Topology, Console,

andNetwork Infowindow.Note thatmany functionsand featuresdonotbecomeavailable

until anetwork is loaded.This includessomeof themenusaswell as the topologywindow.

Menu options may vary depending on your license, user permissions, or modules.
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Table 3: MainWindowDrop-downMenus

Chapter 3,
“MainWindow” on page 27

The File menu contains network file functions such as creating, opening,
saving, loading files, and closing the network.

File

Chapter 8,
“Network Menu” on page 113

The Network menu provides comprehensive details on network elements,
such as nodes, links, interfaces, demands, and tunnels. Detailed information
on services, protocols, and paths. Alternative Maps such as BGP.

Network

Chapter 9,
“Design Menu” on page 175

TheDesignmenuprovidesoptions todesign thenetwork’s backbone through
new or incremental designs for the backbone links. Design also enables
functions such as path placement, path diversity design, and tuning.

Design

Chapter 10,
“SimulationMenu” on page 193

The Simulation menu provides options to run scripted and interactive failure
scenarios for nodes, links, sites, and facilities, to test the network’s resiliency
and discover worst-case scenarios.

Simulation

Chapter 11,
“Traffic Menu” on page 203.

The Traffic menu is used to access traffic-related features such as Traffic
Load, Trending, Growth, Import Traffic, and Traffic Aggregation.

Traffic

Chapter 12,
“Inventory Menu” on page 243

The Inventory menu is used to access hardware inventory reports and
hardware equipment cost tables. The Inventorymenu requires a special entry
in your license file. Please contact your Juniper Networks representative for
more details on these features.

Inventory

Chapter 13,
“Report Manager” on page 285

The Report menu is used to access the Report Manager which contains
detailed network, tunnel, simulation, configuration, and user customized
reports.

Report

Chapter 14,
“Admin Menu” on page 343

The Adminmenu is used to access the Task Manager, Device Library, and
User Administration. These functions are normally used by network
administrators or IP/MPLSView administrators.

Admin

Chapter 15,
“Tools Menu” on page 349

The Tools menu contains settings and tools such as Options, Connect to
Server,ComplianceAssessment,RevisionManager,DemandGeneration, and
Add-Ons.Someof these tools requirea special entry in your license file. Please
contact your Juniper Networks representative for more details on these
features.

Tools

TheWindowsmenu lists all sub-windows currently open in IP/MPLSView.Windows

TheHelpmenu contains a link to help documentation, information about the
system, and the Message of the Day.

Help

Figure 2: MainWindow Toolbar (optionsmay vary)

The toolbar contains the following items:

• Update button to update the status and routing on the network after you havemade

changes to the network.

• Stop button to cancel simulation runs or T-Solve processing.

• Two network layer buttons for MPLS-enabled router networks: Tunnel, Layer 3
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• Description of the network model

• Integrity Checks shortcut

• Task Manager shortcut

• Provisioning Manager shortcut

• Console shortcut

• Configuration File search bar to search for text in the configuration files of the currently

opened network.

NOTE: Some features require a special entry in your license file. Please
contact your Juniper Networks representative for more details on these
features.

TopologyMap

The topologymap, orMap(Standard), is themainworkarea in IP/MPLSViewanddisplays

important link and node properties. Links are color-coded according to a specified link

property such as media type, trunk type, or vendor. By default, the links are displayed by

link utilization. Nodes are color-coded by icons and symbols.

Formore informationonhow to select andmovenodes, label nodes, andaccess network

information properties through right-click popupmenus, refer to Chapter 5,

“TopologyWindow” on page 61.

Figure 3: Topology Map
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Figure 4: MainWindow Console

The console displays additional information when loading the network, reading files,

running failure simulation, generating reports, performing path trace, creating designs,

and various other functions. The console can be used to trace through information in

more detail.

Right-click in the console window to access further functions such as copying text,

searching for text in the console, saving the output, or creating a trace file of the console

output.

The Network Info window contains network summary information and detailed

information on nodes, links, interfaces, demands, and tunnels. Within each element tab,

theelement informationcanbesearched, filtered, ormodified for networkwhat if studies.

Additional elements may be available in this window depending on the network model.
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Figure 5: MainWindowNetwork Information

31Copyright © 2018, Juniper Networks, Inc.

Chapter 3: MainWindow



Copyright © 2018, Juniper Networks, Inc.32

IP/MPLSView Java-based Graphical User Interface Reference



CHAPTER 4

File Manager

The File Manager is thewindowwhere you can easily navigate through directories to find

and load network projects (specification files), open and edit files, and create new files

in IP/MPLSView file format. You can also perform basic file functions such as cut, copy,

paste, delete, and directory creation.

• The File Manager Window on page 34

• File Manager Toolbar on page 34

• File Manager Left Pane on page 36

• File Manager Right-Click Menu on page 37

• File Manager Spec File on page 39

• Text Editor on page 50

• Config Editor (Router and Switch) on page 52
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The File ManagerWindow

Figure 6: The File Manager

The File Manager is split into two panes: the left pane is a tree view of the directory

structure on the server, and the right pane displays the directory contents. Some files

and directories may belong to other users and have restricted access. Thus, those files

and directories cannot be opened, deleted, or moved because of file permissions.

File Manager Toolbar

The toolbar located across the top of the File Manager window contains buttons useful

for directory navigation, file manipulation, and configuring the view.

Figure 7: The File Manager Toolbar

Table 4: File Manager Toolbar Functions

DescriptionFunction

Displays the contents of a previous directory accessed.Back

Allows you to go forward on the history list.Forward
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Table 4: File Manager Toolbar Functions (continued)

DescriptionFunction

Changes the directory to the parent of the current directory.Up

Goes to the server’s home directory.Home

Displays the directory path.Path

Refreshes the directory view.Refresh

Search text inside the files of the current directory.Search

This drop-down selection allows you to customize the display.View

Opens the online-help webpage for more detailed information.Help

This field filters for file names or extensions.Files of Types

The file type drop-down filter options include the following IP/MPLSView-specific files:

• All Files (*.*): Displays all file types in a directory in the right pane of the File Manager.

• Spec Files (spec.*):Displays only the specification files in a directory. The specification

file is used by the program to determine which input directories and files to load for

the network.

• DparamFiles (dparam.*):Allows you to display only the dparam files in a directory. The

dparam file contains default parameter values for the network, such as hardware type,

link bandwidth and overhead, size and performance tuning, andmiscellaneous

parameters.

• MuxLoc Files (muxloc.*): Displays onlymuxloc files in the directory. This file contains

the node ID and name of each node in the network.

• BBlinkFiles (bblink.*):Displays onlybblink files. This file contains the location, quantity,

vendor, and attributes of the links found in the network.

• Demand Files (demand.*): Displays only demand files. This file contains information

regarding the end-to-end demands, circuits, or flows, and path specifications needed

for the network.

Youcanenter inacustomfilter stringusing thewildcards “*”and “?”andpress<Enter>.

• ‘*’ (Asterisk): Represents any string of characters. One advantage is that files can be

filtered by runcode. For example, you can type in the filter *.mpls-fish to filter the files

to show only files with the runcodempls-fish.

• ‘?’ (QuestionMark):Representsanyonecharacter. For example, thebblink.mpls? string

canbeused to fetch filesnamedbblink.mpls1andbblink.mpls2butnotbblink.mpls-fish.
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File Manager Left Pane

Figure 8: Directory View and Common Actions/Favorite Links View

In the left paneof theFileManager, clicking theX in theupper-right corner of theDirectory

view opens the Common Actions and Favorite Links view. The Common Actions section

contains shortcuts to various options. Click on Directory View to switch back to the

directory tree view.

Favorite Links to Directories or Files

Under Favorite Links you can store links to commonly used directories or files. To add a

link, right-click the file or directory from the right pane and select Add to Favorites. You

can specify the name of the link in the subsequent dialog box.

Once the link has been added under the Favorite Links section, clicking on a link to a

directory opens that directory in the right pane. Clicking a link to a file performs theOpen

command for that file.
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To rearrange, delete, or rename favorite links, clickOrganize... To rearrange the order,

select an item and clickMove Up orMove Down. To rename a link, type in a new name

and then click Rename.

Figure 9: Organize Favorites

File Manager Right-Click Menu

Right-clicking in the right pane of the File Manager displays the functions listed in

Table 5 on page 37

Table 5: File Manager Right-Click Menu Functions

DescriptionFunction

This menu is equivalent to double-clicking a file. This option allows you to open a highlighted
directoryor file. Theactionsaredifferent fordirectories, specification files, andnon-specification
files:

• A directory: Displays the contents of the directory in the right pane.

• A specification file: Loads the specification file into the program and opens up the network
model.

• A (non-spec) file: Launches the Text Editor where youmay edit the file.

Open

Opens the file in IP/MPLSView’s text editor to allow you to directly edit the file. Refer to “Text
Editor” on page 50.

Edit

Allows you to create new directories and text files in the current path. Refer to File Manager New
Command.

New
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Table 5: File Manager Right-Click Menu Functions (continued)

DescriptionFunction

Contains all functions related to the IP/MPLSView specification file (spec). From this submenu,
you can choose options to load, modify, or create new specification files. Refer to “File Manager
Spec File” on page 39.

Spec File

Allows you to copy the selected file(s) from the server to the local client.Copy File to Client

Enables you to view certain files in a table-like format. Refer toOpenWith Report Viewer .OpenWith Report Viewer

Enables you to viewmultiple reports in one windowwhere the left pane includes the report
name and the right pane includes the report contents. Refer toOpenWith Report Master .

OpenWith Report Master

Enables you to edit entries in the reports.OpenWith Report Editor

Zips files or directories into a tar file.Archive (tar)

Compress and zips files into a gz file.Compress (gzip)

Allows you to change the view of the file listing in the right pane of the File Manager. Most of
these selections can also be found in the view icon’s drop-down selection menu of the toolbar.
Refer to File Manager View.

View

Updates the directory and file listingRefresh

Adds file or directory to the Favorite Links list.Add to Favorites

Stores the selected file(s)/folder(s) in memory until you paste the files in a different location.
Once you paste them in a different location, the selected file(s) are deleted.

Cut

Copies files and/or folders highlighted in the File Manager window.Copy

Places files or folders that were last cut or copied into the directory currently open in the File
Manager.

Paste

Renames the highlighted file or directory.Rename

Removes highlighted files or directories.Delete

TheNewcommandallows you to create newdirectories and text files in the current path.

Note that when creating new files or directories, the youmust have write permission to

create files in that directory.

Table 6: File Manager New Command Functions

DescriptionFunction

This creates a new directory. When selected, you are prompted to enter the name of the directory to
be created.

Directory
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Table 6: File Manager New Command Functions (continued)

DescriptionFunction

This creates a new plain text file in the current directory. When selected, IP/MPLSView prompts you
for a file name. Once the name of the file is entered, the program brings up the text editor for editing
the new text file.

Plain File

This creates a file with tables using comma separated format. It’s recommended to save the file
extension as .csv.

Table

Thiscreatesa template forbackbonedata files:muxloc,bblink,demand,nodeparam,site,group,
graphcoord, owner.

Backbone data

This creates a template for a tariff file. Tariff files include: usercost, usercountrycost.Cost files

This creates templates for the following IP/MPLSViewfiles: fixlink, linkdist, nodeweight, rsvbwfile.Control files

This creates templates for new report files. You can add five types of report files: IP/MPLSView report
master, main only, main and row detail, main and column detail, andmain and cell detail. The
IP/MPLSView report master is similar to the Report Manager in that it allows you to viewmore than
one report in an organized structure. Main only report files show only the main table, while the other
reports show both the main table and detailed information of each row, column, or cell.

Report Files

File Manager Spec File

The Spec File submenu contains all functions related to the specification files. From this

submenu, you can choose options to load, modify, or create new specification files. The

following selections are available:

SpecFile>NewSpec—Allowsyou tocreateanewspecification file. Thisbasicallymeans
you are creating a new network from scratch. To use this option, first close any the

currently open specification files.

SpecFile>LoadSpec—Loads the currently highlighted specification file into the system.
Once a specification file is loaded, the network topology window also appears.

SpecFile>ModifySpec—Allowsyou tochange the runcode, datadirectory, ratedirectory,
and network files of the specification file. After modifying the options and clicking

Finish, you can load the network.

Spec File GenerationWindow—Once you select the New Spec or Modify Spec option,

the specification file generation window appears. From this window you can specify

properties for the specification file, dparam file, and various other specific input files

necessary for a network to be properly loaded and displayed.
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Figure 10: Spec File GenerationWindowGeneral Tab

The specification file is a text file that specifies all the network input files to be loaded

for the active session as well as the runcode (extension), data directory datadir, and rate

directory ratedir.

Table 7: Spec File GenerationWindowGeneral Tab Fields

DescriptionFields

This is the file extension used to distinguish different networks and different sessions. Output files and
reports are appendedwith the specified runcode file extension. Runcodesmay consist of any combination
of alphanumeric characters. This field is saved with the keyword runcode in the specification file.

Runcode

Specifies the nameof the specification file. By default this is spec.<runcode>where <runcode> is replaced
by the network file extension.

Spec File

The data directory datadir represents the path to the default directory in which your data files are searched
for. If a particular file is located in the specified data directory, its absolute path need not be providedwhen
defining that file. For example, if the data directory for a design run is specified as /user/test and the file
muxloc.test is located in that directory, you can simply specifymuxloc.test, rather than
/user/test/muxloc.test, when prompted for the location of themuxloc file. To specify the specification
file directory as the data directory, the character “.” (period) can be used as a shortcut. This field is saved
with the keyword datadir in the specification file.

Data Directory

The rate directory is used to specify the path of the directory where the tariff database files are read. In
most cases, the default path /u/wandl/db/rates/default does not need to be changed. If you want to
use you own tariffs, reference them from a directory other than /u/wandl/db/rates/default. This field
is saved with the keyword ratedir in the specification file.

Rate Directory

The dparam file specifies design and simulation parameters, hardware vendor, link

bandwidth/overhead, size and various other network parameters.
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Figure 11: Spec File GenerationWindowDesign Parameters Tab

Table 8: Spec File GenerationWindowDesign Parameters Tab Fields

DescriptionFields

Specifies the file name of the dparam file.Design Parameters File

Allows you to choose the hardware type of the network. The available hardware types displayed
depend on the current license that have been licensed by the customer. * This field is saved with
the keyword hwvendor in the dparam file.

Hardware Type

The MaximumNumber of Nodes helps the program decide howmuchmemory to allocate and
can only bemodified when the network is closed:

The MaximumNumber of Nodes (saved as maxnodenumber in the dparam file) represents the
maximum number of nodes that may be entered for a particular network. The number entered
should be no smaller than the number of nodes planned and no larger than the node_limit in your
license file. The default value is 100.

MaximumNumber of
Nodes

The MaximumNumber of Links helps the program decide howmuchmemory to allocate and can
only bemodified when the network is closed:

The MaximumNumber of Links (saved as maxlink in the dparam file) represents the maximum
number of links for a particular network. Once the limit is reached during a design, the program
does not continue to add links. The number entered should be no smaller than the number of links
planned. The default value is 1500.

MaximumNumber of
Links

Thedefault linkbandwidth, linkoverheadandper circuit bandwidthoverheadcalculations

vary for different vendors. Because of device-specific characteristics (routing algorithm,

rerouting, buffer size, queueing, etc.) the same network data may yield different results

when comparing switch models.

The Network Files tab contains references to data files that should be loaded in. Each

reference are saved in the specification file with a separate entry.
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You can read in files from the Network Files tab. The files in this tab are categorized as

described in Table 9 on page 42.

Table 9: Spec File GenerationWindowNetwork File Categories

File NamesType of File

bblink, demand, domainfile, facility, graphcoord, group, muxloc, newdemand,
nodeparam, owner, site, srvcprofile, srvctype

Backbone Files

custrate, usercostCost Files

admincost, fixlink, linkdist, nodeweight, rsvbwfileControl Files

devicedir, egress, ingress, t_trafficload, trafdir, trafficload, tunneltrafdirTraffic Files*

chanbank, offckt, offgraphcoord, offloc, offsitekAccess Design Files*

tfxdata, tfxpatternDiscrete Event simulation*

aclist, bgplink, bgpnode, bgpobj, intfmap, junospolicy, policymap, route, tbit,
tunnel, vpn

Device-Specific Files

NOTE: In Table 9 on page 42, an asterisk (*) specifies files used for a feature
that is license dependent.
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Figure 12: Spec File GenerationWindowNetwork Files Tab

Network backbone files specify how the network is represented. Backbone files include

the bblink, demand, domainfile, facilityfile, graphcoord, group, muxloc, newdemand,

nodeparam, owner, site, srvcprofile, and srvctype files.

Table 10: Spec File GenerationWindowNetwork Files List

DescriptionFile

Thebblink file contains backbone link information for the network. Each link entry is defined by a link name
[optional], From_Location, To_Location, Vendor, number of trunks, and trunk type. The vendor may be
specified asDEF (default) if it is not known. SeeBBLINK (bblink=filename) in “BackboneData” on page 370.

bblink

The demand file contains user traffic requirements. A demand is defined by an ID, From_Location,
To_Location, Bandwidth, Type, Priority, and Preempt Priority. See DEMAND (demand=filename).

demand

The domainfile contains the definitions for domain elements. Domain elements are defined by ID, name,
and color to be used in the Map window. If OSPF is present in the network, this file is used to define OSPF
areas. See DOMAIN (domain=filename).

domainfile*
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Table 10: Spec File GenerationWindowNetwork Files List (continued)

DescriptionFile

A facility is a set of nodes and links likely to fail together. The facility file defines the links and/or nodes
associated with a facility. In this file, the first field defines the facility name. The subsequent fields specify
the node IDs or link names associatedwith that facility, delimited by tabs, spaces, or commas. All elements
associated with a facility should be specified on the same line. Whenever more than one line is needed to
specify the elements, a backslash, '\', must be used to indicate that the element list is continued on the
next line.

The facility feature does not check the validity of the nodes and/or links listed in the facility file. Duplicate
links and/or nodes are also duplicated in the facility. Nodesmay be specified either by their node ID or node
name. If both are used in the same facility, then that node is duplicated. Nodes which are not in themux
file and links not in the bblink file are ignored. See FACILITY (facility=filename).

facility*

The graphcoord file is used to position nodes at coordinates different from their true geographic location.
This is often times helpful whenmultiple nodes have the same NPANXX location or are located in close
proximity to each other. Nodes may bemoved by first selecting them and then dragging them to the new
location. Note that pricing information is not changed since only the graphical representation has been
modified rather than the geographical. See FACILITY (facility=filename) .

graphcoord

The group file defines the grouping of nodes in the network topology. Discs are painted on the Standard
map around grouped nodes. See GROUP (group=filename).

group

Muxloc specifies the file containing switch information such as name, ID, NPA, NXX, latitude, longitude,
vertical, or horizontal. This information is used to determine location placement in themapwindow as well
as for link pricing. SeeMUXLOC (muxloc=filename).

muxloc

The newdemand file allows you to specify an additional file containing user traffic requirements besides
the demand file. The purpose is to reduce your effort inmanuallymodifying the existing demand file, and/or
havingmultiple versions. In addition, the newdemand file is often used in theoretical "What if..." situations
in determining capacity planning for the current network state. See DEMAND (demand=filename).

newdemand

The nodeparam file allows you to define specific information on a per-node basis such as the hardware
type, vendor, or model. See NODEPARAM (nodeparam=filename).

nodeparam

The owner file facilitates identifying the ownership of nodes and demands. Ownership should be specified
in either the muxloc or demand files. SeeOWNER (ownerfile=filename).

owner

The site file specifies site information. The site file is used to define nodes in the same physical location
such as a building or campus.

site

The service profile file lists the service types and the percentage that are in each service profile..service profile

The service type file lists service types (for example, FTP, TELNET) and their descriptions (for example,
owner, min. andmax. bandwidth, type, pri, pre).

service type

NOTE: In Table 10 on page 43 an asterisk (*) specifies files used for a feature
that is license dependent.
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For more information regarding the files in Table 10 on page 43, refer to the File Format

Reference for IP/MPLSView

Cost and control files are used to assign tariffs and implement link controls. Examples

of cost and control files are: custrate, usercost, admincost, fixlink, linkdist, nodeweight,

and rsvbwfile.

Table 11: Cost and Control Files

DescriptionFile

The custrate file is used to assign tariffs for links used in the network to approximate the total cost of the
network. You can specify the parameters fromwhich these tariffs are calculated using themodify custom rate
and custom rate class windows. See CUSTRATE (custrate=filename).

custrate*

The usercost file is used to define the cost for links according to the end nodes, vendor, and trunk type. See
USERCOST (usercost=filename).

usercost

The admincost file contains rules to set each link default admin weight/metric according to attributes such
as trunk type, mileage, and the hardware type and sites of the endpoints.

admincost

The fixlink file specifies information for links that cannot be removed from the backbone topology. For varying
reasons, a customer might have a group of links in the backbone that cannot be removed (even if it is optimal
to do so). In this case, during the optimization phase of the design, links from the fixlink file are not modified.
Note that the bblink file might be used for the fixlink file if the current topology cannot be changed. See
FIXLINK (fixlink=filename).

fixlink

The linkdist file is used to define link distance values on a node pair basis. Link distances can be used to bias
path routing by assigning either a higher or lower weight to a node pair. If a linkdist file is not specified or a
particular link’s metric is not defined, and the AdminWeight routing method is specified in the design options
of the Path Placement tab, the default link distance value is assigned. See LINKDIST (linkdist=filename).

linkdist

The nodeweight file is used to restrict the creation of links at particular nodes during design by assigning to
the node a penalty for adding links or themaximum bandwidth capacity for links. This file can also be used to
restrict the transitdemandbandwidthatanode if thehardwaremodel supportspathconfiguration fordemands.

Every entry in thenodeweight file consists of four fields: node IDor name, nodeweight (linkpenalty for design),
maximum bandwidth capacity (to carry links), and transit demand bandwidth limit. Fields are separated by
spaces or tabs. A node weight is required if maximum link bandwidth capacity is to be specified. See
NODEWEIGHT (nodeweight=filename).

nodeweight

The rsvbwfile is used to define reservedbandwidth for links between specific nodepairs. Reservedbandwidth
is specified as a fixed bandwidth (fixfat) plus a percentage of the link bandwidth (fatpct). See RSVBWFILE
(rsvbwfile=filename) for the file format.

• For node pairs not defined in this file, reserved bandwidth specification is derived from the fixfat and fatpct
global parameters defined by selecting Tools > Options > Design in the Reserved Bandwidth options pane.

• Reserved bandwidth is not used by during path assignment and backbone design if the hardware supports
path configuration. The reservation constraints, however, are ignored by the simulation and failure analysis
routines.

rsvbwfile

NOTE: In Table 11 on page 45, an asterisk (*) specifies files used for a feature
that is license dependent.
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For more information regarding these files, refer to the Design Menu chapter and the File

Format Reference for IP/MPLSView.

Access Design Files

This access design feature requires a license. For more information, contact your Juniper

Networks representative. Examples of access design files include: chanbank, offckt,

offgraphcoord, offloc, and offsite.

Examples of traffic files include: devicedir, egress, ingress, t_trafficload, trafdir, trafficload,

and tunneltrafdir.

Table 12: Traffic Files

DescriptionFile

The egress file contains egress traffic of the network interfaces load. Egress traffic specifies traffic
that is going out of the network interfaces. This data is used for calculating link utilization and load.

egress*

The ingress file contains ingress traffic of the network interfaces load. Ingress traffic specifies traffic
that is going into the network interfaces. This data is used for calculating link utilization and load.

ingress*

The trafdir file identifies the location of the interface traffic daily directories repository.

The tunneltrafdir file identifies the location of the tunnel traffic daily directories repository.

trafdir*, tunneltrafdir*

The trafficload file allows you to import measured bandwidth utilizations based on data collected
from the network. Traffic loads for each PVC can be specified over the time intervals for which the
data was collected.

The t_trafficload file (IP/MPLS only) is similar to the trafficload file, but for LSP tunnels (layer 2
instead of layer 3)

trafficload*,
t_trafficload*

NOTE: In Table 12 onpage46, anasterisk (*) specifies files used for a feature
that is license dependent.

For more information regarding these files, refer to the IP/MPLSView Java-Based

Management and Monitoring Guide and the File Format Reference for IP/MPLSView.

Examples of the discrete event simulation files include: tfxdata, tfxpattern

Table 13: Discrete Event Simulation

DescriptionFile

For discrete event simulation only. The trafficdata file allows you to define each demand by specifying
multiple packets and packet sizes. Although this requires you to have a reasonable knowledge of the traffic,
more accurate network simulation results can be obtained in this manner. Refer to TRAFFICDATA
(TRAFFICDATA=filename) for further details.

tfxdata*
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Table 13: Discrete Event Simulation (continued)

DescriptionFile

For discrete event simulation only. The trafficpattern file allows you to define several class types based
on traffic characteristics. Each traffic typemaybespecified in termsof fourparameters: numberofmessages,
duration (seconds), message size (bits), and frame size (bytes). Refer to TRAFFICPATTERN
(TRAFFICPATTERN=filename) for further details.

tfxpattern*

NOTE: In Table 13 onpage46, anasterisk (*) specifies files used for a feature
that is license dependent.

Device specific files contain the definitions for various types of devices. Examples of

device specific files include: aclist, bgplink, bgpnode, bgpobj, intfmap, policymap, tbit,

tunnel, and vpn.

Table 14: Device-Specific Files

DescriptionFile

The aclist file (Router only) contains information about access rules such as access lists, distribute
lists, and filter lists.

aclist*

The bgplink file (Router only) contains the definitions for BGP neighbors. See note for bgpobj. See
note for bgpobj.

bgplink*

The bgpnode file (Router only) contains the definitions for BGP speakers. See note for bgpobj.bgpnode*

The bgpobj file (Router only)contains information about BGP neighbors and is stored in binary format
to speed up performance. Note: If you want to manually edit bgpnode and bgplink, comment out this
entry before reloading the network.

bgpobj*

The intfmap file (Routeronly) contains informationabout router interfaces, including thenode, interface,
IP address, status, bandwidth, VPN-list, and other details.

intfmap*

The policymap file (Router only) contains information about CoS Policies on each routerpolicymap*

The tbit file (Router only) stores names for the tunnel attributes (otherwise referred to as admin group
for Juniper Networks).

tbit*

The tunnel file (Router only) contains information about LSP tunnels.tunnel*

The vpn file (Router only) contains information about Virtual Private Network details such as vrf, route
distinguisher, route target, and protocols.

vpn*

The routing table descriptor (rtd) file (ATM/PNNI only) is used for PNNI networks to read routing table
descriptor information. This file is generated by IP/MPLSView after you saved the network’s RTDs.

rtd*

The hpnni file (ATM/PNNI only) is used for PNNI networks to describe PNNI information for nodes and
logical group nodes in the network. It also contains hierarchical informationwhich allows IP/MPLSView
to group the network’s nodes accordingly.

hpnni*
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NOTE: In Table 14 onpage47, an asterisk (*) specifies files used for a feature
that is license dependent.

For additional files not listed here, or for a detailed description of these files, their

parameters, and their functions, refer to the File Format Reference for IP/MPLSView.

The Report Viewer allows you to view reports that are generated by the system. The

report viewer provides quick access and a uniformed and organizedway of viewing these

reports. To view a report, you must select a file that is in IP/MPLSView report format. To

customize the columns displayed, right-click on the column header and select theSelect

Columns... option.

Figure 13: Report ViewerWindow

Due to the length of some reports, the Report Viewer only displays a portion of the report

in the viewer window. Youmay set howmany lines to display in the Page Setup. With

the jump-to buttons, you can jump to the beginning and end of the report. You can also

move forward or back. Clicking the Search button searches the current table for the

queried text.Clicking theAdvancedSearchbuttonopensanewwindowformorecomplex

searches. The query is entered in the text field at the top of the window. The panels on

the bottom are provided for convenience in selecting keys, relations, and boolean

operators.

Figure 14: Report Viewer Toolbar
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Figure 15: Advanced Filter Window

The Report Master allows you to viewmultiple reports in the Report Master window. The

Report Master is similar to the Report Manager which provides quick access and a

uniformed and organized way of viewing multiple reports without having to open a

network first. To open a report master, you must select a file that is in report master

format.

Figure 16: Report MasterWindow

The Report Master files do not contain any actual reports. Instead, the Report Master

files reference existing reports and place them into an organized tree structure. The

format of a Report Master file is described below.

# IP/MPLSView Report Master
1st_item First.report
2nd_item ../../other_path/2nd.report
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3rd_item {
3-1_item /export/home/data/3-1.report
3-2_item 3-2.report
3-3_item {
3-3-1_item 3-3-1.report
3-3-2_item 3-3-2.report

}
}

The Report Editor allows you to perform basic editing functionality on csv files. Click on

a cell to edit the value. Right-click on a cell to formore options to edit rows and columns.

Figure 17: Report EditorWindow

Table 15: Report EditorWindow File Manager View

This option displays all hidden files in the directoryShow Hidden Files

This option displays files and directories listed in the File Manager’s right pane as large icons in
columns.

Large Icons

This option displays files and directories listed in the File Manager’s as small icons in columns.Small Icons

This option displays files and directories listed in the File Manager’s in list form.List

This option gives adetailed viewof the files displayed in FileManager including information such
as file permission, file owner, file size, and lastmodified date. (Note: Each column can be sorted
by clicking on the column header.)

Details

This toggles the left pane between the Directories view and Common Actions / Favorite Link
view.

Directory View

Text Editor

The text editor allowsyou toedit any text file foundon the systemviaagraphical interface.

When a file such as a log file or IP/MPLSView network file is double-clicked, the text

editor is launched. When a text file is opened in the text editor, the file name is displayed

across the top.
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Figure 18: The Text Editor

Table 16: Text EditorWindow Functions

DescriptionFunction

Save the file.Save

Save the file under a different name and/or directory.Save As

Print the current file to a printer.Print

Cuts the selected text being edited.Cut

Copies the selected text being edited.Copy

Pastes any cut or copied text.Paste

Search for or replace a specified string.Find/Replace

Select and highlight all the text.Select All

Jump to a certain line in the file.Go To

Toggles displaying the line numbers.Show/Hide Line#

Displays only the lines with a text match. Supports regular expression. The filter is
case sensitive.

Filter Line
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Table 16: Text EditorWindow Functions (continued)

DescriptionFunction

Removes any filters and displays the original text.Restore to Original Text

Change the text font size.Font Size

Figure 19: The Find and Replace Dialog Box

Table 17: Text EditorWindow Find and Replace Functions

DescriptionFunction

Specify the text to be searched.Find Text

Specify the replacement text.ReplaceWith

Click this button to search for the next occurrence of the text.Find Next

Click this button to replace the highlighted text.Replace

Click this button to replace all occurrences of the text.Replace All

Toggles the text search to be case sensitive or insensitive.Match Case

Sets the Find/Replace function to search for the text in reverse order toward the
beginning of the file.

Find Backward

NOTE: If you open a file that is larger than 4MB in size, then IP/MPLSView
will launch the text editor in read-only mode. This is to prevent memory
over-usage for the system.

Config Editor (Router and Switch)

IP/MPLSView provides a convenient and easy-to-use config editor for editing router

configuration files. This editor functions similarly to other text editors, but contains some

special operations and built-in recognition of configuration file keywords to facilitate the

editing of config files. Supported router configs include Cisco (IOS, XR, CatOS, Nexus),
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Foundry, Juniper Networks (Junos OS, EX, ERX), Riverstone (RapidOS, ROS-X), Tellabs,

Alcatel, Extreme, Huawei, Redback, Starent, and Zyxel.

Toaccess, simplydouble-clickonaconfiguration filewithin theFileManager. Alternatively,

if your network model was built up from config files via File > Import NetworkWizard,

you can also right-click on the router in the Map window or the Network Info window

Nodes view and select ShowConfig File. This will open up your config file in the Config

Editor as shown in Figure 19 on page 52.

NOTE: For thoseusing theOnlinemoduleof IP/MPLSView, if youhaveopened
theLivenetwork, right-clickedonanode in theMap,andselectedShowConfig

File, the config editor will only allow you to view the configs, and not edit

them. This is because they represent the actual state of the configurations
in the network.

Figure 20: Config EditorWindow

To edit, simplymodify by inserting or deleting characters in the text area. Then, press the

Save icon. To close a file, select Actions > File > Close. To open a config file from your

local machine rather than the server, select Actions > File >Open Local. Editing tools can

be found in the toolbar, in the right-click menu that appears in the left pane, and in the

Actions menu.

Most of the editor functionality is self-explanatory or standard. The following lists some

specific capabilities of the Config Editor:
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• Config Editor Open Multiple Files

• Compare Two Files

• Keep Track of Revisions Made to a File

• Navigate the Config File Quickly With the Outline

• Find and Replace , including ability to search globally within all configuration files in

your current network model

• Collect and Refresh Configuration Files (IP/MPLSView Online Module Only)

• Insert an Entire Text File

• Set Color-Coding and Other Options

To open a config file located on the server, press theOpenicon on the toolbar. Or select

Actions > File > Open. To open a config file located on your local machine, select Actions

> File > Open Local.

A new tab is created in the left pane of the Config Editor for each file that is opened.

You can perform side by side comparison of config files by opening a config file in a new

window. To do so, first select the tab of the desired config file. Right-click somewhere

over the config’s pane and selectOpen in NewWindow. A new instance of the Config

Editor will appear and the selected config is moved from the original window over to the

newwindow.

Compare Two Files

To compare two files, select Actions > Tools > Compare > Two Files. You are prompted

to specify two files located on the server machine. Use the “Browse” buttons to navigate

to the desired file. Then, press “OK”. The File Diff windowwill appear showing the

side-by-side results of the “diff”.

Note that thesesamecomparisoncapabilitiesarealsoavailable via theRevisionManager.

You can access the Revision Manager directly through the Config Editor via Actions >

Tools > Revision Manager. If you have already set up revision information for the current

network, you can compare two files using Actions > Tools > Compare >With Revision.

See “RevisionManager (IPModels)” on page 364 formore information on how to use the

Revision Manager.

NOTE: The Revision Manager requires a license. Please contact your Juniper
Networks representative for more details on this feature.
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Figure 21: Select Two Files for Comparison

Figure 22: File Diff Side-by-Side Comparison

Entries in GREEN indicate that a linewas added. BLUE indicates a linewas removed. RED

indicates the line has changed. The green, blue, and redmarkers on the right bar of the

window can help you quickly scroll to the points where differences have been detected.

Keep Track of RevisionsMade to a File

You can use track changes made to a file, using Actions > Tools > Revision Manager.

After the initial setup of the revision system, you can “Check In” your config file to create

anew revision/versionnumber. See “RevisionManager (IPModels)” onpage364 formore

information on how to use the Revision Manager.

Navigate the Config File QuicklyWith the Outline

The Config Editor divides each router configuration file into blocks. In Junos OS, for

example, blocks are clearly defined by brackets. For other hardware, the Config Editor

divides blocks based on certain major commands. The Outline section of the Config

Editor, located in the upper right hand side of the window, lists a high-level “outline” of

these major commands. Click on any point in the outline to immediately jump to that

section of the config file. Press the “+” and “-” boxes to the left of an entry to expand and

collapse the entry, respectively. You can also hide or show the Outline Pane using the

toggling menu options Actions > Hide Outline Pane and Actions > ShowOutline Pane.

55Copyright © 2018, Juniper Networks, Inc.

Chapter 4: File Manager



Figure 23: How to Use the Outline

• Clicking on an entry in the Outline pane will cause the Config Editor to jump to that

section of the config file, highlight the first line of that section, and expand that block.

In Figure 22, Tunnel7 is expanded in the left pane.

• Right-clickingwithin the left pane reveals threeOutlining options. If yourmouse cursor

is placedsomewhere in theconfig file text in the left pane, andyouselectToggleOutline,

then the section containing the cursor will expand if currently collapsed, or collapse if

currently expanded. You can accomplish the same thing by clicking directly on the “+”

and “-” boxes to the left of each config section. “Collapse All Outline” and “Expand All

Outline” will collapse or expand all sections, or blocks, in the current config file view.

Note that these operations are also available via the Config Editor’s Actions menu on

the window’s topmenu bar.

• Holding your mouse cursor over a “+” box to the left of a collapsed block in the config

file will pop up a tooltip showing the contents of that section.

Find and Replace

The Actions > Search submenu contains the following features:

• Find and Replace: This is a standard Find and Replace editor function.

• Find on this File: This opens the Find function in the Config Editor toolbar.

• Find in Configuration Files: This function allows you to perform a global search on all

config files associated with the currently opened network model, not just the config

files that are opened in the Config Editor. Results are displayed in a table, as shown in
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Figure 24. Within this table, you can double-click on an entry or press the “Show in

Editor”button.Thecorrespondingconfig file isdisplayedin theConfigEditor (oropened

if you have not yet opened it) and the occurrence of the word is highlighted.

• Go To: Jump to a specific line in the file.

Figure 24: Find in Configuration Files

Figure 25: Find in Configuration Files Results

Collect and Refresh Configuration Files (IP/MPLSViewOnlineModule Only)

This feature is located inActions>Tools>Collect andRefreshConfiguration. It is available

for IP/MPLSView only, and accessible only if you are in online, or live, mode (select File

>OpenLiveNetwork ). This option applies to just the config that is currently being viewed

in the Config Editor. It allows you retrieve the router’s configuration file from the live

network and update your copy within the Config Editor.

Insert an Entire Text File

If you have config file statements in another file that you wish to insert at a particular

point of the current config file, select Actions > Edit > Insert Text File. Browse for a text

file that is located on the server. If your text file is located on your local machine, select

Actions > Edit > Insert Local Text File instead.

Set Color-Coding and Other Options

YoucansetConfigEditor color coding, font, andgeneral preferencesviaActions>Options.

Note that you can also access these preferences by selecting Tools > Options > General

from the software’s main menu bar. In the Options window, click on Config Editor.
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Figure 26: General Config Editor Options

DescriptionFunction

If this is enabled, thenas you typewithin theConfig Editor, Auto-completionwill suggest
the completeword based on its database of keywords for the particular hardware. Only
major keywords for certain hardware models are supported.

Enable auto-completion

If this is unchecked, then the Outline and Property panes of the Config Editor is hidden,
providing more room for the main config editing panel.

Show outline and property pane

If this is enabled, then the Config Editor displays a list of items found from Integrity
Checks report.

Show output/integrity check list

If you click this option, then the next time you open a config file, it is opened in
IP/MPLSView’s standard editor. That is, the configuration file will not be outlined in
blocks, there is no color-coding of keywords, auto-completion, etc.

Use memory-efficient alternative
editor

Figure 27: Config Editor Color Options Example
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Figure 28: Config Color Options

DescriptionItem

Foreground is the text color. Background is the color of the page.Foreground, Background

Whatever text that is selected is highlighted in this color. Select text by dragging the mouse.Selection

The cursorCaret

For config files that use brackets, when you select an open bracket (‘{‘), the matching close
bracket (‘}’) will also be highlighted.

Bracket Match

These are colors assigned to different levels of config file keywords. These keywords are
pre-defined by the Config Editor, and selected based on both importance and howwell they
facilitate readability of the file. In general, Keyword 1=major commands,Keyword2=sub-major
commands, Keyword 3 = commands with “negative” meaning (for example, “shutdown”,
“disable”, “inactive”, etc.).

• Note: In a future release, these will also be editable.

Keyword 1,2,3

Any user-specified string, such as an interface description, often in double quotes.Literal

CommentsComment

All instances of IP addressesIP Address
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CHAPTER 5

TopologyWindow

The topology (map) window is the main work area for any network model you load into

the system. Multiple links displayed between nodes uses “line bending" to avoid hidden

trunks in the topology. The topology incorporates node aggregation collapsible views.

You can also view node locations via their geographic coordinates on the world map,

NPA/NXX, or automatic layouts.

The topologywindowdisplays important link and node properties. Links are color-coded

according to utilization. Alternatively, you can view links by other properties such as

media, trunk type, vendor or domain/area. Nodes are color-coded by symbols, icons, or

vendor types.

Path analysis can be performed in the topology window. The path function displays

detailed path information between any two nodes found in the network based on factors

such as routing method used, reserved and actual bandwidth allocation, link distance,

or oversubscription.

• TopologyWindowOverview on page 62

• Center Pane Map on page 63

• Left Pane Legend on page 65

• Map Filters on page 67

• Filters > Protocols on page 67

• Filters > Type on page 69

• Filters > Routing Instances on page 69

• Filters > Advanced on page 70

• Map Elements on page 71

• Network Elements > Nodes on page 71

• Network Elements > Links on page 72

• Network Elements > Facilities on page 72

• Utilization Legends on page 73

• Utilization Legends > Planned Node Load and Measured Node Load on page 75

• Map Subviews on page 75

• Subviews > Link Status on page 75
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• Subviews > Multicast on page 76

• Subviews > Type on page 76

• Right Pane Toolbar on page 79

• Map Popup Menus on page 84

• Map Views on page 84

• Grouping Popup Menus on page 86

• Selection Options on page 87

• Custom URLs on page 88

• Labels Menu on page 89

• Layout on page 91

• Internet Map at Click on page 92

• LineWidths on page 93

• Background Image on page 93

• Country Maps on page 93

• Find on page 93

• Refresh on page 94

• Zoom on page 94

• Print on page 94

• Export on page 94

TopologyWindowOverview

The topology window is divided into three areas: Left Pane Legend for changing the

setting of the topology view; Center Pane Map displaying the network; and Right Pane

Toolbar. Right clicking on themap opens a pop-upmenu for more functions. Move the

mapby holding the leftmouse button anddragging. Zoom in and out by using themouse

scroll wheel.
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Figure 29: The Topology ViewWindow

Table 18: Topology Map Pane Areas

ReferenceDescriptionArea

See “Center Pane Map” on
page 63

TheTopologyMapArea is themiddle portion of the TopologyMap.
In this area, you can select andmove nodes around on themap.

Center Pane Map

See “Left Pane Legend” on
page 65

The left pane of the topology window contains drop-down boxes
for the following functions: Filters, Network Elements, Utilization
Legends, and Subviews.

Left Pane Legend

See “Right Pane Toolbar” on
page 79

The toolbar at the right of the topologywindowprovides shortcuts
to functions in the Popup Menu.

Right Pane Toolbar

See “Map Views” on page 84The popupmenu is accessed by right-clickingwithin the Topology
Map Area. Right-clicking over a node, link, or group results in a
popupmenu for that element.

Pop-Up Menu

Center PaneMap

The topology map is a graphical representation of the baseline network. IP/MPLSView

candisplay the topology in several viewsdependingon thenetwork:BGP(BorderGateway

Protocol), LSP tunnels, Layer 3. These views can be selected from the Network menu in

the MainWindow.

Features

• When thecursor is positionedoveranetworkelement in topologywindow,adescription

of thenetworkelement isdisplayed in thedescriptionbarat thebottomof the topology

window. That description can be customized from the popupmenu’s Labels > Bottom

Bar menu.

• Double-click to get full detailed information about the element.

• Right-click on an element to viewmore options for that element.
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• Hold the left mouse button to drag the map around.

• Use themouse scroll wheel to zoom in and out on themap.

SelectingMultiple Nodes and Links

There are several ways to select nodes and links in the topology map.

• Use the Selection Tool and drag a rectangle around the nodes and links you want to

select.

• <Ctrl>-click or <Shift>-click on nodes and links.

• Right-click on a node and use Select options.

• Right-click on a link and use Select options.

Moving Nodes

Whenmoving nodes in the map area, you are changing the graphical coordinates rather

than the geographical coordinates. Graphical coordinates are the positions of the nodes

in the topology window. Geographical coordinates are positions of the nodes according

to actual physical locations (for example, latitude and longitude). To set the current

positions as geographical positions, right-click over the map area and select Layout >

Set Lat/Lon fromMap.

SavingMap Settings

Topology information that gets saved to each client include the following:

• Map Preferences Settings See “Map Preferences” on page 359.

Topology information that gets saved to each network includes the following:

• group file: Groupings of network devices are saved in the group file.

• graphcoord file:Graphical coordinates of network devices are saved in the graphcoord

file.

• graphcoordaux file: Auxiliary map settings below.

The graphcoordaux file stores the following map settings data:

• Legends:Nodeand link color settings, link utilization color bar settings, line styles,most

checkboxes in Subviews > Protocols, checkboxes in Filters > Type

• Labels:Which node/link labels were turned on, labeling preferences for the bottom

bar.

• Background Image: See “Background Image” on page 93.

• Country Maps: See “Country Maps” on page 93.

• Groups:Which groups were collapsed and which groups were expanded.

Multiple map views can be saved for the same network using the Map Views feature.

Eachview is savedon the server in auserSettingsdirectory consistingof group (grouping),
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graphcoord (graphical coordinates), and graphcoordaux files. For more information, see

“Map Views” on page 84

Left Pane Legend

NOTE: Anasterisk (*) Indicates this feature requiresa license touse.Contact
your Juniper Networks representative for more information.

Filters

Table 19: Left Pane Legend

ReferenceDescriptionItem

See “Filters > Protocols” on
page 67

Allows you to view your network by different categories such as by
protocol.

Protocols

See “Filters > Type” on page 69Allows you to show or label certain categories of nodes (for example,
by hardware type) and links (for example, by trunk type)

Types

“Filters > Routing Instances” on
page 69

Displays routing instances/OSPF process IDs associated with each
link/interface by the color in the legend, which can be customized
using Set Color... in the right-click popupmenu. Refer to the Router
Feature Guide for IP/MPLSView chapter titled Routing Instances for
more details.

Routing
Instances*

See “Filters > Advanced” on
page 70

Includes options to hide certain elements such as nodes (AS’s) or
links (low utilization links)

Advanced

Network Elements

ReferenceDescriptionItem

See “Network Elements > Nodes” on
page 71

Includes a list of the nodes in your network. Clicking on a node
will highlight it on the map.

Nodes

See “Network Elements>Links” onpage 72Includes a list of links for the selected subview. Clicking on a
link will highlight it on the map.

Links

See “Network Elements > Facilities” on
page 72

Includes a list of facilities in the network. A facility is a set of
nodes and links likely to fail together.

Facilities

Utilization Legends

ReferenceDescriptionItem

See “Utilization Legends” on
page 73.

Displays the planned link utilization using colors of the color bar.
Planned utilization is the percentage of the link used by the
demands you input into the network.

Utilization
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ReferenceDescriptionItem

See “Utilization Legends” on
page 73.

The Peak Util display feature is used after running a failure
simulation script to view the highest (or worst case) link
utilization loading experienced by each link, depending on the
rerouting of demand/flow traffic after any single failure.

Peak Util

See “Utilization Legends > Planned
Node Load and Measured Node
Load” on page 75.

Displays the planned traffic on a node by a color bar. For further
information.

Planned Node Load

See “Utilization Legends > Planned
Node Load and Measured Node
Load” on page 75.

Displays themeasured interface traffic on a node by a color bar.MeasuredNodeLoad

Displays the measured interface traffic load by CoS, as an
alternative to Traffic > Traffic Load, Interface.

Measured Link Util

Displays the normal and peak utilization calculated based on
demand routing, as an alternative to Traffic > Traffic Load.

Demand CoS Util

Subviews

DescriptionItem

Displays Autonomous Systems (AS’s) by color. Each respective AS and their colors are shown in the left
pane as a legend. The color can be customized using Set Color... in the right-click popupmenu.

AS

Displays the domain or area (for example, OSPF area) by color. Each respective area and its colors are
shown in the left pane legend. The color can be customized using Set Color... in the right-click popup
menu.

Area/Domain

(MPLS-TEmodule). View linksby logical combinationsofRSVP resource colors (Ciscoattributeor Juniper
Networks admin group). The logical combinations available include all, any, and not. See the Router
Feature Guide for IP/MPLSView for more information.

Attribute/Admin
Group

(Router module). Displays operational statuses of links and virtual trunks using colors or line styles.
Operational Statuses for links include Down, Passive, and Other. Operational statuses for virtual trunks
include VT (for an operational virtual trunk) and VT Down for a non-operational virtual trunk. See
“Subviews > Link Status” on page 75.

Link Status*

Displays linkmedia typesusingcolorsor linestyles.Valid linkmediaattributes include:TERRES(terrestrial),
SAT (satellite), MCWAVE (microwave), FIBER, and ENCRYPT (encrypted). These media descriptors are
used in route biasing of demands using criteria such as preferred, preferred not, and required. The color
and style of these links can be customized by right-clicking on the icon in the left pane and selecting Set
Color or Set Line Style.

Media

Includes multicast groups in the network. Selecting one will highlight the distribution tree on themap.
See “Subviews > Multicast” on page 76.

Multicast*

Allows you to view your network by different categories such as by protocol. See “Filters > Protocols” on
page 67.

Protocols
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DescriptionItem

Displays routing instances/OSPF process IDs associated with each link/interface by the color in the
legend, which can be customized using Set Color... in the right-click popupmenu. See “Filters > Routing
Instances” on page 69. Refer to the Router Feature Guide for IP/MPLSView for more details.

Routing Instances*

Displays types of nodes (for example, by hardware vendor) and links (for example, by trunk type). See
“Filters > Type” on page 69.

Type

Displays link vendors using colors or line styles. Possible values for vendors include those that are specific
to a certain country or region, and are listed in the tariff database. If a vendor is not specified, the vendor
is set to the default DEF. To represent in-house fiber links with zero cost, the vendor should be set to
NET. The color and style of these links can be customized by right-clicking on the icon in the left pane
and selecting Set Color or Set Line Style.

Vendors

Map Filters

Filters > Protocols

The Subviews > Protocols pane offers the ability to display subsets of the available

network routing protocols in the network using logical operations like AND, OR, NOT, and

EQUAL. The selections availablewill vary according to the protocols in the open network

The bottom of the pane contains the number of nodes, pseudo-nodes, groups, and links

that are currently displayed out of the total number. The number displayed is less than

the total when objects are hidden due to selections either in this pane or other Filters

panes.
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Figure 30: Left Pane of TopologyWindowUnder Subviews

Show, Not

Selecting Show by itself for a protocol displays all network elements supporting the

protocol. Selecting Show and Not together for a protocol displays all network elements

that do not support the protocol.

Logical Operations (=, &, and or)

You can perform logical operations on the protocol list selections. The equal operation

(=) specifies that only the currently selected subview is shown. Only one selection is

allowed for this operation. The AND operation (&) specifies that the intersection of the

protocol subviews is displayed. The OR operation (or) specifies that the union of the

protocol subviews is displayed. lists the logical operations.

InterpretationProtocolsLogical Op

Filters the display to showOSPF enabled links.OSPF=

Filters thedisplay to showall linkswithOSPFenabledbutwithout
MPLS enabled

OSPF: “Show” MPLS-TE: “Show Not”&

Filters the display to show all links with either OSPF or ISIS
enabled.

OSPF: “Show” ISIS: “Show”or
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Filters > Type

With the Types function, you can choose to display or hide network element symbols in

the topology map depending on the type of node or link (for example, hardware vendor,

or trunk type) by selecting or deselecting the corresponding checkbox. Use Show All or

None to toggle on or off the display of all element types.

Figure 31: Types

Filters > Routing Instances

With the Routing Instances filter function, you can choose to display or hide links

depending upon the routing instance or OSPF process ID it belongs to by selecting or

deselecting the corresponding checkbox. Use Show All or None to toggle on or off the

display of all routing instances.

Figure 32: Routing Instances

Click a color box to change the legend color. Alternatively, right-click a box and select

Set Color. Right-click on the color box and selectHighlight. These Items to highlight links

of this routing instance.
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Filters > Advanced

Figure 33: Advanced Filter

DescriptionOption

You can select some nodes/links on themap and then click Record to take a snapshot
of the selection. After the recording is made, selecting the checkbox shows only the
recorded selection.

Recorded Selection > ShowOnly
Recorded

You can select some nodes/links on themap and then click Record to take a snapshot
of the selection. After the recording ismade, selecting the checkbox hides the recorded
selection from themap.

Recorded Selection > Hide Recorded

Allows you to show only selected autonomous systems (ASs) in the topology map.
Click Select to specify which ASs to show.

AS > ShowOnly Selected ASs

Intragroup Links connect nodes within a group. If there are several layers of groups,
selecting Intragroup Links > Hide All hides all links within the top-level groups and
selecting Intragroup Links > Hide Tier 2 hides all links within groups that are two group
levels down.

Intragroup Links > Hide All

Intragroup Links > Hide Tier 2

Click Set... for one of the three categories (Node, Group, or Link) to create an advanced
filter statement. Then click the checkbox to turn the filter on or off.

Advanced Filter

Hides nodesandgroups that are disconnected fromall other nodes andgroups in every
subview in the map.

Hide Isolated Points

Hides nodes and groups that are disconnected from all other nodes and groups in the
current subview.

Hide Isolated Points in Subview
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DescriptionOption

Hides ASNODE(s) and the link(s) and/or LANs that connect the ASNODE(s) to the
rest of the network. (ASNODES represent ASs outside the network with EBGP peering
relationships with BGP speakers of the network.)

Hide AS Nodes/Links

Hides back-up routes in the topologyHide Backup

Hides virtual trunks in the topology.Hide VT

Hides intergroup links connecting different groups.Hide Intergroup Links

Map Elements

Network Elements > Nodes

When this option is selected, the groups/nodes in the network are displayed in a tree

view in the left pane. Selecting a node or collapsed group in the list will highlight it on the

map display. The groups, if defined in the network, are displayed with group elements

indented underneath. To expand or collapse a group, click on the hinge icon to the left

of it. You can add an element into a group by selecting the element name, dragging it

and dropping it over the Group’s name.

Figure 34: Network Elements > Nodes List with pop-upmenu
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Network Elements > Links

When selected from thedrop-downmenu, this functions display all links associatedwith

the protocol selected in the Subviews > Protocolsmenu. For example, if you select

Frame-Relay protocol in the Subviews > Protocolsmenus, then the Links list will only

display the links associate with Frame Relay.

The link names are displayed in a list view in the left pane. Selecting a link name in the

list will highlight it in the topology window. Clicking on the links on the topologymapwill

also highlight them on the links list.

Figure 35: Links List with pop-upmenu

Network Elements > Facilities

A facility is a group of links and/or nodes that are likely to fail together. It is used in failure

simulations where accurate modeling requires the simultaneous failure of specific links

and/or nodes. For instance, if several links travel over the same fiber, a fiber cutwill break

all of them at once. In this case, one can define a facility to represent the SRLG (Shared

Risk Link Group) containing those links. Another example is the set of switches on one

floor of a large data center, together with all the links going into or out of that floor.
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Figure 36: Facility List

Utilization Legends

• TheUtilization displays the plannedutilization rate of links resulting from thedemands

in the network model.

• The Peak Util displays the links according to the peak utilization reached on that link

ina failure simulation.See theSimulationchapterof theTrainingGuide for IP/MPLSView

for more details.

• TheMeasured Link Util displays themeasured link utilization, up to 24 periods. A slider

bar can be used to check the utilization at different periods. The data comes from the

ingress (interfaceLoad_in) or egress (interfaceLoad_out) files. For the live network this

is named Interface CoS Util and uses the /u/wandl/data/.network/interface.traffic

and interfacei.traffic files.

• The Demand CoS Util displays the normal and peak utilization per CoS calculated

basedondemand routing. In this case, it is basedoff ofboth thedemandand trafficload

file. The trafficload file is used to display up to 24 periods. A slider bar can be used to

check the utilization at different periods.
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Figure 37: Utilization Legend

PopupMenu

DescriptionMenu Item

This will open a color palette that allows you to choose a color for the section selected
on the color slider.

Edit Color

This will add a new divider on the color bar at the location of the right-mouse-click.Add Divider

This will change themaximum utilization percentage on the color slider to the specified
value in the NewMax window.

Change Max

Use this to zoom intoaparticular percentage range, for example, 0.00-10.00%for greater
granularity.

Change Viewing Range

Selecting this option shows links thathave theselectedcolor.Note thatwhendeselecting
a color, a link is hidden only if the colors of both of its interfaces are deselected.

Show Selected Color

Shows links of any colors.Show All

Hides all links.Show None

This will reset the Prov Util color bar to the original default setting of dividers and colors.Reset to Defaults
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Utilization Legends > Planned Node Load andMeasured Node Load

The Planned Node Load pane allows you to view the planned load on each node based

on thebandwidthofdemandsoriginating (Out), terminating (In)orpassing througheach

node (Transit).

The Measured Node Load pane allows you to view themeasured load of traffic going in

or out of the network. This option shows traffic derived frommeasurements at the

incoming and outgoing interfaces. To use this feature, you should indicate in the

specification file the location of the following files that specify the traffic going in/out of

the node from interfaces: interfaceLoad_in (ingress), interfaceLoad_out (egress). See

the File Format Reference for IP/MPLSView and Router Feature Guide for IP/MPLSView

for more details.

Figure 38: Planned Node Load

For the Planned Node Load andMeasured Node Load panes, there is a color legend that

colors the nodes according to the node load. The colors and divider locations can be

modified in this legend.

In addition, the Node Load legend draws each node as a circle. The bigger the traffic

going in/out of the node, the bigger the circle is, so you can easily see which nodes have

themost traffic to the outside world. For Measured Node Load, there is also a slider to

choose one of up to 24 periods to display.

ForMPLS-enablednetworks, youwill see adifferent viewdependinguponwhether Layer

2 or Layer 3 is selected from the topmenu bar of the main window. Selecting Layer 2

allows you to view the planned load of LSP Tunnels.

Map Subviews

Subviews > Link Status

Indicates the status of the link: Down, Passive, Other, VT, or VT Down.
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Figure 39: Link Status

Subviews >Multicast

Themulticast feature requires a license. Please contact your Juniper Networks

representative for more information on licensing for this feature.

Subviews > Type

The Type pane displays categories of devices found in the currently opened network.

These devices include routers, types of links, and any user-defined network element

groups found in the network. Different types of devices are associated with different

icons.When putting themouse over one of these icons, a tool tip will indicate howmany

items of the corresponding category are represented on themap.

Figure 40: Types Subview

Customizing Nodes and Links

The right-click popupmenu for an icon includes the following options:
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• Set This Icon: Choose an icon

• Highlight These Items: Highlight nodes of this type

The right-click popupmenu for a link supports the following options:

• Set Color: Brings up a color chooser to customize the color

• Set LineWidth: Choose a line width (the larger the number, the thicker the link width)

• Set Line Style: Choose a style (for example, dotted lines)

• Highlight These Items: Highlight links of this type

Customizing Node Type Icons

You set icons by right clicking on the node type or group and selecting Set This Icon. In

the Icon chooser, youmay select an icon and press OK to use a preexisting icon. The

description of an icon can be found by hovering the pointer over the icon.

Figure 41: Icon Chooser

Alternatively, an icon can be uploaded by selecting Upload New Icon and selecting the

image file (PNG, JPG, GIF) in the Choose Iconwindow. Once the image is selected, select

the scale and/or width and height in the Icon Sizing Tool window.

Uploaded icons can be deleted by right-clicking on the type and selecting Set This Icon

and then clicking the Delete Icon button. Upon deleting the icon, nodes of that type will

revert to the original icon used for that type.
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Additional Notes on Icon Import

• Icons uploaded in one sessionwill automatically appear in the "Icon Chooser"window

in later sessions.

• IP/MPLSView's default iconsare flat and two-dimensional, and youcan set their colors

by clicking on the buttons in the Type Legend. By contrast, it is not possible to change

the color of an imported icon.

• Maps with icons cannot be exported to Visio 2002 and earlier (*.csv export). They can

be exported to Visio 2003 and later (*.vdx export).

• When amap is exported to SVG, the *.svg file refers to the icons by their names in the

local cache directory. Before sharing the SVG files with a second user on another

machine, it is necessary to edit the *.svg file to use the icons' names on the second

user's machine.

Customizing Line Style

You canmodify the line style used to represent specific link types, such as OC3, OC12,

STM3, Gigabit Ethernet, etc. Similar to customizing node type icons, to customize link

type line styles, right clickon the link in the type legendandselectoneof themenuoptions.
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Figure 42: Link Styles

NOTE: The Export to Visio feature supports dotted line styles, as long as the
dotted line is limited to one color. Solid lines can be exported in up to two
colors ( for example, to show the utilization in both directions on a link).
However, it is notpossible toexport a link in twocolors to showtheutilization,
and have it be dotted at the same time.

Right Pane Toolbar

Locatedon the right sideof the topologywindow is themap toolbar. The toolbar provides

quick access to some functions that are also available when right-clicking on themap.
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Figure 43: The Topology Toolbar

DescriptionItem

Toggles the selection tool to selectmultiple nodesand links.WhenON, holding the leftmouse
draws a rectangular selection box. When OFF, holding the left mouse drags the map around.

Selection Tool

Shows or hides the left pane of the map window.Show/Hide Left Control Pane

Shows the nodes list in the left pane of the map window.Show Node List

To create a group, select a set of nodes and/or other groups in the topology map. Then click
this button in the toolbar and specify a name for the group. The selected nodes and groups
are combined and displayed as a group icon. Multilevel group hierarchies can be created if
several groups are organized together into a single higher-level group.

Group Selected

This function will ungroup any group(s) chosen by you. Collapse a group, select it, and click
on the Ungroup Selected Groups button. This permanently removes the group from the
system.

Ungroup Selected

This function allows you to undo up to 10 nodemovements/re-layouts.Undo Move Node(s)

This function allows you to redo up to 10 nodemovements/re-layouts.Redo Move Node(s)

Resets the nodes to their initial position on themap.Reset to default

The navigator map provides you with a scaled down version of the topology. After zooming
in to the level you prefer, a box will appear in the navigator map that you canmove to view
other areas at the same zoom level. For further details, refer to Navigator.

Navigator

Copyright © 2018, Juniper Networks, Inc.80

IP/MPLSView Java-based Graphical User Interface Reference



DescriptionItem

This function allows you to zoom in on a particular area of the topology map by drawing a
box around the target area.

Zoom In

This function allows you to zoom out of the topology map.ZoomOut

This function allows you to quickly fit the entire network topology into the topology window. The system only
fits the network elements that are visible.

Zoom to Fit

• You can create a rectangular box on themap by holding down the left mouse button at a point and
dragging the mouse to another point and then letting go of the mouse to create a box.

• After creating that rectangle, you can stretch and rotate the nodes in that rectangle. For more details
on the steps for using this tool, refer to Drag/Rotate Tool.

Drag/ Rotate Tool

• With the Paths button, you can perform path analysis in the topology window. This is the same Path function found
in the Network Elements > Nodes list and in the pop-upmenu in the topology map.

• The path analysis function displays graphically the path between any two nodes found in the network based on
factors suchas routingmethodused, reservedandactual bandwidthallocation, linkdistance, oversubscription. Paths
are displayed as a solid yellow line. Detailed information about the path is displayed in the console window.

Path

Opens the Tools > Options >Map Preferences window for you to customize themap display (for example,
background color, font size, and display of parallel links as curves).

Map Preferences

Opens the online help.Map Help

Navigator

When the Navigator button is clicked, it displays the navigational map with an outlined

box inside it showingwhichpart of themap is in the current view. By clicking anddragging

this box, you can pan across the topology map. This function is ideal for use when you

have zoomed in to one section of the topology, and would like to easily move to other

regions at the same zoom level.

Figure 44: Navigator

Drag/Rotate Tool

Thepurposeof the tool is to choose somenodesor collapsedgroupswithin a rectangular

region, and then stretch or shrink the rectangle, move, or rotate it.

To use the tool, press the Drag/Rotate button. Drag a rectangle on themap around

nodes/groups that you wish to move. Youmay hold down the <Shift> key to constrain
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the rectangle to be a square. If no nodes/groups are selected (highlighted in yellow), the

rectangle will remember all the nodes and collapsed groups inside it. Otherwise, if some

of the nodes/groups in the rectangle are selected (highlighted in yellow), then the

rectangle will remember only the selected nodes/groups in the rectangle. This is useful

if you only want to move selected nodes in a rectangle.

Whenyoustopdragging, the rectangle turnsgreen,meaningactive. Thenyoucanperform

one of the following actions:

• To stretch or shrink the region, drag one of the eight square handles.

• Tomove the region, put the mouse inside the green rectangle and drag the rectangle

to another location.

• To rotate the points inside the green rectangle, rotate the mouse wheel. If you don't

have amousewheel, hold down <Alt> and click the left mouse button to rotate in one

direction. To rotate in the other direction, hold down the <Alt> and <Shift> buttons

and left-click. If you have amiddle mouse button, click the middle mouse button to

rotate themoneway, and <Ctrl> or <Shift>-click themiddle button to rotate the other

way. (The rotation is along ellipses inside the rectangle, so if you want true circular

rotation, make sure the rectangle is a square by using shift-drag when you create it.)

There are two ways to end the drag/rotate operation: click outside the green rectangle,

or click on the Drag/Rotate button to turn it off.

Paths

This function allows you to view the path between any two nodes in the topology map.

To view detailed path information, click the Paths button in the toolbar (or from the

drop-downmenu). A cross-hair will appear. Then select a starting node and drag the

cross-hair to a destination node and click on it. The paths information will appear in the

console window giving detailed information about the paths such the route of the path

between these two nodes. The following is an example of the detailed path information

between two nodes:

Bandwidth initialized to 8000
* * * N1(XN1) - N2(XN2): bw= 8.0K * * *
new N1 N2 8.0K R,A2Z 02,02 N1--N2

(Adm_Weight) Route-cost=100. Max_Path_Bw= 40.704M

Node PopupMenus

The following options are accessible when right-clicking a node or set of nodes.

• View > Selected Nodes: Displays detailed information about the currently selected

nodes.

• View>NodesunderPointer:Displaysdetailed informationabout thenode(s)/switch(es)

at the place where you clicked. If there are multiple nodes at the place where you

clicked, then all are displayed.

• View > Demands on/thru Node: Displays all demands that originate or pass through

this node. In the resulting window.
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• View > Equipment View: Displays node, card, port information.

• View > SRLGs on Node: Displays information about the SRLGs at a node.

• View> InterfacesatNode:Displays informationabout the interfacesat anode, including

but not limited to IP address, name, bandwidth, and status.

• View> Links at Node:Displays detailed information about all links originating from this

node.

• View > Summary at Node: Displays a summary information window for this selected

node. Information such as total number and bandwidth of originating, terminating,

transit, and local demands are all displayed in this summary.

• Modify > Selected Nodes: Allowsmodification of selected nodes.

• Delete Selected Nodes: Deletes the selected nodes. Connecting links may also be

deleted in this process.

• Resize Demands > At Selected Nodes: Enter in a percentage by which to multiply the

bandwidth of the demands that originate or terminate at the node(s) you right-clicked

over. For example, enter in 200% to double the bandwidth of the demands at the

nodes right-clicked over.

• Fail SelectedNodes: Fails selected (highlighted) nodes. The failure simulationwill take

placewhen you click the Run button. This option is available only when the Interactive

Simulation window is open.

• ShowConfig File: This option will open the configuration file for the node if available.

• ShowCollected File: This will open the Run CLI Command windows which lists data

collected by the Task Manager. The categories available are: ARP, Equipment CLI,

Interface, MPLS Topology, Multicast Path, OAM, OSPF Neighbors, Switch CLI, Transit

Tunnel, and Tunnel Path. This option is available only for Live networks.

• InternetMap at Node: Brings up a third partymap from the Internet using the specified

node’s latitude and longitude coordinates.

Link PopupMenus

• View > Selected Links: Displays detailed information about the link(s) that were

highlighted when you selected this option.

• View> Links under Pointer:Displays detailed information about the link(s) at the place

where you clicked.

• View>Demandson/thru Link:Displays the demand that are going through the link. You

can view all of them, all of them in one direction, all that start or end at an endpoint of

the link, or all demands thatpass through the link thatdonot start or endatanendpoint

of the link.

• View > SRLGs on Link: View the SRLGs that this link is part of.

• View > Interfaces on Link: View the interfaces on this link.

• View > Tunnels on/thru Link: Similar to Demands on/thru Link but for tunnels.

• Delete Selected Links: Deletes selected links from the network
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• Fail SelectedLinks: Fails highlighted links. The simulationwill take placewhen you click

the Run button. This option is available only when the Interactive Simulation window

is open.

• Collapse/ExpandMultiple Links: This will collapse or expandmultiple curved links into

one drawn between two nodes. When youmouse-over a collapsedmulti-link, the

bottom information bar displays **1 of x** where ‘x’ is the number of links collapsed

Map PopupMenus

The following menu options are general options available in the map’s right-click menu.

Map Views

For each offline network, you can savemultiple map views, corresponding to different

graphical locations and groupings of network devices. Map settings such as zoom, color

legend sliders, and applied filters are also saved. For eachmap view that is saved, there

is a subdirectory which contains map-related files for that view, including graphcoord,

group, and graphcoordaux files.

• Click SaveMap and enter a Name and optional Description to save a newmap view.

Local is for offline networks. Private and Shared are for Live networks.

• Local savesmap settings to the network spec directory in subdirectory /userSettings

• Private saves map settings to your home directory in subdirectory

/wandlnetworks/livenetwork_output_directory/userSettings/livenetwork/

• Shared saves map settings to the Live network directory

/u/wandl/data/userSettings/livenetwork/

• Select a map view and click LoadMap to load a previously savedmap view.

• To overwrite an existing map view, select an entry, click SaveMap, and use the same

Name.
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Figure 45: Map Views

For the Live Network (File > Open Live Network), you can specify a default private view.

Administrators can create shared views that will appear in everyone’s map view list.

Administrators can also set one as the default shared view. To set your personal default

view, select the radio button under the Default column.

NOTE: Administrators must set one default shared view by selecting the
radio button under the Shared Default column. The Shared Default is the
viewevery userwill seewhenopening the LiveNetwork and usedby theWeb
for group reports and features. If you have selected a different Default view,
your view has higher priority than the Shared Default and it is loaded when
opening the Live Network.

Figure 46: Live Network Map Views

85Copyright © 2018, Juniper Networks, Inc.

Chapter 5: TopologyWindow



Grouping PopupMenus

The Grouping menu contains functions for creating network elements groups in the

topologymap. In thismenu, youcan findoptions for specifyinggroupswithin the topology.

These functionsareespeciallyhelpfulwhen thenetwork is largeandcontainmanydevices

and elements.

• Group Selected: The Group Selected Nodes buttonmerges a set of nodes into a single

group on the topology map. This is useful if you want to partition the network into

groups or hierarchies.

• Ungroup Selected: This function will ungroup any groups you have selected in the

topologywindow. This permanently removes the group from the system. A groupmust

be collapsed and then selected before this function can be accessed.

• Ungroup All: This function permanently ungroups all groups in the topology map.

• CollapseContainingGroup:This functionwill collapse thegroupcontaining the selected

node, displaying it as a small group symbol with its contents hidden.

• Collapse All: This function will collapse any groups, displaying them as small group

symbols with their contents hidden.

• Expand All: This function will expand any collapsed group in the topology. The groups

are displayed as circular discs and the contents are visible.

• Expand Selected: This function will expand selected groups.

• Modify Parent Group of Selected:Moves the selected node from one group to another

group of your choice.

• AutoGroup: This function will allow the program to use its node-grouping algorithm to

auto-group nodes. Nodes can be grouped by AS, area, lat/lon, access domain, tree,

LAN, hardware type, regular expression, and/or NPA/NXX, depending on what type of

network it is. (Options may vary depending upon the hardware type.) You can create

more than one grouping levels. If selecting more than one level, the first selection will

create the top-most (parent) groups. The second level will subdivide the nodes in a

group further into sub-groups, and so forth. For more details, refer to AutoGroup.

• SiblingMesh:When this option is selected, a fully-meshed set of lines is drawn among

themembers of each expanded group. Different groups get different colors.

AutoGroup

Select the nodes that you want to autogroup. Next, right-click over the nodes and select

Grouping > AutoGroup for the following first level groups. Click AutoGroup only selected

instead of all nodes. if you wish to autogroup only the selected nodes.

To create flexible grouping, the “Regexp” button can be used to group according to a

regular expression.
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• Look in the field: Indicates the field to use for the match criteria (for example, Node ID,

Node Name, IP Address)

• Find the first match for: Indicates the regular expression that should match in order to

form a group.

• (Optional) Substitute it into:Specifies a name for the newgroup(s). To create different

groups based on the pattern being matched, you can save a part of the expression

being matched for into a buffer by surrounding it in parentheses in the “Find the first

match for” textbox. Then in the “Substitute it into” textbox, the buffer number can be

accessed by preceding it with the ‘$’ symbol. Note that you can havemore than one

buffer. To create a buffer, surround the expression with a left and right parenthesis.

The first buffer in the expression is accessible using $1, the second is accessible using

$2, and so forth.

• Case-sensitive: Specifies whether the string to match is case-sensitive

AutoGroup Examples

Suppose you have routers with the following IDs: P1_ATL, P2_ATL, P3_ATL, P1_NYC,

P2_NYC,P3_NYC,P1_CHI, P2_CHI, P3_CHI. Enteringeither of thecriteria in the tablebelow

would create the following groups: ATL, NYC, and CHI , each containing 3 routers.

Substitute it intoFind the first match forLook in the field

$1.*_([A-Z]*)ID

$1.._(...)ID

If you wish to group the devices only by the first two characters of the ID, the following

criteria could be used.

Substitute it intoFind the first match forLook in the field

..ID

Note that local area networks (LANs) not matching the criteria is given a group of their

own, suchasGROUP0. Tomove these LANs into the samegroupas their attached router,

selectNetworkElements>Nodes in theStandardmap.Right-click theGROUP0containing

the LANs, and select Grouping>Ungroup this Group. Then right-click the map and select

Grouping>Move LANs to Siblings’ Groups.

Selection Options

• Select >All Points: This functionwill select all network elements on the topologymap.

• Select > Neighbors: Highlights all neighbors of the node that was right-clicked over.

• Select > Nodes on Selected Links: Highlights the two endpoints of every selected link.

• Select > Single-End Neighbors:When you right click on a node, there is an option to

select single-end neighbors. Selecting this will highlight any peripheral nodes
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(single-ended nodes, attached to only one link) that are connected to the selected

node.Theselectednodewill remainhighlighted.Typically, the selectednode is a router,

and thenodes thatare subsequently highlightedare loopbacksandsingle-endedLANs.

• Select > Tree: Available when you right-click on a node, this option will find the largest

tree in the network that contains the selected node and highlight all nodes in that tree.

A tree is defined as any group of nodes that are connected to each other in such away

that there exists only one available path between any two nodes in the group. (Note:

in selecting the tree, this option will stop once it hits a node that belongs to a cycle.)

• Cut Selection:This allows you to cut from the network all currently selected nodes and

any links that (both) originate and terminate at the selected nodes. This action is

reflected in the topology map. The cut elements are stored in the clipboard and can

be pasted back into the network (multiple times if desired) at a location specified by

you.

• Copy Selection: Clicking this when one or more nodes are selected will copy to the

clipboard the selected nodes and any links that (both) originate and terminate at the

selected nodes.

• Paste:Thiswill paste themost recently cut or copied elements onto the topologymap.

Once pasted onto themap, the elements can be dragged around with themouse and

positionedatanappropriate location.Numerical charactersareappended to thenames

of each pasted element in an ascending order to maintain an unique identity for each

element. Any XML router-config data associated with the pasted nodes are carried

over as well.

CustomURLs

Custommenu items can be added to the main map’s right-click menu that pop up a

browser going to a user-definedURL. TheURL canbe specified as a function of the node,

group, or link that is right-clicked over. To create custommenu items, create a server-side

file /u/wandl/data/custom/menuitems.txt. This file should be saved as Unicode UTF-16

format. Each line should have two comma-separated items:

menuItem,URLtoView

where menuItem is substituted with the text that you will see in the right-click popup

menu and URLtoView is the URL that the browser will request. A specific value can be

inserted into the URL depending upon the node, link, or group that is right-clicked over.

To specify a node’s field, use the syntax ${Node.key}, substituting key with the attribute

of interest, which can be found through the node’s Advanced Filter. For example, putting

${Node.ID} in a URLtoViewwill insert the ID field of the node right-clicked over into the

URL. Similarly, use the syntax ${Link.key} and ${Group.key} to indicate a link or group

attribute, where key is one of the available attributes available through Advanced Filter

for links or groups, respectively. The following is an example file:

Explain Node Type,http://en.wikipedia.com/wiki/${Node.Type}
Search Link Name,http://www.google.com/search?q=${Link.Name}
JUNIPER,https://www.juniper.net
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Labels Menu

When selecting one of the menu options below, you are prompted to choose what to

label and with what text.

• Node Labels: Allows you to turn on or off labels for nodes displayed in the topology

map.

• Group Labels: Allows you to turn on or off labels for groups displayed in the topology

map.

• Link Labels: Allows you to turn on or off labels for links displayed in the topology map.

What to Label

ExplanationOption

Displays the label for all elements in the given categoryAll

Removes the label for all elements in the given categoryNone

Displays the label only for selected elements in the given category, removes labels for
nonselected elements

Only Current Selection

Adds label(s) for selected elements in the given category, preserves pre-existing labels
of nonselected elements

Add Current Selection

Removes label(s) for selected elements in the given category, preserves pre-existing
labels of nonselected elements

Remove Current Selection

Label Text

A list of typical attributes that are used to label the item are given in the right-hand side

of the table. For the node and link labels, you also have the option to customize the label

in such a way that it includes other properties or more than one property. This option is

availablebyselectingCustomize...under theWhatText?sectionand results inCustomizing

Labels.

By selecting BottomBar, you can also customize the map window bottom bar display

this is shown when you hover the mouse over a map element such as a node or link.

DescriptionBottom Bar

Allows you to customize the label shown in the bottom bar when the pointer is
over a node

Nodes: Customize...

Resets the node information given in the bottom bar to the default values.Nodes: Reset to Defaults

Allows you to customize the label shown in the bottom bar when the pointer is
over a link

Links: Customize...
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Resets the link information given in the bottom bar to the default values.Links: Reset to Defaults

Customizing Labels

Figure 47: Set Labels... Window

DescriptionOptions

Addmoves selected key from left hand side to the right hand side listAdd/Remove

Moves a selected field up and down to change the field orderUp/Down arrows

In the list of Output Formats, the Key is taken from the titles listed in the top panel, and the Value
is the specific value for any particular Key.

• For example, if you select for link label text the following keys: Name, Used_BW_AZ, and
Used_BW_ZA and the following output format: Key=value; Key=value; ..., you could get the
following results:

• Name=Link2; Used_BW_AZ=84M; Used_BW_ZA=40M

• Note that for the link labels, you can select not only link properties to display but also properties
of the source and destination nodes by double-clicking on NodeA or NodeZ.

Output Format

Show/HideMessage

Toggles on or off anymessages or text that are displayed in the topologymap.Messages

that are displayed in the map usually include total link cost.
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International Map Labels

Each node, link, and group on themap can have one label in any language, defined in a

single server-side file /u/wandl/data/custom/intllabel.txt, which must be saved in

Unicode UTF-16 format. Each line of the file should have three items separated by

commas:

LetterCode,ElementID,intlLabel

• LetterCode is either N (for node), G (for group), or L (for link)

• ElementID is either the nodeID field from themuxloc file (first column), link name from

the bblink file, or group name from the group file.

• intlLabel is the foreign text in Unicode.

Once this file is created, and the network is reopened, this label can then be displayed

on themap by opening the Labels Menu , selecting Customize..., and then selecting the

IntlLabel key. This label can also be displayed in the Network window node and link view

panes by right-clicking the table header, selecting Table Options... and then adding the

IntlLabel column. Finally, the IntlLabel attribute can also be used for advanced filters for

nodes and links.

Layout

This function allows you to layout the display of network elements in the topology map.

• Circle Selected Nodes:When selected, the cursor becomes a crosshair. You should

click once on themap to pick the center of a circle, and click a second time to choose

the radiusof thecircle. All thepoints that are currently selected (highlighted)aremoved

onto the circumference of the circle at equally spaced intervals.

• Distribute Selected Points:When selected, the cursor becomes a crosshair. You should

click once on themap to pick the center of a circle, and click a second time to choose

the radius of the circle. All the points that are currently selected (highlighted) are laid

out on themap in a way that's easier to see. They are fitted inside the circle that you

chose. If any of the points are collapsed groups, the groups are expanded, will have

their contents distributed, and are collapsed again, and so on recursively.

• Distribute Selected PointsWithin Groups: This option is available in the Layout menu

onlyafter selectingcollapsedgroups. For eachselectedgroup, thepointsaredistributed

for that group, and if multiple groups are selected, they are distributed in a way such

that there is little overlap between the groups when they are expanded.

• StraightenSelectedNodes:This feature is likeCircleNodes, butputs theselectedpoints

onto a horizontal line, equally spaced. (Rotate it with the Drag/Rotate tool to align the

selected points vertically instead of horizontally.)

• Flip: This feature flips the entire layout vertically or horizontally depending on your

selection.

• Stiffen:When there are multiple links between two nodes but some of the links are

hidden from view, the parallel links may be spread apart too wide or unevenly or all to

one side. In this case, selecting Stiffen Visible Curves will bring the parallel links closer
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together and center them. Select Unstiffen All to undo this stiffening. Option is only

relevant when DrawMultiple Links as Curves is turned on in the Map Preferences.

• Reset by Lat/Lon: Selecting this option will reset the network topology to its original

geographical layout (provided that the LAT/LON coordinates are used in the network).

This function is useful when you want to view the network in its geographical layout

according to previously specified Lat/Lon values.

• Set Lat/Lon FromMap: Selecting this option will assign Lat/Lon values to all selected

nodes based on their current location on the Map. This function is useful if you have

manually moved nodes on themap to desired locations and wishes to save these

locations for future sessions.

• Quick Layout: Recomputes the X, Y coordinates of all the points using the program's

algorithms to try to lay them out clearly. This is the same algorithm used when a

Topology View is opened and no saved coordinates are available. If latitude/longitude

coordinates are available, they are used to position the nodes, and nodes with the

same Lat/Lon are laid out at the city’s location in a small radius around the city center.

The full recalculation could take a long time for large networks.

• Detail Layout: This topology layout algorithm attempts to distribute the nodes and

links as a planar graph.Meaning the topology is drawn in such away that links intersect

only at nodes, or no links cross each other. This layout is useful to create a topology to

display aminimal amount of links crossing over each other while keeping node groups

together. Various parameters relating to the geographical Lat/Lon position, distance

proximity to other nodes, link length, and groups can have their cost weights adjusted.

Adjusting these weights will impact the algorithm’s topology display.

• Grid Layout: This topology layout algorithm lays out nodes on a grid. The “Intersect

Weight” field can be used to reduce line crossing-- the higher the value, the lower the

number of line crossings. If you would like to rerun the calculation from the previous

iteration’s layout, select the Continue from previous layout if possible checkbox. For

Layout, Geographical Group places the groups at the mean lat/long position of the

nodes within the group and rearranges the nodes within in a radius determined by the

distance to the nearest neighbor. Abstract Group treats the network hierarchically and

lays the groups out in a grid as "nodes" - then lays the nodes within the groups out

within a radius determined by the distance to the nearest neighbor. "Abstract” will

calculate the layout ignoring any group information. “GeographicGroup” and “Abstract

Group”will consider group information. SearchBreadth:With a narrowsearchbreadth,

changes that make the solution worse are more likely to be rejected. At the end of the

iterations, only changes that make the answer better are accepted. However, at the

beginning, you can go backwards -- the probabilities of accepting an answer change

as the iteration progresses. For the Iterations, specify the number of iterations to run

for the optimization problem, for example, 500.

Internet Map at Click

This option brings up a third party Internetmap at the particular latitude/longitude point

that you right-clicked on themap before selecting this option.
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LineWidths

• Auto-assignWidths: Assigns widths based on trunk type. For example, a T3 is wider

than a T1 and an ET1G is wider than an ET100M.

• ResetWidths to Default: Restores widths to the default where all link widths are the

same.

Alternatively, tomanually set thewidths, right-click on the link and selectSetLineWidth...

from the Legendsmenu, Type submenu of the map window’s left pane.

Background Image

This allows you to choose a background image from your local or server machine to

display on the Map window.

Country Maps

Figure 48: The Country MapsMenu

When you select this option, a dialog box will appear. This option allows you to select

the level of map detail to display on the background of the topology window, where the

settings are remembered from session to session. For example, using this option, you

can select a combination of Continents, Countries, and U.S. states to be displayed.

Find

This function searches for any node, link, or group and highlights the element on the

topology.
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Figure 49: Find Box

Refresh

When selected, this function removes certain temporary interface labels and addresses,

clears all highlighted network elements, and deselects all selected network elements.

Zoom

The Zoommenu contains functions for focusing in on a particular area of the topology

map.

• Zoom In: This function allows you to zoom in on a particular area of the topologymap.

To zoom in on the topology, click the Zoom In button and then click and drag a desired

area in the topologymap.Anothermethod to select the zoom inarea is to<Shift>-drag

the rectangle. It will always match the aspect ratio of the map.

• ZoomOut: This function allows you to zoom out from a particular area of the topology

map.

• ZoomTo Fit: This function allows you to quickly fit the entire network topology in the

topologywindow. Items hidden by theSubviewor Label/Showpanes are not included.

• ZoomTo Fit Selection: This makes the map zoom to fit the items that are selected.

• Zoom to Region: Allows you to zoom to a specific geographic region in the topology.

The regionswhich youcan zoomto include the following:World,UnitedStates, Europe,

Asia, and China.

Print

When this function is selected, the programwill allow you to print the current on-screen

topology. You will first be asked which part to print (the entire topology window (Whole

window) or just the topology map (Map only)). Next, you are given printer options.

Export

This functionallowsyou to save the topologywindowasagraphics file in several formats.
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Figure 50: Export Map

For non-Visio file types, selecting the Legends option will export the entire topology

window and deselecting it will export only the map.

For Visio file types (VDX, CSV), the customizable Title and Comment fields, as well as

the Legends and Date and Time can be included in the resulting Visio file.

Export Map to Visio

In the Export dialog, the last three options can be used to export to a file that can be

imported into Visio and then edited or printed from Visio.

• For Visio 2003, it is recommended that you export to a VDX file by selectingVisio 2003

and Later (VDX).

• For Visio 2002 and earlier, it is recommended that you export to a .CSV file by selecting

Visio 2002andEarlier (CSV). After importing the .CSV file into Visio 2002, you can save

the resulting Visio file as a Visio drawing (.VSD) file. Note that opening the .CSV format

in Visio requires extra steps to put the IP/MPLSView stencils where Visio can find it.

• The “Block Diagram for Visio 2003 and later” option is designed to be run after running

Layout > Recalculate Grid Layout as described in “Layout” on page 91.

Please consult the Training Guide for IP/MPLSView for further details and guidelines on

how to use Visio.

Export Map toMapInfo

MapInfo requires two files,myMap.mifwith thexy-coordinates, colors, andother graphical

info, andmyMap.mid with data per node or link for display in mouse-overs, tables, and

reports.
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After selecting a filename and this export option, you are prompted with a chooser to

select a combination of node and link data to put into the mid file. After selecting the

data to put into the mid file, click OK to create the .mif and .mid files for import into

MapInfo.

Export Map to SVG

SVG can be exported from themap right-click menu item Export, or from File > Export

toWeb. Note that the exported SVG file depends upon existing settings in the topology

map. These settings includewhether theworldmap should be displayed, the boundaries

of the world map, and whether node and link labels should be displayed.

When exporting to SVG, the resulting file can be viewed from aweb browser such as

Mozilla FirefoxTM. If you are using Internet ExplorerTM, version 9 or later should be used.

Alternatively, a plug-in can be downloaded for SVG from

http://www.adobe.com/svg/viewer/install/main.html.

Scheduling or Scripting an SVG Export

A CLI version of the SVG export, also used by theWeb Report task in the Task Manager,

can be found in /u/wandl/util/svg.sh. Since this SVGmapmay be generated when the

network is closed, a configuration file is needed to specify SVG-related parameters. The

syntax for calling this script is as follows:

/u/wandl/util/svg.sh <spec_file> <output_svg_file>

To customize the settings of this SVG export, edit the /u/wandl/util/svg/svg.cfg file.

Variables include:

• CANVASWIDTH, CANVASHEIGHT:Width and height of the map

• TITLE: The title of the map

• SHOWSPEC, SHOWDATE, SHOWLEGEND:Whether to show or hide the specification

file path, creation date/time, and node & link legend

• REMOVEASNODES,REMOVEETHERNETNODES,REMOVEISOLATEDNODES:Whether

or not to hide AS pseudonodes, Ethernet pseudonodes, and/or isolated nodes. This

can be used to reduce clutter on the map.

• CURVEDLINKS:Whether or not to show links as curved or overlapping on a straight

line

• COLLAPSEGROUP:Whether or not to collapse groups into a single node

• NODELABEL: How to label the node (for example, by NAME and/or IP)

• LINKLABEL: How to label the link (for example, by NAME and/or TYPE).

• INTFLABEL: How to label the interface (for example, by NAME and/or by UTIL).

• UTILPERIOD:Which trafficload period to use to label the interface utilization

• TITLEFONTSIZE, LEGENDFONTSIZE, NODEFONTSIZE, LINKFONTSIZE, INTFFONTSIZE:

Font sizes
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• TITLEFONTCOLOR,LEGENDFONTCOLOR,NODEFONTCOLOR,LINKFONTCOLOR,IN

TFFONTCOLOR: Font colors

• COLORLINKBY: Links can be colored by type or utilization

• UTILCOLOR = <NUMBER> = <COLOR>: Tomodel the map utilization legend, specify

in ascending order the utilization percentages and associated color between that

number and the next number.

Upon scheduling theWeb Report task, the resulting map(s) can then be viewed from

http://serverip:8091/ (substitute serverip with your application server’s IPaddress). Select

Reports >Network Reports. Then click on the link to the desired network, and click on

“Standard Topology.” Icons are available for zoom in, zoom out, and zoom to fit (reset).

Once zooming in, the map can be panned by clicking the map and dragging it in the

desired direction. Additionally, link and node details can be seen by hovering the mouse

over the link or node.
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CHAPTER 6

File Menu

This chapter explains the uses and functions of the File menu.

• File Menu Functions on page 99

• File > Open Network Browser on page 100

• File > Load Network Files on page 102

• Saving a File on page 103

File Menu Functions

Table 20 on page 99 lists the file menu functions.

Table 20: File Menu Functions

DescriptionFunction

• The submenu Create Network > From Collected Data allows you to create a new network based
on data such as router configuration and interface files. For more information, refer to the Router
Feature Guide for IP/MPLSView.

• The submenu Create Network > Paper Model allows you to create a new network model and
specify the IP/MPLSView files that define the network, such as the muxloc (node), bblink
(backbone links), and demand files.

Create Network

Opens the Network Browser windowwhere you can load previously saved networks, and organize
networks by labels and comments. For more information, refer to “File > Open Network Browser”
on page 100.

Open Network Browser

Opens the File Manager where you can browse through directories and files to create and/or load
a network specification file, view files, or perform basic file operations such as cut, copy, paste, and
delete. See also Chapter 4, “File Manager” on page 33.

Open File Manager

(IP/MPLSView only). When a network model is not open, selecting this option will bring you to the
onlinemodel. See the IP/MPLSView Java-BasedManagement andMonitoringGuide formoredetails.

Open Live Network*

(IP/MPLSView only). When a network model is not open, selecting this option will bring you to the
provisioning model.

Open Provisioning
Network*

Opens the Import NetworkWizard, allowing you to import data files that are converted into the
IP/MPLSView network model. Here, you can specify the import input and output directories and
select other options for parsing a set of data files. See also Chapter 7,
“Network Data Import Wizard” on page 105 or the Router Feature Guide for IP/MPLSView.

Import NetworkWizard
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Table 20: File Menu Functions (continued)

DescriptionFunction

Opens the Load Network Files window fromwhich you can read in, or load, various network files
into the network. See “File > Load Network Files” on page 102.

Load Network Files

Closes the current network that is loaded. After closing the current session, you can open another
network model or exit the program.

CloseClose

Saves all files for the current network.Save

Saves all files for the current network into a different directory or as a different runcode. The Save
As option also allows you to add Comments or Labels to help describe and categorize the network.

Save As...

The Save Network option allows you to save the current network. The Save Network File option
allows you to save one network file without saving the entire network. See File > Save Network File
in “Saving a File” on page 103.

Save Network File

Automatically savesall theNetworkReports in theReportManager for viewingvia theweb interface
(File > LaunchWeb). The reports can be savedmultiple times for the same network to compare
the network at different times.

Export toWeb

Accessed via File > LaunchWeb, this menu item opens up the IP/MPLSViewWeb interface in your
browser, allowing convenient view-only browser access to network information and reports. Via
the web interface, you can: View network reports and topology maps, access shared documents
and files, launch the IP/MPLSView client, perform administrative tasks, such as manage users,
system usage, etc., View “live”, or “online” network data, diagnostics, collection files, etc.
(IP/MPLSView only).

LaunchWeb

Locks the application screen until the user password is entered.Lock

The File menu provides shortcuts for the most recently opened specs. Youmay also use the
mnemonic keys (1-5) to access these specification files.

Recent Specs Shortcuts

This option will close the current network and exit the program. Be sure to save the network
environment to avoid losing changes when exiting.

Exit

File > Open Network Browser

Each time a network project is saved, it is recorded in theNetwork Browserwindow. Each

network project is uniquely identified in the Network Browser by its Path and Runcode.

The Network Browser also provides additional details for each network project such as

the user, the last modified date/time, descriptive comments about the network, and

user-defined labels.

Filter the projects by user-defined labels by selecting a label from the Labels list on the

left hand pane, or by typing in a custom string in the Filter text box and pressing <Enter>

or<Return>.A label is a user-createddescriptive tagwhich canbeapplied tooneormore

networks. For example, the label OSPF was created in the example below to tag all

networks which have the OSPF protocol.
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Figure 51: Network Browser

Action Buttons

• Open: To open a network project from the list, double-click an entry from the table.

• Modify: Tomodify the labels of a network project, double-click an entry in the Labels

column from the table. Labels can be tagged to the network and comments added.

Check off the labels you would like to be associated with your network. If the label

does not exist, click Create and enter in a new label. Thenmake sure to check off the

new label and click Apply.

Figure 52: Add Comments and Labels

• Delete:Todeleteanetworkproject, right-click anentry fromthe table and selectDelete.

This will tag the network with the “Recycle Bin” label.

• Restore: To restore a network project from the “Recycle Bin” before it is permanently

deleted, click the “Recycle Bin” label, right-click an entry from the table and select

Restore.

• Permanent Delete: To delete a network project permanently, click the “Recycle Bin”

label, right-click an entry from the table and select Delete. This will delete the network
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project files from the hard disk. A backup copy of the network is zipped and placed in

the “trashbin” folder of the network owner.

File > Load Network Files

The Load Network Files window allows you to read in, or load, individual files into the

current network project.

Figure 53: Loading FilesWindow

Locating a File Type

To locate the file type to load, either search by one of the categories above by clicking

the Arrange by Category button, or search by alphabetical order by clicking the Sort

Alphabetically button. By default, only the modifiable file types are displayed. To show

all file types, select the Filter not modifiable button.

Loading a File

To read in a new file, type in the file location or click Browse to choose a file location from

the File Chooser window. Then click the Load button to load the file into the current

network.
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Note that if a file type is not modifiable, the text “[Not Modifiable]” is displayed in red

and you will not be able to modify the file path. To edit these fields, close the current

network, right click in the File Manager, and select Spec File >Modify Spec or Edit. For

more information about creating and editing the specification file, see the Training Guide

for IP/MPLSView.

Removing a File

To unload a file, select Remove.

Saving a File

The File > Save As option saves the network project and all associated reports and files

with it. The files include: spec, bblink, muxloc, and dparam files.

This option opens the following dialog window.

Figure 54: Save Network Dialog

To save the network, select the directory in which to save the network and type in the

runcode (file nameextension) thatwill identify the network. Optionally addadescriptive

comment and/or labels to organize the networks, as described in “File > Open Network

Browser” onpage 100.Thenclick theOKbutton. Thenetwork is saved toasetof fileswith

this runcode, which are organized together by a specification file of the same runcode.

Directory Selection

To select a directory, click Browse... Then type in the directory in the Look In field and

press the <Enter> or <Return> key. The contents of that directory will then be shown in

list format. The up arrow can be used to navigate to the parent directory and

double-clicking a directory from the list will open a directory. The following directory

shortcuts are also available from the Look In drop-down list:

• Spec Dir: The directory containing the last opened specification file.

• Output Dir: The directory where output files (such as trace files or reports) are saved

and stored. This directory can only be changed before a network spec is launched.

Once a network spec is opened, the Output Path remains fixed for the remainder of

the session. Bydefault, theoutputdirectory/path is set equivalent to the specdirectory.

Certain output files are generated and given the runcode extension defined by you in

the specification file.
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• HomeDir: Your Unix administrative home directory

• Current Path: The current path in the File Manager

File > Save Network File

This option allows you to save only certain files separately without having to save all the

network files. These files can later be read into a network project via File > Load Network

Files. Note that unlike the Save option, saving a single file to a new location will not

automatically update the specification file to reflect the new location of the input file.

The available files that can be individually saved include the demand file, the bblink

(links) file, the graphcoord (topology coordinates) file, the graphcoordaux (topology

window settings) file, and the group (logical grouping for the topology map) file. If you

havemoved the network elements around on themap and would like to save their new

positions, be sure to save the graphcoord file.
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CHAPTER 7

Network Data Import Wizard

TheNetwork Data ImportWizard is accessed from themainmenu File > Import Network

Wizard. This feature allows you to import different types of network configuration data

into the software. In the process, a corresponding network project specification file is

created, saved into the user-specified output directory and automatically loaded into

the program.

After importing network configuration data into your networkmodel, youmay also want

to import any existing traffic data via the Traffic > Import Traffic menu.

NOTE: A license is requiredwhen importingdata for specific hardware types.
Please contact your Juniper Networks representative for more information.
Not all data file types listed are documented in this guide.

The Data Import feature supports the following types of data files:

• Import NetworkWizard Introduction on page 105

• Routers and Switches (IP/MPLS only) on page 108

• IP/MPLSView Config File on page 108

• OSPF Database on page 108

• ISIS Database on page 109

• Marconi CLI on page 109

• Nortel PND on page 110

• Nortel Virtual Router on page 111

• Tunnel Path Extraction on page 111

Import NetworkWizard Introduction

Figure 55 on page 106 shows the initial Import NetworkWizard window.
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Figure 55: Import NetworkWizard

The following buttons apply to most pages of the import wizard.

Table 21: Import NetworkWizard Functions

DescriptionFunction

Goes back to the previous page of the wizard.< Back

Goes to the next page of the wizard.Next >

Cancels the import action and closes the wizard without saving.Cancel

Accesses the reference page of this window in the help document.Help

Select the type of the data you want to import and the directory where the data files are

stored.
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Figure 56: Import NetworkWizard Specifying Import Directory and Type

Table 22: Import NetworkWizard Import Types and Directories

DescriptionFunction

Click to see the drop-down selection box to select the appropriate data type for import
and conversion.

Import Type

This allows user to load an import template to automaticallymap fields and settings based
on previous import runs.

Use Saved Settings

The directory shown here displays the current import directory source. This field should
specify the directory inwhich data files are stored. For certain import types, this field is used
to indicate an import file instead of a directory.

Default Input Directory

Select where the IP/MPLSView specification file are createdOutput Directory

Specify a file name extension for the specification file and related project filesRuncode

Depending on which data type is being imported, the next pages of the wizard will guide

you through a different set of tabs and required parameters to be entered.
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Routers and Switches (IP/MPLS only)

This section only provides a high-level summary of the router config import. See the

Router Feature Guide for IP/MPLSView for details on importing router configuration files.

Default Tab—This tab provides additional import options to the standard Configuration
files. You can import Interface, VLAN Discovery, Switch CLI, Tunnel Path, Transit

Tunnel, Equipment CLI, and Equipment SNMP files.

BandwidthOptions—This tabprovides options for deriving the interfacebandwidth. You
can specify supplementary sources such as the MPLS Topology file or rules to use

to derive the bandwidth.

Network Options—This tab allows you to specify an already-defined network file that
should be preserved during the import. Additionally, you can specify VPN and BGP

options.

Misc Options—Miscellaneous options are provided here, such as ignoring the private IP
address.

IP/MPLSView Config File

Youmay create and import your own user-defined configuration file using IP/MPLSView

Config file format. Using any text editor, save your file extension as .cfg and follow the

syntax example below:

## WANDL CONFIG
HOSTNAME=ROUTER01
HWTYPE=JUNIPER
IP=1.2.3.4
INTERFACE=ge-1/0/0.1 IP=1.2.3.4/30 BW=1G

The keyword ##WANDL CONFIGmust be in the file to identify it as a IP/MPLSView

configuration file. Select ImportType>RoutersandSwitches to import theseconfiguration

files.

OSPF Database

The OSPF Database import supports Cisco, Juniper Networks, and Alcatel-Lucent and

accepts a file with output from the following commands. In case more than one

commands are mandatory, combine the outputs in the same file.

Cisco IOS

• show ip ospf database router (mandatory)

• show ip ospf database network (mandatory)

• show ip ospf database opaque-area (optional for RSVP TE information)

• show ip ospf database summary (optional to create virtual link between ABR and node

in another area -- Only available in text mode using -igpsummary)
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Cisco IOS-XR

• show ospf database router (mandatory)

• show ospf database network (mandatory)

• show ospf database opaque-area (optional for RSVP TE information)

• show ospf database summary (optional to create virtual link between ABR and node

in another area -- Only available in text mode using -igpsummary)

Juniper Networks Junos OS

• show ospf database extensive (includes both ospf and TE)

Alcatel-Lucent

• show router ospf database detail (mandatory)

• show router ospf opaque-database detail (optional for RSVP TE information)

Options

• DNS Lookup or /etc/hosts Lookup: Use the text mode -igpdns flag

• Import Multiple Files: Use the text mode -ospfdir flag instead of -ospf

• Only Import Links of Specified Area: -igparea <a.b.c.d> : If specified, only bblink with

the specified area are reported, and the igpsummary are disabled.</a.b.c.d>

ISIS Database

ISISDatabase import supports Cisco and Juniper Networks and accepts fileswith output

from the following commands:

Cisco IOS and IOS-XR

• show isis database verbose

Juniper Networks Junos OS

• show isis database extensive

Options

• DNS Lookup or /etc/hosts Lookup: Use the text mode -igpdns flag

• Import Multiple Files: Use the text mode -isisdir flag instead of -isis

Marconi CLI

NOTE: This feature requires a license. Please contact your Juniper Networks
representative for more details on this feature.
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The Default Tab provides the following:

• Select Output Directory: Select where the IP/MPLSView specification file is created

• Specify Runcode: Specify a file name extension for the specification file and related

project files

• Specify Old Runcode: Specify the runcode of the original specification file, if any

The Advanced Tab provides the following:

Table 23: Marconi CLI Advanced Tab

DescriptionOption

This option allows you to select a link file to include in the import to complete the topology.
These links are typically WAN links connecting through an external carrier's ATM backbone.

Select External Link File

If selected, the importwill generatepseudonodes for all unknown linkdestinationaddresses.Generate psuedo nodes

The import programwill attempt an ad-hoc virtual pathmatching algorithm to generate link
anddemandconnectivity. This shouldonlybeused in caseswhereeitherPNNI info ismissing,
signaling has been turned off on the ports, or encryptors exist between links.

Match paths

This is another option that should only be usedwhen there are encryptors between links that
short-circuit the topology.

Suppress logical links

Nortel PND

NOTE: This feature requires a license. Please contact your Juniper Networks
representative for more details on this feature.

The Default Tab provides the following:

• Select Output Directory: Select where the IP/MPLSView specification file is created

• Specify Runcode: Specify a file name extension for the specification file and related

project files

• Specify Old Runcode: Specify the runcode of the original specification file, if any
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The Advanced Tab provides the following:

• Select EPIC SPVCData File: The PND extracted data does not include SPVC info. This

info, along with UNI addresses should be queried and logged via EPIC. This options

allows you to specify the file that contains the additional EPIC data.

Nortel Virtual Router

NOTE: This feature requires a license. Please contact your Juniper Networks
representative for more details on this feature.

The Nortel Virtual Router import type has the same option tabs as Router Configuration,

but it is tailored for importing Nortel passport configuration files to extract virtual router

information. As with Router Configuration import, the Nortel VR import uses getipconf

on the backend, so it can acceptmulti-vendor router configs. Refer to the Router Feature

Guide for IP/MPLSView for more details.

Tunnel Path Extraction

The tunnel path extraction feature shows the exact network viewof tunnel paths. It helps

to simulate the impact of tunnel set up on IGP routing by taking into account Explicit

Tunnel Routing, Affinity and Trunk attributes. This is useful if the LSPs can be dynamic

(as opposed to explicit). IP/MPLSViewdisplays the current status and routing of the LSP

tunnels within the defined network.

NOTE: Thetunnelpath feature requiresa license.Pleasecontactyour Juniper
Networks representative for more details on this feature.

The MPLS Tunnel Extraction feature retrieves the actual placement of the tunnel and

the status (up or down) of the LSP paths by parsing the output of the following Juniper

Networks Junos OS command:

show mpls lsp statistics extensive

The same is true for the following Cisco IOS command:

show mpls traffic-eng tunnels

To use this feature, youmust have a network open and then specify a directory that

contains the output of these commands. There should be one file per router. On the

second page of the Import Wizard, select Tunnel Path in the Import Type selection box.

Then click on the Browse button above to open the Import Directory Chooser window.

Navigate to the directory that contains the files andpressSelect. Click.Next> to continue.
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This should generate an IP/MPLSView format file of the tunnel paths and status called

tunnelpath.runcode, where runcode is the file extension used for your network model.

This will automatically be loaded into the network model.
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CHAPTER 8

Network Menu

The Network menu from themain menu bar provides access to network information for

all types of network elements. Themost basic of these are nodes, links, and demands.

Other types of network information are available depending on the hardware type of

your network as well as on which features you have licensed.

You can also access network information by right-clicking the mouse over a network

object in the Map window. For example, to view node information, right-click themouse

over a node and selectView>Node in the pop-upmenu to display the properties for that

node.

• Network Menu Options on page 114

• Network Menu Summary on page 115

• Network Menu Maps on page 122

• Network Menu Nodes on page 122

• Configuring NetworkWindow Links on page 128

• Interfaces on page 134

• Demands on page 136

• Tunnels on page 153

• Sites on page 158

• SRLG on page 159

• Owners on page 160

• Templates on page 161

• OSPF Areas/Domains on page 163

• QoSManager on page 163

• Service Type on page 164

• AdminWeight on page 165

• Custom Rates on page 166

• Custom Rates Class on page 169

• Path and Capacity on page 169

• Show Site Demands on page 172
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• Aggregate Demands/Tunnels on page 172

• OAM on page 173

NetworkMenu Options

Note that some of the following features are hardware or module-dependent andmay

require a license. For more information on any of these features, please contact Juniper

Networks support.

Table 24: Network Menu Feature Options

ReferenceFeature

See “Network Menu Summary Overview” on page 115Summary

See“Network Menu Maps” on page 122Maps

See “Network Menu Nodes” on page 122Nodes

See “NetworkWindow Links” on page 128Links

See “Interfaces” on page 134Interfaces

See “DemandsWindow Properties Tab” on page 137Demands

See TunnelsTunnels

See “Sites” on page 158Sites

See “SRLG” on page 159SRLGs

See “Owners” on page 160Owners

See “Templates” on page 161Element Templates

See “Add Single Demand” on page 139.User Parameters

See Virtual Private Networks in the Router Feature Guide for IP/MPLSView.VPN

See Virtual Local Area Networks in the Router Feature Guide for IP/MPLSView.VLAN

SeeVirtual LocalAreaNetworks chapter in theRouter FeatureGuide for IP/MPLSView.Access Domains

See Border Gateway Protocol in the Router Feature Guide for IP/MPLSView.BGP

SeeMulticast in the Router Feature Guide for IP/MPLSView.Multicast

See “OSPF Areas/Domains” on page 163.OSPF Areas

See Routing Instances in the Router Feature Guide for IP/MPLSView.OSPF/ISIS Routing Instance
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Table 24: Network Menu Feature Options (continued)

ReferenceFeature

See Static Routes in the Router Feature Guide for IP/MPLSView.Static Route Table

See “OAM” on page 173OAM

See “QoSManager” on page 163QoSManager

See “AdminWeight” on page 165AdminWeight

See “Custom Rates” on page 166 and “Custom Rates Class” on page 169Custom Rates

See “Service Type” on page 164Service Type

See “Path and Capacity” on page 169Path & Capacity

NetworkMenu Summary

This section describes the following:

• Network Menu Summary Overview on page 115

• Filter on page 116

• Search by Property on page 117

• Advanced Search on page 118

• Navigation Page Setup on page 119

• Table Options on page 120

NetworkMenu Summary Overview

To obtain general information about the network under review, select Summary from

theNetworkmenu.TheNetworkSummarywindowwill appeardisplaying statisticsabout

the various network elements in the network, including nodes, links, and demands. The

demand statistics indicate the average andmaximumhops of demands and the number

of placed, unplaced, anddeactivateddemands. Placeddemandsaredemands thatwere

routed over the network. Unplaced demandswere demands that failed to route over the

network. Deactivated demands are demands that are not routed over the network, for

example, demands from a node to itself.
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Figure 57: Network SummaryWindow (Options May Vary)

In some windows such as the Nodes window, you can find a text field labeled Filter and

icons labeled Search by Property, Advanced Search, and Filter fromMap. These allow

you to search for and display a subset of the network elements that match your filter or

search criteria. This section uses the Nodes window as an example.

NOTE: The search functionality for the Filter and Advanced Search is not
case-sensitive. For example, ID = abc alsomatches ABC. The filter searches

all entries within the current table.

Filter

In the Nodes window, type the text you wish to perform a search on in the Filter box. To

reset the list of elements, clear the text field.

Figure 58: Filter Text Box
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Search by Property

In the Nodes window, click Search by Property to open the Find Nodes window. From the

Properties tab, specify the Search preference you wish to use. These are explained in

following the table.

Table 25: Network Information Search Filters

DescriptionFilter

Allows you to match exactly the string entered.Exact match

Allows you to match to a subset of the strings entered.Exact match as substring

Allows the use of wildcards in the search string.

• When the “*” character is used in the search string, the programwillmatch any of the
text with the “*” character.

• The “?” character will match only to one character.

Wildcards * and ?

Allows special characters and other expressions to be entered as search strings. This is
the same with regular expressions in Unix.

Regular Expression Syntax

Then specify the criteria to bematched in any of the text fields or drop downmenus

within any of the tabs in the window. ClickOK to apply the search filter

Figure 59: Find NodesWindow
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Advanced Search

The Advanced Search offers more filtering options. In the Advanced Filter window, a

basic query statement consists of a keyword, followed by a relation, and then a value

(for example, “Hardware=ETHERNET”). More complicated queries can be formed by

joining statements using the and, or, and not conjunctions. Left and right parentheses

can be used to override the order of precedence (the “and” operator takes precedence

over the “or” operator).

Figure 60: Advanced Filters for Nodes

You can type your query directly in the Enter a query text box. Or use the lists for Keys,

Relations, Current Values, and And/Or. To insert text into the query text box from one of

the lists, select the desired item from the list, and then click Insert. The Current Values

list will automatically populate with valid values for the selected Key. You can choose a

value from the Current Values list, or simply type in your own. Once you have specified

your query in the Enter a query text box, clickOK to apply the search filter.

Table 26: Advanced Search Preference Options

DescriptionOption

The query matches a value if the two strings match exactlyExact Match

(Default) The query matches if it is a substring of the value. For instance, "id = S"
matches BOSTON as well as SEATTLE.

Match Substring

When the "*" character is used in the query, it matches any text. The "?" character
matches any one character.

Wildcards * and ?

Allows regular expressions in the query. This is like regular expressions in Unix.Regular Expressions
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Here is an advanced filter node example. To find all devices that have an ID beginning

withN1 but notN11, togetherwith Ethernet and token ring, all east of theMississippi River

in the U.S., selectWildcards * and ? for the search preference and type:

(ID = N1* and not ID = N11* or type=ethernet or type=tokenring) and lon > -90 and lon <

-60 and Country = US

Here is an advanced filter link example. To find all OC3 links that either belong to area

AREA0 or have an endpoint whose IP address begins with 205.101 but not 205.101.1.1,

selectWildcards * and ? for the search preference and type:

Trunk = OC3 and ( Area = AREA0 or IP_A = 205.101* or IP_Z = 205.101* and not ( IP_A =

205.101.1.1 or IP_Z = 205.101.1.1 ) )

To save a query as favorite, select Favorites > Add to Favorite and enter in a name for the

query. The Favorites menu displays the favorite queries by name, followed by a list of

most recent queries. Select Favorites > Organize to reorder, rename, or delete queries.

Note that the favorites settings are saved on the client machine.

Figure 61: Search Favorites

Navigation Page Setup

For the Interfaces, Demands, and Tunnel tables, the default display is 1000 entries per

page and the Filter text box is disabled to enhance performance. Click the Navigation

Page Setup icon to change these settings.
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Figure 62: Navigation Page Setup

Table Options

Many tables can be customize by right-clicking on a column header in the table. The

following options may be available:

• SortAscending/Descending:Sorts thecolumnentries inascendingordescendingorder.

You can also sort a column directly by left-clicking the respective column header.

• Alignment Left/Right/Center: Positions the text within a column on the left side, right

side, or center of the cell.

• Best Fit: Sizes each column to fit the longest text in each column.

• Best Fit (all columns): Sizes all columns to fit the longest text for each column.

• Filter Checkbox: Filters the table based on the entry selections of the column. Select

All checks all entries and Clear All de-selects all entries

• Table Options:Opens a window that allows you to select which columns should be

displayed. These settings are saved on the client.
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Figure 63: Right-Click Table Columns

• Use image iconsoracheckbox ifapplicable:Some fields canbedisplayedwithan image

icon or text (for example, certain hardware types). For these fields, if this checkbox is

checked, the image icon is displayed. Otherwise, the corresponding text is displayed.

• AutoFit toWindow: Adjusts the columns to fit inside the width of the table. Columns

are given equal width. This option is useful if there are not toomany columns.

• Selected Item(s): You can select the desired columns to display in the table bymoving

them from the Available Item(s) list to the Selected Item(s) list. To do so, select the

item in theAvailable Item(s) list andclickAdd. Select oneormore items in theSelected

Item(s) list and use the Up / Down Arrows to rearrange the column order. For multiple

selection, use <Ctrl >-click or <Shift>-click.</Shift></Ctrl>
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Figure 64: Table Options

NetworkMenuMaps

Select Network >Maps to display additional maps such as the BGP, Events, and IP VPN

maps if available.

Select Network >Maps > CopyMap Layout to take the layout of one of the maps and

copy it onto another openmap. When the network is saved, the layout of the main map

is also saved, but not that of other maps.

NetworkMenu Nodes

Fromthemainmenubar, node informationcanbeviewedbyselectingNetwork>Elements

> Nodes. Nodes can be added, modified, or deleted in the Nodes window. You can also

view andmodify node information interactively by:

• Double-clicking on a particular node in the Map window.

• Right-clicking on a specific node in theMapwindowand selectVieworModify options.

The number of tabs and type of information displayed in the Node window depend on

the hardware type of the network model. Click on the up and down arrow to view the

additional tabs.
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Figure 65: NodesWindowGeneral Tab

Table 27: NodesWindowGeneral Tab Fields

DescriptionField

The user-assigned identifier for a node.ID

The user-assigned name associated with a node.Name

The IP address of the node (if applicable). Specified in the nodeparam file: IPADDR=ip_addressIP Address*

Themanagement IPaddress is the IPaddress thatwasused fromthe router profile to collect information
for this router.

Mgmt IP Address

Defines the switch hardware being used.Hardware

This field specifies the country location of the switch. Country designations are in the form of two letter
abbreviations (i.e. UK = United Kingdom)

Country

The number planning area (NPA) code for the node. This field is required for locations in the United
States andCanada. Latitude and longitude coordinates are determined fromNPA information and used
in graphical display and pricing. For locations elsewhere, the NPA field should be set to 999.

NPA

The NXX code for the node. In the North American direct, distance-dialing numbering plan, the NXX
code represents either the central office code or a given 10,000-line unit of subscriber lines. This field
is required for locations in the United States and Canada. Latitude and longitude coordinates are
determined from NXX information and used in graphical display and pricing. For locations elsewhere,
the NXX field should be set to 999.

NXX

The local access transport area (LATA) for the node. This only applies to locations inside the United
States.

LATA

This field specifies the latitude coordinates for a switch location. The latitude can be described using
either a floating point number between -90 and 90, or a string in the format ddmmssN or ddmmssS
where dd stands for degree, mm stands for minute, and ss stands for seconds. Nmeans North, and S
means South. It is required for locations outside of the U.S. and Canada.

Latitude
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Table 27: NodesWindowGeneral Tab Fields (continued)

DescriptionField

This field specifies the longitude coordinates for a switch location. The longitude can be described using
a floating point number between -180 and 180, a string in the format dddmmssE or dddmmssW. In that
latter form, ddd stands for degree, mm stands for minute, ss stands for seconds, E means East, andW
meansWest. It is required for locations outside of the U.S. and Canada.

Longitude

Vertical and Horizontal projection system used by Telco's and is mapped to LATA and NPA NXX. If NPA
NXX is given, V and H coordinates can be calculated.

V and H Coordinates

The UK easting and northing fields only apply when the country is set to “UK”. These fields correspond
to the UK Ordnance Survey grid and uses a point of origin near Scilly Isles. The field should be specified
with 3 digits for each field. Note: For these fields to be saved, the country code should be the UK and
the “saveUKENcoord” variable should be set to 1 inside the network model’s dparam file.

E and N Coordinates

The comment field can be used to addmiscellaneous notes andmessages about a node. You should
note that comments are not used in any part of the modification, design, or simulation of the program
and are merely provided as a convenience.

Comment

Table 28: NodesWindowGeneral Advanced Tab Fields

DescriptionField

The delay (in ms) associated with this node.Delay

The site with which a particular node is associated. Sites are used to represent node elements that
reside in the same room, building, or general area.

Site ID

Allows you to specify whether a particular node is collocated at an IXC POP. The reason for doing this
is to save on the local loop (LL) charges, however a collocation rental fee may be charged for the
equipment. Note that collocation applies only to U.S. locations.

Colocation

Youmay specifywhether a node is a core, regular, single-ended, or feeder node in this field. Core nodes
are nodes residing in the center of the backbone and receive the heaviest traffic. Regular nodes are
non-core nodes. Single-End nodes only connect to one other node (it is a nodewith a single neighbor).
Feeder nodes only connect to one other node, and only through one link (no parallel links to its single
neighbor).

Hierarchy Level

The custom rate class to which the node belongs. Custom rate classes are defined by you and used
for customized tariff/pricing purposes. For more information, see “Custom Rates Class” on page 169
and “Custom Rates” on page 166.

Custom Rate Class

Miscellaneous fields. For example, Shortcut specifies whether the node is enabled for forwarding
equivalence class.

Misc

Indicates if the element can fail during exhaustive failure simulation.CanFail
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Table 29: NodesWindowGeneral Design Tab Fields

DescriptionField

During a design, a link will not be added to the node if adding the link will exceed the node’s
capacity for links specified here. The default value is infinity. This value can also be specified from
the nodeweight file.

Max. Trunk BW

Allowsyou to specify thenumberof demands thatpass through this node,whichdoesnot include
any demands originating or terminating at this node.

Max. Transit Demand
Count

During a design, the node weight acts as a penalty for purchasing links at a node if the value is
<100000. This parameter can also be used to disallow pass-through traffic. If set to PASSTHRU,
it is not allowed in the designmode. If set to BLOCK, it is not allowed in the design and simulation
modes. See the nodeweight file in the Control Files section of the File Format Reference for
IP/MPLSView for more details. The default value is zero.

NodeWeight

During a design, this setting will prevent the program from adding new links from or to this node.Block from adding new
trunks

Allows you to specify the maximum total bandwidth of demands that pass through this node,
which does not include any demands originating or terminating at this node.

Max. Transit Demand BW

This field allows you to specifywhether a node is a gateway.Gatewaynodes are usedas entry/exit
pointswhenusingmultipledomains.Selecting thiswill activate theAccessibleAreaListparameter.

Gateway*

This field allows you to specify the area/domain association for the node. Areas/domains allow
you to effectively partition the backbone topology into smaller networks for purposes such as
facilitating network administration as well as overcoming physical hardware limitations.

Area/Domain*

Specifies the constraint of areas that this node can become a gateway to. This parameter is used
for design purposes. The areas should be separated by commas. The gateway checkboxmust
be selected in order for this field to be editable.

Accessible Area List*

Fields identified with an * are for device-specific models.

Table 30: NodesWindowGeneral Protocol Tab Fields

DescriptionField

OSPF reference bandwidth value if the default value or metric is not usedOSPF Reference BW

Identifies if the node has OSPF overload bit setOSPF Overload Bit

IS-IS reference bandwidth value if the default value or metric is not usedISIS Reference BW

Identifies if the node is using the overload bit in IS-ISISIS Overload Bit

The IS-IS areaISIS Area

Autonomous System number of the nodeAS

BGP Confederation ID of the nodeConfederation ID
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Table 30: NodesWindowGeneral Protocol Tab Fields (continued)

DescriptionField

Identifies if the node is a BGP speakerBGP Speaker

Identifies if the node is a route reflectorRoute Reflector

Identifies if the node is configured with multicastMulticast

The shortest path tree switch-over threshold valueSPT Threshold

Identifies if the node is a rendezvous pointRP

The rendezvous point addressRP Address

Table 31: NodesWindowGeneral BGP Tab Fields

DescriptionField

Displays the autonomous system (AS) number that this node belongs to.AS

Markswhether this node is aBGPspeaker. ABGPspeaker is a router configured to support
BGP.

BGP Speaker

Marks whether this node is a route reflector in this autonomous system.Router Refl.

Displays the confederation ID for this node.Confederation ID

To add a new node, press the Add button in the Nodes window. The Add Node window

will appear. Specify the properties for the new node and click Add. Note that the Add

Node window remains open to allow you to continue adding nodes if desired.

NOTE: If youplan toaddmanynodeswith similar properties to your network,
the use of templates can speed up the process. Node templates can be
defined by selecting Network > Elements > Templates > Node. Once defined,

templates canbe specified via theApply Template dropdownbox in theAdd
Node window. This will automatically populatemany of the fields in the
window. For example, the node template also supports autonumbering of
the Node ID and Node Name fields.

Specifying Node Location

Basedon the locationselectionmethodchosenbyyou, certainparameters in the location

tab are activated.

The Add Node window contains the following options for selecting the node location.
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• Mouse: This method allows themouse to be used for the specification of the location

for a new node. You should first check the boxmarked Mouse in the Location tab and

thenmove the cursor to the map window.When the cursor is in an area of the map

windowwhere a location can be selected, it will change to a white crosshair pointer.

Move this pointer to the desired location for the new node and left click. The

corresponding latitude and longitude coordinates will automatically appear in the

Location tab.

• City, Country: This method allows you to specify a node location by country and city.

For remote locations not in the database, youmay need to either specify a larger city

within close proximity to the desired location or use the Mousemethod.

When the City, Country option is selected, the country and city text fields become

active. Youmust first select a valid country from the drop-down combo box labeled

'Country'. A corresponding city name should then be entered in the city text field. City

namesmay also be searched by entering a partial name and clicking on the Search

button. Names of cities in the specified country that contain the search string is

displayed in the drop-down combo box labeled 'City'.

• NPANXX: This method is used to specify a node location using the number planning

area or area code (NPA) and the local exchange (NXX). Note that this method can

onlybeused fordefining locations in theUnitedStatesandCanada.When theNPANXX

option is selected, the NPANXX field in the Location tab becomes active. You should

enter thedesired location'sNPANXXcodeandclick Add. Information in thecity, latitude,

longitude, vertical, and horizontal text fields will then be updated.

• Lat/Lon: This method is used to specify a node location using latitude and longitude

coordinates. When this option is selected, the corresponding latitude and longitude

fields in the Location tab become active.

Latitude can be described using either a floating point number between -90 and 90

orastring in the formatddmmssNorddmmssSwheredd,mm, ss,N, andS respectively

stand for degree, minute, seconds, North, and South.

Longitude can be described using a floating point number between -180 and 180 or a

string in the format dddmmssE or dddmmssW. In this format, ddd, mm, ss, E, andW

stand for degree, minute, seconds, East, andWest respectively.

Modify Nodes

Tomodify one or more nodes, first select or highlight these nodes in the Nodes window.

Then, click theModifybutton. In theModifyNodeswindow, current valuescanbemodified

by changing the corresponding text field.

Whenmore thanonenode is selected formodification, certain fields suchas IDandName

are disabled and cannot bemodified. If no change is made to a particular field (i.e. the

field is left blank), then that property will not be touched or modified for any of the

selected nodes.
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Configuring NetworkWindow Links

• NetworkWindow Links on page 128

• Links General Tab on page 129

• Location Tab on page 130

• Capacity Tab on page 130

• MPLS/TE Tab on page 131

• Protocols Tab on page 132

• Attributes Tab on page 132

• CoS Policy Tab on page 132

• Add Links on page 132

• Modify Links on page 133

• Right-Click Menu Options on page 133

NetworkWindow Links

Link information can be displayed from themain menu by selecting Network > Elements

>Link. Or select the link(s) from themapand right-click selectView>SelectedLinks from

the popupmenu to open the Links window.

The number of tabs and type of information displayed in the Linkwindowdepend on the

hardware type of the network model. Click on the up and down arrow to view the

additional tabs

Figure 66: LinksWindowGeneral Tab
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Links General Tab

DescriptionField

The user-assigned name for a link. If a name is not assigned, references to that link aremade using the node
pair representing its origination and termination ends.

Name

This field specifies the type of trunk being used. The trunk type is subsequently used in determining link
pricing and bandwidth availability.

Trunk

The vendor field allows you to specify the vendor to be associated with the particular link. Possible values
for vendors include those that are specific to a certain country or region, and are listed in the tariff database.
If a vendor is not specified, the vendor is set to the default DEF. To represent in-house fiber links with zero
cost, the vendor should be set to NET.

Vendor

This field allows you to specify the cost for a particular link. If this field is specified, the link price is based
on this value, rather than one from the tariff database.

Cost

This field allows you to specify whether a link is to be considered permanent in the backbone topology. If
this field is checked, the particular link will not be considered for removal during the optimization phases
of design and/or diversity design.

Fixed

Indicates if the element can fail during exhaustive failure simulation.CanFail

Defines the bandwidth in each direction if it is different from the default bandwidth.BW

Defines the bandwidth reserved for signaling. The default value is used if not specified.Ovhd

This field isusedonly if the routingmethod is set toDelayMetric.When theprogramperformspathplacement
and is trying to find the best route for a call, delay metrics are examined to determine the
desirability/undesirability of a link. Two delay metrics are supported, one for each direction of the trunk. If
asymmetric delay metrics are not supported by the hardware, the second delay is marked as '-'. If a delay
metric is not defined for a trunk, a default delay is calculated based on propagation delay and serialization
delay. Units are in milliseconds.

Delay

When the program performs path placement, link metrics are examined to determine the least cost path.
Twometrics are supported, one for each direction of the trunk. If asymmetric metrics are not supported by
the hardware, the secondmetric is marked as '-'. For the metric to be used, an appropriate routing method
should be set in the Tools > Options > Design, Path Placement options pane.

DIST= number

DISTA2Z= number

DISTZ2A= number

Metric

(IP/MPLS only) Link metric as seen by tunnels. Defaults to IGPmetric if not specified.

TDIST= number

TDISTA2Z= number

TDISTZ2A= number

Tunnel Metric
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DescriptionField

Indicates theoperating status of the link. This field reflects the current status of the link. Valid status include:
Unknown, Install, Live, Active, Order, Planned.

Op Status

This parameter reflects the current status of the link. Valid states include: Unknown, Install, Active, Live,
Order, and Planned.

Admin Status

This field specifies the service type of the trunk. Current service types include ATM and Frame. This field
specifies the type of traffic switches support, either frame or cell. If a service type is not explicitly set by you,
a default value will automatically be set based on the hardware switch being used.

Service

Themedia field allows you toassign attributes to a link. Validmedia attributes include: TERRES (terrestrial),
SAT (satellite), MCWAVE (microwave), FIBER, and ENCRYPT (encrypted). These media descriptors are
used in route biasing of calls using criteria such as preferred, preferred not, and required.

Media

This field is used to display special characteristics of a link.

Themiscellaneous field contains media and link overhead, distance, cost, delay specifications for links. If
more than one specification qualifier is needed for a link in themedia type field, these specifications should
be separated by commas (,) without any spaces.

For complete description of this field, see the File Format Reference for IP/MPLSView.

Misc

Comments attached to the trunk definition. You should note that comments are not used in any part of the
modification, design, or simulation of the program and are merely provided as a convenience.

Comments

Location Tab

DescriptionField

The “Area” field will appear only when the OSPF protocol is used. The “Domain” field will
appear only for networks with multiple domains.

Area/Domain

Displays the source and destination of the link. It is important that you be able to clearly
distinguish between Node A and Node Z, especially in defining one-way demands.

Node A, Node Z

These indicate the card, port, and shelf numbers of the originating and destination nodes.
These fields are useful for identifying the source and destination of the link. These fields
are only available for certain hardware types.

Card A, Port A, Shelf A, Card Z,
Port Z, Shelf Z

This indicates the interface at node A and node Z that this link comes out of.Interface A, Z

This indicates the IP address andmask of node A and node Z.IP/Mask A, Z

Capacity Tab

In general, the Capacity tab of the Links windows is used to display link utilization

information, derived fromthebandwidthofdemands (for example,PVCsor flows) routed
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over the link and the link’s total bandwidth. The upper half shows summary information

and the lower half gives a breakdown by partition.

DescriptionField

The Direction of the link, either “A2Z” or “Z2A”.Dir

The total bandwidth of the link.Total BW

The amount of bandwidth still available on the link.Avail

The amount of bandwidth used on the link by demands (or tunnels)Used

The utilization percentage of the link, as calculated from the Used and Total BW values.Util

The amount of reserved bandwidth on the link. This affects routing design. Reserved bandwidth is often
used to let you “save” bandwidth for scenarios such as network growth or potential outage. Note that
the maximum usable bandwidth for routing is set to Total BW - Rsv. To change the reserved bandwidth
value, select Tools > Options > Design and switch to the Design>Reserved Bandwidth options pane. For
more information, see Reserved Bandwidth.

Rsv

MPLS/TE Tab

File FormatDescriptionField

bblink file

FRR_A= backuptunnel

no/yes: specifies if there is a fast reroute backup tunnel
for the Node A to Node Z direction.

If yes, specify the fast reroute backup tunnel.

FRR A

bblink file

FRR_Z= backuptunnel

no/yes: specifies if there is a fast reroute backup tunnel
for the Node A to Node Z direction.

If yes, specify the fast reroute backup tunnel.

FRR Z

bblink file (for Cisco)

GLBPOOL= bw

GLBPOOLA2Z= bw

GLBPOOLZ2A= bw

(for Juniper Networks)

RSVP= bw

RSVPA2Z= bw

RSVPZ2A= bw

Tunnels cannot route over a link unless there is available
bandwidth in the global pool.

GLB Pool /
RSVP
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File FormatDescriptionField

bblink file (for Cisco)

SUBPOOL= bw

SUPOOLA2Z= bw

SUBPOOLZ2A= bw

(for Juniper Networks)

GB= bw

GBA2Z= bw

GBZ2A= bw

“Guaranteedbandwidth” tunnels cannot routeover a link
unless there is available bandwidth in the subpool.

SUB Pool / GB

Protocols Tab

The following protocols can be viewed in the Protocol tab: MPLS, OSPF, ISIS, EIGRP,

IGRP, RIP, LDP, TDP. The corresponding metric (if applicable) is displayed underneath

the A-Z Metric and Z-A Metric columns, such as the tunnel metric for MPLS-TE and the

cost for OSPF, ISIS1 and ISIS2. Themetric for a given IGP protocol is used for routing the

demands if the default routing protocol is set to that protocol.

Note that there are two additional entries, Metric Bandwidth and (E)IGRP delay that can

also used to influence the routing metric. The Metric Bandwidth is an informational and

routing parameter corresponding to the “bandwidth” statements for Cisco and Juniper

Networks interfaces. The (E)IGRP delay corresponds to the “delay” statement for Cisco

interfaces.

EIGRP and IGRPmetrics can be influenced by changing the Metric Bandwidth or EIGRP

Delay fields. To change the K-values from the text file before opening the network, the

following line can be added to or edited in the dparam file: IGRP_param1=

TOS:0,K1:1,K2:0,K3:1,K4:0,K5:0

For OSPF, the Metric Bandwidth is used to calculate the routing metric only if no cost is

specified. The reference bandwidth can be changed bymodifying the Node.

Attributes Tab

Tunnels can be prevented from routing over particular links if the link attributes, tunnel

mask, and tunnel affinity are set.

CoS Policy Tab

Specify the CoS policy attached to the interface of node A (source) or node Z

(destination).

Add Links

Click the Add button in the Links window to open the Add Link window. The required

information (in blue) includes the trunk type (T3, OC3, etc.) and the link’s end nodes (on
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the Location tab.) The end nodes of the link may be chosen by referencing the Node ID

or by using the mouse.

• ByMouse: Select node A and node B from the display map by using the mouse. When

the nodes are selected, the node IDs are displayed in the node A and node B fields of

the Location tab.

• Node ID: Select node A and node B by browsing through the node list by each field.

For router networks the interface and IP address canbe specified. To specify an interface,

click the search icon to see available choices. Other hardware types may have fields for

the card and port number instead of the interface and IP address.

Clicking Add submits the new link to the network model. The Add Link window remains

open to allow adding additional links if desired.

Apply Template

Thispull-downselectionallowsyou toapplya link template thatwascreatedbyselecting

the “Link Template” window as detailed in Link Templates. This can serve as a shortcut

to automatically filling in fields that are in common amongst many links.

Auto Add onMouse Clicks

When this checkbox is selected, youmay automatically add new links from themap by

choosing node A and node Z. The properties of the new link should be specified on the

properties tab of the “Add Link” window before adding the link with the mouse.

Modify Links

Tomodify one or more link, first select or highlight these links in the Links window. Then,

click the Modify button. In the Modify Links window, current values can bemodified by

changing the corresponding text field.

Whenmore than one link is selected for modification, certain fields are disabled and

cannot bemodified. If no change is made to a particular field (i.e. the field is left blank),

then that property will not be touched or modified for any of the selected links.

Right-Click Menu Options

• TrafficChart:Traffic charts include the traffic loadperperiodderived fromthe trafficload

file andmeasured interface traffic from the interfaceLoad_in(ingress) and

interfaceLoad_out (egress) files. For router hardware, options vary depending upon the

chosen layer (Layer 2 or Layer 3) indicated in the toolbar.

• Node Detail A, Node Detail Z: Switches to a view displaying information on the source

node (Node A) or destination node (Node Z)

• ShowConfig A, ShowConfig Z: (Router only). Displays the configuration file for the

source node (Node A) or destination node (Node Z)

• Demands on/thru Link: Displays a list of demands routed over this link.

• SRLGs on Link: Displays a list of facilities containing the selected link
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• Interfaces on Link: View the interfaces used for the selected link.

• Nodes on Link: Displays NodeA and NodeZ on the link.

• Tunnels on/thru Link: Displays a list of tunnels that routes through the link.

• Tunnel Table on/thru Link: Displays a list of tunnels that routes through the link in a

table.

• CLI - Show Interfaces: (Live Network only). Opens the Run CLI window and runs the

show interface command on the interfaces of the link.

• Live Link Status Check: (Live Network only). Opens the Live Status window and runs

queries to check the operation and admin status of the link.

Interfaces

The interface window is available from Network > Elements > Interfaces

Figure 67: InterfacesWindow

General Tab

DescriptionField

The interface nameInterface Name

The IP address andmask of the interfaceIP Address/Mask

The allocated bandwidthBandwidth

Layer 3 (IP) or Layer 2 (switches)Layer
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DescriptionField

The node which contains the interfaceNode

The link which uses the interfaceLink

The operational status of the interface (active, passive, planned, down, unknown)Oper Status

The administration status of the interface (active passive, planned, down)Admin Status

Advanced Tab - Layer 3

DescriptionField

The virtual circuit identifier or the data link connection identifier for ATM frame relayVCI/DLCI

The VPN being used on the interfaceVPN

The virtual routing and forwarding instance nameVRF

The virtual router nameVRouter

The hot standby routing protocolHSRP

The interface encapsulation typeEncapsulation

Themultipoint interfaceMultipoint

The automatic protection switching groupAPS Group

The automatic protection switching addressAPS Protected Address

The automatic protection switching nodeAPS Protected Node

The VLAN associated with this interface, if anyVLAN ID

The aggregated interface (for example, ae0, ae1 for Juniper Networks) associated
with this interface.

Aggregated Interface

To associate an interface with a link, modify the link’s Location tab. Click on the search

button next to each Interface text box to bring up the Select Interface window. Highlight

the interface you wish to associate with that end of the link and clickOK.

Advanced Tab - Layer 2

DescriptionField

The interface encapsulation typeEncapsulation

The VLAN associated with this interface, if anyVLAN ID
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DescriptionField

Redundant trunk groups can be configured on EX-series switches so that when the active
link in the group fails, a secondary link will start forwarding data traffic.

Redundant Trunk Group

The aggregated interface (for example, ae0, ae1 for Juniper Networks) associated with this
interface.

Aggregated Interface

Access (SW_ACCESS) or Trunk (SW_TRUNK)Port Mode

Specifies the tagging type (For Juniper Networks, VLAN_TAGGING is for single tagging,
STACKED_TAGGING is for double taggin, and FLEX_TAGGING can be configured on the
physical interface to support different tagging types on different logical interfaces of the
same physical interface).

Tagging

Right-Click Menu Options

• Live Interface Load (Live Network only): Indicates the traffic load collected by

IP/MPLSView using the Traffic Collection Manager.

• ShowRelated Interface(s):Opens a table of related subinterface(s) of a physical

interface, aggregate link (for example, ae link) to which this interface belongs, if

applicable, and connected interface(s). The Relation column indicates the nature of

the relationship (Physical/Main Interface, Sibling, Connected, Self, Subinterface, etc.)

When selecting a link of this table, the bottom pane indicates the relationship. For

example, for WAS3640.Ethernet0/1.6, the Physical/Main Interface is

WAS3640.Ethernet0/1, aSibling interface isWAS3640.Ethernet0/1.2, andaConnected

interface is J3.ge-0/0/1.6 (there is a link betweenWAS3640 and J3).

Add Interfaces

Toaddan interface, clickAdd toopen theAdd Interfacewindow.Thenspecifyan Interface

Name, IP Address/Mask, Bandwidth, and select a Node from the drop-down box.

Modify Interfaces

Tomodify an interface, select an interface and clickModify tomake the desired changes.

To associate an interface with a link, go to the Links window and clickModify. In the

Location tab, click on search button next to each Interface text box to bring up the Select

Interface window. Highlight the interface you wish to associate with that end of the link

and click “OK”.

Demands

• DemandsWindow Properties Tab on page 137

• Properties Tab on page 137

• Paths Tab on page 138

• Add Single Demand on page 139

• Demand Type Parameter Generation on page 142
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• AddMultiple Demands on page 143

• Add One Hop on page 145

• Modify Single Demand on page 146

• Modify Multiple Demands on page 147

• Right-Click Menu Options on page 148

• Further Notes on Priority and Preemption on page 148

• Demand Statistics View on page 149

• Traffic Load on page 150

• End-to-End Delay on page 151

• Find Demands Filter on page 152

DemandsWindowProperties Tab

FromthemainmenuselectNetwork>Elements>Demands toopentheDemandswindow.

“Demands” is a generic terminology used in IP/MPLSView. It is equivalent to “PVCs” in

ATM networks or end to end “flows” in router networks.

Figure 68: DemandsWindow Properties Tab

Properties Tab

DescriptionField

The demand name specified by you when the demand was added.Demand

Displays the source node (Node A) and termination node (Node Z) of the demand and their IP
addresses (router model only).

Note that IPv6 requires a license.

Node A, Node Z IP A, IPZ
IPv6 A, IPv6 Z*
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DescriptionField

This is the bandwidth required by the demand. Demand overhead is automatically calculated by
the program.

BW

The priority and preempt fields of the demand specification consists of two numbers separated
by a comma (,). The first number defines the priority of the demand, and the second number the
preempt priority of the demand. The preempt priority should be at the same or lower priority as
the priority of the demand. It is assumed that this demand can bump any of the demands with
priority lower than thepreemptpriority.See “FurtherNotesonPriorityandPreemption”onpage 148.

pri,pre

Indicates the type of the demand, whether it is a data demand or voice demand.Type

Displays the name of the owner of this demand. Owner groups can be defined using the Owners
section in the Modify menu.

Owner

Indicates the user-defined service type of the demand (for example, FTP, VOIP) as described in
“Service Type” on page 164.

Service

For the optical transport model, this will indicate if the demand is a 1+1 demandPath Config Options

Indicates whether or not the path is routed on the primary configured route. ‘yes’ means the path
is routed on the primary configured route ‘no’ means the path is routed but not on the primary
configured route ‘-’ means there is no configured route ‘not routed’ means the path failed to be
placed

On Pref Rt (On Preferred
Route)

User-entered commentsComment

Paths Tab

DescriptionField

This is the current route/path of the demand. This path is calculated by the programaccording to themetric,
partitions, etc. as specified by you in the Design options.

• The route consists of a sequence of node IDs or names separated by “--”. Different delimiters are used
to mark the distance relationship between nodes. A listed configured route for a demand would be
something like “ATL--WDC--HOU--NYC”. This means the path of the demand begins at node Atlanta,
goes toWashington DC, Houston, and terminates at node New York City.

• Use the Report Options window (Tools > Options > Report) to decide whether to display the path using
the linkname or only the nodes along the path.

Current Route

This field displays the user-configured route/path for this demand. This route is specified by you in the
Add/Modify Single Demand window.

• The route consists of a sequence of node IDs or names separated by “--”. Different delimiters are used
to mark the distance relationship between nodes. A listed configured route for a demand would be
something like “ATL--WDC--HOU--NYC”. This means the path of the demand begins at node Atlanta,
goes toWashington DC, Houston, and terminates at node New York City.

• Use the Report Options window (Tools > Options > Report) to decide whether to display the path using
the linkname or only the nodes along the path.

Configured
Paths

Displays all secondary routes/paths of the demand. Secondary routes are also specified by you in the
Add/Modify Single Demand window.

Secondary
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Add Single Demand

To add a single demand, click the Add > One demand button. Enter in the source (Node

A), destination (Node Z), bandwidth (BW) and a demand identifier (Demand ID). For an

explanation of the parameters in this window refer to the table below.

Figure 69: Add DemandWindow

Properties

DescriptionField

The Demand identifier as specified by you.Demand ID

Displays the name of the owner of this demand. Owner groups can be defined using the Owners
section in the Modify menu. In router models, this shows the VPN in which the demand belongs.

Owner/VPN

Originating node of the demand.Node A

Destination node of the demand.Node Z

The bandwidth required by the demand. Overhead is automatically calculated by the program.BW

Indicates the type of the demand. (varies with different hardware types)Type

Comments attached to the demand definition. You should note that comments are not used in
any part of the modification, design, or simulation of the program and are merely provided as a
convenience.

comment
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Advanced

DescriptionField

The priority and preempt (or holding priority) fields of the demand specification consists of two numbers
separated by a comma (,), or a forward-slash (/). The first number defines the call priority of the circuit, and
the second number the preempt priority or holding priority of the circuit. The preempt priority or holding
priority should be at the same or lower priority as the call priority of the circuit.

• Whether the second number is the preempt or holding priority depends on the hardware. Most hardware
vendors use holding priority. Note the subtle difference between the two types: A circuit can bump any
circuit with call priority lower than the preempt priority. A circuit can only be bumped by a circuit with call
priority higher than the holding priority.

• See “Further Notes on Priority and Preemption” on page 148

pri,pre

Indicates the service typeof thedemand.Theavailable service typescanbe found in theServiceTypewindow
as detailed in “Service Type” on page 164.

Service

Displays the path configuration options used to mark current routes as configured paths or to remove
configured paths. Options available are: Config, Div. Sec. and Div. Stdby.

• Div. Sec. and Div. Stdby options are applicable only for ATM PVCs and LSP tunnels. When specified,
IP/MPLSViewwill create a secondary or standby path entry, respectively, for the PVC/tunnel.

• Specifying Config will cause the Configured Route to be set equivalent to the Current Route.

Path Config.
Options

Location

NOTE: An asterisk (*) denotes a hardware specific field. Note also that IPv6
requires a license.

DescriptionField

Displays the source node of the demand.Node A

Displays the IP address of node A.IP A*

Displays the IPv6 address of node A.IPv6 A*

Displays the destination node of the demand.Node Z

Displays the IP address of node B.IP B*

Displays the IPv6 address of node B.IPv6 B*

Paths

DescriptionField

This is the user-specified name of the route for this demand. This pathname is specified by you in the
Add/Modify Single Demand window.

Pathname

Copyright © 2018, Juniper Networks, Inc.140

IP/MPLSView Java-based Graphical User Interface Reference



DescriptionField

This field indicates the priority of this path/route in the “Opt” field. In the “Opt” field, the programwill select
the smallest number to be the primary route. For example, youmay specify an Opt 2 for route “Backup1”
andOpt 5 for “Backup2”. The programwill sort these two routes and selectBackup1 to be the primary route
since its Opt is smaller.

Opt

This field displays the user-configured route/path for this demand. This route is specified by you in the
Add/Modify Single Demand window.

• The route consists of a sequence of node IDs or names separated by “--”. Different delimiters are used
to mark the distance relationship between nodes. A listed configured route for a demand would be
something like “ATL--WDC--HOU--NYC”. This means the path of the demand begins at node Atlanta,
goes toWashington DC, Houston, and terminates at node New York City.

Configured Path

Configuring the Demand Path

When adding a demand, you can configure a path or route for the demand.

NOTE: This featureapplies forconnection-orientednetworks likeATMwhere
a path can be preferred or required. (For IP/MPLS networks, configuring the
demand path applies only for tunnels, not for demands.)

To configure the path, underneath the “Demands / Paths associated with this demand”

section, first double-click the Pathname field to change the pathname so that it is no

longer “Dynamic”. There are multiple ways to configure the path through the graphical

interface.

• One way is to select Click links/nodes onmap, then right-click in table next to where it

says “To choose paths.” Then, <Ctrl>-click all the links along the path, right-click the

relevant row entry in this table, and then select UseMap Sel’n.

• Anotherway is to selectClick consecutive nodes starting at nodeA next towhere it says

“To choose paths.” Then click the nodes from source to destination to automatically

populate the Configured Route. Because this method is based on nodes only rather

than including the links, this method cannot be used to select a particular link when

there are parallel links between two nodes.

• Finally, anothermethod is to right-click anentry andselectEditRoute toopenawindow

where you are given options for each next hop until the destination is received.

Edit Route

DescriptionField

Displays the current originating node fromwhich the path of this demand is to be specified.Current Node

Displays the name of the demand as specified by you.Circuit ID / Flow ID
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DescriptionField

Here, you can select three methods to choose the next hop or path for this demand.

The Node ID/Name option allows you to select the next hop by choosing the next node of
the path. The Link Name option allows you to select the path of the demand by choosing
the linksonwhich thedemandwill traverse. Lastly,with theLooseRouteoption, theprogram
displays a list of routes calculated

Next Available Hop(s) / Available
Nodes

Clicking on this button will add the highlighted hop or path to the path list.Add to Path

Deletes the highlighted path from the current path list.Delete from Path

Selecting this button displays the path in the topologymap. The path is displayed in a think
yellow line.

Show Path

This will clear the list of chosen paths from the current paths section of this window.Clear Selections

Allows you to set the next available hop using the IP address or node ID/name.Hop Disp Opt

As you defines and adds to the path for the demand, this field will progessively display the
path as specified by you.

Defined Path

User Parameters

User parameters allow you to define their own parameters for network elements such

as nodes, links and demands, and then to associate values to these parameters for the

individual network elements. For more information on this feature, see the User

Parameters and Link Rules chapter of the Training Guide for IP/MPLSView.

Demand Type Parameter Generation

Click theTypebutton in theAddorModifyDemandswindowtoaccessadditionaldemand

settings. Clicking OK causes the Type field to be populated with the corresponding

keywords. Note that different parameters will appear for different hardware device

models.

File FormatDescriptionField

MAXDELAY=x
(optional unit ‘s’ or ‘ms’ for seconds and
milliseconds)

Specify a maximum delay constraint (default in milliseconds).Max Delay

HcntSpecify a maximum hop constraintMax Hop

MAXCOST=xSpecify amaximumend-to-end cost of the path ( for example,
sum of the metrics/admin weights)

Max Cost

BFsizeUsed to calculate overhead.Frame Size
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File FormatDescriptionField

Ddivgroupnamewhere divgroupname is
the name of a group of paths

Specify the name of a group of demands this demand belongs
to. When performing diverse path design, the programwill try
to design the paths of the demands in this group to be diverse.

Diversity

GB,Specifies that the demand should route over a Guaranteed
Bandwidth (for example, subpool) tunnel

Guaranteed BW

DUPLEX,If this checkbox is selected, the flow is routed along the same
route in both directions.

Full Duplex

COS=policyname, where policyname is
substituted by the CoS policy name

CoS PolicyPolicy Class

MCip-address, where ip-address is
substitutedby thedestination IPaddress

If this checkbox is selected, specify the destination IP in the
adjacent select menu.

Multicast

pim-mode, where pim-mode is
substituted by the multicast mode (for
example, PIM-DM)

The following Protocol Independent Multicast modes can be
specified:

• PIM-DM (densemode) PIM-SM (sparse mode)

• PIM-SM (sparse mode)

• Bidir-PIM

• SSM

PIMMode

LIVE is live
MOD is modified
NEW is new
PLAN is planned
SHUTDOWN is shutdown

These are labels for status classification that can be applied to
a demand or tunnel.

• LIVE,MOD,NEW, andPLAN labels haveno impact on routing
and is used for identification purposes.

• If SHUTDOWNlabel is used, thedemandbecomesunplaced.

Admin Status

ECMP= n, where n is substituted by an
integer

Specify that this demand can be load-balanced to Equal Cost
Multiple Paths: specify a number in the adjacent textbox to
specify the number of sub-flows that the flow can be broken
down into

ECMP

AddMultiple Demands

Select Add >Multiple Demands to addmultiple demand definitions to the network at

one time. A list box is used to indicate the origin (Node A) and destination (Node Z)

locations.Meshed demands are created between all locations listed inNodeA andNode

Z.
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Figure 70: The AddMultiple DemandsWindow

DescriptionField

Specifies the circuit identifier assigned by you to the demand.Apply Template

Specifies thedemandsuffix numberassigned formultipledemands.Thisnumberwill automatically
increment.

Demand ID (Prefix and #)

Specify the name of the owner of this demand or the VPN in which this demand belongs. Owner
groups can be defined using theOwners section in theModifymenu. VPN can be defined using the
Add/Modify IP VPNwindow in the Modify menu.

Owner

Specifies the number of demands to be added between node pairs.Count

This is the bandwidth required by the demand. Demand overhead is automatically calculated by
the program.

BW

Indicates the type of the demand, whether it is a data demand or voice demand. This field also
indicates parameters for QoS networks. See “Demand Type Parameter Generation” on page 142.

Type

The priority and preempt priority (or holding priority) fields of the demand specification consists
of two numbers separated by a comma (,), or a forward-slash (/). The first number defines the
call priority of the circuit, and the second number the preempt priority (or holding priority) of the
circuit. The preempt priority should be at the same or lower priority as the call priority of the circuit.
See “Further Notes on Priority and Preemption” on page 148

Pri,Pre
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DescriptionField

Indicates the service type of the demand. The available service types can be found in the Service
Type window. For more information on service types, see “Service Type” on page 164.

Service

Specifies the path configuration option, which can be Config, Div.Stdby, or Div.Sec.Path Config. Options

Displays any comments youmay be inclined to enter.Comment

Specifies that thedestination IPAddress of eachnewdemand should beautomatically populated.Populate Destination IP

• Filter:Opens the Find Nodes window in order to add nodes to the Node A and Node Z

lists.

• Filter FromMap:Adds nodes to the Node A andNode Z lists that are highlighted on the

topology map.

• Remove: Remove the selected node from the Node A or Node Z list.

• Copy A-> Z: Copies the nodes that are on the Node A list to the Node Z list.

AddOne Hop

The Add > One Hop option allows you to create two demands per link, one in each

direction. Because these demands have adjacent source and destination nodes, they are

referred here as “one hop demands.” For example, for a link connecting ATL to DAL, the

program can create two one-hop demands, one from ATL to DAL and one from DAL to

ATL.

The purpose of this feature is to allow you to analyze the network to find out which

demands are routed over the direct link and which are routed over a detour path. The

detour path may be taken, for example, if the metric of the direct link is higher than that

of the detour path. You can then check to see whether the detour path was intended or

not.

Upon opening the following window, you should perform a Filter... or Filter FromMap to

select the links for which to add one-hop demands. Then enter a bandwidth and

bandwidth unit for the demands to be added, for example, 1M for 1Mbps, and click “OK”.
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Figure 71: Add One Hop Demands

NOTE: For information on the Add One Hop Tunnels feature, see the Router
Feature Guide for IP/MPLSView. Whereas for demands, the routing is left
dynamic inorder toallowdiscoveryofmulti-hoppaths, for tunnels, anexplicit
tunnel path over the selected link is given to force the tunnel over the direct
link.Therearealsoadditionaloptions to label theadded tunnelswitha tunnel
user parameter for the tunnel ID group.

Modify Single Demand

When you selectModify > Selected... for only one entry in the Network Info window

Demands view pane, the following window is opened. Youmust first select a set of

demands to modify in the table.

Figure 72: Modifying a Single Demand (Options May Vary)
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Paths Tab

• PathTable:Whenselected, a tablewill appear displaying eachconfiguredor calculated

path that originates at the source node of this demand. Note that these paths are not

necessarily associatedwith thedemand, andarenot tobeconfusedwith theconfigured

or current path taken by the demand.

• ShowRoute:When selected, this button displays the highlighted path in the detailed

demand information window.

• ShowAllPaths:This optiondisplaysall paths listed in thedetaileddemand information

window.

Modify Multiple Demands

When you selectModify > Selected... for multiple entries in the Network Info window’s

Demands view pane, the following window is displayed.

Figure 73: Modifying Multiple Demands (Optionsmay vary)

DescriptionField

This option can be used to changemultiple demands to have the same Demand ID. In most cases
Demand IDs are unique and this option will not be needed. However, for certain features, the same
demand IDmay be used for different demands in order to group them together. These features include
multicast demands (ATMor router hardware)andvirtual concatenationgroups (optical transport only).

New Demand ID
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DescriptionField

When this checkbox is selected, the programwill performabandwidthmultiplication by the percentage
specifiedhere. Thebandwidthofeverydemandselected formodification ismultipliedby thispercentage.

Multiply BW by

When this checkbox is selected, the programwill remove the current route for the demands being
modified. Accordingly, those demands are unplaced and the Current_Route column of the demand
window is cleared for those demand entries.

• You can then have those demands routed when updating the network state or exiting frommodify
mode by answering “Yes” to the dialog prompt to update the demand routing tables. Alternatively,
youmay perform tuning for unplaced paths only from Design > Demands > Route Paths > Unplaced
Paths.

Remove Current
Route

Right-Click Menu Options

• ShowPath: Displays the path of the demand in the topology map, if it is routed. If

multiple demands are selected, their paths are highlighted on the topology map, and

thedemandcurrently selected in thepathwindow ishighlightedwitha slightly different

color.

• Highlight All: Displays on the Standard map the source to destination pairs of all

demands listed in this window.

• Bottlenecks: Displays the location of the bottleneck in the console when a demand is

unplaced.

• BW_Ovhd:Displays thebandwidthusedby thedemandandalso theactual bandwidth

allocated to the demand. This information is displayed in the console window.

• All Configured Routes: This option displays on themap the configured routes for this

demand. If the path is dynamic rather than configured, you should use the Show Path

option instead.

• PathTable:Whenselected, a tablewill appear displaying eachconfiguredor calculated

path that originates at the source node of this demand. Note that these paths are not

necessarily associatedwith thedemand, andarenot tobeconfusedwith theconfigured

or current path taken by the demand.

• End-to-End Delay: View a chart of the end-to-end delay per period as described in

“End-to-End Delay” on page 151. ShowTraffic Load: View a chart of the traffic load per

period in the network as described in “Traffic Load” on page 150.

• ShowSite Demands: Display site-to-site demands on topology map, with a legend to

indicate the load between each site pair. See “Show Site Demands” on page 172 for

more information.

• AggregateDemands:Viewthe total bandwidthbetweeneachnodepair in table format.

See “Aggregate Demands/Tunnels” on page 172 for more information.

Further Notes on Priority and Preemption

The Priority and Preempt Priority (or “pri,pre”) values of a demand (or MPLS LSP tunnel

in Router models) influences routing order and placement. Note that although

IP/MPLSView uses the term “preempt priority” throughout its graphical interface, for a
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majority of hardware types, if supported, this value actuallymaps to a demand’s Holding

Priority. IP/MPLSViewwill mimic the behavior of the hardware device.

Note that Holding Priority and Preempt Priority differ subtly in meaning. A demand with

a holding priority of some value x indicates that “any demand with a priority higher than

x can preempt this demand.” A demandwith a preempt priority of some value x indicates

that “this demand can preempt any demand that has a lower priority.” Net.comPromina

hardware, for example, uses “preemptpriority”. Themajorityof supportedATMand router

hardware, however, use a “holding priority” implementation (for the routers, this applies

to MPLS LSP tunnels, as opposed to demands).

Also, for the majority of supported hardware models, a lower number indicates a higher

priority. For a few hardware types, however, it is the reverse. Refer to your hardware’s

documentation to check for the proper numbering scheme. IP/MPLSViewwill mimic the

hardware’s behavior.

For example, suppose a demand has a pri,pre value of (7,0). Assume the lower value

receives a higher priority. So, a “0” holding priority is already the highest priority and

indicates thatnodemand is able topreempt this particular demand.The “7”priority value

is used to determine routing order. If demands are placed with higher priority demands

first (thedefault), then this demandwill notbe routeduntil after thedemandsofpriorities

0 through 6 are routed.

NOTE: The preempt priority, or holding priority, should always be set to a
higherpriority than thepriority value.To illustrate, assumethatwearedealing
with holding priorities, as defined earlier, and that the lower value receives a
higher priority. Then, a pri,pre value of (7,8) is invalid. To understand why,
imagine if you had two such demands with pri,pre values of (7,8). One
demand, of holding priority 8, could be preempted by the other demand,
whose priority is 7. The preempting demand could then become preempted
by the original demand, causing an oscillating scenario.

Demand Statistics View

The statistics view can be obtained by right-clicking a demand and selecting View >

Statistics View. The tabs are explained below:

DescriptionField

TheGeneral demand information tab displays the total amount of placed and unplaced voice and data
demands found in the network in terms of bandwidth.

General

The Priority Load tab sorts the demands found in the network by their defined priority and displays
them in a table form in the demand information window.

Pri Load
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DescriptionField

The BW&Ovhd tab provides summary information on the bandwidth and overhead of the demands
shown in the Demands window. The program calculates the bandwidth of the demands including the
overhead calculation and summarizes this data in this tab.

Note: This tab is only activated when you are viewing demands on/thru a specific link. (Right-click on
a link; select View > Demands On/Thru Link.)

BW&Ovhd

The NHop Path tab categorizes the demands found in a network by the total number of hops in each
demand's route.

N Hop Path

Traffic Load

NOTE: A license for traffic loadanalysis is required for the traffic load feature.
Please contact your Juniper Networks representative for more information.

As a prerequisite, you should load in the trafficload file, which details the period by period

bandwidth utilization. Refer to the chapter The Demand/Traffic Files in the File Format

Reference for IP/MPLSView for more details.

Right-click a demand from the Network Info window’s demand view pane and select

Show Traffic Load to view the traffic load for a single demand or Show All Traffic Load

to view the sum total traffic load for all demands. This displays the Traffic Loadwindow,

displaying the traffic load in either barchart or line form.

In the traffic load graph show below, the Y-axis displays the traffic load in megabits per

second. One bar is displayed on the barchart for each of up to 24 time periods. The first

two bars display the planned or normal bandwidth ("N") and the worst or peak traffic

load ("W") which occurred during those periods.
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Figure 74: The Traffic Load Graph

End-to-End Delay

NOTE: A license for traffic load analysis is required for the end-to-end delay
menu. Please contact your Juniper Networks representative for more
information.

Right-click a demand from the Network Info window’s demand view pane and select

End-to-End Delay to view the period to period end-to-end delay for a single demand or

All End-to-End Delay to view the average of the end to end delays for all demands in the

networks. This displays the Traffic Load window, displaying the traffic load in either bar

chart or line form.

The End-to-End Delay graph displays the delay experienced by the demands in the

network. In the graph, the end-to-end delay is shown inmilliseconds. The delay found in

the planned and peak bandwidths are shown as the first two bars in the graph.
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Figure 75: End-to-End Delay

Find Demands Filter

Click the Search by Property button in the Demands window to open the Find Demands

window. The Find Demands window is a utility for filtering demands by matching the

fields entered. Fields that are left blank are ignored.
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Figure 76: Find DemandsWindow

The From fields indicate the starting Node, Site, Lata, Group, or Area. For example, if you

select Group this will find all the demands originating at a node in the selected topology

group. Select Flow ID to indicate a specific demand.

The Status section can be used to narrow down on the demands of a particular status.

For example, to view only the Unplaced demands, deselect the checkboxes for Placed

and Deactivated.

The Type field is used to hold many specific demand type parameters, separated by

commas. Pressing on theTypebuttonwill open theDemandTypeParameterGeneration

window, which can be used to help you automatically populate the Type field.

The Type field is used to hold many specific demand type parameters, separated by

commas. Pressing on theTypebuttonwill open theDemandTypeParameterGeneration

window, which can be used to help you automatically populate the Type field.

After youhaveenteredanydemandproperties in theFindDemandswindow, theprogram

willmatch thepropertiesenteredand returna listofdemandsmatching thoseproperties.

For example, if youwant to search for all demands thathaveabandwidthof5megabytes

both way, you would enter an “5M” in the A->Z and Z->A fields. Then click on the OK

button to retrieve the list of demands.

Tunnels

From themain menu select Network > Elements > Tunnels to open the Tunnels window.

153Copyright © 2018, Juniper Networks, Inc.

Chapter 8: Network Menu



Figure 77: TunnelsWindow Properties Tab

• Properties Tab on page 154

• Paths Tab on page 155

• Right-Click Menu Options on page 155

• Tunnel Type Parameter Generation on page 155

• Design Tab on page 157

• Virtual Trunk Tab on page 158

Properties Tab

DescriptionField

This is the bandwidth required by the tunnel.BW(J)

Indicates the type of the tunnel as specified in the Tunnel Attributes window. Youmay edit this field
by right-clicking on the table and selecting Edit Type.

Type(J)

Allows you to set the affinity/mask of the tunnel for Cisco, or the include all, exclude, and include-any
settings for Juniper Networks admin groups to prohibit particular tunnels from routing on trunks with
particular attributes (admin-groups). Trunk attributes effectively color the trunk, whereas a tunnel’s
affinity/mask or include-all, exclude, and include-any settings determine which color trunks the
tunnel is permitted to be placed upon. Youmay edit this field by right-clicking on the table and
selecting Edit Affinity/Mask for Cisco or Edit Include-All/Exclude/Include-Any for Juniper Networks.

Affinity/Mask (C)

IncludeAll/ Exclude/
IncludeAny (J)

The priority field of the circuit specification consists of two numbers separated by a comma (,), or a
back-slash (/). The first number defines the setup priority of the circuit, and the second number the
holding priority of the circuit. The holding priority should be at the same or lower priority as the setup
priority of the tunnel. It is assumed that this tunnel can only be bumped by a tunnel with a setup
priority higher than its holding priority.

Pri,Pre(J)

Displays any comments youmay wish to enter.Comment(J)
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Paths Tab

DescriptionField

This is the user-specified name of the route for this tunnel. If “Dynamic” is specified, the route is chosen
dynamically and you should not configure a path in that entry. Otherwise, you can specify a different path.

This field indicates the priority of this path/route in the “Opt” field. In the “Opt” field, IP/MPLSViewwill select
the smallest number to be the primary route. For example, youmay specify an Opt 2 for route “Backup1” and
Opt 5 for “Backup2”. IP/MPLSViewwill sort these two routes and select Backup1 to be the primary route since
its Opt is smaller.

Opt

This field displays the user-configured route/path for this tunnel.

• The route consists of a sequence of node IDs or names separated by “--”. Different delimiters are used to
mark the distance relationship between nodes. A listed configured route for a tunnel would be something
like “ATL--WDC--HOU--NYC”. Thismeans the path of the tunnel begins at nodeAtlanta, goes toWashington
DC, Houston, and terminates at node New York City.

Configured

Right-Click Menu Options

• ShowPath: Displays the current route and the defined routes (for example, primary

and backup) of the given tunnel in the topology map. If multiple tunnels are selected,

their primary paths are highlighted on the topology map, and the tunnel currently

selected in the path window is highlighted with a slightly different color.

• HighlightAll:Displayson theStandardmap the source todestinationpairs of all tunnels

listed in this window.

• Bottlenecks: Displays the location of the bottleneck in the console when a tunnel is

unplaced.

• BW_Ovhd: Displays the bandwidth used by the tunnel and also the actual bandwidth

allocated to the tunnel. This information is displayed in the console window.

• ShowTrafficLoad:Viewachartof the traffic loadperperiod in thenetworkasdescribed

in “Traffic Load” on page 150.

• PathTable:Whenselected, a tablewill appear displaying eachconfiguredor calculated

path that originates at the source node of this tunnel. Note that these paths are not

necessarily associatedwith the tunnel, and are not to be confusedwith the configured

or current path taken by the tunnel.

• All Configured Routes: This option displays on themap the configured routes for this

tunnel. If the path is dynamic rather than configured, you should use the Show Path

option instead. If there are multiple paths

• Aggregate Tunnels: View the total planned tunnel bandwidth between each node pair

in table format. See“Aggregate Demands/Tunnels” on page 172 for more information.

Tunnel Type Parameter Generation

Click theTypebutton in theAddorModifyDemandswindowtoaccessadditionaldemand

settings. Clicking OK causes the Type field to be populated with the corresponding
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keywords. Note that different parameters will appear for different hardware device

models.

General Tab

File FormatDescriptionField

ABS=absolute_metric
REL=relative_metric

A tunnel metric (absolute, relative or don’t care) used by IGP if Autoroute
Announce is checked.

Absolute: Use tunnel metric as is

Relative:Set tunnelmetric relative to IGPMetric (for example, 10wouldmean
tunnel metric = IGPmetric + 10)

Don’t Care: Tunnel metric defaults to IGPmetric.

Tunnel Metric

Specifies whether the tunnel is primary, secondary, or standby. This option
can be configured for a tunnel originating at a Juniper Networks router by
selecting Edit Type from the right-click menu of the bottom half of the Add
Tunnel or Modify Tunnel window.

Tunnel Option

NOAA (No Autoroute
Announce)
corresponds to not
selecting this
checkbox

Announces thepresenceof the tunnelby the routingprotocol.WhenAutoroute
announce is enabled, the IGP will include the tunnel in its shortest path
calculation when the tunnel is up

Autoroute Announce

GREGeneric Router EncapsulationGRE

0BWCisco feature. During reroute, the tunnel bandwidth is 0. If this is a backup
tunnel, then selecting this option would mean that bandwidth will not be
reserved from the link(s) for this tunnel.

Zero Backup
Bandwidth

If there was a policy class established and applied to this tunnel, it would
appear here. You can click on the down arrow and review all policies that
apply to the tunnel.

Policy Class

GBGB Tunnels can only be routed on trunks with available bandwidth in the
SubPool.

Guaranteed
Bandwidth-TE

Circuit cross-connect.Thismeans that this tunnel is cross-connectingbetween
two interfaces using CCC

CCC

NOBDNoBorderFlag.This is anartificial parameterused fordesign.Whenset, routing
will not follow OSPF constraints. That is, the whole network is treated like a
flat network.

No BD

NOCSPFIndicates that administrative groups/link attributes are ignored by this tunnel.No CSPF

IGPIf checked, the tunnel is routed using the current Interior Gateway Protocol’s
metric rather than the tunnelmetric. Thecurrent routingmethodcanbe found
in the Design Options, Path Placement options pane.

IGP
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File FormatDescriptionField

REOPTIndicates that the LSP can be automatically reoptimized if the existing path
becomes suboptimal.

Auto-Reoptimization

TMLT=templatenameSpecifies a configlet template in the $WANDL_HOME/data/templates or
/u/wandl/data/templates directory. This option allows you to select a
manually-generated template tobeused for theconfiglet generationprocess.
Select the directory in which this template file is saved.

Template

For the remainder of the fields and their file format, refer to the File Format Reference for

IP/MPLSView chapter, on the Demand/Traffic files.

Design Tab

File FormatDescriptionField

MAXDELAY=<delay>Themaximum delay allowed for this tunnel. Themax delay is calculated either
from thedelay inputtedon the links, or else the value set in theDelayParameters
section of the Design Options window (by default, 1ms per 100miles).

Max Delay

H<hopcount>Themaximum number of hops allowed for this tunnel.Max Hop

MAXCOST=<value>Themaximum total admin cost (sometimes referred to as “distance” or “admin
weight”) allowed for this tunnel. That is, the total admin cost of all the links that
the tunnel traverses should not exceed this value.

Max Cost

NODEDIV
LINKDIV
FACDIV

Allows you to specify path diversity requirements for tunnels with standby or
secondary paths. Select the desired level of diversity NODEDIV for node disjoint
paths
LINKDIV for link disjoint paths
FACDIV for facility/SRLG disjoint paths

Diverse Level

DSITEDIV
Ddivgroupnamewhere
divgroupname is the
name of a group of
tunnels forwhich diverse
paths is desired

If SITEDIV is selected, the programwill pair tunnels with the same originating
and terminating sites. Paired tunnels are routed diversely.

• This fieldcanalsobeused tospecify thenameofagroupof tunnels this tunnel
belongs to.Whenperformingdiversepathdesign, theprogramwill try todesign
the paths of the tunnels in this group to be diverse.

Diversity Group

3DIVIndicates that if there is a third path for this tunnel (for example, in the case of
one primary plus two secondary paths), that all three paths should be designed
to be diverse.

You should add an entry for the second and third path and then design the path
by selecting Design>Diverse Path Design for IP/MPLSView to design this path.

Tertiary Diverse

When there are two tunnelswith the same end nodes but in opposite directions,
the path routing will use the same set of links. Example, Tunnel1 source to
destination is NodeA to NodeZ, and Tunnel2 source to destination is NodeZ to
NodeA. Selecting Tunnel1-Tunnel2 as a symmetric pair group will place both
tunnels along the same set of links. In the tunnel file, the keyword is
PAIR=groupname in the type field. Tunnels in the same group are paired based
on the source and destination node.

Symmetric Pair
Group
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Virtual Trunk Tab

The Virtual Trunk tab is used to indicate traffic engineering tunnels advertised as links in

an IGP network (OSPF or ISIS) and to indicate the correspondingmetric assigned. Select

theVirtual Trunk checkbox in order to configure the relevant protocol, area, and/ormetric

for which the virtual trunk will apply.

For Cisco, the corresponding statement would be “showmpls traffic-eng

forwarding-adjacency”.

For Juniper Networks, the corresponding statement would be the “label-switched-path

namemetricmetric” statement under the hierarchcy level [edit protocols ospf area

area-id] or “label-switched-path name” under the hierarchy level [edit protocols isis]

VT or
VT_areanumber

If a tunnel is marked as a virtual trunk, it is known to other routers and itsmetric and available
bandwidth information is broadcast to other routers as if it were a link. Just as a link has
interfacesdefinedonbothends, two tunnels (one in eachdirection)mustbedefinedas virtual
trunks for this setting to take effect. Otherwise, the virtual trunk is perceived as being “down”.

Virtual
Trunk

TheOSPFareaassigned to theVirtual Trunk. This optionapplies only if Virtual Trunk is selected
and the network usesOSPF routing (as opposed to, say, ISIS routing). A tunnel that ismarked
as a virtual trunk is advertised as a link to other routers. If those routers perform OSPF area
routing, they need to knowwhat area this virtual trunk belongs to. Select the area from the
pull-down box.

Area

Sites

The Site window allows you to get more detailed information about currently defined

sites in the network. Sites represent node associations. These associations are typically

by physical location. If several nodes are located in the same area, such as in a building,

small campus, or in the samecallingarea, youmaywant to logically group these together

by site. This grouping is not necessarily related to the hardware design of a network.

Figure 78: SitesWindow
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• NodeDetails: Jumps to the Nodes view and displays nodes that belong to the selected

site.

• CreateGroup: Creates a group based on the nodes of the selected site. Opens an input

name dialog window for the new group.

• Add:OpensaAddSitedialogwindowfor inputting thenameof thenewsite, andvalues

of customized site user parameters.

• Modify:Modify a site or the site user parameters

• Delete: Deletes the selected site from the network.

Assigning Nodes to a Site

Nodesmaybeadded toasite fromtheNodeswindowbyusingeitherAddNodeorModify

Node functions. In the Add or Modify window, select the site from the Site ID drop down

menu.

User Parameters

User parameters allow you to define their own parameters for sites. Before entering in

values for site user parameters, these parameters must first be created under Modify >

User Parameters, in the Site tab. For more information on this feature, see the User

Parameters and Link Rules chapter of the Training Guide for IP/MPLSView.

SRLG

The SRLGwindow provides amethod of grouping links and/or nodes that are likely to

fail together if they fail at all. The facility definition is used in failure simulations where

accuratemodeling requires the simultaneous failure of specific links and/or nodes. It can

also be used for diverse path designwhere primary andbackuppaths for tunnels (Router

model) or 1+1 demands (SONETmodel) are required to be routed on facility-diverse

paths.

Facilities can be used to model SRLGs (shared risk link groups) when only specifying a

group of links. If several links travel over the same fiber, so that a fiber cut will break all

of them at once, it's good to define a facility containing those links. Facilities can also be

used to group together links on the same card. Another example of a facility is the set of

switches on one floor of a large data center, together with the links going into or out of

that floor.
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Figure 79: SRLGWindow

• Add:Opens the Add Facility windowwhich allows you to add a new facility and select

the nodes and links that belong to the facility.

• Modify:Opens the Modify Facility windowwhich allows you to modify the facility

groupings. Use themouse to highlight elements you desire to be in the selected facility.

Deselect those elements to be removed from the facility. There are multiple ways to

select elements. You can select nodes and/or links directly from the list provided. Click

the first element and then<Shift>-click the last element to select a range of elements.

<Ctrl>-click an element to toggle the selection of a particular element in the facility.

Alternatively, to add elements from themap, highlight the nodes and links on themap

(for example, selected by <Ctrl>-click or by drawing a box around a group of nodes

and links) and then click.Add fromMap. Anothermethod is to clickAddLinks fromFilter

and then enter in advanced filtering criteria as described in “Advanced Search” on

page 118.

• Delete: Deletes the selected facility group.

Owners

The Owners feature accessed by selecting Network > Elements > Owners allows you to

displaydetailedcircuit information for thecurrentlydefinedownergroups.By right-clicking

an Owner and selecting View Demands, information for the demands associated with

the currently selected owner can be displayed.

This feature isuseful for linkownership identification.Bydefininganownerandassociating

certain demands with that owner, the task of bandwidth reconciliation is simplified.

Service providers that carry the traffic of several companies use the owner feature to

quicklydetermine thedistributionof traffic in thenetwork. For example, abusinessowner

demands 1.544megabits/second bandwidth over a network. That business owner owns
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that 1.544megabit demand. The Owners information window allows you to see how

bandwidth in a network is allocated to all such business owners.

• ViewDemands:Selecting thisbuttondisplays theViewDemandswindow.Thiswindow

will appear only if the selected owner group has been assigned to a demand.

• Add:Opens the Add Owner dialog box which allows you to specify the name of the

new owner.

• Delete: Deletes the selected owner group.

Templates

Node Templates

The Node Template window accessed from Network > Elements > Element Templates

> Node, allows you to create sets of default values to expedite the addition of nodes.

Templates may be created andmodified by you and then used while in the Add Node

window.

• Add:Opens an Add Node Template window that allows you to add a new template.

• Modify:Opens the Modify Node Template window that allows you to modify the

selected template.

DescriptionField

The name identifying the template.Template namesmust be unique.Template Name

Generate the node ID using the specified prefix and number to create a unique node ID.Auto-Generate node ids

Defined prefix for generating node IDs.Prefix

Number fromwhich to start numberinggeneratednode IDs. Example: If Prefix is set to "COR"
and Start# "1", autogenerate node ID would create node ID "COR1", "COR2", "COR3", etc.

Start #

Generate the node name using the specified prefix and number to create a unique node
name.

Auto-Generate node names

Defined prefix for generating node names.Prefix

Number fromwhich to start numbering generated node names. Example: If Prefix is set to
"NODE"andStart# "1", autogenerate nodenameswould create node ID "NODE1", "NODE2",
"NODE3", etc.

Start #

Link Templates

The Link Templates accessed from Network > Elements > Element Templates > Link,

allow you to create sets of default values to aid in the addition or modification of links.

Templates may be created andmodified by you and then used in the Add Link window.

When saving the network environment, link templates are saved into the file

linktemplate.<runcode>.
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• Add: Opens an Add Link Template window that allows you to add a new template.

• Modify:Opens the Modify Link Template window to allow you to makemodifications

to the selected template. You should select the desired template formodification from

the Template list found on the right of the Link Templates window.

DescriptionField

The name identifying the template. Template namesmust be unique.Template Name

Generate the link name using the specified prefix and number to create a unique link name.Auto Generate Link names

Defined prefix for generating link names.Prefix

Number fromwhich to start numbering generated link names. Example: If Prefix is set to
"LINK" and Start# "1", autogenerate node names would create node ID "LINK1", "LINK2",
"LINK3", etc.

Start #

Demand Templates

The Demand Templates accessed from Network > Elements > Element Templates >

Demand, allows you to create sets of default values to aid in the addition ormodification

of demands. Templates may be created andmodified by you and then used in the Add

Multiple Demands windows.

• Add:Opens anAddDemandTemplatewindow that allows you to add a new template.

• Modify:Opens the Modify Demand Template window that allows you to modify the

selected template.

DescriptionField

The name identifying the template. Template namesmust be unique.Template Name

Select a owner for this demand. Ownership is defined in the Owners option of the Modify menu.Owner

Specifies the count of the demand.Count

Specify the bandwidth required by the demand. Demand overhead is automatically calculated by
the program.

BW

Indicates the type of the demand.Type

The priority field of the circuit specification consists of two numbers separated by a comma (,), or
a forward-slash (/). The first number defines the call priority of the circuit, and the second number
the preempt priority of the circuit. The preempt priority should be at the same or lower priority as
the call priority of the circuit. It is assumed that this circuit can bump any of the circuit with call
priority lower than the preempt priority.

pri,pre

Specify any comments youmay wish to enter.comment

Tunnel Templates
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The Tunnel Templates accessed from Network > Elements > Element Templates >

Tunnel, allows you to create sets of default values to aid in the addition or modification

of tunnels. Templates may be created andmodified by you and then used in the Add

Multiple Tunnels windows. The tunnel template is similar to the demand template, but

includes some tunnel-specific properties in the Type field. Refer to the Router Feature

Guide For NPAT and IP/MPLSView for more details on these settings.

OSPF Areas/Domains

The OSPF Areas/Domains option allows you to view existing area or domain definitions.

Depending on the hardware type, this option will appear as either “area” or “domain”.

They both have the same options, so for the sake of simplicity in this document, we will

refer to “area” only. Keep in mind that it also applies to domains.

NOTE: This feature requires a license. Please contact your Juniper Networks
representative for more information.

Areas are network partitions designed to make the network more scalable. Network

summary information is exchanged between two areas through gateways.

When you select Network > Protocols> OSPF Areas, the Areas information windowwill

appear. The first table displays the current area definitions while the second table lists

the nodes and links in the currently selected area.

• Node Details:When this menu is selected, the Nodes view will appear and display

information regarding the nodes in the selected domain/area.

• LinkDetails:When thismenu is selected, the Links viewwindowwill appear anddisplay

information regarding the links in the selected domain/area.

• Create Group: This menu will create a group for the nodes in the selected area.

• Add:Opensdialogat the topof thewindowwhichallowsyou toaddanewdomain/area.

• Delete: Deletes the selected area in this window.

Link OSPF Settings

To enable OSPF for a link and to specify an area for a link, modify a link from the Links

window by selectingModify > Links. In the Protocols tab, set OSPF to “yes” and select

an Area.

QoSManager

TheQuality of ServiceManager displays CoS Forwarding Classes, CoSPolicies, and Rate

LimitPolicies in thenetwork.Use the left-panel tonavigate through the treeviewstructure.

The Summary view displays the total number of forwarding classes, CoS policies, nodes

with CoS policies, rate limit policies, and nodes with rate limit polices. For more details

on using Class of Service see the Router Feature Guide for IP/MPLSView.
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NOTE: Themaximum number of supported CoS classes is eight.

The Forwarding Class displays a list of the classes, CoS alias, primary classes, EXP bits,

IP Prec bits, and DSCP bits.

The CoS Policy displays a list, grouped by policy name or grouped by node, of the nodes,

policy names, policy types, and class mapping status. The Properties tab displays the

class weight or bandwidth, PIR, and Queue size of the node. The Interfaces tab displays

the interfaces with the polices of the node.

The Rate Limit Policy displays a list, grouped by policy name or grouped by node, of the

policer name, node name, classifier, number of interfaces, CIR, BC, PIR, BE, conformed

action, exceed action, and violate action. The Interfaces tab displays the interfaces with

the policies of the node. The Configlet tab displays the policy statements in the

configuration file of the node.

Figure 80: QoSManager

Service Type

The Service Typewindow accessed from themainmenuNetwork >More > Service Type

displays a list of service types defined by you. Service types are defined by you to be used

as a template when demands are created or modified. Once a service type is created,

you can select it to populate all the demand parameter fields when creating demands.

For more information on how to create and use service types, see the Training Guide for

IP/MPLSView .

• Add:Opens the Add Service Type window to create a new service type.

• Modify:Opens theModify Service Typewindow tomodify the selected existing service

type.
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• Delete: Deletes the selected service type from the network model.

DescriptionField

Displays the name of the service type. This name is specified by you.Name

Displays the owner for this demand. Owners are defined by selectingModify > Owners.Owner

These fields are only used with the Demand Generation feature (Traffic > Demand Generation >
General), during which newly generated demands of the given service type are ensured to have a
bandwidth between Min BW andMax BW. That is, a very large generated demand is split into smaller
pieces with amaximum bandwidth of Max BW.

Note:A license is required for thedemandgeneration feature. SeeChapter 11, “TrafficMenu”onpage203
for more information, as well as the Advanced Traffic Generation chapter of the Training Guide for
IP/MPLSView.

Min, Max BW

Displays the bandwidth required by the demand. Demand overhead is automatically calculated by the
program.

BW

Indicates the type of the demand for this service type.Type

The priority field of the circuit specification consists of two numbers separated by a comma (,), or a
forward-slash (/). The first number defines the call priority of the circuit, and the second number the
holding priority of the circuit.

pri,pre

Miscellaneous information that might be included in the service type file.Misc

Comments regarding this service type.Comment

This section displays all service types that have been defined by you.Services

AdminWeight

The AdminWeight window accessed from themain menu Network > More > Admin

Weight displays rules that can be used to set the default administrative weight (or link

metric) for links to influence routing.Note that the specificationofadministrativeweights

in this window is overridden by distances explicitly set in the bblink file or linkdist file. For

more informationon theorder ofprecedence, please seeSetting theAdministrativeWeight

in the File Format Reference for IP/MPLSView.

1. Youmust first specify criteria to match a desired set of links, such as protocol and

end node types.

2. Then, you should specify the values of the weight variables. The fixed and variable

weights determine how the link’s administrative weight is calculated. The formula is:

AdminWeight = FixedWeight + (Link Mileage * VariableWeight)

where Link Mileage is calculated by IP/MPLSView and is always in miles. Link Mileage

is based upon the “airlinemileage”, or geographical distance between two points. The

distance between two nodes is calculated based upon the coordinates in themuxloc

file. The coordinates may be derived from the NPA NXX values (for the United States

165Copyright © 2018, Juniper Networks, Inc.

Chapter 8: Network Menu



and Canada) or latitude and longitude values. See the File Format Reference for

IP/MPLSView for more details on the muxloc file format.

NOTE: If themuxloc file does not contain any coordinates, this will lead to
unpredictable results in the AdminWeight calculations.

• Add:Opens the Add AdminWeight windowwhich allows you to add a new

administrative weight rule to the network. the selected administrative weight rule(s).

• Modify:Opens the Modify AdminWeight windowwhich allows you to modify the

selected administrative weight rule(s).

• Delete: Deletes the selected administrative weight rule(s) from the network.

CustomRates

DescriptionField

Displays the protocol to which this particular administrative weight applies to. The protocol displayed
dependson theprotocols andhardwareused in thenetwork. For example, for a router networkpossible
values include “OSPF” or “ISIS”. For an ATM network, possible values include “ADMINWEIGHT” or
“PNNI” (PNNI requires a license). The default value is “ALL”, indicating no protocol constraint.

Protocol

The hardware type of the end point where the administrative weight is applied. For example, if this
column displays “ETHERNET” and the HWType2 column displays “ASNODE”, then the admin weight
is applied to all links originating at nodes designated with the “ETHERNET” hardware type and
terminating at nodes designated with the “ASNODE” hardware type.

HW Type1 and HW
Type2

Hierarchy levels CORE, REGULAR and ACCESS. These values are defined for each node in the Node
Propertieswindow.Corenodesarenodes residing in thecenter of thebackboneand receive theheaviest
traffic. Access nodes are either single-end or feeder nodes. (Single-end nodes only connect to one
other node (it is a nodewith a single neighbor). Feeder nodes only connect to one other node, and only
through one link (no parallel links to its single neighbor).) Regular nodes are all other nodes in the
network not considered core or access.

Hlevel1 and Hlevel2

Displays the trunk type for this administrative weight.Trunk

Indicates whether the administrative weight applies to links in the same site. A site represents node
associations. Theseassociationsare typically user-definedbyphysical location. See “Sites” onpage 158
formore information. If Same Site is set on “True”, then this administrative weight is applied to all links
within sites defined by you. “False” will apply this admin weight to links between sites. “Don’t Care”
will apply this admin weight to all links found in the network. Possible Values:

• INTER: between nodes in two sites, or from a node not belonging to any user-defined site to a
user-defined site

• INTRA: between nodes in the same site

• EXTRA: between nodes both of which are not in a site

• Don’t Care

Same Site

Indicates whether the administrative weight applies to links in the same peer group (if applicable).
This field appears only for hierarchical PNNI networks.

Same PeerGroup
(PNNI)
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DescriptionField

Displays the value of the fixed administrative weight.FixedWeight

Displays the value of the variable administrative weight.VariableWeight

The Custom Rates window accessed from themain menu Network > More > Custom

Rates > View Bands option is one of several methods of specifying link tariffs to price

the backbone links. A backbonedesign runwill add the necessary links to satisfy network

demandswhile optimizing the link tariffs. For a list of the other ways to specify link costs

and the order of precedence, see the File Format Reference for IP/MPLSView.

The window is divided into two halves. The upper half includes the link category, as

defined by the vendor, service (for example, OC3, OC12), and the tariff classes of the

link’s end-nodes. Additionally, it includes the non-recurring charge (install fee) for that

link category. The bottom half displays the recurring charges and can havemultiple rows

if the recurring charge is distance-dependent.

Figure 81: Custom RatesWindow

Link Category

The link category is defined by the link’s vendor, service (for example, OC3, OC12), and

the tariff classes of the link’s end-nodes. The tariff classes should be specified ahead of

time in the Custom Rates Class window (see “Custom Rates Class” on page 169). To

specify rateswithin the sameclass, the class specified in theclass1 andclass2 fieldwould
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be the same. Note that “ALL” is a reserved class name that applies to nodes of all tariff

classes and is used as a default unless the rate for a specific class is specified.

DescriptionField

Indicates the link vendor (for example, ATT, MCI, etc.) or DEF for defaultVendor

Indicates the link type. Valid link typesare: T1, E1, T2, T3, E3,HSSI, AIM,OC3,OC12,OC48,OC192,
STM1, STM4, etc.

Link Type

Indicates the class associated with the originating node.Class1

Indicates the class associated with the destination node.Class2

General Tariff Parameters

DescriptionField

This drop-downmenu allows you to choose the country currency to apply the tariff in. The default
is United States (US dollars).

Note: For the EURO currency (symbolized by “ER”), select ER EURO from the country list.

Currency

Specifies the unit which distance is measured in. Default distance is set to the MILE.Distance

Incremental distance. This is the unit that is used for calculating the cost as specified in the
incremental cost field.

Inc. Distance

Tariff Bands

DescriptionField

This is the non-recurring charge (NRC) for this link category. All other costs are recurring (for
example, monthly) charges.

Install Fee

Defines a distance band starting from the previous distance, or 0 if no other distances are listed.
The last distance value should be 9999 or higher.

Distance (up to)

Sets the fixed cost for this band. Fixed costs do not vary with distance.Fixed Cost

Sets the incremental cost that must be paid for each incremental distance unit (for example, 1
mile) of the link whose distance falls within this tariff band.

Inc. Cost

Calculating the Link Tariff

Todeterminea link’s tariff, theprogramfinds thematching link category. For thematching

link category, the program then uses the link’s distance (using airline mileage as an

approximation) todeterminewhichdistancebandwill apply. The recurring charge is then

determined by the fixed cost for that distance band plus a variable cost per distance
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increment. The formula is as follows:

Recurring_charge=Fixed_cost+(Inc_cost/Inc_dist)*linklength

where thevalueof Inc_costandFixed_costare taken fromthedistancebandwithinwhich

the link’s airline distance falls.

Add /Modify CustomRates

Click theAdd orModify button to add ormodify the custom tariff rates for a link category.

• Add Row: Adds a new row to the Bands table.

• Delete Row: Deletes the selected row in the Bands table.

Upon saving the network, the custom tariffs information is saved in the custrate.runcode

file. Tariff information can also be directly entered in from the text file. More details on

the file format can be found in “The Cost Files” chapter of the File Format Reference For

NPAT and IP/MPLSView.

CustomRates Class

The Custom Rates Class function allows you to view the existing custom rate classes

that are in the network model. Classes are defined by you for customer tariff purposes.

To add customer classes, select Network >More > CustomRate > View Classes and then

click the Add or Modify button. Class namesmay be up to ten characters in length.

To associate a custom rate class for each node in the network, go to the Nodes window

and use the Modify Nodes function. The custom rate and be applied in the Advanced

Properties tab, Custom Rate Class drop downmenu.

Path and Capacity

The Path and Capacity feature allows you to quickly determine whether sufficient

bandwidth exists in the network to place additional user demands. The program can

determineboth straightpathplacementanddiversity pathplacement formission-critical

traffic.When thePath&Capacityoption is selected fromtheNetworkmenu, the following

submenu is displayed.

DescriptionField

This option is used to determine if there is enough bandwidth for a circuit to be routed between a given
pair of nodes. These nodes can be selected by using the drop-down combo boxes in the Demand Path
window or by clicking the left mouse button on two nodes in the map window. To see if a path exists,
click on the Show Path button. If BW is not specified, then the default BW is 8000

Path

This option, available for Router networks, displays a round-trip path between a given pair of nodes. The
paths from Node A to Z and from Node Z to Amay differ because of asymmetric link costs/metrics,
whichmay or may not be desirable. Select the end nodes by using the drop-down selection boxes in the
Demand Paths AZ + ZAwindow or by clicking the left mouse button on two nodes in the map window.
Use the Round Trip Paths window to zoom into a segment of the path in either direction.

Paths AZ + ZA
(Router-only)
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DescriptionField

This option is used to find out if there is enough bandwidth to route two circuits in node disjoint paths
between a given pair of nodes. These nodes can be selected by using the drop-down combo boxes in
the Demand Path window or by clicking the left mouse button on two nodes in the map window. If it
cannot find nodedisjoint paths, the programwill look for edge disjoint paths. If it fails to find edgedisjoint
paths, it will search for paths with aminimum number of common nodes or edges.

Diverse Path

This option is used to find out if there is sufficient bandwidth to route a path between two selected sites.
You will first be prompted to select two nodes. These nodes can be selected by using the drop-down
combo boxes in the Demand Path window or by clicking the left mouse button on two nodes in themap
window. It will then check to see if there is enough bandwidth to place a path between the sites where
the two nodes are located.

Site Path

This option is used to determine if two node disjoint paths exist between sites.Site Diverse Path

This option sets each virtual circuit, as well as its assigned QoS, bandwidth, and calculated equivalent
capacity. This option is only available for router networks.

Equivalent Path

Selecting any of the Path & Capacity options displays a window similar to the following

whichwill allowyou to select twonodes for theprogramtodemandsufficientbandwidth

between them.

Figure 82:Window for Viewing Capacity

DescriptionField

Source and destination endpoints of the path analysisNode A and Z

Source and destination IPv4 addresses. You should enter an IP address that corresponds to one
of the node’s IP addresses or its interface’s IP addresses

IP Address A and Z

Source and destination IPv6 addresses. Requires separate license for IPv6.IPv6 Address A and Z*
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DescriptionField

Selecting an owner or VPN allows you to limit the nodes that are in the Node A and Node B
combo boxes to those with the selected owner/VPN.

Owner

Specifies the bandwidth of the demand. The programwill check if there is sufficient capacity
to route a demand of this size.

Note: For ATM networks, the bandwidth should only include the payload (not the overhead).

BW

The type field is a field from the demand file. Refer to the File Format Reference for IP/MPLSView
formore details. Clicking the Type buttonwill bring awindow to select specific options. Options
vary by hardware.

Type

Priority and preempt priority values for the demandpri,pre

Highlights the selected nodes A and Z on the topology map.Highlight Nodes

Highlights all of the nodes in the network on the topology map.Highlight All

Checks the path of a demand from node A to node Bwith the specified demand properties and
opens a Path Table showing each hop of the demand’s path.

Show Path

The following window appears after performing a path analysis, indicating details about

each step of the path:

Figure 83: PathsWindow

• SelectHideUnrelatedNodes to show on themap only those nodes and links along the

path.

• SelectHighlightSinglePathandselectClearPathHighlights to turnoff thepathhighlight

on themap.

• The Console displays information from the path analysis.

• The Map displays the path route.

171Copyright © 2018, Juniper Networks, Inc.

Chapter 8: Network Menu



ShowSite Demands

The Show Site Demands option is available from Network > Elements > Demands.

Right-click on a demand and select ShowSite Demands to display the site-to-site

demands on themap. The program calculates the total demand between two nodes

anddrawsa lineconnecting themaccording to thecolorsdescribed in the “BBload-Kbits”

legend,which is displayed inoneof the tabmenus in the left paneof the topologywindow.

Figure 84: Viewing Site Demands

This view of the topology map is useful since it provides the use a visual picture of the

demands found in the network. The utilization of each demand in displayed according

to the color found in the legend.

Aggregate Demands/Tunnels

The Aggregate Demands feature is accessible through Network > Elements > Demands.

Right-click on a demand and select Aggregate Demands. For each pair of nodes A and Z

in the network, the Aggregate Demands function adds up the total bandwidth of all the

demands starting at originating nodes A and destination nodes Z. Aggregate Demands

then presents a table with one row for each node pair, showing A, Z, and the total

bandwidth. The demands are sorted by bandwidth, the largest at the top.
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NOTE: For MPLS-enabled networks, there is a similar Aggregate Tunnels
feature, accessible by selectingNetwork > Elements > Tunnels. Right-click on

a tunnel and select Aggregate Tunnels. While reading this section, simply

replace each occurrence of “demand” with “tunnel”.

A license for tunnels is required to access the Aggreg Tunnels feature.

DescriptionField

When this option is checked, the row for A-Z includes the demands from Z to A as well as
A to Z. If it is not checked, there is one row for A-Z and one for Z-A.

Combine A-Z with Z-A

When this option is checked, Aggregate Demandswill only add up demands that have been
placed by the program in the current network model.

Place demands only

A network can have hundreds of thousands of node pairs. This option lets you see a
manageable number of the heaviest pairs of nodes.

Show at most

After specifying theAggregateDemandsparameters, theaggregateddemandbandwidth

is presented in a table form.

• Highlight All: This function highlights all node pairs in this table on the topology map.

• Report: This function saves the aggregate demands in a report on the server and client

machines.

OAM

The Operations, Administration, and Maintenance feature displays a list of nodes

configured with Ethernet OAM, connectivity-fault-management, and

link-fault-management in the network. Use the left-panel to navigate through the tree

viewstructure.TheSummaryviewdisplays theOAMelements:OAMnodes,Maintenance

Domains, and LFM. If there are no nodes in the network configuredwith CFM statements

in the configuration file, the OAM feature will not load.

The CFMdisplays a list, grouped by customers, operators, service providers, and devices;

of nodes, maintenance domains, levels, maintenance associations,

maintenance-end-points, remote maintenance-end-points, priorities, and interfaces

configured for connectivity-fault-management. Click the Node name or Highlight to

highlight the node on the Map window, or click Highlight All to highlight all nodes. Use

the Filter text field o filter queries from the top-panel.

The LFM displays a list of the links, Node A, Interface A, MAC A, Node Z, Interface Z, and

MAC Z configured for link-fault-management. Click the Node A or Node Z name or

Highlight to highlight the node on the Map window, or click Highlight All to highlight all

nodes. Use the Filter text field o filter queries from the top-panel.
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Figure 85: OAM

Right-click on a node in the top right panel to open a pop-up submenu. The available

selections are shortcuts to selecting Network > Elements Nodes, Run CLI Commands,

Show Config, Ping Advance, and Traceroute Advance.
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CHAPTER 9

Design Menu

The Design menu allows you to access functions related to the backbone topology of

the network. You can perform demand and tunnel path design, rerouting, sizing; and

network resizing, optimization and analysis.

For information about FRR Design, Tunnel Sizing, T-Solve, and Auto Tunnel Design see

the Router Feature Guide for IP/MPLSView.

• Backbone Design on page 175

• Net Groom on page 178

• Route OptimizationWizard on page 180

• Path Diversity Design on page 183

• Configlets/Delta on page 190

• Metric Optimization on page 191

Backbone Design

• Resize on page 175

• Route Paths on page 177

Resize

The Design > Backbone > Resize option may be used to tune and optimize the current

backbone topology. Links can be resized based on normal link utilization or peak link

utilization based on failure simulation results. When the resize option is performed,

IP/MPLSView replaces links in the network based on the Link TypeCandidate in theTools

> Options > Resize window.

• Types in Tariff: Valid link types are taken from the current tariff table

• AGGR(xGb): Valid link types are based onmultiples of 1G with default set to 10G.

Once you have selected the valid link types for the resize, you can choose to resize based

on

• The peak link utilizations of the latest failure simulation performed

• The current link utilization when not under failure
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• You can also automatically run exhaustive failure simulation for nodes, links, and

SRLGs, and then resize the links accordingly.

Figure 86: Resize Options

Make your selection (or selectQuit to cancel). Then click theOK button. The following

windowwill provide resize recommendations based on the previously selected Resize

options.

Figure 87: Resize Recommendations

The choices are as follows:

• No Action

• Update All Links: Update all links’ trunk types based on recommendations

• UpdateOverloaded LinksOnly:Update only the links’ trunk typeswhich have utilization

above 100%. In other words, trunk types will only be upgraded to higher bandwidths

and not downgraded.

• View Changes or Update Selected Links:Manually select which links are to be resized.

• Remove All Changes resets the links trunk types back to their original size.
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Figure 88: Resize Links

The Resize Links windows allowsmanually selecting the links to be resized. Once a row

is selected, the columns at right are activated so that the trunk type (NewType) and

count (NewCount) can bemodified if necessary. Then select Resize Selected Links. In

the subsequent window, click Quit to exit from themain menu. The trunk types of the

selected links are then resized.

Route Paths

Route FromScratch

The Design > Demands > Route Paths > Route From Scratch option removes demand

path placements from the network and reroutes all the demands from scratch in

sequential order. The Design > TE Tunnels > Route Paths > Route From Scratch option

works similarly but for TE Tunnels.

Tuning

With thecurrentpaths remaining inplace, theTuningoptionperformsa local optimization

of path placement on the network. If there is sufficient bandwidth, path placement is

performed on the network for the selected paths:

Tune All Paths

The programwill try to place unplaced demands and improve on already placed paths.

Tune Unplaced Paths

The programwill try to place only unplaced demands.

Restore

Resets the paths of demands as specified in the input demand file.

Remove

Removes all placed demands from the network.

Remove Configured Paths
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Removes all configured paths (Path Select, Path Required) and reroutes them

dynamically.

Net Groom

Due to the dynamic rerouting of demands/designs during node or link failures, demand

placement in the network may gradually become sub-optimal. The Design > Demands

> Net Groom and Design > TE Tunnels > Net Groom option finds the best path for each

demand(or tunnel)usingexistingnetworkbandwidth (withoutpreemption)anddisplays

these demands. Net Groom reroutes paths to minimize the distancemetric of the paths

using available bandwidth in the network.

Figure 89: Net Groom - Fetch DemandsWindow

• Filter: Opens the Find Nodes windowwhich allows user to select nodes based on

various parameters and add them to the list of nodes for net groom.

• Filter FromMap: Adds the selected nodes from the Map window to the list of nodes

for net groom.

• Remove: Removes the selected node(s) from the list of nodes for net groom.

• Read From File: Allows user to import a list of source nodes for the demands from a

file on the server. The format of this file is simply a list of node IDs - one per line.

• Set Routing Method: Brings up the console and allows you to specify which variables

to use when calculating optimal placement of demands.

• OK: Applies the current settings and brings up the Net Groomwindow.
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• Close: Closes the window and discards all settings.

• Help: Directs you to the online help documents for this window.

DescriptionField

Specifies the type of demand to optimizeDemand Type

Specifies the maximum bandwidth of demands to optimizeMax BW

Specifies maximum priority of demands to optimizeMax Priority

Selects which types of links to use when optimizing demands.Use links of this status when finding new
routes

Anydemands thatwill not achieveagain in adminweight larger than this value
when optimized will not be optimized

Min AW gain needed to use new route

Specifies whether or not the original path of the demand being optimized is
factored into the network when optimizing a demand

Release BW on current route before finding
new route

Specifies how the demands are sorted when a report is generated on the
optimized demands.

Sort demands in report by

Figure 90: Net GroomWindow After Optimization

• Optimize Selected Demands:Optimizes the selected demands.

• Optimize All:Optimizes all demands in the table, including those not shown on the

current page.

• View Paths: View the original, best, and new (if demand is optimized) paths of the

selected demand

• View Report: Brings up a report window detailing the optimized demand weights and

paths.
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• Close: Closes the window.

• Help: Directs you to the help documents for this window.

DescriptionField

The name of the demandName

The source node of the demandNode A

The destination node of the demandNode Z

Total bandwidth of the demandBW

The admin weight of the demand prior to optimizationOrig AW

The best possible admin weight for the demand if there were no other demands in the
network

Best AW

The difference between Orig AW and Best AWBest AWGain

The optimal admin weight for the demand, taking into account the other demands in the
network.

New AW

The difference between Orig AW and New AWAWGain

The original path of the demandOrig Path

The best possible path of the demand if there were no other demands in the network.Best Path

The optimal path for the demand, taking into account the other demands in the network.New Path

After a Net Groom session has been performed and the network has been saved, the

following parameters are added into the network’s dparam file:

• netgroom_demandtype

• netgroom_maxpriority

• netgroom_minawgain

• netgroom_linkstatus

• netgroom_releasebw

• netgroom_reportorder

Route OptimizationWizard

Use the route optimization wizard, by selecting Design > Demands > Route Optimization

or Design > TE Tunnels > Route Optimization to modify link metrics, to view the
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demands/tunnels thatare reroutedasa result, and tohave theoption toundo thechanges

if undesired.

Figure 91: Route OptimizationWizard Instructions

Clicking Nextprovides the option to modify link metrics.

Figure 92: Link Metrics

You can select the row(s) of your choice and clickModify Metrics... to change a set of

links to have a specific metric. This can be donemultiple times to modify different links.

When all the changes are made, clicking Nextwill indicate the changed routes without

committing the link changes.
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Figure 93: Changed Routes

DescriptionColumn

The Demand’s name and source and destination nodesName

NodeA

NodeZ

The specification of the path for the old and new routes.Orig Path

New Path

The path cost for the old and new routes, equal to the sumof the linkmetrics
(and nodemetrics, if applicable) traversed by the demand

Orig Path Cost

New Path Cost

The hop count for the old route and new routeOrig # Hops

New # Hops

DescriptionOption

Highlight the new route on themapShow Paths...

Save the contents of this table to a CSV fileReport...

Clicking Next again will provide you the option to save or undo changes.
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Figure 94: Save Changes

Path Diversity Design

Use Path Diversity Design by selecting Design > Demands > Path Design or Design > TE

Tunnels > Path Design to automatically configure two paths to be on diverse routes. This

feature is available for demand paths in ATM networks and Optical Transport networks,

as well as LSP tunnel paths in MPLS-enabled networks.

For MPLS-enabled networks, refer to the Path Diversity Design chapter of the Router

Feature Guide for IP/MPLSView for more information on adding diverse standby and

secondary paths.

NOTE: This feature requires a license. Please ask your Juniper Networks
representative for more information.

After selectingDesign >Demands >PathDesign orDesign >TETunnels >PathDesign, the

Diverse Paths window is opened with a list of demands (for ATM/optical networks) or

tunnels (for IP/MPLS networks) that have diversity requirements.
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Figure 95: Diverse PathsWindow

Tune

• To perform a diversity design, either select Tune > All Paths to design on all entries, or

Tune > Selected Paths to tune the diversity for only selected entries.

• A sort can be performed on the Actual Div Level column to tune only entries that are

not at the desired diversity level. A new placement is considered better than an old

placement if either of the following conditions is true:

• The new placement is at a higher diversity level than the old placement, or

• The new placement is at the same diversity level as the old placement, but the total

length of the new path is less than the total length of the old path.

Copyright © 2018, Juniper Networks, Inc.184

IP/MPLSView Java-based Graphical User Interface Reference



Figure 96: Diverse Path DesignWindow

DescriptionField

Indicate the default level of path diversity to aim for. Available options include facility, link, or site
(“divgrouplevel” in the dparam file). Note: For IP/MPLS networks, the targeted diversity level can be set on
a per-tunnel basis by modifying the Tunnel Type Parameter window, Diversity tab, and will override the
default for those particular tunnels.

Default
Diversity Level

(Router only) Indicate howmany backup paths you want to add by selecting Add if missing for the backup
paths you would like to add. Additionally, select the type of backup path to add (standby or secondary) and
whether it should be Dynamic (loose) or Explicit (strict/nailed-down routing).

• Selecting Add if missing creates new backup paths andmodify existing backup paths. Selecting Change
only existing backup only modifies existing backup paths.

• Select Preserve secondary/standby settings of existing tunnels to prevent existing backup paths from
changing the backup path type from secondary to standby or from standby to secondary. This option
should usually be checked, in which case the backup path type settings only applies to added backup
paths.

To specify a requirement for tertiary diverse paths, select Add if missing and Explicit for both Backup Path #1
and Backup Path #2.

Backup Path
Config Options
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DescriptionField

Options may vary according to hardware type.

• Remove configured paths before tuning:

Select this in order to allowmodification of already existing paths. If a path is set to required, the program
will not attempt to find a path satisfying diversity even if that path does not already satisfy diversity. If you
change the current paths from Required to Preferred, the program can change the path, if necessary to
satisfy diversity.

• Mark new paths as configured:

After the paths are designed, the resulting path are marked as path required (corresponds to PR flag in
the demand type field). Recall that a required path, as opposed to a “preferred” path, will only route on
the specified path. If that path is not available, the demand/tunnel is not placed.

• Mark new paths as preferred:

After the paths are designed, paths are marked as path preferred (corresponds to PS flag in the demand
type field).

NOTE: If you do not mark a secondary path configured or preferred, the current path specification will not
be recorded when you save the demand/tunnel file or network environment. If you choose not to mark it
configured or preferred at this time, you can still do so afterwards through the Design > TE Tunnels > Route
Paths > Interactive Modemenu (option Update Preferred Path Setting, 3. Use current routes as
preferred/required routes). (On the contrary, the current path specification with standby paths are recorded
even if not configured because they are given separate demand/tunnel entries of their own.)

Path Config.
Options
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Figure 97: Advanced Options

DescriptionField

Thebackuppath’sbandwidthcanbeconfiguredasapercentageof theprimarypathbandwidth
plus a fixed bandwidth,

Backup Path Bandwidth

This specifies howmuch bandwidth is already reserve as a percentage of the link’s bandwidth
(fat%) plus a fixed bandwidth (fatpct and fixfat in the dparam file). This information is for
reference only. Tomodify it, select Tools > Options > Design, Reserved Bandwidth options
pane.

Link Reservation Parameters

MPLS-EnabledModesetsall links tobempls enabledor uses thecurrentmpls settingsdefined
on each link.

• Option to allow path intersections at No FAIL nodes and links to be considered diverse. The
No FAIL flag on nodes and links can be set in Modify mode by setting Fail=0 toTrue.

Path Placement Options

Modify Options

Tomodify tunnel backup paths or diversity requirements, selectModify > All Paths or

Modify > Selected Paths.
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Figure 98: Path Design: Tunnel Modification

DescriptionField

Use the Configured Diversity Level menu to specify per tunnel diversity level requirements. This
will override the Default Diversity Level.

• SelectReplaceExplicitwithDynamic to change theprimary tunnel fromanexplicit toadynamic
route.

General Path Options

Demands or tunnels in the same Diversity Group are paired off and then designed for diversity.
Select a name for the Div Group.

• The special Div Group SITEPAIR is a reserved group. For demands or tunnels in the group
SITEPAIR, those sharing the same source and destination sites are paired together.

Diversity Group
Configuration Options

The “Max # Backup Paths” specifies can be used to limit the number of backup paths. For
example, specifying a Max # Backup Paths of 0 will delete all the backup paths for the existing
tunnel.

• Use the “Backup Path Type” option to specify per tunnel backup path type requirements (for
example, Standby vs. Secondary). This will override the Default Backup Type.

• Use the “Tertiary Path Option” to specify tertiary diversity requirements (Add 3DIV or Remove
3DIV)

Backup Path Configuration
Options

View/Tune PathsWindow

After designing or tuning the paths in the Diverse Path Table, click on any of the following

buttons to view details regarding the current diversity status for the selected demand

(or tunnel):
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• ShowPaths: A Path windowwill open to highlight in different colors on themap the

two diverse paths, if any (or three diverse paths, in the case of 3DIV).

• View Path Details:Opens up the Demand or Tunnel window to view details on the

selected demand/tunnel. Select the Paths tab of the first entry to display the details

of the diverse paths, if any, including secondary/standby paths.

• Filter button: A text filter and advanced filter option are provided to filter out only

desired entries of the table based on user-defined criteria. Use the previous or next

page to navigate if there are more than 100 entries. Note that when performing a text

filter as opposed to the Advanced Filter, each result is a successive filter. Use “*” to

refresh the table before performing a new search.

• Action > Report: Saves the Diverse Paths table to a comma-separated file.

• Action > LSP DeltaWizard: Provides a shortcut to the LSP DeltaWizard to generate

LSP delta configlets (offline module) or create a provisioning order (provisioning

module only)

• Action> ImportDivPathDefinition file:TheDivGroup settings exported by selecting File

> Save Network File > Tunnels to usertunneldef.runcode can be imported from this

option.

The file format is as follows:

#NodeName TunnelName DivGroupName
BOS,RBOSWDC,test
WDC,RWDCBOS,test
ATL,RATLCHI,test
HOU,RHOUWDC,test

Additional Notes for the Router Module

When selecting View Path Details, if you designed for standby paths, they are displayed

as additional demands/tunnels and STANDBY are listed in the type field of the new

demand/tunnel.

If youdesigned for secondarypaths, this information isdisplayed in the same tunnel entry

as theprimarypath.TheSecondary fieldwill give thepathnameof thenewpath.However,

a path namemay not be created for you. In that case, click on the Details button for a

demand/tunnel. Your secondary path are listed in the paths associated with the

demand/tunnel. If you enter a path name in modify mode, the name is displayed under

the Secondary field. A secondary path’s path specification will only be displayed if the

path is preferred or required.

You can also see the new paths from the Report Manager. Select Network Reports >

Demand Reports > Demand Path & Diversity (or Tunnel Layer Reports > Tunnel Reports >

Tunnel Path & Diversity. In this report, each path has its own entry. The type field will say

SECONDARY or STANDBY if present. It will say PR(path_specification) or

PS(path_specification) where path_specification is replaced by an actual path

specification (nodes separated by dashes), if the pathwas set to be required or preferred

(PR for path required, PS for path select).

189Copyright © 2018, Juniper Networks, Inc.

Chapter 9: Design Menu



Below are the possible columns in this table. Column namesmay vary depending on the

hardware model. If a column name is missing, right-click on the column header, select

Table Options, and select which columns to display.

DescriptionField

Name of the group of paths which should be designed to be diverse. For IP/MPLS networks with
Standby/Secondary paths, the tunnel name is used for the group name.

Group Name

Names up to three paths that form the diverse group, which the programwill try to route along
diverse paths

Path1 Name

Path2 Name

Path3 Name

Indicates the group type. For example, secondary/standby (router only), 1+1, VCAT (transport
only), or DivGroup (for a user-defined diverse group)

Div Type

Indicates current level of diversity satisfied (for example, NO_DIVERSITY, SITE, LINK) or if the
path is unplaced. Note that the Actual Div Level considers also access nodes.

NOTE: Only one type of diversity is listed. If one includes the other, the more inclusive category
is listed (for example, site diversity implies link diversity, so it is sufficient to indicate site diversity).
In the case where both are satisfied but one does not include the other, still only one is listed. For
example, if site and facility diversity are satisfied, only site diversity is listed.

Div Level

Actual Div Level

(IP/MPLS only). Indicates the configured target diversity level if configured on a per tunnel basis,
for example, through the Tunnel Type Parameter Generation window, Diverse Level drop-down
box.

Config Div Level

Indicates if tertiary diversity is desired. For IP/MPLS networks, to design a tunnel to have one
primary and 2 secondary paths that are all diverse, this setting should be set for the tunnel and
an entry should be created for each path for the program to configure during the Path Design.

3Div

For Path1, Path2, and Path3 are indicated the source and destination nodes, sites containing
source and destination nodes, primary bandwidth, and priority/preempt setting. Not all of these
fields are displayed by default. Right-click the table column header and select Table Options... to
turn on the display of these columns.

NodeA, NodeZ, Site A,
SiteZ, BW, PriPre

The current paths of the demands/tunnels for Path1, Path2, and Path3Current Path

The configured paths of the two demands/tunnels for Path1, Path2, and Path3Config Path

Configlets/Delta

LSP DeltaWizard (IP/MPLS only)

The LSP DeltaWizard is used to compare LSP configurations in the baseline network

with LSP configurations in the current network, and to create CSV and XML reports of

the differences. Refer to the LSP DeltaWizard chapter of the Router Feature Guide for

IP/MPLSView (IP/MPLS only) for further details.

LSP/VPN/Switch Configlet (IP/MPLS only)
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LSP, VPN, and switch configlets can be generated based onmodifications made to LSP

tunnels, VPNs, and switches in the software. The configlet generation is available in the

Design action mode. Refer to the LSP Generation and Virtual Private Networks chapters

of the Router Feature Guide for IP/MPLSView for further details.

Metric Optimization

NOTE: Metric Optimization is available for router networks.

TheDesign>MetricOptimizationoptionattempts tooptimize the linkmetrics
to remove congestion from the network. Upon selecting this option, awizard
guidesyou toselect thecandidate links thatcanbechangedandanalgorithm
touse foroptimizing theirmetrics.Once theoperation is complete, themetric
changes are reported in METRICBAL.runcode, where runcode is the file
extensionusedbyyournetworkproject specification file. The report indicates
thenumberof linkswhosemetricshavebeenchanged, theoldandnewworst
case utilization, and the old and newmetric values for modified links. You
have the option to review the link changes and rerouted demands and to
accept or discard the newmetric changes. After accepting the newmetric
changes, you can save themetrics by saving the entire network or savingonly
thebblink file using File >SaveNetwork File > Links. If youwish to revert back
to your original link metrics, simply read in the original bblink file using the
File > Load Network Files window. Click on the “Network Files” tab, and then
press the bblink button to browse for the original link file.

For further details, refer to the Router Feature Guide for IP/MPLSView.
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CHAPTER 10

Simulation Menu

TheSimulationmenu is used to runvarious failure scenarios. Youcanperformsimulations

on both new and existing designs to determine resiliency in the backbone. By default,

IP/MPLSView simulation mimics the actual hardware. However, you can also adjust

simulation parameters for experimentation and “what-if” purposes.

• Failure Analysis on page 193

• Predefined Scenarios on page 194

• Scripts on page 194

• Report Options on page 196

• Advanced Options on page 198

• Interactive Scenarios on page 199

Failure Analysis

In Failure Analysis, path provisioning simulates the hardware's implementation of

bandwidthallocationanddemand routingon theexisting topology.Youcan run interactive

simulations or simulation scripts (predefined or user-created). In addition, you can try

simulating path placement for several iterations to see what impact demand path

placement and demand routing order have on the network.

By default, IP/MPLSView failure simulationwillmimic the actual hardware ( for example,

in routing, max hop, etc.). However, you can adjust simulation parameters for

experimentation purposes.

ThesecanbeaccessedbyselectingTools>Options>FailureSimulation, andaredescribed

indetail in “FailureSimulationOptions”onpage357. Inaddition toPathPlacementcontrols,

these options also control certain aspects of the Failure Analysis and Reporting.

Failure analysis reports can be generated for the following cases:

• Single Line Failure Report - simulation report for each single line failure

• Link Failure Report - simulation report for each link failure

• Node Failure Report - simulation report for each single node failure at every site for

each vendor
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• RandomDaily Failure Report - simulation report for randomly generatedmulti-link or

multi-vendor failure scenarios

• Replay Up-Down Sequences Report - simulation report for any link/node/vendor up

or down sequence

Predefined Scenarios

Scripted simulationsarepredefined simulation scenarios,whichprovideaquick andeasy

way for you to test the network's resiliency to various failures. For each script, a failure

report is automatically generated.

NOTE: Before running a scripted, or batch simulation, be sure to review your
failure simulation option settings. These can be accessed by selecting Tools

>Options>FailureSimulation, andaredescribed indetail in “FailureSimulation

Options” on page 357. By default, an exhaustive failure simulationwill fail all
elements one for each simulation. To specify not to fail certain nodesor links,
firstmodify the node (Design Properties tab) or link (Properties tab) and set
FAIL=0 to true.

Scripts

Exhaustive Single Element Failures

The exhaustive single failure scripts fail all network elements of a given type, one at a

time.

Figure 99: Single Failure SimulationWindow

• Exhaustive Node Failure: Exhaustively fails every single node in the network.

• Exhaustive Link Failure: Exhaustively fails every single trunk in the network.
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• Exhaustive Site Failure: Exhaustively fails all sites in the network. A site file is required

to define nodes within the same site. Nodes that are not grouped within a site are

considered sites by themselves.

• ExhaustiveSlotFailure:Exhaustively fails all slots that aredefined in thenetwork (router

networks only).

• Exhaustive Card Failure: Exhaustively fails all cards that are defined in the network. For

all ATMnetworks, cards can be specified in the definition of links. Go to the Links detail

tabandselect theLocation tab. For certain routermodels, cards canbedefined through

the Equipment View feature. Select Inventory > Hardware Inventory, or right-click on a

nodeandselectView>EquipmentView. Note that theHardwareModel feature requires

a license.

• Exhaustive SRLG/Facility Failure: Fails all facilities. A facility file is required to define

node and trunk facility associations. Trunks that are not associated with a facility are

considered to be facilities by themselves.

• Exhaustive Parallel Links Failure: Exhaustively fails all trunks between all node pairs.

• Exhaustive Voice Trunk Group Failure: (Requires a license for voice). Exhaustively fails

all voice trunk groups defined in the network. Select Network > Voice > Trunk Group to

examine the trunk groups in your network. Addition of trunk groups through the Java

user interface is not supported at this time, althoughmodification is supported. To

define trunk groups, the trunk group file should be edited through a text editor.

Reports

• The Peak Link Utilization Report (Simulation Reports > Network Statistics > Peak Link

Utilization) records the maximum trunk utilization for each trunk during the period of

all the selected simulations and the element whose failure triggered this maximum

utilization. Peak utilization is reset each time predefined scenarios are run. See

“SimulationReports”onpage337 fordetailson this report. The resultingpeakutilizations

can also be viewed graphically on the Standard map by selecting Utilization Legends

> Peak Util.

• PeakSimLink:ThePeakSimLink report containsdetailed informationonoversubscribed

links after the exhaustive failure simulation.

• PeakSimRoute:The PeakSimRoute report contains detailed information of failed

demands or tunnels.

• PeakSimReroute:ThePeakSimReroute report containsdetailed information for rerouted

demands or tunnels. To generate this report, select Generate Detailed Reroute Report

from the Options tab.

• PeakSimSummary:ThePeakSimSummary report containsasummaryofall exhaustive

failure simulations performed.

Exhaustive Multiple Element Failures
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Figure 100: Multiple Failure SimulationWindow

To run an exhaustive failure script for the simultaneous failure of 2 or 3 elements, select

theMultiple Failure tab. Select the number of elements to be failed together (Double or

Triple), select the Exhaustive radio button, and then select the element type to be failed

(node, link, etc.) for the Failures Type. For example, selecting Double, Exhaustive Failure,

for the Failure Types: Node and Link and then clicking the Run button will result in an

exhaustive failure simulation of node & node, node & link, and link & link combinations.

To randomly simulate a specified number of double or triple failures, rather than all

possible failure combinations exhaustively, select “Cases to Simulate” instead of

Exhaustive Failure, and enter the number of cases to simulate.

Report Options

Figure 101: Report Options
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• IncludeSimulationEvents for all Periods: In the Peak LinkUtilization report, information

is provided regarding the event triggering the peak link utilization, indicating which

failure type triggered the peak link simulation (for example, node, link, or facility) and

the name of the element.With this option unchecked, the simulation event is reported

only for the planned period (based on the demand file) and worst failure scenario

among the periods of the trafficload file. If this option is checked, the simulation event

is also displayed for all of the individual periods (up to 24).

• GenerateDemandOverTunnelUtilizationReport:This optionwill generate theDemand

Traffic on Tunnel report in the Tunnel layer reports.

• Generate PeakGroupTransit Statistics:Records themaximumnumber and bandwidth

of demands transiting through a topology group. This information is displayed in the

Group > Group Demand Bandwidth Distribution report of the Report Manager. These

statistics can also be turned on by first setting CheckTransitDemandLimit=2 in the

dparam file before opening the specification file.

• Generate SRLG and Up-Down Sequence for Upper Layer: Selecting this option will

generate a report, UPDOWN.runcode, which lists the demands or tunnels that went

down during the simulation. This report is often used as an Up-Down Sequence File in

an upper layer network inwhich the demands of the lower layer network are translated

into links in the upper layer network. Thus, the demands that are reported as being

down in theUPDOWN.runcode report canbe read inasdowned links inacustomfailure

simulation script for anupper layer network. Additionally, anSRLG file is created, based

on the set of demands of the lower layer (links of the upper layer) which go down

together.

• Generate Detailed Reroute Information: Report detailed information on demands that

rerouted during the failure simulation.

Related
Documentation

•
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Advanced Options

Figure 102: Advanced Options

Fast Reroute Options

(Router networks only): See the Fast Reroute chapter of the Router Feature Guide for

IP/MPLSView for more information.

NOTE: The Fast Reroute feature requires a license. Contact your Juniper
Networks representative for assistance and further information.

Replay Up-Down Sequence

Use a custom failure simulation script. The file name of the script must be specified. An

example of a custom failure simulation script is provided below:

Link1 down
Link2 down
RESET
Link3 down
Link4 down
RESET LINK
Link5 down
Link6 down
WAIT
Node1 down
Node2 down
RESET

Before you run an up-down sequence simulation, youmust first specify whether to

simulate Every Event or to simulateWhenWAIT/RESET is Encountered. Assuming the

latter, in the above example, Link1 and Link2 is brought down first.
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At theRESET line, theprogramwill attempt to routeall unplaceddemands in thenetwork

(and generate the appropriate reports), after which all links are brought back up and all

demands are placed back in their original paths. The programwill then fail Link3 and

Link4. Upon seeing the RESET LINK line, the programwill again attempt to route all

affected and unplaced demands in the network (and append the appropriate reports),

after which all links are brought back up.

However, this time, the demands will not be placed back in their original paths; instead,

the demandswill remain routed according to the paths foundwhile Link3 and Link4were

down. The programwill then go on to fail Link5 and Link6. At theWAIT line, the program

will attempt to route all unplaced demands (and append the appropriate reports), but

will not bring up any links afterwards. Node1 and Node2 are then failed, and at the next

RESET line the programwill attempt to route all unplaced demands in the networkwhile

Link5, Link6, Node1, and Node2 are all down (and append the appropriate reports), after

which all links and nodes are brought back up and all demands are assigned to their

original paths.

After the program has finished running through the script, youmay view the appropriate

failure simulation reports for information recorded at each of the RESET, RESET LINK,

andWAIT lines.

If you choose to simulate Every Event, then the programwill run a simulation after every

network failure. In theaboveexample, Link1 is takendownfirst, and theunplaceddemands

are rerouted and the appropriate reports generated. Then, Link2 is taken down (Link1 is

still down) and the unplaced demands are rerouted. When RESET is encountered, all

links are brought back up and all demands are placed back in their original paths.

Related
Documentation

•

Interactive Scenarios

Interactive Simulation allows you to specify the nodes, trunks, and/or facilities that he

wants to fail for the simulation run. Subsequent failures can also be performed by

continuing the simulation using a different set of failed elements.

NOTE: Before runningan interactivesimulation, reviewyour failuresimulation
option settings via Tools > Options > Failure Simulation, and are described
in detail in “Failure Simulation Options” on page 357.

Fail Link

Fails selected trunks in the network. In the Fail Links tab, a list of all trunks is displayed.

To fail a link, simply select the row for a link. The link is grayedout on themapandmarked

with a red ‘F’ symbol to indicate its failure. To bring a trunk back up, select the failed trunk.

'Reset All' will bring all failed trunks up. Use the View Changes option to see how the

failure impacts link utilization, and demand/tunnel routing.
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Figure 103: Fail LinksWindow

Fail Interface

The purpose of this tab is to study the failure of a physical interface, which can have

multiple logical links. For example, failing fe-0/1/2on routerATL_TESTwill cause3 logical

links associated with fe-0/1/2.0, fe-0/1/2.211, fe-0/1/242 to fail. Select the row for a

physical interface to bring down or up the physical interface and associated logical links.

‘Reset All’ will bring all failed interfaces up. Use the View Changes option to see how the

failure impacts link utilization, and demand/tunnel routing.

Fail Node

Fail selected nodes in the network. Use the View Changes option to see how the failure

impacts link utilization, and demand/tunnel routing.

Figure 104: Fail NodesWindow

Fail Facility
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Fail selected facilities in the network. A facility file must be defined and loaded in order

to use this feature.

Use the View Changes option to see how the failure impacts link utilization, and

demand/tunnel routing.

Run, Step, Stop

• Run is used to run a simulation with the given failures.

• Step is used to step through a simulation. A step consists of the rerouting of a single

demand. For each step, a Paths window appears indicating the rerouted path (if any)

and the disconnected path. This feature is applicable only when a running simulation

has been stopped.

• Stop is used to stop a running simulation.

View Changes

The following changes can be viewed after performing the interactive simulation:

• View Link Changes: View changes to the link utilization and RSVP utilization

• ViewDemandChanges:View changes to the demand placement, number of hops, and

delay (ms)

• View Tunnel Changes: View changes to the tunnel placement, number of hops, and

delay (ms)

Reset Simulation

Reset the simulation to the initial network state. All trunks and nodes are set to active

and all demands are routed according to the state at which the simulation mode was

entered.
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CHAPTER 11

Traffic Menu

This chapter explains how to use the various traffic features in the Traffic Menu. The

addendum at the end of this chapter also explain how to access and interpret the basic

traffic charts available in IP/MPLSView.

• Traffic Load on page 203

• Growth on page 206

• Trending on page 207

• Network Files on page 207

• Other Files on page 208

• Import Traffic on page 212

• Computation Method and Aggregation on page 230

• Using the Generated Trafficload File on page 230

• Addendum: Traffic Data Input Files on page 234

• Addendum: Accessing Traffic Charts on page 236

• Addendum: Interpreting the Traffic Charts on page 237

Traffic Load

NOTE: This feature requires a license. Please contact your Juniper Networks
representative for more details on this feature.

Select Traffic Load to open the Load/Util window. The window options may vary

depending on the hardware type or license. Themost basic windowwill contain the

Normal andPeak radiobuttonsand the slider bar. Routermoduleswill haveanadditional

option for live interface (for Layer 3) or tunnel (for Layer 2) traffic and the option to fetch

historical traffic from thedatabase froma selected starting period andat a selected time

interval. The link utilizations on themap will reflect planned traffic, worst-case traffic,

or a certain time period of traffic (up to 24) by moving the horizontal slider.
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Figure 105: Traffic Load window (Options May Vary)

• The Planned period reflects the loading based on the bandwidth specified for each

demand in the demand file (this can be set to the peak payload per demand for a

specified time interval,measuredandextractedby thehardwaredevice'smanagement

platform).

• TheWorst period (for the Normal traffic load option, based on the trafficload file)

provides the traffic loading supposing each demand is at its worst period (maximum

value) among the 24 periods in the traffic load file, even though these could actually

occur at different times. For router modules, with actual measured interface traffic,

theWorst period (for the Interface or Tunnel option), will show the highest value of

the 24 periods.

• Following thePlannedandWorstperiodsareup to24periodsbasedon the “trafficload”

file that is referenced to from the specification file.

Theprogramwill followthehardware's implementationofdemandroutingandbandwidth

allocation as in the Path Provisioning mode of simulation. Once the demand path is

established, traffic load information for each demand is then loaded onto the network
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model. By using measured traffic, snapshots of actual trunk utilization can be analyzed

and a better understanding of the impacts under failure conditions can be gained.

DescriptionField

Displays link utilizations based upon the routing of specified demand/flow traffic. In the specification file,
traffic input is read in fromthe “trafficload” file. See theFile FormatReference for IP/MPLSView for information
on the required format. Note: For the Router module with MPLS enabled features, if Layer 2 (tunnel layer)
is selected, then selecting Normal in the Load/Util window displays the link utilizations based upon the
routing of tunnel traffic that is specified in the “tunnel trafficload”, or “T_trafficload” file in the specification
file. This file has a format similar to that of the “trafficload” file.

Normal

This option is only applicable after you have run a failure simulation scenario (and has checked the Include
Traffic Load box in the Simulation Script Options). Peak represents the highest (or worst) link utilization
loading experienced by each link, depending on the rerouting of the demand/flow traffic after any single
failure. If 24 periods of traffic are specified in the “trafficload” file, then the peak utilization will represent the
worst loading on that link during each of the 24 periods.

Peak

Displays the results as link utilization on the topology map. This is the default.Utilization

Displays the results as queueing delay (in milliseconds) on the topology map according to a custommap
legend.

QDelay

Displays the results as drop percentage on the topology map according to a custommap legend.Drop

Starts running the animation that is reflected on the topology map. Begins with Planned, Worst, and is
followed by the periods of traffic.

Run

Router-Specific options

DescriptionField

This optionappears if youare in theLayer 3 (Demand) viewanddisplays linkutilizationbasedon traffic actually
measured at the interface. This differs from the “Normal” option which displays the utilization based on the
routing of traffic associated with end to end flows. Interface traffic can be read from two sources:

1. User-supplied “ingress” or “egress” files, also referred to in the specification file as “interfaceLoad_in” and
“interfaceLoad_out”.

2. Traffic saved in a database when performing a traffic collection in the Live Network using the Traffic
CollectionManager. (Refer to the IP/MPLSViewJava-BasedManagementandMonitoringGuide for information
on setting up traffic collection.)

After selecting a start date and time interval, click Fetch to fetch the data from the database. Subsequently,
you can replay the historical traffic using the Run button or view the traffic in chart format via the Traffic Load
>Measured Interface Traffic menu.

Interface
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DescriptionField

This option appears if you are in the Layer 2 (Tunnel) view and displays tunnel traffic at an interface. Tunnel
traffic can be read from two sources:

1. Traffic data from a tunnel trafficload file (referred to as “T_trafficload” in the specification file)

2. Traffic saved in a database when performing a traffic collection in the Live Network using the Traffic
CollectionManager. (Refer to the IP/MPLSViewJava-BasedManagementandMonitoringGuide for information
on setting up traffic collection.)

After selecting a start date and time interval, click Fetch to fetch the data from the database. Subsequently,
you can replay the historical traffic using the Run button or view the traffic in chart format via the Traffic Load
> Tunnel Traffic on Link menu.

Tunnel

By choosing aparticular Class of Service (CoS), the traffic statistics associatedwith that CoS canbedisplayed.
This information is based on demands, as opposed to measured data. Note that CoS-related features require
a license. Please contact your Juniper Networks representative for more information on obtaining this feature.

CoS

This panel is only applicable for router modules if you have run traffic data collection live, using the Traffic
Collection Manager, which stores the traffic data into a database. You should first select a starting date and
then an interval between the periods, and then click ‘Fetch’ to load the summarized traffic data. After the
status message says “Traffic Ready,” then, click on ‘Run’ or open the appropriate traffic chart (Traffic Load >
Measured Interface Traffic for interface traffic or Traffic Load > Tunnel Traffic on Link for tunnel traffic.

Start From...
Interval and
Fetch

Growth

The Growth option in the Traffic menu can be used as a simple way of projecting future

network growth. This tool allows you tomodel the existing network in terms of projected

future growth.

This network growth feature is not cumulative; the percentage growth is always applied

to the original demandbandwidths. If the growth feature is invoked twice, each timewith

200 percent, for example, the result after the second increase is still a doubling, rather

than a quadrupling, of the original demand bandwidth.

Figure 106: Adjusting the Network Growth Factor

You can use the slide rule in the Growth Options window to increase the bandwidth of

existing demands in the network as a way to project future network growth. Using the

slide rule, the current demands in network can bemultiplied by a factor anywhere from

0 percent to 1000 percent.
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Trending

The Trending feature takes as input several periods of traffic data or other data. It then

performs a “trending” by extrapolating future growth of the data based on a number of

user-supplied parameters such as the type of regression to use, the number of points to

extrapolate, and so on. The Trending data input file can be any one of four different

Network Files. Alternatively, you can specify a separate input file by choosing Trending

> Other Files. The file formats for all these input files are described briefly below. For a

more detailed explanation of the traffic file formats, see theDemand/Traffic Files chapter

of the File Format Guide for IP/MPLSView.

Network Files

Interface Traffic (Ingress or Egress)

To use IP/MPLSView interface files as the trending input, select Traffic > Trending >

Network Files > Interface Traffic (Ingress) or Interface Traffic (Egress). These files list

period-by-period ingress or egress traffic per interface.

In order to use these files, theymust first have been loaded into your network project. To

do so, select File > Load Network Files, select the Traffic tab, and press the ingress or

egress buttons, respectively. Typically a user only specify one of these.

The file format is as follows:

NodeID Interface Direction - Period1 Period2 ... PeriodN
MYNODE1 POS0/1 A2Z 0 100200112 100601536 100400624 100601536

An alternative file format for interface traffic is:

LinkName Direction - Period1 Period2 ... PeriodN
MYLINK1 A2Z - 100200112 100601536 100400624 100601536
MYLINK1 Z2A - 5003683 5003822 5284499 683344

The units for the period data should be in bits per second.

NOTE: The NodeIDmust match the ID or name of one of the nodes in the
muxloc file.

Trafficload (Demand, NCP, ...)

To use IP/MPLSView trafficload files as the trending input, select Traffic > Trending >

Network Files > Demand Trafficload. These files list period-by-period traffic per demand.

In order to use these files, theymust first have been loaded into your network project. To

do so, select File > Load Network Files, Traffic tab, and press the “trafficload” button.
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The file format is as follows:

DemandID Direction - Period1 Period2 etc…
MYDMD A2Z - 100200112 100601536 100400624 100601536
Or, for those with Node-Card-Port (NCP) data:
FromNodeCardPort Direction - Period1 Period2 etc…
ToNodeCardPort Direction - Period1 Period2 etc…
MYNODE.P3C5 A2Z - 100200112 100601536 100400624 100601536

Tunnel Trafficload (IP/MPLS only)

Touse IP/MPLSView tunnel trafficload files as the trending input, selectTraffic>Trending

> Network Files > Tunnel Trafficload. These files list period-by-period traffic per LSP

tunnel.

In order to use these files, theymust first have been loaded into your network project. To

do so, select File > Load Network Files, Device Specific tab, and press the trafficload

button.

The file format is as follows:

NodeID:TunnelName Direction - Period1 Period2 etc…
MYNODE1:MYTUNNEL290 A2Z - 100200112 100601536 100400624 100601536

Peak Link Traffic

To use peak link traffic load files as the trending input, run an exhaustive single element

failure fromSimulation >PredefinedScenarios on a networkwith a trafficload file, which

contains the period-by-period traffic per demand. For example, the sample fish network

(/u/wandl/sample/IP/fish/spec.mpls-fish) could be used to generate a peak link traffic

load since the specification file references a trafficload file with the period-by-period

traffic per demand. After the failure simulation is complete, a file namedPeakLinkLoad.<

runcode> is created, which indicates for a particular link and a particular period, what

was theworst link load experienced for that link, taking into consideration all of the single

element failure simulations that were simulated on the network.

The file format is as follows:

Node,Interface,Dir,Peak_1,Peak_2,Peak_3,Peak_4,Peak_5,Peak_6,Peak_7,Peak_8,Peak_9,Peak_10,
ATL,LINK1,A2Z,25952066,31141680,36327296,36327296,41518908,46707684,46707684,36327296,31141680,25952066,

Load the file using Traffic > Trending > Network Files > Peak Link Traffic.

Other Files

Youcanalso load trending input fromany file, as longas the file has theproper file format.

To load this file, select Traffic > Trending > Other Files. You are prompted to specify the

location of the trending file. The recommended name for this file is

trending.trending.<runcode>..The file should contain the <COLUMN>, <START>, and

</START> tags and have the following comma-separated format:
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<COLUMN>
TextColName1,TextColName2,...,TextColNameN,DataColName1,DataColName2,...,DataCol
NameM
<START>
MYDATUM1,Chicago,100200112,100601536,100400624,100601536
MYDATUM2,Jersey,20045634,20135645,22411224,21044335 # This is a comment
</START>

NOTE: Files in this comma-separated format can be opened automatically
in Report Viewer. Go to the File Manager window, right-click on the file, and
choose“Open inReportViewer” fromthedrop-downmenu.The<COLUMN>,
<START>,and</START>tagsenable the file tobe readbytheReportViewer.

TrendingWindow

Once the data is read in, IP/MPLSViewwill filter out any entries with toomany

“Undetermined Values” such as negative numbers. Howmany undetermined values is

toomany? In IP/MPLSView, for a polynomial of degree k, the data should have nomore

than k undetermined values. For linear or exponential, the data should have nomore

than one undetermined value. Otherwise, the data is omitted from the analysis.

NOTE: For traffic files generated by the IP/MPLSView, a “-1” is often used
for a period lacking traffic data. In Trending, a “0” zero value is also ignored
so that the projection from the non-zero values aremore accurate.

Figure 107: “Bad” or “Undetermined” Data Points are Discarded

209Copyright © 2018, Juniper Networks, Inc.

Chapter 11: Traffic Menu



Figure 108: TrendingWindow

DescriptionColumn

The node and interface to which the traffic data points and trending data points in that row
correspond. Link indicates the corresponding link name and Type indicates the trunk type. Note
that other fields may be present in this gray section, depending on the.input data.

Node, Intf (gray)

These columns contain the period data based on your IP/MPLSView data file or
trending.<runcode> input file.

Pdn (white)

These columns contain the forecasted data. The number of trending data points is based on
the specified # to Forecast.

Pdntrend (red)

The coefficient of determination. It is a value between 0 and 1, where 1 indicates that the curve
fitting matched the data perfectly.

RSq (green)

The number of good data points included in the trending analysis. Bad data points (typically
values of ”-1” or “0”) are automatically omitted.

GoodDataCt (blue)
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Figure 109: Trending Chart for a Particular Interface

DescriptionField

TThe number of data points to forecast. Press <Enter> after specifying a value. The trending table
will then automatically update.

# to Forecast

The type of regression to be performed.Linear / Exponential /
Polynomial

Data can be viewed and processed in two forms: either Raw (raw traffic data numbers) or Util
(Raw/BW) (the traffic utilization on each trunk). The Util view is the more useful and interesting.

Data

This number is used to “smooth out” any outliers in the data. If the value is set to “3”, then each
data point is the arithmetic average of the traffic value in the previous, current and next time
interval of the original data. If the value is set to “5”, then each data point is the average of the
values of the two previous, the current, and the two following time intervals in the original data.

Moving Average

Allows you to display only selected rows in the table. For example, if your Data value is set to Util
(Raw/BW), then youmight query for Pd5trend > 1.0 to identify where traffic may exceed trunk
capacity five periods in the future.

Adv Filter

Displays a line chart of the raw and trending data points corresponding to the selected row in the
trending table. See Figure 109 on page 211 .

Show Chart

Highlights all entries on the Map. Highlight all nodes in the table, all nodes and links in the table,
or all links in the table along with their end nodes.

Highlight All

Allows you to exclude selected periods of data from the regression.Exclude Pds
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DescriptionField

Saves the current table into a TRENDING.<runcode> file.Save

Creates a link file (in bblink format), calledTRENDING_BBLINK.<runcode>, from the rows currently
displayed in the table.

Save as bblink

Generates the corresponding traffic matrix input file, TRENDING_TMATRIX.<runcode>, for the
specified trendingperiod.Use this file as an input to theTrafficMatrix feature, accessible viaDesign
> T-Solve in a multitude of traffic engineering studies.

*The Traffic Matrix feature requires a license. For more information on this feature, see “Growth”
on page 206.

To Traffic Matrix*

Related
Documentation

•

Import Traffic

The Import Traffic Wizard is accessed via Traffic > Import Traffic. This wizard performs

three functions which can be executed independently of each other:

• Convert third party traffic data to IP/MPLSView traffic data.

• Aggregate IP/MPLSView traffic data frommultiple sessions to a single aggregated

IP/MPLSView data set.

• Convert aggregated IP/MPLSView data to a 24 period trafficload file.
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Figure 110: Traffic Data ImportWizard

Third Party Traffic Data > IP/MPLSView Traffic Data

NOTE: This feature requires a license. Please contact your Juniper Networks
representative for more details on this feature.

The Import Traffic feature supports the following types of data files:

• MRTG (Multi-Router Traffic Grapher)

• Arbor Networks (XML)

• Juniper Networks LDP Statistics Import

Note that, for popular traffic sources, Juniper Networks may offer customized utilities to

perform the conversion from other traffic formats into IP/MPLSView’s required input

format. Please contact Juniper Networks support to learn if IP/MPLSView supports

conversion of your traffic measurement data type.
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Figure 111: Select Import Directory, Import Type, and Output Directory

DescriptionField

Click to see the drop-down selection box to select the appropriate data type for import.Select Import Type

The directory shown here displays the current import directory. This field should specify
the directory in which traffic data files are stored. Click on the Browse button to change
this setting.

Select Import Directory

This file contains configuration settings specific to the type of Import Type being
performed.

Select Parser Configuration File

The directory shown here displays the current output directory. This field should specify
the directory in which output files are saved. Click on the Browse button to change this
setting.

Select Output Directory

Depending on which data type is being imported, the next pages of the wizard will show

different tabs and required parameters to be entered.

To import third party traffic data, select one of either MRTG, InfoVista, or Concord from

the Import Type drop-downmenu.

In order to import thirdparty traffic sources, youmust configure import options toperform

pattern matching on filenames, indicators, and other fields. This requires knowledge of

regular expressions. Examples are provided in this document. For information on regular

expressions, please visit http://www.regular-expressions.info.

MRTG (Multi-Router Traffic Grapher)
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NOTE: This feature requires a license. Please contact your Juniper Networks
representative for more details on this feature.

Figure 112: Selecting MRTG as the Import Type

This option imports traffic collected from anMRTG, or Multi-Router Traffic Grapher. The

grapher generally provides traffic log files, whose filename contains delimiters that need

to be specified in the import wizard. The format of a filenamemight look like

“<nodename>-<interface>.log”, where the dash (“-”) is the delimiter, and “log” is the

filename extension.

After you have selected the import directory in which these log files are located, the next

page in the wizard prompts you for instructions on how to convert MRTG log file names

to the correct node and interface names. In the example below, the goal is to use the

Transform Pattern to convert filenames in the Text Source directory, which are displayed

in the Text column, to the format specified by the Transform Template. Prior to applying

the Transform Pattern, the Text Transform Substitutions are applied.
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Figure 113: MRTG Filename Parsing

In the previous example, the Text Transform Substitution replaces the underscore with

the forward slash. The TransformPattern thenmatches the first word to the node name,

uses the first forward slash as adelimiter, thenmatches the remainingword (up to “.old”)

to the interface name. Thus, ahdbccr1_fxp0.old gets transformed to AHDBCCR1 FXP0.
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Figure 114: MRTGOptions

TheMRTGOptions tab lists several options related to MRTG parsing, as explained in the

following table.

DescriptionField

This is the type of traffic being collected. Choices are Interface, Tunnel, and PVC. For MRTG,
this is usually Interface.

Traffic Type

This is the data type being collected. Choices are traffic delta, raw traffic count, traffic rate,
and aggregate traffic rate. For MRTG, this should be traffic rate.

Data Type

This sets howmuchdata to store inmemorybefore flushing it out toa file.Onmost systems,
setting this to 0 (no limit) should be fine. However, if the traffic source is extraordinarily
large, it might be prudent to set a data cache limit.

Data Cache Limit

This option indicateswhether or not to overwrite existing traffic data in the output directory
specified in the first step. If there is overlapping data in the output directory (identical
interface and days), then if this option is checked, that data is overwritten. If this option is
not checked, that data is averaged with the new data.

Overwrite IP/MPLSView traffic
data

This is the rate used to convert the traffic unit in the source data to bits. SinceMRTG reports
traffic in bytes, a value of eight should be used here.

Conversion from traffic rate to
bits

This is the sample interval to be used when collecting data from the traffic source.Sample Interval (minutes)

Data with sample intervals larger than the sample interval limit specified here are ignored.Sample Interval Limit (minutes)
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DescriptionField

All data between the start time and the present time are extracted.Start Time

This is the interval to be used in the 24 period trafficload file, which are generated at the
completion of the Import Traffic Wizard. A typical value for the interval is 60minutes.

Interval (minutes)

The MRTG Config Directory is the location of the MRTG configuration files, which are

used todetermine thedevice/interface names. These config files canbe createdby using

a perl script from theMRTG packagewhich performs an snmp collection on all interface

indices on each device. To create the MRTG configs, SNMP access to network devices

anda list of the devices is necessary. Please ask yourMRTGadministrator for the location

of MRTG configuration files.

At this point, clicking Next will start the conversion of MRTG data to IP/MPLSView traffic

data. Once this conversion is complete, the next step is to convert IP/MPLSView traffic

data to aggregate IP/MPLSView traffic data. Please skip ahead to that section,

“IP/MPLSViewTraffic Data >Aggregate IP/MPLSViewTraffic Data” formore information.

Arbor Networks (XML)

NOTE: This feature requires a license. Please contact your Juniper Networks
representative for more details on this feature.

Figure 115: Selecting Arbor XML as the Import Type
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Arbor traffic import can be used to import xml files with the end-to-end flow traffic at

the router level. The following is a sample input file format:

<item id=”10.0.0.2/32” name=”10.0.0.2/32”>
<key id=”10.0.0.2/32” name=”10.0.0.2/32”/>
<class type=”in”>
<current value=”135000000”/>
<avg value=”148000000”/>
<max value=”199000000”/>
<pct95 value=”186000000”/>
<sample value=”140000000|147000000000|147000000000|...”./>
</class>
<class type=”out”>
<current value=”125000000”/>
<avg value=”110000000”/>
<max value=”520000000”/>
<pct95 value=”240000000”/>
<sample value=”440000|140000000|125000000|...”./>
</class>
</item>

To import the xml files, select the Import Directory (where the data is stored) and the

Output Directory (where output files are written), and click Next. The automatic import

processwill then begin, whichwill convert Arbor traffic data to IP/MPLSView traffic data.

Once this conversion is complete, the next step is to convert IP/MPLSView traffic data

to aggregate IP/MPLSView traffic data. Please skip ahead to that section, “IP/MPLSView

Traffic Data > Aggregate IP/MPLSView Traffic Data” for more information.

Juniper Networks LDP Statistics Import

NOTE: This feature requires a license. Please contact your Juniper Networks
representative for more details on this feature.

This option imports Juniper Networks LDP traffic statistics data files obtained by FTP

from Juniper Networks devices (routers and switches) specifically configured to collect

traffic statistics. Juniper Networks LDP traffic statistics can report the amount of traffic

destined to each forwarding equivalence class (FEC) from a Juniper Networks device

running LDP.

This is a different method than that employed by the LDP Traffic Collection Task, as

described in the “Reference” chapter of the IP/MPLSView Java-Based Management and

Monitoring Guide, which uses the CLI show command to collect Juniper Networks LDP

traffic statistics. Both methods can be used to generate a demand and trafficload file.

However, the Traffic Import method in this chapter assumes that you have already

downloaded LDP traffic statistics data from the devices, whereas the Traffic Collection

Task employs an online, automated approach, via CLI.

Prerequisites

Toobtain Juniper Networks LDP traffic statistics data files for the traffic import, youmust

configure the traffic-statistics statement at the [edit protocols ldp] hierarchy level. This

219Copyright © 2018, Juniper Networks, Inc.

Chapter 11: Traffic Menu



configuration causes the router to automatically gather the LDP traffic statistics and

periodically write the statistics to a file. The relevant syntax is as follows:

[edit protocols ldp]
traffic-statistics {
file filename <files number> <size size> <world-readable | no-world-readable>;
interval seconds;
no-penultimate-hop;

}

where:

• file filename—Name of the file to receive the output of the LDP statistics operation.

Enclose the namewithin quotationmarks. All files are placed in the directory /var/log.

• files number—(Optional) Maximum number of LDP statistics files. When a statistics

file named ldp-stat reaches its maximum size, it is renamed ldp-stat.0, then ldp-stat.1,

and soon, until themaximumnumber of LDPstatistics files is reached. Then theoldest

file is overwritten.

Range: 2 through 1000

Default: 2 files

If you specify amaximum number of files, you alsomust include the size statement to

specify the maximum file size.

• interval seconds—(Optional) The interval, in seconds, at which the statistics are polled

and written to the file.

Default: 300 seconds (5minutes)

• no-penultimate-hop—(Optional) Do not collect traffic statistics on the penultimate

hop router.

• no-world-readable—(Optional) Prevent all users from reading the log file.

• size size—(Optional)Maximumsize of each statistics file, in kilobytes (KB),megabytes

(MB), or gigabytes (GB). When a statistics file named ldp-stat reaches this size, it is

renamed ldp-stat.0. When ldp-stat again reaches this size, ldp-stat.0 is renamed

ldp-stat.1 and ldp-stat is renamed ldp-stat.0. This renaming scheme continues until the

maximum number of statistics files is reached. Then the oldest statistics file is

overwritten.

Syntax: xk to specify KB, xm to specify MB, or xg to specify GB

Range: 10 KB through themaximum file size supported on your system

Default: 1 MB

If you specify a maximum file size, you also must also include the files statement to

specify the maximum number of files.

• world-readable—(Optional) Enable log file access for all users.

See the JUNOS
®
OSMPLS Applications Configuration Guide for more detailed LDP traffic

statistics configuration details.
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For instance, the following figure shows the traffic-statistics statement configured on a

router called SFO.

Figure 116: LDP Stats Configuration

The router SFOwill then automatically collect LDP traffic statistics into the file

/var/log/LDP_Stats every 300sec.

You can then use a utility such asSCPor SFTP to copy the compressedor uncompressed

versions of the /var/log/LDP_Stats files to the IP/MPLSView server. For compressed

(*.gz) files, be sure to manually uncompress the file before copying it to the server.

When you use the Import Traffic Wizard to import the LDP_stats.file, IP/MPLSView does

not perform any integrity checks to validate whether the collected LDP statistics are

complete. Incomplete LDP statistics can occur, for example, if there are days for which

theLDPstatisticsarenot fully collectedonall JuniperNetworksdevices.Runningnetwork

simulations using these partial LDP statistics as input can cause erroneous results.

To ensure that the LDP_Stats files are complete, we recommend that you create a

preprocessing script that verifies theLDPstatistics files fromall importeddevices, checks

the included timestamps, and determines for which days the LDP stats are complete for

all devices. Youcan thensafely import theLDP_Stats files using the ImportTrafficWizard.

NOTE: When the ldp-stat file on a Juniper Networks device reaches the

maximum configured size, it is closed and a new file is opened. In this case,
an FEC statistics recordmight get split across two files. The IP/MPLSView
Import TrafficWizard cannot process an FEC statistics record that happens
toget split across two files. ToenableThe IP/MPLSView ImportTrafficWizard
to process the FEC statistics record, youmust merge the two files.

For the Import TrafficWizard to correlate thedevicewith its LDP statistics data file, name

the files using the format {router-node-ID}.LDP-STATS, irrespective of the LDP statistics

filename configured on the router itself. For example, if the router hostname is SFO-re0
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orSFO-re1 (dependingonwhichRoutingEngine ismomentarily active)and theconfigured

LDP statistics file on that router is named LDP.stats, then the LDP statistics data file

should be named SFO.LDP-STATS.

BEST PRACTICE: IP/MPLSView does not create LDP statistics-based
demands(traffic)boundforunknowndestinations(that is, IPaddresses that
are not attached to any device in your IP/MPLS View topology), and does
not generate an error log for such discarded demands. To obtain realistic
simulation results, we recommend that you create a script to verify that all
LDP destinations collected in LDP statistics files are actually present in the
imported IP/MPLS View network topology.

To use the Juniper Networks LDP Stat traffic import feature, first start the Import Traffic

Wizard by selecting Traffic>Import Traffic. In the Traffic Import Options window, select

Select Import Type>Juniper LDP Stat.

In the Select Import Directory pane, click Browse and select the directory where the

Juniper Networks LDPStatistics data files are located. Under the SelectOutput Directory

pane, click Browse and select the directory where IP/MPLSView traffic data object files

(created in the background by the conviptraf program) are to be stored.

Finally, select Use destination node IP to include the destination node’s IP address in the

demand file that is created. Click Next and the Juniper Networks LDP Statistics data file

(by conviptraf) is parsed.

Figure 117: Selecting Juniper Networks LDP Stat as the Import Type
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After a period of time parsing/processing the data files, the next stage is the traffic data

aggregation stage, in which data points frommultiple days are aggregated together for

each hour. IP/MPLSView Traffic Data object files (created by conviptraf) are created for

each day that data is available. Choose particular days to consider for aggregation by

checking the box next to that day. Finally, under Specify Aggregate Directory, specify the

directory where aggregated results are to be stored. Click on Next, and the aggregation

process (run in the background by the rolliptraf program) begins.

Figure 118: Choose Dates for Aggregation

After traffic data aggregation has completed, you are given the option of changing the

directorywhere theoutputsarewritten to.ClickBrowse if youwish tochange thedirectory.

Click Next to go to the final step to specify further aggregation and demand generation

options, as shown in the following figure and table.
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Figure 119: Choose Aggregation and Demand Generation Options

• Output runcode: Specify the runcode for the demand and trafficload files created. � � �

� �

• Max BW (bps) per demand: Generated demands will not exceed this value

• Min BW (bps): Generated demands are at least this value.

• Range: This option indicates which period to use to generate the demand file. Options

include Peak Period, 24 Period, and Period n, where 1<=n<=24

• ECMP: Used to created ECMP demands as appropriate.

• Aggregationstatistic:This is thecomputationmethodsused tocalculate traffic.Options

include 99th, 95th, 90th, and 80th percentiles, average, andmax.

• Traffic type: Demand and Trafficload files are generated

IP/MPLSView Traffic Data > Aggregate IP/MPLSView Traffic Data

Once third party traffic data has been converted to IP/MPLSView traffic data, this data

can be aggregated. This allowsmultiple traffic sources to be combined into a single

trafficload file. If you had previously completed the procedure for importing third party

traffic data, they will automatically proceed to the following window. If starting from

scratch, simply start the Import Traffic Wizard and selectWANDL Traffic Data from the

Select Import Typemenu.
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Figure 120: Selecting IP/MPLSView Traffic Data as the Import Type

The import itemshown inFigure 121onpage226 is the ImportDirectory,whichmustcontain

valid IP/MPLSViewtrafficdata.To includesubdirectories, check the IncludeSubdirectories

checkbox, then select all the subdirectories to include.
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Figure 121: Including SubdirectoriesWith the Import Directory

Usually it is wise to include all subdirectories at this step, because data from different

days are usually stored in separate subdirectories. If the import directories and

subdirectories are configured correctly, clicking Next displays a window containing a list

of all thedatesassociatedwith the IP/MPLSView traffic data found in the Import directory

and subdirectories, as shown in the following figure.
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Figure 122: Traffic Import Dates

Select the dates to be aggregated, and bring them over to the right panel by clicking the

right arrow button. Clicking Next at this point will start the aggregation process. Once

that is complete, this step is over, and the only step remaining is to convert the aggregate

data to a trafficload file.

IP/MPLSView Aggregate Traffic Data > TrafficLoad File

Once IP/MPLSView traffic data has been aggregated, it can be converted to a trafficload

file. To do this, selectWANDL Aggregate Traffic Data as the Import Type. If continuing

from a previous step, this selection will already bemade.
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Figure 123: SelectingWANDL Aggregate Traffic Data as the Import Type

Clicking Next displays the Aggregation Options window shown here.
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Figure 124: Aggregation Options

DescriptionField

This is the computationmethod used to calculate traffic. Options include 99th, 95th, 90th,
and 80th percentiles, average, andmax.

Aggregation Statistic

This is the traffic type to be converted to the trafficload file. Options include interface traffic,
tunnel traffic, and demand traffic.

Traffic Type

The following aggregation options are available when the traffic type Demand Traffic

Load is selected.

• Output runcode: Specify the runcode for the demand and trafficload files created.

• Max BW (bps) per demand: Generated demands will not exceed this value

• Min BW (bps): Generated demands are at least this value.

• Range: This option indicates which period to use to generate the demand file. Options

include Peak Period, 24 Period, and Period n, where 1<=n<=24

• ECMP: Used to created ECMP demands as appropriate.
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ComputationMethod and Aggregation

The computation methods used to calculate aggregate traffic from source data are

described in the table here.

DescriptionComputation Method

For each hour of 24 hours, the maximum of the sample values within that hour is used.Max

For each hour of 24 hours, the samples within that hour are averaged. If there are N samples within
an hour, the result is the sum of the all the sample values divided by N.

Average

For each hour of 24 hours, the 95th percentile value of the samples within that hour is used. The
95th percentile is computed from the equation: Average + 1.645 * stddev, where Average refers to
theaverageof the samples in thathourandstddev is the standarddeviation.Anotherwayof thinking
about this is that 95 percent of the sample values lie below the calculated value. The corresponding
equation for the 90th percentile is: Average + 1.282 * stddev.

95th percentile

Roll-up / Aggregation Defined

The intention of traffic aggregation is to summarize the network traffic data that is

generated across several days of collection. Selected days or a range of days can be

specified to be included in the aggregated result. For example, one can aggregate all

Mondays in the month of January, weekdays only, or aggregate all the days in an entire

month, months, or year.

For example, in the aggregated data for a particular interface, there are 24 values

representing the 24 hours. For that particular interface, all sample points in hour 1 (In bps

and Out bps values) across all the days are grouped together, all sample points in hour

2 across all the days are grouped together, and so on. The 95th percentile for hour 1 then

takes into consideration as sample points, all the sample points for that interface during

hour 1 on all the selected days.

NOTE: Aggregate directories have the same format as the daily directories
andcanalsobeaggregated.Thismightbeusefulwhenperforming theoffline
traffic processing incrementally asmore traffic data becomes available.
However it is up to you to remember exactly which days of traffic were
aggregated - usually by supplying ameaningful name the directory.

Using the Generated Trafficload File

The status windowwill indicate when the traffic files are successfully processed and

aggregated. Generating the interface/tunnel traffic files should be very quick, in amatter

of minutes or less. Corresponding IP/MPLSView format ingress and egress interface

traffic files or tunnel traffic files are generated and loaded into the system if you check

the Load traffic data checkbox. Once completed, click on the Finish button. SelectTraffic

> Traffic Load to display the Load/Util window. For MPLS-enabled networks, the proper

layer (Layer 2 or Layer 3) should be selected.
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Figure 125: Interface Traffic Load Files Generated

In the Load/Util window, select the Interface radio button (or Tunnel for tunnel traffic in

MPLS-enabled networks). Then, click the Run button for an animated 24-period link

utilization display. The 24 periods represent 24 hourly values. The slider can also be

dragged to a particular period, to view the corresponding link utilization on the topology

map. The second “tick” on the slider shows the Peak period. Peak represents the highest

value of the 24 periods.
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Figure 126: View the Utilization on theMap over 24 Periods

Right-clicking on a link will also display the 24-hour interface traffic bar chart.

• To display the corresponding traffic bar chart for interface traffic, select Traffic Load

>Measured Interface Traffic from the popupmenu.

• To display the corresponding traffic bar chart for tunnel traffic, select Traffic Load >

Tunnel Traffic on Link from the popupmenu.

To display a detailed report of the traffic and utilization for each interface for each 24

hour period, click on Interface Traffic Reports > Interface Traffic Report in the Report

Manager.
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Figure 127: 24-period Aggregate Data on a Link

This section describes how to use the IP/MPLSView conversion utilities.

IP/MPLSView takes selected types of traffic data as input and converts them into a

concisebinary format, organizedby “daily directories”, that is suitable for rapidaggregation

using any of a choice of statistical computation methods. For example, it allows you to

"roll-up" a week's worth of data into 24 hourly periods and display the hourly utilization

based on the 95th percentile.

The followingexplains thestructureof thedailydirectories. Thesedirectorieshavenames

in date format such as:

MAR19.01
MAR20.01

In each of these daily directories is a number of files- one file per device for which traffic

was collected on that particular day.

For example,

>ls MAR19.01
ROUTER1 ROUTER2 ROUTER3

Thus, if interface traffic for Router1 was collected on all three days, there is a binary file

for Router1 under each of the three daily directories.
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Related Spec File Parameters

To save the imported traffic from a particular network scenario, select File > Save As, for

example, to save any new configurations to the specification file.

Toview the text versionof the spec file in theFileManager, right clickon thenewly created

(or refreshed) specification file and selectSpecFile>ModifySpec, orEdit from thepopup

menu .

The traffic-related specification file parameters are described here.

Description
Interface Traffic
Parameters

24-period incoming, or ingress trafficmeasured on the interface. This corresponds to the ingress
file.When importing traffic, the ingress file is automatically named interfacei.runcodeandplaced
in the trafdir.

ingress

24-period outgoing, or egress traffic measured on the interface. This corresponds to the egress
file.When importing traffic, the egress file is automatically named interface.runcode andplaced
in the trafdir.

egress

The location of the interface traffic daily directories repository. This is also called trafdir.trafdir

DescriptionTunnel traffic Parameters

24-period tunnel traffic file. This corresponds to the tunnel trafficload parameter in the
Device Specific tab. When importing traffic, the tunnel traffic file is automatically named
tunneltraf.runcode and placed in the tunnelrafdir.

t_trafficload

The location of the tunnel traffic daily directories repository. This corresponds to the
tunneltrafdir parameter in the Device Specific tab.

tunneltrafdir

Addendum: Traffic Data Input Files

This section contains information on the traffic-related input files and their format. Many

of these files are very similar: each line begins with some element ID, such as that for a

demand, tunnel or interface. This is followed by a series of numbers representing the

measured or estimated traffic statistics over that network element acrossmany periods

(for example, 24 hourly periods of traffic measurements collected on an interface.)
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Figure 128: File > Load Network FilesWindow

Descriptiondparam equivalentSpec File > Load Network Files

Demand traffic filetrafficload=trafficload

Location/path of ingress and egress filestrafdir=trafdir

Interface traffic fileinterfaceLoad_in=ingress

Interface traffic fileinterfaceLoad_out=egress

Sample Demand Traffic Input (“trafficload” File)

The following shows a sample of a trafficload file containing 24-period traffic load data

for a demand with demand ID RNode1toNode3 originating from Node1. Note that the

“UNIT=1” line is important because it establishes the unit of all other numbers in the file.

In this case, the unit is 1 bit per second. Somemay want to change this to “UNIT=8”

depending on the data.

UNIT = 1 # bit per second
Node1:RNode1toNode3 A2Z - 5.000M 5.5M 5.833M 2.222M 1.0M 300K 400K 2.0M 6.0M 8.0M
 11.25M 15.5M
14.054M 9.053M 6.8M 3.1M 2.0M 1.8M 500K 400K 400K 800K 1.9M 3.1M
...
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The format for each demand entry is:

NodeID:DemandID Direction FrameSize P_01 P_02 P_03 P_04 P_05 P_06 P_07 P_08 P_09
 P_10 P_11 P_12 P_13
P_14 P_15 P_16 P_17 P_18 P_19 P_20 P_21 P_22 P_23 P_24

See the File Format Reference for IP/MPLSView for more information.

Sample Interface Traffic Input (“interface” Files)

The following is an example of an interface egress file. The ingress file has the same

format.

UNIT = 1 # bit per second
LDN2600 Ethernet0/0 A2Z 0 7669 7580 7555 7567 7495 7582 7608 7533 7533 7283 6841
 -1 -1 -1 -1 -1 -1 -1 -1
-1 -1 -1 -1 -1
LDN2600 Serial0/0 A2Z 0 58 58 58 58 58 58 61 58 58 58 58 -1 -1 -1 -1 -1 -1 -1 -1
 -1 -1 -1 -1 -1

The format for each ingress or egress entry is:

NodeID Interface Direction Framesize P_01 P_02 P_03 P_04 P_05 P_06 P_07 P_08 P_09
 P_10 P_11 P_12 P_13
P_14 P_15 P_16 P_17 P_18 P_19 P_20 P_21 P_22 P_23 P_24

Note that a “-1” can be used as a placeholder indicating that no traffic wasmeasured on

the interface for that particular period.

Note that special unit characters such as “K” and “M” are not supported in the interface

files at this time.

Also note that the IP/MPLSViewwill use egress values if they are available. In situations

where there is noegress value for aparticularperiod, the softwarewill check themeasured

ingress values and use the corresponding value. For example, for a link from Node A ->

NodeZ, if no valuewasmeasured for the egress traffic fromNodeAon the interface from

Node A to Node Z, then the IP/MPLSViewwill check the ingress value at Node Z along

the same link and use that as an approximate value.

See the Demand/Traffic Files chapter of the File Format Reference for IP/MPLSView for

more information.

Addendum: Accessing Traffic Charts

Viewing Traffic on a Link

There are many ways to access traffic charts. To view the traffic on a particular link, you

can right-click on the link in theMapwindowand choose an option from the Traffic Load

submenu.
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NOTE: For MPLS-enabled networks, there is a very similar Tunnel Traffic
menu in Layer 2. The descriptions are identical to those of Demand Traffic;
simply replace “Demand” with “Tunnel” in the table below.

DescriptionField

Brings up chart of Demand Traffic load on this link (takes into account all
demands routed on this link)

Demand Traffic on Link

BringsupDemandTraffic loadchart that partitions the traffic byClassofService
(CoS) for viewing.

*The CoS feature requires a license.

Demand Traffic Load by CoS* (Router only)

Brings up the Load/BWRatio Charts that shows Demand Traffic load over Link
BW.

Demand Traffic Load/BWRatio

Brings up Interface Traffic Load chart for this link.Measured Interface Traffic

Brings up chart that compares Interface and Demand Traffic loads on this link.Interface vs Demand

Alternatively, you can open the Links window by selecting Network > Elements > Links.

Right-clickagiven link. Fromthepopupmenuyoucan thenselectTrafficChart>Measured

Interface Traffic or Demand Traffic Load by CoS if you have a router network and

appropriate license. Otherwise, you can select the Demand Traffic on Link chart.

Viewing Traffic on a Demand

To view the traffic on a demand, select Network > Elements > Demands. Select the

Demands you wish to view. Right-click and select either Show Traffic Load or End to End

Delay.

DescriptionField

Shows the traffic load chart for the selected demand in the Demands
window.

Show Traffic Load for Single Demand

Shows the sum of the traffic load for all demands for each period.Show Traffic Load for All Demands

Shows the computed end-to-end delay for the selected demand in the
Demands window.

E2E Delay for Single Demand

Shows the average end-to-end delay for all demands for each period.E2E Delay for All Demands

Addendum: Interpreting the Traffic Charts

In the Computed Load from Demand Traffic window. the computed load is the traffic

load on the link determined by the load on the demands that are routed over the link.

The load on each demand for each of a number of periods is read from the trafficload
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file. IP/MPLSViewcomputes theplacementof thedemands, and then reads the trafficload

file to determine the traffic load on any particular link. If there are multiple demands

traversing a link, then the Link Traffic Chart displays the sum of the demand loads.

Figure 129: Traffic Load on a Link

• Planned: The first column represents the total bandwidth of the demands (from the

demand file) that are routed over the link.

• Worst:Thesecondcolumn represents thehighest link loadamong the followingperiods.

• Load: Represents the link load (up to 24 periods) based on the information given in

the trafficload file.

• Peak: If failure simulation is performed, peak is the highest link load during failure.

Customizing the Traffic Chart

• The style of the chart can be toggled between a Bar chart and a Line chart, by pressing

Bar/Line.

• The color of the traffic chart can be edited by right-clicking on the graph and selecting

Properties.

• The period names at the bottom of the chart (excluding those for the Planned and

Worst) can be customized for just the demand traffic charts by editing the optional

“FORMAT” line in the original trafficload file. The “FORMAT” line looks similar to the

following, and should be placed above the first line of actual traffic data:
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FORMAT DIR FRAMESIZE Per1 Per2 Hour3 Hour4 5 6
F0001 A2Z - 6852 2083 1372 2749 1183 1242
F0001 Z2A - 18795 11703 4578 5065 4748 6155

For more information on file formats, see the Demand/Traffic Files chapter of the File

Format Reference for IP/MPLSView.

Understanding Planned Load

The planned value is the sum of the bandwidth allocated on the link for every demand

of the demand file. In the router environment, it is the same as the sum of the demand

bandwidths. For ATM networks, it is the sum of the CAC. If an overbooking factor is set,

the CAC value is modified. Planned bandwidth is the bandwidth from the router’s or

switch's routing point of view.

UnderstandingWorst Load

The worst load is simply the worst traffic load experienced on the link over all periods

for which traffic load data is supplied.

Understanding Peak Load

The peak is displayed only after performing a failure simulation. Peak load is based on

themaximum utilization of a link resulting from the latest failure scenario.

After running a failure simulation script, Peak load values become available in the traffic

charts. Each simulated failure results in the rerouting of demands around that failure.

The new routes, carrying each demand’s traffic load, are reflected in the peak load values

on the links. IP/MPLSViewwill compute the worst-case or peak load experienced on

every link over each period over the course of the entire failure simulation sequence.

The Peak load in theWorst (second) column, reflects the value of the period with the

highest peak load.

The peak planned load is also higher than the normal planned load because of the

additional bandwidth required for demands rerouting over the link.
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Figure 130: Traffic Statistics on Link After Running a Failure Simulation

Load/BWRatio Charts

The Load/BWRatio chart is accessed by right-clicking on a link and choosing Traffic

Load > Demand Traffic Load/BWRatio from the popupmenu.

Period (X-Axis)

• P stands for planned and indicates the load based on demand bandwidths, as defined

in the demand file.

• W represents the load during the worst period based on demand traffic load values

from the trafficload file.

• Periods represent the load information based on demand traffic load values from the

trafficload file.

Ratio (Y-Axis)

• Load/BW: Normal Load/Total Demand Bandwidth

• LoadUtil:Normal Load/LinkBandwidth; Theutilizationof the link for aparticular period

based on the traffic load of those demands routed over it, as given in the trafficload

file.
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• Peak/BW: Peak Load/Total Demand Bandwidth (experienced during Failure Sim)

• Peak Util: Peak Load/Link Bandwidth; The peak utilization is the highest bandwidth

utilization obtained at the chosen link during the failure simulation. It will only be

displayed after running a failure simulation, such as a scripted exhaustive node failure.

Figure 131: Load/BWRatio Chart After Failure Simulation

Measured Interface Traffic Chart

The Interface Traffic chart can be accessed either by selecting Traffic Chart >Measured

Interface Traffic from the right-click menu of the NetInfo window Link tab, or by

right-clicking on a link in the Map and selecting Traffic Load >Measured Interface Traffic.

This chart displays the measured interface load from the interfaceLoad_in (ingress) or

interfaceLoad_out (egress) files.Note that this is different fromthe traffic loadofdemands

routed over a link, where the load is derived based on the load on the demands routed

over the link for a particular period. Rather, it represents the actual loadmeasured at the

link interface.

241Copyright © 2018, Juniper Networks, Inc.

Chapter 11: Traffic Menu



Copyright © 2018, Juniper Networks, Inc.242

IP/MPLSView Java-based Graphical User Interface Reference



CHAPTER 12

Inventory Menu

The Hardware Model, accessed through Inventory > Hardware Inventory, allows you to

view details about the equipment in a network. There are two ways to view Hardware

Model information: through the Hardware Inventory window, or through the Equipment

Cost window. The Hardware Model feature can be very helpful to the network planner

who is concerned about equipment cost and availability. This feature can also be used

to keep track of equipment in an existing network, including information such as number

of available ports, operating system versions, part numbers, serial numbers, and other

inventory related operations. Link and card failure simulations can also be launched.

NOTE: This feature requires a license. Please contact your Juniper Networks
representative for more details on this feature.

• Overview on page 244

• Collecting Hardware Inventory on page 244

• Importing and Saving on page 245

• Hardware Inventory on page 247

• Hardware Inventory Summary on page 247

• Devices List on page 247

• Line Cards on page 250

• Physical Interfaces on page 252

• Transceivers on page 254

• Miscellaneous Parts on page 256

• Extensive Parts List on page 257

• Hardware Integrity on page 257

• Device Usage on page 258

• Line Card Usage on page 259

• Customer Usage on page 260

• Hardware Capex on page 261

• Categorized by Parts on page 262

• Equipment View on page 263
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• Event View on page 272

• Hardware Equipment Cost on page 274

• Templates on page 276

Overview

Components of the HardwareModel

• Hardware Inventory deals with detailed equipment reporting, equipment utilization

view, hardware capacity management, and hardware CapEx.

• HardwareEquipmentCosts isusedtoassociatecostswithspecifichardwareequipment,

and is the major financial input table for the Hardware Inventory Capex report. For

information on how to assign costs to hardware, refer to “Hardware Equipment Cost”

on page 274.

Collecting Hardware Inventory

Hardware inventory information can be derived fromCLI commands,which can be either

automated in from the Network Config Data Collection task or Scheduling Live Network

Collection task, or collected through a third-party tool.

• Importing CLI Output Commands on page 244

Importing CLI Output Commands

Hardware information can be imported from text files containing CLI output commands.

The following is a partial list of currently supported CLI output commands:

Juniper Networks Junos OS

• show version

• show chassis hardware

Cisco IOS

• show version

• show hardware

• show diag

• show env all

• show idprom backplane

Cisco XR

• show version

• show hardware

• show diag
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Cisco Catalyst

• showmodule

Nortel Passport

• show config

Alcatel SR

• showmda

Riverstone

• show version

Configs Collected by Rancid

• Cisco IOS

• Juniper Networks Junos OS

• Tellabs

Importing and Saving

Hardware information froma livenetworkcanalsobe importedon-demandvia real-time

SNMP and CLI outputs. Previously saved SNMP, CLI, and CSV data can also be imported

for an offline network. To do this, open the Hardware Inventory window by selecting

Inventory > Hardware Inventory. Then, at the bottom of the window, there is a toolbar

with Load and Save buttons.

Clicking on the Load button displays several options.

DescriptionField

Collect real-time SNMP and CLI data from a live network.Collect Inventory

Load previously saved SNMP output.SNMPOutput

Load previously saved CLI output.CLI Output

Load previously saved CSV data.Node/Shelf/Card Descriptions

Clicking on the Actions > Save button displays several options.

DescriptionField

This saves the current report displayed in the right pane. Different reports can
be selected via the tree in the left pane.

Current Report

Saves node/shelf/card descriptions for all devices in the network to a CSV file.All Node/Shelf/Card Descriptions
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DescriptionField

Save the current complete hardware profile for future comparison.All Hardware Information for Comparison

Hardware Inventory File Format

When using CLI to collect the hardware information, the raw data files are saved into

directory /u/wandl/data/collection/.LiveNetwork/equipment_cli. The file naming

convention is “<Router Profile Name>.equipment_cli”.

When using SNMP to collect the hardware information, the raw data files are saved into

directory /u/wandl/data/collection/.LiveNetwork/equipment. The file namingconvention

is “<IP>.iftable” and “<IP>.snmp”.

From the raw data, hardware inventory files are generated into XML format in directory

/u/wandl/data/livenetwork_output_directory/swconf.x. The file naming convention is

“<hostname>.xml”. Each collection methodmay have slightly different raw data values

which is dependent on the device vendor. Also, SNMPmay not be able to collect certain

data fields that CLI can collect and vice versa. If both SNMP and CLI collectionmethods

are used, the combined data collected will compliment each other in the hardware

inventory files.

From the hardware inventory files, hardware inventory reports in CSV format can be

generated by running Task Manager > Hardware Inventory Reports. The output directory

of the reports can be specified alongwith options to timestamp the file names and save

the reports to theWeb. The CSV reports created are listed in the table below.

DescriptionFilename

Device, IP, Vendor, OS, Chassis, Hardware ID, Boot Image, ROM, Memory,
Processor

ROUTER_LIST

Card ID, Part #, Serial #, Port countCARD_LIST

Interface, IP, Status, Physical AddressINTF_LIST

TransceiverTRANSCEIVER_LIST

Miscellaneous parts: power supply, fan, displayMISC_PART_LIST

Cost, Part Type, Component Name grouped by DeviceHW_CAPEX_REPORT

Cost, Part Type, Component Name grouped by Part TypeHW_PARTS_REPORT

Card Usage, Port Usage grouped by DeviceHW_DEVICE_USAGE_REPORT

Card Usage, Port Usage grouped by CardHW_LINECARD_USAGE_REPORT

Integrity Check report for unknown or unsupported dataHW_IC_REPORT
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Hardware Inventory

When a network is loaded, the Hardware Inventory window can be opened by selecting

Inventory >Hardware Inventory. This window contains reports and information about the

hardware at each individual node in the network. When viewing hardware information

at a specific node, the Hardware Inventory window is split into two panes. The left pane

displaysa tree listingall existinghardware (routers)andsummary reports. The rightpane

displays the content of the item selected in the left pane.

Hardware Inventory Summary

When the Hardware Inventory window is opened, the right panewill show a summary of

all the equipment in the network. This provides a quick tally of the number and types of

devices and interfaces in the entire network.

Figure 132: Hardware Inventory Summary

Devices List

SelectingDevices in the left panedisplaysaDevice List report in the right pane. The saved

report’s filename starts with “ROUTER_LIST.” Clicking on the small icon to the left of

Devices in the left pane will expand the tree to show a list of routers in the left pane.

These devices can then be individually selected to display a detailed Equipment View in

the right pane for the selected router. See “Equipment View” on page 263 for more

information
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Figure 133: Device List

Various actions can be executed by right clicking on a row and selecting an item from

the popupmenu. The items in this popupmenu are available for many reports in the

Hardware Inventory window, though not all reports will contain all items.

• NodeDetail:Brings up aNodewindowwith detailed information about the node in the

selected row.

• Highlight: Highlights the relevant node in the Map window.

• ShowConfig:Opens the router configuration file for the relevant node if such a file is

available.

• Show Equipment: This will open the Equipment Viewwindow for the relevant node.

The Table Options window can be opened by right clicking on a row in a report and

selecting Table Options. This is useful for customizing the type of information displayed

in the report.
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Figure 134: Hardware Inventory Table Options

Selecting Use image icons or checkbox if applicable displays image icons in vendor and

status cells that make the reports more visually pleasing and easier to comprehend at

a glance. The Autofit to window option will, when selected, automatically resize the

column widths to fit the width of the report window. In the bottom half of the Table

Options window, specific columns can be either included are excluded from the report.

DescriptionColumns

Device name converted into IP/MPLSView formatName

Device hostnameHostname

Device vendor (for example, Cisco, Juniper Networks)Vendor

Loopback IP address of the Device, typically the first one listedIP Address

Filename of collected configuration fileSource

The type of chassis, for example, WS-C6509-E (similar to SNMP chassisType)Chassis Type

Operating System Version, for example, 12.2(53)SEOS Version

SNMP sysContactContact*

Device descriptionDescription
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DescriptionColumns

SNMP sysLocationLocation*

SNMP sysNameSystem Name*

The boot image, e.g, a string starting with flash:, bootflash:, disk0:Boot Image

Non-volatile configuration memory (bytes)Configuration Memory

Non-volatile configuration memory in use (bytes) SNMP nvRAMUsedConfiguration Memory in Use*

SNMP configRegister, for the configuration register valueConfiguration Register*

Equivalent of SNMP chassisId, which defaults to the chassis serial numberHardware Id

Equivalent of SNMP chassisVersion, which defaults to the chassis hardware revision
level

Hardware Version

The last time this file was updated by CLI collectionLast Update by CLI

Equivalent of SNMP processorRam, based on RAM available to CPU (bytes)Memory

The Management IP Address is the IP addressed used by IP/MPLSView to discover
the device.

Mgmt IP Addr

The Hardware model can provide additional detail not known from the vendor, for
example, by distinguishing JUNIPER and JUNIPER_EX

Model

The operating system family (for example, IOS, Junos OS)OS Family

The device processor, for example, PowerPC405Processor

SNMP romSysVersion, which contains the ROM system software versionROM System Version*

SNMP romVersion, which contains the ROMmonitor versionROM Version

NOTE: SNMP fields will not be populated if hardware inventory is collected
by CLI.

Related
Documentation

•

Line Cards

Selecting LineCards in the left pane displays a Card List with information on all the cards

in the network. The saved report name starts with CARD_LIST. This list is useful for

managing aspects of a network related to card capacity, such as keeping track of how
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many ports of a specific type are available in the network. The Table Options (right-click

a table header for this menu option) can be used to add additional columns such as the

Version.

Figure 135: Hardware Inventory: Line Cards

DescriptionColumn

Device hostnameHostname

Line card name, for example, WS-X6704-10GEName

Device name converted into IP/MPLSView formatDevice Name

Vendor Hardware vendor (Cisco, Juniper Networks)Device

Slot information, for example, S-0/1Card Id

Ports Number of ports that (a) have a corresponding link in
themodel, (b)areoperationally up, or (c)havean IPaddress
defined on the interface

Connected

Number of physical portsNo. of Ports

Line Card Part numberPart

Line Card Serial numberS/N

Line Card Version information, for example, rev A0 ver 4Version

Controller memory (Cisco-specific field)Controller Mem.*

Estimated hardware costCost (Estimated)
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DescriptionColumn

Line Card DescriptionDescription

Loopback IP address of the Device, typically the first one
listed

Device IP Addr.

The Management IP Address is the IP addressed used by
IP/MPLSView to discover the device.

Device Mgmt IP Addr.

Details related to the Field Replacement Unit (Cisco)FRU Line Card FRU

Packet Mem.

FRU Route Mem.

Details related to the L3 Engine (Cisco)L3 Engine

L3 Engine Type

NumberofReservedports, basedoncustomizablekeywords
found in the description.

Reserved Ports

Ports that have operational or admin status downShutdown Ports

Top Assembly Number (Cisco ordering number)TAN

NOTE: NMP fields will not be populated if hardware inventory is collected
by CLI.

Related
Documentation

•

Physical Interfaces

Selecting Physical Interfaces in the left pane displays an Interface List report listing all

interfaces, their status, and additional information in the right pane. The saved report’s

filename starts with “INTF_LIST.” The rows in the report can be sorted by clicking on the

column header for the property to sort by.
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Figure 136: Hardware Inventory: Physical Interfaces

DescriptionColumn

Physical Interface Name, for example, TenGigE0/2/0/2Name

Device hostnameHostname

Device name converted into IP/MPLSView formatDevice Name

Hardware vendor (Cisco, Juniper Networks)Device Vendor

Slot information, for example, S-0/1Card Id

Physical interface descriptionDescription

IP address of physical interface, if assignedIP Address

Loopback IP address of the Device, typically the first one listedDevice IP Addr.

The Management IP Address is the IP addressed used by IP/MPLSView to discover
the device.

Device Mgmt IP Addr.

Interface Administrative status (active, down, or unknown)Admin Status

The address of the physical interface, based on intfmap IP/MPLSView file.Physical Address

Any associated aggregated link, such as PortChannel or Bundle-EtherAggregated Link

he physical interface bandwidth, for example, 100.0MBandwidth T

IPv6 address information (based on IP/MPLSView intfmap file)IPv6

MTU information (based on IP/MPLSView intfmap file)MTU
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DescriptionColumn

The Physical interface media type, for example,

ATM,BRI,BVI,Cable,Channelized
E1,DS,E1,Ethernet,FE,GE,OC3/STM1,T1,T3

Media Type

Interface Operational Status (active, down, or unknown)Operational Status

Switchport mode for layer 2 interfaces, for example, access or trunkSwitchport Mode

List of VLAN’s for this physical interface, for example, “22 100-102 105-108”VLAN

Related
Documentation

•

Transceivers

Selecting Transceivers in the left pane displays a Transceivers List with information on

all the transceivers or small form-factor modules of devices in the network. This report

can be filtered and sorted by clicking on the appropriate column headers. The saved

report’s filename starts with TRANSCEIVER_LIST_LIST.
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Figure 137: Hardware Inventory: Transceivers

DescriptionColumn

Transceiver name, for example, SFP-10GBase-ERName

Device hostnameHostname

Device name converted into IP/MPLSView formatDevice Name

Hardware vendor (Cisco, Juniper Networks)Device Vendor

Loopback IP address of the Device, typically the first one listedDevice IP Addr.

Slot information, for example, S-0/1Index

Part numberPart

Serial numberS/N

Estimated hardware costCost (Estimated)

Related
Documentation

•
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Miscellaneous Parts

SelectingMisc Parts in the left pane displays aMiscellaneous Parts List with information

on all the power supplies and fans of devices in the network. This report can be filtered

and sorted by clicking on the appropriate column headers. The saved report’s filename

starts withMISC_PART_LIST.

Figure 138: Hardware Inventory: Misc Parts

DescriptionColumn

Name of miscellaneous part, for example, “Power Supply 1”Name

Device hostnameHostname

Device name converted into IP/MPLSView formatDevice Name

Hardware vendor (Cisco, Juniper Networks)Device Vendor

Loopback IP address of the Device, typically the first one listedDevice IP Addr.

Description of miscellaneous partDescription

Part numberPart

Serial numberS/N

Estimated hardware costCost (Estimated)
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Related
Documentation

•

Extensive Parts List

Selecting Extensive Parts List in the left pane displays a report listing all parts along with

the part number, serial number, description, and the device it belongs to in the right pane.

The rows in the report can be sorted by clicking on the column header for the property

to sort by.

Figure 139: Hardware Inventory: Extensive Parts List

Related
Documentation

•

Hardware Integrity

The Hardware Integrity report window provides a summary check of possible errors in

the hardware configuration as represented by the Hardware Model. This report can be

sorted by clicking on the appropriate column headers. This report is useful when, for

example, checking to make sure that all links have connected interfaces. The saved

report’s filename starts with “HW_IC_REPORT.”
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Figure 140: Hardware Inventory: Hardware Integrity

DescriptionColumn

Device name converted into IP/MPLSView formatDevice Name

Severity level of integrity check: Info,Severity,WarningSeverity

Description of the integrity check findingDescription

Related
Documentation

•

Device Usage

The Device Usage report provides an estimate of the degree to which all the cards and

ports in the nodes of the network are being utilized. The report lists total numbers of

cards and ports side by side with the number of utilized cards and ports, sorted by node,

to give you an idea ofwhere the network stands in terms of hardware capacity and usage

at each node. You can also choose to show interface usage through the table options

window (by right-clicking on the column headers). The saved report’s filename starts

with “HW_DEVICE_USAGE_REPORT.”
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Figure 141: Router Inventory Reports: Device Usage

DescriptionColumn

Device hostnameHostname

Device name converted into IP/MPLSView formatDevice Name

Number of line cards which are usedOccupied Line Cards

Number of line cards which are emptyAvailable Line Cards

Total number of line cardsTotal Line Cards

Number of ports that (a) have a corresponding link in the model, (b) are
operationally up, or (c) have an IP address defined on the interface

Connected Ports

Total Number of physical portsNo. of Ports

Number of Reserved ports, based on customizable keywords found in the
description.

Reserved Ports

Ports that have operational or admin status downShutdown Ports

Related
Documentation

•

Line Card Usage

The Line Card Usage report lists all the cards in the network sorted by card type and

provides usage information for these cards. This is useful when searching for capacity

information, such as the number of port vacancies in a particular type of card in the

network. The saved report’s filename starts with “HW_LINECARD_USAGE_REPORT.”
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Figure 142: Hardware Inventory: Line Card Usage

DescriptionColumn

Name of line cardCard Name

Corresponding device name converted into IP/MPLSView formatDevice Name

Slot information, for example, S-0/1Card Id

Number of ports that (a) havea corresponding link in themodel, (b) are operationally
up, or (c) have an IP address defined on the interface

Connected Ports

Total Number of physical portsNo. of Ports

Number ofReservedports, basedoncustomizable keywords found in thedescription.Reserved Ports

Ports that are operationally or administratively downShutdown Ports

Related
Documentation

•

Customer Usage

The Customer Usage report displays network usage on a per customer basis. Customer

names are parsed from the interface comments in the imported configuration files. The

regular expression used to parse the customer names can be customized by selecting a

device from the Hardware Inventory window, going to the Logical View panel, selecting

Actions>Options, andgoing to theMisc tab. There, youwill seea sectioncalledCustomer

Identifier with a field called Use regular-expression in interface description. Enter your

custom regular expression here.
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Theparser looks for customernameswithinparenthesis. For example, tomatchanumber

sequence in interface comments of the format, cust####..., use the expression,

cust([0-9]+).* There is currently no way to define customers other than parsing them

from interface comments in the imported configuration files.

Figure 143: Hardware Inventory: Customer Usage

Related
Documentation

•

Hardware Capex

The Hardware Capex report window displays the hardware costs associated with the

network grouped by node. A similar cost report grouped by parts is also available, as is

explained below. To expand or collapse a group in the Hardware Capex report, click on

the small icon to the left of the node name. To expand or collapse all groups in the

Hardware Capex report, simply right click anywhere in the report and select Expand All

or Collapse All. The saved report filename starts with HW_CAPEX_REPORT.
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Figure 144: Hardware Cost

DescriptionColumn

Device hostnameDevice

Type of component (for example, Chassis, Card, or Scvr)Type

Slot information, for example, S-0/1Index

Name of the component, for example, 26xGEComponent Name

Estimated Cost of componentCost (Estimated)

Related
Documentation

•

Categorized by Parts

The information contained in the Categorized by Parts sub-report is related to that of

the default Hardware Capex report. However, the grouping of the costs is different, as

this report lists costs based on the component type rather than for each node. The saved

report’s filename starts with HW_PARTS_REPORT.
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Figure 145: Hardware Inventory: Hardware Costs Categorized by Parts

DescriptionColumn

Type of component (for example, Chassis, Card, or Scvr)Type

Name of the component, for example, 26xGEComponent Name

Count of such components in the deviceCount

Estimated Cost of componentCost (Estimated)

Related
Documentation

•

Equipment View

The Equipment Viewwindow provides detailed information on the chassis, cards, ports,

and interfaces on any given router. It can be accessed by right clicking on a node in the

Map window and selecting View > Equipment View. There are two types of views in

Equipment View, accessible by clicking on the appropriate tabs at the top of thewindow:

Logical View and Tabular View.

Logical View

Logical View provides a schematic representation of the hardware at the node. Empty,

occupied, and designated template slots are distinguished by different colors which can

be customized as described later in this chapter.

Connected and disconnected ports are distinguished by the symbols next to the port

name. Connected ports have a colored bar in the circle, whose color can be customized

in the Options window. A port is considered connected here if there is a link in the bblink
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file associated with this port (Network > Elements > Links). Left clicking on a port will

popup a translucent window showing detailed information about the port.

Figure 146: Equipment View for a Specific Router: Logical View

Additional detailed port information can be displayed by right clicking on the port and

selecting an option from the table below. The available options may vary depending on

the network model:

DescriptionField

Selecting this will open the Demands window to display all demands going through
the port.

Show Demand

Selecting this will open the Links window to display all links connected to the port.Show Link

Selecting this will open the Demands window to display all demands going through
the card.

Show Demands in Card

Selecting this will open the Links window to display all links connected to the card.Show Links in Card

This displays ca view of the card along with all the links attached to the card and the
nodes on the other end of those links.

Card Connections View

This displays details about the card in the Properties pane to the right.Display Card Details

This displays details about the port in the Properties pane to the right.Display Port Details
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Figure 147: Card Connections View

Logical ViewMode Button

Clicking on the Logical ViewMode button will open amenu through which youmay

customize the window.

DescriptionMenu Item

This displays the color legend used for this window.Show Color Legend

This displays the full names of the ports in each slotShow Fullname

This causes only the port name to be displayed next to each port.Hide Metrics

This causes the total egress and ingress demand bandwidth to be displayed next to
each port.

Show Demand Egress, Ingress

This causes a horizontal bar graph representing total port utilization to be displayed
next to each port.

Show Utilizations

Selecting this displays all unused slots. De-selecting this will hide all unused slots.Show Empty Slots

If template slots have been defined, selecting this displays these slots.Show Pre-planned Slots

This controls how slots or displayed. Vertical displays slots on top of each other, while
Horizontal displays slots side by side.

Slot Orientation
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DescriptionMenu Item

This controls how slots are ordered. Ascending will order slots from lowest index to
highest index, while Descending will order slots from highest index to lowest index.

Slot Ordering

This displays VLANs that are connected to the card.Logical Port Connections

This item is available only if there are VLANs connected to the card, andwill highlight
the VLANs if they exist.

Highlight VLAN ID

This item is available only if there are VRFMemberships defined on the card, andwill
highlight the relevant ports.

Highlight VRF Membership

This item is available only if there are VRMemberships defined on the card, and will
highlight the relevant ports.

Highlight VRMembership

Tabular View

Tabular View can be accessed by clicking on the Tabular View tab at the top of the

Equipment Viewwindow. This displays the Hardware Model information for the node in

tabular form. The top pane of Tabular View displays a summary of interface types and

bandwidth information. The bottompane lists all ports and interfaces in a sortable table

along with their attributes and related information.

Figure 148: Equipment View for a Specific Router: Tabular View
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You can use the Actions button to bring up amenu through which various Hardware

Model relatedactionscanbecarriedout. Theseactionsareusefulwhenyouare interested

inviewingadditional informationabout theparticularnodeormodifyingvariousproperties

on the node.

DescriptionMenu Item

Opens up the standard Node window for the current node to display additional information.Node Detail

Highlights the node in the Map window.Highlight

Open the config file for the current node in a text editor.Show Config

This allows you to save the Hardware Model for the current node as a Template in a client side
xml file. This Template can later be imported and applied to additional nodes.

Save As Template

Opens the Hardware Modeling Template window through which youmay apply an existing
template to the current node.

Hardware Template

Prints a report of the current hardware information.Print

Savesa text report of the currentHardwareModel information for the current node to the client.Report

Refreshes the Hardware Model information of the current node using SNMP data. Youmust
be connected to the device and have the necessary login information to use this option.

Refresh using SNMP

Refreshes the Hardware Model information of the current node using CLI data from Cisco and
Juniper Networks hardware. Youmust be connected to the device and have the necessary login
information to use this option. The commands issued during CLI refresh are as follows:

Cisco hardware:

• show version

• show diag

• show env all

• show idprom backplane

• showmodule

Juniper Networks hardware:

• show chassis hardware

• show version

Refresh using CLI

Hides the Properties Pane normally displayed on the right side of the Equipment Viewwindow.Hide Properties Pane

Opens an Options window that allows you to set various options related to how Hardware
Model information is visually presented in the Equipment Viewwindow.

Options

Various options related to how information is visually displayed in the Equipment View

windowcanbecustomized in theHardwareModelingOptionswindow,accessible through

the Actions button in the Equipment Viewwindow by selectingOptions.

General Tab
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In the General tab of the Hardware Modeling Options window, youmay choose how

optical ports are represented in the Equipment Viewby selecting an option in theOptical

Port Representation field. In the bottom half of the window, you can customize what

type of information is displayed in the bottom table of Tabular View.

Figure 149: Hardware Modeling Options: General

View Tab
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Figure 150: Hardware Modeling Options: View

TheView tabof theHardwareModelingOptionswindowallowsyou to customize various

color, font and text position properties in Logical View. To change the color of a property,

simply click on the color bar and a newwindowwill pop up fromwhich a new color for

property can be chosen. The font used to display information in Logical View can also

be changed here by clicking the Edit button. The position of the card label in Logical View

can be customized to be shown either on the top or bottom of the card.

Device Specific Tab

Cisco IOS XR, Ignore preconfigured ports in Hardware Model: An interface that does not

yet existmaybeconfiguredusing the “interfacepreconfigure” command.Those interfaces

are included by default with status “planned”. If this Ignore option is selected, those

interfaces will not be displayed and the port counts may decrease as a result.

Template Tab
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Figure 151: Template Tab

Apply Template: Here you can also specify the default state to be used when applying

card templates.

Identifiers Tab
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Figure 152: Hardware Modeling Options: Identifiers

• ReservedPort Identifier:For theDeviceUsageReport, if the interfacedescriptioncontains

oneof the strings in this commaseparated list, that interface is interpretedasa reserved

port. Note that the Reserved Ports column can be added to the report display by

right-clicking the table header and selecting Table Options.

• ReservedPort Identifier:For theDeviceUsageReport, if the interfacedescriptioncontains

oneof the strings in this commaseparated list, that interface is interpretedasa reserved

port. Note that the Reserved Ports column can be added to the report display by

right-clicking the table header and selecting Table Options.

• Customer Identifier: For the Customer Usage report, interfaces are associated with

customers based on the interface description field. For example, to match a number

sequence in interface comments of the format, cust####..., use the expression,

cust([0-9]+).*

• User Defined Port Identifier: Suppose you want to count the number of interfaces in a

line card containing a particular keyword in its description. Add the desired strings in a

comma-separated list, each surrounded by quotations marks, similar to the Reserved

Port Identifier format. Select the Line Cards report, right-click the table header, and

selectTableOptions to adda column for each keyword, to see the number of interfaces

containing that keyword.

The Properties Pane
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The Properties Pane is displayed on the right side of the Equipment Viewwindow and

containsuseful informationabout thecardandports in thechassis. It providesanoverview

of the hardware, node details, and card details. The Properties Pane can be closed by

clicking the [x] button on the top right and shown through clicking the Actions button

and selecting ShowProperties Pane.

Event View

The Hardware Inventory window is capable of displaying hardware related event counts

fromtheLiveNetwork. This requiresopening theEventMapbeforeopening theHardware

Inventory window. Click the Events button and select the desired view. The event count

appears in the left panel under Devices.

• Show node event count always displays the total number of events.

• Show updated event count only displays the number of new events since refreshing

the hardware inventory window. Selecting a device will clear the counter.

• Hide event count hides the event counters.

Thenumberofeventsoneachnodearedisplayedagainstabackgroundcoloredaccording

to the Event Map severity legend. Note that some of the event counters are followed by

a `+' symbol. In this case, the counter represents the number of events belonging to the

worst severity category used for the background color and the `+' symbol indicates that

there are additional events of lower severity not factored into this counter.

If a physical port goes down, the port icon will flash.

When new events occur, a lightning bolt icon will appear. Clicking on the icon opens a

newwindow similar to Event Browser with the related events.
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Figure 153: Hardware Inventory Device Events View

Right-clicking in the Logical View panel opens a pop-upmenu to Show Events by node,

card, or port. This opens a newwindow similar to Event Browser with only the events

relevant to the device selected.

273Copyright © 2018, Juniper Networks, Inc.

Chapter 12: Inventory Menu



Figure 154: Hardware Inventory Device Show Events

Hardware Equipment Cost

NOTE: This feature applies to router networks only.

For pricing purposes, you can specify the cost for certain ports, cards or chassis within

the Hardware Model. Cost data can be set either:

• Globally, by selecting from themain menu Inventory > Hardware Equipment Costs.

• Individually, per device. In the EquipmentView for a particular device, select the Logical

View tab. Within the Logical View, youmay right click on a card and selectModify

Properties > Chassis orModify Properties > Card from the popupmenu. The price for

that specific Chassis or Card can then be entered into the price field.

• By editing the cardcost file as described in Hardware Equipment Cost File.

The hardware equipment costs window displays the costs of all equipment that has

been defined. It allows you to add,modify and delete cards from its list. This list includes

per port costs,whichareusedwhennomatching cards canbe found, as explainedabove.

Three sets of equipment costs can be defined using this window. They are chassis, card

andport costs. Port costs arealsoused if aparticular card is notdefined in theequipment

costs table.
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Figure 155: Hardware Equipment Cost

Note that the initial costs indicated in theHardwareEquipmentCostwindowarearbitrary

values to help you get started. To add an item to the Hardware Equipment Cost window,

simply click the Add button, and a newwindowwill popup allowing you to enter the

necessary values. Tomodify an item, select the item and click theModify button. To

delete an item, select the item or multiple items and click the Delete button.

Note that the hardware equipment costs are saved on a per-network base. Youmay

importacustomHardwareEquipmentCost listbyclicking the Importbuttonandbrowsing

to the appropriate file.

For cards, the Component Name can be substituted with the Part Number of the card.

The Hardware CapEx report will associate the cost of the card to the part number. The

Part Number can be found in theHardware InventorywindowDevices or LineCard views.

• If no price is specified in the price field in Equipment View, then the program calculates

a default price based on the information in the Hardware Equipment Cost window as

follows:

• If the name of the card in Equipment Viewmatches a card name in the Hardware

EquipmentCostwindow, the cost of the card in theHardwareEquipmentCostwindow

is used for the card in Equipment View.

• If no exact match can be found based on card name, then the programwill search for

amatch based on the type and number of ports on the card. If an appropriate card can

be found in the Hardware Equipment Cost window that matches the specifications of
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the card in Equipment View, then the price of that card in the Hardware Equipment

Cost window is applied to the card in Equipment View.

• If no appropriate card in the Hardware Equipment Cost window can be found that

matches the specificationsof thecard inEquipmentView, thenapricebasedondefault

per port pricing as defined in the Hardware Equipment Cost window is calculated for

the card in Equipment View.

Hardware Equipment Cost File

Whenyoumodifyoradd to theHardwareEquipmentCostwindowandsaves thenetwork,

a cardcost.runcode file is created which contains the Hardware Equipment Cost

information for that specific network. Thecardcost file is referenced fromthespecification

file using the keyword “cardcost” . The format of this file can be used to create a custom

file that canbe imported into theHardware EquipmentCostwindowasdescribed above.

Some sample lines along with field descriptions are provided below.

Specific Card Cost

# Vendor, Name, 'card', Cost, Number of Ports, Media, Description
Cisco, LC-4OC3/POS-SM, card, 39000.0, 4, OC3/STM1, "4port OC3/STM1 Card"

Generic Port Cost

# Vendor, Name, Media, Cost per port
Juniper, -, OC12/STM4, 29000.0

Depending on the format used, the programwill recognize the cost as a specific card

cost or a generic port cost.

Templates

The Templates are an advanced feature used to map individual hardware components

with a specific brand and type ( for example, Cisco 12816 or Juniper Networks M40).
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Figure 156: Hardware ModelWorkflow

There are two levels of templates in the Hardware Model feature: Chassis and Card. A

Chassis Template defines the number of slots on the chassis and can also designate a

slot to be occupied by a card template if so desired. A Card Template defines the number

of ports on the card as well as the media type of the ports. When a Chassis Template is

applied to a node, that node receives all the properties of the Chassis Template. To view

the list of available templates, click on the Tools menu and select HardwareModel

Template.
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Figure 157: Hardware Model Templates

Template Actions

When clicking on the Actions button in the templates window, the following options are

available:

DescriptionAction

This opens the Chassis Template Builder window, allowing you to create a new
chassis template.

New Chassis Template

This opens the Card Template Builder window, allowing you to create a new
chassis template.

New Card Template

Import templates from a CSV formatted spreadsheet.Import from Spreadsheet

Import templates from the Hardware Equipment Cost window.Import from Hardware Equipment Cost

Saves the current template information in a CSV formatted spreadsheet file.Export

Organizing Templates
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When right-clicking in the templates window, the following options are available:

DescriptionAction

Creates a new folder in which to organize templates. Note that templates can be
dragged and dropped into this new folder.

Create Category

Creates an alias for the selected template.Create Alias

Creates a duplicate of a template.Duplicate

Opens a template to be viewed andmodifiedView/Modify

Renames a templateRename

Opens the Apply Template window, allowing you to select a set of nodes to which
the selected template is applied.

Apply Selected Template

Removes a template from the template libraryDelete

Chassis Template Builder

Figure 158: Chassis Template Builder

In this window, you can specify the following fields:
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• Vendor/model (select a generic vendor if the desired vendor is unspecified)

• Chassis name

• Part number

• Number of shelves: Currently, only switches are allowed to havemore than one shelf.

In the future, the programwill support multiple shelves for standard routers as well as

switches.

• Description

• Slot number starts from 1: This options specifieswhether the slot number starts at 1 (or

0).

• Shelf name

• Number of slots

• Shelf layout

Once you select the number of shelves, you can select a particular shelf to specify the

shelf layout by using the Shelf Index’s previous and next buttons. For a particular shelf

name, you can specify the number of slots on that shelf using the up and down arrows

next to No. of Slots..

To customize the shelf layout using the available cards, you should select the slot(s) in

the shelf layout to which the card is applied. To select a range of shelves, you can click

the first shelf and <Shift>-click the last shelf. To select shelves one by one, you can also

<Ctrl>-click each additional shelf. Once the shelves have been selected, you should

select a card from the Available Card(s) list. If the desired card does not exist, you can

create a new card by right clicking in the Available Card(s) list and selecting NewCard

Template.Whenboth the shelvesand thecardhavebeenselected, clicking theSetbutton

will assign the selected card to the selected shelves.

Shelf Layout Options

DescriptionAction

Moves selected card into selected slotsSet

Erases the cards in selected slotsClear

Selects all slotsSelect All

Deselects all slotsDeselect All

Chassis Template Builder Options

DescriptionAction

Imports template information from an XML fileImport

When inmodifymode, this option is used toapply the template to specific nodes in thenetwork.Apply
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DescriptionAction

Saves the chassis template information in the template librarySave

Saves the chassis template information as an XML file on the client machineSave As

Brings up the online help for the hardware model chapterHelp

Applying the Template

A selected template can be applied to nodes by pressing the Apply button.

Figure 159: Apply Template

The template is applied to the nodes selected by you in the Router list. To select one at

a time, you can click the checkboxes to the left of those nodes. You can also select a

range of rows by clicking the first row and shift-clicking the last row. Then you can select

or de-select those entries from the right-click menu. Click Apply to have the template

applied to selected nodes.

• Select All: Selects all rows

• Mark as Selected: Marks selected rows

• Clear: Clears selected rows

• Clear All: Clears all rows

Card Template Builder
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Figure 160: Card Template Builder

You should specify the following fields

• Apply this template to: Select the vendor here � � � � � � � �

• Card Name: Required field

• Abbreviation

• Part Number

• No. of adapters

• Max No. of Ports

• Description

• CPU/Processor card

• Ports in Card

Modifying Ports

When a new card is created, the ports are all unassigned. It is up to you to assign specific

media types to each port. This is done by selecting the desired ports in the box labeled

Ports in Card, specifying the proper settings to the right, and clicking the Change button

to apply the settings to the selected ports. Below is a list of the settings available for a

port.
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• Port Name

• Adapter No.

• Port No.

• Bandwidth (bps)

• Port Media: Selecting the Port Media automatically populates the Bandwidth (bps)

field

Card Template Builder Options

DescriptionAction

Imports template information from an XML fileImport

Saves the slot/card template in the template librarySave

Saves the template information into an XML file on the client machine for later import.Save As

Vendor Hardware Support for Templates

Aspecific vendor canbespecifiedduring chassis or card template creation. TheHardware

Model template module supports the following vendors: Cisco, Juniper Networks,

Riverstone, Alcatel, Nortel, Tellabs. For all other vendors, this field can be set to Generic.
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CHAPTER 13

Report Manager

TheReportManager, accessed from themainmenuReport >ReportManager, generates

network reports including link utilization reports, cost reports for links, hardware and

demands, load reports, and simulation.

Each report possesses sorting and filtering functions, allowing you to easily pinpoint the

source of problems. These reports are automatically saved onto the server or youmay

save a copy onto the client.

NOTE: Further descriptions of the reports can be found in the Output Files
chapter of the File Format Reference For NPAT and IP/MPLSView.

• The Report Manager Window on page 285

• List of Network Reports on page 292

• List of Tunnel Layer Network Reports on page 296

• List of Simulation Reports on page 297

• List of Configuration Reports (Router Only) on page 299

• Customized Reports on page 300

• Network Reports on page 305

• Tunnel Layer Network Reports on page 336

• Simulation Reports on page 337

• Configuration Reports on page 339

The Report ManagerWindow

The Report Manager window is split into two panes, where the left pane displays the

available reports in a tree view, and the right pane, or Results Pane, displays the contents

of the selected report. The reports are categorized into the following categories:
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• Network Reports: These are the main network reports, including path, utilization, and

cost reports. These reports are dynamically generated, meaning the report is always

up todate, reflecting thecurrent stateof your networkmodel. Each time that theReport

Manager is opened, upon the first click of a report, the report is generated and saved

to the Report folder of the network model. For all other subsequent clicks on that

report, the report is read from the cache unless you close and reopen the Report

Manager, or chooses to regenerate the report, an option described in the next page.

• Tunnel Layer Network Reports: These are the tunnel layer related network reports,

including tunnel path and diversity, tunnel traffic, FRR, and tunnel RSVP BW reports.

• Simulation Reports: These reports provide information on the performance of the

network after running failure simulation. Certain reports are only available after running

specific failure simulations.

• TunnelLayerSimulationReports:These reportsprovide informationon theperformance

of the network relating to the tunnel layer after running failure simulation.

• Configuration Reports (Router only): These reports are generated when you import

network configuration files into your network model (via File > Import Data).

• Customized Reports: The customized reports are user-customized reports, where you

select columns of interest from an existing Node, Link, Interface, Demand, and Tunnel

report.

Figure 161: Report ManagerWindow - Report View

Some report windows contain a filter mechanismwhich allows you to search for any

expression.

DescriptionField

Provides an explanation of the currently selected report.Explanation

Allows two consecutive sorting methods to be applied to the current report.Multiple Sort

Displays the report in its original form prior to any sorting or searching.Restore
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DescriptionField

Opens a Column Selection window, allowing you to select which columns to display in the
report.

Select Columns

Refreshes the currently selected report.Re-Generate

This createsa file for filtering the report in textmode.The filter is basedon thequery specified
in the Advance Filter window.

Script

The actions available include setting columns to display, saving the report, and printing.Actions drop down

When therearemultipleperiods in the report, this allowsyou to select a specific timeperiod.LoadBw drop down

Performs the search as specified in the Filter field.Filter

Opens anAdvanced Filterwindow, allowing you to search by exactmatch, substringmatch,
wildcards, and regular expressions.

Advance Filter

Displays the page entered here. Enter the page number and click “Go” or click <Enter>.Go to page

Sets the number of lines that are shown on each page or the viewer. Enter the number of
lines to show per page and click “Set” or click <Enter>.

Lines Per Page

Some report are displayed simply as a text output without tables.

Figure 162: Report ManagerWindow - Text View

Additional Report Manager Actions

The following actions can be performed on the column headers in report view in the right

pane. Some actions are available by right-clicking on the column header.
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• Sort: The information displayed in the right pane of the Report Manager can be sorted.

Click on the column header to sort in an alphabetical order. To reverse sort, click the

header again.

• Select Columns: This function will open up a Columns Selection window allowing you

to select the columns to display in the report if applicable. The ordering of the column

headers can be set in this window or by dragging the column header in the report view.

• ShowAll Columns: Selecting this option displays all available columns for this report

in the right-pane.

• Reset the column order: If the column order has been changed, selecting this option

will reset it to its default order.

• Auto Fit This Column:Only the selected column is resized to fit the longest text entry.

• Auto Fit All Columns: All columns are resized to fit the longest text entry.

• Freeze Column: The column(s) are frozen for horizontal scrolling.

The following actions can be performed bt right-clicking on the report entry in the left

pane.

• Re-generate Report:When this option is selected, the programwill regenerate the

report and update any fields that might need updating.

• SaveWhole Report to Client: Any available reports in the Report Manager can be

exported to a Comma-Separated Values (CSV) file. Selecting this option will open up

a directory chooser window and allow you to save the report to the desired location.

This will save the entire report ignoring any filters applied.

• Save Filtered Report to Client: If you have used any of the filter functions on the report,

then only the filtered results are saved.

• Convert Report: Saves the report into the desired format. Choose from XML,

Comma-Separated Values (CSV), or Hyper-Text Markup Language (HTML). Indicate

an Output File name on the server in which to save the report. The report is saved into

the Output Path as indicated in the File Manager window. To change the path, press

the “Browse” button and navigate to the desired directory. You can also save a copy

of the report to your local client, by marking the “Copy to client” checkbox. Press the

“Browse” button to navigate to the desired location on your local machine.

• Generate Filter Script: This allows you to generate an advanced filtering shell script in

your UNIX server environment. Once created, this script enables you to create

customized reports fromexistingnetworkproject reportsata later time,withouthaving

to launch the IP/MPLSView client. This is useful for the advanced user whomay wish

to run batch processes for efficiency purposes, especially if he or she always needs to

customize the generated reports using specific filters. Filter Scripts are described in

detail in Advanced Filter Script Utility.

Report Options

Options that influence the output of these reports can be set in the Report Options

window of the Tools > Options > Report menu. These settings include node and link

references, bandwidth and distance units, and currency.
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Figure 163: Report OptionsWindow

See “Report Options” on page 361 for an explanation of additional items.

Advanced Filter Script Utility

The Advanced Filter Script utility allows you to create and then to apply a filtering shell

script in the Unix environment on reports that have been generated by the tool. This is a

convenient way to produce filtered reports without the need to launch the client. The

shell script can also be called by other scripts that are used for automated daily batch

report generation, for instance. The following figure, showing the Report Manager’s Path

& Diversity Report, is used to illustrate how to use the Advanced Filter Script in the

following steps.

NOTE: In the Report Manager, the Script utility is only available for reports
that are inCommaSeparatedValues (CSV) format, a format that is viewable
inmanyprogramssuchasMicrosoftExcel. If youdonot see theScriptbutton,
select Tools > Options > Report andmake sure that the Report Style is set to

CSV. Once that is done, go back to the Report Manager, right-click on the
report file name you are trying to view and select Re-Generate Report from

the popupmenu. If CSV format is supported for the report, it will then be
re-displayed in a table format.
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Figure 164: Demand Path and Diversity Report

1. First click on the Advanced Filter button to bring up the Advanced Filter window.

Suppose we want to only look at certain demands, such as demands starting from

ATL. One way to do this is to use the query, “From_Node# = ATL”.

2. ClickOK to apply the filter.

Figure 165: Define a Query in the Advanced Filter Window

3. Next, clickon theScriptbutton in theReportManager tobringup theAdvancedFiltering

Script window, as shown in the following figure. Youmay change the script file name

or the filtered report output file name by editing the Script File Name and Output File

Name text boxes, respectively. You can also choose to regenerate the original report

in full (in this case, the Path and Diversity Report) before the filter is performed on it.

To do so, mark the Generate New Report checkbox. Once you have finished with any

changes, click on the Generate button and a shell script is created in the output path.

In this example, PATHRPT.mpls-fish.sh is generated.
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NOTE: TheGenerateNewReportoptionworks formost reports.However,
itwill not regeneratecertain reports, suchasSimulationandConfiguration
(Router-only) reports, which are only created once during the
corresponding failure simulation, or configuration import operation,
respectively.

Figure 166: Advanced Filtering Script window

4. Next, log onto your server and navigate to the output directory. (You can do this via

Tools > Connect to Server.) Then, to execute the Advanced Filter shell script, simply

type the name of the script file at the command prompt, as shown in the following

figure.
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Figure 167: Run the Advanced Filter shell script

5. Once the shell script has been run, the filtered report is generated, as indicated by the

“Output Result” line as shown in the figure above. The following figure shows the

filtered report displayed in the Report Viewer (in the File Manager, right click on the

file name and selectOpenWith > Report Viewer.

Figure 168: Filtered Path and Diversity Report

List of Network Reports

Depending on the network type, the Report Manager displays a different set of reports.

The following table lists the available reports. Reports marked with (Router) are
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device-specific reports andwill only appear for the corresponding network type. All other

reports are general and should appear for all networks.

NOTE: Reports followed by an asterisk (*) require a feature-related license.

DescriptionFileDemand Reports

Lists details of all user demand requirements in the network. See
“Demand Reports” on page 305

PATHRPTDemand Path & Diversity

Displays the worst propagation and queueing delays for each
demand. See CoS Demands Report .

DEMANDCOSCoS Demands* (Router)

Provides utilization costs according to demand routes. SeeDemand
Route Cost Report .

CKTCOST_RTDemand Route Cost

Lists equal cost multiple paths that exist in the network for nodes
in the same AS and same OSPF area, and also for inter-area and
inter-VPN demands. See Equal Cost Multi-Path Report.

EQPATHRPTEqual Cost Multi-Path (Router)

Displays the demand path through links by interface out and in
sequence.

DEMAND_LINKDemand Link

DescriptionFileLink Reports

Provides demand bandwidth utilization information for each
link in the network. See “Link Reports” on page 310.

LKUTILPlanned Link Utilization

Provides demand bandwidth utilization information for each
physical interface in the network. See Planned Physical
Interface Utilization.

PHYUTILPlanned Physical Interface
Utilization

Shows link utilization by period from the interface ingress and
egress traffic files between connecting nodes.

MEASUREDLKBWRPTPer Node Pair (Measured)

Shows themeasured traffic by link based on the trafficload
file.

L3LINKUTILMeasured Link Util (based on
trafficload)

Showsthecomparisonbetweenplannedandmeasured traffic.
See Demand Traffic Versus Interface Traffic.

L3LINKUTILCOMPAREDemand Traffic vs Interface Traffic

Shows the comparison between planed andmeasured traffic
on physical interfaces.

L3PHYUTILCOMPAREDemand Traffic vs Physical
Interface Traffic

Displays the worst propogation and queueing delays for each
CoS class on each link. See CoS Links Report.

LINKCOS, L2_LINKCOSCoS Links* (Router)

Provides detailed link pricing information.LKCOSTLink Cost
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DescriptionFileLink Reports

Displays link partitions and their capacity allocation.LKPARTRSVP Bandwidth Allocation
(Router)

DescriptionFileInterface Traffic

Displays interface load and utilization information. See Interface Traffic
Report.

IntfUtilInterface Traffic (Router)

Displays interface Traffic by Class of Service.INTFCOSInterface CoS Traffic (Router)

Displays interface Multicast Traffic.INTFMULTICASTInterface Multicast Traffic
(Router)

Displays traffic information for interfaces at different AS’s. See AS Traffic
Report

ASTrafficAS Traffic (Router)

Displays traffic information between different AS’s. See Inter-AS Traffic
Report.

InterASTrafficInter-AS Traffic (Router)

For each node, displays an aggregate outbound and aggregate inbound
value, corresponding to the sum of traffic originating and terminating at
a node respectively - but only on interfaces that do not correspond to
any links in thenetworkmodel ( for example, customer-facing interfaces,
PE-CE interfaceswhenCEconfiguration filesaremissing fromthenetwork
model). This information is derived from themeasured traffic on the
interfaces (interface “egress” and “ingress” traffic files in the File > Load
Network Files window). One purpose for this file is for use in the Traffic
Matrix tool, as described in the Router Feature Guide for IP/MPLSView.

NWKTRAFInbound/Outbound Network
Traffic (Router)

DescriptionFileGroup

Shows summarized information for demands that are
requestedwithin agroupor between twodifferent groups.

GROUPDEMANDSUMMARYGroupDemandSummarybyGroup
Pair

Shows detailed information for demands that are
requestedwithin agroupor between twodifferent groups.

GROUPDEMANDDETAILGroup Demand Detail by Group
Pair

Shows summarized information for links that exist within
a group or between two different groups.

GROUPLINKSUMMARYGroup Demand Traffic on Link
Summary

Shows detailed information for links that exist within a
group or between two different groups.

GROUPLINKDETAILGroup Demand Traffic on Link
Detail

Shows summarized information for interface load of links
within a group or between two different groups.

GROUPINTFSUMMARYGroup Interface Load Summary
(Router)

Shows detailed information for interface load of links
within a group or between two different groups.

GROUPINTFDETAILGroup Interface Load Detail
(Router)
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DescriptionFileGroup

Shows traffic statistics for groups such as source,
destination, transit, and intra-group traffic.

L3GROUPLOADGroup Demand Bandwidth
Distribution

DescriptionFileNode

Shows statistical information on demands that originate, pass
through or terminate at each node in the network.

SWITCHCONNDemand Traffic Per Node

Displaysup to24periodsof total incomingandoutgoing traffic from
each node based on themeasured interface traffic data. Note that
only interfaces corresponding to links in the network model are
considered.

MEASNODELOADMeasured Interface Traffic Per
Node (Router)

Displays the number of ports on a node by link type.NodeLinkPortNode Link Port

DescriptionFileVPN

Reports the ingress and egress traffic on VPN interfaces
for each traffic load period.

VPNINTFTRAFVPN Interface Traffic (Router)

Reports VPN interface traffic broken down into CoS
classes.

VPNINTFCOSVPN Interface CoS Traffic
(Router)

Reports on the VPN interface multicast traffic load.VPNINTFMULTICASTVPN Interface Multicast Traffic
(Router)

Displays the route target export/import relationships that
exist between VPNs in the network.

VPNEXPORTIMPORTVPN Export-Import (Router)

Displays the details of Layer 3 VPN’s in the network.VPNREPORT_LAYER3Layer3 (Router)

Displays thedetails of Layer 2Martini VPN’s in thenetwork.
See Layer2 Martini Report .

VPNREPORT_LAYER2Layer2 Martini (Router)

Displays the details of Layer 2 Kompella VPN’s in the
network. See Layer3/Layer2 Kompella Report

VPNREPORT_L2KOMPELLALayer2 Kompella* (Router)

Displays the details of Layer 2 circuit cross-connect VPN’s
in the network.

VPNREPORT_L2CCCLayer2 CCC (Router)

Shows LDP based VPLS informationVPNREPORT_VPLSVPLS-LDP
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DescriptionFileVPN

Shows BGP based VPLS information. Juniper Networks
only.

VPNREPORT_VPLS_JUNIPERVPLS-BGP

DescriptionFileProtocols

Reports on Routing Instances for OSPF or IS-IS. For more
information, see the Router Feature Guide for IP/MPLSView,
Routing Instances chapter.

RTINSTRPTRoute Instance (Router) *

Displays all subnets in the network modelSUBNETRPTSubnet (Router) *

Also called the BGP Integrity Checks Report. It contains four
sections (select Application > Options > Report) including
UnbalancedBGPNeighborCheck, IBGPMeshConnectivityCheck,
Local/NeighborASSpecification, andRouteReflectorStatistics.
See “BGP Reports” on page 334

BGPRPTBGP > BGP * (Router)

Displays the load distribution between areas in the networkINTDOMLOADOSPF > Inter Area Load
Distribution* (Router)

Displays information regardingpathsbetweentwouser-specified
areas

INTDOMPATHOSPF > Inter Area Paths* (Router)

Generates information regarding demands passing through an
area in the network

DOMPASSTHRUOSPF > Area Pass through Paths*
(Router)

Shows summarized information for each OSPF area SeeOSPF
Area Summary

OSPFSUMMARYRPTOSPF > OSPF Area Summary*
(Router)

Shows detailed information for all routers in each OSPF area.
SeeOSPF Area Detail Report

OSPFDETAILRPTOSPF>OSPFAreaDetail* (Router)

Displays the bordering areas for each ABR. See ABR Bordering
Area Report.

ABRBORDERRPTOSPF > ABR Bordering Area* (Router)

List of Tunnel Layer Network Reports

DescriptionFileTunnel Reports

Displays details of all tunnels in the network and their paths.
.

TUNNELRPTTunnel Path & Diversity

Provides utilization costs according to tunnel routes.L2_CKTCOST_RTTunnel Route Cost

Displays comprehensive tunnel information in the network.
See “Link Reports” on page 310.

TUTILDemand Traffic on Tunnel

Displays tunnel load and utilization information.TUTRAFRPTTunnel Traffic
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DescriptionFileTunnel Reports

Displays information for each interface segment of each
tunnel’s path.

TUNNEL_LINKTunnel-Link

DescriptionFileTunnel Layer Link Reports

Provides tunnel bandwidth utilization information for each
link in the network

L2_LKUTILTunnel RSVP BW on Link

Provides tunnelbandwidthutilization information forgrouped
links (links that have the same endpoints)

L2_LKBWRPTTunnel RSVP BW on Node Pair

Shows tunnel traffic on the link by period from the
T_trafficload or tunnel.traffic file for Live networks.

L2_MEASUREDLKUTILMeasured Link Util (based on
T_trafficload)

Shows tunnel traffic between connecting nodes by period
from the T_trafficload or tunnel.traffic file for Live networks.

L2_MEASUREDLKBWRPTTunnel Layer Per Node Pair
(Measured)

Compares aggregate tunnel traffic load versus themeasured
interface traffic.

LINKUTILCOMPARETunnel Traffic vs Interface Traffic

Displays partitions of the link bandwidth (RSVP and
GB=Guaranteed Bandwidth, GlobalPool and SubPool, or CT
partitions for DiffServ-TE) and shows the tunnel bandwidth
for each partition.

L2_LKPARTRSVP Bandwidth Allocation

DescriptionFileTunnel Layer Group

Shows summarized information for tunnels that are
requestedwithinagrouporbetweentwodifferentgroups.

GROUPTUNNELSUMMARYGroup Tunnel Summary by Group
Pair

Showsdetailed information for tunnels thatare requested
within a group or between two different groups.

GROUPTUNNELDETAILGroup Tunnel Detail by Group Pair

Shows total ingress, egress, and transit tunnel traffic
through the groups.

GROUPLOADGroupTunnelBandwidthDistribution

DescriptionFileNode

Showsstatistical informationon tunnels thatoriginate, pass
through or terminate at each node in the network.

TUNNELSTATPlanned Tunnel RSVP BWPer Node

Shows ingressandegress tunnel traffic tunnel traffic through
the nodes.

L2_MEASNODELOADMeasured Tunnel Traffic Per Node

List of Simulation Reports

All simulation reports are pre-generated. That is, they are generated after performing

the associated simulation script. The Report Manager provides a quick, organized way
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of accessing these reports, though the reports can also be opened directly via the File

Manager.

Simulation Report Icons

Because the Simulation Reports are pre-generated, at the time a simulation report is

viewed, itmaynotaccurately correlatewith thecurrent stateof thenetwork. For example,

in the interim youmay havemodified the network, adding or removing network elements

like nodes, links or demands. Special icons are used to quickly allow you to distinguish

newer reports from older reports that may be out of date:

Figure 169: Report Icons

• Faded Gray: Indicates that the report is not available. The associated simulation script

has not yet been run.

• White: Indicates that the reportwas generatedduring the current network session. This

does not guarantee that the report reflects the current state of the network model. It

is just an indicator that the report is relatively new.

• Dark Gray: Indicates that the report was generated during a previous network session.

Associated Simulation Scripts

The following table lists the simulation script corresponding to each report. The scripts

are accessed from themain menu Simulation > Simulation Scenarios. For more detail
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about the varietyof simulations, seeChapter 10, “SimulationMenu”onpage 193. Formore

detail about the contents of each report, see the output files chapter of the File Format

Reference for IP/MPLSView.

Associated SimulationFileReport

Displays link and bandwidth information under normal and peak conditions
obtained from failure simulation runs

DVSIMPeak Link Util

Tools >Options > Failure Simulation; In Failure Report Tab, ensure that the “Yes”
checkbox for Trace File is marked. Then, perform an interactive failure sequence
by failingnodes/links via themap right-clickmenusor viaSimulation> Interactive
Scenarios. Run or Step through the simulation. See Interactive Failure (SIMRPT)
Reports.

SIMRPTInteractive Failure

Simulation > Simulation ScenariosPeakSimSummary
PinkSimLink
PeakSimRoute

Exhaustive Failure

This file is generated when a Random Daily Failure simulation is run. To perform
this simulation, select Simulation >Simulation Scenarios, selectMultiple Failures,
select Double or Triple failure, and enter in a number of Cases to Simulate.

• This file records the random daily failure sequence into an up-down sequence
file that can be replayed with the Replay Up-Down Sequence simulation.

DAILYSEQDaily Sequence

This report is generated with almost every simulation script that you run. It
indicates theworstpathdelayexperiencedbyeachdemand, aswell as the failure
event that caused the worst-case scenario. Note that the report is overwritten
each time.

PATHDELAYPath Delay
Information

Under Simulation > Simulation Scenarios, select Generate Up-Down Sequence
for use in Upper Layer option in addition to the simulation script to be run.

UPDOWNUp-Down Sequence

This file is generated during an Up-Down Sequence simulation, for use in Upper
Layer. It basically creates a facility file that groups the failed demands
corresponding to eachnetwork element failure just simulated in the current layer.
These demands correspond to links in a higher network layer, where you can
proceed to run an Exhaustive Facility Failure. In this way, you can see the impact
of the network failure at a higher network level.

SRLGShared Risk Link
Groups

Under Simulation > Simulation Scenarios > Advanced Options, select Replay
Up-DownSequence, then specify the up-down sequence file. The DAILYSEQ file
generated from RandomDaily Failure can be used here.

REPFAILReplay Up-Down
Sequence

List of Configuration Reports (Router Only)

All configuration reports are “pre-generated”. That is, they are generated after you import

configuration files into the network model by selecting File > Import Data. The Report

Manager provides a quick, organized way of accessing these reports, though the reports

can also be opened directly from the File Manager.

For more information on configuration import, see the router data extraction chapter of

the Router Feature Guide for IP/MPLSView.
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NOTE: A router license is required to access these reports.

DescriptionFileReport

Displays detailed integrity checks. See “Configuration Reports”
on page 339.

configLogIntegrity Checks

Displays a summary of the integrity checks. This report can also
beaccesseddirectly bypressing theStethoscope iconon themain
menu bar.

Integrity_Summary_rptIntegrity Checks
Summary

Displays the details of IS-IS configuration. See ISIS Reports.ISISReportISIS Config

Displays the details of OSPF configurationOSPFReportOSPF Config

Displays the details of CoS configurationConfigCoSCoS Config

Displays the file properties of collected configuration files.ConfigFileStatusConfig Files Status

Displays details of the VLAN’s collected from switches via SNMP.
For more information, see the IP/MPLSView Java-Based
Management and Monitoring Guide, VLAN Discovery chapter.

VLANReportVLAN Detail*

Displays duplicate IP address(es) found in the configuration files.ConfigDuplicateAddressDuplicated IP Address

Displays the names of devices (nodes) added to or removed from
thenetworkafter completionof aSchedulingLiveDataCollection
taskorNetworkConfigDataCollection task. Togenerate theNode
Discovery report, IP/MPLSView compares the device differences
between the previous network and the current network, and lists
any devices that have been added or removed.

BridgeVLAN

ConfigCoS

ConfigElementDiscovery

ConfigFileStatus

ConfigIntegrityChecks

ConfigIntegrityChecksSummary

ConfigISIS

ConfigOSPF

Node Discovery

Customized Reports

The customized reports feature allows you to create a customized report by selecting

certain columns of interest from an existing Node, Link, Interface, Demand, and Tunnel

report.
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1. To create a customized report, right-click over Customized Reports in the Report

Manager and choose Add a newReport from themenu.

Figure 170: Adding a New Customized Report

The Customized Report Editor Wizard then appears, as shown in the following figure.

Click Next to continue.

Figure 171: Customized ReportWizard
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2. Specify the report name, file name, and a description, and click Next to continue.

Figure 172: Define Report Name, File Name, and Description
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3. Choose the type of report fromwhich to derive a customized report. After choosing

the report type, click Next to continue.

Figure 173: Choose the Report Type

4. Select the columns of interest for the customized report by highlighting rows from

the Available Columns list and clicking on the -> button. For each column selected

for the customized report, youmay choose a new name for an existing column name

by clicking on the text box in the New name column and typing in a new string.
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Figure 174: Choose Columns of Interest

5. Click on Finish to create the customized report, which is placed into the Customized

Reports folder.

Figure 175: A Customized Report Derived from the Link Report

6. After a customized report has been created, youmay export it as a template. This

templatemay thenbe importedbyadifferentnetwork spec, and thesamecustomized

report could be generated for that network.
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Figure 176: Exporting/Importing a Customized Report Template

Network Reports

• Demand Reports on page 305

• Link Reports on page 310

• Interface Traffic Reports on page 317

• Group Reports on page 320

• Node Reports on page 327

• VPN Reports on page 329

• Protocols Reports on page 330

• BGP Reports on page 334

Demand Reports

Demand Path & Diversity Report

The Demand Path & Diversity Report lists all user demand requirements in the network,

with demand ID, origination, destination, bandwidth, type, priority, preempt priority, path

routing, and distancemetrics. The output file that is written to the output directory is

called “PATHRPT.runcode”.
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Figure 177: The Path and Diversity Report in a Frame Relay Network

DescriptionField

The ID of the demand. (Column name varies with hardware modules.)FlowID/PVCID

The full name of the origination node of the demand.From_Node_Name

The domain at which the demand originates, if any.From_Domain/From_Area

The ID of the origination node of the demand.From_Node#

The country in which the origination node resides.From_Country

The name of the card which the demand is connected to; the card slot position that the
demand/flow uses.

Card

The port number of the card which the demand is connected to; the port associated with the
card the demand/flow uses

Port

The full name of the destination node of the demand.To_Node_Name

The domain at which the demand is destined for, if any.To_Domain/To_Area

The ID of the destination node of the demand.To_Node#

The country in which the destination node resides.To_Country

The name of the card which the demand is connected to; the card slot position that the
demand/flow uses

Card

The port number of the card which the demand is connected to; the port associated with the
card the demand/flow uses

Port

The amount of bandwidth allocated to the selected demand.Bandwidth

The type of the demand, whether it is a data demand (R) or voice demand (V), and the direction
of the demand (A-Z, Z-A).

Type
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DescriptionField

The demand's preference for terrestrialmedia. Valid entries include: Don't Care, Required, Prefer,
Prefer Not, and Avoid. Note that this parameter is used in route biasing andmay not actually
reflect true media characteristics.

Terrestrial

The demand's preference for fiber media. Valid entries include: Don't Care, Required, Prefer,
Prefer Not, and Avoid. Note that this parameter is used in route biasing andmay not actually
reflect true media characteristics.

Fiber

Thedemand'spreference for encryptionmedia. Valid entries include:Don'tCare, Required, Prefer,
Prefer Not, and Avoid. Note that this parameter is used in route biasing andmay not actually
reflect true media characteristics.

Encrypted

The priority field of the demand specification consists of two numbers separated by a comma
(,), or a forward-slash (/). The first numberdefines the call priority of thedemand, and the second
number the preempt priority of the demand. The preempt priority should be at the sameor lower
priority as the call priority of the demand. It is assumed that this demand can bump any of the
demand with call priority lower than the preempt priority.

Pri, PrePri

The current path (routing) of the demand.Actual_Path

This field displays the sum of the metrics (administrative weights) of the links that the demand
traverses. For asymmetric demands, two separate rows are used to show themetric, one for
each direction. Note that the defaultmetric of a link depends upon the routingmethod set in the
Tools > Options > Design window, Design>Path Placement options pane.

Route_Cost

When the program performs path placement and is trying to find the best route for a call, delay
metrics are examined to determine the desirability/undesirability of a link. Two delaymetrics are
supported, one for each direction of the trunk. If asymmetric delay metrics are not supported by
the hardware, the second delay is marked as '-'. If a delay metric is not defined for a trunk, a
default delay is calculated based on propagation delay and serialization delay.

Delay

Specifies the sum of the actual mileage distance of links in the current path.Geo_Dist(Mile)

Specifies the total number of hops of the current path.#Hop

Specifies if the demand could not be routed on the specified path.OnPrefRt/Path_Violation

Specifies if the demand could not be routed on the specifiedmedia (terrestrial, fiber, encrypted).Media_Error

Any user-specified comments.Comment

Group name for demands that are to be diverse from each other.DivLevel/DivGroup

CoS Demands Report

The CoS Demands Report provides information on interface load and queueing delays

for the demands of the selected CoS class in the network. See the Router Feature Guide

for IP/MPLSView for details on the Class of Service feature.

The output file that is written to the output directory is called “DEMANDCOS.runcode”.
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Figure 178: The CoS Demands Report

• Normal or Peak: Normal traffic means the network does not experience any

failure/outages. Peak means that failure simulation reports are going to be used.

• CoS Classes: Select all or one specific class of traffic. Reports can be issued for all

classes of traffic or for a particular one (for example, the priority class).

• Period: Select planned, worst, all, or a specific time period (from traffic load files).

Plannedmeans the report is generated using the interface load calculated based on

the demand file values. Worst means that the report is generated using the interface

load calculated based on the worst traffic load.

DescriptionField

The name of the demand.DemandName

The originating node of the demand.NodeA

The terminating node of the demand.NodeZ

The bandwidth of the demand.BW

The type of the demand, whether it is a data demand (R) or voice demand (V), and the
direction of the demand (A-Z, Z-A).

Type

The policy class to which the demand belongs.Policy Class

The direction of the demand: A2Z, Z2A.Dir

The sumof node delay and link propagation delay for nodes and links in the path. Delay
at the first node is not included.

PropDelay(ms)

Specifies the total number of hops of the current path.#Hop

Specifies the Codec Packet DelayCodecPktDelay

The bandwidth defined in the demand’s bandwidth field. The amount of bandwidth
planned for this demand.

Planned Load
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DescriptionField

The queueing delay based on the planned load and CoS policies.Planned QDelay(ms)

The planned drop bandwidth for this demandPlanned DropBW

The jitter as defined by the standard deviation of the total path delay.Planned Jitter

The highest bandwidth among the load in all the traffic periods.Worst Load

The highest queueing delay value among all the traffic periods.Worst QDelay

The highest dropped bandwidth among all the traffic periods.Worst DropBW

The bandwidth of the demand in the specified time period.1, 2, ... Load

The queueing delay in the specified time period.1, 2, ... QDelay

The dropped bandwidth in the specified time period.1, 2, ... DropBW

Demand Route Cost Report

The Demand Route Cost Report provides cost information for each demand based on

the demand’s route. Each entry is a demand in the network. The report specifies details

of each demand, its total cost, and the breakdown of the cost by each link that it passes

through.

The output file that is written to the output directory is called “CKTCOST_RT.runcode”.

Figure 179: The Demand Route Cost Report

##############################################################
# COST REPORT FOR DEMANDS File=CKTCOST_RT.x
##############################################################
##
# Currency= DL(American Dollar), DistUnit=mile
Ratedir = /u/wandl/db/rates/default
# Calculation Method: utilization cost according to demand routes
# i.e. Demand cost = Sum of (bandwidth/link_cap)*(link cost)
# for links in the path
#
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Equal Cost Multi-Path Report

The Equal Cost Multi-Path Report displays all the equal cost multiple-paths in the

network. It lists each set of equal cost paths, displaying the originating and destinating

nodes, and the hop-by-hop paths. See the Router Feature Guide For NPAT and

IP/MPLSView for details on the ECMP feature. The output file that iswritten to the output

directory is called “EQPATHRPT.runcode”.

Figure 180: The Equal Cost Multi-Path Report

NOTE: ECMPpaths are calculated based on IGP routing, but the actual path
placementwill also take intoconsiderationMPLSTrafficEngineeringTunnels.

* Notations:
* & : Same site
* - : Intra-LATA or Intra-Country
* -- : Inter-LATA or Inter-Country
* = : Intra-LATA or Intra-Country, Second vendor or linktype
* == : Inter-LATA or Inter-Country, Second vendor or linktype.
* @ : Intra-LATA or Intra-Country, Inter-domain
* @@ : Inter-LATA or Inter-country, Inter-domain
* -*- : Link missing or not enough bandwidth

Link Reports

Planned Link Utilization Report

The Planned Utilization Report lists comprehensive link and bandwidth information for

the network. The output file that is written to the output directory is called

“LKUTIL.runcode”.
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Figure 181: The Planned Link Utilization Report, LKUTIL

DescriptionField

The name of the link.Linkname

The direction of the link.dir

The origination node of the link.Anode

The destination node of the link.Znode

The type of trunk being used. The trunk type is subsequently used in determining link pricing
and bandwidth availability.

Type

The totalbandwidthof the link fromnodesA toZ.This is also thesumof theAvailBW,UsedBW
and Ovhd values.

TrunkBw

The available amount of unutilized bandwidth between nodes A and Z.AvailBW

The amount of bandwidth actually used by the demand requirements between nodes A and
Z.

UsedBW

The amount of reserved bandwidth for overhead. (TotalBw = AvailBw + UsedBw +Ovhd)Ovhd

The utilization of this link calculated by (UsedBW+Ovhd)/TotalBW.UtilPct

The number of demands routed on or through the link.nDemand/ncall

Planned Physical Interface Utilization

The Planned Physical Interface Utilization Report provides utilization statistics for each

physical interface in the network. The output file that is written to the output directory

is called “PHYUTIL.runcode”.
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Figure 182: Planned Physical Interface Utilization

Demand Traffic Versus Interface Traffic

The Demand Traffic vs Interface Traffic report merges together the Measured Link

Utilization and the Interface Traffic reports and compares them.

In Layer 3, the Compared Link Utilization report is used to compare the link utilizations

computed from the traffic load versus that computed from the interface traffic. For each

of the 24periods, the difference between the link utilization computed from the interface

traffic and from the traffic load is calculated and displayed in the Diff (intf - Demand)

columns for each period and for the worst period and the average of the periods.

In Layer 2, the Compared Link Utilization report is used to compare the link utilizations

computed from the tunnel traffic load versus that computed from the interface traffic.

Figure 183: Compared Link Utilization Report

CoS Links Report

The CoS Links Report provides information on interface load and queueing delays for

links of the selected CoS class(es). See the Router Feature Guide for IP/MPLSView for

details on this feature. The output file that is written to the output directory is called

“LINKCOS.runcode”.
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Figure 184: The CoS Links Report

• Normal or Peak: Normal traffic means the network does not experience any

failure/outages. Peak means that failure simulation reports are going to be used.

• CoS Classes: Select all or one specific class of traffic. Reports can be issued for all

Classes of Traffic or for a particular one (for example, the Priority class)

• Period: Select planned, worst, all, or a specific time period (from interface load files).

Plannedmeans the report is generated using the interface load calculated based on

the demand file values. Worst means that the report is generated using the interface

load calculated based on the worst traffic load.

DescriptionField

The name of the link.LinkName

The type of the link, for example, OC3 or STM1TrunkType

The bandwidth of the link.Bandwidth

One of the link’s endpoints. This specifies the direction of traffic described in this
row.

Node

The interface on the node that the link is connected to.Interface

The CoS policy specified for the link.Policy Name

The CoS class of traffic.Policy-Class

Bandwidth reserved for the policy class.Policy Bandwidth

The Peak Information RatePIR

The class name used in demands' CoS definition.Class

The"IPprecedence"or "MPLSEXPbits"usedasmatchingconditions for thespecified
class.

Match

313Copyright © 2018, Juniper Networks, Inc.

Chapter 13: Report Manager



DescriptionField

The propagation delay on the link.PropDelay

The amount of bandwidth planned for demands on the link.Planned Load

Percentage of the trunk bandwidth that is used.Planned Util

Percentage of the bandwidth reserved for the policy class that is used.Planned PolicyUtil

The queueing delay on the link.Planned QDelay(ms)

The dropped bandwidth planned on this link.Planned DropBW

The standard deviation of the total path delay.Planned Jitter

The highest bandwidth among the load in all the traffic periods.Worst Load

The highest queueing delay value among all the traffic periods.Worst QDelay

The highest dropped bandwidth among all the traffic periods.Worst DropBW

The load of the link in the specified time period.1, 2, ... Load

The queueing delay in the specified time period.1, 2, ... QDelay

The dropped bandwidth in the specified time period.1, 2, ... DropBW

Link Cost Report

The Link Cost Report provides detailed link pricing information. Each link in the network

is listed by its source and destination nodes, Vendor, Type, Monthly Cost, and

Non-Recurring Charge. Link grouping is done by LEC and IXC vendor.

The output file that is written to the output directory is called “LKCOST.runcode”.

Copyright © 2018, Juniper Networks, Inc.314

IP/MPLSView Java-based Graphical User Interface Reference



Figure 185: The Link Cost Report

******************************************************************
*
* Backbone Link Configuration and Pricing Report -- runcode=x
*
******************************************************************
*
Remark 1: vendor/cost marked with * are default specified in usercost file
Remark 2: vendor/cost marked with # are default specified in bblink file
Remark 3: cost marked with @ are calculated from usercountrycost file
Remark 4: cost marked with ^ are estimated from default specified in usercost
file

Special characters (such as #, *, @, ^) appended to a vendor or cost value is used to

indicate how the pricing was calculated. For example, a vendor or cost value marked

with a '#' means that default values specified in the bblink file were used. Press the Exp

button in the report window for an explanation.

If the report is saved in CSV format or is viewed through the IP/MPLSView client, there

are questionmarks ('??') in theMonthly andNRC columns indicating that pricing for this

link cannot be determined. This usually occurs if the service type is not supported in the

tariff database. In this case, you can:

• Specify the desired link cost directly in the bblink file, or

• Use the usercost file to define the default vendor and cost for various service types

between particular node pairs. More detailed information on this file can be found in

the File Format Reference For NPAT and IP/MPLSView.

• Use the custrate file to create pricing tables between defined classes of nodes. Note

that this the custrate feature is an unbundled add-on feature.

DescriptionField

Identifier of the linkLinkname

The NPA/NXX location of where the link originates.CntryA/NXX

The name of the node where the link originates.NodeA
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DescriptionField

Any information regarding the card found at the origin node of the link.CardA

The name of the interface at the orign node of the link.InterfaceA

The NPA/NXX location of the destination of the link.CntryZ/NXX

The name of the destination node where the link terminates.NodeZ

Any information regarding the card found at the destination node of the link.CardZ

The name of the interface at the destination node of the link.InterfaceZ

The vendor associated with this link. Possible values for vendors include those that are specific
to a certain country or region, and are listed in the tariff database. If a vendor is not specified,
this value is set to the default value DEF.

Vendor

The number of links from node A to node Z.#

The type of link being used. The link type is used in determining link pricing and bandwidth
availability.

Type

Link/circuit cost expressed a amonthly billed amount.Monthly

Non-Recurring Charge also known as installation charge.NRC

The distance between the two nodes (in miles).Dist (mile)

The administrative weight or distance of the link. AdminDistA for A-Z direction; AdminDistZ for
Z-A direction.

AdminDist

The delay of the link in each direction. DelayA=delay for A-Z; DelayZ=delay for Z-A.Delay

The custom rate class that the nodes belong to. CLASSA=class for node A; CLASSZ=class for
node Z.

CLASS

The site that the nodes belong to. SITEA=site for node A; SITEZ=site for node Z.SITE

The hardware type of the nodes. HWTYPEA=hw type for node A; HWTYPEZ=hw type for node
Z.

HWTYPE

RSVP Bandwidth Allocation Report

The RSVP Bandwidth Allocation Report displays detailed link partition information for

each link in thenetwork. This report displays the samedetailed information in thecapacity

tabmenu of the Links window found in the Network menu.

The output file that is written to the output directory is called “LKPART.runcode”.
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Figure 186: The Link Partition Report in a Router Network

Measured Link Utilization Report

The Measured Link Utilization report displays the computed link utilization based on the

routed traffic load in the network. For live network models, this report can be viewed

after opening the live network and switching to Offline mode.

In Layer 3, the traffic load could be either the measured end-to-end traffic load, which

can be read in as a trafficload file in the Load Network Files window, or the end-to-end

demands. If a trafficload file is read in, then up to 24 periods of traffic data could be

available. For each period, load and utilization information are displayed in two columns.

Worst and average statistics are also shown (for example, Average Load and Average

Util columns).

In Layer 2, the link utilization is based on the tunnel traffic load in the network. The tunnel

traffic load can be read in as a t_trafficload file in the Load Network Files window.

Figure 187: Measured Link Utilization Report

Interface Traffic Reports

The Interface Traffic Reports detail the measured traffic on each link over a set of time

periods, if data is provided. In order to access these reports, traffic should have first been

collected (either using the offline traffic collection features in IP/MPLSView or other

traffic sources) and imported into the software using the offline traffic import feature.

For more on Offline Traffic Import, see the Router Feature Guide for IP/MPLSView.

Processed interface traffic data is saved in a file that is referenced by the specification

file in the lines, “interfaceLoad_out” (egress traffic) and “interfaceLoad_in” (ingress

317Copyright © 2018, Juniper Networks, Inc.

Chapter 13: Report Manager



traffic). The Interface Traffic Report, AS Traffic Report and Inter-AS Traffic Report are

derived from these files. Up to 24 periods of traffic data could be available. For each

period, load and utilization information are displayed in two columns.Worst and average

statistics are also shown (for example, Average Load and Average Util columns). The

report is the same in Layer 3 as in Layer 2.

NOTE: If theoutgoingtrafficmeasurementscannotbefound(goingout from
Node A to Node B) in the egress traffic file, then IP/MPLSViewwill use the
numbers from the ingress traffic file (going into Node B fromNode A) if
available.

Figure 188: Interface Traffic Report

Interface Traffic Report

The Interface Traffic Report is generated when you perform an offline traffic import.

DescriptionField

The name of the link.LinkName

The source (A) and destination (Z) endpoints of the link.NodeA/Z

The originating (A) and terminating (Z) interfaces on Node A and Z respectively.InterfaceA/Z

The total bandwidth of the link.Bandwidth

The link type (for example, T1, OC3, ATM10M)Trunk Type

The worst load experienced over all time periods.*Worst Load

The link utilization correlating to theWorst Load.Worst Util

The average of the loads experienced over all time periods.*Average Load

The link utilization correlating to the Average Load.Average Util

The load experienced during period1, period2, ... periodn.*period1...n

The link utilization correlating to the loadmeasured each period. There should be a
“Util(%)” column immediately after each “period” column.

Util(%)
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To determine the units (for example, Kbps), press the Explanation button at the top of

the report.

AS Traffic Report

The Autonomous System (AS) Traffic Report details the traffic measured over links

whose endpoints are located in two different ASs.

DescriptionField

The AS number of the source AS for the link.AS1

The node ID of the source node of the link.nodeID1

The link interface at the source node.interface1

The AS number of the destination AS for the link.AS2

The node ID of the destination node of the link.nodeID2

The link interface at the destination node.interface2

The bandwidth of the link.bandwidth

The average incoming traffic measured on the link in the AS2->AS1 direction.Average-in

The average outgoing traffic measured on the link in the AS1->AS2 direction.Average-out

Inter-AS Traffic Report

The Inter-AS Traffic Report details the aggregated average traffic measured on all links

between two different Autonomous Systems (AS).

DescriptionField

The AS number of the source AS.AS1

The AS number of the destination AS.AS2

The AS name corresponding to AS1. By default, the AS names are derived from the file,
$WANDL_HOME/db/misc/ASNames.

AS1 Name

The AS name corresponding to AS2.AS2 Name

The Total Bandwidth of all links between these two ASs.Total BW

Theaverage traffic loadmeasuredonall linksbetweenAS1andAS2 in theAS2->AS1direction.Average-in

Theaverage traffic loadmeasuredonall linksbetweenAS1andAS2 in theAS1->AS2direction.Average-out
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Inbound/Outbound Network Traffic

This report displays an aggregate outbound and aggregate inbound value for each node,

corresponding to the sum of traffic originating and terminating at a node respectively -

but only on interfaces that do not correspond to any links in the network model (for

example, customer-facing interfaces, PE-CE interfaces when CE configuration files are

missing from the network model). This information is derived from themeasured traffic

on the interfaces (interface “egress” and “ingress” traffic files in the File > Load Network

Files window).

One purpose for this file is for use in the Traffic Matrix tool, as described in the Router

Feature Guide for IP/MPLSView.

Figure 189: Inbound/Outbound Network Traffic

Group Reports

This set of group reports in the Report Manager displays information about groups in the

networkmodel. This information includes linkanddemandsummariesanddetailswithin

and between groups.When you have categorized nodes into groups, these reports show

the amount of links and traffic that existswithin a certain group or between twodifferent

groups. After a failure simulation run, you can also choose to view network group

information in peak conditions.

These reports can be generated in Layer 2 of an IP/MPLS network regarding tunnel

information between groups, as well as in an ATM network containing PNNI groups. To

view information between PNNI groups, select this option in the Group Type selection

box.

Group Demand Summary by Group Pair Report

Figure 190: Group Demand Summary Report
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The output file that is written to the output directory is called

“GROUPDEMANDSUMMARY.runcode”.

• Normal, Peak: Select Normal to display network information under normal conditions.

After having run a failure simulation, selecting “Peak” will show peak utilization

information.

• GroupType:The default selection is user-defined groups. If this network contains PNNI

groups, then the selection box will also allow you to choose PNNI groups for viewing.

• Period: Based on the traffic load file, the report can display traffic load information in

the selected time period(s).

DescriptionField

This rowcontains summarized information fordemands thatoriginateatgroupAand terminate
at group Z.

Group A, Z

The total number of requested demands (placed and unplaced) from group A to group Z.# Demand

The sum of the demands’ bandwidth.BW

The sum of the traffic load for these demands in the worst case out of all the time periods.
(Data taken from traffic load file.)

WorstLd

The ratio of worst load and the sum of the demands’ bandwidth.WorstLd/BW

The sum of the traffic load for these demands in period 1 (P_01), period 2 (P_02), etc. (Data
taken from traffic load file.)

P_01, P_02, ...

Group Demand Detail by Group Detail Report

The output file that is written to the output directory is called

GROUPDEMANDDETAIL.runcode.

• Normal, Peak: Select Normal to display network information under normal conditions.

After having run a failure simulation, select Peak to show peak utilization information.

• GroupType:The default selection is user-defined groups. If this network contains PNNI

groups, then the selection box also allows you to choose PNNI groups for viewing.

• Period: Based on the traffic load file, the report can display traffic load information in

the selected time period(s).

DescriptionField

This row describes a demand that originates at node A and terminates at node Z.Node A, Z

Group A is the group in which node A resides. Group Z is the group in which node Z resides.Group A, Z

The bandwidth of the demand.BW
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DescriptionField

Theworst load of this demand out of all the time periods. (Data taken from traffic load file.)WorstLd

The ratio of worst load and the bandwidth of the demand.WorstLd/BW

The load of this demand fromnodeA to node Z in period 1 (P_01), period 2 (P_02), etc. (Data
taken from traffic load file.)

P_01, P_02, ...

Group Demand Traffic on Link Summary Report

The output file that is written to the output directory is called

“GROUPLINKSUMMARY.runcode”.

Figure 191: Group Demand Traffic on Link Summary Report

• Normal, Peak: Select Normal to display network information under normal conditions.

After having run a failure simulation, selectPeak to display peak utilization information.

• GroupType:The default selection is user-defined groups. If this network contains PNNI

groups, then the selection box also allows you to choose PNNI groups for viewing.

• Period: Based on the traffic load file, the report can display traffic load information in

the selected time period(s).

DescriptionField

This row contains summarized information for links in the network whose first endpoint is in
group A and other is in group Z.

Group A, Z

The sum of the bandwidth of links between group A and group Z.TotalBW

The sum of the amount of bandwidth in the links planned for demands that are routed on or
pass through the links.

ProvBW

The number of links between group A and group Z.# Link

The number of demands routed on or through the links between group A and group Z.# Calls

The sumof the links’ traffic load in theworst case out of all the time periods. (Data taken from
traffic load file.)

WorstLd
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DescriptionField

The ratio of worst load and sum of the bandwidth of the links.WorstLd/TotalBW

The sum of the links’ traffic load in period 1 (P_01), period 2 (P_02), etc. (Data taken from
traffic load file.)

P_01, P_02, ...

Group Demand Traffic on Link Detail Report

The output file that is written to the output directory is called

“GROUPLINKDETAIL.runcode”.

• Normal, Peak: Select Normal to display network information under normal conditions.

After having run a failure simulation, selectPeak to displaypeak utilization information.

• GroupType:The default selection is user-defined groups. If this network contains PNNI

groups, then the selection box will also allow you to choose PNNI groups for viewing.

• Period: Based on the traffic load file, the report can display traffic load information in

the selected time period(s).

DescriptionField

This row describes a link in the network whose endpoints are at node A and node Z.Node A, Z

Group A is the group in which node A resides. Group Z is the group in which node Z resides.Group A, Z

The bandwidth of the link.TotalBW

The amount of bandwidth in the link planned for demands that are routed on the link or pass
through the link.

ProvBW

The number of demands routed on or through the link.

Note: This canbeverifiedby right-clickingon the link in themapandselectingView>Demands
On/Thru Link.

# Calls

The link’s traffic load in the worst case out of all the time periods. (Data taken from traffic
load file.)

WorstLd

The ratio of worst load and the link’s bandwidth.WorstLd/TotalBW

The traffic load in the link in period 1 (P_01), period 2 (P_02), etc. (Data taken from traffic load
file.)

P_01, P_02, ...

Group Interface Load Summary Report

The output file that is written to the output directory is called

“GROUPINTFSUMMARY.runcode”.
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NOTE: To display interface load information in these reports, the interface
load files must first be read into the networkmodel.

Figure 192: Group Interface Summary Report

• GroupType:The default selection is user-defined groups. If this network contains PNNI

groups, then the selection box will also allow you to choose PNNI groups for viewing.

• Period: Based on the traffic load file, the report can display traffic load information in

the selected time period(s).

DescriptionField

This row contains summarized information for traffic that originate at the interfaces of nodes that
belong in group A and terminate at the interfaces of nodes that belong in group Z.

Group A is the group in which node A resides. Group Z is the group in which node Z resides.

Group A, Z

The sum of the bandwidth of links between group A and group Z.Bandwidth

The interface traffic load of the links from group A to group Z in the worst case out of all the time
periods. (Data taken from interface traffic load files.)

WorstLoad

The average interface load of the links from group A to group Z in all the time periods. (Data taken
from interface traffic load files.)

AverageLoad

Group Interface Load Detail Report

The output file that is written to the output directory is called

“GROUPINTFDETAIL.runcode”.
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Figure 193: Group Interface Detail Report

• GroupType:The default selection is user-defined groups. If this network contains PNNI

groups, then the selection box will also allow you to choose PNNI groups for viewing.

• Period: Based on the interface traffic load file, the report can display traffic load

information in the selected time period(s).

DescriptionField

The name of a link whose end points are at node A and node Z. If the link does not have a
link name, then it will appear as [nodeA]-[nodeZ].

LinkName

This row describes a link in the network whose endpoints are at node A and node Z.Node A, Z

This row gives interface A,Z that corresponds to node A,Z.Interface A, Z

The groups that nodes A and Z belong to, respectively.Group A,Z

This corresponds to the bandwidth of interface ABandwidth

The link trunk type.Trunk Type

The interface load of the link from interface A to interface Z in the worst case out of all the
time periods. (Data taken from interface load files.)

Worst Load

The average interface load of the link from interface A to interface Z in all the time periods.
(Data taken from interface load files.)

Average Load

Group Demand Bandwidth Distribution Report

Like the “VPN Reports” on page 329, the Group Demand Bandwidth Distribution Report

provides summarized traffic statistics. The output file is saved to the L3GROUPLOAD

file. The source, destination, transit, and intra-group traffic is reported for each group, in

terms of the number of demands and the bandwidth of those demands. Note that the

source and destination traffic for a group do not include intra-group traffic.

Two additional columns #Transit(Max) and TransitBW(Max) may appear after running

an exhaustive failure simulation script from Simulation>Scripts with the Generate Peak

Group Transit Statistics checkbox selected or by setting CheckTransitDemandLimit=2

in the dparam file.
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Figure 194: The Group Bandwidth Distribution Report

DescriptionField

The name of the group whose traffic load is being analyzed.

For nodes not belonging to any group, they are categorized together as “No Group”

Group

The VPN, if any, whose traffic is being analyzed. For networks with multiple VPNs, select a
specific owner under the Owner dropdownmenu to view only statistics for a particular VPN.
Alternatively, select owner “All” to view a breakdown into statistics for each VPN. followed by
the sum total.

• If Total appears in this column, all traffic at this group is factored in, including traffic for each
VPN and traffic not in any VPN.

• Traffic that is not using any VPN is categorized under No VPN.

VPN

Total number of demands and bandwidth of demands that originate at this group and visit at
least one other group.

Note: This category includes local inter-group traffic but not local intra-group traffic. For the
total bandwidth originating at this group, add Src(Inter)+Local(Intra).

#Src(Inter)
SrcBW(Inter)

Number of routed demands and total bandwidth of routed demands that originate at this
group and visit at least one other group. Unlike Src(Inter), Src(Placed) excludes unplaced
demands.

#Src(Placed)
SrcBW(Placed)

Total number of demands and bandwidth of demands that terminate at this group and visit
at least one other group

Note: This category includes local inter-group traffic but not local intra-group traffic. For the
total bandwidth terminating at this group, add Dest(Inter)+Local(Intra).

#Dest(Inter)
DestBW(Inter)

Total number of routed demands and bandwidth of routed demands that terminate at this
groupafter visitingat leastoneother group.UnlikeDest(Inter), Dest(Placed)excludesunplaced
demands.

#Dest(Placed)
DestBW(Placed)

Number of demands and total bandwidth of demands that pass through this group without
originating or terminating at it

Note: If a demand transits through a groupmore than once, it is countedmultiple times.

#Transit
TransitBW

Total number of demands and bandwidth of demands that originate and terminate at the
same group, subdivided below into Local(Intra) and Local(Inter).

#Local
LocalBW
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DescriptionField

Demands that originate and terminate at the same group which never go outside the group.#Local(Intra)
LocalBW (Intra)

Demands that originate and terminate at the samegroupbut transit through at least one other
group. These demands are also counted under Src(Inter) and Dest(Inter).

#Local(Inter)
LocalBW (Inter)

Max number and bandwidth of transit demands at this group during peak failure simulation#Transit(Max)
TransitBW(Max)

To view the details of the demands included in each category: Src(Inter), Dest(Inter),

Transit, and Local(Inter), Local(Intra), access the text mode either from the command

line using /u/wandl/bin/bbdsgn followed by the specification file path. Detailed info can

be foundunder themenu item:3.Network Information>4.Path> 13.Group.Uponentering

the group name, you can select which category of demands to view. For example, the

following indicates the demands transiting through Group 1.

Enter group name: group1
Group Demands Menu (GROUP1):
1. ALL 2. Src (Inter) 3. Dest (Inter) 4. Transit
5. Local (Intra) 6. Local (Inter)
Select: 4
Demands Passing Through GROUP1:
* Bandwidth Unit = bit
Demand Node Node Bandwidth Type Pri/Pre path
flow10 ATL SDG 418017 R,A2Z 02,02 ATL--LAX--SDG
flow52 DEN SDG 402000 R,A2Z 02,02 DEN--SFO-SJC--LAX--SDG
flow78 NYC SDG 4801220 R,A2Z 02,02
NYC--PHI--WDC--ATL--LAX--SDG
flow82 PHI SDG 1216020 R,A2Z 02,02 PHI--WDC--ATL--LAX--SDG
flow88 SDG WDC 662011 R,A2Z 02,02 SDG--LAX--ATL--WDC
xflow10 SDG ATL 452011 R,A2Z 02,02 SDG--LAX--ATL
xflow52 SDG DEN 452011 R,A2Z 02,02 SDG--LAX--SJC-SFO--DEN
xflow78 SDG NYC 662011 R,A2Z 02,02
SDG--LAX--ATL--WDC--PHI--NYC
xflow82 SDG PHI 452011 R,A2Z 02,02 SDG--LAX--ATL--WDC--PHI
xflow88 WDC SDG 4689230 R,A2Z 02,02 WDC--ATL--LAX--SDG
--- 10 demands, Total bandwidth = 14.207M

Node Reports

Demand Traffic Per Node Report

The Demand Traffic Per Node Report contains summary traffic statistics for each node,

including theamountof source, destination, and transit traffic reportedeither asanumber

of demands or as the combined bandwidth of those demands. Note that local demands

(demands that originate and end at the same node) are not included in the source or

destination traffic statistics.

The output file that is written to the output directory is called “SWITCHCONN.runcode”.
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Figure 195: The Node Traffic Summary Report

DescriptionField

The name of the node.NodeName

Numberofdemandsand total bandwidthofdemands thatoriginateat this node
and terminate elsewhere (outgoing)

#Demand(Src)
DemandBW(Src)

Number of demands and total bandwidth of demands that terminate at this
node and originate elsewhere (incoming)

#Demand(Dest)
DemandBW(Dest)

#Demand(Total)= #Demand(Src) + #Demand(Dest)
DemandBW(Total)=DemandBW(Src) + DemandBW(Dest)

#Demand(Total)
DemandBW(Total)

Number of demands and total bandwidth of demands that pass through this
node without originating or terminating at it

#TransitDemand
TransitBW

Max number and bandwidth of transit demands at this node during peak failure
simulation

#TransitDmd(Max)
TransitBW(Max)

For ATMmodels, the headings for the report are shown in the following table.

DescriptionField

The name of the node.NodeName

The number of local demands at the node. Local demands are ones that originate and
terminate at the node.

#LocalDmd

The bandwidth of local demands at the node.LocalBW

The number of non-local demands that originate from the node.#NonLocalDmd(Src)
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DescriptionField

The bandwidth of non-local demands that originate from the node.NonLocalBW(Src)

Total number of non-local demands originating/terminating at the node.#NonLocalDmd

Total bandwidth of non-local demands originating/terminating at the node. For
asymmetric demands, the bandwidth of a demand is set to the larger value.

NonLocalBW

Thenumber of transit demandsat the node. Transit demandsare ones that pass through
the node, neither originating or terminating at the node.

#TransitDmd

Themaximum number of transit demands at the node during peak failure simulation.#TransitDmd(Max)

VPNReports

The VPN Reports in the Report Manager display information about Layer3/Layer2

Kompella VPNs as well as Layer2 Martini VPNs.

Layer3/Layer2 Kompella Report

DescriptionField

The name of the nodeNode

The VPN nameVPN Name

The virtual routing and forwarding instance nameVRF

The route distinguisher - used to determine which VPN a route belongs toRD

Target VPN community that routes are exported toRoute Target Export

Target VPN community that routes are imported fromRoute Target Import

The VPN protocol usedProtocols

The interfaced used by the VPNInterface

The VPN’s IP AddressIP address

The allocated bandwidthBandwidth

Layer2 Martini Report

DescriptionField

The name of the VPNVPNName
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DescriptionField

The end points of the VPN and the nodes at which the circuits reside. Circuit A resides in
node A, and circuit Z resides in node Z

Node A, Z

The (unique) virtual circuit identifiersVCID

The circuits at nodes A and Z that the VPN is connected tocircuit A, Z

The interface encapsulation typeEncapsulation ID

The amount of bandwidth allocated to the VPNBW

Protocols Reports

Inter Area Load Distribution Report

The Inter Domain Load Distribution Report displays information on the load distribution

between domains/areas in the network and is saved as “INTDOMLOAD.runcode”.

Demand Info: --- Total --- --- Placed --- - Not Placed - - Deactivated
- Area -> Area Count Bandwidth Count Bandwidth Count Bandwidth Count Bandwidth
AREA1 ->AREA0 10 4.864M 10 4.864M 0 0 0 0
AREA1 ->AREA3 15 3.712M 15 3.712M 0 0 0 0
AREA0 ->AREA1 10 4.864M 10 4.864M 0 0 0 0
AREA0 ->AREA3 20 1.280M 20 1.280M 0 0 0 0
AREA2 ->AREA1 24 32.544M 0 0 24 32.544M 0 0
AREA2 ->AREA0 16 21.696M 0 0 16 21.696M 0 0
AREA2 ->AREA3 8 10.848M 0 0 8 10.848M 0 0
AREA3 ->AREA1 12 2.176M 12 2.176M 0 0 0 0
AREA3 ->AREA0 20 1.280M 20 1.280M 0 0 0 0
-------------------------------------------------------------------------------
ALL ->ALL 135 83.264M 87 18.176M 48 65.088M 0 0
--- Inter-Domain Traffic from DOMAIN-EAST to DOMAIN-WEST
Demand1,DOMAIN_EAST,N1,,,XN1,US,DOMAIN_WEST,N2,,,XN2,US,
900000,"R,A2Z,CBR",Don't Care,Don't Care,Don't Care,"00,00",N1@@N2,684,25,no,no,
,
PVC Info: --- Total --- --- Placed --- - Not Placed - - Deactivated-
Domain -> Domain Count Bandwidth Count Bandwidth Count Bandwidth Count Bandwidth
DOMAIN-EAST->DOMAIN-WEST 1 900.000K 1 900.000K 0 0 0
0

--- Inter-Domain Traffic from DOMAIN-EAST to TEST
--- Inter-Domain Traffic from DOMAIN-WEST to NONE

--- Inter-Domain Traffic from DOMAIN-WEST to DOMAIN-EAST
Demand1,DOMAIN_EAST,N1,,,XN1,US,DOMAIN_WEST,N2,,,XN2,US,
900000,"R,Z2A,CBR",Don't Care,Don't Care,Don't Care,"00,00",N1@@N2,684,25,no,no,
,
PVC Info: --- Total --- --- Placed --- - Not Placed - - Deactivated-Domain -> 
Domain Count Bandwidth Count Bandwidth Count Bandwidth Count Bandwidth
DOMAIN-WEST->DOMAIN-EAST 1 900.000K 1 900.000K 0 0 0
0
--- Inter-Domain Traffic from DOMAIN-WEST to TEST
Demand2,DOMAIN_WEST,N2,,,XN2,US,TEST,N3,,,XN3,US, 750000,"R,A2Z,CBR",Don't
Care,Don't Care,Don't Care,"00,00",N2@@N3,684,21,no,no, ,
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PVC Info: --- Total --- --- Placed --- - Not Placed - - Deactivated-
Domain -> Domain Count Bandwidth Count Bandwidth Count Bandwidth Count Bandwidth
DOMAIN-WEST->TEST 1 750.000K 1 750.000K 0 0 0
0

DescriptionField

The number of demands/PVCs between the two areas.Count

The amount of bandwidth used by the demands/PVCs.Bandwidth

All demands/PVCs between the two areas: placed + not placed + deactivated.Total

The demands/PVCs between the areas that are routed.Placed

The demands/PVCs between the areas that are not routed.Not Placed

The demands/PVCs between the areas that are not activated.Deactivated

Inter Area Paths Report

The Inter Domain Paths Report displays information regarding paths between two

user-specified areas/domains. The output file that is written to the output directory is

called “INTDOMPATH.runcode”.

DescriptionField

The number of demands/PVCs between the two areas.Count

The amount of bandwidth used by the demands/PVCs.Bandwidth

All demands/PVCs between the two areas: placed + not placed + deactivated.Total

The demands/PVCs between the areas that are routed.Placed

The demands/PVCs between the areas that are not routed.Not Placed

The demands/PVCs between the areas that are not activated.Deactivated

Area Pass Through Paths Report

The Area Pass Through Paths Report, or the Domain Pass Through Paths Report,

generates information regarding demands passing through an area or domain in the

network. This report is only available for networks definedwithmultiple areasor domains

and demands to and from each domain. The output file that is written to the output

directory is called “DOMPASSTHRU.runcode”.
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Following is a sample text file of the Domain Pass Through Paths Report from an ATM

network:

Demands passing through domain AREA0:
RN1N15,0.0.0.3,N1,,,XN1,US,0.0.0.1,N15,,,XN15,US, 
768000,"R,BR1.0M,BM768K,BB200K,RT",Don't Care,Don't
Care,Don't Care,"02,02",N1-N10@@N17--N4--N7@@N8--N15,600,23,no,no, ,
RN1N15,0.0.0.3,N1,,,XN1,US,0.0.0.1,N15,,,XN15,US, 
768000,"R,BR1.0M,BM768K,BB200K,RT",Don't Care,Don't
Care,Don't Care,"02,02",N1-N10@@N5--N6--N7@@N8--N15,600,22,no,no, ,
RN2N3,0.0.0.3,N2,,,XN2,US,0.0.0.1,N3,,,XN3,US, 512000,"R,Z2A,UBR+",Don't Care,Don't
 Care,Don't
Care,"02,02",N2--N10@@N17--N4@@N3,400,16,no,no, ,
RN2N3,0.0.0.3,N2,,,XN2,US,0.0.0.1,N3,,,XN3,US, 512000,"R,Z2A,UBR+",Don't Care,Don't
 Care,Don't
Care,"02,02",N2--N10@@N17--N4@@N3,400,16,no,no, ,
RN2N3,0.0.0.3,N2,,,XN2,US,0.0.0.1,N3,,,XN3,US, 512000,"R,Z2A,UBR+",Don't Care,Don't
 Care,Don't
Care,"02,02",N2--N10@@N17--N4@@N3,400,16,no,no, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't 
Care,Don't
Care,"02,02",N2--N10@@N11--N6@@N13,400,13,no,no, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't 
Care,Don't
Care,"02,02",N2--N10@@N11--N6@@N13,400,13,no,no, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't 
Care,Don't
Care,"02,02",N2--N10@@N11--N6@@N13,400,13,no,no, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't 
Care,Don't
Care,"02,02",N2--N10@@N11--N6@@N13,400,13,no,no, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't 
Care,Don't
Care,"02,02",N2--N10@@N11--N6@@N13,400,13,no,no, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't 
Care,Don't
Care,"02,02",N2--N10@@N5--N6@@N13,400,12,no,no, 
,RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't
 Care,Don't
Care,"02,02",N2--N10@@N11--N6@@N13,400,13,no,no, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't 
Care,Don't
Care,"02,02",N2--N10@@N5--N6@@N13,400,12,no,no, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't 
Care,Don't
Care,"02,02",N2--N10@@N11--N6@@N13,400,13,no,no, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't 
Care,Don't
Care,"02,02",N2--N10@@N11--N6@@N13,400,13,no,no, ,
-- 15 PVC(s)(bw=3.712M) pass through domain AREA0

OSPF Area Summary Report

The Area Reports in the Report Manager display information about areas in the network

model. This section includes a description of theOSPF area summary and detail reports,

as well as the ABR border area report.
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Figure 196: The OSPF Area Summary Report

DescriptionField

The AS number of the areaAS Number

The name of the OSPF areaOSPF Area

The number of nodes that are defined as Area Border Routers (gateway routers)# of ABRs

The number of routers in the OSPF area that aren’t defined as ABRs# Internals

The total number of routers in the area (equivalent to # of ABRs + # Internals)# Routers

A unique name created by concatenating the AS number and the area nameASno_Area

OSPF Area Detail Report

Figure 197: The OSPF Area Detail Report

DescriptionField

The AS number of the OSPF area that the router is located inAS Number

The name of the OSPF area that the router is located inOSPF Area

The name of the routerRouter Name
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DescriptionField

The router’s IP AddressRouter IP

Is this router defined as an Area Border RouterABR

ABR Bordering Area Report

DescriptionField

The AS number of the area that the ABR is located inAS Number

The name of the ABRABR

A list of all the areas that the router is borderingBordering Area(s)

BGP Reports

When the client session is opened for the first time, the BGP Report should be checked

to make sure that the network has no obvious BGP configuration errors. The output file

that is written to the output directory is called “BGPRPT.runcode”.

BGP Integrity Check Report:

BGP statistics – This section shows:

• The total number of BGP speakers in the network

• The total number of neighbors

• The total number of policies

• The list of all ASs and the number of their BGP speakers

* BGP Integrity Check Report
******************************************************
-- 17 BGP speakers,89 neighbors,283 members,183 policies
-- 3 local AS:
ASno 222: 9 routers
ASno 111: 7 routers
ASno 555: 1 routers

Neighbor AS Specification Error Check Report

This section shows any errors about ASs that are not specified correctly. For example,

routerAdeclares that its neighbor, routerB, is inAS1243, but routerB is actually inAS4312.

* * * * * Neighbor AS Specification Error Check Report
AS Location Nbr_AS Nbr_IP_Addr Nbr-Location ValidAS Comments
111 X39 224 69.49.226.34 Q39 222
*** 1 AS specification errors
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In the example, the Neighbor AS Specification Error Check Report shows that there is an

error in the node (Location) X39.

The neighbor node(Nbr-Location) is Q39 and the neighbor AS (Nbr_AS) is 224, which

should be 222 as shown in the ValidAS field.

Unbalanced BGPNeighbor Check Report

The BGPprotocol requires that if router A declares router B to be its neighbor, then router

B also has to declare that router A is its neighbor. If not, then an unbalanced neighbor

occurs. This section reports any unbalanced neighbors between BGP speakers within

the network.

* * * * * Unbalanced BGP Neighbor Check Report
# Unbalanced BGP Neighbor = 2
AS Location Nbr_AS Nbr-Location
111 S39 111 X39
111 W39 111 X39

The Unbalanced BGP Neighbor Check Report shows that there are two unbalanced

neighbors. On the first record S39 declares that X39 is its neighbor but X39 does not

declare that S39 is its neighbor. The second record shows a similar error.

IBGPMesh Connectivity Check Report

All IBGP speakers within an AS have to be fully meshed, unless route reflectors or

confederation are used. This section shows if any AS is not fully meshed.

A full mesh for both IPV4 and VPNV4 address families are checked.

* * * * *
IBGP Mesh Connectivity Check Report
AS222: #IPV4 IBGP neighbor=0. Check mesh definition for VPNV4 address family
AS 222: passed mesh connectivity checking
---- VPNV4 AS111: S39 is not defined as X39's neighbor
IPV4 VPNV4 AS111: W39 is not defined as X39's neighbor
AS111: 2 neighbor definition missing
AS333: IPV4, VPNV4, L2VPN IBGP neighbors are not defined
AS 555: passed mesh connectivity checking* * * * *
IBGP Mesh Connectivity Check Report
AS222: #IPV4 IBGP neighbor=0. Check mesh definition for VPNV4 address family
AS 222: passed mesh connectivity checking
---- VPNV4 AS111: S39 is not defined as X39's neighbor
IPV4 VPNV4 AS111: W39 is not defined as X39's neighbor
AS111: 2 neighbor definition missing
AS333: IPV4, VPNV4, L2VPN IBGP neighbors are not defined
AS 555: passed mesh connectivity checking

The IBGPMesh Connectivity Check Report shows the following
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• AS222 is fully meshed for the VPNV4 address family but no IBGP neighbors exist for

IPV4 address family.

• AS111 is not fullymeshed for IPV4 and VPNV4. For the VPNV4 address family, S39 and

W39arenotdefinedasX39’sneighbors. For the IPV4address family,W39 isnotdefined

as X39’s neighbor.

• AS555 passes the mesh connectivity check for both IPV4 and VPNV4.

• AS333 is missing IBGP neighbors for the IPV4, VPNV4, and L2VPN address families.

IPV4/VPNV4/L2VPN Route Reflector Statistics

These three sections indicate the route reflector statistics, including number of route

reflectors, number of route reflector clients, and hierarchical route reflector information.

Route reflector clients with only one route reflector are listed as a warning that they do

not have redundant route reflectors defined. The following is an example of the IPV4

route reflector statistics:

IPV4 Route Reflector Statistics: 200 BGP Speakers, 8 Route Reflectors, 100 Route

Reflector Clients

Redundant Route Reflectors are not defined at 2 RR Clients

1. WDC1, RR= PHI1

2. WDC2, RR= PHI1

#Route Reflector Hierarchy Level= 3
Top Level: 4RR(s)
1. NYC1,
2. NYC2,
3. BOS1,
4. BOS2,
Level 2: 3RR(s)
1. PHI1, RR= NYC1 NYC2
1. PHI2, RR= NYC1 NYC2
2. BOS3, RR= BOS1 BOS2
Level 3: 1RR(s)
1. TRE1, RR= PHI1 PHI2

VPNV4 and L2VPN route reflector statistics are similarly provided.

It is recommended that all errors reported in the BGPReport file get fixed before carrying

on further analysis. One way to do it is to correct the errors on the configuration files and

then run through getipconf again.

Tunnel Layer Network Reports

• Tunnel Reports on page 336

Tunnel Reports

Demand Traffic on Tunnel Report

The Demand Traffic on Tunnel provides comprehensive tunnel bandwidth information.

Switch to the Tunnel layer before opening the Report Manager to see the tunnel layer
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reports.See theRouter FeatureGuide for IP/MPLSView fordetailsonviewingandmodifying

tunnels. The output file that is written to the output directory is called TUTIL.runcode”.

Figure 198: The Demand Traffic on Tunnel Report

DescriptionField

The name of the tunnel.TunnelName

The originating node of the tunnel.FromNode

The terminating node of the tunnel.ToNode

The total bandwidth of the tunnel.Bandwidth

The number of flows or demands that are routed on this tunnel.#Flow

The amount of bandwidth used by the demands on the tunnel.FlowBW

The difference between the flow bandwidth and the total bandwidth. This value is
calculated by FlowBW - Bandwidth.

BW_Diff

If the tunnel’s bandwidth is 0, then this value is the FlowBW. If the tunnel’s bandwidth is
greater than 0, then this value is calculated by dividing BW_Diff by the total andwidth.

BW_Diff_Ratio

This is the actual routed path of the tunnel.RoutePath

Simulation Reports

Link Utilization Reports

The Link Utilization Report displays the link and bandwidth information under normal

and peak conditions obtained from failure simulation runs. Thus, before opening this

report, youmust first run a failure simulation script (Simulation > Simulation Scenarios).

The results depend on the settings of the failure simulation.
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Figure 199: The Link Peak Utilization Report

DescriptionField

The name of the link.Linkname

The ID of the source node where the link originates.Anode

The name of the source node where the link originates.Aloc

The country where the source node is located.ACountry

The ID of the destination node where the link terminates.Znode

The name of the destination node where the link terminates.Zloc

The country where the destination node is located.ZCountry

The vendor associated with this link. Possible values for vendors include those that are specific
to a certain country or region, and are listed in the tariff database. If a vendor is not specified,
this value is set to the default value DEF.

Vdr

The type of trunk being used. The trunk type is subsequently used in determining link pricing
and bandwidth availability.

Type

The total bandwidth of the link from node A to Z.TotalBw

Theamountofbandwidthusedon this interfaceby thedemand requirements fromthedemand
file.

UsedBw

The peak (maximum) bandwidth used by the demand requirements between node A and Z
during failure simulation.

PeakBw

The percentage of total bandwidth used by demands prior to the failure simulation.UtilPct

The peak percentage of total bandwidth used during failure simulation.

This is calculated as PeakBW divided by TotalBW.

PeakUtilPct

The number of demands carried by the link in the normal mode#Demand

The peak number of demands carried by the link during failure simulation.PeakCnt
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DescriptionField

The number of failures that caused the used bandwidth to exceed (1-fatpct)*TotalBw.#OverSubCnt

The amount of bandwidth used on this interface by the demand requirements during period n
of the trafficload file.

LoadBW_n

Thepeak (maximum)bandwidthusedduring failure simulation for thisperiodnof the trafficload
file.

PeakLoadBw_n

The type of simulation event (for example, NDFAIL stands for node failure) that triggered the
worst traffic load on either end of the link, and the associated event detail (for example, name
of failed network element).

SimType / SimEvent

The type of simulation event that triggered the worst demand count on the link (for example,
NDFAIL stands for node failure), and the associated event detail (for example, name of failed
network element).

Cnt_SimType/Cnt_SimEvent

Interactive Failure (SIMRPT) Reports

The Interactive Failure report is a trace file that records statistics during an interactive

failure simulation. To create the report, you must enable the Trace option in the Failure

Report tab of the Failure Simulation Options (Tools > Options > Failure Simulation).

Then, performan interactive failure sequenceby failingnodes/links via themap right-click

menus or via Simulation > Fail Link/Node/Facility. When you run or step through the

simulation, results are appended onto the Interactive Failure report.

The Interactive Failure report is typically used for quick analysis. The report is usually

used following another failure simulation. For example, youmight first perform an

Exhaustive Link Failure, during which a few problem links are identified. Youmay then

want to analyze those link failures further by performing an interactive failure simulation

in which just those links are brought down and up.

NOTE: If you change any failure simulation options via Tools > Options >
FailureSimulationandpress “OK”, theSIMRPT isoverwritten(that is, cleared).

Note that for every network session (each time you open a network project
or specification file), you will need to set the failure simulation options, as
they are not saved.

Because this is a running trace file, you should not delete the SIMRPT file
during a network session. The results of an interactive failure simulationmay
not be saved in this event.

Configuration Reports

Integrity Checks Reports

When router configuration files are read into IP/MPLSView, a configuration integrity

checks report is generatedwhich lists possible errors found by the programwhile parsing
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the router configuration files. To access this report, you must first import configurations

files using the Import DataWizard from File > Import Data. Once the configuration files

have been imported, you can bring up the Configuration Reports in Report Manager.

Figure 200: Integrity Checks

DescriptionField

This field indicates the source of the error. This will usually be a configuration file name, or may
sometimes be a description whenmore than one configuration file is involved.

Error Source

This field gives the line in the configuration file where the error was found.Line

This field indicates the severity of the error. The levels include High, Medium, Low, andWarning.Severity

This field provides a description of the error andmay contain references to specific configuration
files or host names whenmore than one configuration file is involved.

Message

Config Files Status Reports

This report displays the config files used for the configuration integrity check reports.
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Figure 201: Config File Status

DescriptionField

This field specifies the directory path and filename of the node’s configuration.file

This field is the last modified date and time of the config file.timeStamp

This field is the Byte size of the config file.size

ISIS Reports

The ISIS Report displays the details of IS-IS configuration as a result of parsing a set of

configuration files from a network. Click on a row to see the ISIS attributes associated

with the router. The output file that is written to the output directory is called

“ISISReport.runcode”.

341Copyright © 2018, Juniper Networks, Inc.

Chapter 13: Report Manager



Figure 202: The ISIS Report

DescriptionField

The router name.Router

The interface of the router.Interface

The IP address andmask of the interface.address/mask

The IS-IS router type.Type

The IS-IS cost for this interface in level 1.Level 1 Metric

The IS-IS cost for this interface in level 2.Level 2 Metric

A portion of the configuration file that applies to its IS-IS configuration.Detail
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CHAPTER 14

Admin Menu

The Admin Menu contains system functions for the Task Manager, Device Library, User

Administration, and License File Manager.

The Task Manager is used to schedule data collection tasks for live networks. See the

IP/MPLSView Java-Based Management and Monitoring Guide for further details.

TheDevice Library opens theHardware Vendor andTypeManagerwindowwhich is used

to add new hardware types for live networks, modify the CLI template used for live

networks, andmodify theweb images used for a hardware vendor. See the IP/MPLSView

Java-Based Management and Monitoring Guide for further details.

• User Administration on page 343

• License File Manager on page 348

User Administration

TheUserAdministrationwindow isusedby the IP/MPLSViewadmin tocreateandmanage

accounts for accessing the software andWeb Portal.

• Accessing the User AdministrationWindow on page 343

• Creating User Groups and Permissions on page 344

• Creating Users / Assigning Users to Groups on page 346

• Performing User Administration From Text Mode on page 347

Accessing the User AdministrationWindow

To access the User Administration window, youmust log in to the client with the user

accountused to install the server.Otheruserswill not see theUserAdministrationwindow.

There are three types of users:

• Full Accessuserswhocan log into the client andoptionally theweb,whicharemapped

to a Unix User. Any Full Access user created through the User Administration window

must map to an existing Unix user on the IP/MPLSView server. The login name used

to log in to IP/MPLSViewshouldbe the sameas theUnix user name.Thecorresponding

password is the same as the password for the corresponding Unix user account. The

only exception is the “admin” user which is mapped to the Unix account of the user
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that installed the application. Authentication is done through an LDAP server that is

installed on the same server machine of IP/MPLSView.

• Web Portal users who are restricted to the web only.

• Web VPN users who are restricted to the web VPN view. These users can be assigned

access to view only certain VPN customers.

Creating User Groups and Permissions

An admin user can create any number of IP/MPLSView user groups and assign to each

of these group a custom set of permissions. Select the group type and enter in the group

name.

Figure 203: User Groups Tab of the User AdministrationWindow

Setting Permissions

Onceauser grouphasbeencreated, youcanassignpermissions to that user group.Some

features allow both View/Enable and Modify permissions, while others are turned

completely on or off with just the View/Enable permission.

Note that enabling some featuresmay require additional features to be enabled as well.

This is because certain features are dependent on other features to be enabled before

they canbeaccessed.When selecting the checkbox for sucha feature, the checkbox(es)

of the additional required feature(s) will automatically be checked as well.
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To select all View/Enable or Modify items within a category, check the corresponding

checkbox in the gray row indicating a category. Click the gray checkbox again to deselect

all items under that category. Individual items within a category can also be turned on

and off.

Changesmade to a user group’s permission checkboxes are savedwhen clicking “Apply”

or “OK.”

Regional Permissions

For the live network view, Full Access andWeb Portal users can be restricted to being

able to directly access the routers only for particular region(s). For devices outside of the

permitted regions,whicharegrouped into theOUTSIDE_REGIONgroup, view-onlyaccess

is provided, and features such as ping, traceroute, show config, and hardware inventory

are disabled. To limit the region(s), first define the regions in the top Regions tab. Note

that you need to have run a live network task in order to define regions based on routers

collected in the task.

Defining Regions

Figure 204: Defining Network Regions

Select the routers to add to a region from the left pane and then click Add toNewRegion

to create a new region with these selected routers. Alternatively, click Add NewRegion

in the right pane and then selectmultiple routers (using <Shift> and <Ctrl> keys), and

drag them from the left pane to the right pane. Note that youmust drag them over a

group name and not over a groupmember to add them to a group. Tomove a router

from one group to another, select the router, and drag it to another group. To remove the

router from the group, drag it outside of the right pane. Click Apply to save your changes.

Setting Regional Permissions
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Once the region has been added, select the User Groups tab.at the bottom of the right

pane and select the Regions tab. Here, you can limit the permissions for accessing the

router live by unchecking the All Regions checkbox and then checking the corresponding

region(s) to which the user can have access.

Figure 205: Setting Regional Permissions

Creating Users / Assigning Users to Groups

Once user groups have been setup with the desired permissions, you can create users

and assign them to user groups. To create a user, click on Add User icon button on the

bottom of the Users tab of the User Administration window.

Figure 206: Users Tab of the User AdministrationWindow

Type a login namenext toName. Next, choose the radio button for the appropriate group

type (Full Access, Web Portal, or Web VPN). Then select one of the available groups for

that group type.
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• For Full Access users, please choose a valid Unix User ID tomap the new IP/MPLSView

user to. This should be the same as the login name. (Note: To add a new user ID, you

must access the server via telnet or ssh window, switch to root user, and either run

“admintool” (requires display of the desktop) or use the “useradd” command (for

example, “useradd -g staff -d /export/home/wandl wandl” would add user wandl in

group staff with home directory /export/home/wandl). Subsequently, youmay create

a password for that user using the command “passwd userid” substituting useridwith

the Unix User ID. Note that you can similarly modify or delete a Unix user ID as root

user using the commands “usermod” and “userdel”.)

• ForWeb Portal andWeb VPN users, enter in a password to log in to the web interface.

Optionally specify additional contact information such as Email, Phone, IM, and a

Description for this new user.

Max Logins can be configured to control themaximumnumber of times a specific user

can be logged into the IP/MPLSView server.

Access level (Full Control, Browsing, Restricted, or Blocked) can be configured to

further control the access level of a user.

• Full Control Access: The Full Control user canmodify, perform design and simulation

on the network model in IP/MPLSView.

• Browsing Access: The Browsing user can only open a network model in IP/MPLSView

for viewing, but is not allowed to perform anymodification, design, or simulation on

the network model.

• Restricted Access: The Restricted user has Browsing privileges, but with even stricter

limitations to view only certain networks, files and directories: Once logged in, the

Restricted user can only navigate to the Home Directory and its child directories. Only

spec.* and newdemand.* network files are displayed in the File Manager. The user

cannot access "Hidden" files. All Report Manager reports are read-only, and are not

regenerated before displaying in the Report Manager. Certain menus are disabled.

• Block Access: The user is blocked from opening a networkmodel in IP/MPLSView. The

length of time a user is blocked from accessing the system is defined by the Block

Period in the Update GUI Login Policy section.

Once an IP/MPLSView user name has been added, that user name will also appear in

the User Groups tab of the User Administration window under the group to which it

belongs. Tomodify an existing user, select the user in the Users tab, and click the Modify

Icon button at the bottom of the window. To delete an existing user, select the user and

click the Delete Icon button.

If the user name has beenmapped to a valid Unix User ID, the new user should be able

to log in to the IP/MPLSViewclientand interface,whenassigned theappropriateprivileges,

using either the user name and the corresponding password for this Unix User ID.

Performing User Administration From Text Mode

In addition to using the GUI interface to perform user administration, users can also be

added from text mode using /u/wandl/bin/addWandlUser.sh.
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Usage: addWandlUser.sh: "name" "group" <-u "uid"|-w "webpassword"> [-a
<Full|Browsing|Restricted|Blocked>] [-e "email"] [-p "phone"] [-i
"im"] [-d "description"]
name => mandatory username
group => mandatory user admin group-u unixloginname => unix user id (mandatory
 if group is a full access group)
-w webpassword => password for web user (mandatory if group is a web
or vpn group)
-a <Full|Browsing|Restricted|Blocked> => sets access level to one of
the 4 choices (defaults to Full if not specified for non web/vpn
group)
-e email => optional email
-p phone => optional phone
-i im => optional im
-d description => optional description
Example:
$ cd /u/wandl/bin
$ ./addWandlUser.sh lab Administrators -u lab -a Full -d “for test”

To configure the maximum number of logins per user, edit the file

/u/wandl/data/.usr/.usercountwith one line per user to control. The last line is the default

maximum number of logins. For example, to configure at most 3 IP/MPLSView users,

and at most one user for all other users, the format is as follows:

wandl 3
1

License File Manager

TheLicenseFileManager allowsyou toview thecurrent license installed for IP/MPLSView.

It contains entries for themodules supported,maximumnumber of users, and expiration

date. The License File Manager also allows you to upload a license file to the server. This

will replace any existing license file.
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CHAPTER 15

Tools Menu

The Tools menu contains general tools such as Connect to Server, Revision Manager,

Add-ons and Options menu to change the various IP/MPLSView settings. Additional

tools may be available depending on your license or network model.

• Options:See “GeneralOptions” onpage350 to learnabout the variousoptions that can

be configured for IP/MPLSView.

• Diagnostics: Used for ping and trace route for live networks (IP/MPLS only). See the

IP/MPLSViewJava-BasedManagementandMonitoringGuide,PerformanceManagement

chapter for more details.

• MIB Browser / Monitoring by SNMP: Used to access andmonitor SNMPMIB objects

from network devices (IP/MPLS only). Refer to the IP/MPLSView Java-Based

ManagementandMonitoringGuideperformancemanagementchapter formoredetails.

• Compliance Assessment: Used to compare router configuration files’ to certain

templates for compliance (IP/MPLS only). See the Router Feature Guide for

IP/MPLSView, Compliance Assessment chapter for more details.

• RevisionManager: See “Revision Manager (IP Models)” on page 364.

• Connect to Server: Enables access to your server via Telnet or SSH. See “Connect to

Server” on page 363.

• Options Menu on page 349

• Connect to Server on page 363

• Revision Manager (IP Models) on page 364

OptionsMenu

NOTE: Depending on the hardware type, the Options windowsmay look
different and contain additional fields than what is described below. For
description of hardware-specific fields, see the hardware-specific guides.

• General Options on page 350

• Config Editor Options on page 350

• Path Placement Options on page 351
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• Failure Simulation Options on page 357

• Resize Options on page 358

• Map Preferences on page 359

• Report Options on page 361

• JMS Access Options on page 362

General Options

• Show progressmonitor while opening a network: The progress monitor when opening

a network displays the current status, whether it be loading the network or creating

the map.

• Show and notify other user’s login/logout activities: This option can be used to pop up

a status message in IP/MPLSViewwhen another user has logged into IP/MPLSView,

including details such as the user name, client PC name and client PC IP address.

• KeepAliveMessage:The server and client send keep-alivemessages tomake sure that

the connection stays up. This value sets the message interval time in seconds.

• Use SSL forWeb Access: If this option is selected, then when IP/MPLSView redirects

users to theWeb Portal, it will direct them to a link prefixedwith https using port 8443

rather thanhttponport8091. Bydefault this is determinedby theServerDefault setting,

USE_SSL, in /u/wandl/bin/mplsenvsetup.sh.

Figure 207: General Options

Config Editor Options

The Config Editor Options window is used to set options for the Configuration Editor,

which is a text editor enhanced for configuration files. There are also two sub-options

windowswhichallowyou tomodify thecolorsand fontsused in theeditor. For information

on how to access the Config Editor, see “Config Editor (Router and Switch)” on page 52.
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Figure 208: Config Editor Options

• Enable auto-completion:Selecting this option enables the intelligent auto-completion

of commonly-used configuration commands as you type.

• Show outline and property pane: Selecting this option displays two extra panes on the

right-hand side of the editor. The Config Editor divides each config file into blocks,

based on significant keywords. The outline pane provides an outline view of the config

file based on these blocks and allows you to quickly jump to a specific section of the

config file. The property pane reveals information regarding the router and associated

config file, such as IP address, vendor, version number, as well as the location of the

config file.

• Showoutput/integritycheck list:Selecting this optiondisplays the results of the integrity

checks in a separate pane within the editor.

• Usememory-efficient alternative editor: Selecting this option disables the

configuration-enhanced text editor and uses the standard text editor when you open

a router configuration file.

• Config Editor > Fonts: select to configure the font used by the config editor.

• Config Editor > Colors: select to configure the colors used by the config editor. See Set

Color-Coding and Other Options for more details.

Path Placement Options

NOTE: Depending on the hardware type, this optionmay contain additional
fields than what is described below. For a description of those
hardware-specific fields, see the hardware-specific guides.
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Figure 209: Path Placement Options

DescriptionField

The link prefix that gets used to generate the link name for newly added links. Bydefault, this is set to “NONE”
which means no link name is generated.

New Link Prefix

Themaximum number of hops allowed for a demand pathMax Hop

This specifies the method IP/MPLSViewwill use to determine a demand’s path placement: for example,
Constant Distance, Actual Mileage, Delay, Admin. Weight, OSPF, ISIS, IGRP, or EIGRP.

• ConstantDistance: Each link in thenetworkhas the samedistancemetric.Whenademand is tobeplaced,
theprogramfindsaminimumdistancepath. Sinceeach linkhas the samemetric, this effectively translates
into finding a shortest hop path.

• ActualMileage:Thedistancemetric for each link in thenetwork isbasedon itsairlinemileage. Indetermining
apath, theprogramwill search foraminimumdistancepath.Note thatbecauseof various tariff regulations,
the shortest distance path may not always be the least cost as well.

• Admin. Weight: This distancemetric for each link in the network is assigned by you in the bblink file
miscellaneous field. If a metric is not assigned for a particular link, the linkdist file node-to-node distance
is used. Otherwise, the linkdistunit parameter in the dparam file is used. The programwill attempt to find
the minimum distance path.

• Delay: The delay metric for each link in the network is used to compute the shortest path, not to exceed
theMax Delay value. If the delaymetric for a trunk is not assigned in the bblink file, a default value is given
based on the propagation delay and serialization delay.

• OSPF: The distancemetric for each link is based on the OSPF distance formula. For the router module,
thismay be a configured OSPFmetric, a configured OSPF reference bandwidth/trunk bandwidth or 10^8
/ trunk bandwidth. In a Frame Relay or ATM environment, it is set to 10^8 / available trunk bandwidth.

• ISIS: Uses the ISIS distancemetric.

• IGRP: Uses the IGRP distancemetric. This is a Cisco proprietary protocol.

• EIGRP: Uses the enhanced IGRP distancemetric. This is also a Cisco proprietary protocol.

• CDV: The distancemetric is based on the cell delay variation (CDV) for a trunk. The programwill find the
minimum distance path based on the CDV for each type of trunk.

Routing Method

This defines the average frame size, in bytes, used in overhead calculation for traffic utilization estimation
and delay calculation.

Frame Size
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DescriptionField

If there are parallel links between two nodes, this option is used to decide which link is used to route a
demand/tunnel. The following options are supported:

• Best Fit: This is used in layer3/layer2 multi-layer simulation for the router model. If there are multiple
tunnelsbetween twonodes, the "bestfit" algorithm isused to selectwhich tunnel touse for traffic between
those two nodes.

• Default: This uses the default algorithm implemented by the hardware.

• First Fit: This selects the first link encountered in the routing algorithm.

• Load Balance: This option will try to place the demands proportionally among the equal-cost paths, by
selecting the link with minimum traffic load.

• Random: This randomly selects a link; this is the default option for routers.

Link Balancing

Sets the delay for the node. Delay is in milliseconds (ms).Node Delay

Sets the propagation delay. Propagation delay is determined using the assumption that every 100miles
equals onemillisecond of delay.

Propagation
Delay

Advanced

DescriptionField

This parameter affects the placement order of demands. Possible values are:

• High-PriorityFirst: InputOrder:Placehigh-prioritydemandsbefore low-prioritydemands. Fordemands
with the same priority, sort by the order of the demands in the input file.

• High-Priority First: Scramble: Placehigh-priority demandsbefore low-priority demands. For demands
with the same priority, sort randomly. This is the default used in IP/MPLSView.

• High-Priority, High BWDemands First: Input Order: Place high-priority demands before low-priority
demands. Fordemandswith thesamepriority, placehighbandwidthdemandsbefore lowbandwidth
demands. For demands with the same priority and bandwidth, sort by the order of the demands in
the input file.

• High-Priority, High BWDemands First: Scramble: Place high-priority demands before low-priority
demands. Fordemandswith thesamepriority, placehighbandwidthdemandsbefore lowbandwidth
demands. For demands with the same priority and bandwidth, sort randomly.

• Scramble Randomly: Sort all demands together randomly and place them accordingly.

• Low Bandwidth Demands First: Scramble: Place low-bandwidth demands before high-bandwidth
demands. Among same-bandwidth demands, sort randomly. If there aremultiple links between two
nodes, less demands can usually be routed if this option is used. It is provided for worst-case study.

• High Bandwidth Demands First: Scramble: Place high-bandwidth demands before low-bandwidth
demands. Among same-bandwidth demands, sort randomly.

• Input Order: Route demands only by the order in the input file.

Placement Order
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DescriptionField

Thisparameter influencespath selectionwhenmore thanoneshortestpath is found to routeademand.
Possible values are:

• Hardware Implementation: Select among the shortest paths based on the existing hardware’s
implementation.

• Shortest Path Encountered First: (For experimentation) Among the shortest paths, use the first one
the program discovers, regardless of whether the hardware would select that path. This feature
might be useful in simulating a hardware device that uses a different routing algorithm than the
existing hardware.

• Select Randomly Among Best Candidates :(For experimentation) Randomly choose a path among
the paths with the shortest paths, regardless of whether the hardware would select that path. This
feature might be useful in simulating a hardware device that uses a different routing algorithm than
the existing hardware.

Path Selection
Method

When set to True, this forces the program to check demands against Policy Based Routing (PBR) even
if there is no destination IP address defined on the demand. When set to false, demands that do not
have destination IP address defined are not checked against PBR. Demands that do have destination
IP address defined are checked against PBR regardless of how this option is set.

Force PBR Check

Only interfaces of the same OSPF process/routing instance are allowed to exchange routing tables
and send traffic to one another. Forwhat-if studies, however, this parameter can be set to true to ignore
this requirement and to see how traffic would route if they were in the same OSPF process. For more
details, refer to the Router Feature Guide for IP/MPLSView chapter, Routing Instances.

Ignore Multiprocess

If this option is selected, demands are placed even if they exceed themax delay constraint property
specified for the demand.

Ignore Max Delay

This selection specifies whether the available bandwidth of trunks will or will not be checked during
path placement. When Yes is selected, it is not checked. When No is selected, it is checked. Hardware
default selection will depend on the hardware specification.

Allow Negative
Available Capacity in
Layer 3

By default False, any admin weight on the node itself is not included in the path length calculation. If
set to True, then the admin weight on the node is added to the path length calculation.

Include Node’s
AdminWeight in
Path Length
Calculation

BGP

DescriptionField

When both a BGP and IGP path are available between two ASs, by default the BGP protocol is treated
as having the higher administrative distance/preference. If this option, IGP Override, is set to true, then
the IGP route is used instead of the BGP route. If this option is set to false, the BGP route is used, as is
usually thedefault inmostnetworks. In thedparamfile, set this parameter to trueby setting IGPoverride=1.

IGP Override

IBGP Policies may be used to change the BGP next hop info when passing BGP tables from one speaker
toanotherusing IBGPneighbordefinitions.To turnon IBGPpolicychecking, set this to true. Forperformance
reasons, youmay want to change this flag to false for a network without IBGP policies.

In the dparam file, set this parameter to true by setting chkIBGPflag=1 (0 to skip IBGP policy checking).

Check IBGP Policy
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DescriptionField

Live BGP routing tables can be used to create a live BGP table object file that can be loaded into the
program to route according to the live BGP routing table by specifying the livebgprtblobj file in the
specification file. The live BGP routing table may have additional information about the BGP next hop to
external IP addresses that is otherwise unavailable through the config files. Select True to route according
to the live BGP routing table specified in the specification file. Select False to have the program route
according to the BGP routing table information generated from the config files and any additional BGP
protocol parameters that were entered into the BGP subnet file. In the dparam file, set this parameter
to true by setting useliveBGPrtbl=1.

Use Live BGPTable
If Available*

ECMP

DescriptionField

This number specifies themaximum number of ECMP sub-flows that can be split from
one original flow.

Max. ECMP Count

This bandwidth value specifies the minimum bandwidth a flowmust have in order to
split it into sub-flows.

Min. ECMP Flow BW

Hardware

This window allows you to specify the bandwidth of each type of trunk in the network,

a limit on the length of paths, and the demand priority scheme. The hardware type of

the network is displayed for you, but cannot be changed in this particular window.

DescriptionField

The current hardware typemay be selected from the Hardware Options window. Note that the
available list of device models is based on the switch libraries that have been licensed from Juniper
Networks.

Hardware Type

The reversepri parameterdetermineswhichdemandpriority schemeshouldbeusedby IP/MPLSView.

"No" for larger numbers that have higher priority (1=lowest priority) and
"Yes" if smaller numbers have higher priority (1=highest priority).

Reverse Priority

This number specifies the hop limit of the actual hardware and is used only in simulation mode,
primarily during the Simulate Path Placement function.

Thisparameter is not tobeconfusedwith themaxhopparameterwhich is usedduringdesignaspects
of IP/MPLSView.

Physical Hop Limit

The bandwidth and overhead fields indicate the trunk values which the program uses, by default,
for the selected Hardware Type. If, for any reason, these values are inconsistent with your expected
values, this Hardware Options window is the place to modify them. Bandwidth and link overhead
are used in the routing and rerouting algorithms when determining demand placement.

Bandwidth, Overhead
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Multicast

DescriptionField

This option allows you to enable or disable all links as PIM-enabled.Enable PIM

This specifies the PIMmode for the multicast feature.PIMMode

MPLS TE

DescriptionField

This option allows you to enable all links as MPLS-enabled, or have them set as specified per
link in the Protocols tab of the Link window.

MPLS-Enabled Mode

This specifies whether or not IDs of deleted tunnels should be reused. This applies to Tunnel
ID groups that are used to rename tunnel IDs to Cisco’s default tunnel ID format.When a tunnel
that has been assigned a tunnel ID is deleted, whether or not its ID is reused is determined by
this option.

Tunnel Parameters: Reuse ID
of Deleted Tunnels

This determines how bandwidth for multiple classes is displayed in the Link window. User can
choose between Maximum Allocation Model (MAM) and Russian Doll Model (RDM). Refer to
the Router Feature Guide for IP/MPLSView, chapter DiffServ Traffic Engineering Tunnels for
further details on the RAM andMAM bandwidth models.

Bandwidth Model

This defines the percentage of bandwidth reserved on a link for global pool / RSVP. This setting
is the default global setting for the entire network.

GlbPool/RSVP

This defines the percentage of bandwidth reserved on a link for sub pool / GB (Guaranteed
Bandwidth). This setting is the default global setting for the entire network.

SubPool/GB

MPLS TE LSP Tunnel Attributes

Type over the bitxx to a name you want to be associated with your attributes on the

Tunnels and links.

Reserved Bandwidth

DescriptionField

The Reserve Bandwidth File field indicates the path of the reserved bandwidth file that is being
used, if any. To incorporate the reserved bandwidth file into the network model, you can import it
using the File > Read, Network Files tab, Control Files category, rsvbwfile.

The file specifies reservedbandwidth information for specific trunks. See the File FormatReference
For NPAT and IP/MPLSView for details on the rsvbwfile file format.

Reserve Bandwidth File

Global parameter that indicates the default percentage of bandwidth to be reserved for ethernet
trunks. This parameter can be overridden in the rsvbwfile.

Ethernet Fat (%)

Global parameter that indicates the default percentage of bandwidth to be reserved for all trunks.
This parameter can be overridden in the rsvbwfile.

Default Fat (%)
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DescriptionField

Global parameter that indicates the default amount of bandwidth to be reserved for all trunks.
Fixed fat is specified in either bits or kilobits. This parameter can be overridden in the rsvbwfile.

Default Fixed Fat

Failure Simulation Options

Figure 210: Failure Simulation Options

DescriptionField

This field specifies whether “CanFail = 0” trunks should be included in link failure
simulations. A link marked as “CanFail = 0” represents a link that will never fail. A
link marked as “CanFail = 1” represents a link that will fail.

Include Never CanFail trunks in failure
simulations

This field specifies whether unplaced demands should be included in the failure
simulation. Note that unless specified in this option, unplaced demands are listed
along with failed demands in the node, link, and single line failure simulations.

Exclude Currently Unplaced Demands

If set to Yes, AS nodes and AS links are failed in the exhaustive node and link
simulations, respectively. Toexclude theASnodesandAS links fromtheexhaustive
simulations, set this option to No.

Include AS Node/Link

Duringnode failure simulation, demandsand tunnels thatare lower than thedefined
value are automatically dropped and will not be rerouted in the simulation results.

Drop all Demands/Tunnels with Priority
lower than <value> when a Node Fails

During link failure simulation, demands and tunnels that are lower than the defined
value are automatically dropped and will not be rerouted in the simulation results.

Drop all Demands/Tunnels with Priority
lower than <value> when a Link Fails

FRR

This window defines the default FRRmode used during failure simulation batch scripts.

If no FRRmode is specified in failure simulation batch scripts, the script will use the FRR
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mode specified in this window by default. The FRRmodes are explained in the table

below:

Simulates the “normal” tunnel reroute. Does not consider the effect of the FRR detours during the
simulation. Peak utilization reflects that during the “normal” situation.

Normal

Simulates only the FRR detour. The resulting link peak utilization report reveals just the peak utilization
experienced during the detour.

FRR only

Simulates the FRR detour first followed by the normal primary tunnel reroute as established at the
head-end router. The resulting link peak utilization report identifies the worst utilization, or max value
of the transient detour and normal modes.

NOTE: A primary tunnel being detoured is marked down if it cannot be rerouted.

FRR + Normal

Failure Report

Specifies whether output results should be in detailed (verbose) or summary format. When in
verbosemode, the programwill draw colored lines representing failed and rerouted demands
on the topology map during interactive failure simulations. When verbosemode is disabled,
no such lines are drawn on themap during interactive failure simulations.

Verbose Mode

This option allows you to sequentially step through a given simulation run. You can advance
to the next simulation by clicking the left mouse button. If sequential mode is set to “No”, the
simulation will automatically run to completion.

Sequential Mode

This option specifies whether a trace file should be used to record simulation output results.Trace File

Specifies whether paths that originate or terminate at a failed node should be displayed in the
simulation output. All such demands will obviously be brought down in a node failure.

DisplayPaths at FailedNodes

Specifies whether demands that failed because of path required criteria should be excluded
in the simulation. If a demand is definedwith a path required field and that path is not available
for some reason, the demandwill fail. The programwill not attempt to reroute the demand on
an alternate path.

Exclude Path Required
Demands in Failure Statistics

When running an exhaustive failure simulation in layer 3 and selectingGeneratePeakUtilization
Report, the Tunnel Peak Utilization report generation can be turned off by setting this to No.

Report Tunnel Utilization

Resize Options

The Resize Options may be used to tune and optimize the current backbone topology.

Accessed from Design > Backbone > Resize, this design feature will modify the current

link bandwidths to maximize utilization. Three resize options can be chosen: based on

the current peak simulation results, based on normal utilization, or based on exhaustive

node/link/SRLG failure simulation results. This analysis andmodification presume that

there might be unnecessary bandwidth in certain links and also take into account the

additional bandwidth necessary during demand rerouting. When the resize option is
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performed, IP/MPLSView replaces links in the network in accordance with the Link Type

Candidate selected in the Design Options window.

DescriptionField

Added penalty during Resize for replacing large trunks with multiple trunks of smaller size.Additional Trunk Penalty

Valid link types are taken from the current tariff tableTypes in Tariff

For the aggregate link type, valid link types are based onmultiples of a specified unit, for
example, if the unit is 10G, then the resize will choosemultiples of 10G, for example,
AGGR10G, AGGR20G, etc.

AGGR

Map Preferences

The color scheme and display options of the topology mapmay be changed in the Map

Preferenceswindow.Click onany color to change it. Youmayalso changeoptions related

to the display of the network topology.

Figure 211: Map PreferencesWindow

DescriptionField

This selects the color for the background on the topology window.Background

This selects the color for text labels and other foreground items.Foreground Text

This selects the color for any groups in the topology defined by you. A group is a region that
can be set by you.

Grouping Discs
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DescriptionField

This is the color for any user-selected objects in the topology window.Selected Objects

This is the color for failed elements (links, nodes, facilities, etc.)Failed Elements

Allows you to set the color for back-up links.Backup Links

Allows you to set the color for virtual trunks.Virtual Trunks

This selects the color of country borderswhen the countrymap is displayed in theTopology
window.

Country Borders

Specifies the color of the lines shown when you click and drag the mouse in the topology
window.

Mouse Drag Lines

Youmay increase or decrease the font size of text (such as node labels, link labels, etc.)
that appear in the Topology window.

Font Size

Allows you to select a method for painting discs for groups on the topology map. The
choices are: translucent, quick rings, opaque and none. On somemachines, choosing quick
rings or opaquemay improve performance.

Paint Discs

When checked, the programwill drawmultiple links between a given node pair as curves
for better display of the paths.

Drawmultiple links as curves

If Drawmultiple links as curves is not checked, thenmultiple links are drawnas onebundled
link.

When Showmax is not checked, the utilization displayed frommouse-over in the bottom
bar of the map is the Average utilization of the multiple links.

WhenShowmaxoption is checked, theutilizationdisplayed frommouse-over in thebottom
bar of the map is the Highest utilization of the multiple links.

Show utilization max instead of
average within bundle

When checked, this option will animate the Distribute Points function in the Topology
window. Refer to the Topology chapter for more information.

Animate Distribute Points

This optionwill animate thepathbetween twopoints in the topology, showing thedirection
the path is flowing. Turning off the animation will improve the performance of the system.

Animate Paths

Selecting this option will cause the initial layout when opening a network to attempt to
layout nodes in such away thatminimizes LAN link lengths asmuch as possible. Since this
only affects the initial layout when opening a network, changes made to this option will
not have any effect until a new network is opened.

This option should be turned off if nodes connected by ethernet can be separated by longer
distances.

Group by LAN in default layout

Displays virtual trunks as regular trunks. When this option is not checked, virtual trunks are
always displayed in the color chosen above.

Show VT as normal

By default, the graphcoordaux file is automatically saved when closing a network to avoid
losing auxiliary changesmade to themap, such asmap legend settings. Uncheck to disable
this feature.

Automatically save
graphcoordaux file when closing
a network
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DescriptionField

Resets options to the previous settings.Reset

Sets options to the system default settings.Defaults

Applies new settings immediately without closing the Map Preferences window.Apply

Applies new settings and closes the dialog window.OK

Cancels the any changes.Cancel

Opens the help documentation.Help

Report Options

TheReportOptionswindow isused tocustomize the formatof reportsgenerated through

IP/MPLSView.

Figure 212: Report Options

DescriptionField

The runcode is the filename extension appended to the end of each output file generated in a particular
run of IP/MPLSView. It allows you to distinguish amongst several sessions using the same data set. To
specify a runcode, you should type thedesired input in theRuncode text box of theReportOptionswindow.
This runcodemay consist of a combination of alphanumeric characters. Subsequently, any report files
generated is in the format filename.runcode. It is important to use unique runcodes. Otherwise, there is a
danger of accidentally overwriting existing files with the same names.

Runcode
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DescriptionField

You can choose to view report data related only to the specified owner(s).Owner

This option sets the display preference for paths in the report.Path Reference

In report files, nodes may be referred to by either node name, node ID, or hostname.Node Reference

In report files, linksmaybe referred tobyusingoneof twoconventions. The standardmethod is to represent
a link by the node pair that defines it. An alternative method is to associate a user-defined link namewith
that link. If a link name is not defined for a link, the node pair naming convention is used. To use either
method, select the appropriate box in the Link Reference section. Note: This option applies not just to
report files, but also to some console messages, for example, those displayed during an Exhaustive Single
Line Failure.

Link Reference

Youmay specify the file format of subsequent reports in the Report Options section. Three formats are
supported: Formatted Text, CSV, and HTML. Formatted Text is simply standard ASCII output that may be
viewed in any text viewer without additional preprocessing. Comma delimited format (CSV) outputs text
so that a comma is usedas a separator for eachdistinct field in the report. This ismost often used to import
report files into spreadsheet applications, and can be viewed using the Report Viewer. Finally, Hypertext
Markup Language format (HTML) outputs reports in HTML-compliant format so that the report files can
be directly viewed by web page browsers.

Report Style

The bandwidth unit used in reports may be selected in the Bandwidth Unit section of the Report Options
menu. The Best Fit option can be used when there is a large number of different bandwidth types being
used. Reports generated with the Best Fit option may contain Bits, Kilobits, or Megabits depending on the
available field space. Note that cells may only be selected for ATM hardware devices. In the ATM case,
values entered in bits are converted to the appropriate number of cells using a conversion formula. Decimal
Places is the number of digits to the right of the decimal point displayed in reports.

Bandwidth Unit

The distance unit used in report files may be specified in the Report Options menu. To specify a distance
unit, go to the Distance Unit section and select an appropriate one. The available options are miles and
kilometers (km).

Distance Unit

Sets the currency unit for IP/MPLSView. To specify a currency, first go to the Currency section. Then, select
a country from the drop-down combo box listing the available countries. Once this is done, the selected
country's associated currency unit is used in subsequent monetary values.

NOTE: For the EURO currency used in various European countries, select ER EURO from the country list.
The Euro unit is displayed as ER.

Currency

JMS Access Options

NOTE: JMS Access is used for Live Networks only.

The JMS Access parameters are for Events and Threshold related use. Toggling the

“Connect upon opening the Live Network” option is used to turn on or off the display and

refreshing of the event counters on theStandardMap for the FaultManagementmodule.

This setting will not take into effect until the next time the live network is opened.
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Figure 213: JMS Access Options

Connect to Server

The Telnet application allows you to open a telnet session to any host. Right clicking in

the window displays a pop-upmenu with the following additional functions:

DescriptionField

Once a host IP or name have been specified, selected this will connect you to the specified
host. This option requires that the NPAT or IP/MPLSView Sun server machine be connected
to the specified host.

Connect using Telnet

SSH is ameans to connect to the specified host using a secure shell. This option requires that
the NPAT or IP/MPLSView client machine be connected to the specified host.

Connect using SSH

Disconnects the current telnet session.Disconnect

Copies text that is selected in the telnet window to the clipboard.Copy

Pastes text in the clipboard to the current telnet window.Paste

The telnet capture can be used to telnet to a router and execute a router command. Some
of the major commands used by Cisco and Juniper Networks routers to display configuration
information is in a drop downmenu in the Capture window.

Capture

Selecting this option allows you to save the telnet session into a file.Capture to File

Settings for Encoding and Font Family of the telnet window.Options

Exits the telnet window.Exit Telnet/SSH
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RevisionManager (IPModels)

NOTE: This feature requires a license. Please contact your Juniper Networks
representative for more details on this feature.

The RevisionManager is a powerful tool available in the IPmodel of IP/MPLSViewwhich

allowsyou tokeep trackof changesmade to router configuration filesandcertainnetwork

project files. Similar to the UNIX “diff” command, the Revision Manager displays a list of

the changesmade to the current version of the files as compared to the original version.

Themanager’s functionality includes viewing previous versions of a file, checking in new

versions of a file, side-by-side comparison of two files in different versions, and saving

the differences in a text file on the client machine.

The Revision Manager also has additional options in the Actionsmenu in the upper right

corner. To switch between network file revision and configuration file revision for Live

Networks, use the Actions > Network File Revision and Actions > Config File Revision

menus.

• The configuration revision management is covered in the Router Feature Guide for

IP/MPLSView chapter on Configuration Revision and in the IP/MPLSView Java-Based

Management and Monitoring Guide chapter on Configuration File Management.

• The network file revision tracks changes to the following network project files: bblink,

intfmap, nodeparam,pathtable, and tunnel.Note thatpseudo-nodes suchasASnodes

and Ethernet nodes are ignored for the purpose of the nodeparam file revision.

Figure 214: The Revision ManagerWindow

The Revision Manager window is split into three sections. The panel on the left displays

all the configuration files in tree view for this particular network model and the number

of revisions each configuration file has undergone. The right top section of this window

displays the contents of the highlighted file in the left panel.
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File versions are listed in incremental order, where the first revision of the file is listed as

version 1.1 up to the last revision (in the previous figure, version 1.3).

The current version of the file is listed as “current”. To see the dates of these revisions,

select the folder for the configuration file, and the revisions are listed on the right pane

in a table with “Last checked-in” times.

Revision Summary

For an overview of all the files in the revision manager, right-click on the left pane and

select Revision Summary. This would open a table with the latest revision number and

checked in date per file.

Figure 215: Revision Summary

Compare

The Compare option in the pop-upmenu allows you to compare files in the system.

Compare the SelectionWith Revision...

To compare file and see the differences between any two versions of a config, first select

a file version in the left panel and then right click on themouse and select Compare the

selected revision with... and a dialog box will appear listing all versions of the file to be

compared with.

Once you have selected the version for comparison, the Revision Manager displays the

two versions side-by-side in a table display. In this view, you can browse through the two

different versions and compare the difference. Any differences between the two versions

are displayed in red text.

Differences are shown by the colored text in the tables. Entries that are marked in RED

signify that the line was edited. Entries in GREEN in the older revision file signify that the

linewas deleted. Entries in BLUE in the newer revision file signify that the linewas added.

The padlock symbol in the upper right corner of the second table allows you to “lock” or

“unlock” the two table listings together. When the tables are locked, you can use the

scroll bars in either table to scroll through the file. Scrolling is synchronized in both tables
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as you browse through the table. When the tables are not locked, each tables act

independently and you can scroll through each table individually.

With the forward, reverse, and save buttons at the bottomof these two tables (as shown

in the figure above), you can jump to the next or previous difference in these two versions

of the input file (or jump to the last or first difference found in these two file versions).

You can also save the difference in a text file on the local machine.

Clicking on the disk button will allow you to the save differences to local text file.

Checking In Input Files

In offline mode, in order to have the Revision Manager to recognize and display the

different versions of input files, youmust check in these IP/MPLSView input files into the

system after saving the network using File > Save Network to the same runcode.

Check In

To check in IP/MPLSView input files, Select the desired file type. Right-click over the left

pane and select Check-In. After you have checked in the file, any new versions of the file

is displayed in the left panel. You can thenperforma file comparison to see thedifference

between the new version and the previous revision by selecting Compare the selection

with revision... function from the pop-upmenu.

Check in All IP/MPLSView Files

With this option, you can also check in files by selecting the Check in All IP/MPLSView

files function in the pop-upmenu. By doing so, any newMPLSView input files that have

been changed since the last revision is checked into the system.

Remove the Last Check In

This option will remove the last file version that was checked into the revision system.

Retrieve Configurations By Time Stamp

To retrieve configuration files by time stamp, right-click in the left-hand side panel and

select Retrieve all by timestamp. Select the date and time for which to retrieve the

configuration files, andBrowse to select thedirectory inwhich to retrieve theconfiguration

files. A new directory can be created using the Directory Chooser dialog, if necessary.

The Selection tab can be used to retrieve only configuration files which are marked with

a checkbox. Right-click in the window and select Uncheck All or Check All.

Purge Revisions

Over time, the amount of data storedmay accumulate and itmaybedesirable to remove

older versions of files. Select Actions > Schedule revision purge in order to purge revisions

older than 1 Month, 2 Months, 3 Months, 6 Months, or 1 Year.
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PART 1

Appendixes

• Input Files Format on page 369

• Search Preferences on page 379
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APPENDIX A

Input Files Format

This appendix describes the input files, file format, and file specifications used by

IP/MPLSView. Formoredetails on these filesandother files, see theFile FormatReference

for IP/MPLSView.

• Spec File on page 369

• Backbone Data on page 370

• Control Files on page 375

• Cost Files on page 376

Spec File

The specification file contains a list of the files that characterize a network. Each line

specifying a file location should be in the format, keyword=filename, where keyword is

the file type name and filename is the file path (either absolute or relative to the path

specified in thedatadir variable).Note thatboth keywordand filenamearecase-sensitive.

Following are a list of keywords.

DescriptionType

bblink, demand, domain*, facility*, graphcoord, group, muxloc, newdemand,
nodeparam, owner*, site

Backbone data files

custrate*, intlratespec*, ratespec, usercost, usercountrycostCost Files

fixlink, linkdist, nodeweight, rsvbwfileControl Files

NOTE: Files denoted by an asterisk (*) are license dependent. See separate
manual for more details.

A specification file also includes the following keywords:

• runcode default file extension when saving files

• datadir default input file directory prefix
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• ratedir tariff database directory

• dparam file containing design parameters

For keywords for hardware-specific files, please see the appropriate document.

Backbone Data

MUXLOC (muxloc=filename)

Description: Node File

General format (United States and Canada locations):

#nodeID name npa nxx[MISC]
N01 NYC(5WTC) 212 392
General format (International locations):
#nodeID name npa nxx countrycode lat long [MISC]
N33 LEED 999 999 UK 534959N 0013459W

BBLINK (bblink=filename)

Description: Link File

#[LinkName] NodeA NodeZ Vendor # BwType [Misc]
N2 N6 ATT 3 T3
LINK1 N3 N4 DEF 1 OC3

DEMAND (demand=filename)

Description: Demand File

#DemandID NodeA NodeZ bw Type_field Pri,Pre [Path]
I000123A N01 N02 256000 R2 12,10 N01-N05-N02

To addmore demands without modifying the original demand file, use the

NEWDEMAND file (newdemand=filename)

NODEPARAM (nodeparam=filename)

Description: Node Hardware Type File

#nodeID/name hwtype [MISC]
Y36 MUX

SITE (site=filename)

Description: Site Definition File (useful for diversity design, simulation, path placement,

pricing)

Purpose: The site file is used to define sites as logical groupings of nodes. The site

definitions are used for the purpose of failure simulation, diversity design, and diverse

path placement. By default, if a node is not included in a user-defined site definition, it
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is treated as being in a site of its own for these purposes. Site information can also be

used to facilitate pricing specifications, as in the usercost file.Purpose: The site file is

used to define sites as logical groupings of nodes. The site definitions are used for the

purpose of failure simulation, diversity design, and diverse path placement. By default,

if a node is not included in a user-defined site definition, it is treated as being in a site of

its own for these purposes. Site information can also be used to facilitate pricing

specifications, as in the usercost file.

Usage: Each line entry in the site file uses the following syntax to indicate the nodes in a

site:

#sitename=node1=node2=...=nodeN
mysite01=N08
mysite02=N46=N86 = N71 = N72 \
= N73 = N74

A node can be indicated by ID or name. If you needmultiple lines to define a site, use a

back slash character (\) to continue the entry from one line to the next. Choose site

names that differ from node names to avoid potential confusion in the input data.

GROUP (group=filename)

Description: Topology Groups File (useful for visual grouping; unlike the site file, this file

does not influence diversity design, simulation, path placement, or pricing)

# Group_name Members
GROUPA N1, N2, N3

Grouping isa topology featureused togroupnodes together. If yousaveyour specification

file with groups, the next time you open it up, nodes in a group is grouped together under

one group symbol.

GRAPHCOORD (graphcoord=filename)

Description: TopologyWindow Definition and Node Coordinates (useful for display only;

to be distinguished from latitude & longitude coordinates and geographical V & H

coordinates)

window 1228 158 2114 1515
#first line defines the window size, Only locations and #line segments within
the window coordinates are displayed.
#node npa nxx graph_v graph_h
N001 212 406 4919 1447
N002 212 406 4933 1570
N003 212 406 5154 1394
END

Graphics coordinates for backbone nodes may be changed bymoving locations around

on the topologymap and using theMap Views feature. Note that changing the graphical

coordinates does not change geographical informationwhich is stored in themuxloc file.

DOMAIN (domain=filename)
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Description: Domain File

#domain_ID domain_name color
1 REDNET MAGENTA
V2 BLUENET BLUE
TRANSIT=V2

This file is needed only for large networks that are to be partitioned into different areas

(domains). In it you can specify the ID, name, and color of domain regions. Nodes in

different domains may only communicate with each other through gateway nodes. The

domain file allows for node/link coloring by domain and for the specification of a transit

domain.

For the Domain_ID, the format Dd, where d is a number, is reserved to signify a domain

with domain number of d. For domains using this format, leading zeros are ignored, so

D5, D05, and D005 are all treated as the same domain identifier.

NOTE: This file can also be used for OSPF areas instead of domains.
Depending on the hardware vendor specified in the dparam file
(hwvendor=hardware_vendor), the domain file is interpreted to contain
domains or OSPF areas.

OWNER (ownerfile=filename)

Description:Owner File

#OwnerID Name Color
G1 wandl blue
G5 wandl2 red

The purpose of this file is to facilitate the identification of node and demand ownership.

By defining anowner andassociating certain demandswith that owner, service providers

that carry traffic of several companies can use the owner feature to quickly determine

the distribution of traffic in the network.

Toassociateademandwithanowner, the type fieldof thedemand'sentry in thedemand

file should include ownerID where ownerID is substituted by the corresponding ownerID

in the owner file. To associate a node with an owner, specify OWNER=ownerID in the

miscellaneous fieldof themuxloc file.Ownernamesdefined in themuxlocand/ordemand

files are automatically added to the owner list if they are not defined in the owner file.

Valid Color Values: Red, Green, Cyan, Blue, White, Magenta, Yellow.

FACILITY (facility=filename)

Description: Facility Definition File (useful for diversity design, simulation)

#Facility_name net_element1 [net_element2 ]*
FAC1 L2N2N3 L3N2N3
FAC2 L2N4N5 L3N4N5 L4N4N5 \
L5N4N5
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The facility file is used to define facilities as logical groupings of nodes and links. The

facility definitions are used for the purpose of failure simulation and diversity design.

Each entry of the facility file should be a separate line containing a facility name followed

by the associated node ID (or node name) or link name.

The network elements should be delimited by tabs, spaces, or commas. If you need

multiple lines to define a facility, use a back slash character (\) to continue the entry

from one line to the next.

The facility feature does not check the validity of the nodes and/or links listed in the

facility file. Duplicate links and/or nodes will also be duplicated in the facility. If both are

used in the same facility, then that node is duplicated. Nodes that are not in the muxloc

file and links not in the bblink file are ignored.

TRAFFIC LOAD (trafficload=filename)

Description: Peak Load by Period

#Facility_name net_element1
The format for the traffic load file is shown below:
# --Peak load in bits--
#DmdID Dir AvgFrameSize Period1 Period2 etc…
V0001 - 20 12800 12800 12800 12800
F0001 A2Z 87 6852 2083 1372 2749
F0001 Z2A 456 18795 11703 4578 5065

For each demand, peak load information can be recorded in this file for various time

periods. Data collected from the network or user-defined data can be stored in this file.

Upon reading this data, the program can then calculate link bandwidth utilization at

different times based on this information. This feature is applicable to ATM, FrameRelay,

or Router networks.

• DmdIDmust correspond to a demand ID defined in the demand file. The direction of

the demandmay be specified using one of the following three identifiers: "-" for

Two-way, "A2Z" for One-way fromOrigination switch to Destination switch, or "Z2A"

for One-way from Destination switch to Origination switch.

• Alternatively, The FromNodeCardPort or ToNodeCardPort can be specified instead of

the DemandID. See The Demand/Traffic Files chapter in the File Format Reference for

IP/MPLSView for more details.

• AvgFrameSize indicates the average frame size of the demand. It may be specified

using anumber or a dash. It is assumed that overhead is already included in the interval

definition.

• "#_bytes_in_frame": Traffic load specified is adjusted based on whether it is being

routed over a frame or cell trunk.
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• The remainingcolumns (Period 1, Period2, etc.) indicate the traffic load (bits)measured

during the corresponding interval. A maximum of 24 intervals may be specified per

PVC.

• The field "unit = number" may be placed before the actual traffic data for demands

or tunnels. The default unit value is 1 bit. All the traffic data in the traffic load file is

interpretedas kilobits if the valueof unit is specifiedas 1000.Thedataunit is interpreted

as byte if unit = 8 is specified.

TRAFFICPATTERN (TRAFFICPATTERN=filename)

NOTE: This file is for discrete event simulation only.

#traname #msg Duration Msg size framsize
# second bits bytes
PATTERN1 1.0 2.0 160000 1500
PATTERN2 3.0 1.0 2000000 256
PATTERN3 4.0 3.0 500000 1000
PATTERN4 1.0 1.0 1000000 1000

The traffic pattern file allows you to define several class types based on traffic

characteristics. Each traffic typemay be specified in terms of four parameters: number

of messages, duration (seconds), message size (bits), and frame size (bytes).

In the example above, PATTERN1 is defined as 1 message lasting 2.0 seconds, with a

message size of 160,000 bits and a frame size of 1,500 bytes. PATTERN2 is defined as

3messages lasting 1 second, with a message size of 2,000,000 bits and a frame size of

256 bytes. PATTERN3 is defined as 4messages with a duration of 3 seconds, amessage

size of 500,000 bits and a frame size of 1,000 bytes. PATTERN4 is defined as 1message

lasting 1 second, with a message size of 1,000,000 bits and a frame size of 1,000 bytes.

TRAFFICDATA (TRAFFICDATA=filename)

NOTE: This file is for discrete event simulation only.

#format = unit unit_size
#interval = x (number of seconds)
#pvcname direction #unit unit_size #unit2 unit_size2
# format line may be one of the following:
# packet size
# byte size
# bit size
# size packet
# size byte
# size bit
format = packet size
interval = 300
PVC1 A2Z 16,48,30,512,35,256,20,512
PVC1 Z2A 10,48,20,512,30,256
PVC2 A2Z 20,48,50,512
PVC2 Z2A 20,48,50,512
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The traffic data file allows you to define each demand by specifying multiple packets

andpacket sizes. Although this requires you tohavea reasonable knowledgeof the traffic,

more accurate simulation results can be obtained in this manner. For each PVC, up to 10

pairs (#unitx and unit_size)may be specified in defining the demand. Note that although

the PVC definition entries in the example above are delimited by commas, youmay also

use spaces and tabs to separate entries.

This file specifies an interval of 300seconds (5minutes), anddefinesa traffic distribution

for two PVCs. In this example, the PVCs are full duplex (both A2Z and Z2A directions are

defined). To define a simplex PVC, specify either A2Z or Z2A for the direction field. The

direction field assumes that a demand from the first node to the second node is marked

as A2Z, and the reverse direction as Z2A. During the 5minute interval, 16 packets of 48

bytes, 30packets of 512 bytes, 35 packets of 256bytes, and 20packets of 512 byteswere

sent in the A2Z direction of PVC1. Similarly, 10 packets of 48 bytes, 20 packets of 512

bytes, and 30 packets of 256 bytes were sent in the Z2A direction of PVC1. In PVC2 from

the A2Z direction, 20 packets of 48 bytes, and 50 packets of 512 bytes were sent. The

identical distribution is present for PVC2 in the Z2A direction because they have identical

traffic entries.

Control Files

FIXLINK (fixlink=filename)

The format of the fixlink file is exactly the same as that of the bblink file. This file is used

to tell IP/MPLSView that the links specified in this file should not be deleted during

backbone link design.

LINKDIST (linkdist=filename)

#from to dist
N01 N02 5
N01 N03 1

This file contains default distances (admin weights) that can be assigned between

backbone nodes. If the hopdist design parameter (in the dparam file) is set to

Adm_Weight, then the distances in the linkdist file may be used to calculate the lengths

of the demand paths during path placement. The only way to override this adminweight

is to use the admin weight specified in the miscellaneous field of the bblink file for a

particular link between two nodes. In the bblink file, use "DIST=x" (symmetric),

"DISTA2Z=x", or "DISTZ2A=x" (asymmetric), where x is substituted by a number.

For a link between a node pair not listed in the linkdist file, the admin weight defaults to

the linkdistunit parameter in the dparam file. This parameter can be specified in the

"User-Defined Link Distance" function of the "Read Files" menu in the text version of

BBDsgn. If linkdistunit is positive, that value is the default admin weight for all links. If

linkdistunit is negative, the default admin weight for all links is calculated as the airline

distance between each pair of nodes divided by the absolute value of linkdistunit and

rounded up to the nearest integer. For example, if linkdistunit=-50, the user-defined

distance for links from 1 to 50miles is 1. Similarly, for links from 51 to 100miles, the

user-defined distance is set to 2.

375Copyright © 2018, Juniper Networks, Inc.

Appendix A: Input Files Format



NODEWEIGHT (nodeweight=filename)

#nodeID/name nodeweight trunk-bandwidth-limit transit-bandwidth-limit
N0007 100 500M 1000M
N0011 -1 10808000
N0010 BLOCK

• Node weight, or Link Penalty for Design: A penalty at a node for purchasing links at it

during a design. Use a number less than 100000. If 100000 or higher, this value has

another meaning: no pass-through demands are allowed in design mode.

• Trunk-bandwidth-limit: amaximumtrunkbandwidthcapacityatanode thatgetsused

during design, and For example, if the trunk-bandwidth-limit is set to 5M (5Mbps) and

the link type being designed for is a T1, then only 3 T1s (each ~1.5 Mbps) can be added

since 4 T1s would exceed this limit.

• Transit-bandwidth-limit: a maximum transit demand bandwidth capacity for a node

that gets used for path placement. For example, specifying a limit of 0 will prevent

pass-through demands at a node.

NOTE: A node weight is required if maximum link bandwidth capacity is to
be specified. The default NodeWeight is 0 and the Default Maximum Link
Bandwidth Capacity is infinity.

RSVBWFILE (rsvbwfile=filename)

#node1 node2 fixfat fatpct
N01 N02 128000 0.1
N05 N10 256000 0

The fixfat and fatpct parameters in the dparam file are used to globally define reserved

bandwidth for all links in the network. To define reserved bandwidth for specific node

pairs, the rsvbwfile should be used. Reserved bandwidth is calculated based on values

in the rsvbwfile. For node pairs not defined in this file, reserved bandwidth is calculated

based on the fixfat and fatpct global parameters. To follow the reservation constraints,

BBDsgn will avoid using reserved bandwidth during path assignment and backbone

design. In failure analysis/failure simulation routines, however, these reservation

constraints are ignored.

Cost Files

CUSTRATE (custrate=filename)

Description: Customized Tariff File

DIST= MILE #DIST= Unit of measure; KM or mile
COUNTRY= IT #Specifies the Country Rate
INCR_DIST=0.1 MILE #Incremental unit:0.1 MILE (default=1 M)
#service class1 class2 NRC [tomile fix rate_per_incdist]*
OC3 ALL ALL 1000 9999 270000 600
T3 CA CB 1000 100 300 30 9999 1000 20
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The custrate file is used to define tariff rates for links that cannot be priced out using the

tariff database.

For any link, the rate depends on the service used and the class of the nodes of the link's

endpoints. The service field denotes a trunk type like OC3 or T3. The fields class1 and

class2 are logical groupings of nodes. These classes are defined by adding a

CLASS=classname in the miscellaneous field of the muxloc file.

The pricing method used is the bandmethod. For a given link, the non-recurring charge

is NRC and the recurring charge depends on themileage band it falls under.

Following the first four fields are a set of three numbers representing the first mileage

band.Subsequent triplets represent subsequentmileagebands.The field tomile indicates

the end of the mileage band.

The recurring charge is determinedusing a fixed rate plus a rate per incremental distance.

That is:

Recurring charge = fixed_rate+(rate_per_inc_dist/inc_dist)*link_airline_distance

Example: Suppose we have a 200mile T3 link between a node in class CA and a node

in class CB. Using the custrate file specified above, the link would fall within the second

mileage band. The non-recurring charge would be 1000. The recurring charge would be

1000+(20/0.1)*200=41000.

USERCOST (usercost=filename)

The usercost file is used to define the cost for links according to the end nodes, vendor,

and trunk type. The format of the usercost file is as following:

#from to vendor type [cost/mo.]
N01 N02 ATT T1 1000.00
N01 N02 ATT FT56K 300.00
N01 N02 WTG FT56K 250.00
N03 N04 USS T1
site2 site3 USS T1 2000.00
N05 site3 USS T1 2000.00
N05 site3 ATT T1 2200.00

The from and to fields should specify a node ID, node name, or site name. If a site name

is entered, the assignment applies to all locations in that site. You should ensure that

site names are different from node names in order to prevent pricing inconsistencies.

If more than one vendor is assigned to the same type for the same node pair, then the

least cost vendor is treated as the default vendor. In the example above, the default

vendor for a FT56K link between N01 and N02 is WTG. If ATT is selected as the vendor

for a FT56K between N01 and N02, the cost of that link is calculated as $300.

If site names are specified in the from/to fields, then the price and default vendor

assignments apply to all the locations in the site specified. The default intra-site cost is

0.
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USERCOUNTRYCOST (usercountrycost=filename)

#CountryCodeA CountryCodeZ vendor type [cost/mo.]
FR GE DEF FT64K 1000.00

Theonly difference is that the fromand to fields are replacedby two-letter country codes

rather than node Ids.
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APPENDIX B

Search Preferences

This appendix describes the search preferences available in IP/MPLSView and examples

of how strings arematched. This applies to the Find and Advanced Filter windows of the

IP/MPLSView client (for example, FindNode, Find Link) and to theAutoGroup byRegular

Expression (Regexp) option in the topology map.

• Exact Match Strings on page 379

Exact Match Strings

Does Not MatchMatchesString

food,Foofoofoo

fox, Foofoo, food, afootfoo

food, Foofoofoo

afootfoo, foodfoo*

foo, food, afoot*foo*

foo, foodsfoodfoo?

fox, Foofoo, food, afootfoo

fofoo, foxfo

paapt, pat, paaatpa*t

ppa, paa, paaapa+

paatpt, patpa?t

Jpat, npatNpat, Ipat[NI]pat

ipatpat, patty^pat

pattypat, ipatpat$
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Does Not MatchMatchesString

paipaatpa{2}

papaa, paaapa{2,}

pat, paaaatpaat, paaatpa{2,3}t

any digit\d

any non-digit\D

any white space character\s

any non-white space character\S

any alphanumeric character\w

any non-alphanumeric character\W

pa, papa, papapa(pa)+

banana([bn]a)*
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