Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

 

The Report Manager Window

 

The Report Manager window is split into two panes, where the left pane displays the available reports in a tree view, and the right pane, or Results Pane, displays the contents of the selected report. The reports are categorized into the following categories:

  • Network Reports: These are the main network reports, including path, utilization, and cost reports. These reports are dynamically generated, meaning the report is always up to date, reflecting the current state of your network model. Each time that the Report Manager is opened, upon the first click of a report, the report is generated and saved to the Report folder of the network model. For all other subsequent clicks on that report, the report is read from the cache unless you close and reopen the Report Manager, or chooses to regenerate the report, an option described in the next page.

  • Tunnel Layer Network Reports: These are the tunnel layer related network reports, including tunnel path and diversity, tunnel traffic, FRR, and tunnel RSVP BW reports.

  • Simulation Reports: These reports provide information on the performance of the network after running failure simulation. Certain reports are only available after running specific failure simulations.

  • Tunnel Layer Simulation Reports: These reports provide information on the performance of the network relating to the tunnel layer after running failure simulation.

  • Configuration Reports (Router only): These reports are generated when you import network configuration files into your network model (via File > Import Data).

  • Customized Reports: The customized reports are user-customized reports, where you select columns of interest from an existing Node, Link, Interface, Demand, and Tunnel report.

Figure 161: Report Manager Window - Report View
Report Manager Window - Report View

Some report windows contain a filter mechanism which allows you to search for any expression.

Field

Description

Explanation

Provides an explanation of the currently selected report.

Multiple Sort

Allows two consecutive sorting methods to be applied to the current report.

Restore

Displays the report in its original form prior to any sorting or searching.

Select Columns

Opens a Column Selection window, allowing you to select which columns to display in the report.

Re-Generate

Refreshes the currently selected report.

Script

This creates a file for filtering the report in text mode. The filter is based on the query specified in the Advance Filter window.

Actions drop down

The actions available include setting columns to display, saving the report, and printing.

LoadBw drop down

When there are multiple periods in the report, this allows you to select a specific time period.

Filter

Performs the search as specified in the Filter field.

Advance Filter

Opens an Advanced Filter window, allowing you to search by exact match, substring match, wildcards, and regular expressions.

Go to page

Displays the page entered here. Enter the page number and click “Go” or click <Enter>.

Lines Per Page

Sets the number of lines that are shown on each page or the viewer. Enter the number of lines to show per page and click “Set” or click <Enter>.

Some report are displayed simply as a text output without tables.

Figure 162: Report Manager Window - Text View
Report Manager Window - Text View


Additional Report Manager Actions



The following actions can be performed on the column headers in report view in the right pane. Some actions are available by right-clicking on the column header.

  • Sort: The information displayed in the right pane of the Report Manager can be sorted. Click on the column header to sort in an alphabetical order. To reverse sort, click the header again.

  • Select Columns: This function will open up a Columns Selection window allowing you to select the columns to display in the report if applicable. The ordering of the column headers can be set in this window or by dragging the column header in the report view.

  • Show All Columns: Selecting this option displays all available columns for this report in the right-pane.

  • Reset the column order: If the column order has been changed, selecting this option will reset it to its default order.

  • Auto Fit This Column: Only the selected column is resized to fit the longest text entry.

  • Auto Fit All Columns: All columns are resized to fit the longest text entry.

  • Freeze Column: The column(s) are frozen for horizontal scrolling.

The following actions can be performed bt right-clicking on the report entry in the left pane.

  • Re-generate Report: When this option is selected, the program will regenerate the report and update any fields that might need updating.

  • Save Whole Report to Client: Any available reports in the Report Manager can be exported to a Comma-Separated Values (CSV) file. Selecting this option will open up a directory chooser window and allow you to save the report to the desired location. This will save the entire report ignoring any filters applied.

  • Save Filtered Report to Client: If you have used any of the filter functions on the report, then only the filtered results are saved.

  • Convert Report: Saves the report into the desired format. Choose from XML, Comma-Separated Values (CSV), or Hyper-Text Markup Language (HTML). Indicate an Output File name on the server in which to save the report. The report is saved into the Output Path as indicated in the File Manager window. To change the path, press the “Browse” button and navigate to the desired directory. You can also save a copy of the report to your local client, by marking the “Copy to client” checkbox. Press the “Browse” button to navigate to the desired location on your local machine.

  • Generate Filter Script: This allows you to generate an advanced filtering shell script in your UNIX server environment. Once created, this script enables you to create customized reports from existing network project reports at a later time, without having to launch the IP/MPLSView client. This is useful for the advanced user who may wish to run batch processes for efficiency purposes, especially if he or she always needs to customize the generated reports using specific filters. Filter Scripts are described in detail in Advanced Filter Script Utility.



Report Options



Options that influence the output of these reports can be set in the Report Options window of the Tools > Options > Report menu. These settings include node and link references, bandwidth and distance units, and currency.

Figure 163: Report Options Window
Report Options Window

See Report Options for an explanation of additional items.



Advanced Filter Script Utility



The Advanced Filter Script utility allows you to create and then to apply a filtering shell script in the Unix environment on reports that have been generated by the tool. This is a convenient way to produce filtered reports without the need to launch the client. The shell script can also be called by other scripts that are used for automated daily batch report generation, for instance. The following figure, showing the Report Manager’s Path & Diversity Report, is used to illustrate how to use the Advanced Filter Script in the following steps.

Note

In the Report Manager, the Script utility is only available for reports that are in Comma Separated Values (CSV) format, a format that is viewable in many programs such as Microsoft Excel. If you do not see the Script button, select Tools > Options > Report and make sure that the Report Style is set to CSV. Once that is done, go back to the Report Manager, right-click on the report file name you are trying to view and select Re-Generate Report from the popup menu. If CSV format is supported for the report, it will then be re-displayed in a table format.

Figure 164: Demand Path and Diversity Report
Demand Path and Diversity Report
  1. First click on the Advanced Filter button to bring up the Advanced Filter window. Suppose we want to only look at certain demands, such as demands starting from ATL. One way to do this is to use the query, “From_Node# = ATL”.

  2. Click OK to apply the filter.

    Figure 165: Define a Query in the Advanced Filter Window
    Define a Query in the Advanced Filter Window
  3. Next, click on the Script button in the Report Manager to bring up the Advanced Filtering Script window, as shown in the following figure. You may change the script file name or the filtered report output file name by editing the Script File Name and Output File Name text boxes, respectively. You can also choose to regenerate the original report in full (in this case, the Path and Diversity Report) before the filter is performed on it. To do so, mark the Generate New Report checkbox. Once you have finished with any changes, click on the Generate button and a shell script is created in the output path. In this example, PATHRPT.mpls-fish.sh is generated.

    Note

    The Generate New Report option works for most reports. However, it will not regenerate certain reports, such as Simulation and Configuration (Router-only) reports, which are only created once during the corresponding failure simulation, or configuration import operation, respectively.

    Figure 166: Advanced Filtering Script window
    Advanced Filtering Script window
  4. Next, log onto your server and navigate to the output directory. (You can do this via Tools > Connect to Server.) Then, to execute the Advanced Filter shell script, simply type the name of the script file at the command prompt, as shown in the following figure.

    Figure 167: Run the Advanced Filter shell script
    Run the Advanced Filter shell script
  5. Once the shell script has been run, the filtered report is generated, as indicated by the “Output Result” line as shown in the figure above. The following figure shows the filtered report displayed in the Report Viewer (in the File Manager, right click on the file name and select Open With > Report Viewer.

    Figure 168: Filtered Path and Diversity Report
    Filtered Path and Diversity Report