Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Bandwidth

    1. Click on the next tab, Bandwidth. The interface bandwidth of the network model will be derived from any files specified here, and different options can be selected for data conversion.
    2. Under Select Bandwidth Sources, there is a list of six sources from which the program can derive interface bandwidth. As there are multiple sources that can be supplied, the first source in the list from which the bandwidth value can be retrieved for a particular interface will be used. These sources are described in detail in the table below.
    3. Click on “Browse” to select the appropriate file or directory for each source. Then, if you want to deselect a file or directory as a source, use the drop-down selection box and choose <none selected>.

      Figure 1: Bandwidth Tab

      Bandwidth Tab
    4. In the Select Bandwidth Options section, click in the checkboxes to select any of the desired options. A description of these options is listed in the table below.

      Option

      Description

      Corresponding Text Interface Option

      MPLS Topology File

      This is the file that contains the topology information of the network obtained from the following commands:

      show mpls traf topology (Cisco)
      show ted database extensive (Juniper)

      -t topfile

      Interface Directory

      This directory contains interface bandwidth data retrieved using CLI commands. Read the CLI results of “show interface” on the router to get the bandwidth of the interfaces and save it to a file. The CLI commands are: Cisco:

      # show running | include hostname
      # show interfaces

      Juniper:

      # show configuration | match “host-name”
      # show interfaces | no-more

      -i interfaceDir

      SNMP Directory

      This directory contains interface bandwidth data retrieved from SNMP data. SNMP data is collected by the IP/MPLSView Traffic Data Collector. The file names should be hostname.suffix or ipaddress.suffix.

      -snmp snmpDir

      Config Directory

      This directory contains your router configuration files (obtained using commands like “show configuration | display inheritance” (Juniper) and “show running-config” (Cisco).

       

      Use the first word of the interface description for trunk type

      This option is for certain users who indicate the trunk type in the description line for an interface. If checked, the first word of the interface description will be used to set the trunk type of that interface, if it is a valid trunk type. If it is not a valid trunk type, then the Trunk Type File, $WANDL_HOME/db/misc/bwconv, will be used to set the trunk type.

      For example, suppose you have the following statement in the interface section for a Serial link:
      description T3 to N2 (Cisco)
      description “T3 to N2”; (Juniper)

      If you select this option, that link will be assigned the trunktype T3.

      -commentBW

      Trunk Type File

      This file is used primarily to define a mapping from interface types not recognized by IP/MPLSView into trunk types that are recognized. The default bwconvfile is located in $WANDL_HOME/db/misc/bwconv and is editable.

      -b bwconvfile

      Use STM instead of OC for trunk type

      Trunk types in the generated IP/MPLSView bblink file will be given “STM” prefixes rather than “OC” prefixes.

      -STM

      Use average ATM bandwidth

      (Retired option) In a router, if there are ATM interfaces, e.g. ATM1/0, ATM1/0.1, ATM1/0.2 and ATM1/0.3, their bandwidth will be derived using the following simple formula(if this option is selected):

      Maximum BW of these interfaces / # of interfaces and subinterfaces

      If ATM1/0 is 20M, ATM1/0.1 is 0, ATM1/0.2 is 2M, and ATM1/0.3 is 10M, then each bandwidth will be calculated as 20M/4 = 5M.

      -atmbw

      TSolve Bandwidth

      If the interface utilization at the time of collecting “show interface” exceeds this bandwidth, a link will be created for this interface to a dummy node (e.g., AS1000xxx).

      -TSolveBW bw

      Figure 2: Network Tab

      Network Tab
    5. Next, click on the Network tab. During configuration import, if you supplied a runcode that already exists in the specified output directory (i.e. you are importing over an existing network model), some IP/MPLSView network files may be overwritten. To preserve or append to the original files, specify them in the Reconcile Network Files section.

      For example, you may have previously painstakingly arranged your network nodes on the topology map. This information is saved into the Graph Coordinates (graphcoord) file. To ensure that you do not lose all your hard work from overwriting the file, specify the desired graph coordinates file in the Reconcile Network Files section.

      Note: At this time, incremental configuration import is not supported. If you import over an existing network model (i.e. you use the same runcode), you must specify the location where the entire set of configuration files are located, not just a subset. Alternatively, you can perform the new import into a new IP/MPLSView network project (corresponding to a different specification file and runcode), and then use File > Load Network Files to read in IP/MPLSView files (such as the graphcoord file) from a previous import or network project. After doing so, be sure to save your new network project (File > Save Network...).

    6. There are additional options the user can select that are related to VPNs and BGPs. The description of these options are explained in the table below.

      Option

      Description

      Corresponding Text Interface Option

      Spec

      This is the file that lists, or specifies, all files related to a particular network project. If specified, the following files from specFile will be preserved: ratedir, datadir, site, graphcoord, graphcoordaux, usercost, linkdist, fixlink, domain, and group.

      -spec specFile

      Muxloc

      This is the file that contains additional location information of the nodes such as NPA, NXX, latitude and longitude. If specified, the existing muxloc file will be preserved or appended to.

      -n muxloc

      Node Parameter

      This is the file that specifies the parameters — node ID, hardware, IP address — of each node. If specified, the existing “nodeparam” file will be preserved or appended to.

      -p nodeparam

      Graph Coordinates

      This is the file that contains any existing graph coordinates information. If specified, the existing “graphcoord” file will be preserved or appended to. This file will overwrite the graphcoord file in the Spec option, if a specification file is also specified in the “Reconcile Network Files” section.

      -coord coordFile

      Group

      This is the file that contains any existing grouping information. If specified, the existing “group” file will be preserved or appended to. This file will overwrite the group file in the Spec option.

      -group groupFile

      CoS Alias

      A router network may have more than eight CoS names defined, but only eight or fewer real CoS classes, as each router is at liberty to assign its own CoS name. The CoS Alias file matches CoS names that are used for the same CoS class.

      -cosalias
      CoSAliasFile

      Ignore VPN

      When selected, VPN statements will be ignored and will not be imported.

      -noVPN

      ID VPN elements by VRF

      When selected, this option will match Virtual Private Networks (VPNs) by looking up the VPN Routing and Forwarding Instance (VRF) names instead of matching import/export route targets.

      -vpnName

      Omit PE-CE links

      When selected, the program will omit links between Provider Edge (PE) routers and Customer Edge (CE) routers.

      -noCE

      PE-CE Connection File

      This file can be used to specify PE and CE connectivity, and is only necessary for networks that re-use private ip addresses for their VRF interfaces. For such networks, this file is needed in order to stitch up the PE-CE links correctly. See PE-CE Connection File for file format information.

      -PECE

      Ignore AS Node and Links

      Selecting this option will ignore AS nodes and AS links during the data extraction. This option can improve performance by reducing the number of pseudo-links on the map and reducing the policymap file when there are policies on the AS links.

      -noASNodeLink

      AS Name File

      The user can specify a different Autonomous System (AS) name file, ASNameFile, mapping an AS name (rather than just a number) to the name of the AS nodes for display on the topology map. If left unspecified, a default file located at /u/wandl/db/misc/ASNames is used. Note however that this file may not be entirely up to date.

      -as ASNameFile

      BGP Table Obj File*

      The BGP routing table object file is used by the routing engine to perform BGP table lookup. To create the BGP Table Obj File from the live network, BGP routing tables are needed, with the hostname prepended in the first line of each file preceded by the word ‘hostname’. Run the following commands (for Juniper BGP routing table output ) to create the object file output_object_file for this option.

      /u/wandl/bin/prefixGroup -firstAS routingtablefiles
      /u/wandl/bin/routeGroup -o output_object_file -g group.firstAS routingtablefiles

      -bgpGroupTable

    7. Click on the next tab, Misc. Here, you may set other desired options during the conversion of the router configuration files to the IP/MPLSView network model.

      Figure 3: Misc Tab

      Misc Tab

      Option

      Description

      Corresponding Text Interface Option

      Allow duplicate address links

      This option will print those links that have duplicated IP addresses in other links. By default, these links are commented out.

      -printDup

      Stitch by secondary subnet

      For ethernets which have secondary addresses, if their primary addresses do not match any subnet, the program will try to match their secondary addresses.

      -secondary

      Only list policies on link

      Only the CoS policies on links in the network will be processed and saved to the policymap file. This option can be used to speed up performance by reducing the number of policies to only the ones that are relevant to routing/dimensioning.

      -policyOnLink

      Enable media type checking

      This option will match nodes that have different media types but are within the same subnet.

      -noMedia (to disable this option)

      Extract NetFlow sample rate

      This option will read in the user-specified NetFlow sample rate

      -iptraf

      Extended Integrity Check

      This option will cause the set of extended integrity checks to be performed

      -exIC

      Include management interfaces

      By default, management interfaces, e.g., fxp0 for Juniper, will not be stitched together to form links. If it is desired to stitch together management interfaces based on IP address subnets, check this icon.

      -mgnt

      Create dummy nodes for unrecognized files

      If you would like to include hosts other than routers and switches in your network model, check the option

      -dummyNode

      Allow logical nodes without interface

      If this option is selected, logical nodes without any interfaces configured will be parsed and displayed as an isolated node. By default, this option is not selected, and logical nodes lacking interfaces will not be displayed.

      -nodewoIntf

      Use IPv6 addresses to stitching links

      If this option is selected IPv6 addresses will be used to stich links.

      -IPv6

      Mark operational down links as deleted

      If this option is selected, links that are operationally down will be marked as deleted in the bblink file.

      -operStatus

      Delete existing data with duplicated hostname

      If this option is selected, and a config file is collected for the same hostname twice, one of the config files will be deleted.

       

      Ignore VRF when stitching links

      The data extraction program uses various rules to stitch links, some of which are intelligent guesses based on BGP/VPNv4 information. If this option is selected, those VRF-related rules will be ignored, and links will not be stitched based on VRF information.

      -ignoreVRFOnLink

      Remove JUNOS RE extension in hostname

      For JUNOS dual routing engine support, by default the RE extension in the router name is removed for the Node ID and Node Name, but not the hostname. To also remove it from the hostname, select this option.

       

      Use shutdown interfaces/tunnel for links

      If this option is selected, then shutdown links will be used for stitching up the backbone links. By default, these links are not used for link stitch-up.

       
    8. Click on the Files tab.

      Figure 4: Files Tab

      Files Tab

      Option

      Description

      Corresponding Text Interface Option

      IC message file

      The IC message file is the integrity check profile file that allows the user to define the severity of a check as well as whether or not to include a particular check in the generated report.

      -IC

      Delay measurement file

      A delay measurement file provides an easier method of inputting delay statistics into the network model. (Alternatively, delay information can be specified in the bblink link file.) Supplying the actual link delay measurements enables the program to accurately compute delays of end-to-end paths. See Delay Measurement File for file format information.

      -delay delayFile

      Routing instance file

      A file containing routing instance definitions. For more information about this feature including the file format, see IP/MPLSView Routing Instances Overview.

      -routeInstance
      routeinstanceFile

      Service Type File

      The service type file is used to match demands with services such as email, ftp, etc. For more information about the servicetype file format, see File Format Reference for IP/MPLSView

      -srvcType
      serviceTypeFile

      SRP Topology File

      Output of “show srp topology” used for RPR rings. For more information, see Resilient Packet Ring Overview.

      -srp srpTopoFile

      Node Alias File

      This file can be used when there are devices with dual routing engines to indicate that two routing engine hostnames belong to the same device. For Juniper, this is only needed if the names do not follow the standard naming convention of ending with re0 or re1.

      Each line of the node alias file should contain the mapping from the routing engine(s) to the corresponding AliasName that will represent the device on the topology.

      <AliasName> <RoutingEngine0’s Hostname> <RoutingEngine1’s Hostname>

      -nodealias
      nodealiasFile

      OSPF Neighbor

      Either a directory or file can be specified for this option. If a directory neighborDir is specified, the program will read all the files in that directory. The text files should contain the results of a Cisco IOS router’s “show ip ospf neighbor” statement or Juniper router’s “show ospf neighbor | no-more” statement. See /u/wandl/db/command for the statements for additional vendors like Cisco CRS and Tellabs. This additional information helps connect the devices on the topology view.

      Each file should be preceded by the hostname, e.g., “hostname <hostname>” for Cisco or “host-name <hostname>;” for Juniper. In some cases, it may be possible to extract the hostname from the prompt if the line "[hostname]>show ip ospf neighbor" is included before its results. Note that the prompt can be either “>” or “#” and that the short form, “sh ip ospf nei” is also recognized.

      -ospfnbr neighborDir or -ospfnbr neighborFile

      OAM directory

      OAM can be used for connectivity checking for Juniper and Zyxel at the MAC address layer. The OAM directory can be collected from the Scheduling Live Network Task (online users), or manually via the commands in /u/wandl/db/command/*.oam.

      -oam oamDir

      Multicast Path

      Output of “show ip mroute” (Cisco IOS) or “show multicast route” (JUNOS). Each file should be begin with the router hostname information.

       

      ISIS Neighbor

      If a directory is specified, containing the outputs of “show isis neighbors detail” (for Cisco IOS) or “show isis adjacency detail” (for JUNOS), the program will read these files to stitch together devices on the topology view.

      Each file’s command outputs should be preceded by the hostname, e.g., “hostname <hostname>” for Cisco or “host-name <hostname>;” for Juniper.

      -isisnbr neighborDir

      LDP Neighbor

      If a directory is specified, containing the outputs of “show ldp neighbor” (JUNOS) or “show mpls ldp neighbor” (Cisco IOS), the program will read these files to stitch together devices on the topology view.

      Each file’s command outputs should be preceded by the hostname, e.g., “hostname <hostname>” for Cisco or “host-name <hostname>;” for Juniper.

      -ldpnbr ldpDir

      Figure 5: Ignore Options Tab

      Ignore Options Tab
    9. Click on the final tab, the Ignore Options tab. Here, you specify the IP addresses and ERX interfaces you want to ignore. If you select the Ignore private IP addresses checkbox, then the following blocks of IP addresses will be ignored during the import:
      • 10.0.0.0 - 10.255.255.255
      • 172.16.0.0 - 172.31.255.255
      • 192.168.0.0 - 192.168.255.255
      • 169.254.0.0 - 169.254.255.255

      Option

      Description

      Corresponding Text Interface Option

      Ignore IP Addresses

      This is the option to instruct the program that the IP address ipaddr should be ignored. The user can specify more than one IP address. This option is useful when the user has private IP addresses for which it is not desirable to include in the analysis.

      -ignore ipaddr

      Ignore ERX Interfaces

      This is the option to instruct the program to ignore certain interfaces. The user can specify more than one interface. Interfaces are matched based on substring.

      -ignoreIntf interface

    10. When all the options are selected as desired, click Next > to begin importing the configuration files. The generated network model will be automatically loaded if there is not already a specification file open. Otherwise, the program will ask if you want to close the current network.
    11. When complete with the configuration import, click Finish to close the wizard.

    Modified: 2017-05-30