Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Topology Map Left Pane

    The IP/MPLSView topology map can display the topology in several ways. The left pane of the topology map window controls what is displayed in the topology map right pane.

    Figure 1 shows the topology map left pane menu.

    Figure 1: Topology Map Left Pane Menu

    Topology Map Left Pane Menu

    Topology Map Left Pane Network Summary

    Select Network Summary to display high-level information about the types of devices in your network by vendor or model.

    Figure 2 shows the Network Summary Pane.

    Figure 2: Network Summary Pane

    Network Summary Pane

    Mouse over a section of the pie chart to display the number of nodes for that vendor.

    Expand the Network Elements pane to display the total number of nodes, links, tunnels, and interfaces in your network.

    Options

    Use the Options menu to select which labels are displayed in the topology map, how links and paths are displayed, and whether to display utilization and a background map.

    Figure 3 shows the topology map left pane Options menu.

    Figure 3: Topology Map Left Pane Options Menu

    Topology
Map Left Pane Options Menu

    Table 1 describes each option.

    Table 1: Topology Map Left Pane Options

    Item

    Description

    Show Node Labels

    Displays or hides the node labels configured for each node.

    Show Link Labels

    Displays or hides the link labels.

    Draw Multi-links as Curve

    Toggles between displaying parallel links as a single line or as multiple lines.

    Draw Path as Curve

    Toggles between displaying multiple paths between a given node pair as a single line or as multiple lines.

    Link Utilization

    Displays the measured link utilization using the colors of the color bar.

    Country Map

    Displays or hides a background image. The default image is a world map.

    Topology Map Left Pane Menus

    Figure 4 shows the remaining topology map left pane menus.

    Figure 4: Topology Map Left Pane Menus

    Topology Map Left Pane Menus

    Table 2 descries each of the remaining topology map left pane menus.

    Table 2: Topology Map Left Pane Menus

    Menu Item

    Description

    Types

    A list of vendors. Select a vendor from the list to display that vendor’s nodes in the topology map.

    Groups

    An expandable list of nodes organized by groups. Select a node in the list to highlight it in the topology map.

    Sites

    An expandable list of sites. Select a site from the list to highlight it in the topology map.

    Protocols

    A list of protocols. Select a protocol from the list to display links in the topology map that transport that protocol.

    Events

    A list of event severities. Select the severity you want, and the nodes in the topology map with events of that severity display a count of events in the color of the severity.

    AS

    A list of BGP autonomous system numbers. Select an AS from the list to color nodes in the topology map that are members of that AS.

    ISIS Areas and OSPF Areas

    The IS-IS areas menu item displays a list of IS-IS area numbers. The OSPF Areas menu displays a list of OSPF area numbers. Select an area in from the list to color and display nodes and links in the topology map that are in that area.

    Link Status

    Displays or hides links that are in the Up state.

    Device/Network Performance

    Select CPU Usage, CPU Temperature, Memory Usage, or Link Latency to change how nodes and links are colored and displayed in the map.

    The colors indicate a range of values in percent or absolute values automatically calibrated based on the type of measurements. You can change the range by double-clicking the color legend in the topology pane.

    Double-click the highlighted element in the topology to display the measured value or chart the values over time.

    Topology Map Left Pane Layout Menu

    Use the topology map left pane Layout menu to change the way the map icons are arranged. The Layout menu is available when the left pane Options menus is selected.

    Figure 5 shows the topology map left pane Layout menu.

    Figure 5: Topology Map Left Pane Layout Menu

    Topology Map Left Pane Layout
Menu

    Table 3 descries the topology map Layout menu items.

    Table 3: Topology Map Left Pane Layout Menu

    Menu Item

    Description

    Group selected nodes

    Ungroup selected nodes

    To group nodes and links, Shift-click and drag a rectangle around the nodes and links you want. Select Layout > Group selected nodes. A Group Name dialog is displayed. Type the name of the group and click OK. The nodes icons are replaced with a group icon in the topology map. To expand the group, Select Layout > Ungroup selected nodes or use the topology map left pane Groups menu.

    Circle selected nodes

    To arrange selected nodes in a circle, Shift click and drag a rectangle around the nodes and links you want. Select Layout > Circle selected nodes.

    Distribute selected nodes

    To distribute nodes in a non-circular or non-straighten layout, Shift-click and drag a rectangle around the nodes and links you want. Select Layout > Distribute selected nodes.

    Straighten selected nodes

    To arrange selected nodes onto a equally-spaced horizontal line, select Layout > Straighten selected nodes.

    Reset by Lat and Lon

    To position selected nodes by latitude and longitude, select the nodes you want. Select Layout> Reset by Lat and Lon.

    This function is useful when you want to view the network in its geographical layout according to previously specified latitude and longitude values.

    Manage Layouts

    To save, edit, or load a topology map view, select Layout > Manage Layouts.

    When you select Layout > Manage Layouts, the Map View dialog box is displayed.

    Figure 6 shows the Map View dialog box and the Save Map dialog box.

    Figure 6: Map View and Save Map Dialog Boxes

    Map View and Save Map Dialog Boxes
    Map View and Save Map Dialog Boxes

    To save a map view, select Save. The Save Map dialog box is displayed. Select Private or Shared and type a name and description. Click OK. After you save a map view, it is listed in the Map View dialog box.

    To make a view the default view when IP/MPLSView is started, check Default.

    To change the view name or description, select Edit > Rename or Edit > Change Description.

    To load a previously saved map view, select the view in the Map View dialog box and click Load.

    To delete a previously saved map view, select the view in the Map View dialog box and click Delete.

    Topology Map Left Pane Settings Menu

    Use the topology map left pane Settings menu to set node labels, link labels, and adjust the utilization legend. The Settings menu is available when the left pane Options menus is selected.

    Figure 7 shows the topology map left pane Settings menu and the dialog boxes for node and link labels.

    Figure 7: Topology Map Left Pane Settings Menu and Dialog Boxes

    Topology Map Left Pane Settings
Menu and Dialog Boxes

    To set which type of label is used for nodes, select Settings Configure Node Label. A Settings Label By dialog box is displayed. Select Name, Hostname, IP Address, or ISIS System ID, and click OK. The labels are stored in the /u/wandl/data/.network/nodeparam.x file.

    To set which type of label is used for links, select Settings Configure Link Label. A Settings Label By dialog box is displayed. Select the label you want and click OK. The A-Z selection identifies the nodes at each end of the link.

    Table 4 describes the link label settings.

    Menu Item

    Description

    Name

    The link is labeled with the node A hostname and the physical and logical interface identifier.

    Node Name A-Z

    The link is labeled with the node A and node Z hostnames.

    IP A-Z

    The link is labeled with the node A and node Z IP addresses.

    Interface A-Z

    The link is labeled with the node A and node Z physical and logical interface identifiers.

    Bandwidth A-Z

    The link is labeled with the configured bandwidth.

    RSVP Util A-Z

    The link is labeled with the RSVP bandwidth.

    To change the percent utilization for each color, select Settings > Change Utilization Setting. The Utilization slider bar is displayed. Figure 8 shows the Utilization slider bar.

    Figure 8: Utilization Slider Bar

    Utilization Slider Bar

    Adjust the percentages for each color and close the slider bar. The legend in the topology map is updated.

    Modified: 2016-11-08