Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Input Seed Demands

    The seed demands are used to identify the possible source-destination pairs in the network and provide suggested bandwidth information. Given this information, the Traffic Matrix Solver will assign bandwidth values to the demands, such that, when routed over the network, these demands produce link utilizations that closely match a period of the user-specified measured interface traffic data.

    Some of the flows you may already have the information for, and these can be entered into the trafficload file discussed in the previous section. A corresponding demand entry with the same DemandID should be included in the demand file.

    For any other flows, for which you do not have bandwidth information for, you can also enter them into the same demand file. Alternatively, to keep things better organized, it is recommended to separate both sets of flows into two separate demand files, “demand” and “newdemand”, with one file for the flows with known bandwidth, and the other file with the flows whose bandwidth are to be derived.

    When defining the flows that need to be solved for, information or assumptions regarding the traffic patterns of these demands in the network can help to provide a more accurate traffic matrix. For example, if you have a good idea which nodes are the source and sink (origination and termination) nodes of the traffic, you can create a full mesh between only those source and sink nodes to create a more limited set of “test” demands. In this way, the traffic solver will avoid creating originating or destinating traffic at transit routers. For example, if the traffic sources and sinks are in the edge routers, but not in the core routers, you can create a full mesh of flows between those edge routers. For VPNs, you might want to use only the Provider Edge (PE) and Customer Edge (CE) routers as sources and sinks, assuming that the Provider (P) routers are transit routers where almost all the traffic is pass-through, with very little originating or terminating traffic. The instructions in the next section indicate how to create a full mesh of demands between a set of nodes, such as the PE’s.

    Additionally, if you have some idea of the relative bandwidth proportions for different demands, you can also enter in suggested bandwidths. This bandwidth information will be used to create a “shaping” matrix against which possible solutions will be compared. The shaping matrix (Src x Dest) will indicate the percentage of traffic to different destinations. If you have no assumptions to make here, you can set the bandwidths to be the same, e.g., 1k bandwidth.


    Creating a Full Mesh of Demands


    1. To create a full mesh of demands between traffic sources and sinks, switch to Modify mode and select Modify > Elements > Demands, Add > Multiple Demands.... Select the source and destination nodes from the Node A and Node Z boxes, respectively. You can filter on special criteria using the Adv Filter... button, e.g., using the criteria “isPE = true” to select the PE routers. Select “Populate Destination IP.” Then, enter in a bandwidth, such as 1k. Note that this will be overwritten after running the traffic solver.
    2. If you want to provide different bandwidths to different demands, you can select multiple demands from the Network window, Demands view pane, and select Modify > Selected... to modify their bandwidth.
    3. Note : If you have made any modifications to your currently loaded demand file during this network session, you may wish to save a copy of your demand file before using the Traffic Matrix tool. The Traffic Matrix tool will modify the bandwidth of demands in your network. To save your network environment, go to File>Save Network.... To save just the demand file, go to File>Save Network File>Demands....
    4. If you have an already created demand or newdemand file, you can also read it in from File > Load Network Files and save the network so that you do not have to read it in again each time you open up the network. Alternatively, you can edit the specification file to add the line “demand = <path>” substituting <path> with the location of the demand file, or “newdemand = <path>” substituting <path> with the location of the newdemand file.

    Unplaced Test Demands


    If there are a significant number of demands which are unplaced, it is an indication that there may be some routing issues that need to be resolved first before proceeding. Go to Network > Elements > Demands, press the Search (magnifying glass) icon and search for just Unplaced demands. Select one of the unplaced demands and press the Show Path button to highlight the route. Any bottleneck information or clues will be displayed in the Console.

    Modified: 2016-11-08