Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation  Back up to About Overview 
ContentIndex
  
[+] Expand All
[-] Collapse All

No index entries found.

Related Documentation

    Right Pane Toolbar

    Located on the right side of the topology window is the map toolbar. The toolbar provides quick access to some functions that are also available when right-clicking on the map.

    Figure 43: The Topology Toolbar

    The Topology Toolbar

    Item

    Description

    Selection Tool

    Toggles the selection tool to select multiple nodes and links. When ON, holding the left mouse draws a rectangular selection box. When OFF, holding the left mouse drags the map around.

    Show/Hide Left Control Pane

    Shows or hides the left pane of the map window.

    Show Node List

    Shows the nodes list in the left pane of the map window.

    Group Selected

    To create a group, select a set of nodes and/or other groups in the topology map. Then click this button in the toolbar and specify a name for the group. The selected nodes and groups are combined and displayed as a group icon. Multilevel group hierarchies can be created if several groups are organized together into a single higher-level group.

    Ungroup Selected

    This function will ungroup any group(s) chosen by you. Collapse a group, select it, and click on the Ungroup Selected Groups button. This permanently removes the group from the system.

    Undo Move Node(s)

    This function allows you to undo up to 10 node movements/re-layouts.

    Redo Move Node(s)

    This function allows you to redo up to 10 node movements/re-layouts.

    Reset to default

    Resets the nodes to their initial position on the map.

    Navigator

    The navigator map provides you with a scaled down version of the topology. After zooming in to the level you prefer, a box will appear in the navigator map that you can move to view other areas at the same zoom level. For further details, refer to Navigator.

    Zoom In

    This function allows you to zoom in on a particular area of the topology map by drawing a box around the target area.

    Zoom Out

    This function allows you to zoom out of the topology map.

    Zoom to Fit

    This function allows you to quickly fit the entire network topology into the topology window. The system only fits the network elements that are visible.

    Drag/ Rotate Tool

    • You can create a rectangular box on the map by holding down the left mouse button at a point and dragging the mouse to another point and then letting go of the mouse to create a box.
    • After creating that rectangle, you can stretch and rotate the nodes in that rectangle. For more details on the steps for using this tool, refer to Drag/Rotate Tool.

    Path

    • With the Paths button, you can perform path analysis in the topology window. This is the same Path function found in the Network Elements > Nodes list and in the pop-up menu in the topology map.
    • The path analysis function displays graphically the path between any two nodes found in the network based on factors such as routing method used, reserved and actual bandwidth allocation, link distance, oversubscription. Paths are displayed as a solid yellow line. Detailed information about the path is displayed in the console window.

    Map Preferences

    Opens the Tools > Options > Map Preferences window for you to customize the map display (for example, background color, font size, and display of parallel links as curves).

    Map Help

    Opens the online help.


    Navigator


    When the Navigator button is clicked, it displays the navigational map with an outlined box inside it showing which part of the map is in the current view. By clicking and dragging this box, you can pan across the topology map. This function is ideal for use when you have zoomed in to one section of the topology, and would like to easily move to other regions at the same zoom level.

    Figure 44: Navigator

    Navigator

    Drag/Rotate Tool


    The purpose of the tool is to choose some nodes or collapsed groups within a rectangular region, and then stretch or shrink the rectangle, move, or rotate it.

    To use the tool, press the Drag/Rotate button. Drag a rectangle on the map around nodes/groups that you wish to move. You may hold down the <Shift> key to constrain the rectangle to be a square. If no nodes/groups are selected (highlighted in yellow), the rectangle will remember all the nodes and collapsed groups inside it. Otherwise, if some of the nodes/groups in the rectangle are selected (highlighted in yellow), then the rectangle will remember only the selected nodes/groups in the rectangle. This is useful if you only want to move selected nodes in a rectangle.

    When you stop dragging, the rectangle turns green, meaning active. Then you can perform one of the following actions:

    • To stretch or shrink the region, drag one of the eight square handles.
    • To move the region, put the mouse inside the green rectangle and drag the rectangle to another location.
    • To rotate the points inside the green rectangle, rotate the mouse wheel. If you don't have a mouse wheel, hold down <Alt> and click the left mouse button to rotate in one direction. To rotate in the other direction, hold down the <Alt> and <Shift> buttons and left-click. If you have a middle mouse button, click the middle mouse button to rotate them one way, and <Ctrl> or <Shift>-click the middle button to rotate the other way. (The rotation is along ellipses inside the rectangle, so if you want true circular rotation, make sure the rectangle is a square by using shift-drag when you create it.)

    There are two ways to end the drag/rotate operation: click outside the green rectangle, or click on the Drag/Rotate button to turn it off.


    Paths


    This function allows you to view the path between any two nodes in the topology map. To view detailed path information, click the Paths button in the toolbar (or from the drop-down menu). A cross-hair will appear. Then select a starting node and drag the cross-hair to a destination node and click on it. The paths information will appear in the console window giving detailed information about the paths such the route of the path between these two nodes. The following is an example of the detailed path information between two nodes:

    Bandwidth initialized to 8000
    * * * N1(XN1) - N2(XN2): bw= 8.0K * * *
    new N1 N2 8.0K R,A2Z 02,02 N1--N2
    (Adm_Weight) Route-cost=100. Max_Path_Bw= 40.704M

    Node Popup Menus


    The following options are accessible when right-clicking a node or set of nodes.

    • View > Selected Nodes: Displays detailed information about the currently selected nodes.
    • View > Nodes under Pointer: Displays detailed information about the node(s)/switch(es) at the place where you clicked. If there are multiple nodes at the place where you clicked, then all are displayed.
    • View > Demands on/thru Node: Displays all demands that originate or pass through this node. In the resulting window.
    • View > Equipment View: Displays node, card, port information.
    • View > SRLGs on Node: Displays information about the SRLGs at a node.
    • View > Interfaces at Node: Displays information about the interfaces at a node, including but not limited to IP address, name, bandwidth, and status.
    • View > Links at Node: Displays detailed information about all links originating from this node.
    • View > Summary at Node: Displays a summary information window for this selected node. Information such as total number and bandwidth of originating, terminating, transit, and local demands are all displayed in this summary.
    • Modify > Selected Nodes: Allows modification of selected nodes.
    • Delete Selected Nodes: Deletes the selected nodes. Connecting links may also be deleted in this process.
    • Resize Demands > At Selected Nodes: Enter in a percentage by which to multiply the bandwidth of the demands that originate or terminate at the node(s) you right-clicked over. For example, enter in 200% to double the bandwidth of the demands at the nodes right-clicked over.
    • Fail Selected Nodes: Fails selected (highlighted) nodes. The failure simulation will take place when you click the Run button. This option is available only when the Interactive Simulation window is open.
    • Show Config File: This option will open the configuration file for the node if available.
    • Show Collected File: This will open the Run CLI Command windows which lists data collected by the Task Manager. The categories available are: ARP, Equipment CLI, Interface, MPLS Topology, Multicast Path, OAM, OSPF Neighbors, Switch CLI, Transit Tunnel, and Tunnel Path. This option is available only for Live networks.
    • Internet Map at Node: Brings up a third party map from the Internet using the specified node’s latitude and longitude coordinates.

    Link Popup Menus


    • View > Selected Links: Displays detailed information about the link(s) that were highlighted when you selected this option.
    • View > Links under Pointer: Displays detailed information about the link(s) at the place where you clicked.
    • View > Demands on/thru Link: Displays the demand that are going through the link. You can view all of them, all of them in one direction, all that start or end at an endpoint of the link, or all demands that pass through the link that do not start or end at an endpoint of the link.
    • View > SRLGs on Link: View the SRLGs that this link is part of.
    • View > Interfaces on Link: View the interfaces on this link.
    • View > Tunnels on/thru Link: Similar to Demands on/thru Link but for tunnels.
    • Delete Selected Links: Deletes selected links from the network
    • Fail Selected Links: Fails highlighted links. The simulation will take place when you click the Run button. This option is available only when the Interactive Simulation window is open.
    • Collapse/Expand Multiple Links: This will collapse or expand multiple curved links into one drawn between two nodes. When you mouse-over a collapsed multi-link, the bottom information bar displays **1 of x** where ‘x’ is the number of links collapsed

    Modified: 2016-11-08