Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation  Back up to About Overview 
ContentIndex
  
[+] Expand All
[-] Collapse All

No index entries found.

Related Documentation

    File Manager Spec File

    The Spec File submenu contains all functions related to the specification files. From this submenu, you can choose options to load, modify, or create new specification files. The following selections are available:

    Spec File > New Spec

    Allows you to create a new specification file. This basically means you are creating a new network from scratch. To use this option, first close any the currently open specification files.

    Spec File > Load Spec

    Loads the currently highlighted specification file into the system. Once a specification file is loaded, the network topology window also appears.

    Spec File > Modify Spec

    Allows you to change the runcode, data directory, rate directory, and network files of the specification file. After modifying the options and clicking Finish, you can load the network.

    Spec File Generation Window

    Once you select the New Spec or Modify Spec option, the specification file generation window appears. From this window you can specify properties for the specification file, dparam file, and various other specific input files necessary for a network to be properly loaded and displayed.

    Figure 10: Spec File Generation Window General Tab

    Spec File Generation Window General Tab

    The specification file is a text file that specifies all the network input files to be loaded for the active session as well as the runcode (extension), data directory datadir, and rate directory ratedir.

    Table 7: Spec File Generation Window General Tab Fields

    Fields

    Description

    Runcode

    This is the file extension used to distinguish different networks and different sessions. Output files and reports are appended with the specified runcode file extension. Runcodes may consist of any combination of alphanumeric characters. This field is saved with the keyword runcode in the specification file.

    Spec File

    Specifies the name of the specification file. By default this is spec.<runcode> where <runcode> is replaced by the network file extension.

    Data Directory

    The data directory datadir represents the path to the default directory in which your data files are searched for. If a particular file is located in the specified data directory, its absolute path need not be provided when defining that file. For example, if the data directory for a design run is specified as /user/test and the file muxloc.test is located in that directory, you can simply specify muxloc.test, rather than /user/test/muxloc.test, when prompted for the location of the muxloc file. To specify the specification file directory as the data directory, the character “.” (period) can be used as a shortcut. This field is saved with the keyword datadir in the specification file.

    Rate Directory

    The rate directory is used to specify the path of the directory where the tariff database files are read. In most cases, the default path /u/wandl/db/rates/default does not need to be changed. If you want to use you own tariffs, reference them from a directory other than /u/wandl/db/rates/default. This field is saved with the keyword ratedir in the specification file.

    The dparam file specifies design and simulation parameters, hardware vendor, link bandwidth/overhead, size and various other network parameters.

    Figure 11: Spec File Generation Window Design Parameters Tab

    Spec File Generation Window Design Parameters Tab

    Table 8: Spec File Generation Window Design Parameters Tab Fields

    Fields

    Description

    Design Parameters File

    Specifies the file name of the dparam file.

    Hardware Type

    Allows you to choose the hardware type of the network. The available hardware types displayed depend on the current license that have been licensed by the customer. * This field is saved with the keyword hwvendor in the dparam file.

    Maximum Number of Nodes

    The Maximum Number of Nodes helps the program decide how much memory to allocate and can only be modified when the network is closed:

    The Maximum Number of Nodes (saved as maxnodenumber in the dparam file) represents the maximum number of nodes that may be entered for a particular network. The number entered should be no smaller than the number of nodes planned and no larger than the node_limit in your license file. The default value is 100.

    Maximum Number of Links

    The Maximum Number of Links helps the program decide how much memory to allocate and can only be modified when the network is closed:

    The Maximum Number of Links (saved as maxlink in the dparam file) represents the maximum number of links for a particular network. Once the limit is reached during a design, the program does not continue to add links. The number entered should be no smaller than the number of links planned. The default value is 1500.

    The default link bandwidth, link overhead and per circuit bandwidth overhead calculations vary for different vendors. Because of device-specific characteristics (routing algorithm, rerouting, buffer size, queueing, etc.) the same network data may yield different results when comparing switch models.

    The Network Files tab contains references to data files that should be loaded in. Each reference are saved in the specification file with a separate entry.

    You can read in files from the Network Files tab. The files in this tab are categorized as described in Table 9.

    Table 9: Spec File Generation Window Network File Categories

    Type of File

    File Names

    Backbone Files

    bblink, demand, domainfile, facility, graphcoord, group, muxloc, newdemand, nodeparam, owner, site, srvcprofile, srvctype

    Cost Files

    custrate, usercost

    Control Files

    admincost, fixlink, linkdist, nodeweight, rsvbwfile

    Traffic Files*

    devicedir, egress, ingress, t_trafficload, trafdir, trafficload, tunneltrafdir

    Access Design Files*

    chanbank, offckt, offgraphcoord, offloc, offsitek

    Discrete Event simulation*

    tfxdata, tfxpattern

    Device-Specific Files

    aclist, bgplink, bgpnode, bgpobj, intfmap, junospolicy, policymap, route, tbit, tunnel, vpn

    Note: In Table 9, an asterisk (*) specifies files used for a feature that is license dependent.

    Figure 12: Spec File Generation Window Network Files Tab

    Spec File Generation Window Network Files Tab

    Network backbone files specify how the network is represented. Backbone files include the bblink, demand, domainfile, facilityfile, graphcoord, group, muxloc, newdemand, nodeparam, owner, site, srvcprofile, and srvctype files.

    Table 10: Spec File Generation Window Network Files List

    File

    Description

    bblink

    The bblink file contains backbone link information for the network. Each link entry is defined by a link name [optional], From_Location, To_Location, Vendor, number of trunks, and trunk type. The vendor may be specified as DEF (default) if it is not known. See BBLINK (bblink=filename) in Backbone Data.

    demand

    The demand file contains user traffic requirements. A demand is defined by an ID, From_Location, To_Location, Bandwidth, Type, Priority, and Preempt Priority. See DEMAND (demand=filename).

    domainfile*

    The domainfile contains the definitions for domain elements. Domain elements are defined by ID, name, and color to be used in the Map window. If OSPF is present in the network, this file is used to define OSPF areas. See DOMAIN (domain=filename).

    facility*

    A facility is a set of nodes and links likely to fail together. The facility file defines the links and/or nodes associated with a facility. In this file, the first field defines the facility name. The subsequent fields specify the node IDs or link names associated with that facility, delimited by tabs, spaces, or commas. All elements associated with a facility should be specified on the same line. Whenever more than one line is needed to specify the elements, a backslash, '\', must be used to indicate that the element list is continued on the next line.

    The facility feature does not check the validity of the nodes and/or links listed in the facility file. Duplicate links and/or nodes are also duplicated in the facility. Nodes may be specified either by their node ID or node name. If both are used in the same facility, then that node is duplicated. Nodes which are not in the mux file and links not in the bblink file are ignored. See FACILITY (facility=filename).

    graphcoord

    The graphcoord file is used to position nodes at coordinates different from their true geographic location. This is often times helpful when multiple nodes have the same NPANXX location or are located in close proximity to each other. Nodes may be moved by first selecting them and then dragging them to the new location. Note that pricing information is not changed since only the graphical representation has been modified rather than the geographical. See FACILITY (facility=filename) .

    group

    The group file defines the grouping of nodes in the network topology. Discs are painted on the Standard map around grouped nodes. See GROUP (group=filename).

    muxloc

    Muxloc specifies the file containing switch information such as name, ID, NPA, NXX, latitude, longitude, vertical, or horizontal. This information is used to determine location placement in the map window as well as for link pricing. See MUXLOC (muxloc=filename).

    newdemand

    The newdemand file allows you to specify an additional file containing user traffic requirements besides the demand file. The purpose is to reduce your effort in manually modifying the existing demand file, and/or having multiple versions. In addition, the newdemand file is often used in theoretical "What if..." situations in determining capacity planning for the current network state. See DEMAND (demand=filename).

    nodeparam

    The nodeparam file allows you to define specific information on a per-node basis such as the hardware type, vendor, or model. See NODEPARAM (nodeparam=filename).

    owner

    The owner file facilitates identifying the ownership of nodes and demands. Ownership should be specified in either the muxloc or demand files. See OWNER (ownerfile=filename).

    site

    The site file specifies site information. The site file is used to define nodes in the same physical location such as a building or campus.

    service profile

    The service profile file lists the service types and the percentage that are in each service profile..

    service type

    The service type file lists service types (for example, FTP, TELNET) and their descriptions (for example, owner, min. and max. bandwidth, type, pri, pre).

    Note: In Table 10 an asterisk (*) specifies files used for a feature that is license dependent.

    For more information regarding the files in Table 10, refer to the File Format Reference for IP/MPLSView

    Cost and control files are used to assign tariffs and implement link controls. Examples of cost and control files are: custrate, usercost, admincost, fixlink, linkdist, nodeweight, and rsvbwfile.

    Table 11: Cost and Control Files

    File

    Description

    custrate*

    The custrate file is used to assign tariffs for links used in the network to approximate the total cost of the network. You can specify the parameters from which these tariffs are calculated using the modify custom rate and custom rate class windows. See CUSTRATE (custrate=filename).

    usercost

    The usercost file is used to define the cost for links according to the end nodes, vendor, and trunk type. See USERCOST (usercost=filename).

    admincost

    The admincost file contains rules to set each link default admin weight/metric according to attributes such as trunk type, mileage, and the hardware type and sites of the endpoints.

    fixlink

    The fixlink file specifies information for links that cannot be removed from the backbone topology. For varying reasons, a customer might have a group of links in the backbone that cannot be removed (even if it is optimal to do so). In this case, during the optimization phase of the design, links from the fixlink file are not modified. Note that the bblink file might be used for the fixlink file if the current topology cannot be changed. See FIXLINK (fixlink=filename).

    linkdist

    The linkdist file is used to define link distance values on a node pair basis. Link distances can be used to bias path routing by assigning either a higher or lower weight to a node pair. If a linkdist file is not specified or a particular link’s metric is not defined, and the Admin Weight routing method is specified in the design options of the Path Placement tab, the default link distance value is assigned. See LINKDIST (linkdist=filename).

    nodeweight

    The nodeweight file is used to restrict the creation of links at particular nodes during design by assigning to the node a penalty for adding links or the maximum bandwidth capacity for links. This file can also be used to restrict the transit demand bandwidth at a node if the hardware model supports path configuration for demands.

    Every entry in the nodeweight file consists of four fields: node ID or name, node weight (link penalty for design), maximum bandwidth capacity (to carry links), and transit demand bandwidth limit. Fields are separated by spaces or tabs. A node weight is required if maximum link bandwidth capacity is to be specified. See NODEWEIGHT (nodeweight=filename).

    rsvbwfile

    The rsvbwfile is used to define reserved bandwidth for links between specific node pairs. Reserved bandwidth is specified as a fixed bandwidth (fixfat) plus a percentage of the link bandwidth (fatpct). See RSVBWFILE (rsvbwfile=filename) for the file format.

    • For node pairs not defined in this file, reserved bandwidth specification is derived from the fixfat and fatpct global parameters defined by selecting Tools > Options > Design in the Reserved Bandwidth options pane.
    • Reserved bandwidth is not used by during path assignment and backbone design if the hardware supports path configuration. The reservation constraints, however, are ignored by the simulation and failure analysis routines.

    Note: In Table 11, an asterisk (*) specifies files used for a feature that is license dependent.

    For more information regarding these files, refer to the Design Menu chapter and the File Format Reference for IP/MPLSView.


    Access Design Files


    This access design feature requires a license. For more information, contact your Juniper Networks representative. Examples of access design files include: chanbank, offckt, offgraphcoord, offloc, and offsite.

    Examples of traffic files include: devicedir, egress, ingress, t_trafficload, trafdir, trafficload, and tunneltrafdir.

    Table 12: Traffic Files

    File

    Description

    egress*

    The egress file contains egress traffic of the network interfaces load. Egress traffic specifies traffic that is going out of the network interfaces. This data is used for calculating link utilization and load.

    ingress*

    The ingress file contains ingress traffic of the network interfaces load. Ingress traffic specifies traffic that is going into the network interfaces. This data is used for calculating link utilization and load.

    trafdir*, tunneltrafdir*

    The trafdir file identifies the location of the interface traffic daily directories repository.

    The tunneltrafdir file identifies the location of the tunnel traffic daily directories repository.

    trafficload*, t_trafficload*

    The trafficload file allows you to import measured bandwidth utilizations based on data collected from the network. Traffic loads for each PVC can be specified over the time intervals for which the data was collected.

    The t_trafficload file (IP/MPLS only) is similar to the trafficload file, but for LSP tunnels (layer 2 instead of layer 3)

    Note: In Table 12, an asterisk (*) specifies files used for a feature that is license dependent.

    For more information regarding these files, refer to the IP/MPLSView Java-Based Management and Monitoring Guide and the File Format Reference for IP/MPLSView.

    Examples of the discrete event simulation files include: tfxdata, tfxpattern

    Table 13: Discrete Event Simulation

    File

    Description

    tfxdata*

    For discrete event simulation only. The trafficdata file allows you to define each demand by specifying multiple packets and packet sizes. Although this requires you to have a reasonable knowledge of the traffic, more accurate network simulation results can be obtained in this manner. Refer to TRAFFICDATA (TRAFFICDATA=filename) for further details.

    tfxpattern*

    For discrete event simulation only. The trafficpattern file allows you to define several class types based on traffic characteristics. Each traffic type may be specified in terms of four parameters: number of messages, duration (seconds), message size (bits), and frame size (bytes). Refer to TRAFFICPATTERN (TRAFFICPATTERN=filename) for further details.

    Note: In Table 13, an asterisk (*) specifies files used for a feature that is license dependent.

    Device specific files contain the definitions for various types of devices. Examples of device specific files include: aclist, bgplink, bgpnode, bgpobj, intfmap, policymap, tbit, tunnel, and vpn.

    Table 14: Device-Specific Files

    File

    Description

    aclist*

    The aclist file (Router only) contains information about access rules such as access lists, distribute lists, and filter lists.

    bgplink*

    The bgplink file (Router only) contains the definitions for BGP neighbors. See note for bgpobj. See note for bgpobj.

    bgpnode*

    The bgpnode file (Router only) contains the definitions for BGP speakers. See note for bgpobj.

    bgpobj*

    The bgpobj file (Router only)contains information about BGP neighbors and is stored in binary format to speed up performance. Note: If you want to manually edit bgpnode and bgplink, comment out this entry before reloading the network.

    intfmap*

    The intfmap file (Router only) contains information about router interfaces, including the node, interface, IP address, status, bandwidth, VPN-list, and other details.

    policymap*

    The policymap file (Router only) contains information about CoS Policies on each router

    tbit*

    The tbit file (Router only) stores names for the tunnel attributes (otherwise referred to as admin group for Juniper Networks).

    tunnel*

    The tunnel file (Router only) contains information about LSP tunnels.

    vpn*

    The vpn file (Router only) contains information about Virtual Private Network details such as vrf, route distinguisher, route target, and protocols.

    rtd*

    The routing table descriptor (rtd) file (ATM/PNNI only) is used for PNNI networks to read routing table descriptor information. This file is generated by IP/MPLSView after you saved the network’s RTDs.

    hpnni*

    The hpnni file (ATM/PNNI only) is used for PNNI networks to describe PNNI information for nodes and logical group nodes in the network. It also contains hierarchical information which allows IP/MPLSView to group the network’s nodes accordingly.

    Note: In Table 14, an asterisk (*) specifies files used for a feature that is license dependent.

    For additional files not listed here, or for a detailed description of these files, their parameters, and their functions, refer to the File Format Reference for IP/MPLSView.

    The Report Viewer allows you to view reports that are generated by the system. The report viewer provides quick access and a uniformed and organized way of viewing these reports. To view a report, you must select a file that is in IP/MPLSView report format. To customize the columns displayed, right-click on the column header and select the Select Columns... option.

    Figure 13: Report Viewer Window

    Report Viewer Window

    Due to the length of some reports, the Report Viewer only displays a portion of the report in the viewer window. You may set how many lines to display in the Page Setup. With the jump-to buttons, you can jump to the beginning and end of the report. You can also move forward or back. Clicking the Search button searches the current table for the queried text. Clicking the Advanced Search button opens a new window for more complex searches. The query is entered in the text field at the top of the window. The panels on the bottom are provided for convenience in selecting keys, relations, and boolean operators.

    Figure 14: Report Viewer Toolbar

    Report Viewer Toolbar

    Figure 15: Advanced Filter Window

    Advanced Filter Window

    The Report Master allows you to view multiple reports in the Report Master window. The Report Master is similar to the Report Manager which provides quick access and a uniformed and organized way of viewing multiple reports without having to open a network first. To open a report master, you must select a file that is in report master format.

    Figure 16: Report Master Window

    Report Master Window

    The Report Master files do not contain any actual reports. Instead, the Report Master files reference existing reports and place them into an organized tree structure. The format of a Report Master file is described below.


    # IP/MPLSView Report Master
    1st_item First.report
    2nd_item ../../other_path/2nd.report
    3rd_item {3-1_item /export/home/data/3-1.report3-2_item 3-2.report3-3_item {3-3-1_item 3-3-1.report3-3-2_item 3-3-2.report}}

    The Report Editor allows you to perform basic editing functionality on csv files. Click on a cell to edit the value. Right-click on a cell to for more options to edit rows and columns.

    Figure 17: Report Editor Window

    Report Editor Window

    Table 15: Report Editor Window File Manager View

    Show Hidden Files

    This option displays all hidden files in the directory

    Large Icons

    This option displays files and directories listed in the File Manager’s right pane as large icons in columns.

    Small Icons

    This option displays files and directories listed in the File Manager’s as small icons in columns.

    List

    This option displays files and directories listed in the File Manager’s in list form.

    Details

    This option gives a detailed view of the files displayed in File Manager including information such as file permission, file owner, file size, and last modified date. (Note: Each column can be sorted by clicking on the column header.)

    Directory View

    This toggles the left pane between the Directories view and Common Actions / Favorite Link view.

    Modified: 2016-11-08