Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation  Back up to About Overview 
ContentIndex
  
[+] Expand All
[-] Collapse All

No index entries found.

Related Documentation

    Detailed Procedures

    Integrity Checks Report

    1. Select Report > Report Manager. Then select Configuration Reports > Integrity Checks to view potential configuration errors and warnings in the network or Configuration Reports > Summary of Integrity Checks to view a summary of how many integrity checks are found in each category.

      Figure 99: Integrity Checks Report

      Integrity Checks Report

      For more details, refer to the Router Guide.

    2. Right-click an entry in the Integrity Checks Report and select View Source... to open the configuration file to the relevant line or View Source > Open All... to open all relevant configuration files in the Configuration Editor.

      Figure 100: Configuration Editor

      Configuration Editor
    3. The Configuration Editor indicates the lines where various integrity checks have been identified and can also be accessed by right-clicking a router and selecting “Show Config File.” The configuration editor allows for easy navigation of configuration file sections and the Actions menu also provides a global search function among all configuration files for the project (Search > Find in Configuration Files...).

    Configuration Conformance

    1. To check your router configuration files against a user-defined template, select Tools > Configuration Conformance... A project is made of a set of configuration files listed in the Configurations tab and a set of templates listed in the Templates tab that are used to check the configuration files.
    2. To populate the Configurations tab, right-click over the left pane and select Open Configuration(s) from the server. Navigate to the directory containing the live network configuration files (/u/wandl/data/collection/.LiveNetwork/config) and select all files using Ctrl-A. Click Select.
    3. To populate the Templates tab, right-click over the left pane and select New Template. Provide the filename and directory to store the template. Select the configuration type and relevant options (such as use regular expression). Then click OK.
    4. In the Templates tab, right-click the template from the left pane and select “Show in Main Pane.” In the Configurations tab, right-click a configuration file containing statements that should be matched and select “Show in Secondary Pane.” Copy and paste the statements that should be matched from the secondary pane to the main pane. (Only the main pane can be edited.) In some cases, certain statements can be configured for flexibility in matching by including regular expressions in portions of the statement. For example, to have all Cisco router hostnames start with “rtr” one line would be “hostname rtr.*”
    5. Right-click the edited template and click “Save.”
    6. To save the project, right-click over the left pane and select Project>Save As on the server. It is necessary to save on the server rather than the client PC in order to schedule conformance tasks on a regular basis.
    7. To check for conformance, right-click over the left pane and select Check Conformance. View the All Conformance Results tab at the bottom of the window to view statements that matched, partially matched, or failed to be matched. Double-click an entry to view the relevant configuration file lines color-coded according to indicate matched and unmatched lines.

      For details on more advanced template creation and additional features, refer to the Router Guide.


      Configuration Revision Manager

    8. To compare a configuration file with a previous version, right-click a device and select Show Config File. Then in the resulting Config Editor, select the following menu from the upper right Actions menu: Actions > Tools > Compare > With revision... Then select the version to compare with.
    9. To open the Revision Manager to access all configuration files and their revisions, select Tools>Revision Manager to access the revision manager. In the upper right corner, select Actions>Configuration Revision to access the configuration revision manager. The program will then attempt to access the configuration files that were collected on the server side and display them in the revision manager window. Whenever a new router collection is performed, the revision manager will then create a new revision of the configuration files and keep a history of them.

      Note: If you have trouble opening up the Configuration Revision view, please make sure that you have scheduled the Scheduling Live Network Collection task at a regular interval in the Task Manager to perform repeated config file collection. This allows the program to establish a baseline of the configuration files, against which future versions of the files are compared.

    10. The configuration files will be listed in the left column. If there are multiple revisions, they will be listed under a folder for that router. To see the dates of these revisions, select the folder, and the revisions will be listed on the right pane in a table with “Last checked-in” times.
    11. To compare revisions, right-click over a configuration file version and select “Compare the selection with revision...” The differences will be color-coded (blue for addition, green for removal, and red for modification).

    For more details, refer to the Router Guide.

    Figure 101: Viewing Configuration Changes

    Viewing Configuration Changes

    Using the Web Browser

    1. To view configuration revisions through the web portal, select File > Launch Web or open IP/MPLSView on your web browser to http://<host-ip-addr>:8091/ or http://<host-ip-addr>:8443/ (supporting SSL), where <host-ip-addr> is the hostname or IP address of the server on which you are running IP/MPLSView.
    2. After logging in, on the Live Network menu select View Collection Files. You should see two folders available for viewing. Click the one that is named . LiveNetwork.
    3. Once you have opened this folder, you should be able to see a list of router configuration files with its size, last modified date, and current revision number listed in long format (as shown in Figure 102).

      Note: You may click on the “To short format” button to view the list of files without the detailed information.

      Figure 102: Router Configuration Files Collected from Live Network

      Router Configuration Files Collected from Live Network
    4. Click on any config file name to view that file.
    5. To view any changes to the router configuration files, click on the version number to the right of the file name. The revision version number should be higher than 1.1. The version-by-version differences will be displayed sequentially, as shown in the following figure.

      Figure 103: Revision History for a Router Configuration File

      Revision History for a Router Configuration File
    6. You may also view Tunnel Path Files by clicking on the “View Tunnel Paths” button on the Configuration Files listing page.

    Task Scheduling

    Note that before scheduling configuration management tasks for the live network, you should first setup a live network collection task.


    Configuration Comparison Task and Conformance Task


    1. As the application admin user, select Admin > Task Manager.
    2. Click the “New Task” button and select the “Config, Comparison, Conformance, and IC Report” task.
    3. There will be tabs for each task (Configuration comparison, Conformance Check, and Integrity Check). After enabling the task by selecting the corresponding checkmark, check that it is enabled for the Live Network under the “Network” section if applicable.
    4. Note that the Conformance Check task requires first setting up a project. Refer to the “Configuration Conformance” chapter of the Router Guide for more details on setting up a project.
    5. The Integrity Check option will schedule the report indicating potential configuration errors (same as Report > Report Manager, Configuration Reports > Integrity Checks Report.) For more details, refer to the “Integrity Check Report” chapter of the Router Guide.
    6. Under the Report Options tab, you may select which files to save the reports to, and optionally set up the server to send the report via e-mail. Enter in the full path of the file to save the reports to without including spaces in the name.
    7. After scheduling the task, and after the task completes, navigate to the appropriate directory in the File Manager for the reports. Note that for the Integrity Check Report, you can right-click the report name and select “Open in Report Viewer.”

    Refer to the Router Guide for more details.

    Modified: 2015-12-29