Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation  Back up to About Overview 
ContentIndex
  
[+] Expand All
[-] Collapse All

No index entries found.

Related Documentation

    Detailed Procedures

    Setting Up the Live Network

    As the IP/MPLSView admin user, select Admin > Task Manager, click the New Task button, and scroll down to select the Scheduling Live Network Collection task (or the Network Config Data Collection task for the offline equivalent). Enter in a Task Name and click Next.. Only the IP/MPLSView administrative user can access the Task Manager.

    Figure 74: Create a Scheduling Live Network Collection Task

    Create a Scheduling Live Network Collection Task

    Figure 75: Scheduling Live Network Collection (Options May Vary)

    Scheduling Live Network Collection (Options May Vary)

    One difference of the Network Config Data Collection task is that it will provide an additional option for the Collection Directory in which the collected files and network baseline will be saved.

    Choosing Routers to be Collected

    Select the routers for the live collection. To choose to use the router profile directly, select the “Use Profile Directly” checkbox. This option is strongly recommended for a task that is scheduled to run periodically because it will capture future modifications to the router profile. Note that once selecting this checkbox, you will be given the router profile(s) to choose from. More than one router profile can be collected together.

    Figure 76: Use Profile Directly

    Use Profile Directly

    Another option is to select the “Use Master Profile” checkbox and select the device(s) to collect from the Master Profile, which contains the last successfully used credentials for previously collected devices. This checkbox appears if the Master Profile has been generated from a previous task.)

    In contrast, the following options enable the user to add a subset of routers within a router profile or to concatenate routers from different router profiles. However, note that this will save the login information of the router profile at the time the task was created, but it will not change automatically when the associated router profiles are changed. (If that behavior is desired, then use the “Use Profile Directly” option instead.)

    1. Uncheck “Use Profile Directly”. Choose a router profile from the Router Profiles pull-down list. This will populate the list on the left with the IP addresses of all the routers in that profile.
    2. To select only particular routers from a router profile, highlight the routers from the list on the left. Highlight the desired ones and click Add-> to add them to the “Routers to be collected” list on the right. Alternatively, click Add All >> to add all the routers in the profile. Note that future changes to the router profile will not be picked up
    3. You can concatenate on to “Routers to be collected” list with additional routers from other router profiles by selecting a different router profile from the left hand side and likewise adding routers from that profile to the right hand side.
    4. To remove routers from the Routers to be collected list on the right, select an entry or entries to delete and right-click over the list. Then select “<-Remove”.

    Note: See Chapter 3, Setting Up Device Profiles for more information on creating router profiles.

    Specifying Intermediary Servers

    If one or more routers must be reached through an intermediary server with a different login/password, the router profile for these device(s) should specify the IP address of the intermediary server(s) in the Agent(s) field, shown below. Furthermore, the router profile entry for the intermediary server(s) must also be added to the list of routers to be collected.

    Note that the agent field is also used for environments setup with a Jump Server.

    Figure 77: Router Profile Agent Field

    Router Profile Agent Field

    Data Collector Instruction

    1. Specify whether to use Telnet or SSH. The default option “Use Router Profile Setting” will use the Access Method preference specified in the selected router profile entries. You can override this by specifying Telnet only or SSH only. Alternatively, if you choose Telnet - or SSH as alternate, then telnet will be used first to log into a device. Only if that fails, then SSH will be used. Vice versa for SSH - or Telnet as alternate. If necessary, the command used to collect ssh can be edited in /u/wandl/db/command/ssh.cmd.
    2. Check the box for Incremental Data Collection for a live network collection when you do not want to lose or overwrite data from previous collections on the same network.
    3. Check the box for Archive Old Data to store data in /u/wandl/data/collection.archive as a .tar.Z file which can be extracted using the uncompress and tar commands. (Regular collected data is stored in /u/wandl/data/collection/.LiveNetwork/LiveNetwork for the live network, and /u/wandl/data/collection/Default for the offline network. The .Live Network directory is hidden because it should not be modified.) For more details about file organization, refer to Appendix A, Data Repository.
    4. Check the box for “Consolidate with existing planned data” to reuse existing muxloc, nodeparam, and vpn files, etc.to construct the network files. For example, this could include additional info that cannot be derived from the configuration files, such as geographical information of nodes, or links manually added and specified as fixed links. Select also the output directories for any previously run VLAN Discovery or Host Discovery task, to have as fully comprehensive a network as possible.

    Data to Be Collected

    Select the checkbox besides “Select All” to collect configuration, interface, tunnel path, transit tunnel, MPLS topology, equipment CLI, OSPF neighbors, ISIS neighbors, ARP, and switch CLI. Alternatively, select only the data types desired. This usually includes minimally the configuration and interface files. If necessary, to modify the commands used to collect this information, check the relevant file (named using hardware vendor followed by data type) in the /u/wandl/db/command directory.

    Note: It may be desirable to set different frequencies of collection for different data being collected depending upon how frequently the data is expected to change. To do this, multiple live network tasks can be scheduled with different frequencies for different data. For example, you could create one task collecting only configuration files and interface on an interval such as once a day and a second live network task to collect only “tunnel path” and “transit tunnel” more frequently (for example, every 15 minutes).


    Alternate Login


    A list of alternate login/password(s) can be entered in sequentially into a file, and used only if the default login/password information fails. The passwords will be encrypted into this file. To use this feature, select the Edit button and then add in the logins in order from first to last. Note that having a long list of incorrect logins can potentially slow down the collection process. This file and the password order should therefore be used with care.

    Collector Settings

    After a certain number of seconds, if the collector fails to collect data from the router, it will time out. After the Time Out period, if a positive No. of retries is configured, it will proceed to try again to collect data from a router. The No. of retries and Time Out can be increased to ensure that data will not fail to be collected due to transient network conditions or delays. However, note that by increasing these numbers, the overall time to collect data will also increase when there are many routers that cannot be reached.

    The No. of processes can be increased to allow for separate processes to collect data in parallel.

    If you specified a secondary address in the router profile and wish to use the secondary address in case the primary address could not be reached, select also “Use secondary address if failed on primary address.”

    If Turn on trace is selected, then collection errors will be logged in /u/wandl/log/wtalklog.log. This option should not be used in general, since it may add to the processing time, but it can be used when collecting a specific, problematic device when troubleshooting is necessary. Contact Juniper support for more information.

    Conversion Options Tab

    Click on the Conversion Options tab to specify any options to be considered when the configuration files are collected and parsed into the IP/MPLSView network model.

    If customized reports need to be saved between collections, the network Spec File can be specified.

    You can specify a Graph Coordinates (graphcoord) and Group (group) file to set default map display coordinates and grouping. This can be set to any file except $HOME/livenetwork_output_directory/group.x and $HOME/livenetwork_output_directory/graphcoord.x which are special reserved filenames. For each individual user, these two reserved files will be used, if they exist, to set the graphical coordinates and grouping. If they do not exist, then any graphcoord and group file specified in the Conversion Options tab will be used.

    If you would like to include hosts other than routers and switches in your network model, check the option “Create dummy nodes for unrecognized files.”

    If you have devices with dual routing engines, then browse for the Node Alias File. For the format and explanation of this file, see Dual Routing Engine Support.

    If you would like to stitch by OSPF neighbor information, select “Stitch by OSPF Neighbor” and browse for the directory containing ospf neighbor output (For Cisco, this is the output of the commands “terminal length 0” and “show ip ospf neighbor”).

    In the special case if you would like to stitch together fxp0 interfaces, check the option “Don’t ignore management interfaces”.

    Many of the other options are the same as the Misc tab of the Import Config Wizard. For more information, refer to the “Router Data Extraction” chapter of the Router Guide.

    Configuring Scheduling Parameters

    Click Next to proceed to scheduling the task. If you want to collect router data on a regular basis, select a Schedule Type of either Minutes, Hours, Daily, Weekly, Monthly, or Yearly.

    Next, select an Interval (the default is one).

    Set the Start Time and Stop Time, or Never Stop if you wish to collect the selected type of router. Set the date and time either by typing directly into the textfield or by using the drop down calendar.

    Figure 78: Calendar Used to Set a Start or Stop Time

    Calendar Used to Set a Start or Stop Time

    Alternatively, Immediately can be used to schedule the task to occur now, and Once can be used to schedule the task to occur in the future. The “Immediately After” type is used to chain tasks, allowing the current task to execute after a certain previously configured task is completed. When selecting this option, choose which task should be completed before executing this one. Note that the preceding task must be one that was either scheduled Once in the future or on a recurring basis.

    When ready, click Finish to submit the live network discovery task.

    Viewing Task Status

    You can check a task’s status live by selecting the task entry and clicking the Task Status, Properties, and Execution History tabs. The task entry will also include a Status such as “Waiting,” “Running,” or “Completed”. By default the status is automatically updated. To toggle this on or off, right-click over the table and toggle the “Auto Status Update” checkbox.

    In the Task Status tab, you should see a list of IP addresses of routers, the Status, and the Job Type (Interface, Config, Tunnel Path). When the task is completed, the status will say COMPLETE. To see an explanation of the Status and warning and error coloring, see Chapter 19, Reference . Logs are stored in a directory where they can be viewed via the IP/MPLSView Web from the Admin > View Logs menu as described in Chapter 9, Configuration File Management .

    For troubleshooting tips, refer to Troubleshooting.

    Viewing the Collected Network

    If you scheduled a live network collection, select File > Open Live Network. Answer any dialog prompts you may receive. You should be in Monitor mode. If you wait the scheduled interval, you will see the network refreshed and the Last updated time changed on the Topology map after the collection has completed and the data has been imported into the network.

    If you scheduled a Network Config Data Collection, find the network baseline in /u/wandl/data/collection/<yourdirectory>/baseline/, where <yourdirectory> is the Collection Directory chosen when the task was scheduled.


    Graphical Coordinates and Group Settings


    If you did not specify a Graph Coordinates file in the Conversion Options of the task, note that all of the network elements may be located in one point. To rearrange them, right-click on the map and select Layout>Recalculate Layout from the right-click menu. Now your nodes will be rearranged.

    Figure 79: Map After Recalculate Layout Operation

    Map After Recalculate Layout Operation

    To save the graphical coordinates, use File>Save Network File>Graph Coordinates... If you are in the live network, decide whether to save it as a default, public graphical coordinate setting or a private graphical coordinate setting. The default graphical coordinates come from the shared file /u/wandl/data/.network/graphcoord.x, but will be overridden by the user’s preferences in the $HOME/livenetwork_output_directory/graphcoord.x file.

    If you did specify a Graph Coordinates file in the Conversion Options of the task, then every time a collection is performed, the originally specified graphcoord file will be used by default, unless it is overridden by the user’s own preferences. To go back to the default graphcoord file used to schedule the task, rename this personal graphcoord.x file and close/reopen the network, or import the graphcoord file each time using the File > Load Network Files menu.

    Similarly, you can use the grouping functions, and then save your groups using File>Save Network File>Groups. Decide whether to save it as a default public setting (/u/wandl/data/.network/group.x) or a private group setting ($HOME/livenetwork_output_directory/group.x).

    The group file can also be specified in the Conversion Options of the task to ensure that it is used every time the network is collected. Note, however, that it can be overridden by personal settings.

    View collected router, link, interface, and tunnel information from the Nodes, Links, Interfaces or Tunnel options under the Network > Elements menu. Right-click the table header in the Network Info window and select Table Options... to view if there is any column data that you would like to add to the table.

    Right-click on a router and select “Show Collected File” to view the raw collected files from the Scheduling Live Network Collection task.

    Figure 80: Show Collected File

    Show Collected File

    Tunnel Path Information

    To see collected tunnel path information via the graphical interface, select Network > Elements > Tunnels from pull-down menu.

    Figure 81: All Tunnels (Options May Vary)

    All Tunnels (Options May Vary)

    Scroll to the right to see the Current Route column. Click on a row where this column is not empty and press “Show Path.”

    Figure 82: Show Tunnel Path

    Show Tunnel Path

    In the Properties tab, check the Misc field to view the live status (up, down, or missing).

    To see tunnel secondary/standby backup paths, select Network > Elements > Tunnels Diverse Status.

    To view tunnels going through a node, right-click over a node and select “View Tunnels Thru Node” from the right-click menu. By clicking on the drop-down menu in the upper right corner of the Network Info window, you can toggle between starting at, ending at, and passing through Node to selectively view tunnels. You can also view tunnels through a link by right-clicking over a link and selecting View >Tunnels on/thru Link from the right-click menu. For more details on viewing tunnels, refer to the Router Guide.

    Modifying a Task

    Suppose you now want to change the collection interval to something longer. Or, perhaps, you set the task to run continually and now you want to set a stop time. To make this change to your task, open the Task Manager and select the desired task in the tasks table. Click the Modify Task button. Alternatively, you can right-click on the task in the tasks table and select “Modify” from the drop-down menu, as shown in the following figure.

    Figure 83: Modify Selected Task Option

    Modify Selected Task Option

    The task window will open, allowing you to change the task parameters. Change the task settings as you wish. For example, you may want to uncheck the Never Stop radio button if it was formerly checked and/or you may want to change the collection interval as previously explained.

    On the Scheduling page, you can also select “Click to modify Task Name and/or Comment” to change the name and comment for the task.

    After you make your changes, press Next if applicable and finally Finish to resubmit the task.

    You will be asked whether or not you want to modify the existing task. Select “Yes” to replace the existing task or “Copy as New Task” to create a new task, leaving the previous task unmodified. If you changed the start and stop times and/or interval, you can go back to the Task Manager tasks table and see that the entry is changed.

    In some cases you may also want to correct some router login information by clicking the Router Profiles... button. However, note that this information will not automatically be updated unless the user selected to Use Profile Directly in the Collections tab as discussed in Choosing Routers to be Collected on page 111. The Routers to be collected section will still use the original parameters from the router profile when the task was created. To fix this, when modifying a task, remove the router(s) with changed parameters. Then select the profile(s) containing those router(s) and reselect the router(s) from the left hand side and add them back to the right hand side.

    You can also delete a task. To do so, right-click on the desired task in the Task Manager tasks table and select “Delete”. Answer “Yes” to the following dialog box. Your task will then be removed from the list of scheduled tasks.

    Deleting a Node (Permanent)

    This section describes the process to permanently delete a node and all information related to the node in the IP/MPLSView files when it is no longer needed in the network model. Deleting a node is a four-step process that involves deleting it from the Map topology, Task Manager, Traffic Collection Manager, and Router Profile.

    • Map topology. Switch to Setup mode. In the Map window, right-click the node to delete, and select Delete Node. Click “Confirm” on the Setup panel to confirm the delete action. Switch to Monitor mode. Files located in the directories of .network and .Live Network will delete entries related to the node. The node will be deleted from the topology along with any links connected to it.

      Figure 84: Map - Delete Node

      Map - Delete Node
    • Task Manager. Open Admin > Task Manager, select all the tasks, right-click the task group, and select Remove Nodes in Scheduled Tasks. Enter the node name or IP address of the node to delete. Use one line per node entry. Click “OK” to commit the change. A confirmation message will appear if the node is successfully deleted from the scheduled task. All tasks will no longer collect data related to the deleted node.

      Figure 85: Task Manager - Remove Nodes in Scheduled Tasks

      Task Manager - Remove Nodes in Scheduled Tasks
    • Traffic Collection Manager. Open Performance > Traffic Collection Manager, right-click the node to delete, and select Delete. Click “OK“ at the delete prompt to delete the node from traffic collection. Click the Save icon from the menu to commit the change. Traffic data will no longer be collected from the deleted node. Note that if you select Remove instead of Delete, the node is moved into the Free Routers list and is still available for collection.

      Figure 86: Traffic Collection Manager - Delete Node

      Traffic Collection Manager - Delete Node
    • Router Profile. Open Admin > Task Manager > Router Profile, select all the profiles containing the node to delete, and click Delete. Click Save to commit the changes and save the Router Profiles. The node data will no longer be stored in the router profile. Note that if the node exists in multiple profiles, you should delete the node from each profile.

      Figure 87: Delete Node - Router Profile

      Delete Node - Router Profile

    After completing the four steps to delete the node from the Map topology, Task Manager, Traffic Collection Manager, and Router Profile, save the network specification file using File > Save Network.

    Live Network Dashboard

    Live Network Dashboard displays a Top N list in either tabular or chart format of performance data collected for devices, events, link latency, ping, and traffic. Accessed from menu Network > Dashboard. Once data collection has been setup, click Add Content to select the reports to display on the Dashboard. The Options button allows configuring the number of report columns to display and the refresh time interval. The Refresh All button immediately refreshes all reports. On each report, you may click the Options drop-down and select Settings to further configure individual reports.

    Figure 88: Live Network Dashboard

    Live Network Dashboard

    Troubleshooting

    If the Task Manager does not open, go to /u/wandl/bin and run the command status_mplsview. Check that the Task Server and Web Server (JBoss) are both running. Depending upon your server performance, it may take a few seconds to a couple of minutes for the Web Server to finish deploying. Once it is finished starting up or being restarted, then close and reopen the IP/MPLSView client and reattempt to connect to the Task Manager.

    If you see the error message “The client could not establish a connection to the Task Server. Please verify that the Task Server is running and fully initialized”, another place to check is the Java Control Panel settings. Select Control Panel > Java > General > Network Settings and select Direct connection. (The location of the Java Control Panel may vary depending upon which Windows operating system you use.)

    If the tasks are not completing, check the file /u/wandl/bin/mplsenvsetup.sh and look for the MPLS_JBOSS_MEMORY setting. The Task Manager Memory setting is specified during the installation of the IP/MPLSView server and is defaulted to 256 MB. To change this setting to a higher number (512 or higher is recommended), modify the MPLS_TMNG_MEMORY line in /u/wandl/bin/mplsenvsetup.sh.

    If there are abundant login problems when checking the Task Status tab, check the IP addresses that failed to be collected for. You may want to open a telnet/ssh window to the server and check whether you can ping those IP addresses. If not, check the routing table on your server (“netstat -rn”) and add any necessary routes (“route add”). Otherwise, you may want to check that the router profile login/password are configured correctly.

    If the task fails, see Test Profile Connectivity to check for telnet, SSH, ping, and SNMP access.

    Some routers cannot be reached directly due to a firewall, but can be reached by first logging in to another machine. To handle this, one method is to create the file /u/wandl/db/config/wtalk.agent with the IP addresses of the intermediate machines, one per line. This will be used for all routers and the default login and password to the intermediate machine is the same as for the routers. Another method is to enter in the intermediate server IP in the agent field of the router profile entry. Refer to Specifying Intermediary Servers on page 112 for more information. If a different login and password are needed for the intermediate machine(s), a router profile entry should be created for the intermediate machine(s), which should be added to the list of devices to be collected.

    If the task completes without an error message but the Live Network fails to display on the topology map after the task is complete, check for the configuration files in /u/wandl/data/collection/.LiveNetwork/config directory. Check that the configuration files are present and contain the hostname of the router. In some cases, the router login provided in the router profile may not have full permission, and therefore certain commands in the /u/wandl/db/command file may be restricted. For more information, see Editing Show Commands for Data Collection.

    To check for Task Manager errors, check /u/wandl/log/tmng.log.n for exceptions, and /u/wandl/log/tmng.msg for startup messages. To check for collection errors, check /u/wandl/log/wDriverTask.log , and /u/wandl/log/wtalklog.log (wtalklog is created if “Turn on Trace” option is selected).

    If data (configuration files, interface files, etc.) cannot be completely collected within the timeout period, for example, as indicated by configuration files with partial data, increase the Timeout value in the Collection Options tab, Data Collector Parameters section. Partial collections can be identified in the config, interface, tunnel_path, etc. subdirectories of /u/wandl/data/collection/. LiveNetwork if there is the suffix ++ at the end of a file.

    Modified: 2015-12-29