Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation  Back up to About Overview 
ContentIndex
  
[+] Expand All
[-] Collapse All

No index entries found.

Related Documentation

    Detailed Procedures

    This chapter steps you through the usage of the following diagnostic tests and features:

    Diagnostics Manager

    The diagnostics manager provides an interface to keep track of ping and traceroute operations performed on the live network.To open the Diagnostics Manager, select Tools > Diagnostics > Diagnostics Manager.

    Figure 134: Diagnostics Tool

    Diagnostics Tool

    The ping and traceroute options provided by this tool include the following. More details on the various options are provided in subsequent sections of this chapter.

    • Ping > Device From Device: Ping from one device to another device. The Advanced option provides a selection of ping commands for the device
    • Ping > Multiple Devices From Device: Ping from one device to multiple devices
    • Ping > Devices from Server: Ping from the IP/MPLSView server to multiple devices
    • Ping > Devices to Device/Server: Ping from multiple devices to a device or to the IP/MPLSView server. Note that even if the server can ping a device by its loopback address, this does not guarantee that the device can also ping the server. It is possible that the source interface that the device uses to ping the server is unreachable to the server, so that the ping response never returns back to the device.
    • Ping > Continuous Ping: Ping at regular intervals between two devices and display the result graphically. The Advanced option provides a selection of ping commands available for the device.
    • Traceroute > Device From Device: Traceroute between two devices and display of the path on the map (right-click menu option). The Advanced option provides a selection of traceroute commands available for the device.
    • Traceroute > Multiple Devices From Device: Traceroute from one device to multiple devices

    Grouped Pings


    • Ping/Traceroute within Device Group...: Perform a ping between each pair of routers in the group.
    • Ping/Traceroute between Device Groups...: Perform a ping from routers in the first group to routers in the second group.
    • Ping/Traceroute from Device Group to Multiple Devices...: Ping from routers in the first group to selected routers
    • Ping within Devices of VPN: For a given Layer 3 VPN, ping from PE to CE, CE to PE, or PE to CE loopback. This VPN group must be predefined from Grouping > Customized VPN Diagnostics...
    • Ping/Traceroute by Customized Advanced Group: Perform a ping between each designated pair of source router/interface and destination router/interface. This option is useful if you need to specify a particular source interface to use for the ping. This group must be predefined from Grouping > Customized Advanced Group.

    For each ping or traceroute operation performed from the Ping and Traceroute buttons or from the Tools > Diagnostics menus, an entry is added to the upper table, describing the operation and the time it was performed. Click on a row to display the results in the bottom of the window.

    • For each entry, a green circle indicates a successful operation, a timer glass indicates an operation in progress, and a red circle indicates a failed operation.
    • Right-clicking a row in the upper table provides options to rerun a ping or traceroute, show the path for a traceroute, stop a continuous ping and turn off the chart view for continuous ping, or to delete an entry.
    • The buttons in the lower left of the window allow the user to save a single entry or all entries to a text file on the client machine, and to view details of an item in a separate window.

    Diagnostics Configuration Settings

    Default settings for Diagnostics can be customized by adjusting the Diagnostic Configuration Settings via the IP/MPLSView Web interface. In the IP/MPLSView Web interface, log in as “admin” and go to Admin > Change Diag Settings. To adjust any of the settings, simply edit the corresponding textfield in the New Value column. Then, scroll down to the bottom of the page and press the “Submit” button. These parameters are described further below.

    Note: Only the IP/MPLSView Web administrator (login = “admin”) is allowed to make these adjustments.


    Diagnostics Using SSH


    By default, diagnostics are performed using telnet. To change the default, Go to Admin > Diagnostics Settings and you should see the screen as shown in Figure 135.

    Under the section called Diagnostic Configuration Parameters, there is a Use SSH (instead of telnet) parameter. Set this value to “yes”. Then, press the “Submit” button at the bottom of the page. Now, SSH will be used to access all devices during the various diagnostics tests.

    In order for SSH diagnostics to work, you must make sure that the SSH keys have already been accepted. If not, you should log into the device(s) using SSH and accept the keys when prompted.

    Figure 135: Diagnostics Configuration Settings from Web Browser

    Diagnostics Configuration Settings from Web Browser

    Table 35: Diagnostic Configuration Ping Parameters

    Ping Parameter

    Description

    Ping Path

    Location on the server of the ping utility to use during any ping operation

    Ping Count

    Number of actual pings to issue during a ping operation

    Ping Type of Service (TOS)

    Sets the ToS value in the ICMP packet for routers that are set up to treat packets with certain types of service differently than others. Note that ToS is not used very often and most routers ignore it.

    Ping Packet Size (bytes)

    Size of the ping packet

    Ping Hex Fill Pattern

    A hexadecimal fill pattern to include in the ping packet

    Ping Threshold 1 and 2 (milliseconds)

    A ping value that is less than Ping Threshold 1 is “acceptable”. A value greater than or equal to Ping Threshold 1 and less than Ping Threshold 2 will be flagged as “problematic”. A value that is greater than or equal to Ping Threshold 2 will be flagged as “unacceptable”.

    Ping Threshold Colors

    Hexadecimal color code indicates the color to display for acceptable, problematic, and unacceptable ping values.

    Table 36: Diagnostic Configuration Trace Parameters

    Trace Route Parameter

    Description

    Traceroute Timeout (seconds)

    Number of seconds to allow the traceroute to run for.

    Traceroute Resolve IP Address

    Indicates whether or not to resolve hostnames associated with the IP addresses. 0 = Don’t Resolve; 1 = Resolve.

    Traceroute Type of Service (Juniper only)

    Value to include in the IP Type of Service (ToS) field. The range of values is 0 through 255.

    Traceroute Time To Live (TTL) in hops

    Maximum TTL value to include in the traceroute request. The range of values is 0 through 128.

    Traceroute Wait Time (for response) in seconds

    Maximum time to wait for a response to the traceroute request

    Table 37: Diagnostic Configuration Additional Parameters

    Other Parameter

    Description

    Show Command Execution Timeout

    Number of seconds to allow “show” commands to run for.

    Debug Level

    This toggles debuging messages on and off. Users should leave this setting at 0 unless instructed otherwise by Juniper support.

    Figure 136: Diagnostic Configuration Parameters

    Diagnostic Configuration Parameters

    Table 38: Diagnostic Configuration Device Parameters

    Diagnostic Configuration Parameter

    Description

    OS Type

    This allows the user to select the type of OS on which the server is running. Options include Linux and Solaris. The correct setting is required in some cases for ping and traceroute diagnostics to function properly.

    Diagnostic Login TypeDiagnostic Login Type

    This parameter applies to users who have TACACS. For TACACS users, Cisco “show” commands are executed differently, requiring a different login sequence.

    Use SSH (instead of telnet)

    Some operations such as “show” commands require the system to log into a device. Use this field to specify whether to use secure shell (SSH) or telnet when logging in. See Diagnostics Using SSH.

    Use Enable Mode

    Sets the enable mode when executing “show” commands via the IP/MPLSView Web interface and in the client graphical interface. Default value is “No”.

    Router Profile File

    The default router profile file is located in:/u/wandl/data/.TaskManager/tmp/.diag

    Diag Working Directory

    A directory in which the IP/MPLSView system stores temporary results while processing diagnostics data.

    Node Parameter File

    The IP/MPLSView node parameter (nodeparam) file. This file is used to correlate IP addresses with device hostnames.

    Hardware Mapping File

    The hardwaretypemapping.csv file contains a mapping of recognized device models with their vendors.

    Vendor Configuration File

    The vendortemplatefile.csv file contains a mapping of vendor, command template, and icon used.

    Command Template Directory

    The command template directory contains templates for each vendor to specify which commands are issued on the devices immediately after logging in.

    General Show Command File

    The location of the file containing general “show” commands. The default location is in $INSTALLDIR/db/config/shownodecmds. Whatever commands are listed in this file will appear in the drop-down selection box when user issues a “show” command to a device from either the IP/MPLSView Web interface or IP/MPLSView client.

    VPN Show Command File

    Similar to the General Show Command File, this parameter specifies the location of the file in which vpn-related “show” commands are saved. The default location is: $INSTALLDIR/db/config/showvpncmds.

    Ping Device From Device

    To measure connectivity, round trip time (RTT), delay, and packet loss, you can issue a ping operation from one device to another device, or from one device to multiple devices. The round trip time (RTT) is the time from the moment the ping packet is sent to the time a reply is received. After a number of pings, the minimum, maximum, and average round trip time in millisecond is collected, as well as the standard deviation and percentage packet loss.

    1. To access the ping feature, select Tools > Diagnostics > Ping Device From Device (or Ping > Device From Device from the Diagnostics Manager window). Move your cursor to the topology map and notice it is displayed as a cross-hair. Click on the device you want to ping from and then click on the router you want to ping to.

      Note: For a VPN network, the ping only works for a pair (source-destination) of routers within a given VPN. A ping operation to a router outside the source router’s VPN will time out.

    2. After selecting source and destination devices, the following window is displayed, indicating the source and destination devices.

      Figure 137: Ping Device to Device

      Ping Device to Device
    3. The default option for “Ping device to device” is to ping to the destination device’s loopback IP address (Use Loopback IP address). You can optionally change this to the destination device’s management IP address, where the management IP address is the IP address defined in the router profile that is used by the IP/MPLSView server to collect information from the router (Use Management IP address).
    4. Select More Actions > Enter destination IP addresst o enter in a specific IP address of the destination device.
    5. Select More Actions > Choose Source Interface to select the ping source interface
    6. Click on the Options... button if necessary to change the diagnostic timeout from the default of 30 seconds.
    7. Click on the Run button to start the ping.

      Figure 138: Ping Results

      Ping Results

    Advanced Ping

    The advanced ping settings allows the user to customize the number of pings (ping count) to perform, the source or destination interfaces/IP addresses, or to run advanced ping features such as mpls and vpn ping.

    1. To access the advanced settings, select Tools > Diagnostics > Ping Device From Device (or Ping > Device From Device from the Diagnostics Tool window).
    2. Again, select the source and destination devices as for the basic ping.
    3. In the subsequent window, click the Advanced button for the following display. Note that options will vary depending upon the hardware vendor of the selected devices.

      Figure 139: Advanced Settings for Ping

      Advanced Settings for Ping
    4. Select the ping command that you wish to run. Depending upon the selected ping command, different options will be provided below it, corresponding to items between the ‘<‘ and ‘>’ symbols. For example, for the command “ping count <count> <dest-addr> source <src-addr>”, the user will be prompted for a count and given options for the destination address and source address.

    Ping Multiple Devices from Device or Ping Devices from Server

    1. To ping from one device to multiple devices, select Tools > Diagnostics > Ping All Devices From Device.... Move your mouse to the topology map and the cursor will become a crosshair. Click on the desired source device. (Alternatively, select Ping>Multiple Devices from Device... from the Diagnostics Tool window and select the source device.)

      Figure 140: Select Multiple Devices to Ping

      Select Multiple Devices to Ping

      Alternatively, to ping from the IP/MPLSView server to multiple devices to check for connectivity from the IP/MPLSView server to the devices, select Ping>Devices from Server... from the Diagnostics Tool window.)

    2. Note that some of these options are also available from the map. Right-click a device on the map or a device in the map’s Node/Interface List legend. Then select Ping>All from Selected Router or Ping > Selected Router from the IP/MPLSView server].
    3. Select the checkboxes for the devices that will be pinged from the source device or server. To select all devices, select the arrow next to “(All Devices)” and select Check All.
    4. Note that the Loopback IP address is used by default when pinging from device to device, but the Management IP address is used by default when pinging from the server to devices.
    5. The source interface to use for ping can be specified by selecting “Use source interface” and then selecting the source interface from the drop-down.
    6. Click Run to submit the ping request.

      Note: This process may take more time simply because a ping is being performed between the source router and every other router

      Figure 141: Ping from the IP/MPLSView Server to Multiple Devices

      Ping from the IP/MPLSView Server to Multiple Devices

      Figure 142: Ping from One Device to Multiple Devices

      Ping from One Device to Multiple Devices

      A table is displayed indicating the round trip time and packet loss information for each device being pinged.

      Item

      Description

      Target

      The destination router. This is the second device the user selects in the topology map.

      Target IP

      The destination IP address of the ping.

      Min/Max/Avg/Stddev

      The smallest, largest, and average round trip time, respectively, in milliseconds, and the standard deviation.

      Loss Percentage

      The packet loss percentage experienced during the ping operation

    Continuous Ping

    This utility charts the results of continuous pings between one router and another

    1. Select Tools>Diagnostics>Continuous Ping or Ping>Continuous Ping from the Diagnostics Tool.
    2. In the former case, your cursor will become a cross hair. On the Map window, select the source and destination routers by clicking one after the other on the map.

      Figure 143: Continuous Ping Options

      Continuous Ping Options
    3. Select the interval to ping and which IP address to use (Loopback by default).
    4. To specify the source interface or destination IP address, use the More Actions > Choose source interface or More Actions > Enter destination IP address.
    5. To access additional options, such as selecting the source/destination interface or IP address, or vrf, running mpls or vpn ping, or setting the ping count, click the Advanced button.
    6. Click the “Run” button to begin the series of pings.

      Figure 144: Continuous Ping Graph

      Continuous Ping Graph

      By default, ping results are displayed in blue for max, green for avg, and black for min. These are the maximum, minimum, and average ping results. Loss% ( in red) reports the percentage of packets lost.

    7. To zoom into an area, select a rectangle area on the graph by dragging the mouse pointer from an upper left corner to a lower right corner of the rectangle. Select Auto Range > Both Axes to undo the zoom.

      Figure 145: Continuous Ping Chart

      Continuous Ping Chart
    8. To view the data points making up the graph, right-click on the row in the upper half of the Diagnostics Tool and deselect the “Chart View” checkbox.
    9. To stop the continuous ping, right-click on the row in the upper half of the Diagnostics Tool and select “Stop continuous ping.”

    MPLS Ping

    An MPLS ping is used to check that echo requests are sent over the tunnel as MPLS packets with the “ping mpls rsvp lsp-name detail” command.

    The MPLS Ping can also be accessed from the Diagnostics Manager, Ping > Device From Device option, when clicking the Advanced button and selecting the relevant mpls ping command.

    Additionally, the MPLS Ping can be accessed from Network > Elements > Tunnels. Right-click on a tunnel and select “MPLS RSVP Ping.” (Note that for the MPLS ping feature to work, the destination (egress) router must first be configured with 127.0.0.1/32 on the loopback lo0 interface.)

    Figure 146: MPLS Ping Results

    MPLS Ping Results

    Traceroute from Device to Device

    The traceroute utility traces the route of an IP packet from one device to another.

    1. Select Tools > Diagnostics > Trace Route.
    2. Move your cursor to the topology map and you will notice that it has become a cross-hair. Click on the router you want to trace from, then click on the router you want to trace to, or select “Enter destination IP address” to enter in a specific destination IP address.

      Figure 147: Basic Traceroute Options

      Basic Traceroute Options
    3. Use the options in the More Actions drop-down to specify the source interface or destination IP address.
    4. To customize the traceroute command and specify information such as source/destination interface or IP address, click the Advanced button, select the applicable command and options.

      Figure 148: Advanced Traceroute Options

      Advanced Traceroute Options
    5. Click Run to view the traceroute results.

      Figure 149: Traceroute Results

      Traceroute Results
    6. The results indicate the IP addresses at each hop of the path and the time it to for the IP trace packet to travel along this hop.
    7. After the traceroute operation is complete, as indicated by the green circle, right-click on the traceroute entry in the upper table of the Diagnostics tool and select “Show path on the map”.

      Figure 150: Traceroute Path Window

      Traceroute Path Window

      Note: The word “unknown” in the Paths table may indicate that the path traverses an MPLS tunnel.

    Traceroute Multiple Devices from Device

    1. To traceroute multiple devices from a device, select Traceroute > Multiple Devices from Device... Next, select the source device, optional source interface, and multiple destination devices.
    2. Specify whether to traceroute the loopback IP address (default) or Management IP address of the destination devices.
    3. This will create a separate entry in the Diagnostic Manager for each source and destination device pair. For each entry, right-click the row and select “Show path on the map” to view the Path window and the path highlighted on the topology map.

    Ping and Traceroute for Router Groups

    Device Group


    1. To ping within a group, between groups, or between a group and selected routers, a group of routers must first be created. Click Grouping > Device Group.. to create a group.
    2. Click New Group... and enter in the name of the new group. Then select from the list of available devices in the left and click Add->to move them into the group. The filter above the router list can be used to filter for a particular hardware type.

      Figure 151: Diagnostic Group Creation

      Diagnostic Group Creation
    3. To create a diagnostics group using a topology group on the standard map, use the “New from Map...” option and select from the available groups on the topology map. (To create a group on the topology map, select the routers to group and then either click on the grouping icon on the toolbar or right-click over a node and select Grouping > Group Selected. For information on creating a new group, refer to the Reference Guide chapter on the Topology window.) Once the groups are created, click OK.
    4. Select the corresponding ping or traceroute group option from the Ping or Traceroute menus. The following is an example of Ping > Ping between Device Groups.

      Figure 152: Ping from Group1 to Group2

      Ping from Group1 to Group2

      For the traceroute between groups, note that a separate entry will still be created for each traceroute, so that the path can be analyzed on the map via the right-click option, “Show path on the map”.


    Customized Advanced Group


    1. To specify greater detail for the device groups, including the specific interface to use, select Grouping > Customized Advanced Group.

      Figure 153: Customized Advanced Group

      Customized Advanced Group
    2. Click the New Group button and enter in a name of a group and an optional description. (These can be later modified by clicking the Properties button.) Select that group from the Group selection menu. Then click Add to add a new Source Router/Source Interface and Destination Router/Destination Interface pair. Click OK.
    3. To execute the selected ping pairs, select Ping > Ping by Customized Advanced Group, and select the group. The option to select either Management or Loopback IP address is still available in case the destination router’s interface was not specified in the Customized Advanced Group.

      One entry will be created for each source/destination pair from the Customized Advanced Group.

      Figure 154: Ping by Customized Advanced Group

      Ping by Customized Advanced Group

    Customized VPN Diagnostics


    Select Grouping > Customized VPN Diagnostics to create a group for diagnosing a Layer 3 VPN. This will create the necessary source device/interface to destination device/interface pairs to ping between CE and PE and between PE and CE, and from the PE to the local CE loopback.

    Figure 155: VPN Diagnostics Group

    VPN Diagnostics Group

    Customized Diagnostics Group File Format


    Alternatively, these source/destination router/interface pairs can be specified via file. For the live network, it is saved to the /u/wandl/data/.network/diagnosticgroup.x file. The file format for the advanced groups can be one of the following two formats:

    <Group> CUSTOM=<src_device>,<dest_device>,<srcIP>,<destIP>
    <Group> CUSTOM=<src_device>,<dest_device>,<srcintfname>
    (<srcIP>),<destintfname> (<destIP>)
    Customized Diagnostics Group
    #Group_Name Members
    MyDevGroup BEK3640,HKG3640,LAX3640
    MyAdvGroup CUSTOM=HKG3640,LAX3640,Ethernet1/0 (10.111.66.5),Ethernet0/0 (192.10.21.186)
    MyAdvGroup2 CUSTOM=HKG3640,LAX3640,10.111.66.5,192.10.21.186
    L3VPNC100 VPN=checked,PE-local CE Intf,BEK3640,WAS3640,Ethernet3/1.100,10.111.88.6/30,
    Ethernet1/1.100,10.111.88.5,L3VPNC100
    Example for a VPN Diagnostics Group:
    L3VPNC100 VPN=checked,CE-local PE Intf,WAS3640,BEK3640,Ethernet1/1.100,10.111.88.5,
    Ethernet3/1.100,10.111.88.6/30,L3VPNC100
    L3VPNC100 VPN=checked,PE-local CE loopback,BEK3640,WAS3640,Ethernet3/1.100,10.111.88.6/30,
    Loopback0,10.6.6.6,

    You may need to close and reopen the Diagnostic Manager to load in the new file.

    VPN Diagnostics

    VPN ping and traceroute options can be accessed from the Diagnostics Manager, Ping > Device From Device and Traceroute options, when clicking the Advanced button and selecting the relevant vpn ping/traceroute commands.

    Additionally, Virtual Private Network (VPN) diagnostics can be accessed from Network > Services > VPN.

    Figure 156: VPN Summary Window

    VPN Summary Window

    In the VPN window, select the VPN for which you would like to run diagnostics from the left hand pane. To run a traceroute, right-click on a router in the VPN Topology tab on the right hand pane. Next, select the target node. This will open up the Diagnostics Manager with the appropriate advanced traceroute command.

    In the VPN window, select the VPN for which you would like to run diagnostics from the left hand pane and then click the Diagnostics button for the following window. Note that the possible source/destinations are listed in the CE Ping Matrix. The features accessible via the “Diagnostics” button is available for most, but not all, VPN types. Please contact Juniper support if you would like to request a particular feature.

    Note: Through the IP/MPLSView Web interface, basic VPN diagnostics can also be accessed from Live Network > View VPNs.

    Figure 157: VPN Diagnostics for Selected Layer 3 VPN

    VPN Diagnostics for Selected Layer 3 VPN

    Ping and Traceroute


    In the Ping/Trace Route section of the window, select a Source and Destination interface. Then, Click the “Ping“ button. The VPN Ping Results window will appear and ping probes will be issued on the live network. For an explanation of ping results, please refer to Ping Device From Device.

    Click the “Trace Route” button to issue the traceroute command on the live network. The trace route will open the VPN Trace Results window and a Paths window. For an explanation of the traceroute results, please refer to Traceroute from Device to Device.

    Alternatively, the trace route can be accessed via the VPN Topology window: Click on a VPN name in the left pane of the IP VPN window. In the right pane, select the VPN Topology tab. Right-click on the source node and select “Traceroute”. Then click on the second, or destination device in the VPN Topology. You can click on any segment of the path to zoom into that portion of the path on the Main/Standard Map window.


    CE Ping Matrix


    Click the “CE Ping Matrix” button to view a matrix of ping results, in milliseconds, between all Customer Edge (CE) devices in the selected VPN. Please refer to Ping Device From Device for more details.


    MPLS Ping


    To enable the MPLS Ping button, select an entry from the upper right table of the VPN Diagnostics window. Then select MPLS Ping>VPN Instance and enter in a Prefix/Mask.

    Figure 158: MPLS Ping Options

    MPLS Ping Options

    Show CLI Command


    You can also issue various “show” commands on the devices in the live network via the IP VPN window.

    Click on a VPN name in the left pane. In the right pane, select the tab called “Detailed”. A list of nodes/interfaces in the selected VPN will be shown in the table. Select the desired node for which you would like to issue the “show” command. Alternatively, click on “PE Devices” in the left pane tree. In the right pane, a table will display all PE devices in the network. Select the desired one.

    Then, at the bottom of the window, click on the “Actions” button and select “Run CLI” rom the popup menu. This will pop up the Show Command Window for that node. From the drop-down selection box, select the desired “show” command and press the “Go” arrow to the right to issue the command and view the results.

    Note: Because there are numerous “show” commands but only certain ones that each user cares about, it is up to the user to configure the most frequently used show commands in a special IP/MPLSView file. See Configuring the Show Commands for detailed instructions.

    Figure 159: VPN Actions

    VPN Actions

    MIB Browser

    To work with SNMP, network devices utilize a data store called the Management Information Base (MIB), a hierarchical collection of device attributes organized in tree format. Each attribute contains a name, object identifier (numeric value), data type, and indication of whether the value associated with the object can be read from and/or written to. Some attributes are fixed or “hard coded” while others are dynamic values calculated by software running on the device. The MIB Browser enables users to browse MIB details and query devices with snmpget. To access the MIB browser, select Tools > MIB Browser.

    Figure 160: MIB Browser

    MIB Browser

    A number of MIB modules are preloaded into the software, and are listed in the left pane of the MIB Browser. Each module is a collection of the descriptions of all the manageable features.

    To load new MIB subtrees, download the appropriate MIB files from the appropriate router vendor. Then click MIB > Load MIB... to select the MIB file. Note that there may be some dependencies among MIBs in which case certain MIBs need to be loaded first.

    To unload a MIB subtree, select the MIB and click MIB > Unload MIB.To unload all MIBs not originally installed with the software, click MIB > Unload All User MIBs. (This may be desired if there are conflicts between different MIB files.) After unloading MIBs, close and reopen the MIB browser to clear the cache.

    The MIBs can alternately be displayed using the Module or Module Identity field by selecting MIB > Organize > by Module or MIB > Organize > by Module Identity. Additionally, the tree can be organized by OID, by selecting MIB > Organize > by OID as shown below.

    Figure 161: MIB Browser Organized by OID

    MIB Browser Organized by OID

    The MIB Detail tab contains details such as the Object Type, OID, Syntax, Access, Status, and Description while the Access Device tab provides users with a means of querying the router for MIB data. Click the MIB Detail tab and then click any object from the MIB tree to view details about the MIB.

    Different icons and colors are used in the MIB tree to differentiate the object types and statuses. Object types are shown in Table 39.

    Table 39: MIB Browser Object Types

    Object Type

    Icon

    Module (top level) or Object Identifier object type: Folder icon

    Notification object type: Trap/Loud Speaker Icon.

    Notification Group and Object Group object type: Package Icon.

    Compliance object type: Light green circle.

    Table: Grid Icon.

    Table Row: Grid icon with orange row.

    Obsolete or Deprecated status: Yellow ball.

    Not Accessible status: Red ball.

    Textual Convention: Blue square.

    Others: Green ball.


    Obtaining SNMP Mib Information


    1. To obtain the SNMP MIB information from a device, select the Access Device tab and enter in the IP address, or click the magnifying glass to the right of the IP Address field and select a router to automatically populate the IP Address field.
    2. Enter in the Read Community string. If this field is left empty, the default value “public” will be used.
    3. Select the appropriate SNMP version (1, 2c, or 3) by clicking the SNMP button at the bottom of the window. To determine which version of SNMP is supported by the router, check the router’s config file. For SNMP version 3, additional fields can be specified, including User Name, Authentication type and Authentication password, and Privacy type and Privacy password.

      Figure 162: SNMP Version 3 Options

      SNMP Version 3 Options
    4. Select an item from the left pane that you want to collect information for, or search for the item via MIB > Find... (F5) and MIB>Find Next (F3). This will automatically populate the OID in the Access Device tab on the right pane.
    5. If the IP/MPLSView jump server package has been installed and is needed as an intermediate hop before reaching the router, then specify the jump server machine’s IP address as the Proxy IP and 1099 and the Proxy Port.
    6. Click “Retrieve > Get” to get the data for a selected OID. To stepthrough the OIDs, continue clicking “Retrieve > Get Next.” To get all of the child OIDs associated with the selected parent OID, click “Retrieve > Get All (Text)”. The details will be shown in the Results section. To clear the results view, click “Clear.”

      Figure 163: MIB Browser

      MIB Browser
    7. To retrieve every OID within a table click on the table icon and then select “Retrieve > Get All (Table)”. After all the data is collected, it will be displayed in table format.

      Figure 164: Retrieving All OIDs Under ifXEntry

      Retrieving All OIDs Under ifXEntry

    Online Monitoring by SNMP

    1. After the MIB object icon or table icon is selected from the MIB Browser, and the desired IP Address is entered or selected, click the Monitor button
    2. When selecting a table icon, the subsequent window allows you to choose which OID to use as the key.

      Figure 165: MIB Monitoring Object Keys

      MIB Monitoring Object Keys

      Figure 166: MIB Monitoring Objects

      MIB Monitoring Objects
    3. Right-click a column header and select “Check All this Column” to check all the objects in the column.
    4. Click OK to open the following Configuration window.
    5. Indicate the polling interval next to “Monitor every:”
    6. To view the delta per second between periods, instead of the absolute values, check the Delta checkbox.
    7. To show an OID on the chart, check the “Show on Chart” checkbox for that OID
    8. Right-click a column header and select “Check All this Column” to check all the objects in a column.
    9. Object names and OIDs can also be modified by selecting a row, editing the information, and clicking Modify. To add an OID, enter in the Name and OID and then click Add. Click the up arrow next to the Add button for some suggestions.

      Figure 167: Network Monitor by SNMP

      Network Monitor by SNMP
    10. Click Apply to start graphing the data on the chart.
    11. Data points will appear as the chart collects CPU utilization data from the point when the chart was opened. You can stop data collection by clicking the Stop button.

      Figure 168: Network Monitor by SNMP Graph of Deltas

      Network Monitor by SNMP Graph of Deltas
    • To reduce the number of items graphed, go back to the Configuration tab and deselect “Show on Chart” for elements that should be hidden. They will still be included in the Table View tab, which indicates all the collected data.
    • The graph can be saved to an image file by right-clicking the chart and selecting “Save as...”
    • To zoom into an area on the graph, drag a rectangle over a region of the graph using the mouse. To zoom to fit, right-click the graph and select “Auto Range>Both Axes
    • Click the Table View tab to view the data in table format. The save button in the lower left corner can be used to save the table to a CSV file that can be opened in Microsoft Excel
    • The Export button can be used to save the Configuration data to an XML file so that it can later be imported.

    Configuring SNMP Trap Handling for the Fault Management Module

    The MIB Browser can also be used in conjunction with the Event Browser to enable handling for new trap types. To use this feature, select MIB > Enable SNMP Config Editing

    Live Status Window

    The Live Status window displays the status or states of Links, Tunnels, BGP Neighbor, ISIS Adjacency, or OSPF Neighbors. Accessed by right-clicking on the Topology Map, selecting Live Status Check, and choosing the category to display. Multiple categories can be displayed in separate tabs with the add icon.

    Figure 169: Live Status Window

    Live Status Window

    Live Link Status Check


    The Live Link Status Check window displays the Admin and Operation Status of the links in real time via SNMP collection. It is accessed by right-clicking on the Topology Map and selecting Live Link Status Check. Select the desired Links using the checkboxes and press Start to begin the SNMP collection.

    Figure 170: Live Link Status Check

    Live Link Status Check
    • Admin Status returns the value from MIB ifTable OID ifAdminStatus: up, down, testing. If NodeA and NodeZ return different values, then both statuses will be displayed as “NodeA, NodeZ.”
    • Oper Status returns the value from MIB ifTable OID ifOperStatus: up, down, testing, unknown, dormant, notPresent, lowerLayerDown. If NodeA and NodeZ return different values, then both statuses will be displayed as “NodeA, NodeZ.”
    • Last Updated is the last collection time.

    Live Tunnel Status Check


    The Live Tunnel Status check window displays the Admin and Operation status of the tunnels in real time via SNMP collection. It is accessed from NetInfo > Tunnels window by right-clicking in the tunnel table and selecting Live Tunnel Status Check. Select the desired Tunnels using the checkboxes and press Start to begin the SNMP collection.

    Figure 171: Live Tunnel Status Check

    Live Tunnel Status Check
    • Role returns the value from MIB OID mplsTunnelRole. This value signifies the role that this tunnel entry/instance represents. This value MUST be set to head(1) at the originating point of the tunnel. This value MUST be set to transit(2) at transit points along the tunnel, if transit points are supported. This value MUST be set to tail(3) at the terminating point of the tunnel if tunnel tails are supported. The value headTail(4) is provided for tunnels that begin and end on the same LSR.
    • Admin Status returns the value from MIB OID mplsTunnelAdminStatus. Indicates the desired operational status of this tunnel.
    • Oper Status returns the value from MIB OID mplsTunnelOperStatus. Indicates the actual operational status of this tunnel, which is typically but not limited to, a function of the state of individual segments of this tunnel.
    • mplsTunnelTotalUpTime returns the value from MIB OID mplsTunnelTotalUpTime. This value represents the aggregate up time for all instances of this tunnel, if available. If this value is unavailable, it MUST return a value of 0.
    • LastUpdated is the last collection time

    Performance Report Manager

    The Performance Report Manager displays reports specifically related to device performance and network performance of the Live network. Accessed from the Performance > Performance Reports menu, the following reports are available if the appropriate tasks are scheduled in Task Manager. These reports are also available from the Web under Reports > View Summary Reports menu.

    Device

    Report

    Task to Collect

    Device

    System Uptime

    Device SNMP

    Device

    CPU Usage

    Device SNMP

    Device

    CPU Temperature

    Device SNMP

    Device

    Memory Usage

    Device SNMP

    Network

    Ping

    Device Ping

    Network

    LSP Ping

    LSP Ping

    Network

    SLA

    Device SLA

    Network

    Link Latency

    Link Latency

    Figure 172: Performance Report Manager

    Performance Report Manager

    Troubleshooting Performance and Diagnostics

    If ping and traceroute are not working from the graphical interface, try to login to the IP/MPLSView server using a telnet or ssh window. As root user, try to ping and traceroute the relevant routers. If this does not work, check the Getting Started Guide “System Administration” chapter’s section on setting up routes to the router network and troubleshooting ping/traceroute issues.

    For problems accessing devices to execute show commands, check the file /u/wandl/data/.TaskManager/tmp/.diag to see what IP address is being used. Additionally, check that the show command is properly set to use the right program, telnet or ssh, in the diagnostics configuration settings described in Diagnostics Configuration Settings. To customize diagnostics settings, log into the Web Portal as the admin user and select Admin > Change Diag Settings.

    If you cannot connect to the router, run ping, traceroute, or CPU Utilization, from the application, try scheduling a live network to populate the /u/wandl/data/.TaskManager/tmp/.diag. If that does not help, copy a router profile from /u/wandl/data/.TaskManager/profile to /u/wandl/data/.TaskManager/tmp/.diag and restart the server using ./stop_mplsview and ./startup_mplsview commands in /u/wandl/bin.

    If you have TACACS, make sure to select that under Diagnostic Login Type in the diagnostics configuration settings described in Diagnostics Configuration Settings.

    Modified: 2015-12-29