ON THIS PAGE
Base Configurations
This Appendix lists the base configurations on all devices (refer to EVPN Base Configuration in DC Fabric Topology chapter). To quickly configure the boxes and get started, copy and paste the configurations on the devices as indicated.
Base Configuration on SPINE-1
set interfaces xe-0/0/0 description “TO BL-1”
set interfaces xe-0/0/0 unit 0 family inet address 4.4.4.2/24
set interfaces xe-0/0/1 description “TO BL-2”
set interfaces xe-0/0/1 unit 0 family inet address 6.6.6.2/24
set interfaces xe-0/0/2 description “TO LEAF-1”
set interfaces xe-0/0/2 unit 0 family inet address 8.8.8.1/24
set interfaces xe-0/0/3 description “TO LEAF-2”
set interfaces xe-0/0/3 unit 0 family inet address 9.9.9.1/24
set interfaces xe-0/0/4 description “TO LEAF-3”
set interfaces xe-0/0/4 unit 0 family inet address 10.10.10.1/24
set interfaces xe-0/0/5 description “TO LEAF-4”
set interfaces xe-0/0/5 unit 0 family inet address 11.11.11.1/24
set interfaces xe-0/0/6 description “TO LEAF-5”
set interfaces xe-0/0/6 unit 0 family inet address 12.12.12.1/24
set interfaces lo0 unit 0 family inet address 103.103.103.103/32
set policy-options policy-statement EXPORT-LO term 1 from
protocol direct
set policy-options policy-statement EXPORT-LO term 1 then
accept
set routing-options router-id 103.103.103.103
set routing-options autonomous-system 65003
set protocols bgp group UNDERLAY family inet any
set protocols bgp group UNDERLAY export EXPORT-LO
set protocols bgp group UNDERLAY local-as 65003
set protocols bgp group UNDERLAY neighbor 4.4.4.1 description
BL-1
set protocols bgp group UNDERLAY neighbor 4.4.4.1 peer-as
65001
set protocols bgp group UNDERLAY neighbor 6.6.6.1 description
BL-2
set protocols bgp group UNDERLAY neighbor 6.6.6.1 peer-as
65002
set protocols bgp group UNDERLAY neighbor 8.8.8.2 description
LEAF-1
set protocols bgp group UNDERLAY neighbor 8.8.8.2 peer-as
65005
set protocols bgp group UNDERLAY neighbor 9.9.9.2 description
LEAF-2
set protocols bgp group UNDERLAY neighbor 9.9.9.2 peer-as
65006
set protocols bgp group UNDERLAY neighbor 10.10.10.2 description
LEAF-3
set protocols bgp group UNDERLAY neighbor 10.10.10.2 peer-as
65007
set protocols bgp group UNDERLAY neighbor 11.11.11.2 description
LEAF-4
set protocols bgp group UNDERLAY neighbor 11.11.11.2 peer-as
65008
set protocols bgp group UNDERLAY neighbor 12.12.12.2 description
LEAF-5
set protocols bgp group UNDERLAY neighbor 12.12.12.2 peer-as
65009
Base Configuration on SPINE-2
set interfaces xe-0/0/0 description “TO BL-1
set interfaces xe-0/0/0 unit 0 family inet address 5.5.5.2/24
set interfaces xe-0/0/1 description “TO BL-2”
set interfaces xe-0/0/1 unit 0 family inet address 7.7.7.2/24
set interfaces xe-0/0/2 description “TO LEAF-1”
set interfaces xe-0/0/2 unit 0 family inet address 13.13.13.1/24
set interfaces xe-0/0/3 description “TO LEAF-2”
set interfaces xe-0/0/3 unit 0 family inet address 14.14.14.1/24
set interfaces xe-0/0/4 description “TO LEAF-3”
set interfaces xe-0/0/4 unit 0 family inet address 15.15.15.1/24
set interfaces xe-0/0/5 description “TO LEAF-4”
set interfaces xe-0/0/5 unit 0 family inet address 16.16.16.1/24
set interfaces xe-0/0/6 description “TO LEAF-5”
set interfaces xe-0/0/6 unit 0 family inet address 17.17.17.1/24
set interfaces lo0 unit 0 family inet address 104.104.104.104/32
set policy-options policy-statement EXPORT-LO term 1 from
protocol direct
set policy-options policy-statement EXPORT-LO term 1 then
accept
set routing-options router-id 104.104.104.104
set routing-options autonomous-system 65004
set protocols bgp group UNDERLAY family inet any
set protocols bgp group UNDERLAY export EXPORT-LO
set protocols bgp group UNDERLAY local-as 65004
set protocols bgp group UNDERLAY neighbor 5.5.5.1 description
BL-1
set protocols bgp group UNDERLAY neighbor 5.5.5.1 peer-as
65001
set protocols bgp group UNDERLAY neighbor 7.7.7.1 description
BL-2
set protocols bgp group UNDERLAY neighbor 7.7.7.1 peer-as
65002
set protocols bgp group UNDERLAY neighbor 13.13.13.2 description
LEAF-1
set protocols bgp group UNDERLAY neighbor 13.13.13.2 peer-as
65005
set protocols bgp group UNDERLAY neighbor 14.14.14.2 description
LEAF-2
set protocols bgp group UNDERLAY neighbor 14.14.14.2 peer-as
65006
set protocols bgp group UNDERLAY neighbor 15.15.15.2 description
LEAF-3
set protocols bgp group UNDERLAY neighbor 15.15.15.2 peer-as
65007
set protocols bgp group UNDERLAY neighbor 16.16.16.2 description
LEAF-4
set protocols bgp group UNDERLAY neighbor 16.16.16.2 peer-as
65008
set protocols bgp group UNDERLAY neighbor 17.17.17.2 description
LEAF-5
set protocols bgp group UNDERLAY neighbor 17.17.17.2 peer-as
65009
Base Configuration on LEAF-1
set chassis aggregated-devices ethernet deviCE-3ount 2
set interfaces xe-0/0/0 description “TO SPINE-1”
set interfaces xe-0/0/0 unit 0 family inet address 8.8.8.2/24
set interfaces xe-0/0/1 description “TO SPINE-2”
set interfaces xe-0/0/1 unit 0 family inet address 13.13.13.2/24
set interfaces xe-0/0/2 gigether-options 802.3ad ae0
set interfaces xe-0/0/3 gigether-options 802.3ad ae1
set interfaces xe-0/0/4 description “TO Host-2”
set interfaces xe-0/0/4 unit 0 family ethernet-switching
interface-mode trunk
set interfaces xe-0/0/4 unit 0 family ethernet-switching
VLAN members VLAN-101
set interfaces xe-0/0/4 unit 0 family ethernet-switching
VLAN members VLAN-102
set interfaces ae0 description “TO CE-1”
set interfaces ae0 esi 00:11:11:11:11:11:11:11:11:11
set interfaces ae0 esi all-active
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic
fast
set interfaces ae0 aggregated-ether-options lacp system-id
00:11:11:11:11:11
set interfaces ae0 unit 0 family ethernet-switching interface-mode
trunk
set interfaces ae0 unit 0 family ethernet-switching VLAN
members VLAN-101
set interfaces ae0 unit 0 family ethernet-switching VLAN
members VLAN-102
set interfaces ae1 description “TO CE-2”
set interfaces ae1 esi 00:22:22:22:22:22:22:22:22:22
set interfaces ae1 esi all-active
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp periodic
fast
set interfaces ae1 aggregated-ether-options lacp system-id
00:22:22:22:22:22
set interfaces ae1 unit 0 family ethernet-switching interface-mode
trunk
set interfaces ae1 unit 0 family ethernet-switching VLAN
members VLAN-101
set interfaces ae1 unit 0 family ethernet-switching VLAN
members VLAN-102
set interfaces lo0 unit 0 family inet address 105.105.105.105/32
set policy-options policy-statement EXPORT-LO term 1 from
protocol direct
set policy-options policy-statement EXPORT-LO term 1 then
accept
set routing-options router-id 105.105.105.105
set routing-options autonomous-system 65005
set protocols bgp group UNDERLAY family inet any
set protocols bgp group UNDERLAY export EXPORT-LO
set protocols bgp group UNDERLAY local-as 65005
set protocols bgp group UNDERLAY neighbor 8.8.8.1 description
SPINE-1
set protocols bgp group UNDERLAY neighbor 8.8.8.1 peer-as
65003
set protocols bgp group UNDERLAY neighbor 13.13.13.1 description
SPINE-2
set protocols bgp group UNDERLAY neighbor 13.13.13.1 peer-as
65004
set protocols bgp group OVERLAY type internal
set protocols bgp group OVERLAY local-address 105.105.105.105
set protocols bgp group OVERLAY family evpn signaling
set protocols bgp group OVERLAY local-as 65000
set protocols bgp group OVERLAY neighbor 101.101.101.101
description BL-1
set protocols bgp group OVERLAY neighbor 102.102.102.102
description BL-2
set protocols bgp group OVERLAY neighbor 106.106.106.106
description LEAF-2
set protocols bgp group OVERLAY neighbor 107.107.107.107
description LEAF-3
set protocols bgp group OVERLAY neighbor 108.108.108.108
description LEAF-4
set protocols bgp group OVERLAY neighbor 109.109.109.109
description LEAF-5
set protocols evpn encapsulation vxlan
set protocols evpn extended-vni-list 101
set protocols evpn extended-vni-list 102
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 105.105.105.105:1
set switch-options vrf-target target:1:1
set vlans VLAN-101 VLAN-id 101
set vlans VLAN-101 vxlan vni 101
set vlans VLAN-102 VLAN-id 102
set vlans VLAN-102 vxlan vni 102
Base Configuration on LEAF-2
set chassis aggregated-devices ethernet deviCE-3ount 2
set interfaces xe-0/0/0 description “TO SPINE-1”
set interfaces xe-0/0/0 unit 0 family inet address 9.9.9.2/24
set interfaces xe-0/0/1 description “TO SPINE-2”
set interfaces xe-0/0/1 unit 0 family inet address 14.14.14.2/24
set interfaces xe-0/0/2 gigether-options 802.3ad ae0
set interfaces xe-0/0/3 gigether-options 802.3ad ae1
set interfaces xe-0/0/4 description “TO Host-4”
set interfaces xe-0/0/4 unit 0 family ethernet-switching
interface-mode trunk
set interfaces xe-0/0/4 unit 0 family ethernet-switching
VLAN members VLAN-101
set interfaces xe-0/0/4 unit 0 family ethernet-switching
VLAN members VLAN-102
set interfaces ae0 description “TO CE-1”
set interfaces ae0 esi 00:11:11:11:11:11:11:11:11:11
set interfaces ae0 esi all-active
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic
fast
set interfaces ae0 aggregated-ether-options lacp system-id
00:11:11:11:11:11
set interfaces ae0 unit 0 family ethernet-switching interface-mode
trunk
set interfaces ae0 unit 0 family ethernet-switching VLAN
members VLAN-101
set interfaces ae0 unit 0 family ethernet-switching VLAN
members VLAN-102
set interfaces ae1 description “TO CE-2”
set interfaces ae1 esi 00:22:22:22:22:22:22:22:22:22
set interfaces ae1 esi all-active
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp periodic
fast
set interfaces ae1 aggregated-ether-options lacp system-id
00:22:22:22:22:22
set interfaces ae1 unit 0 family ethernet-switching interface-mode
trunk
set interfaces ae1 unit 0 family ethernet-switching VLAN
members VLAN-101
set interfaces ae1 unit 0 family ethernet-switching VLAN
members VLAN-102
set interfaces lo0 unit 0 family inet address 106.106.106.106/32
set policy-options policy-statement EXPORT-LO term 1 from
protocol direct
set policy-options policy-statement EXPORT-LO term 1 then
accept
set routing-options router-id 106.106.106.106
set routing-options autonomous-system 65006
set protocols bgp group UNDERLAY family inet any
set protocols bgp group UNDERLAY export EXPORT-LO
set protocols bgp group UNDERLAY local-as 65006
set protocols bgp group UNDERLAY neighbor 9.9.9.1 description
SPINE-1
set protocols bgp group UNDERLAY neighbor 9.9.9.1 peer-as
65003
set protocols bgp group UNDERLAY neighbor 14.14.14.1 description
SPINE-2
set protocols bgp group UNDERLAY neighbor 14.14.14.1 peer-as
65004
set protocols bgp group OVERLAY type internal
set protocols bgp group OVERLAY local-address 106.106.106.106
set protocols bgp group OVERLAY family evpn signaling
set protocols bgp group OVERLAY local-as 65000
set protocols bgp group OVERLAY neighbor 101.101.101.101
description BL-1
set protocols bgp group OVERLAY neighbor 102.102.102.102
description BL-2
set protocols bgp group OVERLAY neighbor 105.105.105.105
description LEAF-1
set protocols bgp group OVERLAY neighbor 107.107.107.107
description LEAF-3
set protocols bgp group OVERLAY neighbor 108.108.108.108
description LEAF-4
set protocols bgp group OVERLAY neighbor 109.109.109.109
description LEAF-5
set protocols evpn encapsulation vxlan
set protocols evpn extended-vni-list 101
set protocols evpn extended-vni-list 102
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 106.106.106.106:1
set switch-options vrf-target target:1:1
set vlans VLAN-101 VLAN-id 101
set vlans VLAN-101 vxlan vni 101
set vlans VLAN-102 VLAN-id 102
set vlans VLAN-102 vxlan vni 102
Base Configuration on LEAF-3
set chassis aggregated-devices ethernet deviCE-3ount 2
set interfaces xe-0/0/0 description “TO SPINE-1”
set interfaces xe-0/0/0 unit 0 family inet address 10.10.10.2/24
set interfaces xe-0/0/1 description “TO SPINE-2”
set interfaces xe-0/0/1 unit 0 family inet address 15.15.15.2/24
set interfaces xe-0/0/2 gigether-options 802.3ad ae0
set interfaces ae0 description “TO CE-3”
set interfaces ae0 esi 00:33:33:33:33:33:33:33:33:33
set interfaces ae0 esi all-active
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic
fast
set interfaces ae0 aggregated-ether-options lacp system-id
00:33:33:33:33:33
set interfaces ae0 unit 0 family ethernet-switching interface-mode
trunk
set interfaces ae0 unit 0 family ethernet-switching VLAN
members VLAN-101
set interfaces ae0 unit 0 family ethernet-switching VLAN
members VLAN-102
set interfaces lo0 unit 0 family inet address 107.107.107.107/32
set policy-options policy-statement EXPORT-LO term 1 from
protocol direct
set policy-options policy-statement EXPORT-LO term 1 then
accept
set routing-options router-id 107.107.107.107
set routing-options autonomous-system 65007
set protocols bgp group UNDERLAY family inet any
set protocols bgp group UNDERLAY export EXPORT-LO
set protocols bgp group UNDERLAY local-as 65007
set protocols bgp group UNDERLAY neighbor 10.10.10.1 description
SPINE-1
set protocols bgp group UNDERLAY neighbor 10.10.10.1 peer-as
65003
set protocols bgp group UNDERLAY neighbor 15.15.15.1 description
SPINE-2
set protocols bgp group UNDERLAY neighbor 15.15.15.1 peer-as
65004
set protocols bgp group OVERLAY type internal
set protocols bgp group OVERLAY local-address 107.107.107.107
set protocols bgp group OVERLAY family evpn signaling
set protocols bgp group OVERLAY local-as 65000
set protocols bgp group OVERLAY neighbor 101.101.101.101
description BL-1
set protocols bgp group OVERLAY neighbor 102.102.102.102
description BL-2
set protocols bgp group OVERLAY neighbor 105.105.105.105
description LEAF-1
set protocols bgp group OVERLAY neighbor 106.106.106.106
description LEAF-2
set protocols bgp group OVERLAY neighbor 108.108.108.108
description LEAF-4
set protocols bgp group OVERLAY neighbor 109.109.109.109
description LEAF-5
set protocols evpn encapsulation vxlan
set protocols evpn extended-vni-list 101
set protocols evpn extended-vni-list 102
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 107.107.107.107:1
set switch-options vrf-target target:1:1
set vlans VLAN-101 VLAN-id 101
set vlans VLAN-101 vxlan vni 101
set vlans VLAN-102 VLAN-id 102
set vlans VLAN-102 vxlan vni 102
Base Configuration on LEAF-4
set chassis aggregated-devices ethernet deviCE-3ount 2
set interfaces xe-0/0/0 description “TO SPINE-1”
set interfaces xe-0/0/0 unit 0 family inet address 11.11.11.2/24
set interfaces xe-0/0/1 description “TO SPINE-2”
set interfaces xe-0/0/1 unit 0 family inet address 16.16.16.2/24
set interfaces xe-0/0/2 gigether-options 802.3ad ae0
set interfaces xe-0/0/3 description “TO Host-6”
set interfaces xe-0/0/3 unit 0 family ethernet-switching
interface-mode trunk
set interfaces xe-0/0/3 unit 0 family ethernet-switching
VLAN members VLAN-101
set interfaces xe-0/0/3 unit 0 family ethernet-switching
VLAN members VLAN-102
set interfaces ae0 description “TO CE-3”
set interfaces ae0 esi 00:33:33:33:33:33:33:33:33:33
set interfaces ae0 esi all-active
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic
fast
set interfaces ae0 aggregated-ether-options lacp system-id
00:33:33:33:33:33
set interfaces ae0 unit 0 family ethernet-switching interface-mode
trunk
set interfaces ae0 unit 0 family ethernet-switching VLAN
members VLAN-101
set interfaces ae0 unit 0 family ethernet-switching VLAN
members VLAN-102
set interfaces lo0 unit 0 family inet address 108.108.108.108/32
set policy-options policy-statement EXPORT-LO term 1 from
protocol direct
set policy-options policy-statement EXPORT-LO term 1 then
accept
set routing-options router-id 108.108.108.108
set routing-options autonomous-system 65008
set protocols bgp group UNDERLAY family inet any
set protocols bgp group UNDERLAY export EXPORT-LO
set protocols bgp group UNDERLAY local-as 65008
set protocols bgp group UNDERLAY neighbor 11.11.11.1 description
SPINE-1
set protocols bgp group UNDERLAY neighbor 11.11.11.1 peer-as
65003
set protocols bgp group UNDERLAY neighbor 16.16.16.1 description
SPINE-2
set protocols bgp group UNDERLAY neighbor 16.16.16.1 peer-as
65004
set protocols bgp group OVERLAY type internal
set protocols bgp group OVERLAY local-address 108.108.108.108
set protocols bgp group OVERLAY family evpn signaling
set protocols bgp group OVERLAY local-as 65000
set protocols bgp group OVERLAY neighbor 101.101.101.101
description BL-1
set protocols bgp group OVERLAY neighbor 102.102.102.102
description BL-2
set protocols bgp group OVERLAY neighbor 105.105.105.105
description LEAF-1
set protocols bgp group OVERLAY neighbor 106.106.106.106
description LEAF-2
set protocols bgp group OVERLAY neighbor 107.107.107.107
description LEAF-3
set protocols bgp group OVERLAY neighbor 109.109.109.109
description LEAF-5
set protocols evpn encapsulation vxlan
set protocols evpn extended-vni-list 101
set protocols evpn extended-vni-list 102
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 108.108.108.108:1
set switch-options vrf-target target:1:1
set vlans VLAN-101 VLAN-id 101
set vlans VLAN-101 vxlan vni 101
set vlans VLAN-102 VLAN-id 102
set vlans VLAN-102 vxlan vni 102
Base Configuration on LEAF-5
set interfaces xe-0/0/0 description “TO SPINE-1”
set interfaces xe-0/0/0 unit 0 family inet address 12.12.12.2/24
set interfaces xe-0/0/1 description “TO SPINE-2”
set interfaces xe-0/0/1 unit 0 family inet address 17.17.17.2/24
set interfaces xe-0/0/2 description “TO Host-7”
set interfaces xe-0/0/2 unit 0 family ethernet-switching
interface-mode trunk
set interfaces xe-0/0/2 unit 0 family ethernet-switching
VLAN members VLAN-102
set interfaces xe-0/0/2 unit 0 family ethernet-switching
filter input SH-INGRESS
set interfaces xe-0/0/2 unit 0 family ethernet-switching
filter output SH-EGRESS
set interfaces lo0 unit 0 family inet address 109.109.109.109/32
set policy-options prefix-list MCAST-GROUP 225.1.1.1/32
set policy-options policy-statement EXPORT-LO term 1 from
protocol direct
set policy-options policy-statement EXPORT-LO term 1 then
accept
set firewall family ethernet-switching filter SH-INGRESS
term 1 from destination-prefix-list MCAST-GROUP
set firewall family ethernet-switching filter SH-INGRESS
term 1 then accept
set firewall family ethernet-switching filter SH-INGRESS
term 1 then count SH-INGRESS-COUNTER
set firewall family ethernet-switching filter SH-INGRESS
term 2 then accept
set firewall family ethernet-switching filter SH-EGRESS
term 1 from destination-prefix-list MCAST-GROUP
set firewall family ethernet-switching filter SH-EGRESS
term 1 then accept
set firewall family ethernet-switching filter SH-EGRESS
term 1 then count SH-EGRESS-COUNTER
set firewall family ethernet-switching filter SH-EGRESS
term 2 then accept
set routing-options router-id 109.109.109.109
set routing-options autonomous-system 65009
set protocols bgp group UNDERLAY family inet any
set protocols bgp group UNDERLAY export EXPORT-LO
set protocols bgp group UNDERLAY local-as 65009
set protocols bgp group UNDERLAY neighbor 12.12.12.1 description
SPINE-1
set protocols bgp group UNDERLAY neighbor 12.12.12.1 peer-as
65003
set protocols bgp group UNDERLAY neighbor 17.17.17.1 description
SPINE-2
set protocols bgp group UNDERLAY neighbor 17.17.17.1 peer-as
65004
set protocols bgp group OVERLAY type internal
set protocols bgp group OVERLAY local-address 109.109.109.109
set protocols bgp group OVERLAY family evpn signaling
set protocols bgp group OVERLAY local-as 65000
set protocols bgp group OVERLAY neighbor 101.101.101.101
description BL-1
set protocols bgp group OVERLAY neighbor 102.102.102.102
description BL-2
set protocols bgp group OVERLAY neighbor 105.105.105.105
description LEAF-1
set protocols bgp group OVERLAY neighbor 106.106.106.106
description LEAF-2
set protocols bgp group OVERLAY neighbor 107.107.107.107
description LEAF-3
set protocols bgp group OVERLAY neighbor 108.108.108.108
description LEAF-4
set protocols bgp group OVERLAY neighbor 103.103.103.103
description SPINE-1
set protocols bgp group OVERLAY neighbor 104.104.104.104
description SPINE-2
set protocols evpn encapsulation vxlan
set protocols evpn extended-vni-list 102
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 109.109.109.109:1
set switch-options vrf-target target:1:1
set vlans VLAN-102 VLAN-id 102
set vlans VLAN-102 vxlan vni 102
Base Configuration on BL-1
set interfaces xe-0/0/1 description “TO SPINE-1”
set interfaces xe-0/0/1 unit 0 family inet address 4.4.4.1/24
set interfaces xe-0/0/2 description “TO SPINE-2”
set interfaces xe-0/0/2 unit 0 family inet address 5.5.5.1/24
set interfaces irb unit 101 virtual-gateway-accept-data
set interfaces irb unit 101 virtual-gateway-esi 00:66:66:66:66:66:66:66:66:66
set interfaces irb unit 101 virtual-gateway-esi all-active
set interfaces irb unit 101 family inet address 18.18.18.1/24
virtual-gateway-address 18.18.18.100
set interfaces irb unit 102 virtual-gateway-accept-data
set interfaces irb unit 102 virtual-gateway-esi 00:77:77:77:77:77:77:77:77:77
set interfaces irb unit 102 virtual-gateway-esi all-active
set interfaces irb unit 102 family inet address 19.19.19.1/24
virtual-gateway-address 19.19.19.100
set interfaces lo0 unit 0 family inet address 101.101.101.101/32
set interfaces lo0 unit 1 family inet address 101.101.101.102/32
set policy-options policy-statement EXPORT-LO term 1 from
protocol direct
set policy-options policy-statement EXPORT-LO term 1 then
accept
set routing-instances VRF-1 instance-type virtual-router
set routing-instances VRF-1 interface irb.101
set routing-instances VRF-1 interface irb.102
set routing-instances VRF-1 interface lo0.1
set routing-instances VRF-1 protocols pim rp local address
101.101.101.102
set routing-instances VRF-1 protocols pim interface all
mode sparse
set routing-options router-id 101.101.101.101
set routing-options autonomous-system 65001
set protocols bgp group UNDERLAY family inet any
set protocols bgp group UNDERLAY export EXPORT-LO
set protocols bgp group UNDERLAY local-as 65001
set protocols bgp group UNDERLAY neighbor 4.4.4.2 description
SPINE-1
set protocols bgp group UNDERLAY neighbor 4.4.4.2 peer-as
65003
set protocols bgp group UNDERLAY neighbor 5.5.5.2 description
SPINE-2
set protocols bgp group UNDERLAY neighbor 5.5.5.2 peer-as
65004
set protocols bgp group OVERLAY type internal
set protocols bgp group OVERLAY local-address 101.101.101.101
set protocols bgp group OVERLAY family evpn signaling
set protocols bgp group OVERLAY local-as 65000
set protocols bgp group OVERLAY neighbor 102.102.102.102
description BL-2
set protocols bgp group OVERLAY neighbor 105.105.105.105
description LEAF-1
set protocols bgp group OVERLAY neighbor 106.106.106.106
description LEAF-2
set protocols bgp group OVERLAY neighbor 107.107.107.107
description LEAF-3
set protocols bgp group OVERLAY neighbor 108.108.108.108
description LEAF-4
set protocols bgp group OVERLAY neighbor 109.109.109.109
description LEAF-5
set protocols evpn encapsulation vxlan
set protocols evpn default-gateway no-gateway-community
set protocols evpn extended-vni-list 101
set protocols evpn extended-vni-list 102
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 101.101.101.101:1
set switch-options vrf-target target:1:1
set vlans VLAN-101 VLAN-id 101
set vlans VLAN-101 l3-interface irb.101
set vlans VLAN-101 vxlan vni 101
set vlans VLAN-102 VLAN-id 102
set vlans VLAN-102 l3-interface irb.102
set vlans VLAN-102 vxlan vni 102
Base Configuration on BL-2
set interfaces xe-0/0/1 description “TO SPINE-1”
set interfaces xe-0/0/1 unit 0 family inet address 6.6.6.1/24
set interfaces xe-0/0/2 description “TO SPINE-2”
set interfaces xe-0/0/2 unit 0 family inet address 7.7.7.1/24
set interfaces irb unit 101 virtual-gateway-accept-data
set interfaces irb unit 101 virtual-gateway-esi 00:66:66:66:66:66:66:66:66:66
set interfaces irb unit 101 virtual-gateway-esi all-active
set interfaces irb unit 101 family inet address 18.18.18.2/24
virtual-gateway-address 18.18.18.100
set interfaces irb unit 102 virtual-gateway-accept-data
set interfaces irb unit 102 virtual-gateway-esi 00:77:77:77:77:77:77:77:77:77
set interfaces irb unit 102 virtual-gateway-esi all-active
set interfaces irb unit 102 family inet address 19.19.19.2/24
virtual-gateway-address 19.19.19.100
set interfaces lo0 unit 0 family inet address 102.102.102.102/32
set interfaces lo0 unit 1 family inet address 102.102.102.103/32
set policy-options policy-statement EXPORT-LO term 1 from
protocol direct
set policy-options policy-statement EXPORT-LO term 1 then
accept
set routing-instances VRF-1 instance-type virtual-router
set routing-instances VRF-1 interface irb.101
set routing-instances VRF-1 interface irb.102
set routing-instances VRF-1 interface lo0.1
set routing-instances VRF-1 protocols pim rp local address
102.102.102.103
set routing-instances VRF-1 protocols pim interface all
mode sparse
set routing-options router-id 102.102.102.102
set routing-options autonomous-system 65002
set protocols bgp group UNDERLAY family inet any
set protocols bgp group UNDERLAY export EXPORT-LO
set protocols bgp group UNDERLAY local-as 65002
set protocols bgp group UNDERLAY neighbor 6.6.6.2 description
SPINE-1
set protocols bgp group UNDERLAY neighbor 6.6.6.2 peer-as
65003
set protocols bgp group UNDERLAY neighbor 7.7.7.2 description
SPINE-2
set protocols bgp group UNDERLAY neighbor 7.7.7.2 peer-as
65004
set protocols bgp group OVERLAY type internal
set protocols bgp group OVERLAY local-address 102.102.102.102
set protocols bgp group OVERLAY family evpn signaling
set protocols bgp group OVERLAY local-as 65000
set protocols bgp group OVERLAY neighbor 101.101.101.101
description BL-1
set protocols bgp group OVERLAY neighbor 105.105.105.105
description LEAF-1
set protocols bgp group OVERLAY neighbor 106.106.106.106
description LEAF-2
set protocols bgp group OVERLAY neighbor 107.107.107.107
description LEAF-3
set protocols bgp group OVERLAY neighbor 108.108.108.108
description LEAF-4
set protocols bgp group OVERLAY neighbor 109.109.109.109
description LEAF-5
set protocols evpn encapsulation vxlan
set protocols evpn default-gateway no-gateway-community
set protocols evpn extended-vni-list 101
set protocols evpn extended-vni-list 102
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 102.102.102.102:1
set switch-options vrf-target target:1:1
set vlans VLAN-101 VLAN-id 101
set vlans VLAN-101 l3-interface irb.101
set vlans VLAN-101 vxlan vni 101
set vlans VLAN-102 VLAN-id 102
set vlans VLAN-102 l3-interface irb.102
set vlans VLAN-102 vxlan vni 102
Base Configuration on CE-1
set chassis aggregated-devices ethernet deviCE-3ount 1
set interfaces ge-0/0/0 description “TO Host-1”
set interfaces ge-0/0/0 unit 0 family bridge interface-mode
trunk
set interfaces ge-0/0/0 unit 0 family bridge VLAN-id-list
101
set interfaces ge-0/0/0 unit 0 family bridge VLAN-id-list
102
set interfaces ge-0/0/1 gigether-options 802.3ad ae0
set interfaces ge-0/0/2 gigether-options 802.3ad ae0
set interfaces ae0 description “TO LEAF-1_LEAF-2”
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic
fast
set interfaces ae0 unit 0 family bridge interface-mode
trunk
set interfaces ae0 unit 0 family bridge VLAN-id-list 101
set interfaces ae0 unit 0 family bridge VLAN-id-list 102
set bridge-domains BD-101 domain-type bridge
set bridge-domains BD-101 VLAN-id 101
set bridge-domains BD-102 domain-type bridge
set bridge-domains BD-102 VLAN-id 102
Base Configuration on CE-2
set chassis aggregated-devices ethernet deviCE-3ount 1
set interfaces ge-0/0/0 description “TO Host-3”
set interfaces ge-0/0/0 unit 0 family bridge interface-mode
trunk
set interfaces ge-0/0/0 unit 0 family bridge VLAN-id-list
101
set interfaces ge-0/0/0 unit 0 family bridge VLAN-id-list
102
set interfaces ge-0/0/1 gigether-options 802.3ad ae0
set interfaces ge-0/0/2 gigether-options 802.3ad ae0
set interfaces ae0 description “TO LEAF-1_LEAF-2”
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic
fast
set interfaces ae0 unit 0 family bridge interface-mode
trunk
set interfaces ae0 unit 0 family bridge VLAN-id-list 101
set interfaces ae0 unit 0 family bridge VLAN-id-list 102
set bridge-domains BD-101 domain-type bridge
set bridge-domains BD-101 VLAN-id 101
set bridge-domains BD-102 domain-type bridge
set bridge-domains BD-102 VLAN-id 102
Base Configuration on CE-3
set chassis aggregated-devices ethernet deviCE-3ount 1
set interfaces ge-0/0/0 description “TO Host-5”
set interfaces ge-0/0/0 unit 0 family bridge interface-mode
trunk
set interfaces ge-0/0/0 unit 0 family bridge VLAN-id-list
101
set interfaces ge-0/0/0 unit 0 family bridge VLAN-id-list
102
set interfaces ge-0/0/1 gigether-options 802.3ad ae0
set interfaces ge-0/0/2 gigether-options 802.3ad ae0
set interfaces ae0 description “TO LEAF-3_LEAF-4”
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic
fast
set interfaces ae0 unit 0 family bridge interface-mode
trunk
set interfaces ae0 unit 0 family bridge VLAN-id-list 101
set interfaces ae0 unit 0 family bridge VLAN-id-list 102
set bridge-domains BD-101 domain-type bridge
set bridge-domains BD-101 VLAN-id 101
set bridge-domains BD-102 domain-type bridge
set bridge-domains BD-102 VLAN-id 102