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END USER LICENSE AGREEMENT

READ THIS END USER LICENSE AGREEMENT (“AGREEMENT”) BEFORE DOWNLOADING, INSTALLING, OR USING THE SOFTWARE. BY DOWNLOADING,
INSTALLING, OR USING THE SOFTWARE OR OTHERWISE EXPRESSING YOUR AGREEMENT TO THE TERMS CONTAINED HEREIN, YOU (AS CUSTOMER
OR IF YOU ARE NOT THE CUSTOMER, AS A REPRESENTATIVE/AGENT AUTHORIZED TO BIND THE CUSTOMER) CONSENT TO BE BOUND BY THIS
AGREEMENT. IF YOU DO NOT OR CANNOT AGREE TO THE TERMS CONTAINED HEREIN, THEN (A) DO NOT DOWNLOAD, INSTALL, OR USE THE SOFTWARE,
AND (B) YOU MAY CONTACT JUNIPER NETWORKS REGARDING LICENSE TERMS.

1. The Parties. The parties to this Agreement are (i) Juniper Networks, Inc. (if the Customer’s principal office is located in the Americas) or Juniper Networks
(Cayman) Limited (if the Customer’s principal office is located outside the Americas) (such applicable entity being referred to herein as “Juniper”), and (ii)
the person or organization that originally purchased from Juniper or an authorized Juniper reseller the applicable license(s) for use of the Software (“Customer”)
(collectively, the “Parties”).

2. The Software. In this Agreement, “Software” means the program modules and features of the Juniper or Juniper-supplied software, for which Customer
has paid the applicable license or support fees to Juniper or an authorized Juniper reseller, or which was embedded by Juniper in equipment which Customer
purchased from Juniper or an authorized Juniper reseller. “Software” also includes updates, upgrades and new releases of such software. “Embedded
Software” means Software which Juniper has embedded in or loaded onto the Juniper equipment and any updates, upgrades, additions or replacements
which are subsequently embedded in or loaded onto the equipment.

3. License Grant. Subject to payment of the applicable fees and the limitations and restrictions set forth herein, Juniper grants to Customer a non-exclusive
and non-transferable license, without right to sublicense, to use the Software, in executable form only, subject to the following use restrictions:

a. Customer shall use Embedded Software solely as embedded in, and for execution on, Juniper equipment originally purchased by Customer from Juniper
or an authorized Juniper reseller.

b. Customer shall use the Software on a single hardware chassis having a single processing unit, or as many chassis or processing units for which Customer
has paid the applicable license fees; provided, however, with respect to the Steel-Belted Radius or Odyssey Access Client software only, Customer shall use
such Software on a single computer containing a single physical random access memory space and containing any number of processors. Use of the
Steel-Belted Radius or IMS AAA software on multiple computers or virtual machines (e.g., Solaris zones) requires multiple licenses, regardless of whether
such computers or virtualizations are physically contained on a single chassis.

c. Product purchase documents, paper or electronic user documentation, and/or the particular licenses purchased by Customer may specify limits to
Customer’s use of the Software. Such limits may restrict use to a maximum number of seats, registered endpoints, concurrent users, sessions, calls,
connections, subscribers, clusters, nodes, realms, devices, links, ports or transactions, or require the purchase of separate licenses to use particular features,
functionalities, services, applications, operations, or capabilities, or provide throughput, performance, configuration, bandwidth, interface, processing,
temporal, or geographical limits. In addition, such limits may restrict the use of the Software to managing certain kinds of networks or require the Software
to be used only in conjunction with other specific Software. Customer’s use of the Software shall be subject to all such limitations and purchase of all applicable
licenses.

d. For any trial copy of the Software, Customer’s right to use the Software expires 30 days after download, installation or use of the Software. Customer
may operate the Software after the 30-day trial period only if Customer pays for a license to do so. Customer may not extend or create an additional trial
period by re-installing the Software after the 30-day trial period.

e. The Global Enterprise Edition of the Steel-Belted Radius software may be used by Customer only to manage access to Customer’s enterprise network.
Specifically, service provider customers are expressly prohibited from using the Global Enterprise Edition of the Steel-Belted Radius software to support any
commercial network access services.

The foregoing license is not transferable or assignable by Customer. No license is granted herein to any user who did not originally purchase the applicable
license(s) for the Software from Juniper or an authorized Juniper reseller.

4. Use Prohibitions. Notwithstanding the foregoing, the license provided herein does not permit the Customer to, and Customer agrees not to and shall
not: (a) modify, unbundle, reverse engineer, or create derivative works based on the Software; (b) make unauthorized copies of the Software (except as
necessary for backup purposes); (c) rent, sell, transfer, or grant any rights in and to any copy of the Software, in any form, to any third party; (d) remove
any proprietary notices, labels, or marks on or in any copy of the Software or any product in which the Software is embedded; (e) distribute any copy of
the Software to any third party, including as may be embedded in Juniper equipment sold in the secondhand market; (f) use any ‘locked’ or key-restricted
feature, function, service, application, operation, or capability without first purchasing the applicable license(s) and obtaining a valid key from Juniper, even
if such feature, function, service, application, operation, or capability is enabled without a key; (g) distribute any key for the Software provided by Juniper
to any third party; (h) use the Software in any manner that extends or is broader than the uses purchased by Customer from Juniper or an authorized Juniper
reseller; (i) use Embedded Software on non-Juniper equipment; (j) use Embedded Software (or make it available for use) on Juniper equipment that the
Customer did not originally purchase from Juniper or an authorized Juniper reseller; (k) disclose the results of testing or benchmarking of the Software to
any third party without the prior written consent of Juniper; or (l) use the Software in any manner other than as expressly provided herein.

5. Audit. Customer shall maintain accurate records as necessary to verify compliance with this Agreement. Upon request by Juniper, Customer shall furnish
such records to Juniper and certify its compliance with this Agreement.

■ iii



6. Confidentiality. The Parties agree that aspects of the Software and associated documentation are the confidential property of Juniper. As such, Customer
shall exercise all reasonable commercial efforts to maintain the Software and associated documentation in confidence, which at a minimum includes
restricting access to the Software to Customer employees and contractors having a need to use the Software for Customer’s internal business purposes.

7. Ownership. Juniper and Juniper’s licensors, respectively, retain ownership of all right, title, and interest (including copyright) in and to the Software,
associated documentation, and all copies of the Software. Nothing in this Agreement constitutes a transfer or conveyance of any right, title, or interest in
the Software or associated documentation, or a sale of the Software, associated documentation, or copies of the Software.

8. Warranty, Limitation of Liability, Disclaimer of Warranty. The warranty applicable to the Software shall be as set forth in the warranty statement that
accompanies the Software (the “Warranty Statement”). Nothing in this Agreement shall give rise to any obligation to support the Software. Support services
may be purchased separately. Any such support shall be governed by a separate, written support services agreement. TO THE MAXIMUM EXTENT PERMITTED
BY LAW, JUNIPER SHALL NOT BE LIABLE FOR ANY LOST PROFITS, LOSS OF DATA, OR COSTS OR PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES,
OR FOR ANY SPECIAL, INDIRECT, OR CONSEQUENTIAL DAMAGES ARISING OUT OF THIS AGREEMENT, THE SOFTWARE, OR ANY JUNIPER OR
JUNIPER-SUPPLIED SOFTWARE. IN NO EVENT SHALL JUNIPER BE LIABLE FOR DAMAGES ARISING FROM UNAUTHORIZED OR IMPROPER USE OF ANY
JUNIPER OR JUNIPER-SUPPLIED SOFTWARE. EXCEPT AS EXPRESSLY PROVIDED IN THE WARRANTY STATEMENT TO THE EXTENT PERMITTED BY LAW,
JUNIPER DISCLAIMS ANY AND ALL WARRANTIES IN AND TO THE SOFTWARE (WHETHER EXPRESS, IMPLIED, STATUTORY, OR OTHERWISE), INCLUDING
ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NONINFRINGEMENT. IN NO EVENT DOES JUNIPER
WARRANT THAT THE SOFTWARE, OR ANY EQUIPMENT OR NETWORK RUNNING THE SOFTWARE, WILL OPERATE WITHOUT ERROR OR INTERRUPTION,
OR WILL BE FREE OF VULNERABILITY TO INTRUSION OR ATTACK. In no event shall Juniper’s or its suppliers’ or licensors’ liability to Customer, whether
in contract, tort (including negligence), breach of warranty, or otherwise, exceed the price paid by Customer for the Software that gave rise to the claim, or
if the Software is embedded in another Juniper product, the price paid by Customer for such other product. Customer acknowledges and agrees that Juniper
has set its prices and entered into this Agreement in reliance upon the disclaimers of warranty and the limitations of liability set forth herein, that the same
reflect an allocation of risk between the Parties (including the risk that a contract remedy may fail of its essential purpose and cause consequential loss),
and that the same form an essential basis of the bargain between the Parties.

9. Termination. Any breach of this Agreement or failure by Customer to pay any applicable fees due shall result in automatic termination of the license
granted herein. Upon such termination, Customer shall destroy or return to Juniper all copies of the Software and related documentation in Customer’s
possession or control.

10. Taxes. All license fees payable under this agreement are exclusive of tax. Customer shall be responsible for paying Taxes arising from the purchase of
the license, or importation or use of the Software. If applicable, valid exemption documentation for each taxing jurisdiction shall be provided to Juniper prior
to invoicing, and Customer shall promptly notify Juniper if their exemption is revoked or modified. All payments made by Customer shall be net of any
applicable withholding tax. Customer will provide reasonable assistance to Juniper in connection with such withholding taxes by promptly: providing Juniper
with valid tax receipts and other required documentation showing Customer’s payment of any withholding taxes; completing appropriate applications that
would reduce the amount of withholding tax to be paid; and notifying and assisting Juniper in any audit or tax proceeding related to transactions hereunder.
Customer shall comply with all applicable tax laws and regulations, and Customer will promptly pay or reimburse Juniper for all costs and damages related
to any liability incurred by Juniper as a result of Customer’s non-compliance or delay with its responsibilities herein. Customer’s obligations under this
Section shall survive termination or expiration of this Agreement.

11. Export. Customer agrees to comply with all applicable export laws and restrictions and regulations of any United States and any applicable foreign
agency or authority, and not to export or re-export the Software or any direct product thereof in violation of any such restrictions, laws or regulations, or
without all necessary approvals. Customer shall be liable for any such violations. The version of the Software supplied to Customer may contain encryption
or other capabilities restricting Customer’s ability to export the Software without an export license.

12. Commercial Computer Software. The Software is “commercial computer software” and is provided with restricted rights. Use, duplication, or disclosure
by the United States government is subject to restrictions set forth in this Agreement and as provided in DFARS 227.7201 through 227.7202-4, FAR 12.212,
FAR 27.405(b)(2), FAR 52.227-19, or FAR 52.227-14(ALT III) as applicable.

13. Interface Information. To the extent required by applicable law, and at Customer's written request, Juniper shall provide Customer with the interface
information needed to achieve interoperability between the Software and another independently created program, on payment of applicable fee, if any.
Customer shall observe strict obligations of confidentiality with respect to such information and shall use such information in compliance with any applicable
terms and conditions upon which Juniper makes such information available.

14. Third Party Software. Any licensor of Juniper whose software is embedded in the Software and any supplier of Juniper whose products or technology
are embedded in (or services are accessed by) the Software shall be a third party beneficiary with respect to this Agreement, and such licensor or vendor
shall have the right to enforce this Agreement in its own name as if it were Juniper. In addition, certain third party software may be provided with the
Software and is subject to the accompanying license(s), if any, of its respective owner(s). To the extent portions of the Software are distributed under and
subject to open source licenses obligating Juniper to make the source code for such portions publicly available (such as the GNU General Public License
(“GPL”) or the GNU Library General Public License (“LGPL”)), Juniper will make such source code portions (including Juniper modifications, as appropriate)
available upon request for a period of up to three years from the date of distribution. Such request can be made in writing to Juniper Networks, Inc., 1194
N. Mathilda Ave., Sunnyvale, CA 94089, ATTN: General Counsel. You may obtain a copy of the GPL at http://www.gnu.org/licenses/gpl.html, and
a copy of the LGPL at http://www.gnu.org/licenses/lgpl.html.

15. Miscellaneous. This Agreement shall be governed by the laws of the State of California without reference to its conflicts of laws principles. The provisions
of the U.N. Convention for the International Sale of Goods shall not apply to this Agreement. For any disputes arising under this Agreement, the Parties
hereby consent to the personal and exclusive jurisdiction of, and venue in, the state and federal courts within Santa Clara County, California. This Agreement
constitutes the entire and sole agreement between Juniper and the Customer with respect to the Software, and supersedes all prior and contemporaneous
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agreements relating to the Software, whether oral or written (including any inconsistent terms contained in a purchase order), except that the terms of a
separate written agreement executed by an authorized Juniper representative and Customer shall govern to the extent such terms are inconsistent or conflict
with terms contained herein. No modification to this Agreement nor any waiver of any rights hereunder shall be effective unless expressly assented to in
writing by the party to be charged. If any portion of this Agreement is held invalid, the Parties agree that such invalidity shall not affect the validity of the
remainder of this Agreement. This Agreement and associated documentation has been written in the English language, and the Parties agree that the English
version will govern. (For Canada: Les parties aux présentés confirment leur volonté que cette convention de même que tous les documents y compris tout
avis qui s'y rattaché, soient redigés en langue anglaise. (Translation: The parties confirm that this Agreement and all related documentation is and will be
in the English language)).
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About this Guide

■ Objectives on page xiii

■ Audience on page xiv

■ Conventions on page xiv

■ List of Technical Publications on page xv

■ Requesting Technical Support on page xvi

Objectives

Network and Security Manager (NSM) is a software application that centralizes control
and management of your Juniper Networks devices. With NSM, Juniper Networks
delivers integrated, policy-based security and network management for all security
devices.

NOTE: NSM supports only the domestic version of JUNOS on J Series and SRX Series
platforms.

This guide provides the information you need to understand, configure, and maintain
J Series Services Routers and SRX Series Services Gateways using NSM. The J Series
and SRX Series device configuration features that are detailed in this guide are as
follows:

■ User Authentication

■ Chassis

■ USB Modem Interfaces

■ Policy Options

■ Routing Options

■ Protocols

■ Integrated Convergence Services

■ SNMP

■ DHCP

■ Class of Service

■ Application Layer Gateway (ALG)

■ Unified Threat Management (UTM)

Objectives ■ xiii



NOTE: Because the NSM device-side configuration guides are not updated on the
same release schedule as the JUNOS releases, consult the JUNOS Software Documentation
for information about configuration settings that might occur in NSM and not in the
device-side configuration guides or vice versa.

Audience

This guide is for the system administrator responsible for configuring J Series Services
Routers and SRX Series Services Gateways.

Conventions

Table 1 on page xiv defines notice icons used in this guide.

Table 1: Notice Icons

DescriptionMeaningIcon

Indicates important features or instructions.Informational note

Indicates a situation that might result in loss of data or hardware damage.Caution

Alerts you to the risk of personal injury or death.Warning

Alerts you to the risk of personal injury from a laser.Laser warning

Table 2 on page xiv defines text conventions used in this guide.

Table 2: Text Conventions

ExamplesDescriptionConvention

■ Issue the clock source command.

■ Specify the keyword exp-msg.

■ Click User Objects

■ Represents commands and keywords
in text.

■ Represents keywords

■ Represents UI elements

Bold typeface like this

user inputRepresents text that the user must type.Bold typeface like this
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Table 2: Text Conventions (continued)

ExamplesDescriptionConvention

host1# 
show ip ospf
Routing Process OSPF 2 with Router
 ID 5.5.0.250
Router is an area Border Router 
(ABR)

Represents information as displayed on
the terminal screen.

fixed-width font

Ctrl + dIndicates that you must press two or more
keys simultaneously.

Key names linked with a plus (+)
sign

■ The product supports two levels of
access, user and privileged.

■ clusterID, ipAddress.

■ Emphasizes words

■ Identifies variables

Italics

Object Manager > User Objects > Local
Objects

Indicates navigation paths through the UI
by clicking menu options and links.

The angle bracket (>)

Table 3 on page xv defines syntax conventions used in this guide.

Table 3: Syntax Conventions

ExamplesDescriptionConvention

terminal lengthRepresent keywordsWords in plain text

mask, accessListNameRepresent variablesWords in italics

diagnostic | lineRepresent a choice to select one keyword or
variable to the left or right of this symbol. The
keyword or variable can be optional or
required.

Words separated by the pipe ( | )
symbol

[ internal | external ]Represent optional keywords or variables.Words enclosed in brackets ( [ ] )

[ level1 | level2 | 11 ]*Represent optional keywords or variables that
can be entered more than once.

Words enclosed in brackets followed
by and asterisk ( [ ]*)

{ permit | deny } { in | out } {
clusterId | ipAddress }

Represent required keywords or variables.Words enclosed in braces ( { } )

List of Technical Publications

Table 4 on page xvi lists the manuals supporting Network and Security Manager and
JUNOS software for J Series and SRX Series platforms. All documents are available
at http://www.juniper.net/techpubs/.
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Table 4:  Technical Documentation for NSM and J Series Services Routers and SRX Series Services Gateways

Details the steps to install the NSM management system on
a single server or on separate servers. It also includes
information on how to install and run the NSM user interface.
This guide is intended for IT administrators responsible for
the installation and/or upgrade of NSM.

Network and Security Manager Installation Guide

Describes how to use and configure key management features
in the NSM. It provides conceptual information, suggested
workflows, and examples where applicable. This guide is best
used in conjunction with the NSM Online Help, which provides
step-by-step instructions for performing management tasks
in the NSM UI.

This guide is intended for application administrators or those
individuals responsible for owning the server and security
infrastructure and configuring the product for multi-user
systems. It is also intended for device configuration
administrators, firewall and VPN administrators, and network
security operation center administrators.

Network and Security Manager Administration Guide

Describes NSM features that relate to device configuration and
management. It also explains how to configure basic and
advanced NSM functionality, including deploying new device
configurations, managing Security Policies and VPNs, and
general device administration.

Network and Security Manager Configuring Firewall/VPN
Devices Guide

Provides task-oriented procedures describing how to perform
basic tasks in the NSM user interface. It also includes a brief
overview of the NSM system and a description of the GUI
elements.

Network and Security Manager Online Help

Explains how to configure SRX Series and J Series interfaces
for basic IP routing with standard routing protocols, ISDN
service, firewall filters (access control lists), and class-of-service
(CoS) traffic classification.

JUNOS Software Interfaces and Routing Configuration Guide

Explains how to configure and manage SRX Series and J Series
security services such as stateful firewall policies, IPsec VPNs,
firewall screens, Network Address Translation (NAT), Public
Key Cryptography, chassis clusters, Application Layer
Gateways (ALGs), and Intrusion Detection and Prevention
(IDP).

JUNOS Software Security Configuration Guide

Shows how to monitor SRX Series and J Series devices and
routing operations, firewall and security services, system
alarms and events, and network performance. This guide also
shows how to administer user authentication and access,
upgrade software, and diagnose common problems.

JUNOS Software Administration Guide

Requesting Technical Support

Technical product support is available through the Juniper Networks Technical
Assistance Center (JTAC). If you are a customer with an active J-Care or JNASC support
contract, or are covered under warranty, and need post-sales technical support, you
can access our tools and resources online or open a case with JTAC.
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■ JTAC policies—For a complete understanding of our JTAC procedures and policies,
review the JTAC User Guide located at
http://www.juniper.net/customers/support/downloads/7100059-EN.pdf  .

■ Product warranties—For product warranty information, visit
http://www.juniper.net/support/warranty/  .

■ JTAC hours of operation—The JTAC centers have resources available 24 hours a
day, 7 days a week, 365 days a year.

Self-Help Online Tools and Resources

For quick and easy problem resolution, Juniper Networks has designed an online
self-service portal called the Customer Support Center (CSC) that provides you with
the following features:

■ Find CSC offerings: http://www.juniper.net/customers/support/

■ Search for known bugs: http://www2.juniper.net/kb/

■ Find product documentation: http://www.juniper.net/techpubs/

■ Find solutions and answer questions using our Knowledge Base:
http://kb.juniper.net/

■ Download the latest versions of software and review release notes:
http://www.juniper.net/customers/csc/software/

■ Search technical bulletins for relevant hardware and software notifications:
https://www.juniper.net/alerts/

■ Join and participate in the Juniper Networks Community Forum:
http://www.juniper.net/company/communities/

■ Open a case online in the CSC Case Management tool: http://www.juniper.net/cm/

To verify service entitlement by product serial number, use our Serial Number
Entitlement (SNE) Tool: https://tools.juniper.net/SerialNumberEntitlementSearch/

Opening a Case with JTAC

You can open a case with JTAC on the Web or by telephone.

■ Use the Case Management tool in the CSC at http://www.juniper.net/cm/ .

■ Call 1-888-314-JTAC (1-888-314-5822 toll-free in the USA, Canada, and Mexico).

For international or direct-dial options in countries without toll-free numbers, see
http://www.juniper.net/support/requesting support.html .
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Part 1

Getting Started

■ Understanding J Series Services Router and SRX Series Services Gateway
Configuration on page 3

■ J Series Services Routers and SRX Series Services Gateways and NSM Installation
and Integration Overview on page 7
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Chapter 1

Understanding J Series Services Router
and SRX Series Services Gateway
Configuration

■ NSM and Device Management Overview on page 3

■ Communication Between NSM and a Device Overview on page 3

■ Device Configurations Supported in NSM for the J Series Services Router and
SRX Series Services Gateway on page 5

NSM and Device Management Overview

NSM is the Juniper Networks network management tool that allows distributed
administration of network appliances. You can use the NSM application to centralize
status monitoring, logging, and reporting, and to administer device configurations.

With NSM you can manage and administer a device from a single management
interface.

In addition, NSM lets you manage most of the parameters that you can configure
through the device’s admin console. The configuration screens rendered through
NSM are similar to the screens in the device’s admin console.

NSM incorporates a broad configuration management framework that allows
co-management using other methods. To manage the device configuration, you can
also use the XML files import and export feature, or you can manage from the device’s
admin console.

Related Topics Communication Between NSM and a Device Overview on page 3■

■ Device Configurations Supported in NSM for the J Series Services Router and
SRX Series Services Gateway on page 5

Communication Between NSM and a Device Overview

The NSM application and a device communicate through the Device Management
Interface (DMI). DMI is a collection of schema-driven protocols that run on a common
transport (that is, TCP). DMI is designed to work with Juniper Networks platforms to

NSM and Device Management Overview ■ 3



make device management consistent across all administrative realms. Supported
DMI protocols include:

■ NetConf (for inventory management, XML-based configuration, text-based
configuration, alarm monitoring, and device specific commands)

■ Structured syslog

■ Threat flow for network profiling

DMI supports third-party network management systems that incorporate the DMI
standard; however, only one DMI-based agent per device is supported.

The device’s configuration is represented as a hierarchical tree of configuration items.
This structure is expressed in XML and can be manipulated with NetConf. NetConf
is a network management protocol that uses XML. DMI uses NetConf’s generic
configuration management capability to allow remote configuration of the device.

To allow NSM to manage the device using the DMI protocol, NSM must import the
schema and metadata files from the Juniper Networks Schema Repository, a publicly
accessible resource that is updated with each device release. In addition to
downloading the device’s current schema, NSM may also download upgraded
software.

The Schema Repository enables access to XSD and XML files defined for each device,
model, and software version.

Before attempting to communicate with NSM, you must first complete the initial
configuration of the device. Initial configuration includes network interface settings,
DNS settings, licensing, and password administration.

If you have several devices that will be configured in a clustering environment, the
cluster abstraction must first be created in the NSM Cluster Manager. Then you can
add individual nodes.

After you have completed the initial network configuration, you can configure the
device to communicate with NSM using the appropriate network information. Once
the device has been configured to communicate with NSM, the device contacts NSM
and establishes a DMI session through an initial TCP handshake.

All communications between the device and NSM occur over SSH to ensure data
integrity.

After the device initially contacts NSM and a TCP session is established, interaction
between the device and NSM is driven from NSM, which issues commands to get
hardware, software, and license details of the device. NSM connects to the Schema
Repository to download the configuration schema that is specific to the device.

NSM then issues a command to retrieve configuration information from the device.
If NSM is contacted by more than one device as a member of a cluster, information
from only one of the cluster devices is gathered. NSM attempts to validate the
configuration received from the device against the schema from Juniper Networks.

Once the device and NSM are communicating, the device delivers syslog and event
information to NSM.

4 ■ Communication Between NSM and a Device Overview
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After NSM and the device are connected, you can make any configuration changes
directly on the device, bypassing NSM. NSM automatically detects these changes and
imports the new configuration data. Changes to device cluster members will similarly
be detected by NSM.

When you make changes to the device’s configuration through NSM, you must push
the changes to the device by performing an Update Device operation.

When you double-click the device icon in the Device Manager and select the
Configuration tab, the configuration tree appears in the main display area in the
same orientation as items appear on the device’s admin console.

Related Topics NSM and Device Management Overview on page 3■

■ Device Configurations Supported in NSM for the J Series Services Router and
SRX Series Services Gateway on page 5

Device Configurations Supported in NSM for the J Series Services Router and SRX
Series Services Gateway

NSM supports the following services for J Series Services Router and SRX Series
services gateway platforms:

■ Inventory management service—Enables management of the software, hardware,
and licensing details for the J Series Services Router and the SRX Series services
gateway. Adding or deleting licenses and upgrading or downgrading software
are not supported.

■ Status monitoring service—Allows the status of the J Series Services Router and
the SRX Series services gateway to be obtained, including name, domain, OS
version, synchronization status, connection details, and current alarms.

■ Logging service—Allows logs to be obtained in a time-generated order for the J
Series Services Router and the SRX Series services gateway device . Logging
configuration details that are set on the J Series Services Router and the SRX
Series services gateway will apply to NSM.

■ XML-based configuration management service—Enables NSM to manage the
configuration of the J Series Services Router and the SRX Series services gateway.
NSM uses the same XML schema as the J Series Services Router and the SRX
Series services gateway, so you can troubleshoot NSM using XML files downloaded
from either device.

NOTE: NSM supports only the domestic version of JUNOS on J Series and SRX Series
platforms.

The following device configurations are not supported:

■ Editing licensing information, although licenses can be viewed

■ Packaging log files or debug files for remote analysis

Device Configurations Supported in NSM for the J Series Services Router and SRX Series Services Gateway ■ 5
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Related Topics ■ NSM and Device Management Overview on page 3

■ Communication Between NSM and a Device Overview on page 3
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Configuring J Series Services Routers and SRX Series Services Gateways Guide



Chapter 2

J Series Services Routers and SRX Series
Services Gateways and NSM Installation
and Integration Overview

■ J Series Services Router and SRX Series Services Gateway Installation and
Configuration Overview on page 7

■ NSM Installation Overview on page 8

■ Adding J Series Services Routers or SRX Series Services Gateways in NSM
Overview on page 8

■ Adding J Series Services Router Clusters and SRX Series Services Gateway Clusters
Overview on page 9

■ Using Templates and Configuration Groups in NSM Overview on page 9

J Series Services Router and SRX Series Services Gateway Installation and
Configuration Overview

NOTE: For important safety information, read the Juniper Networks Security Products
Safety Guide.

Before you can add either a J Series Services Router or an SRX Series services gateway
to NSM, the device must be installed and configured, and logon credentials for an
NSM administrator must be configured for it. Follow these steps:

1. Connect the device to the network and configure one of the interfaces so that
the device can reach the NSM device server.

2. Add a user for NSM that has full administrative rights.

For complete details on installing and configuring J Series Services Routers, see the
corresponding Hardware Guide for your device.

For complete details on installing and configuring SRX Series services gateway, see
the corresponding Hardware Guide for your device.

Related Topics NSM Installation Overview on page 8■
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■ NSM and Device Management Overview on page 3

■ Communication Between NSM and a Device Overview on page 3

NSM Installation Overview

NSM is a software application that enables you to integrate and centralize
management of your Juniper Networks environment. You need to install two main
software components to run NSM: the NSM management system and the NSM user
interface (UI).

See the Network Security Manager Installation Guide for the steps to install the NSM
management system on a single server or on separate servers. It also includes
information on how to install and run the NSM user interface. The Network Security
Manager Installation Guide is intended for IT administrators responsible for installing
or upgrading NSM.

Related Topics J Series Services Router and SRX Series Services Gateway Installation and
Configuration Overview on page 7

■

■ NSM and Device Management Overview on page 3

Adding J Series Services Routers or SRX Series Services Gateways in NSM Overview

Before NSM can manage devices, you must first add those devices to the management
system using the NSM UI. To add a device, you create an object in the UI that
represents the physical device, and then create a connection between the UI object
and the physical device so that their information is linked. When you make a change
to the UI device object, you can push that information to the real device so the two
remain synchronized. You can add a single device at a time or add multiple devices
all at once.

For complete details on adding J Series Services Routers or SRX Series services
gateways, see the Network and Security Manager Administration Guide.

Related Topics ■ NSM and Device Management Overview on page 3

■ Communication Between NSM and a Device Overview on page 3

■ Device Configurations Supported in NSM for the J Series Services Router and
SRX Series Services Gateway on page 5

■ Adding J Series Services Router Clusters and SRX Series Services Gateway Clusters
Overview on page 9

8 ■ NSM Installation Overview
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Adding J Series Services Router Clusters and SRX Series Services Gateway Clusters
Overview

A cluster consists of multiple devices joined together in a high availability configuration
to ensure continued network uptime. The device configurations are synchronized,
meaning all cluster members share the same configuration settings, enabling a device
to handle traffic for another if one device fails.

Adding a cluster is a two-stage process:

■ Add the cluster device object.

■ Add the members of the cluster to the cluster device object.

For complete details on adding J Series Services Router clusters or SRX Series services
gateway clusters, see the Network and Security Manager Administration Guide.

Related Topics ■ NSM and Device Management Overview on page 3

■ Communication Between NSM and a Device Overview on page 3

■ Device Configurations Supported in NSM for the J Series Services Router and
SRX Series Services Gateway on page 5

■ Adding J Series Services Routers or SRX Series Services Gateways in NSM
Overview on page 8

Using Templates and Configuration Groups in NSM Overview

Use templates to define a common device configuration and then reuse that
configuration information across multiple devices. In a template, you need to define
only those configuration parameters that you want to set; you do not need to specify
a complete device configuration.

Templates provide these benefits:

■ You can configure parameter values for a device by referring to one or more
templates when configuring the device.

■ When you change a parameter value in a template and save the template, the
value also changes for all device configurations that refer to that template, unless
specifically overridden in the device object.

For complete details on using device templates and configuration groups, see the
Network and Security Manager Administration Guide.

Related Topics ■ Adding J Series Services Routers or SRX Series Services Gateways in NSM
Overview on page 8

■ Adding J Series Services Router Clusters and SRX Series Services Gateway Clusters
Overview on page 9

Adding J Series Services Router Clusters and SRX Series Services Gateway Clusters Overview ■ 9
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Part 2

Configuring J Series Services Routers and
SRX Series Services Gateways

NOTE: Because the NSM device-side configuration guides are not updated on the
same release schedule as the JUNOS releases, consult the JUNOS Software Documentation
for information about configuration settings that might occur in NSM and not in the
device-side configuration guides or vice versa.

■ Configuring User Authentication in J Series Services Routers and SRX Series
Services Gateways on page 13

■ Configuring Chassis in J Series Services Routers and SRX Series Services
Gateways on page 21

■ Configuring USB Modem Interfaces in J Series Services Routers and SRX Series
Services Gateways on page 27

■ Configuring Policy Options in J Series Services Routers and SRX Series Services
Gateways on page 33

■ Configuring Routing Options in J Series Services Routers and SRX Series Services
Gateways on page 43

■ Configuring Protocols for J Series Services Routers and SRX Series Services
Gateways on page 69

■ Configuring Integrated Convergence Services on the SRX Series Services
Gateways on page 89

■ Configuring SNMP for Network Management in J Series Services Routers and
SRX Series Services Gateways on page 105

■ Configuring J Series Services Routers and SRX Series Services Gateways for
DHCP on page 111

■ Configuring Class of Service in J Series Services Routers and SRX Series Services
Gateways on page 115

■ Configuring Application Layer Gateways in J Series Services Routers and SRX
Series Services Gateways on page 139

■ Configuring Unified Threat Management Features in J Series Services Routers
and SRX Series Services Gateways on page 153
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Chapter 3

Configuring User Authentication in J
Series Services Routers and SRX Series
Services Gateways

■ Configuring RADIUS Authentication (NSM Procedure) on page 13

■ Configuring TACACS+ Authentication (NSM Procedure) on page 14

■ Configuring Authentication Order (NSM Procedure) on page 15

■ Configuring User Access (NSM Procedure) on page 16

■ Configuring Template Accounts (NSM Procedure) on page 17

Configuring RADIUS Authentication (NSM Procedure)

To use RADIUS authentication, you must configure at least one RADIUS server.
Configuring RADIUS authentication involves identifying the RADIUS server, specifying
the secret (password) of the RADIUS server, and setting the source address of the
device's RADIUS requests to the loopback address of the device.

To configure RADIUS authentication:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure RADIUS authentication.

3. Click the Configuration tab. In the configuration tree, select System > Radius
Server.

4. Add or modify Radius settings as specified in Table 5 on page 14.

5. Click one:

■ New—Adds a new RADIUS server.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.
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Table 5: RADIUS Authentication Configuration Details

Your ActionFunctionOption

Enter the IP address of the
RADIUS server.

Specifies the IP address of the RADIUS server.Name

Enter the shared secret of the
RADIUS server.

Specifies the shared secret (password) of the
RADIUS server. The secret is stored as an
encrypted value in the configuration database.

Secret

Enter the loopback address of
the device.

Specifies the source address to be included in
the RADIUS server requests by the device. In
most cases, you can use the loopback address
of the device.

Source
Address

Related Topics Configuring TACACS+ Authentication (NSM Procedure) on page 14■

■ Configuring Authentication Order (NSM Procedure) on page 15

■ Configuring User Access (NSM Procedure) on page 16

Configuring TACACS+ Authentication (NSM Procedure)

To use TACACS+ authentication, you must configure at least one TACACS+ server.
Configuring TACACS+ authentication involves identifying the TACACS+ server,
specifying the secret (password) of the TACACS+ server, and setting the source
address of the device's TACACS+ requests to the loopback address of the device.

To configure TACACS+ authentication:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure TACACS+ authentication.

3. Click the Configuration tab. In the configuration tree, select System > TACACS+
Server.

4. Add or modify TACACS+ settings as specified in Table 6 on page 14.

5. Click one:

■ New—Adds a new TACACS+ server.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 6: TACACS+ Authentication Configuration Details

Your ActionFunctionOption

Enter the IP address of the
TACACS+ server.

Specifies the IP address of the TACACS+ server.Name

14 ■ Configuring TACACS+ Authentication (NSM Procedure)
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Table 6: TACACS+ Authentication Configuration Details (continued)

Your ActionFunctionOption

Enter the shared secret of the
TACACS+ server.

Specifies the shared secret (password) of the
TACACS+ server. The secret is stored as an
encrypted value in the configuration database.

Secret

Enter the loopback address of
the device.

Specifies the source address to be included in
the TACACS+ server requests by the device. In
most cases, you can use the loopback address
of the device.

Source
Address

Related Topics Configuring RADIUS Authentication (NSM Procedure) on page 13■

■ Configuring Authentication Order (NSM Procedure) on page 15

■ Configuring User Access (NSM Procedure) on page 16

Configuring Authentication Order (NSM Procedure)

You can configure the device so that user authentication occurs with the local
password first, then with the RADIUS server, and finally with the TACACS+ server.

To configure authentication order:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure authentication order.

3. Click the Configuration tab. In the configuration tree, select System >
Authentication Order.

4. In the Authentication Order workspace, click the New button. The New
authentication-order list appears.

5. To add RADIUS authentication to the authentication order, select radius from
the New authentication-order list.

6. To add TACACS+ authentication to the authentication order, select tacplus from
the New authentication-order list.

7. To add Password authentication to the authentication order, select password
from the New authentication-order list.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Related Topics Configuring RADIUS Authentication (NSM Procedure) on page 13■

■ Configuring TACACS+ Authentication (NSM Procedure) on page 14

■ Configuring User Access (NSM Procedure) on page 16
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Configuring User Access (NSM Procedure)

This section includes the following topics:

■ Configuring Login Classes on page 16

■ Configuring User Accounts on page 17

Configuring Login Classes

You can define any number of login classes and then apply one login class to an
individual user account. All users who can log in to the router must be in a login
class. With login classes, you define the following:

■ Access privileges users have when they are logged in to the router

■ Commands and statements that users can and cannot specify

■ How long a login session can be idle before it times out and the user is logged
out

To configure login classes:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure a login class.

3. Click the Configuration tab. In the configuration tree, select System > Login
> Class.

4. Add or modify login class settings as specified in Table 7 on page 16.

5. Click one:

■ New—Adds a new login class.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 7: Login Class Authentication Configuration Details

Your ActionFunctionOption

Enter a name for the login class.Specifies a name for the login class.Name

Enter the command name enclosed
in quotation marks. For example,
“request system reboot”.

Specifies the operational mode
commands that members of a login
class can use.

Allow Commands

Login > Class > Permissions

Enter a new permission.Configures the login access privileges
to be provided on the device.

Permissions
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Configuring User Accounts

User accounts provide one way for users to access the device. (Users can access the
router without accounts if you configured RADIUS or TACACS+ servers.) For each
account, define the login name for the user and, optionally, information that identifies
the user. After you have created an account, a home directory is created for the user.

To configure user accounts:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure login class.

3. Click the Configuration tab. In the configuration tree, select System > Login
> User.

4. Add or modify login class settings as specified in Table 8 on page 17.

5. Click one:

■ New—Adds a new user account.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 8: User Authentication Configuration Details

Your ActionFunctionOption

Enter a unique name for the user.Identifies the user with a unique
name.

Name

Select the class name.Specifies the user's login class.Class

Login > User > Authentication

Enter the plain text password for
the user.

Specifies the user’s password.Plain Text Password
Value

Related Topics Configuring RADIUS Authentication (NSM Procedure) on page 13■

■ Configuring TACACS+ Authentication (NSM Procedure) on page 14

■ Configuring Authentication Order (NSM Procedure) on page 15

Configuring Template Accounts (NSM Procedure)

You can create template accounts that are shared by a set of users when you are
using RADIUS or TACACS+ authentication. When a user is authenticated by a
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template account, the CLI username is the login name, and the privileges, file
ownership, and effective user ID are inherited from the template account.

To configure template accounts, follow these procedures:

■ Creating a Remote Template Account on page 18

■ Creating a Local Template Account on page 19

Creating a Remote Template Account

You can create a remote template that is applied to users authenticated by RADIUS
or TACACS+ that do not belong to a local template account.

By default, JUNOS software with enhanced services uses the remote template account
when:

■ The authenticated user does not exist locally on the Services Router.

■ The authenticated user's record in the RADIUS or TACACS+ server specifies
local user, or the specified local user does not exist locally on the device.

The following procedure creates a sample user named remote that belongs to the
operator login class.

To create a remote template account:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to create a remote template account.

3. Click the Configuration tab. In the configuration tree, select System > Login
> User.

4. Add or modify login class settings as specified in Table 9 on page 18.

5. Click one:

■ New—Creates a new remote template account.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 9: Remote Template Account Details

Your ActionFunctionOption

Enter the user name. For example, type
remote.

Specifies a name for the user name.Name

Enter the number associated with the
login account.

Specifies the user identifier for a
login account.

Uid

Select the login class. For example, select
operator.

Specifies the login class for the user.Class
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Creating a Local Template Account

You can create a local template that is applied to users authenticated by RADIUS or
TACACS+ that are assigned to the local template account. You use local template
accounts when you need different types of templates. Each template can define a
different set of permissions appropriate for the group of users who use that template.

The following procedure creates a sample user named admin that belongs to the
superuser login class.

To create a local template account:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to create a local template account.

3. Click the Configuration tab. In the configuration tree, select System > Login
> User.

4. Add or modify login class settings as specified in Table 10 on page 19.

5. Click one:

■ New—Creates a new local template account.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 10: Local Template Account Details

Your ActionFunctionOption

Enter the user name. For example, type
admin.

Specifies a name for the user name.Name

Enter the number associated with the
login account.

Specifies the user identifier for a
login account.

Uid

Select the login class. For example, select
superuser.

Specifies the login class for the user.Class

Related Topics ■ Configuring RADIUS Authentication (NSM Procedure) on page 13

■ Configuring TACACS+ Authentication (NSM Procedure) on page 14

■ Configuring Authentication Order (NSM Procedure) on page 15
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Chapter 4

Configuring Chassis in J Series Services
Routers and SRX Series Services
Gateways

■ Configuring Aggregated Devices (NSM Procedure) on page 21

■ Configuring Chassis Alarms (NSM Procedure) on page 22

■ Configuring Routing Engine Redundancy (NSM Procedure) on page 23

■ Configuring a Routing Engine to Reboot or Halt on Hard Disk Errors (NSM
Procedure) on page 24

Configuring Aggregated Devices (NSM Procedure)

The JUNOS Software supports the aggregation of physical devices into the defined
virtual links, such as the link aggregation of Ethernet interfaces defined by the IEEE
802.3ad standard. You can configure the properties for Ethernet and sonet aggregated
devices on the router.

To configure the aggregated devices on the router:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Chassis >
Aggregated Devices.

4. Add or modify the settings as specified in Table 11 on page 22.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.
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Table 11: Aggregated Devices Configuration Details

Your ActionTask

1. Click Ethernet next to Aggregated Devices.

2. Enter the number of aggregated logical devices available to the
router.

Range: 1 through 256 devices

3. Click Lacp next to Ethernet.

4. In the System Priority box, enter the priority for the aggregated
Ethernet system.

5. Click Link Protection next to Lacp.

6. Select the Non Revertive check box if you want to disable the
ability to switch to a better priority link (if one is available) once
a link is established as active and a collection or distribution is
enabled.

Configure properties for
Ethernet aggregated
devices.

1. Click Sonet next to Aggregated Devices.

2. From the Device Count list, select the number of aggregated
logical devices available to the router.

Range: 1 through 16 Devices

Configure properties for
sonet aggregated devices.

Related Topics Configuring Chassis Alarms (NSM Procedure) on page 22■

■ Configuring Routing Engine Redundancy (NSM Procedure) on page 23

■ Configuring a Routing Engine to Reboot or Halt on Hard Disk Errors (NSM
Procedure) on page 24

Configuring Chassis Alarms (NSM Procedure)

You can configure the chassis alarms for an interface type to trigger a red or yellow
alarm or to ignore an alarm. Various conditions related to the chassis components
trigger yellow and red alarms.

To configure chassis alarm on the router:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Chassis > Alarm.

4. Add or modify the alarm settings as specified in Table 12 on page 23.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.
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Table 12: Chassis Alarms Configuration Details

Your ActionTask

1. Select the interface type listed next to Alarm.

2. Select the alarm type for the chassis condition for each
interface type.

Configuring the alarm type.

Related Topics Configuring Aggregated Devices (NSM Procedure) on page 21■

■ Configuring Routing Engine Redundancy (NSM Procedure) on page 23

■ Configuring a Routing Engine to Reboot or Halt on Hard Disk Errors (NSM
Procedure) on page 24

Configuring Routing Engine Redundancy (NSM Procedure)

You can configure redundancy properties for routers that have multiple Routing
Engines or these multiple switching control boards: Switching and Forwarding Modules
(SFMs), System and Switch Boards (SSBs), Forwarding Engine Boards (FEBs), or
Compact Forwarding Engine Boards (CFEBs).

To configure routing engine redundancy in NSM:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, select Chassis >
Redundancy.

4. Add or modify settings as specified in Table 13 on page 23.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 13: Chassis Redundancy Configuration Details

Your ActionTask

1. In the Comment box, enter the comment.

2. From the keepalive list, select the time
before the backup router takes mastership
when it detects loss of the keepalive
signal.

Range: 2 through 10,000

Configure redundancy options.

1. Click Failover next to Redundancy.

2. In the Comment box, enter the comment.

3. Select the type of failover.

Instruct the backup router to take mastership
if it detects hard disk errors or a loss of a
keepalive signal from the master Routing
Engine.
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Table 13: Chassis Redundancy Configuration Details (continued)

Your ActionTask

1. Click Graceful Switchover next to
Redundancy.

2. In the Comment box, enter the comment.

For routing platforms with two Routing
Engines, configure a master Routing Engine to
switch over gracefully to a backup Routing
Engine without interruption to packet
forwarding.

1. Click Routing Engine next to Redundancy.

2. From the Name list, select the slot
number.

3. In the Comment box, enter the comment.

4. Select the function of the Routing Engine
for the specified slot.

5. Select one of the following:

■ master—To configure the routing
engine to be the master.

■ backup—To configure the routing
engine to be the backup.

■ disabled—To disable the routing
engine.

Sets the function of the Routing Engine for the
specified slot. By default, the Routing Engine
in slot 0 is the master Routing Engine and the
Routing Engine in slot 1 is the backup Routing
Engine.

Related Topics Configuring Aggregated Devices (NSM Procedure) on page 21■

■ Configuring Chassis Alarms (NSM Procedure) on page 22

■ Configuring a Routing Engine to Reboot or Halt on Hard Disk Errors (NSM
Procedure) on page 24

Configuring a Routing Engine to Reboot or Halt on Hard Disk Errors (NSM Procedure)

You can configure a Routing Engine to halt or reboot automatically when a hard disk
error occurs. A hard disk error may cause a Routing Engine to enter a state in which
it responds to local pings and interfaces remain up, but no other processes are
responding.

To Configure Routing Engine to reboot or halt:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, select Chassis > Routing
Engine.

4. Add or modify Routing Engine settings as specified in Table 14 on page 25.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.
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Table 14: Chassis Routing Engine Configuration Details

Your ActionOption

From the Disk Failure Action list, select the action to instruct the
router on detecting the hard disk errors on the Routing Engine.

On disk failure.

Related Topics ■ Configuring Aggregated Devices (NSM Procedure) on page 21

■ Configuring Chassis Alarms (NSM Procedure) on page 22

■ Configuring Routing Engine Redundancy (NSM Procedure) on page 23
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Chapter 5

Configuring USB Modem Interfaces in J
Series Services Routers and SRX Series
Services Gateways

■ Configuring a USB Modem Interface (NSM Procedure) on page 27

■ Configuring a Dialer Interface (NSM Procedure) on page 28

■ Configuring Dial-in Options on a Dialer Interface (NSM Procedure) on page 29

■ Configuring a CHAP Access Profile on a Dialer Interface (NSM
Procedure) on page 30

Configuring a USB Modem Interface (NSM Procedure)

To configure a USB modem interface for the device:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure the USB modem interface.

3. Click the Configuration tab. In the configuration tree, select Interfaces >
Interfaces List.

4. Add or modify interface settings as specified in Table 15 on page 27.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 15: USB Modem Interface Configuration Details

Your ActionFunctionOption

Enter a name for the new
interface.

Specifies the name of the new
interface.

Name

Dialer Options > Pool
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Table 15: USB Modem Interface Configuration Details (continued)

Your ActionFunctionOption

Enter a name for the dialer
pool.

Specifies the name of the
dialer pool configured on the
dialer interface you want to
use for USB modem
connectivity.

Name

Set the dialer pool priority.Specifies the dialer pool
priority.

Priority

Modem Options

Enter the modem initialization
command string. For example,
enter ATSO=2.

Configures the modem to
automatically answer calls
after a specified number of
rings.

Init Command String

Related Topics Configuring a Dialer Interface (NSM Procedure) on page 28■

■ Configuring Dial-in Options on a Dialer Interface (NSM Procedure) on page 29

Configuring a Dialer Interface (NSM Procedure)

To configure a dialer interface for the device:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure the dialer interface.

3. Click the Configuration tab. In the configuration tree, select Interfaces >
Interfaces List.

4. Add or modify interface settings as specified in Table 16 on page 28.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 16: Dialer Interface Configuration Details

Your ActionFunctionOption

Enter a name for the new
interface.

Specifies the name of the new
interface.

Name

Enter a description for the new
interface.

Differentiates between
different dialer interfaces.

Description

Select PPP from the
encapsulation list.

Specifies the encapsulation.Encapsulation
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Table 16: Dialer Interface Configuration Details (continued)

Your ActionFunctionOption

Unit

Enter the unit number.Specifies the logical unit.Unit

Unit > Dialer Options

Enter the name of the dialer
pool.

Specifies the name of the
dialer pool to use for USB
modem connectivity.

Pool

Unit > Family > Inet > Address

Enter the source IP address.Specifies the source IP address
for the dialer interface.

Name

Enter the destination IP
address.

Specifies the destination IP
address for the dialer
interface.

Destination

Related Topics Configuring a USB Modem Interface (NSM Procedure) on page 27■

■ Configuring Dial-in Options on a Dialer Interface (NSM Procedure) on page 29

Configuring Dial-in Options on a Dialer Interface (NSM Procedure)

To configure dial-in options on a dialer interface:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure dial-in options.

3. Click the Configuration tab. In the configuration tree, select Interfaces >
Interfaces List.

4. Select the dialer interface and add or modify interface settings as specified in
Table 17 on page 29.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 17: Dialer Interface for Dial-in Configuration Details

Your ActionFunctionOption

Unit > Dialer Options > Incoming Map
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Table 17: Dialer Interface for Dial-in Configuration Details (continued)

Your ActionFunctionOption

■ Select accept-all to
accept all incoming calls.

■ Select caller to accept
calls from a specific caller
ID.

Specifies the incoming map
options for the dialer interface.

Caller

Caller

Enter the caller ID.Specifies the caller ID to be
accepted on the dialer
interface.

Name

Related Topics Configuring a Dialer Interface (NSM Procedure) on page 28■

■ Configuring a USB Modem Interface (NSM Procedure) on page 27

Configuring a CHAP Access Profile on a Dialer Interface (NSM Procedure)

To configure a CHAP access profile on a dialer interface:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure CHAP.

3. Click the Configuration tab. In the configuration tree, select Access > Profile
to define a CHAP access profile.

4. Add or modify CHAP access settings as specified in Table 18 on page 30.

5. Click the Configuration tab. In the configuration tree, select Interfaces >
Interfaces List to configure CHAP on the dialer interface.

6. Select the appropriate dialer interface level, and add or modify interface settings
as specified in Table 19 on page 31.

7. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 18: CHAP Access Profile Configuration Details

Your ActionFunctionOption

Enter a name for the profile.Specifies a name for the
profile.

Name

Client

Enter a name for the client.Specifies a name for the client.Name

30 ■ Configuring a CHAP Access Profile on a Dialer Interface (NSM Procedure)

Configuring J Series Services Routers and SRX Series Services Gateways Guide



Table 18: CHAP Access Profile Configuration Details (continued)

Your ActionFunctionOption

Enter the CHAP secret.

NOTE: Enter the client name
and CHAP secret for each
client to be included in the
CHAP profile.

Specifies the CHAP secret.Chap Secret

Table 19: CHAP Dialer Interface Configuration Details

Your ActionFunctionOption

Unit

Enter the unit number.Specifies the logical unit.Unit

Unit > Ppp Options > Chap

Enter a unique profile name
containing a client list and
access parameters.

Specifies the profile name.Access profile

Related Topics ■ Configuring a Dialer Interface (NSM Procedure) on page 28

■ Configuring a USB Modem Interface (NSM Procedure) on page 27
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Chapter 6

Configuring Policy Options in J Series
Services Routers and SRX Series
Services Gateways

■ Configuring an AS Path in a BGP Routing Policy (NSM Procedure) on page 33

■ Configuring an AS Path Group in a BGP Routing Policy (NSM
Procedure) on page 34

■ Configuring a Community for use in BGP Routing Policy Conditions (NSM
Procedure) on page 35

■ Configuring a BGP Export Policy Condition (NSM Procedure) on page 36

■ Configuring Flap Damping to Reduce the Number of BGP Update Messages (NSM
Procedure) on page 37

■ Configuring a Routing Policy Statement (NSM Procedure) on page 39

■ Configuring Prefix List (NSM Procedure) on page 40

Configuring an AS Path in a BGP Routing Policy (NSM Procedure)

An autonomous system (AS) path is a path to a destination. An AS path consists of
the AS numbers of all the network devices that a packet traverses if it takes the
associated route to a destination. The AS numbers are assembled in a sequence, or
path, that is read from right to left. For example, for a packet to reach a destination
using a route with an AS path 5 4 3 2 1, the packet first traverses AS 1 and so on
until it reaches AS 5, which is the last AS before its destination.

You can define a match condition based on all of or portions of the AS path. You can
create a named AS path and then include it in a BGP routing policy.

To configure an AS path for a BGP routing policy in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Policy Options.

5. Select As Path.
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6. Add or modify the parameters as specified in Table 20 on page 34.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 20: AS Path Configuration Details

Your ActionFunctionOption

Enter a name.Specifies the name of the AS path.Name

Enters a comment.Specifies the comment for the AS path.Comment

Enter an AS path.Specifies the AS path (as an AS number)
to be included in the routing policy.

Path

Configuring an AS Path Group in a BGP Routing Policy (NSM Procedure)

Autonomous System (AS) path group consists of multiple AS paths. You can define
match conditions based on the AS path groups. You can create named AS paths
under an AS path group and then include the AS path group in a routing policy.

To configure an AS path group for a BGP routing policy in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Policy Options.

5. Select As Path Group.

6. Add or modify the parameters as specified in Table 21 on page 35.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.
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NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 21: AS Path Group Configuration Details

Your ActionFunctionOption

Enter a name.Specifies the name of the AS path group.Name

Enter a comment.Specifies the comment for the AS path
group.

Comment

1. Select As Path.

2. Click the New button or select an
AS path and click the Edit button.

3. Specify the name, comment and
path.

4. Click OK, then click OK again.

Specifies an AS path to be included in
the AS path group. Specifies the name
and comment for the AS path and
specifies the path as an AS path number.

As Path

Configuring a Community for use in BGP Routing Policy Conditions (NSM Procedure)

A community is a group of destinations that share a common property. You can
define a community for use in a BGP routing policy match condition.

To configure a community for a BGP routing policy in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Policy Options.

5. Select Community.

6. Add or modify the parameters as specified in Table 22 on page 36.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.
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NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 22: Community Configuration Details

Your ActionFunctionOption

Enter the name.Specifies the name of the community.Name

Enter the comment.Specifies the comment for the
community.

Comment

Select the check-box if you want to
invert the results. Clear the check-box
if you do not want to invert the results.

Enables you to invert the results for the
community expression.

Invert Match

1. Select Members.

2. Click the New button or select a
member and click the Edit button.

3. Enter the member community.

4. Click OK, then click OK again.

Specifies one or more community
members.

Members

Configuring a BGP Export Policy Condition (NSM Procedure)

You can define a routing policy condition based on the existence of routes in specific
tables for use in a BGP export policy.

To configure condition in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Policy Options.

5. Select Condition.

6. Add or modify the parameters as specified in Table 23 on page 37.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.
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NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 23: Condition Configuration Details

Your ActionFunctionOption

Enter a name.Specifies the name of the condition.Name

Enter a comment.Specifies the comment for the condition.Comment

1. Select Route Active On.

2. Select one:

■ None—No policy condition
based on routes need to be
specified.

■ if-route-exists—Specify the
policy condition based on the
routes. Enter the comment,
route and the corresponding
routing table.

3. Click OK.

Enables you to specify the policy
condition based on the existing routes
and the corresponding route tables.

Route Active On

Configuring Flap Damping to Reduce the Number of BGP Update Messages (NSM
Procedure)

To advertise network reachability information, BGP systems send an excessive
number of update messages. You can use flap damping to reduce the number of
update messages sent between BGP peers, thereby reducing the load on these peers
without adversely affecting the route convergence time. Damping reduces the number
of update messages by marking these routes as ineligible, so that they cannot be
selected as active or preferable routes. Applying damping leads to some delay, or
suppression, in the propagation of route information, but the result is increased
network stability. You can define actions by creating a named set of damping
parameters and including the set in a routing policy.

To configure damping for a BGP routing policy in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Policy Options.

5. Select Damping.
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6. Add or modify the parameters as specified in Table 24 on page 38.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 24: Damping Configuration Details

Your ActionFunctionOption

Enter a name.Specifies the name of the damping
parameter setting.

Name

Enter a comment.Specifies the comment for the damping
parameter setting.

Comment

Select the check-box to disable damping.
Clear the check-box to enable damping.

Enables you to disable damping on a
per-prefix basis. Any damping state that
is present in the routing table for a
prefix is deleted if damping is disabled.

Disable

Enter the time limit in minutes or select
it from the list.

Indicates the time in minutes interval
after which the accumulated
figure-of-merit value is reduced by half
if the route remains stable.
Figure-of-merit values correlate to the
probability of future instability of a
device. Routes with higher
figure-of-merit values are suppressed for
longer periods of time.

Half Life

Enter the value or select it from the list.Indicates the figure-of-merit value below
which a suppressed route can be used
again.

Reuse

Enter the value or select it from the list.Indicates the figure-of-merit value above
which a route is suppressed for use or
inclusion in advertisements.

Suppress

1. Enter the time limit or select it
from the list.

2. Click OK.

Indicates the maximum time in minutes
that a route can be suppressed no
matter how unstable it has been.

Max Suppress
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Configuring a Routing Policy Statement (NSM Procedure)

You can configure policy statements for routing policies. Each policy statement is
composed of from criteria, to criteria and then criteria. The from and to criteria
comprise a set of match conditions for the routing policy. The then criteria specify
the action to be taken when the from and to criteria are matched and when they are
not matched.

To configure a routing policy statement in NSM :

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Policy Options.

5. Select Policy statement.

6. Add/Modify the parameters as specified in Table 25 on page 39.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 25: Configuring Policy Statement Fields

Your ActionFunctionOption

1. Click the New button or select a
policy statement and click Edit
button.

2. Select policy-statement .

3. Specify the name.

Specifies the name of the policy
statement.

Name

1. Click the New button or select a
policy statement and click Edit
button.

2. Select policy-statement .

3. Specify the comment.

Specifies the comment for the policy
statement.

Comment
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Table 25: Configuring Policy Statement Fields (continued)

Your ActionFunctionOption

1. Click the New button or select a
policy statement and click Edit
button.

2. Expand policy-statement tree and
select From.

3. Enter the From criteria.

4. Expand From  tree and specify the
match conditions.

Enables you to define the criteria that
an incoming route must match. You can
specify one or more match conditions.
If you specify more than one, all
conditions must match the route for a
match to occur.

From

1. Click the New button or select a
policy statement and click Edit
button.

2. Expand policy-statement tree and
select Term.

3. Click the New button or select a
term and click Edit button.

4. Enter the term name, comment
and the match conditions and
actions.

Indicates the term to be configured for
the routing policy. You can create one
or more terms for a routing policy. Each
term comprises of match conditions and
the corresponding actions.

Term

1. Click the New button or select a
policy statement and click Edit
button.

2. Expand policy-statement tree and
select Then.

3. Specify the parameters for Then
criteria.

4. Expand Then  tree and specify the
actions for each match condition.

Enables you to define the action to be
taken in the case of a match or
mismatch between the packets and
From and To conditions.

Then

1. Click the New button or select a
policy statement and click Edit
button.

2. Expand policy-statement tree and
select To.

3. Enter the To criteria.

4. Expand To  tree and specify the
match conditions.

Enables you to define the criteria that
an outgoing route must match. You can
specify one or more match conditions.
If you specify more than one, all
conditions must match the route for a
match to occur.

To

Configuring Prefix List (NSM Procedure)

A prefix list is a named list of IP addresses. You can specify an exact match with
incoming routes and apply a common action to all matching prefixes in the list. This
feature enables you to create a named prefix list and include it in a routing policy.
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To configure prefix list in NSM:

1. In the navigation tree select Device Manager > Devices  and select the device
from the list.

2. In the configuration tree, expand Policy Options.

3. Select Prefix List.

4. Add/Modify the parameters as specified in Table 26 on page 41.

5. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 26: Configuring Prefix List Fields

Your ActionFunctionField

1. Click the New button or select a
prefix list and click Edit button.

2. Select prefix-list .

3. Specify the name.

Specifies the name of the prefix list.Name

1. Click the New button or select a
prefix list and click Edit button.

2. Select prefix-list .

3. Specify the comment.

Specifies the comment for the prefix list.Comment

1. Click the New button or select a
prefix list and click Edit button.

2. Select prefix-list .

3. Specify the path.

Indicates that the prefix list should
include all IP prefixes pointed to by a
defined path.

Apply Path

1. Click the New button or select a
prefix list and click Edit button.

2. Expand prefix-list tree and select
Prefix List Item.

3. Specify the name and comment.

Specifies the prefix list item.Prefix List Item
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Chapter 7

Configuring Routing Options in J Series
Services Routers and SRX Series
Services Gateways

■ Configuring Maximum Prefixes (NSM Procedure) on page 43

■ Configuring Multicast (NSM Procedure) on page 45

■ Configuring Multipath (NSM Procedure) on page 48

■ Configuring Options (NSM Procedure) on page 49

■ Configuring Route Resolution (NSM Procedure) on page 50

■ Configuring Routing Table Groups (NSM Procedure) on page 51

■ Configuring Routing Tables (NSM Procedure) on page 53

■ Configuring Source Routing (NSM Procedure) on page 55

■ Configuring Static Routes (NSM Procedure) on page 56

■ Configuring Generated Routes (NSM Procedure) on page 57

■ Configuring Graceful Restart (NSM Procedure) on page 58

■ Configuring Forwarding Table (NSM Procedure) on page 59

■ Configuring Flow Route (NSM Procedure) on page 61

■ Configuring Fate Sharing (NSM Procedure) on page 63

■ Configuring Martian Addresses (NSM Procedure) on page 64

■ Configuring Interface Routes (NSM Procedure) on page 66

■ Configuring Instance Export (NSM Procedure) on page 67

■ Configuring Instance Import (NSM Procedure) on page 67

Configuring Maximum Prefixes (NSM Procedure)

You can configure a limit for the number of routes installed in a routing table based
upon the number of route prefixes in the table. .

To configure maximum prefixes limit in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.
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3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Maximum Prefixes.

6. Enter the parameters as specified in Table 27 on page 44.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 27: Configuring Maximum Prefixes Fields

Your ActionFunctionOption

Enter the comment.Specifies the comment for the
maximum prefix limit.

Comment

Enter limit value or select from the list.Indicates the maximum number of route
prefixes. If this limit is reached, a
warning is triggered and additional
routes are rejected.

Limit

Enter the log interval value or select
from the list.

Indicates the minimum time interval (in
seconds) between log messages.

Log Interval

1. Expand the Maximum Prefixes tree
and select Threshold.

2. Select the option button.

Specifies what is to be done when the
routing table reaches the maximum
prefix value. The options are:

■ None—No action is to be taken.

■ threshold—You can configure a
percentage for the maximum
number of prefixes, which when
installed, triggers the warning.

■ log-only—Sets the prefix limit as
an advisory limit. An advisory limit
triggers only a warning, and
additional routes are not rejected.

Threshold

44 ■ Configuring Maximum Prefixes (NSM Procedure)

Configuring J Series Services Routers and SRX Series Services Gateways Guide



Configuring Multicast (NSM Procedure)

You can configure generic multicast properties for routing instances. A routing instance
is a collection of routing tables, interfaces, and routing protocol parameters. The
routing protocol parameters control the information in the routing tables.

To configure generic multicast properties for routing instance in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Multicast.

6. Add or modify the parameters as specified in Table 28 on page 45.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 28: Configuring Multicast Fields

Your ActionFunctionOption

Enter the comment.Specifies the comment for the multicast
configuration.

Comment

1. Expand the Multicast tree and
select Backup Pe Group.

2. Click the New button or select a
group and click the Edit button.

3. Configure the PE group name, local
address, and backup address.

Enables you to configure a backup
provider edge (PE) group for ingress PE
device redundancy when
point-to-multipoint (P2MP)
label-switched paths (LSPs) are used for
multicast distribution.

Backup Pe Group
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Table 28: Configuring Multicast Fields (continued)

Your ActionFunctionOption

1. Expand the Multicast tree and
select Flow Map.

2. Click the New button or select a
flow map and click the Edit button.

3. Configure the following to create
and define a flow map:

■ Enter the flow map name and
comment.

■ Bandwidth—Specify the
bandwidth property of the
multicast flow map.

■ Forwarding Cache—Specify
the forwarding cache
properties of entries defined
by a flow map. You can
specify a timeout of never to
make the forwarding entries
permanent, or you can specify
a timeout from 1 through 720
minutes.

■ Policy—Specify the flow map
policies.

■ Redundant Sources—Specify
the addresses for use as
backup sources for multicast
flows defined by a flow map.

Enables you to set up multicast flow
maps to manage a subset of multicast
forwarding table entries. For example,
you can specify that certain forwarding
cache entries be permanent or have a
different timeout value than those of
other multicast flows that are not
associated with this flow map .

Flow Map

1. Expand the Multicast tree and
select Forwarding Cache.

2. Configure the timeout and
threshold values.

Enables you to configure multicast
forwarding cache properties. These
properties include threshold suppression
and reuse limits, and timeout values.

You can specify a value for the threshold
to suppress new multicast forwarding
cache entries and an optional reuse
value for the threshold at which the
device begins to create new multicast
forwarding cache entries. If you
configure both reuse and suppression
values, configure a reuse value that is
less than the suppression value. The
suppression value is mandatory. If you
do not specify the optional reuse value,
then the number of multicast forwarding
cache entries is limited to the
suppression value. A new entry is
created as soon as the number of
multicast forwarding cache entries falls
below the suppression value. You can
also specify a timeout value for all
multicast forwarding cache entries.

Forwarding Cache
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Table 28: Configuring Multicast Fields (continued)

Your ActionFunctionOption

1. Expand the Multicast tree and
select Interface.

2. Configure the interface and the
bandwidth.

Enables you to configure the interfaces
for multicast properties on which you
plan to manage the maximum
bandwidth.

Interface

1. Expand the Multicast tree and
select Rpf Check Policy.

2. Click the New button or select a
policy and click the Edit button.

3. Enter the RPF check policy name.

Multicast reverse path forwarding (RPF)
checks are used to prevent multicast
routing loops. Routing loops are
particularly debilitating in multicast
applications because packets are
replicated with each pass around the
routing loop.

You can apply policies for disabling
reverse-path forwarding (RPF) checks
on arriving multicast packets.

Rpf Check Policy

1. Expand the Multicast tree and
select Scope.

2. Configure the scope and the
interface for the multicast.

Enables you to configure multicast
scoping to limit multicast traffic by
configuring it to an administratively
defined topological region. Multicast
scoping controls the propagation of
multicast messages—both multicast
group joins upstream toward a source
and data forwarding downstream.
Scoping can relieve stress on scarce
resources, such as bandwidth, and
improve privacy or scaling properties.

Scope

1. Expand the Multicast tree and
select Scope Policy.

2. Specify the scope policy for the
multicast group.

Enables you to configure multicast
scoping policy. A multicast scope policy
contains a set of device interfaces on
which you are configuring scoping and
the scope's address range configured as
a series of device filters.

Scope Policy

1. Expand the Multicast tree and
select Ssm Groups.

2. Click the New button or select a
group and click the Edit button.

3. Specify the address range of the
SSM group.

Enables you to configure source- specific
multicast (SSM) groups. SSM is a service
model that identifies session traffic by
both source and group address. Using
SSM, a client can receive multicast traffic
directly from the source. To deploy SSM
successfully, you need an end-to-end
multicast-enabled network and
applications that use an Internet Group
Management Protocol version 3
(IGMPv3).

Ssm Groups

1. Expand the Multicast tree and
select Ssm Map.

2. Click the New button or select an
SSM map and click the Edit button.

3. Specify the SSM policy for the SSM
map and the source address.

SSM mapping translate IGMPv1 or
IGMPv2 membership reports to an
IGMPv3 report allowing you to support
an SSM network without requiring all
hosts to support IGMPv3.

Ssm Map
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Table 28: Configuring Multicast Fields (continued)

Your ActionFunctionOption

1. Expand the Multicast tree and
select the Traceoptions tab.

2. Set up the file and flag parameters.

Defines tracing options for the multicast
group. You can also set up the file
management and access control
parameters .

Traceoptions

Configuring Multipath (NSM Procedure)

You can configure protocol-independent load balancing for Layer 3 virtual private
networks (VPNs) with load sharing among multiple external BGP paths and multiple
internal BGP paths. You can use forwarding next hops for both the active route and
alternative paths for load balancing.

To configure multipath load balancing in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Multipath.

6. Enter the parameters as specified in Table 29 on page 48.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 29: Configuring Multipath Fields

Your ActionFunctionOption

Enter the comment.Specifies the comment for the multipath
configuration.

Comment

48 ■ Configuring Multipath (NSM Procedure)

Configuring J Series Services Routers and SRX Series Services Gateways Guide



Table 29: Configuring Multipath Fields (continued)

Your ActionFunctionOption

1. Expand the Multipath tree and
select Vpn Unequal Cost.

2. Enter the comment for the vpn
unequal cost configuration and
specify whether both external and
internal BGP paths should be
selected for the multipath
configuration by selecting the Equal
External Internal check box.

Applies protocol-independent load
balancing to VPN routes.

Vpn Unequal Cost

Configuring Options (NSM Procedure)

You can configure the types of system logging messages sent about the routing
protocols process to the system log message file. These messages are also displayed
on the system console. You can log messages at a particular level or up to and
including a particular level.

To configure options in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Options.

6. Enter the parameters as specified in Table 30 on page 50.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.
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Table 30: Configuring Options Fields

Your ActionFunctionOption

Enter the comment.Specifies the comment for the message
option.

Comment

Enter the mark value or select from the
list.

Specifies the mark for the option.Mark

1. Expand the Options tree and select
Syslog.

2. Select the severity levels for system
log messages.

Enables you to configure the generation
of system log messages for a particular
severity level and all higher levels.

Syslog

Configuring Route Resolution (NSM Procedure)

You can configure a routing table to accept routes from specific routing tables to
enable the device to manage and route the traffic effectively between a source host
and destination host. You can configure a routing table to use specific import policies
to produce a route resolution table to resolve routes.

To configure a route resolution table in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Resolution.

6. Add or modify the parameters as specified in Table 31 on page 51.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.
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Table 31: Route Resolution Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the route
resolution.

Comment

1. Expand the Resolution tree and
select Rib.

2. Click the New button or select a
routing table and click the Edit
button.

3. Enter the name and comment for
the routing table and specify the
route import policies and the
resolution routes.

Specifies the name of the routing table
for which the import policies and the
resolution routes are configured.

Rib

1. Expand the Resolution tree and
select Tracefilter.

2. Specify the filter policies for the
routing table.

Specifies the filter policy for the
resolution routes.

Tracefilter

1. Expand the Resolution tree and
select Traceoptions.

2. Expand the Traceoptions tree and
set up the file and flag parameters.

Defines tracing options for route
resolution.

Traceoptions

Configuring Routing Table Groups (NSM Procedure)

You can group together one or more routing tables to form a routing table (RIB)
group. Within a group, a routing protocol can import routes into all the routing tables
in the group and can export routes from a single routing table. Each routing table
group contains one or more routing tables that the JUNOS software uses when
importing routes. In the same way, each routing table group optionally contains one
routing table that the JUNOS software uses when exporting routes to the routing
protocols. You can also specify the import and the export route tables and the import
policies for the routing table group.

To configure routing table groups in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Rib Groups.

6. Add or modify the parameters as specified in Table 32 on page 52.

7. Click one:
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■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 32: Rib Group Fields

Your ActionFunctionOption

1. Expand the Routing Options tree
and select Rib Group.

2. Click the New button or select a
routing table group and click the
Edit button.

3. Enter the name for the routing
table group.

Specifies the unique name for the
routing table group.

Name

1. Expand the Routing Options tree
and select Rib Group.

2. Click the New button or select a
routing table group and click the
Edit button.

3. Enter the comment for the routing
table group.

Specifies the comment for the rorouting
table group.

Comment

1. Expand the Routing Options tree
and select Rib Group.

2. Click the New button or select a
routing table group and click the
Edit button.

3. Enter the name of the routing table.

Specifies the routing table from which
the JUNOS software exports routing
information.

Export Rib

1. Expand the rib-group tree and select
Import Policy.

2. Set up the import policies for the
routing table group.

Enables you to apply one or more
policies to routes imported into the
routing table group.

Import Policy
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Table 32: Rib Group Fields (continued)

Your ActionFunctionOption

1. Expand the rib-group tree and select
Import Policy.

2. Enter the name of the routing table.

Specifies the name of the routing table
into which the JUNOS software is to
import routing information. The first
routing table name you enter is the
primary routing table. Any additional
names you enter identify secondary
routing tables. When a protocol imports
routes, it imports them into the primary
and any secondary routing tables.

Import Rib

Configuring Routing Tables (NSM Procedure)

This feature enables you to configure routing tables. You can also configure the static,
martians, aggregate, maximum paths, maximum prefixes, multipath, or generated
routes to the routing table. If you are not adding any of those routes, then the creation
of the routing table is optional. The JUNOS software uses its default routing tables,
which are inet.0 for IPv4 unicast routes, inet6.0 for IPv6 unicast routes, inet.1 for the
IPv4 multicast forwarding cache, and inet.3 for IPv4 MPLS.

To configure a routing table in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Rib.

6. Add or modify the parameters as specified in Table 33 on page 54.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.
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Table 33: Rib Fields

Your ActionFunctionOption

1. Expand the Routing Options tree
and select Rib.

2. Click the New button or select a
routing table and click the Edit
button.

3. Enter the name for the routing
table.

Specifies the unique name for the
routing table.

Name

1. Expand the Routing Options tree
and select Rib.

2. Click the New button or select a
routing table and click the Edit
button.

3. Enter the comment for the routing
table.

Specifies the comment for the route
resolution.

Comment

1. Expand the Rib tree and select
Aggregate.

2. Select the global aggregate route
options in Defaults and individual
aggregate route options in Route.

Enables you to configure the aggregate
routes for the routing table. Aggregation
allows you to combine groups of routes
with common addresses into a single
entry in the routing table. This decreases
the size of the routing table as well as
the number of route advertisements sent
by the router.

Aggregate

1. Expand the Rib tree and select
Generate.

2. Select the default route to the
destination address in Defaults and
individually generated route
options in Route.

Enables you to configure generated
routes, which are used as routes of last
resort in the routing table.

Generate

1. Expand the Rib tree and select
Martian.

2. Enter the martian addresses.

Enables you to configure martian
addresses in the routing table.

Martians

1. Expand the Rib tree and select
Maximum Paths.

2. Enter the Maximum Paths and the
Threshold.

Enables you to configure a limit for the
number of routes installed in a routing
table.

Maximum Paths

1. Expand the Rib tree and select
Maximum Prefixes.

2. Set up the Maximum Prefixes and
the Threshold.

Enables you to configure a limit for the
number of routes installed in a routing
table.

Maximum Prefixes
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Table 33: Rib Fields (continued)

Your ActionFunctionOption

1. Expand the Rib tree and select
Multipath.

2. Enter the multipath options.

Enables you to configure the multipath
option in the routing table for load
sharing between external BGP and
internal BGP.

Multipath

1. Expand the Rib tree and select
Static.

2. Enter the global static route in
Defaults and destination address of
the static route in Route.

Enables you to configure static routes to
be installed in the routing table.

Static

Configuring Source Routing (NSM Procedure)

You can configure source routing to specify IP addresses of the devices along the
path, that you want an IP packet to take on its way to its destination.

To configure source routing in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Source Routing.

6. Enter the parameters as specified in Table 34 on page 55.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 34: Source Routing Fields

Your ActionFunctionOption

Enter the comment.Specifies the comment for the source
routing configuration.

Comment
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Table 34: Source Routing Fields (continued)

Your ActionFunctionOption

Select the check box.Specifies the IPv4 addressing family for
source routing.

Ip

Select the check box.Specifies the IPv6 addressing family for
source routing.

Ipv6

Configuring Static Routes (NSM Procedure)

You can configure static routes for a routing table group. A router uses static routes
in the following scenarios:

■ When it does not have a route to a destination that has a better (lower) preference
value.

■ When it cannot determine the route to a destination.

■ When it is forwarding unroutable packets.

A static route is installed in the routing table only when the route is active; that is,
the list of next-hop routers configured for that route contains at least one next hop
on an operational interface.

To configure static routes for a routing table group in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Static.

6. Add or modify the parameters as specified in Table 35 on page 57.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.
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Table 35: Static Fields

Your ActionFunctionOption

Enter the comment.Specifies the comment for the static
route.

Comment

Enter the name.Specifies the routing table group name
for which the static route is configured.

Rib Group

1. Expand the Static tree and select
Defaults.

2. Enter the default route to the
destination address.

Enables you to configure the global static
route options. These options only set
the global defaults and apply to all the
configured static routes.

Defaults

1. Expand the Static tree and select
Route.

2. Enter the individual route.

Enables you to configure the individual
static routes options. These options
apply to the individual destination only
and override any options configured in
the Defaults section.

Route

Configuring Generated Routes (NSM Procedure)

Generated routes are used as routes of last resort. A packet is forwarded to the route
of last resort when the routing tables have no information about how to reach that
packet’s destination. One use of route generation is to create a default route to use
if the routing table contains a route from a peer on a neighboring backbone network.
A generated route becomes active when it has one or more contributing routes. A
contributing route is an active route that is a specific match for the generated
destination.

For example, for the destination 128.100.0.0/16, routes to 128.100.192.0/19 and
128.100.67.0/24 are contributing routes, but routes to 128.0.0.0./8, 128.0.0.0/16,
and 128.100.0.0/16 are not. A route can contribute only to a single generated route.
However, an active generated route can recursively contribute to a less specific
matching generated route. For example, a generated route to the destination
128.100.0.0/16 can contribute to a generated route to 128.96.0.0/13. By default,
when generated routes are installed in the routing table, the next hop device selects
from the primary contributing route.

To configure generated routes in NSM:

1. In the navigation tree, select Device Manager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Generate.

6. Add or modify the parameters as specified in Table 36 on page 58.

7. Click one:
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■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 36:  Generated Routes Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the generated
route.

Comment

1. Expand the Generate tree and
select Defaults.

2. Configure the default route options.

Enables you to specify globally
generated route options. These are
treated as global defaults and apply to
all the generated routes you configure.

Defaults

1. Expand the Generate tree and
select Route.

2. Configure the individual route
options.

Enables you to configure individually
generated routes. You can also configure
globally generated route options. These
options apply to the individual
destination only and override any
options you configured in Defaults.

Route

Configuring Graceful Restart (NSM Procedure)

Graceful restart allows a device undergoing a restart to inform its adjacent neighbors
and peers of its condition. The restarting device requests a grace period from the
neighbor or peer, which can then cooperate with the restarting device. With a graceful
restart, the restarting device can still forward traffic during the restart period, and
convergence in the network is not disrupted. The restart is not visible to the rest of
the network, and the restarting device is not removed from the network topology.

The graceful restart request occurs only if the following conditions are met:

■ The network topology is stable.

■ The neighbor or peer cooperates.

■ The restarting device is not already cooperating with another restart already in
progress.

■ The grace period does not expire.

To configure graceful restart in NSM:
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1. In the navigation tree, select Device Manager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Graceful Restart.

6. Enter the parameters as specified in Table 37 on page 59.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 37:  Graceful Restart Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the graceful
restart.

Comment

■ Select the check box to disable
graceful restart.

■ Clear the check box to enable
graceful restart.

Specifies whether graceful restart is
enabled for the device.

Disable

Enter a value for the duration or select
a value from the list.

Specifies the duration of the grace
period for the device to restart.

Restart Duration

Configuring Forwarding Table (NSM Procedure)

A forwarding table contains the routes actually used to forward packets through the
device to their next-hop destination. This feature enables you to configure forwarding
table in NSM.

To configure forwarding table in NSM:

1. In the navigation tree, select Device Manager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.
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5. Select Forwarding Table.

6. Add or modify the parameters as specified in Table 38 on page 60.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 38:  Forwarding Table Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the
forwarding table.

Comment

Select the option button.Specifies that no next- hop parameter
is to be added to the forwarding table.

None

Select the option button to enable
indirect-next- hop.

Specifies that the forwarding table
supports indirectly connected next hops.

indirect-next-hop

Select the option button to enable
no-indirect-next- hop.

Specifies that the forwarding table does
not support indirectly connected next
hops.

no-indirect-next-hop

Select the path from the drop-down list.Enables you to check path validity to
protect the network from IP spoofing.
A unicast reverse-path-forwarding (RPF)
check performs a routing table lookup
on an IP packet’s source address and
checks the incoming interface. The
device determines whether the packet
is arriving from a path that the sender
would use to reach the destination. If
the packet is from a valid path, the
device forwards the packet to the
destination address. If it is not from a
valid path, the device discards the
packet.

Unicast Reverse Path

1. Expand the Forwarding Table tree
and select Export.

2. Enter the export policies.

Enables you to apply one or more
policies to routes being exported from
the routing table into the forwarding
table.

Export
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Configuring Flow Route (NSM Procedure)

Flow routes provide traffic filtering and rate-limiting capabilities much like firewall
filters. You can propagate flow routes across different autonomous systems. A flow
route is an aggregation of match conditions for IP packets. Flow routes are propagated
through the network using flow-specific network-layer reachability information (NLRI)
messages and are maintained in the flow routing table. Packets can travel through
flow routes only if specific match conditions are met. Flow routes and firewall filters
are similar in that they filter packets based on packet components and perform an
action on the packets that match.

To configure a flow route in NSM:

1. In the navigation tree, select Device Manager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Flow.

6. Add or modify the parameters as specified in Table 39 on page 61.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 39: Flow Route Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the flow
route.

Comment

Route

1. Expand the Flow tree and select
Route.

2. Click the New button or select a
flow route and click the Edit button.

3. Enter the flow route name.

Specifies the name of the flow route.Name
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Table 39: Flow Route Fields (continued)

Your ActionFunctionOption

1. Expand the Flow tree and select
Route.

2. Click the New button or select a
flow route and click the Edit button.

3. Enter the comment for the flow
route.

Specifies the comment for the flow
route.

Comment

1. Expand the Route tree and select
Match.

2. Enter a comment for Comment, a
destination address for Destination,
and a source address for Source.

3. Configure the match conditions.

Specifies the conditions that the packet
must match for the packet to be
included in flow route. Match conditions
are:

■ Destination Port

■ DSCP

■ Fragment

■ Icmp Code

■ Icmp Type

■ Packet Length

■ Port

■ Protocol

■ Source Port

■ Tcp Flag

Match

1. Expand the Route tree and select
Then.

2. Configure the then conditions for
the packet.

Enables you to specify the action to take
if the packet matches the conditions you
have configured in the flow route.

Then

Validation

1. Expand the Flow tree and select
Validation.

2. Enter the comment for the
validation procedure.

Specifies a comment for the validation
procedure. Flow routes are installed into
the flow routing table only if they have
been validated using the validation
procedure.

Comment

1. Expand the Validation tree and
select Traceoptions.

2. Expand the Traceoptions tree and
configure the file and flag
parameters, and the tracing policy.

Enables you to define tracing operations
that track all routing protocol
functionality in the device and specify
that tracing results be saved in a log file.
You can configure the tracing flag, filter,
and the tracing policy.

Traceoptions

62 ■ Configuring Flow Route (NSM Procedure)

Configuring J Series Services Routers and SRX Series Services Gateways Guide



Configuring Fate Sharing (NSM Procedure)

Fate sharing allows you to create a database of information that the constrained
shortest path first (CSPF) algorithm uses to compute one or more backup routing
paths to use in case the primary path becomes unstable. The database describes the
relationships between elements of the network. Through fate sharing, you can
configure backup paths that minimize the number of shared links and fiber optic
cables, to ensure that in the event of damage to a fiber optic cable, only the minimum
amount of data is lost and that a path still exists to the destination. For a backup
path to work optimally, it must not share links or physical fiber optic cables with the
primary path. This ensures that a single point of failure will not affect the primary
and backup paths at the same time.

This feature enables you to specify groups of objects that share characteristics resulting
in backup paths to be used if primary paths fail. All objects are treated as /32 host
addresses. You can specify one or more objects within a group. The objects can be
LAN interfaces, device IDs, or point-to-point links.

To configure fate sharing in NSM:

1. In the navigation tree, select Device Manager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Fate Sharing.

6. Add or modify the parameters as specified in Table 40 on page 63.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 40: Fate Sharing Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the fate
sharing.

Comment

Group
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Table 40: Fate Sharing Fields (continued)

Your ActionFunctionOption

1. Expand the Fate Sharing tree and
select Group.

2. Click the New button or select a
group and click the Edit button.

3. Enter the group name.

Specifies the name of the fate sharing
group.

Name

1. Expand the Fate Sharing tree and
select Group.

2. Click the New button or select a
group and click the Edit button.

3. Enter the comment.

Specifies the comment for the fate
sharing group.

Comment

1. Expand the Fate Sharing tree and
select Group.

2. Click the New button or select a
group and click the Edit button.

3. Enter the cost or select a value
from the list.

Specifies the configurable cost attributed
to each group, which represents the
level of impact this group has on CSPF
computations. The higher the cost, the
less likely a backup path will share any
objects in the group with the primary
path.

Cost

1. Expand the Group tree and select
From.

2. Click the New button or select a
group and click the Edit button.

3. Specify the From address.

Specifies the from address and to
address for point-to-point link objects.

From

Configuring Martian Addresses (NSM Procedure)

Martian addresses are host or network addresses about which all routing information
is ignored. They commonly are sent by improperly configured systems on the network
and have destination addresses that are obviously invalid. You can configure a
particular martian address or a range of martian addresses as allowed or disallowed.
You can use the match criteria to configure a range of martian addresses.

To configure a martian address in NSM:

1. In the navigation tree, select Device Manager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Martians.

6. Add or modify the parameters as specified in Table 41 on page 65.

7. Click one:
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■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 41: Configuring Martian Address Fields

Your ActionFunctionOption

1. Click the New button or select a
martian address and click the Edit
button.

2. Enter the address.

Specifies the martian address or the
destination prefix of a series of martian
addresses that are to be allowed or
disallowed.

Address

1. Click the New button or select a
martian address and click the Edit
button.

2. Enter the comment for the martian
address.

Specifies the comment for the martian
address.

Comment

1. Click the New button or select a
martian address and click the Edit
button.

2. Select the check box to allow the
disallowed address. Selecting the
allow option deletes a particular
martian address from the range of
martian addresses.

3. Clear the check box to disallow the
addresses and mark them as a
martian address.

Enables you to explicitly allow a subset
of a range of addresses that are to be
disallowed.

Allow

1. Click the New button or select a
martian address and click the Edit
button.

2. Expand the Martian tree and select
Exact.

3. Enter the match criteria.

Specifies match criteria for the route’s
mask length with the martian address.
The criteria are:

■ Exact

■ Longer

■ Orlonger

■ Upto

■ Through

■ Prefix Length Range

Exact
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Configuring Interface Routes (NSM Procedure)

You can associate a routing table group with the device’s interfaces and specify
routing tables into which interface routes are imported. To define the routing tables
into which interface routes are imported, you create a routing table group and
associate it with the device’s interfaces.

To configure interface routes in NSM:

1. In the navigation tree, select Device Manager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Interface Routes.

6. Add or modify the parameters as specified in Table 42 on page 66.

7. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Table 42: Interface Routes Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the interface
route.

Comment

1. Expand the Interface Routes tree
and select Family.

2. Click the New button or select a
family name and click the Edit
button.

3. Enter the family name and
comment.

4. Set up the export policy and import
policy.

Specifies the address family as IPv4 or
IPv6.

Family
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Table 42: Interface Routes Fields (continued)

Your ActionFunctionOption

1. Expand the Interface Routes tree
and select Rib Group.

2. Enter the comment and Inet.

Specifies the routing table groups to
which interface routes are imported.

Rib Group

Configuring Instance Export (NSM Procedure)

Current configurations that use routing table groups define a policy to select routes
in an IGP export policy. However, no policy controls the export process itself. You
can configure the instance export policy to control the export process. The policy
model supports both interinstance route export and IGP export.

To configure an instance export policy in NSM:

1. In the navigation tree, select Device Manager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Instance Export and specify the export policies for routes being exported
from a routing instance.

6. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.

Configuring Instance Import (NSM Procedure)

You can apply one or more policies to routes being imported into a routing instance.

To configure instance import in NSM:

1. In the navigation tree, select Device Manager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.
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4. In the configuration tree, expand Routing Options.

5. Select Instance Import and specify the import policies to be applied to the routes
that are imported to a routing instance.

6. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply—To apply the routing option settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Updating Devices section in the
Network and Security Manager Administration Guide for more information.
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Chapter 8

Configuring Protocols for J Series
Services Routers and SRX Series
Services Gateways

■ Configuring BGP (NSM Procedure) on page 69

■ Configuring 802.1X Authentication (NSM Procedure) on page 72

■ Configuring GVRP (NSM Procedure) on page 74

■ Configuring IGMP (NSM Procedure) on page 75

■ Configuring MSTP (NSM Procedure) on page 77

■ Configuring OSPF (NSM Procedure) on page 79

■ Configuring RIP (NSM Procedure) on page 82

■ Configuring VSTP (NSM Procedure) on page 84

■ Configuring VRRP (NSM Procedure) on page 86

Configuring BGP (NSM Procedure)

Border Gateway Protocol (BGP) is used for exchanging routing information between
gateway hosts/internet service providers. The routing information refers to the routing
tables containing information about the list of known devices, the addresses they
can reach, and a cost metric associated with the path to each device so that the best
available route is chosen. The primary function of a BGP speaking system is to
exchange network reachability information with other BGP systems. This feature
enables you to configure BGP peering sessions.

To configure BGP in NSM:

1. In the navigation tree select Device Manager > Devices  and select the device
from the list.

2. In the configuration tree, expand Protocols.

3. Select BGP.

4. Add/Modify the parameters under the respective tabs as specified in Table 43
on page 70.

5. Click one:

■ OK—To save the changes.
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■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See Updating Devices for more
information.

Table 43: BGP Configuration Fields

Your ActionFunctionField

1. Expand the Protocol tree.

2. Select BGP and select General tab.

3. Specify the general parameters like
comment, description, local
address, hold time, etc.

The general parameters to be set up for
applying BGP.

General

1. Expand the Protocol tree.

2. Select BGP and select Path Selection
tab.

3. Set up the path selection
parameters and med plus IGP.

Enables you to specify the path selection
criteria.

Path Selection

1. Expand the Protocol tree.

2. Select BGP and select Traceoptions
tab.

3. Set up the file and flag parameters.

Defines trace options for IGMP
snooping.

Traceoptions

1. Expand the Protocol tree.

2. Select BGP and select Metric Out
tab.

3. Set up the metric value and
minimum IGP.

Enables you to specify the metric value
to add to the routes transmitted to the
neighbor.

Metric Out

1. Expand the Protocol tree.

2. Select BGP and select Multihop tab.

3. Set up the comment, Ttl and
specify whether the next hop has
to be changed.

If an EBGP peer is more than one hop
away from the local router, you must
specify the next hop to the peer so that
the two systems can establish a BGP
session. This type of session is called a
multihop BGP session.

Multihop
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Table 43: BGP Configuration Fields (continued)

Your ActionFunctionField

1. Expand the Protocol tree.

2. Select BGP and select Advertise tab.

3. Specify whether Advertise has to
be inactivated and set up the
Advertise Peer As.

Enables you to specify whether BGP
should advertise the best route even if
the routing table did not select it to be
an active route.

Advertise

1. Expand the Protocol tree.

2. Select BGP and select Import tab.

3. Specify the export policies
configured on the peer.

Enables you to apply one or more
routing policies to routes being imported
into the JUNOS routing table from BGP
.

Import

1. Expand the Protocol tree.

2. Select BGP and select Family tab.

3. Specify the Family and Inet
parameters.

4. Expand the Inet tree and set up the
parameters.

Enables you to configure protocol family
information for the logical interface.

Family

1. Expand the Protocol tree.

2. Select BGP and select Authentication
Settings tab.

3. Specify the authentication key,
algorithm and key chain.

Enables you to specify the
authentication settings for BGP.

Authentication Settings

1. Expand the Protocol tree.

2. Select BGP and select Export tab.

3. Specify the export policies
configured on the peer.

Enables you to apply one or more
routing policies to routes being exported
from the JUNOS routing table from BGP
.

Export

1. Expand the Protocol tree.

2. Select BGP and select Local As tab.

3. Enter the comment, as number,
loop and specify whether it is
private.

Enables you to configure BGP with a
different local autonomous session (AS)
number for each BGP session

Local As

1. Expand the Protocol tree.

2. Select BGP and select Graceful
Restart tab.

3. Specify the graceful restart
parameters.

Enables you to specify the graceful
restart parameters.

Graceful Restart
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Table 43: BGP Configuration Fields (continued)

Your ActionFunctionField

1. Expand the Protocol tree.

2. Select BGP and select Bfd Liveness
Detection tab.

3. Specify the Bfd Liveness Detection
parameters, Detection Time and
Transmit Interval.

Enables you to configure bidirectional
forwarding detection (BFD) timers.

Bfd Liveness Detection

1. Expand the Protocol tree.

2. Select BGP and select Group tab.

3. Click the New button or select a
group and click Edit button.

4. Enter all the group parameters.

Enables you to configure BGP group.Group

Configuring 802.1X Authentication (NSM Procedure)

IEEE 802.1X authentication provides network edge security, protecting Ethernet
LANs from denial-of-service (DoS) attacks and preventing unauthorized user access.

802.1X works by using an Authenticator Port Access Entity (the device) to block all
traffic to and from a supplicant (client) at the interface until the supplicant's credentials
are presented and matched on the Authentication server (a RADIUS server). When
authenticated, the switch stops blocking and opens the interface to the supplicant.

To configure 802.1X authentication:

■ Specify 802.1X interface settings on the switch.

■ Specify the 802.1X exclusion list, used to specify which supplicants can bypass
802.1X authentication and be automatically connected to the LAN.

1. Configuring 802.1X Interface Settings on page 72

2. Configuring Static MAC Bypass on page 74

Configuring 802.1X Interface Settings

To configure 802.1X interface settings:

1. In the navigation tree, select Device Manager > Devices. In Device Manager,
select the device for which you want to configure 802.1X settings.

2. In the Configuration tree, expand Protocols > Dot1x.

4. Select Authenticator > Interface.

5. Click the Add icon.

6. Add/modify member settings for the interface as specified in Table 44 on page 73.
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NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See Updating Devices for more
information.

Table 44: 802/1X Authentication for an Interface

Your ActionFunctionOption

Enter the nameSpecifies the name for the profile.Authentication Profile
Name

Select Interface.

Click the Add icon.

Specifies the interface for which 802.1X authentication is
being configured.

Interface

Enter the interface name.Specifies the interface name.Name

Select to disable authentication.Disables 802.1X authentication on the interface.Disable

Select the required mode.Specifies the mode to be adopted for supplicants:

■ Single — allows only one host for authentication.

■ Multiple — allows multiple hosts for authentication.
Each host is checked before being admitted to the
network.

■ Single authentication for multiple hosts — Allows
multiple hosts but only the first is authenticated.

Supplicant

Select a value from the list.Maximum number of retriesRetries

Select a value from the list.Specifies the port waiting time after an authentication
failure.

Quiet Period

Select a value from the list.Specifies the retransmit interval.Transmit Period

Select a value from the list.Port timeout value for the response from the supplicant.Supplicant Timeout

Select a value from the list.Port timeout value for the response from the RADIUS serverServer Timeout

Select a value from the list.Specifies the maximum number of authentication requests
to be made to the server.

Maximum Requests

Enter the VLAN name.Specifies the guest VLAN to move the interface to in case
of an authentication failure.

Guest Vlan

Select Reauthentication.

Select one:

■ none

■ reauthentication

■ no-reauthentication

Specifies enabling reauthentication on the selected interface.Reauthentication
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Configuring Static MAC Bypass

Configure any MAC addresses, supplicants, or interfaces to be excluded from 802.1X
authentication—that is, they will be authenticated.

To configure the 802.1X exclusion:

1. Specify a MAC address to be excluded from 802.1X authentication in the field
Name.

2. Specify the interface for the supplicant to bypass authentication if connected
through that interface.

3. Specify the VLAN to move the supplicant to once it is authenticated.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See Updating Devices for more
information.

Configuring GVRP (NSM Procedure)

As a network expands and the number of clients and VLANs increases, VLAN
administration becomes complex, and the task of efficiently configuring VLANs on
multiple switches becomes increasingly difficult. To automate VLAN administration,
you can enable GARP VLAN Registration Protocol (GVRP) on the network.

GVRP learns VLANs on a particular 802.1Q trunk port, and adds the corresponding
trunk port to the VLAN if the advertised VLAN is preconfigured or existing already
on the switch. For example, a VLAN named “sales” is advertised to trunk port 1 on
the GVRP-enabled device. The device adds trunk port 1 to the sales VLAN if the sales
VLAN already exists on the switch.

As individual ports become active and send a request to join a VLAN, the VLAN
configuration is updated and propagated among the switches. Limiting the VLAN
configuration to active participants reduces the network overhead. GVRP also provides
the benefit of pruning VLANs to limit the scope of broadcast, unknown unicast, and
multicast (BUM) traffic to interested devices only.

To configure GVRP:

1. In the navigation tree, select Device Manager > Devices. In Device Manager,
select the device.

2. In the configuration tree, expand Protocols.

3. Select GVRP.

4. Click the Add icon.

5. Add/modify GVRP settings for the interface as specified in Table 45 on page 75.
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NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See Updating Devices for more
information.

Table 45: GVRP Configuration Fields

Your ActionFunctionOption

Click to select.Select this option to disable GVRP on the interface.Disable

Select a value.Specifies the maximum number of milliseconds the interfaces wait before
sending VLAN advertisements.

Join Timer

Select a value.Specifies the number of milliseconds an interface must wait after receiving
a leave message to remove the interface from the VLAN specified in the
message.

Leave Times

Select a value.Specifies the interval at which Leave All messages are sent on interfaces.
Leave All messages help to maintain current GVRP VLAN membership
information in the network.

Leaveall Times

Configuring IGMP (NSM Procedure)

Internet Group Management Protocol (IGMP) is an Internet protocol that provides a
way for an IP host to report its multicast group membership to adjacent devices. This
feature enables you to associate the IGMP with an interface and allocate it to a
multicast group.

To configure IGMP in NSM:

1. In the navigation tree select Device Manager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Protocols and select IGMP.

5. Add/Modify the parameters as specified in Table 46 on page 76.

6. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.
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NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See Updating Devices for more
information.

Table 46: IGMP Configuration Fields

Your ActionFunctionOption

IGMP

Enter a comment.Specifies the comment for IGMP.Comment

Select the query interval.Defines how often the device sends
general host-query messages. .

Query Interval

Enter the query response interval.Defines how long the query
router/switch waits to receive a response
to a host-query message from a host.

Query Response Interval

Enter the query last member interval.Defines how often the device sends
group-specific query messages.

Query Last Member Interval

Select the robust count.Defines the number of intervals the
device waits before removing a multicast
group from the multicast forwarding
table.

Robust Count

Select to enable accounting.Specifies whether accounting is enabled
for IGMP.

Accounting

1. Expand the IGMP tree and select
Interfaces.

2. Click the New button or select an
interface and click Edit button.

3. Select Disable to disable IGMP on
the interface.

4. Select the version.

5. Specify the Ssm Map.

6. You can enable Immediate Leave
and Promiscuous Mode.

7. You can enable accounting on the
interface.

8. Select the option Interface > Static
to configure the multicast group to
be associated with the interface.

Specifies the interface and the multicast
group that has to be associated with
IGMP.

Interfaces
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Table 46: IGMP Configuration Fields (continued)

Your ActionFunctionOption

1. Expand IGMP tree and select
Traceoptions.

2. Enter a comment for traceoptions.

3. Expand the Traceoptions tree, select
File and set up the file parameters.

4. In the Traceoptions tree select Flag
and set up or edit the file
parameters.

Defines trace options for IGMP .Traceoptions

Configuring MSTP (NSM Procedure)

Multiple Spanning Tree Protocol (MSTP) is used to create a loop-free topology in
networks using multiple spanning tree regions, each region containing multiple
spanning-tree instances (MSTIs). MSTIs provide different paths for different VLANs.
This functionality facilitates better load sharing across redundant links.

MSTP supports up to 64 regions, each one capable of supporting 4094 MSTIs.

To configure MSTP:

1. In the navigation tree, select Device Manager > Devices. In Device Manager,
select the device for which you want to configure a port mirror analyzer.

2. In the Configuration tree, expand Protocols > MSTP.

3. Add/modify MSTP settings as specified in Table 47 on page 77.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See Updating Devices for more
information.

Table 47: MSTP Configuration Fields

Your ActionFunctionOption

Click to select the option.Specifies whether MSTP must be
disabled on the port.

Disable

Type a name.Specifies the configuration name.Configuration Name

Select a value.Specifies the configuration revision level.Revision Level

Select a value.Specifies the number of hops in a region
before the BPDU is discarded.

Max Hops
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Table 47: MSTP Configuration Fields (continued)

Your ActionFunctionOption

Select a value.Specifies the maximum-aging time for
all MST instances. The maximum aging
time is the number of seconds a switch
waits without receiving spanning-tree
configuration messages before
attempting a reconfiguration.

Max Age

Select a value.Specifies the hello time for all MST
instances.

Hello time

Select a value.Specifies the number of seconds a port
waits before changing from its
spanning-tree learning and listening
states to the forwarding state.

Forward Delay

Enter a value.Specifies the bridge priority.Bridge Priority

Select to enable the feature.Specifies whether Bpdu blocks must be
processed.

Bpdu Block on Edge

1. Click the expand icon.

2. Specify the interface name.

3. Specify the port priority.

4. Specify the path cost. MSTP uses
the path cost when selecting an
interface to place into the
forwarding state. A lower path cost
represents higher-speed
transmission.

5. Specify the mode. The link type
can be shared or point-to-point.

6. Select Edge to enable the feature.

7. Select No root port if it is not
specified.

8. Click OK.

9. Specify the Bpdu timeout action:

■ Block

■ Alarm

Specifies MSTP settings for the interface.Interface

1. Specify the Msti ID.

2. Enter a comment.

3. Specify the bridge priority.

4. Click OK.

Specifies MST instances settings for an
interface or VLAN.

Msti
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Configuring OSPF (NSM Procedure)

OSPF uses the shortest path first (SPF) algorithm to determine the route to reach
each destination. All devices in an area run this algorithm in parallel, storing the
results in their individual topological databases. Devices with interfaces to multiple
areas run multiple copies of the algorithm.

To configure OSPF in NSM:

1. In the navigation tree select Device Manager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Protocols and select OSPF.

5. Add/Modify the parameters under the respective tabs as specified in Table 48
on page 79.

6. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See Updating Devices for more
information.

Table 48: OSPF Configuration Fields

Your ActionFunctionOption

OSPF
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Table 48: OSPF Configuration Fields (continued)

Your ActionFunctionOption

1. Enter the comment.Specifies the comment for OSPF.Comment

1. Specify whether to enable or
disable OSPF.

■ To enable OSPF, clear the
check box.

■ To disable OSPF, select the
check box.

Specifies whether to disable the OSPF
configuration.

Disable

1. Enter the prefix export limit or
select from the list.

Configure a limit to the number of
prefixes to be exported.

Prefix Export Limit

1. Select rib group from the list.Specifies the routing table group.Rib Group

1. Select route type community from
the list.

Specifies an extended community value
to encode the OSPF route type

Route Type Community

1. Enter the domain VPN tag or select
from the list.

Virtual private network (VPN) tag for
OSPFv2 external routes generated by
the provider edge (PE) router.

Domain VPN Tag

1. Enter the preference or select from
the list.

Specifies the route preference for OSPF
internal routes.

Preference

1. Enter the external route preference
or select from the list.

Specifies the external route preference.External Preference

1. Enter the reference bandwidth.Specifies the reference bandwidth used
in calculating the default interface cost.

Reference Bandwidth

1. Specify whether to configure RFC
1583.

■ To enable compatibility with
RFC 1583, clear the check
box.

■ To disable compatibility with
RFC 1583, select the check
box.

Disable compatibility with RFC 1583.
Disabling compatibility with RFC 1583
can prevent routing loops.

No RFC 1583

1. Specify whether NSSA ABR has to
be configured.

■ To enable NSSA ABR, clear the
check box.

■ To disable NSSA ABR, select
the check the check box.

Disable compatibility with NSSA ABR.No NSSA ABR

Enables you to set up the area details
for OSPF.

Area
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Table 48: OSPF Configuration Fields (continued)

Your ActionFunctionOption

1. Expand the OSPF tree and select
Area.

2. Set up the area range, interface,
sham link remote, stub and virtual
link.

1. Expand the OSPF tree and select
Domain ID.

2. Specify the domain ID.

Enables you to configure domain ID for
the OSPF.

Domain ID

1. Expand the OSPF tree and select
Export.

2. Specify the export policies.

Enables you to specify the export
policies to be configured on the peer.

Export

1. Expand the OSPF tree and select
Graceful Restart.

2. Set up the graceful restart
parameters.

Enables you to specify the graceful
restart parameters for OSPF.

Graceful Restart

1. Expand the OSPF tree and select
Import.

2. Specify the import policies.

Enables you to specify the import
policies to be configured on the peer.

Import

1. Expand the OSPF tree and select
Overload.

2. Specify the comment and timeout.

Enables you to configure the local router
so that it appears to be overloaded. You
might do this when you want the router
to participate in OSPF routing, but do
not want it to be used for transit traffic.

Overload

1. Expand the OSPF tree and select
Sham Link.

2. Enable the feature and specify the
comment and local address.

Enables you to configure the local
endpoint of a sham link.

Sham Link

1. Expand the OSPF tree and select
SPF Options.

2. Specify the comment, delay,
holddown and rapid runs.

Enables you to configure options for
running the shortest-path-first (SPF)
algorithm. You can configure a delay for
when to run the SPF algorithm after a
network topology change is detected,
the maximum number of times the SPF
algorithm can run in succession, and a
holddown interval after the SPF
algorithm runs the maximum number
of times.

SPF Options
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Table 48: OSPF Configuration Fields (continued)

Your ActionFunctionOption

1. Expand the OSPF tree and select
Traceoptions.

2. Expand the Traceoptions tree and
set up the file and flag parameters.

Enables you to configure OSPF protocol
level tracing options.

Traceoptions

Configuring RIP (NSM Procedure)

Routing Information Protocol (RIP) is an interior gateway protocol (IGP) typically
used in small, homogeneous networks. RIP uses distance-vector routing to route
information through IP networks. Distance-vector routing requires that each device
simply informs its neighbors of its routing table. For each network path, the receiving
device picks the neighbor advertising the lowest metric, then adds this entry into its
routing table for readvertisement. Any host that uses RIP is assumed to have interfaces
to one or more networks. These networks are considered to be directly connected
networks. RIP relies on access to certain information about each of these networks.
The most important information is the network's metric. RIP uses the hop count as
the metric (also known as cost) to compare the value of different routes. The hop
count is the number of devices that data packets must traverse between RIP networks.

To configure RIP in NSM:

1. In the navigation tree select Device Manager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Protocols and select Rip.

5. Add/Modify the parameters under the respective tabs as specified in Table 49
on page 83.

6. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See Updating Devices for more
information.
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Table 49: RIP Configuration Fields

Your ActionFunctionOption

RIP

1. Enter the comment.Specifies the comment for RIP.Comment

1. Specify the metric to add incoming
routes.

Specifies the metric to add to incoming
routes when advertising into RIP routes
that were learned from other protocols.

Metric In

1. Enter the message size or select
from the list.

Specifies the number of route entries to
be included in every RIP update
message.

Message Size

1. Enter the hold down value or select
from the list.

Time period the expired route is
retained in the routing table before
being removed.

Hold Down

1. Enter the route timeout or select
from the list.

Specifies the route timeout interval for
RIP.

Route Timeout

1. Enter the update interval or select
from the list.

Enables you to configure an update time
interval to periodically send out routes
learned by RIP to neighbors.

Update Interval

1. Select authentication type from the
list.

The type of authentication for RIP route
queries received on an interface.

Authentication Type

1. Enter the authentication key.Authentication key for RIP route queries
received on an interface.

Authentication Key

1. Expand the RIP tree and select
Graceful Restart.

2. Enable the feature and set up the
graceful restart parameters.

Enables you to specify the graceful
restart parameters for RIP.

Graceful Restart

1. Expand the RIP tree and select
Group.

2. Click the New button or select a
group and click Edit button.

3. Set up the Bfd Liveness Detection
, Export, Import and Neighbor for
RIP.

RIP neighbors that share an export
policy and metric. The export policy and
metric govern what routes to advertise
to neighbors in a given group.

Group

1. Expand the RIP tree and select
Import.

2. Specify the import policies.

Enables you to specify the import
policies to be configured on the peer.

Import

1. Expand the RIP tree and select
Receive.

2. Specify the receive options.

Enables you to configure RIP receive
options.

Receive
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Table 49: RIP Configuration Fields (continued)

Your ActionFunctionOption

1. Expand the RIP tree and select Rib
Group.

2. Specify the comment and ribgroup
name.

The routing table group.RIB Group

1. Expand the RIP tree and select
Send.

2. Specify the send options.

Enables you to configure RIP send
options.

Send

1. Expand the RIP tree and select
Traceoptions.

2. Expand the Traceoptions tree and
set up the file and flag parameters.

Enables you to configure RIP protocol
level tracing options.

Traceoptions

Configuring VSTP (NSM Procedure)

VLAN Spanning Tree Protocol (VSTP) is a spanning tree protocol which creates a
loop-free topology in VLANs. VSTP maintains a separate spanning tree instance for
each VLAN. Different VLANs can use different spanning tree paths and VSTP can
support up to 4094 different spanning tree topologies.

To configure VSTP in NSM:

1. In the navigation tree select Device Manager > Devices  and select the device
from the list.

2. In the configuration tree, expand Protocols.

3. Select VSTP.

4. Add/Modify the parameters under the respective tabs as specified in Table 50
on page 85.

5. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See Updating Devices for more
information.
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Table 50: VSTP Configuration Fields

Your ActionFunctionField

VSTP

1. Expand the Protocol tree and select
VSTP.

2. Enter the comment.

Specifies comment for OSPF.Comment

1. Expand the Protocol tree and select
VSTP.

2. Specify whether to disable VSTP.

Specifies whether to disable the VSTP
configuration.

Disable

1. Expand the Protocol tree and select
VSTP.

2. Enter the bridge priority.

The bridge priority determines which
bridge is elected as the root bridge. If
two bridges have the same path cost to
the root bridge, the bridge priority
determines which bridge becomes the
designated bridge for a LAN segment.

Bridge Priority

1. Expand the Protocol tree and select
VSTP.

2. Enter the max age or select from
the list.

Specifies the maximum age of received
protocol BPDUs.

Max Age

1. Expand the Protocol tree and select
VSTP.

2. Enter the hello time or select from
the list.

The time interval at which the root
bridge transmits configuration BPDUs.

Hello Time

1. Expand the Protocol tree and select
VSTP.

2. Enter the forward delay time or
select from the list.

Specifies how long a bridge interface
remains in the listening and learning
states before transitioning to the
forwarding state.

Forward Delay

1. Expand the Protocol tree.

2. Select VSTP and expand the tree.

3. Select Interfaces.

4. Set up the priority, cost, mode,
edge and specify whether the
interface has to be disabled.

Specifies the interface to be associated
with VSTP.

Interface

1. Expand the Protocol tree.

2. Select VSTP and expand the tree.

3. Select Traceoptions.

4. Set up the file and flag parameters.

Enables you to configure VSTP level
tracing options.

Traceoptions
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Configuring VRRP (NSM Procedure)

Virtual Router Redundancy Protocol (VRRP) prevents loss of network connectivity
to end hosts if the static default IP gateway fails. By implementing VRRP, you can
designate a number of routers as backup routers in the event that the default master
router fails. VRRP fully supports Virtual Local Area Networks (VLANs) and stacked
VLANs (S-VLANs). In case of a failure, VRRP dynamically shifts the packet-forwarding
responsibility to a backup router. VRRP creates a redundancy scheme which enables
hosts to keep a single IP address for the default gateway but maps the IP address to
a well-known virtual MAC address. VRRP provides this redundancy without user
intervention or additional configuration at the end hosts.

To configure VRRP in NSM:

1. In the navigation tree select Device Manager > Devices  and select the device
from the list.

2. In the configuration tree, expand Protocols.

3. Select VRRP.

4. Add/Modify the parameters under the respective tabs as specified in Table 51
on page 86.

5. Click one:

■ OK—To save the changes.

■ Cancel—To cancel the modifications.

■ Apply — To apply the protocol settings.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See Updating Devices for more
information.

Table 51: VRRP Configuration Fields

Your ActionFunctionField

VRRP

1. Expand the Protocol tree and select
VRRP.

2. Enter the comment.

Specifies comment for VRRP.Comment
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Table 51: VRRP Configuration Fields (continued)

Your ActionFunctionField

1. Expand the Protocol tree and select
VRRP.

2. Enter the startup silent period or
select from the list

Enables the system to ignore the Master
Down Event when an interface
transitions from the disabled state to the
enabled state. It avoids an incorrect
error alarm caused by delay or
interruption of incoming VRRP
advertisement packets during the
interface startup phase.

Startup Silent Period

1. Expand the Protocol tree.

2. Select VRRP and expand the tree.

3. Select Traceoptions.

4. Set up the file and flag parameters.

Enables you to configure VRRP level
tracing options.

Traceoptions
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Chapter 9

Configuring Integrated Convergence
Services on the SRX Series Services
Gateways

■ Configuring the Media Gateway Peer Call Server for SRX Series Integrated
Convergence Services (NSM Procedure) on page 89

■ Configuring Media Gateway Analog Stations and Templates for SRX Series
Integrated Convergence Services (NSM Procedure) on page 91

■ Configuring Media Gateway SIP Stations and Templates for SRX Series Integrated
Convergence Services (NSM Procedure) on page 94

■ Configuring the SRX Series Integrated Convergence Services Media Gateway
(NSM Procedure) on page 96

■ Configuring Trunks for SRX Series Integrated Convergence Services (NSM
Procedure) on page 97

■ Configuring Trunk Groups for SRX Series Integrated Convergence Services (NSM
Procedure) on page 98

■ Configuring a Media Gateway Dial Plan Using Route Patterns for SRX Series
Integrated Convergence Services (NSM Procedure) on page 99

■ Configuring the SRX Series Survivable Call Service (NSM Procedure) on page 100

■ Configuring a Digit Transform Rule for the SRX Series Survivable Call Service
(NSM Procedure) on page 103

Configuring the Media Gateway Peer Call Server for SRX Series Integrated
Convergence Services (NSM Procedure)

This section provides information on configuring a peer call server for the SRX Series
Integrated Convergence Services media gateway.

To configure the peer call server:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the SRX Series Integrated
Convergence Services device for which you want to configure the peer call server.

3. Click the Configuration tab. In the configuration tree, select Services >
Convergence Services > Peer Call Server.

Configuring the Media Gateway Peer Call Server for SRX Series Integrated Convergence Services (NSM Procedure) ■ 89



4. Add or modify settings as specified in Table 52 on page 90.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 52: Peer Call Server Configuration Details

Your ActionFunctionOption

Enter the peer call server
name.

Specifies the peer call server
name.

Name

Enter a description for the
peer call server.

Describes the peer call server,
such as its location.

Description

The default DTMF, as specified
in RFC 2833, is used. (Other
supported methods are inband
and sip-info.)

Specifies the dual-tone
multifrequency (DTMF)
signaling method.

Dtmf Method

Enter the authentication ID.Specifies the authentication ID
used by the SRX Series MGW
to authenticate itself to the
peer call server, if the peer call
server challenges it to do so.

Auth Id

Enter the authentication
password.

Specifies the authentication
password used by the SRX
Series MGW to authenticate
itself to the peer call server, if
the peer call server challenges
it to do so.

Auth Password

Address

Enter the peer call server
address in FQDN format.

Specifies the peer call server
address in fully qualified
domain name (FQDN) format.

Fqdn

NOTE: You can use an FQDN
address rather than an IP
address as a means of
specifying that multiple peer
call servers are to be used. In
this case, the survivable call
server (SRX Series SCS) sends
heartbeat messages to all
servers to determine which
ones are available. It uses the
preferred server, based on the
result of the Domain Name
System (DNS).

Enter the peer call server
address in IPv4 address
format.

Specifies the peer call server
address in IPv4 address
format.

Ipv4 Addr
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Table 52: Peer Call Server Configuration Details (continued)

Your ActionFunctionOption

Codec

For this SRX Series MGW
configuration, you do not need
to specify codecs. The default
set of codecs is used. Included
codecs are specified in the
following order: 711-μ,
G711-A, and G729AB.

Specifies the codec used.Codec

Protocol > Sip

The default port 5060 is used.
For this SRX Series MGW
configuration, you do not need
to specify SIP protocol
information.

Specifies the port number, or
communications endpoint, for
the SIP protocol.

Port

The default transport of UDP
is used. For this SRX Series
MGW configuration, you do
not need to specify SIP
protocol information.

Specifies the transport used
for the SIP protocol, either
UDP, TCP, or TLS.

Transport

Related Topics ■ Configuring Media Gateway Analog Stations and Templates for SRX Series
Integrated Convergence Services (NSM Procedure) on page 91

■ Configuring Media Gateway SIP Stations and Templates for SRX Series Integrated
Convergence Services (NSM Procedure) on page 94

■ Configuring the SRX Series Survivable Call Service (NSM Procedure) on page 100

■ Configuring the SRX Series Integrated Convergence Services Media Gateway
(NSM Procedure) on page 96

Configuring Media Gateway Analog Stations and Templates for SRX Series
Integrated Convergence Services (NSM Procedure)

The SRX Series MGW supports FXS interfaces for connecting analog phones and fax
machines. You must configure stations for analog telephones and fax machines
because the SRX Series MGW intercedes on their behalf, converting analog calls from
them to digital ones to send over the IP WAN, and vice versa. The SRX Series MGW
routes these calls to and from the peer call server. To forward calls to analog stations,
the SRX Series MGW must know station extensions.

To configure the analog station:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the SRX Series Integrated
Convergence Services device for which you want to configure analog stations.
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3. Click the Configuration tab. In the configuration tree, select Services >
Convergence Services.

4. Add or modify settings as specified in Table 53 on page 92.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 53: Analog Station Configuration Details

Your ActionFunctionOption

Station > station

Enter the station name.Specifies the station name.Name

Enter the extension number
for the station.

Specifies the extension
number for the station.

Extension

Enter the caller ID information
to be displayed.

Specifies the caller ID
information to be displayed.

Caller Id

Select the class of restriction
policy.

Specifies the types of calls that
can be made from the station,
for example, local calls and
long-distance calls. By default,
intrabranch and emergency
calls are always allowed.

Class of Restriction

Enter the DID number that
external users can dial to
reach the extension directly.

Specifies direct inward dialing
(DID) capability for the station.
This capability allows external
users to call directly, without
going through an operator or
auto attendant.

Direct Inward Dialing

Enter the authentication ID.Specifies the authentication ID
used by the SRX Series MGW
to authenticate itself to the
peer call server, if the peer call
server challenges it to do so.

Auth Id

Enter the authentication
password.

Specifies the authentication
password used by the SRX
Series MGW to authenticate
itself to the peer call server, if
the peer call server challenges
it to do so.

Auth Password

Station > Station Type

Select analog as the station
type.

Specifies the station type.Sip
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Table 53: Analog Station Configuration Details (continued)

Your ActionFunctionOption

Station > Direct Inward Line

Select the interface fxs-0/0/10,
which is an onboard FXS

Specifies the interface to be
used for the station.

Tdm interface

interface used for analog
stations.

Station Template > Analog Template

Caller ID transmit is enabled
by default.

To disable transmitting the
caller ID information, select
disable.

You can disable caller ID
transmit in a template and
apply the template to a
station.

Specifies whether the caller ID
information configured for this
parameter is routed to all
called parties. However, if it is
disabled in a template that is
applied to the station, caller ID
information configured for the
station is not transmitted.

Caller Id Transmit

VAD is enabled by default.

To disable VAD, select disable.

You can disable VAD in a
template and apply the
template to a station.

Voice activity detection (VAD)
detects the presence of speech
in an audio signal and sends
only audio packets. VAD can
reduce bandwidth and
computational costs.

Voice Activity Detection

Comfort noise generation is
enabled by default.

To disable comfort noise
generation, select disable.

You can disable comfort noise
generation in a template and
apply the template to a
station.

When VAD is enabled and no
one is speaking, comfort noise
generation is often used to
provide familiar background
sound.

Comfort Noise Generation

Related Topics Configuring Media Gateway SIP Stations and Templates for SRX Series Integrated
Convergence Services (NSM Procedure) on page 94

■

■ Configuring the SRX Series Integrated Convergence Services Media Gateway
(NSM Procedure) on page 96

■ Configuring the Media Gateway Peer Call Server for SRX Series Integrated
Convergence Services (NSM Procedure) on page 89
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Configuring Media Gateway SIP Stations and Templates for SRX Series Integrated
Convergence Services (NSM Procedure)

You can configure SIP stations in a number of different ways. You can configure
them discretely, as a group of SIP stations using a range of extensions, or with the
guest feature. With the guest feature, users cannot receive calls.

To configure the SIP station:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the SRX Series Integrated
Convergence Services device for which you want to configure SIP stations.

3. Click the Configuration tab. In the configuration tree, select Services >
Convergence Services.

4. Add or modify settings as specified in Table 54 on page 94.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 54: SIP Station Configuration Details

Your ActionFunctionOption

Station > station

Enter the station name.Specifies the station name.Name

Enter the extension number
for the station.

Specifies the extension
number for the station.

Extension

Enter the caller ID information
to be displayed.

Specifies the caller ID
information to be displayed.

Caller Id

Select the class of restriction
policy.

Specifies the types of calls that
can be made from the station,
for example, local calls and
long-distance calls. By default,
intrabranch emergency calls
are always allowed.

Class of Restriction

Enter the DID number that
external users can dial to
reach the extension directly.

Specifies direct inward dialing
(DID) capability for the station.
This capability allows the
external users to call directly,
without going through an
operator or auto attendant.

Direct Inward Dialing
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Table 54: SIP Station Configuration Details (continued)

Your ActionFunctionOption

Enter the authentication ID.Specifies the authentication ID
used by the SRX Series MGW
to authenticate itself to the
peer call server, if the peer call
server challenges it to do so.

Auth Id

Enter the authentication
password.

Specifies the authentication
password used by the SRX
Series MGW to authenticate
itself to the peer call server, if
the peer call server challenges
it to do so.

Auth Password

Station > Station Type

Select SIP as the station type.Specifies the station type.Sip

Select the SIP template to be
used.

Specifies the SIP template to
be used.

Template

Station Template > Sip Template

Enter the template name.Specifies the template name.Name

Select the DTMF method.Specifies the dual-tone
multifrequency (DTMF)
signaling method.

Dtmf Method

Select the class of restriction
policy.

Specifies the types of calls that
can be made from the station,
for example, local calls and
long-distance calls. By default,
intrabranch emergency calls
are always allowed.

Class of Restriction

Caller ID transmit is enabled
by default.

To disable transmitting the
caller ID information, select
disable.

You can disable caller ID
transmit in a template and
apply the template to a
station.

Specifies whether the caller ID
information configured for this
parameter is routed to all
called parties. However, if it is
disabled in a template that is
applied to the station, caller ID
information configured for the
station is not transmitted.

Caller Id Transmit

Select the codec to be used.Specifies the codec used.Codec
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Table 54: SIP Station Configuration Details (continued)

Your ActionFunctionOption

Specify the extension starting
range in From Extension and
the ending range in To
Extension.

Specifies a range of
extensions.

The most expedient way to
configure stations for SIP
phones is to use the extension
inherit feature template, which
allows you to specify a range
of extensions and create a
single station configuration to
be inherited by all of them.

Extension Inherit

Related Topics Configuring Media Gateway Analog Stations and Templates for SRX Series
Integrated Convergence Services (NSM Procedure) on page 91

■

■ Configuring the Media Gateway Peer Call Server for SRX Series Integrated
Convergence Services (NSM Procedure) on page 89

■ Configuring the SRX Series Integrated Convergence Services Media Gateway
(NSM Procedure) on page 96

Configuring the SRX Series Integrated Convergence Services Media Gateway (NSM
Procedure)

Integrated Convergence Services is composed of hardware and software on the
SRX210 or SRX240 device. It includes media gateway (SRX Series MGW) and
survivable call server (SRX Series SCS) components. The SRX Series MGW functionality
is used predominantly when the peer call server is available to provide call services
and call routing. When the peer call server is unavailable, the SRX Series SCS assumes
control and takes on the role of the peer call server.

To configure the SRX Series MGW:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the SRX Series Integrated
Convergence Services device for which you want to configure MGW.

3. Click the Configuration tab. In the configuration tree, select Services >
Convergence Services > Media Gateway.

4. Add or modify settings as specified in Table 55 on page 97.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.
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Table 55: MGW Configuration Details

Your ActionFunctionOption

media-gateway

Enter the MGW name.Specifies the MGW name.Name

Select the peer call server.Specifies the peer call server.
The MGW works in
conjunction with the peer call
server to route calls.

Peer Call Server

Select the preconfigured dial
plan for the SRX Series MGW.

Specifies the preconfigured
dial plan for the SRX Series
MGW.

Dial Plan

Service Point

Select the zone to which the
SRX Series MGW belongs.

Specifies a service point that
refers to the zone to which the
SRX Series MGW belongs.

Zone

Related Topics ■ Configuring Trunks for SRX Series Integrated Convergence Services (NSM
Procedure) on page 97

■ Configuring Trunk Groups for SRX Series Integrated Convergence Services (NSM
Procedure) on page 98

■ Configuring a Media Gateway Dial Plan Using Route Patterns for SRX Series
Integrated Convergence Services (NSM Procedure) on page 99

■ Configuring the Media Gateway Peer Call Server for SRX Series Integrated
Convergence Services (NSM Procedure) on page 89

■ Configuring the SRX Series Survivable Call Service (NSM Procedure) on page 100

Configuring Trunks for SRX Series Integrated Convergence Services (NSM
Procedure)

The SRX Series MGW dial plan includes route patterns that include one or more trunk
groups. Each trunk group specifies one or more trunks to be used to route calls that
specify a trunk’s prefix, referred to as a trunk access code. You configure trunks
discretely and then use them in trunk groups. Trunks are reusable and you can include
the same trunk in multiple trunk groups.

To configure a trunk for the SRX Series Integrated Convergence Services device:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the SRX Series Integrated
Convergence Services device for which you want to configure a trunk.

3. Click the Configuration tab. In the configuration tree, select Services >
Convergence Services > Trunk.
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4. Add or modify settings as specified in Table 56 on page 98.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 56: Trunk Configuration Details

Your ActionFunctionOption

trunk

Enter the trunk name.Specifies the trunk name.Name

Trunk Type > Fxo

Enable this feature and ensure that FXO is the trunk type.

Select the FXO TDM interface
to be used.

Specifies the FXO TDM
interface.

Tdm Interface

Related Topics Configuring Trunk Groups for SRX Series Integrated Convergence Services (NSM
Procedure) on page 98

■

■ Configuring the SRX Series Integrated Convergence Services Media Gateway
(NSM Procedure) on page 96

■ Configuring a Media Gateway Dial Plan Using Route Patterns for SRX Series
Integrated Convergence Services (NSM Procedure) on page 99

Configuring Trunk Groups for SRX Series Integrated Convergence Services (NSM
Procedure)

After you configure trunks, you add them to trunk groups. For a trunk group composed
of multiple trunks, you specify the trunks in the order in which they should be used
to route a call. You add trunk groups to route patterns that you configure for a dial
plan. When a called number matches the digit pattern of a route pattern, the system
attempts to route the call using the first trunk specified in the preferred trunk group
of that route pattern. (If you do not use preference numbers for trunk groups, then
the first trunk group assigned to the route pattern is considered the preferred one.)
If the first trunk is busy, then the second trunk is tried, and so on in order through
the list of trunks configured for the trunk group.

To configure a trunk group for the SRX Series Integrated Convergence Services device:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the SRX Series Integrated
Convergence Services device for which you want to configure a trunk group.

3. Click the Configuration tab. In the configuration tree, select Services >
Convergence Services > Trunk Group.
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4. Add or modify settings as specified in Table 57 on page 99.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 57: Trunk Group Configuration Details

Your ActionFunctionOption

trunk group

Enter the trunk group name.Specifies the trunk group
name.

Name

Add the preconfigured trunks
to the trunk group in the order
in which you want the trunks
to be tried. To add a trunk to
the trunk group, select the
trunk from the Non-members
area and add it to the
Members area.

Specifies the trunks in the
trunk group.

Trunk

Related Topics Configuring Trunks for SRX Series Integrated Convergence Services (NSM
Procedure) on page 97

■

■ Configuring a Media Gateway Dial Plan Using Route Patterns for SRX Series
Integrated Convergence Services (NSM Procedure) on page 99

■ Configuring the SRX Series Integrated Convergence Services Media Gateway
(NSM Procedure) on page 96

Configuring a Media Gateway Dial Plan Using Route Patterns for SRX Series
Integrated Convergence Services (NSM Procedure)

A dial plan provides endpoint addressing for IP phones, analog phones, and fax
machines. Route pattern entries determine how a call is routed and offer multiple
paths if multiple trunks are configured for the route pattern.

You configure a dial plan to implement digit patterns for the types of calls that the
enterprise supports—emergency, internal, local, long-distance, international, and
custom—so that the system can recognize the digits of a called number that
correspond to a pattern and act on it to route the call.

To configure an MGW dial plan:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the SRX Series Integrated
Convergence Services device for which you want to configure a dial plan.

Configuring a Media Gateway Dial Plan Using Route Patterns for SRX Series Integrated Convergence Services (NSM Procedure) ■ 99

Chapter 9: Configuring Integrated Convergence Services on the SRX Series Services Gateways



3. Click the Configuration tab. In the configuration tree, select Services >
Convergence Services > Dial Plan.

4. Add or modify settings as specified in Table 58 on page 100.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 58: Dial Plan Configuration Details

Your ActionFunctionOption

Dial Plan

Enter the dial plan name.Specifies the dial plan name.Name

Route Pattern

Enter the route pattern name.Specifies the route pattern
name.

Name

Route Pattern > Call Type

Select the call type.Specifies the call type.Call Type

Route Pattern > Trunk Group

Select the name of the trunk
group.

Specifies the name of the
trunk group whose trunks are
to be used.

Name

Enter the trunk group
preference number.

Specifies the trunk group
preference number.

Preference

Select the digit transform rule
for the trunk group.

Specifies the digit transform
rule for the trunk group.

Digit Transform

Related Topics Configuring Trunks for SRX Series Integrated Convergence Services (NSM
Procedure) on page 97

■

■ Configuring Trunk Groups for SRX Series Integrated Convergence Services (NSM
Procedure) on page 98

■ Configuring the SRX Series Integrated Convergence Services Media Gateway
(NSM Procedure) on page 96

Configuring the SRX Series Survivable Call Service (NSM Procedure)

The SRX Series Survivable Call Service (SCS) provides call handling and routing
services locally when the peer call server is unreachable. The SRX Series SCS works
in conjunction with station configurations and the dial plan, which you refer to in
the configuration.
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To configure an SRX Series SCS:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the SRX Series Integrated
Convergence Services device for which you want to configure SCS.

3. Click the Configuration tab. In the configuration tree, select Services >
Convergence Services > Survivable Call Service.

4. Add or modify settings as specified in Table 59 on page 101.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 59: SCS Configuration Details

Your ActionFunctionOption

survivable-call-service

Enter the SRX Series SCS
configuration name.

Specifies the name for the SRX
Series SCS configuration.

Name

Select the peer call server that
the SCS monitors.

Specifies the peer call server
that the SCS monitors. This is
the peer call server (or servers,
if you specified a FQDN for its
address) used to provide call
handling and routing services
for the gateway. This name
must match the name for the
peer call server configuration.

Peer Call Server

Select the dial plan to be used
for call routing.

Specifies the dial plan used for
call routing.

Dial Plan

Enter the registration expiry
timeout.

Range: 30 to 86,400 seconds.
Default: 60 seconds.

Specifies the time during
which the SRX Series SCS
accepts registrations from SIP
stations and redirects any call
requests to the peer call server
after the peer call server has
regained control.

Registration Expiry Timeout

Enter the SIP timeout period.

Range: 16 to 120 seconds
Default: 32 seconds.

Specifies the timeout period
during which the peer call
server must respond to
keepalive messages from the
SRX Series SCS to remain in
control.

Sip Timeout
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Table 59: SCS Configuration Details (continued)

Your ActionFunctionOption

Enter the watch period to
determine if the peer call
server is reachable and stable.

Range: 5 to 20 seconds.
Default: 16 seconds.

Specifies the timeout to
monitor if the peer call server
is reachable consistently.

Monitor Timeout

Enter the heartbeat normal
interval.

Range: 2 to 8 seconds.

Default: 32 seconds.

Specifies the interval when the
SRX Series SCS sends
keepalive messages to the
peer call server. The heartbeat
parameter works in
conjunction with the SIP
timeout parameter.

Heartbeat Normal Interval

Enter the heartbeat survivable
interval.

Range: 100-1000 milliseconds.
Default: 500 milliseconds.

Specifies the interval when the
SRX Series SCS sends
keepalive messages to the
peer call server to determine
if it is reachable and has
recovered from the fault
condition.

After the peer call server
responds, the SRX Series SCS
enters a watch period to
determine if it is reliably
reachable.

Heartbeat Survivable Interval

Protocol > Sip

The default port is 5060.Specifies the port number for
the SIP protocol.

Port

Select the transport to be
used.

Specifies the transport to be
used.

Transport

Response Threshold

Enter the minimum percent.

Range: 10 to 100 percent.
Default: 75 percent.

Specifies the minimum
percent of times the peer call
server must respond to
timeout messages during the
watch period.

Minimum

Service Point

Select the zone to which the
SRX Series device belongs.

Specifies the zone to which the
SRX Series device belongs.

Zone

Related Topics Configuring a Digit Transform Rule for the SRX Series Survivable Call Service
(NSM Procedure) on page 103

■

■ Configuring the SRX Series Integrated Convergence Services Media Gateway
(NSM Procedure) on page 96
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■ Configuring the Media Gateway Peer Call Server for SRX Series Integrated
Convergence Services (NSM Procedure) on page 89

Configuring a Digit Transform Rule for the SRX Series Survivable Call Service (NSM
Procedure)

You use digit transform rules to manipulate called numbers before they are routed
out telephony trunks. You specify the digit transform rule for a trunk group within
the dial plan. You can use a single digit transform rule for multiple trunk groups.

You specify a digit transform rule as a regular expression. When a called number
matches the digit pattern of a route pattern and a digit transform rule is configured
for a trunk group that belongs to the route pattern, then the rule is applied to the
digits of the called number to transform it (before it is routed out any trunk belonging
to the trunk group).

To configure a digit transform rule:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the SRX Series Integrated
Convergence Services device for which you want to configure a digit transform
rule.

3. Click the Configuration tab. In the configuration tree, select Services >
Convergence Services > Digit Manipulation > Digit Transform.

4. Add or modify settings as specified in Table 60 on page 103.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 60: Digit Transform Rule Configuration Details

Your ActionFunctionOption

survivable-call-service

Enter the digit transform rule
name.

It’s helpful to name rules to
represent what they do. For
example, for a rule that inserts
a prefix for a branch before
the telephone number, you
might call the rule
add-branch-prefix.

Specifies the rule name to
refer to in a route pattern
specification of the trunk
group.

Name

Configuring a Digit Transform Rule for the SRX Series Survivable Call Service (NSM Procedure) ■ 103

Chapter 9: Configuring Integrated Convergence Services on the SRX Series Services Gateways



Table 60: Digit Transform Rule Configuration Details (continued)

Your ActionFunctionOption

Enter the regular expression
for the rule.

For example, to strip off the
digit 9, enter s/^9//.

Specifies the digit transform
rule as a regular expression.

Regular Expression

Related Topics ■ Configuring the SRX Series Survivable Call Service (NSM Procedure) on page 100

■ Configuring the SRX Series Integrated Convergence Services Media Gateway
(NSM Procedure) on page 96
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Chapter 10

Configuring SNMP for Network
Management in J Series Services Routers
and SRX Series Services Gateways

■ Configuring Basic System Identification for SNMP (NSM Procedure) on page 105

■ Configuring SNMP Agents and Communities (NSM Procedure) on page 106

■ Configuring SNMP Trap Groups (NSM Procedure) on page 107

■ Configuring SNMP Views (NSM Procedure) on page 108

Configuring Basic System Identification for SNMP (NSM Procedure)

To configure basic system identification information for SNMP:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure basic system identification information.

3. Click the Configuration tab. In the configuration tree, select Snmp.

4. Add or modify basic system identification information as specified in Table 61
on page 105.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 61: Basic System Identification Details

Your ActionFunctionOption

Enter the system name as a free-form
text string.

Specifies a system name for the
device.

System Name

Enter a description for the system. For
example, type J4350 with 4 PIMs.

Provides a description for the
system.

Description

Enter the system location information
(such as a lab name and a rack name).

Specifies the system location
information.

Location
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Table 61: Basic System Identification Details (continued)

Your ActionFunctionOption

Enter the system contact information
(such as a name and a phone number).

Specifies the contact information
for the system.

Contact

Snmp > Engine Id

Select this option.Sets the engine ID to use the MAC
address.

Use Mac Address

Related Topics Configuring SNMP Agents and Communities (NSM Procedure) on page 106■

■ Configuring SNMP Trap Groups (NSM Procedure) on page 107

■ Configuring SNMP Views (NSM Procedure) on page 108

Configuring SNMP Agents and Communities (NSM Procedure)

To configure SNMP agents and communities:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure SNMP agents and communities.

3. Click the Configuration tab. In the configuration tree, select Snmp >
Community.

4. Add or modify community and client information as specified in Table 62 on
page 106.

5. Click one:

■ New—Creates a new community.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 62: SNMP Agents and Community Configuration Details

Your ActionFunctionOption

Enter a name for the
community.

Specifies a name for the
community.

Name

Enter the view name.Specifies the view associated
with the community.

View

Select an access to be granted
for the community. For
example, type read-write.

Specifies the access granted to
the community.

Authorization

SNMP > Community > Client List Name
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Table 62: SNMP Agents and Community Configuration Details (continued)

Your ActionFunctionOption

Enter the IP address.Specifies community access to
a client at a particular IP
address.

Name

Select this option to restrict
client access for the specified
IP address.

Restricts client access to the
specified IP address.

Restrict

Related Topics Configuring Basic System Identification for SNMP (NSM Procedure) on page 105■

■ Configuring SNMP Trap Groups (NSM Procedure) on page 107

■ Configuring SNMP Views (NSM Procedure) on page 108

Configuring SNMP Trap Groups (NSM Procedure)

To configure trap groups:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure SNMP trap groups.

3. Click the Configuration tab. In the configuration tree, select Snmp > Trap
Group.

4. Add or modify SNMP trap group as specified in Table 63 on page 107.

5. Click one:

■ New—Creates a new SNMP trap group.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 63: SNMP Trap Group Configuration Details

Your ActionFunctionOption

Enter a name for the trap
group.

Specifies a name for the trap
group.

Name

Select the version number for
the SNMP trap.

Specifies the version number
of SNMP traps.

Version

Enter the trap port number.Specifies the SNMP trap port
number.

Destination Port

Enter the name of the routing
instance.

Specifies a routing instance for
trap targets.

Routing Instance
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Table 63: SNMP Trap Group Configuration Details (continued)

Your ActionFunctionOption

Snmp > Trap Group > Categories

Select the trap type.Define the types of traps that
will be sent to the targets of
the named trap group.

Category

Snmp > Trap Group > Targets

Enter the IPv4 or IPv6 address
of the system, but not a
hostname.

Specifies the IPv4 or IPv6
address of the system to
receive traps.

Name

Related Topics Configuring Basic System Identification for SNMP (NSM Procedure) on page 105■

■ Configuring SNMP Agents and Communities (NSM Procedure) on page 106

■ Configuring SNMP Views (NSM Procedure) on page 108

Configuring SNMP Views (NSM Procedure)

To configure SNMP views:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure SNMP views.

3. Click the Configuration tab. In the configuration tree, select Snmp > View.

4. Add or modify SNMP views as specified in Table 64 on page 108.

5. Click one:

■ New—Creates a new view.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 64: SNMP View Configuration Details

Your ActionFunctionOption

Enter a name for the view.Specifies a name for the view.Name

Snmp > View > Oid

Enter the OID of the MIB in
either dotted integer or
subtree name format.

Specifies the MIB for the view.Name

Select this option.Specifies whether the view
includes or excludes the MIB

Include or Exclude
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Related Topics ■ Configuring Basic System Identification for SNMP (NSM Procedure) on page 105

■ Configuring SNMP Agents and Communities (NSM Procedure) on page 106

■ Configuring SNMP Trap Groups (NSM Procedure) on page 107
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Chapter 11

Configuring J Series Services Routers and
SRX Series Services Gateways for DHCP

■ Configuring the Device as a DHCP Server (NSM Procedure) on page 111

■ Configuring the Device as a DHCP Client (NSM Procedure) on page 113

Configuring the Device as a DHCP Server (NSM Procedure)

The Dynamic Host Configuration Protocol (DHCP) server provides a framework for
passing configuration information to client hosts (such as PCs) on a TCP/IP network.
A router or interface that acts as a DHCP server can allocate network IP addresses
and deliver configuration settings to client hosts without user intervention. DHCP
access service minimizes the overhead required to add clients to the network by
providing a centralized, server-based setup. You do not have to manually create and
maintain IP address assignments for clients.

To configure the device as a DHCP server for a subnet and a single client:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure a DHCP server.

3. Click the Configuration tab. In the configuration tree, select System > Services
> Dhcp.

4. Add or modify DHCP settings as specified in Table 65 on page 111.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 65: DHCP Server Configuration Details

Your ActionFunctionOption

Select the maximum lease
time.

Specifies the maximum length
of time in seconds for which
a client can request and hold
a lease on a DHCP server.

Maximum Lease Time
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Table 65: DHCP Server Configuration Details (continued)

Your ActionFunctionOption

Select the default lease time.Specifies the length of time in
seconds that a client holds the
lease for an IP address
assigned by a DHCP server.
This setting is used if a lease
time is not requested by the
client.

Default Lease Time

Enter the domain name.Specifies the name of the
domain in which clients search
for a DHCP server host. This
is the default domain name
that is appended to hostnames
that are not fully qualified.

Domain Name

Enter the location of the boot
file on the boot server. The
filename can include a path
name.

Specifies the boot file
advertised to DHCP clients.
After the client receives an IP
address and the boot file
location from the DHCP
server, the client uses the boot
image stored in the boot file
to complete DHCP setup.

Boot File

Enter the address of a boot
server. You must specify an
IPv4 address, not a hostname.

Specifies the name of the boot
server advertised to DHCP
clients. The client uses a boot
file located on the boot server
to complete DHCP setup.

Boot Server

Enter the IPv4 address of the
server. This address must be
accessible by all clients served
within a specified range of
addresses (based on an
address pool or static binding).

Specifies the server identifier.
This is an optional setting that
can be used to identify a
DHCP server in a DHCP
message.

Server Identifier

Dhcp > Pool

Enter the IP address pool
range.

Specifies the logical subnet
address or netmask.

Name

Enter the IP address.Specifies lowest IP address in
the pool that is available for
dynamic address assignment.

Low

Enter the IP address.Specifies highest IP address in
the pool that is available for
dynamic address assignment.

High

Dhcp > Domain Search

Enter the list of domain names
to search. The list can contain
up to 6 domain names, with a
total of up to 256 characters.

Specifies the domain search
suffixes to be used by the
clients.

Name
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Table 65: DHCP Server Configuration Details (continued)

Your ActionFunctionOption

Dhcp > Name Server

Enter the address of the name
server. To configure multiple
name servers, include multiple
address options.

Defines a Domain Name
System (DNS) name server.

Name

Dhcp > Option

Select the ID number.Specifies the ID number that
indexes the option and must
be unique across a DHCP
server.

Name

Select the option type.Specifies the option type.Flag

Dhcp > Static Binding

Enter the MAC address of the
client.

Specifies the MAC address of
the client. This is a hardware
address that uniquely
identifies a client on the
network.

Name

Dhcp > Static Binding > Fixed Address

Enter the fixed IP address.Specifies the fixed IP address
assigned to the client.
Typically a client has one
address assigned, but you can
assign more.

Name

Related Topics ■ Configuring the Device as a DHCP Client (NSM Procedure) on page 113

Configuring the Device as a DHCP Client (NSM Procedure)

A device can act as a DHCP client, receiving its TCP/IP settings and the IP address
for any physical interface in any security zone from an external DHCP server. The
device can also act as a DHCP server, providing TCP/IP settings and IP addresses to
clients in any zone.

To configure the device as a DHCP client:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want
to configure a DHCP client.

3. Click the Configuration tab. In the configuration tree, select Interfaces.

4. Select the interface on which you want to configure DHCP client information,
and select Unit > Family > Inet > Dhcp.
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5. Click Enable next to Dhcp, and add or modify DHCP settings as specified in
Table 66 on page 114.

6. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 66: DHCP Client Configuration Details

Your ActionFunctionOption

Enter the DHCP lease time in
seconds.

Specifies the DHCP lease time
in seconds.

Lease Time

Enter the number of attempts
allowed to retransmit a DHCP
packet.

Specifies the number of
attempts allowed to retransmit
a DHCP packet.

Retransmission Attempt

Enter the interval allowed
between retransmission
attempts in seconds.

Specifies the interval allowed
between retransmission
attempts in seconds.

Retransmission Interval

Enter the IPv4 address of the
preferred DHCP server.

Specifies the IPv4 address of
the preferred DHCP server.

Server Address

Enter the vendor class ID.Specifies the vendor class ID
for the DHCP client.

Vendor Id

Dhcp > Client Identifier

Select the DHCP client
identifier, and type the ASCII
or hexadecimal value.

Specifies the DHCP client
identifier as either an ASCII or
hexadecimal value.

Ascii

Related Topics ■ Configuring the Device as a DHCP Server (NSM Procedure) on page 111
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Chapter 12

Configuring Class of Service in J Series
Services Routers and SRX Series
Services Gateways

■ Configuring CoS Classifiers (NSM Procedure) on page 115

■ Configuring CoS Code Point Aliases (NSM Procedure) on page 118

■ Configuring CoS Drop Profile (NSM Procedure) on page 119

■ Configuring CoS Forwarding Classes (NSM Procedure) on page 121

■ Configuring CoS Forwarding Policy (NSM Procedure) on page 122

■ Configuring CoS Fragmentation Maps (NSM Procedure) on page 124

■ Configuring CoS Host Outbound Traffic (NSM Procedure) on page 125

■ Configuring CoS Interfaces (NSM Procedure) on page 126

■ Configuring CoS Rewrite Rules (NSM Procedure) on page 131

■ Configuring CoS Schedulers (NSM Procedure) on page 134

■ Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 136

Configuring CoS Classifiers (NSM Procedure)

Packet classification associates incoming packets with a particular class-of-service
(Cos) servicing level. Classifiers associate packets with a forwarding class and loss
priority and, based on the associated forwarding class, assign packets to output
queues. JUNOS software supports two general types of classifiers:

■ Behavior aggregate or CoS value traffic classifiers—Examines the CoS value in
the packet header. The value in this single field determines the CoS settings
applied to the packet. BA classifiers allow you to set the forwarding class and
loss priority of a packet based on the Differentiated Services code point (DSCP)
value, IP precedence value, and IEEE 802.1p value. The default classifier is based
on the DSCP value.

■ Multifield traffic classifiers—Examines multiple fields in the packet such as source
and destination addresses and source and destination port numbers of the packet.
With multifield classifiers, you set the forwarding class and loss priority of a
packet based on firewall filter rules.

To configure and apply behavior aggregate classifiers for the switch:
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1. In the navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure and apply behavior aggregate classifiers.

3. Click the Configuration tab. In the configuration tree expand Class of Service.

4. Select Classifiers.

5. Add or modify settings as specified in Table 67 on page 116.

6. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Network and Security Manager
Administration Guide for more information.

Table 67: Configuring and Applying Behavior Aggregate Classifiers

ActionTask

1. Click Add new entry next to Dscp.

2. In the Name box, type the name of the behavior aggregate classifier—for example,
ba-classifier.

3. In the Import box, type the name of the default DSCP map.

Configure behavior aggregate
classifiers for DiffServ CoS.

1. Click Add new entry next to Forwarding class.

2. In the Class name box, type the name of the previously configured best-effort forwarding
class—for example, be-class.

3. Click Add new entry next to Loss priority.

4. From the Loss val list, select high.

5. Click Add new entry next to Code points.

6. In the Value box, type the value of the high-priority code point for best-effort traffic—for
example, 00001.

7. Click OK three times.

Configure a best-effort
forwarding class classifier.
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Table 67: Configuring and Applying Behavior Aggregate Classifiers (continued)

ActionTask

1. Click Add new entry next to Forwarding class.

2. In the Class name box, type the name of the previously configured expedited
forwarding—for example, class-ef-class.

3. Click Add new entry next to Loss priority.

4. From the Loss val list, select high.

5. Click Add new entry next to Code points.

6. In the Value box, type the value of the high-priority code point for expedited forwarding
traffic—for example, 101111.

7. Click OK three times.

Configure an expedited
forwarding class classifier.

1. Click Add new entry next to Forwarding class.

2. In the Class name box, type the name of the previously configured assured
forwarding—for example, class-af-class.

3. Click Add new entry next to Loss priority.

4. From the Loss val list, select high.

5. Click Add new entry next to Code points.

6. In the Value box, type the value of the high-priority code point for assured forwarding
traffic—for example, 001100.

7. Click OK three times.

Configure an assured forwarding
class classifier.

1. Click Add new entry next to Interfaces.

2. In the Interface name box, type the name of the interface—for example, ge-0/0/0.

3. Click Add new entry next to Unit.

4. In the Unit number box, type the logical interface unit number—for example, 0.

5. Click Configure next to Classifiers.

6. In the Classifiers box, under Dscp, type the name of the previously configured behavior
aggregate classifier—for example, ba-classifier.

7. Click OK.

Apply the behavior aggregate
classifier to an interface.

Related Topics ■ Configuring CoS Code Point Aliases (NSM Procedure) on page 118

■ Configuring CoS Drop Profile (NSM Procedure) on page 119

■ Configuring CoS Forwarding Classes (NSM Procedure) on page 121

■ Configuring CoS Interfaces (NSM Procedure) on page 126

■ Configuring CoS Rewrite Rules (NSM Procedure) on page 131

■ Configuring CoS Schedulers (NSM Procedure) on page 134

■ Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 136
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Configuring CoS Code Point Aliases (NSM Procedure)

You can use code-point aliases to streamline the process of configuring CoS features
on your device. A code-point alias assigns a name to a pattern of code-point bits.
You can use this name instead of the bit pattern when you configure other CoS
components such as classifiers, drop-profile maps, and rewrite rules.

To configure code-point aliases:

1. In the navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure CoS code point aliases.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select Code Point Aliases.

5. Add or modify the settings as specified in Table 68 on page 118

6. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Network and Security Manager
Administration Guide for more information.

Table 68: Configuring Code Point Aliases

ActionTask

1. In the Configuration tree, expand Code Point Aliases.

2. Select Dscp.

3. Click the Add New icon.

4. In the Name box, type the alias that you want to assign to the code point—for
example, my1.

5. In the Bits box, type the code point—for example, 110001.

6. Click OK.

Assign an alias to the dscp code
point.

Related Topics ■ Configuring CoS Classifiers (NSM Procedure) on page 115

■ Configuring CoS Drop Profile (NSM Procedure) on page 119

■ Configuring CoS Forwarding Classes (NSM Procedure) on page 121

■ Configuring CoS Interfaces (NSM Procedure) on page 126
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■ Configuring CoS Rewrite Rules (NSM Procedure) on page 131

■ Configuring CoS Schedulers (NSM Procedure) on page 134

■ Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 136

Configuring CoS Drop Profile (NSM Procedure)

Drop profiles provide a congestion management mechanism that enables a switch
or routing platform to drop the arriving packets when queue buffers become full or
begin to overflow. Drop profiles define the meanings of loss priorities. When you
configure drop profiles you are essentially setting the value for queue fullness. The
queue fullness represents the percentage of the memory used to store packets in
relation to the total amount of memory that has been allocated for that specific queue.
The queue fullness defines the delay-buffer bandwidth, which provides packet buffer
space to absorb burst traffic up to the specified duration of delay. Once the specified
delay buffer becomes full, packets with 100 percent drop probability are dropped
from the tail of the buffer.

You specify drop probabilities in the drop profile section of the CoS configuration
hierarchy and reference them in each scheduler configuration. By default, if you do
not configure any drop profile then the drop profile that is in effect functions as the
primary mechanism for managing congestion. In the default tail drop profile, when
the fill level is 0 percent, the drop probability is 0 percent. When the fill level is 100
percent, the drop probability is 100 percent.

To configure drop profiles in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure drop profiles.

3. Click the Configuration tab. In the configuration tree expand Class of Service.

4. Select Drop Profiles.

5. Add or modify the drop profiles as specified in Table 69 on page 120.

6. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See Updating Devices section in the
Network and Security Manager Administration Guide for more information.
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Table 69: Drop Profile Configuration Fields

Your ActionFunctionOption

Drop Profile

1. Click the New button or Edit button
in the Drop Profile interface.

2. Enter the drop profile name in the
Name box.

Specifies the drop profile name.Name

1. Click the New button or Edit button
in the Drop Profile interface.

2. Enter the comment for the drop
profile in the Comment box.

Specifies the comment for the drop
profile.

Comment

Fill Level

1. On Drop Profile interface click the
New button or select a profile and
click the Edit button.

2. Expand the Drop Profile tree and
select Fill Level.

3. Click the New button or select a fill
level and click the Edit button.

4. Select a value from Name list.

Specifies the fill level for the drop
profile.

Name

1. On the Drop Profile interface click
the New button or select a profile
and click the Edit button.

2. Expand the Drop Profile tree and
select Fill Level .

3. Click the New button or select a fill
level and click the Edit button.

4. Enter a comment in the Comment
box.

Specifies the comment for the fill levelComment

Related Topics ■ Configuring CoS Classifiers (NSM Procedure) on page 115

■ Configuring CoS Code Point Aliases (NSM Procedure) on page 118

■ Configuring CoS Forwarding Classes (NSM Procedure) on page 121

■ Configuring CoS Interfaces (NSM Procedure) on page 126

■ Configuring CoS Rewrite Rules (NSM Procedure) on page 131

■ Configuring CoS Schedulers (NSM Procedure) on page 134

■ Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 136
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Configuring CoS Forwarding Classes (NSM Procedure)

Forwarding classes allow you to group packets for transmission. Based on forwarding
classes, you assign packets to output queues.

By default, four categories of forwarding classes are defined: best effort, assured
forwarding, expedited forwarding, and network control.

NOTE: EX-series switches support up to 16 forwarding classes.

To configure CoS forwarding classes:

1. In the navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure CoS forwarding classes.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select Forwarding Classes.

5. Add or modify settings as specified in Table 70 on page 121.

6. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Network and Security Manager
Administration Guide for more information.

Table 70: Assigning Forwarding Classes to Output Queues

ActionTask

1. Select Queue and click Add new entry.

2. In the Queue num box, type 0.

3. In the Class name box, type the previously configured name of the best-effort
class—for example, be-class.

4. Click OK.

Assign best-effort traffic to queue 0.
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Table 70: Assigning Forwarding Classes to Output Queues (continued)

ActionTask

1. Select Queue and click Add new entry.

2. In the Queue num box, type 1.

3. In the Class name box, type the previously configured name of the expedited
forwarding class—for example, ef-class.

4. Click OK.

Assign expedited forwarding traffic to
queue 1.

1. Select Queue and click Add new entry.

2. In the Queue num box, type 3.

3. In the Class name box, type the previously configured name of the assured
forwarding class—for example, af-class.

4. Click OK.

Configure an assured forwarding class
classifier.

Related Topics ■ Configuring CoS Classifiers (NSM Procedure) on page 115

■ Configuring CoS Code Point Aliases (NSM Procedure) on page 118

■ Configuring CoS Drop Profile (NSM Procedure) on page 119

■ Configuring CoS Interfaces (NSM Procedure) on page 126

■ Configuring CoS Rewrite Rules (NSM Procedure) on page 131

■ Configuring CoS Schedulers (NSM Procedure) on page 134

■ Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 136

Configuring CoS Forwarding Policy (NSM Procedure)

Class-of-service (CoS)-based forwarding (CBF) enables you to control next-hop selection
based on a packet’s class of service and, in particular, the value of the IP packet’s
precedence bits.

You can specify a particular interface or next hop to carry high-priority traffic while
all best-effort traffic takes some other path. When a routing protocol discovers
equal-cost paths, it can pick a path at random or load-balance across the paths through
either hash selection or round robin. CBF allows path selection based on class.

To configure CoS forwarding policy in NSM:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select Forwarding Policy.
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5. Add or modify forwarding policy settings as specified in Table 71 on page 123.

6. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 71: Forwarding Policy Configuration Details

Your ActionTask

1. Click Add new entry next to Class.

2. In the Name box, enter the name of
forwarding class.

3. Click Classification Override next to
Class.

4. In the Forwarding Class box, enter the
name of the forwarding class.

Specify the name of forwarding class and
override the incoming packet classification.

1. Click Add new entry next to Next Hop
Map.

2. In the Name box, enter the map that
defines next-hop routes.

3. Click Forwarding Class next to
next-hop-map.

4. Click Add new entry next to Forwarding
Class.

5. In the Name box, enter the name of the
forwarding class.

6. Select the Non LSP Next Hop check box
to use a non-LSP next hop for traffic sent
to the forwarding class next-hop map of
the forwarding policy.

7. Select the Discard check box to discard
the traffic sent to the forwarding class for
the next-hop map referenced by the
forwarding policy.

8. Click Lsp Next Hop  next to
forwarding-class.

9. Click New button next to Lsp Next Hop.

10. In the New Lsp-next-hop dialog box,
enter the LSP regular expression to which
to map the forwarded traffic.

11. Click Next Hop next to forwarding-class.

12. In the New next-hop dialog box, enter the
next-hop name or address to which to
map forwarded traffic.

Specify the map for CoS forwarding routes.

Related Topics Configuring CoS Classifiers (NSM Procedure) on page 115■

■ Configuring CoS Routing Instances (NSM Procedure)

■ Configuring Tracing Operations (NSM Procedure)
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Configuring CoS Fragmentation Maps (NSM Procedure)

For AS PIC link services IQ (lsq-) interfaces only, you can configure fragmentation
properties on a particular forwarding class. You can set a per-forwarding class
fragmentation threshold using fragment-threshold option. This option sets the
maximum size of each multilink fragment. You can also set traffic on a particular
forwarding class to be interleaved rather than fragmented. An extra fragmentation
header is not prepended to the packets received on this queue and that static link
load balancing is used to ensure in-order packet delivery. You can also change the
resequencing interval for each fragmentation class.

To configure CoS fragmentation maps in NSM:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure CoS Fragmentation Maps.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select Fragmentation Maps.

5. Add or modify settings as specified in Table 72 on page 124.

6. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 72: Fragmentation Maps Configuration Details

Your ActionTask

1. Click Add new entry next to
Fragmentation Maps.

2. In the Name box, enter the name of the
fragmentation map.

3. Click Forwarding Class next to
fragmentation-maps.

4. Click Add new entry next to Forwarding
Class.

5. In the Name box, enter the name of the
forwarding class.

6. From the Multilink Class, select the
multilink class to be assigned to the
forwarding class.

Range: 0 through 7

7. From the Drop Timeout list, select the
sequencing timeout interval for each
forwarding class of a multiclass MLPPP.

Range: 0 through 2000

Defines fragmentation properties for individual
forwarding classes.
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Table 72: Fragmentation Maps Configuration Details (continued)

Your ActionTask

1. Click Add new entry next to
Fragmentation Maps.

2. Click Forwarding Class next to
fragmentation-maps.

3. Click Add new entry next to Forwarding
Class.

4. Click Fragment Threshold next to
forwarding-class.

5. Set the fragmentation threshold for an
individual forwarding class.

Range: 64 through 9192 bytes

Set the fragmentation threshold for an
individual forwarding class for only AS PIC link
services IQ interfaces (lsq).

Related Topics Configuring CoS Forwarding Policy (NSM Procedure) on page 122■

■ Configuring CoS Schedulers (NSM Procedure) on page 134

■ Configuring CoS Traffic Control Profiles (NSM Procedure)

Configuring CoS Host Outbound Traffic (NSM Procedure)

You can modify the default queue assignment (forwarding class) and Differentiated
Services Code Point (DSCP) bits used in the Type Of Service (ToS) field of packets
generated by the Routing Engine.

To configure CoS Host Outbound Traffic in NSM:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure Class-of-Service Host Outbound Traffic.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select Host Outbound Traffic.

5. Add or modify settings as specified in Table 73 on page 125.

6. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 73: Host Outbound Traffic Configuration Details

Your ActionFunctionOption

In the Forwarding Class box,
enter the name for the
forwarding class.

Defines a forwarding class
name.

Forwarding Class
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Table 73: Host Outbound Traffic Configuration Details (continued)

Your ActionFunctionOption

From the Dscp Code Point
list, select the DSCP code point
value.

Sets the value of the DSCP
code point in the ToS field of
the packet generated by the
Routing Engine (host).

Dscp Code Point

Related Topics ■ Configuring CoS Forwarding Classes (NSM Procedure) on page 121

■ Configuring CoS Fragmentation Maps (NSM Procedure) on page 124

■ Configuring CoS Traffic Control Profiles (NSM Procedure)

■ Configuring CoS Interfaces (NSM Procedure) on page 126

Configuring CoS Interfaces (NSM Procedure)

An interface is configured for optimal performance in a high-traffic network. This
feature enables you to configure interface-specific CoS properties for incoming
packets.

To configure CoS interfaces in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure CoS interfaces.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select Interfaces.

5. Add or modify the interfaces as specified in Table 74 on page 126.

6. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Network and Security Manager
Administration Guide for more information.

Table 74: Interfaces Configuration Fields

Your ActionFunctionOption

Interface
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Table 74: Interfaces Configuration Fields (continued)

Your ActionFunctionOption

1. Expand the Interfaces tree and
select Interface.

2. Click the New button or select an
interface and click the Edit button
in Interface.

3. Enter the interface name in the
Name box.

Specifies the interface name.Name

1. Expand the Interfaces tree and
select Interface.

2. Click the New button or select an
interface and click the Edit button
in Interface.

3. Enter the comment for the
interface in the Comment box.

Specifies the comment for the interface.Comment

1. Expand the Interfaces tree and
select Interface.

2. Click the New button or select an
interface and click the Edit button
in Interface.

3. Select the scheduler map from the
list.

Specifies the scheduler configuration
mapped to the forwarding class.

Scheduler Map

1. Expand the Interfaces tree and
select Interface.

2. Click the New button or select an
interface and click the Edit button
in Interface.

3. Select the scheduler map chassis
from the list.

Specifies the scheduler configuration
mapped to the forwarding class for the
particular chassis in the chassis queue.

Scheduler Map Chassis

1. Click the New button or select an
interface and click the Edit button
in Interface.

2. Expand the Interface tree and
select Input Traffic Control
Profile.

3. Specify the comment and the
profile name.

4. Click Ok.

Applies an input traffic scheduling and
shaping profile to the logical interface.

Input Traffic Control Profile
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Table 74: Interfaces Configuration Fields (continued)

Your ActionFunctionOption

1. Click the New button or select an
interface and click the Edit button
in Interface.

2. Expand the Interface tree and
select Input Traffic Control Profile
Remaining.

3. Specify a comment and a profile
name.

4. Click Ok.

Applies an input traffic scheduling and
shaping profile for remaining traffic to
the logical interface .

Input Traffic Control Profile Remaining

1. Click the New button or select an
interface and click the Edit button
in Interface.

2. Expand the Interface tree and
select Output Traffic Control
Profile.

3. Specify a comment and a profile
name.

4. Click Ok.

Applies an output traffic scheduling and
shaping profile to the logical interface.

Output Traffic Control Profile

1. Click the New button or select an
interface and click the Edit button
in Interface.

2. Expand the Interface tree and
select Output Traffic Control
Profile Remaining.

3. Specify a comment and a profile
name.

4. Click Ok.

Applies an output traffic scheduling and
shaping profile for remaining traffic to
the logical interface.

Output Traffic Control Profile Remaining

1. Click the New button or select an
interface and click the Edit button
in Interface.

2. Expand Interface tree and select
Shaping Rate.

3. Specify the comment and the rate

4. Click Ok.

Shapes the output of the physical
interface, so that the interface transmits
less traffic than it is physically capable
of carrying.

Shaping Rate
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Table 74: Interfaces Configuration Fields (continued)

Your ActionFunctionOption

1. Click the New button or select an
interface and click the Edit button
in Interface.

2. Expand Interface tree and select
Unit.

3. Specify the Unit, Classifiers, Output
Traffic Control Profile and Shaping
Rate.

4. Click Ok.

Sets the units that need to be allocated
to the specific forwarding class and
scheduling map.

Unit

Interface Set

1. Expand the Interfaces tree and
select Interface Set.

2. Click the New button or select an
interface set and click the Edit
button.

3. Select the name from the list.

Specifies the interface set name.Name

1. Expand the Interfaces tree and
select Interface Set.

2. Click the New button or select an
interface set and click the Edit
button.

3. Enter the comment.

Specifies the comment for the interface.Comment

1. Expand the Interfaces tree and
select Interface Set.

2. Click the New button or select an
interface set and click the Edit
button.

3. Set the internal node.

Sets the scheduler node as internal,
allowing resource scheduling to be
applied equally to interface sets that
include child nodes and those that do
not include child nodes.

Internal Node

1. Expand the Interfaces tree and
select Interface Set.

2. Click the New button or select an
interface set and click the Edit
button.

3. Expand interface—set tree and
select Excess Bandwidth Share.

4. Specify the comment and
proportion.

5. Click Ok.

Sets the excess bandwidth sharing value.Excess Bandwidth Share
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Table 74: Interfaces Configuration Fields (continued)

Your ActionFunctionOption

1. Expand the Interfaces tree and
select Interface Set.

2. Click the New button or select an
interface set and click the Edit
button.

3. Expand interface—set tree and
select Input Excess Bandwidth Share.

4. Specify the comment and
proportion.

5. Click Ok.

Sets the excess input bandwidth sharing
value.

Input Excess Bandwidth Share

1. Expand the Interfaces tree and
select Interface Set.

2. Click the New button or select an
interface set and click the Edit
button.

3. Expand interface—set tree and
select Input Traffic Control Profile.

4. Specify the comment and profile
name.

5. Click Ok.

Applies an input traffic scheduling and
shaping profile to the logical interface.

Input Traffic Control Profile

1. Expand the Interfaces tree and
select Interface Set.

2. Click the New button or select an
interface set and click the Edit
button.

3. Expand interface—set tree and
select Input Traffic Control Profile
Remaining.

4. Specify the comment and profile
name.

5. Click Ok.

Applies an input traffic scheduling and
shaping profile for remaining traffic to
the logical interface.

Input Traffic Control Profile Remaining

1. Expand the Interfaces tree and
select Interface Set.

2. Click the New button or select an
interface set and click the Edit
button.

3. Expand interface—set tree and
select Output Traffic Control Profile.

4. Specify the comment and profile
name.

5. Click Ok.

Applies an output traffic scheduling and
shaping profile to the logical interface.

Output Traffic Control Profile
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Table 74: Interfaces Configuration Fields (continued)

Your ActionFunctionOption

1. Expand the Interfaces tree and
select Interface Set.

2. Click the New button or select an
interface set and click the Edit
button.

3. Expand interface—set tree and
select Output Traffic Control Profile
Remaining.

4. Specify the comment and profile
name.

5. Click Ok.

Applies an output traffic scheduling and
shaping profile for remaining traffic to
the logical interface.

Output Traffic Control Profile Remaining

Related Topics ■ Configuring CoS Classifiers (NSM Procedure) on page 115

■ Configuring CoS Code Point Aliases (NSM Procedure) on page 118

■ Configuring CoS Drop Profile (NSM Procedure) on page 119

■ Configuring CoS Forwarding Classes (NSM Procedure) on page 121

■ Configuring CoS Rewrite Rules (NSM Procedure) on page 131

■ Configuring CoS Schedulers (NSM Procedure) on page 134

■ Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 136

Configuring CoS Rewrite Rules (NSM Procedure)

You configure rewrite rules to alter CoS values in outgoing packets on the outbound
interfaces of a device to match the policies of a targeted peer. Policy matching allows
the downstream router in a neighboring network to classify each packet into the
appropriate service group.

In addition, you often need to rewrite a given marker such as IP precedence, DSCP,
or IEEE 802.1p at the switch's inbound interfaces to accommodate behavior aggregate
(BA) classification by core devices.

You do not need to explicitly apply rewrite rules to interfaces. By default, rewrite
rules are applied to routed packets.

To configure CoS rewrite rules:

1. In the navigation tree, select Device Manager > Devices

2. Click the Device Tree tab, and then double-click the device for which you want
to configure CoS rewrite rules.

3. Click the Configuration tab. In the configuration tree, expand Class of Service

4. Select Rewrite Rules.
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5. Add or modify settings as specified in Table 75 on page 132.

6. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Network and Security Manager
Administration Guide for more information.

Table 75: Configuring and Applying Rewrite Rules

ActionTask

1. Click Configure next to Rewrite Rules.

2. Click Add new entry next to Dscp.

3. In the Name box, type the name of the rewrite rules—for example,
rewrite-dscps.

Configure rewrite
rules for DiffServ
CoS.

1. Click Add new entry next to Forwarding class.

2. In the Queue num box, type 1.

3. In the Class name box, type the name of the previously configured
best-effort forwarding class—for example, be-class.

4. Click Add new entry next to Loss priority.

5. From the Loss val list, select low.

6. In the Code point box, type the value of the low-priority code point
for best-effort traffic—for example, 000000.

7. Click OK.

8. Click Add new entry next to Loss priority.

9. From the Loss val list, select high.

10. In the Code point box, type the value of the high-priority code point
for best-effort traffic—for example, 000001.

11. Click OK twice.

Configure best-effort
forwarding class
rewrite rules.
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Table 75: Configuring and Applying Rewrite Rules (continued)

ActionTask

1. Click Add new entry next to Forwarding class.

2. In the Class name box, type the name of the previously configured
expedited forwarding class—for example, ef-class.

3. Click Add new entry next to Loss priority.

4. From the Loss val list, select low.

5. In the Code point box, type the value of the low-priority code point
for expedited forwarding traffic—for example, 101110.

6. Click OK.

7. Click Add new entry next to Loss priority.

8. From the Loss val list, select high.

9. In the Code point box, type the value of the high-priority code point
for expedited forwarding traffic—for example, 101111.

10. Click OK twice.

Configure expedited
forwarding class
rewrite rules.

1. Click Add new entry next to Forwarding
class.

2. In the Class name box, type the name of
the previously configured expedited
forwarding class—for example, af-class.

3. Click Add new entry next to Loss priority.

4. From the Loss val list, select low.

5. In the Code point box, type the value of
the low-priority code point for assured
forwarding traffic—for example, 001010.

6. Click OK.

7. Click Add new entry next to Loss priority.

8. From the Loss val list, select high.

9. In the Code point box, type the value of
the high-priority code point for assured
forwarding traffic—for example, 001100.

10. Click OK twice.

Configure assured forwarding class rewrite
rules.
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Table 75: Configuring and Applying Rewrite Rules (continued)

1. Click Add new entry next to Interfaces.

2. In the Interface name box, type the name
of the interface—for example, ge-0/0/0.

3. Click Add new entry next to Unit.

4. In the Unit number box, type the logical
interface unit number—for example, 0.

5. Click Configure next to Rewrite rules.

6. In the Rewrite rules name box, under
Dscp, type the name of the previously
configured rewrite rules—for example,
rewrite-dscps.

7. Click OK.

Apply rewrite rules to an interface.

Related Topics ■ Configuring CoS Classifiers (NSM Procedure) on page 115

■ Configuring CoS Code Point Aliases (NSM Procedure) on page 118

■ Configuring CoS Drop Profile (NSM Procedure) on page 119

■ Configuring CoS Forwarding Classes (NSM Procedure) on page 121

■ Configuring CoS Interfaces (NSM Procedure) on page 126

■ Configuring CoS Schedulers (NSM Procedure) on page 134

■ Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 136

Configuring CoS Schedulers (NSM Procedure)

Using schedulers, you can assign attributes to queues and thereby provide congestion
control for a particular class of traffic. These attributes include the amount of interface
bandwidth, memory buffer size, transmit rate, and schedule priority.

To configure CoS schedulers:

1. In the navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure CoS schedulers.

3. Click the Configuration tab. In the configuration tree expand Class of Service.

4. Select Schedulers.

5. Add or modify the settings as specified in Table 76 on page 135.

6. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.
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NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Network and Security Manager
Administration Guide for more information.

Table 76: Configuring Schedulers

ActionTask

1. Click the Add New icon.

2. Expand Buffer Size.

3. Select Percent.

4. Under Percent, select the appropriate option:

■ To specify no buffer size, select None.

■ To specify buffer size as a percentage of the total buffer, select percent and type an
integer from 1 through 100.

■ To specify buffer size as the remaining available buffer, select remainder.

5. Click OK.

Specify the buffer size.

1. Click the Add New icon.

2. Select drop-profile-map.

3. In the Loss Priority box, select the required loss priority—for example, high.

4. In the Protocol box, select the type of protocol—for example, any.

5. In the Drop Profile box, select the previously configured drop profile.

6. Click OK.

Configure drop profile
map.

1. Click the Add New icon.

2. Expand Transmit Rate.

3. Select Rate.

4. Under Rate, select the appropriate option:

■ To not specify transmit rate, select None.

■ To enforce a specific transmission rate, select rate and type the transmission rate that
you want to enforce.

■ To specify a percentage of transmission capacity, select percent and type an integer
from 1 through 100.

■ To specify the remaining transmission capacity, select remainder.

5. Click OK.

Specify the transmit rate.

Related Topics ■ Configuring CoS Classifiers (NSM Procedure) on page 115

■ Configuring CoS Code Point Aliases (NSM Procedure) on page 118

■ Configuring CoS Drop Profile (NSM Procedure) on page 119
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■ Configuring CoS Forwarding Classes (NSM Procedure) on page 121

■ Configuring CoS Interfaces (NSM Procedure) on page 126

■ Configuring CoS Rewrite Rules (NSM Procedure) on page 131

■ Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 136

Configuring CoS and Applying Scheduler Maps (NSM Procedure)

You associate the schedulers with forwarding classes by means of scheduler maps.
You can then associate each scheduler map with an interface, thereby configuring
the queues and packet schedulers that operate according to this mapping.

To configure CoS and apply scheduler maps:

1. In the navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure CoS and apply scheduler maps.

3. Click the Configuration tab. In the configuration tree expand Class of Service.

4. Select Scheduler Maps.

5. Add or modify settings as specified in Table 77 on page 136.

6. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

NOTE: After you make changes to a device configuration, you must push that updated
device configuration to the physical security device for those changes to take effect.
You can update multiple devices at one time. See the Network and Security Manager
Administration Guide for more information.

Table 77: Assigning Forwarding Classes to Output Queues

ActionTask

1. Click Add new entry.

2. In the Name box, type the name of the scheduler map—for example,
diffserv-cos-map.

Configure a scheduler map for
DiffServ CoS.

1. Select Forwarding Class and click Add new entry.

2. In the Name box, type the name of the previously configured best-effort forwarding
class—for example, be-class.

3. Select the previously configured best-effort scheduler—for example, be-scheduler.

4. Click OK.

Configure a best-effort forwarding
class and scheduler.
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Table 77: Assigning Forwarding Classes to Output Queues (continued)

ActionTask

1. Select Forwarding Class and click Add new entry.

2. In the Name box, type the name of the previously configured expedited forwarding
class—for example, ef-class.

3. Select the previously configured expedited forwarding scheduler—for example,
ef-scheduler.

4. Click OK.

Configure an expedited forwarding
class and scheduler.

1. Select Forwarding Class and click Add new entry.

2. In the Name box, type the name of the previously configured assured forwarding
class—for example, af-class.

3. Select the previously configured assured forwarding scheduler—for example,
af-scheduler.

4. Click OK.

Configure an assured forwarding
class and scheduler.

1. Select Interfaces > Interface and click Add new entry.

2. In the Interface name box, type the name of the interface—for example, ge-0/0/0.

3. Select Unit and click Add new entry.

4. In the Unit name box, select the logical interface unit number—for example, 0.

5. In the Scheduler map box, type the name of the previously configured scheduler
map—for example, diffserv-cos-map.

6. Click OK.

Apply the scheduler map to an
interface.

Related Topics ■ Configuring CoS Classifiers (NSM Procedure) on page 115

■ Configuring CoS Code Point Aliases (NSM Procedure) on page 118

■ Configuring CoS Drop Profile (NSM Procedure) on page 119

■ Configuring CoS Forwarding Classes (NSM Procedure) on page 121

■ Configuring CoS Interfaces (NSM Procedure) on page 126

■ Configuring CoS Rewrite Rules (NSM Procedure) on page 131

■ Configuring CoS Schedulers (NSM Procedure) on page 134
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Chapter 13

Configuring Application Layer Gateways
in J Series Services Routers and SRX
Series Services Gateways

■ Configuring H.323 ALG (NSM Procedure) on page 139

■ Configuring SIP ALG (NSM Procedure) on page 141

■ Configuring SCCP ALG (NSM Procedure) on page 144

■ Configuring MGCP ALG (NSM Procedure) on page 146

■ Enabling or Disabling ALGs (NSM Procedure) on page 149

Configuring H.323 ALG (NSM Procedure)

The H.323 standard is a legacy VoIP protocol defined by the ITU-T. H.323 consists
of a suite of protocols (such as H.225.0 and H.245) that are used for call signaling
and call control for VoIP.

To configure H.323 ALG:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure H.323 ALG.

3. Click the Configuration tab. In the configuration tree, select Security > Alg >
H323.

4. Add or modify settings as specified in Table 78 on page 139.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 78: H.323 ALG Configuration Details

Your ActionFunctionOption

Enter a value between 10 and 50,000
seconds.

Controls how long entries
remain in the NAT table.

Endpoint Registration
Timeout
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Table 78: H.323 ALG Configuration Details (continued)

Your ActionFunctionOption

Select this option to enable traffic
from any port number.

Allows media traffic from
any port number. By
default, this feature is
disabled. When disabled,
the device allows a
temporary opening, or
pinhole, in the firewall as
needed for media traffic.

Media Source Port Any

Enter the value for the message flood
gatekeeper threshold.

Limits the rate per second
at which RAS requests to
the gatekeeper are
processed. Messages
exceeding the threshold
are dropped. This feature
is disabled by default.

Threshold

Select this option to permit
unidentified H.323 messages. By
default, unknown (unsupported)
messages are dropped.

Specifies how unidentified
H.323 messages are
handled by the device.
Permitting unknown
messages can compromise
security and is not
recommended. However,
in a secure test or
production environment,
this statement can be
useful for resolving
interoperability issues with
disparate vendor
equipment. By permitting
unknown H.323
(unsupported) messages,
you can get your network
operational and later
analyze your VoIP traffic to
determine why some
messages were being
dropped.

This statement applies only
to received packets
identified as supported
VoIP packets. If a packet
cannot be identified, it is
always dropped. If a packet
is identified as a supported
protocol, the message is
forwarded without
processing.

Permit NAT Applied
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Table 78: H.323 ALG Configuration Details (continued)

Your ActionFunctionOption

Select this option.Specifies that unknown
messages be allowed to
pass if the session is in
Route mode. (Sessions in
Transparent mode are
treated as Route mode.)

Permit Routed

Related Topics ■ Configuring SIP ALG (NSM Procedure) on page 141

■ Configuring SCCP ALG (NSM Procedure) on page 144

■ Configuring MGCP ALG (NSM Procedure) on page 146

■ Enabling or Disabling ALGs (NSM Procedure) on page 149

Configuring SIP ALG (NSM Procedure)

SIP is an IETF-standard protocol for initiating, modifying, and terminating multimedia
sessions over the Internet. Such sessions might include conferencing, telephony, or
multimedia, with features such as instant messaging and application-level mobility
in network environments.

To configure SIP ALG:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure SIP ALG.

3. Click the Configuration tab. In the configuration tree, select Security > Alg >
Sip.

4. Add or modify settings as specified in Table 79 on page 142.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.
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Table 79: SIP ALG Configuration Details

Your ActionFunctionOption

Select a value between 3 and 10
minutes. The default is 3.

Specifies the INVITE
transaction timeout at the
proxy, in minutes. Because
the SIP ALG is in the
middle, instead of using
the INVITE transaction
timer value B (which is (64
* T1) = 32 seconds), the
SIP ALG gets its timer value
from the proxy.

C Timeout

Select a value between 10 and 2,550
seconds. The default is 120 seconds.

Specifies the maximum
length of time (in seconds)
a call can remain active
without any media (RTP or
RTCP) traffic within a
group. Each time an RTP
or RTCP packet occurs
within a call, this timeout
resets. When the period of
inactivity exceeds this
setting, the temporary
openings (pinholes) in the
firewall SIP ALG opened for
media are closed. Note that
upon timeout, while
resources for media
(sessions and pinholes) are
removed, the call is not
terminated.

Inactive Media Timeout

Select a value between 3 and 7,200
minutes. The default is 720 minutes.

Sets the absolute
maximum length of a call.
When a call exceeds this
parameter setting, the SIP
ALG tears down the call
and releases the media
sessions.

Maximum Call Duration

Select a value between 500 and 5,000
milliseconds. The default is 500
milliseconds.

Specifies the roundtrip
time estimate (in seconds)
of a transaction between
endpoints. Because many
SIP timers scale with the
T1-Interval (as described in
RFC 3261), when you
change the value of the
T1-Interval timer, those SIP
timers also are adjusted.

T1 Interval
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Table 79: SIP ALG Configuration Details (continued)

Your ActionFunctionOption

Select a value between 5 and 10
seconds. The default is 5 seconds.

Specifies the maximum
time a message remains .
in the network. Because
many SIP timers scale with
the T4-Interval (as
described in RFC 3261),
when you change the value
of the T4-Interval timer,
those SIP timers also are
adjusted.

T4 Interval

Select this option to enable translation
of host IP address in the call-ID
header. By default, translation is
enabled.

Enables or disables
translation of the host IP
address in the call-ID
header. Translation is
enabled by default.

Disable

Select this option to enable the device
to retain media stream resources
when the media stream is on hold. By
default, media stream resources are
released when the media stream is
held.

Specifies whether the
device frees media
resources for a SIP ALG,
even when a media stream
is placed on hold.

Retain Hold Resource

Enter a value between 1 and 3,600
seconds.

Specifies the amount of
time (in seconds) to make
an attack table entry for
each INVITE, which is
listed in the application
screen.

Timeout

Select None, destination-ip, or all. If
you select destination-ip, enter or
select an IP address.

Protects servers against
INVITE attacks. Configure
the SIP application screen
to protect the server at
some or all destination IP
addresses against INVITE
attacks. You can include up
to 16 destination IP
addresses of servers to be
protected.

Destination Ip
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Table 79: SIP ALG Configuration Details (continued)

Your ActionFunctionOption

Select this option to permit
unidentified SIP messages. By default,
unknown (unsupported) messages are
dropped.

Specifies how unidentified
SIP messages are handled
by the device. Permitting
unknown messages can
compromise security and
is not recommended.
However, in a secure test
or production
environment, this
statement can be useful for
resolving interoperability
issues with disparate
vendor equipment. By
permitting unknown SIP
(unsupported) messages,
you can get your network
operational and later
analyze your VoIP traffic to
determine why some
messages were being
dropped.

This statement applies only
to received packets
identified as supported
VoIP packets. If a packet
cannot be identified, it is
always dropped. If a packet
is identified as a supported
protocol, the message is
forwarded without
processing.

Permit NAT Applied

Select this option.Specifies that unknown
messages be allowed to
pass if the session is in
Route mode. (Sessions in
Transparent mode are
treated as Route mode.)

Permit Routed

Related Topics ■ Configuring SCCP ALG (NSM Procedure) on page 144

■ Configuring H.323 ALG (NSM Procedure) on page 139

■ Configuring MGCP ALG (NSM Procedure) on page 146

■ Enabling or Disabling ALGs (NSM Procedure) on page 149

Configuring SCCP ALG (NSM Procedure)

SCCP is a protocol for call signaling. Skinny is based on a call-agent-based call-control
architecture. The control protocol uses binary-coded frames encoded on TCP frames
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sent to well-known TCP port number destinations to set up and tear down RTP media
sessions.

To configure SCCP ALG:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure SCCP ALG.

3. Click the Configuration tab. In the configuration tree, select Security > Alg >
Sccp.

4. Add or modify settings as specified in Table 80 on page 145.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 80: SCCP ALG Configuration Details

Your ActionFunctionOption

Select a value between 10 and 600
seconds.

Indicates the maximum
length of time (in seconds)
a call can remain active
without any media (RTP or
RTCP) traffic within a
group. Each time an RTP
or RTCP packet occurs
within a call, this timeout
resets. When the period of
inactivity exceeds this
setting, the SCCP ALG the
gates opened for media are
closed.

Inactive Media Timeout

Select a value for call flood threshold
from 2 to 1,000.

Protects SCCP ALG clients
from flood attacks by
limiting the number of calls
they attempt to process.

Threshold
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Table 80: SCCP ALG Configuration Details (continued)

Your ActionFunctionOption

Select this option to permit
unidentified SCCP messages. By
default, unknown (unsupported)
messages are dropped.

Specifies how unidentified
SCCP messages are
handled by the device.
Permitting unknown
messages can compromise
security and is not
recommended. However,
in a secure test or
production environment,
this statement can be
useful for resolving
interoperability issues with
disparate vendor
equipment. By permitting
unknown SCCP
(unsupported) messages,
you can get your network
operational and later
analyze your VoIP traffic to
determine why some
messages were being
dropped.

This statement applies only
to received packets
identified as supported
VoIP packets. If a packet
cannot be identified, it is
always dropped. If a packet
is identified as a supported
protocol, the message is
forwarded without
processing.

Permit NAT Applied

Select this option.Specifies that unknown
messages be allowed to
pass if the session is in
Route mode. (Sessions in
Transparent mode are
treated as Route mode.)

Permit Routed

Related Topics ■ Configuring SIP ALG (NSM Procedure) on page 141

■ Configuring H.323 ALG (NSM Procedure) on page 139

■ Configuring MGCP ALG (NSM Procedure) on page 146

■ Enabling or Disabling ALGs (NSM Procedure) on page 149

Configuring MGCP ALG (NSM Procedure)

MGCP is a text-based Application Layer Protocol used for call setup and call control
between the media gateway and the media gateway controller (MGC).
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To configure MGCP ALG:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure MGCP ALG.

3. Click the Configuration tab. In the configuration tree, select Security > Alg >
Mgcp.

4. Add or modify settings as specified in Table 81 on page 147.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 81: MGCP ALG Configuration Details

Your ActionFunctionOption

Select a value between 10 and 2,550
seconds. The default is 120 seconds.

Specifies the maximum
length of time (in seconds)
a call can remain active
without any media (RTP or
RTCP) traffic within a
group. Each time an RTP
or RTCP packet occurs
within a call, this timeout
resets. When the period of
inactivity exceeds this
setting, the temporary
openings (pinholes) in the
firewall MGCP ALG opened
for media are closed. Note
that upon timeout, while
resources for media
(sessions and pinholes) are
removed, the call is not
terminated.

Inactive Media Timeout

Enter a value from 3 to 50 seconds.Specifies a timeout value
for MGCP transactions. A
transaction is a signaling
message, for example, a
NTFY from the gateway to
the call agent or a 200 OK
from the call agent to the
gateway. The Juniper
Networks device tracks
these transactions, and
clears them when they
time out.

Transaction Timeout
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Table 81: MGCP ALG Configuration Details (continued)

Your ActionFunctionOption

Select a value between 3 and 7,200
minutes. The default is 720 minutes.

Sets the absolute
maximum length of a call.
When a call exceeds this
parameter setting, the
MGCP ALG tears down the
call and releases the media
sessions.

Maximum Call Duration

Enter a value from 2 to 10,000.Limits the number of new
connection requests
allowed per media gateway
per second.

Connection Flood
Threshold

Enter a value from 2 to 50,000
seconds per media gateway. By
default, this feature is disabled.

Limits the rate per second
at which message requests
to the media gateway are
processed. Messages
exceeding the threshold
are dropped by the MGCP
ALG.

Message Flood Threshold

Select this option to permit
unidentified MGCP messages. By
default, unknown (unsupported)
messages are dropped..

Specifies how unidentified
MGCP messages are
handled by the Juniper
Networks device.
Permitting unknown
messages can compromise
security and is not
recommended. However,
in a secure test or
production environment,
this statement can be
useful for resolving
interoperability issues with
disparate vendor
equipment. By permitting
unknown MGCP
(unsupported) messages,
you can get your network
operational and later
analyze your VoIP traffic to
determine why some
messages were being
dropped.

This statement applies only
to received packets
identified as supported
VoIP packets. If a packet
cannot be identified, it is
always dropped. If a packet
is identified as a supported
protocol, the message is
forwarded without
processing.

Permit NAT Applied
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Table 81: MGCP ALG Configuration Details (continued)

Your ActionFunctionOption

Select this option.Specifies that unknown
messages be allowed to
pass if the session is in
Route mode. (Sessions in
Transparent mode are
treated as Route mode.)

Permit Routed

Related Topics ■ Configuring SCCP ALG (NSM Procedure) on page 144

■ Configuring SIP ALG (NSM Procedure) on page 141

■ Configuring H.323 ALG (NSM Procedure) on page 139

■ Enabling or Disabling ALGs (NSM Procedure) on page 149

Enabling or Disabling ALGs (NSM Procedure)

All ALGs are enabled by default.

To enable or disable ALGs:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to enable or disable ALGs.

3. Click the Configuration tab. In the configuration tree, select Security > Alg.

4. Select the check box next to an ALG as specified in Table 82 on page 149.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 82: ALG Configuration Options

Your ActionFunctionOption

Multimedia Application Protocols

Select the Disable check box to
disable the RTSP ALG.

Provides an ALG for the
Real-Time Streaming
Protocol.

RTSP

Basic Internet Protocols

Select the Disable check box to
disable the DNS ALG.

Provides an ALG for the
Domain Name System. The
DNS ALG monitors DNS

DNS

query and reply packets
and closes session if the
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Table 82: ALG Configuration Options (continued)

Your ActionFunctionOption

DNS flag indicates the
packet is a reply message.

Select the Disable check box to
disable the FTP ALG.

Provides an ALG for the
File Transfer Protocol. The
FTP ALG monitors PORT,
PASV and 227 commands.
It performs NAT of IP/port
in the message and gate
opening on the device as
necessary. The FTP ALG
supports FTP put and FTP
get  command blocking.
When FTP_NO_PUT or
FTP_NO_GET is set in the
policy, the FTP ALG sends
back a blocking command
and closes the associated
opened gate when either
the FTP STOR or FTP RETR
command is observed.

FTP

Select the Disable check box to
disable the TFTP ALG.

Provides an ALG for the
Trivial File Transfer
Protocol. The TFTP ALG
processes a TFTP packet
that initiates the request
and opens a gate to allow
return packets from the
reverse direction to the
port that sends the request.

TFTP

Select the Disable check box to
disable the TALK ALG.

Provides an ALG for the
TALK Protocol. The TALK
protocol uses UDP port
517 and port 518 for
control channel
connections. The talk
program consists of a
server and a client. The
server handles client
notifications and helps to
establish talk sessions.
There are two types of talk
servers: ntalk and talkd.
The TALK ALG processes
packets of both ntalk and
talkd formats. It also
performs NAT and gate
opening as necessary.

TALK
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Table 82: ALG Configuration Options (continued)

Your ActionFunctionOption

Select the Disable check box to
disable the RSH ALG.

Provides an ALG for the
Remote Shell. The RSH
ALG handles TCP packets
destined for port 514 and
process the RSH port
command. The RSH ALG
performs NAT on the port
in the port command and
opens gates as necessary.

RSH

Select the Disable check box to
disable the PPTP ALG.

Provides an ALG for the
Point-to-Point Tunneling
Protocol. The PPTP is a
Layer 2 protocol that
tunnels PPP data across
TCP/IP networks. The PPTP
client is freely available on
Windows systems and is
widely deployed for
building VPNs.

PPTP

Database and Network Support Protocols

Select the Disable check box to
disable the SQL ALG.

Provides an ALG for the
Structured Query
Language. The SQLNET
ALG processes an SQL TNS
response frame from the
server side. It parses the
packet and looks for
(HOST=ipaddress),
(PORT=port) pattern, and
performs NAT and gate
opening on the client side
for the TCP data channel.

SQL

Related Topics ■ Configuring H.323 ALG (NSM Procedure) on page 139

■ Configuring SIP ALG (NSM Procedure) on page 141

■ Configuring SCCP ALG (NSM Procedure) on page 144

■ Configuring MGCP ALG (NSM Procedure) on page 146
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Chapter 14

Configuring Unified Threat Management
Features in J Series Services Routers and
SRX Series Services Gateways

■ Configuring Server-Based Antispam (NSM Procedure) on page 153

■ Configuring Local List Antispam (NSM Procedure) on page 154

■ Configuring Antivirus Protection (NSM Procedure) on page 157

■ Configuring Content Filtering (NSM Procedure) on page 162

■ Configuring Web Filtering (NSM Procedure) on page 165

Configuring Server-Based Antispam (NSM Procedure)

Antispam filtering allows you to use both a third-party server-based spam block list
(SBL) and to optionally create your own local whitelists (benign) and blacklists
(malicious) for filtering against e-mail messages. The antispam feature is not meant
to replace your antispam server, but to complement it.

To configure server-based antispam:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure server-based antispam.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Feature Profile > Anti Spam.

4. Select Symantec Sbl and enable the feature.

5. Expand Symantec Sbl and select Profile.

6. Add or modify antispam profile settings as specified in Table 83 on page 154.

7. Click one:

■ New—Adds a new profile.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.
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Table 83: Server-Based Antispam Profile Settings

Your ActionFunctionOption

Enter a unique name for the antispam
profile.

Specifies a name for the
antispam profile.

Name

Select sbl-default-server if you are using
the default server. Otherwise, select
None.

Specifies whether the Symantec
SBL server is used.

sbl-default-server

Select one of the following: tag-subject
(of e-mail), block (e-mail), tag-header
(of e-mail).

Specifies the action to be taken
by the device when spam is
detected.

Spam Action

Enter a custom string for identifying a
message as spam. By default, the device
uses ***SPAM***.

Specifies the string used for
identifying a message as spam.

Custom Tag
String

Related Topics ■ Configuring Local List Antispam (NSM Procedure) on page 154

■ Configuring Antivirus Protection (NSM Procedure) on page 157

■ Configuring Content Filtering (NSM Procedure) on page 162

Configuring Local List Antispam (NSM Procedure)

This section includes the following topics:

■ Configuring Whitelist and Blacklist Entries on page 154

■ Configuring a Custom URL Category List Custom Object on page 155

■ Configuring Server-Based Antispam on page 155

■ Configuring a UTM Policy for SNMP on page 156

Configuring Whitelist and Blacklist Entries

To configure local whitelist and blacklist custom objects:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure whitelist and blacklist custom objects.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Custom Objects.

4. Select Url Pattern and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. Enter a value for the URL pattern for whitelist or blacklist antispam filtering.
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NOTE: For URL pattern wildcard support, the wdildcard rule is as follows: \*\.[]\?*
and you must precede all wildcard URLs with http://. You can only use an asterisk
(*) if it is at the beginning of the URL and is followed by a dot (.). You can only use
a question mark (?) at the end of the URL.

The following wildcard syntax is supported: http://*.juniper.net,
http://www.juniper.ne?, http://www.juniper.n??. The following wildcard syntax is not
supported: *.juniper.net , www.juniper.ne?, http://*juniper.net, http://*.

8. Click OK to save the changes.

Configuring a Custom URL Category List Custom Object

To configure a custom URL category list custom object:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure URL category list custom objects.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Custom Objects.

4. Select Custom Url Category and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. Enter the name of the URL pattern list you created for bypassing scanning.

8. Click OK to save the changes.

Configuring Server-Based Antispam

Antispam filtering allows you to use both a third-party server-based spam block list
(SBL) and to optionally create your own local whitelists (benign) and blacklists
(malicious) for filtering against e-mail messages. The antispam feature is not meant
to replace your antispam server, but to complement it.

To configure server-based antispam:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure server-based antispam.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Feature Profile > Anti Spam.

4. Select Symantec Sbl and enable the feature.

5. Expand Symantec Sbl and select Profile.
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6. Add or modify antispam profile settings as specified in Table 84 on page 156.

7. Click one:

■ New—Adds a new profile.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 84: Server-Based Antispam Profile Settings

Your ActionFunctionOption

Enter a unique name for the antispam
profile.

Specifies a name for the
antispam profile.

Name

Select sbl-default-server if you are using
the default server. Otherwise, select
None.

Specifies whether the Symantec
SBL server is used.

sbl-default-server

Select one of the following: tag-subject
(of e-mail), block (e-mail), tag-header
(of e-mail).

Specifies the action to be taken
by the device when spam is
detected.

Spam Action

Enter a custom string for identifying a
message as spam. By default, the device
uses ***SPAM***.

Specifies the string used for
identifying a message as spam.

Custom Tag
String

Configuring a UTM Policy for SNMP

To configure a UTM policy for SNMP:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to a UTM policy for SNMP.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Utm Policy.

4. Click New to add a new UTM policy entry.

5. Enter a unique name for the UTM policy.

6. Select Antispam and enter the name of the antispam profile.

7. Click OK to save the changes.

Once you have configured a UTM policy for SNMP, attach the UTM policy to a security
policy that you create.

Related Topics Configuring Antivirus Protection (NSM Procedure) on page 157■

■ Configuring Content Filtering (NSM Procedure) on page 162

■ Configuring Web Filtering (NSM Procedure) on page 165
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Configuring Antivirus Protection (NSM Procedure)

This section includes the following topics:

■ Configuring a MIME Pattern List Custom Object on page 157

■ Configuring a Filename Extension List Custom Object on page 157

■ Configuring a URL Pattern List Custom Object on page 158

■ Configuring a Custom URL Category List Custom Object on page 158

■ Configuring an Antivirus Feature Profile on page 159

■ Configuring a UTM Policy for Express Antivirus on page 161

Configuring a MIME Pattern List Custom Object

To configure a MIME pattern list custom object:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure a MIME pattern list custom object.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Custom Objects.

4. Select Mime Pattern and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. Enter a value for the MIME pattern.

8. Click OK to save the changes.

Configuring a Filename Extension List Custom Object

To configure a filename extension list custom object:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure a filename extension list.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Custom Objects.

4. Select Filename Extension and click New.

5. Enter a unique name for the extension list.

6. Select Value and add a new entry.

7. Enter the extensions in the Value box.

8. Click OK to save the changes.
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Configuring a URL Pattern List Custom Object

To configure a URL pattern list custom object:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure URL pattern list custom objects.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Custom Objects.

4. Select Url Pattern and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. In Value, enter the URLs or IP addresses you want added to the list for bypassing
scanning.

NOTE: For URL pattern wildcard support, the wdildcard rule is as follows: \*\.[]\?*
and you must precede all wildcard URLs with http://. You can only use an asterisk
(*) if it is at the beginning of the URL and is followed by a dot (.). You can only use
a question mark (?) at the end of the URL.

The following wildcard syntax is supported: http://*.juniper.net,
http://www.juniper.ne?, http://www.juniper.n??. The following wildcard syntax is not
supported: *.juniper.net , www.juniper.ne?, http://*juniper.net, http://*.

8. Click OK to save the changes.

Configuring a Custom URL Category List Custom Object

To configure a custom URL category list custom object:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to URL category list custom objects.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Custom Objects.

4. Select Custom Url Category and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. Enter the name of the URL pattern list you created for bypassing scanning.

8. Click OK to save the changes.
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Configuring an Antivirus Feature Profile

When configuring antivirus protection, you must first create the antivirus custom
objects you are using. Those custom objects may include the MIME pattern list, MIME
exception list, and the filename extension list. Once you have created your custom
objects, you can configure full antivirus protection, including intelligent prescreening,
and content size limits.

To configure an antivirus feature profile:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure an antivirus feature profile.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Feature Profile > Antivirus > Kaspersky Lab Engine.

4. Add or modify antivirus profile settings as specified in Table 85 on page 159.

5. Click one:

■ New—Adds a new profile.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 85: Antivirus Feature Profile Settings

Your ActionFunctionOption

Pattern Update

If the URL is not already entered, enter the
URL for the pattern database. Note that the
URL is
http://update.juniper-updates.net/AV/SRX210
and you should not change it.

Specifies the URL for
the pattern database.

Url

Enter the time interval for automatically
updating the pattern database. The default
interval is 60 minutes.

Specifies the time
interval for
automatically
updating the pattern
database.

Interval

Select this option if you want to disable
automatic updates and update the pattern
database manually.

Specifies whether
automatic updates
are disabled.

No Autoupdate

Pattern Update > Email Notify

Enter the e-mail addresses of the
administrators who should receive e-mail
notifications when updates are made to the
pattern file.

Specifies the e-mail
addresses of the
administrators.

Admin Email
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Table 85: Antivirus Feature Profile Settings (continued)

Your ActionFunctionOption

Enter the text to appear in the body of the
notification e-mail.

Specifies the text
that will appear in
the custom message.

Custom Message

Enter the text to appear in the subject line of
the notification e-mail.

Specifies the custom
message subject.

Custom Message
Subject

Profile

Enter a unique name for the Kaspersky lab
engine profile.

Specifies the name
of the Kaspersky lab
engine profile.

Name

Profile > Fallback Options

Select this option to enable fallback options.Enables fallback
options.

Enable Feature

Select log-and-permit or block from the list.Specifies the fallback
options.

The available fallback
options are as follows:

■ Default

■ Corrupt File

■ Password File

■ Decompress Layer

■ Content Size

■ Engine Not Ready

■ Timeout

■ Out of Resources

■ Too Many
Requests

Profile > Notification Options

Select this option to enable notification
options.

Enables notification
options.

Enable Feature

■ Custom Message—Enter the text to
appear in the body of the notification
e-mail.

■ Custom Message Subject—Enter the text
to appear in the subject line of the
notification e-mail.

■ notify-mail-sender—Select this option to
notify the sender of the mail.

■ Type—Select protocol-only or message
from the Type list.

Specifies the
notification actions
for fallback block,
fallback nonblock,
and virus detection.

The notification options
that can be configured
are the following:

■ Fallback Block

■ Fallback Non Block

■ Virus Detection

Profile > Scan Options

Select this option to enable scan options.Enables scan
options.

Enable Feature

Select this option to enable intelligent
prescreening.

Enables intelligent
prescreening.

intelligent-prescreening
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Table 85: Antivirus Feature Profile Settings (continued)

Your ActionFunctionOption

Enter content size parameters.Specifies the content
size parameters. The
content size check
occurs before the
scan request is sent.
The content size
refers to
accumulated TCP
payload size.

Content Size Limit

Enter the scanning timeout parameters.Specifies the
scanning timeout
parameters.

Timeout

Profile > Trickling

Select this option to enable trickling feature.Enables trickling
feature.

Enable Feature

Enter the trickling timeout parameters.Specifies the trickling
timeout parameters.

Timeout

Antivirus > Mime
Whitelist

Select this option to enable this feature.Enables this feature.Enable Feature

Enter the name of the URL whitelist custom
object you created.

Specifies the name
of the URL whitelist.

List

Configuring a UTM Policy for Express Antivirus

To configure a UTM policy for express antivirus:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device that you want to
configure.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Utm Policy.

4. Click New to add a new UTM policy entry.

5. Enter a unique name for the UTM policy.

6. Select Antivirus and enter the name of the antivirus profile.

7. In the Http, Imap, Pop3, or Smtp profile boxes, enter the name of the profile
you created earlier.

8. For Ftp, select the upload and download profiles.

9. Click OK to save the changes.
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Once you have configured a UTM policy for express antivirus, attach the UTM policy
to a security policy that you create.

Related Topics Configuring Local List Antispam (NSM Procedure) on page 154■

■ Configuring Content Filtering (NSM Procedure) on page 162

■ Configuring Web Filtering (NSM Procedure) on page 165

Configuring Content Filtering (NSM Procedure)

This section includes the following topics:

■ Configuring a Protocol Command Custom Object on page 162

■ Configuring a Filename Extension List Custom Object on page 162

■ Configuring a MIME Pattern List Custom Object on page 163

■ Configuring a Content–Filtering Feature Profile on page 163

■ Configuring a UTM Policy for Content-Filtering on page 165

Configuring a Protocol Command Custom Object

To configure a protocol command custom object:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure a protocol command custom object.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Custom Objects.

4. Select Protocol Command and click New.

5. Enter a unique name for the protocol command custom object.

6. Select Value and add a new entry.

7. Enter the commands for the protocol in Value.

8. Click OK to save the changes.

Configuring a Filename Extension List Custom Object

To configure a filename extension list custom object:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure a filename extension list.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Custom Objects.

4. Select Filename Extension and click New.
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5. Enter a unique name for the extension list.

6. Select Value and add a new entry.

7. Enter the extensions in the Value box.

8. Click OK to save the changes.

Configuring a MIME Pattern List Custom Object

To configure a MIME pattern list custom object:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure a MIME pattern list custom object.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Custom Objects.

4. Select Mime Pattern and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. Enter a value for the MIME pattern.

8. Click OK to save the changes.

Configuring a Content–Filtering Feature Profile

To configure a content-filtering feature profile:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure a content-filtering feature profile.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Feature Profile > Content Filering > Profile.

4. Add or modify content-filtering profile settings as specified in Table 86 on
page 163.

5. Click one:

■ New—Adds a new profile.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 86: Content–Filtering Feature Profile Settings

Your ActionFunctionOption

Profile
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Table 86: Content–Filtering Feature Profile Settings (continued)

Your ActionFunctionOption

Enter a unique name for this profile.Specifies the name of the
content-filtering profile.

Name

Enter the protocol command custom
object you created for permitting
commands from the list.

The permit protocol command
list is intended to act as an
exception list for the block
protocol command list.

Permit Command

Enter the protocol command custom
object you created for blocking
commands from the list.

Specifies the block command.Block Command

Enter the file extension list custom
object you created for blocking
extensions from the list.

Specifies the extensions that are
blocked.

Block Extension

Profile > Block Content Type

Select one or more of the content types
to be blocked..

Specifies the content types that
can be blocked.

The content types
that can be blocked
are the following:

■ Activex

■ Java Applet

■ Exe

■ Zip

■ Http Cookie

Profile > Block Mime

Select this option to configure block
MIME features.

Enables configuration of block
MIME features.

Enable Feature

Enter the MIME list custom object you
created for blocking MIME patterns.

Specifies the MIME list custom
object.

List

Enter the exception MIME list custom
object you created for MIME patterns
that will not be blocked.

Specifies the exception MIME list
custom object.

Exception

Profile > Notification Options

Select this option to enable notification
options.

Enables notification options.Enable Feature

Select message as the type of
notification that is sent when a fallback
option of block is triggered.

Specifies the notification type.Type

Select this option to notify the sender
of the mail.

Specifies that notification will be
sent to the sender.

notify-mail-sender

Enter the text to appear in the body of
the notification e-mail.

Specifies the notification actions
for fallback block, fallback
nonblock, and virus detection.

Custom Message
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Configuring a UTM Policy for Content-Filtering

To configure a UTM policy for content filtering:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device that you want to
configure.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Utm Policy.

4. Click New to add a new UTM policy entry.

5. Enter a unique name for the UTM policy.

6. Select Content Filtering and enter the name of the profile you had created.

7. In the Http, Imap, Pop3, or Smtp profile boxes, enter the name of the profile
you created earlier.

8. For Ftp, select the upload and download profiles.

9. Click OK to save the changes.

Once you have configured a UTM policy for content filtering, attach the UTM policy
to a security policy that you create.

Related Topics Configuring Local List Antispam (NSM Procedure) on page 154■

■ Configuring Antivirus Protection (NSM Procedure) on page 157

■ Configuring Web Filtering (NSM Procedure) on page 165

Configuring Web Filtering (NSM Procedure)

This section includes the following topics:

■ Configuring a URL Pattern List Custom Object on page 165

■ Configuring a Custom URL Category List Custom Object on page 166

■ Configuring a Web Filtering Feature Profile on page 166

■ Configuring a UTM Policy for Web Filtering on page 168

Configuring a URL Pattern List Custom Object

To configure a URL pattern list custom object:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure URL pattern list custom objects.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Custom Objects.
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4. Select Url Pattern and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. In Value, enter the URLs or IP addresses that you want to be added to the list
for bypassing scanning.

NOTE: For URL pattern wildcard support, the wdildcard rule is as follows: \*\.[]\?*
and you must precede all wildcard URLs with http://. You can only use an asterisk
(*) if it is at the beginning of the URL and is followed by a dot (.). You can only use
a question mark (?) at the end of the URL.

The following wildcard syntax is supported: http://*.juniper.net,
http://www.juniper.ne?, http://www.juniper.n??. The following wildcard syntax is not
supported: *.juniper.net , www.juniper.ne?, http://*juniper.net, http://*.

8. Click OK to save the changes.

Configuring a Custom URL Category List Custom Object

To configure a custom URL category list custom object:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure whitelist and blacklist custom objects.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Custom Objects.

4. Select Custom Url Category and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. Enter the name of the URL pattern list you created for bypassing scanning.

8. Click OK to save the changes.

Configuring a Web Filtering Feature Profile

To configure a Web filtering feature profile:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want
to configure a Web filtering feature profile.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Feature Profile > Web Filtering.
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4. Add or modify Web filtering feature profile settings as specified in Table 87 on
page 167.

5. Click one:

■ New—Adds a new profile.

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Table 87: Web Filtering Feature Profile Settings

Your ActionFunctionOption

Enter the name of the custom URL list you
created. This is the first filtering category
that both integrated and redirect Web
filtering use. If there is no match, the URL
is sent to the SurfControl server.

Specifies the URL whitelist.Url Whitelist

Enter the name of the custom URL list you
created. This is the first filtering category
that both integrated and redirect Web
filtering use. If there is no match, the URL
is sent to the SurfControl server.

Specifies the URL blacklist.Url Blacklist

Select surf-control-integrated from the list.Specifies the type of Web
filtering.

Type

Surf Control Integrated > Cache

Select this option to enable cache options.Enables cache options.Enable Feature

Enter a timeout limit in minutes for
expiring cache entries. (The default is 24
hours and the maximum allowed life span.)

Specifies the timeout limit for
cache entries.

Timeout

Enter a size limit for the cache in kilobytes.
(The default is 500 KB.)

Specifies the size limit for the
cache.

Size

Surf Control Integrated > Server

Select this option to enable server options.Enables server options.Enable Feature

Enter the Surf Control server name or IP
address.

Specifies the Surf Control
server address.

Host

Enter the port number for communicating
with the Surf Control server. (Default ports
are 80, 8080, and 8081.)

Specifies the port number for
communicating with the Surf
Control server.

Port

Surf Control Integrated > Profile

Enter a unique name for this profile.Specifies a name for the
Web-filtering profile.

Name

Select log-and-permit, permit, or block
from the list.

Specifies the default action
for this profile for requests
that experience errors.

Default

Configuring a Web Filtering Feature Profile ■ 167

Chapter 14: Configuring Unified Threat Management Features in J Series Services Routers and SRX Series Services Gateways



Table 87: Web Filtering Feature Profile Settings (continued)

Your ActionFunctionOption

Enter a custom message to be sent when
HTTP requests are blocked.

Specifies the custom
message.

Custom Block
Message

Enter a value in seconds. Once this limit is
reached, fail mode settings are applied. The
default setting is 10 seconds.

Specifies the timeout limit.Timeout

Surf Control Integrated > Profile > Fallback Settings

Select this option to enable fallback options.Enables fallback options.Enable Feature

Select log-and-permitor block from the
list.

Specifies the fallback options.The available
fallback options
are as follows:

■ Default

■ Server
Connectivity

■ Timeout

■ Too Many
Requests

Surf Control Integrated > Profile > Category

Enter the name of the custom URL category
list custom object you created.

Specifies the name of the
category.

Name

Select log-and-permit, permit, or block
from the list.

Specifies the action to be
taken.

Action

Configuring a UTM Policy for Web Filtering

To configure a UTM policy for Web filtering:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device that you want to
configure.

3. Click the Configuration tab. In the configuration tree, select Security > Utm >
Utm Policy.

4. Click New to add a new UTM policy entry.

5. Enter a unique name for the UTM policy.

6. Select Web Filtering and enter the name of Web filtering profile you created
earlier in Http Profile.

7. In the Http profile box, enter the name of the profile you created earlier.

8. Click OK to save the changes.

Once you have configured a UTM policy for Web filtering, attach the UTM policy to
a security policy that you create.
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Related Topics ■ Configuring Local List Antispam (NSM Procedure) on page 154

■ Configuring Content Filtering (NSM Procedure) on page 162

■ Configuring Antivirus Protection (NSM Procedure) on page 157
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Part 3

Managing J Series Services Routers and
SRX Series Services Gateways

■ Using System Management Features in J Series Services Routers and SRX Series
Services Gateways on page 173

■ Topology Manager on page 177

■ IDP Management in J Series Services Routers and SRX Series Services
Gateways on page 181
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Chapter 15

Using System Management Features in J
Series Services Routers and SRX Series
Services Gateways

■ Managing J Series and SRX Series Device Software Versions Overview on page 173

■ Viewing and Reconciling Device Inventory Overview on page 173

■ Viewing Device Inventory in NSM (NSM Procedure) on page 174

■ Removing a J Series or SRX Series Device from NSM Management (NSM
Procedure) on page 175

Managing J Series and SRX Series Device Software Versions Overview

You can use Network and Security Manager (NSM) to upgrade or adjust the software
on managed J Series and SRX Series devices running JUNOS Release 9.3 or later.

When a software upgrade is applied to a J Series or SRX Series device with dual
Routing Engines, the upgraded software is applied to both Routing Engines. The
backup is upgraded first. The router then reboots and the backup becomes the master.
Then the former master is upgraded, as is the standard procedure for upgrading J
Series and SRX Series devices with dual Routing Engines.

For steps on updating the device software version, see “Upgrading the Device
Software” in the Network and Security Manager Administration Guide.

Related Topics Viewing Device Inventory in NSM (NSM Procedure) on page 174■

■ Viewing and Reconciling Device Inventory Overview on page 173

Viewing and Reconciling Device Inventory Overview

Device inventory management in Network and Security Manager (NSM) allows you
to display information about the hardware, software, and license components of
each device. It also provides features to update the NSM database with the most
current inventory information from the device. In addition, you can use Device
Monitor, Device List, and the device tooltip to view the status of inventory
synchronization.
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These inventory management features are available for all J Series and SRX Series
devices, You can use these features to make the NSM database match the device
inventory, but you cannot write new inventory information to the device.

Initially, the device inventory in the NSM database is generated when the device is
first imported into NSM. Immediately after import, the device inventory in the NSM
database matches exactly the inventory on the device itself.

If the hardware on the device is changed, the software is upgraded through the J-Web
or CLI, new software packages are installed, and then the inventory on the device is
no longer synchronized with the NSM database.

The Device Monitor, Device List, and tooltip shows the hardware and software
inventory status for each device. Possible states include:

■ In Sync—Inventory in the NSM database matches the device.

■ Out of Sync—Inventory in the NSM database does not match the device.

■ N/A—Either the device is not yet connected and managed by NSM, or the device
is a ScreenOS security device or IDP sensor.

Changes to the device inventory are not automatically updated in the NSM database.

For detailed information about comparing and reconciling device inventory, see the
Network and Security Manager Administration Guide.

Related Topics ■ Viewing Device Inventory in NSM (NSM Procedure) on page 174

Viewing Device Inventory in NSM (NSM Procedure)

NSM displays the hardware and software inventory for each device according to the
information it has in its database. For a device with dual Routing Engines, NSM
collects the inventory data from the master Routing Engine. To view the device
inventory, the device must be in the Managed state.

To view the device inventory in NSM:

1. In the navigation tree, select Device Manager > Devices.

2. Right-click the device whose inventory you want to view.

3. Select View/Reconcile Inventory. The Device Inventory window appears.

4. Select the Hardware tab to display information about hardware modules in the
device, including the I/O module, the Routing Engine, and so on.

5. Select the Software tab to display information about the software packages
installed in the device, including the installed OS and its version, and any other
installed packages.
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Related Topics ■ Viewing and Reconciling Device Inventory Overview on page 173

Removing a J Series or SRX Series Device from NSM Management (NSM Procedure)

Deleting a device removes all device configuration information from the management
system, but might be the best solution if you need to perform extensive
troubleshooting or reconfigure the device locally.

To remove a J Series or SRX Series device from NSM management:

1. In the NSM navigation tree, select Device Manager> Devices.

2. Click the Device Tree tab and then select the device that you want to remove
from NSM management.

3. Right-click and select Delete, or click the Delete button. The Delete dialog box
appears. If the device is referenced in a firewall rule, this dialog box displays the
rules that reference it. You can click the links that appear to display the security
policies to view or edit those references.

4. Remove the device by clicking Next. The Delete dialog box displays the progress
of the deletion.

5. After NSM finishes, click Finish to close the dialog box.

Related Topics ■ Adding J Series Services Routers or SRX Series Services Gateways in NSM
Overview on page 8
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Chapter 16

Topology Manager

■ Overview of the NSM Topology Manager on page 177

■ Requisites for a Topology Discovery Overview on page 177

■ Understanding the NSM Topology Manager Toolbar on page 178

Overview of the NSM Topology Manager

The Network and Security Manager (NSM) Topology Manager is a tool provided in
the NSM user interface (UI) to discover and manage the physical topology of a network
of devices connected to a Juniper Networks EX-series switch. These include networking
devices such as the J Series, M-series, MX-series, and EX-series, as well as ScreenOS
and IDP devices, IP phones, desktops, printers, and servers. The Topology Manager
also provides details about connections between a device and the EX-series switch.

For more information about the Topology Manager, see the Network and Security
Manager Administration Guide.

Related Topics Requisites for a Topology Discovery Overview on page 177■

■ Understanding the NSM Topology Manager Toolbar on page 178

Requisites for a Topology Discovery Overview

To use the Topology Manager, first add one or more devices to the Device Manager
in NSM. You can then use an added device as a seed device in initiating a topology
discovery.

Alternatively, if there are no devices added or managed in NSM, you can initiate a
topology discovery by configuring preferred subnets. All the IP addresses in the
included subnets range are discovered. Therefore, you need to have either seed
devices and/or preferred subnets to initiate topology discovery. You also need:

■ The management IP address of the device that acts as the seed IP address.

■ SNMP credentials:

■ For SNMPv1 and SNMPv2c: Community string.

■ For SNMPv3: Username, security level, authentication type, privacy type,
privacy password, and authentication password.
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■ Enabled Layer 2 protocols like LLDP, STP, RSTP in the switched network, because
network discovery depends on these as well as on the Address Forwarding Table
information.

For more information about the Topology Manager, see the Network and Security
Manager Administration Guide.

Related Topics Overview of the NSM Topology Manager on page 177■

■ Understanding the NSM Topology Manager Toolbar on page 178

Understanding the NSM Topology Manager Toolbar

You can use the Topology Manager toolbar to perform the following actions:

■ Zoom in and Zoom out: Use these tools to view the network topology according
to the detail required. These tools are only of use in the map view.

■ Save to file: Use this tool to save the network topology map as an image file and
the devices and links tables as text files from their respective views.

■ Print: Use this tool to print a network topology map as an image file and the
devices and links tables as text files from different views.

■ Manage Devices: Use this tool to select one or more devices from a topology
map and manage them in NSM. This tool is applicable only to map views and
not the different table views. To add a device:

a. Click the Manage Devices icon. A dialog box opens.

b. Enter the SSH user name and password.

c. Click OK.

■ Set Preferences: Use this tool to set preferences according to which discovery
engine can perform a topology discovery. You can set preferences for default
SNMP credentials, topology discovery intervals, and subnets to be included or
excluded.

■ Start and Stop Topology Discovery: Use these tools to initiate and stop a topology
discovery based on the set of seed devices and credentials specified in the
topology preferences.

■ Search: You can search for a device, end-point device, link, or port in any of the
table views by providing a string in the search text box. NSM performs a substring
match against all attributes of the particular view and displays the results in the
same table. If you navigate to another tab, your search results are lost. You can
save the search output in a text file as comma-separated values.

The Topology Manager status bar at the bottom of the screen indicates the timestamp
of the last completed topology discovery and whether a discovery is in progress.

For more information about the Topology Manager, see the Network and Security
Manager Administration Guide.
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Related Topics ■ Overview of the NSM Topology Manager on page 177

■ Requisites for a Topology Discovery Overview on page 177
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Chapter 17

IDP Management in J Series Services
Routers and SRX Series Services
Gateways

■ Updating the NSM Attack Database (NSM Procedure) on page 181

■ Loading the IDP Detector Engine on a J Series or SRX Series Device (NSM
Procedure) on page 182

■ Updating the Deep Inspection Attack Database on a J Series or SRX Series Device
(NSM Procedure) on page 182

Updating the NSM Attack Database (NSM Procedure)

You must update the attack object database before you can use IDP functionality.
To update the IDP and deep inspection (DI) databases and the IDP detector engine,
download new attack objects from the attack object database server to the NSM GUI
server.

To update the IDP and DI attack object databases on the NSM GUI server:

1. From the Tools menu in the NSM UI, click View/Update NSM Attack Database.
The Attack Update Manager wizard appears.

2. Click Next to proceed. The current attack database version in NSM and the latest
attack database version appear.

3. Click Finish to start downloading the latest attack database version from the
server. The progress and status of the attack update process appear in the Job
Information page.

4. Click one:

■ Cancel Job—Cancels the IDP detector engine loading process.

■ Refresh—Refreshes the status of the update process.

■ Notify Later—Notifies the completion of the update process.

■ Close—Closes the Job Information page.

After you have updated the attack object database on the NSM GUI server, you can
use that database to update the attack object database on your managed devices.
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Related Topics Loading the IDP Detector Engine on a J Series or SRX Series Device (NSM
Procedure) on page 182

■

■ Updating the Deep Inspection Attack Database on a J Series or SRX Series Device
(NSM Procedure) on page 182

Loading the IDP Detector Engine on a J Series or SRX Series Device (NSM
Procedure)

IDP attack objects are loaded onto IDP-capable devices with the IDP rulebase.

To load a new detector engine onto a J Series or SRX Series device:

1. From the Devices menu in the NSM UI, select IDP Detector Engine > Load IDP
Detector Engine for JUNOS. The Load JUNOS IDP Detector Engine wizard
appears.

2. Click Next to proceed. The available IDP detector engine versions are displayed.

3. Select the JUNOS device to be updated and click Finish. The progress and status
of the IDP detector engine update process appears in the Job Information page.

4. Click one:

■ Cancel Job—Cancels the IDP detector engine loading process.

■ Refresh—Refreshes the status of the update process.

■ Notify Later—Notifies the completion of the update process.

■ Close—Closes the Job Information page.

Related Topics Updating the NSM Attack Database (NSM Procedure) on page 181■

■ Updating the Deep Inspection Attack Database on a J Series or SRX Series Device
(NSM Procedure) on page 182

Updating the Deep Inspection Attack Database on a J Series or SRX Series Device
(NSM Procedure)

To update the deep inspection attack database on a J Series or SRX Series device:

1. From the Devices menu in the NSM UI, select Update Device Attack Database.
The Change Device Signature Package wizard appears.

2. Click Next to proceed. The available deep inspection signature database versions
appear.

3. Select the JUNOS device to be updated and click Finish. The progress and status
of the attack object database update process appears in the Job Information
page.

4. Click one:
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■ Cancel Job—Cancels the attack object database update process.

■ Refresh—Refreshes the status of the update process.

■ Notify Later—Notifies the completion of the update process.

■ Close—Closes the Job Information page.

Related Topics ■ Updating the NSM Attack Database (NSM Procedure) on page 181

■ Loading the IDP Detector Engine on a J Series or SRX Series Device (NSM
Procedure) on page 182
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Part 4

Monitoring J Series Services Routers and
SRX Series Services Gateways

■ Real Time Monitoring of J Series Services Routers and SRX Series Services
Gateways on page 187
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Chapter 18

Real Time Monitoring of J Series Services
Routers and SRX Series Services
Gateways

■ Realtime Monitor Overview on page 187

■ Viewing Device Status on page 188

■ Viewing Device Monitor Alarm Status (NSM Procedure) on page 191

■ Configuring the Polling Interval for Device Alarm Status (NSM
Procedure) on page 192

Realtime Monitor Overview

The Realtime Monitor module in NSM includes views that you can use to monitor
real-time status and statistics about all the managed security devices, VPN tunnels,
NSRP clusters, IDP sensors, and IDP clusters in your network. You can also use the
Realtime Monitor to identify problems, track security events, and discover trends
across multiple geographic regions and functional areas from a central management
location.

The Realtime Monitor can also help you quickly identify potential device, network,
and system-level problems, such as:

■ Configuration status—At the device level, you can monitor the changing status
of one or more security devices in real time.

■ Connection status—At the network level, you can monitor problems that could
lead to failed devices.

The Realtime Monitor does the work of a management expert by first gathering
information about specific processes and network activity, and then color-coding
each event to organize problems.

Related Topics Realtime Monitor Overview on page 187■

■ Viewing Device Status on page 188

Realtime Monitor Overview ■ 187



Viewing Device Status

Table 88 on page 188 lists and describes device information that you can view through
the Device Monitor.

Table 88: Device Status Information

DescriptionColumn

Unique name assigned to the device in NSM.Name

Domain in NSM in which the device is managed.Domain

Model number of the device.Platform

Operating system firmware version running on the device.OS Version
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Table 88: Device Status Information (continued)

DescriptionColumn

Current configuration status of the device in NSM:

■ None—No state has been set (does not show in Device Monitor).

■ Modeled—The device exists in NSM, but a connection to the device
has not yet been established.

■ RMA—Equivalent to bringing the device into the Modeled state. RMA
results from an administrator selection in the UI when a device goes
down.

■ Waiting for 1st connect—NSM is waiting for the device to connect.
You must enter a command on the device to make it connect to NSM.

■ Import Needed—You must import the configuration of the device into
NSM. When you add a device for the first time, verify that your status
indicates “Import Needed” before you attempt to import the device.
During migration, this state indicates that import of the security device
configuration is still required.

■ OS Version Adjustment Needed—The firmware version detected
running on the device is different from what was previously detected
in NSM. This could happen in the event that the automatic adjustment
option was cleared during a change device firmware directive or an
Update Device directive was issued to an IDP device with a firmware
version mismatch.

■ Platform Mismatch—The device platform selected when adding the
DMI device in NSM does not match the device itself. A device in this
state cannot connect to NSM.

■ Device Firmware Mismatch—The OS version selected when adding a
DMI device does not match the OS version running on the device itself.

■ Device Type Mismatch—The type of device specified when adding the
device in NSM does not match the device itself. The device type might
indicate whether the device is part of a vsys device, part of a cluster,
or part of a virtual chassis. A device in this state cannot connect to
NSM.

■ Detected duplicate serial number—The device has the same sequence
number as another managed device. A device in this state cannot
connect to NSM.

■ Update Needed—An update to this device is required.

■ Managed—The device is currently being managed by NSM.

■ Managed, In Sync—The physical device configuration is synced with
the modeled configuration in NSM.

Config Status
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Table 88: Device Status Information (continued)

DescriptionColumn

■ Managed, Device Changed—The physical device configuration is out
of sync with the modeled configuration in NSM. Changes were made
to the physical device configuration (the configuration on the physical
device is newer than the modeled configuration).

■ Managed, NSM Changed—The modeled device configuration is out of
sync with the physical device configuration. Changes were made to
the modeled configuration (the configuration on the NSM is newer
than the physical device configuration).

■ Managed, NSM and Device Changed—Both device configurations
(physical and modeled) are out of sync with each other. Changes were
made to the physical device configuration and to the modeled
configuration.

■ Managed, Sync Pending—Completion of the Update Device directive
is suspended and waiting for the device to reconnect. This state occurs
only for ScreenOS devices that have the Update When Device Connects
option selected during the device update.

Config Status
(continued)

Connection status of the device in NSM:

■ Up—Device is currently connected to NSM.

■ Down—Device is not currently connected to NSM but has connected
in the past.

■ Never Connected—Device has never connected to NSM.

The Device Server checks the connection status of each device every
120 seconds by default. You can change this behavior by editing the
value for the devDaemon.deviceHeartbeatTimeout parameter in the
Device Server configuration file. Refer to the Network and Security
Manager Installation Guide for more information on editing
configuration files.

NOTE: If the network connection goes down for a period longer than six
to eight minutes, the device connection will permanently time out. If this
occurs and the device goes down for any reason, the device still appears
as Up in the Device Monitor.

Connection Status

Displays the current alarm status for each device in NSM:

■ If device has any alarms, the most severe alarm severity is displayed
(either Major or Minor).

■ None—The device has no alarms.

■ Unknown—The device status is unknown. For example, the device
might not be connected.

■ N/A—The device's alarm is not pollable or discoverable, for example,
this column shows "N/A" for ScreenOS and IDP devices.

■ Alarm is colored:

■ Red for Major.

■ Orange for Minor.

■ Green for Ignore, None, Unknown, or N/A.

Alarm
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Table 88: Device Status Information (continued)

DescriptionColumn

Displays the inventory status for hardware on the device:

■ In Sync—The inventory information in the NSM database is
synchronized with the information on the device.

■ Out Of Sync—The inventory information in the NSM database is not
synchronized with the information on the device.

■ N/A—The connected device is a ScreenOS or IDP device, or the device
is not connected and imported.

H/W Inventory
Status

Displays the inventory status for software on the device:

■ In Sync—The inventory information in the NSM database is
synchronized with the software on the device.

■ Out Of Sync—The inventory information in the NSM database is not
synchronized with the software on the device.

■ N/A—The connected device is a ScreenOS or IDP device, or the device
is not connected and imported.

S/W Inventory
Status

Displays the inventory status for software on the device:

■ In Sync—The inventory information in the NSM database is
synchronized with the licenses on the device.

■ Out Of Sync—The inventory information in the NSM database is not
synchronized with the licenses on the device.

■ N/A—The connected device is a ScreenOS or IDP device, or the device
is not connected and imported.

License Inventory
Status

The first time the security device connected to the NSM Device Server.First Connect

The last time the security device connected to the NSM Device Server.Latest Connect

The last time the security device disconnected from the NSM Device Server.Latest Disconnect

Related Topics Viewing Device Monitor Alarm Status (NSM Procedure) on page 191■

■ Configuring the Polling Interval for Device Alarm Status (NSM Procedure) on
page 192

Viewing Device Monitor Alarm Status (NSM Procedure)

Alarms refresh automatically through periodic polling.

To view the alarm status and time:

1. From Device Monitor, right-click the device row entry and select the View Alarm
option.

The device Alarm Status dialog box displays the alarm list and polling time for
the device.

2. Retrieve the current alarm status in the device by clicking the Refresh button.

Viewing Device Monitor Alarm Status (NSM Procedure) ■ 191
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The poll time is derived from the device server time.

Related Topics Viewing Device Status on page 188■

■ Configuring the Polling Interval for Device Alarm Status (NSM Procedure) on
page 192

Configuring the Polling Interval for Device Alarm Status (NSM Procedure)

The default polling interval is 900 seconds (15 minutes). To configure polling intervals
for alarm Status:

1. In the NSM navigation tree, select Device Manager > Devices.

2. Click the Device Tree tab, and then double-click the device to set the polling
interval.

3. Click the Info tab, and select Device Admin.

4. Set the polling interval for the device. The minimum polling interval is 60 seconds.
The maximum interval is 2,147,483,647 seconds. You cannot disable polling.

5. Click one:

■ OK—Saves the changes.

■ Cancel—Cancels the modifications.

Related Topics ■ Viewing Device Status on page 188

■ Viewing Device Monitor Alarm Status (NSM Procedure) on page 191

192 ■ Configuring the Polling Interval for Device Alarm Status (NSM Procedure)
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