J-Security Center

Title: Opera HTTPS Proxy Denial of Service Vulnerability

Severity: MODERATE

Description:

Opera is a freely available web browser for Linux, Sun, BSD, and Windows operating systems.

Opera 6.03 for Linux is reportedly vulnerable to a denial of service. This occurs when Opera is used with an HTTPS proxy. If the certificate for a website is accepted before the HTTP connection to the site has been started, Opera will fail.

This vulnerability was reported when using Squid as the HTTPS proxy, though the issue most likely applies to any HTTPS proxy.

Versions of Opera prior to 6.03 may also be vulnerable to this issue.

Affected Products:

  • Opera Software Opera Web Browser 6.0.3 linux

References:

Juniper Networks provides this content via a wide variety of sources and production methods. If notified of errors or omissions in the content of this page, Juniper Networks, at its discretion, will modify or remove the page or leave the content as is, depending on various factors including but not limited to the reputation and authority of the party providing the notification. Please use the contact information displayed elsewhere on this page to report any errors or omissions regarding the content on this page.