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About This Guide

Use this guide to configure Policy Enforcer component of Junos Space Security Director. Policy Enforcer
integrates with Juniper ATP Cloud to provide centralized threat management and monitors your
software-defined secure network.
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Juniper Networks Connected Security Overview

IN THIS SECTION

Benefits of Juniper Networks Connected Security  |  3

The Juniper Networks Connected Security provides end-to-end network visibility, allowing enterprises
to secure their entire network, both physical and virtual. Using threat detection and policy enforcement,
an Juniper Connected Security solution automates and centrally manages security in a multi-vendor
environment.

The Juniper Connected Security solution is comprised of the following components:

• A threat detection engine—Cloud-based Juniper ATP Cloud detects known and unknown malware.
Known threats are detected using feed information from a variety of sources, including command
control server and GeoIP. Unknown threats are identified using various methods such as sandboxing,
machine learning, and threat deception.

• Centralized policy management—Junos Space Security Director, which also manages SRX Series
devices, provides the management interface for the Juniper Connected Security solution called Policy
Enforcer. Policy Enforcer communicates with Juniper Networks devices and third-party devices
across the network, globally enforcing security policies and consolidating threat intelligence from
different sources. With monitoring capabilities, it can also act as a sensor, providing visibility for intra-
and inter-network communications.

• Expansive policy enforcement—In a multi-vendor enterprise, Juniper Connected Security enforces
security across Juniper Networks devices, cloud-based solutions, and third-party devices. By
communicating with all enforcement points, Juniper Connected Security can quickly block or
quarantine threat, preventing the spread of bi-lateral attacks within the network.

• User intent-based policies—Create policies according to logical business structures such as users,
user groups, geographical locations, sites, tenants, applications, or threat risks. This allows network
devices (switches, routers, firewalls and other security devices) to share information, resources, and
when threats are detected, remediation actions within the network.

With user intent-based policies, you manage clients based on business objectives or user and group
profiles. The following are two examples of a user intent policy:

• Quarantine users in HR in Sunnyvale when they’re infected with malware that has a threat score
greater than 7.
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• Block any user in Marketing when they contact a Command and Control (C&C) server that has a
threat score greater than 6 and then send an e-mail to an IT administrator.

Using user intent-based policies allows network devices (switches, routers, firewalls and other
security devices) to share information, resources, and when threats are detected, remediation actions
within the network.

Unlike rule-based policies, which can contain several rules, you can define only one set of parameters
for each user intent-based policy defined on a device.

Benefits of Juniper Networks Connected Security

• Management and visibility - Enables you to view traffic across the network, dynamically deploy
security policies and block threats. Juniper Connected Security manages the entire network
infrastructure as a single enforcement domain, thereby providing enforcement points across the
network. Uses machine learning and data mining tools to offer effective threat management while
producing detailed data access and user activity reports.

• Comprehensive security - Ensures that the same security policies are applied across all of the devices
in the network. It extends security to each layer of the network, including routers, switches, and
firewalls.

• Protection from advanced malware - Provides automated offense identification and consolidates the
threat intelligence with threat hunting activities to simplify and focus attention on the highest
priority offenses.

• Automated policy or enforcement orchestration - Provides real-time feedback between the security
firewalls. Reduces the risk of compromise and human error by allowing you to focus on maximizing
security and accelerating operations with a simple, concise rule set.

• Scalability - Supports up to 15,000 devices.

• Third-party integration - Provides APIs to integrate with the ecosystem partners for capabilities such
as cloud access security, network access control, and endpoint protection, and additional threat
intelligence feeds.

RELATED DOCUMENTATION

Policy Enforcer Overview  |  4

Policy Enforcer Components and Dependencies  |  13
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Policy Enforcer Overview

IN THIS SECTION

Supported Topologies  |  5

Policy Enforcer, a component of the Junos Space Security Director user interface, integrates with
Juniper ATP Cloud to provide centralized threat management and monitoring to your Juniper connected
security network, giving you the ability to combine threat intelligence from different solutions and act
on that intelligence from one management point.

It also automates the enforcement of security policies across the network and quarantines infected
endpoints to prevent threats across firewalls and switches. Working with Juniper ATP Cloud, it protects
perimeter-oriented threats as well as threats within the network. For example, if a user downloads a file
from the Internet and that file passes through an SRX Series firewall, the file can be sent to the Juniper
ATP Cloud cloud for malware inspection. If the file is determined to be malware, Policy Enforcer
identifies the IP address and MAC address of the host that downloaded the file. Based on a user-defined
policy, that host can be put into a quarantine VLAN or blocked from accessing the Internet.

Figure 1 on page 5 illustrates the flow diagram of Policy Enforcer over a traditional SRX Series
configuration.
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Figure 1: Comparing Traditional SRX Customers to Policy Enforcer Customers

Supported Topologies

Policy Enforcer supports the following topologies:

• Client to Layer 2 switch to Layer 3 SRX (IRB)
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• Client to Layer 2 switch to Layer 3 switch (IRB)

• Client to Layer 2/Layer 3 switch (IRB)

Figure 2 on page 6 illustrates the Policy Enforcer deployment topologies.

Figure 2: Policy Enforcer Deployment Topologies

RELATED DOCUMENTATION

Juniper Networks Connected Security Overview
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Policy Enforcer Configuration Concepts  |  18

Juniper ATP Cloud Overview
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Using Guided Setup for Juniper ATP Cloud with Juniper Connected Security  |  134

Using Guided Setup for Juniper ATP Cloud
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Benefits of Policy Enforcer

Most enterprise computer security revolves around creating a wall around the perimeter of an
organization. See Figure 3 on page 7.

Figure 3: Perimeter-Defined Security Model

With this perimeter oriented security, networks are built with an inherently trusted model where the
applications or users connecting to a network (for example, VLAN) can fundamentally talk to each other
and network security solutions like firewalls and Intrusion Prevention Systems (IPS) are deployed in the
perimeter to provide security. Firewalls are often configured with all possible rules in an effort to prevent
unknown malware, application and network attacks from penetrating the enterprise. This architecture is
based on a model where it is assumed that “Everything already inside the network is fundamentally
trusted” and “Everything outside the network is untrusted” so the perimeter is the location where all
security controls are deployed.

This architecture is consistent across data centers, and campus and branch configurations.
Unfortunately, there are flaws to this security architecture. They don’t help in protecting against internal
threats. Despite the popularity of firewalls, the sophistication of applications and malware in recent
years has found a way to circumvent perimeter defenses. Once inside the enterprise, these threats can
easily spread; where someone’s infected laptop or desktop could make Enterprise networks a botnet
army and become a source of internal and external attacks. Enterprises can protect against internal
threats by deploying multiple layers of firewalls, but that requires careful planning since it is difficult to
take all internal traffic through a separate layer of firewalls.
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The security framework become a highly fragmented approach due to multiple administrators,
management systems and reliance on a lot of manual coordination among different administrators and
systems:

• There is a network security team that manages security policies on perimeter firewalls primarily to
manage external threats.

• There is a network operations team, that typically manages security policies by using network and
application isolation to protect against internal attacks and unauthorized access.

• Then there is third team, an IT team, that manages end-points such as laptops, desktops and
application servers to make sure that they have the correct security posture.

In contrast, Policy Enforcer and Juniper Connected Security, see Figure 4 on page 8, simplifies
network security by providing protection based on logical policies and not security devices. Policy
Enforcer does provide perimeter security, but it’s no longer just protecting the inside from the outside.
The fact that somebody is connected to the internal network does not mean that they can get
unrestricted access to the network. This model is fundamentally more secure because even if one
application on the network is compromised, companies can limit the spread of that infection/threat to
other potentially more critical assets inside the network.

Figure 4: Policy Enforcer and Juniper Connected Security

Policy Enforcer is a model where the information security is controlled and managed by security
software. New devices are automatically covered by security policies, instead of having to identify it’s IP
address as with other models. Because it’s software-defined, environments can be moved without
affecting security policies and controls already in place. Other advantages include:
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• Better and more detailed security—By providing better visibility into network activity, you can
respond faster to cyber threats and other security incidents. Threats can be detected faster by
leveraging threat intelligence from multiple sources (including third-party feeds) and the cloud. A
central control lets you analyze security challenges without interfering with standard network
activity and to distribute security policies throughout your organization. For example, you can
selectively block malicious traffic while allowing normal traffic flow.

• Scalability and cost savings—A software-based model allows you to quickly and easily scale security
up or down based on your immediate needs all without having to add or subtract hardware that is
expensive to buy and maintain.

• Simpler solution—Hardware security architectures can be complex due to the servers and specialized
physical devices that are required. In a software model, security is based on policies. Information can
be protected anywhere it resides without depending on its physical location.

RELATED DOCUMENTATION

Policy Enforcer Overview  |  4

Juniper ATP Cloud Overview

Using Guided Setup for Juniper ATP Cloud with Juniper Connected Security  |  134

Using Guided Setup for Juniper ATP Cloud

Configuring Juniper ATP Cloud with Juniper Connected Security (Without Guided Setup) Overview  |
  150

Juniper ATP Cloud Overview

Juniper ATP Cloud is a cloud-based solution that integrates with Policy Enforcer. Cloud environments
are flexible and scalable, and a shared environment ensures that everyone benefits from new threat
intelligence in near real-time. Your sensitive data is secured even though it is in a cloud shared
environment. Security administrators can update their defenses when new attack techniques are
discovered and distribute the threat intelligence with very little delay.

Juniper ATP Cloud offers the following features:

• Communicates with firewalls and switches to simplify threat prevention policy deployment and
enhance the anti-threat capabilities across the network.

• Delivers protection against “zero-day” threats using a combination of tools to provide robust
coverage against sophisticated, evasive threats.
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• Checks inbound and outbound traffic with policy enhancements that allow users to stop malware,
quarantine infected systems, prevent data exfiltration, and disrupt lateral movement.

• Provides deep inspection, actionable reporting, and inline malware blocking.

• Provides feeds for GeoIP, C&C, allowlist and blocklist, infection hosts, custom configured feeds and
file submission.

Figure 5 on page 10 lists the Juniper ATP Cloud components.

Figure 5: Juniper ATP Cloud Components

Table 1 on page 10 briefly describes each Juniper ATP Cloud component’s operation.

Table 1: Juniper ATP Cloud Components

Component Operation

Command and control
(C&C) cloud feeds

C&C feeds are essentially a list of servers that are known command and control for
botnets. The list also includes servers that are known sources for malware
downloads. See "Command and Control Servers Overview" on page 299.
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Table 1: Juniper ATP Cloud Components (Continued)

Component Operation

GeoIP cloud feeds GeoIP feeds is an up-to-date mapping of IP addresses to geographical regions. This
gives you the ability to filter traffic to and from specific geographies in the world.

Infected host cloud feeds Infected hosts indicate local devices that are potentially compromised because they
appear to be part of a C&C network or other exhibit other symptoms. See "Infected
Hosts Overview" on page 296.

Custom Feeds Lists you customize by adding IP addresses, domains, and URLs to your own lists.
See "Custom Feed Sources Overview" on page 238.

Allowlist and blocklists An allowlist is simply a list of known IP addresses that you trust and a blocklist is a
list that you do not trust.

Malware inspection
pipeline

Performs malware analysis and threat detection.

Internal compromise
detection

Inspects files, metadata, and other information.

RELATED DOCUMENTATION

Juniper ATP Cloud Realm Overview

Using Guided Setup for Juniper ATP Cloud  |  141

Configuring Juniper ATP Cloud (No Juniper Connected Security and No Guided Setup) Overview
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Policy Enforcer Components and Dependencies

The Policy Enforcer management interface is a component of Junos Space Security Director and requires
the following to be configured and deployed:

• Junos Space Platform—Junos Space is a comprehensive network management solution that simplifies
and automates management of Juniper Networks switching, routing, and security devices. Junos
Space Virtual Appliance includes the complete Junos Space software package as well as the Junos OS
operating system. It requires users to create a virtual machine (VM) in order to deploy the appliance.

• Security Director—Junos Space Security Director provides centralized and orchestrated security
policy management through a web-based interface. Security administrators can use Security Director
to manage all phases of the security policy life cycle for every SRX Series physical and virtual device.

• Policy Enforcer—Policy Enforcer itself is installed on a VM and uses RESTful APIs to communicate
with both Security Director and Juniper Networks Advanced Threat Prevention Cloud (Juniper ATP
Cloud). Policy Enforcer contains two components:

• Policy Controller—Defines the logical grouping of the network into secure fabric, automates the
enrollment of SRX Series devices with Juniper ATP Cloud, and configures the SRX firewall
policies.

• Feed Connector—Aggregates the cloud and customer feeds and is the server for SRX Series
devices to download feeds.

• Juniper ATP Cloud—Juniper ATP Cloud employs a pipeline of technologies in the cloud to identify
varying levels of risk, and provides a higher degree of accuracy in threat protection. It integrates with
SRX Series gateways to deliver deep inspection, inline malware blocking, and actionable reporting.

Juniper ATP Cloud’s identification technology uses a variety of techniques to quickly identify a threat
and prevent an impending attack, including:

• Rapid cache lookups to identify known files.

• Dynamic analysis that involves unique deception techniques applied in a sandbox to trick malware
into activating and self-identifying.

• Machine-learning algorithms to adapt to and identify new malware.

• SRX Series device—SRX Series gateways provide security enforcement and deep inspection across all
network layers and applications. Users can be permitted or prohibited from accessing specific
business applications and Web applications, regardless of the network ports and protocols that are
used to transmit the applications.

Figure 6 on page 14 illustrates how the components in the Policy Enforcer Deployment Model interact.
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Figure 6: Components of the Policy Enforcer Deployment Model

Figure 7 on page 15 shows an example infected endpoint scenario to illustrate how some of the
components work together.
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Figure 7: Blocking an Infected Endpoint

Step Action

1 A user downloads a file from the Internet.

2 Based on user-defined policies, the file is sent to the Juniper ATP Cloud cloud for malware inspection.

3 The inspection determines this file is malware and informs Policy Enforcer of the results.

4 The enforcement policy is automatically deployed to the SRX Series device and switches.

5 The infected endpoint is quarantined.

Policy Enforcer can track the infected endpoint and automatically quarantine it or block it from
accessing the Internet if the user moves from one campus location to another. See Figure 8 on page
16.
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Figure 8: Tracking Infected Endpoint Movement

In this example, Juniper ATP Cloud identifies the endpoint as having an IP address of 192.168.10.1 and
resides in SVL-A. The EX Series switch quarantines it because it has been labeled as an infected host by
Juniper ATP Cloud. Suppose the infected host physically moves from location SVL-A to location SVL-B.
The EX Series switch (in SVL-B) microservice tracks the MAC address to the new IP address and
automatically quarantines it. Policy Enforcer then informs Juniper ATP Cloud of the new MAC address-
to-IP address binding.

Policy Enforcer can also quarantine infected hosts even if those hosts are connected to third-party
switches, as shown in Figure 9 on page 17.

For Policy Enforcer to provide threat remediation to endpoints connecting through third-party devices, it
must be able to authenticate those devices and determine their state. It does this using a tracking and
accounting threat remediation plug-in to gather information from a RADIUS server and enforce policies
such as terminate session and quarantine. For more information, see Policy Enforcer Connector
Overview
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Figure 9: Third-Party Switch Support

Step Action

1 An end-user authenticates to the network through IEEE 802.1X or through MAC-based authentication.

2 Juniper ATP Cloud detects the end point is infected with malware and adds it to the infected host feed.

3 Policy Enforcer downloads the infected host feed.

4 Policy Enforcer enforces the infected host policy using the Connector. See Policy Enforcer Connector
Overview.

5 The Connector queries the RADIUS server for the infected host endpoint details and initiates a Change of
Authorization (CoA) for the infected host.

6 The CoA can be either block or quarantine the infected host.

7 The enforcement occurs on the NAC device the infected host is authenticated with.
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(Continued)

Step Action

8 Policy Enforcer communicates the infected host details back to Juniper ATP Cloud.

RELATED DOCUMENTATION
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  150

Policy Enforcer Configuration Concepts

You have some options for how you can approach the initial setup of Juniper ATP Cloud and Policy
Enforcer. There is a “Guided Setup” approach which walks you through the necessary steps for getting
the product up and running. This is the recommended approach. If you prefer, you can manually
configure each part of the product.

Either way, before you begin the configuration, you need to understand the concepts behind the
configuration items required to successfully deploy threat management policies across your network.
These items include security realms for Juniper ATP Cloud, secure fabric for sites, and policy groups for
endpoints. These are explained in this section.

• Security Realm—When configuring Juniper ATP Cloud or Policy Enforcer with Juniper ATP Cloud,
there are Realm selection fields at the top of several pages. A security realm is a group identifier for
an organization used to restrict access to Web applications. You must create at least one security
realm to login into Juniper ATP Cloud. Once you create a realm, you can enroll SRX Series devices
into the realm. You can also give more users (administrators) permission to access the realm.

If you have multiple security realms, note that each SRX Series device can only be bound to one
realm, and users cannot travel between realms.
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• Policy Enforcement Groups—A policy enforcement group is a grouping of endpoints to which threat
prevention policies are applied. Create a policy enforcement group by adding endpoints (firewalls,
switches, subnets, set of end users) under one common group name and later applying a threat
prevention policy to that group.

Some information to know about enforcement groups is as follows: Determine what endpoints you
will add to the group based on how you will configure threat prevention, either according to location,
users and applications, or threat risk. Endpoints cannot belong to multiple policy enforcement
groups.

• Threat Prevention Policies—Once you have a Threat Prevention Policy, you assign one or more Policy
Enforcement Groups to it. Threat prevention policies provide protection and monitoring for selected
threat profiles, including command & control servers, GeoIP, infected hosts, and malware. Using feeds
from Juniper ATP Cloud and custom feeds you configure, ingress and egress traffic is monitored for
suspicious content and behavior. Based on a threat score, detected threats are evaluated and action
may be taken once a verdict is reached.

• Secure Fabric—For your configuration you must create one or more sites for your secure fabric.
Secure fabric is a collection of sites which contain network devices (switches, routers, firewalls, and
other security devices), used in policy enforcement groups. When threat prevention policies are
applied to policy enforcement groups, the system automatically discovers to which sites those groups
belong. This is how threat prevention is aggregated across your secure fabric.

Some information to know about sites is as follows: When you create a site, you must identify the
perimeter firewalls so you can enroll them with Juniper ATP Cloud. If you want to enforce an
infected host policy within the network, you must assign a switch to the site. Devices cannot belong
to multiple sites.
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Juniper ATP Cloud Configuration Type Overview

Juniper ATP Cloud or ATP Appliance with Policy Enforcer can be used in four different configuration
types, which will be explained here.

NOTE: If you are using Juniper ATP Cloud without Policy Enforcer, you must dis-enroll
the devices from Juniper ATP Cloud before you re-enroll to Policy Enforcer.

NOTE: The license you purchase determines if you can use the available configurations
and feature sets for your selected ATP Cloud Configuration Type.

Configuration Type is set here in the UI: Administration > Policy Enforcer > Settings.

The following Juniper ATP Cloud Configuration Types and corresponding workflows are available.
Workflows are the items you configure for each selection.

NOTE: 

ATP Cloud or JATP with Juniper Connected Security—This is the full version of the product. All Policy
Enforcer features and threat prevention types are available.

Here is the Juniper ATP Cloud with Juniper Connected Security workflow:

• Secure Fabric

• Policy Enforcement Group

• Juniper ATP Cloud Realm

• Threat Prevention Policies for the following threat types:

• C&C Server

• Infected Hosts

• Malware

• Geo IP

Here is the ATP Appliance with Juniper Connected Security workflow:

• Secure Fabric
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• Policy Enforcement Group

• Threat Prevention Policies for the following threat types:

• C&C Server

• Infected Hosts

• Malware

• Geo IP

NOTE: After you upgrade from one threat prevention type to ATP Cloud or ATP
Appliance with Juniper Connected Security configuration type, an additional rule is being
created and pushed to the next update in the analysis window.

ATP Cloud or JATP—This includes all threat prevention types, but does not include the benefits of
Secure Fabric, Policy Enforcement Groups, and Threat Prevention policies provided by Policy Enforcer.
All enforcement is done through SRX Series Firewall policies.

Here is the Juniper ATP Cloud workflow:

• Juniper ATP Cloud Realm

• Threat Prevention Policies for the following threat types:

• C&C Server

• Infected Hosts

• Malware

• Geo IP

Here is the ATP Appliance workflow:

• Threat Prevention Policies for the following threat types:

• C&C Server

• Infected Hosts

• Malware

• Geo IP

Cloud feeds only—The prevention types available are command and control server, infections hosts, and
Geo IP feeds. Policy Enforcer Secure Fabric, Policy Enforcement Groups, and Threat Prevention policies
are also available. All enforcement is done through SRX Series Firewall policies.
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Here is the Cloud feeds only workflow:

• Secure Fabric

• Policy Enforcement Group

• Juniper ATP Cloud Realm

• Threat Prevention Policies for the following threat types:

• C&C Server

• Infected Hosts

• Geo IP

No ATP Cloud (no selection)—You would make no Juniper ATP Cloud selection to configure Juniper
Connected Security using custom feeds. Custom feeds are available for dynamic address, allowlist,
blocklist, infected hosts, and C&C Server. With this setting, there are no feeds available from Juniper
ATP Cloud, but the benefits of Secure Fabric, Policy Enforcement Groups, and Threat Prevention policies
provided by Policy Enforcer are available. Infected hosts is the only prevention type available.

Here is the No selection workflow:

• Secure Fabric

• Policy Enforcement Group

• Custom Feeds

• Threat Prevention Policies for the following threat type:

• Infected Hosts

NOTE: Moving between configuration types is not supported in all cases. You can only
move from one Juniper ATP Cloud Configuration Type to a “higher” configuration type.
You cannot move to a lower type. Please note the following hierarchy:

• Juniper ATP Cloud or ATP Appliance with Juniper Connected Security (highest)

• Juniper ATP Cloud or JATP

• Cloud feeds only

• No Juniper ATP Cloud or JATP- No selection (lowest)

For each configuration type, certain features and UI pages are available. Please see the links below for
details.
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• "Features By Sky ATP Configuration Type" on page 23

• "Available UI Pages by Sky ATP Configuration Type" on page 25
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Features By Juniper ATP Cloud Configuration Type

For each configuration type, certain features and UI pages are available.

Refer to the following table for the features available for each configuration type.

Table 2: List of features by Juniper ATP Cloud Configuration Type

Feature ATP Cloud/ATP
Appliance with
Juniper Connected
Security

ATP Cloud/JATP Cloud feeds only No ATP Cloud/
JATP (no selection)

Full Threat
Prevention Support

YES

Support with Policy
Enforcement
Groups across the
entire Secure Fabric
(including Third-
party switch
support)

YES

Support with
existing SRX Series
policies. (No Secure
Fabric, Policy
Enforcement Group
or Third-party
switch support)

Not Available Not Available

SRX Series Firewall
Malware Scanning

YES YES Not Available Not Available
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Table 2: List of features by Juniper ATP Cloud Configuration Type (Continued)

Feature ATP Cloud/ATP
Appliance with
Juniper Connected
Security

ATP Cloud/JATP Cloud feeds only No ATP Cloud/
JATP (no selection)

SRX Series Firewall
Infected Host
Blocking with
Juniper ATP Cloud
or JATP

YES YES Not Available Not Available

Cloud Feeds for
Command and
Control Servers and
GeoIP with Juniper
ATP Cloud or JATP

YES YES YES Not Available

Infected Hosts
Custom Feeds

YES YES YES YES

Dynamic Address
Custom Feeds

YES YES YES YES

Custom Allowlist
and Blocklists

YES YES YES YES

RELATED DOCUMENTATION
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Available UI Pages by Juniper ATP Cloud
Configuration Type

For each configuration type, certain features and UI pages are available.

Refer to the following table for the UI pages available for each configuration type.

Table 3: List of available UI pages by ATP Cloud Configuration Type

UI Page ATP Cloud/ATP
Appliance with
Juniper Connected
Security

ATP Cloud/JATP Cloud feeds only No ATP Cloud/
JATP (no selection)

Monitor Pages: Threat Prevention

Hosts YES YES Not Available Not Available

CC YES YES Not Available Not Available

HTTP File Download YES YES Not Available Not Available

SMTP Quarantine YES YES Not Available Not Available

Email Attachments YES YES Not Available Not Available

Manual Upload YES YES Not Available Not Available

All Hosts Status YES YES YES YES

DDoS Feeds Status YES Not Available YES YES

Devices Page

Secure Fabric YES Not Available YES YES
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Table 3: List of available UI pages by ATP Cloud Configuration Type (Continued)

UI Page ATP Cloud/ATP
Appliance with
Juniper Connected
Security

ATP Cloud/JATP Cloud feeds only No ATP Cloud/
JATP (no selection)

Configure Pages: Threat Prevention

Policies YES YES YES YES

Custom Feeds

(Dynamic Address,
Allowlist, Blocklist, CC)

YES YES YES YES

Custom Feeds

(Infected Host, DDoS)

YES Not Available YES YES

ATP Cloud Realms YES

(Only for ATP Cloud)

YES

(Only for ATP
Cloud)

YES Not Available

Email Management YES YES Not Available Not Available

Malware Management YES YES Not Available Not Available

Shared Objects

Policy Enforcement
Groups

YES Not Available YES YES

Geo IP YES YES YES Not Available

Administration: Policy Enforcer
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Table 3: List of available UI pages by ATP Cloud Configuration Type (Continued)

UI Page ATP Cloud/ATP
Appliance with
Juniper Connected
Security

ATP Cloud/JATP Cloud feeds only No ATP Cloud/
JATP (no selection)

Settings YES YES YES YES

Connectors YES Not Available YES YES

NOTE: SMTP Quarantine is available only for Juniper ATP Cloud. It is not available for
JATP.

RELATED DOCUMENTATION
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Comparing the Juniper Connected Security and non-
Juniper Connected Security Configuration Steps

The remainder of this guide describes how to configure Security Director for either Policy Enforcer with
Juniper ATP Cloud (Juniper Connected Security) or Juniper ATP Cloud with no Policy Enforcer (non-
Juniper Connected Security). An optional quick setup configuration is available to step you through the
configuration tasks. Or you can use Security Director windows to configure each step manually.

Table 4 on page 28 compares the basic steps for both.
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Table 4: Comparing the Juniper Connected Security Configuration Steps to the non-Juniper Connected
Security Configuration Steps

Juniper Connected Security Configuration Steps Non-Juniper Connected Security
Configuration Steps

Create your secure fabric.

A secure fabric is a collection of sites which contain network devices
such as switches, routers, firewalls, and other security devices.

Register one or more Juniper ATP Cloud
accounts.

Create your policy enforcement groups.

You can create policy enforcement groups based on, for example,
location or IP subnets. Policy enforcement groups are basically
endpoints.

Select your SRX Series devices to register.
Only SRX Series devices managed by
Security Director are supported.

Register one or more Juniper ATP Cloud accounts. Create the Juniper ATP Cloud profiles
and policies. You can create C&C (threat
score and actions to take), malware and
infected host policies.

Create threat prevention policies.

Threat prevention policies provide protection and monitoring for
selected threat profiles, including command & control servers,
infected hosts, and malware.

Add the Juniper ATP Cloud policy as a
rule in your firewall policy.

Apply your threat prevention policies to policy enforcement groups.

When threat prevention policies are applied to policy enforcement
groups, the system automatically discovers to which sites those
groups belong. When you dynamically add sites, the policy
enforcement groups and threat prevention policies are updated
automatically.
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Policy Enforcer Installation Overview

Table 5 on page 31 lists the general steps to install and configure Policy Enforcer.

Table 5: Overview of Steps to Install and Configure Policy Enforcer

Step Description See

1 Install and configure Junos Space and Security
Director 16.1 or later.

               

NOTE: After installing Junos Space and
Security Director, you must update to the
latest Junos Space device schema. See your
Junos Space Security Director documentation
for more information on upgrading your
schema.

Junos Space Network Management Platform
software download

               

Junos Space Security Director software
download

2 Install and configure your SRX Series devices, EX
Series switches or QFX Series switches.
Switches are “discoverable” through Junos
Space.

For information on discovering switches, see
"Using Guided Setup for Juniper ATP Cloud with
Juniper Connected Security" on page 134.

Juniper Tech Library

3 Download, deploy and configure the Policy
Enforcer virtual machine.

You install Policy Enforcer on an industry-
standard x86 server running a hypervisor, either
the kernel-based virtual machine (KVM)
hypervisor or the VMware ESXi hypervisor.

"Deploying and Configuring the Policy Enforcer
with OVA files" on page 33

"Installing Policy Enforcer with KVM" on page
39

4 Use the Policy Enforcer Settings screen in
Security Director (Administration > Policy
Enforcer Settings) to identify the Policy Enforcer
virtual machine to communicate with.

"Identifying the Policy Enforcer Virtual Machine
In Security Director" on page 51
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Table 5: Overview of Steps to Install and Configure Policy Enforcer (Continued)

Step Description See

5 Obtain a Juniper ATP Cloud license and create a
Juniper ATP Cloud portal account.

Obtaining a Juniper ATP Cloud License

               

Creating a Juniper ATP Cloud Web Portal Login
Account

6 Install the root CA on your Juniper ATP Cloud-
supported SRX Series devices.

"Loading a Root CA" on page 54

7 Configure ClearPass or Cisco ISE as a connector
for third-party products (non-Juniper Networks)
to unify policy enforcement across all network
elements.

ClearPass Configuration for Third-Party Plug-in

Cisco ISE Configuration for Third-Party Plug-in

8 Use the Guided Setup screens in Security
Director to configure Threat Prevention policies
and deploy to devices. Optionally, you can
configure policies without guided setup.

"Using Guided Setup for Sky ATP with SDSN" on
page 134

               

Using Guided Setup for Juniper ATP Cloud
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Deploying and Configuring the Policy Enforcer with
OVA files

As with other Juniper Networks virtual appliances, Policy Enforcer requires either a VMware ESX server
version 4.0 or later or a VMware ESXi server version 4.0 or later that can support a virtual machine with
the following configuration:

• 2 CPU

• 8-GB RAM (16-GB recommended)

• 120-GB disk space

If you are not familiar with using VMware ESX or EXSi servers, see VMware Documentation and select
the appropriate VMware vSphere version.

To deploy and configure the Policy Enforcer with OVA files, perform the following tasks:

1. Download the Policy Enforcer virtual machine OVA image from the Juniper Networks software
download page.

NOTE: Do not change the name of the Policy Enforcer virtual machine image file
that you download from the Juniper Networks support site. If you change the name
of the image file, the creation of the Policy Enforcer virtual machine can fail.

2. Launch the vSphere Client that is connected to the ESX server where the Policy Enforcer virtual
machine is to be deployed.

3. Select File > Deploy OVF Template from the menu bar.

4. Click Browse to locate the OVA file you downloaded in Step 1.

5. Click Next and follow the instructions in the installation wizard.

It may take a few minutes to deploy your virtual machine. Once deployed, its name appears in the
left side of the vSphere Client.

6. Right-click the virtual machine name in the left side of the vSphere Client and select Open Console
to start configuring your network settings.

7. Log in to your virtual machine using root and abc123 as the username and password, respectively. You
will be required to change the password at a later step.

The welcome page appears.

8. Click OK.

The End User License Agreement (EULA) window appears.
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9. Click Accept to acknowledge the EULA. If you do not agree with the EULA, click Cancel. Your
configuration will stop and you will return to the main vSphere Client page.

The Network configuration page appears. See Figure 10 on page 34.

Figure 10: Defining the Basic Network Configuration Settings

10. Enter the following configuration information.

Option Description

Hostname Enter the hostname for the Policy Enforcer virtual machine; for example,
pe.juniper.net.

IP address Enter the IP address for the Policy Enforcer virtual machine.

NOTE: Make note of this IP address as you’ll need it in a later step.

Network mask Enter the netmask for the Policy Enforcer virtual machine.

Default gateway Enter the IP address of the default gateway that connects your internal network to
external networks.
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(Continued)

Option Description

Primary DNS server Enter the IP address of your primary system registered to join the Domain Name
System (DNS).

Secondary DNS
server

Enter the IP address of a secondary DNS server. Policy Enforcer uses this address
only when the primary DNS server is unavailable.

Skip DNS servers
check

Select this check box if you do not want to check basic network settings. By
default, the system will ping the gateway to ensure it receives a response
indicating your settings are correct.

11. Click Apply Changes.

Your network settings are applied. A progress window indicates the status.

When the system is finished updating your network settings, an NTP server window appears and
prompts you to configure the NTP server list. See Figure 11 on page 35.

Figure 11: Prompt for Configuring the NTP Servers

12. Click Yes to customize the NTP server list. Click No to use the default list of 0, 1, 2 and
3.centos.pool.ntp.org.

13. (Optional) Specify the NTP servers to use. See Figure 12 on page 36. Click Apply Changes to
accept your edits, Clear All to clear all fields in this window, or Cancel to discard any edits and
continue to the next step.
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Figure 12: Configuring the NTP Servers

14. The Root password change page appears. See Figure 13 on page 36.

Figure 13: Changing the Root Password

15. Enter and re-enter a new administrator password for the Policy Enforcer virtual machine.
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Password restrictions are listed in the screen.

NOTE: Make note of this password as you’ll need it in a later step.

If you forget your password, see CentOS root password reset instructions.

16. Click OK.

The Juniper Networks Policy Enforcer page appears. See Figure 14 on page 37.

Figure 14: Reviewing and Changing Your Configuration Settings

17. Select one of the options and press Enter.

Option Description

Review configuration and
finish setup

Lets you review the configuration settings you defined one last time before
applying them to the Policy Enforcer virtual machine.

We recommend that you do not change your configuration settings after
Policy Enforcer is set up within Security Director.

Change... Select a setting to update its value.

Troubleshooting menu Lets you ping the default gateway and custom IP address and lets you perform
a DNS lookup to verify that your settings are correct.

The Review configuration page appears. See Figure 15 on page 38.

37

https://wiki.centos.org/TipsAndTricks(2f)ResetRootPassword.html


Figure 15: Reviewing Your Configuration Settings

18. Review your configuration settings and click Finish setup. To change any of the settings, click
Change configuration.

When you click Finish setup, the configuration settings are applied to the Policy Enforcer virtual
machine. A status page indicates the progress.

When done, the Setup Complete page appears.

19. Click Finish to return to the main vSphere Client page.
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NOTE: Each time you log in to the Policy Enforcer virtual machine, you are given the
option to review or change any of these settings.
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Installing Policy Enforcer with KVM
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The Policy Enforcer Virtual Appliance Release 17.1R2 and later can be deployed on qemu-kvm (KVM)
Release 1.5.3-105.el7 or later which is on CentOS Release 6.8 or later.

NOTE: Juniper Networks does not provide any support for installing and configuring the
KVM server. You must install the virtual appliance image and configure it as per the
recommended specifications for the virtual appliance. Juniper Networks will provide
support only after the Policy Enforcer Virtual Appliance has booted successfully.

The prerequisites to deploy a Policy Enforcer Virtual Appliance on a KVM server are as follows:

• Knowledge about configuring and installing a KVM server.
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• The KVM server and supported packages must be installed on a CentOS machine with the required
kernels and packages. For information about installing a KVM server and supported packages on
CentOS, refer to http://wiki.centos.org/HowTos/KVM.

• The Virtual Machine Manager (VMM) client must be installed on your local system.

• You use virt-manager or virt-install to install Policy Enforcer VMs. See your host OS documentation
for complete details on these packages.

The following are the minimum requirements for installing the Policy Enforcer VM.

• 2 CPU

• 8-GB RAM (16 GB recommended)

• 120-GB disk space

This topic includes:

Installing Policy Enforcer with virt-manager

Ensure that sure you have already installed KVM, qemu, virt-manager, and libvirt on your host OS.

You can install and launch Policy Enforcer with the KVM virt-manager GUI package.

To install Policy Enforcer with virt-manager:

1. Download the Policy Enforcer KVM image from the Juniper software download site.

2. On your host OS, type virt-manager. The Virtual Machine Manager appears.

NOTE: You must have admin rights on the host OS to use virt-manager.

3. Click Create a new virtual machine. The New VM wizard appears .

4. Enter a name for the virtual machine, select Import existing disk image, and click Forward.

5. Browse to the location of the downloaded Policy Enforcer image and select it.

6. Select Linux from the OS type list and select Show all OS options from the Version list.

7. Select Red Hat Enterprise Linux 6 or later from the expanded Version list and click Forward.

8. Set the RAM to 8192 MB and set CPUs to 1. Click Forward.

9. Under Advanced Options, select Specify shared device name and enter the name of the bridge
(typically br0) into the text box.

10. Click Finish. The VM manager creates the virtual machine and launches the Policy Enforcer console.
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Installing Policy Enforcer with virt-install

Ensure that sure you have already installed KVM, qemu, virt-install, and libvirt on your host OS.

NOTE: You must have root access on the host OS to use the virt-install command.

The virt-install and virsh tools are CLI alternatives to installing and managing Policy Enforcer VMs on a
Linux host.

To install Policy Enforcer with virt-install:

1. Download the Policy Enforcer KVM image from the Juniper software download site.

2. On your host OS, use the virt-install command with the mandatory options listed in Table 6 on page
41.

NOTE: See the official virt-install documentation for a complete description of
available options.

Table 6: virt-install Options

Command Option Description

--name name Name the Policy Enforcer VM.

--ram megabytes Allocate RAM for the VM, in megabytes.

--cpu cpu-model, cpu-flags Enable the vmx feature for optimal throughput. You can also enable aes for
improved cryptographic throughput.

NOTE: CPU flag support depends on your host OS and CPU.

Use virsh capabilities to list the virtualization capabilities of your host OS and
CPU.

--vcpus number Allocate the number of vCPUs for the Policy Enforcer VM.
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Table 6: virt-install Options (Continued)

Command Option Description

--disk path Specify disk storage media and size for the VM. Include the following options:

• size=gigabytes

• device=disk

• bus=ide

• format=qcow2

--os-type os-type

--os-variant os-type

Configure the guest OS type and variant.

--import Create and boot the Policy Enforcer VM from an existing image.

The following example creates a Policy Enforcer VM with 8192 MB RAM, 1 vCPUs, and disk storage
up to 120 GB:

hostOS# virt-install --name vPEM --ram 8192 --cpu SandyBridge,+vmx,-invtsc --vcpus=1 --
arch=x86_64 --disk path=/mnt/pe.qcow2,size=120,device=disk,bus=ide,format=qcow2 --os-type 
linux --os-variant rhel6 --import
                  

Configuring Policy Enforcer Settings

By default, when you create the Policy Enforcer VM through virt-manager or virt-install, the console
window appears for you to set up and configure the Policy Enforcer settings. You can open the console
at any time after the initial configuration to review or edit your settings.

To configure Policy Enforcer settings:

1. Log in to your virtual machine using root and abc123 as the username and password, respectively. You
will be required to change the password at a later step.

The welcome page appears.

2. Click OK.
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The End User License Agreement (EULA) window appears.

3. Click Accept to acknowledge the EULA. If you do not agree with the EULA, click Cancel. Your
configuration will stop and you will return to the main vSphere Client page.

The Network configuration page appears. See Figure 16 on page 43.

Figure 16: Defining the Basic Network Configuration Settings

4. Enter the following configuration information.

Option Description

Hostname Enter the hostname for the Policy Enforcer virtual machine; for example,
pe.juniper.net.

IP address Enter the IP address for the Policy Enforcer virtual machine.

NOTE: Make note of this IP address as you’ll need it in a later step.

Network mask Enter the netmask for the Policy Enforcer virtual machine.

Default gateway Enter the IP address of the default gateway that connects your internal network to
external networks.
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(Continued)

Option Description

Primary DNS server Enter the IP address of your primary system registered to join the Domain Name
System (DNS).

Secondary DNS
server

Enter the IP address of a secondary DNS server. Policy Enforcer uses this address
only when the primary DNS server is unavailable.

Skip DNS servers
check

Select this check box if you do not want to check basic network settings. By
default, the system will ping the gateway to ensure it receives a response
indicating your settings are correct.

5. Click Apply Changes.

Your network settings are applied. A progress window indicates the status.

When the system is finished updating your network settings, an NTP server window appears and
prompts you to configure the NTP server list. See Figure 17 on page 44.

Figure 17: Prompt for Configuring the NTP Servers

6. Click Yes to customize the NTP server list. Click No to use the default list of 0, 1, 2 and
3.centos.pool.ntp.org.

7. (Optional) Specify the NTP servers to use. See Figure 18 on page 45. Click Apply Changes to
accept your edits, Clear All to clear all fields in this window, or Cancel to discard any edits and
continue to the next step.
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Figure 18: Configuring the NTP Servers

8. The Root password change page appears. See Figure 19 on page 45.

Figure 19: Changing the Root Password

9. Enter and re-enter a new administrator password for the Policy Enforcer virtual machine.
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Password restrictions are listed in the screen.

NOTE: Make note of this password as you’ll need it in a later step.

If you forget your password, see CentOS root password reset instructions.

10. Click OK.

The Juniper Networks Policy Enforcer page appears. See Figure 20 on page 46.

Figure 20: Reviewing and Changing Your Configuration Settings

11. Select one of the options and press Enter.

Option Description

Review configuration and
finish setup

Lets you review the configuration settings you defined one last time before
applying them to the Policy Enforcer virtual machine.

We recommend that you do not change your configuration settings after
Policy Enforcer is set up within Security Director.

Change... Select a setting to update its value.

Troubleshooting menu Lets you ping the default gateway and custom IP address and lets you perform
a DNS lookup to verify that your settings are correct.

The Review configuration page appears. See Figure 21 on page 47.
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Figure 21: Reviewing Your Configuration Settings

12. Review your configuration settings and click Finish setup. To change any of the settings, click
Change configuration.

When you click Finish setup, the configuration settings are applied to the Policy Enforcer virtual
machine. A status page indicates the progress.

When done, the Setup Complete page appears.

13. Click Finish to return to the main vSphere Client page.
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NOTE: Each time you log in to the Policy Enforcer virtual machine, you are given the
option to review or change any of these settings.

Connecting to the KVM Management Console

By default, when you create the Policy Enforcer VM the console window appears for you to set up and
configure the Policy Enforcer settings. You can open the console at any time after the initial
configuration to review or edit your settings. To do this, you must have the virt-manager package or virsh
installed on your host OS.

To connect to the Policy Enforcer console using virt-manager:

1. Launch virt-manager.

2. Highlight the Policy Enforcer VM you want to connect to from the list of VMs displayed.

3. Click Open.

4. Select View>Text Consoles>Serial 1. The Policy Enforcer console appears.

To connect to the Policy Enforcer console with virsh:

1. Use the virsh console command on the Linux host OS. For example:

                     user@host# virsh console PE-kvm-2 
Connected to domain PE-kvm-2
                  

2. The Policy Enforcer console appears.

RELATED DOCUMENTATION
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Policy Enforcer Ports

NOTE: While using Policy Enforcer in Connected Security deployment, SRX Series
Firewalls do not submit files for detection via Policy Enforcer. SRX Series Firewalls still
need to reach the ATP Cloud server via internet to submit files for malware detection
and analysis. If SRX Series Firewalls are connected to the internet via another firewall or
proxy, then that device must have 8080 and 443 ports open.

You will need to open ports for Policy Enforcer to communicate with other products and devices.

Table 7 on page 49 lists the ports that Policy Enforcer uses to communicate with Security Director.

Table 7: Policy Enforcer Ports to Communicate with Security Director

Service Protocol Port In Out

HTTPS TCP 8080 X

HTTPS TCP 443 X

Table 8 on page 49 lists the ports that Policy Enforcer uses to communicate with SRX Series Firewalls.

Table 8: Policy Enforcer Ports to Communicate with SRX Series Firewalls

Service Protocol Port In Out

HTTPS TCP 443 X

Table 9 on page 50 lists the ports that Policy Enforcer uses to communicate with the Juniper ATP
Cloud server to download feeds.

NOTE: Connectivity between Juniper ATP Cloud and Policy Enforcer is certificate-based.
Once the trust is established, every request is within a context of valid token.

Table 10 on page 50 lists the ports that Policy Enforcer uses to communicate with
ca.junipersecurity.net.
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Table 9: Policy Enforcer Ports to Communicate with cloudfeeds.sky.junipersecurity.net

Service Protocol Port In Out

HTTPS TCP 443 X

Table 10 on page 50 lists the ports that Policy Enforcer uses to communicate with
ca.junipersecurity.net.

Table 10: Policy Enforcer Ports to Communicate with ca.junipersecurity.net

Service Protocol Port In Out

HTTPS TCP 8080 X

Table 11 on page 50 lists the remaining Policy Enforcer services.

Table 11: Policy Enforcer Services

Service Comments

DNS Used for basic network connection.

NTP Used to synchronize system clocks with the Network Time Protocol (NTP).

If you are using NSX with Policy Enforcer (or Security Director), the following ports must be opened on
NSX.

Table 12: NSX Ports

Port In Out Comments

443 X Used for communication between NSX and Security Director.

7804 X Used for outbound SSH based auto discovery of devices.

22 X Used for host management and image upload over sftp.
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Identifying the Policy Enforcer Virtual Machine In
Security Director

You must identify the Policy Enforcer virtual machine in Security Director so that they can communicate
with each other. To do so, follow these steps:

1. Log in to Security Director and select Administration > PE Settings.

2. Enter the IP address of the Policy Enforcer virtual machine and the root password and click OK.

3. Select a Threat Prevention Type:

• ATP Cloud with PE—All Juniper Connected Security features and threat prevention types are
available.

NOTE: If you upgrade from cloud feeds or ATP Cloud, you cannot roll back again.
Upgrading resets all devices previously participating in threat prevention. Use the
setup wizard to expedite the process configuring threat prevention policies.

• ATP Cloud—All threat prevention types are available: Command and control server, Geo IP, and
Infected hosts.

NOTE: If you upgrade from cloud feeds only to ATP Cloud, you cannot roll back
again. Upgrading resets all devices previously participating in threat prevention, and
you must re-enroll them with ATP Cloud. Use the setup wizard to expedite the
process configuring threat prevention policies.

• Cloud Feeds only—Command and control server and Geo IP are the only threat prevention types
available.

For more information on these threat prevention types, see Policy Enforcer Settings.

If you change the Policy Enforcer VM password (see Deploying and Configuring the Policy Enforcer
Virtual Machine), the Policy Enforcer VM still communicates with Security Director even if you do
not update the Policy Enforcer password in the Administration > PE Settings window in Security
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Director. You can, however, update the information in the PE Settings page with the new password
to keep your credentials consistent.
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Policy Enforcer Components and Dependencies  |  13

Obtaining a Juniper ATP Cloud License

Contact your local sales office or a Juniper Networks partner to place an order for a Juniper ATP Cloud
premium license. Once the order is complete, an authorization code is e-mailed to you. You will use this
code in conjunction with your SRX Series device serial number to generate a premium license
entitlement. (Use the show chassis hardware CLI command to find the serial number of the SRX Series
device.)

To obtain a Juniper ATP Cloud premium or basic license, follow these steps:

1. Go to https://www.juniper.net/generate_license/ and log in with your Juniper Networks Customer
Support Center (CSC) credentials.

2. In the Generate Licenses list, select J Series Service Routers and SRX Series Firewalls.

3. Using your authorization code and SRX Series serial number, follow the instructions to generate your
license key. (Note that you do not enter this license key anywhere.)

Once generated, your license key is automatically transferred to the cloud server. It can take up to 24
hours for your activation to be updated in the Juniper ATP Cloud cloud server

The free version does not require you to generate a license. The SRX Series device only needs to be
enrolled to the cloud, and it will automatically be entitled to the free version.

Unlike with physical SRX Series devices, you must install Juniper ATP Cloud premium licenses onto your
vSRX instances. Installing the Juniper ATP Cloud license follows the same procedure as with most
standard vSRX licenses. For more information on installing the Juniper ATP Cloud license onto your
vSRX instance, see the License Management and vSRX Deployments section within Managing the
Advanced Threat Prevention Cloud License.
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Creating a Juniper ATP Cloud Web Portal Login
Account

To create a Juniper ATP Cloud account, you must first have a Customer Support Center (CSC) user
account. For more information, see Creating a User Account. If you forget to do this step, you will be
reminded during the quick setup.

1. Go to https://sky.junipersecurity.net and select your region. On the next screen, click Create a
security realm.

2. Enter the following required information and continue to click Next until you are finished:

• Your single sign-on or Juniper Networks CSC credentials.

• A security realm name — for example, Juniper-Mktg-Sunnyvale. Realm names can only contain
alphanumeric characters and the dash (“-”) symbol.

• Your contact information.

• An e-mail address and password. This will be your login information to access the Juniper ATP
Cloud management interface.

3. When you click Finish, you are automatically logged in and taken to the Juniper ATP Cloud Web UI
dashboard.
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Loading a Root CA

After the Policy Enforcer virtual machine is configured and created and before creating any ATP policy,
you must set up certificates on any Juniper ATP Cloud-supported SRX Series device. For a list of Juniper
ATP Cloud- supported devices, see Juniper ATP Cloud Supported Platforms Guide.

NOTE: The following is simply an example. You will need to modify the group name,
profile and policy name to match your configuration.

To set up certificates for Policy Enforcer:

1. Create the CA profile using the following CLI command. A CA profile configuration contains
information specific to a CA.

root@host# request security pki generate-key-pair certificate-id ssl-inspect-ca size 2048 type rsa
root@host# request security pki local-certificate generate-self-signed certificate-id ssl-inspect-ca 
domain-name www.juniper.net subject "CN=www.juniper.net,OU=IT,O=Juniper Networks,L=Sunnyvale,ST=CA,C=US" 
email security-admin@juniper.net

2. Configure the CA profile.

NOTE: The CA profile name must be policyEnforcer.

root@host# set security pki policyEnforcer ssl-inspect-ca ca-identity ssl-inspect-ca
root@host# set security pki ca-profile policyEnforcer ca-identity ssl-profile-ca

3. Load the default trusted CA.

root@host# request security pki ca-certificate ca-profile-group load ca-group-name All-Trusted-CA-Def 
filename default

4. Enable HTTPS on the threat prevention policy.

When creating your threat prevention policy (in Security Director, select Configure>Threat
Prevention > Policy), enable the Scan HTTPS option to scan files downloaded over HTTPS. For more
information on creating threat prevention policies, see the Security Director online help.
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When you enable HTTPS on the threat prevention policy, Policy Enforcer sends the following
configuration to the devices:

##Security Firewall Policy : trust - untrust##
set security policies from-zone trust to-zone untrust policy PolicyEnforcer-Rule1-1 then 
permit application-services ssl-proxy profile-name policyEnforcer
##Security Firewall Policy : global ##
set security policies global policy PolicyEnforcer-Rule1-1 then permit application-services 
ssl-proxy profile-name policyEnforcer
##SSL Forward proxy Profile Configurations##
set services ssl proxy profile policyEnforcer trusted-ca all
set services ssl proxy profile policyEnforcer root-ca ssl-inspect-ca

5. Export the locally generated certificate from the SRX Series device and install it on clients as a
trusted CA to avoid some of the certificate errors that may occur.

Each website or browser behaves slightly different. Some require exceptions to be added to your
browser to display the content while others may not work because the local certificate is weak.

root@host# request security pki local-certificate export certificate-id ssl-inspect-ca type 
pem filename ssl-inspect-ca.pem

6. (Optional) You can limit some certificate warning messages using the following CLI command:

root@host# set services ssl proxy profile policyEnforcer actions ignore-server-auth-failure

Upgrading Your Policy Enforcer Software

To upgrade to the latest release of Policy Enforcer, download and run the rpm file available from Juniper
Network’s software download page. You must have a version of Policy Enforcer already installed to run
the upgrade script. If you do not, download the latest software version from the Policy Enforcer
software download page and follow the Policy Enforcer Installation Overview instructions.

NOTE: You can upgrade only from the previous release. For example, you can upgrade
from 16.1R1 to 16.1R2 or from 16.1R2 to 17.1. You cannot skip a release. For example,
upgrading from 16.1R1 to 17.1R1 is not supported.
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To upgrade your Policy Enforcer software to the latest release:

1. Access the Policy Enforcer software download page

https://www.juniper.net/support/downloads/?p=sdpe

2. Select the Software tab.

3. From the Version drop-down menu, select the version you want to install.

4. From under the Application Package heading, download the Policy Enforcer RPM to your Policy
Enforcer virtual appliance.

5. On your Policy Enforcer virtual appliance, change directory to where you downloaded the RPM
bundle and install it using the following command:

[root@hostname~]# rpm -Uvh filename.rpm

For example:
[root@hostname~]# rpm -Uvh Policy_Enforcer-22.1R1-XXXX-PE-Upgrade.rpm

It may take a few minutes to install the RPM bundle. Once installed, the Policy Enforcer screens within
Security Director and any schema changes are updated. The configuration settings you used when you
deployed the Policy Enforcer VM are retained.

To verify your upgrade:

• In Security Director, select Administration > PE settings. This page shows the current installed Policy
Enforcer version number.

• Check the log file for any errors.

• (Upgrading from 16.1R1 to 16.2R1) Check the /var/log/pe_upgrade.log file for any errors. The
following is an example output of the pe_upgrade.log file for a successful upgrade.

Location: /var/log/pe_upgrade.log
Update text:
Preparing...                ########################################### [100%]
   1:Policy_Enforcer        ########################################### [100%]
Upgrading..
root
Stopping services
Service: feed_scheduler
Stopping service…
Service stopped
Service: feed_server
Stopping service…
Service stopped
Service: config_server
Stopping service…
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Service stopped
Extracting spotlight-connector package
Extracting security-common-lib package
Executing sql table
Copying spotlight-connector package
Copying security-common-lib package
Starting services
Service: config_server
Starting service…
Service started
Service: feed_server
Starting service…
Service started
Service: feed_scheduler
Starting service…
Service started
root
Done.

• (Upgrading from 17.1R1 to 17.2R1) Check the following log files for errors:

• /var/log/pe_upgrade_17_2.log

• /var/log/pe_upgade_17_2_3rd_party_adapter.log

• /var/log/pe_upgrade_nsx.log
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Policy Enforcer Settings

To configure your Policy Enforcer, perform the following actions.

Before You Begin

• Policy Enforcer Release version and Security Director Release version must be compatible. The
Settings page shows the current release version of Policy Enforcer. If there is an incompatibility, an
error message is shown that there is a mismatch between Security Director and Policy Enforcer
release versions. To know more about the supported software versions, see Policy Enforcer Release
Notes.

You cannot proceed further if the Policy Enforcer and Security Director Release versions are
incompatible.

• A valid Policy Enforcer VM password is required to have a fully functional Policy Enforcer. If the
password is valid, a message is shown at the top of the Settings page that the Policy Enforcer Space
user (pe_user) password is currently valid and the date by when the password expires. The pe_user
has the same capabilities as the super user.

If the password is invalid, an error message is shown at the top of the Settings page. To fix this issue,
login to the Policy Enforcer VM, change the root password, and then enter the new root password in
the Settings page.

• Policy Enforcer with Security Director can be used in four different configuration types. For each
configuration type, certain features are available. Read the following topic: Juniper ATP Cloud
Configuration Type Overview before you make a Juniper ATP Cloud or Juniper Advanced Threat
Prevention (JATP) Configuration Type selection on the Policy Enforcer Settings page.

• If you are using Juniper ATP Cloud or ATP Appliance without Juniper Connected Security or Cloud
Feeds only, you must still download Policy Enforcer and create a policy enforcer virtual machine.

• Juniper ATP Cloud license and account are needed for three of the configuration types (Juniper ATP
Cloud or ATP Appliance with Juniper Connected Security, Juniper ATP Cloud or JATP, and Cloud
Feeds only), but not for the default mode (No Selection). If you do not have a Juniper ATP Cloud
license, contact your local sales office or Juniper Networks partner to place an order for a Juniper
ATP Cloud premium license. If you do not have a Juniper ATP Cloud account, when you configure
Juniper ATP Cloud, you are redirected to the Juniper ATP Cloud server to create one. Please obtain a
license before you try to create a Juniper ATP Cloud account. Refer to Policy Enforcer Installation
Overview for instructions on obtaining a Juniper ATP Cloud premium license.

To set up ATP Cloud or ATP Appliance Configuration Type, you must do the following:

1. Select Security Director>Administration>Policy enforcer>Settings.
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2. Enter the IP address for the policy enforcer virtual machine. (This is the IP address you configured
during the PE VM installation. You can locate this IP address in the vSphere Center portal.)

3. Enter the password for the policy enforcer virtual machine. (This is the same password you use to
login to the VM with your root credentials. Note that the username defaults to root )

NOTE: Refer to Deploying and Configuring the Policy Enforcer with OVA files for
instructions on downloading Policy Enforcer and creating your policy enforcer virtual
machine.

4. If you want to use certificate based authentication, enable the Certificate Based Authentication
option.

Browse the X509 certificate file and X509 certificate Key file.

5. Select ATP Cloud Configuration Type. If you do not select a type, Policy Enforcer works in default
mode. (See Sky ATP Configuration Type Overview for more information.)

Refer Table 13 on page 60 to understand the supported threat prevention types for different Policy
Enforcer modes:

Table 13: Supported Threat Prevention Types for Different PE Modes

Threat Prevention Type No Selection
(Default)

Cloud Feeds
Only

ATP Cloud or
JATP

ATP Cloud or ATP
Appliance with
Juniper Connected
Security

Custom feeds Yes Yes Yes Yes

Command and Control (C&C)
feeds

Yes Yes Yes Yes

Infected Host feed - Yes Yes Yes

Malware inspection - - Yes Yes

Enforcement on EX Series and
QFX Series switches or using
3rd party Connectors

- - - Yes
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You cannot change or modify a higher configuration to a basic mode. For example, you cannot
change:

• Juniper ATP Cloud or JATP ->Cloud feeds only

• Juniper ATP Cloud or ATP Appliance with Juniper Connected Security ->Cloud feeds only

• Juniper ATP Cloud or JATP ->No Selection (Default)

WARNING: If you change to a lower mode, you must reinstall Security Director and
Policy Enforcer.

However, you can change or modify your configuration to a higher mode. For example you can
change:

• Cloud feeds only-> Juniper ATP Cloud or JATP

• Cloud feeds only ->Juniper ATP Cloud with Juniper Connected Security

• Juniper ATP Cloud or JATP -> Juniper ATP Cloud with Juniper Connected Security

6. Polling timers affect how often the system polls to discover endpoints. There are two polling timers,
one that polls network wide and one that polls site wide. They each have default settings, but you
can change those defaults to poll more or less often.

• Network wide polling interval (value in hours): The default is 24 hours. You can set this range from
between 1 to 48 hours. This timer polls all endpoints added to the secure fabric.

• Site wide polling interval (value in minutes): The default is 5 minutes. You can set this range from 1
minute to 60 minutes. This timer polls infected endpoints moving within the sites that are a part
of Secure fabric.

7. Click Enable Feeds Purge to enable the purge option. You can purge the feeds that are older than a
specified number of days.

8. The Purge History determines the number of days you can preserve the history of the feeds in Policy
Enforcer. You can set a range between 300 to 600 days. The default is 365 days.

The purge job runs every day at 12:00 PM and makes sure that the data set on the purge history is
maintained.

9. Click the Download button to view or save Policy Enforcer data logs to your local system. These logs
are in a compressed file format.
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Policy Enforcer Connector Overview

IN THIS SECTION

Benefits of Policy Enforcer Connector  |  64

Configure a connector for third-party products (non-Juniper Networks) to unify policy enforcement
across all network elements. This protects endpoints, wired and wireless, connecting to third-party
devices as well as Juniper devices.

For Policy Enforcer to provide threat remediation to endpoints connecting through third-party devices, it
must be able to authenticate those devices and determine their state. It does this using a tracking and
accounting threat remediation plug-in to gather information from a RADIUS server and enforce policies
such as terminate session and quarantine.

NOTE: All third-party switches being used with Policy Enforcer must support AAA/
RADIUS and Dynamic Authorization Extensions to RADIUS protocol (RFC 3579 and RFC
5176).

NOTE: All Cisco Systems switch models that adhere to Radius IETF attributes and
support Radius Change of Authorization from Aruba ClearPass are supported by Policy
Enforcer for threat remediation.

Once configured, the connector uses an API to gather endpoint MAC address information from the
RADIUS server. If a host is found to be suspicious, the RADIUS server sends a CoA to disconnect the
active session and quarantine the host. Once the threat has been mitigated, the interface can return to
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the network again, but must be authorized to do so by Policy Enforcer using the plug-in and information
gathered from the RADIUS server.

Once you have a connector configured, the following information is provided on the Connectors main
page.

Table 14: Connectors Information- Main Page

Field Description

Name The name you entered for the connector.

Type This field always reads Third Party Switch at this time.

Status The current status of the connector. (Active or Inactive.)

Hover over the status to see more details of connector instances and their respective status.

The following statuses are shown:

• Active status with green icon—All connector instances inside a connector are active

• Inactive status with red icon—All connector instances inside a connector are inactive

• Active status with red icon—One of the connectors is inactive and other connectors are
active.

• In progress status with green icon—All connectors are still in progress.

• Pending (not in progress) status with green icon—All connectors are still pending.

Description Specifies the description of a connector.

Identity Server Specifies the IP address of the product management server.

IP Address The IP address of the ClearPass RADIUS server.
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Benefits of Policy Enforcer Connector

• Custom threat feed and automation - Automates the threat remediation workflows for third-party
products.

• RESTful APIs - Provides a network vendor agnostic mechanism for threat remediation. Enables you
to automate configuration and management of physical, logical, or virtual devices.

RELATED DOCUMENTATION
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Creating a Policy Enforcer Connector for Third-Party Switches  |  75

Creating a Policy Enforcer Connector for Public and
Private Clouds

Before You Begin

• For Amazon Web Services (AWS) connector:

• Create access key and password for your AWS account. This will be a unique username and
password for your Amazon account required to create a connector. See Managing Access Keys for
Your AWS Account.

• Create Virtual Private Clouds(VPC) for the required region. See Getting Started With Amazon
VPC.

• Instantiate the vSRX instance in the required VPC and set the tag identifier, for example
AWS_SDSN_VSRX. This tag identifier must match with the vSRX instance tag key in AWS.

• Create a Security Group in AWS required to create a threat prevention policy for the AWS
connector.

• Deploy workloads in the required VPC and set the resource tags to the workloads.

• For Microsoft Azure connector:

• Get started with Microsoft Azure. See Getting Started With Microsoft Azure.
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• Create tenant ID for you Azure account. See Managing Access Keys for Your Microsoft Azure
Account.

Perform the following actions to configure connectors for the public and private clouds.

To configure threat remediation for a public or private cloud, you must install and register the threat
remediation plug-in with Policy Enforcer as follows:

1. Select Administration > Policy Enforcer > Connectors.

The Connectors page appears.

2. Click the create icon (+).

The Create Connector page appears.

3. Complete the configuration using the information in Table 15 on page 65.

4. Click OK.

NOTE: Once configured, you select the connector name as an Enforcement Point in
your Secure Fabric.

Table 15: Fields on the Create Connector Page for AWS and Contrail

Field Description

General

Name Enter a unique string that must begin with an
alphanumeric character and can include underscores;
no spaces allowed; 63 characters maximum.

Description Enter a description; maximum length is 1024
characters. You should make this description as useful
as possible for all administrators.

Connector Type Select Amazon Web Services, Contrail, or Microsoft
Azure from the list to connect to your secure fabric
and create policies for this network.
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Table 15: Fields on the Create Connector Page for AWS and Contrail (Continued)

Field Description

IP Address/URL Enter the IP (IPv4 or IPv6) address or URL of AWS,
Contrail, or Microsoft Azure.

For AWS, this field is set to www.aws.amazon.com, by
default. This is where all VPCs are located. You cannot
edit this field.

For Microsoft Azure, this field is set to
management.azure.com, by default. This is where all
virtual networks are located. You cannot edit this field.

Port For AWS and Microsoft Azure connectors, the port is
set to 443 by default and you cannot edit this field.

For Contrail connector, provide the port number as
8081.

Username Enter the username of the server for the selected
connector type.

For AWS, enter the generated access key for your
Amazon account. This is not same as your Amazon
account username.

Password Enter the password for the selected connector type.

For AWS, enter your secret password generated along
with your access key. This is not same password as
your amazon account.

Subscription ID

(only for Microsoft Azure connector)

Enter the Azure subscription ID available per tenant
basis.

Tenant ID

(only for Microsoft Azure connector)

Enter the Microsoft Azure tenant ID.

Network Details
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Table 15: Fields on the Create Connector Page for AWS and Contrail (Continued)

Field Description

Connector Type: AWS

Virtual Private Clouds

One or more virtual networks under the AWS account
are discovered. They are called virtual private cloud
(VPC). Only VPCs having vSRX instances deployed are
managed. The VPCs are region specific. Select a region
from the Region list and the corresponding VPCs are
listed. By default, the VPCs for the first available region
are listed.

Security Director suggests a default Secure Fabric site
name for the VPC, in the <connector name>_<vpc
name>_site format. Click the Secure Fabric site name
to edit it. When you edit the name, you will also see
the other Secure Fabric sites that do not have any
switches or connectors assigned to them. You can also
assign these Secure Fabric sites to the connectors. If
the edited site name is already existing with a
connector or a switch, an alert message is shown and
the Secure Fabric site name is reverted to its previous
name.

You must enable either Threat Remediation or Next
Generation Firewall options or both. You cannot create
a connector instance without enabling at least one
option. If you navigate to the next page without
enabling these options, an error message is shown
insisting the user to enable either Threat Remediation
or Next Generation Firewall to proceed further.

You can get a detailed view of the VPC by hovering
over the name and clicking the Detailed View icon. See
Viewing VPC or Projects Details.

NOTE: You can perform search on VPCs. Search is
not supported for the site names.
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Table 15: Fields on the Create Connector Page for AWS and Contrail (Continued)

Field Description

Connector Type: Microsoft Azure

Virtual Networks

One or more virtual networks under the Microsoft
Azure account are discovered. These virtual networks
are based on the Azure subscription per tenant basis. A
tenant can have more than one subscription and a
single subscription can contain one or more virtual
networks.

Security Director suggests a default site name for the
project, in the <connector name>_<virtual network
name>_site format. Click the site name to edit it. When
you edit the site name, you will also see the other sites
that do not have any switches or connectors assigned
to them. You can also assign these sites to the
connectors. If the edited site name is already existing
with a connector or a switch, an alert message is
shown and the site name is reverted to its previous
name.

You must enable either Threat Remediation or Next
Generation Firewall options or both. You cannot create
a connector instance without enabling at least one of
the two options. If you navigate to the next page
without enabling these options, an error message is
shown insisting the user to enable either Threat
Remediation or Next Generation Firewall to proceed
further.

You can get a detailed view of the virtual network by
hovering over the name and clicking the Detailed View
icon.
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Table 15: Fields on the Create Connector Page for AWS and Contrail (Continued)

Field Description

Connector Type: Contrail

Project

Tenant information determined from the Contrail
connector is listed.

Security Director suggests a default site name for the
project, in the <connector name>_<project name>_site
format. Click the site name to edit it. When you edit
the site name, you will also see the other sites that do
not have any switches or connectors assigned to them.
You can also assign these sites to the connectors. If the
edited site name is already existing with a connector or
a switch, an alert message is shown and the site name
is reverted to its previous name.

You must enable either Threat Remediation or Next
Generation Firewall options or both. You cannot create
a connector instance without enabling at least one of
the two options. If you navigate to the next page
without enabling these options, an error message is
shown insisting the user to enable either Threat
Remediation or Next Generation Firewall to proceed
further.

You can get a detailed view of the project by hovering
over the name and clicking the Detailed View icon. See
Viewing VPC or Projects Details.

NOTE: You can perform search on Project names.
Search is not supported for the site names.

Subnets The subnet information for Contrail, Microsoft Azure,
and AWS is determined from the respective systems.
For AWS and Microsoft Azure, subnets are the
availability zones and for Contrail, subnets are virtual
networks. You can create Policy Enforcement Groups
for one or more of the subnets, if threat remediation is
selected.

Subnets for AWS, Microsoft Azure, and Contrail are
allocated to be within the tenant IP Address
Management (IPAM) scheme.
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Table 15: Fields on the Create Connector Page for AWS and Contrail (Continued)

Field Description

Configuration
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Table 15: Fields on the Create Connector Page for AWS and Contrail (Continued)

Field Description

Configuration Metadata

Specifies the resource tag information and the resource
tag values that you have determined from the projects
or VPC. The tag information appears only if the Next
Generation Firewall option is enabled.

For AWS and Microsoft Azure connector, the resource
tag values are fetched from AWS and Microsoft Azure
for all the endpoints and then mapped them to the
Security Director generated metadata names.

Based on the resource tag name, Security Director
checks if a metadata with the same resource tag name
is already available. If available, it automatically maps
the resource tag name to its metadata. If there is no
match found, Security Director suggests a new
metadata name for the corresponding tag. The
suggested metadata name is same as the resource tag
name. You can also edit the suggested metadata name
and customize the resource tag name.

However, in the Generated MetaData Name column,
you cannot use the following predefined metadata
names:

• Tenant

• Provider

• Controller

If you provide these names, an appropriate error
message is shown to choose a different name.

Select the Map option to map the resource tag to the
generated Security Director Metadata while creating
the connector instance. If the Map option is not
selected, the connector instance is created for a
project or VPC without any resource tags. For example,
if you have multiple resource tags for a project, you can
choose one or more resource tags to map to the
corresponding generated metadata, by selecting the
Import option. The project or VPC with the selected
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Table 15: Fields on the Create Connector Page for AWS and Contrail (Continued)

Field Description

resource tags are created when the connector instance
is created.

Mapping of Contrail, Microsoft Azure, and AWS
connector resource tags to Security Director metadata
enables you to create the next generation firewall
policy definitions for the source and destination rules,
based on the metadata expressions. Policy Enforcer
dynamically determines the matching VM instances in
AWS, Microsoft Azure, or Contrail connector to the
metadata expressions and pushes the IP address
content as dynamic address groups to the enforcement
points in the tenant specific vSRX firewall instance.

In the Configuration Value column, provide any
additional information required for this particular
connector connection. For example, if the connector
type is ForeScout CounterACT, you are required to
provide the WebAPI username and password. Similarly
for other connectors if the additional configuration
parameters are required, they are listed in this column.

After the successful completion, the subnet you have
created is mapped to that particular connector
instance.

For AWS and Microsoft Azure, provide the following
configuration parameters:

• SRX username—Specify the username of the vSRX
device that you have instantiated for a VPC or a
virtual network.

• SRX identifier tag—Specify the tag name of the
vSRX device, if the recommended vSRX name was
not used. If you do not specify any value for this
field, Policy Enforcer uses vSRX as a default tag
name to identify the device.

This enables discovery of this particular vSRX
device in Junos Space. This vSRX device is also
added to a specific secure fabric site.
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Table 15: Fields on the Create Connector Page for AWS and Contrail (Continued)

Field Description

• Infected Host Security Group—Specify the security
group name that you would want to tag an infected
workload for threat remediation.

• SRX authentication key—Specify the authentication
key file to access the vSRX device. Editing this in
the grid prompts you to either upload the
authentication key file or view an already existing
uploaded authentication key.

For Contrail, provide the following configuration
parameters:

• SRX username

• SRX password

• Infected host security group

NOTE: 

• For AWS, Microsoft Azure, and Contrail connectors, the site association is achieved in
the Connectors page itself.

• When a connector is added to the site, Policy Enforcer discovers the vSRX Series
associated with the connector and assigns it to the site. Hover over the connector
name to view the corresponding vSRX with its IP address as a tool tip.

• If the mode in PE Setting page is Juniper Connected Security with ATP Cloud, then
you must create ATP Cloud realm and assign the sites associated with the VPC or
Project to the realm. Otherwise the vSRX instances in the VPC or Project does not
download the dynamic address group objects, that is the list of workloads in the VPC
or Project that match a policy metadata expression.

Threat Remediation Workflow

Once you create an AWS, Microsoft Azure, or a Contrail connector with Threat Remediation option, a
site is created in the Secure Fabric page.

Perform the following actions for threat remediation:
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1. Select Configure > Threat Prevention > ATP Cloud Realms.

Select the associated Secure Fabric sites to the respective VPC, virtual networks, or Project that is
successfully added. Add the secure fabric site to a Juniper ATP Cloud realm and enrol the vSRX
devices to the Juniper ATP Cloud. Enroll devices by clicking Add Devices in the list view once the
realm is created.

2. Select Configure > Shared Objects > Policy Enforcement Groups.

Click the add icon to create a new policy enforcement group. You will see a list of all subnets that you
have created in a VPC or virtual network. Select the required subnets for this VPC or a virtual
network and create a policy enforcement group. Associate this policy enforcement group to threat
remediation policy.

3. Select Configure > Threat Prevention > Policies.

Click the add icon to create a new threat prevention policy. Add the threat prevention policy,
including profiles for one or more threat types. The security group that you had selected during
connector configuration is used when the host gets infected within a corresponding VPC or a virtual
network.

Next Generation Firewall Workflow

When you create an AWS, Microsoft Azure, or a contrail connector with Next Generation Firewall
option, it means that for a particular VPC or a virtual network, Layer 7 firewall policy is enabled. Perform
the following actions to enable next generation firewall:

1. Select Configure > Firewall Policy.

2. Select the policy for which you want to define rules and click Add Rule.

The Create Rules page appears.

3. In the General tab, enter the name of the rule and description of the rule

4. In the Source tab, click Select for the Address(es) field to select the source address.

The Source Address page appears.

• In the Address Selection field, click By Metadata Filter option.

• In the Metadata Provider field, select PE as a provider from the list.

• In the Metadata Filter field, all the generated metadatas during the connector configuration are
listed. Using these metadatas, create a required metadata expression. For example, Application =
Web and Tier = App.
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• In the Matched Addresses field, addresses matching the selected metadata are listed. This address
is used as a source address. For every metadata expression, a unique dynamic address group
(DAG) is created.

• Click Ok and complete configuring other parameters for the rule.

• Publish and update the configuration immediately or schedule it later.

RELATED DOCUMENTATION

Policy Enforcer Connector Overview

Editing and Deleting a Connector

Viewing VPC or Projects Details

Creating a Policy Enforcer Connector for Third-Party
Switches

Before You Begin

• Have your ClearPass, Cisco ISE, ForeScout, Pulse Secure server information available.

• To obtain an evaluation copy of ForeScout CounterACT to use with Policy Enforcer, click here.

• Once configure, you select the Connector as an Enforcement Point in your Secure Fabric.

• Review the Policy Enforcer Connector Overview topic.

• To create a connector for a public or a private cloud, see Creating a Policy Enforcer Connector for
Public and Private Clouds.

Perform the following actions to create connectors for the third-party switches.

To configure threat remediation for third-party devices, you must install and register the threat
remediation plug-in with Policy Enforcer as follows:

1. Select Administration > Policy Enforcer > Connectors.

The Connectors page appears.

2. Click the create icon (+).

The Create Connector page appears.

3. Complete the configuration using the information in Table 16 on page 76.
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4. Click OK.

NOTE: Once configured, you select the connector name as an Enforcement Point in
your Secure Fabric.

Table 16: Fields on the Create Connector Page

Field Description

General

Name Enter a unique string that must begin with an
alphanumeric character and can include underscores;
no spaces allowed; 63 characters maximum.

Description Enter a description; maximum length is 1024
characters. You should make this description as useful
as possible for all administrators.

Connector Type Select the required third-party network of devices to
connect to your secure fabric and create policies for
this network. The available connectors are Cisco ISE,
HP ClearPass, Pulse Secure, and ForeScout
CounterACT.

IP Address/URL Enter the IP (IPv4 or IPv6) address of the product
management server.

Port Select the port to be used from the list. When this is
left blank, port 443 is used as the default.
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Table 16: Fields on the Create Connector Page (Continued)

Field Description

Username Enter the username of the server for the selected
connector type.

• ClearPass—Enter the Client ID created while setting
up the ClearPass API client. See ClearPass
Configuration for Third-Party Plug-in for details.

• Cisco ISE—Enter the username you used when you
created the API Client in the Cisco ISE UI. See
Cisco ISE Configuration for Third-Party Plug-in.

• ForeScout—Enter the username of your DEX
plugin. See Integrating ForeScout CounterACT with
Juniper Networks SDSN.

Password Enter the password of the server for the selected
connector type.

• ClearPass—Enter the Client Secret string created
while setting up the ClearPass API client. See
ClearPass Configuration for Third-Party Plug-in for
details.

WARNING: When the Access Token Lifetime
expires, you must generate a new Client Secret
in ClearPass and update it here too.

• Cisco ISE—Enter the password you used when you
created the API Client in the Cisco ISE UI. See
Cisco ISE Configuration for Third-Party Plug-in .

• ForeScout—Enter the password of your DEX plugin.
See Integrating ForeScout CounterACT with
Juniper Networks SDSN.

DEX User Role

(For ForeScout connector type only)

Enter the Data Exchange (DEX) user role information
to authenticate and connect to the ForeScout
connector. See Integrating ForeScout CounterACT with
Juniper Networks SDSN.
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Table 16: Fields on the Create Connector Page (Continued)

Field Description

Network Details

Subnets Connector Type: ClearPass, ForeScout CounterACT,
Pulse Secure, and Cisco ISE

Add subnet information to the connector configuration
so you can include those subnets in groups and then
apply policies to the groups. When using Junos Space,
Policy Enforcer is able to dynamically discover subnets
configured on Juniper switches. Policy Enforcer does
not have the same insight with third-party devices.

When you add subnets as part of the connector
configuration, those subnets become selectable in
Policy Enforcement Groups.

To add subnet information, do one of the following:

• Click Upload File to upload a text file with an IP
address list.

Note that the file you upload must contain only one
item per line (no commas or semi colons). All items
are validated before being added to the list.

OR

• Manually enter the IP addresses. For example:
192.168.0.1/24.

Click the add icon (+) to add more IP addresses.

NOTE: It is mandatory to add at least one IP subnet
to a connector. You cannot proceed to next step
without adding a subnet.

Configuration
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Table 16: Fields on the Create Connector Page (Continued)

Field Description

Configuration Provide any additional information required for this
particular connector connection. After the successful
completion, the subnet you have created is mapped to
that particular connector instance.

NOTE: For ClearPass and Cisco ISE connectors no
additional configuration information are required.

NOTE: 

• You can associate ClearPass, Cisco ISE, Pulse Secure, or Forescout connector to a site
only in your Secure Fabric.

• When a connector is added to the site, Policy Enforcer discovers the vSRX Series
associated with the connector and assigns it to the site. Hover over the connector
name to view the corresponding vSRX with its IP address as a tool tip.

WARNING: Ensure that the correct credentials are provided for the ClearPass, Cisco ISE,
Pulse Secure, and ForeScout identity servers. If the initial connection fails, an error
message is shown only at that time. Once that message disappears, the status of
connectivity to the identity server is not shown in Policy Enforcer. Note that the identity
servers are only queried on-demand.

RELATED DOCUMENTATION

Policy Enforcer Connector Overview

ClearPass Configuration for Third-Party Plug-in

Cisco ISE Configuration for Third-Party Plug-in

Editing and Deleting a Connector

Viewing VPC or Projects Details
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Editing and Deleting a Connector

IN THIS SECTION

Editing a Connector  |  80

Deleting a Connector  |  81

You can edit or delete a connector from the Connector page.

Editing a Connector

To edit a connector:

1. Select Administration > Policy Enforcer > Connectors.

The Connectors page appears.

2. Select the connector you want to edit , and then click the pencil icon.

The Edit Connector page appears displaying the same options that were used to create a new
connector. Note that you cannot edit the Name and IP Address/URL fields.

For the AWS connector, when you select a new region, you must enter the configuration parameters
for the VPCs in that region. This enables you to maintain different vSRX authentication keys across
different regions.

For AWS and Contrail connectors, you can enable or disable the threat remediation and next
generation firewall features. If you disable the next generation firewall feature from a project or VPC,
that particular project or VPC connector instance will be deleted. The VPCs are deleted from the
corresponding regions.

A warning message is shown if you edit the existing generated metadata name. If you edit the
existing metadata name, duplicate metadata objects are created that are associated to a firewall
policy. To edit the metadata name, select Configure > Shared Objects > Object Metadata and edit the
required metadata name. Also if the firewall policies are associated with this metadata, select
Configure > Firewall Policy > Policies and edit the corresponding metadata expression.

To delete the mapping of the tag name with the generated metadata, disable the Map option for the
corresponding project or VPC. A warning message is shown that there could be a firewall policy
associated with this metadata. Select Configure > Firewall Policy > Policies and edit the
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corresponding metadata expression. The mapping is deleted at the end of the edit workflow. You can
also enable the Import option for the tags that were not mapped to the generated metadata while
creating the connector.

3. Modify the required field values and click Save to save your changes.

If you discover a new connector instance, you can enable the threat remediation or next generation
firewall option. A new site is created when you enable one of these options. You must add these new
sites to a realm to perform the threat remediation. At the end of the edit connector workflow, a
reminder message is shown to add the sites to a realm.

NOTE: 

• During the AWS connector editing, if you change the region, changes that you have
made in the current session are discarded. An alert message is shown when you
change the region.

• During the ClearPass or Cisco ISE connector editing, you cannot delete subnets that
are already assigned to a policy enforcement group. However, you can add of any
new subnets and edit their descriptions.

Deleting a Connector

To delete a connector:

1. Select Administration > Policy Enforcer > Connectors.

The Connectors page appears.

2. Select the connector that you want to delete, and select the delete icon (X).

Deleting a connector deletes the connector instances and its references as well. A warning message
is shown listing all the connector instances that will be deleted, before deleting the connector.

3. Click Delete to delete your selection.

If the connector instances that you want to delete has PEG assigned, a warning message is shown to
unassign the subnets from PEG first and then delete the connector, as shown in Figure 22 on page 82.
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Figure 22: Deletion Failed Warning

For AWS and Contrail connectors, if there are connector instances with PEG assigned, only those
connector instances are not deleted. However, other connector instances without PEG assigned are
deleted.

NOTE: 

• You cannot delete the ClearPass or Cisco ISE connector if its subnets are assigned to
a policy enforcement group. You must unassign those subnets from that particular
policy enforcement group and then delete the connector.

• You cannot delete a connector if it is assigned as an enforcement point to a site.
Before deleting a connector, you must unassign it from the site on Secure Fabric.

RELATED DOCUMENTATION

Policy Enforcer Connector Overview

Creating a Policy Enforcer Connector for Third-Party Switches

Viewing VPC or Projects Details

To view the complete details of a VPC or a project:

1. Select Administration > Policy Enforcer > Connectors.

The Connectors page appears.

2. Select the connector you want to edit , and then click the pencil icon.

82



The Edit Connector page appears displaying the same options that were used to create a new
connector.

3. In the Network Details section, get a detailed view by hovering over the VPC or project name and
click the Detailed View icon before the VPC or project name.

The Detailed View page appears, as shown in Figure 23 on page 83.

Figure 23: Detailed View Page

Table 17 on page 83 explains fields on the Detailed View page.

Table 17: Fields on the Detailed View Page

Field Description

Name Specifies name of a VPC or project.

Secure Fabric Specifies the site to which the VPC or project s allocated.

Type/Zone Specifies the connector type. For example, virtual network for Contrails and AvailabilityZone for
AWS.

IPAM Subnet Specifies the IP Address Management (IPAM) subnets allocated to the respective VPC or
project.
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Table 17: Fields on the Detailed View Page (Continued)

Field Description

Group Subnets Specifies the group of subnets allocated to the VPC or project.

For Contrail, you will see a key value of Tier. For example, the group is called web and assigned
subnet is x.x.x.x/xx. For AWS, you will see only the group of subnets.

For Contrail, they are still group of subnets. However, each of the subnets are allocated to a tag,
for example, database, tier, application, and so on.

RELATED DOCUMENTATION

Creating a Policy Enforcer Connector for Third-Party Switches

Editing and Deleting a Connector

Integrating ForeScout CounterACT with Juniper
Networks Connected Security

IN THIS SECTION

Configuring the DEX Plug-in  |  85

Configuring the Web API Plug-in  |  89

Creating ForeScout CounterACT Connector in Security Director  |  91

This topic provides instructions on how to integrate the third-party device ForeScout CounterACT with
Juniper Networks Connected Security solution to remediate threats from infected hosts for enterprises.
ForeScout CounterACT is an agentless security appliance that dynamically identifies and evaluates
network endpoints and applications the instant they connect to your network. CounterACT applies an
agentless approach and integrates with Juniper Connected Security to block or quarantine infected
hosts on Juniper Networks’ devices, third-party switches, and wireless access controllers with or without
802.1x protocol integration.

84



To integrate ForeScout CounterACT with Juniper Connected Security, you must create a connector in
Policy Enforcer that enables CounterACT to connect to your secure fabric and create policies for
CounterACT. Before you configure the ForeScout CounterACT connector, you must ensure that
ForeScout CounterACT is installed and running with the Open Integration Module (OIM). The ForeScout
OIM consists of two plug-ins: Data Exchange (DEX) and Web API. Install both the plug-ins and ensure
that they are running. You must configure these plug-ins before you create a connector in Policy
Enforcer.

If you do not have ForeScout CounterACT installed in your network, obtain an evaluation copy from
here.

This topic includes the following sections:

Configuring the DEX Plug-in

The DEX plug-in receives API information about infected hosts from the ForeScout CounterACT
connector. Messages from infected hosts are either blocked or quarantined.

When you configure the DEX plug-in, you also configure a new property, Test, for DEX. When
configured, this property ensures that Web services are available for Policy Enforcer, monitors the
network status, and validates usernames and passwords.

To configure the DEX plug-in:

1. Select Tools > Options > Data Exchange (DEX) in the CounterACT UI.

The Data Exchange configuration page appears.

2. On the Data Exchange (DEX) page, select the CounterACT Web Services > Accounts tab, as shown
in Figure 24 on page 86.

The DEX Accounts page appears.
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Figure 24: DEX Accounts Page

3. Select Add.

The Add page appears.

4. In the Name field, enter the name for the CounterACT Web service account.

Enter this name in the DEX User Role field (see Step 3) while configuring the ForeScout connector
in Security Director.

5. In the Description field, enter a brief description of the purpose of the Web service account.

6. In the Username field, enter the username that will be used to authorize CounterACT to access the
Web service account.

7. In the Password field, enter the password that will be used to authorize CounterACT to access this
Web service account.

8. Click OK.

9. In the Properties tab, click Add.

The General pane of the Add Property from CounterACT Web Service wizard opens, as shown in
Figure 25 on page 87.
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Figure 25: Add Property-General Pane Page

10. Add properties such as block, quarantine, and Test, as shown in Figure 26 on page 88.

You must include the Test property. Otherwise, you cannot add CounterACT as a third-party
connector to Policy Enforcer successfully.
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Figure 26: DEX Properties Page

11. In the Security Settings tab, click Add and add the IP address range from where communication is
expected, as shown in Figure 27 on page 88.

Figure 27: Add IP Range Page

Click OK. The IP address appears in the IP Address Range list, as shown in Figure 28 on page 89.
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Figure 28: DEX Security Settings Page

12. On the Data Exchange (DEX) page, click Apply.

The configuration is saved and the configuration settings are applied.

Configuring the Web API Plug-in

The Web API plug-in enables external entities to communicate with CounterACT by using simple, yet
powerful Web service requests based on HTTP interaction. You configure the Web API plug-in to create
an account for Policy Enforcer integration.

To configure the Web API plug-in:

1. Select Tools > Options > Web API in the CounterACT UI.

The Web API page appears.

2. In the User Settings tab, select Add.

The Add Credentials page appears.

3. Use the same username and password that you created for the DEX configuration (see Step 6 and
Step 7) and click OK, as shown in Figure 29 on page 90.
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Figure 29: Web API User Settings Page

4. Select the Client IPs tab and click Add.

Add the Policy Enforcer IP address into the access list.

5. Click OK.

The IP address appears in the IP Address Range list, as shown in Figure 30 on page 90.

Figure 30: Web API Client IPs Page
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6. Click Apply to save and apply your configuration.

Creating ForeScout CounterACT Connector in Security Director

After you configure the DEX and Web API plug-ins, you need to create a connector for ForeScout
CounterACT in Policy Enforcer.

To create a ForeScout CounterACT connector in Junos Space Security Director:

1. Select Security Director > Administration > Policy Enforcer > Connectors.

The Connectors page appears.

2. Click the create icon (+).

The Create Connector page appears.

3. In the General tab, select ForeScout CounterACT as the connector type and provide the username,
DEX user role, and password, as shown in Figure 31 on page 91. ( The DEX user role is the one that
you created in Step 4).

Specify 443 as the port number for communication.

Figure 31: Edit Connector Page

4. In the Network Details tab, configure the IP subnets, as shown in Figure 32 on page 92.

CounterACT treats the IP subnets as endpoints and takes action.
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Figure 32: Edit Connector - Network Details Page

5. In the Configuration tab, specify the Web API username and password, as shown in Figure 33 on
page 93.
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Figure 33: ForeScout Connector - Configuration Tab

6. Click Finish.

A new ForeScout CounterACT connector is created.

7. Verify that the communication between Policy Enforcer and CounterACT is working.

After installing ForeScout CounterACT and configuring a connector, in the CounterACT UI, create
policies for CounterACT to take the necessary action on the infected hosts. The Hosts page lists
compromised hosts and their associated threat levels, as shown in Figure 34 on page 94.
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Figure 34: Host Information

Table 18 on page 94 shows the recommended actions performed by CounterACT on the infected hosts
that are blocked or quarantined.

Table 18: Recommended Action to Be Performed on the Infected Hosts

Infected Host Policy
Enforcer Action

Connection State Action Performed by CounterACT

Blocked Wired Apply access control list (ACL) to block inbound and outbound
traffic for a specific MAC address.

Wireless Apply WLAN block on the endpoint, which will block the traffic
based on the wireless MAC address.

Dot1x Apply CoA.

Quarantined Wired Apply VLAN. This action is specified by Policy Enforcer.

Wireless Apply VLAN. This action is specified by Policy Enforcer.
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RELATED DOCUMENTATION

Policy Enforcer Connector Overview

Creating a Policy Enforcer Connector for Third-Party Switches

ClearPass Configuration for Third-Party Plug-in

On ClearPass you will configure the following:

• API Client

• Custom Attribute

• Enforcement Profiles

• Enforcement Policy

Policy Enforcer's ClearPass Connector communicates with the Clearpass Radius server using the
Clearpass API. As part of threat remediation, Policy Enforcer's Clearpass Connector uses enforcement
profiles. This section provides information for configuring Clearpass so that Policy Enforcer can invoke
the appropriate enforcement profiles.

As part of the configuration, on ClearPass you will create two enforcement profiles, one for quarantine
and one for terminate. Then you will use them in the ClearPass enforcement policy. Once ClearPass is
configured, you will configure a ClearPass Connector on Policy Enforcer.

NOTE: 

• Always use a third-party switch that supports 802.1x, Radius CoA, Radius
Accounting, and DHCP snooping features. Enabling DHCP snooping is important
which configures the Radius attribute, Framed-IP-Address. Only after configuring
Framed-IP-Address, Policy Enforcer can detect the session related to the infected-
host IP addresses and terminate the session.

• The stale sessions in ClearPass cannot be terminated and therefore, the actual East-
West traffic block will not be active until you reauthenticate the session. You must
ensure to clear the stale sessions in ClearPass frequently.

To configure the API Client:

1. In ClearPass, navigate to Administration > API Services > API Clients and create a client with the
following attributes:
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NOTE: You must login as ClearPass Guest to see the API services menu.

• Client ID: sdsnclient

• Enabled: Select the check box for Enable API client

• Operator Profile: Create a profile from Administrator > Operator Logins > Profiles for the API
client with minimum access privileges as shown in Figure 35 on page 96.

Figure 35: ClearPass API Client Operator Profile Minimum Privileges

• Grant Type: Select Client credentials (grant_type = client_credentials)

• Client Secret: Copy and save this. It will not be shown again.

• Access Token Lifetime: Enter 5 minutes as a time-frame.
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Figure 36: ClearPass Edit API Client

2. Click Save Changes.

To configure a Custom Attribute:

1. Select ClearPass Policy Manager and navigate to Administration > Dictionaries > Attributes to create
a custom attribute. Then add it into the Dictionary: sdsnEpStatus. Enter the following:

• Entity Type: Endpoint

• Name: sdsnEpStatus (Note that you must use this name - sdsnEpStatus)

• Data Type: List

• Is Mandatory: Yes

• Allowed Values: healthy, blocked, quarantine

• Default Value: healthy
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Figure 37: ClearPass Edit Attribute

2. Click Save.

To configure Enforcement Profiles:

1. In ClearPass, navigate to Configuration > Enforcement > Profiles and create two enforcement
profiles.

2. Profile 1: Create the following profile to quarantine infected endpoints:

• Name: Name of the enforcement profile

• Description: Quarantine profile for Juniper Connected Security

• Type: RADIUS

• Action: Accept
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Figure 38: ClearPass Enforcement Profile: Quarantine

NOTE: The data displayed at the bottom of the screen is for example and not for
configuration purposes. Note that the 4th attribute can be set for the accounting
packets to be sent by the NAS device to the Clearpass Radius server.

3. Profile 2: Create the following profile to block infected endpoints:

NOTE: To configure this profile, copy the default system profile Juniper Terminate
Session and edit the profile name and attributes.

• Name: JNPR SDSN Terminate Session

• Description: Block profile for SDSN

• Type: RADIUS_CoA

• Action: Disconnect

NOTE: If there are any vendor-specific additional attributes required for the Terminate
COA, those needs to be added here. For example, in the case of Juniper Networks
Trapeze Wireless Clients, the JNPR SDSN Terminate Session profile requires two
additional attributes: NAS-IP-Address and User-Name.
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Figure 39: ClearPass Enforcement Profile: Terminate

Configure an Enforcement Policy:

In ClearPass, navigate to Configuration > Enforcement > Policies. Both profiles you created must be
added to all the enforcement policies for endpoints addressed by Policy Enforcer.

Figure 40: ClearPass Enforcement Policy

NOTE: Rules Evaluation should be set to "First applicable."
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NOTE: Make sure the default termination enforcement profile for each of the supported
vendors is not superseded by any of its enforcement profile copies. Also make sure that
all the attributes required for termination are set in the profile. (As in the previous
Juniper Networks Trapeze Wireless Clients example.)

Enable Insight:

1. In ClearPass, navigate to Administration > Server Manager > Server Configuration for the server in
use.

2. Enable Insight in the System tab.

Set the Log accounting Interim-update Packets as TRUE:

1. In ClearPass, navigate to Administration > Server Manager > Server Configuration for the server in
use.

2. Select the Service Parameters tab.

3. In the Select Service drop down list, select Radius Server and set the Log accounting Interim-update
Packets as TRUE.

4. Proceed to Creating a Policy Enforcer Connector for Third-Party Switches to finish the configuration
with Policy Enforcer.

RELATED DOCUMENTATION

Creating a Policy Enforcer Connector for Third-Party Switches

Policy Enforcer Connector Overview

Cisco ISE Configuration for Third-Party Plug-in

Policy Enforcer's Cisco ISE Connector communicates with the Cisco Identity Services Engine server
using the Cisco ISE API. As part of threat remediation, Policy Enforcer's Connector uses enforcement
profiles. This section provides information for configuring Cisco ISE so that Policy Enforcer can invoke
the appropriate enforcement profiles.

As part of the configuration, on Cisco ISE you will create two enforcement profiles, one for quarantine
and one for terminate. Then you will use them in the Cisco ISE enforcement policy. Once Cisco ISE is
configured, you will configure a Cisco ISE Connector on Policy Enforcer.
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On Cisco ISE you will configure the following:

• Change policy modes

• Create an API client

• Configure network profiles

• Add a custom attribute

• Configure authorization profiles

• Set an authorization policy

On Cisco ISE, the Simple Mode policy model is selected by default. For creating an API client, Policy Sets
should be enabled.

• Navigate to Administration > System > Settings > Policy Sets and Enable Policy Sets mode.

You are prompted to login again after changing the mode.

Figure 41: Cisco ISE: Enable Policy Sets Mode

Create an API Client:

1. Using the Cisco ISE web UI, create an Admin User by navigating to Administration > System > Admin
Access > Administrator > Admin User.

2. Create an Admin User and assign it to the following Admin Groups: ERS Admin, MnT Admin.

Make note of the username and password. You will need them when you configure the connector
portion in Policy Enforcer later on.
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Figure 42: Cisco ISE: Create Admin User and Assign to Admin Groups

Enable the External RESTful Services API (ERS) for the Administration Node:

1. Navigate to Administration > System > Settings >ERS Settings and select Enable ERS for Read/Write.

2. Click Save.

Figure 43: Cisco ISE: Enable ERS

Configure network profiles:

Devices managed by ISE must support RADIUS CoA and have the proper network profiles assigned to
handle the CoA commands sent by the ISE server:
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1. Navigate to Administration > Network Resources > Network Device Profiles and verify the existing
network device profile list.

If you are creating a new profile, proceed to the next step for information.

Figure 44: Cisco ISE: Network Device Profiles List

2. If you are configuring a new profile, you must minimally set the following:

• Enable RADIUS and add a corresponding dictionary in the supported protocol list.

Figure 45: Cisco ISE: Network Device Profile, Enable RADIUS
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• Enable and configure the Change of Authorization (CoA) according to the figure below.

Figure 46: Cisco ISE: Configure Change of Authorization (CoA)

• Configure the Disconnection and Re-authenticate operation with the proper RADIUS attributes
and vendor specific VSA to handle the standard disconnect and reauthenticate operations. Below
is the sample configuration for Juniper’s EX devices.
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Figure 47: Sample Configuration for Juniper EX

Configure a custom attribute.

1. Navigate to Administration > Identity Management > Settings > Endpoint Custom Attribute and add
attribute sdsnEpStatus with type string.
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Figure 48: Cisco ISE: Add Attribute sdsnEpStatus

2. Verify the attribute under Policy > Policy Elements > Dictionaries > System > Endpoints.

Figure 49: Cisco ISE: Verify Attribute
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3. Navigate to Policy > Policy Elements > Conditions > Authorization > Simple Conditions. Add there
authorization simple conditions using the sdsnEpStatus attribute you created.

In the screen below,, there are three conditions created using sdsnEpStatus attribute. The condition
names do not need to be the same as in the screen here, but the expressions must be matched.
These conditions will be used in Policy Sets to handle the threat remediation for managed endpoints
as described later in the Policy Sets setting section. Only the sdsnEpStatus-blocked and
sdsnEpStatus-quarantine conditions will be used there. sdsnEpStatus-healthy is created for
fulfillment purpose and can be ignored for now.

Figure 50: Cisco ISE: Configure Simple Conditions, Match Expression
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Figure 51: Cisco ISE: Configure Simple Conditions, Match Expression

Configure permission/authorization profiles.

You can create the authorization profiles corresponding to “block” and “quarantine” actions as fits your
needs. In the sample configuration provided here, the block action will result as total denial access to the
network, and the quarantine profile will move the endpoint to another designated VLAN.

1. Navigate to From Policy > Policy Elements > Results > Authorization > Authorization Profiles.

Refer to the figures below for sample configurations.

Figure 52: Cisco ISE: Configure Authorization Profiles
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Figure 53: Cisco ISE: Configure Authorization Profiles

NOTE: For blocking a host, the default ‘DenyAccess’ profile is used.

Set the authorization policy:

1. Create two rules as Local Exceptions, applying the conditions and authorization/permission profiles
we created in the previous step. Names may be different, but these two rules must be at the top of
the Exception list.

Refer to the figure below for a sample configuration.
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Figure 54: Cisco ISE: Local Exception Rules, Example

NOTE: Find this under Policy > Policy Sets > Authorization Policy.

2. Proceed to Creating a Policy Enforcer Connector for Third-Party Switches to finish the configuration
with Policy Enforcer.

RELATED DOCUMENTATION

Creating a Policy Enforcer Connector for Third-Party Switches

Policy Enforcer Connector Overview
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Integrating Pulse Policy Secure with Juniper
Networks Connected Security
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Overview

IN THIS SECTION

Benefits of the Pulse Policy Secure Integration with Juniper Connected Security  |  113

This topic provides instructions on how to integrate the third-party device Pulse Policy Secure (PPS)
with Juniper Networks Connected Security solution to remediate threats from infected hosts for
enterprises. The Juniper Connected Security solution provides end-to-end network visibility that
enables enterprises to secure their entire physical and virtual networks. PPS provides visibility into the
network by detecting and continuously monitoring the network. Using the threat detection and policy
enforcement, the PPS and Juniper Connected Security solution automates the network security and
supports centralised management, in a multi-vendor environment.

PPS integrates with Juniper Networks Connected Security solution through RESTful APIs and takes
appropriate action based on the admission control policies. The PPS integration with Juniper Connected
Security solution detects and enforces threat prevention policies and provides a collaborative and
comprehensive approach towards complete network security. It enables users to leverage the existing
trusted threat feed sources to provide a consistent and automated defense across diverse environments.
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Benefits of the Pulse Policy Secure Integration with Juniper Connected Security

• PPS has more visibility of endpoints connected to the network.

• Based on the threat alerts received from Juniper Connected Security, PPS enhances the security by
isolating or acting at the endpoint level.

Deployment of Pulse Policy Secure with Juniper Connected Security

The following high level workflow describes the deployment of PPS with Juniper Connected Security.
PPS receives the threat alert information from Juniper Connected Security solution and takes an action
on the endpoint based on the admission control policies.

1. User successfully authenticates with the PPS server.

2. User downloads a file from the Internet. The perimeter firewall (SRX Series device) scans the file and
based on the user-defined policies, sends the scanned file to Juniper ATP Cloud for analysis.

3. Juniper ATP Cloud detects that the file contains malware, identifies the endpoint as an infected host,
and notifies the SRX Series device and Policy Enforcer.

4. Policy Enforcer downloads the infected host feed and sends a threat action to PPS.

5. The PPS server quarantines or blocks the endpoint.

PPS tracks the infected host and does not allow the infected host to acquire full access until the
endpoint is disinfected. When the host is disinfected and cleared from Juniper ATP Cloud or Policy
Enforcer, PPS receives a clear event from the Policy Enforcer connector. After receiving the clear
event, PPS removes the infected host. The host is now authenticated and an appropriate role is
assigned to it.

Configuring Pulse Policy Secure with Juniper Connected Security

IN THIS SECTION

Admission Control Template  |  118

Admission Control Policies  |  118

Admission Control Client  |  121
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The network security devices are configured with PPS for admission access control.

A high-level overview of the configuration steps required to set up and run the integration is described
below:

1. The administrator configures the basic PPS configurations such as creating an authentication server,
authenticating realm, user roles, and role mapping rules. To know more about configuring your PPS,
see Pulse Policy Secure Administration Guide.

2. Configure Policy Enforcer as a client in PPS. PPS acts as a RESTful API server for Policy Enforcer.

The RESTful API access for the admin user must be enabled by accessing the serial console or
alternatively from the PPS admin user interface (UI). Select Authentication>Auth
Server>Administrators>Users. Click Admin and enable the Allow access to REST APIs option.

3. Configure PPS to block or quarantine the endpoint based on the threat prevention policy.

You must configure the admission control client to obtain the Policy Enforcer IP address that sends
events to PPS and admission control policy to understand the PPS event types such as, events-block-
endpoint, quarantine-endpoint, clear-blocked-endpoint, and clear-quarantine-endpoint.

4. Configure the Switches or WLC as RADIUS Client in PPS by selecting Endpoint Policy>Network
Access>Radius Clients>New Radius Client. The switch is configured with PPS as a RADIUS server.

5. Configure RADIUS return attribute policies, to define the action upon receiving the quarantine event.

• Quarantine using VLANs:

The PPS determines which quarantine VLAN to send to RADIUS Client when a quarantine-
endpoint event is received, as shown in Figure 55 on page 115.
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Figure 55: RADIUS Return Attributes for Quarantine-Host

• Quarantine using ACLs:

For environments that has flat VLAN, the PPS provides the ability to quarantine users by applying
a preconfigured firewall filter. Also, this is a preferred method in environments that use static IP
address assignment for end devices.

The following example shows the firewall filter configuration on the switch. The firewall filter
name is then passed on as RADIUS return attribute, as shown in Figure 56 on page 117.

Configure the PERMIT-PULSE-ONLY and PERMIT-ALL firewall filters on the switch using the
following commands:
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set firewall family ethernet-switching filter PERMIT-PULSE-ONLY term pps from destination-address
10.92.81.113/32

set firewall family ethernet-switching filter PERMIT-PULSE-ONLY term pps then accept

set firewall family ethernet-switching filter PERMIT-PULSE-ONLY term dhcp_allow from destination-port 67

set firewall family ethernet-switching filter PERMIT-PULSE-ONLY term dhcp_allow then accept

set firewall family ethernet-switching filter PERMIT-PULSE-ONLY term pps-discard then discard

deactivate firewall family ethernet-switching filter PERMIT-PULSE-ONLY

set firewall family ethernet-switching filter PERMIT-ALL term ALLOW-ALL from destination-address 0.0.0.0/0

set firewall family ethernet-switching filter PERMIT-ALL term ALLOW-ALL then accept

deactivate firewall family ethernet-switching filter PERMIT-ALL

To assign these filters in PPS, select Endpoint Policy>Network Access>Radius Attributes>Return
Attributes.
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Figure 56: RADIUS Return Attributes for Clear-Quarantine

NOTE: 

• Ensure that PPS has the endpoint IP address for the enforcement to work correctly.

• Since the endpoint IP address is mandatory, deployments where the user is behind a
NAT might not work as expected. This is because PPS might have the actual IP
address, and Juniper Connected Security might send the NATed IP address.

117



• To receive the endpoint IP address (accounting information) by PPS, you must use the
Pulse Secure client on endpoints when they are connected to EX4300 Series
switches.

Admission Control Template

The admission control template provides a list of possible events that can be received from the network
security device along with the regular expression to parse the message. The template also provides
possible actions that can be taken for an event.

PPS is loaded with default templates for Policy Enforcer. The administrators can create templates for
other security devices and upload those templates.

To view the admission control templates, select Endpoint Policy>Admission Control>Templates, as
shown in Figure 57 on page 118. You can view the list of configured integration templates with the list
of network security devices and the supported protocol types.

Figure 57: Pulse Secure Templates Page

Admission Control Policies

The admission control policies define the list of actions to be performed on PPS for the user sessions.
The actions are based on the event and the severity of the information received from the network
security device.

To view and add the new integration policy:
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1. Select Endpoint Policy>Admission Control>Policies.

2. Click New Policy.

The New Policy page appears, as shown in Figure 58 on page 119.

Figure 58: Pulse Secure - New Policy Page

3. Enter the policy name.

4. Select Juniper Networks Policy Enforcer as a template.

5. In the Rule on receiving section, select one of the following event types and the severity level. The
event types and the severity level are based on the selected template.

The following event types are supported on sessions:

• Block-endpoint—Blocks the host MAC Address on the PPS permanently. If the administrator
chooses to clear the blocked endpoint, it can be cleared either by using the Junos Space Security
Director application or by using the PPS Administration UI.

• Quarantine-endpoint (Change user roles)—Changes the roles assigned to the user on PPS so that
restrictions or privileges for the user can be changed. The administrator can choose to apply these
roles permanently or temporarily. If it is permanent, system is directly quarantined regardless of
which network it connects to.

• Clear Blocked Endpoint—Clears a previously blocked MAC Address.

• Clear Quarantined Endpoint—Clears a previously quarantined MAC Address.

6. In the then perform this action section, select the following desired action:
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• Select a role and assign it to the endpoint to put that endpoint into a quarantine network.

• In the Make this role assignment option, specify the following actions:

• Permanent—To apply the role assignment permanently. This is the recommended option.
Choose this option for the action to persist.

• For this session only—To apply the role assignment only for the current session.

7. In the Roles section, specify the following options:

• Policy applies to ALL roles—To apply the policy to all users.

• Policy applies to SELECTED roles—To apply this policy only to users who are mapped to roles in
the Selected roles list. You must add roles to this list from the Available roles list.

• Policy applies to all roles OTHER THAN those selected below—To apply this policy to all users
except for those who are mapped to the roles in the Selected roles list. You must add roles to this
list from the Available roles list.

NOTE: These options are applicable to both quarantine and block actions.

8. Click Save changes.

Once the policy is created, you can see the summary page. Figure 59 on page 120 shows the different
policies created for different events with different user roles.

Figure 59: Pulse Secure - Policies Configure Page
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Admission Control Client

The admission control clients are the network security devices on which the syslog forwarding is
enabled. The messages are received by the syslog server module running on PPS.

To add a client:

1. Select Endpoint Policy>Admission Control>Clients.

2. Click New Client.

The New Client page appears, as shown in Figure 60 on page 121.

Figure 60: Pulse Secure - New Client Page

3. Enter the name of the Juniper Networks Policy Enforcer. This is added as a client in the PPS.

4. Enter the description.

5. Enter the IP address of the client.

6. Select the template used by the client: JuniperNerworks-Policy Enforcer-HTTP-JSON.

7. Click Save Changes.

Policy Enforcer is added a new client in the PPS.
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Creating Pulse Policy Secure Connector in Security Director

Once you add Policy Enforcer as a client in PPS, create a connector for PPS to configure the Juniper
Connected Security to send the event information.

To create a connector for PPS and configure Juniper Connected Security using Security Director:

1. Select Security Director>Administration>Policy Enforcer>Connectors.

The Connectors page appears.

2. Click the create icon (+).

The Create Connector page appears, as shown in Figure 61 on page 122.

Figure 61: Create Connector Page

3. In the General tab, select Pulse Policy Secure in the ConnectorType list.

4. In the IP Address/URL field, enter the IP address of PPS.

5. Retain the default port number as 443.

6. Enter the username and password of PPS.

Note that you must have enabled the REST API access on PPS (Authentication > Auth Server >
Administrators > Users > click “admin”, enable Allow access to REST APIs).

7. Click Next.

8. In the Network Details section, configure the IP subnets, as shown in Figure 62 on page 123.
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Figure 62: Create Connector Network Details Page

9. In the Configuration tab, provide any additional information required for this specific connector
connection.

10. Click Finish.

Once the configuration is successful the following page is displayed, as shown in Figure 63 on page
123.

Figure 63: Connectors Page

11. Verify that the communication between Policy Enforcer and PPS is working.

After installing PPS and configuring a connector, in the PPS UI, create policies for PPS to take the
necessary action on the infected hosts.
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Troubleshooting

The following troubleshooting logs are available:

• To verify the event logs on PPS, select System>Log/Monitoring>Events.

You can verify that the event logs are generated every time when an event is received from Policy
Enforcer, as shown in Figure 64 on page 124.

Figure 64: Pulse Secure Events Page

• To verify the user login related logs such as realm, roles, username, and IP address, select
System>Logs & Monitoring>User Access.

• To verify the reports, select System>Reports>Infected Hosts.

You can verify whether the quarantined or blocked host is listed in the Infected Devices report. This
report lists the MAC address, IP address, and the device status, as shown in Figure 65 on page 125.
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Figure 65: Infected Hosts Reports Page

• To enable the debug logs for troubleshooting, select
Maintenance>Troubleshooting>Monitoring>Debug Log, as shown in Figure 66 on page 125.

Figure 66: Debug Log Monitoring Page

• To troubleshoot any issues on the Policy Enforcer, download and verify the Policy Enforcer logs from
Security Director>Administration>Policy Enforcer>Settings page, as shown in Figure 67 on page 126.
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Figure 67: Policy Enforcer Settings Page

• The administrators can also verify the Hosts table from Juniper ATP Cloud to check the status of the
host, as shown in Figure 68 on page 126.

You can clear the host entry if the State Of Investigation field value is Resolved-Fixed.

Figure 68: Juniper ATP Cloud Hosts Page
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Policy Enforcer Backup and Restore

IN THIS SECTION

Backing-Up Policy Enforcer  |  129

Restoring Policy Enforcer from a Backup File  |  131

Policy Enforcer provides the option of backing-up all Policy Enforcer configuration and storing it as a .tar
file. In the event of any unforeseen circumstances such as a malicious attack or system failure you can
use the backup file to restore Policy Enforcer to a previously saved configuration. You can also take a
backup before you change some configuration in Policy Enforcer, and revert to the backed up
configuration, if needed. You can take multiple backups and choose to restore the Policy Enforcer
configuration from any of these backup files.

Policy Enforcer backup includes Policy Enforcer configurations such as .yml files, databases or
sequences, and device configurations. Policy Enforcer also communicates with multiple components to
obtain information, as shown in Figure 69 on page 128.
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Figure 69: Policy Enforcer Communication with Multiple Components

Policy Enforcer communicates with:

• Juniper ATP Cloud/ ATP Appliance for feeds

• Security Director for profiles and configurations

• Junos Space Network Management Platform and Security Director to discover network connectivity
like endhosts

• Connectors to connect to AWS, Azure, ClearPass, Contrail, PulseSecure, and Forescout

Policy Enforcer backup includes the backup of all these configurations and dependencies. When you
backup Policy Enforcer, both Policy Enforcer and Security Director configurations are backed up.

NOTE: Policy Enforcer backup does not include feed data.
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Backing-Up Policy Enforcer

Before You Begin

You must be aware of the following before you initiate a Policy Enforcer backup:

• When you initiate a backup/restore, Policy Enforcer goes into maintenance mode and will be
unresponsive until the backup/restore process is complete. Ensure that you complete all the tasks
with Policy Enforcer before you start the backup/restore process.

• If you are saving the backup .tar file on a remote server, ensure that there is enough space for the file
on that server.

• Ensure that Policy Enforcer and Security Director backups are taken and restored at the same time to
prevent unexpected application behavior.

• Ensure Policy Enforcer and connected Junos Space Security Director database backups are taken at
the same time and no changes are made when backups are happening.

To take a backup of Policy Enforcer:

1. Select Administration > Policy Enforcer > Backup and Restore.

The Backup and Restore page appears.

2. Click Backup on the top-right corner of the page.

The Backup page appears.

3. Complete the configuration using the information in Table 19 on page 130.

4. Click OK.

A job is created to execute the backup process. To see the progress of the backup, go to the Job
Management page.

NOTE: Policy Enforcer will be in maintenance mode and will be unavailable till the
backup process is complete.

After the backup process is complete, the backup .tar file is listed on the Backup and Restore page.
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Table 19: Fields on the Backup Page

Field Description

Server Type Select whether you want to save the backup .tar file to
a local server or to a remote server.

• Local—Saves the backup .tar file locally in the /opt/
policyEnforcer/feeder/backup folder.

• Remote—Saves the backup .tar file in the device
that you specify in the IP Address field.

Description Enter a description; maximum length is 1024
characters. Make this description as useful as possible
for everyone.

Username Enter the username of the remote server where you
want to save the backup .tar file.

Password Enter the password for the selected remote server.

IP Address Enter the IPv4 or IPv6 address of the remote server
where you want to save the backup .tar file.

Directory Enter the filepath and folder name on the remote
server where you want to save the backup .tar file.
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Table 19: Fields on the Backup Page (Continued)

Field Description

Schedule Backup To select a schedule for the backup:

1. Click Add Schedule.

The Backup Schedule page opens.

In the Type field:

• Select Run now to start the backup immediately.

• Select Schedule at a later time and select the
date and time of the backup.

2. Click OK.

The Backup page appears with the schedule details.

You can also edit or delete the backup schedule by
clicking Edit or Delete, respectively.

Restoring Policy Enforcer from a Backup File

Before You Begin

You must be aware of the following before you restore Policy Enforcer from a backup file:

• When you initiate a backup/restore, Policy Enforcer goes into maintenance mode and will be
unresponsive until the backup/restore process is complete. Ensure that you complete all the tasks
with Policy Enforcer before you start the backup/restore process.

• Ensure that Policy Enforcer and Security Director backups are taken and restored at the same time to
prevent unexpected application behavior.

• When you restore Policy Enforcer from a backup file, ensure the matching Security Director backup
is also restored at the same time. Do not make any changes to managed devices in Security Director
or devices connected to Policy Enforcer as the system does not check for this.

To restore Policy Enforcer from a backup file:

1. Select Administration > Policy Enforcer > Backup and Restore.

The Backup and Restore page appears.
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2. Select the backup file from which you want to restore Policy Enforcer configurations and click
Restore on the top-right corner of the page.

A pop-up page appears asking for confirmation to restore Policy Enforcer from the backup file.

3. Click Restore to start the restore process.

RELATED DOCUMENTATION
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Using Guided Setup for Juniper ATP Cloud with
Juniper Connected Security

Guided Setup is the most efficient way to complete your Juniper ATP Cloud with Juniper Security
configuration. To locate Guided Setup, navigate to Configure > Guided Setup > Threat Prevention in the
Junos Space Security Director Portal.

Before You Begin

• The ATP Cloud Configuration type you select on the Policy Enforcer Settings page determines the
guided setup process. Guided setup provides all the configuration items you need for your chosen
type. See "Juniper ATP Cloud Configuration Type Overview" on page 20 for details on each
configuration type.

• Before you begin the guided setup process, you must enter the IP address and login credentials for
the policy enforcer virtual machine on the Policy Enforcer Settings page. If you haven’t yet done that,
go to Administration > Policy Enforcer > Settings and enter the necessary information. See Policy
Enforcer Settings for more information.

• Ensure that all the devices that you want to set up threat prevention for are already discovered and
available on Junos Space. See Overview of Device Discovery in Security Director.

• Ensure that you install the proper Schema that is suitable with the OS Version of the device.

• Ensure that device version should not be less than 15.x.

• Juniper ATP Cloud license and account are needed for all Juniper ATP Cloud Configuration Types.
(Juniper ATP Cloud with Juniper Connected Security, Juniper ATP Cloud, and Cloud Feeds only). If
you do not have a Juniper ATP Cloud license, contact your local sales office or Juniper Networks
partner to place an order for a Juniper ATP Cloud premium or basic license. If you do not have a
Juniper ATP Cloud account, when you configure Juniper ATP Cloud, you are redirected to the
Juniper ATP Cloud server to create one. Please obtain a license before you try to create a Juniper
ATP Cloud account. Refer to Obtaining a Juniper ATP Cloud License for instructions on obtaining a
Juniper ATP Cloud license.

• There are some concepts you should understand before you begin the configuration. We recommend
that you read about them here in advance. "Policy Enforcer Configuration Concepts" on page 18.

This video provides a complete overview of how you can set up use Policy Enforcer threat prevention to
block malicious servers and domains. You can refer to the procedure below for more elaborate
instructions.

Video: Using Guided Setup for Set Up Threat Prevention
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The Guided Setup process offers the following steps for configuring Juniper ATP Cloud with Juniper
Connected Security threat prevention.

1. Navigate to the Guided Setup page from the Configuration > Guided Setup > Threat Prevention
menu.

The Threat Prevention Policy Setup page appears as shown in Figure 70 on page 135.

Figure 70: Threat Presentation Guided Setup

2. Click Start Setup to begin the guided setup.

The guided setup takes you through the various configuration, the first being Tenants, as shown in
Figure 71 on page 136.

3.
NOTE: This step is not applicable for SRX Series devices. Tenants are only applicable
for MX Series devices.

Create a tenant representing an enterprise by clicking + on the top-right corner of the page. The
Create Tenant page appears.

Use the instructions provided in section "Create Secure Fabric Tenants" on page 166 to create a
tenant.
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NOTE: When a tenant is created, a VRF instance is assigned to the tenant. When a
site is associated with this tenant, only those devices that have the VRF instance
associated with the tenant can be added to the site.

Click OK to move on to the next step.

The Secure Fabric page appears.

NOTE: In Policy Enforcer Release 20.1R1, only MX series devices support LSYS and
VRF. Also, only root-logical system is supported. All the sites of a realm are either
with tenants or without tenants.

Figure 71: Threat Prevention Configuration

4. A Secure Fabric is a collection of network devices (switches, routers, firewalls, and other security
devices), used by users or user groups, to which policies for aggregated threat prevention are
applied. Create a Secure Fabric by clicking + on the top-right corner of the page. The Create Site
page appears.

Use the instructions provided in section "Creating Secure Fabric and Sites" on page 160 to create a
site.

After you create a site, you must add the devices for which you want to apply a common security
policy, to the site. To do so, click Add Enforcement Points in the Enforcement Points column of a
device or, alternately select a device and click Add Enforcement Points on the top-right corner of
the page. Use the instructions provided in section "Adding Enforcement Points" on page 157 to add
endpoints to the site.

NOTE: 
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• A device can belong to only one site and you must remove it from any other site
where it is used.

• Firewall devices are automatically enrolled with ATP Cloud as part of this step.
No manual enrollment is required.

You can find the newly created Secure Fabric on the Devices page.

Click OK to move on to the next step.

The Policy Enforcement Group page appears.

5. A policy enforcement group is a grouping of endpoints ready to receive advance threat prevention
policies. Create a policy enforcement group by clicking + on the top-right corner of the page. The
Policy Enforcement Group page appears.

Use the instructions provided in section "Creating Policy Enforcement Groups" on page 168 to
create a policy enforcement group.

You can find the newly created policy enforcement group on the Configure > Shared Objects page.

Click OK to move on to the next step.

The ATP Cloud Realm page appears.

6. A security realm is a group identifier for an organization used to restrict access to Web applications.
You can create one or multiple realms. If you have not created a realm from within your ATP Cloud
account, you can create and register it here by clicking the + sign on the top-right corner of the
page.

Use the instructions provided in section Creating Juniper ATP Cloud Realms and Enrolling Devices
or Associating Sites to create and register a realm, and then enroll SRX Series devices into the
realm.

If a realm is already created with a site assigned, all devices in a site are listed under the Devices in
Site(s) column that includes EX Series, SRX Series, all enforcement points, and devices that are
originally from a realm. Devices that are marked as perimeter firewall devices are listed under the
Perimeter Firewall column.

Click OK to move on to the next step.

The Threat Prevention Policy page appears.

7. Create a threat prevention policy by clicking + on the top-right corner of the page. The Create
Threat Prevention Policy page appears.

Use the instructions provided in section "Creating Threat Prevention Policies" on page 173 to
create a threat prevention policy.
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The newly created threat prevention policy is available on page Configure > Threat Prevention >
Policies.

Click OK to move on to the next step.

The Geo IP page appears.

8. (Optional) Geo IP refers to the method of locating a computer terminal's geographic location by
identifying that terminal's IP address. A Geo IP feed is an up-to-date mapping of IP addresses to
geographical regions. By mapping IP address to the sources of attack traffic, the geographic regions
of origin can be determined, giving you the ability to filter traffic to and from specific locations in
the world. Create a Geo IP by clicking + on the top-right corner of the page. The Create Geo IP
page appears as shown in Figure 72 on page 138.

Use the instructions provided in section "Creating Geo IP Policies" on page 181 to create a Geo IP.

Click Finish to move on to the Summary page.

The Geo IP page appears.

Figure 72: Create Geo IP

9. The last page is a summary of the parameters you have configured using quick setup. Click OK to
create the threat prevention policy. The Policies page appears with the newly created policy listed.

10. You must apply your new or edited policy configuration to Policy Enforcer in order for the policy
configuration to go live. In order to do that, click the Ready to Update link in the Status column. The
Threat Policy Analysis page appears.
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Use the Threat Policy Analysis page to view your pending policy changes in chronological order.
Click the View Analysis link to view the changes.

In the Action section, you can choose to: Update now to , Update later, or Save the changes
without updating.

• Update now—Apply the policy configuration immediately.

• Update later—Apply the policy configuration at a scheduled date and time of your choice.

• Save the changes without updating—Save the policy changes without applying them to Policy
Enforcer.
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Using Guided Setup for Juniper ATP Cloud

Guided Setup is the most efficient way to complete your initial configuration. Locate Guided Setup from
the Configuration > Guided Setup > Threat Prevention menu.

• The Juniper ATP Cloud Configuration type you select on the Policy Enforcer Settings page
determines the guided setup process. Guided setup provides all the configuration items you need for
your chosen type. See "Juniper ATP Cloud Configuration Type Overview" on page 20 for details on
each configuration type.

• Before you begin the guided setup process, you must enter the IP address and login credentials for
the policy enforcer virtual machine on the Policy Enforcer Settings page. If you haven’t yet done that,
go to Administration > Policy Enforcer > Settings and enter the necessary information. See Policy
Enforcer Settings for more information.

• Juniper ATP Cloud license and account are needed for all Juniper ATP Cloud Configuration Types.
(Juniper ATP Cloud with Juniper Connected Security, Juniper ATP Cloud, and Cloud Feeds only). If
you do not have a Juniper ATP Cloud license, contact your local sales office or Juniper Networks
partner to place an order for a Juniper ATP Cloud premium or basic license. If you do not have a
Juniper ATP Cloud account, when you configure Juniper ATP Cloud, you are redirected to the
Juniper ATP Cloud server to create one. Please obtain a license before you try to create a Juniper
ATP Cloud account. Refer to "Obtaining a Juniper ATP Cloud License" on page 52 for instructions on
obtaining a Juniper ATP Cloud license.

• There are some concepts you should understand before you begin the configuration. Read "Juniper
ATP Cloud Overview" on page 9 for further information.

Click Start Setup from Configuration > Guided Setup > Threat Prevention to begin.

1. Add a ATP Cloud Realm—If you have not created a realm from within your Juniper ATP Cloud
account, you can create it here by clicking the + sign. Once you add a realm, you can enroll SRX
Series devices into the realm. A security realm is a group identifier for an organization used to restrict
access to Web applications. You can create one or multiple realms. See Juniper ATP Cloud Realm
Overview for information. A realm has the following configuration fields

• Username and Password—These are credentials you must provide, obtained through your Juniper
ATP Cloud account.

• Realm—This is the name of the realm you are creating.

2. Click Add devices to enroll them in threat prevention before proceeding to the next step. Devices
designated as perimeter firewalls are automatically enrolled with Juniper ATP Cloud.
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3. Create a Policy—You create a name for the policy, choose one or more profile types depending on the
type of threat prevention this policy provides (C&C Server, Infected Host, Malware), and select a log
setting.

• Once configured, threat prevention policies are located under Configure > Threat Prevention >
Policies. A policy has the following fields:

• Name and Description.

• Profiles—The type of threat this policy manages:

• C&C Server (Command and Control Server)—A C&C server is a centralized computer that
issues commands to botnets (compromised networks of computers) and receives reports
back from them. A C&C profile provides information on C&C servers that have attempted
to contact and compromise hosts on your network. Information such as IP address, threat
level, and country of origin are gathered.

• Infected Host—An infected host profile provides information on compromised hosts and
their associated threat levels. Host information includes IP address, threat level, blocked
status, when the threat was seen, command and control hits, and malware detections.

• Malware—A malware profile provides information on files downloaded by hosts and found
to be suspicious based on known signatures or URLs. The filename, file type, signature,
date and time of download, download host, URL, and file verdict are gathered.

• Logging—All traffic is logged by default. Use the pulldown to narrow the types of traffic to be
logged.

4. Geo IP—Geo IP refers to the method of locating a computer terminal's geographic location by
identifying that terminal's IP address. A Geo IP feed is an up-to-date mapping of IP addresses to
geographical regions. By mapping IP address to the sources of attack traffic, geographic regions of
origin can be determined, giving you the ability to filter traffic to and from specific locations in the
world. For Geo IP, you configure the following:

• Name and Description

• Countries—Select the check box beside the countries in the Available list and click the > icon to
move them to the Selected list. The countries in the Selected list will be included in the policy and
action will be taken according to their threat level.

• Block Traffic—Choose what traffic to block from the selected countries. Incoming traffic, Outgoing
traffic, or Incoming and Outgoing traffic.

5. The last page is a summary of the items you have configured. Click OK to be taken to the Policies
page under Configure > Threat Prevention, and your policy is listed there.
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NOTE: When you are using Juniper ATP Cloud without Policy Enforcer, you must assign
the policy to a firewall rule before it can take affect. Navigate to Configure > Firewall
Policy > Policies. In the Advanced Security column, click an existing item to access the
Edit Advanced Security page and select the Threat Prevention Policy from the Threat
Prevention pulldown list.
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Using Guided Setup for No Juniper ATP Cloud (No
Selection)

Guided Setup is the most efficient way to complete your initial configuration. Locate Guided Setup from
the Configuration > Guided Setup > Threat Prevention menu.

You would make no ATP Cloud selection to configure Juniper Connected Security using only custom
feeds. Custom feeds are the only threat prevention type available if you make no selection for ATP
Cloud Configuration Type in the Policy Enforcer Settings page.

• Before you begin the guided setup process, you must enter the IP address and login credentials for
the policy enforcer virtual machine on the Policy Enforcer Settings page. If you haven’t yet done that,
go to Administration > Policy Enforcer > Settings and enter the necessary information. See Policy
Enforcer Settings for more information.

• There are some concepts you should understand before you begin the configuration. It is
recommended you read about them here in advance. "Policy Enforcer Configuration Concepts" on
page 18.

The Guided Setup process offers the following steps for configuring threat prevention with custom
feeds (No ATP Cloud selection). Click Start Setup to begin.

1. Tenants—You can create a tenant representing an Enterprise. When a tenant is created, a VRF is
assigned to the tenant. When a site is associated with this tenant, only those devices that have the
VRF associated with the tenant can be added to the site.

NOTE: In Policy Enforcer Release 20.1R1, only MX series devices support LSYS and
VRF. Also, only root-logical system is supported. All the sites of a realm are either with
tenants or without tenants.

2. Secure Fabric—Secure Fabric is a collection of network devices (switches, routers, firewalls, and other
security devices), used by users or user groups, to which policies for aggregated threat prevention are
applied. Once created, secure fabric is located under Devices. For secure fabric, the following is
configured:

• Sites—A site is a collection of network devices participating in threat prevention. Using quick
setup, you can create your own site, but note that a device can only belong to one site and you
must remove it from the any other site where it is used to use it elsewhere.
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Click Add Devices in the Device Name column or in the IP address column to add devices to a
site. Using the check boxes in the device list, you should indicate which devices are firewalls or
switches.

3. Policy Enforcement Group—A policy enforcement group is a grouping of endpoints ready to receive
advance threat prevention policies. Create a policy enforcement group by adding endpoints (firewalls
and switches) under one common group name and later applying a security policy to that group. For
policy enforcement group, the following is configured:

• Once configured, policy enforcement groups are located under Configure > Shared Objects. A
policy enforcement groups has the following fields:

• Name and Description.

• Group Type—IP Address, Subnet, or Location

• Endpoint—IP addresses included in the group

4. Custom Feeds— Policy Enforcer uses threat feeds to provide actionable intelligence to policies about
various types of threats. These feeds can come from different sources. In this case, the feeds are
customized by adding IP addresses, domains, and URLs to your own lists.

The following types of custom threat feeds are available:

• Dynamic Address—A dynamic address is a group of IP addresses that can be imported from
external sources. These IP addresses are for specific domains or for entities that have a common
attribute such as a particular undesired location that poses a threat. You can then configure
security policies to use the dynamic addresses within a security policy.

• Allowlist—An allowlist contains known trusted IP addresses, URLs, and domains. Content
downloaded from locations on the allowlist does not have to be inspected for malware.

• Blocklist—A blocklist contains known untrusted IP addresses, URLs, and domains. Access to
locations on the blocklist is blocked, and therefore no content can be downloaded from those
sites.

• Infected Host—Infected hosts are hosts known to be compromised.

NOTE: The Juniper ATP Cloud advanced anti-malware detection of the infected
host is not supported in SRX Series 300 and SRX Series 320 devices, if these devices
are running Junos OS release prior to 18.3R1.

• DDoS—Using DDoS threat feed, policy Enforcer blocks source IP addresses in the feed, rate limit
the traffic from the source IP addresses, and takes BGP Flowspec action to apply null-route
filtering or redirect the traffic to scrubbing centers.
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• Command and Control Server (C&C)—C&C is a centralized computer that issues commands to
botnets (compromised networks of computers) and receives reports back from them. Botnets can
be used to gather sensitive information, such as account numbers or credit card information, or to
participate in a distributed DDoS attack.

5. Threat Prevention Policy—A threat prevention policy requires you to create a name for the policy,
choose one or more profile types depending on the type of threat prevention this policy provides
(infected hosts), and select a log setting. Once configured, you apply policies to policy enforcement
groups.

• Once configured, threat prevention policies are located under Configure > Threat Prevention >
Policies. A policy has the following fields:

• Name and Description.

• Profiles—The type of threat this policy manages:

• Infected Hosts—An infected host profile would provide information on compromised hosts
and their associated threat levels. Host information includes IP address, threat level,
blocked status, when the threat was seen, command and control hits, and malware
detections.

• Logging—All traffic is logged by default. Use the pulldown to narrow the types of traffic to be
logged.

• Group—Once your policy is created, it is applied to the policy enforcement group.

6. The last page is a summary of the items you have configured using quick setup. Click OK to be taken
to the Policies page under Configure > Threat Prevention > Policies and your policy is listed there.

7. You must update to apply your new or edited policy configuration. Clicking the Ready to Update link
takes you the Threat Policy Analysis page. See "Threat Policy Analysis Overview" on page 180. From
there you can view your changes and choose to Update now, Update later, or Save them in draft
form without updating.
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Configuring Juniper ATP Cloud with Juniper
Connected Security (Without Guided Setup)
Overview

This is an outline of the tasks required to configure ATP Cloud with Juniper Connected Security.

NOTE: If you prefer to use quick setup, which automatically takes you through the steps
listed below, it is located under Configure>Guided Setup >ATP Cloud with PE.

Before You Begin

• Juniper ATP Cloud license and account are needed for all threat prevention types (Juniper ATP Cloud
with PE, Juniper ATP Cloud, and Cloud Feeds only). If you do not have Juniper ATP Cloud license,
contact your local sales office or Juniper Networks partner to place an order for Juniper ATP Cloud
premium or basic license. If you do not have Juniper ATP Cloud account, when you configure Juniper
ATP Cloud, you are redirected to the Juniper ATP Cloud server to create one. Please obtain a license
before you try to create Juniper ATP Cloud account. Refer to Obtaining a Juniper ATP Cloud License
for instructions on obtaining Juniper ATP Cloud license.

• Before you configure Policy Enforcer, you must enter the IP address and login credentials for the
policy enforcer virtual machine. Go to Administration > Policy Enforcer > Settings. Once this
information is entered, you can begin the setup process. See Policy Enforcer Settings. (Refer to
"Policy Enforcer Installation Overview" on page 31 for instructions on downloading Policy Enforcer
and creating your policy enforcer virtual machine.)

To configure Juniper ATP Cloud with Juniper Connected Security:

1. Create one or more Juniper ATP Cloud realms and enroll SRX Series devices in the appropriate realm.
(Enroll devices by clicking Add Devices in the list view once the realm is created.)

In the UI, navigate to Configure>Threat Prevention>ATP Cloud Realms. Click the + icon to add a new
ATP Cloud realm.

See Creating Juniper ATP Cloud Realms and Enrolling Devices or Associating Sites for details.

2. Create sites and add devices to those sites.

In the UI, navigate to Devices >Secure Fabric. Click the + icon to create a new site.

See "Creating Secure Fabric and Sites" on page 160 for details.

3. Create a policy enforcement group.
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In the UI, navigate to Configure>Shared Objects>Policy Enforcement Groups. Click the + icon to
create a new policy enforcement group.

See "Creating Policy Enforcement Groups" on page 168 for details.

4. Add the threat prevention policy, including profiles for one or more threat types: C&C server,
infected host, malware.

In the UI, navigate to Configure> Threat Prevention > Policies. Click the + icon to create a new threat
prevention policy.

See "Creating Threat Prevention Policies" on page 173 for details.
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Creating Juniper ATP Cloud Realms and Enrolling
Devices or Associating Sites

You can select a geographical location and enter your Juniper ATP Cloud credentials to create a realm
and associate sites or devices with the realm.

If you do not have Juniper ATP Cloud account, select a geographical region and click here. You are
redirected to the Juniper ATP Cloud account page.

Before You Begin
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•
NOTE: 

• Policy Enforcer does not support the Multi-factor authentication (MFA) feature in
Cloud ATP. Disable the MFA feature in the Cloud ATP before adding realms to the
Security Director.

• You cannot use single sign-on (SSO) credentials to add the Juniper ATP realm to
Security Director.

Use the login credentials used to create the realm.

• Understand which type of Juniper ATP Cloud license you have: free, basic, or premium. The license
controls which Juniper ATP Cloud features are available.

• To configure a Juniper ATP Cloud realm, you must already have Juniper ATP Cloud account with an
associated license.

• Ensure that the internet connectivity is available for Policy Enforcer. Without the internet
connectivity, you cannot create a realm.

• Decide which region will be covered by the realm you are creating. You must a select a region when
you configure a realm.

• Note that adding a device to a realm results in one or more commit operations occurring on the
device to apply the Juniper ATP Cloud or Policy Enforcer configuration.

To configure ATP Cloud Realm:

1. Select Configure>Threat Prevention>Feed Sources.

The Feed Sources page appears.

2. In the ATP Cloud tab, click the + icon to add a realm.

3. Complete the initial configuration by using the guidelines in Table 20 on page 152 below.

4. Click Finish.

Table 20: Fields on the Add ATP Cloud Realm Page

Field Description

ATP Cloud Realm Credentials
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Table 20: Fields on the Add ATP Cloud Realm Page (Continued)

Field Description

Location Select a region of the world from the available choices.

The following options are available in the Location list:

• North America

• European Region

• Canada

• Asia Pacific

By default, the North America value appears in the list. To know more about the geographic
region, see here.

Username Enter your e-mail address. Your username for Juniper ATP Cloud is your e-mail address.

Password Enter a unique string at least 8 characters long. Include both uppercase and lowercase letters,
at least one number, and at least one special character (~!@#$%^&*()_-+={}[]|:;<>,./?); no
spaces are allowed, and you cannot use the same sequence of characters that are in your
username.

Realm Enter a name for the security realm. This should be a name that is meaningful to your
organization. A realm name can only contain alphanumeric characters and the dash symbol.
Once created, this name cannot be changed.

NOTE: When you create a custom feed with a realm, the feed is associated at the site level
and not at the realm level. If you modify this realm and associate new sites to it, a warning
message is shown that there are custom feeds are associated with this realm. Changing the
site information will change the custom feed information. You must go and edit the custom
feed that was associated with this realm and verify the realm association.

Site
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Table 20: Fields on the Add ATP Cloud Realm Page (Continued)

Field Description

Site Select one or more sites to enroll into the realm. If there are no sites associated with the realm,
click Create new site. To know more about creating a new site, see "Creating Secure Fabric and
Sites" on page 160.

NOTE: 

• If you are using Juniper ATP Cloud without Policy Enforcer, you are not prompted to
select a site.

• Assigning a site to the realm will cause a change in the device configuration in the
associated devices.

• You must select the sites either with tenants or without tenants. You cannot select both
at a time.

Unmanaged
Devices

Lists all devices from the realm that are not managed in Security Director. You must manually
discover them.

If you are using Juniper ATP Cloud with Policy Enforcer and you have no devices enrolled in
the realm, you are asked to select devices in the box on the left and move them to the right to
enroll them. All selected devices are automatically enrolled with Juniper ATP Cloud when you
finish the guided setup. To disenroll a device, you can edit a realm and move the device back to
the left side box.

NOTE: Adding a device to a realm results in one or more commit operations occurring on
the device to apply the Juniper ATP Cloud or Policy Enforcer configuration.

Global Configuration

IPv6 Feeds Enable this option to receive IPv6 feeds (C&C and Geo IP) from Policy Enforcer.

Threat Level
Threshold

Select a threshold level to block the infected hosts and to send an e-mail to the selected
administrators notifying about the infected host events.

Click the+ sign if you want to add new administrators to the list.

Logging Enable this option to log the Malware or the Host Status event or both the event types.
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Table 20: Fields on the Add ATP Cloud Realm Page (Continued)

Field Description

Proxy Servers Click the add icon (+) to enter the trusted IPv4 address of the proxy server, in the Server IP
column.

When there is a proxy server between users on the network and a firewall, the firewall might
see the proxy server IP address as the source of an HTTP or HTTPS request, instead of the
actual address of the user making the request.

With this in mind, X-Forwarded-For (XFF) is a standard header added to packets by a proxy
server that includes the real IP address of the client making the request. Therefore, if you add
trusted proxy servers IP addresses to the list in Juniper ATP Cloud, by matching this list with
the IP addresses in the HTTP header (X-Forwarded-For field) for requests sent from the SRX
Series devices, Juniper ATP Cloud can determines the originating IP address.

NOTE: XFF only applies to HTTP or HTTPS traffic, and only if the proxy server supports the
XFF header.

NOTE: If you enrolled a device into a realm from within Security Director and you want
to disenroll it, you must do that from within Security Director. If you enrolled a device
into a realm from within Juniper ATP Cloud and you want to disenroll it, you must do
that from within Juniper ATP Cloud. You cannot disenroll a device from within Security
Directory that was enrolled from within Juniper ATP Cloud.

RELATED DOCUMENTATION

About the Feed Sources Page  |  240

Juniper ATP Cloud Realm Overview

Juniper ATP Cloud Overview  |  9

Creating Secure Fabric and Sites  |  160

Secure Fabric Overview

Secure Fabric is a collection of sites which contain network devices (switches, routers, firewalls, and
other security devices), used in policy enforcement groups. When threat prevention policies are applied
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to policy enforcement groups, the system automatically discovers to which sites those groups belong.
This is how threat prevention is aggregated across your secure fabric.

• Add Enforcement Points—Click the Add Enforcement Points link to add Firewalls, Switches, and/or
Connectors. There is a one-to-one mapping between devices with sites. If a device is mapped to a
site, you cannot use the same device to map to a different site. The connector can be mapped to
multiple sites. To filter by type, click the three vertical dots beside the search field and select the
check box for the device type. See "Creating Secure Fabric and Sites" on page 160 for more
information.

• Drag and Drop Enforcement Points—From the main page, you can select enforcement points and
drag them to other sites to include them there. When you drag, the enforcement point is disenrolled
from the current site and gets enrolled to the new site where the enforcement point is dropped.

You can either have switches or a connector as enforcement points and not both. However, you can
drag a switch and add to a site that already has a switch or SRX Series device.

Table 21 on page 156 shows fields on the Secure Fabric page.

Table 21: Secure Fabric Page Fields

Field Description

Site Specifies the name of the secure fabric site.

Tenant Specifies the name of the secure fabric tenant.

Enforcement Points Specifies the enforcement points for that particular site, if enforcement points are already
added. If not added, click Add Enforcement Points to add Firewalls, Switches, or
Connectors as enforcement points.

A firewall icon is shown against some of the devices to indicate that they are the perimeter
firewalls.

For connectors, if you hover over the enforcement point, a tool tip is shown listing the
corresponding vSRX devices with IP addresses and descriptions.

NOTE: If tenant is configured to the site, only MX Series device can be added as
enforcement points.

IP Specifies the IP address of the enforcement point, if the enforecement point is available.

Model Specifies the type of the enforcement point. For example, vSRX, QFX, Connector.
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Table 21: Secure Fabric Page Fields (Continued)

Field Description

Feed Source Specifies the feed source to Policy Enforcer.

ATP Cloud Enroll
Status

Specifies the status of the Juniper ATP Cloud enrollment.

The Success status with a warning symbol indicates that the device is enabled for cloud
feeds only and there is no support for malware capability and enhanced mode. This field
will be blank if the device fails to disenroll Juniper ATP Cloud.

If the status is Failed, click Retry to enroll the device with Juniper ATP Cloud again. You can
hover over the Failed status to see the corresponding job details. The device enroll retry
option is available only when the status is Failed.

Last Updated Specifies the date on which the Secure Fabric page was last updated.

Description Specifies the description that you had entered at the time of creating a secure fabric site.

RELATED DOCUMENTATION

Creating Secure Fabric and Sites  |  160

Policy Enforcement Groups Overview  |  167

Threat Prevention Policy Overview  |  170

Adding Enforcement Points

Use the Add Enforcement Points page to assign devices to a site and indicate which devices are
perimeter firewalls. To enroll a device with Juniper ATP Cloud/JATP, you must assign one or more
perimeter firewalls to each site.

NOTE: 
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• When a connector instance is assigned to a site, that particular connector instance
will not be listed as available enforcement point for other sites.

• If you want to enforce an infected host policy within the network, you must assign a
switch to the site.

• Assigning a device to the site will cause a change in the device configuration.

To add firewalls, switches, or connectors as an enforcement point:

1. Select Devices>Secure Fabric.

The Secure Fabric page appears.

2. Select the required site for which you want to add enforcement points, and click Add Enforcement
Points.

The Add Enforcement Points page appears.

3. Complete the configuration as shown in Table 22 on page 158.

4. Click OK.

Table 22: Fields on the Add Enforcement Points Page

Field Description

Enforcement
points

All device types are displayed in the list. To filter by type, click the four vertical dots beside the
search field and select the check box for the device type.

To include a device, select the check box beside the device in the Unassigned Devices list and
click the > icon to move them to the Selected list. The devices in the Selected list will be
included in the site.

There is a one-to-one mapping between SRX Series devices and connectors with sites. If a
device or a connector is mapped to a site, you cannot use the same device or a connector to
map to a different site.

NOTE: Firewall devices are automatically enrolled with Juniper ATP Cloud/ATP Appliance as
part of this step. No manual enrollment is required. The exceptions are “no selection” mode
and Cloud Feeds only mode where Juniper ATP Cloud/ATP Appliance is not available and
therefore no enrollment takes place. (see "Juniper ATP Cloud Configuration Type Overview"
on page 20)

The name of the connector type is shown as a tool tip when you hover over the name.

NOTE: If a site is associated with a tenant, only MX Series devices are listed. Only those MX
Series devices are listed that have the VRF associated with the tenant that the site is
associated with.
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Table 22: Fields on the Add Enforcement Points Page (Continued)

Field Description

Perimeter
Device

Select the edge firewall devices connecting the network to the internet. These devices will
receive the threat feeds. Only firewall (SRX, vSRX) or router devices (MX) that you choose in
the Enforcement Points field appear in the Perimeter Device field. You can have SRX Series and
MX Series devices in the same site and select both as perimeter devices.

You must configure MX Series router as a perimeter device to download Command & Control
(C&C), allowlist, blocklist from Policy Enforcer. In the Juniper ATP Cloud/ATP Appliance with
Juniper Connected Security mode, if you choose a MX Series router as a perimeter firewall
device, the MX Series router is not enrolled to Juniper ATP Cloud/JATP. The Policy Enforcer
URL is configured to the device and this enables the device to request and receive feeds from
Policy Enforcer.

NOTE: The policies to take action based on the feed are not configured in Policy Enforcer.
The policies have to be manually configured on the MX Series device.

Among the listed devices, you can choose which device to consider as a perimeter firewall.
Only the perimeter firewall devices are enrolled to Juniper ATP Cloud/JATP. If you do not
choose any firewall device as a perimeter firewall, all firewall devices listed in this field are
enrolled to Juniper ATP Cloud/ATP Appliance as perimeter firewalls by default.

You can delete devices manually from the field. However, all the firewall devices are still
available in the list to include later. To remove firewall devices permanently from list, you must
move the firewall devices from the Selected column to the Available column in the
Enforcement points field.

In any Juniper ATP Cloud/ATP Appliance configuration types, if there is a firewall device
assigned to a site, it is mandatory to assign one of those devices as a perimeter firewall. If there
are no firewall devices assigned to a site, the perimeter firewall list will be empty.

When you enroll a connector instance to Policy Enforcer, the connector instance provides few
vSRX Series devices. These vSRX devices are discovered by Policy Enforcer in Junos Space.
Hover over the connector instances appearing in the Secure Fabric page to view the details of
the corresponding vSRX devices. The vSRX Series devices associated with a connector are not
shown in the Perimeter Firewall field. However, they are considered as perimeter firewalls.

NOTE: If a branch SRX Series device is added and selected as a perimeter firewall, system
reboots and a warning message is shown before rebooting the system.

RELATED DOCUMENTATION
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Creating Secure Fabric and Sites  |  160

Creating Secure Fabric and Sites

You can create sites within your secure fabric from the secure fabric page.

Before You Begin

• Plan out your sites in advance. A site is a grouping of network devices, including firewalls and
switches, that contribute to threat prevention.

• Keep in mind that when you create a site, you must identify the perimeter firewalls so you can enroll
them with Juniper ATP Cloud/JATP.

• If you want to enforce an infected host policy within the network, you must assign a switch to the
site.

• SRX Series devices cannot belong to multiple sites.

• MX Series devices associated with tenants can belong to multiple sites.

• Sites that are associated with tenants do not need switches as enforcement points.

• Switches and connectors cannot be added to the same site.

To create a site within your secure fabric:

1. Select Devices>Secure Fabric.

2. Click the + icon.

3. Complete the configuration by using the guidelines in Table 23 on page 160 below.

4. Click OK.

5. Create a new site and add an enforcement point to a site.

Table 23: Create Site Page Fields

Field Description

Site Enter a unique string that must begin with an alphanumeric character and can include underscores;
no spaces allowed; 63-characters maximum.

Tenant Select a tenant.
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Table 23: Create Site Page Fields (Continued)

Field Description

Description Enter a description; maximum length is 1024 characters. You should make this description as useful
as possible for all administrators.

WARNING: If you add certain SRX Series Firewalls to your Secure Fabric as enforcement
points, you may see a warning that the device(s) must be reconfigured in enhanced mode
and require a reboot. Here is a list of SRX models that may require rebooting for
enhanced mode after being registered with Policy Enforcer/Juniper ATP Cloud/JATP.

• SRX340

• SRX345

• SRX650

• SRX240h2

• SRX320

• SRX300

• SRX550

RELATED DOCUMENTATION
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Threat Prevention Policy Overview  |  170

Editing or Deleting a Secure Fabric

You can edit or delete a secure fabric from the secure fabric main page.

To edit or delete a secure fabric:

1. Select Devices > Secure Fabric.
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The secure fabric page appears.

2. Select the secure fabric you want to edit or delete and then right-click.

• Select Edit to modify your secure fabric. The secure fabric configuration page appears. Make the
changes and click OK.

• Select Delete to remove your secure fabric. An alert message appears verifying that you want to
delete your selection. Click Yes to delete your selection.

RELATED DOCUMENTATION
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Logical System and Virtual Routing and Forwarding
Instance Overview

IN THIS SECTION

What's Next  |  164

Starting in Policy Enforcer Release 20.1R1, you can create a tenant representing an enterprise and you
can assign a Virtual Routing and Forwarding (VRF) instance to a tenant. The custom feed sends feeds to
Policy Enforcer at the logical system (LSYS) and VRF instance levels on the MX Series device. The VRF
instance is dedicated to handling traffic within the tenant's private network. You can route the traffic on
the tenant’s private network from the VRF instance on the MX Series device at one site to the same
VRF instance on another MX Series device at a different site. The MX Series device supports multiple
VRF instances assigned to different tenants. Therefore, a device can be shared with multiple tenants.
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NOTE: In Policy Enforcer Release 20.1R1, only MX Series devices support LSYS and VRF
instance. Also, only root logical system is supported. All the sites of a realm are either
with tenants or without tenants.

When a tenant is created, a VRF instance is assigned to the tenant. When a site is associated with the
tenant, only those devices that have the VRF instance associated with the tenant can be added to the
site. When you associate a site with a realm in Juniper ATP Cloud/JATP, the tenant receives the feeds
configured for the realm. The MX Series device performs policy enforcement based on tenant system
and the associated Juniper ATP Cloud/ATP Appliance realm.

On an MX Series device, VRF instance based feeds such as C&C, allowlist, and blocklist are supported
through custom feeds as shown in Figure 73 on page 164.

NOTE: If you want to use the C&C global feed from ATP Cloud/JATP, then custom feed
for C&C should not be configured in Policy Enforcer.

For, example: VRFx and VRFy are associated with tenants on MX device 1. Custom feed for tenant 1
(VRFx) and custom feed for tenant 2 (VRFy) are associated to each tenant. The custom feed provides
LSYS and VRF instance information. When the device requests for a feed, Policy Enforcer provides all
the feed data associated with the device (global without VRF instance information) in addition to all the
data for the VRF instances configured on the device that are associated with the tenants configured on
Policy Enforcer.
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Figure 73: LSYS and VRF Instance Support
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About the Secure Fabric Tenants Page

IN THIS SECTION

Tasks You Can Perform  |  165

Field Descriptions  |  165

What's Next  |  166

To access this page, click Devices > Secure Fabric > Tenants.

Starting in Policy Enforcer Release 20.1R1, you can create a tenant representing an enterprise. When a
tenant is created, a VRF instance is assigned to the tenant.

Tasks You Can Perform

You can perform the following tasks from this page:

• Create a tenant. See "Create Secure Fabric Tenants" on page 166.

You can also modify and delete a tenant.

Field Descriptions

Table 24 on page 165 provides guidelines on using the fields on the Secure Fabric Tenants page.

Table 24: Fields on the Secure Fabric Tenants Page

Field Description

Tenant Specifies the name of the tenant.

LDOM Specifies the root logical system.
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Table 24: Fields on the Secure Fabric Tenants Page (Continued)

Field Description

VRF Specifies the VRF created on the MX Series device.

Sites Specifies the name of the sites.

WHAT'S NEXT

"Creating Secure Fabric and Sites"  |  160

RELATED DOCUMENTATION

Logical System and Virtual Routing and Forwarding Instance Overview  |  162

Create Secure Fabric Tenants

To create a tenant within your secure fabric:

1. Select Devices > Secure Fabric > Tenants.

2. Click the + icon.

3. Complete the configuration using the guidelines in Table 25 on page 166.

4. Click OK.

A tenant is created. After the tenant is created, it can be associated to a site.

Table 25: Create Tenant

Field Guidelines

Name Enter a unique string that must begin with an alphanumeric character and can
include underscores; no spaces allowed; 63-character maximum.
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Table 25: Create Tenant (Continued)

Field Guidelines

LDOM By default, the root logical system is selected, which you cannot edit. In
Policy Enforcer Release 20.1R1, only root logical system is supported.

VRF Enter the virtual routing and forwarding (VRF) instance name, which is
created on the MX Series device.

To edit a tenant, select a tenant and click the pencil icon.

To delete a tenant, select the delete icon. If a tenant is associated to a site, the tenant cannot be deleted.

What's Next

• "Creating Secure Fabric and Sites" on page 160

RELATED DOCUMENTATION
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Policy Enforcement Groups Overview

A policy enforcement group is a grouping of endpoints to which threat prevention policies are applied.
Create a policy enforcement group by adding endpoints (firewalls, switches, subnets, set of end users)
under one common group name and later applying a threat prevention policy to that group.

RELATED DOCUMENTATION

Creating Policy Enforcement Groups  |  168

Threat Prevention Policy Overview  |  170
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Creating Policy Enforcement Groups

You can create policy enforcement groups from the policy enforcement groups page.

Before You Begin

• Know what type of endpoints you are including in your policy enforcement group: IP address/subnet,
or location.

• Determine what endpoints you will add to the group based on how you will configure threat
prevention according to location, users and applications, or threat risk.

• Keep in mind that endpoints cannot belong to multiple policy enforcement groups.

To create a policy enforcement group:

1. Select Configure>Shared Objects>Policy Enforcement Groups.

2. Click the + icon.

3. Complete the configuration by using the guidelines in the Table 26 on page 168 below.

4. Click OK.

Table 26: Fields on the Policy Enforcement Group Page

Field Description

Name Enter a unique string that must begin with an alphanumeric character and can include only
dashes and underscores; no spaces allowed; 32-character maximum.

Description Enter a description; maximum length is 64 characters. You should make this description as useful
as possible for all administrators.

Group Type Select a group type from the available choices. IP Address/Subnet or Location.
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Table 26: Fields on the Policy Enforcement Group Page (Continued)

Field Description

Connector IPs This field is available only if the Group Type field is IP Address/Subnet

The subnets of all connectors added in the Connector page are dynamically listed in the
Available column. If the Group Type is IP Address/Subnet, the subnets within the connector
instances that have the threat remediation enabled are only listed.

When using Junos Space, Policy Enforcer is able to dynamically discover subnets configured on
Juniper switches. Policy Enforcer does not have the same insight with third-party devices.
Therefore you can add subnets to your connector configuration and select them here. This
allows you to selectively apply policies to those subnets.

If you have not configured a connector, you will see only Junos Space subnets discovered by
Policy Enforcer. If you have a connector configured, you can see the subnets of a connector in
the Available column. Hover over subnets to view the description for these subnets entered
during the connector creation. You will not see any description if it is not entered during creating
a connector. The description will show “No description available” for subnets that come from
Junos Space.

The Available and Selected columns have filters listed with connectors or Space. You can choose
a connector and filter only the subnets belonging to that particular connector. The result shows
the name of a device to which the subnet belongs and also the type of the device.

You can also use the search bar to search and filter the result based on subnet, name of the
device, or type of the device.

Click Refresh Available IPs to refresh the available IP addresses or subnets. If you edit any
selected items in the Selected column, the list is refreshed to the initial selected list after the
refresh. A progress bar is shown with the refresh progress in percentage.

In a scenario where there are no IP addresses or subnets, the refresh will still be successful. A
message is displayed showing that the refresh was successful but there are no IP addresses or
subnets found.

Additional IP This field is available only if the Group Type field is IP Address/Subnet

Enter an IP address and select the connector type from the list to add to PEG. The IP address
must be within the subnet range of the selected connector. Click Add to add the additional IP
address to the Selected column of the Connector IPs field.

A validation is performed to check if the additional IP address is within the subnet range of the
selected connector. If not, an error message is shown to enter the IP address within the subnet
range.
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Table 26: Fields on the Policy Enforcement Group Page (Continued)

Field Description

Sites Sites with the threat remediation enabled instances are only listed, if the Group Type is Location.
Select the check box beside the sites in the Available list and click the > icon to move them to
the Selected list.

The endpoints in the Selected list will be included in the policy enforcement group.

You can create a policy enforcement group with subnets from different connectors based on how they
have grouped their network segments. For example, If you have Junos Space EX switch with subnets
HR: 1.1.1.1/24 and Finance: 2.2.2.2/24, ClearPass connector with subnets HR: 1.1.1.1/24 and
Marketing: 2.2.2.2/24, Cisco ISE with subnets HR: 1.1.1.1/24 and Finance: 2.2.2.2/24. You can create a
single policy enforcement group and name it as HR by choosing the following subnets: Junos Space EX
HR: 1.1.1.1/24, ClearPass connector subnet HR: 1.1.1.1/24, and Cisco ISE connector subnet HR:
1.1.1.1/24.

RELATED DOCUMENTATION
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Threat Prevention Policy Overview

IN THIS SECTION

Benefits of Threat Prevention Policy  |  172

Threat prevention policies provide protection and monitoring for selected threat profiles, including
command and control servers, infected hosts, and malware. Using feeds from ATP Cloud and optional
custom feeds that you configure, ingress and egress traffic is monitored for suspicious content and
behavior. Based on a threat score, detected threats are evaluated and action may be taken once a
verdict is reached.
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Once policies are configured, the following fields are available on the Security Director main page to
provide an overview of each policy.

Table 27: Threat Prevention Policy Fields

Field Description

Name The user-created name for the policy.

Profile: C&C Server Threat score settings overview if selected for the
policy. (Otherwise this field is empty.) For example:

Block: 8-10

Monitor: 5-7

Permit: 1-4

Profile: Infected Host Threat score settings overview if selected for the
policy. (Otherwise this field is empty.)

Profile: Malware HTTP Threat score settings overview if selected for the
policy. (Otherwise this is empty.)

Profile: Malware SMTP Threat score settings overview if selected for the
policy. (Otherwise this field is empty.)

171



Table 27: Threat Prevention Policy Fields (Continued)

Field Description

Status This displays the status of the policy. This status is a
clickable link you can use to change the policy status.
When you first create a policy and assign it to a group,
this field reads View Analysis. Read "Threat Policy
Analysis Overview" on page 180 for more information
on this field.

If the status is Update Failed, click Retry to perform the
rule analysis again. You can click the Update Failed
status to see the corresponding job details. The rule
analysis retry option is available only when the status is
Update Failed.

NOTE: If the policy has been updated after it has
already been pushed to the endpoint, the status
here is Update with a warning icon to notify you the
policy has been changed but not pushed.

Policy Enforcement Group This is the group to which the policy is assigned.

Log This field displays the log setting for the policy.

Description The user-created description for the policy.

Benefits of Threat Prevention Policy

• Enables you to define and enforce policies for controlling specific applications and embedded social
networking widgets.

• Reduces the need for manual updates and automatically applies policies and enforcement rules,
driving down the costs of managing network security.

• Leverages the network for multiple enforcement points across the infrastructure. Enables you to stop
threats closer to infection points and to prevent threats from spreading, which greatly improves the
efficacy of security operations.
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RELATED DOCUMENTATION

Creating Threat Prevention Policies  |  173
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Creating Geo IP Policies  |  181
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Benefits of Policy Enforcer  |  7

Policy Enforcer Components and Dependencies  |  13

Juniper ATP Cloud Overview

Creating Threat Prevention Policies

You can create threat prevention policies for various profiles from the Policies page.

NOTE: If you are creating policies for the first time, you are given the option of setting
up Policy Enforcer with Juniper ATP Cloud or configuring Juniper ATP Cloud alone.
Clicking either button takes you to quick setup for your selection. See "Comparing the
Juniper Connected Security and non-Juniper Connected Security Configuration Steps"
on page 27 for a configuration comparison.

Before You Begin

• Determine the type of profile you will use for this policy; command & control server, infected hosts,
malware. You can select one or more threat profiles in a policy. Note that you configure Geo IP
policies separately. See "Creating Geo IP Policies" on page 181.

• Determine what action to take if a threat is found.

• Know what policy enforcement group you will add to this policy. To apply the policy, you must assign
one or more policy enforcement groups. See the instructions for assigning groups to policies at the
bottom of this page.

• Once policies are configured with one more groups assigned, you can save a policy in draft form or
update it. Policies changes do not go live until they have been updated.

• If you are using Juniper ATP Cloud without Policy Enforcer, you must assign your threat prevention
policy to a firewall rule for it to take affect. See the instructions at the bottom of this page.

• If you delete a threat prevention policy that is assigned to a policy enforcement group, a status
screen appears displaying the progress of the deletion and the affected configuration items.
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To create a threat prevention policy:

1. Select Configure>Threat Prevention > Policies.

2. Click the + icon.

The Create Threat Prevention Policy page appears.

3. Complete the configuration by using the guidelines in theTable 28 on page 174, Table 29 on page
175, Table 30 on page 175, Table 31 on page 176, and Table 32 on page 179 below.

4. Click OK.

Table 28: Fields on the Threat Prevention Policy Page

Field Description

Name Enter a unique string that must begin with an alphanumeric character and can include
underscores; no spaces allowed; 63-character maximum.

Description Enter a description; maximum length is 1024 characters. You should make this description
as useful as possible for all administrators.

Profiles Include the following profiles to your threat prevention policy. You must include at least
one profile. An error message is shown if you try to create the threat prevention policy
without selecting a profile.

• C&C profile—See Table 29 on page 175.

• Infected host profile—See Table 30 on page 175.

• Malware profile—See Table 31 on page 176.

• DDoS profile—See Table 32 on page 179.

Log Setting (Policy
setting for all
profiles)

Select the log setting for the policy. You can log all traffic, log only blocked traffic, or log no
traffic.

Table 29 on page 175 shows the management of command and control server threat in a policy.
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Table 29: C&C Server Profile Management

Field Description

Command and
Control Server

Select and choose settings for command and control servers. A C&C is a centralized
computer that issues commands to botnets (compromised networks of computers) and
receives reports back from them. Botnets can be used to gather sensitive information, such
as account numbers or credit card information, or to participate in a distributed denial-of-
service (DDoS) attack.

Include C& C
profile in policy

Select the check box to include management for this threat type in the policy.

Threat Score Use the slider to change the action to be taken based on the threat score. Threat scores are
assigned using several criteria. Refer to the monitoring pages in the UI to investigate, located
under Monitor > Threat Management.

Actions If the threat score is high enough to cause a connection to be blocked, you have following
configurable options:

• Drop connection silently (This is the default and recommended setting.)

• Close connection and do not send a message

• Close connection and redirect to URL—In the field provided, enter a URL to redirect
users to when connections are dropped.

• Send custom message—In the field provided, enter a message to be shown to users
when connections are dropped.

Table 30 on page 175 shows the management of infected host threat in a policy.

Table 30: Infected Host Profile Management

Field Description

Infected Host Infected hosts are systems for which there is a high confidence that attackers have gained
unauthorized access. Infected hosts data feeds are listed with the IP address or IP subnet of the
host, along with a threat score.
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Table 30: Infected Host Profile Management (Continued)

Field Description

Include
infected host
profile in
policy

Select the check box to include management for this threat type in the policy.

NOTE: If you want to enforce an infected host policy within the network, you must include a
switch in the site.

Actions You have following options:

• Drop connection silently (This is the default and recommended setting.)

• Monitor—Choose this option to log all the traffic for certain infected hosts and monitor it.
You can then choose to perform any action on the monitored data.

NOTE: The PEG must contain only Space subnets or devices. The Monitor action for the
infected host profile is not applicable to any third party connector devices. An error
message is shown.

• Quarantine—In the field provided, enter a VLAN to which quarantined files are sent. (Note
that the fallback option is to block and drop the connection silently.)

Table 31 on page 176 shows the management of malware threat in a policy.

Table 31: Malware Threat Profile Management

Field Description

Malware (HTTP file
download, SMTP
File attachment,
and IMAP
attachments)

Malware is files that are downloaded by hosts or received as email attachments and found
to be suspicious based on known signatures, URLs. or other heuristics.

Include malware
profile in policy

Select the check box to include management for this threat type in the policy.

HTTP file download Turn this feature on to scan files downloaded over HTTP and then select a file scanning
device profile. The device profile is configured using Juniper ATP Cloud.
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Table 31: Malware Threat Profile Management (Continued)

Field Description

Scan HTTPS Turn this feature to scan encrypted files downloaded over HTTPS.

Device Profile Select ATP Cloud device profile. This is configured through ATP Cloud. ATP Cloud profiles
let you define which files to send to the cloud for inspection. You can group types of files
to be scanned together under a common name and create multiple profiles based on the
content you want scanned.

Actions If the threat score is high enough to cause a connection to be blocked, you have following
configurable options:

• Drop connection silently (This is the default and recommended setting.)

• Close connection and do not send a message

• Close connection and redirect to URL—In the field provided, enter a URL to
redirect users to when connections are dropped.

• Send custom message—In the field provided, enter a message to be shown to users
when connections are dropped.

SMTP File
Attachments

Turn this feature on to inspect files received as email attachments (over SMTP only).

Scan SMTPS Enable this option to configure reverse proxy for SMTP.

The reverse proxy does not prohibit server certificates. It forwards the actual server
certificate or chain as is to the client without modifying it.

Device Profile If you do not click the Change button to select a device profile for SMTP scanning, the
device profile selected for HTTP will be used by default.

Select Change to use a different device profile for SMTP.

Device profiles are configured through ATP Cloud and define which files to send to the
cloud for inspection.

Threat Score Use the slider to change the action to be taken based on the threat score. Threat scores
are assigned using several criteria. This threat score applies to all malware, HTTP and
SMTP. (Note: There is no monitoring setting for malware.)
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Table 31: Malware Threat Profile Management (Continued)

Field Description

Actions Actions for SMTP File Attachments include: Quarantine, Deliver malicious messages with
warning headers added, and Permit. This actions are set in ATP Cloud. Refer to the Juniper
ATP Cloud documentation for information.

IMAP Attachments Turn this feature on to select a a file scanning device profile and threat score ranges to
apply to IMAP e-mails.

Scan IMAPS Enable this option to configure reverse proxy for IMAP e-mails.

Device Profile If you do not click the Change button to select a device profile for IMAP scanning, the
device profile selected for HTTP will be used by default.

Select Change to use a different device profile for IMAP.

Device profiles are configured through ATP Cloud and define which files to send to the
cloud for inspection.

Actions Actions for IMAP Attachments include: Block, Deliver malicious messages with warning
headers added, and Permit. This actions are set in ATP Cloud. Refer to the Juniper ATP
Cloud documentation for information.

Threat Score Use the slider to change the action to be taken based on the threat score. Threat scores
are assigned using several criteria. This threat score applies to all malware, HTTP, SMTP,
and IMAP. (Note: There is no monitoring setting for malware.)

Table 32 on page 179 shows the management of DDoS threat in a policy
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Table 32: DDoS Threat Profile Management

Field Description

Include DDoS
Profile in
Policy

Enable this option to include the management of Distributed denial-of-service (DDoS)
protection that enables the MX router to quickly identify an attack and prevent a flood of
malicious control packets from exhausting system resources.

When you create a threat policy for the DDoS profile, it is not pushed to the device because the
policy is not yet assigned to any device. Assign the policy to the policy enforcement group.
Because the policy is created for the MX router, rule analysis is not initiated when a policy is
assigned to the policy enforcement group (PEG).

Actions Select the following actions from the list for the DDoS profile:

• Block—Use this option to block the DDoS attack.

• Rate Limit Value—Use this option to limit the bandwidth on the flow route. You can express
the rate limit value in Kbps, Mbps, or Gbps units. The rate limit range is 10Kbps to 100Gbps.

• Forward to—Use this option to configure the routing next hop to forward the packets for
scrubbing.

Scrubbing Site Specify a routing instance to which packets are forwarded in the as-number:community-value
format, where each value is a decimal number. For example, 65001:100.

Once you have a threat prevention policy, you assign one or more groups to it:

1. In the threat prevention policy main page (located under Configure>Threat Prevention > Policy), find
the appropriate policy.

2. In the Policy Enforcement Groups column, click the Assign to Groups link that appears here when
there are no policy enforcement groups assigned or click the group name that appears in this column
to edit the existing list of assigned groups. You can also select the check box beside a policy and click
the Assign to Groups button at the top of the page. See "Policy Enforcement Groups Overview" on
page 167 .

For the infected host profiles created with Monitor action, you cannot assign a policy enforcement
group if it contains only the third-party connector devices or the combination of both Junos Space
and third-party connector devices. You must have only the Junos Space subnets in the policy
enforcement groups to assign them to the infected host profiles with Monitor action.

If you edit an existing infected host profile with either Drop Connection or Quarantine action to
Monitor action, you cannot assign any policy enforcement group having only third-party connector
devices or the combination of Junos Space and third-party connector devices.
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3. In the Assign to Groups page, select the check box beside a group in the Available list and click the >
icon to move it to the Selected list. The groups in the Selected list will be assigned to the policy.

4. Click OK.

5. Once one or more policy enforcement groups have been assigned, a Ready to Update link appears in
the Status column. You must update to apply your new or edited policy configuration. Clicking the
Ready to Update link takes you the Threat Policy Analysis page. See "Threat Policy Analysis
Overview" on page 180. From there you can view your changes and choose to Update now, Update
later, or Save them in draft form without updating.

6. If you are using Juniper ATP Cloud without Policy Enforcer, you must assign your threat prevention
policy to a firewall rule for it to take affect. Navigate to Configure > Firewall Policy > Policies. In the
Advanced Security column, click an item to access the Edit Advanced Security page and select the
threat prevention policy from the Threat Prevention pulldown list.

RELATED DOCUMENTATION

Comparing the Juniper Connected Security and non-Juniper Connected Security Configuration
Steps  |  27

Creating Policy Enforcement Groups  |  168

Threat Policy Analysis Overview  |  180

Creating Geo IP Policies  |  181

Threat Prevention Policy Overview  |  170

Policy Enforcer Overview  |  4

Benefits of Policy Enforcer  |  7

Policy Enforcer Components and Dependencies  |  13

Juniper ATP Cloud Overview

Threat Policy Analysis Overview

In the Threat Prevention Policies page, click the Ready to Update link in the Status column to update
policy changes. Policies must be updated before they can go live.
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NOTE: If the policy has been updated after it has already been pushed to the endpoint,
the status here is Update with a warning icon to notify you that the policy has been
changed but not pushed.

Use the threat policy analysis page to view your pending policy changes in chronological order. Click the
View Analysis link to view the changes. In the Action section, you can select to Update now, Update
later, or Save the changes without updating. If you select to update later, you can schedule a time to
update.

By clicking on the policy links, you can update only the policies you select and choose not to update
others.

RELATED DOCUMENTATION

Threat Prevention Policy Overview  |  170

Creating Threat Prevention Policies  |  173

Geo IP Overview

Geo IP refers to the method of locating a computer terminal's geographic location by identifying that
terminal's IP address. A Geo IP feed is an up-to-date mapping of IP addresses to geographical regions.
By mapping IP address to the sources of attack traffic, geographic regions of origin can be determined,
giving you the ability to filter traffic to and from specific locations in the world.

RELATED DOCUMENTATION

Creating Geo IP Policies  |  181

Threat Prevention Policy Overview  |  170

Juniper ATP Cloud Realm Overview

Creating Geo IP Policies

You can create Geo IP policies from the Geo IP policies page.
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Before You Begin

• You must have Juniper ATP Cloud account to receive Geo IP feeds. Make sure you configure the
necessary steps for Juniper ATP Cloud before creating a Geo IP policy.

• Geo IP filtering is a useful tool when you are experiencing certain types of attacks, such as DDOS
from specific geographical locations.

• If you are using Juniper ATP Cloud without Policy Enforcer, you must select your Geo IP policy as the
source and/or destination of a firewall rule to apply it.

To create a Geo IP policy:

1. Select Configure>Shared Objects>Geo IP.

2. Click the + icon.

3. Complete the configuration by using the guidelines in Table 33 on page 182 below.

4. Click OK.

Table 33: Fields on the Geo IP Policy Page

Name Enter a unique string that must begin with an alphanumeric character and can include
underscores; no spaces allowed; 63-character maximum.

Description Enter a description; maximum length is 1024 characters. You should make this description as
useful as possible for all administrators.

Countries Select the check box beside the countries in the Available list and click the > icon to move them to
the Selected list. The countries in the Selected list will be included in the policy and action will be
taken according to their threat level.

Block Traffic Choose what traffic to block from the selected countries. Incoming traffic, Outgoing traffic, or
Incoming and Outgoing traffic. (Policy Enforcer only)

Log Setting Choose to log all traffic or only blocked traffic. (Policy Enforcer only)

Once you have a Geo IP policy, you assign it to one more groups (Policy Enforcer only):

To assign a Geo IP policy to a group or groups:

1. In the Group column, click the Assign to Groups link that appears here when there are no groups
assigned or click the group name that appears in this column to edit the existing list of assigned
groups.
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2. In the Assign to Groups page, select the check box beside a group in the Available list and click the >
icon to move it to the Selected list. The groups in the Selected list will be assigned to the policy.

3. Click OK.

4. Once one or more groups have been assigned, a Ready to Update link appears in the Status column.
You must update to apply your new or edited policy configuration. Clicking the Ready to Update link
takes you the Threat Policy Analysis page. See "Threat Policy Analysis Overview" on page 180. From
there you can view your changes and choose to Update now, Update later, or Save them in draft
form without updating.

5. If you are using Juniper ATP Cloud without Policy Enforcer, you must select your Geo IP policy as the
source and/or destination of a firewall rule. Navigate to Configure > Firewall Policy > Policies.

RELATED DOCUMENTATION

Creating Policy Enforcement Groups  |  168

Creating Threat Prevention Policies  |  173

Threat Policy Analysis Overview  |  180

Geo IP Overview  |  181

Configuring Cloud Feeds Only  |  202

183



9
CHAPTER

Configuring Juniper ATP Cloud
(without Guided Setup)

IN THIS CHAPTER

Configuring Juniper ATP Cloud (No Juniper Connected Security and No
Guided Setup) Overview  |  185

Juniper ATP Cloud Realm Overview  |  186

Creating Juniper ATP Cloud Realms and Enrolling Devices or Associating
Sites  |  187

Threat Prevention Policy Overview  |  191

Creating Threat Prevention Policies  |  193

 



Configuring Juniper ATP Cloud (No Juniper
Connected Security and No Guided Setup) Overview

This is an outline of the configuration tasks you must complete to configure Juniper ATP Cloud mode
without Juniper Connected Security mode.

NOTE: Configuring Policy Enforcer (Juniper Connected Security mode) is required if you
want to work on the Juniper Connected Security architecture from within Security
Director.

If you prefer to use guided setup, which automatically takes you through the steps listed below, it is
located under Configure>Guided Setup >ATP Cloud.

• Juniper ATP Cloud license and account are needed for all threat prevention types (Juniper ATP Cloud
with PE, Juniper ATP Cloud, and Cloud Feeds only). If you do not have a Juniper ATP Cloud license,
contact your local sales office or Juniper Networks partner to place an order for a Juniper ATP Cloud
premium license. If you do not have a Juniper ATP Cloud account, when you configure Juniper ATP
Cloud, you are redirected to the Juniper ATP Cloud server to create one. Please obtain a license
before you try to create a Juniper ATP Cloud account. Refer to Obtaining a Juniper ATP Cloud
License for instructions on obtaining a Juniper ATP Cloud premium license.

• Before you configure Juniper ATP Cloud you must enter the IP address and login credentials for the
policy enforcer virtual machine. Go to Administration > Policy Enforcer > Settings. Once this
information is entered, you can begin the setup process. See Policy Enforcer Settings. (Refer to
"Policy Enforcer Installation Overview" on page 31 for instructions on downloading Policy Enforcer
and creating your policy enforcer virtual machine.)

1. Create one or more Juniper ATP Cloud realms and enroll SRX Series devices in the appropriate realm.
(Enroll devices by clicking Add Devices in the list view once the realm is created.)

In the UI, navigate to Configure>Threat Prevention>ATP Cloud Realms. Click the + icon to add a new
ATP Cloud realm.

See Creating Juniper ATP Cloud Realms and Enrolling Devices or Associating Sites for details.

2. Create a threat prevention policy, including profiles for one or more threat types: C&C server,
infected host, or malware.

In the UI, navigate to Configure>Threat Prevention >Policy. Click the + icon to create a new threat
prevention policy.

See "Creating Threat Prevention Policies" on page 173 for details.
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3. You must assign a threat prevention policy to a firewall rule before it can take affect.

In the UI, navigate to Configure > Firewall Policy > Policies. In the Advanced Security column, click an
item to access the Edit Advanced Security page and select the threat prevention policy from the
Threat Prevention pulldown list.

RELATED DOCUMENTATION

Creating Juniper ATP Cloud Realms and Enrolling Devices or Associating Sites

Creating Threat Prevention Policies  |  173

Creating Geo IP Policies  |  181

Juniper ATP Cloud Realm Overview

A security realm is a group identifier for an organization used to restrict access to Web applications. You
must create at least one security realm to login into Juniper ATP Cloud. Once you create a realm, you
can enroll SRX Series devices into the realm. You can also give more users (administrators) permission to
access the realm.

If you have multiple security realms, note that each SRX Series device can only be bound to one realm,
and users cannot travel between realms.

RELATED DOCUMENTATION

About the Feed Sources Page  |  240

Creating Juniper ATP Cloud Realms and Enrolling Devices or Associating Sites

Using Guided Setup for Juniper ATP Cloud

Configuring Juniper ATP Cloud (No Juniper Connected Security and No Guided Setup) Overview
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Creating Juniper ATP Cloud Realms and Enrolling
Devices or Associating Sites

You can select a geographical location and enter your Juniper ATP Cloud credentials to create a realm
and associate sites or devices with the realm.

If you do not have Juniper ATP Cloud account, select a geographical region and click here. You are
redirected to the Juniper ATP Cloud account page.

Before You Begin

•
NOTE: 

• Policy Enforcer does not support the Multi-factor authentication (MFA) feature in
Cloud ATP. Disable the MFA feature in the Cloud ATP before adding realms to the
Security Director.

• You cannot use single sign-on (SSO) credentials to add the Juniper ATP realm to
Security Director.

Use the login credentials used to create the realm.

• Understand which type of Juniper ATP Cloud license you have: free, basic, or premium. The license
controls which Juniper ATP Cloud features are available.

• To configure a Juniper ATP Cloud realm, you must already have Juniper ATP Cloud account with an
associated license.

• Ensure that the internet connectivity is available for Policy Enforcer. Without the internet
connectivity, you cannot create a realm.

• Decide which region will be covered by the realm you are creating. You must a select a region when
you configure a realm.

• Note that adding a device to a realm results in one or more commit operations occurring on the
device to apply the Juniper ATP Cloud or Policy Enforcer configuration.

To configure ATP Cloud Realm:

1. Select Configure>Threat Prevention>Feed Sources.

The Feed Sources page appears.

2. In the ATP Cloud tab, click the + icon to add a realm.

3. Complete the initial configuration by using the guidelines in Table 34 on page 188 below.
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4. Click Finish.

Table 34: Fields on the Add ATP Cloud Realm Page

Field Description

ATP Cloud Realm Credentials

Location Select a region of the world from the available choices.

The following options are available in the Location list:

• North America

• European Region

• Canada

• Asia Pacific

By default, the North America value appears in the list. To know more about the geographic
region, see here.

Username Enter your e-mail address. Your username for Juniper ATP Cloud is your e-mail address.

Password Enter a unique string at least 8 characters long. Include both uppercase and lowercase letters,
at least one number, and at least one special character (~!@#$%^&*()_-+={}[]|:;<>,./?); no
spaces are allowed, and you cannot use the same sequence of characters that are in your
username.

Realm Enter a name for the security realm. This should be a name that is meaningful to your
organization. A realm name can only contain alphanumeric characters and the dash symbol.
Once created, this name cannot be changed.

NOTE: When you create a custom feed with a realm, the feed is associated at the site level
and not at the realm level. If you modify this realm and associate new sites to it, a warning
message is shown that there are custom feeds are associated with this realm. Changing the
site information will change the custom feed information. You must go and edit the custom
feed that was associated with this realm and verify the realm association.

Site
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Table 34: Fields on the Add ATP Cloud Realm Page (Continued)

Field Description

Site Select one or more sites to enroll into the realm. If there are no sites associated with the realm,
click Create new site. To know more about creating a new site, see "Creating Secure Fabric and
Sites" on page 160.

NOTE: 

• If you are using Juniper ATP Cloud without Policy Enforcer, you are not prompted to
select a site.

• Assigning a site to the realm will cause a change in the device configuration in the
associated devices.

• You must select the sites either with tenants or without tenants. You cannot select both
at a time.

Unmanaged
Devices

Lists all devices from the realm that are not managed in Security Director. You must manually
discover them.

If you are using Juniper ATP Cloud with Policy Enforcer and you have no devices enrolled in
the realm, you are asked to select devices in the box on the left and move them to the right to
enroll them. All selected devices are automatically enrolled with Juniper ATP Cloud when you
finish the guided setup. To disenroll a device, you can edit a realm and move the device back to
the left side box.

NOTE: Adding a device to a realm results in one or more commit operations occurring on
the device to apply the Juniper ATP Cloud or Policy Enforcer configuration.

Global Configuration

IPv6 Feeds Enable this option to receive IPv6 feeds (C&C and Geo IP) from Policy Enforcer.

Threat Level
Threshold

Select a threshold level to block the infected hosts and to send an e-mail to the selected
administrators notifying about the infected host events.

Click the+ sign if you want to add new administrators to the list.

Logging Enable this option to log the Malware or the Host Status event or both the event types.
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Table 34: Fields on the Add ATP Cloud Realm Page (Continued)

Field Description

Proxy Servers Click the add icon (+) to enter the trusted IPv4 address of the proxy server, in the Server IP
column.

When there is a proxy server between users on the network and a firewall, the firewall might
see the proxy server IP address as the source of an HTTP or HTTPS request, instead of the
actual address of the user making the request.

With this in mind, X-Forwarded-For (XFF) is a standard header added to packets by a proxy
server that includes the real IP address of the client making the request. Therefore, if you add
trusted proxy servers IP addresses to the list in Juniper ATP Cloud, by matching this list with
the IP addresses in the HTTP header (X-Forwarded-For field) for requests sent from the SRX
Series devices, Juniper ATP Cloud can determines the originating IP address.

NOTE: XFF only applies to HTTP or HTTPS traffic, and only if the proxy server supports the
XFF header.

NOTE: If you enrolled a device into a realm from within Security Director and you want
to disenroll it, you must do that from within Security Director. If you enrolled a device
into a realm from within Juniper ATP Cloud and you want to disenroll it, you must do
that from within Juniper ATP Cloud. You cannot disenroll a device from within Security
Directory that was enrolled from within Juniper ATP Cloud.

RELATED DOCUMENTATION

About the Feed Sources Page  |  240

Juniper ATP Cloud Realm Overview

Juniper ATP Cloud Overview  |  9

Creating Secure Fabric and Sites  |  160
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Threat Prevention Policy Overview

IN THIS SECTION

Benefits of Threat Prevention Policy  |  192

Threat prevention policies provide protection and monitoring for selected threat profiles, including
command and control servers, infected hosts, and malware. Using feeds from ATP Cloud and optional
custom feeds that you configure, ingress and egress traffic is monitored for suspicious content and
behavior. Based on a threat score, detected threats are evaluated and action may be taken once a
verdict is reached.

Once policies are configured, the following fields are available on the Security Director main page to
provide an overview of each policy.

Table 35: Threat Prevention Policy Fields

Field Description

Name The user-created name for the policy.

Profile: C&C Server Threat score settings overview if selected for the
policy. (Otherwise this field is empty.) For example:

Block: 8-10

Monitor: 5-7

Permit: 1-4

Profile: Infected Host Threat score settings overview if selected for the
policy. (Otherwise this field is empty.)

Profile: Malware HTTP Threat score settings overview if selected for the
policy. (Otherwise this is empty.)
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Table 35: Threat Prevention Policy Fields (Continued)

Field Description

Profile: Malware SMTP Threat score settings overview if selected for the
policy. (Otherwise this field is empty.)

Status This displays the status of the policy. This status is a
clickable link you can use to change the policy status.
When you first create a policy and assign it to a group,
this field reads View Analysis. Read "Threat Policy
Analysis Overview" on page 180 for more information
on this field.

If the status is Update Failed, click Retry to perform the
rule analysis again. You can click the Update Failed
status to see the corresponding job details. The rule
analysis retry option is available only when the status is
Update Failed.

NOTE: If the policy has been updated after it has
already been pushed to the endpoint, the status
here is Update with a warning icon to notify you the
policy has been changed but not pushed.

Policy Enforcement Group This is the group to which the policy is assigned.

Log This field displays the log setting for the policy.

Description The user-created description for the policy.

Benefits of Threat Prevention Policy

• Enables you to define and enforce policies for controlling specific applications and embedded social
networking widgets.

• Reduces the need for manual updates and automatically applies policies and enforcement rules,
driving down the costs of managing network security.
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• Leverages the network for multiple enforcement points across the infrastructure. Enables you to stop
threats closer to infection points and to prevent threats from spreading, which greatly improves the
efficacy of security operations.

RELATED DOCUMENTATION

Creating Threat Prevention Policies  |  173

Policy Enforcement Groups Overview  |  167

Creating Geo IP Policies  |  181

Policy Enforcer Overview  |  4

Benefits of Policy Enforcer  |  7

Policy Enforcer Components and Dependencies  |  13

Juniper ATP Cloud Overview

Creating Threat Prevention Policies

You can create threat prevention policies for various profiles from the Policies page.

NOTE: If you are creating policies for the first time, you are given the option of setting
up Policy Enforcer with Juniper ATP Cloud or configuring Juniper ATP Cloud alone.
Clicking either button takes you to quick setup for your selection. See "Comparing the
Juniper Connected Security and non-Juniper Connected Security Configuration Steps"
on page 27 for a configuration comparison.

Before You Begin

• Determine the type of profile you will use for this policy; command & control server, infected hosts,
malware. You can select one or more threat profiles in a policy. Note that you configure Geo IP
policies separately. See "Creating Geo IP Policies" on page 181.

• Determine what action to take if a threat is found.

• Know what policy enforcement group you will add to this policy. To apply the policy, you must assign
one or more policy enforcement groups. See the instructions for assigning groups to policies at the
bottom of this page.

• Once policies are configured with one more groups assigned, you can save a policy in draft form or
update it. Policies changes do not go live until they have been updated.
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• If you are using Juniper ATP Cloud without Policy Enforcer, you must assign your threat prevention
policy to a firewall rule for it to take affect. See the instructions at the bottom of this page.

• If you delete a threat prevention policy that is assigned to a policy enforcement group, a status
screen appears displaying the progress of the deletion and the affected configuration items.

To create a threat prevention policy:

1. Select Configure>Threat Prevention > Policies.

2. Click the + icon.

The Create Threat Prevention Policy page appears.

3. Complete the configuration by using the guidelines in theTable 36 on page 194, Table 37 on page
195, Table 38 on page 195, Table 39 on page 196, and Table 40 on page 199 below.

4. Click OK.

Table 36: Fields on the Threat Prevention Policy Page

Field Description

Name Enter a unique string that must begin with an alphanumeric character and can include
underscores; no spaces allowed; 63-character maximum.

Description Enter a description; maximum length is 1024 characters. You should make this description
as useful as possible for all administrators.

Profiles Include the following profiles to your threat prevention policy. You must include at least
one profile. An error message is shown if you try to create the threat prevention policy
without selecting a profile.

• C&C profile—See Table 37 on page 195.

• Infected host profile—See Table 38 on page 195.

• Malware profile—See Table 39 on page 196.

• DDoS profile—See Table 40 on page 199.

Log Setting (Policy
setting for all
profiles)

Select the log setting for the policy. You can log all traffic, log only blocked traffic, or log no
traffic.

Table 37 on page 195 shows the management of command and control server threat in a policy.
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Table 37: C&C Server Profile Management

Field Description

Command and
Control Server

Select and choose settings for command and control servers. A C&C is a centralized
computer that issues commands to botnets (compromised networks of computers) and
receives reports back from them. Botnets can be used to gather sensitive information, such
as account numbers or credit card information, or to participate in a distributed denial-of-
service (DDoS) attack.

Include C& C
profile in policy

Select the check box to include management for this threat type in the policy.

Threat Score Use the slider to change the action to be taken based on the threat score. Threat scores are
assigned using several criteria. Refer to the monitoring pages in the UI to investigate, located
under Monitor > Threat Management.

Actions If the threat score is high enough to cause a connection to be blocked, you have following
configurable options:

• Drop connection silently (This is the default and recommended setting.)

• Close connection and do not send a message

• Close connection and redirect to URL—In the field provided, enter a URL to redirect
users to when connections are dropped.

• Send custom message—In the field provided, enter a message to be shown to users
when connections are dropped.

Table 38 on page 195 shows the management of infected host threat in a policy.

Table 38: Infected Host Profile Management

Field Description

Infected Host Infected hosts are systems for which there is a high confidence that attackers have gained
unauthorized access. Infected hosts data feeds are listed with the IP address or IP subnet of the
host, along with a threat score.
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Table 38: Infected Host Profile Management (Continued)

Field Description

Include
infected host
profile in
policy

Select the check box to include management for this threat type in the policy.

NOTE: If you want to enforce an infected host policy within the network, you must include a
switch in the site.

Actions You have following options:

• Drop connection silently (This is the default and recommended setting.)

• Monitor—Choose this option to log all the traffic for certain infected hosts and monitor it.
You can then choose to perform any action on the monitored data.

NOTE: The PEG must contain only Space subnets or devices. The Monitor action for the
infected host profile is not applicable to any third party connector devices. An error
message is shown.

• Quarantine—In the field provided, enter a VLAN to which quarantined files are sent. (Note
that the fallback option is to block and drop the connection silently.)

Table 39 on page 196 shows the management of malware threat in a policy.

Table 39: Malware Threat Profile Management

Field Description

Malware (HTTP file
download, SMTP
File attachment,
and IMAP
attachments)

Malware is files that are downloaded by hosts or received as email attachments and found
to be suspicious based on known signatures, URLs. or other heuristics.

Include malware
profile in policy

Select the check box to include management for this threat type in the policy.

HTTP file download Turn this feature on to scan files downloaded over HTTP and then select a file scanning
device profile. The device profile is configured using Juniper ATP Cloud.
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Table 39: Malware Threat Profile Management (Continued)

Field Description

Scan HTTPS Turn this feature to scan encrypted files downloaded over HTTPS.

Device Profile Select ATP Cloud device profile. This is configured through ATP Cloud. ATP Cloud profiles
let you define which files to send to the cloud for inspection. You can group types of files
to be scanned together under a common name and create multiple profiles based on the
content you want scanned.

Actions If the threat score is high enough to cause a connection to be blocked, you have following
configurable options:

• Drop connection silently (This is the default and recommended setting.)

• Close connection and do not send a message

• Close connection and redirect to URL—In the field provided, enter a URL to
redirect users to when connections are dropped.

• Send custom message—In the field provided, enter a message to be shown to users
when connections are dropped.

SMTP File
Attachments

Turn this feature on to inspect files received as email attachments (over SMTP only).

Scan SMTPS Enable this option to configure reverse proxy for SMTP.

The reverse proxy does not prohibit server certificates. It forwards the actual server
certificate or chain as is to the client without modifying it.

Device Profile If you do not click the Change button to select a device profile for SMTP scanning, the
device profile selected for HTTP will be used by default.

Select Change to use a different device profile for SMTP.

Device profiles are configured through ATP Cloud and define which files to send to the
cloud for inspection.

Threat Score Use the slider to change the action to be taken based on the threat score. Threat scores
are assigned using several criteria. This threat score applies to all malware, HTTP and
SMTP. (Note: There is no monitoring setting for malware.)
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Table 39: Malware Threat Profile Management (Continued)

Field Description

Actions Actions for SMTP File Attachments include: Quarantine, Deliver malicious messages with
warning headers added, and Permit. This actions are set in ATP Cloud. Refer to the Juniper
ATP Cloud documentation for information.

IMAP Attachments Turn this feature on to select a a file scanning device profile and threat score ranges to
apply to IMAP e-mails.

Scan IMAPS Enable this option to configure reverse proxy for IMAP e-mails.

Device Profile If you do not click the Change button to select a device profile for IMAP scanning, the
device profile selected for HTTP will be used by default.

Select Change to use a different device profile for IMAP.

Device profiles are configured through ATP Cloud and define which files to send to the
cloud for inspection.

Actions Actions for IMAP Attachments include: Block, Deliver malicious messages with warning
headers added, and Permit. This actions are set in ATP Cloud. Refer to the Juniper ATP
Cloud documentation for information.

Threat Score Use the slider to change the action to be taken based on the threat score. Threat scores
are assigned using several criteria. This threat score applies to all malware, HTTP, SMTP,
and IMAP. (Note: There is no monitoring setting for malware.)

Table 40 on page 199 shows the management of DDoS threat in a policy
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Table 40: DDoS Threat Profile Management

Field Description

Include DDoS
Profile in
Policy

Enable this option to include the management of Distributed denial-of-service (DDoS)
protection that enables the MX router to quickly identify an attack and prevent a flood of
malicious control packets from exhausting system resources.

When you create a threat policy for the DDoS profile, it is not pushed to the device because the
policy is not yet assigned to any device. Assign the policy to the policy enforcement group.
Because the policy is created for the MX router, rule analysis is not initiated when a policy is
assigned to the policy enforcement group (PEG).

Actions Select the following actions from the list for the DDoS profile:

• Block—Use this option to block the DDoS attack.

• Rate Limit Value—Use this option to limit the bandwidth on the flow route. You can express
the rate limit value in Kbps, Mbps, or Gbps units. The rate limit range is 10Kbps to 100Gbps.

• Forward to—Use this option to configure the routing next hop to forward the packets for
scrubbing.

Scrubbing Site Specify a routing instance to which packets are forwarded in the as-number:community-value
format, where each value is a decimal number. For example, 65001:100.

Once you have a threat prevention policy, you assign one or more groups to it:

1. In the threat prevention policy main page (located under Configure>Threat Prevention > Policy), find
the appropriate policy.

2. In the Policy Enforcement Groups column, click the Assign to Groups link that appears here when
there are no policy enforcement groups assigned or click the group name that appears in this column
to edit the existing list of assigned groups. You can also select the check box beside a policy and click
the Assign to Groups button at the top of the page. See "Policy Enforcement Groups Overview" on
page 167 .

For the infected host profiles created with Monitor action, you cannot assign a policy enforcement
group if it contains only the third-party connector devices or the combination of both Junos Space
and third-party connector devices. You must have only the Junos Space subnets in the policy
enforcement groups to assign them to the infected host profiles with Monitor action.

If you edit an existing infected host profile with either Drop Connection or Quarantine action to
Monitor action, you cannot assign any policy enforcement group having only third-party connector
devices or the combination of Junos Space and third-party connector devices.
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3. In the Assign to Groups page, select the check box beside a group in the Available list and click the >
icon to move it to the Selected list. The groups in the Selected list will be assigned to the policy.

4. Click OK.

5. Once one or more policy enforcement groups have been assigned, a Ready to Update link appears in
the Status column. You must update to apply your new or edited policy configuration. Clicking the
Ready to Update link takes you the Threat Policy Analysis page. See "Threat Policy Analysis
Overview" on page 180. From there you can view your changes and choose to Update now, Update
later, or Save them in draft form without updating.

6. If you are using Juniper ATP Cloud without Policy Enforcer, you must assign your threat prevention
policy to a firewall rule for it to take affect. Navigate to Configure > Firewall Policy > Policies. In the
Advanced Security column, click an item to access the Edit Advanced Security page and select the
threat prevention policy from the Threat Prevention pulldown list.
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Configuring Cloud Feeds Only

This in an outline of the configuration tasks you must complete to configure Cloud feeds only threat
prevention.

NOTE: Since devices are not enrolled to ATP Cloud in Cloud feed only mode, there is no
information to display under Monitor > Threat Prevention, and therefore those screens
are unavailable.

• Juniper ATP Cloud license and account are needed for the following (Juniper ATP Cloud with Juniper
Connected Security, Juniper ATP Cloud, and Cloud feeds only). If you do not have a Juniper ATP
Cloud license, contact your local sales office or Juniper Networks partner to place an order for a
Juniper ATP Cloud premium license. If you do not have a Juniper ATP Cloud account, when you
configure Juniper ATP Cloud, you are redirected to the Juniper ATP Cloud server to create one.
Please obtain a license before you try to create a Juniper ATP Cloud account. Refer to Obtaining a
Juniper ATP Cloud License for instructions on obtaining a Juniper ATP Cloud premium license.

• Before you configure Cloud Feeds you must enter the IP address and login credentials for the policy
enforcer virtual machine. Go to Administration > Policy Enforcer > Settings. Once this information is
entered, you can begin the setup process. See Policy Enforcer Settings. (Refer to "Deploying and
Configuring the Policy Enforcer with OVA files" on page 33 for instructions on downloading Policy
Enforcer and creating your policy enforcer virtual machine.)

To configure Security Director for Cloud feed only threat prevention, do the following:

NOTE: Cloud feed only configuration is similar to ATP Cloud (without Juniper Connected
Security) configuration. The only differences being that devices do not have to be
enrolled to Juniper ATP Cloud and the only threat prevention types available are
command and control server and Geo IP.

1. Create a tenant representing an Enterprise. When a tenant is created, a VRF is assigned to the
tenant.

In the UI, navigate to Devices >Secure Fabric > Tenants. Click the + icon to create a new tenant.

See "Create Secure Fabric Tenants" on page 166 for details.

NOTE: In Policy Enforcer Release 20.1R1, only MX series devices support LSYS and
VRF. Also, only root-logical system is supported. All the sites of a realm are either with
tenants or without tenants.
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2. Create one or more Juniper ATP Cloud realms and add devices to the realm. (Note that devices do
not have to be enrolled to Juniper ATP Cloud for Cloud Feed only mode.)

In the UI, navigate to Configure>Threat Prevention>ATP Cloud Realms. Click the + icon to add a new
ATP Cloud realm.

See Creating Juniper ATP Cloud Realms and Enrolling Devices or Associating Sites for details.

3. Create sites and add devices to those sites.

In the UI, navigate to Devices >Secure Fabric. Click the + icon to create a new site.

See "Creating Secure Fabric and Sites" on page 160 for details.

4. Create a policy enforcement group.

In the UI, navigate to Configure>Shared Objects>Policy Enforcement Groups. Click the + icon to
create a new policy enforcement group.

See "Creating Policy Enforcement Groups" on page 168 for details.

5. Create a threat prevention policy for Command and Control server, Geo IP, or Infected hosts.

In the UI, navigate to Configure>Threat Prevention >Policy. Click the + icon to create a new threat
prevention policy.

See "Creating Threat Prevention Policies" on page 173 for details.

6. Configure Geo IP settings for inclusion in a firewall policy. See "Creating Geo IP Policies" on page
181.

You must select your Geo IP policy as the source and/or destination of a firewall rule before it can
take effect. Navigate to Configure > Firewall Policy > Policies.

RELATED DOCUMENTATION
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Secure Fabric Overview

Secure Fabric is a collection of sites which contain network devices (switches, routers, firewalls, and
other security devices), used in policy enforcement groups. When threat prevention policies are applied
to policy enforcement groups, the system automatically discovers to which sites those groups belong.
This is how threat prevention is aggregated across your secure fabric.

• Add Enforcement Points—Click the Add Enforcement Points link to add Firewalls, Switches, and/or
Connectors. There is a one-to-one mapping between devices with sites. If a device is mapped to a
site, you cannot use the same device to map to a different site. The connector can be mapped to
multiple sites. To filter by type, click the three vertical dots beside the search field and select the
check box for the device type. See "Creating Secure Fabric and Sites" on page 160 for more
information.

• Drag and Drop Enforcement Points—From the main page, you can select enforcement points and
drag them to other sites to include them there. When you drag, the enforcement point is disenrolled
from the current site and gets enrolled to the new site where the enforcement point is dropped.

You can either have switches or a connector as enforcement points and not both. However, you can
drag a switch and add to a site that already has a switch or SRX Series device.

Table 41 on page 205 shows fields on the Secure Fabric page.

Table 41: Secure Fabric Page Fields

Field Description

Site Specifies the name of the secure fabric site.

Tenant Specifies the name of the secure fabric tenant.
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Table 41: Secure Fabric Page Fields (Continued)

Field Description

Enforcement Points Specifies the enforcement points for that particular site, if enforcement points are already
added. If not added, click Add Enforcement Points to add Firewalls, Switches, or
Connectors as enforcement points.

A firewall icon is shown against some of the devices to indicate that they are the perimeter
firewalls.

For connectors, if you hover over the enforcement point, a tool tip is shown listing the
corresponding vSRX devices with IP addresses and descriptions.

NOTE: If tenant is configured to the site, only MX Series device can be added as
enforcement points.

IP Specifies the IP address of the enforcement point, if the enforecement point is available.

Model Specifies the type of the enforcement point. For example, vSRX, QFX, Connector.

Feed Source Specifies the feed source to Policy Enforcer.

ATP Cloud Enroll
Status

Specifies the status of the Juniper ATP Cloud enrollment.

The Success status with a warning symbol indicates that the device is enabled for cloud
feeds only and there is no support for malware capability and enhanced mode. This field
will be blank if the device fails to disenroll Juniper ATP Cloud.

If the status is Failed, click Retry to enroll the device with Juniper ATP Cloud again. You can
hover over the Failed status to see the corresponding job details. The device enroll retry
option is available only when the status is Failed.

Last Updated Specifies the date on which the Secure Fabric page was last updated.

Description Specifies the description that you had entered at the time of creating a secure fabric site.

RELATED DOCUMENTATION
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Policy Enforcement Groups Overview  |  167

Threat Prevention Policy Overview  |  170

Creating Secure Fabric and Sites

You can create sites within your secure fabric from the secure fabric page.

Before You Begin

• Plan out your sites in advance. A site is a grouping of network devices, including firewalls and
switches, that contribute to threat prevention.

• Keep in mind that when you create a site, you must identify the perimeter firewalls so you can enroll
them with Juniper ATP Cloud/JATP.

• If you want to enforce an infected host policy within the network, you must assign a switch to the
site.

• SRX Series devices cannot belong to multiple sites.

• MX Series devices associated with tenants can belong to multiple sites.

• Sites that are associated with tenants do not need switches as enforcement points.

• Switches and connectors cannot be added to the same site.

To create a site within your secure fabric:

1. Select Devices>Secure Fabric.

2. Click the + icon.

3. Complete the configuration by using the guidelines in Table 42 on page 207 below.

4. Click OK.

5. Create a new site and add an enforcement point to a site.

Table 42: Create Site Page Fields

Field Description

Site Enter a unique string that must begin with an alphanumeric character and can include underscores;
no spaces allowed; 63-characters maximum.
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Table 42: Create Site Page Fields (Continued)

Field Description

Tenant Select a tenant.

Description Enter a description; maximum length is 1024 characters. You should make this description as useful
as possible for all administrators.

WARNING: If you add certain SRX Series Firewalls to your Secure Fabric as enforcement
points, you may see a warning that the device(s) must be reconfigured in enhanced mode
and require a reboot. Here is a list of SRX models that may require rebooting for
enhanced mode after being registered with Policy Enforcer/Juniper ATP Cloud/JATP.

• SRX340

• SRX345

• SRX650

• SRX240h2

• SRX320

• SRX300

• SRX550

RELATED DOCUMENTATION
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Logical System and Virtual Routing and Forwarding
Instance Overview

IN THIS SECTION

What's Next  |  210

Starting in Policy Enforcer Release 20.1R1, you can create a tenant representing an enterprise and you
can assign a Virtual Routing and Forwarding (VRF) instance to a tenant. The custom feed sends feeds to
Policy Enforcer at the logical system (LSYS) and VRF instance levels on the MX Series device. The VRF
instance is dedicated to handling traffic within the tenant's private network. You can route the traffic on
the tenant’s private network from the VRF instance on the MX Series device at one site to the same
VRF instance on another MX Series device at a different site. The MX Series device supports multiple
VRF instances assigned to different tenants. Therefore, a device can be shared with multiple tenants.

NOTE: In Policy Enforcer Release 20.1R1, only MX Series devices support LSYS and VRF
instance. Also, only root logical system is supported. All the sites of a realm are either
with tenants or without tenants.

When a tenant is created, a VRF instance is assigned to the tenant. When a site is associated with the
tenant, only those devices that have the VRF instance associated with the tenant can be added to the
site. When you associate a site with a realm in Juniper ATP Cloud/JATP, the tenant receives the feeds
configured for the realm. The MX Series device performs policy enforcement based on tenant system
and the associated Juniper ATP Cloud/ATP Appliance realm.

On an MX Series device, VRF instance based feeds such as C&C, allowlist, and blocklist are supported
through custom feeds as shown in Figure 74 on page 210.

NOTE: If you want to use the C&C global feed from ATP Cloud/JATP, then custom feed
for C&C should not be configured in Policy Enforcer.

For, example: VRFx and VRFy are associated with tenants on MX device 1. Custom feed for tenant 1
(VRFx) and custom feed for tenant 2 (VRFy) are associated to each tenant. The custom feed provides
LSYS and VRF instance information. When the device requests for a feed, Policy Enforcer provides all
the feed data associated with the device (global without VRF instance information) in addition to all the
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data for the VRF instances configured on the device that are associated with the tenants configured on
Policy Enforcer.

Figure 74: LSYS and VRF Instance Support
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Creating Juniper ATP Cloud Realms and Enrolling Devices or Associating Sites

"Creating Custom Feeds"  |  216
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About the Feed Sources Page  |  240

About the Secure Fabric Tenants Page

IN THIS SECTION

Tasks You Can Perform  |  211

Field Descriptions  |  211

What's Next  |  212

To access this page, click Devices > Secure Fabric > Tenants.

Starting in Policy Enforcer Release 20.1R1, you can create a tenant representing an enterprise. When a
tenant is created, a VRF instance is assigned to the tenant.

Tasks You Can Perform

You can perform the following tasks from this page:

• Create a tenant. See "Create Secure Fabric Tenants" on page 166.

You can also modify and delete a tenant.

Field Descriptions

Table 43 on page 212 provides guidelines on using the fields on the Secure Fabric Tenants page.
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Table 43: Fields on the Secure Fabric Tenants Page

Field Description

Tenant Specifies the name of the tenant.

LDOM Specifies the root logical system.

VRF Specifies the VRF created on the MX Series device.

Sites Specifies the name of the sites.

WHAT'S NEXT

"Creating Secure Fabric and Sites"  |  160

RELATED DOCUMENTATION

Logical System and Virtual Routing and Forwarding Instance Overview  |  162

Create Secure Fabric Tenants

To create a tenant within your secure fabric:

1. Select Devices > Secure Fabric > Tenants.

2. Click the + icon.

3. Complete the configuration using the guidelines in Table 44 on page 213.

4. Click OK.

A tenant is created. After the tenant is created, it can be associated to a site.
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Table 44: Create Tenant

Field Guidelines

Name Enter a unique string that must begin with an alphanumeric character and can
include underscores; no spaces allowed; 63-character maximum.

LDOM By default, the root logical system is selected, which you cannot edit. In
Policy Enforcer Release 20.1R1, only root logical system is supported.

VRF Enter the virtual routing and forwarding (VRF) instance name, which is
created on the MX Series device.

To edit a tenant, select a tenant and click the pencil icon.

To delete a tenant, select the delete icon. If a tenant is associated to a site, the tenant cannot be deleted.

What's Next

• "Creating Secure Fabric and Sites" on page 160

RELATED DOCUMENTATION

Logical System and Virtual Routing and Forwarding Instance Overview  |  162

Creating Policy Enforcement Groups

You can create policy enforcement groups from the policy enforcement groups page.

Before You Begin

• Know what type of endpoints you are including in your policy enforcement group: IP address/subnet,
or location.

• Determine what endpoints you will add to the group based on how you will configure threat
prevention according to location, users and applications, or threat risk.

• Keep in mind that endpoints cannot belong to multiple policy enforcement groups.

To create a policy enforcement group:
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1. Select Configure>Shared Objects>Policy Enforcement Groups.

2. Click the + icon.

3. Complete the configuration by using the guidelines in the Table 45 on page 214 below.

4. Click OK.

Table 45: Fields on the Policy Enforcement Group Page

Field Description

Name Enter a unique string that must begin with an alphanumeric character and can include only
dashes and underscores; no spaces allowed; 32-character maximum.

Description Enter a description; maximum length is 64 characters. You should make this description as useful
as possible for all administrators.

Group Type Select a group type from the available choices. IP Address/Subnet or Location.
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Table 45: Fields on the Policy Enforcement Group Page (Continued)

Field Description

Connector IPs This field is available only if the Group Type field is IP Address/Subnet

The subnets of all connectors added in the Connector page are dynamically listed in the
Available column. If the Group Type is IP Address/Subnet, the subnets within the connector
instances that have the threat remediation enabled are only listed.

When using Junos Space, Policy Enforcer is able to dynamically discover subnets configured on
Juniper switches. Policy Enforcer does not have the same insight with third-party devices.
Therefore you can add subnets to your connector configuration and select them here. This
allows you to selectively apply policies to those subnets.

If you have not configured a connector, you will see only Junos Space subnets discovered by
Policy Enforcer. If you have a connector configured, you can see the subnets of a connector in
the Available column. Hover over subnets to view the description for these subnets entered
during the connector creation. You will not see any description if it is not entered during creating
a connector. The description will show “No description available” for subnets that come from
Junos Space.

The Available and Selected columns have filters listed with connectors or Space. You can choose
a connector and filter only the subnets belonging to that particular connector. The result shows
the name of a device to which the subnet belongs and also the type of the device.

You can also use the search bar to search and filter the result based on subnet, name of the
device, or type of the device.

Click Refresh Available IPs to refresh the available IP addresses or subnets. If you edit any
selected items in the Selected column, the list is refreshed to the initial selected list after the
refresh. A progress bar is shown with the refresh progress in percentage.

In a scenario where there are no IP addresses or subnets, the refresh will still be successful. A
message is displayed showing that the refresh was successful but there are no IP addresses or
subnets found.

Additional IP This field is available only if the Group Type field is IP Address/Subnet

Enter an IP address and select the connector type from the list to add to PEG. The IP address
must be within the subnet range of the selected connector. Click Add to add the additional IP
address to the Selected column of the Connector IPs field.

A validation is performed to check if the additional IP address is within the subnet range of the
selected connector. If not, an error message is shown to enter the IP address within the subnet
range.
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Table 45: Fields on the Policy Enforcement Group Page (Continued)

Field Description

Sites Sites with the threat remediation enabled instances are only listed, if the Group Type is Location.
Select the check box beside the sites in the Available list and click the > icon to move them to
the Selected list.

The endpoints in the Selected list will be included in the policy enforcement group.

You can create a policy enforcement group with subnets from different connectors based on how they
have grouped their network segments. For example, If you have Junos Space EX switch with subnets
HR: 1.1.1.1/24 and Finance: 2.2.2.2/24, ClearPass connector with subnets HR: 1.1.1.1/24 and
Marketing: 2.2.2.2/24, Cisco ISE with subnets HR: 1.1.1.1/24 and Finance: 2.2.2.2/24. You can create a
single policy enforcement group and name it as HR by choosing the following subnets: Junos Space EX
HR: 1.1.1.1/24, ClearPass connector subnet HR: 1.1.1.1/24, and Cisco ISE connector subnet HR:
1.1.1.1/24.

RELATED DOCUMENTATION
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Using Guided Setup for Juniper ATP Cloud with Juniper Connected Security  |  134

Creating Custom Feeds

Use the Create Custom Feed page to configure the Dynamic Address, Allowlist, Blocklist, Infected Hosts,
DDoS, and C&C Server custom feeds. These feeds provide relevant and timely intelligence that you can
use to create enforcement policies.

Before You Begin

• Know what type of feed you are configuring and have all the necessary information on hand. Local
feeds are created on your local system and uploaded from there.

• Note that infected hosts are hosts known to be compromised. For an infected host custom feed,
enter host IP addresses manually or upload a text file with the IP addresses of infected hosts.

• If you create an allowlist, blocklist, or infected hosts feed, it will override the respective Juniper ATP
Cloud/ATP Appliance feed.
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• Note that when ATP Cloud/ATP Appliance only mode is selected as the Threat Prevention Type, the
infected host and DDoS custom feeds are not available.

To create local file and remote file custom feeds:

1. Select Configure>Threat Prevention> Feed Sources.

The Feed Sources page appears. You will see only custom feeds available as the threat prevention
type, if you make no selection for ATP Cloud/ATP Appliance Configuration Type in the Policy
Enforcer Settings page.

2. Click Create and select one of the following:

• Feeds with local files—Enter your data manually into the provided fields or upload from a text file
on your location machine.

• Feeds with remote file server—Configure communication with the remote server to fetch the data
feed from it.

3. Complete the configuration by using the guidelines in Table 46 on page 217 or Table 47 on page 220.

4. Click OK.

NOTE: 

• To use a custom feed of dynamic-address type, apply it to the source or destination
address in a firewall rule. In the firewall rule, you can filter addresses to show only the
custom feeds.

If there is a firewall policy rule created using the dynamic address, you cannot delete
the same dynamic address from the Feed Sources page. You must first delete the
firewall policy rule and then , delete the dynamic address from the Feed Sources
page.

• When you have no ATP Cloud/ATP Appliance Configuration Type selected (No
selection), ATP Cloud/ATP Appliance realms are disabled. Because site selection is
usually done from the ATP Cloud/ATP Appliance realm page, you must select sites
from the Create Custom Feed page when in “No selection” mode. The custom feeds
are then downloaded to the devices in the chosen sites. This is the only time site
selection available in the Create Custom Feed page.

Table 46: Fields on the Create Custom Feed Page, Feeds with Local Files

Field Description

Name Enter a unique string that must begin with an alphanumeric character and can include only
dashes and underscores; no spaces allowed; 32-character maximum.
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Table 46: Fields on the Create Custom Feed Page, Feeds with Local Files (Continued)

Field Description

Description Enter a description for your custom feed; maximum length is 64 characters. You should make
this description as useful as possible for all administrators.

Feed Type Select one of the following custom feeds as a threat prevention type:

• Dynamic Address

• Allowlist

• Blocklist

• Infected Hosts

• DDoS

• CC

Sites Select the required sites from the list to associate them with the dynamic address or allowlists,
blocklists, or C&C Server feeds.

In the default mode (no ATP Cloud), only sites are listed because of no ATP Cloud. You can
share a site across the same feed type for dynamic address, allowlist, blocklist, and C&C Server.
For Infected hosts and DDoS, sites cannot be shared across the same feed type. However, you
can share a site across different feed types.

Zones/Realms Select the required realms from the list, if you are in Cloud feeds only, ATP Cloud/JATP, or ATP
Cloud/ATP Appliance with Juniper Connected Security mode.

Associate these realms with dynamic address or allowlists, blocklists, and C&C Server feeds.
You can share a realm across the same feed type for dynamic address, allowlist, blocklist, and
CC. For Infected hosts and DDoS, realms cannot be shared across the same feed type.
However, you can share a realm across different feed types.

The ATP Cloud/ATP Appliance realm without any assigned sites are not listed here. Only
realms with sites associated are listed here.

NOTE: If a site is associated with a tenant, the ATP Cloud/ATP Appliance realm displays the
list in the <realm-name>(Tenant:<tenant-name>) format.
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Table 46: Fields on the Create Custom Feed Page, Feeds with Local Files (Continued)

Field Description

User Input
Type

(Available for
Allowlist and
Blocklist)

Select one of the following input types for Allowlist and Blocklist:

• IP, Subnet and Range—Enter an IPV4 address in standard four octet format. CIDR notation
and IP address ranges are also accepted. Any of the following formats are valid: 1.2.3.4,
1.2.3.4/30, or 1.2.3.4-1.2.3.6.

• URL and Domain—The following formats are valid:

• http://www.yourfeed.com

• https://www.yourfeed.com

• www.yourfeed.com

• yourfeed.com

• yourfeed.com/abc

Wildcards and protocols are not valid entries.

Custom List Do one of the following:

• Click Upload File to upload a text file with an IP address list. Click the Add button to include
the address list in your custom list.

For infected host and DDoS, the uploading file must have the string add at the beginning,
followed by the IP addresses. If you want to delete certain IP addresses, enter the string
delete followed by the IP addresses to delete.

Note that the file must contain only one item per line (no commas or semi colons). All items
are validated before being added to the custom list.

The file must not contain more than 500 entries. An error message is shown if you try to
upload a file containing more than 500 IP addresses. Use the Feeds with remote file server
option to upload a file containing more than 500 IP addresses.

• Manually enter your item and threshhold value in the space provided in the Custom List
section. To add more items, click + to add more spaces.

For syntax, enter an IPv4 address in standard four octet format. CIDR notation and IP
address ranges are also accepted. Any of the following formats are valid: 1.2.3.4,
1.2.3.4/30, or 1.2.3.4-1.2.3.6.
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Table 47: Fields on the Create Custom Feed Page, Feeds with Remote File Server

Field Description

Name Enter a unique string that must begin with an alphanumeric character and can include
only dashes and underscores; no spaces allowed; 32-character maximum.

Description Enter a description for your custom feed; maximum length is 64 characters. You should
make this description as useful as possible for all administrators.

Feed Type Select one of the following custom feeds as a threat prevention type:

• Dynamic Address

• Allowlist

• Blocklist

• Infected Hosts

• DDoS

• CC

Type of Server URL Select one of the following:

• http

• https

Server File URL Enter the URL for the remote file server.

Certificate Upload

(If the URL type is
HTTPS)

Click Browse and select the CA certificate to upload.

If you do not upload a certificate for https server URL, a warning message is shown that
a certificate is not uploaded and to whether proceed further or not. Click Yes to proceed
further without uploading a certificate or No to go back and upload the certificate.

Username Enter the credentials for the remote file server.

This is not a mandatory field. You can still proceed to create a custom feed without
entering the username.
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Table 47: Fields on the Create Custom Feed Page, Feeds with Remote File Server (Continued)

Field Description

Password Enter the credentials for the remote file server.

This is a mandatory field, if you have provided the username.

Update Interval Select how often updates are retrieved from the remote files server: Hourly, Daily,
Weekly, Monthly, Never

Sites Select the required sites from the list to associate them with the custom feeds.

If you try to disenroll a site in an infected host, a warning message is shown to resolve all the current
infected hosts from the respective endpoints within a site. To resolve the infected hosts, log-in to ATP
Cloud UI, resolve the hosts, and then unassign sites from Policy Enforcer. Ensure that you always resolve
the infected hosts before unassigning sites. Once you unassign sites, you cannot resolve the hosts.

RELATED DOCUMENTATION

Custom Feed Sources Overview  |  238

About the Feed Sources Page  |  240

Configuring Settings for Custom Feeds  |  272

Threat Prevention Policy Overview

IN THIS SECTION

Benefits of Threat Prevention Policy  |  223

Threat prevention policies provide protection and monitoring for selected threat profiles, including
command and control servers, infected hosts, and malware. Using feeds from ATP Cloud and optional
custom feeds that you configure, ingress and egress traffic is monitored for suspicious content and
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behavior. Based on a threat score, detected threats are evaluated and action may be taken once a
verdict is reached.

Once policies are configured, the following fields are available on the Security Director main page to
provide an overview of each policy.

Table 48: Threat Prevention Policy Fields

Field Description

Name The user-created name for the policy.

Profile: C&C Server Threat score settings overview if selected for the
policy. (Otherwise this field is empty.) For example:

Block: 8-10

Monitor: 5-7

Permit: 1-4

Profile: Infected Host Threat score settings overview if selected for the
policy. (Otherwise this field is empty.)

Profile: Malware HTTP Threat score settings overview if selected for the
policy. (Otherwise this is empty.)

Profile: Malware SMTP Threat score settings overview if selected for the
policy. (Otherwise this field is empty.)
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Table 48: Threat Prevention Policy Fields (Continued)

Field Description

Status This displays the status of the policy. This status is a
clickable link you can use to change the policy status.
When you first create a policy and assign it to a group,
this field reads View Analysis. Read "Threat Policy
Analysis Overview" on page 180 for more information
on this field.

If the status is Update Failed, click Retry to perform the
rule analysis again. You can click the Update Failed
status to see the corresponding job details. The rule
analysis retry option is available only when the status is
Update Failed.

NOTE: If the policy has been updated after it has
already been pushed to the endpoint, the status
here is Update with a warning icon to notify you the
policy has been changed but not pushed.

Policy Enforcement Group This is the group to which the policy is assigned.

Log This field displays the log setting for the policy.

Description The user-created description for the policy.

Benefits of Threat Prevention Policy

• Enables you to define and enforce policies for controlling specific applications and embedded social
networking widgets.

• Reduces the need for manual updates and automatically applies policies and enforcement rules,
driving down the costs of managing network security.

• Leverages the network for multiple enforcement points across the infrastructure. Enables you to stop
threats closer to infection points and to prevent threats from spreading, which greatly improves the
efficacy of security operations.
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RELATED DOCUMENTATION

Creating Threat Prevention Policies  |  173

Policy Enforcement Groups Overview  |  167

Creating Geo IP Policies  |  181

Policy Enforcer Overview  |  4

Benefits of Policy Enforcer  |  7

Policy Enforcer Components and Dependencies  |  13

Juniper ATP Cloud Overview

Creating Threat Prevention Policies

You can create threat prevention policies for various profiles from the Policies page.

NOTE: If you are creating policies for the first time, you are given the option of setting
up Policy Enforcer with Juniper ATP Cloud or configuring Juniper ATP Cloud alone.
Clicking either button takes you to quick setup for your selection. See "Comparing the
Juniper Connected Security and non-Juniper Connected Security Configuration Steps"
on page 27 for a configuration comparison.

Before You Begin

• Determine the type of profile you will use for this policy; command & control server, infected hosts,
malware. You can select one or more threat profiles in a policy. Note that you configure Geo IP
policies separately. See "Creating Geo IP Policies" on page 181.

• Determine what action to take if a threat is found.

• Know what policy enforcement group you will add to this policy. To apply the policy, you must assign
one or more policy enforcement groups. See the instructions for assigning groups to policies at the
bottom of this page.

• Once policies are configured with one more groups assigned, you can save a policy in draft form or
update it. Policies changes do not go live until they have been updated.

• If you are using Juniper ATP Cloud without Policy Enforcer, you must assign your threat prevention
policy to a firewall rule for it to take affect. See the instructions at the bottom of this page.

• If you delete a threat prevention policy that is assigned to a policy enforcement group, a status
screen appears displaying the progress of the deletion and the affected configuration items.
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To create a threat prevention policy:

1. Select Configure>Threat Prevention > Policies.

2. Click the + icon.

The Create Threat Prevention Policy page appears.

3. Complete the configuration by using the guidelines in theTable 49 on page 225, Table 50 on page
226, Table 51 on page 226, Table 52 on page 227, and Table 53 on page 230 below.

4. Click OK.

Table 49: Fields on the Threat Prevention Policy Page

Field Description

Name Enter a unique string that must begin with an alphanumeric character and can include
underscores; no spaces allowed; 63-character maximum.

Description Enter a description; maximum length is 1024 characters. You should make this description
as useful as possible for all administrators.

Profiles Include the following profiles to your threat prevention policy. You must include at least
one profile. An error message is shown if you try to create the threat prevention policy
without selecting a profile.

• C&C profile—See Table 50 on page 226.

• Infected host profile—See Table 51 on page 226.

• Malware profile—See Table 52 on page 227.

• DDoS profile—See Table 53 on page 230.

Log Setting (Policy
setting for all
profiles)

Select the log setting for the policy. You can log all traffic, log only blocked traffic, or log no
traffic.

Table 50 on page 226 shows the management of command and control server threat in a policy.
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Table 50: C&C Server Profile Management

Field Description

Command and
Control Server

Select and choose settings for command and control servers. A C&C is a centralized
computer that issues commands to botnets (compromised networks of computers) and
receives reports back from them. Botnets can be used to gather sensitive information, such
as account numbers or credit card information, or to participate in a distributed denial-of-
service (DDoS) attack.

Include C& C
profile in policy

Select the check box to include management for this threat type in the policy.

Threat Score Use the slider to change the action to be taken based on the threat score. Threat scores are
assigned using several criteria. Refer to the monitoring pages in the UI to investigate, located
under Monitor > Threat Management.

Actions If the threat score is high enough to cause a connection to be blocked, you have following
configurable options:

• Drop connection silently (This is the default and recommended setting.)

• Close connection and do not send a message

• Close connection and redirect to URL—In the field provided, enter a URL to redirect
users to when connections are dropped.

• Send custom message—In the field provided, enter a message to be shown to users
when connections are dropped.

Table 51 on page 226 shows the management of infected host threat in a policy.

Table 51: Infected Host Profile Management

Field Description

Infected Host Infected hosts are systems for which there is a high confidence that attackers have gained
unauthorized access. Infected hosts data feeds are listed with the IP address or IP subnet of the
host, along with a threat score.
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Table 51: Infected Host Profile Management (Continued)

Field Description

Include
infected host
profile in
policy

Select the check box to include management for this threat type in the policy.

NOTE: If you want to enforce an infected host policy within the network, you must include a
switch in the site.

Actions You have following options:

• Drop connection silently (This is the default and recommended setting.)

• Monitor—Choose this option to log all the traffic for certain infected hosts and monitor it.
You can then choose to perform any action on the monitored data.

NOTE: The PEG must contain only Space subnets or devices. The Monitor action for the
infected host profile is not applicable to any third party connector devices. An error
message is shown.

• Quarantine—In the field provided, enter a VLAN to which quarantined files are sent. (Note
that the fallback option is to block and drop the connection silently.)

Table 52 on page 227 shows the management of malware threat in a policy.

Table 52: Malware Threat Profile Management

Field Description

Malware (HTTP file
download, SMTP
File attachment,
and IMAP
attachments)

Malware is files that are downloaded by hosts or received as email attachments and found
to be suspicious based on known signatures, URLs. or other heuristics.

Include malware
profile in policy

Select the check box to include management for this threat type in the policy.

HTTP file download Turn this feature on to scan files downloaded over HTTP and then select a file scanning
device profile. The device profile is configured using Juniper ATP Cloud.
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Table 52: Malware Threat Profile Management (Continued)

Field Description

Scan HTTPS Turn this feature to scan encrypted files downloaded over HTTPS.

Device Profile Select ATP Cloud device profile. This is configured through ATP Cloud. ATP Cloud profiles
let you define which files to send to the cloud for inspection. You can group types of files
to be scanned together under a common name and create multiple profiles based on the
content you want scanned.

Actions If the threat score is high enough to cause a connection to be blocked, you have following
configurable options:

• Drop connection silently (This is the default and recommended setting.)

• Close connection and do not send a message

• Close connection and redirect to URL—In the field provided, enter a URL to
redirect users to when connections are dropped.

• Send custom message—In the field provided, enter a message to be shown to users
when connections are dropped.

SMTP File
Attachments

Turn this feature on to inspect files received as email attachments (over SMTP only).

Scan SMTPS Enable this option to configure reverse proxy for SMTP.

The reverse proxy does not prohibit server certificates. It forwards the actual server
certificate or chain as is to the client without modifying it.

Device Profile If you do not click the Change button to select a device profile for SMTP scanning, the
device profile selected for HTTP will be used by default.

Select Change to use a different device profile for SMTP.

Device profiles are configured through ATP Cloud and define which files to send to the
cloud for inspection.

Threat Score Use the slider to change the action to be taken based on the threat score. Threat scores
are assigned using several criteria. This threat score applies to all malware, HTTP and
SMTP. (Note: There is no monitoring setting for malware.)
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Table 52: Malware Threat Profile Management (Continued)

Field Description

Actions Actions for SMTP File Attachments include: Quarantine, Deliver malicious messages with
warning headers added, and Permit. This actions are set in ATP Cloud. Refer to the Juniper
ATP Cloud documentation for information.

IMAP Attachments Turn this feature on to select a a file scanning device profile and threat score ranges to
apply to IMAP e-mails.

Scan IMAPS Enable this option to configure reverse proxy for IMAP e-mails.

Device Profile If you do not click the Change button to select a device profile for IMAP scanning, the
device profile selected for HTTP will be used by default.

Select Change to use a different device profile for IMAP.

Device profiles are configured through ATP Cloud and define which files to send to the
cloud for inspection.

Actions Actions for IMAP Attachments include: Block, Deliver malicious messages with warning
headers added, and Permit. This actions are set in ATP Cloud. Refer to the Juniper ATP
Cloud documentation for information.

Threat Score Use the slider to change the action to be taken based on the threat score. Threat scores
are assigned using several criteria. This threat score applies to all malware, HTTP, SMTP,
and IMAP. (Note: There is no monitoring setting for malware.)

Table 53 on page 230 shows the management of DDoS threat in a policy
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Table 53: DDoS Threat Profile Management

Field Description

Include DDoS
Profile in
Policy

Enable this option to include the management of Distributed denial-of-service (DDoS)
protection that enables the MX router to quickly identify an attack and prevent a flood of
malicious control packets from exhausting system resources.

When you create a threat policy for the DDoS profile, it is not pushed to the device because the
policy is not yet assigned to any device. Assign the policy to the policy enforcement group.
Because the policy is created for the MX router, rule analysis is not initiated when a policy is
assigned to the policy enforcement group (PEG).

Actions Select the following actions from the list for the DDoS profile:

• Block—Use this option to block the DDoS attack.

• Rate Limit Value—Use this option to limit the bandwidth on the flow route. You can express
the rate limit value in Kbps, Mbps, or Gbps units. The rate limit range is 10Kbps to 100Gbps.

• Forward to—Use this option to configure the routing next hop to forward the packets for
scrubbing.

Scrubbing Site Specify a routing instance to which packets are forwarded in the as-number:community-value
format, where each value is a decimal number. For example, 65001:100.

Once you have a threat prevention policy, you assign one or more groups to it:

1. In the threat prevention policy main page (located under Configure>Threat Prevention > Policy), find
the appropriate policy.

2. In the Policy Enforcement Groups column, click the Assign to Groups link that appears here when
there are no policy enforcement groups assigned or click the group name that appears in this column
to edit the existing list of assigned groups. You can also select the check box beside a policy and click
the Assign to Groups button at the top of the page. See "Policy Enforcement Groups Overview" on
page 167 .

For the infected host profiles created with Monitor action, you cannot assign a policy enforcement
group if it contains only the third-party connector devices or the combination of both Junos Space
and third-party connector devices. You must have only the Junos Space subnets in the policy
enforcement groups to assign them to the infected host profiles with Monitor action.

If you edit an existing infected host profile with either Drop Connection or Quarantine action to
Monitor action, you cannot assign any policy enforcement group having only third-party connector
devices or the combination of Junos Space and third-party connector devices.
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3. In the Assign to Groups page, select the check box beside a group in the Available list and click the >
icon to move it to the Selected list. The groups in the Selected list will be assigned to the policy.

4. Click OK.

5. Once one or more policy enforcement groups have been assigned, a Ready to Update link appears in
the Status column. You must update to apply your new or edited policy configuration. Clicking the
Ready to Update link takes you the Threat Policy Analysis page. See "Threat Policy Analysis
Overview" on page 180. From there you can view your changes and choose to Update now, Update
later, or Save them in draft form without updating.

6. If you are using Juniper ATP Cloud without Policy Enforcer, you must assign your threat prevention
policy to a firewall rule for it to take affect. Navigate to Configure > Firewall Policy > Policies. In the
Advanced Security column, click an item to access the Edit Advanced Security page and select the
threat prevention policy from the Threat Prevention pulldown list.
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Juniper ATP Cloud Realm Overview

A security realm is a group identifier for an organization used to restrict access to Web applications. You
must create at least one security realm to login into Juniper ATP Cloud. Once you create a realm, you
can enroll SRX Series devices into the realm. You can also give more users (administrators) permission to
access the realm.

If you have multiple security realms, note that each SRX Series device can only be bound to one realm,
and users cannot travel between realms.

RELATED DOCUMENTATION

About the Feed Sources Page  |  240

Creating Juniper ATP Cloud Realms and Enrolling Devices or Associating Sites

Using Guided Setup for Juniper ATP Cloud

Configuring Juniper ATP Cloud (No Juniper Connected Security and No Guided Setup) Overview

Juniper ATP Cloud Email Management Overview

IN THIS SECTION

Quarantine Release  |  235

Blocklist and Allowlist  |  236

With Email Management, enrolled devices transparently submit potentially malicious email attachments
to the cloud for inspection. Once an attachment is evaluated, Juniper ATP Cloud assigns the file a threat
score between 0-10 with 10 being the most malicious.

NOTE: If an email contains no attachments, it is allowed to pass without any analysis.

Configure one of the following actions when an email attachment is determined to be malicious:
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• Quarantine Malicious Messages—If you select to quarantine emails with attachments found to be
malicious, those emails are stored in the cloud in an encrypted form and a replacement email is sent
to the intended recipient. That replacement email informs the recipient of the quarantined message
and provides a link to the Juniper ATP Cloud quarantine portal where the email can be previewed.
The recipient can then choose to release the email by clicking a Release button (or request that the
administrator release it) or Delete the email.

• Deliver malicious messages with warning headers added—When you select this option, headers are
added to emails that most mail servers recognize and filter into Spam or Junk folders.

• Permit—You can select to permit the email and the recipient receives it intact.

Figure 75: Email Management Overview

Quarantine Release

If the recipient selects to release a quarantined email, it is allowed to pass through the SRX series with a
header message that prevents it from being quarantined again, but the attachments are placed in a
password-protected ZIP file. The password required to open the ZIP file is also included as a separate
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attachment. The administrator is notified when the recipient takes an action on the email (either to
release or delete it).

If you configure Juniper ATP Cloud to have the recipient send a request to the administrator to release
the email, the recipient previews the email in the Juniper ATP Cloud quarantine portal and can select to
Delete the email or Request to Release. The recipient receives a message when the administrator takes
action (either to release or delete the email.)

Blocklist and Allowlist

Emails are checked against administrator-configured blocklists and allowlists using information such as
Envelope From (MAIL FROM), Envelope To (RCPT TO), Body Sender, Body Receiver. If an email matches
the allowlist, that email is allowed through without any scanning. If an email matches the blocklist, it is
considered to be malicious and is handled the same way as an email with a malicious attachment.

RELATED DOCUMENTATION

Juniper ATP Cloud Email Management: SMTP Settings  |  250

Juniper ATP Cloud Malware Management Overview

Malware management includes profiles you can create to group file types together for scanning. It also
lets you configure customized allowlists and blocklists.

• File inspection profiles let you define which files to send to the cloud for inspection. By grouping
similar file types together to be scanned (such as .tar, .exe, and .java) under a common name, you can
create multiple profiles based on the content you want scanned. Then enter the profile names on
eligible SRX Series devices to apply them.

• Use the allowlist and blocklist pages to configure custom trusted and untrusted URLs and IPs.
Content downloaded from locations on the allowlist is trusted and does not have to be inspected for
malware. Hosts cannot download content from locations on the blocklist because those locations are
untrusted.

RELATED DOCUMENTATION

Creating File Inspection Profiles  |  260
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File Inspection Profiles Overview

File Inspection profiles let you define which files to send to the cloud for inspection. You can group
types of files to be scanned together (such as .tar, .exe, and .java) under a common name and create
multiple profiles based on the content you want scanned. Then enter the profile names on eligible
devices to apply them.

Table 54: File Category Contents

Category Description

Archive Archive files

Configuration Configuration files

Document All document types except PDFs

Executable Executable binaries

Java Java applications, archives, and libraries

Library Dynamic and static libraries and kernel modules

Mobile Mobile formats

OS package OS-specific update applications

PDF PDF, e-mail, and MBOX files

Rich Application Installable Internet Applications such as Adobe Flash, JavaFX, Microsoft Silverlight

Script Scripting files

You can also define the maximum file size requirement per each category to send to the cloud. If a file
falls outside of the maximum file size limit the file is automatically downloaded to the client system.
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NOTE: Once the profile is created, use the set services advanced-anti-malware policy
CLI command to associate it with the Juniper ATP Cloud profile.

NOTE: If you are using the free model of Juniper ATP Cloud, you are limited to only the
executable file category.

RELATED DOCUMENTATION

Creating File Inspection Profiles  |  260

Juniper ATP Cloud Malware Management Overview  |  236

File Scanning Limits  |  314

Custom Feed Sources Overview

IN THIS SECTION

Benefits of Custom Feed Sources  |  239

Policy Enforcer uses threat feeds to provide actionable intelligence to policies about various types of
threats. These feeds can come from different sources, such as Juniper ATP Cloud, and from lists that you
can customize by adding IP addresses, domains, and URLs.

NOTE: Juniper ATP Cloud feeds and custom feeds are mutually exclusive. You can only
have one source for dynamic address, allowlist, blocklist, infected host feeds, and C&C
Server.

NOTE: When dynamic address custom feeds are available, you cannot use office_365
feeds from Juniper ATP Cloud.

The following types of custom threat feeds are available:
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• A dynamic address is a group of IP addresses that can be imported from external sources. These IP
addresses are for specific domains or for entities that have a common attribute such as a particular
undesired location that poses a threat. You can then configure security policies to use the dynamic
addresses within a security policy.

• An allowlist contains known trusted IP addresses, URLs, and domains. Content downloaded from
locations on the allowlist does not have to be inspected for malware.

• A blocklist contains known untrusted IP addresses, URLs, and domains. Access to locations on the
blocklist is blocked, and therefore no content can be downloaded from those sites.

• Infected hosts are hosts known to be compromised. Enter host IP addresses manually or upload a
text file with the IP addresses of infected hosts.

• Using DDoS threat feed, policy Enforcer blocks source IP addresses in the feed, rate limit the traffic
from the source IP addresses, and takes BGP Flowspec action to apply null-route filtering or redirect
the traffic to scrubbing centers.

• Command and Control Server (C&C Server) is a centralized computer that issues commands to
botnets (compromised networks of computers) and receives reports back from them. Botnets can be
used to gather sensitive information, such as account numbers or credit card information, or to
participate in a distributed DDoS attack.

For threat management policies to use these feeds, you must enter configuration information for each
feed type.

Benefits of Custom Feed Sources

• Provides relevant and timely intelligence that you can use to create enforcement policies. Enables
you to customize threat feeds specific to your industry or organization.

• Provides flexible mechanisms to synchronize threat information to:

• Configure Policy Enforcer to poll from local file and remote file custom feeds.

• Push threat feeds to Policy Enforcer using the Threat Feed API .

RELATED DOCUMENTATION

Creating Custom Feeds  |  216

Example: Creating a Dynamic Address Custom Feed and Firewall Policy  |  270
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About the Feed Sources Page

IN THIS SECTION

Tasks You Can Perform  |  240

Field Descriptions  |  241

To access this page, click Configure > Threat Prevention > Feed Sources.

Policy Enforcer uses threat feeds to provide actionable intelligence to policies about various types of
threats. These feeds can come from different sources, such as Juniper ATP Cloud, Juniper ATP, and from
lists that you can customize by adding IP addresses, domains, and URLs.

You can add allowlist and blocklist in Juniper ATP Cloud and as well as in Custom feeds. When you add
an allowlist or blocklist in Custom feeds, a warning message shows that it will erase the existing allowlist
or a blocklist in Juniper ATP Cloud, if any. You can only have one source for allowlist, blocklist, and
infected host feeds.

Tasks You Can Perform

You can perform the following tasks from the Juniper ATP Cloud page:

• Add ATP Cloud realm. See Creating Juniper ATP Cloud Realms and Enrolling Devices or Associating
Sites.

• Inspect and manage email attachments sent over SMTP. See "Sky ATP Email Management: SMTP
Settings" on page 250.

• Configure email management for IMAP. See "Configure IMAP Settings" on page 257.

• Configure Allowlist and Blocklist. See "Creating Whitelists for Sky ATP Email and Malware
Management" on page 253 and "Creating Blacklists for Sky ATP Email and Malware Management" on
page 255.

• Configure file inspection profiles. See "Creating File Inspection Profiles" on page 260.

• Edit the ATP Cloud realm. See Modifying Juniper ATP Cloud Realm.

• Delete the ATP Cloud realm.
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You can perform the following tasks from the ATP Appliance page:

• Add ATP Appliance server. See "Add JATP Server" on page 262.

• Edit the ATP Appliance server configuration. See "Edit or Delete a JATP Server" on page 264

• Delete the ATP Appliance server.

You can perform the following tasks from the Custom Feeds page:

• Create custom feeds for the dynamic address, allowlist, blocklist, infected hosts, DDoS, and C&C
Server feed types. See "Creating Custom Feeds" on page 216.

• Configure settings. See "Configuring Settings for Custom Feeds" on page 272.

• Edit the custom feed.

• Delete the custom feed.

Field Descriptions

Table 55 on page 241 provides guidelines on using the fields on the Feed Sources page.

Table 55: Fields on the Feed Sources Page

Field Description

ATP Cloud

Realm Name of the Juniper ATP Cloud realm.

Sites Name of the site associated to the realm.

Devices Name of the perimeter firewall devices that are enrolled to Juniper ATP Cloud.

Location Region of the Juniper ATP Cloud realm.

Enrollment Status Enrollment status of the realm.
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Table 55: Fields on the Feed Sources Page (Continued)

Field Description

Token Expiry Expiry date and time of a token generated at the Juniper ATP Cloud side when a realm is
registered. The token will be valid for one year. Once the token expires, the status is
flipped to Expired.

Thirty days prior to the expiry date, renew option is enabled to renew the token. Click
Renew to renew the token. Enter the realm credentials in the renew window and if the
realm credentials are valid, a new token is generated and assigned to the realm. The old
and the expired token is deleted.

NOTE: The username (e-mail address) that you provide as realm credentials must
exactly match with the username that is used while creating a realm in Juniper ATP
Cloud. To view the username in the Juniper ATP Cloud user interface, go to
Administration>Users.

The e-mail address used as a username is case sensitive. If there is a mismatch in the
username, the validation of realm credentials fails and the token will not be renewed.

Feed Status The consolidated status of all the feeds of a selected Juniper ATP Cloud realm is shown
here.

If the status of any one of the feeds is FAILED, then the consolidated status is shown as
FAILED. Hover over the field to see the individual status of each feed. The status of IPv6
feeds are also listed along with other feed sources.

Last Downloaded The date and time of the last time Policy Enforcer has requested the feeds from Juniper
ATP Cloud is shown here. Hover over the field to view a detailed list of date and time of
each feed download.

JATP

Zone Name Name of the Juniper ATP zone.

Sites Name of the site associated to the zone.
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Table 55: Fields on the Feed Sources Page (Continued)

Field Description

Feed Status The consolidated status of all the feeds of a selected Juniper ATP zone is shown here.
Hover over the field to see the individual status of each feed. The status of IPv6 feeds are
also listed along with other feed sources.

If the status of any one of the feeds is FAILED, then the consolidated status is shown as
FAILED.

Last Downloaded The date and time of the last time Policy Enforcer has requested the feeds from Juniper
ATP is shown here. Hover over the field to view a detailed list of date and time of each
feed download.

Devices Name of the perimeter firewall devices that are enrolled to Juniper ATP.

Enrollment Status Enrollment status of the zone.

Server IP Address The IP address of the configured Juniper ATP appliance.

Custom Feeds

Name Name of the custom feed.

Feed Type Type of the custom feed. For example, dynamic address, allowlist, blocklist, infected hosts,
DDoS, or C&C Server.

Last Updated Date and time when the selected custom feed was last updated.

Days to Become
Inactive

Number of days within which the custom feed is going to expire or become inactive.

243



Table 55: Fields on the Feed Sources Page (Continued)

Field Description

Remote Download
Status

View the status of downloading feeds from a remote file server to Policy Enforcer. This
field is blank for the locally created custom feeds.

The following statuses are shown under different scenarios:

• Pending—Status is shown as pending until Policy Enforcer downloads the new feeds
from the remote file server.

• Success—Status is shown as success when Policy Enforcer downloads the feeds
successfully.

• Failed—Status is shown as failed when downloading the feeds fails.

Description View the description of your custom feed.

In the Custom Feeds page, you can search for any particular custom feed by its name and type of the
custom feed. Click the filter icon and the following fields can be searchable:

• Name—Enter the name of the custom feed to be searched.

• Feed Type—Select the feed type from the list.

RELATED DOCUMENTATION
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Creating File Inspection Profiles  |  260
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244

https://www.juniper.net/documentation/en_US/junos-space/policy-enforcer/topics/task/configuration/junos-space-policy-enforcer-atp-cloud-realm-creating-realms.html


Creating Juniper ATP Cloud Realms and Enrolling
Devices or Associating Sites

You can select a geographical location and enter your Juniper ATP Cloud credentials to create a realm
and associate sites or devices with the realm.

If you do not have Juniper ATP Cloud account, select a geographical region and click here. You are
redirected to the Juniper ATP Cloud account page.

Before You Begin

•
NOTE: 

• Policy Enforcer does not support the Multi-factor authentication (MFA) feature in
Cloud ATP. Disable the MFA feature in the Cloud ATP before adding realms to the
Security Director.

• You cannot use single sign-on (SSO) credentials to add the Juniper ATP realm to
Security Director.

Use the login credentials used to create the realm.

• Understand which type of Juniper ATP Cloud license you have: free, basic, or premium. The license
controls which Juniper ATP Cloud features are available.

• To configure a Juniper ATP Cloud realm, you must already have Juniper ATP Cloud account with an
associated license.

• Ensure that the internet connectivity is available for Policy Enforcer. Without the internet
connectivity, you cannot create a realm.

• Decide which region will be covered by the realm you are creating. You must a select a region when
you configure a realm.

• Note that adding a device to a realm results in one or more commit operations occurring on the
device to apply the Juniper ATP Cloud or Policy Enforcer configuration.

To configure ATP Cloud Realm:

1. Select Configure>Threat Prevention>Feed Sources.

The Feed Sources page appears.

2. In the ATP Cloud tab, click the + icon to add a realm.

3. Complete the initial configuration by using the guidelines in Table 56 on page 246 below.
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4. Click Finish.

Table 56: Fields on the Add ATP Cloud Realm Page

Field Description

ATP Cloud Realm Credentials

Location Select a region of the world from the available choices.

The following options are available in the Location list:

• North America

• European Region

• Canada

• Asia Pacific

By default, the North America value appears in the list. To know more about the geographic
region, see here.

Username Enter your e-mail address. Your username for Juniper ATP Cloud is your e-mail address.

Password Enter a unique string at least 8 characters long. Include both uppercase and lowercase letters,
at least one number, and at least one special character (~!@#$%^&*()_-+={}[]|:;<>,./?); no
spaces are allowed, and you cannot use the same sequence of characters that are in your
username.

Realm Enter a name for the security realm. This should be a name that is meaningful to your
organization. A realm name can only contain alphanumeric characters and the dash symbol.
Once created, this name cannot be changed.

NOTE: When you create a custom feed with a realm, the feed is associated at the site level
and not at the realm level. If you modify this realm and associate new sites to it, a warning
message is shown that there are custom feeds are associated with this realm. Changing the
site information will change the custom feed information. You must go and edit the custom
feed that was associated with this realm and verify the realm association.

Site
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Table 56: Fields on the Add ATP Cloud Realm Page (Continued)

Field Description

Site Select one or more sites to enroll into the realm. If there are no sites associated with the realm,
click Create new site. To know more about creating a new site, see "Creating Secure Fabric and
Sites" on page 160.

NOTE: 

• If you are using Juniper ATP Cloud without Policy Enforcer, you are not prompted to
select a site.

• Assigning a site to the realm will cause a change in the device configuration in the
associated devices.

• You must select the sites either with tenants or without tenants. You cannot select both
at a time.

Unmanaged
Devices

Lists all devices from the realm that are not managed in Security Director. You must manually
discover them.

If you are using Juniper ATP Cloud with Policy Enforcer and you have no devices enrolled in
the realm, you are asked to select devices in the box on the left and move them to the right to
enroll them. All selected devices are automatically enrolled with Juniper ATP Cloud when you
finish the guided setup. To disenroll a device, you can edit a realm and move the device back to
the left side box.

NOTE: Adding a device to a realm results in one or more commit operations occurring on
the device to apply the Juniper ATP Cloud or Policy Enforcer configuration.

Global Configuration

IPv6 Feeds Enable this option to receive IPv6 feeds (C&C and Geo IP) from Policy Enforcer.

Threat Level
Threshold

Select a threshold level to block the infected hosts and to send an e-mail to the selected
administrators notifying about the infected host events.

Click the+ sign if you want to add new administrators to the list.

Logging Enable this option to log the Malware or the Host Status event or both the event types.

247



Table 56: Fields on the Add ATP Cloud Realm Page (Continued)

Field Description

Proxy Servers Click the add icon (+) to enter the trusted IPv4 address of the proxy server, in the Server IP
column.

When there is a proxy server between users on the network and a firewall, the firewall might
see the proxy server IP address as the source of an HTTP or HTTPS request, instead of the
actual address of the user making the request.

With this in mind, X-Forwarded-For (XFF) is a standard header added to packets by a proxy
server that includes the real IP address of the client making the request. Therefore, if you add
trusted proxy servers IP addresses to the list in Juniper ATP Cloud, by matching this list with
the IP addresses in the HTTP header (X-Forwarded-For field) for requests sent from the SRX
Series devices, Juniper ATP Cloud can determines the originating IP address.

NOTE: XFF only applies to HTTP or HTTPS traffic, and only if the proxy server supports the
XFF header.

NOTE: If you enrolled a device into a realm from within Security Director and you want
to disenroll it, you must do that from within Security Director. If you enrolled a device
into a realm from within Juniper ATP Cloud and you want to disenroll it, you must do
that from within Juniper ATP Cloud. You cannot disenroll a device from within Security
Directory that was enrolled from within Juniper ATP Cloud.

RELATED DOCUMENTATION

About the Feed Sources Page  |  240

Juniper ATP Cloud Realm Overview

Juniper ATP Cloud Overview  |  9

Creating Secure Fabric and Sites  |  160
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Modifying Juniper ATP Cloud Realm

Use the Modify ATP Cloud Realm page to modify the site information and global configuration
information of an existing ATP Cloud realm. You can also view devices from the realm that are not
managed by Security Director.

To modify a Juniper ATP Cloud realm:

1. Select Configure>Threat Prevention> Feed Sources.

The Feed Sources page appears.

2. Select the realm and click the pencil icon to modify the configuration.

The Modify ATP Cloud Realm page appears.

3. Complete the configuration by using the guidelines in Table 57 on page 249.

4. Click Finish to complete the configuration or Cancel to discard the changes.

NOTE: Assigning a site to the realm will cause a change in the device configuration in the
associated devices.

Table 57: Fields on the Modify ATP Cloud Realm page

Field Description

Site

Site Select a site to enroll into the realm. If there are no sites associated with the realm, click
Create new site.

Unmanaged Devices Lists all devices from the realm that are not managed in Security Director. You must
manually discover them.

Global Configuration

IPv6 Feeds Enable this option to receive IPv6 feeds from Policy Enforcer.

Threat Level Threshold Select a threshold level to block the infected hosts and to send an e-mail to the
selected administrators notifying about the infected host events.
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Table 57: Fields on the Modify ATP Cloud Realm page (Continued)

Field Description

Logging Enable or disable logging for the Malware or the Host Status event.

Proxy Servers Click the add icon (+) to enter the IPv4 address of the proxy server, in the Server IP
column.

You can also edit the existing IP address or delete them.

RELATED DOCUMENTATION

Creating Juniper ATP Cloud Realms and Enrolling Devices or Associating Sites

About the Feed Sources Page  |  240

Juniper ATP Cloud Email Management: SMTP
Settings

Use the SMTP Settings page to inspect and manage email attachments sent over SMTP.

Before You Begin

• Read the "Juniper ATP Cloud Email Management Overview" on page 234 topic.

• Decide how malicious emails are handled: quarantined, delivered with headers, or permitted.

To configure the email management settings for the Juniper ATP Cloud realm:

1. Select Configure > Threat Prevention > Feed Sources.

The Feed Sources page appears

2. Under the ATP Cloud tab, right-click ATP Cloud Realm or from the More list, select SMTP Settings.

3. Based on your selections, configuration options described in Table 58 on page 251, Table 59 on page
252, and Table 60 on page 253.
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Table 58: Configure Quarantine Malicious Messages

Setting Guideline

Action to take Quarantine malicious messages (the default)—When you select to
quarantine malicious email messages, in place of the original email,
intended recipients receive a custom email you configure with
information on the quarantining. Both the original email and the
attachment are stored in the cloud in an encrypted format.

Release option • Recipients can release email—This option provides recipients with a
link to the Juniper ATP Cloud quarantine portal where they can
preview the email. From the portal, recipients can select to Release
the email or Delete it. Either action causes a message to be sent to
the administrator.

NOTE: If a quarantined email has multiple recipients, any
individual recipient can release the email from the portal and all
recipients will receive it. Similarly, if one recipient deletes the
email from the portal, it is deleted for all recipients.

• Recipients can request administrator to release email—This option
also provides recipients with a link to the Juniper ATP Cloud
quarantine portal where they can preview the email. From the
portal, recipients can select to Request to Release the email or
Delete it. Either choice causes a message to be sent to the
administrator. When the administrator takes action on the email, a
message is sent to the recipient.

NOTE: When a quarantined email is released, it is allowed to pass
through the SRX series with a header message that prevents it from
being quarantined again, but the attachment is placed inside a
password-protected zip file with a text file containing the password
that the recipient must use to open the file.

Email Notifications for End Users

Learn More Link URL If you have a corporate web site with further information for users,
enter that URL here. If you leave this field blank, this option will not
appear to the end user.
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Table 58: Configure Quarantine Malicious Messages (Continued)

Setting Guideline

Subject When an email is quarantined, the recipient receives a custom
message informing them of their quarantined email. For this custom
message, enter a subject indicating a suspicious email sent to them has
been quarantined, such as "Malware Detected."

Custom Message Enter information to help email recipients understand what they
should do next.

Custom Link Text Enter custom text for the Juniper ATP Cloud quarantine portal link
where recipients can preview quarantined emails and take action on
them.

Click Preview to view the custom message that will be sent to a
recipient when an email is quarantined.

Table 59: Configure Deliver with Warning Headers

Setting Guideline

Action to take Deliver malicious messages with warning headers added—When you
select to deliver a suspicious email with warning headers, you can add
headers to emails that most mail servers will recognize and filter into
spam or junk folders.

SMTP Headers • X-Distribution (Bulk, Spam)—Use this header for messages that are
sent to a large distribution list and are most likely spam. You can
also select “Do not add this header.”

• X-Spam-Flag—This is a common header added to incoming emails
that are possibly spam and should be redirected into spam or junk
folders. You can also select “Do not add this header.”

• Subject Prefix—You can prepend headers with information for the
recipient, such as "Possible Spam."
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Table 60: Permit

Setting Guideline

Action to take Permit—You can select to permit the message and no further
configuration is required.

To send notifications to administrators when emails are quarantined or released from quarantine:

1. Click the + sign to add an administrator.

2. Enter the administrator's email address.

3. Select the Quarantine Notification check box to receive those notifications.

4. Select the Release Notifications check box to receive those notifications.

5. Click OK.

RELATED DOCUMENTATION

Juniper ATP Cloud Email Management Overview  |  234

Creating Allowlist for Juniper ATP Cloud Email and
Malware Management

Use the Modify Allowlist page to add email addresses, IP addresses, and URLs to the allowlist. An
allowlist contains known trusted IP addresses, URLs, and domains. Content downloaded from locations
on the allowlist does not have to be inspected for malware.

Before You Begin

• Read the "Juniper ATP Cloud Email Management Overview" on page 234 topic.

• Read the "Juniper ATP Cloud Malware Management Overview" on page 236 topic.

• Decide on the type of location you intend to define: URL or IP address.

• Review the current list of entries to ensure that the item you are adding does not already exist.

To configure the allowlists:
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1. Select Configure>Threat Prevention> Feed Sources.

The Feed Sources page appears.

2. Under the ATP Cloud tab, right-click the ATP Cloud realm or from the More list, select Allowlist.

The Modify Allowlist page appears.

3. Click the + sign to add more entries to the allowlist.

4. Complete the configuration by using the guidelines in Table 61 on page 254.

5. Click OK.

Table 61: Fields on the Modify Allowlist Page

Field Description

Email List

Email Sender The allowed email senders are listed here.

To add more email senders to the allowlist, click the + sign.

Enter the full address in the format name@domain.com or wildcard the name to permit all emails
from a specific domain. For example, *@domain.com.

Malware List

IP and URL Enter an IP address or a URL.

• IP—Enter an IPV4 address in standard four octet format. CIDR notation and IP address ranges
are also accepted. Any of the following formats are valid: 1.2.3.4, 1.2.3.4/30, or
1.2.3.4-1.2.3.6.

• URL—Enter the URL using the following format: juniper.net. Wildcards and protocols are not
valid entries. The system automatically adds a wildcard to the beginning and end of URLs.
Therefore juniper.net also matches a.juniper.net, a.b.juniper.net, and a.juniper.net/abc. If you
explicitly enter a.juniper.net, it matches b.a.juniper.net, but not c.juniper.net. You can enter a
specific path. If you enter juniper.net/abc, it matches x.juniper.net/abc, but not x.juniper.net/
123.

To edit an existing allowlist entry, select the allowlist that you want to edit and click the pencil icon.

Juniper ATP Cloud periodically polls for new and updated content and automatically downloads it to
your SRX Series device. There is no need to manually push your allowlist files.
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Creating Blocklists for Juniper ATP Cloud Email and
Malware Management

Use the Modify Blocklist page to add email addresses, IP addresses, and URLs to the blocklist. A blocklist
contains known untrusted IP addresses, URLs, and domains. Access to locations on the blocklist is
blocked, and therefore no content can be downloaded from those sites.

Before You Begin

• Read the "Juniper ATP Cloud Email Management Overview" on page 234 topic.

• Read the "Juniper ATP Cloud Malware Management Overview" on page 236 topic.

• Compile a list of known malicious email addresses or domains to add to your blocklist. If an email
matches the blocklist, it is considered to be malicious and is handled the same way as an email with a
malicious attachment, blocked and a replacement email is sent. If an email matches the allowlist, that
email is allowed through without any scanning.

• It is worth noting that attackers can easily fake the “From” email address of an email, making
blocklists a less effective way to stop malicious emails.

• Decide on the type of location you intend to define: URL or IP address.

• Review the current list of entries to ensure that the item you are adding does not already exist.

To configure the blocklists:

1. Select Configure>Threat Prevention> Feed Sources.

The Feed Sources page appears.

2. Under the ATP Cloud tab, right-click the ATP Cloud realm or from the More list, select Blocklist.

The Modify Blocklist page appears.

3. Click the + sign to add more entries to the blocklist.

4. Complete the configuration by using the guidelines in Table 62 on page 256.

5. Click OK.
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Table 62: Fields on the Modify Blocklist Page

Field Description

Email List

Email Sender The allowed email senders are listed here.

To add more email senders to the blocklist, click the + sign.

Enter the full address in the format name@domain.com or wildcard the name to permit all emails
from a specific domain. For example, *@domain.com.

Malware List

IP and URL Enter an IP address or a URL.

• IP—Enter an IPV4 address in standard four octet format. CIDR notation and IP address ranges
are also accepted. Any of the following formats are valid: 1.2.3.4, 1.2.3.4/30, or
1.2.3.4-1.2.3.6.

• URL—Enter the URL using the following format: juniper.net. Wildcards and protocols are not
valid entries. The system automatically adds a wildcard to the beginning and end of URLs.
Therefore juniper.net also matches a.juniper.net, a.b.juniper.net, and a.juniper.net/abc. If you
explicitly enter a.juniper.net, it matches b.a.juniper.net, but not c.juniper.net. You can enter a
specific path. If you enter juniper.net/abc, it matches x.juniper.net/abc, but not x.juniper.net/
123.

To edit an existing blocklist entry, select the blocklist that you want to edit and click the pencil icon.

Juniper ATP Cloud periodically polls for new and updated content and automatically downloads it to
your SRX Series device. There is no need to manually push your blocklist files.

RELATED DOCUMENTATION
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Configure IMAP Settings

Use the IMAP Settings page to configure email management for IMAP. With email management for
IMAP, the enrolled SRX Series devices can transparently submit suspicious emails to Juniper ATP Cloud
for inspection and blocking.

Before You Begin

• Read the "Juniper ATP Cloud Email Management Overview" on page 234 topic.

• Decide how malicious emails are handled. For IMAP, the available options are to block or permit
email. Unlike SMTP, there is no quarantine option for IMAP and there is no option to preview a
blocked email.

To configure the IMAP settings:

1. Select Configure > Threat Prevention > Feed Sources.

The Feed Sources page appears

2. Under the ATP Cloud tab, right-click ATP Cloud Realm or from the More list, select IMAP Settings.

3. Complete the configuration as per the guidelines given in Table 63 on page 258.

Based on your selections, configuration options will vary.
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Table 63: Configure Block Malicious Messages

Setting Guideline

Action to take • Permit download of attachments—Allow email attachments, either
from all IMAP servers or specific IMAP servers, through to their
destination.

NOTE: In Permit mode, blocklists and allowlists are not checked.
Emails from blocklisted addresses are not sent to the cloud for
scanning. They are allowed through to the client.

• Block download of attachments—Block email attachments, either
from all IMAP servers or specific IMAP servers, from reaching their
destination.

NOTE: In Block mode, blocklists and allowlists are checked.
Emails from blocklisted addresses are blocked. Emails from
allowlisted addresses are allowed through to the client.

Recipients can send a request to an administrator to release the
email. Enter the email address to which recipients should send a
release request.

NOTE: If a blocked email has multiple recipients, any individual
recipient can request to release the email and all recipients will
receive it.

When you select to block email attachments, in place of the original
email, intended recipients receive a custom email you configure with
information on the block action. Both the original email and the
attachment are stored in the cloud in an encrypted format.

IMAP Server • All IMAP Servers—The permitting or blocking of email attachments
applies to all IMAP servers.

• Specific IMAP Server—The permitting or blocking of email
attachments applies only to IMAP servers with hostnames that you
add to a list. A configuration section to add the IMAP server name
appears when you select this option.

When you add IMAP servers to the list, it is sent to the SRX Series
device to filter emails sent to Juniper ATP Cloud for scanning. For
emails that are sent for scanning, if the returned score is above the set
policy threshold on the SRX, then the email is blocked.
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Table 63: Configure Block Malicious Messages (Continued)

Setting Guideline

IMAP Servers Select the Specific IMAP Server option above and click the + sign to
add IMAP server hostnames to the list.

NOTE: You must use the IMAP server hostname and not the IP
address.

Email Notifications for End Users

Learn More Link URL If you have a corporate web site with further information for users,
enter that URL here. If you leave this field blank, this option will not
appear to the end user.

Subject When an email is blocked, the recipient receives a custom message
informing them of their blocked email. For this custom message, enter
a subject indicating a suspicious email sent to them has been blocked,
such as "Malware Detected."

Custom Message Enter information to help email recipients understand what they
should do next.

Custom Link Text Enter custom text for the Juniper ATP Cloud quarantine portal link
where recipients can preview blocked emails and take action on them.

Click Preview to view the custom message that will be sent to a
recipient when an email is blocked.

To send notifications to administrators when emails are blocked or released from quarantine:

1. Click the + sign to add an administrator.

2. Enter the email address of the administrator and click OK.

3. Once the administrator is created, you can uncheck or check which notification types the
administrator will receive.

• Block Notifications—If you enable this option, a notification is sent when an email is blocked.

• Unblock Notifications—If you enable this option, a notification is sent when a user releases a
blocked email.
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Creating File Inspection Profiles

Use the ATP Cloud File Inspection Profiles page to create profiles to define which files to send to the
cloud for inspection.

Before you Begin

• Read the "File Inspection Profiles Overview" on page 237 topic.

• Read the "File Scanning Limits" on page 314 topic.

• Note that if you are using the free version of Juniper ATP Cloud, only executable files are scanned.

To configure file inspection profiles:

1. Select Configure>Threat Prevention> Feed Sources.

The Feed Sources page appears.

2. Under the ATP Cloud tab, select ATP Cloud realm, right-click or from the More list, select File
Inspection Profiles.

The ATP Cloud File Inspection Profiles page appears showing the existing file inspection profiles.

3. Click the + sign to create new profiles.

The Create Profile page appears.

4. Enter a name for the profile. (You can create multiple profiles for file inspection.)

5. In the File Categories section, select the file categories and the following actions from the list for
each file category:

• Do not scan—The file category will not be scanned.

• Scan file up to max size—The maximum files size (up to 32MB) to scan. If a file falls outside of the
maximum file size limit, the file is automatically downloaded to the client system.

• Hash lookup only—Hash lookups are not recommended because, they are compared with the files
that are already evaluated before.

See Table 64 on page 261 for the list of file types for each category.

6. Click OK.
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Table 64: File Category Contents

Category Description

Archive Archive files

Configuration Configuration files

Document All document types except PDFs

Executable Executable binaries

Java Java applications, archives, and libraries

Library Dynamic and static libraries and kernel modules

Mobile Mobile formats

OS package OS-specific update applications

PDF PDF, e-mail, and MBOX files

Script Scripting files

Rich Application Installable Internet Applications such as Adobe Flash, JavaFX, Microsoft Silverlight

NOTE: Once the profile is created, use the set services advanced-anti-malware policy
CLI command to associate it with the Juniper ATP Cloud profile.

RELATED DOCUMENTATION
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File Scanning Limits  |  314
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Add ATP Appliance Server

Configure the Juniper ATP appliance in Policy Enforcer to receive threat feeds for threat mitigation.

Before You Begin

Before you add the Juniper ATP Appliance:

• Obtain the IP address of the Juniper ATP appliance.

• Generate the API Authorization key for the Juniper ATP admin user. This is required to provide
authorized programmatic access to the Juniper ATP Appliance REST API. The configured
Authorization Key for that user is then applied each time an API request is made by that user.

• In the Juniper ATP Appliance web UI, navigate to Config>System Profiles>Users and click on an
existing user account.

• In the Update User page, select the Generate New API Key option.

For more information, see Updating a User Account and Setting an API Authorization Key.

• Configure multi-tenancy Web Collector Zones for Managed Security Service Provider (MSSP)
support.

• In the Juniper ATP Appliance web UI, navigate to Config>System Profiles>Zones.

For more information, see Configuring MSSP Multi-Tenancy Zones.

To add a Juniper ATP server:

1. Select Configure>Threat Prevention>Feed Sources.

The Feed Source page appears.

2. In the ATP Appliance page, click the + sign.

The Add ATP Appliance Server page appears.

3. Complete the configuration according to the guidelines provided in Table 65 on page 263.

4. Click Finish.

The required Juniper ATP appliance is added to Policy Enforcer for threat monitoring.
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Table 65: Fields on the Add ATP Appliance Server Page

Field Description

ATP Appliance Server Settings

ATP Appliance Server
IP Address

Enter the IP address of the Juniper ATP appliance.

API Key Enter the API Authorization key of the Juniper ATP appliance user. The same API key is
used for general Juniper ATP RESTful API access and also to integrate with SRX Series
devices.

The API key is used only once to obtain the application token from the ATP Appliance
server. The obtained application token is provided to Policy Enforcer and this token
never expires.

To know more about generating the API key, see Updating a User Account and Setting
an API Authorization Key.

Zone Name Enter the configured zone name.

You can enroll Policy Enforcer with the Juniper ATP default zone or with a specific
Juniper ATP zone. This enrollment is authenticated with an API authorization key.

Site

Site Select the site to be enrolled to the zone from the list.

If there are no sites associated with the realm, click Add new Site.

Unmanaged Devices Lists all devices from the zone that are not managed in Security Director. You must
manually discover them.

IPv6 Feeds Enable this option to receive IPv6 feeds (C&C and Geo IP) from Policy Enforcer.

RELATED DOCUMENTATION
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JATP Operator’s Guide

Edit or Delete a ATP Appliance Server

You can modify the site information of an existing Juniper ATP zone or delete a Juniper ATP server,
from the Feed Sources page.

To edit or delete a Juniper ATP server:

1. Select Configure>Threat Prevention>Feed Sources>JATP.

The Feed Sources page appears.

2. Select the zone you want to edit or delete and then right-click.

• Select Edit to modify site information. The Modify ATP Appliance Server page appears. Make the
changes and click Finish.

You can also click the pencil icon to modify the configuration.

• Select Delete to remove the Juniper ATP server. An alert message appears verifying that you
want to delete your selection. Click Yes to delete your selection.

You can also click the delete icon to delete the Juniper ATP server.

RELATED DOCUMENTATION
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Creating Custom Feeds

Use the Create Custom Feed page to configure the Dynamic Address, Allowlist, Blocklist, Infected Hosts,
DDoS, and C&C Server custom feeds. These feeds provide relevant and timely intelligence that you can
use to create enforcement policies.

Before You Begin

• Know what type of feed you are configuring and have all the necessary information on hand. Local
feeds are created on your local system and uploaded from there.
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• Note that infected hosts are hosts known to be compromised. For an infected host custom feed,
enter host IP addresses manually or upload a text file with the IP addresses of infected hosts.

• If you create an allowlist, blocklist, or infected hosts feed, it will override the respective Juniper ATP
Cloud/ATP Appliance feed.

• Note that when ATP Cloud/ATP Appliance only mode is selected as the Threat Prevention Type, the
infected host and DDoS custom feeds are not available.

To create local file and remote file custom feeds:

1. Select Configure>Threat Prevention> Feed Sources.

The Feed Sources page appears. You will see only custom feeds available as the threat prevention
type, if you make no selection for ATP Cloud/ATP Appliance Configuration Type in the Policy
Enforcer Settings page.

2. Click Create and select one of the following:

• Feeds with local files—Enter your data manually into the provided fields or upload from a text file
on your location machine.

• Feeds with remote file server—Configure communication with the remote server to fetch the data
feed from it.

3. Complete the configuration by using the guidelines in Table 66 on page 266 or Table 67 on page 268.

4. Click OK.

NOTE: 

• To use a custom feed of dynamic-address type, apply it to the source or destination
address in a firewall rule. In the firewall rule, you can filter addresses to show only the
custom feeds.

If there is a firewall policy rule created using the dynamic address, you cannot delete
the same dynamic address from the Feed Sources page. You must first delete the
firewall policy rule and then , delete the dynamic address from the Feed Sources
page.

• When you have no ATP Cloud/ATP Appliance Configuration Type selected (No
selection), ATP Cloud/ATP Appliance realms are disabled. Because site selection is
usually done from the ATP Cloud/ATP Appliance realm page, you must select sites
from the Create Custom Feed page when in “No selection” mode. The custom feeds
are then downloaded to the devices in the chosen sites. This is the only time site
selection available in the Create Custom Feed page.
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Table 66: Fields on the Create Custom Feed Page, Feeds with Local Files

Field Description

Name Enter a unique string that must begin with an alphanumeric character and can include only
dashes and underscores; no spaces allowed; 32-character maximum.

Description Enter a description for your custom feed; maximum length is 64 characters. You should make
this description as useful as possible for all administrators.

Feed Type Select one of the following custom feeds as a threat prevention type:

• Dynamic Address

• Allowlist

• Blocklist

• Infected Hosts

• DDoS

• CC

Sites Select the required sites from the list to associate them with the dynamic address or allowlists,
blocklists, or C&C Server feeds.

In the default mode (no ATP Cloud), only sites are listed because of no ATP Cloud. You can
share a site across the same feed type for dynamic address, allowlist, blocklist, and C&C Server.
For Infected hosts and DDoS, sites cannot be shared across the same feed type. However, you
can share a site across different feed types.
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Table 66: Fields on the Create Custom Feed Page, Feeds with Local Files (Continued)

Field Description

Zones/Realms Select the required realms from the list, if you are in Cloud feeds only, ATP Cloud/JATP, or ATP
Cloud/ATP Appliance with Juniper Connected Security mode.

Associate these realms with dynamic address or allowlists, blocklists, and C&C Server feeds.
You can share a realm across the same feed type for dynamic address, allowlist, blocklist, and
CC. For Infected hosts and DDoS, realms cannot be shared across the same feed type.
However, you can share a realm across different feed types.

The ATP Cloud/ATP Appliance realm without any assigned sites are not listed here. Only
realms with sites associated are listed here.

NOTE: If a site is associated with a tenant, the ATP Cloud/ATP Appliance realm displays the
list in the <realm-name>(Tenant:<tenant-name>) format.

User Input
Type

(Available for
Allowlist and
Blocklist)

Select one of the following input types for Allowlist and Blocklist:

• IP, Subnet and Range—Enter an IPV4 address in standard four octet format. CIDR notation
and IP address ranges are also accepted. Any of the following formats are valid: 1.2.3.4,
1.2.3.4/30, or 1.2.3.4-1.2.3.6.

• URL and Domain—The following formats are valid:

• http://www.yourfeed.com

• https://www.yourfeed.com

• www.yourfeed.com

• yourfeed.com

• yourfeed.com/abc

Wildcards and protocols are not valid entries.
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Table 66: Fields on the Create Custom Feed Page, Feeds with Local Files (Continued)

Field Description

Custom List Do one of the following:

• Click Upload File to upload a text file with an IP address list. Click the Add button to include
the address list in your custom list.

For infected host and DDoS, the uploading file must have the string add at the beginning,
followed by the IP addresses. If you want to delete certain IP addresses, enter the string
delete followed by the IP addresses to delete.

Note that the file must contain only one item per line (no commas or semi colons). All items
are validated before being added to the custom list.

The file must not contain more than 500 entries. An error message is shown if you try to
upload a file containing more than 500 IP addresses. Use the Feeds with remote file server
option to upload a file containing more than 500 IP addresses.

• Manually enter your item and threshhold value in the space provided in the Custom List
section. To add more items, click + to add more spaces.

For syntax, enter an IPv4 address in standard four octet format. CIDR notation and IP
address ranges are also accepted. Any of the following formats are valid: 1.2.3.4,
1.2.3.4/30, or 1.2.3.4-1.2.3.6.

Table 67: Fields on the Create Custom Feed Page, Feeds with Remote File Server

Field Description

Name Enter a unique string that must begin with an alphanumeric character and can include
only dashes and underscores; no spaces allowed; 32-character maximum.

Description Enter a description for your custom feed; maximum length is 64 characters. You should
make this description as useful as possible for all administrators.
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Table 67: Fields on the Create Custom Feed Page, Feeds with Remote File Server (Continued)

Field Description

Feed Type Select one of the following custom feeds as a threat prevention type:

• Dynamic Address

• Allowlist

• Blocklist

• Infected Hosts

• DDoS

• CC

Type of Server URL Select one of the following:

• http

• https

Server File URL Enter the URL for the remote file server.

Certificate Upload

(If the URL type is
HTTPS)

Click Browse and select the CA certificate to upload.

If you do not upload a certificate for https server URL, a warning message is shown that
a certificate is not uploaded and to whether proceed further or not. Click Yes to proceed
further without uploading a certificate or No to go back and upload the certificate.

Username Enter the credentials for the remote file server.

This is not a mandatory field. You can still proceed to create a custom feed without
entering the username.

Password Enter the credentials for the remote file server.

This is a mandatory field, if you have provided the username.

Update Interval Select how often updates are retrieved from the remote files server: Hourly, Daily,
Weekly, Monthly, Never
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Table 67: Fields on the Create Custom Feed Page, Feeds with Remote File Server (Continued)

Field Description

Sites Select the required sites from the list to associate them with the custom feeds.

If you try to disenroll a site in an infected host, a warning message is shown to resolve all the current
infected hosts from the respective endpoints within a site. To resolve the infected hosts, log-in to ATP
Cloud UI, resolve the hosts, and then unassign sites from Policy Enforcer. Ensure that you always resolve
the infected hosts before unassigning sites. Once you unassign sites, you cannot resolve the hosts.

RELATED DOCUMENTATION

Custom Feed Sources Overview  |  238

About the Feed Sources Page  |  240

Configuring Settings for Custom Feeds  |  272

Example: Creating a Dynamic Address Custom Feed
and Firewall Policy

As stated earlier, dynamic addresses provide dynamic IP address information to security policies. A
dynamic address entry (DAE) is a group of IP addresses, not just a single IP prefix, that can be entered
manually or imported from external sources. The DAE feature allows feed-based IP objects to be used in
security policies to either deny or allow traffic based on either source or destination IP criteria. For
example, a DAE may contain IP addresses for specific domains or for entities that have a common
attribute such as a particular undesired location that poses a threat. When the DAE is updated, the
changes automatically become part of the security policy. There is no need to manually update the
policy; no configuration commit action is required.

This topic steps you through a simple example of creating a DAE and associating it with a policy. For
complete information in creating firewall policies in Security Director, see Creating Firewall Policies.

1. Click Configure>Threat Prevention>Feed Sources.

The Feed Sources page appears.

2. In the Custom Feeds tab, click Create > Feeds with local files.

3. Enter DAE_example1 as the name.
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4. Select Dynamic Address from the Feed Type list.

5. Select the ATP Cloud realms from the Realms field.

6. In the Custom List field, click the plus sign (+) to add individual entries to the custom list.

7. Add the following IP addresses. See the online help for information on supported formats.

• 192.0.2.0

• 192.0.2.1/10

• 198.51.100.0-198.51.100.5

8. Make sure all entries in the custom list are unchecked and click OK.

9. Click Configure > Firewall Policy > Policies.

NOTE: This is example uses simplistic rules to show how to associate a DAE with an
allowlist firewall policy. When creating your own firewall policy, you will have to
configure the rules that meet your company’s requirements.

10. Click the plus sign (+) to create a new firewall policy.

11. Enter dynamic_address_test as the name.

12. Select All Logging Enabled from the Profile pull-down menu.

13. Select Device Policy as the Type and select a device from the Device pull-down menu.

14. Click OK.

After a few seconds, the dynamic_address_test policy appears in the list.

15. Click Add Rule next to the dynamic_address_test policy to start the rule wizard.

16. Enter dynamic_rule as the name and click Next.

17. In the Source window, select untrust from the Zone pulldown menu and click Select under the
Address(es) field.

18. In the Source Address window, select the Include Specific radio button.

19. Select DAE_example1 in the left table and click the right arrow to move it to the right table. Then click
Next.

The Source window reappears and DAE_example1 appears in the address(es) field.

20. In the Destionation window, select trust from the Zone pulldown menu and click Next.

21. In the Advanced Security window, select permit from the Rule Action pulldown menu and click
Next.

22. In the Rule Options window, click Next to use the default settings.

23. Click Select in the Address(es) section and click the Include Specifics radio button.

24. In the Rule Analysis window, select the Analyze the new rule to suggest a placement to avoid
anomalies checkbox and click Next.

After a few seconds, an analysis of your rule appears, including where it should be placed, etc.
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25. Click Finish and then OK to exit the wizard.

26. In the resulting page, click Save (located near the top of the window.)

27. Check the checkbox for the dynamic_rule policy and click Publish.

When you publish rules, the process takes into account the priority and precedence values set on
the policy and the order of rules on the device.

Configuring Settings for Custom Feeds

Use the Settings page to specify the number of days for the custom feed to be active and expire once
the duration is crossed. Also, specify how often the feeds must be updated.

In the ATO Cloud with Juniper Connected Security, Clouds feed only, and No ATO Cloud modes, you
can configure the Time To Live (TTL) settings for dynamic address, allowlist, blocklist, infected host,
DDoS, and C&C Server feed types. In the ATO Cloud mode, you can configure TTL settings for only
dynamic address, allowlist, blocklist, and C&C Server feed types.

NOTE: When you configure a TTL setting for a particular feed type, the configuration is
applicable for all the custom feeds belonging to that particular feed type. For example, if
you set TTL for Allowlist feed type to 45 days, then all Allowlist feeds will have the same
configuration.

To configure Settings:

1. Select Configure>Threat Prevention>Feed Source.

The Feed Sources page appears.

2. In the Custom Feeds tab, select Settings.

The Settings page appears.

3. Complete the configuration by using the guidelines in Table 68 on page 273.

4. Click Update.

The settings are updated and a success message is shown that the Settings are updated successfully.

At the beginning of the Settings page, the last updated settings information is shown. This message is
refreshed whenever you update the setting.
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Table 68: Fields on the Settings Page

Option Description

Time to live Select one of the following options:

• Specify manually—Select this option to specify the number of days for the required custom
feed type to be active.

• Expires in (days)—Enter the number of days for the required custom feed to be active.
Default value is 30 days. The available range is 1 to 365 days.

The number of days that you configure in this field appears in the Days to Become Inactive
field on the Custom Feeds page. If you make any changes to this field, the same
information is refreshed in the Days to Become Inactive field and the timer is adjusted to
the updated value.

• Never Expire—Select this option if you do not want any custom feed type to be inactive or
expire.

Update
Interval

Specify how often each feed type must be updated.

By default, all feeds are updated every 5 minutes.

Valid range is 1 through 5 minutes.
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Implementing Threat Policy on VMWare NSX
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Configuring VMware NSX with Policy Enforcer  |  279

Example: Creating a Firewall Rule in VMWare vCenter Server Using SDSN_BLOCK Tag  |  282

VMWare NSX Integration with Policy Enforcer and Juniper ATP Cloud
Overview

IN THIS SECTION

Implementation of Infected Hosts Policy Overview for VMware NSX  |  276

Registering NSX Micro Service as Policy Enforcer Connector Instance Overview  |  277

Juniper Networks Advanced Threat Prevention Cloud (Juniper ATP Cloud) identifies the infected virtual
machines (VMs) running on VMWare NSX and tags these VMs as infected. This is based on a malware
file exchange from the infected VMs and/or based on the Command and Control communication with
known botnet sites on the internet.

Based on this identification of infected or compromised hosts, you can take one of the following actions:

• Enable additional security features such as Layer-7 Application Firewall and Intrusion Prevention
(IPS) leveraging vSRX

• Enforce Layer-2 to Layer-4 controls using NSX Distributed Firewall

• Leverage NSX integration with Host-Based security vendors (https://www.vmware.com/
products/nsx/technology-partners.html) to take host-based security actions such as running antivirus
or anti malware features on the infected VMs.

Policy Enforcer provides a set of Connector APIs for the third-party adaptors. The NSX Connector
integrates with the Policy Enforcer using these APIs to enable enforcement of the infected hosts policy
on Secure Fabric. For NSX connectors, the NSX Manager , its associated vCenter, and an edge firewall
form the Secure Fabric.

The following topology shows how NSX Manager and the edge firewall create a Secure Fabric to use
with Policy Enforcer.
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Figure 76: Topology of NSX Integration with Policy Enforcer

Within the NSX Manager, the virtual machines (VM) connect to logical networks, shown as green and
yellow colour logical networks, as shown in Figure 76 on page 275. The logical switches connect to each
other using a Distributed Logical Router(DLR). To form the Secure Fabric, configure the edge service
gateway (ESG) to point to SRX Series devices or vSRX as the gateway for the networks hosted on NSX.
This is implemented by establishing IBGP session between ESG and vSRX or SRX Series device. This
ensures that all the north-south traffic passes through the vSRX edge firewall. The vSRX edge gateway is
enrolled with Juniper ATP Cloud for the traffic inspection.

If NAT services are required, it must be configured on the vSRX and not on the ESG. Configure NAT
services using the following CLI commands.

set security nat source rule-set trust-to-untrust from zone trust

set security nat source rule-set trust-to-untrust to zone untrust

set security nat source rule-set trust-to-untrust rule snat-rule match source-address 0.0.0.0/0

set security nat source rule-set trust-to-untrust rule snat-rule then source-nat interface

To establish a BGP session, use the following configuration commands:

set routing-options autonomous-system 10

set protocols bgp group nsx neighbor 5.0.0.2 peer-as 10
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You can view the BGP configuration in VMWare vCenter Server, as shown in Figure 77 on page 276.

Figure 77: VMWare vCenter BGP Configuration

NOTE: You can register the NSX Manager with Security Director only when the Policy
Enforcer is configured. The NSX micro service is bundled with the Policy Enforcer VM.
However, the NSX micro service is packaged as a standalone rpm, so that the NSX micro
service upgrade and patches can be performed independent of the Policy Enforcer VM.

Implementation of Infected Hosts Policy Overview for VMware NSX

The vSRX or SRX Series devices running as an edge firewall is enrolled to send all the suspected traffic
to Juniper ATP Cloud.

The following steps explain the high-level workflow:

• If an infection is detected, Juniper ATP Cloud notifies the Policy Enforcer about the infected IP
addresses

• If the infected IP address belongs to Secure Fabric associated with the NSX domain, Policy Enforcer
calls the NSX plugin APIs to notify the NSX Connector about the list of infected IP addresses

• NSX service will then retrieve the VM corresponding to the IP addresses sent and then calls the NSX
API to tag to an appropriate VM with a security tag, SDSN_BLOCK.

You can then create a policy to block the infected hosts using the SDSN_BLOCK tag by creating
VMWare Distributed Firewall (DFW) rules. The block policy consists of two rules for ingress block and
egress block. The ingress block rule applies to any traffic originating from a security group composed of
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VMs tagged with a block tag to any destination. Similarly, the egress block rule applies to any traffic
destined to security group composed of VMs tagged with block tag from any source.

The creation of security groups associated with the SDSN_BLOCK tag, creation of ingress and egress
block rules, and the action to take on the matching packets must be configured by the VMWare
administrators. The NSX Connector will simply apply the SDSN_BLOCK tag on the infected VM.

Registering NSX Micro Service as Policy Enforcer Connector Instance Overview

The integration of each NSX manager discovered in Security Director with Policy Enforcer is triggered
automatically.

The automatic registration of a connector instance involves the following steps:

1. Discovering the NSX Manager in Security Director. This triggers an auto creation of the Policy
Enforcer connector instance.

2. Secure Fabric is created to manage the discovered NSX Manager.

3. Creation of threat prevention policy requires the knowledge of Juniper ATP Cloud realm and the
edge firewall device. These are taken as inputs from the user.

Before You Begin

IN THIS SECTION

Infected Hosts Workflow in VMware vCenter Server  |  277

Before you begin to configure NSX with Policy Enforcer, configure the infected hosts workflow in
VMWare vCenter Server.

Infected Hosts Workflow in VMware vCenter Server

To block the infected hosts:

1. Log in to the vSphere Web Client through the VMware vCenter Server.

2. From the vSphere Web Client, click Networking & Security and then click NSX Managers.

Under the Manage section, click Security Tags column head and create SDSN_BLOCK security tag for
NSX, as shown in Figure 78 on page 278.
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Figure 78: SDSN_BLOCK Security Tag

The feed for the infected hosts will be triggered by Juniper ATP Cloud down to Policy Enforcer.
When there is a trigger, the SDSN_BLOCK tag is attached to the VM. Click on the VM Count column
to see the VM details attached to the tag.

3. Select Networking & Security and then click Service Composer.

The Service Composer page appears. From the Service Composer, click the Security Groups tab. The
security administrator can create the security group based on the security tag.

4. Click the New Security Group icon to create a new security group.

5. Enter a name and description for the security group and then click Next.

6. On the Define dynamic membership page, define the criteria that an object must meet for it to be
added to the security group you are creating.

In the Criteria Details row, select Security Tag from the list and provide the SDSN_BLOCK tag name,
as shown in Figure 79 on page 279.
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Figure 79: Define Dynamic Membership Page

Click Next.

7. In the Ready to Complete page, verify the parameters and click Finish.

In the Service Composer page, under the Security Groups tab, you can see that the security group
has been created and the VM with the security tag is assigned to the security group.

Configuring VMware NSX with Policy Enforcer

The following steps explain configuring VMWare NSX with Policy Enforcer:

1. Add the NSX Manager to the Security Director database, as shown in Figure 80 on page 280. To
know more about adding a NSX Manager, see Adding the NSX Manager.
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Figure 80: Adding NSX Manager Page

2. After discovering the NSX Manager in Security Director, use the Guided Setup workflow to configure
the following parameters:

• Secure Fabric

• Policy Enforcement Group (PEG)

• Juniper ATP Cloud Realm

• Threat policies for the following threat types:

• Command and Control (C&C) Server

• Infected Hosts

• Malware

3. Select Configuration > Guided Setup > Threat Prevention.

The Threat Prevention Policy Setup page appears.

4. Click Stat Setup.

The Threat Prevention Policy Setup page appears, as shown in Figure 81 on page 281. Some of the
resources are already configured as you discover the NSX Manager.
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Figure 81: Guided Setup Page

5. In the Secure Fabric page, the site is already created. For that site, one enforcement point is also
added.

To create a secure fabric site in Policy Enforcer for NSX based environment, you require two parts :
NSX Manager and edge firewall. In the Add Enforcement Points page, add vSRX, as shown in the
topology, as a edge firewall. Select the vSRX device listed under the Available column and move it to
the Selected column. You now have two enforcement points within the Secure Fabric.

Click Next.

6. In the Policy Enforcement Groups page, the policy enforcement group is already created based on
the Location Group Type. The location points to the Secure Fabric site created for NSX.

Click. Next.

7. In the ATP Cloud Realm page, associate the Secure Fabric with ATP Cloud realm.

If the ATP Cloud realm is already created, click Assign Sites in the Sites Assigned column and chose
the Secure Fabric site. The ATP Cloud realm and Secure Fabric are now associated.

Click. Next.

8. In the Policies page, create a threat prevention policy by choosing the profile types depending on the
type of threat prevention this policy provides (C&C Server, Infected Host, Malware) and an action for
the profile. The DDoS profile is not supported by the NSX Connector. Once configured, you apply
policies to PEGs.

Click Assign groups in the Policy Enforcement Group column to associate the policy enforcement
group with the policy.

Security Director takes the snapshot of the firewall by performing the rule analysis and threat
remediation rules are pushed into the edge firewall.

Click Finish.
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NOTE: The GeoIP feeds are not used with the NSX Connectors.

9. The last page is a summary of the items you have configured using quick setup. Click OK to be taken
to the Policies page under Configure > Threat Prevention > Policies and your policy is listed there.

Example: Creating a Firewall Rule in VMWare vCenter Server Using
SDSN_BLOCK Tag

The following example shows the firewall rule creation using the SDSN_BLOCK security tag:

1. Log in to the vSphere Web Client through the VMware vCenter Server.

2. Select Networking & Security and then click Service Composer.

The Service Composer page appears.

3. Select Security Policies tab in the Service Composer page.

Create a security policy to block the traffic coming from the infected hosts.

4. Select the Create Security Policy icon.

The New Security Policy page appears.

5. Enter a name and description for the security policy, and click Next.

6. Select the Firewall Rules option from the left pane.

The Firewall Rules page appears.

7. Select the New Firewall Rule icon (+) to create a new firewall rule.

The New Firewall Rule page appears.

8. Enter the name of the firewall rule.

9. In the Action field, select the Block option.

10. In the Source field, click Change and select the security group.

11. In the Destination field, click Change and select the security group to add as Any.

Click Ok. Figure 82 on page 283 shows a sample firewall rule configuration.
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Figure 82: New Firewall Rule Page

12. Click Finish.

A new policy is created. You can apply this policy to the security group.

13. In the Security Policies page, right-click on the policy name and select Apply Policy.

The Apply Policy to Security Groups page appears, as shown in Figure 83 on page 284.
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Figure 83: Apply Policy to SG Page

14. Select the security group that you have created and assign to a policy.

Security administrator is now able to block the traffic coming from the infected hosts.

Implement Threat Policy on VMWare NSX-T

IN THIS SECTION

VMWare NSX-T Integration with Policy Enforcer and ATP Appliance Cloud Overview  |  285

Before You Begin  |  287

Configure VMware NSX-T with Policy Enforcer  |  289

Example: Create a Firewall Rule in VMware NSX-T Using SDSN_BLOCK Tag  |  292
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VMWare NSX-T Integration with Policy Enforcer and ATP Appliance
Cloud Overview

IN THIS SECTION

Implementation of Infected Hosts Policy Overview  |  286

Register NSX Micro Service as Policy Enforcer Connector Instance Overview  |  287

Juniper Networks Advanced Threat Prevention Cloud (ATP Appliance Cloud) identifies the infected
virtual machines (VMs) running on VMWare NSX-T and tags these VMs as infected. This is based on a
malware file exchange from the infected VMs and/or based on the Command and Control
communication with known botnet sites on the internet.

Based on this identification of infected or compromised hosts, you can take one of the following actions:

• Enable additional security features such as Layer-7 Application Firewall and Intrusion Prevention
(IPS) leveraging vSRX

• Enforce Layer-2 to Layer-4 controls using NSX Distributed Firewall

• Leverage NSX integration with Host-Based security vendors (https://www.vmware.com/
products/nsx/technology-partners.html) to take host-based security actions such as running antivirus
or anti malware features on the infected VMs.

Policy Enforcer provides a set of Connector APIs for the third-party adaptors. The NSX Connector
integrates with the Policy Enforcer using these APIs to enable enforcement of the infected hosts policy
on Secure Fabric. For NSX connectors, the NSX-T Manager, its associated vCenter, and an edge firewall
form the Secure Fabric.

The following topology shows how NSX Manager and the edge firewall create a Secure Fabric with
Policy Enforcer.
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Figure 84: Topology of NSX-T Integration with Policy Enforcer

The service which is deployed in Tier 0 gateway in VMware NSX-T is enrolled into ATP Appliance Cloud
and acts as an edge firewall.

NOTE: You can register the NSX-T Manager with Security Director only when the Policy
Enforcer is configured. The NSX micro service is bundled with the Policy Enforcer VM.
However, the NSX micro service is packaged as a standalone rpm, so that the NSX micro
service upgrade and patches can be performed independent of the Policy Enforcer VM.

Implementation of Infected Hosts Policy Overview

The vSRX or SRX Series Firewall running as an edge firewall is enrolled to send all the suspected traffic
to ATP Appliance Cloud.

The following steps explain the high-level workflow:

• If an infection is detected, ATP Appliance Cloud notifies the Policy Enforcer about the infected IP
addresses

• If the infected IP address belongs to Secure Fabric associated with the NSX domain, Policy Enforcer
calls the NSX plugin APIs to notify the NSX Connector about the list of infected IP addresses

• NSX service will then retrieve the VM corresponding to the IP addresses sent and then calls the NSX
API to tag to an appropriate VM with a security tag, SDSN_BLOCK.

286



You can then create a policy to block the infected hosts using the SDSN_BLOCK tag by creating
gateway specific rules. The block policy consists of two rules for ingress block and egress block. The
ingress block rule applies to any traffic originating from a security group composed of VMs tagged with a
block tag to any destination. Similarly, the egress block rule applies to any traffic destined to security
group composed of VMs tagged with block tag from any source.

The creation of security groups associated with the SDSN_BLOCK tag, creation of ingress and egress
block rules, and the action to take on the matching packets must be configured by the VMWare
administrators. The NSX Connector will simply apply the SDSN_BLOCK tag on the infected VM.

Register NSX Micro Service as Policy Enforcer Connector Instance Overview

The integration of each NSX-T Manager discovered in Security Director with Policy Enforcer is triggered
automatically.

The automatic registration of a connector instance involves the following steps:

1. Discovering the NSX-T Manager in Security Director. This triggers an auto creation of the Policy
Enforcer connector instance.

2. Secure Fabric is created to manage the discovered NSX-T Manager.

3. Creation of threat prevention policy requires the knowledge of ATP Appliance Cloud realm and the
edge firewall device. These are taken as inputs from the user.

Before You Begin

IN THIS SECTION

Infected Hosts Workflow in VMware NSX-T  |  287

Before you begin to configure NSX with Policy Enforcer, configure the infected hosts workflow in
VMWare NSX-T Manager.

Infected Hosts Workflow in VMware NSX-T

To block the infected hosts:

1. Log in to VMware NSX-T Manager.
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2. Select Inventory > Tags.

The Tags page is displayed.

3. Click ADD TAG and enter the tag name as SDSN_BLOCK.

4. Click Set Virtual Machines to select Virtual Machines where the tag should be applied.

The Select Virtual Machines page is displayed.

5. Select the virtual machine and click Apply.

6. Click SAVE to add the tag.

On successful creation of the tag, it will be displayed on the Tags page as shown in Figure 85 on
page 288.

Figure 85: Tags Page

7. Select Inventory > Groups and then click ADD GROUP.

The security administrator can create the security group based on the security tag.

8. Enter a name of the security group.

9. Click Set Members.

The Select Members page is displayed, where you can define or add members for the security
group.

10. On the Membership Criteria tab, click ADD CRITERIA.

11. Define the criteria that an object must meet for it to be added to the security group you are
creating.

In the Criteria row, select the Virtual Machine and select the tag from the list and then select the
SDSN_BLOCK tag name, as shown in Figure 86 on page 289.
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Figure 86: Membership Criteria

Click Apply.

12. On the Groups page, click SAVE to add the group.

You can see that the security group has been created and the Virtual Machine with the security tag
is assigned to the security group.

Configure VMware NSX-T with Policy Enforcer

The following steps explain configuring VMWare NSX-T with Policy Enforcer:

1. Add the NSX-T Manager to the Security Director database, as shown in Figure 87 on page 290. To
know more about adding a NSX Manager, see Adding the NSX Manager.
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Figure 87: Add NSX Manager Page

2. After discovering the NSX-T Manager in Security Director, use the Guided Setup workflow to
configure the following parameters:

• Secure Fabric

• Policy Enforcement Group (PEG)

• ATP Appliance Cloud Realm

• Threat policies for the following threat types:

• Command and Control (C&C) Server

• Infected Hosts

• Malware

3. Select Configuration > Guided Setup > Threat Prevention.

The Threat Prevention Policy Setup page appears.

4. Click Stat Setup.

The Threat Prevention Policy Setup page appears, as shown in Figure 88 on page 291. Some of the
resources are already configured as you discover the NSX-T Manager.
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Figure 88: Threat Prevention Policy Setup Page

5. In the Secure Fabric page, the site is already created. For that site, one enforcement point is also
added.

To create a secure fabric site in Policy Enforcer for NSX based environment, you require two parts :
NSX Manager and edge firewall. In the Add Enforcement Points page, add vSRX, as shown in the
topology, as a edge firewall. Select the vSRX device listed under the Available column and move it to
the Selected column. You now have two enforcement points within the Secure Fabric.

Click Next.

6. In the Policy Enforcement Groups page, the policy enforcement group is already created based on
the Location Group Type. The location points to the Secure Fabric site created for NSX.

Click. Next.

7. In the ATP Cloud Realm page, associate the Secure Fabric with ATP Cloud realm.

If the ATP Cloud realm is already created, click Assign Sites in the Sites Assigned column and chose
the Secure Fabric site. The ATP Cloud realm and Secure Fabric are now associated.

Click. Next.

8. In the Policies page, create a threat prevention policy by choosing the profile types depending on the
type of threat prevention this policy provides (C&C Server, Infected Host, Malware) and an action for
the profile. The DDoS profile is not supported by the NSX Connector. Once configured, you apply
policies to PEGs.

Click Assign groups in the Policy Enforcement Group column to associate the policy enforcement
group with the policy.

Security Director takes the snapshot of the firewall by performing the rule analysis and threat
remediation rules are pushed into the edge firewall.

Click Finish.

NOTE: The GeoIP feeds are not used with the NSX Connectors.
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9. The last page is a summary of the items you have configured using quick setup. Click OK to be taken
to the Policies page under Configure > Threat Prevention > Policies and your policy is listed there.

Example: Create a Firewall Rule in VMware NSX-T Using SDSN_BLOCK
Tag

The following example shows the firewall rule creation using the SDSN_BLOCK security tag:

1. Log in to VMware NSX-T Manager.

2. Select Security > Gateway Firewall.

The GATEWAY FIREWALL page appears. Gateway firewall represents rules applied at the
perimeter firewall.

3. Select GATEWAY SPECIFIC RULES tab and then select a gateway.

4. Click Add Policy.

5. Enter the policy name for the new security policy.

6. Select a policy and then select Add Rule to create a new firewall rule and then enter the firewall
rule name.

7. Select the source as the security group with SDSN_BLOCK tag and click Apply.

8. In the Applied To column, select the interface to which the rule should be applied.

9. In the Action field, select the Drop option.

10. In the Destination field, select Any.
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Figure 89: Gateway Firewall

11. Click PUBLISH.

Now security administrator can block the traffic coming from the infected hosts.

RELATED DOCUMENTATION

VMware NSX Data Sheet

vSRX
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Policy Enforcer Dashboard Widgets

Policy enforcer adds widgets to the dashboard that provide a summary of all gathered information on
compromised content and hosts. Drag and drop widgets to add them to your dashboard. Mouse over a
widget to refresh, remove, or edit the contents.

In addition, you can use the dashboard to:

• Navigate to the File Scanning page from the Top Scanned Files and Top Infected Files widgets by
clicking the More Details link.

• Navigate to the Hosts page from the Top Compromised Hosts widget by clicking the More Details
link.

• Navigate to the Command and Control Servers page from the C&C Server Malware Source Location
widget.

NOTE: C&C and GeoIP filtering feeds are only available with the Cloud Feed or Premium
license.

Available dashboard widgets are as follows:

Table 69: ATP Cloud Dashboard Widgets

Widget Definition

Top Malware Identified A list of the top malware found based on the number of times the malware is
detected over a period of time. Use the arrow to filter by different time frames.

Top Compromised Hosts A list of the top compromised hosts based on their associated threat level and
blocked status.

Top Infected File Types A graph of the top infected file types by file extension. Examples: exe, pdf, ini, zip.
Use the arrows to filter by threat level and time frame.

Top Infected File
Categories

A graph of the top infected file categories. Examples: executables, archived files,
libraries. Use the arrows to filter by threat level and time frame.
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Table 69: ATP Cloud Dashboard Widgets (Continued)

Widget Definition

Top Scanned File Types A graph of the top file types scanned for malware. Examples: exe, pdf, ini, zip. Use
the arrows to filter by different time frames.

Top Scanned File
Categories

A graph of the top file categories scanned for malware. Examples: executables,
archived files, libraries. Use the arrows to filter by different time frames.

C&C Server and Malware
Source

A color-coded map displaying the location of Command and Control servers or
other malware sources. Click a location on the map to view the number of detected
sources.
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Infected Hosts Overview

The hosts page lists compromised hosts and their associated threat levels. From here, you can monitor
and mitigate malware detections on a per host basis.

NOTE: You must select ATP Cloud realm from the available pulldown.

Compromised hosts are systems for which there is a high confidence that attackers have gained
unauthorized access. When a host is compromised, the attacker can do several things to the computer,
such as:

• Send junk or spam e-mail to attack other systems or distribute illegal software.

• Collect personal information, such as passwords and account numbers.
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Compromised hosts are listed as secure intelligence data feeds (also called information sources.) The
data feed lists the IP address or IP subnet of the host along with a threat level; for example,
130.131.132.133 and threat level 5. Once threats are identified, you can create threat prevention
policies to take enforcement actions on the inbound and outbound traffic on these infected hosts.

Export Data—Click the Export button to download compromised host data to a CSV file. You are
prompted to narrow the data download to a selected time-frame.
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Infected Host Details

Use the host details page to view in-depth information about current threats to a specific host by time
frame. From here you can change the investigation status and the blocked status of the host.

Table 70 on page 297 shows the information provided on the host details page:

Table 70: Threat Level Definitions

Threat Level Definition

0 Clean; no action is required.

1–3 Low threat level. Recommendation: Disable this host.

4–6 Medium threat level. Recommendation: Disable this host.

7–10 High threat level. Host has been automatically blocked.
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• Host Status—Displays the current state by threat level, which could be any of the levels described in
the table above.

• Investigation Status—The following states of investigation are available: Open, In progress, Resolved -
false positive, Resolved - fixed, and Resolved - ignored.

• Policy override for this host—The following options are available: Use configured policy (not included
in infected hosts feed), Always include host in infected hosts feed, Never include host in infected
hosts feed.

NOTE: The blocked status changes in relation to the investigation state. For example,
when a host changes from an open status (Open or In Progress) to one of the resolved
statuses, the blocked status is changed to allowed and the threat level is brought down
to 0. Also, when the investigation status is changed to resolved, an event is added to
the log at the bottom of the page.

• Host threat level graph—This is a color-coded graphical representation of threats to this host
displayed by time frame. You can change the time frame, and you can slide the graph backward or
forward to zoom in or out on certain times. When you zoom in, you can view individual days within a
month.

• Expand time-frame to separate events—Use this check box to stretch a period of time and see the
events spread out individually.

• Past threats—The date and status of past threats to this host are listed here. The time frame set
previously also applies to this list. The description for each event provides details about the threat
and the action taken at the time.
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Command and Control Servers Overview

The Command and Control (C&C) servers page lists information on servers that have attempted to
contact and compromise hosts on your network. A C&C server is a centralized computer that issues
commands to botnets (compromised networks of computers) and receives reports back from them.
Botnets can be used to gather sensitive information, such as account numbers or credit card
information, or to participate in a distributed denial-of-service (DDoS) attack.

NOTE: 

• C&C and Geo IP filtering feeds are only available with ATP Cloud premium license.

• When managing ATP Cloud with Security Director, you must select ATP Cloud realm
from the available pulldown.

When a host on your network tries to initiate contact with a possible C&C server on the Internet, the
SRX Series device can intercept the traffic and perform an enforcement action based on real-time
intelligence feed information that identifies the C&C server IP address and URL.

• Export Data—Click the Export button to download C&C data to a CSV file. You are prompted to
narrow the data download to a selected time-frame.

• Report False Positives—Click the FP/FN button to launch a new screen which lets you send a report
to Juniper Networks, informing Juniper of a false position or a false negative. Juniper will investigate
the report, however, this does not change the verdict. If you want to make a correction (mark system
as clean) you must do it manually.

Table 71 on page 299 provides the following information available on the C&C page.

Table 71: Command & Control Server Data Fields

Field Definition

C&C Server The IP address of the suspected command and control server.

C&C Threat Level The threat level of the C&C server as determined by an analysis of actions and behaviors.

Hits The number of times the C&C server has attempted to contact hosts on your network.

C&C Country The country where the C&C server is located.
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Table 71: Command & Control Server Data Fields (Continued)

Field Definition

Last Seen The date and time of the most recent C&C server hit.

Protocol The protocol (TCP or UDP) the C&C server used to attempt communication.

Client Host The IP address of the host the C&C server attempted to communicate with.

Action The action taken on the communication (permitted or blocked).
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Command and Control Server Details

IN THIS SECTION

Hosts That have Contacted This C&C Server  |  301

Associated Domains  |  302

Signatures  |  302

Use Command and Control Server Details page to view analysis information and a threat summary for
the C&C server. The following information is displayed for each server.
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• Total Hits

• Threat Summary (Threat level, Location, Category, Time last seen)

• Ports and protocols used

You can filter this information by clicking on the time-frame links: 1 day, 1 week, 1 month, Custom
(select your own time-frame). You can also expand the time-frame to separate events using the slider.

Hosts That have Contacted This C&C Server

This is a list of hosts that have contacted the server. Table 72 on page 301 shows the information
provided in this section:

Table 72: Command & Control Server Contacted Host Data

Field Definition

Client Host The name of the host in contact with the command and control server.

Client IP Address The IP address of the host in contact with the command and control
server. (Click through to the Host Details page for this host IP.)

C&C Threat Level The threat level of the C&C server as determined by an analysis of
actions and behaviors.

Action The action taken on the communication (permitted or blocked).

Protocol The protocol (TCP or UDP) the C&C server used to attempt
communication.

Port The port the C&C server used to attempt communication.

Device Name The name of the device in contact with the command and control server.

Date Seen The date and time of the most recent C&C server hit.
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Table 72: Command & Control Server Contacted Host Data (Continued)

Field Definition

Username The name of the host user in contact with the command and control
server.

Associated Domains

This is a list of domains the destination IP addresses in the C&C server events resolved to.

Signatures

This is a list of command and control indicators that were detected.
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HTTP File Download Overview

A record is maintained of all file metadata sent to the cloud for inspection. These are files downloaded
by hosts and found to be suspicious based on known signatures or URLs. From the main page, click the
file’s signature to view more information, such as file details, what other malware scanners say about
this file, and a complete list of hosts that downloaded this file.

NOTE: When managing Juniper ATP Cloud with Security Director, you must select ATP
Cloud realm from the available pulldown.
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Export Data—Click the Export button to download file scanning data to a CSV file. You are prompted to
narrow the data download to a selected time-frame.

Table 73 on page 303 shows the following information available on this page:

Table 73: HTTP Scanning Data Fields

Field Definition

File Signature A unique identifier located at the beginning of a file that provides information on the contents
of the file. The file signature can also contain information that ensures the original data stored
in the file remains intact and has not been modified.

Threat Level The threat score.

NOTE: Click the three vertical dots at the top of the column to filter the information on the
page by threat level.

Filename The name of the file, including the extension.

NOTE: Enter text in the space at the top of the column to filter the data.

Last Submitted The time and date of the most recent scan of this file.

URL The URL from which the file originated.

NOTE: Enter text in the space at the top of the column to filter the data.

Malware The name of file and the type of threat if the verdict is positive for malware. Examples: Trojan,
Application, Adware. If the file is not malware, the verdict is "clean."

NOTE: Enter text in the space at the top of the column to filter the data.

Category The type of file. Examples: PDF, executable, document.

NOTE: Enter text in the space at the top of the column to filter the data.
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Email Attachments Scanning Overview  |  308

File Scanning Limits  |  314

HTTP File Download Details

IN THIS SECTION

File Summary  |  305

HTTP Downloads  |  306

Use the File Scanning Details page to view analysis information and malware behavior summaries for the
downloaded file. In the HTTP File Download page, click on the File Signature to go to the File Scanning
Details page. This page is divided into several sections:

Report False Positives—Click the Report False Positive button to launch a new screen which lets you
send a report to Juniper Networks, informing Juniper of a false position or a false negative. Juniper will
investigate the report, however, this does not change the verdict. If you want to make a correction (mark
system as clean) you must do it manually.

Printable View—Click this link to organize the information into a print-ready format.

The top of the page provides a quick view of the following information (scroll to the right in the UI to
see more boxes):

• Threat Level—This is the threat level assigned (0-10), This box also provides the threat category and
the action taken.

• Top Indicators—In this box, you will find the malware name, the signature it matches, and the IP
address/URL from which the file originated.

• Prevalence—This box provides information on how often this malware has been seen, how many
individual hosts on the network downloaded the file, and the protocol used.

304



File Summary

Table 74: General Summary Fields

Field Definition

Threat Level This is the assigned threat level 0-10. 10 is the most malicious.

Global Prevalence How often this file has been seen across different customers.

Last Scanned The time and date of the last scan to detect the suspicious file.

File Name The name of the suspicious file. Examples: unzipper-setup.exe, 20160223158005.exe,,
wordmui.msi.

Category The type of file. Examples: PDF, executable, document.

File Size The size of the downloaded file.

Platform The target operating system of the file. Example. Win32

Malware Name If possible, ATP Cloud determines the name of the malware.

Malware Type If possible, Juniper ATP Cloud determines the type of threat. Example: Trojan, Application,
Adware.

Malware Strain If possible, Juniper ATP Cloud determines the strain of malware detected. Example:
Outbrowse.1198, Visicom.E, Flystudio.

sha256 and md5 One way to determine whether a file is malware is to calculate a checksum for the file and
then query to see if the file has previously been identified as malware.

In the Network Activity section, you can view information in the following tabs:

• Contacted Domains—If available, lists any domains that were contacted while executing the file in
the Juniper ATP Cloud sandbox.
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• Contacted IPs—If available, lists all IPs that were contacted while executing the file, along with the
destination IP’s country, ASN, and reputation. The reputation field is based on Juniper IP intelligence
data destination.

• DNS Activity— This tab lists DNS activity while executing the file, including reverse lookup to find
the domain name of externally contacted servers. This tab also provides the known reputation of the
destination servers.

HTTP Downloads

This is a list of hosts that have downloaded the suspicious file. Click the IP address to be taken to the
Host Details page for this host. Click the Device Serial number to be taken to the Devices page. From
there you can view device versions and version numbers for the Juniper ATP Cloud configuration,
including profile, allowlist, and blocklist versions. You can also view the malware detection connection
type for the device: telemetry, submission, or C&C event.
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SMTP Quarantine Overview

Access this page from the Monitor menu.

The SMTP quarantine monitor page lists quarantined emails with their threat score and other details
including sender and recipient. You can also take action on quarantined emails here, including releasing
them and adding them to the blocklist.

The following information is available from the Summary View:
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Table 75: Blocked Email Summary View

Field Description

Time Range Use the slider to narrow or increase the time-frame within the selected
the time parameter in the top right: 12 hrs, 24 hrs, 7 days or custom.

Total Email Scanned This lists the total number of emails scanned during the chosen time-
frame and then categorizes them into blocked, quarantined, released, and
permitted emails.

Malicious Email Count This is a graphical representation of emails, organized by time, with lines
for blocked emails, quarantined and not released emails, and quarantined
and released emails.

Emails Scanned This is a graphical representation of emails, organized by time, with lines
for total emails, and emails with one or more attachments.

Email Classification This is another graphical view of classified emails, organized by
percentage of blocked emails, quarantined and not released emails, and
quarantined and released emails.

The following information is available from the Detail View:

Table 76: Blocked Email Detail View

Field Description

Recipient The email address of the recipient.

Sender The email address of the sender.

Subject Click the Read This link to go to the Juniper ATP Cloud quarantine portal
and preview the email.

Date The date the email was received.
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Table 76: Blocked Email Detail View (Continued)

Field Description

Malicious Attachment Click on the attachment name to go to the Juniper ATP Cloud file
scanning page where you can view details about the attachment.

Size The size of the attachment in kilobytes.

Threat Score The threat score of the attachment, 0-10, with 10 being the most
malicious.

Threat Name The type of threat found in the attachment, for example, worm or trojan.

Action The action taken, including the date and the person (recipient or
administrator) who took the action.

Using the available buttons on the Details page, you can take the following actions on blocked emails:

• Add domain to blocklist

• Add sender to blocklist

• Release
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Email Attachments Scanning Overview

A record is kept of all file metadata sent to the cloud for inspection. These are files downloaded by hosts
and found to be suspicious based on known signatures From the main page, click the file’s signature to
view more information, such as file details, what other malware scanners say about this file, and a
complete list of hosts that downloaded this file.
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NOTE: You must select a ATP Cloud realm from the available pulldown.

Export Data—Click the Export button to download file scanning data to a CSV file. You are prompted to
narrow the data download to a selected time-frame.

Table 77 on page 309 shows the information available on this page.

Table 77: Email Attachments Scanning Data Fields

Field Definition

File Signature A unique identifier located at the beginning of a file that provides information on the contents
of the file. The file signature can also contain information that ensures the original data stored
in the file remains intact and has not been modified.

Threat Level The threat score.

Date Scanned The date and time the file was scanned.

Filename The name of the file, including the extension.

Recipient The email address of the intended recipient.

Sender The email address of the sender.

Malware Name The type of malware found.

Status Indicates whether the file was blocked or permitted.

Category The type of file. Examples: PDF, executable, document.
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File Scanning Limits  |  314

Email Attachments Scanning Details

IN THIS SECTION

File Summary  |  311

Use the File Scanning Details page to view analysis information and malware behavior summaries for the
downloaded file. In the Email Attachments page, click on the File Signature to go to the File Scanning
Details page. This page is divided into several sections:

Report False Positives—Click the Report False Positive button to launch a new screen which lets you
send a report to Juniper Networks, informing Juniper of a false position or a false negative. Juniper will
investigate the report, however, this does not change the verdict. If you want to make a correction (mark
system as clean) you must do it manually.

Printable View—Click this link to organize the information into a print-ready format.

The top of the page provides a quick view of the following information (scroll to the right in the UI to
see more boxes):

• Threat Level—This is the threat level assigned (0-10), This box also provides the threat category and
the action taken.

• Top Indicators—In this box, you will find the malware name, the signature it matches, and the IP
address/URL from which the file originated.

• Prevalence—This box provides information on how often this malware has been seen, how many
individual hosts on the network downloaded the file, and the protocol used.
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File Summary

Table 78: General Summary Fields

Field Definition

Threat Level This is the assigned threat level 0-10. 10 is the most malicious.

Action Taken The action taken based on the threat level and host settings: block or permit.

Global Prevalence How often this file has been seen across different customers.

Last Scanned The time and date of the last scan to detect the suspicious file.

File Name The name of the suspicious file. Examples: unzipper-setup.exe, 20160223158005.exe,,
wordmui.msi.

Category The type of file. Examples: PDF, executable, document.

File Size The size of the downloaded file.

Platform The target operating system of the file. Example. Win32

Malware Name If possible, Juniper ATP Cloud determines the name of the malware.

Malware Type If possible, Juniper ATP Cloud determines the type of threat. Example: Trojan, Application,
Adware.

Malware Strain If possible, Juniper ATP Cloud determines the strain of malware detected. Example:
Outbrowse.1198, Visicom.E, Flystudio.

sha256 and md5 One way to determine whether a file is malware is to calculate a checksum for the file and
then query to see if the file has previously been identified as malware.

In the Network Activity section, you can view information in the following tabs:

311



NOTE: This section will appear blank if there has been no network activity.

• Contacted Domains—If available, lists any domains that were contacted while executing the file in
the Juniper ATP Cloud sandbox.

• Contacted IPs—If available, lists all IPs that were contacted while executing the file, along with the
destination IP’s country, ASN, and reputation. The reputation field is based on Juniper IP intelligence
data destination.

• DNS Activity—This tab lists DNS activity while executing the file, including reverse lookup to find the
domain name of externally contacted servers. This tab also provides the known reputation of the
destination servers.

In the Behavior Details section, you can view the behavior of the file on the system. This includes any
processes that were started, files that were dropped, and network activity seen during the execution of
the file. Dropped files are any additional files that were downloaded and installed by the original file.
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IMAP Block Overview

The IMAP Block monitor page lists blocked emails with their threat score and other details including
sender and recipient. You can also take action on blocked emails here, including releasing them and
adding them to the blocklist.

Table 79 on page 313 shows information available from the Summary View tab.
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Table 79: Blocked Email Summary View

Field Description

ATP Cloud Realm Select the registered Juniper ATP Cloud realm from the list.

Time Range Use the slider to narrow or increase the time-frame within the selected
the time parameter in the top right: 12 hrs, 24 hrs, 7 days or custom.

Malicious Email Count This lists the total number of malicious emails scanned during the chosen
time-frame and then categorizes them into blocked, blocked and not
allowed, quarantined and allowed.

Emails Scanned This is a graphical representation of all scanned emails, organized by
date.

Table 80 on page 313 shows information available from the Detail View tab.

Table 80: Blocked Email Detail View

Field Description

Recipient Specifies the email address of the recipient.

Sender Specifies the email address of the sender.

Subject Click Read This to go to the Juniper ATP Cloud quarantine portal and
preview the email.

Date Specifies the date the email was received.

Malicious Attachment Click on the attachment name to go to the Juniper ATP Cloud file
scanning page where you can view details about the attachment.

Size Specifies the size of the attachment in kilobytes.
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Table 80: Blocked Email Detail View (Continued)

Field Description

Threat Score Specifies the threat score of the attachment, in a scale of 0-10, with 10
being the most malicious.

Threat Name Specifies the type of threat found in the attachment, for example, worm
or trojan.

Action Specifies the action taken, including the date and the person (recipient or
administrator) who took the action.

Using the available buttons on the Details page, you can take the following actions on blocked emails:

• Unblock Attachment for Selected User(s)

• Unblock Attachment for All Users

File Scanning Limits

There is a limit to the number of files which can be submitted to the cloud for inspection. This limit is
dictated by the device and license type. When the limit is reached, the file submission process is paused.

NOTE: This limit applies to all files, HTTP and SMTP.

Limit thresholds operate on a sliding scale and are calculated within 24-hour time-frame starting "now."

Perimeter Device Free License (files per day) Premium License (files per day)

SRX340 200 1,000

SRX345 300 2,000

SRX550m 500 5,000
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(Continued)

Perimeter Device Free License (files per day) Premium License (files per day)

SRX1500 2,500 10,000

SRX5400 5,000 50,000

SRX5600 5,000 70,000

SRX5800 5,000 100,000

vSRX(10mbps) 25 200

vSRX(100mbps) 200 1,000

vSRX(1000mbps) 2,500 10,000

vSRX(2000mbps) 2,500 10,000

vSRX(4000mbps) 3,000 20,000
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All Hosts Status Details

Use the All Hosts Status page to view the enforcement status of infected hosts feeds. The supported
host feeds are custom and Juniper ATP Cloud.
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By default, details for both custom and Juniper ATP Cloud hosts are shown. You must select the
required feed type from the Feed Source column.

NOTE: To view the All Hosts Status page, you must have the Threat Management
privileges or predefined roles enabled.

To see the details of all hosts status:

1. Select Monitor > Threat Prevention > All Hosts Status.

The All Hosts Status page appears.

2. Table 81 on page 316 shows the information provided on the All Hosts Status page.

Table 81: Fields on All Hosts Status Page

Column Name Description

IP Address Specifies the IP address of the feed.

MAC Address Specifies the MAC address of the feed.

Feed Name Specifies the name of the feed.

Feed Source Specifies type of the feed source.

Action Specifies the action of the infected host. For example: Block or Quarantine.

Enforcement Status Specifies the enforcement status of the infected host.

Switch Name Specifies the name of the Juniper Networks switch used to monitor the feed.

Interface Name Specifies the interface on the switch where the user is connected to a network.

Policy Associated Specifies the name of the associated threat prevention policy.

This column is not shown by default. Click Show Hide Column and select this field to
appear on the All Hosts Status page.
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Table 81: Fields on All Hosts Status Page (Continued)

Column Name Description

PEG Associated Specifies the Policy Enforcement Group (PEG) associated with the policy.

This column is not shown by default. Click Show Hide Column and select this field to
appear on the All Hosts Status page.

Matched Subnet Specifies the subnet that is added as an endpoint for the PEG.

This column is not shown by default. Click Show Hide Column and select this field to
appear on the All Hosts Status page.

Connector Type Specifies the type of connector used as an enforcement point.

Connector Name Specifies the name of the connector.

This column is not shown by default. Click Show Hide Column and select this field to
appear on the All Hosts Status page.

Endpoint Address Space
Type

Specifies the type of endpoints added to a PEG.

This column is not shown by default. Click Show Hide Column and select this field to
appear on the All Hosts Status page.

Endpoint Address Space
Name

Specifies the name of an endpoint.

This column is not shown by default. Click Show Hide Column and select this field to
appear on the All Hosts Status page.

You can click the filter icon to filter the data based on the following fields:

• Feed source type

• Action

• Enforcement status

• Connector type
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Device Feed Status Details

Use the Device Feed Status page to view the download status of feeds from various feed sources. You
can view the status of feeds for each device.

NOTE: To view the Device Feed Status page, you must have the Threat Management
privileges or predefined roles enabled.

To view the details of the device feed status:

1. Select Monitor > Threat Prevention > Device Feed Status.

The Device Feed Status page appears.

2. Table 82 on page 318 shows the information provided on the Device Feed Status page.

Table 82: Fields on the Device Feed Status Page

Column Name Description

Device Name Specifies the name of the device.

IP Specifies the IP address of the device.

Model Specifies the model of the device mentioned in the Device Name column. For example, vSRX.

Feed Name Specifies the name of the feed downloaded to the device.

This also shows the number of feeds downloaded. Click on the number to view the names of
the individual feeds.

Feed Category Specifies the category of the feed. For example, CC.

Last Downloaded Specifies the last downloaded date and time of each feed.
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You can click the filter icon to filter the data based on the following fields:

• Device name

• IP address of the device

• Model of the device

• Name of the feed

• Following feed categories:

• C&C

• Allowlist

• Blocklist

• Infected hosts

• Dynamic address

• DDoS

• GeoIP

RELATED DOCUMENTATION
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DDoS Feeds Status Details

Use the DDoS Feeds Status page to view the enforcement status of Distributed Denial of Service
(DDoS) feeds.

In ATP Cloud Only mode, you do not see the DDoS Feeds Status page under Monitor. An error message
is shown that the page is unavailable because the current threat prevention type is set to ATP Cloud
only mode.

NOTE: To view the DDoS Feeds Status page, you must have the Threat Management
privileges or predefined roles enabled.

To view details of DDoS feeds status:
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1. Select Monitor > Threat Prevention > DDoS Feeds Status.

The DDoS Feeds Status page appears.

2. Table 83 on page 320 shows information provided on the DDoS Feeds Status page.

Table 83: Fields on the DDoS Feeds Status Page

Column Name Description

Feed Name Specifies the DDoS feed name to monitor the feeds.

Site Specifies the associated site name with the DDoS feeds

MX Name Specifies the name of the MX router where DDoS is enabled.

MX IP Specifies the IP address of the MX router.

MX Status Specifies the status of the MX router.

Action Specifies the action taken for the DDoS profile

To filter the data based on a specific action, click the filter icon and select the required
DDoS profile action from the list.

Enforcement Status Specifies the enforcement status of the feed. Hover over the status to view the reason for
that particular status.

To filter the data based on a specific enforcement status, click the filter icon and select the
required enforcement status from list to monitor the feed.

Policy Specifies the name of the associated threat prevention policy.

PEG Specifies the Policy Enforcement Group (PEG) associated with the policy.

RELATED DOCUMENTATION
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Policy Enforcer Log File Locations

The following Policy Enforcer configuration settings files are located under /srv/feeder/etc/log:

NOTE: Do not edit these files unless instructed by the Juniper Networks Technical
Assistance Center (JTAC).

Table 84: Policy Enforcer Configuration Settings Files

Configuration settings files Description Example

controller_log.yml Defines the format for the controller.log file Message and date format and
maximum file size.

feed_collector_log.yml Defines the format for the
feed_collector.log file

Message and date format and
maximum file size.

feed_provider_log.yml Defines the format for the feed_provider.log
file.

Message and date format and
maximum file size.

The following Policy Enforcer log files are located under /srv/feeder/log. By default, a maximum of 10 files
are created for each log file. For example, controller.log, controller.log.1, controller.log.2, etc. After 10 files
are created, the oldest file (in this example, controller.log) is overwritten next.

Table 85: Policy Enforcer Log Files under /srv/feeder/log

Log files Description

controller.log Contains log messages for the interaction of Security Director with Policy Enforcer.

feed_collector.log Contains log messages for the downloading of feeds.

feed_provider.log Contains log messages for distributing feeds to the SRX Series devices.

The following Policy Enforcer log files are located under /var/log:
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Table 86: Policy Enforcer Log Files under /var/log

Log files Description

prepare_vm.log Contains information about your Policy Enforcer software installation.

pe_upgrade.log Contains information about your Policy Software software upgrade.

Troubleshooting Common Policy Enforcer Problems
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HTTPS-Based Malware Not Detected  |  325
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This topic lists some common problem areas you may encounter and how to remedy them.

Troubleshooting Policy Enforcer Installation

Most common Policy Enforcer installation problems occur around creating and deploying the OVA file. If
you are not familiar with virtual machines or OVA files, please see VMware Documentation and select
the appropriate VMware vSphere version.

Other areas to look for include:
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• Configuring the virtual machine with the correct network configuration. These values vary according
to your installation. When configuring the virtual machine network, you will need to know the
following:

• Virtual machine hostname, IP address and network mask.

• Default gateway that connects your internal network to external networks.

• Primary and secondary DNS servers.

• (optional) NTP servers.

• Virtual machine IP address and ssh root credentials. When configuring the virtual machine, you must
identify and record the IP address and the ssh root password. In order for Security Director to
communicate with your Policy Enforcer virtual machine, you must enter these values into the PE
Settings page (Administration > PE Settings) of Security Director.

If you forget the virtual machine IP address, log into the virtual machine again. The setup script
automatically runs each time you log in so that you can review your settings.

If you forget the root password, there is no way to retrieve it. You must instead reset your password.
Be sure to enter your new password into the PE settings page in Security Director. To reset your
password, see CentOS root password reset instructions.

Troubleshooting Juniper ATP Cloud Realms and Enrolling Devices

Juniper ATP Cloud has two service levels: free and premium. The free model solution performs basic
malware detection while the premium model solution offers more protection. For more information on
Juniper ATP Cloud license types and the features for each type, see Sky Advanced Threat Prevention
Licenses.

Some common problems areas with Juniper ATP Cloud are:

• Trying to enroll devices that are not supported by Juniper ATP Cloud. See the Juniper ATP Cloud
Supported Platforms Guide for more information on supported devices.

• The Juniper ATP Cloud file limit has been reached. Juniper ATP Cloud has a maximum number of
files per day that you can submit to the cloud for inspection. When an SRX Series device has reached
its maximum number of files, it goes into a paused state and cannot submit files for inspection. The
device automatically changes to the allowed state when it once again is below the maximum limit.
See Juniper ATP Cloud File Limits for more information on the maximum number of files per day per
device type.
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• The vSRX instance fails to enroll. Check to make sure the proper Juniper ATP Cloud license is
installed. See Managing the Juniper ATP Cloud License for more information on license management
with vSRX deployments.

Troubleshooting Threat Policies and Policy Enforcement Groups

This section lists some common issues found with threat policies and policy enforcement groups.

• You create a threat policy but don’t see the appropriate profiles to choose.

Select Administration > PE Settings and make sure the correct mode has been selected. You can only
change the mode in the follow order: Cloud Feed Only to ATP Cloud to ATP Cloud with PE.

• Assigning a threat policy to a policy enforcement group in the Juniper ATP Cloud with PE mode.

Threat policies are enforced and pushed to devices that support the given profile. If a device is not
supported by a profile, it will be listed in the analysis results and in the Junos Space job details.

• You create a policy enforcement group with an IP address subnet but no IP addresses are listed in the
GUI.

Make sure that a switch is assigned to the site and that the L3 interfaces are configured on the
aggregate switch.

HTTPS-Based Malware Not Detected

If your HTTPS-based malware is not detected by Juniper ATP Cloud, the root certificate on your SRX
Series device (for HTTPS forward proxy) may be invalid. This may occur when the CA profile name is not
correct. It must be named policyEnforcer.

For example:

root@host# set security pki policyEnforcer ssl-inspect-ca ca-identity ssl-inspect-ca
root@host# set security pki policyEnforcer ssl-ca ca-identity ssl-ca

For more information on loading root certificates with Policy Enforcer, see "Loading a Root CA" on page
54.
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Unable to add Policy Enforcer to Security Director

If you are unable to add Policy Enforcer to Security Director, do the following:

• Check if Policy Enforcer and Security Director are on the same version.

• Make sure to open the following ports:

• 8080, 443—Used to connect Security Director or Policy Enforcer to Internet.

• 443, 8080—Used to connect Policy Enforcer to Security Director.

• Check the Policy Enforcer node disk space using df -kh command and make sure that it has enough
disk space.

• Check Policy Enforcer log files. For more information, see Policy Enforcer Log File Locations.

Troubleshooting Policy Enforcer and SRX Series device Enrolment Issues

To resolve Policy Enforcer and SRX Series device enrolment issues, you must do the following:

• Check if Policy Enforcer and Security Director are on the same version.

• Use supported SRX Series or EX Series devices.

• SRX Series or EX Series device must be running supported Junos OS Release. For more information,
see Supported Devices.

• Check for SRX Series supported feature against the Model Cloud feed, ATP Cloud and so on.

• Check for SRX Series premium, basic, or free license and supported features.

• For SRX550M, SRX340, or SRX345 models, use set security forwarding-process enhanced-services-mode
command.

NOTE: Above command requires device reboot, therefore plan the downtime.

• Junos Space should have matching schema as per device Junos version.

• Check that the device is not enrolled directly via SLAX script. If enrolled, then disenroll the device.

• To check if the device is directly enrolled to ATP Cloud or enrolled via Policy Enforcer.

For example
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• root@jtac> show configuration services -intelligence |match "url "

If you get the output as https://IPADDRESS:443/api/v1/manifest.xml; then the device is enrolled via
Policy Enforcer. If you get https://cloudfeeds.argon.junipersecurity.net/api/manifest.xml, then the
device is directly enrolled to ATP Cloud.

• When you start enrolling the device to realm <RPC> job is triggered in Security Director and this is
visible only for ATP Cloud and ATP Cloud with SDSN mode Policy Enforcer deployment.

• For SDSN to work, make sure that the topologies should be as per "Supported Topologies" on page 5.
End host connection should be Access Port and other interconnecting ports should be Trunk Port.

Troubleshooting ClearPass Issues
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This section describes general troubleshooting tips when dealing with ClearPass issues with Policy
Enforcer. For detailed information on troubleshooting ClearPass and ClearPass logs, see your ClearPass
documentation.
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Viewing Logs Files

Policy Enforcer writes third-party plug-in log information to /srv/3rd-party-adapter/logs/plugin_server.log
using the following format:

[<date><time>:<line number>:<function name>:<level>]<detailed message>

Three types of information are recorded in the logs:

• Application initialization information.

• Heart-beat with Policy Enforcer—communication status between Policy Enforcer and the third-party
plug-in.

• Application operations—for troubleshooting third-party plug-in functionality.

The default logging level is set to DEBUG.

The following is an example of a heart-beat message log:

[07/20/2017 04:21:59 PM:_internal.py:87:_log():INFO ] 10.92.82.125 - - [20/Jul/2017 16:21:59] 
"GET /api/v1/adaptor/heartbeat HTTP/1.1" 200 -
[07/20/2017 04:22:29 PM:produces.py:117:wrapper():DEBUG ] Jsonifing http://
10.92.82.125:8082/api/v1/adaptor/heartbeat
[07/20/2017 04:22:29 PM:parameter.py:90:wrapper():DEBUG ] Function Arguments: []

The following is an example of an application operation log:

[07/20/2017 05:45:52 PM:default_controller.py:228:adaptor_threats_post():DEBUG ] Incoming threat 
POST request: {u'action': u'block', u'threatType': u'InfectedHost', u'endpoint': {u'macAddress': 
u'unknown', u'ip': u'192.168.140.20', u'name': u'', u'tags': []}}
[07/20/2017 05:45:52 PM:track_endpoint.py:27:__init__():INFO ] Creating new infected host 
tracking DB.
[07/20/2017 05:45:52 PM:clearpass_agent.py:66:getApiAuthenticationToken():DEBUG ] Get Oauth2 
access token for API client
[07/20/2017 05:45:52 PM:connectionpool.py:805:_new_conn():INFO ] Starting new HTTPS connection 
(1): 10.92.81.112
[07/20/2017 05:45:52 PM:connectionpool.py:401:_make_request():DEBUG ] "POST /api/oauth HTTP/1.1" 
200 116
[07/20/2017 05:45:52 PM:clearpass_agent.py:73:getApiAuthenticationToken():INFO ] Successful get 
Oauth2 access token
[07/20/2017 05:45:52 PM:thirdparty_controller.py:84:infectedHostNotif():DEBUG ] Validating 

328



endpoint [192.168.140.20] against Clearpass Endpoint DB
[07/20/2017 05:45:52 PM:clearpass_agent.py:80:getEndpointDataByIp():DEBUG ] Getting Endpoint 
detail by IP Address [192.168.140.20]

...

You can also access logs within ClearPass Policy Manager and ClearPass Guest to assist in
troubleshooting.

• Checking session logs

The Access Tracker window displays information of per-session access activity. To view this activity,
select Monitoring > Access Tracker within ClearPass Policy Monitor. See Figure 90 on page 329.

Figure 90: Checking Session Logs

Click a session in the table to display the Request Details window with details about that session.
Click Show Logs to view the log details. Change your log level to view more or less session
information.

• Errors reported by ClearPass
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To view events and messages generated by the ClearPass application, select Administration
> Support > Application Log within ClearPass Guest. See Figure 91 on page 330.

Figure 91: Viewing ClearPass Errors

Click an event to view details, such as possible causes for that error or a pointer for where to look for
more information.

Configuration Issues

The following are mandatory ClearPass information that must be passed to the Policy Enforcer third-
party plug-in to ensure proper communication:

• ClearPass IP address and port number.

• Client ID (clientId) for the API to access (configured with ClearPass Guest module).

• Client secret key, used together with clientId to obtain the access token for performing REST API
calls to the ClearPass server.

If you see a 404 error with “ClearPass configuration is missing” in the log file, then ClearPass is not
configured for Policy Enforcer. See "ClearPass Configuration for Third-Party Plug-in" on page 95 for
information on configuring ClearPass with Policy Enforcer.

Another method for checking whether ClearPass is configured for Policy Enforcer is to look for the /srv/
3rd-party-adapter/configuration.yaml file. If this file exists, then the configuration step has been performed.
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Error Code 500

If you receive an error code 500 with the log message There are no sessions to display. You should enable
Insight on at least one node in Policy Manager: Administration > Server Manager > Server Configuration then the
configured ClearPass server does not have Insight enabled. ClearPass Insight is used by ClearPass Policy
Manager for in-depth reporting and enhanced analytics.

To enable ClearPass Insight, select Administration > Server Manager > Server Configuration from
ClearPass Policy Manager. Click the ClearPass server and enable Insight. See Figure 92 on page 331.

Figure 92: Enabling ClearPass Insight

Unable to Block Infected Endpoint

If you are unable to block an infected endpoint, perform the following tasks:

• Validate the IP address using ClearPass API Explorer: Insight API, Endpoint service, then issue GET /
insight/endpoint/ip/{ip}

• Validate the corresponding active session using ClearPass API Explorer: GuestManager API,
ActiveSession service, then issue GET /session with corresponding “framedipaddress” equals to the
infected endpoint’s IP address, and sorted by “accstarttime” in order to ensure that the most recent
active sessions associated with the IP are displayed first. If there is no current active session
returned, the IP address passed down to the plug-in to block is invalid or does not existed.

• If the IP address is valid, confirm that the custom attribute sdsnEpStatus has been set accordingly to the
value ‘blocked’, using ClearPass API Explorer’s Endpoint API, Managed Endpoint services by issuing
the API GET /endpoint/mac-address/{mac-address} ,with {mac-address} of the endpoint obtained
from the output of the active session query issued earlier.
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• Custom attribute sdsnEpStatus can also be verified looking into the corresponding session in
ClearPass Policy Manager’s Access Tracker, in Input tab, “Compute Attributes” section.

Unable to Quarantine Infected Endpoint

If you are unable to quarantine an infected endpoint, first validate the IP address of the infected host
following the same procedure as in the Unable to Block Infected Endpoint topic above. Next, verify that
the value of the custom attribute sdsnEpStatus has been set to quarantine.

Unable to Clear Blocked or Quarantined Endpoint

If you are unable to clear blocked or quarantined endpoints, it’s usually because the passing IP address
does not exist in the infected endpoint tracking database maintained by the plug-in. Infected hosts are
located in the /srv/3rd-party-adapter/infectedEndpointList file. It is expected that a clear request will come
with the same IP address of the endpoint as in the earlier blocked or quarantined endpoint request. If
the clear request arrives with a new IP address that is not in the infected endpoint tracking database,
the request fails.

Also, check the ClearPass application log for possible internal errors.
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The Spotlight Secure Threat Intelligence Platform aggregates threat feeds from multiple sources to
deliver open, consolidated, actionable intelligence to SRX Series Firewalls across an organization. This
product is now superseded by the Juniper Connected Security Policy Enforcer. The Juniper Connected
Security framework delivers enhanced security from external as well as internal attacks by leveraging
both security as well as network devices as a coherent security system.

Policy Enforcer is an orchestration solution that orchestrates user intent policy enforcement for threat
remediation as well as micro-segmentation across the entire network. This document talks about the
logistics of migrating from Spotlight Secure to Policy Enforcer.

Spotlight Secure and Policy Enforcer with Juniper ATP Cloud are two different platforms and therefore a
direct migration of threat policies from Spotlight Secure to Policy Enforcer is not supported. Instead it is
recommended that you remove Spotlight Connector from your Space Fabric and remove threat related
configurations on Security Director before you install Policy Enforcer. Then you will need to reconfigure
your data and threat feeds. The following sections provide an overview of the transition process from
Spotlight Secure to Policy Enforcer with Juniper ATP Cloud.

Spotlight Secure and Policy Enforcer Deployment Comparison

The function of Spotlight Secure connector, to bring together all the available threat intelligence and
make it available to security policies, is now done via Policy Enforcer with Juniper ATP Cloud. In
addition, Policy enforcer is a key part of the Juniper Connected Security Solution.
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Spotlight Secure was installed to a separate virtual machine and then added as a specialized node to the
Junos Space Fabric on Junos Space until version 15.1. Policy Enforcer is shipped as a virtual machine
that is deployed independently. Instead of adding the new VM as a Junos Space node, the configuration
has been simplified with a workflow using the Security Director user interface.

NOTE: Spotlight Secure supported a HA deployment. The current version of Policy
Enforcer is supported only as a single stand-alone deployment.

License Requirements

For existing Spotlight Secure customers, no new additional license is needed. If you have a Spot-CC
license, it can be used with Policy Enforcer and Juniper ATP Cloud as well. A Policy Enforcer license
would only be needed if you want to use the complete set of Juniper Connected Security features with
Juniper ATP Cloud. Juniper Connected Security/Policy Enforcer features includes all threat prevention
types: C&C, infected hosts, malware, GeoIP, and policy management and deployment features such as
secure fabric and threat prevention policies. See "Features By Juniper ATP Cloud Configuration Type" on
page 23 for more details.

Juniper ATP Cloud and Spotlight Secure Comparison Table

The following table provides a product comparison:
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Table 87: Juniper ATP Cloud and Spotlight support Quick Summary

Feature Support in Spotlight
Secure

Support with Policy
Enforcer and Juniper
ATP Cloud

Workflow using Juniper ATP Cloud,
Security Director and Policy Enforcer

Command and
Control Feed

Fully Supported Fully Supported • Create a Realm in Juniper ATP
Cloud if you do not already have
one

• Configure Policy Enforcer in Cloud
feed only or Juniper ATP Cloud or
Juniper ATP Cloud with Juniper
Connected Security modes to
connect to the realm

• Configure a Threat Prevention
Profile using Command and
Control options

• Use this Threat Prevention Profile
in Firewall Policy

Custom Feeds Blocklist, Allowlist
and Dynamic
Address features are
fully supported.

Blocklist, Allowlist,
Infected Host, and
Dynamic Address
features are fully
supported

• Create a Realm in Juniper ATP
Cloud if you do not already have
one

• Configure Policy Enforcer Setting in
Juniper ATP Cloud mode

• Create a Custom Feed using
Blocklist, Allowlist or Dynamic
address options selecting static IP
or file options

Infected Host Not directly
supported by
Spotlight. You must
create custom feeds

Juniper ATP Cloud
supports an Infected
Host feed, natively
integrated with Policy
Enforcer and Security
Director.

Juniper ATP Cloud supports an
Infected Host feed, natively integrated
with Policy Enforcer and Security
Director.
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Table 87: Juniper ATP Cloud and Spotlight support Quick Summary (Continued)

Feature Support in Spotlight
Secure

Support with Policy
Enforcer and Juniper
ATP Cloud

Workflow using Juniper ATP Cloud,
Security Director and Policy Enforcer

Infected Host
Remediation at the
Access Network level

Not supported using
Spotlight and
Security Director

Juniper ATP Cloud
supports an Infected
Host feed which is
natively integrated
with Policy Enforcer.
Policy Enforcer can
take block/quarantine
actions at the access
network level.

NOTE: This requires
a Policy Enforcer
license and does not
come with a
SPOT_CC license.

Juniper ATP Cloud supports an
Infected Host feed which is natively
integrated with Policy Enforcer. Policy
Enforcer can take block/quarantine
actions at the switch port level.

Migrating Spotlight Secure to a Policy Enforcer Configuration Overview

In this section, there is a side by side comparison of feature configuration for Spotlight Secure on
Security Director 15.1 and Policy Enforcer on Security Director 16.1 and higher to aid in re-configuring
your threat policies.

This is an overview of the tasks needed to migrate:

1. Document the current data and feed configuration from current version of Security Director.

2. Remove Spotlight Connector from your Junos Space Fabric and remove the threat prevention
configuration.

3. Upgrade to the latest versions of Junos Space and Security Director.

NOTE: Since the underlying operation system is upgraded to Centos6.8 on Junos Space
version 16.1, first upgrade Junos Space and applications to 15.2R2 and then follow the
documentation to restore the database before deploying 16.1 or higher. Please refer to
the Junos Space 16.1 release notes for details.
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4. Deploy the Policy Enforcer virtual machine. See instructions in the following section.

5. Deploy Security Director and install Policy Enforcer to Security Director.

6. Configure a Juniper ATP Cloud realm and enroll SRX Series devices into the realm. For all deployment
models, it is necessary to configure ATP Cloud Realm and enroll firewalls.

7. Configure feeds and threat policies.

Installing Policy Enforcer

Policy Enforcer provides centralized, integrated management of all your security devices (both physical
and virtual), allowing you to combine threat intelligence from different solutions and act on that
intelligence from one management point. Using Policy Enforcer and the intelligence feeds it offers
through Juniper ATP Cloud, you can create threat prevention policies that provide monitoring and
actionable intelligence for threat types such as known malware, command and control servers, infected
hosts, and Geo IP-based server data.

Policy enforcer is shipped as a OVA file that should be deployed over VMware ESX.

1. Download the Policy Enforcer virtual machine OVA image from the Juniper Networks software
download page. It is recommended to deploy Policy Enforcer on the same ESX server as Junos Space.

NOTE: Do not change the name of the Policy Enforcer virtual machine image file that
you download from the Juniper Networks support site. If you change the name of the
image file, the creation of the Policy Enforcer virtual machine can fail.
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Figure 93: Deploy Policy Enforcer OVF File 1

Figure 94: Deploy Policy Enforcer OVF File 2
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NOTE: See "Deploying and Configuring the Policy Enforcer with OVA files" on page 33
for the complete Policy Enforcer installation documentation.

2. Initial configuration is done through the console. In addition to network and host configuration, you
must set a customer ID and reset the root password. The default login to Policy Enforcer is
Username: root,Password: abc123

Figure 95: Policy Enforcer Configuration Summary

3. Once Policy Enforcer is deployed, it must be added to Security Director via Security Director User
Interface. From the Security Director UI, navigate to Administration > Policy Enforcer > Settings.

NOTE: Unlike Spotlight Secure, Policy Enforcer does not need to be added to Junos
Space Fabric. The addition is done only through the Security Director UI.

4. On the Settings page, there three ATP Cloud Configuration Types to choose from.

• ATP Cloud with Juniper Connected Security—All Policy Enforcer features and threat prevention
types are available

• ATP Cloud—All threat prevention types are available: Command and control server, Geo IP, and
Infected hosts.
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• Cloud feeds only—Command and control server and Geo IP are the only threat prevention types
available.

• No selection (No ATP Cloud)—You can choose to make no selection. When you make no
selection, there are no feeds available from Juniper ATP Cloud, but the benefits of Secure Fabric,
Policy Enforcement Groups, and Threat Prevention policies provided by Policy Enforcer are
available. Infected hosts is the only prevention type available

NOTE: You can switch from Cloud feeds only to ATP Cloud, or ATP Cloud to ATP Cloud
with Juniper Connected Security, but the reverse is not supported.

NOTE: If you upgrade from Cloud feeds only to ATP Cloud, you cannot roll back again.
Upgrading resets all devices previously participating in threat prevention, and you must
re-enroll them with ATP Cloud. This is true for upgrading from ATP Cloud to ATP Cloud
with Juniper Connected Security. “ATP Cloud with Juniper Connected Security” is for
the Juniper Connected Security solution and not covered in this section.

NOTE: See "Juniper ATP Cloud Configuration Type Overview" on page 20 for the Policy
Enforcer documentation on this topic.

NOTE: Policy Enforcer with ATP Cloud does not support a workflow for removing Policy
Enforcer. To switch to a different Policy Enforcer, replace the IP and login information in
the Policy Enforcer settings page.

Configuring Advanced Threat Prevention Features: Spotlight Secure/
Policy Enforcer Comparison

The following section is a side by side comparison of how advanced threat prevention features were
configured on Spotlight Secure compared to how they are configured with Policy Enforcer.

Configuring Command and Control and Infected Host

Spotlight Secure: C&C and Infected Host

This is how C&C and infected host feeds were configured on Security Director 15.1 with Spotlight
Secure:
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1. Under Security intelligence > Information Source, click + to add a new information source. Select
Spotlight Secure Cloud as source.

Figure 96: Spotlight Secure: Add Information Source

2. Create a Security Intelligence profile from Security intelligence > Profiles . Choose Command and
Control as the feed category and set the Blocking threshold. Configure Block Options and Logging.
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Figure 97: Spotlight Secure: Create Security Intelligence Profile

3. Complete the workflow to create a profile.

Figure 98: Spotlight Secure: Create Profile

4. Create a security intelligence policy.
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Figure 99: Spotlight Secure: Create Security Intelligence Policy

5. Apply the security intelligence policy to a firewall policy.

Figure 100: Spotlight Secure: Apply Security Intelligence Policy to Firewall Policy

Policy Enforcer with ATP Cloud: C&C and Infected Host

This is how C&C and infected host feeds are configured on Security Director 16.1 and higher with Policy
Enforcer:

NOTE: Policy Enforcer can be configured with Juniper ATP Cloud or Cloud feeds only to
enable Command and Control feeds. The following instructions are for Cloud feeds only.
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NOTE: In addition to the instructions provided here, Threat Prevention Guided Setup
under Configuration > Guided Setup > Threat Prevention can be leveraged for a wizard
driven workflow.

1. Configure a Juniper ATP Cloud Realm by navigating to Configure > Threat Prevention > ATP Cloud
Realms. Click + to create a realm.

(You must have a Juniper ATP Cloud account to configure a realm. If you do not have an account
please click on the link provided in the Juniper ATP Cloud Realm window to create one at the Juniper
ATP Cloud account page. See Creating Juniper ATP Cloud Realms and Enrolling Devices or
Associating Sites for details).

NOTE: You do not need a Juniper ATP Cloud premium license to create an account or
realm.

2. Once the ATP Cloud realm is created, add a policy by navigating to Configure > Threat Prevention >
Policies. Click + to create a policy. Enable the check box to Include C&C profile in policy and set
threat score thresholds, actions, and logging.

Figure 101: Policy Enforcer: Create Threat Prevention Policy
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Figure 102: Policy Enforcer: Create Threat Prevention Policy, Select Threat Score and Logging

3. Apply the threat prevention policy to a firewall policy.

Figure 103: Policy Enforcer: Apply Threat Prevention Policy to Firewall Policy

4. Publish, verify the configuration and update to the firewall.
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Figure 104: Policy Enforcer: Update Firewall Policy

NOTE: If ATP Cloud is chosen as the ATP Cloud Configuration Type under
Administration > Policy Enforcer > Settings, the workflow remains the same, but
additional parameters become available for configuring anti-malware.

Configuring Custom Feeds

Spotlight Secure: Custom Feeds

This is how custom feeds were configured on Security Director 15.1 with Spotlight Secure:

1. Create an information source by navigating to Security Intelligence > Information Source . Click + to
add a source. (Note that WebApp Secure is no longer supported.)
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Figure 105: Spotlight Secure: Add Information Source

2. Upload from a custom file. Select Source as Custom File Upload and point to a local file.

Figure 106: Spotlight Secure: Configure Custom File Upload

3. Configure a periodic upload from a remote file server. Provide the full URL to the plain text file you
want to poll and enter server login information, Username and Password.
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Figure 107: Spotlight Secure: Enter Server Login for Custom File Upload

4. Create a dynamic object by navigating to Security Intelligence > Dynamic Address Group. Configure
the feed as the custom feed that was created in the previous step.

Figure 108: Spotlight Secure: Select Custom Feed in Dynamic Address Group

5. Use the dynamic object in a security policy.
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Figure 109: Spotlight Secure: Select Dynamic Address in Security Policy

6. Configure a custom feed as an allowlist or blocklist by navigating to Security Intelligence > Profiles.
Edit Global Allow List or Global Back List to add a custom feed created in the previous steps.

Policy Enforcer with ATP Cloud: Custom Feeds

This is how custom feeds are configured on Security Director 16.1 and higher with Policy Enforcer:

NOTE: In addition to the instructions provided here, Threat Prevention Guided Setup
under Configuration > Guided Setup > Threat Prevention can be leveraged for a wizard
driven workflow.

Policy Enforcer supports manually adding or uploading custom feed information from a file server. The
custom feed can be a dynamic object, infected hosts list, allowlist or blocklist which can then be used
within the match criteria of a firewall rule.

1. Create Custom Feeds by navigating to Configure > Threat Prevention > Custom Feeds. Click + to
create a new feed.

2. Provide a Name and Description for the custom feed and choose the tab for the type of feed:
Dynamic Address, Blocklist, Allowlist or Infected Host.

3. Manually configure the IP list or upload it from a local file. The IP list can be defined as individual IP
addresses, IP address ranges, or subnets. See "Creating Custom Feeds" on page 216 for complete
details.
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NOTE: Dynamic objects can be used within a firewall policy to match criteria as a
source or destination address object.

NOTE: Policy Enforcer supports only cloud based C&C feeds and not custom C&C
feeds. Policy Enforcer APIs can be used to extend this functionality.

4. Upload a local file. Select the Upload file option in the right corner of the page.

5. If you have configured an allowlist, downloads from those IP addresses are considered trusted. For
blocklists, all downloads from those IP addresses are blocked. Dynamic objects can be used within a
firewall policy match criteria as a source or destination address object.

Figure 110: Policy Enforcer: Use Dynamic Addresses in Firewall Policy

Configuring Geo IP

Spotlight Secure: Geo IP

This is how Geo IP feeds were configured on Security Director 15.1 with Spotlight Secure:

1. Create a GeoIP object under dynamic object by navigating to Security Intelligence > Dynamic
Address Group. Select the feed as GeoIP and pick the countries from the drop down list.
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Figure 111: Spotlight Secure: Create Geo IP with Dynamic Address Group

2. Use the Geo IP object in a firewall policy.

Figure 112: Spotlight Secure: Use Geo IP in Firewall Policy

Policy Enforcer with ATP Cloud: Geo IP

This is how Geo IP feeds are configured on Security Director 16.1 and higher with Policy Enforcer:
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1. Define GeoIP objects that can then be used within the match criteria of a firewall policy by
navigating to Configure > Shared Objects > Geo IP. Create a Geo IP feed and choose countries to
include from the list.(This feature requires a SecIntel or Juniper ATP Cloud license.)

Figure 113: Policy Enforcer: Create Geo IP

2. Use the Geo IP feed you created as the source or destination address in a firewall policy.
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Figure 114: Policy Enforcer: Use Geo IP in the Firewall Policy
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