ON THIS PAGE
Managing an EVPN-VXLAN Fabric With CRB
Up to this point in the configuration of the EVPN-VXLAN fabric, we have used a topology with three virtual networks and one access layer switch that simulates an access closet. Use this section to add a second access switch and a new virtual network.
These configuration examples use the same devices you configured in the How to Configure an EVPN-VXLAN Fabric for a Campus Network With CRB configuration example.
Add an Access Layer Switch
Requirements
Overview
Use this section to add a new access layer switch to the network that is multihomed to the same distribution layer switches. Figure 1 shows the physical topology of the network after you have added Access Switch 2.
Configuration
This section shows the step-by-step configuration procedures to add Access Switch 2 to your network.
Distribution 1 Configuration
Step-by-Step Procedure
Specify the interface to include in the aggregated Ethernet bundle.
set interfaces ge-0/0/11 description "Access Switch 2" set interfaces ge-0/0/11 ether-options 802.3ad ae4
Configure the aggregated Ethernet interface to the new access layer switch.
set chassis aggregated-devices ethernet device-count 10 set interfaces ae4 esi 00:00:22:22:33:33:44:44:00:02 set interfaces ae4 esi all-active set interfaces ae4 aggregated-ether-options minimum-links 1 set interfaces ae4 aggregated-ether-options lacp active set interfaces ae4 aggregated-ether-options lacp periodic fast set interfaces ae4 aggregated-ether-options lacp system-id 00:40:00:00:00:02 set interfaces ae4 unit 0 family ethernet-switching interface-mode trunk set interfaces ae4 unit 0 family ethernet-switching vlan members 1-3
Distribution 2 Configuration
Step-by-Step Procedure
Specify the interface to include in the aggregated Ethernet bundle.
set interfaces ge-0/0/13 description "Access Switch 2" set interfaces ge-0/0/13 ether-options 802.3ad ae4
Configure the aggregated Ethernet interface to the new access layer switch.
set interfaces ae4 esi 00:00:22:22:33:33:44:44:00:02 set interfaces ae4 esi all-active set interfaces ae4 aggregated-ether-options minimum-links 1 set interfaces ae4 aggregated-ether-options lacp active set interfaces ae4 aggregated-ether-options lacp periodic fast set interfaces ae4 aggregated-ether-options lacp system-id 00:40:00:00:00:02 set interfaces ae4 unit 0 family ethernet-switching interface-mode trunk set interfaces ae4 unit 0 family ethernet-switching vlan members 1-3
Access Switch 2 Configuration
Step-by-Step Procedure
Configure the physical LAG interface.
set interfaces ge-2/0/0 ether-options 802.3ad ae4 set interfaces ge-2/0/14 ether-options 802.3ad ae4
Configure the LAG interface to the new access layer switch.
set chassis aggregated-devices ethernet device-count 10 set interfaces ae4 aggregated-ether-options minimum-links 1 set interfaces ae4 aggregated-ether-options lacp active set interfaces ae4 aggregated-ether-options lacp periodic fast set interfaces ae4 unit 0 family ethernet-switching interface-mode trunk set interfaces ae4 unit 0 family ethernet-switching vlan members 1-3
The new access layer switch is now part of your network.
Configure the VLANs. VLAN_1 will be used to send management traffic from Mist APs to the Internet and VLAN_2 and VLAN_3 will be used to connect wired and wireless client devices.
set vlans vlan_1 vlan-id 1 set vlans vlan_2 vlan-id 2 set vlans vlan_3 vlan-id 3
Configure the Access Ports for Mist Access Points connections. For example, you can configure and map the SSID for employees to VLAN2 and the SSID for guests to VLAN3.
set poe interface ge-2/0/4 set poe interface ge-2/0/5 set interfaces ge-2/0/4 unit 0 family ethernet-switching interface-mode trunk set interfaces ge-2/0/5 unit 0 family ethernet-switching interface-mode trunk set interfaces ge-2/0/4 native-vlan-id 1 set interfaces ge-2/0/4 unit 0 family ethernet-switching vlan members 1-3 set interfaces ge-2/0/5 native-vlan-id 1 set interfaces ge-2/0/5 unit 0 family ethernet-switching vlan members 1-3
Add a Virtual Network
Requirements
Overview
So far, you have configured a topology with three virtual networks: 1, 2, and 3. Use this section to add a new virtual network to the network.
Figure 2 shows the virtual network topology after you have added the fourth virtual network.
Configuration
This section shows the step-by-step configuration procedures to add virtual network 4 to your network. For example, you can use the 4th virtual network to connect wired and wireless IoT devices.
- Core 1 Configuration
- Core 2 Configuration
- Distribution 1 Configuration
- Distribution 2 Configuration
- Access Switch Configuration
Core 1 Configuration
Step-by-Step Procedure
Configure the IRB interface that acts as the Layer 3 gateway for the virtual network. IP address 172.20.4.251/24 belongs to IRB 4.
set interfaces irb unit 4 proxy-macip-advertisement set interfaces irb unit 4 family inet address 172.20.4.251/24 virtual-gateway-address 172.20.4.250 set interfaces irb unit 4 family inet6 address 2001:db8::172:20:4:251/112 virtual-gateway-address 2001:db8::172:20:4:250 set interfaces irb unit 4 family inet6 address fe80::172:20:4:251/112
Add the IRB interface to the evpn_vrf__1 routing instance.
set routing-instances evpn_vrf__1 interface irb.4
Configure VLAN 4 and virtual network 4 along with the Layer 3 gateway for the virtual network. Assign the Layer 3 interface to the routing instance.
set routing-instances VS__1 vlans vlan4_4 vlan-id 4 set routing-instances VS__1 vlans vlan4_4 l3-interface irb.4 set routing-instances VS__1 vlans vlan4_4 vxlan vni 5004 set routing-instances VS__1 vlans vlan4_4 vxlan ingress-node-replication
Core 2 Configuration
Step-by-Step Procedure
Configure the IRB interface that acts as the Layer 3 gateway for the virtual network. IP address 172.20.4.252/24 belongs to IRB 4.
set interfaces irb unit 4 proxy-macip-advertisement set interfaces irb unit 4 family inet address 172.20.4.252/24 virtual-gateway-address 172.20.4.250 set interfaces irb unit 4 family inet6 address 2001:db8::172:20:4:252/112 virtual-gateway-address 2001:db8::172:20:4:250 set interfaces irb unit 4 family inet6 address fe80::172:20:4:252/112
Add the IRB interface to the evpn_vrf__1 routing instance.
set routing-instances evpn_vrf__1 interface irb.4
Configure VLAN 4 and virtual network 4 along with the Layer 3 gateway for the virtual network and assign the Layer 3 interface to the routing instance.
set routing-instances VS__1 vlans vlan4_4 vlan-id 4 set routing-instances VS__1 vlans vlan4_4 l3-interface irb.4 set routing-instances VS__1 vlans vlan4_4 vxlan vni 5004 set routing-instances VS__1 vlans vlan4_4 vxlan ingress-node-replication
Distribution 1 Configuration
Step-by-Step Procedure
Configure VLAN 4 and virtual network 4.
set vlans vlan_4 vlan-id 4 set vlans vlan_4 vxlan vni 4 set vlans vlan_4 vxlan ingress-node-replication
Configure the virtual network as part of the overlay EVPN control plane.
set protocols evpn extended-vni-list 4
Configure VLAN 4 as part of the LAG interface connected to the access switch.
set interfaces ae3 unit 0 family ethernet-switching vlan members 1-4
Note:If you have added another access switch to the topology, also configure VLAN 4 as part of that LAG interface.
Distribution 2 Configuration
Step-by-Step Procedure
Configure VLAN 4 and virtual network 4.
set vlans vlan_4 vlan-id 4 set vlans vlan_4 vxlan vni 4 set vlans vlan_4 vxlan ingress-node-replication
Configure the virtual network as part of the overlay EVPN control plane.
set protocols evpn extended-vni-list 4
Configure VLAN 4 as part of the LAG interface connected to the access switch.
set interfaces ae3 unit 0 family ethernet-switching vlan members 1-4
Note:If you have added another access switch to the topology, also configure VLAN 4 as part of that LAG interface.
Access Switch Configuration
Step-by-Step Procedure
Configure VLAN 4. In this case, VLAN interface 1 will be used to send management traffic from Mist APs to the Internet and VLAN interface 4 will be used to connect wired and wireless IOT devices.
set vlans vlan_4 vlan-id 4
Configure LAG uplink interface with the new VLAN.
set interfaces ae3 unit 0 family ethernet-switching vlan members 1-4
Note:If you have added another access switch to the topology, repeat this configuration on that access switch.
You have now added a fourth virtual network to your network.
Configure the Access Ports as trunk interface for connecting Mist Access Points and map the SSID for IoT devices to VLAN 4.
set interfaces ge-0/0/6 unit 0 family ethernet-switching interface-mode trunk set interfaces ge-0/0/6 native-vlan-id 1 set interfaces ge-0/0/6 unit 0 family ethernet-switching vlan members 1-4 set interfaces ge-0/0/5 unit 0 family ethernet-switching vlan members 1-4 set interfaces ge-0/0/4 unit 0 family ethernet-switching vlan members 1-4