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Introduction

Juniper Networks EX Series Ethernet Switches are shipped with the Juniper Networks Junos operating
system (Junos OS) installed.

Junos OS has the following primary user interfaces:

• Juniper Web Device Manager (J-Web) GUI

• Junos OS CLI

You can use these interfaces to access, configure, and manage your EX Series switch.

This topic provides an overview of the newly re-designed J-Web interface.
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Supported EX Series Switches

In J-Web Application Package 25.2A1 which aligns with Junos OS Release 25.2R1, the J-Web interface
supports the following models: EX2300, EX2300-C, EX2300-MP, EX3400, EX4100, EX4100-F, EX4100-
H-12MP, EX4100-H-24MP, EX4100-H-24F, EX4300-48MP, EX4400, EX4400-24X, EX4400-48XP,
EX4400-48MXP, and the EX4400-EM-1C uplink module for EX4400 and EX4400-24X switches, which
were also supported in earlier releases.

To obtain more information about the components that are supported on each switch, and the special
compatibility guidelines for the release, see the Hardware Guide for the switch.

To determine the features supported on EX Series switches in this release, use the Juniper Networks
Feature Explorer, a Web-based application that helps you to explore and compare Junos OS feature
information to find the right software release and hardware platform for your network. Find Feature
Explorer at https://apps.juniper.net/feature-explorer/.

RELATED DOCUMENTATION

Distribution Model  |  2

1

https://apps.juniper.net/feature-explorer/


Distribution Model

IN THIS SECTION

Release Compatibility  |  3

For Junos OS Release 14.1X53-D10 and later, the J-Web interface is available in two packages:

• Platform package—Provides basic features of J-Web and is installed as part of Junos OS.

The Platform package of J-Web is installed as part of Junos OS that is shipped with your EX Series
switch. The Platform package provides the basic features of the J-Web interface. The Platform
package enables you to configure and maintain your switch.

• Application package—Provides all features of J-Web and is a separately installable package.

The Application package is not installed by default on your switch. You must download it and install it
over the Platform package on your switch. The Application package provides all the features of the J-
Web interface that enable you to configure, monitor, maintain, and troubleshoot your switch.

For information about installing the Application package, see "Upgrading to J-Web Application Package"
on page 5.

The Platform package, which is installed as part of the Junos OS that is shipped with your switch,
follows the Junos OS release cycle. However, the Application packages have their own release cycle
which is independent of the Junos OS release cycle. This separate release cycle helps you get the latest
features of J-Web by installing the latest version of the Application package, without waiting for Junos
OS releases.

NOTE: 

• The J-Web Application package is hot-pluggable. You can install it on top of the
current Junos OS installation, and you need not reboot the switch after the
installation.

• To determine which J-Web package you are currently using, click Help > About. The
About window appears. If you are using a Platform package, only the Platform
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package details are displayed. If you are using an Application package, both the
Platform package and Application package details are displayed.

If your current J-Web package is: Then you can:

Platform package Upgrade to the Application package.

Application package Update to a latest version of the Application package
available on the Juniper Networks server that is
compatible with the Junos OS on your switch.

NOTE: If you upgrade Junos OS on your switch, the current J-Web package is replaced
with the J-Web Platform package that is associated with the upgraded Junos OS release.
You can then install the latest Application package that is associated with the main
release of the upgraded Junos OS, over the Platform package.

Release Compatibility

The Application packages of J-Web have their own release cycles (A1, A2, A3, and so on), which are
independent of the Junos OS release cycle. An Application package is compatible only with the
corresponding major release of Junos OS.

Table 1 on page 3 lists the release compatibility.

Table 1: J-Web Release Compatibility Matrix

Junos OS Release Associated J-Web Application Package Release

21.4R1 21.4A1

21.4R1 21.4A2

22.2R1 22.2A1
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Table 1: J-Web Release Compatibility Matrix (Continued)

Junos OS Release Associated J-Web Application Package Release

22.2R1 22.2A2

22.4R1 22.4A1

22.4R1

You must upgrade from Junos OS Release 22.4R1 to
22.4R3-S2 or later to install Application Package
22.4A2.

22.4A2

23.2R1 23.2A1

23.2R1 23.2A2

23.2R2 23.2A3

23.4R1 23.4A1

24.2R1 24.2A1

24.4R1 24.4A1

25.2R1 25.2A1

Any available later version of the Application package for a Junos OS release supersedes the earlier
version. We recommend that you install the latest available version of the Application package.
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This section describes the features and enhancements in J-Web Application Package Release 25.2A1.

What’s New in J-Web Application Package Release
25.2A1

In J-Web Application Package 25.2A1 which aligns with Junos OS Release 25.2R1, the J-Web interface
supports the following models: EX2300, EX2300-C, EX2300-MP, EX3400, EX4100, EX4100-F, EX4100-
H-12MP, EX4100-H-24MP, EX4100-H-24F, EX4300-48MP, EX4400, EX4400-24X, EX4400-48XP,
EX4400-48MXP, and the EX4400-EM-1C uplink module for EX4400 and EX4400-24X switches, which
were also supported in earlier releases.

Upgrading to J-Web Application Package

There are two ways in which you can download and install the J-Web Application package:

• Manual update

• CLI procedure

There is a prescribed order for the installation tasks for updating to the Application package from an
earlier version or from the Platform package. See Table 2 on page 6 to determine the prescribed order
of tasks for your installation.
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Table 2: Installation Outline

Mode of Installation Installation Outline

Manual Update To manually check and install the latest J-Web
Application package:

1. Go to Maintain > Update J-Web in the side pane,
and click Select Application Package.

2. Select Local File in the Update J-Web window,
enter authentication details download the file to
your local system, select the file, and click Update.

CLI Procedure 1. Download the J-Web Application package and save
it in the switch.

2. Log in to the CLI and enter the operational mode.

3. Install the package using the CLI command request
system software add <application package file
name>.

Software Compatibility

To access the J-Web interface for the switch, your management device requires the following software:

• Supported browsers—Mozilla Firefox and Google Chrome.

NOTE: 

• We recommended a screen resolution of 1440 X 900 pixels.

• Microsoft ended Internet Explorer support in June 2022. Therefore, starting with
Junos OS Release 22.4R1 or later, J-Web user interface is not supported in Internet
Explorer.

• Language support—English-version browsers.
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This section lists the known issues in the J-Web Application package Release 25.2A1.

Known Issues

Table 3 on page 8 lists the PR numbers and its description that are known issues in the J-Web
Application package Release 25.2A1.
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Table 3: Known Issues

PR Number Problem Description

NA Adobe Flash Player support ended on December 31,
2020. Therefore:

• For Junos OS Release 20.3R1 and earlier releases,
the following pages will not load correctly:

• Monitor > System View > Process Details

• Monitor > Interfaces

• Monitor > Power over Ethernet

• Monitor > Service > DHCP > Server

• Monitor > Service- > DHCP > Relay

• Monitor > Switching > IGMP Snooping

• Monitor > Virtual Chassis

• Monitor > Security > Port Security

• Monitor > Routing > OSPF Information

• For Junos OS Release 20.4R1 and later releases,
the following pages will not be supported:

• Monitor > System View > Process Details

• Monitor > Power over Ethernet

• Monitor > Service- > DHCP > Relay

• Monitor > Switching > IGMP Snooping

• Monitor > Virtual Chassis

• Monitor > Security > Port Security

• Monitor > Routing > OSPF Information
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Table 3: Known Issues (Continued)

PR Number Problem Description

• For Junos OS Release 20.4R1 and later releases,
the Flash components are removed from the
following pages.

• Monitor > Interfaces

• Monitor > Service > DHCP > Server

1029736 In the Maintain > Update J-Web page, Select
Application package > Update J-Web, local file does
not work in Microsoft IE9 and later releases, because
of the default security options set on these browsers.
As a workaround, increase the security level:

Method 1:

1. Navigate to Internet Options > Security.

2. Select the zone Local intranet.

3. Click the custom level button.

4. Disable the option Include local directory Path
when uploading file to the server in the Settings >
miscellaneous section.

5. Repeat Step 3 and Step 4 for the zone Internet.

Method 2:

Navigate to Internet Options > Security > Custom
level... and set Reset custom settings to Medium-High
or High. This automatically disables the option Include
local directory Path when uploading file to the server
under Settings > miscellaneous section.

1810275 For Junos OS Release 24.2A1, in J-Web, we've
deprecated the feature to Install Junos OS Upgrade
package from a remote server, which was available at
Maintain > Update Junos.
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Known Limitations

Table 4 on page 10 lists the PR numbers and its description that are known limitations in the J-Web
Application package Release 25.2A1.

Table 4: Known Limitations

PR Number Problem Description

1877719 The auto update option is not supported.

To manually check and install the latest J-Web
Application package:

1. Go to Maintain > Update J-Web in the side pane,
and click Check for updates.

If the latest update is available on the Juniper
Networks server, the Update Available window
appears.

2. Click the support site link available in the Update
Available window to download the latest Junos OS
Web management application package

3. Once you download the latest application package,
go to Maintain > Update J-Web in the side pane,
and click Select Application Package. The Update J-
Web window appears.

4. Select the downloaded application package file, and
click Install Package.

NOTE: You must save all your changes before
installing the new J-Web Application Package.
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Table 4: Known Limitations (Continued)

PR Number Problem Description

1513612 For Junos OS release 18.X and 19.X and its service
releases, the auto update option is not supported.

Where X is R1, R2, R3, and R4.

NOTE: To disable the auto update information, go to
Maintain > Update J-Web page and clear the Check
for updates automatically on every login check box
under Update Preference.

To manually check and install the latest J-Web
Application package:

1. Go to Maintain > Update J-Web in the side pane,
and click Select Application Package.

2. Select Local File in the Update J-Web window,
enter authentication details, download the file to
your local system, select the file, and click Update.

777372 If a Virtual Chassis contains more than six members,
the Support Information page (Maintain > Customer
Support > Support information) might not load. This is
a known software limitation.

604595 The J-Web interface does not support role-based
access control; it supports only users in the super-user
authorization class. Therefore, a user who is not in the
superuser class, such as a user with view-only
permission, is able to launch the J-Web interface and is
allowed to configure everything, but the configurations
fail on commit, and the switch displays access
permission errors. This is a known software limitation.

1026308 If you uninstall the J-Web Platform package by using
CLI, reinstalling the Application package will not
restore J-Web.

Workaround: Reinstall Junos OS software.
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Table 4: Known Limitations (Continued)

PR Number Problem Description

1006208 J-Web software does not compare for appropriateness
of the Application package or restrict you from
installing inappropriate Application package on top of a
Platform or Application package.

Workaround: Install the appropriate J-Web package.

915069 The J-Web interface does not display CLI generated
certificates in the Certificate section in the
Management Access Configuration page (Configure >
System Properties > Management Access). Using J-
Web interface you cannot create or edit certificates.

Workaround: Use the CLI interface for accessing
certificate related configurations.

400814 In the J-Web interface, you cannot commit some
configuration changes in the Ports Configuration page
or the VLAN Configuration page because of the
following limitations for port-mirroring ports and port-
mirroring VLANs:

• A port configured as the output port for an
analyzer cannot be a member of any VLAN other
than the default VLAN.

• A VLAN configured to receive analyzer output can
be associated with only one interface.

This is a known software limitation.

Workaround: None.

425693 In the J-Web interface, the Ethernet Switching Monitor
page (Monitor > Switching > Ethernet Switching) might
not display monitoring details if the switch has more
than 13,000 MAC entries. This is a known software
limitation.
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Table 4: Known Limitations (Continued)

PR Number Problem Description

866976 When you try to commit your changes to the switch
from your laptop by using the EZsetup procedure, the
status of the commit operation is displayed as Success,
even if the laptop is disconnected from the switch.

Workaround: Reconnect your laptop to the switch and
commit the changes again.

1921440 For EX4300 platform, J-Web Application Package
21.4A3.3 package is incompatible. You must use the J-
Web Application Package 21.4A2.
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