Supported Standards for Segment Routing
Learn about the Segment Routing RFCs and Internet Drafts supported by Junos OS.
This topic lists the Segment Routing RFCs and Internet Drafts that Junos OS supports, partially supports, or does not support. It also identifies the RFCs that the IETF categorizes as Experimental or Informational.
Supported RFCs and Internet Drafts
Junos OS supports the following Segment Routing RFCs and Internet Drafts.
Supported RFCs
-
RFC 5286, Basic Specification for IP Fast Reroute: Loop-Free Alternates
-
RFC 7471, OSPF Traffic Engineering (TE) Metric Extensions
-
RFC 7490, Remote Loop-Free Alternate (LFA) Fast Reroute (FRR)
-
RFC 7684, OSPFv2 Prefix/Link Attribute Advertisement
-
RFC 7752, North-Bound Distribution of Link-State and Traffic Engineering (TE) Information Using BGP
-
RFC 7855, Source Packet Routing in Networking (SPRING) Problem Statement and Requirements
-
RFC 8102, Remote-LFA Node Protection and Manageability
-
RFC 8277, Using BGP to Bind MPLS Labels to Address Prefixes
-
RFC 8287, LSP Ping/Traceroute for Segment Routing
-
RFC 8403, A Scalable and Topology-Aware MPLS Data-Plane Monitoring System
-
RFC 8426, RSVP-SR coexistence
-
RFC 8571, BGP - Link State (BGP-LS) Advertisement of IGP Traffic Engineering Performance Metric Extensions
-
RFC 8604, Interconnecting Millions of Endpoints with Segment Routing
-
RFC 8660, Segment Routing with the MPLS Data Plane
-
RFC 8661, Segment Routing MPLS Interworking with LDP
-
RFC 8665, OSPF Extensions for Segment Routing
-
RFC 8690, Clarification of Segment ID Sub-TLV Length for RFC 8287
-
RFC 8986, Segment Routing over IPv6 (SRv6) Network Programming
-
RFC 9085, Border Gateway Protocol - Link State (BGP-LS) Extensions for Segment Routing
-
RFC 9086, Border Gateway Protocol - Link State (BGP-LS) Extensions for Segment Routing BGP Egress Peer Engineering
-
RFC 9256, Segment Routing Policy Architecture
-
RFC 9252, BGP Overlay Services Based on Segment Routing over IPv6 (SRv6)
-
RFC 9350, IGP Flexible Algorithm
-
RFC 9800, Compressed SRv6 Segment List Encoding (Partial support). We only support SRv6 Micro-SIDs.
-
RFC 9819, Argument Signaling for BGP Services in Segment Routing over IPv6 (SRv6)
Supported Internet Drafts
-
draft-agrawal-spring-srv6-mpls-interworking-06, SRv6 and MPLS interworking
Supports service interworking.
-
draft-bashandy-rtgwg-segment-routing-ti-lfa, Topology Independent Fast Reroute using Segment Routing
-
draft-bashandy-rtgwg-segment-routing-uloop, Microloop Avoidance using Segment Routing
-
draft-filsfils-rtgwg-segment-routing-use-cases-02, Segment Routing Use Cases
-
draft-filsfils-spring-sr-policy-considerations-05, SR Policy Implementation and Deployment Considerations
-
draft-filsfils-spring-sr-traffic-counters, SR traffic counters
-
draft-ietf-idr-bgp-prefix-sid, Advertise BGP segment for a BGP Prefix
-
draft-ietf-idr-bgpls-segment-routing-epe, BGP-LS extensions for Egress peer traffic engineering using SR
-
draft-ietf-idr-segment-routing-te-policy, Advertise SR-TE policies through BGP
-
draft-ietf-idr-segment-routing-te-policy-09, Advertising Segment Routing Policies in BGP
-
draft-ietf-lsr-isis-srv6-extensions, IS-IS Extensions to Support Segment Routing over IPv6 Dataplane
-
draft-ietf-ospf-segment-routing-extensions, OSPF extensions to distribute SR segments
-
draft-ietf-pce-segment-routing, PCE extensions to setup a SR-TE path from the controller (south bound)
-
draft-ietf-isis-segment-routing-extensions, IS-IS extensions to distribute SR segments
-
draft-ietf-rtgwg-segment-routing-ti-lfa-04, Topology Independent Fast Reroute using Segment Routing
-
draft-ietf-spring-conflict-resolution, Segment Routing MPLS Conflict Resolution
-
draft-ietf-spring-resiliency-use-cases, Resiliency use cases in SPRING networks
-
draft-ietf-spring-segment-routing-central-epe, SR Centralized BGP Egress Peer Engineering
-
draft-ietf-spring-segment-routing-mpls, Segment Routing details with MPLS forwarding
-
draft-ietf-spring-segment-routing-policy-07.txt, Segment Routing Policy Architecture
-
draft-kaliraj-idr-bgp-classful-transport-planes-12, BGP Classful Transport Planes
-
draft-ali-6man-srv6-vpn-icmp-error-handling-00 ICMP Error Handling in SRv6-based VPN Networks
Partially Supported RFCs and Internet Drafts
Junos OS partially supports the following Segment Routing RFCs and Internet Drafts.
Partially Supported RFCs
-
RFC 4971, Intermediate System to Intermediate System (IS-IS) Extensions for Advertising Router Information (Partial support)
-
RFC 8402, Segment Routing Architecture (Partial support)
-
RFC 8570, IS-IS Traffic Engineering (TE) Metric Extensions (Partial support)
Supports link delay related parameters.
-
RFC 8663, MPLS Segment Routing over IP (Partial support)
-
RFC 8919, IS-IS Application-Specific Link Attributes (Partial support)
-
RFC 9862, Path Computation Element Communication Protocol (PCEP) Extensions for Segment Routing (SR) Policy Candidate Paths
A minor deviation exists in the handling of the SRPOLICY-CAPABILITY TLV. The implementation follows the draft-ietf-pce-segment-routing-policy-cp-05 specification, which does not mandate the SRPOLICY-CAPABILITY TLV in the PCEP Open object. Consequently, the PCC does not advertise this TLV, leading to failed PCEP session establishment with peers strictly enforcing RFC 9862. If a PCEP speaker receives an SRPA object without prior TLV exchange, it must send a PCErr message (Error-Type=10 "Reception of an invalid object" and Error-value=44 "Missing SRPOLICY-CAPABILITY TLV") and terminate the session.
-
RFC 9603, Path Computation Element Communication Protocol (PCEP) Extensions for IPv6 Segment Routing
-
Junos OS always sets the N bit to 0 in the PCEP Open message.
-
The Path Computation Client (PCC) and segment routing–traffic engineering (SR-TE) cannot resolve a network access identifier (NAI) to an SRv6 segment identifier (SID).
-
SR-TE does not verify SIDs in the Explicit Route Object (ERO), including when the V bit is set to 1.
-
Partially Supported Internet Drafts
-
draft-ali-spring-sr-traffic-accounting, SR traffic matrix accounting (Partial support)
Supports counter only.
-
draft-ginsberg-isis-prefix-attributes, IS-IS Prefix Attributes for Extended IPv4 and IPv6 Reachability (Partial support)
-
draft-ietf-spring-ipv6-use-cases, Use Cases for IPv6 Source Packet Routing in Networking (Partial support)
-
draft-ietf-spring-segment-routing-msdc, BGP-Prefix Segment in Large Scale data centers (Partial support)
-
draft-ietf-spring-segment-routing-policy, SR policy for TE (Partial support)
-
draft-xu-mpls-sr-over-ip, MPLS Segment Routing over IP (Partial support)
Experimental and Informational RFCs
The following RFCs do not define standards, but provide information about Segment Routing and related technologies. The IETF classifies these RFCs variously as “Experimental” or “Informational.”
-
RFC 6571, Loop-Free Alternate (LFA) Applicability in Service Provider (SP) Networks
-
RFC 9087, Segment Routing Centralized BGP Egress Peer Engineering
Unsupported RFCs
The following Segment Routing RFCs and Internet Drafts are not supported by Junos OS.
-
RFC 5642, Dynamic Hostname Exchange Mechanism for OSPF
-
RFC 8668, Advertising Layer 2 Bundle Member Link Attributes in IS-IS
The implementation supports static MPLS label assignment for member links because IS-IS advertisement of these labels is not supported.
-
RFC 9871, BGP Color-Aware Routing (CAR)
-
RFC 9960, Segment Routing Point-to-Multipoint Policy
-
RFC 9524, Segment Routing Replication for Multipoint Service Delivery