How to Configure Multiple Independent IGP Instances of IS-IS
Learn how to configure and run multiple instances of IS-IS on a router.
Configure Multiple IGP Instances of IS-IS
Learn about the benefits and get an overview of running multiple interior gateway protocol (IGP) instances of IS-IS on a router.
Benefits of Multi-Instance IS-IS
- You can use multiple IGP instances of IS-IS to redistribute routes among independent IS-IS domains on a single router.
- You can construct flexible IS-IS hierarchies across independent IGP domains.
- Allows decoupling of multiple IS-IS flooding domains and therefore achieve a more scalable IS-IS deployment.
Figure 1 illustrates several benefits of configuring multiple IGP instances of IS-IS on the router. For example, Router F participates in two independent IS-IS instances. Router F treats IS-IS Aggregation Network-1 and IS-IS Core Network as two independent IGP domains, while at the same time redistributing routes between those domains. Network operators can use this flexibility to construct a hierarchy of IS-IS domains.
Figure 1 also illustrates the use of multiple IGP instances of IS-IS to separate metro networks into independent IS-IS flooding domains. In the example, routers D and E participate in the IS-IS metro-a, IS-IS metro-b, and IS-IS metro-c networks, as well as in IS-IS Aggregation Network-1. Routers D and E do not flood the different IS-IS domains with IS-IS advertisements. Instead they redistribute specific routes among the different IS-IS domains, which allows for more scalable metro deployments.
Multi-Instance IS-IS Overview
You can configure and run multiple independent IGP instances of IS-IS simultaneously on a router. These instances are associated with the default routing instance, and they install routes in the default routing table.Each IS-IS instance can also export the routes installed in the routing table by other IS-IS instances using the standard Junos OS routing policy configuration. By default, the routes installed by the different IS-IS instances have the same route preference.
Junos OS does not support configuring the same logical interface in multiple IGP instances of IS-IS.
In most deployment scenarios, only one IS-IS instance on a router installs a route for a given prefix. Therefore, you don't need to configure different route preferences for multiple IS-IS instances. However, for certain deployment scenarios where multiple IS-IS instances install the routes for the same prefix in the routing table, you can set a different route preference for the routes installed by other IS-IS instances. This allows the routing table to choose the routes with the best route preference and installs those routes in the forwarding table.
You can use the multiple IS-IS instance feature for both hierarchical and parallel deployments. In the case of hierarchical deployments, there are well-defined borders between the groups of routers participating in different IGP instances. In parallel deployments, different IGP instances (typically not more than two or three) span entire groups of routers. You can also have mixed deployments, with some domains in a hierarchical deployment running IGP instances in parallel.
You can configure multiple independent IGP instances of IS-IS by including the
isis-instance
configuration statement at the [edit
protocols
] hierarchy level. The configuration statements that you use at the
[edit protocols isis-instance igp-instance-name
]
hierarchy level are the same as those available at the [edit protocols
isis
] hierarchy level.
The isis-instance
configuration statement is not supported at the
[edit routing-instances routing-instance-name
protocols
] hierarchy level.
Example: Configure Independent IS-IS Instances in Metro Flooding Domains
Use this example to learn how to configure independent metro flooding domains running multiple IGP instances of IS-IS.
Overview
This example shows how to configure and run multiple independent IGP instances of IS-IS in metro flooding domains.
Topology
Figure 2 shows an example of metro flooding domains (metro-a and metro-b) running independent IGP instances of IS-IS. In the topology, routers R3 and R4 participate in metro IS-IS domains (IS-IS metro-a and IS-IS metro-b) and the IS-IS core network domain. Routers R3 and R4 do not flood the different IS-IS domains with IS-IS advertisements. Instead they redistribute specific routes among the different IS-IS domains, which allows for a more scalable metro deployment.
Requirements
This example uses the following hardware and software components:
- MX Series routers
- Junos OS Release 21.1R1 or later running on all devices
You must configure the network services mode as Enhanced IP. The Enhanced IP configuration ensures that the router uses enhanced mode capabilities.
[edit] user@CE1#set chassis network-services enhanced-ip
After you configure the enhanced-ip
statement and commit the
configuration, the following warning message
appears,
prompting you to reboot the router:
'chassis' WARNING: Chassis configuration for network services has been changed. A system reboot is mandatory. Please reboot the system NOW. Continuing without a reboot might result in unexpected system behavior. commit complete
The reboot brings up the FPCs on the router.
Configuration
To configure and run multiple IGP instances of IS-IS on the router, perform these tasks:
CLI Quick Configuration
To quickly configure this example, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, and then copy and paste the commands into the CLI at the [edit] hierarchy level.
Device R1
set interfaces ge-0/0/1 description R1-to-R4 set interfaces ge-0/0/1 unit 0 family inet address 192.168.1.1/24 set interfaces ge-0/0/1 unit 0 family iso set interfaces ge-0/0/2 description R1-to-R3 set interfaces ge-0/0/2 unit 0 family inet address 192.168.2.1/24 set interfaces ge-0/0/2 unit 0 family iso set interfaces lo0 unit 0 family inet address 192.168.100.1/32 set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0001.00 set protocols isis interface ge-0/0/1.0 level 2 metric 100 set protocols isis interface ge-0/0/1.0 level 1 disable set protocols isis interface ge-0/0/1.0 point-to-point set protocols isis interface ge-0/0/2.0 level 1 disable set protocols isis interface ge-0/0/2.0 level 2 metric 100 set protocols isis interface ge-0/0/2.0 point-to-point set protocols isis interface lo0.0 passive set routing-options router-id 192.168.100.1
Device R2
set interfaces ge-0/0/1 description R2-to-R3 set interfaces ge-0/0/1 unit 0 family inet address 192.168.3.1/24 set interfaces ge-0/0/1 unit 0 family iso set interfaces ge-0/0/2 description R2-to-R4 set interfaces ge-0/0/2 unit 0 family inet address 192.168.4.1/24 set interfaces ge-0/0/2 unit 0 family iso set interfaces lo0 unit 0 family inet address 192.168.100.2/32 set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0002.00 set protocols isis interface ge-0/0/1.0 level 1 disable set protocols isis interface ge-0/0/1.0 level 2 metric 100 set protocols isis interface ge-0/0/1.0 point-to-point set protocols isis interface ge-0/0/2.0 level 1 disable set protocols isis interface ge-0/0/2.0 level 2 metric 100 set protocols isis interface ge-0/0/2.0 point-to-point set protocols isis interface lo0.0 passive set routing-options router-id 192.168.100.2
Device R3
set interfaces ge-0/0/1 description R3-to-R2 set interfaces ge-0/0/1 unit 0 family inet address 192.168.3.2/24 set interfaces ge-0/0/1 unit 0 family iso set interfaces ge-0/0/2 description R3-to-R1 set interfaces ge-0/0/2 unit 0 family inet address 192.168.2.2/24 set interfaces ge-0/0/2 unit 0 family iso set interfaces ge-0/0/3 description R3-to-R5 set interfaces ge-0/0/3 unit 0 family inet address 192.168.6.1/24 set interfaces ge-0/0/3 unit 0 family iso set interfaces ge-0/0/4 description R3-to-R4 set interfaces ge-0/0/4 vlan-tagging set interfaces ge-0/0/4 unit 0 vlan-id 10 set interfaces ge-0/0/4 unit 0 family inet address 192.168.5.1/24 set interfaces ge-0/0/4 unit 0 family iso set interfaces ge-0/0/4 unit 1 vlan-id 11 set interfaces ge-0/0/4 unit 1 family inet address 192.168.9.1/24 set interfaces ge-0/0/4 unit 1 family iso set interfaces ge-0/0/4 unit 2 vlan-id 12 set interfaces ge-0/0/4 unit 2 family inet address 192.168.10.1/24 set interfaces ge-0/0/4 unit 2 family iso set interfaces lo0 unit 0 family inet address 192.168.100.3/32 set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0003.00 set policy-options policy-statement export-direct-loopback from protocol direct set policy-options policy-statement export-direct-loopback from route-filter 192.168.100.3/32 exact set policy-options policy-statement export-direct-loopback then accept set policy-options policy-statement export-isis from protocol isis set policy-options policy-statement export-isis from level 2 set policy-options policy-statement export-isis from route-filter 192.168.100.0/24 longer set policy-options policy-statement export-isis then accept set policy-options policy-statement export-isis-metro-a from igp-instance metro-a set policy-options policy-statement export-isis-metro-a from protocol isis set policy-options policy-statement export-isis-metro-a from level 2 set policy-options policy-statement export-isis-metro-a from route-filter 192.168.100.0/24 longer set policy-options policy-statement export-isis-metro-a then accept set policy-options policy-statement export-isis-metro-b from igp-instance metro-b set policy-options policy-statement export-isis-metro-b from protocol isis set policy-options policy-statement export-isis-metro-b from level 2 set policy-options policy-statement export-isis-metro-b from route-filter 192.168.100.0/24 longer set policy-options policy-statement export-isis-metro-b then accept set protocols isis interface ge-0/0/3.0 level 1 disable set protocols isis interface ge-0/0/3.0 level 2 metric 100 set protocols isis interface ge-0/0/3.0 point-to-point set protocols isis interface ge-0/0/4.0 level 1 disable set protocols isis interface ge-0/0/4.0 level 2 metric 100 set protocols isis interface ge-0/0/4.0 point-to-point set protocols isis interface lo0.0 passive set protocols isis export export-isis-metro-a set protocols isis export export-isis-metro-b set protocols isis-instance metro-b interface ge-0/0/1.0 level 1 disable set protocols isis-instance metro-b interface ge-0/0/1.0 level 2 metric 100 set protocols isis-instance metro-b interface ge-0/0/1.0 point-to-point set protocols isis-instance metro-b interface ge-0/0/4.2 level 1 disable set protocols isis-instance metro-b interface ge-0/0/4.2 level 2 metric 100 set protocols isis-instance metro-b interface ge-0/0/4.2 point-to-point set protocols isis-instance metro-b export export-isis set protocols isis-instance metro-b export export-direct-loopback set protocols isis-instance metro-b export export-isis-metro-a set protocols isis-instance metro-a interface ge-0/0/2.0 level 1 disable set protocols isis-instance metro-a interface ge-0/0/2.0 level 2 metric 100 set protocols isis-instance metro-a interface ge-0/0/2.0 point-to-point set protocols isis-instance metro-a interface ge-0/0/4.1 level 1 disable set protocols isis-instance metro-a interface ge-0/0/4.1 level 2 metric 100 set protocols isis-instance metro-a interface ge-0/0/4.1 point-to-point set protocols isis-instance metro-a export export-isis set protocols isis-instance metro-a export export-direct-loopback set protocols isis-instance metro-a export export-isis-metro-b set routing-options router-id 192.168.100.3
Device R4
set interfaces ge-0/0/1 description R4-to-R1 set interfaces ge-0/0/1 unit 0 family inet address 192.168.1.2/24 set interfaces ge-0/0/1 unit 0 family iso set interfaces ge-0/0/2 description R4-to-R2 set interfaces ge-0/0/2 unit 0 family inet address 192.168.4.2/24 set interfaces ge-0/0/2 unit 0 family iso set interfaces ge-0/0/3 description R4-to-R6 set interfaces ge-0/0/3 unit 0 family inet address 192.168.7.1/24 set interfaces ge-0/0/3 unit 0 family iso set interfaces ge-0/0/4 description R4-to-R3 set interfaces ge-0/0/4 vlan-tagging set interfaces ge-0/0/4 unit 0 vlan-id 10 set interfaces ge-0/0/4 unit 0 family inet address 192.168.5.2/24 set interfaces ge-0/0/4 unit 0 family iso set interfaces ge-0/0/4 unit 1 vlan-id 11 set interfaces ge-0/0/4 unit 1 family inet address 192.168.9.2/24 set interfaces ge-0/0/4 unit 1 family iso set interfaces ge-0/0/4 unit 2 vlan-id 12 set interfaces ge-0/0/4 unit 2 family inet address 192.168.10.2/24 set interfaces ge-0/0/4 unit 2 family iso set interfaces lo0 unit 0 family inet address 192.168.100.4/32 set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0004.00 set policy-options policy-statement export-direct-loopback from protocol direct set policy-options policy-statement export-direct-loopback from route-filter 192.168.100.4/32 exact set policy-options policy-statement export-direct-loopback then accept set policy-options policy-statement export-isis from protocol isis set policy-options policy-statement export-isis from level 2 set policy-options policy-statement export-isis from route-filter 192.168.100.0/24 longer set policy-options policy-statement export-isis then accept set policy-options policy-statement export-isis-metro-a from igp-instance metro-a set policy-options policy-statement export-isis-metro-a from protocol isis set policy-options policy-statement export-isis-metro-a from level 2 set policy-options policy-statement export-isis-metro-a from route-filter 192.168.100.0/24 longer set policy-options policy-statement export-isis-metro-a then accept set policy-options policy-statement export-isis-metro-b from igp-instance metro-b set policy-options policy-statement export-isis-metro-b from protocol isis set policy-options policy-statement export-isis-metro-b from level 2 set policy-options policy-statement export-isis-metro-b from route-filter 192.168.100.0/24 longer set policy-options policy-statement export-isis-metro-b then accept set protocols isis interface ge-0/0/3.0 level 1 disable set protocols isis interface ge-0/0/3.0 level 2 metric 100 set protocols isis interface ge-0/0/3.0 point-to-point set protocols isis interface ge-0/0/4.0 level 1 disable set protocols isis interface ge-0/0/4.0 level 2 metric 100 set protocols isis interface ge-0/0/4.0 point-to-point set protocols isis interface lo0.0 passive set protocols isis export export-isis-metro-a set protocols isis export export-isis-metro-b set protocols isis-instance metro-a interface ge-0/0/1.0 level 1 disable set protocols isis-instance metro-a interface ge-0/0/1.0 level 2 metric 100 set protocols isis-instance metro-a interface ge-0/0/1.0 point-to-point set protocols isis-instance metro-a interface ge-0/0/4.1 level 1 disable set protocols isis-instance metro-a interface ge-0/0/4.1 level 2 metric 100 set protocols isis-instance metro-a interface ge-0/0/4.1 point-to-point set protocols isis-instance metro-a export export-isis set protocols isis-instance metro-a export export-direct-loopback set protocols isis-instance metro-a export export-isis-metro-b set protocols isis-instance metro-b interface ge-0/0/2.0 level 1 disable set protocols isis-instance metro-b interface ge-0/0/2.0 level 2 metric 100 set protocols isis-instance metro-b interface ge-0/0/2.0 point-to-point set protocols isis-instance metro-b interface ge-0/0/4.2 level 1 disable set protocols isis-instance metro-b interface ge-0/0/4.2 level 2 metric 100 set protocols isis-instance metro-b interface ge-0/0/4.2 point-to-point set protocols isis-instance metro-b export export-isis set protocols isis-instance metro-b export export-direct-loopback set protocols isis-instance metro-b export export-isis-metro-a set routing-options router-id 192.168.100.4
Device R5
set interfaces ge-0/0/2 description R5-to-R6 set interfaces ge-0/0/2 unit 0 family inet address 192.168.8.1/24 set interfaces ge-0/0/2 unit 0 family iso set interfaces ge-0/0/3 description R5-to-R3 set interfaces ge-0/0/3 unit 0 family inet address 192.168.6.2/24 set interfaces ge-0/0/3 unit 0 family iso set interfaces lo0 unit 0 family inet address 192.168.100.5/32 set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0005.00 set protocols isis interface ge-0/0/2.0 level 1 disable set protocols isis interface ge-0/0/2.0 level 2 metric 100 set protocols isis interface ge-0/0/2.0 point-to-point set protocols isis interface ge-0/0/3.0 level 1 disable set protocols isis interface ge-0/0/3.0 level 2 metric 100 set protocols isis interface ge-0/0/3.0 point-to-point set protocols isis interface lo0.0 passive set routing-options router-id 192.168.100.5
Device R6
set interfaces ge-0/0/2 description R6-to-R5 set interfaces ge-0/0/2 unit 0 family inet address 192.168.8.2/24 set interfaces ge-0/0/2 unit 0 family iso set interfaces ge-0/0/3 description R6-to-R4 set interfaces ge-0/0/3 unit 0 family inet address 192.168.7.2/24 set interfaces ge-0/0/3 unit 0 family iso set interfaces lo0 unit 0 family inet address 192.168.100.6/32 set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0006.00 set protocols isis interface ge-0/0/2.0 level 1 disable set protocols isis interface ge-0/0/2.0 level 2 metric 100 set protocols isis interface ge-0/0/2.0 point-to-point set protocols isis interface ge-0/0/3.0 level 1 disable set protocols isis interface ge-0/0/3.0 level 2 metric 100 set protocols isis interface ge-0/0/3.0 point-to-point set protocols isis interface lo0.0 passive set routing-options router-id 192.168.100.6
Configure R1
Step-by-Step Procedure
The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.
You can use the steps in this example to also configure the R2, R5, and R6 routers. See CLI Quick Configuration and Figure 2 to understand the interface IDs, IP addresses, and the loopback addresses used on these routers.
To configure R1:
-
Configure the interfaces to enable IP (
inet
) and ISO family support.user@R1# set interfaces ge-0/0/1 description R1-to-R4 user@R1# set interfaces ge-0/0/1 unit 0 family inet address 192.168.1.1/24 user@R1# set interfaces ge-0/0/1 unit 0 family iso user@R1# set interfaces ge-0/0/2 description R1-to-R3 user@R1# set interfaces ge-0/0/2 unit 0 family inet address 192.168.2.1/24 user@R1# set interfaces ge-0/0/2 unit 0 family iso
-
Create the loopback interface and configure the IP and NET addresses.
user@R1# set interfaces lo0 unit 0 family inet address 192.168.100.1/32 user@R1# set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0001.00
-
Configure routing options to identify the router in the domain.
user@R1# set routing-options router-id 192.168.100.1
-
Enable IS-IS on the interfaces.
user@R1# set protocols isis interface ge-0/0/1.0 level 2 metric 100 user@R1# set protocols isis interface ge-0/0/1.0 level 1 disable user@R1# set protocols isis interface ge-0/0/1.0 point-to-point user@R1# set protocols isis interface ge-0/0/2.0 level 1 disable user@R1# set protocols isis interface ge-0/0/2.0 level 2 metric 100 user@R1# set protocols isis interface ge-0/0/2.0 point-to-point user@R1# set protocols isis interface lo0.0 passive
Results
From configuration mode,
confirm
your configuration by entering the show interfaces
,
show routing-options
, and show
protocols
commands. If the output does not display the intended
configuration, repeat the instructions in this example to correct the
configuration.
interfaces { ge-0/0/1 { description R1-to-R4; unit 0 { family inet { address 192.168.1.1/24; } family iso; } } ge-0/0/2 { description R1-to-R3; unit 0 { family inet { address 192.168.2.1/24; } family iso; } } lo0 { unit 0 { family inet { address 192.168.100.1/32; } family iso { address 49.0002.0192.0168.0001.00; } } } } protocols { isis { interface ge-0/0/1.0 { level 2 metric 100; level 1 disable; point-to-point; } interface ge-0/0/2.0 { level 1 disable; level 2 metric 100; point-to-point; } interface lo0.0 { passive; } } } routing-options { router-id 192.168.100.1; }
Configure R3
Step-by-Step Procedure
The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.
You can use the steps in this example to also configure the R4 router. See CLI Quick Configuration and Figure 2 to understand the interface IDs, IP addresses, and the loopback address used on the router.
To configure R3:
-
Configure the interfaces connecting to R1, R2, and R5 to enable IP and ISO family support.
user@R3# set interfaces ge-0/0/1 description R3-to-R2 user@R3# set interfaces ge-0/0/1 unit 0 family inet address 192.168.3.2/24 user@R3# set interfaces ge-0/0/1 unit 0 family iso user@R3# set interfaces ge-0/0/2 description R3-to-R1 user@R3# set interfaces ge-0/0/2 unit 0 family inet address 192.168.2.2/24 user@R3# set interfaces ge-0/0/2 unit 0 family iso user@R3# set interfaces ge-0/0/3 description R3-to-R5 user@R3# set interfaces ge-0/0/3 unit 0 family inet address 192.168.6.1/24 user@R3# set interfaces ge-0/0/3 unit 0 family iso
-
Configure three subinterfaces (logical interfaces) connecting R3 and R4 (one IS-IS standard instance and two IS-IS metro instances (IS-IS metro-a and IS-IS metro-b)).
Note:The standard IS-IS instance refers to the IS-IS IGP instance configured at the [
edit protocols isis
] hierarchy level.user@R3# set interfaces ge-0/0/4 description R3-to-R4 user@R3# set interfaces ge-0/0/4 vlan-tagging user@R3# set interfaces ge-0/0/4 unit 0 vlan-id 10 user@R3# set interfaces ge-0/0/4 unit 0 family inet address 192.168.5.1/24 user@R3# set interfaces ge-0/0/4 unit 0 family iso user@R3# set interfaces ge-0/0/4 unit 1 vlan-id 11 user@R3# set interfaces ge-0/0/4 unit 1 family inet address 192.168.9.1/24 user@R3# set interfaces ge-0/0/4 unit 1 family iso user@R3# set interfaces ge-0/0/4 unit 2 vlan-id 12 user@R3# set interfaces ge-0/0/4 unit 2 family inet address 192.168.10.1/24 user@R3# set interfaces ge-0/0/4 unit 2 family iso
-
Create the loopback interface and configure the IP and NET addresses.
user@R3# set interfaces lo0 unit 0 family inet address 192.168.100.3/32 user@R3# set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0003.00
-
Configure policies to redistribute loopback addresses of IS-IS metro-instance (IS-IS metro-a and IS-IS metro-b) and IS-IS standard-instance (core network) routers, so that the routes can be distributed across IS-IS domains as required.
-
Configure policies to distribute the loopback address of R3.
user@R3# set policy-options policy-statement export-direct-loopback from protocol direct user@R3# set policy-options policy-statement export-direct-loopback from route-filter 192.168.100.3/32 exact user@R3# set policy-options policy-statement export-direct-loopback then accept
-
Configure policies to distribute the loopback addresses of the R5 and R6 routers (standard IS-IS instance).
user@R3# set policy-options policy-statement export-isis from protocol isis user@R3# set policy-options policy-statement export-isis from level 2 user@R3# set policy-options policy-statement export-isis from route-filter 192.168.100.0/24 longer user@R3# set policy-options policy-statement export-isis then accept
-
Configure policies to distribute the loopback addresses of R1 (IS-IS metro-a instance).
user@R3# set policy-options policy-statement export-isis-metro-a from igp-instance metro-a user@R3# set policy-options policy-statement export-isis-metro-a from protocol isis user@R3# set policy-options policy-statement export-isis-metro-a from level 2 user@R3# set policy-options policy-statement export-isis-metro-a from route-filter 192.168.100.0/24 longer user@R3# set policy-options policy-statement export-isis-metro-a then accept
-
Configure policies to distribute the loopback addresses of R2 (IS-IS metro-b instance).
user@R3# set policy-options policy-statement export-isis-metro-b from igp-instance metro-b user@R3# set policy-options policy-statement export-isis-metro-b from protocol isis user@R3# set policy-options policy-statement export-isis-metro-b from level 2 user@R3# set policy-options policy-statement export-isis-metro-b from route-filter 192.168.100.0/24 longer user@R3# set policy-options policy-statement export-isis-metro-b then accept
-
-
Enable IS-IS on the standard-instance interface (connecting R3 to R5) and on the subinterface (connecting R3 to R4).
user@R3# set protocols isis interface ge-0/0/3.0 level 1 disable user@R3# set protocols isis interface ge-0/0/3.0 level 2 metric 100 user@R3# set protocols isis interface ge-0/0/3.0 point-to-point user@R3# set protocols isis interface ge-0/0/4.0 level 1 disable user@R3# set protocols isis interface ge-0/0/4.0 level 2 metric 100 user@R3# set protocols isis interface ge-0/0/4.0 point-to-point user@R3# set protocols isis interface lo0.0 passive
-
Configure IS-IS to export loopback addresses from IS-IS metro-a and IS-IS metro-b instances to the IS-IS standard instance. This configuration distributes specific routes instead of flooding the entire metro domain.
user@R3# set protocols isis export export-isis-metro-a user@R3# set protocols isis export export-isis-metro-b
-
Enable IS-IS on the IS-IS metro-b instance interface (connecting R3 to R2) and on the subinterface (R3 to R4).
user@R3# set protocols isis-instance metro-b interface ge-0/0/1.0 level 1 disable user@R3# set protocols isis-instance metro-b interface ge-0/0/1.0 level 2 metric 100 user@R3# set protocols isis-instance metro-b interface ge-0/0/1.0 point-to-point user@R3# set protocols isis-instance metro-b interface ge-0/0/4.2 level 1 disable user@R3# set protocols isis-instance metro-b interface ge-0/0/4.2 level 2 metric 100 user@R3# set protocols isis-instance metro-b interface ge-0/0/4.2 point-to-point
-
Configure IS-IS to export the loopback addresses of IS-IS metro-a and standard IS-IS instances to the IS-IS metro-b instance. This configuration distributes specific routes instead of flooding the entire standard IS-IS instances and metro-a domain instances.
user@R3# set protocols isis-instance metro-b export export-isis user@R3# set protocols isis-instance metro-b export export-direct-loopback user@R3# set protocols isis-instance metro-b export export-isis-metro-a
-
Enable IS-IS on the IS-IS metro-a instance interface (connecting R3 to R1) and on the subinterface (R3 to R4).
user@R3# set protocols isis-instance metro-a interface ge-0/0/2.0 level 1 disable user@R3# set protocols isis-instance metro-a interface ge-0/0/2.0 level 2 metric 100 user@R3# set protocols isis-instance metro-a interface ge-0/0/2.0 point-to-point user@R3# set protocols isis-instance metro-a interface ge-0/0/4.1 level 1 disable user@R3# set protocols isis-instance metro-a interface ge-0/0/4.1 level 2 metric 100 user@R3# set protocols isis-instance metro-a interface ge-0/0/4.1 point-to-point
-
Configure IS-IS to export the loopback addresses of IS-IS metro-b and standard IS-IS instances to the IS-IS metro-a instance. This configuration distributes specific routes instead of flooding the entire standard IS-IS instances and metro-b domain instances.
user@R3# set protocols isis-instance metro-a export export-isis user@R3# set protocols isis-instance metro-a export export-direct-loopback user@R3# set protocols isis-instance metro-a export export-isis-metro-b
-
Configure routing options to identify the router in the domain.
user@R3# set routing-options router-id 192.168.100.3
Results
From configuration mode,
confirm
your configuration by entering the show interfaces
,
show routing-options
, and show protocols
commands. If the output does not display the intended configuration, repeat the
instructions in this example to correct the configuration.
interfaces { ge-0/0/1 { description R3-to-R2; unit 0 { family inet { address 192.168.3.2/24; } family iso; } } ge-0/0/2 { description R3-to-R1; unit 0 { family inet { address 192.168.2.2/24; } family iso; } } ge-0/0/3 { description R3-to-R5; unit 0 { family inet { address 192.168.6.1/24; } family iso; } } ge-0/0/4 { description R3-to-R4; vlan-tagging; unit 0 { vlan-id 10; family inet { address 192.168.5.1/24; } family iso; } unit 1 { vlan-id 11; family inet { address 192.168.9.1/24; } family iso; } unit 2 { vlan-id 12; family inet { address 192.168.10.1/24; } family iso; } } lo0 { unit 0 { family inet { address 192.168.100.3/32; } family iso { address 49.0002.0192.0168.0003.00; } } } } policy-options { policy-statement export-direct-loopback { from { protocol direct; route-filter 192.168.100.3/32 exact; } then accept; } policy-statement export-isis { from { protocol isis; level 2; route-filter 192.168.100.0/24 longer; } then accept; } policy-statement export-isis-metro-a { from { igp-instance metro-a; protocol isis; level 2; route-filter 192.168.100.0/24 longer; } then accept; } policy-statement export-isis-metro-b { from { igp-instance metro-b; protocol isis; level 2; route-filter 192.168.100.0/24 longer; } then accept; } } protocols { isis { interface ge-0/0/3.0 { level 1 disable; level 2 metric 100; point-to-point; } interface ge-0/0/4.0 { level 1 disable; level 2 metric 100; point-to-point; } interface lo0.0 { passive; } export [ export-isis-metro-a export-isis-metro-b ]; } isis-instance metro-b { interface ge-0/0/1.0 { level 1 disable; level 2 metric 100; point-to-point; } interface ge-0/0/4.2 { level 1 disable; level 2 metric 100; point-to-point; } export [ export-isis export-direct-loopback export-isis-metro-a ]; } isis-instance metro-a { interface ge-0/0/2.0 { level 1 disable; level 2 metric 100; point-to-point; } interface ge-0/0/4.1 { level 1 disable; level 2 metric 100; point-to-point; } export [ export-isis export-direct-loopback export-isis-metro-b ]; } } routing-options { router-id 192.168.100.3; }
Verification
To verify that the configuration is working properly, perform the following tasks:
- Verify IS-IS Advertisements
- Verify the Routing Table
- Verify the Routes in the IS-IS Routing Table
- Verify IS-IS Interfaces
Verify IS-IS Advertisements
Purpose
Verify the IS-IS advertisement entries in the IS-IS link-state database (LSDB), which contains data about PDU packets.
Action
From operational mode, run the show isis database level 2
command.
On R3
user@R3>show isis database level 2 IS-IS level 2 link-state database: LSP ID Sequence Checksum Lifetime Attributes R6.00-00 0x75d 0x1ff7 1181 L1 L2 R5.00-00 0x75b 0xffdc 741 L1 L2 R4.00-00 0x780 0x4e1 552 L1 L2 R3.00-00 0x7f0 0x8643 496 L1 L2 4 LSPs
user@R3>show isis database level 2 igp-instance metro-a IS-IS level 2 link-state database: LSP ID Sequence Checksum Lifetime Attributes R1.00-00 0x136 0x46e5 1046 L1 L2 R4.00-00 0x781 0xf65e 768 L1 L2 R3.00-00 0x7f2 0x871b 764 L1 L2 3 LSPs
user@R3>show isis database level 2 igp-instance metro-b IS-IS level 2 link-state database: LSP ID Sequence Checksum Lifetime Attributes R2.00-00 0x13a 0x7997 1013 L1 L2 R4.00-00 0x781 0x86ba 771 L1 L2 R3.00-00 0x7f2 0x1288 510 L1 L2 3 LSPs
On R1
user@R1>show isis database level 2 IS-IS level 2 link-state database: LSP ID Sequence Checksum Lifetime Attributes R1.00-00 0x136 0x46e5 851 L1 L2 R4.00-00 0x781 0xf65e 571 L1 L2 R3.00-00 0x7f2 0x871b 565 L1 L2 3 LSPs
Meaning
This output on R3 illustrates that R3 sees the IS-IS advertisements from R4, R5, and R6 which is standard IS-IS instance. R3 also sees the IS-IS advertisements from R1 (IS-IS metro-a), R2 (IS-IS metro-b), and R4 (both IS-IS metro-a and IS-IS metro-b). Thus, you can see that R3 is a common router that redistributes IS-IS routes among the IS-IS metro-a instance, the IS-IS metro-b instance, and the standard IS-IS instance (core network).
The output on R1 illustrates that R1 sees the IS-IS advertisements only from R3 and R4. R1 does not see any IS-IS advertisements from R2. Thus, you see that IS-IS metro-a and IS-IS metro-b are separate IS-IS flooding domains. You can use this property to build more scalable networks.
Verify the Routing Table
Purpose
Verify the route entries in the routing table.
Action
From operational mode, run the show route table inet.0
route-destination address extensive
command.
On R3
user@R3>show route table inet.0 192.168.100.1 extensive
inet.0: 28 destinations, 28 routes (28 active, 0 holddown, 0 hidden)
192.168.100.1/32 (1 entry, 1 announced)
TSI:
KRT in-kernel 192.168.100.1/32 -> {192.168.2.1}
IS-IS level 1, LSP fragment 0
IS-IS level 2, LSP fragment 0
IS-IS level 1, LSP fragment 0
IS-IS level 2, LSP fragment 0
*IS-IS Preference: 18
Level: 2
Next hop type: Router, Next hop index: 601
Address: 0xc5b21cc
Next-hop reference count: 2
Next hop: 192.168.2.1 via ge-0/0/2.0, selected
Session Id: 0x140
State: <Active Int>
Age: 2d 18:10:36 Metric: 63
Validation State: unverified
ORR Generation-ID: 0
Task: IS-IS-metro-a
Announcement bits (3): 0-KRT 2-IS-IS 10-IS-IS-metro-b
AS path: I
Thread: junos-main
user@R3>show route table inet.0 192.168.100.2 extensive
inet.0: 28 destinations, 28 routes (28 active, 0 holddown, 0 hidden)
192.168.100.2/32 (1 entry, 1 announced)
TSI:
KRT in-kernel 192.168.100.2/32 -> {192.168.3.1}
IS-IS level 1, LSP fragment 0
IS-IS level 2, LSP fragment 0
IS-IS level 1, LSP fragment 0
IS-IS level 2, LSP fragment 0
*IS-IS Preference: 18
Level: 2
Next hop type: Router, Next hop index: 602
Address: 0xc5b2234
Next-hop reference count: 2
Next hop: 192.168.3.1 via ge-0/0/1.0, selected
Session Id: 0x141
State: <Active Int>
Age: 2d 18:18:48 Metric: 63
Validation State: unverified
ORR Generation-ID: 0
Task: IS-IS-metro-b
Announcement bits (3): 0-KRT 2-IS-IS 4-IS-IS-metro-a
AS path: I
Thread: junos-main
Meaning
The output illustrates that the loopback address of R1 (192.168.100.1) is mapped to the IS-IS metro-a instance (IS-IS-metro-a) and the loopback address of R2 (192.168.100.2) is mapped to the IS-IS metro-b instance (IS-IS-metro-b) as configured in R3.
Verify the Routes in the IS-IS Routing Table
Purpose
Verify the routes in the IS-IS routing table.
Action
From operational mode, run the show isis route
command.
On R3
user@R3>show isis route IS-IS routing table Current version: L1: 1885 L2: 1956 IPv4/IPv6 Routes ---------------- Prefix L Version Metric Type Interface NH Via Backup Score 192.168.7.0/24 2 1956 126 int ge-0/0/4.0 IPV4 R4 192.168.8.0/24 2 1956 126 int ge-0/0/3.0 IPV4 R5 192.168.100.4/32 2 1956 63 int ge-0/0/4.0 IPV4 R4 192.168.100.5/32 2 1956 63 int ge-0/0/3.0 IPV4 R5 192.168.100.6/32 2 1956 126 int ge-0/0/3.0 IPV4 R5 ge-0/0/4.0 IPV4 R4
user@R3>show isis route igp-instance metro-a IS-IS routing table Current version: L1: 1889 L2: 1961 IPv4/IPv6 Routes ---------------- Prefix L Version Metric Type Interface NH Via Backup Score 192.168.1.0/24 2 1961 126 int ge-0/0/4.1 IPV4 R4 ge-0/0/2.0 IPV4 R1 192.168.100.1/32 2 1961 63 int ge-0/0/2.0 IPV4 R1
user@R3>show isis route igp-instance metro-b IS-IS routing table Current version: L1: 1892 L2: 1949 IPv4/IPv6 Routes ---------------- Prefix L Version Metric Type Interface NH Via Backup Score 192.168.4.0/24 2 1949 126 int ge-0/0/4.2 IPV4 R4 ge-0/0/1.0 IPV4 R2 192.168.100.2/32 2 1949 63 int ge-0/0/1.0 IPV4 R2
On R1
user@R1>show isis route IS-IS routing table Current version: L1: 313 L2: 392 IPv4/IPv6 Routes ---------------- Prefix L Version Metric Type Interface NH Via Backup Score 192.168.9.0/24 2 392 126 int ge-0/0/2.0 IPV4 R3 ge-0/0/1.0 IPV4 R4 192.168.100.2/32 2 392 126 int ge-0/0/2.0 IPV4 R3 ge-0/0/1.0 IPV4 R4 192.168.100.3/32 2 392 73 int ge-0/0/2.0 IPV4 R3 192.168.100.4/32 2 392 73 int ge-0/0/1.0 IPV4 R4 192.168.100.5/32 2 392 126 int ge-0/0/2.0 IPV4 R3 ge-0/0/1.0 IPV4 R4 192.168.100.6/32 2 392 126 int ge-0/0/2.0 IPV4 R3 ge-0/0/1.0 IPV4 R4
Meaning
The output on R3 shows the loopback addresses and the IS-IS instance mapping information of R1, R2, R4, R5, and R6.
The output on R1 shows the loopback addresses of R2, R3, R4, R5, and R6.
Verify IS-IS Interfaces
Purpose
Verify the status information about IS-IS-enabled interfaces.
Action
From operational mode, run the show isis interface
command.
On R3
user@R3>show isis interface IS-IS interface database: Interface L CirID Level 1 DR Level 2 DR L1/L2 Metric ge-0/0/3.0 2 0x1 Disabled Point to Point 10/100 ge-0/0/4.0 2 0x1 Disabled Point to Point 10/100 lo0.0 3 0x1 Passive Passive 0/0
user@R3>show isis interface igp-instance metro-a IS-IS interface database: Interface L CirID Level 1 DR Level 2 DR L1/L2 Metric ge-0/0/2.0 2 0x1 Disabled Point to Point 10/100 ge-0/0/4.1 2 0x1 Disabled Point to Point 10/100
user@R3>show isis interface igp-instance metro-b IS-IS interface database: Interface L CirID Level 1 DR Level 2 DR L1/L2 Metric ge-0/0/1.0 2 0x1 Disabled Point to Point 10/100 ge-0/0/4.2 2 0x1 Disabled Point to Point 10/100
On R1
user@R1>show isis interface IS-IS interface database: Interface L CirID Level 1 DR Level 2 DR L1/L2 Metric ge-0/0/1.0 2 0x1 Disabled Point to Point 10/100 ge-0/0/2.0 2 0x1 Disabled Point to Point 10/100 lo0.0 3 0x1 Passive Passive 0/0
Meaning
The output shows the interfaces mapped to different IS-IS instances.