ON THIS PAGE
Troubleshooting: 10-Gigabit Ethernet Port Stuck in Down State
Problem
Description
10-Gigabit Ethernet port is stuck in DPC or PIC down state.
Environment
Juniper Networks T Series and MX Series routers. Refer to the related documentation section for more information.
Symptoms
The device has failed to initialize because the Ethernet port is down.
Diagnosis
Try disabling and reenabling the interface and resetting the transceiver and cable. If the interface remains down, it can be stuck in DPC or PIC down state.
Does the router function normally after disabling and reenabling the interface and resetting the transceiver and cable?
Yes:
The system is not stuck in DPC or PIC down state. Disabling and reenabling the interface or resetting the transceiver, and cable resolved the issue.
No:
The interface might be stuck in DPC or PIC down state. Refer to the To resolve the issue section for recovery options.
Resolution
To resolve the issue
From the aforementioned diagnosis, you ascertain that the interface is stuck in DPC or PIC down state.
This is not a hardware defect. Implement one of the following solutions on the backup Routing Engine to resolve this issue:
Reset the PIC.
Toggle the framing mode.
In configuration mode, go to the
[edit interfaces]
hierarchy level.user@host1# edit interfaces interface name
Toggle the framing mode. In the following configuration, WAN-PHY mode is toggled.
[edit interfaces interface-name is in the et-fpc/pic/port user@host1# set framing wan-phy user@host1# commit user@host1# framing { user@host1# wan-phy; user@host1# } user@host1# delete framing user@host1# commit
Reset the PIC (T Series Routers)
user@host1# request chassis pic fpc-slot x pic-slot y offline user@host1# request chassis pic fpc-slot x pic-slot y online
Reset the PIC (MX Series Routers)
user@host1# request chassis fpc slot x offline user@host1# request chassis fpc slot x online