Technical Documentation

Router Configurations for the Aggregated Interfaces Network

Purpose

The configurations in this topic are for the five routers in the example network illustrated in Aggregated Interfaces Network Topology.

Action

To display the configuration of a router, use the following JUNOS CLI operational mode command:

user@host> show configuration | no-more

Sample Output 1

user@R0> show configuration | no-more
[...Output truncated...]
interfaces {
    ge-1/2/0 {
        unit 0 {
            family inet {
                address 10.35.1.1/30;
            }
            family iso;
            family mpls;
        }
    }
}
routing-options {
    autonomous-system 69;
}
protocols {
    }
    mpls {
        traffic-engineering bgp-igp-both-ribs;
        interface all;
    }
    bgp {
        group int {
            type internal;
            local-address 10.255.71.197;
            family inet {
                any;
            }
            family inet-vpn {
                any;
            }
            neighbor 10.255.70.79;
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface lo0.0;
                passive
            interface all;
            interface fxp0.0 {
                disable;
            }
        }
    }
    ldp {
        interface all;
        interface lo0.0
            passive
       }
    }
}
policy-options {
    policy-statement all_routes {
        then accept;
    }
}

Sample Output 2

user@R1> show configuration | no-more
[...Output truncated...]
chassis {
    redundancy {
        graceful-switchover {
            enable;
        }
    }
    aggregated-devices {
        sonet {
            device-count 1;
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 10.35.1.2/30;
            }
            family iso;
            family mpls;
        }
    }
    so-7/2/0 {
        sonet-options {
            aggregate as0;
        }
    }
    so-7/2/1 {
        sonet-options {
            aggregate as0;
        }
    }
    as0 {
        aggregated-sonet-options {
            minimum-links 1;
        }
        unit 0 {
            family inet {
                address 10.35.200.1/30;
            }
            family iso;
            family mpls;
        }
    }
}
routing-options {
    autonomous-system 69;
    forwarding-table {
        export pplb;
    }
}
protocols {
    rsvp {
        interface all;
    }
    mpls {
        traffic-engineering bgp-igp-both-ribs;
        label-switched-path to_R3_from_R1 {
            to 10.255.71.199;
            ldp-tunneling;
        }
        label-switched-path to_R3_from_R1_1 {
            to 10.255.71.199;
            ldp-tunneling;
        }
        label-switched-path to_R3_from_R1_2 {
            to 10.255.71.199;
            ldp-tunneling;
        }
        label-switched-path to_R3_from_R1_3 {
            to 10.255.71.199;
            ldp-tunneling;
        }
        label-switched-path to_R3_from_R1_4 {
            to 10.255.71.199;
            ldp-tunneling;
        }
        label-switched-path to_R3_from_R1_5 {
            to 10.255.71.199;
            ldp-tunneling;
        }
        label-switched-path to_R3_from_R1_6 {
            to 10.255.71.199;
            ldp-tunneling;
        }
        label-switched-path to_R3_from_R1_7 {
            to 10.255.71.199;
            ldp-tunneling;
        }
        interface all;
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface lo0.0;
                passive
            interface all;
            interface fxp0.0 {
                disable;
            }
        }
    }
    ldp {
        interface ge-0/0/0.0;
        interface lo0.0;
    }
}
policy-options {
    policy-statement pplb {
        then {
            load-balance per-packet;
        }
    }
}

Sample Output 3

user@R2> show configuration | no-more
[...Output truncated...]
chassis {
    redundancy {
        graceful-switchover {
            enable;
        }
    }
    aggregated-devices {
        ethernet {
            device-count 1;
        }
        sonet {
            device-count 3;
        }
    }
}
interfaces {
    ge-1/1/0 {
        gigether-options {
            802.3ad {
                ae0;
            }
        }
    }
    so-4/1/0 {
        sonet-options {
            aggregate as0;
        }
    }
    so-4/1/1 {
        sonet-options {
            aggregate as0;
        }
    }
    ge-4/3/1 {
        gigether-options {
            802.3ad {
                ae0;
            }
        }
    }
    ae0 {
        aggregated-ether-options {
            minimum-links 1;
        }
        unit 0 {
            family inet {
                address 10.35.200.5/30;
            }
            family iso;
            family mpls;
        }
    }
    as0 {
        aggregated-sonet-options {
            minimum-links 1;
        }
        unit 0 {
            family inet {
                address 10.35.200.2/30;
            }
            family iso;
            family mpls;
        }
    }
}
forwarding-options {
    hash-key {
        family mpls {
            label-1;
            label-2;
            label-3;
        }
    }
}
routing-options {
    autonomous-system 69;
    forwarding-table {
        export pplb;
    }
}
protocols {
    rsvp {
        interface all;
    }
    mpls {
        traffic-engineering bgp-igp-both-ribs;
        interface all;
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface lo0.0;
            interface all;
            interface fxp0.0 {
                disable;
            }
        }
    }
}
policy-options {
    policy-statement pplb {
        then {
            load-balance per-packet;
        }
    }
}

Sample Output 4

user@R3> show configuration | no-more
[...Output truncated...]
chassis {
    redundancy {
        graceful-switchover {
            enable;
        }
    }
    aggregated-devices {
        ethernet {
            device-count 1;
        }
        sonet {
            device-count 2;
        }
    }
}
interfaces {
    ge-1/3/0 {
        gigether-options {
            802.3ad {
                ae0;
            }
        }
    }
    ge-4/0/1 {
        gigether-options {
            802.3ad {
                ae0;
            }
        }
    }
    ge-7/0/0 {
        unit 0 {
            family inet {
                address 10.35.1.53/30;
            }
            family iso;
            family mpls;
        }
    }
    ae0 {
        aggregated-ether-options {
            minimum-links 1;
        }
        unit 0 {
            family inet {
                address 10.35.200.6/30;
            }
            family iso;
            family mpls;
        }
    }
}
routing-options {
    autonomous-system 69;
}
protocols {
    rsvp {
        interface all;
    }
    mpls {
        traffic-engineering bgp-igp-both-ribs;
        label-switched-path to_R1_from_R3 {
            to 10.255.70.186;
            ldp-tunneling;
        }
        interface all;
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface lo0.0;
            interface all;
            interface fxp0.0 {
                disable;
            }
        }
    }
    ldp {
        interface ge-7/0/0.0;
        interface lo0.0;
    }
}

Sample Output 5

user@R4> show configuration | no-more
[...Output truncated...]
interfaces {
    ge-0/3/0 {
        unit 0 {
            family inet {
                address 10.35.1.54/30;
            }
            family iso;
            family mpls;
        }
    }
}
routing-options {
    autonomous-system 69;
}
protocols {
    mpls {
        traffic-engineering bgp-igp-both-ribs;
        interface all;
    }
    bgp {
        group int {
            type internal;
            local-address 10.255.70.79;
            family inet {
                any;
            }
            family inet-vpn {
                any;
            }
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface lo0.0;
            interface all;
            interface fxp0.0 {
                disable;
            }
        }
    }
    ldp {
        interface all;
    }
}

Meaning

Sample Outputs 1 through 5 show the configuration of all routers in the example network shown in Aggregated Interfaces Network Topology.


Published: 2010-01-30