Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    family (for EX Series switches)

    Syntax

    family ccc

    family ccc;

    family ethernet-switching

    family ethernet-switching { filter input filter-name; filter output filter-name; native-vlan-id vlan-id; port-mode mode; vlan { members [ (all | names | vlan-ids) ];}}

    family inet

    family inet {address address {primary;vrrp-group group-id {advertise-interval milliseconds;preempt | no-preempt {hold-time seconds;}priority number;virtual-address [addresses];virtual-link-local-address ip-address;}} filter input filter-name; filter output filter-name; primary;rpf-check;targeted-broadcast;}

    family inet6

    family inet6 {address address {primary;vrrp-inet6-group group-id {inet6-advertise-interval milliseconds;preempt | preempt {hold-time seconds;}priority number;virtual-inet6-address [addresses];virtual-link-local-address ipv6–address;}} filter input filter-name; filter output filter-name; policer input policer-name; policer output policer-name;rpf-check;}

    family iso

    family iso {address interface-address;}

    family mpls

    family mpls;

    Hierarchy Level

    [edit interfaces (for EX Series switches) interface-name unit logical-unit-number]

    Release Information

    Statement introduced in JUNOS Release 9.0 for EX Series switches, including options ethernet-switching, inet, and iso.

    Option inet6 introduced in JUNOS Release 9.3 for EX Series switches.

    Options ccc and mpls introduced in JUNOS Release 9.5 for EX Series switches.

    Description

    Configure protocol family information for the logical interface on the switch.

    Most standard JUNOS Software configuration statements are available in JUNOS Software for EX Series switches. This topic lists standard JUNOS Software statements that you commonly use when configuring protocol families for interfaces on EX Series switches as well as statements that are used to configure protocol families only on switch interfaces. For information about additional standard JUNOS Software statements that you can configure on interfaces, see the JUNOS Software Network Interfaces Configuration Guide at https://www.juniper.net/techpubs/software/junos/index.html.

    Default

    Access interfaces on EX2200, EX3200, EX4200, and EX4500 switches are set to family ethernet-switching by default. If you are going to change the family setting for an interface, you might have to delete this default setting or any user-configured family setting before you change the setting to another family type.

    EX8200 switch interfaces do not have a default family setting.

    You must configure a logical interface to be able to use the physical device.

    Options

    See Table 1 for protocol families available on the switch interfaces. Different protocol families support different subsets of the interfaces types on the switch.

    Interface types on the switch are:

    • Aggregated Ethernet (ae)
    • Gigabit Ethernet (ge)
    • Interface-range configuration (interface-range)
    • Loopback (lo0)
    • Management Ethernet (me0)
    • Routed VLAN interface (RVI) (vlan)
    • Virtual management Ethernet (vme)
    • 10-Gigabit Ethernet (xe)

    If you are using an interface range, the supported protocol families are the ones supported by the interface types that compose the range.

    Not all interface types support all family substatements. Check your switch CLI for supported substatements for a particular protocol family configuration.

    Table 1: Protocol Families and Supported Interface Types

    FamilyDescriptionSupported Interface Types
    ae ge lo0 me0 vlanvme xe

    ccc

    Circuit cross-connect protocol family

     

    ethernet-
    switching

    Ethernet switching protocol family

     

      

    inet

    IPv4 protocol family

    inet6

    IPv6 protocol family

    iso

    JUNOS protocol family for IS-IS traffic

    mpls

    MPLS protocol family

     

    The remaining statements are explained separately.

    Required Privilege Level

    interface—To view this statement in the configuration.
    interface-control—To add this statement to the configuration.

    Published: 2011-05-11