Technical Documentation

Example: Configuring MBGP Multicast VPNs

This example provides a step-by-step procedure to configure multicast services across a multiprotocol BGP (MBGP) Layer 3 virtual private network.

Before You Begin

Depending on the devices you are using, you might be required to configure static routes to:

  • The multicast sender
  • The Fast Ethernet interface to which the sender is connected on the multicast receiver
  • The multicast receiver
  • The Fast Ethernet interface to which the receiver is connected on the multicast sender

Overview and Topology

This example configures the following technologies:

  • IPv4
  • BGP
  • OSPF
  • RSVP
  • MPLS
  • PIM sparse mode
  • Static RP

The topology of the network is shown in Figure 1.

Figure 1: Multicast Over Layer 3 VPN Example Topology

Image g016920.gif

Configuration

Note: In any configuration session it is a good practice to periodically verify that the configuration can be committed using the commit check command.

In this example, the router being configured is identified using the following command prompts:

  • ce1 identifies the customer edge 1 (CE1) router
  • pe1 identifies the provider edge 1 (PE1) router
  • p identifies the provider core (P) router
  • ce2 identifies the customer edge 2 (CE2) router
  • pe2 identifies the provider edge 2 (PE2) router

To configure MBGP multicast VPNs for the network shown in Figure 1, perform the following steps:

Configuring Interfaces

Step-by-Step Procedure

  1. On each router, configure an IP address on the loopback logical interface 0 (lo0.0).
    user@ce1# set interfaces lo0 unit 0 family inet address 192.168.6.1/32 primaryuser@pe1# set interfaces lo0 unit 0 family inet address 192.168.7.1/32 primaryuser@p# set interfaces lo0 unit 0 family inet address 192.168.8.1/32 primaryuser@pe2# set interfaces lo0 unit 0 family inet address 192.168.9.1/32 primaryuser@ce2# set interfaces lo0 unit 0 family inet address 192.168.0.1/32 primary

    Use the show interfaces terse command to verify that the IP address is correct on the loopback logical interface.

  2. On the PE and CE routers, configure the IP address and protocol family on the Fast Ethernet interfaces. Specify the inet protocol family type.
    user@ce1# set interfaces fe-1/3/0 unit 0 family inet address 10.10.12.1/24user@ce1# set interfaces fe-0/1/0 unit 0 family inet address 10.0.67.13/30user@pe1# set interfaces fe-0/1/0 unit 0 family inet address 10.0.67.14/30user@pe2# set interfaces fe-0/1/0 unit 0 family inet address 10.0.90.13/30user@ce2# set interfaces fe-0/1/0 unit 0 family inet address 10.0.90.14/30user@ce2# set interfaces fe-1/3/0 unit 0 family inet address 10.10.11.1/24

    Use the show interfaces terse command to verify that the IP address is correct on the Fast Ethernet interfaces.

  3. On the PE and P routers, configure the ATM interfaces' VPI and maximum VCs. If the default PIC type is different on directly connected ATM interfaces, configure the PIC type to be the same. Configure the logical interface VCI, protocol family, local IP address, and destination IP address.
    user@pe1# set interfaces at-0/2/0 atm-options pic-type atm1 user@pe1# set interfaces at-0/2/0 atm-options vpi 0 maximum-vcs 256user@pe1# set interfaces at-0/2/0 unit 0 vci 0.128user@pe1# set interfaces at-0/2/0 unit 0 family inet address 10.0.78.5/32 destination 10.0.78.6user@p# set interfaces at-0/2/0 atm-options pic-type atm1user@p# set interfaces at-0/2/0 atm-options vpi 0 maximum-vcs 256user@p# set interfaces at-0/2/0 unit 0 vci 0.128user@p# set interfaces at-0/2/0 unit 0 family inet address 10.0.78.6/32 destination 10.0.78.5user@p# set interfaces at-0/2/1 atm-options pic-type atm1user@p# set interfaces at-0/2/1 atm-options vpi 0 maximum-vcs 256user@p# set interfaces at-0/2/1 unit 0 vci 0.128user@p# set interfaces at-0/2/1 unit 0 family inet address 10.0.89.5/32 destination 10.0.89.6user@pe2# set interfaces at-0/2/1 atm-options pic-type atm1user@pe2# set interfaces at-0/2/1 atm-options vpi 0 maximum-vcs 256user@pe2# set interfaces at-0/2/1 unit 0 vci 0.128user@pe2# set interfaces at-0/2/1 unit 0 family inet address 10.0.89.6/32 destination 10.0.89.5

    Use the show configuration interfaces command to verify that the ATM interfaces' VPI and maximum VCs are correct and that the logical interface VCI, protocol family, local IP address, and destination IP address are correct.

Configuring OSPF

Step-by-Step Procedure

  1. On the P and PE routers, configure the provider instance of Open Shortest Path First (OSPF). Specify the lo0.0 and ATM core-facing logical interfaces. The provider instance of OSPF on the PE router forms adjacencies with the OSPF neighbors on the other PE router and the P router.
    user@pe1# set protocols ospf area 0.0.0.0 interface at-0/2/0.0user@pe1# set protocols ospf area 0.0.0.0 interface lo0.0user@p# set protocols ospf area 0.0.0.0 interface lo0.0user@p# set protocols ospf area 0.0.0.0 interface alluser@p# set protocols ospf area 0.0.0.0 interface fxp0 disableuser@pe2# set protocols ospf area 0.0.0.0 interface lo0.0user@pe2# set protocols ospf area 0.0.0.0 interface at-0/2/1.0

    Use the show ospf interfaces command to verify that the lo0.0 and ATM core-facing logical interfaces are configured for OSPF.

  2. On the CE routers, configure the customer instance of Open Shortest Path First (OSPF). Specify the loopback and Fast Ethernet logical interfaces . The customer instance of OSPF on the CE routers form adjacencies with the neighbors within the VPN routing instance of OSPF on the PE routers.
    user@ce1# set protocols ospf area 0.0.0.0 interface fe-0/1/0.0user@ce1# set protocols ospf area 0.0.0.0 interface fe-1/3/0.0user@ce1# set protocols ospf area 0.0.0.0 interface lo0.0user@ce2# set protocols ospf area 0.0.0.0 interface fe-0/1/0.0user@ce2# set protocols ospf area 0.0.0.0 interface fe-1/3/0.0user@ce2# set protocols ospf area 0.0.0.0 interface lo0.0

    Use the show ospf interfaces command to verify that the correct loopback and Fast Ethernet logical interfaces have been added to the OSPF protocol.

  3. On the P and PE routers, configure OSPF traffic engineering support for the provider instance of OSPF.

    The shortcuts statement enables the master instance of OSPF to use a label-switched path as the next hop.

    user@pe1# set protocols ospf traffic-engineering shortcutsuser@p# set protocols ospf traffic-engineering shortcutsuser@pe2# set protocols ospf traffic-engineering shortcuts

    Use the show ospf overview or show configuration protocols ospf command to verify that traffic engineering support is enabled.

Configuring BGP

Step-by-Step Procedure

  1. On the P router, configure BGP for the VPN. The local address is the local lo0.0 address. The neighbor addresses are the PE routers' lo0.0 addresses.

    The unicast statement enables the router to use BGP to advertise network layer reachability information (NLRI). The signaling statement enables the router to use BGP as the signaling protocol for the VPN.

    user@p# set protocols bgp group group-mvpn type internaluser@p# set protocols bgp group group-mvpn local-address 192.168.8.1user@p# set protocols bgp group group-mvpn family inet unicastuser@p# set protocols bgp group group-mvpn family inet-mvpn signalinguser@p# set protocols bgp group group-mvpn neighbor 192.168.9.1user@p# set protocols bgp group group-mvpn neighbor 192.168.7.1

    Use the show configuration protocols bgp command to verify that the router has been configured to use BGP to advertise NLRI.

  2. On the PE and P routers, configure the BGP local autonomous system number.
    user@pe1# set routing-options autonomous-system 0.65010user@p# set routing-options autonomous-system 0.65010user@pe2# set routing-options autonomous-system 0.65010

    Use the show configuration routing-options command to verify that the BGP local autonomous system number is correct.

  3. On the PE routers, configure BGP for the VPN. Configure the local address as the local lo0.0 address. The neighbor addresses are the lo0.0 addresses of the P router and the other PE router.
    user@pe1# set protocols bgp group group-mvpn type internaluser@pe1# set protocols bgp group group-mvpn local-address 192.168.7.1user@pe1# set protocols bgp group group-mvpn family inet-vpn unicastuser@pe1# set protocols bgp group group-mvpn family inet-mvpn signalinguser@pe1# set protocols bgp group group-mvpn neighbor 192.168.9.1user@pe1# set protocols bgp group group-mvpn neighbor 192.168.8.1user@pe2# set protocols bgp group group-mvpn type internaluser@pe2# set protocols bgp group group-mvpn local-address 192.168.9.1user@pe2# set protocols bgp group group-mvpn family inet-vpn unicastuser@pe2# set protocols bgp group group-mvpn family inet-mvpn signalinguser@pe2# set protocols bgp group group-mvpn neighbor 192.168.7.1user@pe2# set protocols bgp group group-mvpn neighbor 192.168.8.1

    Use the show bgp group command to verify that the BGP configuration is correct.

  4. On the PE routers, configure a policy to export the BGP routes into OSPF.
    user@pe1# set policy-options policy-statement bgp-to-ospf from protocol bgpuser@pe1# set policy-options policy-statement bgp-to-ospf then acceptuser@pe2# set policy-options policy-statement bgp-to-ospf from protocol bgpuser@pe2# set policy-options policy-statement bgp-to-ospf then accept

    Use the show policy bgp-to-ospf command to verify that the policy is correct.

Configuring RSVP

Step-by-Step Procedure

  1. On the PE routers, enable RSVP on the interfaces that participate in the LSP. Configure the Fast Ethernet and ATM logical interfaces.
    user@pe1# set protocols rsvp interface fe-0/1/0.0user@pe1# set protocols rsvp interface at-0/2/0.0user@pe2# set protocols rsvp interface fe-0/1/0.0 user@pe2# set protocols rsvp interface at-0/2/1.0
  2. On the P router, enable RSVP on the interfaces that participate in the LSP. Configure the ATM logical interfaces.
    user@p# set protocols rsvp interface at-0/2/0.0user@p# set protocols rsvp interface at-0/2/1.0

    Use the show configuration protocols rsvp command to verify that the RSVP configuration is correct.

Configuring MPLS

Step-by-Step Procedure

  1. On the PE routers, configure an MPLS LSP to the PE router that is the LSP egress point. Specify the IP address of the lo0.0 interface on the router at the other end of the LSP. Configure MPLS on the ATM, Fast Ethernet, and lo0.0 interfaces.

    To help identify each LSP when troubleshooting, configure a different LSP name on each PE router. In this example we use the name to-pe2 as the name for the LSP configured on PE1 and to-pe1 as the name for the LSP configured on PE2.

    user@pe1# set protocols mpls label-switched-path to-pe2 to 192.168.9.1user@pe1# set protocols mpls interface fe-0/1/0.0user@pe1# set protocols mpls interface at-0/2/0.0user@pe1# set protocols mpls interface lo0.0user@pe2# set protocols mpls label-switched-path to-pe1 to 192.168.7.1user@pe2# set protocols mpls interface fe-0/1/0.0user@pe2# set protocols mpls interface at-0/2/1.0user@pe2# set protocols mpls interface lo0.0

    Use the show configuration protocols mpls and show route label-switched-path to-pe1 commands to verify that the MPLS and LSP configuration is correct.

    After the configuration is committed, use the show mpls lsp name to-pe1 and show mpls lsp name to-pe2 commands to verify that the LSP is operational.

  2. On the P router, enable MPLS. Specify the ATM interfaces connected to the PE routers.
    user@p# set protocols mpls interface at-0/2/0.0user@p# set protocols mpls interface at-0/2/1.0

    Use the show mpls interface command to verify that MPLS is enabled on the ATM interfaces.

  3. On the PE and P routers, configure the protocol family on the ATM interfaces associated with the LSP. Specify the mpls protocol family type.
    user@pe1# set interfaces at-0/2/0 unit 0 family mplsuser@p# set interfaces at-0/2/0 unit 0 family mplsuser@p# set interfaces at-0/2/1 unit 0 family mplsuser@pe2# set interfaces at-0/2/1 unit 0 family mpls

    Use the show mpls interface command to verify that the MPLS protocol family is enabled on the ATM interfaces associated with the LSP.

Configuring the VRF Routing Instance

Step-by-Step Procedure

  1. On the PE routers, configure a routing instance for the VPN and specify the vrf instance type. Add the Fast Ethernet and lo0.1 customer-facing interfaces. Configure the VPN instance of OSPF and include the BGP-to-OSPF export policy.
    user@pe1# set routing-instances vpn-a instance-type vrfuser@pe1# set routing-instances vpn-a interface lo0.1user@pe1# set routing-instances vpn-a interface fe-0/1/0.0user@pe1# set routing-instances vpn-a protocols ospf export bgp-to-ospfuser@pe1# set routing-instances vpn-a protocols ospf area 0.0.0.0 interface alluser@pe2# set routing-instances vpn-a instance-type vrfuser@pe2# set routing-instances vpn-a interface lo0.1user@pe2# set routing-instances vpn-a interface fe-0/1/0.0user@pe2# set routing-instances vpn-a protocols ospf export bgp-to-ospfuser@pe2# set routing-instances vpn-a protocols ospf area 0.0.0.0 interface all

    Use the show configuration routing-instances vpn-a command to verify that the routing instance configuration is correct.

  2. On the PE routers, configure a route distinguisher for the routing instance. A route distinguisher allows the router to distinguish between two identical IP prefixes used as VPN routes. Configure a different route distinguisher on each PE router. This example uses 65010:1 on PE1 and 65010:2 on PE2.
    user@pe1# set routing-instances vpn-a route-distinguisher 65010:1user@pe2# set routing-instances vpn-a route-distinguisher 65010:2

    Use the show configuration routing-instances vpn-a command to verify that the route distinguisher is correct.

  3. On the PE routers, configure default VRF import and export policies. Based on this configuration, BGP automatically generates local routes corresponding to the route target referenced in the VRF import policies. This example uses 2:1 as the route target.

    Note: You must configure the same route target on each PE router for a given VPN routing instance.

    user@pe1# set routing-instances vpn-a vrf-target target:2:1user@pe2# set routing-instances vpn-a vrf-target target:2:1

    Use the show configuration routing-instances vpn-a command to verify that the route target is correct.

  4. On the PE routers, configure the VPN routing instance for multicast support.
    user@pe1# set routing-instances vpn-a protocols mvpnuser@pe2# set routing-instances vpn-a protocols mvpn

    Use the show configuration routing-instance vpn-a command to verify that the VPN routing instance has been configured for multicast support.

  5. On the PE routers, configure an IP address on the loopback logical interface 1 (lo0.1) used in the customer routing instance VPN.
    user@pe1# set interfaces lo0 unit 1 family inet address 10.10.47.101/32user@pe2# set interfaces lo0 unit 1 family inet address 10.10.47.100/32

    Use the show interfaces terse command to verify that the IP address on the loopback logical interface 1 is correct.

Configuring PIM

Step-by-Step Procedure

  1. On the PE and P routers, enable the provider instance of PIM. Add the core-facing ATM interfaces. On the PE routers, also configure the lo0.0 interface. Specify the mode as sparse and the version as 2.
    user@pe1# set protocols pim interface at-0/2/0.0 mode sparse user@pe1# set protocols pim interface at-0/2/0.0 version 2user@pe1# set protocols pim interface lo0.0 mode sparseuser@pe1# set protocols pim interface lo0.0 version 2user@p# set protocols pim interface at-0/2/0.0 mode sparse user@p# set protocols pim interface at-0/2/0.0 version 2user@p# set protocols pim interface at-0/2/1.0 mode sparseuser@p# set protocols pim interface at-0/2/1.0 version 2user@pe2# set protocols pim interface at-0/2/1.0 mode sparse user@pe2# set protocols pim interface at-0/2/1.0 version 2user@pe2# set protocols pim interface lo0.0 mode sparseuser@pe2# set protocols pim interface lo0.0 version 2

    Use the show pim interfaces command to verify that PIM sparse-mode is enabled on the core-facing ATM interfaces.

  2. On the PE routers, enable the VPN customer instance of PIM. Configure the lo0.1 and the customer-facing Fast Ethernet interface. Specify the mode as sparse and the version as 2.
    user@pe1# set routing-instances vpn-a protocols pim interface lo0.1 mode sparse user@pe1# set routing-instances vpn-a protocols pim interface lo0.1 version 2 user@pe1# set routing-instances vpn-a protocols pim interface fe-0/1/0.0 mode sparseuser@pe1# set routing-instances vpn-a protocols pim interface fe-0/1/0.0 version 2user@pe2# set routing-instances vpn-a protocols pim interface lo0.1 mode sparse user@pe2# set routing-instances vpn-a protocols pim interface lo0.1 version 2 user@pe2# set routing-instances vpn-a protocols pim interface fe-0/1/0.0 mode sparseuser@pe2# set routing-instances vpn-a protocols pim interface fe-0/1/0.0 version 2

    Use the show pim interfaces instance vpn-a command to verify that PIM sparse-mode is enabled on the lo0.1 interface and the customer-facing Fast Ethernet interface.

  3. On the CE routers, enable the customer instance of PIM. In this example we configure all interfaces. Specify the mode as sparse and the version as 2.
    user@ce1# set protocols pim interface alluser@ce2# set protocols pim interface all mode sparseuser@ce2# set protocols pim interface all version 2

    Use the show pim interfaces command to verify that PIM sparse mode is enabled on all interfaces.

Configuring the Provider Tunnel

Step-by-Step Procedure

  1. On the PE1 router, configure the provider tunnel. Specify the multicast address to be used.

    The provider-tunnel statement instructs the router to send multicast traffic across a tunnel. The pim-asm statement instructs the router to accept the multicast stream from any source.

    user@pe1# set routing-instances vpn-a provider-tunnel pim-asm group-address 224.1.1.1

    Use the show configuration routing-instance vpn-a command to verify that the multicast group address is correct on Router PE1.

  2. On the PE2 router, configure the provider tunnel. Specify the multicast address to be used.
    user@pe2# set routing-instances vpn-a provider-tunnel pim-asm group-address 224.1.1.1

    Use the show configuration routing-instance vpn-a command to verify that the multicast group address is correct on Router PE2.

Configuring the Rendezvous Point

Step-by-Step Procedure

  1. Configure the PE1 router to be the rendezvous point for the provider instance of PIM. Specify the lo0.0 address of the PE1 router.
    user@pe1# set protocols pim rp local address 192.168.7.1

    Use the show pim rps command to verify that to correct local IP address is configured for the provider instance RP.

  2. Configure the static rendezvous point on the P router and PE2 router for the provider instance of PIM. Specify the lo0.0 address of the PE1 router. Specify the version as 2.
    user@p# set protocols pim rp static address 192.168.7.1 version 2user@pe2# set protocols pim rp static address 192.168.7.1 version 2

    Use the show pim rps command to verify that the correct static IP address is configured for the provider instance RP.

  3. Configure the PE1 router to be the rendezvous point for the customer instance of PIM. Specify the lo0.1 address of the PE1 router. Specify the multicast address to be used.
    user@pe1# set routing-instances vpn-a protocols pim rp local address 10.10.47.101user@pe1# set routing-instances vpn-a protocols pim rp local group-ranges 224.1.1.1/32

    Use the show pim rps instance vpn-a command to verify that the correct local IP address is configured for the customer instance RP.

  4. On the PE2 router, configure the static rendezvous point for the customer instance of PIM. Specify the lo0.1 address of the PE1 router.
    user@pe2# set routing-instances vpn-a protocols pim rp static address 10.10.47.101

    Use the show pim rps instance vpn-a command to verify that the correct static IP address is configured for the customer instance RP.

  5. On the CE routers, configure the static rendezvous point for the customer instance of PIM. Specify the lo0.1 address of the PE1 router.
    user@ce1# set protocols pim rp static address 10.10.47.101 version 2user@ce2# set protocols pim rp static address 10.10.47.101 version 2

    Use the show pim rps command to verify that the correct static IP address is configured for the customer instance RP.

  6. Use the commit check command to verify that the configuration can be successfully committed. If the configuration passes the check, commit the configuration.
  7. Start the multicast sender device connected to CE1.
  8. Start the multicast receiver device connected to CE2.
  9. Verify that the receiver is receiving the multicast stream.
  10. Use show commands to verify the routing, VPN, and multicast operation.

Results

The configuration and verification parts of this example have been completed. The following section is for your reference.

The relevant sample configuration for the CE1 router follows.

Router CE1

interfaces {lo0 {unit 0 {family inet {address 192.168.6.1/32 {primary;}}}}fe-0/1/0 {unit 0 {family inet {address 10.0.67.13/30;}}}fe-1/3/0 {unit 0 {family inet {address 10.10.12.1/24;}}}}protocols {ospf {area 0.0.0.0 {interface fe-0/1/0.0;interface lo0.0;interface fe-1/3/0.0;}}pim {rp {static {address 10.10.47.101 {version 2;}}}interface all;}}

The relevant sample configuration for the PE1 router follows.

Router PE1

interfaces {lo0 {unit 0 {family inet {address 192.168.7.1/32 {primary;}}}}fe-0/1/0 {unit 0 {family inet {address 10.0.67.14/30;}}}at-0/2/0 {atm-options {pic-type atm1;vpi 0 {maximum-vcs 256;}}unit 0 {vci 0.128;family inet {address 10.0.78.5/32 {destination 10.0.78.6;}}family mpls;}}lo0 {unit 1 {family inet {address 10.10.47.101/32;}}}}routing-options {autonomous-system 0.65010;}protocols {rsvp {interface fe-0/1/0.0;interface at-0/2/0.0;}mpls {label-switched-path to-pe2 {to 192.168.9.1;}interface fe-0/1/0.0;interface at-0/2/0.0;interface lo0.0;}bgp {group group-mvpn {type internal;local-address 192.168.7.1;family inet-vpn {unicast;}family inet-mvpn {signaling;}neighbor 192.168.9.1;neighbor 192.168.8.1;}}ospf {traffic-engineering {shortcuts;}area 0.0.0.0 {interface at-0/2/0.0;interface lo0.0;}}pim {rp {local {address 192.168.7.1;}}interface at-0/2/0.0 {mode sparse;version 2;}interface lo0.0 {mode sparse;version 2;}}}policy-options {policy-statement bgp-to-ospf {from protocol bgp;then accept;}}routing-instances {vpn-a {instance-type vrf;interface lo0.1;interface fe-0/1/0.0;route-distinguisher 65010:1;provider-tunnel {pim-asm {group-address 224.1.1.1;}}vrf-target target:2:1;protocols {ospf {export bgp-to-ospf;area 0.0.0.0 {interface all;}}pim {rp {local {address 10.10.47.101;group-ranges {224.1.1.1/32;}}}interface lo0.1 {mode sparse;version 2;}interface fe-0/1/0.0 {mode sparse;version 2;}}mvpn;}}}

The relevant sample configuration for the P router follows.

Router P

interfaces {lo0 {unit 0 {family inet {address 192.168.8.1/32 {primary;}}}}at-0/2/0 {atm-options {pic-type atm1;vpi 0 {maximum-vcs 256;}}unit 0 {vci 0.128;family inet {address 10.0.78.6/32 {destination 10.0.78.5;}}family mpls;}}at-0/2/1 {atm-options {pic-type atm1;vpi 0 {maximum-vcs 256;}}unit 0 {vci 0.128;family inet {address 10.0.89.5/32 {destination 10.0.89.6;}}family mpls;}}}routing-options {autonomous-system 0.65010;}protocols {rsvp {interface at-0/2/0.0;interface at-0/2/1.0;}mpls {interface at-0/2/0.0;interface at-0/2/1.0;}bgp {group group-mvpn {type internal;local-address 192.168.8.1;family inet {unicast;}family inet-mvpn {signaling;}neighbor 192.168.9.1;neighbor 192.168.7.1;}}ospf {traffic-engineering {shortcuts;}area 0.0.0.0 {interface lo0.0;interface all;interface fxp0.0 {disable;}}}pim {rp {static {address 192.168.7.1 {version 2;}}}interface at-0/2/0.0 {mode sparse;version 2;}interface at-0/2/1.0 {mode sparse;version 2;}}}

The relevant sample configuration for the PE2 router follows.

Router PE2

interfaces {lo0 {unit 0 {family inet {address 192.168.9.1/32 {primary;}}}}fe-0/1/0 {unit 0 {family inet {address 10.0.90.13/30;}}}at-0/2/1 {atm-options {pic-type atm1;vpi 0 {maximum-vcs 256;}}unit 0 {vci 0.128;family inet {address 10.0.89.6/32 {destination 10.0.89.5;}}family mpls;}}lo0 {unit 1 {family inet {address 10.10.47.100/32;}}}}routing-options {autonomous-system 0.65010;}protocols {rsvp {interface fe-0/1/0.0;interface at-0/2/1.0;}mpls {label-switched-path to-pe1 {to 192.168.7.1;}interface lo0.0;interface fe-0/1/0.0;interface at-0/2/1.0;}bgp {group group-mvpn {type internal;local-address 192.168.9.1;family inet-vpn {unicast;}family inet-mvpn {signaling;}neighbor 192.168.7.1;neighbor 192.168.8.1;}}ospf {traffic-engineering {shortcuts;}area 0.0.0.0 {interface lo0.0;interface at-0/2/1.0;}}pim {rp {static {address 192.168.7.1 {version 2;}}}interface lo0.0 {mode sparse;version 2;}interface at-0/2/1.0 {mode sparse;version 2;}}}policy-options {policy-statement bgp-to-ospf {from protocol bgp;then accept;}}routing-instances {vpn-a {instance-type vrf;interface fe-0/1/0.0;interface lo0.1;route-distinguisher 65010:2;provider-tunnel {pim-asm {group-address 224.1.1.1;}}vrf-target target:2:1;protocols {ospf {export bgp-to-ospf;area 0.0.0.0 {interface all;}}pim {rp {static {address 10.10.47.101;}}interface fe-0/1/0.0 {mode sparse;version 2;}interface lo0.1 {mode sparse;version 2;}}mvpn;}}}

The relevant sample configuration for the CE2 router follows.

Router CE2

interfaces {lo0 {unit 0 {family inet {address 192.168.0.1/32 {primary;}}}}fe-0/1/0 {unit 0 {family inet {address 10.0.90.14/30;}}}fe-1/3/0 {unit 0 {family inet {address 10.10.11.1/24;}family inet6 {address fe80::205:85ff:fe88:ccdb/64;}}}}protocols {ospf {area 0.0.0.0 {interface fe-0/1/0.0;interface lo0.0;interface fe-1/3/0.0;}}pim {rp {static {address 10.10.47.101 {version 2;}}}interface all {mode sparse;version 2;}}}

Published: 2010-04-15