Technical Documentation

Router Configurations for Bandwidth Load Balancing

Purpose

The configuration in this topic is for ingress router R1 in the example network illustrated in RSVP Bandwidth Network. The configuration for the other five routers in the network are the same as those found in Router Configurations for the Load-Balanced MPLS Network.

Action

To display a router configuration, use the following JUNOS CLI operational mode command:

user@host> show configuration | no-more

Sample Output

user@R1> show configuration | no-more 
[....Output truncated...]
interfaces {
    fe-0/1/0 {
        unit 0 {
            family inet {
                address 10.0.12.13/30;
            }
            family mpls;
        }
    }
    fe-0/1/2 {
        unit 0 {
            family inet {
                address 10.0.16.13/30;
            }
            family mpls;
        }
    }
    fxp0 {
        unit 0 {
            family inet {
                address 192.168.70.143/21;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 192.168.1.1/32;
            }
        }
    }
}
routing-options {
    static {
        [...Output truncated...]
        }
        route 100.100.1.0/24 reject;
    }
    router-id 192.168.1.1;
    autonomous-system 65432;
    forwarding-table {
        export lbpp;
    }
}
protocols {
    rsvp {
         load-balance bandwidth; #RSVP bandwidth load balancing
        interface fe-0/1/0.0;
        interface fe-0/1/2.0;
        interface fxp0.0 {
            disable;
        }
    }
    mpls {
        label-switched-path lsp1 {
            to 192.168.0.1;
            install 10.0.90.14/32 active;
             bandwidth 10m; #Bandwidth configured for each LSP
            primary via-r4;
        }
        label-switched-path lsp2 {
            to 192.168.0.1;
            install 10.0.90.14/32 active;
             bandwidth 20m; #Bandwidth configured for each LSP
            primary via-r2;
        }
        label-switched-path lsp3 {
            to 192.168.0.1;
            install 10.0.90.14/32 active;
             bandwidth 30m; #Bandwidth configured for each LSP
            primary via-r2;
        }
        label-switched-path lsp4 {
            to 192.168.0.1;
            install 10.0.90.14/32 active;
             bandwidth 40m; #Bandwidth configured for each LSP
            primary via-r4;
        }
        path via-r2 {
            10.0.29.2 loose;
        }
        path via-r4 {
            10.0.24.2 loose;
        }
        interface fe-0/1/0.0;
        interface fe-0/1/2.0;
        interface fxp0.0 {
            disable;
        }
    }
    bgp {
        export send-statics;
        group internal {
            type internal;
            local-address 192.168.1.1;
            neighbor 192.168.2.1;
            neighbor 192.168.4.1;
            neighbor 192.168.9.1;
            neighbor 192.168.6.1;
            neighbor 192.168.0.1;
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface fe-0/1/0.0;
            interface fe-0/1/2.0;
            interface lo0.0 {
                passive;
            }
        }
    }
}
policy-options {
    policy-statement lbpp { Load balancing policy
        then {
            load-balance per-packet;
        }
    }
    policy-statement send-statics {
        term statics {
            from {
                route-filter 100.100.1.0/24 exact;
            }
            then accept;
        }
    }
}

Meaning

The sample output shows the configuration for the ingress router R1 in the example network illustrated in RSVP Bandwidth Network. The configuration for the other five routers in the network is the same as those found in Router Configurations for the Load-Balanced MPLS Network.


Published: 2010-01-30