Technical Documentation

Example: Configuring IP Directed Broadcast on an EX Series Switch

IP directed broadcast provides a method of sending broadcast packets to hosts on a specified subnet without broadcasting those packets to hosts on the entire network.

This example shows how to enable a subnet to receive IP directed broadcast packets so you can perform backups and other network management tasks remotely:

Requirements

This example uses the following software and hardware components:

  • JUNOS Release 9.4 or later for EX Series switches
  • One PC
  • One EX Series switch

Before you configure IP directed broadcast for a subnet:

Overview and Topology

You might want to perform remote administration tasks such as backups and wake-on-LAN (WOL) application tasks to manage groups of clients on a subnet. One way to do this is to send IP directed broadcast packets targeted at the hosts in a particular target subnet.

The network forwards IP directed broadcast packets as if they were unicast packets. When the IP directed broadcast packet is received by a VLAN that is enabled for targeted-broadcast, the switch broadcasts the packet to all the hosts in its subnet.

In this topology (see Figure 1), a host is connected to an interface on an EX Series switch to manage the clients in subnet 10.1.2.1/24. When the switch receives a packet with the broadcast IP address of the target subnet as its destination address, it forwards the packet to the subnet’s Layer 3 interface and broadcasts it to all the hosts within the subnet.

Figure 1: Topology for IP Directed Broadcast

Image g020304.gif

Table 1 shows the settings of the components in this example.

Table 1: Components of the IP Directed Broadcast Topology

Property Settings

Switch hardware

EX Series switch

Ingress VLAN name

v0

Ingress VLAN IP address

10.1.1.1/24

Egress VLAN name

v1

Egress VLAN IP address

10.1.2.1/24

Interfaces in VLAN v0

ge-0/0/3.0

Interfaces in VLAN v1

ge-0/0/0.0 and ge-0/0/1.0

Configuration

To configure IP directed broadcast on a subnet to enable remote management of its hosts:

CLI Quick Configuration

To quickly configure the switch to accept IP directed broadcasts targeted at subnet 10.1.2.1/24, copy the following commands and paste them into the switch’s terminal window:


[edit]


set interfaces ge-0/0/0.0 family ethernet-switching vlan members v1


set interfaces ge-0/0/1.0 family ethernet-switching vlan members v1


set interfaces vlan.1 family inet address 10.1.2.1/24


set interfaces ge-0/0/3.0 family ethernet-switching vlan members v0


set interfaces vlan.0 family inet address 10.1.1.1/24


set vlans v1 l3-interface vlan.1


set vlans v0 l3-interface vlan.0


set interfaces vlan.1 family inet targeted-broadcast

Step-by-Step Procedure

To configure the switch to accept IP directed broadcasts targeted at subnet 10.1.2.1/24:

  1. Add logical interface ge-0/0/0.0 to VLAN v1:

    [edit interfaces]
    user@switch# set ge-0/0/0.0 family ethernet-switching vlan members v1
  2. Add logical interface ge-0/0/1.0 to VLAN v1:

    [edit interfaces]
    user@switch# set ge-0/0/1.0 family ethernet-switching vlan members v1
  3. Configure the IP address for the egress VLAN, v1:

    [edit interfaces]
    user@switch# set vlan.1 family inet address 10.1.2.1/24
  4. Add logical interface ge-0/0/3.0 to VLAN v0:

    [edit interfaces]
    user@switch# set ge-0/0/3.0 family ethernet-switching vlan members v0
  5. Configure the IP address for the ingress VLAN:

    [edit interfaces]
    user@switch# set vlan.0 family inet address 10.1.1.1/24
  6. To route traffic between the ingress and egress VLANs, associate a Layer 3 interface with each VLAN:

    [edit vlans]
    user@switch# set v1 l3-interfacevlan.1
    user@switch# set v0 l3–interface vlan.0
  7. Enable the Layer 3 interface for the egress VLAN to receive IP directed broadcasts:

    [edit interfaces]
    user@switch# set vlan.1 family inet targeted-broadcast

Results

Check the results:

user@switch# show
interfaces {
ge-0/0/0 {
unit 0 {
family ethernet-switching {
vlan {
members v1;
}
}
}
}
ge-0/0/1 {
unit 0 {
family ethernet-switching {
vlan {
members v1;
}
}
}
}
ge-0/0/3 {
unit 0 {
family ethernet-switching {
vlan {
members v0;
}
}
}
}
vlan {
unit 0 {
family inet {
targeted-broadcast;
address 10.1.1.1/24;
}
}
unit 1 {
family inet {
targeted-broadcast;
address 10.1.2.1/24;
}
}
}
vlans {
default;
v0 {
l3-interface vlan.0;
}
v1 {
l3-interface vlan.1;
}
}

Published: 2009-07-22