Technical Documentation

Example: Configuring CoS on EX Series Switches

Configure class of service (CoS) on your switch to manage traffic so that when the network experiences congestion and delay, critical applications are protected. Using CoS, you can divide traffic on your switch into classes and provide various levels of throughput and packet loss. This is especially important for traffic that is sensitive to jitter and delay, such as voice traffic.

This example shows how to configure CoS on a single EX Series switch in the network.

Requirements

This example uses the following hardware and software components:

  • JUNOS Release 9.0 or later for EX Series switches
  • One Juniper Networks EX3200 switch

Overview and Topology

This example uses the topology shown in Figure 1.

Figure 1: Topology for Configuring CoS

Image g020033-140.gif

The topology for this configuration example consists of one EX Series switch at the access layer.

The EX Series access switch is configured to support VLAN membership. Switch ports ge-0/0/0and ge-0/0/1 are assigned to the voice-vlan for two VoIP phones. Switch port ge-0/0/2 is assigned to the camera-vlan for the surveillance camera. Switch ports ge-0/0/3, ge-0/0/4, ge-0/0/5, and ge-0/0/6 are assigned to the server-vlan for the servers hosting various applications such as those provided by Citrix, Microsoft, Oracle, and SAP.

Table 1 shows the VLAN configuration components.

Table 1: Configuration Components: VLANs

VLAN Name

VLAN ID

VLAN Subnet and Available IP Addresses

VLAN Description

voice-vlan

10

192.168.1.0/32
192.168.1.1 through 192.168.1.11

192.168.1.12 is the subnet’s broadcast address.

Voice VLAN used for employee VoIP communication.

camera-vlan

20

192.168.1.13/32
192.168.1.14 through 192.168.1.20

192.168.1.21 is the subnet’s broadcast address.

VLAN for the surveillance cameras.

server-vlan

30

192.168.1.22/32
192.168.1.23 through 192.168.1.35

192.168.1.36 is the subnet’s broadcast address.

VLAN for the servers hosting enterprise applications.

Ports on the EX Series switches support Power over Ethernet (PoE) to provide both network connectivity and power for VoIP telephones connecting to the ports. Table 2 shows the switch interfaces that are assigned to the VLANs and the IP addresses for devices connected to the switch ports:

Table 2: Configuration Components: Switch Ports on a 48-Port All-PoE Switch

Interfaces

VLAN Membership

IP Addresses

Port Devices

ge-0/0/0, ge-0/0/1

voice-vlan

192.168.1.1 through 192.168.1.2

Two VoIP telephones.

ge-0/0/2

camera-vlan

192.168.1.14

Surveillance camera.

ge-0/0/3, ge-0/0/4, ge-0/0/5, ge-0/0/6

sevrer-vlan

192.168.1.23 through 192.168.1.26

Four servers hosting applications such as those provided by Citrix, Microsoft, Oracle, and SAP.

Note: This example shows how to configure CoS on a single EX Series switch. This example does not consider across-the-network applications of CoS in which you might implement different configurations on ingress and egress switches to provide differentiated treatment to different classes across a set of nodes in a network.

Configuration

CLI Quick Configuration

To quickly configure CoS, copy the following commands and paste them into the switch terminal window:


[edit]
set class-of-service forwarding-classes class app queue-num 5
set class-of-service forwarding-classes class mail queue-num 1
set class-of-service forwarding-classes class db queue-num 2
set class-of-service forwarding-classes class erp queue-num 3
set class-of-service forwarding-classes class video queue-num 4
set class-of-service forwarding-classes class best-effort queue-num 0
set class-of-service forwarding-classes class voice queue-num 6
set class-of-service forwarding-classes class network-control queue-num 7
set firewall family ethernet-switching filter voip_class term voip from source-address 192.168.1.1/32
set firewall family ethernet-switching filter voip_class term voip from source-address 192.168.1.2/32
set firewall family ethernet-switching filter voip_class term voip from protocol udp
set firewall family ethernet-switching filter voip_class term voip from source-port 2698
set firewall family ethernet-switching filter voip_class term voip then forwarding-class voice loss-priority low
set firewall family ethernet-switching filter voip_class term network_control from precedence [net-control internet-control]
set firewall family ethernet-switching filter voip_class term network_control then forwarding-class network-control loss-priority low
set firewall family ethernet-switching filter voip_class term best_effort_traffic then forwarding-class best-effort loss-priority low
set interfaces ge-0/0/0 description phone1–voip-ingress-port
set interfaces ge-0/0/0 unit 0 family ethernet-switching filter input voip_class
set interfaces ge-0/0/1 description phone2–voip-ingress-port
set interfaces ge-0/0/1 unit 0 family ethernet-switching filter input voip_class
set firewall family ethernet-switching filter video_class term video from source-address 192.168.1.14/32
set firewall family ethernet-switching filter video_class term video from protocol udp
set firewall family ethernet-switching filter video_class term video from source-port 2979
set firewall family ethernet-switching filter video_class term video then forwarding-class video loss-priority low
set firewall family ethernet-switching filter video_class term network_control from precedence [net-control internet-control]
set firewall family ethernet-switching filter video_class term network_control then forwarding-class network-control loss-priority low
set firewall family ethernet-switching filter video_class term best_effort_traffic then forwarding-class best-effort loss-priority low
set interfaces ge-0/0/2 description video-ingress-port
set interfaces ge-0/0/2 unit 0 family ethernet-switching filter input video_class
set firewall family ethernet-switching filter app_class term app from source-address 192.168.1.23/32
set firewall family ethernet-switching filter app_class term app from protocol tcp
set firewall family ethernet-switching filter app_class term app from source-port [1494 2512 2513 2598 2897]
set firewall family ethernet-switching filter app_class term app then forwarding-class app loss-priority low
set firewall family ethernet-switching filter app_class term mail from source-address 192.168.1.24/32
set firewall family ethernet-switching filter app_class term mail from protocol tcp
set firewall family ethernet-switching filter app_class term mail from source-port [25 143 389 691 993 3268 3269]
set firewall family ethernet-switching filter app_class term mail then forwarding-class mail loss-priority low
set firewall family ethernet-switching filter app_class term db from source-address 192.168.1.25/32
set firewall family ethernet-switching filter app_class term db from protocol tcp
set firewall family ethernet-switching filter app_class term db from source-port [1521 1525 1527 1571 1810 2481]
set firewall family ethernet-switching filter app_class term db then forwarding-class db loss-priority low
set firewall family ethernet-switching filter app_class term erp from source-address 192.168.1.26/32
set firewall family ethernet-switching filter app_class term erp from protocol tcp
set firewall family ethernet-switching filter app_class term erp from source-port [3200 3300 3301 3600]
set firewall family ethernet-switching filter app_class term erp then forwarding-class erp loss-priority low
set firewall family ethernet-switching filter app_class term network_control from precedence [net-control internet-control]
set firewall family ethernet-switching filter app_class term network_control then forwarding-class network-control loss-priority low
set firewall family ethernet-switching filter app_class term best_effort_traffic then forwarding-class best-effort loss-priority low
set interfaces ge-0/0/3 unit 0 family ethernet-switching filter input app_class
set interfaces ge-0/0/4 unit 0 family ethernet-switching filter input app_class
set interfaces ge-0/0/5 unit 0 family ethernet-switching filter input app_class
set interfaces ge-0/0/6 unit 0 family ethernet-switching filter input app_class
set class-of-service schedulers voice-sched buffer-size percent 10
set class-of-service schedulers voice-sched priority strict-high
set class-of-service schedulers voice-sched transmit-rate percent 10
set class-of-service schedulers video-sched buffer-size percent 15
set class-of-service schedulers video-sched priority low
set class-of-service schedulers video-sched transmit-rate percent 15
set class-of-service schedulers app-sched buffer-size percent 10
set class-of-service schedulers app-sched priority low
set class-of-service schedulers app-sched transmit-rate percent 10
set class-of-service schedulers mail-sched buffer-size percent 5
set class-of-service schedulers mail-sched priority low
set class-of-service schedulers mail-sched transmit-rate percent 5
set class-of-service schedulers db-sched buffer-size percent 10
set class-of-service schedulers db-sched priority low
set class-of-service schedulers db-sched transmit-rate percent 10
set class-of-service schedulers erp-sched buffer-size percent 10
set class-of-service schedulers erp-sched priority low
set class-of-service schedulers erp-sched transmit-rate percent 10
set class-of-service schedulers nc-sched buffer-size percent 5
set class-of-service schedulers nc-sched priority strict-high
set class-of-service schedulers nc-sched transmit-rate percent 5
set class-of-service schedulers be-sched buffer-size percent 35
set class-of-service schedulers be-sched priority low
set class-of-service schedulers be-sched transmit-rate percent 35
set class-of-service scheduler-maps ethernet-cos-map forwarding-class voice scheduler voice-sched
set class-of-service scheduler-maps ethernet-cos-map forwarding-class video scheduler video-sched
set class-of-service scheduler-maps ethernet-cos-map forwarding-class app scheduler app-sched
set class-of-service scheduler-maps ethernet-cos-map forwarding-class mail scheduler mail-sched
set class-of-service scheduler-maps ethernet-cos-map forwarding-class db scheduler db-sched
set class-of-service scheduler-maps ethernet-cos-map forwarding-class erp scheduler erp-sched
set class-of-service scheduler-maps ethernet-cos-map forwarding-class network-control scheduler nc-sched
set class-of-service scheduler-maps ethernet-cos-map forwarding-class best-effort scheduler be-sched
set class-of-service interfaces ge-0/0/20 scheduler-map ethernet-cos-map

Step-by-Step Procedure

To configure and apply CoS:

  1. Configure one-to-one mapping between eight forwarding classes and eight queues:

    [edit class-of-service]
    user@switch# set forwarding-classes class app queue-num 5
    user@switch# set forwarding-classes class mail queue-num 1
    user@switch# set forwarding-classes class db queue-num 2
    user@switch# set forwarding-classes class erp queue-num 3
    user@switch# set forwarding-classes class video queue-num 4
    user@switch# set forwarding-classes class best-effort queue-num 0
    user@switch# set forwarding-classes class voice queue-num 6
    user@switch# set forwarding-classes class network-control queue-num 7
  2. Define the firewall filter voip_class to classify the VoIP traffic:

    [edit firewall]
    user@switch# set family ethernet-switching filter voip_class
  3. Define the term voip:

    [edit firewall]
    user@switch# set family ethernet-switching filter voip_class term voip from source-address 192.168.1.1/32
    user@switch# set family ethernet-switching filter voip_class term voip from source-address 192.168.1.2/32
    user@switch# set family ethernet-switching filter voip_class term voip protocol udp
    user@switch# set family ethernet-switching filter voip_class term voip source-port 2698
    user@switch# set family ethernet-switching filter voip_class term voip then forwarding-class voice loss-priority low
  4. Define the term network_control:

    [edit firewall]
    user@switch# set family ethernet-switching filter voip_class term network_control from precedence [net-control internet-control]
    user@switch# set family ethernet-switching filter voip_class term network_control then forwarding-class network-control loss-priority low
  5. Define the term best_effort_traffic with no match conditions:

    [edit firewall]
    user@switch# set family ethernet-switching filter voip_class term best_effort_traffic then forwarding-class best-effort loss-priority low
  6. Apply the firewall filter voip_class as an input filter to the interfaces for the VoIP phones:

    [edit interfaces]
    user@switch# set ge-0/0/0 description phone1–voip-ingress-port
    user@switch# set ge-0/0/0 unit 0 family ethernet-switching filter input voip_class
    user@switch# set ge-0/0/1 description phone2–voip-ingress-port
    user@switch# set ge-0/0/1 unit 0 family ethernet-switching filter input voip_class
  7. Define the firewall filter video_class to classify the video traffic:

    [edit firewall]
    user@switch# set family ethernet-switching filter video_class
  8. Define the term video:

    [edit firewall]
    user@switch# set family ethernet-switching filter video_class term video from source-address 192.168.1.14/32
    user@switch# set family ethernet-switching filter video_class term video protocol udp
    user@switch# set family ethernet-switching filter video_class term video source-port 2979
    user@switch# set family ethernet-switching filter video_class term video then forwarding-class video loss-priority low
  9. Define the term network_control (for the video_class filter):

    [edit firewall]
    user@switch# set family ethernet-switching filter video_class term network_control from precedence [net-control internet-control]
    user@switch# set family ethernet-switching filter video_class term network_control then forwarding-class network-control loss-priority low
  10. Define the term best_effort_traffic (for the video_class filter):

    [edit firewall]
    user@switch# set family ethernet-switching filter video_class term best_effort_traffic then forwarding-class best-effort loss-priority low
  11. Apply the firewall filter video_class as an input filter to the interface for the surveillance camera:

    [edit interfaces]
    user@switch# set ge-0/0/2 description video-ingress-port
    user@switch# set ge-0/0/2 unit 0 family ethernet-switching filter input video_class
  12. Define the firewall filter app_class to classify the application server traffic:

    [edit firewall]
    user@switch# set family ethernet-switching filter app_class
  13. Define the term app:

    [edit firewall]
    user@switch# set family ethernet-switching filter app_class term app from source-address 192.168.1.23/32
    user@switch# set family ethernet-switching filter app_class term app protocol tcp
    user@switch# set family ethernet-switching filter app_class term app source-port [1494 2512 2513 2598 2897]
    user@switch# set family ethernet-switching filter app_class term app then forwarding-class app loss-priority low
  14. Define the term mail:

    [edit firewall]
    user@switch# set family ethernet-switching filter app_class term mail from source-address 192.168.1.24/32
    user@switch# set family ethernet-switching filter app_class term mail protocol tcp
    user@switch# set family ethernet-switching filter app_class term mail source-port [25 143 389 691 993 3268 3269]
    user@switch# set family ethernet-switching filter app_class term mail then forwarding-class mail loss-priority low
  15. Define the term db:

    [edit firewall]
    user@switch# set family ethernet-switching filter app_class term db from source-address 192.168.1.25/32
    user@switch# set family ethernet-switching filter app_class term db protocol tcp
    user@switch# set family ethernet-switching filter app_class term db source-port [1521 1525 1527 1571 1810 2481]
    user@switch# set family ethernet-switching filter app_class term db then forwarding-class db loss-priority low
  16. Define the term erp:

    [edit firewall]
    user@switch# set family ethernet-switching filter app_class term erp from source-address 192.168.1.26/32
    user@switch# set family ethernet-switching filter app_class term erp protocol tcp
    user@switch# set family ethernet-switching filter app_class term erp source-port [3200 3300 3301 3600]
    user@switch# set family ethernet-switching filter app_class term erp then forwarding-class erp loss-priority low
  17. Define the term network_control (for the app_class filter):

    [edit firewall]
    user@switch# set family ethernet-switching filter app_class term network_control from precedence [net-control internet-control]
    user@switch# set family ethernet-switching filter app_class term network_control then forwarding-class network-control loss-priority low
  18. Define the term best_effort_traffic (for the app_class filter):

    [edit firewall]
    user@switch# set family ethernet-switching filter app_class term best_effort_traffic then forwarding-class best-effort loss-priority low
  19. Apply the firewall filter app_class as an input filter to the interfaces for the servers hosting applications:

    [edit interfaces]
    user@switch# set ge-0/0/3 unit 0 family ethernet-switching filter input app_class
    user@switch# set ge-0/0/4 unit 0 family ethernet-switching filter input app_class
    user@switch# set ge-0/0/5 unit 0 family ethernet-switching filter input app_class
    user@switch# set ge-0/0/6 unit 0 family ethernet-switching filter input app_class
  20. Configure schedulers:

    [edit class-of-service]
    user@switch# set schedulers voice-sched buffer-size percent 10
    user@switch# set schedulers voice-sched priority strict-high
    user@switch# set schedulers voice-sched transmit-rate percent 10
    user@switch# set schedulers video-sched buffer-size percent 15
    user@switch# set schedulers video-sched priority low
    user@switch# set schedulers video-sched transmit-rate percent 15
    user@switch# set schedulers app-sched buffer-size percent 10
    user@switch# set schedulers app-sched priority low
    user@switch# set schedulers app-sched transmit-rate percent 10
    user@switch# set schedulers mail-sched buffer-size percent 5
    user@switch# set schedulers mail-sched priority low
    user@switch# set schedulers mail-sched transmit-rate percent 5
    user@switch# set schedulers db-sched buffer-size percent 10
    user@switch# set schedulers db-sched priority low
    user@switch# set schedulers db-sched transmit-rate percent 10
    user@switch# set schedulers erp-sched buffer-size percent 10
    user@switch# set schedulers erp-sched priority low
    user@switch# set schedulers erp-sched transmit-rate percent 10
    user@switch# set schedulers nc-sched buffer-size percent 5
    user@switch# set schedulers nc-sched priority strict-high
    user@switch# set schedulers nc-sched transmit-rate percent 5
    user@switch# set schedulers be-sched buffer-size percent 35
    user@switch# set schedulers be-sched priority low
    user@switch# set schedulers be-sched transmit-rate percent 35
  21. Assign the forwarding classes to schedulers with the scheduler map ethernet-cos-map:

    [edit class-of-service]
    user@switch# set scheduler-maps ethernet-cos-map forwarding-class voice scheduler voice-sched
    user@switch# set scheduler-maps ethernet-cos-map forwarding-class video scheduler video-sched
    user@switch# set scheduler-maps ethernet-cos-map forwarding-class app scheduler app-sched
    user@switch# set scheduler-maps ethernet-cos-map forwarding-class mail scheduler mail-sched
    user@switch# set scheduler-maps ethernet-cos-map forwarding-class db scheduler db-sched
    user@switch# set scheduler-maps ethernet-cos-map forwarding-class erp scheduler erp-sched
    user@switch# set scheduler-maps ethernet-cos-map forwarding-class network-control scheduler nc-sched
    user@switch# set scheduler-maps ethernet-cos-map forwarding-class best-effort scheduler be-sched
  22. Associate the scheduler map with the outgoing interface:

    [edit class-of-service interfaces]
    user@switch# set ge-0/0/20 scheduler-map ethernet-cos-map

Results

Display the results of the configuration:

user@switch# show firewall
firewall family ethernet-switching {
filter voip_class {
term voip {
from {
source-address {
192.168.1.1/32;
192.168.1.2/32;
}
protocol udp;
source-port 2698;
}
then {
forwarding-class voice;
loss-priority low;
}
}
term network control {
from {
precedence [net-control internet-control];
}
then {
forwarding-class network-control;
loss-priority low;
}
}
term best_effort_traffic {
then {
forwarding-class best-effort;
loss-priority low;
}
}
}
filter video_class {
term video {
from {
source-address {
192.168.1.14/32;
}
protocol udp;
source-port 2979;
}
then {
forwarding-class video;
loss-priority low;
}
}
term network control {
from {
precedence [net-control internet-control];
}
then {
forwarding-class network-control;
loss-priority low;
}
}
term best_effort_traffic {
then {
forwarding-class best-effort;
loss-priority low;
}
}
}
filter app_class {
term app {
from {
source-address {
192.168.1.23/32;
}
protocol tcp;
source-port [1491 2512 2513 2598 2897];
}
then {
forwarding-class app;
loss-priority low;
}
}
term mail {
from {
source-address {
192.168.1.24/32;
}
protocol tcp;
source-port [25 143 389 691 993 3268 3269];
}
then {
forwarding-class mail;
loss-priority low;
}
}
term db {
from {
source-address {
192.168.1.25/32;
}
protocol tcp;
source-port [1521 1525 1527 1571 1810 2481];
}
then {
forwarding-class db;
loss-priority low;
}
}
term erp {
from {
source-address {
192.168.1.26/32;
}
protocol tcp;
source-port [3200 3300 3301 3600];
}
then {
forwarding-class erp;
loss-priority low;
}
}
term network control {
from {
precedence [net-control internet-control];
}
then {
forwarding-class network-control;
loss-priority low;
}
}
term best_effort_traffic {
then {
forwarding-class best-effort;
loss-priority low;
}
}
}
}
user@switch# show class-of-service
forwarding-classes {
class app queue-num 5;
class mail queue-num 1;
class db queue-num 2;
class erp queue-num 3;
class video queue-num 4;
class best-effort queue-num 0;
class voice queue-num 6;
class network-control queue-num 7;
}
schedulers {
voice-sched {
buffer-size percent 10;
priority strict-high;
transmit-rate percent 10;
}
video-sched {
buffer-size percent 15;
priority low;
transmit-rate percent 15;
}
app-sched {
buffer-size percent 10;
priority low;
transmit-rate percent 10;
}
mail-sched {
buffer-size percent 5;
priority low;
transmit-rate percent 5;
}
db-sched {
buffer-size percent 10;
priority low;
transmit-rate percent 10;
}
erp-sched {
buffer-size percent 10;
priority low;
transmit-rate percent 10;
}
nc-sched {
buffer-size percent 5;
priority strict-high;
transmit-rate percent 5;
}
be-sched {
buffer-size percent 35;
priority low;
transmit-rate percent 35;
}
}
scheduler-maps {
ethernet-cos-map {
forwarding-class voice scheduler voice-sched;
forwarding-class video scheduler video-sched;
forwarding-class app scheduler app-sched;
forwarding-class mail scheduler mail-sched;
forwarding-class db scheduler db-sched;
forwarding-class erp scheduler erp-sched;
forwarding-class network-control scheduler nc-sched;
forwarding-class best-effort scheduler be-sched;
}
}
user@switch# show interfaces
ge-0/0/0 {
unit 0 {
family ethernet {
filter {
input voip_class;
}
}
}
}
ge-0/0/1 {
unit 0 {
family ethernet {
filter {
input voip_class;
}
}
}
}
ge-0/0/2 {
unit 0 {
family ethernet {
filter {
input video_class;
}
}
}
}
ge-0/0/3 {
unit 0 {
family ethernet {
filter {
input app_class;
}
}
}
}
ge-0/0/4 {
unit 0 {
family ethernet {
filter {
input app_class;
}
}
}
}
ge-0/0/5 {
unit 0 {
family ethernet {
filter {
input app_class;
}
}
}
}
ge-0/0/6 {
unit 0 {
family ethernet {
filter {
input app_class;
}
}
}
}

Verification

To confirm that the configuration is working properly, perform these tasks:

Verifying That the Defined Forwarding Classes Exist and Are Mapped to Queues

Purpose

Verify that the following forwarding classes app, db, erp, mail, video, and voice have been defined and mapped to queues.

Action


user@switch> show class-of-service forwarding-class
Forwarding class                       ID    Queue 
  app                                   0       5       
  db                                    1       2      
  erp                                   2       3      
  best-effort                           3       0      
  mail                                  4       1      
  voice                                 5       6      
  video                                 6       4      
  network-control                       7       7      

Meaning

This output shows that the forwarding classes have been defined and mapped to appropriate queues.

Verifying That the Forwarding Classes Have Been Assigned to Schedulers

Purpose

Verify that the forwarding classes have been assigned to schedulers.

Action


user@switch> show class-of-service scheduler-map
Scheduler map: ethernet-cos-map, Index: 2
  Scheduler: voice-sched, Forwarding class: voice, Index: 22
    Transmit rate: 5 percent, Rate Limit: none, Buffer size: 15 percent,
    Priority: Strict-high
    Drop profiles:
      Loss priority   Protocol    Index    Name
      High            non-TCP         1    <default-drop-profile>  
      High            TCP             1    <default-drop-profile>

  Scheduler: video-sched, Forwarding class: video, Index: 22
    Transmit rate: 10 percent, Rate Limit: none, Buffer size: 10 percent,
    Priority: low
    Drop profiles:
      Loss priority   Protocol    Index    Name
      High            non-TCP         1    <default-drop-profile>
      High            TCP             1    <default-drop-profile>

  Scheduler: app-sched, Forwarding class: app, Index: 22
    Transmit rate: 10 percent, Rate Limit: none, Buffer size: 10 percent,	
    Priority: low
    Drop profiles:
      Loss priority   Protocol    Index    Name
      High            non-TCP         1    <default-drop-profile>
      High            TCP             1    <default-drop-profile>

  Scheduler: mail-sched, Forwarding class: mail, Index: 22
    Transmit rate: 5 percent, Rate Limit: none, Buffer size: 5 percent,
    Priority: low
    Drop profiles:
      Loss priority   Protocol    Index    Name
      High            non-TCP         1    <default-drop-profile>
      High            TCP             1    <default-drop-profile>

  Scheduler: db-sched, Forwarding class: db, Index: 22
    Transmit rate: 10 percent, Rate Limit: none, Buffer size: 10 percent,
    Priority: low
    Drop profiles:
      Loss priority   Protocol    Index    Name
      High            non-TCP         1    <default-drop-profile>
      High            TCP             1    <default-drop-profile>

  Scheduler: erp-sched, Forwarding class: erp, Index: 22
    Transmit rate: 10 percent, Rate Limit: none, Buffer size: 10 percent,
    Priority: low
    Drop profiles:
      Loss priority   Protocol    Index    Name
      High            non-TCP         1    <default-drop-profile>
      High            TCP             1    <default-drop-profile>

  Scheduler: be-sched, Forwarding class: best-effort, Index: 20
    Transmit rate: 35 percent, Rate Limit: none, Buffer size: 35 percent,
    Priority: low
    Drop profiles:
      Loss priority   Protocol    Index    Name
      High            non-TCP         1    <default-drop-profile>
      High            TCP             1    <default-drop-profile>

  Scheduler: nc-sched, Forwarding class: network-control, Index: 22
    Transmit rate: 5 percent, Rate Limit: none, Buffer size: 5 percent,
    Priority: Strict-high
    Drop profiles:
      Loss priority   Protocol    Index    Name
      High            non-TCP         1    <default-drop-profile>
      High            TCP             1    <default-drop-profile>
 
 

Meaning

This output shows that the forwarding classes have been assigned to schedulers.

Verifying That the Scheduler Map Has Been Applied to the Interface

Purpose

Verify that the scheduler map has been applied to the interface.

Action


user@switch> show class-of-service interface
...
Physical interface: ge-0/0/20, Index: 149
Queues supported: 8, Queues in use: 8
  Scheduler map: ethernet-cos-map, Index: 43366
  Input scheduler map: <default>, Index: 3
...

Meaning

This output shows that the scheduler map (ethernet-cos-map) has been applied to the interface (ge-0/0/20).


Published: 2009-07-22