Print

Open MATE Plan File to Design and Simulate Topologies

Designing and Simulating Topologies

MATE enables you to model, simulate, and analyze both design changes and failures. This is done by working on MATE plan files that consist of a series of tables describing network characteristics, such as network topology, simulated traffic (demands), and routing protocols. Specifically, the MATE license for use in Junosphere Lab gives you the following capabilities.

Documentation Note ― This section of the documentation gives you very brief overviews and instructions to get you started. To best understand how to use the MATE product, refer to its documentation. You can access it through the Help menu in the MATE graphical user interface or in the $CARIDEN_HOME/docs/pdf directory. ($CARIDEN_HOME is the directory in which you downloaded MATE). If you are new to MATE, you will likely find the following material most helpful:

Open and Save Plan Files

The first step to using MATE is to open a MATE plan file by selecting the File->Open menu. Either enter or browse to the plan file.

To save the model that you create on the MATE virtual machine for use after the Junosphere Lab session ends, save the plan file to a local storage device. Select either the File->Save or File->Save As menu. These plan files must be saved in .pln format, which is the default. You can then use the plan file in subsequent Junosphere Lab sessions, MATE trial use, or if you purchase Cariden MATE software.

Create a MATE Network Topology

You have three options for creating a network topology.

Import IGP Database

Follow these steps to import an IGP database using the MATE graphical user interface.

  1. Select the File->Import IGP Database menu. A dialog box appears with available import options.
  2. Either enter a complete path or browse to the location of the IGP database file.
  3. Select whether to import an OSPF or IS-IS database.
    • For OSPF, the default area is 0 (zero). If needed, specify a different area or select All to import all OSPF areas.
    • For IS-IS, the default level is 2. Change this to level 1, if needed.
  4. If you want the DNS (domain name server) to resolve IP addresses (router names) in the IS-IS database file, select the DNS option.
  5. Click OK. The MATE network plot area populates with the imported topology.

Build a Topology

The most basic components of a MATE topology are nodes, sites, circuits, and interfaces. In a MATE network plot, each node represents a router, and nodes are contained within sites. Circuits connect the nodes, and each circuit contains two interfaces. The MATE GUI has numerous tools for creating a topology that includes these objects and more. Following are a few basic editing functions:

Add Simulated Traffic to the Topology

MATE uses demands to simulate traffic between source and destination endpoints within the network. Each demand has a specified amount of traffic. The demand traffic is the basis for many of MATE's tools.

Unless you are using an existing MATE plan file, you likely need to create demands.

By default, demands have no traffic. There are a number of tools for adding traffic to demands. The following are just a few basic methods. For more information, refer to the documentation.

The interfaces are then colored based on the percentage of the interface capacity being used by traffic.

Simulate Failures and Run Simulation Analysis

You can perform simple failures, as well as execute a detailed simulation analysis that calculates worst-case performance of the network over a range of failure scenarios. The latter, which is executed using the Simulation Analysis tool, not only graphically plots network behavior when objects fail, but also provides an analysis of the consequences of such behavior. Alternatively, you can use this tool to identify the failures causing the highest utilizations.