Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

 
 

Detalles del protocolo de enrutamiento

  1. Para modificar la información de protocolo de un vínculo, seleccione Modificar elementos > vínculos de >... en el modo Modificar. Seleccione uno o más vínculos que desee modificar y haga clic en el botón Modificar. En la ventana Modificar vínculos resultante, seleccione la pestaña Protocolos.
    Figura 1: Modificar pestaña Protocolos de Network configuration interface for modifying link properties; Protocols tab selected; OSPF enabled with AREA0; other protocols set to no; options for OK, Cancel, Help. vínculo
  2. Para habilitar un protocolo, seleccione "sí" a la derecha del protocolo. Para ingresar una métrica para un protocolo en particular, como MPLS-TE, OSPF, SI-SI o ISIS2, ingrésela en las columnas "Métrica A-Z" y "Métrica Z-A" a la derecha del protocolo. Estas métricas corresponden a las interfaces A y Z del vínculo, como se indica en la pestaña Ubicaciones. Tenga en cuenta que al enrutar para un IGP específico, las métricas deben introducirse en la pestaña Protocolos en lugar de en la pestaña Propiedades.

En las siguientes secciones, se proporcionan más detalles sobre la configuración de información específica del protocolo.

RIP

No es necesario introducir métricas para RIP, ya que todas las métricas serán las mismas.

En el panel Herramientas > opciones > Diseño, Opciones de ubicación de ruta, el método de enrutamiento debe establecerse en Distancia constante y el Salto máximo debe configurarse en 15.

IGRP y EIGRP

Para IGRP y EIGRP, la métrica se puede cambiar a través de los campos Ancho de banda métrico y Retraso (E)IGRP. Estos campos se basan en las instrucciones de interfaz de ancho de banda y retraso y deben distinguirse del ancho de banda físico y el retraso de propagación dados en la pestaña Propiedades del vínculo. Las unidades deben ingresarse en el cuadro de texto, por ejemplo, "10M" para 10Mbps y "100us" para 100 microsegundos. Estos valores se utilizarán para calcular la métrica de acuerdo con la siguiente fórmula:

Figura 2: Cálculo de la métrica EIGRP/IGRP Metric formula: K1 times BW^x plus K2 times BW^y divided by 256 minus load plus K3 times delay, all times K5 divided by reliability plus K4.

De forma predeterminada, el programa establece K1 = K3 = 1 y K2 = K4 = K5 = 0 en la fórmula anterior. En este caso, solo se utilizan el ancho de banda y el retraso para calcular la métrica IGRP y EIGRP, utilizando una función del ancho de banda de la interfaz más lento y la suma de los retrasos de las interfaces salientes en la ruta. Para obtener el retardo' en la fórmula anterior, los retardos de interfaz (en microsegundos) que se suman se dividirán por 10 para IGRP y luego se multiplicarán por 256 para EIGRP. Para obtener el ancho de banda', 10^7 se dividirá por el ancho de banda de la interfaz en Kbps para IGRP y, luego, se multiplicará por 256 para EIGRP.

Para cambiar los valores K del archivo de texto antes de abrir la red, se puede agregar o editar la siguiente línea en el archivo dparam: IGRP_param1= TOS:0,K1:1,K2:0,K3:1,K4:0,K5:0

En el panel Herramientas > Opciones > Diseño, Opciones de colocación de rutas, el método de enrutamiento debe establecerse en IGRP o EIGRP. El salto máximo, también se puede configurar aquí (por ejemplo, 100 para IGRP) de acuerdo con el comando métrico maximum-hops.

OSPF

Las métricas de OSPF se pueden cambiar directamente estableciendo el costo a la derecha de la fila de OSPF (o fila de OSPF3 en el caso de la versión 3 de OSPF) en las columnas "Métrica de la A a la Z" y "Métrica de la Z-A".

De lo contrario, si este número no está configurado, el programa utilizará el ancho de banda de la interfaz (correspondiente a la instrucción bandwidth de la interfaz) y el ancho de banda de referencia OSPF para calcular la métrica mediante la fórmula: reference_bandwidth/interface_bandwidth, donde el valor predeterminado reference_bandwidth=10^8.

  • Para modificar el ancho de banda de la interfaz con fines de cálculo de métricas, introdúzcalo en los campos Ancho de banda de métricas. El cuadro de texto de la izquierda es para la interfaz del Nodo A y el cuadro de texto de la derecha es para la interfaz del Nodo Z. (La pestaña Ubicación indicará qué nodo es el Nodo A y qué nodo es el Nodo Z). Nuevamente, tenga en cuenta que el ancho de banda métrico puede ser diferente del ancho de banda físico. La unidad predeterminada es bps, pero se puede modificar agregando al número un sufijo de K para Kbps, M para Mbps y G para Gbps.

  • Para cambiar el ancho de banda de referencia del valor predeterminado, seleccione la vista Nodos en la ventana Información de red. Seleccione los nodos que desea modificar y haga clic en el botón Modificar. Luego seleccione la pestaña IP e ingrese un BW de referencia de OSPF. La unidad predeterminada es bps, pero se puede modificar agregando al número un sufijo de K para Kbps, M para Mbps y G para Gbps.

    Figura 3: Ingresar el BW de referencia desde la pestaña Modificar nodos, IP Modify 1 Node window with settings for OSPF and IS-IS protocols; fields include OSPF Reference BW, OSPF Overload Bit, IS-IS Reference BW, IS-IS Overload Bit, IS-IS Area, and TE Shortcut; buttons: OK, Cancel, Help.
  • Para especificar a qué área pertenece el vínculo, selecciónela en el cuadro desplegable Área. También se puede especificar un área secundaria en el cuadro desplegable Área2 si el vínculo pertenece a más de un área. Si no hay ningún área disponible en el cuadro desplegable, primero se puede agregar un área desde Modificar protocolos de > > OSPF áreas. Haga clic en Agregar. AREA0 se agregará automáticamente. Posteriormente puede ingresar en áreas adicionales.

Para establecer el bit de sobrecarga de OSPF, seleccione la vista Nodos en la ventana Información de red. Seleccione los nodos que desea modificar y haga clic en el botón Modificar. Luego seleccione la pestaña IP y cambie el bit de sobrecarga de OSPF a verdadero. Si se establece el bit de sobrecarga de OSPF, el tráfico de tránsito de OSPF no se enrutará a través del enrutador.

SI-SI e ISIS2

En la ventana Modificar elementos > > vínculos, pestaña Protocolos, las métricas de nivel SI-SI 1 se pueden cambiar en las columnas "Métrica de la A a la Z" y "Métrica de la Z-A" a la derecha de ISIS1 . Las métricas de nivel 2 de SI-SI se pueden cambiar en las columnas "Métrica de la A a la Z" y "Métrica de la Z-A" a la derecha de ISIS2.

Para ver el ID del sistema SI-SI de un nodo, haga clic con el botón secundario en la columna Encabezado de tabla Nodos y seleccione Opciones de tabla... A continuación, seleccione ISIS_System_ID y agréguelo a las columnas que se mostrarán. Otras opciones de columna relacionadas SI-SI para la vista Nodos incluyen ISIS_Area, ISIS_Overload_Bit y ISIS_Ref_BW. El área SI-SI también se puede ver desde la pestaña Protocolos en la vista Nodos.

Para cambiar el ancho de banda de referencia SI-SI del valor predeterminado, seleccione la vista Nodos en la ventana Información de red. Seleccione los nodos que desea modificar y haga clic en el botón Modificar. A continuación, seleccione la pestaña IP e introduzca un BW de referencia SI-SI. La unidad predeterminada es bps, pero se puede modificar agregando al número un sufijo de K para Kbps, M para Mbps y G para Gbps.

Para establecer el bit de sobrecarga SI-SI, seleccione la vista Nodos en la ventana Información de red. Seleccione los nodos que desea modificar y haga clic en el botón Modificar. A continuación, seleccione la pestaña IP y cambie el bit de sobrecarga de SI-SI a true. Si se establece el bit de sobrecarga SI-SI, el tráfico de tránsito SI-SI no se enrutará a través del enrutador.

MPLS-TE

La métrica de túnel para MPLS-TE se puede cambiar en las columnas "Métrica A-Z" y "Métrica Z-A" a la derecha de MPLS-TE. Los túneles LSP que no están configurados para enrutar según el protocolo de enrutamiento IGP actual se enrutarán de acuerdo con estas métricas.

Actualizar las propiedades del vínculo desde un archivo

La información de la métrica OSPF/SI-SI/retraso del vínculo también se puede modificar por lotes a través de la versión en modo texto. Este formato de archivo también es flexible y puede admitir los siguientes campos:

NodeA, NodeZ, Node, InterfaceA, InterfaceZ, Interface, DelayAZ, DelayZA, LatencyA2Z, LatencyZ2A, Delay, IPaddrZ, IPaddr, RoundTripDelay, linkname, OSPFMetric, ISIS2Metric, ISIS1Metric, LinkName, BWType, Node, Interface, DelayAZ, DelayZA

La primera línea debe especificar las columnas mediante una lista separada por comas de las palabras clave anteriores, incluida una columna para el nodo y la interfaz o dirección IP como mínimo. Las líneas siguientes deben especificar el par Nodo/Interfaz o Nodo/IP y las otras columnas relevantes que se van a actualizar. Por ejemplo:

Para cargar este archivo, seleccione Herramientas > el modo de texto/ASCII o, en una ventana de consola, escriba /u/wandl/bin/bbdsgn specfilepath.

Seleccione en el menú principal: 5. Modificar configuración > 4. Configuración del vínculo > u. Actualizar las propiedades del vínculo desde un archivo. Seleccione ? para el menú Ayuda para obtener información sobre el formato del archivo de entrada.

Seleccione 2. Ingrese el nombre del archivo e ingrese la ubicación del archivo que se utilizará para actualizar los vínculos (aquí se acepta la ruta absoluta o relativa). Seleccione 3. Nombre de salida de error para introducir la ubicación de un archivo opcional para la salida de errores. Seleccione 4. Operación para indicar qué campos actualizar en función del archivo de entrada (el valor predeterminado incluye todos los campos) y q para salir de este menú.

Seleccione 5. Actualice la configuración del vínculo para realizar la entrada real basada en el archivo de entrada especificado.

Una vez finalizada la actualización, escriba 'q' hasta llegar al menú principal. En el modo de texto, seleccione 2. Guardar archivos para guardar los cambios, o en el modo de gráficos Java, salga del menú y guarde a través de Archivo > Guardar red...