Estándares admitidos para el enrutamiento por segmentos
Obtenga información sobre las RFC de enrutamiento por segmentos y los borradores de Internet compatibles con Junos OS.
En este tema se enumeran las RFC de enrutamiento por segmentos y los borradores de Internet que Junos OS admite, admite parcialmente o no admite. También identifica los RFC que el GTI-I clasifica como experimentales o informativos.
RFC y borradores de Internet compatibles
Junos OS admite los siguientes RFC de enrutamiento por segmentos y borradores de Internet.
RFC compatibles
-
RFC 5286, Especificación básica para el reenrutamiento rápido de IP: Alternativas sin bucles
-
RFC 7471, Extensiones métricas de ingeniería de tráfico (ING-T) de OSPF
-
RFC 7490, Reenrutamiento rápido (FRR) alternativo remoto sin bucles (LFA)
-
RFC 7684, Anuncio de atributo de vínculo o prefijo OSPFv2
-
RFC 7752, Distribución en dirección norte de información de estado de vínculos e ingeniería de tráfico (TE) mediante BGP
-
RFC 7855, Enrutamiento de paquetes fuente en redes (SPRING) Enunciado del problema y requisitos
-
RFC 8102, Protección y capacidad de administración de nodos de LFA remota
-
RFC 8277, Uso de BGP para enlazar etiquetas MPLS a prefijos de dirección
-
RFC 8287, Ping/traceroute de LSP para enrutamiento por segmentos
-
RFC 8403, Un sistema de monitoreo de plano de datos MPLS escalable y consciente de la topología
-
RFC 8426, coexistencia RSVP-SR
-
RFC 8571, BGP: anuncio de estado del vínculo (BGP-LS) de extensiones métricas de rendimiento de ingeniería de tráfico de IGP
-
RFC 8604, Interconexión de millones de puntos de conexión con enrutamiento por segmentos
-
RFC 8660, Enrutamiento por segmentos con el plano de datos MPLS
-
RFC 8661, Enrutamiento por segmentos MPLS interfuncionando con LDP
-
RFC 8665, Extensiones de OSPF para enrutamiento por segmentos
-
RFC 8690, Aclaración de la longitud de sub-TLV de ID de segmento para RFC 8287
-
RFC 8986, Programación de red de enrutamiento por segmentos mediante IPv6 (SRv6)
-
RFC 9085, Protocolo de puerta de enlace de frontera: extensiones de estado de vínculo (BGP-LS) para enrutamiento por segmentos
-
RFC 9086, Protocolo de puerta de enlace de frontera: extensiones de estado de vínculo (BGP-LS) para enrutamiento por segmentos Ingeniería de par de salida de BGP
-
RFC 9256, Arquitectura de política de enrutamiento por segmentos
-
RFC 9252, Servicios de superposición de BGP basados en enrutamiento por segmentos sobre IPv6 (SRv6)
-
RFC 9350, Algoritmo flexible IGP
-
RFC 9800, Codificación de lista de segmentos SRv6 comprimidos (compatibilidad parcial). Solo admitimos microSID SRv6.
-
RFC 9819, Señalización de argumentos para servicios de BGP en enrutamiento por segmentos a través de IPv6 (SRv6)
Borradores de Internet admitidos
-
draft-agrawal-spring-srv6-mpls-interworking-06, intertrabajo SRv6 y MPLS
Admite el intertrabajo de servicios.
-
draft-bashandy-rtgwg-segment-routing-ti-lfa, Reenrutamiento rápido independiente de topología mediante enrutamiento por segmentos
-
draft-bashandy-rtgwg-segment-routing-uloop, Evitación de microbucles mediante el enrutamiento por segmentos
-
draft-filsfils-rtgwg-segment-routing-use-cases-02, Casos de uso de enrutamiento por segmentos
-
draft-filsfils-spring-sr-policy-considerations-05, Consideraciones de implementación y despliegue de políticas de SR
-
draft-filsfils-spring-sr-traffic-counters, contadores de tráfico de SR
-
draft-ietf-idr-bgp-prefix-sid, Anunciar segmento de BGP para un prefijo de BGP
-
draft-ietf-idr-bgpls-segment-routing-epe, extensiones BGP-LS para ingeniería de tráfico de par de salida mediante SR
-
draft-ietf-idr-segment-routing-te-policy, Anunciar políticas de SR-TE a través del BGP
-
draft-ietf-idr-segment-routing-te-policy-09, Políticas de enrutamiento por segmentos publicitarias en BGP
-
draft-ietf-lsr-isis-srv6-extensions, extensiones de SI-SI para admitir el enrutamiento por segmentos mediante plano de datos IPv6
-
draft-ietf-ospf-segment-routing-extensions, extensiones de OSPF para distribuir segmentos de SR
-
draft-ietf-pce-segment-routing, extensiones PCE para configurar una ruta de SR-TE desde el controlador (hacia el sur)
-
draft-ietf-isis-segment-routing-extensions, extensiones de SI-SI para distribuir segmentos de SR
-
draft-ietf-rtgwg-segment-routing-ti-lfa-04, Reenrutamiento rápido independiente de topología mediante enrutamiento por segmentos
-
draft-ietf-spring-conflict-resolution, Resolución de conflictos MPLS de enrutamiento por segmentos
-
draft-ietf-spring-resiliency-use-cases, Casos de uso de resistencia en redes SPRING
-
draft-ietf-spring-segment-routing-central-epe, SR Ingeniería de par de salida de BGP centralizada
-
draft-ietf-spring-segment-routing-mpls, detalles del enrutamiento por segmentos con reenvío MPLS
-
draft-ietf-spring-segment-routing-policy-07.txt, arquitectura de políticas Enrutamiento por segmentos
-
draft-kaliraj-idr-bgp-classful-transport-planes-12, Aviones de transporte con clase BGP
-
draft-ali-6man-srv6-vpn-icmp-error-handling-00 Manejo de errores ICMP en redes VPN basadas en SRv6
RFC y borradores de Internet parcialmente compatibles
Junos OS admite parcialmente los siguientes RFC de enrutamiento por segmentos y borradores de Internet.
RFC parcialmente compatibles
-
RFC 4971, Extensiones de sistema intermedio a sistema intermedio (SI-SI) para anunciar información de enrutador (compatibilidad parcial)
-
RFC 8402, Arquitectura de enrutamiento por segmentos (compatibilidad parcial)
-
RFC 8570, Extensiones métricas de ingeniería de tráfico (ING-T) SI-SI (compatibilidad parcial)
Admite parámetros relacionados con el retraso del vínculo.
-
RFC 8663, Enrutamiento por segmentos MPLS sobre IP (compatibilidad parcial)
-
RFC 8919, Atributos de vínculo específicos de la aplicación SI-SI (soporte parcial)
-
RFC 9862, Extensiones del protocolo de comunicación de elementos de computación de ruta (PCEP) para rutas candidatas de política de enrutamiento por segmentos (SR)
Existe una pequeña desviación en el manejo del TLV de SRPOLICY-CAPABILITY. La implementación sigue la especificación draft-ietf-pce-segment-routing-policy-cp-05, que no exige el SRPOLICY-CAPABILITY TLV en el objeto PCEP Open. En consecuencia, el PCC no anuncia este TLV, lo que lleva a un establecimiento fallido de la sesión PCEP con pares que aplican estrictamente RFC 9862. Si un anunciador PCEP recibe un objeto SRPA sin intercambio previo de TLV, debe enviar un mensaje PCErr (Error-Type=10 "Recepción de un objeto no válido" y Error-value=44 "Falta el TLV SRPOLICY-CAPABILITY") y finalizar la sesión.
-
RFC 9603, Extensiones del protocolo de comunicación de elementos de computación de ruta (PCEP) para enrutamiento por segmentos IPv6
-
Junos OS siempre establece el bit N en 0 en el mensaje PCEP Open.
-
El cliente de computación de ruta (PCC) y la ingeniería de tráfico y enrutamiento de segmentos (SR-TE) no pueden resolver un identificador de acceso a red (NAI) en un identificador de segmento (SID) SRv6.
-
SR-TE no verifica los SID en el objeto de ruta explícito (ERO), incluso cuando el bit V se establece en 1.
-
Borradores de Internet parcialmente compatibles
-
draft-ali-spring-sr-traffic-accounting, contabilidad de matriz de tráfico de SR (soporte parcial)
Solo admite contador.
-
draft-ginsberg-isis-prefix-attributes, atributos de prefijo SI-SI para accesibilidad IPv4 e IPv6 extendida (soporte parcial)
-
draft-ietf-spring-ipv6-use-cases, casos de uso para el enrutamiento de paquetes fuente IPv6 en redes (compatibilidad parcial)
-
draft-ietf-spring-segment-routing-msdc, segmento de prefijo BGP en centros de datos a gran escala (compatibilidad parcial)
-
draft-ietf-spring-segment-routing-policy, política de SR para TE (soporte parcial)
-
draft-xu-mpls-sr-over-ip, Enrutamiento por segmentos MPLS sobre IP (compatibilidad parcial)
RFC experimentales e informativos
Las siguientes RFC no definen estándares, sino que proporcionan información acerca del enrutamiento por segmentos y las tecnologías relacionadas. El GTI-I clasifica estas RFC de diversas maneras como "experimentales" o "informativas".
-
RFC 6571, Aplicabilidad de alternativas sin bucles (LFA) en redes de proveedores de servicios (SP)
-
RFC 9087, Enrutamiento por segmentos Ingeniería de par de salida de BGP centralizada
RFC no compatibles
Los siguientes RFC de enrutamiento por segmentos y borradores de Internet no son compatibles con Junos OS.
-
RFC 5642, Mecanismo de intercambio dinámico de nombres de host para OSPF
-
RFC 8668, Anunciar atributos de vínculo de miembro de paquete de capa 2 en SI-SI
La implementación admite la asignación de etiquetas MPLS estáticas para vínculos de miembro porque no se admite el anuncio SI-SI de estas etiquetas.
-
RFC 9871, Enrutamiento consciente del color (CAR) del BGP
-
RFC 9960, Política de punto a multipunto de enrutamiento por segmentos
-
RFC 9524, Replicación de enrutamiento por segmentos para prestación de servicios multipunto