Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

 
 

세그먼트 라우팅에 지원되는 표준

Junos OS에서 지원하는 세그먼트 라우팅 RFC 및 인터넷 초안에 대해 알아보십시오.

이 주제에서는 Junos OS가 지원, 부분적으로 지원하거나 지원하지 않는 세그먼트 라우팅 RFC 및 인터넷 초안을 나열합니다. 또한 IETF가 실험 또는 정보로 분류하는 RFC도 식별합니다.

지원되는 RFC 및 인터넷 초안

Junos OS는 다음 세그먼트 라우팅 RFC 및 인터넷 초안을 지원합니다.

지원되는 RFC

  • RFC 5286, IP 고속 재라우팅에 대한 기본 사양: 루프 프리 대체

  • RFC 7471, 최단 경로 우선(OSPF) 트래픽 엔지니어링(TE) 메트릭 확장

  • RFC 7490, 원격 LFA(Loop-Free Alternate) FRR(Fast Reroute)

  • RFC 7684, OSPFv2 접두사/링크 속성 보급

  • RFC 7752, BGP를 사용한 Link-State 및 트래픽 엔지니어링(TE) 정보 북향 배포

  • RFC 7855, SPRING(Source Packet Routing in Networking) 문제 설명 및 요구 사항

  • RFC 8102, 원격-LFA 노드 보호 및 관리 효율성

  • RFC 8277, BGP를 사용하여 MPLS 레이블을 바인딩하여 접두사 주소 지정

  • RFC 8287, 세그먼트 라우팅을 위한 LSP 핑/트레이스라우트

  • RFC 8403, 확장 가능하고 토폴로지를 인식하는 MPLS 데이터 플레인 모니터링 시스템

  • RFC 8426, RSVP-SR 공존

  • RFC 8571, BGP - IGP 트래픽 엔지니어링 성능 메트릭 확장의 링크 상태(BGP-LS) 광고

  • RFC 8604, 세그먼트 라우팅으로 수백만 개의 엔드포인트 상호 연결

  • RFC 8660, MPLS 데이터 플레인을 사용한 세그먼트 라우팅

  • RFC 8661, LDP와 연동되는 세그먼트 라우팅 MPLS

  • RFC 8665, 세그먼트 라우팅을 위한 최단 경로 우선(OSPF) 확장

  • RFC 8690, RFC 8287에 대한 세그먼트 ID 하위 TLV 길이 설명

  • RFC 8986, IPv6(SRv6)를 통한 세그먼트 라우팅 네트워크 프로그래밍

  • RFC 9085, Border Gateway Protocol - 세그먼트 라우팅을 위한 링크 상태(BGP-LS) 확장

  • RFC 9086, Border Gateway Protocol - 세그먼트 라우팅을 위한 링크 상태(BGP-LS) 확장 BGP 송신 피어 엔지니어링

  • RFC 9256, 세그먼트 라우팅 정책 아키텍처

  • RFC 9252, IPv6(SRv6)를 통한 세그먼트 라우팅 기반 BGP 오버레이 서비스

  • RFC 9350, IGP 유연한 알고리즘

  • RFC 9800, 압축된 SRv6 세그먼트 목록 인코딩(부분 지원). 주니퍼는 SRv6 마이크로 SID만 지원합니다.

  • RFC 9819, IPv6(SRv6)을 통한 세그먼트 라우팅에서 BGP 서비스에 대한 인수 신호

지원되는 인터넷 초안

  • draft-agrawal-spring-srv6-mpls-interworking-06, SRv6 및 MPLS 상호 연동

    서비스 상호 연동을 지원합니다.

  • draft-bashandy-rtgwg-segment-routing-ti-lfa, 세그먼트 라우팅을 사용한 토폴로지 독립적 고속 재라우팅

  • draft-bashandy-rtgwg-segment-routing-uloop, 세그먼트 라우팅을 사용한 마이크로루프 방지

  • draft-filsfils-rtgwg-segment-routing-use-cases-02, 세그먼트 라우팅 사용 사례

  • draft-filsfils-spring-sr-policy-considerations-05, SR 정책 구현 및 구축 고려 사항

  • draft-filsfils-spring-sr-traffic-counters, SR 트래픽 카운터

  • draft-ietf-idr-bgp-prefix-sid, BGP 접두사에 대한 BGP 세그먼트 보급

  • draft-ietf-idr-bgpls-segment-routing-epe, SR을 사용하는 송신 피어 트래픽 엔지니어링을 위한 BGP-LS 확장

  • draft-ietf-idr-segment-routing-te-policy, BGP를 통해 SR-TE 정책 보급

  • draft-ietf-idr-segment-routing-te-policy-09, BGP에서 세그먼트 라우팅 정책 보급

  • draft-ietf-lsr-isis-srv6-extensions, IPv6 데이터플레인을 통한 세그먼트 라우팅을 지원하기 위한 IS-IS 확장

  • draft-ietf-ospf-segment-routing-extensions, SR 세그먼트를 배포하기 위한 OSPF 확장

  • draft-ietf-pce-segment-routing, 컨트롤러에서 SR-TE 경로를 설정하기 위한 PCE 확장(남쪽 방향)

  • draft-ietf-isis-segment-routing-extensions, SR 세그먼트를 배포하기 위한 IS-IS 확장

  • draft-ietf-rtgwg-segment-routing-ti-lfa-04, 세그먼트 라우팅을 사용한 토폴로지 독립적 고속 재라우팅

  • draft-ietf-spring-conflict-resolution, 세그먼트 라우팅 MPLS 충돌 해결

  • draft-ietf-spring-resiliency-use-cases, SPRING 네트워크의 복원력 사용 사례

  • draft-ietf-spring-segment-routing-central-epe, SR 중앙화된 BGP 송신 피어 엔지니어링

  • draft-ietf-spring-segment-routing-mpls, MPLS 포워딩을 통한 세그먼트 라우팅 세부 정보

  • draft-ietf-spring-segment-routing-policy-07.txt, 세그먼트 라우팅 정책 아키텍처

  • draft-kaliraj-idr-bgp-classful-transport-planes-12, BGP 클래스풀 전송 플레인

  • draft-ali-6man-srv6-vpn-icmp-error-handling-00 SRv6 기반 VPN 네트워크에서의 ICMP 오류 처리

부분적으로 지원되는 RFC 및 인터넷 초안

Junos OS는 다음 세그먼트 라우팅 RFC 및 인터넷 초안을 부분적으로 지원합니다.

부분적으로 지원되는 RFC

  • RFC 4971, 라우터 정보 보급을 위한 IS-IS(Intermediate System to Intermediate System) 확장(부분 지원)

  • RFC 8402, 세그먼트 라우팅 아키텍처(부분 지원)

  • RFC 8570, IS-IS 트래픽 엔지니어링(TE) 메트릭 확장(부분 지원)

    링크 지연 관련 매개 변수를 지원합니다.

  • RFC 8663, IP를 통한 MPLS 세그먼트 라우팅(부분 지원)

  • RFC 8919, IS-IS 애플리케이션별 링크 속성(부분 지원)

  • RFC 9862, SR(세그먼트 라우팅) 정책 후보 경로에 대한 PCEP(Path Computation Element Communication Protocol) 확장

    SRPOLICY-CAPABILITY TLV 처리에 약간의 차이가 있습니다. 구현은 PCEP Open 개체에서 SRPOLICY-CAPABILITY TLV를 의무화하지 않는 draft-ietf-pce-segment-routing-policy-cp-05 사양을 따릅니다. 결과적으로 PCC는 이 TLV를 보급하지 않으므로 RFC 9862를 엄격하게 시행하는 피어와의 PCEP 세션 설정이 실패하게 됩니다. PCEP 스피커가 사전 TLV 교환 없이 SRPA 개체를 수신하면 PCErr 메시지(Error-Type=10 "Reception of an invalid object" 및 Error-value=44 "Missing SRPOLICY-CAPABILITY TLV")를 보내고 세션을 종료해야 합니다.

  • RFC 9603, IPv6 세그먼트 라우팅을 위한 PCEP(Path Computation Element Communication Protocol) 확장

    • Junos OS는 PCEP 열기 메시지에서 항상 N비트를 0으로 설정합니다.

    • PCC(Path Computation Client) 및 SR-TE(segment routing-traffic engineering)는 NAI(Network Access Identifier)를 SRv6 세그먼트 식별자(SID)로 확인할 수 없습니다.

    • SR-TE는 V 비트가 1로 설정된 경우를 포함하여 명시적 경로 개체(ERO)의 SID를 확인하지 않습니다.

부분적으로 지원되는 인터넷 초안

  • draft-ali-spring-sr-traffic-accounting, SR 트래픽 매트릭스 어카운팅(부분 지원)

    카운터만 지원합니다.

  • draft-ginsberg-isis-prefix-attributes, 확장된 IPv4 및 IPv6 연결성을 위한 IS-IS 접두사 속성(부분 지원)

  • draft-ietf-spring-ipv6-use-cases, 네트워킹의 IPv6 소스 패킷 라우팅 사용 사례(부분 지원)

  • draft-ietf-spring-segment-routing-msdc, 대규모 데이터센터의 BGP-Prefix 세그먼트(부분 지원)

  • draft-ietf-spring-segment-routing-policy, TE를 위한 SR 정책(부분 지원)

  • draft-xu-mpls-sr-over-ip, IP를 통한 MPLS 세그먼트 라우팅(부분 지원)

실험 및 정보 RFC

다음 RFC는 표준을 정의하지 않지만 세그먼트 라우팅 및 관련 기술에 대한 정보를 제공합니다. IETF는 이러한 RFC를 "실험적" 또는 "정보성"으로 다양하게 분류합니다.

  • RFC 6571, 서비스 프로바이더(SP) 네트워크에서 LFA(Loop-Free Alternate) 적용 가능성

  • RFC 9087, 세그먼트 라우팅 중앙 집중식 BGP 송신 피어 엔지니어링

지원되지 않는 RFC

다음 세그먼트 라우팅 RFC 및 인터넷 초안은 Junos OS에서 지원되지 않습니다.

  • RFC 5642, OSPF를 위한 동적 호스트 이름 교환 메커니즘

  • RFC 8668, IS-IS의 레이어 2 번들 멤버 링크 속성 보급

    이러한 레이블의 IS-IS 광고가 지원되지 않으므로 구현은 멤버 링크에 대한 정적 MPLS 레이블 할당을 지원합니다.

  • RFC 9871, BGP 색상 인식 라우팅(CAR)

  • RFC 9960, 세그먼트 라우팅 포인트 투 멀티포인트 정책

  • RFC 9524, 멀티포인트 서비스 딜리버리를 위한 세그먼트 라우팅 복제