例:VLAN なしの H-VPLS の設定
この例では、階層型仮想プライベートLANサービス(H-VPLS)を設定する方法を示しています。この例では、VLAN は設定されていません。
要件
この例を設定する前に、デバイス初期化以外の特別な設定は必要ありません。
概要
H-VPLS は、LDP ベースの VPLS を使用して疑似配線のシグナリングと確立を行います。LDP ベースの VPLS は、RFC 4762、 ラベル配布プロトコル(LDP)シグナリングを使用した VPLS(仮想プライベート LAN サービス)で定義されています。RFC 4762は、H-VPLSと呼ばれるLDP VPLSの階層的な動作モードも定義しています。
VPLSとH-VPLSはスケーリングに関して異なります。VPLSでは、VPLSサービスに参加するすべてのPE(プロバイダエッジ)ルーター間で、トンネルラベルスイッチパス(LSP)のフルメッシュが必要です。VPLS サービスごとに、PE ルーター間で n*(n-1)/2 擬似配線を設定する必要があります。対照的に、H-VPLS は、MPLS コアを使用して相互接続された複数のエッジ ドメインにネットワークをパーティション化します。各エッジ デバイスは、1 つのローカル PE デバイスのみを学習する必要があるため、ルーティング テーブルのサポートが少なくて済みます。これは、サービス プロバイダがカスタマー エッジで比較的安価なデバイス(EX シリーズ スイッチなど)を使用できるようにする可能性があります。
ジュニパーネットワークスは、H-VPLSの代替として、VPLSの拡張性に対応する他の方法を提供しています。詳細については、「 アプリケーション ノート: H-VPLS を分別する」を参照してください。
H-VPLS は、2 つの役割または機能を定義します。
PE-r —他の PE-r デバイスと VPLS を実行するが、アクセス レイヤーを提供するマルチテナント ユニット(MTU)と呼ばれる別のデバイスとの疑似配線(QinQ アクセスに基づいても可能)を持つ PE デバイス。
MTU—H-VPLS アーキテクチャ上のアクセス レイヤーを表し、VPLS トラフィックが転送される 1 つ以上の PE-r デバイスに疑似配線を確立する PE デバイス。
図 1 は、この例で使用したトポロジーを示しています。
この例では、2つのPE-rデバイス(デバイスPE2およびデバイスPE3)に接続された1つのMTU(デバイスPE1)を示しています。
デバイスPE1とデバイスPE3の間の疑似配線は、プライマリまたはワーキングパスです。デバイス PE1 とデバイス PE2 の間の疑似配線はバックアップ パスです。
CLI クイック設定 は、 図 1 にすべてのデバイスの設定を示しています。セクション ステップバイステップ手順 では、デバイス PE1 とデバイス PE2 の手順について説明します。
構成
手順
CLI クイックコンフィギュレーション
この例を迅速に設定するには、以下のコマンドをコピーしてテキスト ファイルに貼り付け、改行を削除し、ネットワーク設定に合わせて必要な詳細を変更してから、 階層レベルの CLI にコマンドを [edit]
コピー アンド ペーストします。
デバイスPE1
set interfaces ge-2/0/5 encapsulation ethernet-ccc set interfaces ge-2/0/5 unit 0 family ccc set interfaces ge-2/0/10 unit 0 family inet address 192.0.2.2/24 set interfaces ge-2/0/10 unit 0 family iso set interfaces ge-2/0/10 unit 0 family mpls set interfaces ge-2/0/11 unit 0 family inet address 192.0.2.3/24 set interfaces ge-2/0/11 unit 0 family iso set interfaces ge-2/0/11 unit 0 family mpls set interfaces lo0 unit 0 family inet address 10.255.14.217/32 set interfaces lo0 unit 0 family iso address 49.0001.0102.5501.4217.00 set protocols mpls interface ge-2/0/10.0 set protocols mpls interface ge-2/0/11.0 set protocols isis level 1 disable set protocols isis interface ge-2/0/10.0 set protocols isis interface ge-2/0/11.0 set protocols isis interface lo0.0 set protocols ldp interface ge-2/0/10.0 set protocols ldp interface ge-2/0/11.0 set protocols ldp interface lo0.0 set protocols l2circuit neighbor 10.255.14.225 interface ge-2/0/5.0 virtual-circuit-id 601 set protocols l2circuit neighbor 10.255.14.225 interface ge-2/0/5.0 backup-neighbor 10.255.14.216 standby set routing-options router-id 10.255.14.217
デバイスPE2
set interfaces ge-2/0/6 encapsulation ethernet-vpls set interfaces ge-2/0/6 unit 0 family vpls set interfaces ge-2/0/10 unit 0 family inet address 192.0.2.4/24 set interfaces ge-2/0/10 unit 0 family iso set interfaces ge-2/0/10 unit 0 family mpls set interfaces lo0 unit 0 family inet address 10.255.14.216/32 set interfaces lo0 unit 0 family iso address 49.0001.0102.5501.4216.00 set protocols mpls interface ge-2/0/10.0 set protocols isis level 1 disable set protocols isis interface ge-2/0/10.0 set protocols isis interface lo0.0 set protocols ldp interface ge-2/0/10.0 set protocols ldp interface lo0.0 set routing-instances customer instance-type vpls set routing-instances customer interface ge-2/0/6.0 set routing-instances customer protocols vpls vpls-id 601 set routing-instances customer protocols vpls neighbor 10.255.14.217 set routing-options router-id 10.255.14.216
デバイスPE3
set interfaces ge-2/1/3 encapsulation ethernet-vpls set interfaces ge-2/1/3 unit 0 family vpls set interfaces ge-2/0/10 unit 0 family inet address 192.0.2.5/24 set interfaces ge-2/0/10 unit 0 family iso set interfaces ge-2/0/10 unit 0 family mpls set interfaces lo0 unit 0 family inet address 10.255.14.225/32 set interfaces lo0 unit 0 family iso address 49.0001.0102.5501.4225.00 set protocols mpls interface ge-2/0/10.0 set protocols isis level 1 disable set protocols isis interface ge-2/0/10.0 set protocols isis interface lo0.0 set protocols ldp interface ge-2/0/10.0 set protocols ldp interface lo0.0 set routing-instances customer instance-type vpls set routing-instances customer interface ge-2/1/3.0 set routing-instances customer protocols vpls vpls-id 601 set routing-instances customer protocols vpls neighbor 10.255.14.217 set routing-options router-id 10.255.14.225
デバイスCE1
set interfaces ge-2/0/8 unit 0 family inet address 172.16.0.3/24 set interfaces lo0 unit 0 family inet address 10.255.14.214/32 set protocols ospf area 0.0.0.0 interface lo0.0 passive set protocols ospf area 0.0.0.0 interface ge-2/0/8.0
デバイスCE2
set interfaces ge-2/1/5 unit 0 family inet address 172.16.0.4/24 set interfaces lo0 unit 0 family inet address 10.255.14.215/32 set protocols ospf area 0.0.0.0 interface lo0.0 passive set protocols ospf area 0.0.0.0 interface ge-2/1/5.0
デバイスCE3
set interfaces ge-2/0/9 unit 0 family inet address 172.16.0.5/24 set interfaces lo0 unit 0 family inet address 10.255.14.218/32 set protocols ospf area 0.0.0.0 interface lo0.0 passive set protocols ospf area 0.0.0.0 interface ge-2/0/9.0
手順
次の例では、設定階層内のさまざまなレベルに移動する必要があります。CLIのナビゲーションについては、 CLIユーザーガイドの設定モードでのCLIエディターの使用を参照してください。
MTUデバイスでH-VPLSを設定するには:
-
インターフェイスを設定します。
カスタマーエッジに接続するMTUデバイスインターフェイスで、CCC(回線クロスコネクト)カプセル化タイプとCCCアドレスファミリーのいずれかを設定します。これにより、レイヤー 2 回線が有効になります。
コアに面したインターフェイスで、MPLS ラベルを有効にします。IS-ISがコアで使用されているため、コアに面したインターフェイスでもISOアドレスが必要です。
[edit interfaces] user@PE1# set ge-2/0/5 encapsulation ethernet-ccc user@PE1# set ge-2/0/5 unit 0 family ccc user@PE1# set ge-2/0/10 unit 0 family inet address 192.0.2.2/24 user@PE1# set ge-2/0/10 unit 0 family iso user@PE1# set ge-2/0/10 unit 0 family mpls user@PE1# set ge-2/0/11 unit 0 family inet address 192.0.2.3/24 user@PE1# set ge-2/0/11 unit 0 family iso user@PE1# set ge-2/0/11 unit 0 family mpls user@PE1# set lo0 unit 0 family inet address 10.255.14.217/32 user@PE1# set lo0 unit 0 family iso address 49.0001.0102.5501.4217.00
-
インターフェイスでMPLSとLDPを有効にします。
他のPEデバイスに接続するMTUデバイスインターフェイスで、MPLSとLDPを設定します。
[edit protocols mpls] user@PE1# set interface ge-2/0/10.0 user@PE1# set interface ge-2/0/11.0 [edit protocols ldp ] user@PE1# set interface ge-2/0/10.0 user@PE1# set interface ge-2/0/11.0 user@PE1# set interface lo0.0
-
インターフェイスでルーティングを有効にします。
他のPEデバイスに接続するMTUデバイスインターフェイスで、OSPFやIS-ISなどの内部ゲートウェイプロトコル(IGP)を設定します。
[edit protocols isis] user@PE1# set level 1 disable user@PE1# set interface ge-2/0/10.0 user@PE1# set interface ge-2/0/11.0 user@PE1# set interface lo0.0
-
レイヤー 2 回線を設定します。
ネイバー 10.255.14.225 は、デバイス PE3 のループバック インターフェイス アドレスです。これにより、作業パスが設定されます。
ネイバー 10.255.14.216 は、デバイス PE2 のループバック インターフェイス アドレスです。これにより、バックアップパスが設定されます。
仮想回線 ID は、デバイス PE2 とデバイス PE3 で設定された VPLS ID と一致する必要があります。
[edit protocols l2circuit neighbor 10.255.14.225 interface ge-2/0/5.0] user@PE1# set virtual-circuit-id 601 user@PE1# set backup-neighbor 10.255.14.216 standby
-
ルーターIDを設定します。
[edit routing-options] user@PE1# set router-id 10.255.14.217
手順
次の例では、設定階層内のさまざまなレベルに移動する必要があります。CLIのナビゲーションについては、 CLIユーザーガイドの設定モードでのCLIエディターの使用を参照してください。
MTUデバイスでH-VPLSを設定するには:
インターフェイスを設定します。
カスタマーエッジに接続するPE-rデバイスインターフェイスで、VPLSカプセル化タイプとVPLSアドレスファミリーのいずれかを設定します。これにより VPLS が有効になります。
コアに面したインターフェイスで、MPLS ラベルを有効にします。IS-ISがコアで使用されているため、コアに面したインターフェイスでもISOアドレスが必要です。
[edit interfaces] user@PE2# set ge-2/0/6 encapsulation ethernet-vpls user@PE2# set ge-2/0/6 unit 0 family vpls user@PE2# set ge-2/0/10 unit 0 family inet address 192.0.2.4/24 user@PE2# set ge-2/0/10 unit 0 family iso user@PE2# set ge-2/0/10 unit 0 family mpls user@PE2# set lo0 unit 0 family inet address 10.255.14.216/32 user@PE2# set lo0 unit 0 family iso address 49.0001.0102.5501.4216.00
インターフェイスでMPLSとLDPを有効にします。
他のPEデバイスに接続するMTUデバイスインターフェイスで、MPLSとLDPを設定します。
[edit protocols mpls] user@PE2# set interface ge-2/0/10.0 [edit protocols ldp ] user@PE2# set interface ge-2/0/10.0 user@PE2# set interface lo0.0
インターフェイスでルーティングを有効にします。
他のPEデバイスに接続するMTUデバイスインターフェイスで、OSPFやIS-ISなどの内部ゲートウェイプロトコル(IGP)を設定します。
[edit protocols isis] user@PE2# set level 1 disable user@PE2# set interface ge-2/0/10.0 user@PE2# set interface lo0.0
VPLSを設定します。
ステートメントは
neighbor 10.255.14.217
、デバイスPE1のループバックインターフェイスアドレスを指し示します。VPLS ID は、MTU(デバイス PE1)で設定された仮想回線 ID と一致する必要があります。
[edit routing-instances customer] user@PE2# set instance-type vpls user@PE2# set interface ge-2/0/6.0 user@PE2# set protocols vpls vpls-id 601 user@PE2# set protocols vpls neighbor 10.255.14.217
ルーターIDを設定します。
[edit routing-options] user@PE2# set router-id 10.255.14.216
結果
設定モードから、 、show routing-instances
show protocols
および のコマンドをshow interfaces
入力して設定をshow routing-options
確認します。出力結果に意図した設定が表示されない場合は、この例の手順を繰り返して設定を修正します。
デバイスPE1
user@PE1# show interfaces
ge-2/0/5 {
encapsulation ethernet-ccc;
unit 0 {
family ccc;
}
}
ge-2/0/10 {
unit 0 {
family inet {
address 192.0.2.2/24;
}
family iso;
family mpls;
}
}
ge-2/0/11 {
unit 0 {
family inet {
address 192.0.2.3/24;
}
family iso;
family mpls;
}
}
lo0 {
unit 0 {
family inet {
address 10.255.14.217/32;
}
family iso {
address 49.0001.0102.5501.4217.00;
}
}
}
user@PE1# show protocols
mpls {
interface ge-2/0/10.0;
interface ge-2/0/11.0;
}
isis {
level 1 disable;
interface ge-2/0/10.0;
interface ge-2/0/11.0;
interface lo0.0;
}
ldp {
interface ge-2/0/10.0;
interface ge-2/0/11.0;
interface lo0.0;
}
l2circuit {
neighbor 10.255.14.225 {
interface ge-2/0/5.0 {
virtual-circuit-id 601;
backup-neighbor 10.255.14.216 {
standby;
}
}
}
}
user@PE1# show routing-options
router-id 10.255.14.217;
デバイスPE2
user@PE2# show interfaces
ge-2/0/6 {
encapsulation ethernet-vpls;
unit 0 {
family vpls;
}
}
ge-2/0/10 {
unit 0 {
family inet {
address 192.0.2.4/24;
}
family iso;
family mpls;
}
}
lo0 {
unit 0 {
family inet {
address 10.255.14.216/32;
}
family iso {
address 49.0001.0102.5501.4216.00;
}
}
}
user@PE2# show protocols
mpls {
interface ge-2/0/10.0;
}
isis {
level 1 disable;
interface ge-2/0/10.0;
interface lo0.0;
}
ldp {
interface ge-2/0/10.0;
interface lo0.0;
}
user@PE2# show routing-instances
customer {
instance-type vpls;
interface ge-2/0/6.0;
protocols {
vpls {
vpls-id 601;
neighbor 10.255.14.217;
}
}
}
user@PE2# show routing-options
router-id 10.255.14.216;
デバイスの設定が完了したら、設定モードから を入力します commit 。
検証
設定が正しく機能していることを確認します。
レイヤー 2 回線の検証
目的
レイヤー 2 回線が MTU デバイスで動作していることを確認します。
アクション
動作モードから、 コマンドを show l2circuit connections
入力します。
user@PE1> show l2circuit connections Layer-2 Circuit Connections: Legend for connection status (St) EI -- encapsulation invalid NP -- interface h/w not present MM -- mtu mismatch Dn -- down EM -- encapsulation mismatch VC-Dn -- Virtual circuit Down CM -- control-word mismatch Up -- operational VM -- vlan id mismatch CF -- Call admission control failure OL -- no outgoing label IB -- TDM incompatible bitrate NC -- intf encaps not CCC/TCC TM -- TDM misconfiguration BK -- Backup Connection ST -- Standby Connection CB -- rcvd cell-bundle size bad SP -- Static Pseudowire LD -- local site signaled down RS -- remote site standby RD -- remote site signaled down XX -- unknown Legend for interface status Up -- operational Dn -- down Neighbor: 10.255.14.216 Interface Type St Time last up # Up trans ge-2/0/5.0(vc 601) rmt ST Neighbor: 10.255.14.225 Interface Type St Time last up # Up trans ge-2/0/5.0(vc 601) rmt Up Oct 5 19:38:15 2012 1 Remote PE: 10.255.14.225, Negotiated control-word: No Incoming label: 299872, Outgoing label: 800001 Negotiated PW status TLV: No Local interface: ge-2/0/5.0, Status: Up, Encapsulation: ETHERNET
意味
予想通り、デバイスPE3へのレイヤー2回線接続が動作しており、デバイスPE2への接続はスタンバイモードです。
VPLS接続の確認
目的
VPLS 接続が PE-r デバイスで動作していることを確認します。
アクション
動作モードから、 コマンドを show vpls connections
入力します。
user@PE2> show vpls connections Layer-2 VPN connections: Legend for connection status (St) EI -- encapsulation invalid NC -- interface encapsulation not CCC/TCC/VPLS EM -- encapsulation mismatch WE -- interface and instance encaps not same VC-Dn -- Virtual circuit down NP -- interface hardware not present CM -- control-word mismatch -> -- only outbound connection is up CN -- circuit not provisioned <- -- only inbound connection is up OR -- out of range Up -- operational OL -- no outgoing label Dn -- down LD -- local site signaled down CF -- call admission control failure RD -- remote site signaled down SC -- local and remote site ID collision LN -- local site not designated LM -- local site ID not minimum designated RN -- remote site not designated RM -- remote site ID not minimum designated XX -- unknown connection status IL -- no incoming label MM -- MTU mismatch MI -- Mesh-Group ID not available BK -- Backup connection ST -- Standby connection PF -- Profile parse failure PB -- Profile busy RS -- remote site standby SN -- Static Neighbor LB -- Local site not best-site RB -- Remote site not best-site VM -- VLAN ID mismatch Legend for interface status Up -- operational Dn -- down Instance: customer VPLS-id: 601 Neighbor Type St Time last up # Up trans 10.255.14.217(vpls-id 601) rmt Up Oct 8 14:46:54 2012 1 Remote PE: 10.255.14.217, Negotiated control-word: No Incoming label: 800001, Outgoing label: 299856 Negotiated PW status TLV: No Local interface: vt-2/0/10.84934913, Status: Up, Encapsulation: ETHERNET Description: Intf - vpls customer neighbor 10.255.14.217 vpls-id 601
user@PE3> show vpls connections Layer-2 VPN connections: Legend for connection status (St) EI -- encapsulation invalid NC -- interface encapsulation not CCC/TCC/VPLS EM -- encapsulation mismatch WE -- interface and instance encaps not same VC-Dn -- Virtual circuit down NP -- interface hardware not present CM -- control-word mismatch -> -- only outbound connection is up CN -- circuit not provisioned <- -- only inbound connection is up OR -- out of range Up -- operational OL -- no outgoing label Dn -- down LD -- local site signaled down CF -- call admission control failure RD -- remote site signaled down SC -- local and remote site ID collision LN -- local site not designated LM -- local site ID not minimum designated RN -- remote site not designated RM -- remote site ID not minimum designated XX -- unknown connection status IL -- no incoming label MM -- MTU mismatch MI -- Mesh-Group ID not available BK -- Backup connection ST -- Standby connection PF -- Profile parse failure PB -- Profile busy RS -- remote site standby SN -- Static Neighbor LB -- Local site not best-site RB -- Remote site not best-site VM -- VLAN ID mismatch Legend for interface status Up -- operational Dn -- down Instance: customer VPLS-id: 601 Neighbor Type St Time last up # Up trans 10.255.14.217(vpls-id 601) rmt Up Oct 8 14:46:54 2012 1 Remote PE: 10.255.14.217, Negotiated control-word: No Incoming label: 800001, Outgoing label: 299872 Negotiated PW status TLV: No Local interface: vt-2/0/10.68157697, Status: Up, Encapsulation: ETHERNET Description: Intf - vpls customer neighbor 10.255.14.217 vpls-id 601
意味
予想通り、VPLS 接続は両方の PE-r デバイスで動作しています。
接続性の確認
目的
デバイス CE1 がデバイス CE3 に ping を実行できることを確認します。
アクション
user@CE1> ping 10.255.14.218 PING 10.255.14.218 (10.255.14.218): 56 data bytes 64 bytes from 10.255.14.218: icmp_seq=0 ttl=64 time=0.858 ms 64 bytes from 10.255.14.218: icmp_seq=1 ttl=64 time=0.527 ms 64 bytes from 10.255.14.218: icmp_seq=2 ttl=64 time=0.670 ms ^C --- 10.255.14.218 ping statistics --- 3 packets transmitted, 3 packets received, 0% packet loss round-trip min/avg/max/stddev = 0.527/0.685/0.858/0.136 ms
意味
出力は、H-VPLSが動作していることを示しています。
アクティブ擬似回線から冗長擬似回線へのスイッチの手動トリガー
目的
デバイス PE1 とデバイス PE2 間の疑似配線が動作していることを確認します。
アクション
user@CE1> request l2circuit-switchover virtual-circuit-id 601 neighbor 10.255.14.225 user@CE1> ping 10.255.14.215 PING 10.255.14.215 (10.255.14.215): 56 data bytes 64 bytes from 10.255.14.215: icmp_seq=0 ttl=64 time=0.738 ms 64 bytes from 10.255.14.215: icmp_seq=1 ttl=64 time=0.627 ms 64 bytes from 10.255.14.215: icmp_seq=2 ttl=64 time=0.629 ms ^C --- 10.255.14.215 ping statistics --- 3 packets transmitted, 3 packets received, 0% packet loss round-trip min/avg/max/stddev = 0.627/0.665/0.738/0.052 ms
意味
デバイスCE1からデバイスCE2への pingが成功すると、デバイスPE1とPE2の間の疑似配線が動作していることを示しています。これで、デバイス CE1 からデバイス CE3 に ping を送信すると、ping は失敗するはずです。