セグメントルーティングでサポートされている標準
Junos OSでサポートされているセグメントルーティングRFCとインターネットドラフトについて説明します。
このトピックでは、Junos OSがサポートする、部分的にサポートする、またはサポートしていないセグメントルーティングRFCとインターネットドラフトの一覧を説明します。また、IETFが実験または情報として分類するRFCも特定されます。
サポートされているRFCとインターネットドラフト
Junos OSは、以下のセグメントルーティングRFCとインターネットドラフトをサポートしています。
対応RFC
-
RFC 5286、 IP高速再ルートの基本仕様:ループフリーの代替ルート
-
RFC 7471、 OSPFトラフィックエンジニアリング(TE)メトリック拡張
-
RFC 7490、 リモートループフリー代替(LFA)高速再ルート(FRR)
-
RFC 7684、 OSPFv2プレフィックス/リンク属性アドバタイズメント
-
RFC 7752、 BGPを使用したリンクステートおよびトラフィック制御(TE)情報の北回り配信
-
RFC 7855、 Source Packet Routing in Networking(SPRING)の問題ステートメントと要件
-
RFC 8102、 リモートLFAノード保護と管理性
-
RFC 8277、 BGPを使用してMPLSラベルをアドレスプレフィックスにバインド
-
RFC 8287、 セグメントルーティング用のLSP ping/traceroute
-
RFC 8403、 拡張可能でトポロジーを認識するMPLSデータプレーン監視システム
-
RFC 8426、 RSVP-SR共存
-
RFC 8571、 BGP - IGPトラフィック制御パフォーマンスメトリック拡張のリンク状態(BGP-LS)アドバタイズメント
-
RFC 8604、 セグメントルーティングによる数百万のエンドポイントの相互接続
-
RFC 8660、 MPLSデータプレーンを使用したセグメントルーティング
-
RFC 8661、LDPとのセグメントルーティングMPLS相互作用
-
RFC 8665、 セグメントルーティング用のOSPF拡張
-
RFC 8690、 RFC 8287のセグメントIDサブTLV長の明確化
-
RFC 8986、 セグメントルーティング over IPv6(SRv6)ネットワークプログラミング
-
RFC 9085、セグメント ルーティング用の境界ゲートウェイプロトコル - リンク状態(BGP-LS)拡張
-
RFC 9086、 境界ゲートウェイプロトコル - セグメントルーティングBGP egressピアエンジニアリング用のリンクステート(BGP-LS)拡張
-
RFC 9256、 セグメントルーティングポリシーアーキテクチャ
-
RFC 9252、 IPv6(SRv6)上のセグメントルーティングに基づくBGPオーバーレイサービス
-
RFC 9350、 IGPフレキシブルアルゴリズム
-
RFC 9800、 圧縮SRv6セグメントリストエンコーディング(部分サポート)。SRv6 Micro-SIDのみをサポートします。
-
RFC 9819、 IPv6(SRv6)上のセグメントルーティングにおけるBGPサービスの引数シグナリング
サポートされているインターネットドラフト
-
draft-agrawal-spring-srv6-mpls-interworking-06、 SRv6、MPLSの相互作用
サービスインターワーキングをサポートします。
-
draft-bashandy-rtgwg-segment-routing-ti-lfa、 セグメントルーティングを使用したトポロジー非依存高速再ルート
-
draft-bashandy-rtgwg-segment-routing-uloop、セグメントルーティングによるマイクロセグメントルーティング回避
-
draft-filsfils-rtgwg-segment-routing-use-cases-02、 セグメントルーティングのユースケース
-
draft-filsfils-spring-sr-policy-considerations-05、 SRポリシーの実装と導入に関する考慮事項
-
draft-filsfils-spring-sr-traffic-counters、 SRトラフィックカウンター
-
draft-ietf-idr-bgp-prefix-sid、 BGPプレフィックス用のBGPセグメントのアドバタイズ BGP
-
draft-ietf-idr-bgpls-segment-routing-epe、 SRを使用したエグレスピアトラフィックエンジニアリング用のBGP-LS拡張
-
draft-ietf-idr-segment-routing-te-policy、BGP経由でSR-TEポリシーをアドバタイズする
-
draft-ietf-idr-segment-routing-te-policy-09、 BGPでのセグメントルーティングポリシーのアドバタイズ
-
draft-ietf-lsr-isis-srv6-extensions、 IPv6データプレーン上でのセグメントルーティングをサポートするためのIS-IS拡張
-
draft-ietf-ospf-segment-routing-extensions、 SRセグメントを配信するためのOSPF拡張
-
draft-ietf-pce-segment-routing、 コントローラからSR-TEパスを設定するためのPCE拡張(サウスバウンド)
-
draft-ietf-isis-segment-routing-extensions、 SRセグメントを配信するためのIS-IS拡張
-
draft-ietf-rtgwg-segment-routing-ti-lfa-04、セグメント ルーティングを使用したトポロジー非依存高速セグメントルーティング
-
draft-ietf-spring-conflict-resolution, セグメントルーティング MPLSの競合解決
-
draft-ietf-spring-resiliency-use-cases, SPRINGネットワークにおける耐障害性の使用事例
-
draft-ietf-spring-segment-routing-central-epe、 SR 集中型 BGP エグレス ピア エンジニアリング
-
draft-ietf-spring-segment-routing-mpls、 MPLS転送によるセグメントルーティングの詳細
-
draft-ietf-spring-segment-routing-policy-07.txt、 セグメントルーティングポリシーアーキテクチャ
-
draft-kaliraj-idr-bgp-classful-transport-planes-12、 BGPクラスフルトランスポートプレーン
-
draft-ali-6man-srv6-vpn-icmp-error-handling-00 SRv6ベースVPNネットワークにおけるICMPエラー処理
部分的にサポートされているRFCとインターネットドラフト
Junos OSは、以下のセグメントルーティングRFCとインターネットドラフトを部分的にサポートしています。
部分的にサポートされているRFC
-
RFC 4971、 アドバタイズルーター情報用の中間システム間(IS-IS)拡張(部分サポート)
-
RFC 8402、 セグメントルーティングアーキテクチャ(部分サポート)
-
RFC 8570、 IS-ISトラフィックエンジニアリング(TE)メトリック拡張(部分サポート)
リンク遅延関連のパラメーターをサポートします。
-
RFC 8663、 IP上のMPLSセグメントルーティング(部分サポート)
-
RFC 8919、 IS-ISアプリケーション固有のリンク属性(部分サポート)
-
RFC 9862、 セグメントルーティング(SR)ポリシー候補パス用のパス計算要素通信プロトコル(PCEP)拡張
SRPOLICY-CAPABILITY TLV の処理に若干の逸脱があります。この実装は、PCEP Open オブジェクトの SRPOLICY-CAPABILITY TLV を義務付けていないdraft-ietf-pce-segment-routing-policy-cp-05仕様に準拠しています。その結果、PCCはこのTLVをアドバタイズせず、RFC 9862を厳格に施行するピアとのPCEPセッション確立に失敗します。PCEPスピーカーが事前のTLV交換なしにSRPAオブジェクトを受信した場合、PCErrメッセージ(Error-Type=10 "Reception of an invalid object" and Error-value=44 "Missing SRPOLICY-CAPABILITY TLV")を送信し、セッションを終了する必要があります。
-
RFC 9603、 IPv6セグメントルーティング用のパス計算要素通信プロトコル(PCEP)拡張
-
Junos OS は、PCEP オープン メッセージで常に N ビットを 0 に設定します。
-
パス計算クライアント(PCC)およびセグメントルーティングトラフィックエンジニアリング(SR-TE)は、ネットワークアクセス識別子(NAI)をSRv6セグメント識別子(SID)に解決できません。
-
SR-TEは、Vビットが1に設定されている場合を含め、明示的なルートオブジェクト(ERO)のSIDを検証しません。
-
部分的にサポートされているインターネットドラフト
-
draft-ali-spring-sr-traffic-accounting、 SRトラフィックマトリクスアカウンティング(部分サポート)
カウンターのみをサポートします。
-
draft-ginsberg-isis-prefix-attributes、 拡張IPv4およびIPv6到達可能性用のIS-ISプレフィックス属性(部分サポート)
-
draft-ietf-spring-ipv6-use-cases、 ネットワークにおけるIPv6ソースパケットルーティングのユースケース(部分サポート)
-
draft-ietf-spring-segment-routing-msdc、 大規模データセンターのBGPプレフィックスセグメント(部分サポート)
-
draft-ietf-spring-segment-routing-policy、 TEのSRポリシー(部分サポート)
-
draft-xu-mpls-sr-over-ip、 IP上のMPLSセグメントルーティング(部分サポート)
実験的および情報用のRFC
以下のRFCは標準を定義していませんが、セグメントルーティングおよび関連技術に関する情報を提供します。IETF は、これらの RFC を「実験」または「情報」として別に分類しています。
-
RFC 6571、 サービスプロバイダ(SP)ネットワークにおけるループフリーの代替(LFA)適用可能性
-
RFC 9087、 セグメントルーティング集中型BGPエグレスピアエンジニアリング
サポートされていないRFC
以下のセグメントルーティングRFCとインターネットドラフトは、Junos OSではサポートされていません。
-
RFC 5642、 OSPFの動的ホスト名交換メカニズム
-
RFC 8668、 IS-ISのレイヤー2バンドルメンバーリンク属性のアドバタイズ
これらのラベルの IS-IS アドバタイズはサポートされていないため、実装ではメンバー リンクの静的 MPLS ラベル割り当てがサポートされています。
-
RFC 9871、 BGPカラー認識ルーティング(CAR)
-
RFC 9960、 セグメントルーティングポイントツーマルチポイントポリシー
-
RFC 9524、 マルチポイントサービス提供のためのセグメントルーティングレプリケーション