Présentation de Junos OS CoS
Lorsqu’un réseau subit une congestion et des retards, certains paquets doivent être abandonnés. La classe de service (CoS) de Junos OS vous permet de diviser le trafic en classes et de définir différents niveaux de débit et de perte de paquets en cas de congestion. Vous avez un meilleur contrôle sur la perte de paquets car vous pouvez configurer des règles adaptées à vos besoins.
Vous pouvez configurer les fonctionnalités CoS pour fournir plusieurs classes de service pour différentes applications. Le CoS vous permet également de réécrire le point de code des services différenciés (DSCP) ou les bits de point de code IEEE 802.1p des paquets quittant une interface, ce qui vous permet d’adapter les paquets aux exigences réseau des pairs distants.
Le CoS fournit plusieurs classes de service pour différentes applications. Vous pouvez configurer plusieurs classes de transfert pour transmettre des paquets, définir quels paquets sont placés dans chaque file d’attente de sortie, planifier le niveau de service de transmission pour chaque file d’attente et gérer la congestion à l’aide d’un algorithme de détection précoce aléatoire pondérée (WRED).
Lors de la conception de CoS applications, vous devez examiner attentivement vos besoins en matière de services, et vous devez planifier et concevoir minutieusement votre configuration CoS afin de garantir la cohérence et l’interopérabilité entre toutes les plates-formes d’un domaine CoS.
Le CoS étant implémenté dans le matériel plutôt que dans le logiciel, vous pouvez expérimenter et déployer CoS fonctionnalités sans affecter les performances de transfert de paquets et de commutation.
Les stratégies CoS peuvent être activées ou désactivées sur chaque interface de commutateur. En outre, chaque interface physique et logique du commutateur peut avoir des règles CoS personnalisées associées.
Lorsque vous modifiez ou lorsque vous désactivez puis réactivez la configuration de classe de service, le système subit des pertes de paquets, car le système bloque momentanément le trafic pour modifier le mappage du trafic entrant aux files d’attente d’entrée.
Cette rubrique décrit :
Normes CoS
Les RFC suivants définissent les normes relatives aux capacités CoS :
-
RFC 2474, Définition du champ Services différenciés dans les en-têtes IPv4 et IPv6
-
RFC 2597, Assured Forwarding Groupe PHB
-
RFC 2598, Un PHB de transfert accéléré
-
RFC 2698, un marqueur à deux débits et trois couleurs
-
RFC 3168, Ajout de la notification explicite de congestion (ECN) à l’IP
Les normes DCB (Data Center Bridging) suivantes sont également prises en charge afin de fournir les CoS (et d’autres caractéristiques) requises par Fibre Channel over Ethernet (FCoE) pour transmettre le trafic de stockage sur un réseau Ethernet :
-
IEEE 802.1Qbb, contrôle de flux basé sur la priorité (PFC)
-
IEEE 802.1Qaz, sélection de transmission améliorée (ETS)
-
Extension IEEE 802.1AB (LLDP) appelée Data Center Bridging Capability Exchange Protocol (DCBX)
Fonctionnement de la CoS de Junos OS
Junos OS CoS examine le trafic entrant à la périphérie de votre réseau. Le commutateur classe le trafic en groupes de services définis afin de traiter le trafic sur le réseau de manière spéciale. Par exemple, vous pouvez envoyer du trafic vocal sur certaines liaisons et du trafic de données sur d’autres liaisons. De plus, les flux de trafic de données peuvent être desservis différemment le long du chemin réseau pour garantir un meilleur service aux clients les plus rémunérateurs. Lorsque le trafic quitte le réseau par la périphérie distante, vous pouvez le reclasser pour qu’il réponde aux stratégies de l’homologue ciblé en réécrivant les bits de point de code DSCP ou IEEE 802.1.
Pour prendre en charge le CoS, vous devez configurer chaque commutateur du réseau. En général, chaque commutateur examine les paquets qui y pénètrent pour déterminer leurs paramètres CoS. Ces paramètres déterminent quels paquets sont transmis en premier au commutateur en aval suivant. Les commutateurs situés en périphérie du réseau peuvent être nécessaires pour modifier les paramètres CoS des paquets qui entrent dans le réseau afin de classer les paquets dans les groupes de services appropriés.
Sur la Figure 1, le commutateur A reçoit du trafic. À chaque paquet, le commutateur A examine les paramètres CoS actuels du paquet et classe le trafic dans l’un des regroupements définis sur le commutateur. Cette définition permet au commutateur A de hiérarchiser ses ressources pour traiter les flux de trafic qu’il reçoit. Le commutateur A peut modifier les paramètres CoS (classe de transfert et priorité de perte) des paquets pour mieux correspondre aux groupes de trafic définis.
Lorsque le commutateur B reçoit les paquets, il examine les paramètres CoS, détermine les groupes de trafic appropriés et traite le paquet en fonction de ces paramètres. Il transmet ensuite les paquets au commutateur C, qui effectue les mêmes actions. Le commutateur D examine également les paquets et détermine les groupes appropriés. Comme le commutateur D se trouve à l’extrémité du réseau, il peut reclasser (réécrire) les bits de point de code CoS des paquets avant de les transmettre.
Comportement CoS par défaut
Si vous ne configurez pas CoS paramètres, le logiciel exécute certaines fonctions CoS pour s’assurer que le système transfère le trafic et les paquets de protocole avec un délai minimal lorsque le réseau rencontre des congestion. Certains paramètres CoS, tels que les classificateurs, sont automatiquement appliqués à chaque interface logique que vous configurez. D’autres paramètres, tels que les règles de réécriture, ne sont appliqués que si vous les associez explicitement à une interface.