Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Ejemplo Configuración del espejado de puertos para análisis remoto

 

Utilice la creación de reflejos de puertos para enviar tráfico a aplicaciones que analicen el tráfico con el fin de supervisar el cumplimiento, aplicar políticas, detectar intrusiones, supervisar y predecir los patrones de tráfico, correlacionar eventos, etc. El duplicado del puerto copia los paquetes que entran o salen de una interfaz o que entran en una VLAN, y las envía a una interfaz local para su supervisión local o a una VLAN para la supervisión remota. Este ejemplo describe cómo configurar el espejeado de puertos para análisis remoto.

Aplicables

En este ejemplo se utilizan los siguientes componentes de hardware y software:

  • Junos OS versión 13,2 para el serie QFX

  • Un conmutador

Descripción general y topología

Este tema incluye dos ejemplos relacionados que describen cómo reflejar el tráfico que entra en los puertos del conmutador en una VLAN de analizador, de modo que pueda realizar análisis con un dispositivo remoto. El primer ejemplo muestra cómo reflejar todo el tráfico enviado por los equipos de los empleados al conmutador. El segundo ejemplo incluye un filtro para reflejar solo el tráfico de los empleados que se dirige al Web.

En este ejemplo:

  • ge-0/0/0 Y ge-0/0/1 son interfaces de capa 2 que se conectan a los equipos de los empleados.

  • ge-0/0/2 Es una interfaz de capa 2 que se conecta a otro conmutador.

  • La remote-analyzer VLAN se configura en todos los conmutadores de la topología para llevar el tráfico reflejado.

Nota

Además de realizar los pasos de configuración que se describen aquí, también debe configurar la VLAN delremote-analyzer analizador (en este ejemplo) de los otros conmutadores que se utilizan para conectar el conmutador de origen (el que se encuentra en esta configuración) al estación está conectada a.

Espejado de todo el tráfico de empleados para análisis remoto

Configuración rápida de CLI

Para configurar rápidamente esta sección del ejemplo, copie los siguientes comandos, péguelos en un archivo de texto, elimine los saltos de línea, cambie los detalles necesarios para que coincidan con su configuración de red y, a continuación, copie y edit pegue los comandos en la CLI en la nivel de jerarquía:

[edit]
set vlans remote-analyzer vlan-id 999
set interfaces ge-0/0/10 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/10 unit 0 family ethernet-switching vlan members 999
set forwarding-options analyzer employee-monitor input ingress interface ge-0/0/0.0
set forwarding-options analyzer employee-monitor input ingress interface ge-0/0/1.0
set forwarding-options analyzer employee-monitor output vlan remote-analyzer

Procedimiento detallado

Para configurar el reflejo de Puerto remoto básico:

  1. Configure la VLAN del analizador remote-analyzer (a la que se llama en este ejemplo):
    [edit vlans]

    user@switch# set vlans remote-analyzer vlan-id 999
  2. Configure la interfaz conectada a otro conmutador para el modo de Troncalización y remote-analyzer asóciela con la VLAN:
    [edit interfaces]

    user@switch# set ge-0/0/10 unit 0 family ethernet-switching port-mode trunk

    user@switch# set ge-0/0/10 unit 0 family ethernet-switching vlan members 999
  3. Configure employee-monitor el analizador:
    [edit forwarding-options]

    user@switch# set analyzer employee–monitor

    user@switch# set analyzer employee-monitor input ingress interface ge-0/0/0.0

    user@switch# set analyzer employee-monitor input ingress interface ge-0/0/1.0

    user@switch# set analyzer employee-monitor output vlan remote-analyzer

  4. Configure remote-analyzer la VLAN en los conmutadores que conectan este conmutador a la estación de trabajo de supervisión.

Resultados

Compruebe los resultados de la configuración:

Cómo reflejar el tráfico entre el empleado y la web para análisis remoto

Configuración rápida de CLI

Para configurar rápidamente esta sección del ejemplo, copie los siguientes comandos, péguelos en un archivo de texto, elimine los saltos de línea, cambie los detalles necesarios para que coincidan con su configuración de red y, a continuación, copie y edit pegue los comandos en la CLI en la nivel de jerarquía:

[edit]
set vlans remote-analyzer vlan-id 999
set interfaces ge-0/0/10 unit 0 family ethernet-switching interface-mode trunk
set interfaces ge-0/0/10 unit 0 family ethernet-switching vlan members 999set forwarding-options port-mirroring instance employee-web-monitor loss-priority high output vlan 999
set firewall family ethernet-switching filter watch-employee term employee-to-web from destination-port 80
set firewall family ethernet-switching filter watch-employee term employee-to-web then port-mirror-instance employee-web-monitor employee-web-monitor
set ge-0/0/0 unit 0 family ethernet-switching filter input watch-employee
set interfaces ge-0/0/1 unit 0 family ethernet-switching filter input watch-employee

Procedimiento detallado

  1. Configure la VLAN del analizador remote-analyzer (a la que se llama en este ejemplo):
    [edit vlans]

    user@switch# set remote-analyzer vlan-id 999
  2. Configure una interfaz para asociarla con remote-analyzer la VLAN:
    [edit interfaces]

    user@switch# set interfaces ge-0/0/10 unit 0 family ethernet-switching interface-mode trunk

    user@switch# set ge-0/0/10 unit 0 family ethernet-switching vlan members 999

  3. Configure employee-web-monitor el analizador. (Configure solo la—salida que la entrada procede del filtro.)
    [edit forwarding-options]

    user@switch# set forwarding-options port-mirroring instance employee-web-monitor output vlan 999
  4. Configure un filtro de watch-employee Firewall llamado para hacer coincidir el tráfico enviado al Web y envíelo employee-web-monitoral analizador:
    [edit firewall family ethernet-switching]

    user@switch# set filter watch-employee term employee-to-web from destination-port 80

    user@switch# set filter watch-employee term employee-to-web then port-mirror-instance employee-web-monitor
  5. Aplique el filtro Firewall a las interfaces adecuadas como filtro de ingreso:
    [edit interfaces]

    user@switch# set ge-0/0/0 unit 0 family ethernet-switching filterinput watch-employee

    user@switch# set ge-0/0/1 unit 0 family ethernet-switching filter input watch-employee
  6. Configure remote-analyzer la VLAN en los conmutadores que conectan este conmutador a la estación de trabajo de supervisión.

Resultados

Compruebe los resultados de la configuración:

Comproba

Verificación de que el analizador se ha creado correctamente

Finalidad

Compruebe que el analizador o employee-monitoremployee-web-monitor el nombre se haya creado en el conmutador con las interfaces de entrada apropiadas y una interfaz de salida adecuada.

Acción

Puede verificar que el analizador de Mirror del puerto esté configurado según lo show analyzer esperado mediante el comando.

user@switch> show analyzer

Significado

Esta salida muestra que el employee-monitor analizador está espejando el tráfico que ge-0/0/0 entra ge-0/0/1 y envía el tráfico de duplicación al analizador remote-analyzer.