Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation  Back up to About Overview 
  
[+] Expand All
[-] Collapse All

Operating System Prerequisite Packages

This section lists the operating system packages that are required to install Signalware on a Linux platform. For more details about operating system requirements, see the Signalware SP Release 9 Service Pack 6 Linux Installation Manual.

Note: If you modify any kernel module, you need to execute the swcommission(1s) script again as well as configure Signalware.

To configure Signalware:

  • Configure the computing element (configurePlatform(1s))
  • Commission the drivers (swcommission(1s))
  • Configure the nodes (configureNodes(1s))
  • Perform provisioning

Red Hat Enterprise Linux Release 6

Ensure that the following packages are installed on the Red Hat Enterprise Linux Release 6 operating system:

  • kernel-2.6.32-44.2.el6 or later, configured with SMP enabled
  • kernel-devel-2.6.32-44.2.el6 or later, matching the running SMP-enabled kernel
  • kernel-headers-2.6.32-44.2.el6.x86_64 or later, matching the running SMP-enabled kernel
  • bash-4.1.2-3.el6.x86_64 or later
  • bind-utils-9.7.0-5.P2.el6 and bind-libs-9.7.0-5.P2.el6 or later
  • coreutils-8.4-9.el6 or later
  • rpm-4.8.0-10.el6 or later
  • gcc, libstdc++, libstdc++-devel, version 4.4.4-10.el6 or later
  • glibc, glibc-devel, version 2.12-1.4.el6 or later
  • xinetd-2.3.14-29.el6 or later
  • java-1.6.0-openjdk-1.6.0.0-1.20.b17.el6 or later

64-Bit x86_64 Red Hat Installations

On 64-bit Red Hat installations, both the 32-bit and 64-bit versions of Red Hat glibc, glibcdevel, libstdc++, and libgcc package RPMs must be installed.

To verify that the system contains both 32-bit and 64-bit versions of these GCC compiler tools packages, type:

rpm -q --queryformat “%{name}-%{version}-%{release}-%{arch}\n” glibc glibc-devel libstdc++ libgcc

This rpm command must return a report as follows where xxx is the version number:

  • glibc-xxx-x86_64
  • glibc-xxx-i686
  • glibc-devel-xxx-x86_64
  • glibc-devel-xxx-i386
  • glibc-devel-xxx-i686 (RHEL 6 only)
  • libstdc++-xxx-x86_64
  • ibstdc++-xxx-i386
  • libstdc++-xxx-i686 (RHEL 6 only)
  • libgcc-xxx-x86_64
  • libgcc-xxx-i386
  • libgcc-xxx-i686 (RHEL 6 only)

Only the 64-bit version of libstdc++-devel needs to be installed. To verify that the system contains the 64-bit version of the libstdc++-devel package, type:

rpm -q --queryformat “%{name}-%{version}-%{release}-%{arch}\n” libstdc++-devel

This must return a report as follows where xxx is the version number:

libstdc++-devel-xxx-x86_64

Red Hat Enterprise Linux Release 7.2

Ensure that the following packages are installed on the Red Hat Enterprise Linux Release 7.2 operating system:

  • kernel-3.10.0-229.11.1.el7.x86_64 or higher, configured with smp enabled
  • kernel-devel-3.10.0-229.11.1.el7.x86_64 or higher, matching the running smp enabled kernel
  • kernel-headers-3.10.0-229.11.1.el7.x86_64 or higher, matching the running smp enabled kernel
  • bash-4.2.46-12.el7 or higher
  • bind-utils-9.9.4-18.el7 and bind-libs-lite-9.9.4-18.el7 or higher
  • coreutils-8.22-12.el7 or higher
  • rpm-4.11.1-25.el7 or higher
  • gcc, version 4.8.3-9.el7 or higher
  • 64 bit libstdc++, libstdc++-devel, version 4.8.3-9.el7 or higher
  • 32 bit libstdc++, libstdc++-devel, version 4.8.3-9.el7 or higher
  • 64 bit glibc, glibc-devel, version glibc-2.17-78.el7 or higher
  • 32 bit glibc, glibc-devel, version glibc-2.17-78.el7 or higher
  • xinetd-2.3.15-12.el7 or higher
  • java-1.6.0-openjdk-1.6.0.0-1.20.b17 or higher
  • perl-Env-1.04-2.el7

Modified: 2017-10-26