Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation  Back up to About Overview 
  
[+] Expand All
[-] Collapse All

Other Prerequisites to Install Signalware on a Linux Platform

The following are the prerequisites to install Signalware on a Linux platform:

  • Uninstall any operating system Stream Control Transmission Protocol (SCTP) packages before installing Signalware. For example, none of the following packages should be installed:
    [root@sbr-wf-eng1 ~]# yum info *sctp*
        Loaded plugins: product-id, rhnplugin, subscription-manager
        Updating Red Hat repositories.
        Available Packages
        Name        : lksctp-tools
        Arch        : x86_64
        Version     : 1.0.10
        Release     : 5.el6
        Size        : 77 k
        Repo        : rhel-x86_64-server-6
        Summary     : User-space access to Linux Kernel SCTP
        License     : GPLv2 and GPLv2+ and LGPLv2 and BSD
        Description : This is the lksctp-tools package for Linux Kernel SCTP Reference Implementation. This package is intended to supplement the Linux Kernel SCTP Reference Implementation now available in the Linux kernel source tree in  versions 2.5.36 and later.  For more information about LKSCTP, see the package documentation README file, section titled "LKSCTP - Linux Kernel SCTP." This package contains the base run-time library and command-line tools.
  • If you are using a Red Hat Enterprise Linux 6.6 machine, set the SELINUX parameter in the /etc/selinux/config file to disabled.
  • Copy the Signalware 9 license file to the /etc directory.
    • If you are migrating from an existing installation, you can use the existing Signalware 9 license as long as the license is applied on the same host (hostid).
    • To obtain a new license file for Signalware 9, contact your Juniper Networks representative.
  • Create a UNIX user account called siguser as a member of the users group.
  • Download Signalware packages to a temporary working directory or copy from a Signalware CD.
    • For Red Hat Enterprise Linux 6, download “Signalware 9 SP6.0” and “Signalware 9 SP6.V” or “Signalware 9 SP6.1”.
    • For Red Hat Enterprise Linux 7.2, download “Signalware 9 SP6.v” and “Signalware 9 SP6.1”.

      Note: Signalware installation has been tested only with the Red Hat Enterprise Linux 6.7 and 7.2 versions.

  • Install the Signalware packages.
    • For Red Hat Enterprise Linux 6, install the “Signalware 9 SP6.0” package first and then upgrade to “Signalware 9 SP6.V” or “Signalware 9 SP6.1”.
    • For Red Hat Enterprise Linux 7.2, install the “Signalware 9 SP6.v” package first and then upgrade to “Signalware 9 SP6.1”.
  • To troubleshoot errors that might occur during the installation and configuration process, see Troubleshooting Signalware Installation and Configuration.

Modified: 2016-10-21