Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation  Back up to About Overview 
  
[+] Expand All
[-] Collapse All

Navigating in the Web GUI

This section describes how to use the Web GUI menus and pages.

Web GUI Menus

The Web GUI has six menus: Home, RADIUS Configuration, Diameter Configuration, Tools, Help, and Logout.

Note: The Diameter Configuration menu is available only if you have installed a valid Diameter license.

Home Menu

The Home menu displays the Home page (Figure 5), which lists status of the running server, IP addresses, available authentication methods, license information, and any initialization errors that might have occurred.

Figure 5: Web GUI Home Page

Web GUI Home Page

RADIUS Configuration Menu

You use the entries in the RADIUS Configuration menu to configure RADIUS operations and display statistics. For example, to configure RADIUS clients and client groups, select RADIUS Configuration > RADIUS Clients. This displays the RADIUS Clients List page (Figure 6).

Figure 6: RADIUS Clients List Page

RADIUS Clients
List Page

Diameter Configuration Menu

You use the entries in the Diameter Configuration menu to configure Diameter operations and display Diameter statistics. For example, to configure local profiles, select Diameter Configuration > Policy > Local Profiles. This displays the Local Profiles List page (Figure 7).

Figure 7: Local Profiles List Page

Local Profiles
List Page

Tools Menu

Table 7 describes the functions of each entry in the Tools menu in the Web GUI.

Table 7: Tools Menu Options

Menu Entry

Function

License

Opens the License Registration page, which enables you to add a license string for your SBR Carrier software. For more information, see Adding License Keys.

Import

Opens the Browse Import File page, which enables you to import information from an XML file into the SBR Carrier database.

The Import Configuration page is described in Importing and Exporting Data.

Note: You cannot import Diameter configuration information to the SBR Carrier database.

Export

Opens the Export Configuration page, which enables you to export selected information from the SBR Carrier database to an XML file.

The Export Configuration page is described in Importing and Exporting Data.

Note: You cannot export Diameter configuration information to the XML file.

Backup/Restore

Opens the Backup/Restore page, which enables you to back up the SBR Carrier database to an archive file or restore SBR Carrier from an archive file.

Note: You cannot back up or restore Diameter configuration information.

Help Menu

Table 8 describes the functions of each entry in the Help menu in the Web GUI.

Table 8: Help Menu Options

Menu Entry

Function

Contents

Opens the online help for the Web GUI.

About

Displays the version information of SBR Carrier. For more information, see Displaying Version Information.

Logout Menu

The Logout menu terminates your connection to the SBR Carrier server.

Web GUI Pages

This section summarizes how to use Web GUI pages and controls.

Adding an Entry

To add an entry to the SBR Carrier database, open the appropriate Web GUI page and click the Add button. The Web GUI page displays a Create pane. Figure 8 displays a sample Create Profile pane.

Figure 8: Sample Create Pane

Sample Create Pane

Every object of the same type must have a unique name. If the name you assign to an item is already being used by another item of the same type, the Web GUI displays a warning.

Table 9 describes the functions of common GUI elements available on the Web GUI pages.

Table 9: Common Elements on Web GUI

GUI Element

Function

Add

Adds an object to the SBR Carrier database.

Edit

Edits an existing object in the SBR Carrier database.

Note: Active only when an object is selected in the active page.

Delete

Deletes an existing object from the SBR Carrier database.

Clone Mode

Enables the clone feature, which allows you to reuse an existing object and make the required changes to it.

Save

Saves any configurations or changes you have made to the server settings.

<

Displays the previous page entries.

>

Displays the next page entries.

<<

Displays the first page entries.

>>

Displays the last page entries.

Refreshes the displayed list of items in the Web GUI page.

Page

Displays the entries available on the entered page number.

Show

Select the number of entries to be displayed in a page.

Reset

Restores the default values for controls in the active page.

Load

Loads specific values (such as attributes, called station IDs, and IP addresses) for the cloned object from other objects that exist in the active page.

Note: The Load button is available only when the clone feature is enabled.

Clear

Clears all the values configured for controls in the active page.

Cancel

Cancels the action and exits from the active pane or dialog box.

Editing an Entry

To edit an existing entry in the SBR Carrier database, open the appropriate Web GUI page and select the entry you want to change. The Web GUI page displays the settings configured for the selected entry in a Selected pane. Depending on the page that you are working in, you may use a Save or OK button to save your changes.

While editing an existing entry, you cannot change the name associated with the entry. To change the name of an entry, use the Clone pane. For more information about the Clone pane, see Cloning an Entry.

Cloning an Entry

The clone feature enables you to reuse an existing entry and make the required changes to it instead of creating a new entry from scratch. To clone an existing entry:

  1. Open the appropriate Web GUI page and click the Clone Mode button.

    A message stating that clone mode is enabled pops up.

    Note: When the clone feature is enabled, the Add and Delete buttons are disabled. If you want to disable the clone feature when it is enabled, you need to click the Clone Mode button again.

  2. Select the entry you want to clone.

    The Web GUI page displays the settings configured for the selected entry in a Clone pane. Figure 9 displays a sample Clone Profile pane.

    Figure 9: Sample Clone Pane

    Sample Clone Pane
  3. Edit the name of the entry and the settings you want to change.

    The Load button is available for some configurations (such as attributes, called station IDs, and IP addresses). You can use the Load button to load specific values for the clone entry from other entries that exist in the active page.

  4. Click Save to save your changes. Some settings of the same entry type must be unique. If any one of those settings you configured for the duplicate entry is already being used by the original entry or another entry of the same type, the Web GUI displays a warning.

    A confirmation dialog box stating “Would you like to delete the existing object” is displayed.

  5. Click Yes if you want to delete the original entry or click No to skip deleting the original entry.

    The duplicated entry is added to the corresponding Web GUI page.

Resizing Columns

You can resize columns in a Web GUI page by dragging the column header boundary to the left or right.

Changing Column Sequence

You can change the sequence of columns in a Web GUI page by dragging the column headers left and right.

Sorting Information

By default, entries in Web GUI pages are sorted by names. You can sort the entries in ascending or descending order by clicking a column header.

To sort a table by more than one column (for example, sort first by address pool and then by IP address), click the least-significant column (IP Address), and then click the more significant columns (Address Pool).

Searching Entries

You can search for specific entries by specifying certain criteria to display only the entries that match the criteria. To find a specific entry in a Web GUI page, move your cursor on the column header and click the Down arrow. Then, move your cursor over the Filters check box and enter the searching criteria in the text box. The Web GUI page displays the entries that match the entered criteria. Clear the Filters check box after finding the specific entries.

Hiding or Restoring Columns

To hide or restore columns in a Web GUI page, move your cursor on the column header and click the Down arrow. Then, move your cursor over Columns and select or clear the corresponding check box of the column name.

Modified: 2016-11-15