[an error occurred while processing this directive] [an error occurred while processing this directive]

Example: Connecting an Access Switch to a Distribution Switch

In large local area networks (LANs), you commonly need to aggregate traffic from a number of access switches into a distribution switch.

This example describes how to connect an access switch to a distribution switch:

Contents

Requirements

This example uses the following hardware and software components:

  • For the distribution switch, one EX-series Latte L-24F switch. This model is designed to be used as a distribution switch for aggregation or collapsed core network topologies and in space-constrained data centers. It has twenty-four 1–Gigabit Ethernet fiber SPF ports and an uplink module with two 10–Gigabit Ethernet XFP ports.
  • For the access switch, one EX-series Espresso E-24P, which has twenty-four 1–Gigabit Ethernet ports, all of which support Power over Ethernet (PoE) and an uplink module with four 1–Gigabit Ethernet ports.
  • JUNOS 8.5B1 software (Hurricane software package)

Before you connect an access switch to a distribution switch, be sure you have:

  • Installed the two switches [add topic-xref]
  • Performed the initial software configuration on both switches [add topic-xref]

Overview and Topology

In a large office that is spread across several floors or buildings, or in a data center, you commonly aggregate traffic from a number of access switches into a distribution switch. This configuration example shows a simple topology to illustrate how to connect a single access switch to a distribution switch (see Figure xx).

Figure 1: Topology for Connecting an Access Switch to a Distribution Switch

Image .gif

[add topology figure here]

In this topology, the LAN is segmented into two VLANs, one for the sales department and the second for the support team. One 1–Gigabit Ethernet port on the access switch's uplink module connects to the distribution switch, to one 1–Gigabit Ethernet port on the distribution switch. Table xx explains the components of the example topology.

Table 1: Components of the Topology for Connecting an Access Switch to a Distribution Switch

PropertySettings

Access switch hardware

EX-series Espresso E-24P, 24 1–Gigabit Ethernet ports, all PoE-enabled (ge-0/0/0 through ge-0/0/23); one 4–port 1–Gigabit Ethernet uplink module (EM module)

Distribution switch hardware

EX-series Latte L-24F, 24 1–Gigabit Ethernet fiber SPF ports (ge-0/0/0 through ge-0/0/23); one 2–port 10–Gigabit Ethernet XFP uplink module

VLAN names and tag IDs

sales, tag 100
support, tag 200

VLAN subnets

sales: 192.0.2.0/25(addresses 192.0.2.1 through 192.0.2.126)
support: 192.0.2.128/25 (addresses 192.0.2.129through 192.0.2.254)

Trunk port interfaces

On the access switch: ge-0/1/0
On the distribution switch: ge-0/0/0

Access port interfaces in VLAN sales (on access switch)

Avaya IP telephones: ge-0/0/3 through ge-0/0/19
WAPs: ge-0/0/0 and ge-0/0/1
Printers: ge-0/0/22 and ge-0/0/23
File servers: ge-0/0/20and ge-0/0/21

Access port interfaces in VLAN support (on access switch)

Avaya IP telephones: ge-0/0/25 through ge-0/0/43
WAP: ge-0/0/24
Printers: ge-0/0/44 and ge-0/0/45
File servers: ge-0/0/46 and ge-0/0/47

Unused interfaces on access switch

ge-0/0/2 and ge-0/0/25

Configuration

To connect an access switch to a distribution switch, perform these tasks:

CLI Quick Configuration

To quickly configure the access switch, copy the following commands and paste them into the switch terminal window:


[edit]
set interfaces ge-0/0/0 unit 0 description “Sales WAP port”
set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members sales
set interfaces ge-0/0/3 unit 0 description “Sales phone port”
set interfaces ge-0/0/3 unit 0 family ethernet-switching vlan members sales
set interfaces ge-0/0/22 unit 0 description “Sales printer port”
set interfaces ge-0/0/22 unit 0 family ethernet-switching vlan members sales
set interfaces ge-0/0/20 unit 0 description “Sales file server port”
set interfaces ge-0/0/20 unit 0 family ethernet-switching vlan members sales
set interfaces ge-0/0/24 unit 0 description “Support WAP port”
set interfaces ge-0/0/24 unit 0 family ethernet-switching vlan members support
set interfaces ge-0/0/26 unit 0 description “Support phone port”
set interfaces ge-0/0/26 unit 0 family ethernet-switching vlan members support
set interfaces ge-0/0/44 unit 0 description “Support printer port”
set interfaces ge-0/0/44 unit 0 family ethernet-switching vlan members support
set interfaces ge-0/0/46 unit 0 description “Support file server port”
set interfaces ge-0/0/46 unit 0 family ethernet-switching vlan members support
set interfaces ge-0/1/0 unit 0 description “Uplink module port connection to distribution swithc”
set interfaces ge-0/1/0 unit 0 family ethernet-switching port-mode trunk
set interface ge-0/1/0 unit 0 family ethernet switching vlan members [ sales support]
set interfaces ge-0/1/0 unit 0 family ethernet-switching nativevlan-id 1
set interfaces vlan unit 0 family inet address 192.0.2.0/25
set interfaces vlan unit 1 family inet address 192.0.2.128/25
set vlans sales interfaces ge-0/0/0.0
set vlans sales interfaces ge-0/0/3.0
set vlans sales interfaces ge-0/0/22.0
set vlans sales interfaces ge-0/0/20.0
set vlans sales l3–interface vlan.0
set vlans sales vlan-id 100
set vlans sales vlan-description “Sales VLAN”
set vlans support interfaces ge-0/0/24.0
set vlans support interfaces ge-0/0/26.0
set vlans support interfaces ge-0/0/44.0
set vlans support interfaces ge-0/0/46.0
set vlans support vlan-id 200
set vlans support l3–interface vlan.1
set vlans support vlan-description “Support VLAN”

Step-by-Step Procedure

To configure the access switch:

  1. Configure the 1–Gigabit Ethernet interface on the uplink module to be the trunk port that connects to the distribution switch:
    [edit interfaces ge-0/1/0 unit 0]
    user@access-switch# set description “Uplink module port connection to distribution switch”
    user@access-switch# set ethernet-switching port-mode trunk
  2. Specify the VLANs to be aggregated on the trunk port:
    [edit interfaces ge-0/1/0 unit 0]
    user@access-switch# set ethernet-switching vlan members [ sales support ]
  3. Configure the VLAN ID to use for packets that are received with no dot1q tag:
    [edit interfaces ge-0/1/0 unit 0]
    user@access-switch# set ethernet-switching native-vlan-id 1
  4. Configure the sales VLAN:
    [edit vlans sales]
    user@access-switch# set vlan-description “Sales local area network”
    user@access-switch# set vlan-id 100
    user@access-switch# set l3–interface vlan.0
  5. Configure the support VLAN:
    [edit vlans support]
    user@access-switch# set vlan-description “Support local area network”
    user@access-switch# set vlan-id 200
    user@access-switch# set l3–interface vlan.1
  6. Create the subnet for the sales broadcast domain:
    [edit interfaces]
    user@access-switch# set vlan unit 0 family inet address 192.0.2.0/25
  7. Create the subnet for the support broadcast domain:
    [edit interfaces]
    user@access-switch# set vlan unit 1 family inet address 192.0.2.128/25
  8. Configure the interfaces in the sales VLAN:
    [edit interfaces]
    user@access—switch# set ge-0/0/0 unit 0 description “Sales WAP port”
    user@access—switch# set ge-0/0/0 unit 0 family ethernet-switching vlan members sales
    user@access—switch# set ge-0/0/3 unit 0 description “Sales phone port”
    user@access-switch# set ge-0/0/3 unit 0 family ethernet-switching vlan members sales
    user@access-switch# set ge-0/0/20 unit 0 description “Sales file server port”
    user@access—switch# set ge-0/0/20 unit 0 family ethernet-switching vlan members sales
    user@access-switch# set ge-0/0/22 unit 0 description “Sales printer port”
    user@access-switch# set ge-0/0/22 unit 0 family ethernet-switching vlan members sales
  9. Configure the interfaces in the support VLAN:
    [edit interfaces]
    user@access-switch# set ge-0/0/24 unit 0 description “Support WAP port”
    user@access-switch# set ge-0/0/24 unit 0 family ethernet-switching vlan members support
    user@access-switch# set ge-0/0/26 unit 0 description “Support phone port”
    user@access—switch# set ge-0/0/26 unit 0 family ethernet-switching vlan members support
    user@access-switch# set ge-0/0/44 unit 0 description “Support printer port”
    user@access-switch# set ge-0/0/44 unit 0 family ethernet-switching vlan members support
    user@access-switch# set ge-0/0/46 unit 0 description “Support file server port”
    user@access-switch# set ge-0/0/46 unit 0 family ethernet-switching vlan members support
  10. Configure descriptions and VLAN tag IDs for the sales and support VLANs:
    [edit vlans]
    user@switch# set sales vlan-description “Sales VLAN”
    user@switch# set sales vlan-id 100
    user@switch# set support vlan-description “Support VLAN”
    user@switch# set support vlan-id 200
  11. To route traffic between the sales and support VLANs, define the interfaces that are members of each VLAN and associate a Layer 3 interface with each VLAN:
    [edit vlans]
    user@access-switch# set sales interfaces ge-0/0/0.0
    user@access-switch# set sales interfaces ge-0/0/3.0
    user@access-switch# set sales interfaces ge-0/0/22.0
    user@access-switch# set sales interfaces ge-0/0/20.0
    user@access-switch# set sales l3–interface vlan.0
    user@access-switch# set sales interfaces ge-0/0/24.0
    user@access-switch# set support interfaces ge-0/0/26.0
    user@access-switch# set support interfaces ge-0/0/44.0
    user@access-switch# set support interfaces ge-0/0/46.0
    user@access-switch# set support l3–interface vlan.1

Configuration Results

Display the results of the configuration:

[edit]
user@access-switch# show
interfaces {
ge-0/0/0 {
unit 0 {
description “Sales WAP port”;
family ethernet-switching {
vlan members sales;
}
}
}
ge-0/0/3 {
unit 0 {
description “Sales phone port”;
family ethernet-switching {
vlan members sales;
}
}
ge-0/0/20 {
unit 0 {
description “Sales file server port”;
family ethernet-switching {
vlan members sales;
}
}
ge-0/0/22 {
unit 0 {
description “Sales printer port”;
family ethernet-switching {
vlan members sales;
}
}
ge-0/0/24 {
unit 0 {
description “Support WAP port”;
family ethernet-switching {
vlan members support;
}
}
ge-0/0/26 {
unit 0 {
description “Support phone port”;
family ethernet-switching {
vlan members support;
}
}
ge-0/0/44 {
unit 0 {
description “Support printer port”;
family ethernet-switching {
vlan members sales;
}
}
ge-0/0/46 {
unit 0 {
description “Support file server port”;
family ethernet-switching {
vlan members support;
}
}
ge-0/1/0 {
unit 0 {
description “Uplink module port connection to distribution switch”;
family ethernet-switching {
port-mode trunk;
vlan members [ sales support ];
native-vlan-id 1;
}
}
vlan {
unit 0 {
unit 0 {
family inet {
address 192.0.2.0/25;
}
}
}
}
vlans {
sales {
vlan-id 100;
vlan-description “Sales VLAN”;
l3–interface vlan.0;
}
support {
vlan-id 200;
vlan-description “Support VLAN”;
l3–interface vlan.1;
}
}

To quickly configure the access switch, issue the load merge terminal command, then copy the hierarchy and paste it into the switch terminal window.

CLI Quick Configuration

To quickly configure the distribution switch, copy the following commands and paste them into the switch terminal window:


set interfaces ge-0/0/0 description “Connection to access switch”
set interfaces ge-0/0/0 ethernet-switching port-mode trunk
set interfaces ge-0/0/0 ethernet-switching vlan members [ sales support ]
set interfaces ge-0/0/0 ethernet-switching native-vlan-id ???
set interfaces vlan unit 0 family inet address 192.0.2.0/25
set interfaces vlan unit 1 family inet address 192.0.2.128/25
set vlans sales vlan-description “Sales VLAN”
set vlans sales vlan-id 100
set vlans sales l3–interface vlan.0
set vlans support vlan-description “Support VLAN”
set vlans support vlan-id 200
set vlans support l3–interface vlan.1

Step-by-Step Procedure

To configure the distribution switch:

  1. Configure the interface on the switch to be the trunk port that connects to the access switch:
    [edit interfaces ge-0/0/0 unit 0]
    user@distribution-switch# set description “Connection to access switch”
    user@distribution-switch# set ethernet-switching port-mode trunk
  2. Specify the VLANs to be aggregated on the trunk port:
    [edit interfaces ge-0/0/0 unit 0]
    user@distribution-switch# set ethernet-switching vlan members [ sales support ]
  3. Configure the native VLAN ID [is this necessary?]
    [edit interfaces]
    user@distribution-switch# set ge-0/0/0 ethernet-switching native-vlan-id ???
  4. Configure the sales VLAN:
    [edit vlans sales]
    user@distribution-switch# set vlan-description “Sales VLAN”
    user@distribution-switch# set vlan-id 100
    user@distribution-switch# set l3–interface vlan.0

  5. Configure the support VLAN:
    [edit vlans support]
    user@distribution-switch# set vlan-description “Support VLAN”
    user@distribution-switch# set vlan-id 200
    user@distribution-switch# set l3–interface vlan.1
  6. Create the subnet for the sales broadcast domain:
    [edit interfaces]
    user@distribution-switch# set vlan unit 0 family inet address 192.0.2.0/25
  7. Create the subnet for the support broadcast domain:
    [edit interfaces]
    user@distribution-switch# set vlan unit 1 family inet address 192.0.2.128/25

Configuration Results

Display the results of the configuration:

[edit]
user@access-switch# show
interfaces {
ge-0/0/0 {
description “Connection to access switch”;
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan members [ sales support ];
native-vlan-id ???;
}
}
}
vlan {
unit 0 {
family inet {
address 192.0.2.0/25;
}
}
unit 1 {
family inet {
address 192.0.2.128/25;
}
}
}
}
}
vlans {
sales {
vlan-id 100;
vlan-description “Sales LAN”;
l3–interface vlan.0;
}
support {
vlan-id 200;
vlan-description “Support LAN”;
l3–interface vlan.1;
}
}

To quickly configure the distribution switch, issue the load merge terminal command, then copy the hierarchy and paste it into the switch terminal window.

Verification

To confirm that the configuration is working properly, perform these tasks:

Verifying the VLAN Members and Interfaces on the Access Switch

Purpose

Action



What it Means

Verifying the VLAN Members and Interfaces on the Distribution Switch

Purpose

Action



What it Means

Troubleshooting

To troubleshoot [item], perform these tasks:

Problem

Solution

    Related Topics

    [an error occurred while processing this directive]