Appendix: Quick Configurations for Configuration Example
This section includes all-in-one quick configurations for each device in the configuration example.
Interface and System Configuration
CLI Quick Configuration
Leaf 1 (VCF-1)
set interfaces et-0/0/10 unit 0 description "to Spine 1"
set interfaces et-0/0/10 unit 0 family inet address 192.168.1.1/24
set interfaces et-0/0/10 unit 0 description "to Spine 2"
set interfaces et-0/0/11 unit 0 family inet address 192.168.2.1/24
set interfaces lo0 unit 0 family inet address 192.168.10.1/32
set routing-options router-id 192.168.10.1
set routing-options autonomous-system 65100
set interfaces xe-6/0/40 description "to Server H1"
set interfaces xe-6/0/40 encapsulation ethernet-bridge
set interfaces xe-6/0/40 unit 0 family ethernet-switching
vlan members vlan10
set chassis aggregated-devices ethernet device-count 1
set interfaces et-0/0/15 description "to Server H4"
set interfaces et-0/0/15 ether-options 802.3ad ae0
set interfaces ae0 encapsulation ethernet-bridge
set interfaces ae0 esi 00:01:01:01:01:01:01:01:01:01
set interfaces ae0 esi all-active
set interfaces ae0 unit 0 family ethernet-switching vlan
members vlan10
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic
fast
set interfaces ae0 aggregated-ether-options lacp system-id 00:00:00:01:01:01
Leaf 2 (VCF-2)
set interfaces et-0/0/20 unit 0 description "to Spine 1"
set interfaces et-0/0/20 unit 0 family inet address 192.168.3.1/24
set interfaces et-0/0/21 unit 0 description "to Spine 2"
set interfaces et-0/0/21 unit 0 family inet address 192.168.4.1/24
set interfaces lo0 unit 0 family inet address 192.168.20.1/32
set routing-options router-id 192.168.20.1
set routing-options autonomous-system 65300
set interfaces xe-2/0/16:0 description "to Server H2"
set interfaces xe-2/0/16:0 encapsulation ethernet-bridge
set interfaces xe-2/0/16:0 unit 0 family ethernet-switching
vlan members vlan10
set chassis aggregated-devices ethernet device-count 1
set interfaces et-0/0/17 description "to Server H4"
set interfaces et-0/0/17 ether-options 802.3ad ae0
set interfaces ae0 encapsulation ethernet-bridge
set interfaces ae0 esi 00:01:01:01:01:01:01:01:01:01
set interfaces ae0 esi all-active
set interfaces ae0 unit 0 family ethernet-switching vlan
members vlan10
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic
fast
set interfaces ae0 aggregated-ether-options lacp system-id 00:00:00:01:01:01
Leaf 3 (Standalone QFX5100)
set interfaces et-0/0/18 unit 0 description "to Spine 1"
set interfaces et-0/0/18 unit 0 family inet address 192.168.5.1/24
set interfaces et-0/0/19 unit 0 description "to Spine 2"
set interfaces et-0/0/19 unit 0 family inet address 192.168.6.1/24
set interfaces lo0 unit 0 family inet address 192.168.30.1/32
set routing-options router-id 192.168.30.1
set routing-options autonomous-system 65000
set interfaces xe-0/0/12:0 description "to Server H3"
set interfaces xe-0/0/12:0 encapsulation ethernet-bridge
set interfaces xe-0/0/12:0 unit 0 family ethernet-switching
vlan members vlan10
Spine 1 (QFX10K-1)
set interfaces et-0/0/4 unit 0 description "to Leaf 1"
set interfaces et-0/0/4 unit 0 family inet address 192.168.1.100/24
set interfaces et-0/0/5 unit 0 description "to Leaf 2"
set interfaces et-0/0/5 unit 0 family inet address 192.168.3.100/24
set interfaces et-0/0/18 unit 0 description "to Leaf 3"
set interfaces et-0/0/18 unit 0 family inet address 192.168.5.100/24
set interfaces lo0 unit 0 family inet address 192.168.40.1/32
set routing-options router-id 192.168.40.1
set routing-options autonomous-system 65200
Spine 2 (QFX10k-2)
set interfaces et-0/0/11 unit 0 description "to Leaf 1"
set interfaces et-0/0/11 unit 0 family inet address 192.168.2.100/24
set interfaces et-0/0/21 unit 0 description "to Leaf 2"
set interfaces et-0/0/21 unit 0 family inet address 192.168.4.100/24
set interfaces et-0/0/19 unit 0 description "to Leaf 3"
set interfaces et-0/0/19 unit 0 family inet address 192.168.6.100/24
set interfaces lo0 unit 0 family inet address 192.168.50.1/32
set routing-options router-id 192.168.50.1
set routing-options autonomous-system 65500
Underlay Configuration
CLI Quick Configuration
This section includes configuration of EBGP sessions between each of the leaf and spine devices.
Leaf 1 (VCF-1)
set protocols bgp group underlay type external
set protocols bgp group underlay export directs
set protocols bgp group underlay multipath multiple-as
set protocols bgp group underlay description "to Spine
1/2"
set protocols bgp group underlay neighbor 192.168.1.100
peer-as 65200
set protocols bgp group underlay neighbor 192.168.2.100
peer-as 65500
set policy-options policy-statement directs term 1 from
protocol direct
set policy-options policy-statement directs term 1 then
accept
Leaf 2 (VCF-2)
set protocols bgp group underlay type external
set protocols bgp group underlay export directs
set protocols bgp group underlay multipath multiple-as
set protocols bgp group underlay description "to Spine
1/2"
set protocols bgp group underlay neighbor 192.168.3.100
peer-as 65200
set protocols bgp group underlay neighbor 192.168.4.100
peer-as 65500
set policy-options policy-statement directs term 1 from
protocol direct
set policy-options policy-statement directs term 1 then
accept
Leaf 3 (Standalone QFX5100)
set protocols bgp group underlay type external
set protocols bgp group underlay export directs
set protocols bgp group underlay multipath multiple-as
set protocols bgp group underlay description "to Spine
1/2"
set protocols bgp group underlay neighbor 192.168.5.100
peer-as 65200
set protocols bgp group underlay neighbor 192.168.6.100
peer-as 65500
set policy-options policy-statement directs term 1 from
protocol direct
set policy-options policy-statement directs term 1 then
accept
Spine 1 (QFX10K-1)
set protocols bgp group underlay type external
set protocols bgp group underlay export directs
set protocols bgp group underlay multipath multiple-as
set protocols bgp group underlay description "to Leaf 1/2/3"
set protocols bgp group underlay neighbor 192.168.1.1 peer-as
65100
set protocols bgp group underlay neighbor 192.168.3.1 peer-as
65300
set protocols bgp group underlay neighbor 192.168.5.1 peer-as
65000
set policy-options policy-statement directs term 1 from
protocol direct
set policy-options policy-statement directs term 1 then
accept
Spine 2 (QFX10k-2)
set protocols bgp group underlay type external
set protocols bgp group underlay export directs
set protocols bgp group underlay multipath multiple-as
set protocols bgp group underlay description "to Leaf 1/2/3"
set protocols bgp group underlay neighbor 192.168.2.1 peer-as
65100
set protocols bgp group underlay neighbor 192.168.4.1 peer-as
65300
set protocols bgp group underlay neighbor 192.168.6.1 peer-as
65000
set policy-options policy-statement directs term 1 from
protocol direct
set policy-options policy-statement directs term 1 then
accept
Overlay Configuration
CLI Quick Configuration
This section includes configuration of EVPN between the leaf (PE) devices. The overlay is configured as a single AS, using MP-IBGP for peering.
Leaf 1 (VCF-1)
set protocols bgp group overlay type internal
set protocols bgp group overlay local-address 192.168.10.1
set protocols bgp group overlay family evpn signaling
set protocols bgp group overlay local-as 65400
set protocols bgp group overlay multipath
set protocols bgp group overlay neighbor 192.168.20.1
set protocols bgp group overlay neighbor 192.168.30.1
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 192.168.10.1:1
set switch-options vrf-import LEAF-IN
set switch-options vrf-target target:9999:9999
set protocols evpn vni-options vni 10 vrf-target export
target:1:10
set protocols evpn encapsulation vxlan
set protocols evpn extended-vni-list 10
set protocols evpn multicast-mode ingress-replication
set policy-options policy-statement LEAF-IN term import_leaf_esi
from community comm-leaf_esi
set policy-options policy-statement LEAF-IN term import_leaf_esi
then accept
set policy-options policy-statement LEAF-IN term import_vni10
from community com10
set policy-options policy-statement LEAF-IN term import_vni10
then accept
set policy-options community com10 members target:1:10
set policy-options community comm-leaf_esi members target:9999:9999
set policy-options policy-statement loadbalance then load-balance
per-packet
set routing-options forwarding-table export loadbalance
set vlans vlan10 vlan-id 10
set vlans vlan10 vxlan vni 10
set vlans vlan10 vxlan ingress-node-replication
Leaf 2 (VCF-2)
set protocols bgp group overlay type internal
set protocols bgp group overlay local-address 192.168.20.1
set protocols bgp group overlay family evpn signaling set
protocols
set protocols bgp group overlay local-as 65400
set protocols bgp group overlay multipath
set protocols bgp group overlay neighbor 192.168.10.1
set protocols bgp group overlay neighbor 192.168.30.1
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 192.168.20.1:1
set switch-options vrf-import LEAF-IN
set switch-options vrf-target target:9999:9999
set protocols evpn vni-options vni 10 vrf-target export
target:1:10
set protocols evpn encapsulation vxlan
set protocols evpn extended-vni-list 10
set protocols evpn multicast-mode ingress-replication
set policy-options policy-statement LEAF-IN term import_leaf_esi
from community comm-leaf_esi
set policy-options policy-statement LEAF-IN term import_leaf_esi
then accept
set policy-options policy-statement LEAF-IN term import_vni10
from community com10
set policy-options policy-statement LEAF-IN term import_vni10
then accept
set policy-options community com10 members target:1:10
set policy-options community comm-leaf_esi members target:9999:9999
set policy-options policy-statement loadbalance then load-balance
per-packet
set routing-options forwarding-table export loadbalance
set vlans vlan10 vlan-id 10
set vlans vlan10 vxlan vni 10
set vlans vlan10 vxlan ingress-node-replication
Leaf 3 (Standalone QFX5100)
set protocols bgp group overlay type internal
set protocols bgp group overlay local-address 192.168.30.1
set protocols bgp group overlay family evpn signaling
set protocols bgp group overlay local-as 65400
set protocols bgp group overlay multipath
set protocols bgp group overlay neighbor 192.168.20.1
set protocols bgp group overlay neighbor 192.168.10.1
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 192.168.30.1:1
set switch-options vrf-import LEAF-IN
set switch-options vrf-target target:9999:9999
set protocols evpn vni-options vni 10 vrf-target export
target:1:10
set protocols evpn encapsulation vxlan
set protocols evpn extended-vni-list 10
set protocols evpn multicast-mode ingress-replication
set policy-options policy-statement LEAF-IN term import_leaf_esi
from community comm-leaf_esi
set policy-options policy-statement LEAF-IN term import_leaf_esi
then accept
set policy-options policy-statement LEAF-IN term import_vni10
from community com10
set policy-options policy-statement LEAF-IN term import_vni10
then accept
set policy-options community com10 members target:1:10
set policy-options community comm-leaf_esi members target:9999:9999
set policy-options policy-statement loadbalance then load-balance
per-packet
set routing-options forwarding-table export loadbalance
set vlans vlan10 vlan-id 10
set vlans vlan10 vxlan vni 10
set vlans vlan10 vxlan ingress-node-replication