Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Example: Configuring Multichassis Link Aggregation on EX9200 Switches in the Core for Data Center Networks

    MC-LAG in a data center configuration allows you to bond two or more physical links into a logical link between core-aggregation or aggregation-access switches. MC-LAG improves availability by providing active/active links between multiple switches over a standard Link Aggregation Group (LAG), eliminates the need for the Spanning Tree Protocol (STP), and provides faster Layer 2 convergence upon link and device failures. With multiple active network paths, MC-LAG enables you to load balance traffic across the multiple physical links. If a link fails, the traffic can be forwarded through the other available links and the aggregated link remains available.

    Requirements

    This example uses the following hardware and software components:

    • Junos OS Release 13.2R5.10 for EX Series
    • Two EX9200 switches

    Note: This configuration example has been tested using the software release listed and is assumed to work on all later releases.

    Before you configure an MC-LAG, be sure that you understand how to:

    Overview

    In this example, you configure an MC-LAG across two switches, consisting of two aggregated Ethernet interfaces, an interchassis link-protection link (ICL-PL), multichassis protection link for the ICL-PL, ICCP for the peers hosting the MC-LAG, and Layer 3 connectivity between MC-LAG peers. Layer 3 connectivity is required for ICCP.

    Topology

    The topology used in this example consists of two switches hosting an MC-LAG. The two switches are connected to an EX4600 switch and an MX80 router. Figure 1 shows the topology of this example.

    Figure 1: Topology Diagram

    Topology Diagram

    Table 1 details the topology used in this configuration example.

    Table 1: Components of the Topology for Configuring a Multichassis LAG Between Two Switches

    HostnameBase HardwareMultichassis Link Aggregation Group

    EX9200-A

    EX9200-B

    EX9200

    EX9200

    ae0 is configured as an aggregated Ethernet interface, and is used as an ICCP link. The following interfaces are part of ae0: et-1/0/0 and et-1/0/1 on EX9200-A and
    et-1/0/0 and et-1/0/1 on EX9200-B.

    ae1 is configured as an aggregated Ethernet interface and is used as an ICL link, and the following two interfaces are part of ae1:
    xe-2/0/3 and xe-2/0/4 on EX9200-A and
    xe-2/0/3 and xe-2/0/4 on EX9200-B.

    ae2 is configured as an MC-LAG, and the following interfaces are part of ae2:
    et-1/0/0 on EX9200-A and et-1/1/0 on EX9200-B.

    ae4 is configured as an MC-LAG, and the following interfaces are part of ae4:
    xe-2/0/0 on EX9200-A and xe-2/0/0 on EX9200-B.

    Configuration

    CLI Quick Configuration

    To quickly configure this example, copy the following commands, paste them in a text file, remove any line breaks, change any details necessary to match your network configuration, copy and paste the commands into the CLI at the [edit] hierarchy level, and then enter commit from configuration mode.

    EX9200-A

    set chassis aggregated-devices ethernet device-count 20
    set interfaces et-1/0/0 ether-options 802.3ad ae0
    set interfaces et-1/0/1 ether-options 802.3ad ae0
    set interfaces xe-2/0/3 hold-time up 100
    set interfaces xe-2/0/3 hold-time down 9000
    set interfaces xe-2/0/3 ether-options 802.3ad ae1
    set interfaces xe-2/0/4 hold-time up 100
    set interfaces xe-2/0/4 hold-time down 9000
    set interfaces xe-2/0/4 ether-options 802.3ad ae1
    set interfaces et-1/2/0 ether-options 802.3ad ae2
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options lacp periodic fast
    set interfaces ae0 unit 0 family inet address 192.168.90.1/24
    set interfaces ae1 description ICL-LINK
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 aggregated-ether-options lacp periodic fast
    set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae1 unit 0 family ethernet-switching vlan members all
    set interfaces ae2 aggregated-ether-options lacp active
    set interfaces ae2 aggregated-ether-options lacp periodic fast
    set interfaces ae2 aggregated-ether-options lacp system-id 00:01:02:03:04:05
    set interfaces ae2 aggregated-ether-options lacp admin-key 3
    set interfaces ae2 aggregated-ether-options mc-ae mc-ae-id 3
    set interfaces ae2 aggregated-ether-options mc-ae redundancy-group 1
    set interfaces ae2 aggregated-ether-options mc-ae chassis-id 0
    set interfaces ae2 aggregated-ether-options mc-ae mode active-active
    set interfaces ae2 aggregated-ether-options mc-ae status-control active
    set interfaces ae2 aggregated-ether-options mc-ae init-delay-time 520
    set interfaces ae2 aggregated-ether-options mc-ae events iccp-peer-down prefer-status-control-active
    set interfaces ae2 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae2 unit 0 family ethernet-switching vlan members all
    set interfaces irb unit 100 family inet address 192.168.10.3/24 arp 192.168.10.2 l2-interface ae1.0
    set interfaces irb unit 100 family inet address 192.168.10.3/24 arp 192.168.10.2 mac 3c:8a:b0:85:78:70
    set interfaces irb unit 100 family inet address 192.168.10.3/24 vrrp-group 1 virtual-address 192.168.10.1
    set interfaces irb unit 100 family inet address 192.168.10.3/24 vrrp-group 1 priority 150
    set interfaces irb unit 100 family inet address 192.168.10.3/24 vrrp-group 1 accept-data
    set interfaces lo0 unit 0 family inet address 192.18.39.1/32
    set protocols iccp local-ip-addr 192.18.39.1
    set protocols iccp peer 192.18.39.2 session-establishment-hold-time 50
    set protocols iccp peer 192.18.39.2 redundancy-group-id-list 1
    set protocols iccp peer 192.18.39.2 backup-liveness-detection backup-peer-ip 10.105.5.6
    set protocols iccp peer 192.18.39.2 liveness-detection minimum-interval 2000
    set protocols iccp peer 192.18.39.2 liveness-detection multiplier 4
    set multi-chassis multi-chassis-protection 192.18.39.2 interface ae1
    set switch-options service-id 1
    set vlans rack_1 vlan-id 100
    set vlans rack_1 l3-interface irb.100
    set forwarding-options dhcp-relay forward-snooped-clients all-interfaces
    set forwarding-options dhcp-relay overrides allow-snooped-clients
    set forwarding-options dhcp-relay server-group GVP-DHCP 10.105.5.202
    set forwarding-options dhcp-relay active-server-group GVP-DHCP
    set forwarding-options dhcp-relay route-suppression destination
    set forwarding-options dhcp-relay group Floor1 interface irb.100
    set forwarding-options dhcp-relay relay-option-82 circuit-id use-interface-description device
    set protocols rstp interface ae2
    set protocols rstp interface ae4
    set protocols rstp system-identifier 00:01:02:03:04:05
    set interfaces xe-2/0/0 ether-options 802.3ad ae4
    set interfaces ae4 aggregated-ether-options lacp active
    set interfaces ae4 aggregated-ether-options lacp periodic fast
    set interfaces ae4 aggregated-ether-options lacp system-id 00:01:02:03:04:06
    set interfaces ae4 aggregated-ether-options lacp admin-key 7
    set interfaces ae4 aggregated-ether-options mc-ae mc-ae-id 7
    set interfaces ae4 aggregated-ether-options mc-ae redundancy-group 1
    set interfaces ae4 aggregated-ether-options mc-ae chassis-id 1
    set interfaces ae4 aggregated-ether-options mc-ae mode active-active
    set interfaces ae4 aggregated-ether-options mc-ae status-control standby
    set interfaces ae4 aggregated-ether-options mc-ae init-delay-time 520
    set interfaces ae4 aggregated-ether-options mc-ae events iccp-peer-down prefer-status-control-active
    set interfaces ae4 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae4 unit 0 family ethernet-switching vlan members v51
    set interfaces ae4 unit 0 family ethernet-switching vlan members v54
    set vlans v54 vlan-id 54
    set vlans v54 l3-interface irb.54
    set interfaces irb unit 54 family inet address 192.168.54.2/24 arp 192.168.54.1 l2-interface ae1.0
    set interfaces irb unit 54 family inet address 192.168.54.2/24 arp 192.168.54.1 mac 3c:8a:b0:85:78:70
    set interfaces irb unit 54 family inet address 192.168.54.2/24 vrrp-group 4 virtual-address 192.168.54.3
    set interfaces irb unit 54 family inet address 192.168.54.2/24 vrrp-group 4 priority 200
    set protocols igmp-snooping vlan rack_1
    set protocols igmp-snooping vlan v54
    set multicast-snooping-options multichassis-lag-replicate-state
    set protocols igmp-snooping vlan rack_1 interface ae1.0 multicast-router-interface
    set protocols igmp-snooping vlan v54 interface ae1.0 multicast-router-interface
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ospf area 0.0.0.0 interface ae0.0
    set protocols ospf area 0.0.0.0 interface irb.54
    set protocols ospf area 0.0.0.0 interface irb.100
    set protocols pim interface irb.54
    set protocols pim interface irb.100
    set protocols pim interface lo0.0
    set protocols pim rp bootstrap-priority 150
    set protocols pim rp local address 192.18.39.1

    EX9200-B

    set chassis aggregated-devices ethernet device-count 20
    set interfaces et-1/0/0 ether-options 802.3ad ae0
    set interfaces et-1/0/1 ether-options 802.3ad ae0
    set interfaces xe-2/0/3 hold-time up 100
    set interfaces xe-2/0/3 hold-time down 9000
    set interfaces xe-2/0/3 ether-options 802.3ad ae1
    set interfaces xe-2/0/4 hold-time up 100
    set interfaces xe-2/0/4 hold-time down 9000
    set interfaces xe-2/0/4 ether-options 802.3ad ae1
    set interfaces et-1/2/0 ether-options 802.3ad ae2
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options lacp periodic fast
    set interfaces ae0 unit 0 family inet address 192.168.90.2/24
    set interfaces ae1 description ICL-LINK
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 aggregated-ether-options lacp periodic fast
    set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae1 unit 0 family ethernet-switching vlan members all
    set interfaces ae2 aggregated-ether-options lacp active
    set interfaces ae2 aggregated-ether-options lacp periodic fast
    set interfaces ae2 aggregated-ether-options lacp system-id 00:01:02:03:04:05
    set interfaces ae2 aggregated-ether-options lacp admin-key 3
    set interfaces ae2 aggregated-ether-options mc-ae mc-ae-id 3
    set interfaces ae2 aggregated-ether-options mc-ae redundancy-group 1
    set interfaces ae2 aggregated-ether-options mc-ae chassis-id 1
    set interfaces ae2 aggregated-ether-options mc-ae mode active-active
    set interfaces ae2 aggregated-ether-options mc-ae init-delay-time 520
    set interfaces ae2 aggregated-ether-options mc-ae events iccp-peer-down prefer-status-control-active
    set interfaces ae2 aggregated-ether-options mc-ae status-control standby
    set interfaces ae2 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae2 unit 0 family ethernet-switching vlan members all
    set interfaces irb unit 100 family inet address 192.168.10.2/24 arp 192.168.10.3 l2-interface ae1.0
    set interfaces irb unit 100 family inet address 192.168.10.2/24 arp 192.168.10.3 mac 00:1f:12:b6:6f:f0
    set interfaces irb unit 100 family inet address 192.168.10.2/24 vrrp-group 1 virtual-address 192.168.10.1
    set interfaces irb unit 100 family inet address 192.168.10.2/24 vrrp-group 1 priority 200
    set interfaces irb unit 100 family inet address 192.168.10.2/24 vrrp-group 1 accept-data
    set interfaces lo0 unit 0 family inet address 192.18.39.2/32
    set protocols iccp local-ip-addr 192.18.39.2
    set protocols iccp peer 192.18.39.1 session-establishment-hold-time 50
    set protocols iccp peer 192.18.39.1 redundancy-group-id-list 1
    set protocols iccp peer 192.18.39.1 backup-liveness-detection backup-peer-ip 10.105.5.5
    set protocols iccp peer 192.18.39.1 liveness-detection minimum-interval 2000
    set protocols iccp peer 192.18.39.1 liveness-detection multiplier 4
    set multi-chassis multi-chassis-protection 192.18.39.1 interface ae1
    set switch-options service-id 1
    set vlans rack_1 vlan-id 100
    set vlans rack_1 l3-interface irb.100
    set forwarding-options dhcp-relay forward-snooped-clients all-interfaces
    set dhcp-relay overrides allow-snooped-clients
    set forwarding-options dhcp-relay server-group GVP-DHCP 10.105.5.202
    set forwarding-options dhcp-relay active-server-group GVP-DHCP
    set forwarding-options dhcp-relay route-suppression destination
    set forwarding-options dhcp-relay group Floor1 interface irb.100
    set forwarding-options dhcp-relay relay-option-82 circuit-id use-interface-description device
    set protocols rstp interface ae2
    set protocols rstp interface ae4
    set protocols rstp system-identifier 00:01:02:03:04:05
    set interfaces xe-2/0/0 ether-options 802.3ad ae4
    set interfaces ae4 aggregated-ether-options lacp active
    set interfaces ae4 aggregated-ether-options lacp periodic fast
    set interfaces ae4 aggregated-ether-options lacp system-id 00:01:02:03:04:06
    set interfaces ae4 aggregated-ether-options lacp admin-key 7
    set interfaces ae4 aggregated-ether-options mc-ae mc-ae-id 7
    set interfaces ae4 aggregated-ether-options mc-ae redundancy-group 1
    set interfaces ae4 aggregated-ether-options mc-ae chassis-id 0
    set interfaces ae4 aggregated-ether-options mc-ae mode active-active
    set interfaces ae4 aggregated-ether-options mc-ae status-control active
    set interfaces ae4 aggregated-ether-options mc-ae init-delay-time 520
    set interfaces ae4 aggregated-ether-options mc-ae events iccp-peer-down prefer-status-control-active
    set interfaces ae4 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae4 unit 0 family ethernet-switching vlan members v51
    set interfaces ae4 unit 0 family ethernet-switching vlan members v54
    set vlans v54 vlan-id 54
    set vlans v54 l3-interface irb.54
    set interfaces irb unit 54 family inet address 192.168.54.1/24 arp 192.168.54.2 l2-interface ae1.0
    set interfaces irb unit 54 family inet address 192.168.54.1/24 arp 192.168.54.2 mac 00:1f:12:b6:6f:f0
    set interfaces irb unit 54 family inet address 192.168.54.1/24 vrrp-group 4 virtual-address 192.168.54.3
    set interfaces irb unit 54 family inet address 192.168.54.1/24 vrrp-group 4 priority 150
    set protocols igmp-snooping vlan rack_1
    set protocols igmp-snooping vlan v54
    set multicast-snooping-options multichassis-lag-replicate-state
    set protocols igmp-snooping vlan rack_1 interface ae1.0 multicast-router-interface
    set protocols igmp-snooping vlan v54 interface ae1.0 multicast-router-interface
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ospf area 0.0.0.0 interface ae0.0
    set protocols ospf area 0.0.0.0 interface irb.54
    set protocols ospf area 0.0.0.0 interface irb.100
    set protocols pim interface lo0.0
    set protocols pim rp bootstrap-priority 200
    set protocols pim rp local address 192.18.39.2

    Configuring MC-LAG on Switch A

    Step-by-Step Procedure

    The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

    1. Configure the number of aggregated Ethernet interfaces to be created on Switch A.
      [edit chassis]
      user@switch# set aggregated-devices ethernet device-count 20
    2. Add member interfaces to the aggregated Ethernet interfaces that will be used for the Inter-Chassis Control Protocol (ICCP) interface.
      [edit interfaces]
      user@switch# set et-1/0/0 ether-options 802.3ad ae0
      user@switch# set et-1/0/1 ether-options 802.3ad ae0
    3. Configure the member interfaces for the interchassis link (ICL) with a hold-time value that is higher than the configured BFD timer to prevent the ICL from being advertised as being down before the ICCP link is down.

      If the ICL goes down before the ICCP link goes down, the MC-LAG interface configured as the standby status-control peer goes up and down. The interface going up and down causes a delay in convergence.

      [edit interfaces]
      user@switch# set xe-2/0/3 hold-time up 100
      user@switch# set xe-2/0/3 hold-time down 9000
      user@switch# set xe-2/0/3 ether-options 802.3ad ae1
      user@switch# set xe-2/0/4 hold-time up 100
      user@switch# set xe-2/0/4 hold-time down 9000
      user@switch# set xe-2/0/4 ether-options 802.3ad ae1
    4. Specify the member interfaces that belong to interface ae2.
      [edit interfaces]
      user@switch# set et-1/2/0 ether-options 802.3ad ae2
    5. Configure ae0 as a Layer 3 interface.
      [edit interfaces]
      user@switch# set ae0 aggregated-ether-options lacp active
      user@switch# set ae0 aggregated-ether-options lacp periodic fast
      user@switch# set ae0 unit 0 family inet address 192.168.90.1/24
    6. Configure ae1 as a Layer 2 interface.
      [edit interfaces]
      user@switch# set ae1 description ICL-LINK
      user@switch# set ae1 aggregated-ether-options lacp active
      user@switch# set ae1 aggregated-ether-options lacp periodic fast
    7. Configure a trunk interface between EX9200-A and EX9200-B.
      [edit interfaces]
      user@switch# set ae1 unit 0 family ethernet-switching interface-mode trunk
      user@switch# set ae1 unit 0 family ethernet-switching vlan members all
    8. Configure the LACP parameters on ae2.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options lacp active
      user@switch# set ae2 aggregated-ether-options lacp periodic fast
    9. Configure the LACP administration key on ae2.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options lacp system-id 00:01:02:03:04:06
    10. Configure the MC-AE interface properties.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options lacp admin-key 3
      user@switch# set ae2 aggregated-ether-options mc-ae mc-ae-id 3
      user@switch# set ae2 aggregated-ether-options mc-ae redundancy-group 1
    11. Specify a unique chassis ID for the MC-LAG that the aggregated Ethernet interface belongs to.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options mc-ae chassis-id 0
    12. Specify the mode of the MC-LAG that the aggregated Ethernet interface belongs to.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options mc-ae mode active-active
    13. Configure the status control on the switch that hosts the MC-LAG.

      If one switch is in active mode, then the other switch must be in standby mode.

      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options mc-ae status-control active
    14. Specify the time in seconds by when routing adjacencies must form.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options mc-ae init-delay-time 520
    15. Specify that if a peer of the MC-LAG group goes down, the peer that is configured as status-control active becomes the active peer.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options mc-ae events iccp-peer-down prefer-status-control-active
    16. Configure ae2 as a trunk port with membership in all VLANs.
      [edit interfaces]
      user@switch# set ae2 unit 0 family ethernet-switching interface-mode trunk
      user@switch# set ae2 unit 0 family ethernet-switching vlan members all
    17. Configure an integrated routing and bridging (IRB) interface on VLAN 100.

      To configure an MC-LAG IRB, configure static Address Resolution Protocol (ARP) on the MC-LAG IRB peers to allow routing protocols to traverse the IRB interface.

      [edit interfaces]
      user@switch# set irb unit 100 family inet address 192.168.10.3/24 arp 192.168.10.2 l2-interface ae1.0
      user@switch# set irb unit 100 family inet address 192.168.10.3/24 arp 192.168.10.2 mac 3c:8a:b0:85:78:70
    18. Enable VRRP on the MC-LAGs by creating an IRB interface for each MC-LAG, assign a virtual IP address that is shared between each switch in the VRRP group, and assign an individual IP address for each individual member in the VRRP group.
      [edit interfaces]
      user@switch# set irb unit 100 family inet address 192.168.10.3/24 vrrp-group 1 virtual-address 192.168.10.1
      user@switch# set irb unit 100 family inet address 192.168.10.3/24 vrrp-group 1 priority 150
      user@switch# set irb unit 100 family inet address 192.168.10.3/24 vrrp-group 1 accept-data
    19. Configure a loopback interface.
      [edit interfaces]
      user@switch# set lo0 unit 0 family inet address 192.18.39.1/32
    20. Configure ICCP using the loopback address.
      [edit protocols]
      user@switch# set iccp local-ip-addr 192.18.39.1
    21. Configure the session establishment hold time for ICCP to connect faster.

      Note: We recommend 50 seconds as the session establishment hold time value.

      [edit protocols]
      user@switch# set iccp peer 192.18.39.2 session-establishment-hold-time 50
      user@switch# set iccp peer 192.18.39.2 redundancy-group-id-list 1
      user@switch# set iccp peer 192.18.39.2 backup-liveness-detection backup-peer-ip 10.105.5.6
    22. To enable Bidirectional Forwarding Detection (BFD), configure the minimum receive interval.

      We recommend a minimum receive interval value of 6 seconds.

      [edit protocols]
      user@switch# set iccp peer 192.18.39.2 liveness-detection minimum-interval 2000
      user@switch# set iccp peer 192.18.39.2 liveness-detection multiplier 4

      [edit multi-chassis]
      user@switch# set multi-chassis-protection 192.18.39.2 interface ae1
    23. Specify the switch service ID.

      The switch service ID is used to synchronize applications, IGMP, ARP, and MAC learning across MC-LAG members.

      [edit switch-options]
      user@switch# set service-id 1
    24. Configure VLAN 100.
      [edit vlans]
      user@switch# set rack_1 vlan-id 100
      user@switch# set rack_1 l3-interface irb.100
    25. Configure forward snooped unicast packets on all interfaces.
      [edit fowarding-options]
      user@switch# set dhcp-relay forward-snooped-clients all-interfaces
    26. Create a binding entry to snoop unicast clients.
      [edit forwarding-options]
      user@switch# set dhcp-relay overrides allow-snooped-clients
    27. Create a DHCP server group.
      [edit forwarding-options]
      user@switch# set dhcp-relay server-group GVP-DHCP 10.105.5.202
    28. Apply a DHCP relay agent configuration to the named group of DHCP server addresses.
      [edit forwarding-options]
      user@switch# set dhcp-relay active-server-group GVP-DHCP
    29. Configure the relay agent to suppress the installation of ARP and route entries for corresponding client binding.
      [edit forwarding-options]
      user@switch# set dhcp-relay route-suppression destination
    30. Create a DHCP relay group that includes at least one interface.

      DHCP runs on the interfaces defined in the DHCP groups.

      [edit forwarding-options]
      user@switch# set dhcp-relay group Floor1 interface irb.100
    31. Configure DHCP relay with option 82.
      [edit forwarding-options]
      user@switch# set dhcp-relay relay-option-82 circuit-id use-interface-description device
    32. Enable the Rapid Spanning Tree Protocol on the ae2 and ae4 interfaces for optional loop prevention.
      [edit protocols]
      user@switch# set rstp interface ae2
      user@switch# set rstp interface ae4
    33. Configure the system identifier.
      [edit protocols]
      user@switch# set rstp system-identifier 00:01:02:03:04:05
    34. Configure multicast with multichassis link aggregation between EX9200-A and an MX Series router.

      Specify the members that belong to ae4.

      [edit interfaces]
      user@switch# set xe-2/0/0 ether-options 802.3ad ae4
    35. Configure the LACP parameters on ae4.
      [edit interfaces]
      user@switch# set ae4 aggregated-ether-options lacp active
      user@switch# set ae4 aggregated-ether-options lacp periodic fast
    36. Specify the LACP administration key.
      [edit interfaces]
      user@switch# set ae4 aggregated-ether-options lacp system-id 00:01:02:03:04:06
      user@switch# set ae4 aggregated-ether-options lacp admin-key 7
      user@switch# set ae4 aggregated-ether-options mc-ae mc-ae-id 7
      user@switch# set ae4 aggregated-ether-options mc-ae redundancy-group 1
    37. Specify a unique chassis ID for the MC-LAG that the aggregated Ethernet interface belongs to.
      [edit interfaces]
      user@switch# set ae4 aggregated-ether-options mc-ae chassis-id 1
      user@switch# set ae4 aggregated-ether-options mc-ae mode active-active
    38. Configure the status control on the switch that hosts the MC-LAG.

      If one switch is in active mode, then the other switch must be in standby mode.

      [edit interfaces]
      user@switch# set ae4 aggregated-ether-options mc-ae status-control standby
      user@switch# set ae4 aggregated-ether-options mc-ae init-delay-time 520
      user@switch# set ae4 aggregated-ether-options mc-ae events iccp-peer-down prefer-status-control-active
    39. Configure ae4 as a Layer 2 interface.
      [edit interfaces]
      user@switch# set ae4 unit 0 family ethernet-switching interface-mode trunk
      user@switch# set ae4 unit 0 family ethernet-switching vlan members v51
      user@switch# set ae4 unit 0 family ethernet-switching vlan members v54
    40. Configure VLAN 54.
      [edit vlans]
      user@switch# set v54 vlan-id 54
      user@switch# set v54 l3-interface irb.54
    41. Configure an IRB interface on VLAN 100.

      You must configure static ARP on the MC-LAG peers to allow routing protocols to traverse over the IRB interface.

      [edit interfaces]
      user@switch# set irb unit 54 family inet address 192.168.54.2/24 arp 192.168.54.1 l2-interface ae1.0
      user@switch# set irb unit 54 family inet address 192.168.54.2/24 arp 192.168.54.1 mac 3c:8a:b0:85:78:70
    42. Enable VRRP on the MC-LAGs by creating an IRB interface for each MC-LAG, assign a virtual IP address that is shared between each switch in the VRRP group, and assign an individual IP address for each individual member in the VRRP group.
      [edit interfaces]
      user@switch# set irb unit 54 family inet address 192.168.54.2/24 vrrp-group 4 virtual-address 192.168.54.3
      user@switch# set irb unit 54 family inet address 192.168.54.2/24 vrrp-group 4 priority 200
    43. Enable IGMP snooping for all VLANs.
      [edit protocols]
      user@switch# set igmp-snooping vlan rack_1
      user@switch# set igmp-snooping vlan v54
    44. Synchronize multicast states across MC-LAG peers when bridge domains are configured.

      At the global level, IGMP join and leave messages are replicated from the MC-LAG interface active link to the standby link to enable faster recovery of membership information after a failover.

      [edit multicast-snooping-options]
      user@switch# set multichassis-lag-replicate-state
    45. Configure the ICL-PL interface as a router-facing interface.
      [edit protocols]
      user@switch# set igmp-snooping vlan rack_1 interface ae1.0 multicast-router-interface
      user@switch# set igmp-snooping vlan v54 interface ae1.0 multicast-router-interface
    46. Configure an OSPF area.
      [edit protocols]
      user@switch# set ospf area 0.0.0.0 interface lo0.0
      user@switch# set ospf area 0.0.0.0 interface ae0.0
      user@switch# set ospf area 0.0.0.0 interface irb.54
      user@switch# set ospf area 0.0.0.0 interface irb.100
    47. Configure Protocol Independent Multicast (PIM) as the multicast protocol.
      [edit protocols]
      user@switch# set pim interface irb.54
      user@switch# set pim interface irb.100
    48. Configure the loopback interface.
      [edit protocols]
      user@switch# set pim interface lo0.0
    49. Configure the switch as a secondary rendezvous point (RP).

      A lower priority setting indicates that the secondary RP is in a bootstrap configuration.

      [edit protocols]
      user@switch# set pim rp bootstrap-priority 150
      user@switch# set pim rp local address 192.18.39.1
    50. (Optional) To change the MC-AE mode, use this command.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options mc-ae mode active-standby

    Configuring MC-LAG on Switch B

    Step-by-Step Procedure

    The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

    1. Configure the number of aggregated Ethernet interfaces to be created on Switch B.
      [edit chassis]
      user@switch# set aggregated-devices ethernet device-count 20
    2. Add member interfaces to the aggregated Ethernet interfaces that will be used for the Inter-Chassis Control Protocol (ICCP) interface.
      [edit interfaces]
      user@switch# set et-1/0/0 ether-options 802.3ad ae0
      user@switch# set et-1/0/1 ether-options 802.3ad ae0
    3. Configure the member interfaces for the interchassis link (ICL) with a hold-time value that is higher than the configured BFD timer to prevent the ICL from being advertised as being down before the ICCP link is down.

      If the ICL goes down before the ICCP link goes down, the MC-LAG interface configured as the standby status-control peer goes up and down. The interface going up and down causes a delay in convergence.

      [edit interfaces]
      user@switch# set xe-2/0/3 hold-time up 100
      user@switch# set xe-2/0/3 hold-time down 9000
      user@switch# set xe-2/0/3 ether-options 802.3ad ae1
      user@switch# set xe-2/0/4 hold-time up 100
      user@switch# set xe-2/0/4 hold-time down 9000
      user@switch# set xe-2/0/4 ether-options 802.3ad ae1
    4. Specify the member interfaces that belong to interface ae2.
      [edit interfaces]
      user@switch# set et-1/2/0 ether-options 802.3ad ae2
    5. Configure ae0 as a Layer 3 interface.
      [edit interfaces]
      user@switch# set ae0 aggregated-ether-options lacp active
      user@switch# set ae0 aggregated-ether-options lacp periodic fast
      user@switch# set ae0 unit 0 family inet address 192.168.90.2/24
    6. Configure ae1 as a Layer 2 interface.
      [edit interfaces]
      user@switch# set ae1 description ICL-LINK
      user@switch# set ae1 aggregated-ether-options lacp active
      user@switch# set ae1 aggregated-ether-options lacp periodic fast
    7. Configure a trunk interface between EX9200-A and EX9200-B.
      [edit interfaces]
      user@switch# set ae1 unit 0 family ethernet-switching interface-mode trunk
      user@switch# set ae1 unit 0 family ethernet-switching vlan members all
    8. Configure the LACP parameters on ae2.
      [edit interfaces]
      user@switch# set interfaces ae2 aggregated-ether-options lacp active
      user@switch# set interfaces ae2 aggregated-ether-options lacp periodic fast
    9. Configure the LACP administration key on ae2.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options lacp system-id 00:01:02:03:04:05
    10. Configure the MC-AE interface properties.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options lacp admin-key 3
      user@switch# set ae2 aggregated-ether-options mc-ae mc-ae-id 3
      user@switch# set ae2 aggregated-ether-options mc-ae redundancy-group 1
    11. Specify a unique chassis ID for the MC-LAG that the aggregated Ethernet interface belongs to.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options mc-ae chassis-id 1
    12. Specify the mode of the MC-LAG that the aggregated Ethernet interface belongs to.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options mc-ae mode active-active
    13. Specify time in seconds by when routing adjacencies must form.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options mc-ae init-delay-time 520
    14. Specify that if a peer of the MC-LAG group goes down, the peer that is configured as status-control active becomes the active peer.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options mc-ae events iccp-peer-down prefer-status-control-active
    15. Configure the status control on the switch that hosts the MC-LAG.

      If one switch is in standby mode, then the other switch must be in active mode.

      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options mc-ae status-control standby
    16. Configure ae2 as a trunk port with membership in all VLANs.
      [edit interfaces]
      user@switch# set ae2 unit 0 family ethernet-switching interface-mode trunk
      user@switch# set ae2 unit 0 family ethernet-switching vlan members all
    17. Configure an integrated routing and bridging (IRB) interface on VLAN 100.

      To configure an MC-LAG IRB, configure static Address Resolution Protocol (ARP) on the MC-LAG IRB peers to allow routing protocols to traverse the IRB interface.

      [edit interfaces]
      user@switch# set irb unit 100 family inet address 192.168.10.2/24 arp 192.168.10.3 l2-interface ae1.0
      user@switch# set irb unit 100 family inet address 192.168.10.2/24 arp 192.168.10.3 mac 00:1f:12:b6:6f:f0
    18. Enable VRRP on the MC-LAGs by creating an IRB interface for each MC-LAG, assign a virtual IP address that is shared between each switch in the VRRP group, and assign an individual IP address for each individual member in the VRRP group.
      [edit interfaces]
      user@switch# set irb unit 100 family inet address 192.168.10.2/24 vrrp-group 1 virtual-address 192.168.10.1
      user@switch# set irb unit 100 family inet address 192.168.10.2/24 vrrp-group 1 priority 200
      user@switch# set irb unit 100 family inet address 192.168.10.2/24 vrrp-group 1 accept-data
    19. Configure a loopback interface.
      [edit interfaces]
      user@switch# set lo0 unit 0 family inet address 192.18.39.2/32
    20. Configure ICCP using the loopback address.
      [edit protocols]
      user@switch# set iccp local-ip-addr 192.18.39.2
    21. Configure the session establishment hold time for ICCP to connect faster.

      Note: We recommend 50 seconds as the session establishment hold time value.

      [edit protocols]
      user@switch# set iccp peer 192.18.39.1 session-establishment-hold-time 50
      user@switch# set iccp peer 192.18.39.1 redundancy-group-id-list 1
      user@switch# set iccp peer 192.18.39.1 backup-liveness-detection backup-peer-ip 10.105.5.5
    22. To enable Bidirectional Forwarding Detection (BFD), configure the minimum receive interval.

      We recommend a minimum receive interval value of 6 seconds.

      [edit protocols]
      user@switch# set iccp peer 192.18.39.1 liveness-detection minimum-interval 2000
      user@switch# set iccp peer 192.18.39.1 liveness-detection multiplier 4

      [edit multi-chassis]
      user@switch# set multi-chassis-protection 192.18.39.1 interface ae1
    23. Specify the switch service ID.

      The switch service ID is used to synchronize applications, IGMP, ARP, and MAC learning across MC-LAG members.

      [edit switch-options]
      user@switch# set service-id 1
    24. Configure VLAN 100.
      [edit vlans]
      user@switch# set rack_1 vlan-id 100
      user@switch# set rack_1 l3-interface irb.100
    25. Configure forward snooped unicast packets on all interfaces.
      [edit forwarding-options]
      user@switch# set dhcp-relay forward-snooped-clients all-interfaces
    26. Create a binding entry to snoop unicast clients.
      [edit forwarding-options]
      user@switch# set dhcp-relay overrides allow-snooped-clients
    27. Create a DHCP server group.
      [edit forwarding-options]
      user@switch# set dhcp-relay server-group GVP-DHCP 10.105.5.202
    28. Apply a DHCP relay agent configuration to the named group of DHCP server addresses.
      [edit forwarding-options]
      user@switch# set dhcp-relay active-server-group GVP-DHCP
    29. Configure the relay agent to suppress the installation of ARP and route entries for corresponding client binding.
      [edit forwarding-options]
      user@switch# set dhcp-relay route-suppression destination
    30. Create a DHCP relay group that includes at least one interface.

      DHCP runs on the interfaces defined in the DHCP groups.

      [edit forwarding-options]
      user@switch# set dhcp-relay group Floor1 interface irb.100
    31. Configure DHCP relay with option 82.
      [edit forwarding-options]
      user@switch# set dhcp-relay relay-option-82 circuit-id use-interface-description device
    32. Enable the Rapid Spanning Tree Protocol on the ae2 and ae4 interfaces for optional loop prevention.
      [edit protocols]
      user@switch# set rstp interface ae2
      user@switch# set rstp interface ae4
    33. Configure the system identifier.
      [edit forwarding-options]
      user@switch# set rstp system-identifier 00:01:02:03:04:05
    34. Configure multicast with multichassis link aggregation between EX9200-B and an MX Series router.

      Specify the members that belong to ae4.

      [edit interfaces]
      user@switch# set xe-2/0/0 ether-options 802.3ad ae4
    35. Configure the LACP parameters on ae4.
      [edit interfaces]
      user@switch# set ae4 aggregated-ether-options lacp active
      user@switch# set ae4 aggregated-ether-options lacp periodic fast
    36. Specify the LACP administration key.
      [edit interfaces]
      user@switch# set ae4 aggregated-ether-options lacp system-id 00:01:02:03:04:06
      user@switch# set ae4 aggregated-ether-options lacp admin-key 7
      user@switch# set ae4 aggregated-ether-options mc-ae mc-ae-id 7
      user@switch# set ae4 aggregated-ether-options mc-ae redundancy-group 1
    37. Specify a unique chassis ID for the MC-LAG that the aggregated Ethernet interface belongs to on each switch.
      [edit interfaces]
      user@switch# set ae4 aggregated-ether-options mc-ae chassis-id 0
      user@switch# set ae4 aggregated-ether-options mc-ae mode active-active
    38. Configure the status control on the switch that hosts the MC-LAG.

      If one switch is in standby mode, then the other switch must be in active mode.

      [edit interfaces]
      user@switch# set ae4 aggregated-ether-options mc-ae status-control active
      user@switch# set ae4 aggregated-ether-options mc-ae init-delay-time 520
      user@switch# set ae4 aggregated-ether-options mc-ae events iccp-peer-down prefer-status-control-active
    39. Configure ae4 as a Layer 2 interface.
      [edit interfaces]
      user@switch# set ae4 unit 0 family ethernet-switching interface-mode trunk
      user@switch# set ae4 unit 0 family ethernet-switching vlan members v51
      user@switch# set ae4 unit 0 family ethernet-switching vlan members v54
    40. Configure VLAN 54.
      [edit vlans]
      user@switch# set v54 vlan-id 54
      user@switch# set v54 l3-interface irb.54
    41. Configure an IRB interface on VLAN 100.

      You must configure static ARP on the MC-LAG peers to allow routing protocols to traverse over the IRB interface.

      [edit interfaces]
      user@switch# set irb unit 54 family inet address 192.168.54.1/24 arp 192.168.54.2 l2-interface ae1.0
      user@switch# set irb unit 54 family inet address 192.168.54.1/24 arp 192.168.54.2 mac 00:1f:12:b6:6f:f0
    42. Enable VRRP on the MC-LAGs on each switch by creating an IRB interface for each MC-LAG, assign a virtual IP address that is shared between each switch in the VRRP group, and assign an individual IP address for each switch in the VRRP group.
      [edit interfaces]
      user@switch# set irb unit 54 family inet address 192.168.54.1/24 vrrp-group 4 virtual-address 192.168.54.3
      user@switch# set irb unit 54 family inet address 192.168.54.1/24 vrrp-group 4 priority 150
    43. Enable IGMP snooping for all VLANs.
      [edit protocols]
      user@switch# set igmp-snooping vlan rack_1
      user@switch# set igmp-snooping vlan v54
    44. Synchronize multicast states across MC-LAG peers when bridge domains are configured.

      At the global level, IGMP join and leave messages are replicated from the MC-LAG interface active link to the standby link to enable faster recovery of membership information after a failover.

      [edit multicast-snooping-options]
      user@switch# set multichassis-lag-replicate-state
    45. Configure the ICL-PL interface as a router-facing interface.
      [edit protocols]
      user@switch# set igmp-snooping vlan rack_1 interface ae1.0 multicast-router-interface
      user@switch# set igmp-snooping vlan v54 interface ae1.0 multicast-router-interface
    46. Configure an OSPF area.
      [edit protocols]
      user@switch# set ospf area 0.0.0.0 interface lo0.0
      user@switch# set ospf area 0.0.0.0 interface ae0.0
      user@switch# set ospf area 0.0.0.0 interface irb.54
      user@switch# set ospf area 0.0.0.0 interface irb.100
    47. Configure Protocol Independent Multicast (PIM) as the multicast protocol.
      [edit protocols]
      user@switch# set pim interface irb.54
      user@switch# set pim interface irb.100
    48. Configure the loopback interface.
      [edit protocols]
      user@switch# set pim interface lo0.0
    49. Configure the switch as a secondary rendezvous point (RP).

      A lower priority setting indicates that the secondary RP is in a bootstrap configuration.

      [edit protocols]
      user@switch# set pim rp bootstrap-priority 200
      user@switch# set pim rp local address 192.18.39.2
    50. (Optional) To change the MC-AE mode, use this command.
      [edit interfaces]
      user@switch# set ae2 aggregated-ether-options mc-ae mode active-standby

    Verification

    Confirm that the configuration is working properly.

    Verifying ICCP on MC-LAG

    Purpose

    Verify that ICCP is running on each device in the MC-LAG.

    Action

    1. Verify that ICCP is running on Switch A.
      root@EX92000-A> show iccp
      Redundancy Group Information for peer 192.18.39.2
        TCP Connection       : Established
        Liveliness Detection : Up
      
      Backup liveness peer status: Up
        Redundancy Group ID          Status
          1                           Up   
      
      Client Application: l2ald_iccpd_client
        Redundancy Group IDs Joined: 1 
      
      Client Application: lacpd
        Redundancy Group IDs Joined: 1 
      
      Client Application: MCSNOOPD
        Redundancy Group IDs Joined: 1 
      
    2. Verify that ICCP is running on Switch B.
      root@EX9200-B> show iccp
      Redundancy Group Information for peer 192.18.39.1
        TCP Connection       : Established
        Liveliness Detection : Up
      
      Backup liveness peer status: Up
        Redundancy Group ID          Status
          1                           Up   
      
      Client Application: lacpd
        Redundancy Group IDs Joined: 1 
      
      Client Application: l2ald_iccpd_client
        Redundancy Group IDs Joined: 1 
      
      Client Application: MCSNOOPD
        Redundancy Group IDs Joined: 1 
      

    Meaning

    This output shows that the TCP connection between the peers hosting the MC-LAG is up, liveness detection is up, and MCSNOOPD and ESWD client applications are running.

    Verifying LACP on MC-LAG

    Purpose

    Verify that LACP is working properly on each device in the MC-LAG.

    Action

    1. Verify that the LACP interfaces are up and running on Switch A.
      root@EX9200-A> show lacp interfaces
      Aggregated interface: ae0
          LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
            et-1/0/0       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            et-1/0/0     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
            et-1/0/1       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            et-1/0/1     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
          LACP protocol:        Receive State  Transmit State          Mux State 
            et-1/0/0                  Current   Fast periodic Collecting distributing
            et-1/0/1                  Current   Fast periodic Collecting distributing
      
      Aggregated interface: ae1
          LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
            xe-2/0/3       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            xe-2/0/3     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
            xe-2/0/4       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            xe-2/0/4     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
          LACP protocol:        Receive State  Transmit State          Mux State 
            xe-2/0/3                  Current   Fast periodic Collecting distributing
            xe-2/0/4                  Current   Fast periodic Collecting distributing
      
      Aggregated interface: ae3
          LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
            xe-2/0/1       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            xe-2/0/1     Partner    No    No   Yes  Yes  Yes   Yes     Fast   Passive
            xe-2/0/2       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            xe-2/0/2     Partner    No    No   Yes  Yes  Yes   Yes     Fast   Passive
          LACP protocol:        Receive State  Transmit State          Mux State 
            xe-2/0/1                  Current   Fast periodic Collecting distributing
            xe-2/0/2                  Current   Fast periodic Collecting distributing
      
      Aggregated interface: ae4
          LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
            xe-2/0/0       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            xe-2/0/0     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
          LACP protocol:        Receive State  Transmit State          Mux State 
            xe-2/0/0                  Current   Fast periodic Collecting distributing
      
      
    2. Verify that the LACP interfaces are up and running on Switch B.
      root@EX9200-B> show lacp interfaces
      Aggregated interface: ae0
          LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
            et-1/0/0       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            et-1/0/0     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
            et-1/0/1       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            et-1/0/1     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
          LACP protocol:        Receive State  Transmit State          Mux State 
            et-1/0/0                  Current   Fast periodic Collecting distributing
            et-1/0/1                  Current   Fast periodic Collecting distributing
      
      Aggregated interface: ae1
          LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
            xe-2/0/3       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            xe-2/0/3     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
            xe-2/0/4       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            xe-2/0/4     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
          LACP protocol:        Receive State  Transmit State          Mux State 
            xe-2/0/3                  Current   Fast periodic Collecting distributing
            xe-2/0/4                  Current   Fast periodic Collecting distributing
      
      Aggregated interface: ae2
          LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
            et-1/2/0       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            et-1/2/0     Partner    No    No   Yes  Yes  Yes   Yes     Fast   Passive
          LACP protocol:        Receive State  Transmit State          Mux State 
            et-1/2/0                  Current   Fast periodic Collecting distributing
      
      Aggregated interface: ae4
          LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
            xe-2/0/0       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
            xe-2/0/0     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
          LACP protocol:        Receive State  Transmit State          Mux State 
            xe-2/0/0                  Current   Fast periodic Collecting distributing
      
      

    Meaning

    This output means that both devices and all related interfaces are properly participating in LACP negotiations.

    Verifying Aggregated Ethernet Interfaces in MC-LAG

    Purpose

    Verify that all of the ae interfaces are configured properly in the MC–LAG.

    Action

    1. Verify the ae interfaces on Switch A.
      user@EX9200-A> show interfaces mc-ae
       
       Member Link                  : ae2
       Current State Machine's State: mcae active state
       Local Status                 : active
       Local State                  : up
       Peer Status                  : active
       Peer State                   : up
           Logical Interface        : ae2.0
           Topology Type            : bridge
           Local State              : up
           Peer State               : up
           Peer Ip/MCP/State        : 192.18.39.2 ae1.0 up
      
       Member Link                  : ae4
       Current State Machine's State: mcae active state
       Local Status                 : active
       Local State                  : up
       Peer Status                  : active
       Peer State                   : up
           Logical Interface        : ae4.0
           Topology Type            : bridge
           Local State              : up
           Peer State               : up
           Peer Ip/MCP/State        : 192.18.39.2 ae1.0 up
      
      
    2. Verify the ae interfaces on Switch B.
      root@EX9200-B> show interface mc-ae
       Member Link                  : ae2
       Current State Machine's State: mcae active state
       Local Status                 : active
       Local State                  : up
       Peer Status                  : active
       Peer State                   : up
           Logical Interface        : ae2.0
           Topology Type            : bridge
           Local State              : up
           Peer State               : up
           Peer Ip/MCP/State        : 192.18.39.1 ae1.0 up
      
                                              
       Member Link                  : ae4
       Current State Machine's State: mcae active state
       Local Status                 : active
       Local State                  : up
       Peer Status                  : active
       Peer State                   : up
           Logical Interface        : ae4.0
           Topology Type            : bridge
           Local State              : up
           Peer State               : up
           Peer Ip/MCP/State        : 192.18.39.1 ae1.0 up
      
      

    Meaning

    This output means that the mc-ae interfaces on each device are up and active.

    Verifying MAC Learning on MC-LAG

    Purpose

    Verify that MAC learning between devices is happening in the MC-LAG.

    Action

    1. Show Ethernet switching table in Switch A.
      root@EX9200-A> show ethernet-switching table
      MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static
                 SE - statistics enabled, NM - non configured MAC, R - remote PE MAC)
      
      
      Ethernet switching table : 68 entries, 68 learned
      Routing instance : default-switch
          Vlan                MAC                 MAC         Age    Logical
          name                address             flags              interface
          dmzuplink           00:00:5e:00:01:ba   DL            -   ae4.0                
          dmzuplink           00:10:db:bc:f5:9d   DR            -   ae4.0                
          dmzuplink           00:10:db:ff:10:01   DL            -   ae3.0                
          dmzuplink           00:19:e2:57:33:81   DR            -   ae4.0                
          dmzuplink           00:26:88:92:ef:1d   DR            -   ae4.0                
          dmzuplink           28:8a:1c:74:fb:07   DR            -   ae4.0                
          dmzuplink           28:8a:1c:75:05:1f   DR            -   ae4.0                
          dmzuplink           28:c0:da:6a:1d:2a   DR            -   ae4.0                
          dmzuplink           2c:21:72:7d:40:01   DL            -   ae4.0                
          dmzuplink           3c:8a:b0:77:a9:d6   DR            -   ae4.0                
          dmzuplink           5c:5e:ab:0e:cd:e0   DL            -   ae4.0                
          dmzuplink           84:18:88:8d:9d:2a   DL            -   ae4.0                
      
      MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static
                 SE - statistics enabled, NM - non configured MAC, R - remote PE MAC)
      
      
      Ethernet switching table : 68 entries, 68 learned
      Routing instance : default-switch
          Vlan                MAC                 MAC         Age    Logical
          name                address             flags              interface
          rack_1              00:50:56:9b:01:57   DR            -   ae2.0                
          rack_1              00:50:56:9b:09:95   DL            -   ae2.0                
          rack_1              00:50:56:9b:15:2e   DL            -   ae2.0                
          rack_1              00:50:56:9b:20:44   DL            -   ae2.0                
          rack_1              00:50:56:9b:20:a7   DL            -   ae2.0                
          rack_1              00:50:56:9b:22:a8   DR            -   ae2.0                
          rack_1              00:50:56:9b:38:01   DL            -   ae2.0                
          rack_1              00:50:56:9b:66:dc   DL            -   ae2.0                
          rack_1              00:50:56:9b:75:60   DR            -   ae2.0                
      
      MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static
                 SE - statistics enabled, NM - non configured MAC, R - remote PE MAC)
      
                                              
      Ethernet switching table : 68 entries, 68 learned
      Routing instance : default-switch
          Vlan                MAC                 MAC         Age    Logical
          name                address             flags              interface
          v54                 80:71:1f:c1:85:f0   DL            -   ae4.0                
      
      
    2. Show Ethernet switching table in Switch B.
      root@EX9200-B> show ethernet-switching table
      MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static
                 SE - statistics enabled, NM - non configured MAC, R - remote PE MAC)
      
      
      Ethernet switching table : 66 entries, 66 learned
      Routing instance : default-switch
          Vlan                MAC                 MAC         Age    Logical
          name                address             flags              interface
          rack_1              00:50:56:9b:01:57   DL            -   ae2.0                
          rack_1              00:50:56:9b:09:95   DR            -   ae2.0                
          rack_1              00:50:56:9b:15:2e   DR            -   ae2.0                
          rack_1              00:50:56:9b:20:44   DR            -   ae2.0                
          rack_1              00:50:56:9b:20:a7   DR            -   ae2.0                
          rack_1              00:50:56:9b:22:a8   DL            -   ae2.0                
          rack_1              00:50:56:9b:38:01   DR            -   ae2.0                
          rack_1              00:50:56:9b:66:dc   DR            -   ae2.0                
          rack_1              00:50:56:9b:75:60   DL            -   ae2.0                
      
      MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static
                 SE - statistics enabled, NM - non configured MAC, R - remote PE MAC)
      
      Ethernet switching table : 66 entries, 66 learned
      Routing instance : default-switch
          Vlan                MAC                 MAC         Age    Logical
          name                address             flags              interface
      
      MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static
                 SE - statistics enabled, NM - non configured MAC, R - remote PE MAC)
      
      
      Ethernet switching table : 66 entries, 66 learned
      Routing instance : default-switch       
          Vlan                MAC                 MAC         Age    Logical
          name                address             flags              interface
          v54                 80:71:1f:c1:85:f0   DR            -   ae4.0                
      

    Meaning

    This output means that the MAC addresses are properly learned within the shared VLANs defined in the MC-LAG. This includes IRB interfaces to define the MC-LAG as well as the ICL interfaces used to configure VRRP.

    Verifying VRRP in MC-LAG

    Purpose

    Verify that VRRP is up and active between the devices in the MC-LAG.

    Action

    1. Confirm that VRRP is up and active on Switch A.
      root@EX9200-A> show vrrp
      Interface     State       Group   VR state VR Mode   Timer    Type   Address
      irb.54        up              4   backup   Active      D  3.090 lcl    192.168.54.1   
                                                                      vip    192.168.54.3   
                                                                      mas    192.168.54.2   
      irb.100       up              1   backup   Active      D  2.655 lcl    192.168.10.3   
                                                                      vip    192.168.10.1   
                                                                      mas    192.168.10.2   
      

      In this example, Switch A is the backup VRRP member.

    2. Confirm that VRRP is up and active on Switch B.
      root@EX9200-B> show vrrp
      Interface     State       Group   VR state VR Mode   Timer    Type   Address
      irb.54        up              4   master   Active      A  0.900 lcl    192.168.54.2   
                                                                      vip    192.168.54.3   
      irb.100       up              1   master   Active      A  0.175 lcl    192.168.10.2   
                                                                      vip    192.168.10.1   
      

      In this example, Switch B is the master VRRP member.

    Meaning

    This output means that VRRP is up and running properly.

    Verifying OSPF on MC-LAG

    Purpose

    Verify that OSPF is properly up and running with MC-LAG.

    Action

    1. Show OSPF neighbors on Switch A.
      root@EX9200-A> show ospf neighbor
      Address          Interface              State     ID               Pri  Dead
      192.168.90.2     ae0.0                  Full      192.18.39.2      128    35
      192.168.10.2     irb.100                Full      192.18.39.2      128    33
      192.168.54.2     irb.54                 Full      192.18.39.2      128    38
      
    2. Show OSPF routing table on Switch A.
      root@EX9200-A> show ospf route
      Topology default Route Table:
      
      Prefix             Path  Route      NH       Metric NextHop       Nexthop      
                         Type  Type       Type            Interface     Address/LSP
      192.18.39.2        Intra Router     IP            1 ae0.0         192.168.90.2
                                                          irb.100       192.168.10.2
                                                          irb.54        192.168.54.2
      192.18.39.1/32     Intra Network    IP            0 lo0.0
      192.18.39.2/32     Intra Network    IP            1 ae0.0         192.168.90.2
                                                          irb.100       192.168.10.2
                                                          irb.54        192.168.54.2
      192.168.10.0/24    Intra Network    IP            1 irb.100
      192.168.54.0/24    Intra Network    IP            1 irb.54
      192.168.90.0/24    Intra Network    IP            1 ae0.0
      
    3. Show OSPF neighbors on Switch B.
      root@EX9200-B> show ospf neighbor
      Address          Interface              State     ID               Pri  Dead
      192.168.90.1     ae0.0                  Full      192.18.39.1      128    32
      192.168.10.3     irb.100                Full      192.18.39.1      128    34
      192.168.54.1     irb.54                 Full      192.18.39.1      128    37
      
    4. Show OSPF routing table on Switch B.
      root@EX9200-B> show ospf route
      Topology default Route Table:
      
      Prefix             Path  Route      NH       Metric NextHop       Nexthop      
                         Type  Type       Type            Interface     Address/LSP
      192.18.39.1        Intra Router     IP            1 ae0.0         192.168.90.1
                                                          irb.100       192.168.10.3
                                                          irb.54        192.168.54.1
      192.18.39.1/32     Intra Network    IP            1 ae0.0         192.168.90.1
                                                          irb.100       192.168.10.3
                                                          irb.54        192.168.54.1
      192.18.39.2/32     Intra Network    IP            0 lo0.0
      192.168.10.0/24    Intra Network    IP            1 irb.100
      192.168.54.0/24    Intra Network    IP            1 irb.54
      192.168.90.0/24    Intra Network    IP            1 ae0.0
      

    Published: 2014-12-10