Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Configuration, Files, Users, Licenses, and Product Registration

 
Note

This topic applies only to the J-Web Application package.

Managing Configuration Files Through the Configuration History (J-Web Procedure)

Note

This topic applies only to the J-Web Application package.

Use the Configuration History function to manage configuration files.

  1. Displaying Configuration History

  2. Displaying Users Editing the Configuration

  3. Comparing Configuration Files with the J-Web Interface

  4. Downloading a Configuration File with the J-Web Interface

  5. Loading a Previous Configuration File with the J-Web Interface

Displaying Configuration History

To manage configuration files with the J-Web interface, select Maintain > Config Management > History. The main pane displays History — Database Information page.

Table 77 summarizes the contents of the display.

The configuration history display allows you to:

  • View a configuration.

  • Compare two configurations.

  • Download a configuration file to your local system.

  • Roll back the configuration to any of the previous versions stored on the switch.

Table 77: J-Web Configuration History Summary

Field

Description

Number

Version of the configuration file.

Date/Time

Date and time the configuration was committed.

User

Name of the user who committed the configuration.

Client

Method by which the configuration was committed:

  • cli—A user entered a Junos OS CLI command.

  • junoscript—A Junos XML protocol client performed the operation. Commit operations performed by users through the J-Web interface are identified in this way.

  • snmp—An SNMP set request started the operation.

  • other—Another method was used to commit the configuration.

Comment

Comment.

Log Message

Method used to edit the configuration:

  • Imported via paste— Configuration was edited and loaded with the Configure > CLI Tools > Edit Configuration Text option.

  • Imported upload [filename]—Configuration was uploaded with the Configure > CLI Tools > Point Click Editor option.

  • Modified via J–Web Configure — Configuration was modified with the J-Web Configure menu.

  • Rolled back via user-interface— Configuration was rolled back to a previous version through the user interface specified by user-interface, which can be Web Interface or CLI.

Action

Action to perform with the configuration file. The action can be Download or Rollback.

Displaying Users Editing the Configuration

To display a list of users editing the switching platform configuration, select Config Management > History. The list is displayed as Database Information in the main pane. Table 78 summarizes the Database Information display.

Table 78: J-Web Configuration Database Information Summary

Field

Description

User Name

Name of user editing the configuration.

Start Time

Time of day the user logged in to the switch.

Idle Time

Elapsed time since the user issued a configuration command from the CLI.

Terminal

Terminal on which the user is logged in.

PID

Process identifier assigned to the user by the switching platform.

Edit Flags

Designates a private or exclusive edit.

Edit Path

Level of the configuration hierarchy that the user is editing.

Comparing Configuration Files with the J-Web Interface

To compare any two of the past 50 committed configuration files:

  1. Select Config Management > History. A list of the current and the previous 49 configurations is displayed as Configuration History in the main pane.
  2. Select the check boxes to the left of the two configuration versions you want to compare.
  3. Click Compare.

    The main pane displays the differences between the two configuration files at each hierarchy level as follows:

    • Lines that have changed are highlighted side by side in green.

    • Lines that exist only in the more recent configuration file are displayed in red on the left.

    • Lines that exist only in the older configuration file are displayed in blue on the right.

Downloading a Configuration File with the J-Web Interface

To download a configuration file from the switch to your local system:

  1. Select Config Management > History. A list of current and previous 49 configurations is displayed as Configuration History in the main pane.
  2. In the Action column, click Download for the version of the configuration you want to download.
  3. Select the options your Web browser provides that allow you to save the configuration file to a target directory on your local system.

    The file is saved as an ASCII file.

Loading a Previous Configuration File with the J-Web Interface

To load (roll back) and commit a previous configuration file stored on the switching platform:

  1. Select Config Management > History. A list of current and previous 49 configurations is displayed as Configuration History in the main pane.
  2. In the Action column, click Rollback for the version of the configuration you want to load.

    The main pane displays the results of the rollback operation.

    Note

    When you click Rollback, the switch loads and commits the selected configuration. This behavior is different from the switch's behavior that occurs after you enter the rollback configuration mode command from the CLI. In the latter case, the configuration is loaded but not committed.

Setting or Deleting the Rescue Configuration (J-Web Procedure)

Note

This topic applies only to the J-Web Application package.

A rescue configuration is a well-known configuration that recovers a switch from a configuration that denies management access. You set a current committed configuration to be the rescue configuration through the J-Web interface or CLI.

If someone inadvertently commits a configuration that denies management access to an EX Series switch and the console port is not accessible, you can overwrite the invalid configuration and replace it with the rescue configuration by using the LCD panel on the switch. The rescue configuration is a previously committed, valid configuration. We recommend that the rescue configuration include the IP address (accessible from the network) for the management port.

To view, set, or delete the rescue configuration using the J-Web interface, select Maintain > Config Management > Rescue. On the Rescue page, you can perform the following tasks:

  • View the current rescue configuration—Click View rescue configuration.

  • Set the current running configuration as the rescue configuration—Click Set rescue configuration.

  • Delete the current rescue configuration—Click Delete rescue configuration.

Uploading a Configuration File (J-Web Procedure)

Note

This topic applies only to the J-Web Application package.

You can create a configuration file on your local system, copy the file to the EX Series switch and then load the file into the CLI. After you have loaded the configuration file, you can commit it to activate the configuration on the switch. You can also edit the configuration interactively using the CLI and commit it at a later time.

To upload a configuration file from your local system:

  1. Select Maintain > Config Management > Upload.

    The work area displays the File to Upload box.

  2. Specify the name of the file to upload using one of the following methods:
    • Type the absolute path and filename in the File to Upload box.

    • Click Browse to navigate to the file.

  3. Click Upload and Commit to upload and commit the configuration.

    The switch checks the configuration for the correct syntax before committing it.

Managing Log, Temporary, and Crash Files on the Switch (J-Web Procedure)

Note

This topic applies only to the J-Web Application package.

You can use the J-Web interface to rotate log files and delete unnecessary log, temporary, and crash files on the switch.

  1. Cleaning Up Files

  2. Downloading Files

  3. Deleting Files

Cleaning Up Files

If you are running low on storage space, use the file cleanup procedure to quickly identify files to delete.

The file cleanup procedure performs the following tasks:

  • Rotates log files—Archives the current log files, and creates fresh log files.

  • Deletes log files in /var/log—Deletes files that are not currently being written to.

  • Deletes temporary files in /var/tmp—Deletes files that have not been accessed within two days.

  • Deletes all crash files in /var/crash—Deletes core files that the switch has written during an error.

To rotate log files and delete unnecessary files with the J-Web interface:

  1. Select Maintain > Files.
  2. In the Clean Up Files section, click Clean Up Files. The switching platform rotates log files and identifies files that can be safely deleted.

    The J-Web interface displays the files that you can delete and the amount of space that will be freed on the file system.

  3. Click one of the following options:
    • To delete the files and return to the Files page, click OK.

    • To cancel your entries and return to the list of files in the directory, click Cancel.

Downloading Files

You can use the J-Web interface to download a copy of an individual log, temporary, or crash file from the switching platform. When you download a file, it is not deleted from the file system.

To download files with the J-Web interface:

  1. In the J-Web interface, select Maintain > Files.
  2. In the Download and Delete Files section, Click one of the following options:
    • Log Files—Log files in the /var/log directory on the switch.

    • Temporary Files—Lists the temporary files in the /var/tmp directory on the switching platform.

    • Jailed Temporary Files (Install, Session, and so on)—Lists the files in the /var/jail/tmp directory on the switching platform.

    • Crash (Core) Files—Lists the core files in the /var/crash directory on the switching platform.

      The J-Web interface displays the files located in the directory.

  3. Select the files that you want to download and click Download.
  4. Choose a location for the saved file.

    The file is saved as a text file, with a .txt file extension.

Deleting Files

You can use the J-Web interface to delete an individual log, temporary, and crash file from the switching platform. When you delete the file, it is permanently removed from the file system.

Caution

If you are unsure whether to delete a file from the switching platform, we recommend using the Clean Up Files tool described in Cleaning Up Files. This tool determines which files can be safely deleted from the file system.

To delete files with the J-Web interface:

  1. Select Maintain > Files.
  2. In the Download and Delete Files section, Click one of the following options:
    • Log Files—Lists the log files in the /var/log directory on the switching platform.

    • Temporary Files—Lists the temporary files in the /var/tmp directory on the switching platform.

    • Jailed Temporary Files (Install, Session, etc)—Lists the files in the /var/jail/tmp directory on the switching platform.

    • Crash (Core) Files—Lists the core files in the /var/crash directory on the switching platform.

      The J-Web interface displays the files in the directory.

  3. Select the box next to each file you plan to delete.
  4. Click Delete.

    The J-Web interface displays the files you can delete and the amount of space that will be freed on the file system.

  5. Click one of the following buttons on the confirmation page:
    • To delete the files and return to the Files page, click OK.

    • To cancel your entries and return to the list of files in the directory, click Cancel.

Managing Users (J-Web Procedure)

You can use the Users Configuration page for user information to add new users to an EX Series switch. For each account, you define a login name and password for the user and specify a login class for access privileges.

To configure users:

  1. Select Configure > System Properties > User Management.

    The User Management page displays details of users, the authentication order, the RADIUS servers and TACACS servers present.

  2. Click Edit.
  3. Click any of the following options on the Users tab:
    • Add—Select this option to add a user. Enter details as described in Table 79.

    • Edit—Select this option to edit an existing user's details. Enter details as described in Table 79.

    • Delete—Select this option to delete a user.

  4. Click an option on the Authentication Methods and Order tab:
    • Authentication Order—Drag and drop the authentication type from the Available Methods section to the Selected Methods. Click the up or down buttons to modify the authentication order.

    • RADIUS server—Click one of the following options:

      • Add—Select this option to add an authentication server. Enter details as described in Table 80.

      • Edit—Select this option to modify the authentication server details. Enter details as described in Table 80.

      • Delete—Select this option to delete an authentication server from the list.

    • TACACS server—Click one of the following options:

      • Add—Select this option to add an authentication server. Enter details as described in Table 80.

      • Edit—Select this option to modify the authentication server details. Enter details as described in Table 80.

      • Delete—Select this option to delete an authentication server from the list.

      Note

      After you make changes to the configuration on this page, you must commit the changes for them to take effect. To commit all changes to the active configuration, select Commit Options > Commit. See Using the Commit Options to Commit Configuration Changes for details about all commit options.

Table 79: User Management Configuration Page Summary

Field

Function

Your Action

User Information

Username (required)

Specifies the name that identifies the user.

Type the username. It must be unique within the switching platform. Do not include spaces, colons, or commas in the username.

User Id

Specifies the user identification.

Type the user’s ID.

Full Name

Specifies the user's full name.

Type the user's full name. If the full name contains spaces, enclose it in quotation marks. Do not include colons or commas.

Login Class (required)

Defines the user's access privilege.

Select the user's login class from the list:

  • operator

  • read-only

  • super-user/superuser

  • unauthorized

This list also includes any user-defined login classes.

Password

Specifies the login password for this user.

Type the login password for this user. The login password must meet these criteria:

  • The password must be at least 6 characters long.

  • It can include alphabetic, numeric, and special characters, but not control characters.

  • It must contain at least one change of case or character class.

Confirm Password

Verifies the login password for this user.

Retype the login password for this user.

Table 80: Add an Authentication Server

Field

Function

Your Action

IP Address

Specifies the IP address of the server.

Type the server’s 32-bit IP address, in dotted decimal notation.

Password

Specifies the password of the server.

Type the password of the server.

Confirm Password

Verifies that the password of the server is entered correctly.

Retype the password of the server.

Server Port

Specifies the port with which the server is associated.

Type the port number.

Source Address

Specifies the source address of the server.

Type the server’s 32-bit IP address, in dotted decimal notation.

Retry Attempts

Specifies the number of login retries allowed after a login failure.

Type the number.

Note: Only 1 retry is permitted for a TACACS server.

Time out

Specifies the time interval to wait before the connection to the server is closed.

Type the interval in seconds.

Managing Licenses for the EX Series Switch (J-Web Procedure)

Note

This topic applies only to the J-Web Application package.

To enable and use some Junos OS features on an EX Series switch, you must purchase, install, and manage separate software licenses. Each switch requires one license. For a Virtual Chassis deployment, two licenses are recommended for redundancy. After you have configured the features, you see a warning message if the switch does not have a license for the feature.

Before you begin managing licenses, be sure that you have:

  • Obtained the needed licenses. For information about how to purchase software licenses, contact your Juniper Networks sales representative.

  • Understand what makes up a license key. For more information, see License Key Components for the EX Series Switch.

This topic includes the following tasks:

Adding New Licenses

To add one or more new license keys on the switch, with the J-Web license manager:

  1. In the J-Web interface, select Maintain > Licenses.
  2. Under Installed Licenses, click Add to add a new license key or keys.
  3. Do one of the following, using a blank line to separate multiple license keys:
    • In the License File URL box, type the full URL to the destination file containing the license key or keys to be added.

    • In the License Key Text box, paste the license key text, in plain-text format, for the license to be added.

  4. Click OK to add the license key or keys.

A list of features that use the license key is displayed. The table also lists the ID, state, and version of the license key.

Deleting Licenses

To delete one or more license keys from a switch with the J-Web license manager:

  1. In the J-Web interface, select Maintain > Licenses.
  2. Select the check box of the license or licenses you want to delete.
  3. Click Delete.

Displaying License Keys

To display the license keys installed on a switch with the J-Web license manager:

  1. In the J-Web interface, select Maintain > Licenses.
  2. Under Installed Licenses, click Display Keys to display all the license keys installed on the switch.

A screen displaying the license keys in text format appears. Multiple licenses are separated by a blank line.

Downloading Licenses

To download the license keys installed on the switch with the J-Web license manager:

  1. In the J-Web interface, select Maintain > Licenses.
  2. Under Installed Licenses, click Download Keys to download all the license keys installed on the switch to a single file.
  3. Select Save it to disk and specify the file to which the license keys are to be written. You can also download the license file to your system.

Registering the EX Series Switch with the J-Web Interface

Note

This topic applies only to the J-Web Application package.

You can register your EX Series switch with the J-Web interface so that you can request technical assistance as and when required. To register an EX Series switch:

  1. In the J-Web interface, select Maintain > Customer Support > Product Registration. For an EX8200 Virtual Chassis configuration, select the member from the list.

    Note the serial number that is displayed.

  2. Click Register. Enter the serial number in the page that is displayed.

Generating Support Information Reports for EX Series Switches Using the J-Web Interface

Note

This topic applies only to the J-Web Application package.

For requesting technical support for EX Series switches, you can either contact the Juniper Networks Technical Assistance Center (JTAC) or raise an online request on the Customer Support Center (CSC) portal at https://www.juniper.net/customers/support/ for quick and easy problem resolution. You can generate the support information report for your device before requesting technical support and include this information with your request for technical support. This information helps the technical assistance providers in identifying your system setup and diagnosing the problem.

To generate the support information report for your switch:

  1. In the J-Web interface, select Maintain > Customer Support > Support Information. For a Virtual Chassis configuration, select a member from the list.

    The Support Information page displays the general information about the switch, such as software version, chassis information, and configuration.

  2. To obtain the support information for your device, click Generate Report to obtain a local copy of the support information report.

With the support information generated, you can access the CSC portal to view a list of the support options available to you, or you can open a case online using CSC’s Case Management tool.

JTAC policies—For understanding JTAC procedures and policies, use the JTAC User Guide located at https://www.juniper.net/us/en/local/pdf/resource-guides/7100059-en.pdf .