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About This Guide

Use this guide to access information about the NPAT (Network Planning and Analysis Tools) and
Paragon Planner desktop application user interface. See the Paragon Planner User Guide for details
about router-specific features such as MPLS, BGP, VPN.
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Access Paragon Planner Desktop Application

The Paragon Planner desktop application helps you simulate the effect of changes in a network without
affecting the actual network. The following is a high level list of tasks you can perform using the Paragon
Planner desktop application:

Design, simulate, and analyze a network offline.

A network topology map shows simulated or imported data for nodes, links, and LSP paths.
Network information table shows simulated or imported data for nodes, links, and LSPs.
Import or add nodes, links, and LSPs for network modeling.

Add and stage LSPs for provisioning to the network.

Create or schedule simulation events to analyze the network model from failure scenarios.
Report manager provides extensive reports for simulation and planning.

Import interface data or aggregate archived data to generate historical statistics for querying and
chart displays.

You can access the Paragon Planner desktop application by using the Java Network Launch Protocol
(JNLP) file, which you can download from the Paragon Automation web Ul. JNLP files are used to launch
applications hosted on a web server or a remote computer.

NOTE: Ensure that the client PC from which you access the Paragon Planner desktop application
has the following software installed:

e Java Runtime Environment (JRE): Depending on the OS of the client PC, you can must install a
JRE or equivalent. For example, Azul Zulu (https:/www.azul.com/downloads/?package=jdk)
offers builds of OpenJDK (Open Java Development Kit) for both Windows and Mac OS.

e Web Start: You can use Open Web Start (https:/openwebstart.com/) as a replacement for
Java Web Start. Alternatively, you can use Iced Tea on Windows (https://adoptopenjdk.net/
icedtea-web.html).

To download and launch the Paragon Planner desktop application:

1.
2.

3.

From the Paragon Automation web Ul, select Planning > Paragon Planner Desktop.

In the Paragon Planner Desktop page, enter the memory you want to allocate, and click OK. The
default value is 512 MB.

Click Save File when prompted.



A Java Network Launch Protocol (JNLP) file is downloaded to your computer.
4. Double-click the JNLP file to launch Paragon Planner desktop application.
5. Log in using the credentials for Paragon Planner.

Paragon Planner desktop application opens.

Key Paragon Planner Features | 3

Main Window Overview | 8

Key Paragon Planner Features

Paragon Planner is an integrated software package that addresses backbone topological design and
simulation, as well as maintenance issues using TDM multiplexers, Routers, Frame Relay switches and
ATM switches. Several hardware devices are currently modeled.

Feature Description

Capacity e The impact of adding new demands, or traffic, can be analyzed in a network model before

they are placed onto the real network. The software determines whether there is

sufficient available capacity in the network and recommend places where capacity should
Design, and be added.
Diversity Design

Planning
Backbone

e A network can be automatically designed based on end-to-end traffic requirements,
starting from an existing set of backbone trunks (“Incremental Design”) or from scratch
(“Green-field Design”). Using powerful heuristic algorithms, Paragon Planner can evaluate
whether trunks can be pruned from the network without compromising diversity
constraints. Trunks can be optimally added to ensure all traffic is placed under any single
element failure (“Diversity Design”). Potential bottlenecks are also easily detected.
Further analysis capabilities include load balancing and end-to-end delay and loss
calculations.

Failure Exhaustive single, double, or triple element failures, interactive or customizable scripted
Simulation failure scenarios can be simulated to analyze and evaluate a networks' resiliency.



(Continued)

Feature

Hardware-
Specific Device
Library

Path
Assignments

Tariffs

Detailed Design
and Analysis
Reports

(Continued)

Detailed
Topology
Views

Description

e Hardware-specific device models have been developed by through close working
relationships with the major device vendors. This ensures the accuracy and precision of
the model, as well as the support of many device-specific features.

e Paragon Planner includes various data extraction tools to convert network data (for
example, router configuration files) into a format readable by Paragon Planner.

For an existing backbone network, the optimal layout or path assignment can be determined
which satisfies all demand constraints. Demand constraints may include media preferences,
diverse paths, hardware bandwidth overhead calculations, and delay/hop constraints. In the
case of routers, tunnel constraints may include link attributes/colors and capacity. Available
paths can be found even when the actual hardware fails to find a path. If the hardware
switch supports user-specified paths, then paths found using the model can be downloaded
to the real network.

Paragon Planner can help reduce private line leasing costs (monthly recurring and non-
recurring components) by producing designs that satisfy user requirements and constraints
while maintaining a minimal cost. You can specify your own pricing tables which are then
integrated into Paragon Planner suite to price out lines. This is used extensively in the
program's heuristic least-cost design algorithms. The savings reaped normally translate to a
quick return on investment.

As with all modules, detailed reports are generated to help you to quickly assess and
summarize network-related data. These reports include trunk pricing, trunk utilization, and
demand paths. Reports can be generated in text format, CSV (comma separated) format, or
web-friendly HTML.

Detailed topology views allow you to view your network nodes and links. These can be placed by

geographical location, rearranged by hand, or automatically rearranged in a format that
distributes the points to make the network easier to view. Panned utilization, link vendors and

other attributes can be viewed by color; hardware devices are represented by various icons. Links

can be labeled by a number of attributes including link metrics. From the topology map, popup
menus can be accessed by right-clicking on nodes or links, providing quick targeted access to
information about the selected network element.



Paragon Planner Power Features

Feature

Discrete Event
Simulation

Domain/Structured
Networks

Traffic Load Analysis

Facility Feature

Class of Service
(CoS) Feature

Customer Tariff

Path Diversity
Design

Description

Packet-by-packet simulation is available for Frame Relay and Router device models, giving
statistics on queuing delays and packet loss ratios.

Partitioned or structured networks, including PNNI, are supported by Paragon Planner.
Device-specific support of domains is also correctly modeled.

Analysis of real traffic load per demand can be loaded into the software model to obtain a
more accurate link utilization for failure simulations. Paragon Planner can do multi-period
load and performance analyses.

Any number of nodes and/or links can be grouped together in a facility for failure
scenarios and reporting options.

The class of service feature allows you to classify traffic into four classes, including the
strict priority class. With this feature, the accuracy of the Paragon Planner’s Design and
Discrete Event Simulation modules are greatly improved, as the software takes into
account all the details of class-based weighted fair queueing (CBWFQ) in its routing
process.

The customer tariff feature allows you to specify various tariff classes and their rates for
the network. Each node is associated with a particular tariff class. All links would then be
priced according to its service and the classes of the nodes it connects.

The path diversity design feature allows you to configure demands (or tunnels) on link-
disjoint, site-disjoint, or facility-disjoint paths.



Supported Hardware

IN THIS SECTION

Juniper Networks | 6
Cisco Systems | 6
Alcatel | 6

Huawei | 6

Juniper Networks

e Routers: Junos OS and JunosE-based devices such as Juniper Networks® MX Series 5G Universal
Routing Platforms, J Series, PTX Series Packet Transport Routers, M Series and T Series routers

Cisco Systems

e Routers: I0S and I0OS-XR-based devices such as ASR, NCS, and CRS

e MPLS/Tag Switching (MPLS-TE, GB-TE)

Alcatel

e 7750 Service Router

Huawei

e AR Series Routers

e NE Series Routers
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Main Window Overview

This topic explains the functions of the main window, the workspace from which all Paragon Planner
windows are launched or opened. In addition, it discusses the File menu of the menu bar. Figure 1 on
page 8 shows the main window, displayed when a network is launched.

Figure 1: The Main Window
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The main window consists of the following elements: Menu, Toolbar, Topology, Console, and Network
Info window. Note that many functions and features do not become available until a network is loaded.
This includes some of the menus as well as the topology window.

Menu options may vary depending on your user permissions, or modules.

Table 1: Main Window Drop-down Menus

File The File menu contains network file functions such as creating, "File Menu Functions" on
opening, saving, loading files, and closing the network. page 100



Network

Design

Simulation

Traffic

Inventory

Report

Admin

Tools

Windows

Help

The Network menu provides comprehensive details on network
elements, such as nodes, links, interfaces, demands, and tunnels.
Detailed information on services, protocols, and paths. Alternative
Maps such as BGP.

The Design menu provides options to design the network’s
backbone through new or incremental designs for the backbone
links. Design also enables functions such as path placement, path
diversity design, and tuning.

The Simulation menu provides options to run scripted and
interactive failure scenarios for nodes, links, sites, and facilities, to
test the network’s resiliency and discover worst-case scenarios.

The Traffic menu is used to access traffic-related features such as
Traffic Load, Trending, Growth, and Traffic Aggregation.

The Inventory menu is used to access hardware inventory reports
and hardware equipment cost tables.

The Report menu is used to access the Report Manager which
contains detailed network, tunnel, simulation, configuration, and
user customized reports.

The Admin menu is used to access the Task Manager, Device
Library, and User Administration. These functions are normally
used by network administrators or Paragon Planner
administrators.

The Tools menu contains settings and tools: VPN Traffic
Generation, and Options.

The Windows menu lists all sub-windows currently open in
Paragon Planner.

The Help menu contains a link to help documentation, information
about the system, and the Message of the Day.

"Network Menu Overview" on
page 121

"Design Menu Overview" on
page 196

"Simulation Menu Overview"
on page 217

"Traffic Menu Overview" on
page 230

"Inventory Menu Overview'
on page 262

"Report Manager Window
Overview" on page 315

"Accessing the User
Administration Window" on
page 397

"Tools Menu Overview" on
page 404



Figure 2: Main Window Toolbar (options may vary)
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The toolbar contains the following items:

e Update button to update the status and routing on the network after you have made changes to the
network.

e Stop button to cancel simulation runs or T-Solve processing.

e Two network layer buttons for MPLS-enabled router networks: Tunnel, Layer 3
e Description of the network model

o Integrity Checks shortcut

e Task Manager shortcut

e Provisioning Manager shortcut

e Console shortcut

e Configuration File search bar to search for text in the configuration files of the currently opened
network.

Topology Map

The topology map, or Map (Standard), is the main work area in Paragon Planner and displays important
link and node properties. Links are color-coded according to a specified link property such as media
type, trunk type, or vendor. By default, the links are displayed by link utilization. Nodes are color-coded
by icons and symbols.



For more information on how to select and move nodes, label nodes, and access network information

properties through right-click popup menus, refer to "Topology Window Overview" on page 53.

Figure 3: Topology Map
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Figure 4: Main Window Console
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The console displays additional information when loading the network, reading files, running failure
simulation, generating reports, performing path trace, creating designs, and various other functions. The
console can be used to trace through information in more detail.

Right-click in the console window to access further functions such as copying text, searching for text in
the console, saving the output, or creating a trace file of the console output.

The Network Info window contains network summary information and detailed information on nodes,
links, interfaces, demands, and tunnels. Within each element tab, the element information can be



searched, filtered, or modified for network what if studies. Additional elements may be available in this
window depending on the network model.

Figure 5: Main Window Network Information
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The File Manager Window

The File Manager is the window where you can easily navigate through directories to find and load
network projects (specification files), open and edit files, and create new files in Paragon Planner file
format. You can also perform basic file functions such as cut, copy, paste, delete, and directory creation.
Figure 6 on page 15 shows the File Manager window.

Figure 6: The File Manager
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The File Manager is split into two panes: the left pane is a tree view of the directory structure on the
server, and the right pane displays the directory contents. Some files and directories may belong to
other users and have restricted access. Thus, those files and directories cannot be opened, deleted, or
moved because of file permissions.



File Manager Toolbar

The toolbar located across the top of the File Manager window contains buttons useful for directory

navigation, file manipulation, and configuring the view.

Figure 7: The File Manager Toolbar
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Table 2: File Manager Toolbar Functions

Function

Back

Forward

Up

Home

Path

Refresh

Search

View

Help

Description

Displays the contents of a previous directory accessed.

Allows you to go forward on the history list.

Changes the directory to the parent of the current directory.

Goes to the server's home directory.

Displays the directory path.

Refreshes the directory view.

Search text inside the files of the current directory.

This drop-down selection allows you to customize the display.

Opens the online-help webpage for more detailed information.

16



Table 2: File Manager Toolbar Functions (Continued)

Function Description

Files of Types This field filters for file names or extensions.

The file type drop-down filter options include the following Paragon Planner-specific files:
o All Files (*.*): Displays all file types in a directory in the right pane of the File Manager.

e Spec Files (spec.*): Displays only the specification files in a directory. The specification file is used by
the program to determine which input directories and files to load for the network.

e Dparam Files (dparam.*): Allows you to display only the dparam files in a directory. The dparam file
contains default parameter values for the network, such as hardware type, link bandwidth and
overhead, size and performance tuning, and miscellaneous parameters.

e MuxLoc Files (muxloc.*): Displays only mux/oc files in the directory. This file contains the node ID and
name of each node in the network.

o BBIlink Files (bblink.*): Displays only bblink files. This file contains the location, quantity, vendor, and
attributes of the links found in the network.

e Demand Files (demand.*): Displays only demand files. This file contains information regarding the
end-to-end demands, circuits, or flows, and path specifications needed for the network.

You can enter in a custom filter string using the wildcards “*” and “?” and press <Enter>.

o " (Asterisk): Represents any string of characters. One advantage is that files can be filtered by
runcode. For example, you can type in the filter x.mpls-fish to filter the files to show only files with
the runcode mpls-fish.

e ‘2" (Question Mark): Represents any one character. For example, the bblink.mpls? string can be used to
fetch files named bblink.mpls1 and bblink.mpls2 but not bblink.mpls-fish.



File Manager Left Pane

Figure 8: Directory View and Common Actions/Favorite Links View
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In the left pane of the File Manager, clicking the X in the upper-right corner of the Directory view opens
the Common Actions and Favorite Links view. The Common Actions section contains shortcuts to
various options. Click on Directory View to switch back to the directory tree view.

Favorite Links to Directories or Files



Under Favorite Links you can store links to commonly used directories or files. To add a link, right-click
the file or directory from the right pane and select Add to Favorites. You can specify the name of the link
in the subsequent dialog box.

Once the link has been added under the Favorite Links section, clicking on a link to a directory opens
that directory in the right pane. Clicking a link to a file performs the Open command for that file.

To rearrange, delete, or rename favorite links, click Organize... To rearrange the order, select an item and
click Move Up or Move Down. To rename a link, type in a new name and then click Rename.

Figure 9: Organize Favorites
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File Manager Right-Click Menu

Right-clicking in the right pane of the File Manager displays the functions listed in Table 3 on page 20



Table 3: File Manager Right-Click Menu Functions

Function

Open

Edit

New

Spec File

Copy File to Client

Open With Report
Viewer

Open With Report
Master

Open With Report
Editor

Archive (tar)

Description

This menu is equivalent to double-clicking a file. This option allows you to open a
highlighted directory or file. The actions are different for directories, specification files, and
non-specification files:

e A directory. Displays the contents of the directory in the right pane.

e A specification file. Loads the specification file into the program and opens up the
network model.

e A (non-spec) file: Launches the Text Editor where you may edit the file.

Opens the file in Paragon Planner’s text editor to allow you to directly edit the file. Refer
to "Text Editor" on page 38.

Allows you to create new directories and text files in the current path. Refer to File
Manager New Command.

Contains all functions related to the Paragon Planner specification file (spec). From this
submenu, you can choose options to load, modify, or create new specification files. Refer
to "File Manager Spec File" on page 22.

Allows you to copy the selected file(s) from the server to the local client.

Enables you to view certain files in a table-like format. Refer to Open With Report Viewer .

Enables you to view multiple reports in one window where the left pane includes the
report name and the right pane includes the report contents. Refer to Open With Report
Master.

Enables you to edit entries in the reports.

Zips files or directories into a tar file.



Table 3: File Manager Right-Click Menu Functions (Continued)

Function Description
Compress (gzip) Compress and zips files into a gz file.
View Allows you to change the view of the file listing in the right pane of the File Manager.

Most of these selections can also be found in the view icon’s drop-down selection menu of
the toolbar. Refer to File Manager View.

Refresh Updates the directory and file listing
Add to Favorites Adds file or directory to the Favorite Links list.
Cut Stores the selected file(s)/folder(s) in memory until you paste the files in a different

location. Once you paste them in a different location, the selected file(s) are deleted.

Copy Copies files and/or folders highlighted in the File Manager window.

Paste Places files or folders that were last cut or copied into the directory currently open in the
File Manager.

Rename Renames the highlighted file or directory.

Delete Removes highlighted files or directories.

The New command allows you to create new directories and text files in the current path. Note that
when creating new files or directories, the you must have write permission to create files in that
directory.

Table 4: File Manager New Command Functions

Function Description

Directory This creates a new directory. When selected, you are prompted to enter the name of the
directory to be created.



Table 4: File Manager New Command Functions (Continued)

Function

Plain File

Table

Backbone data

Cost files

Control files

Report Files

Description

This creates a new plain text file in the current directory. When selected, Paragon Planner
prompts you for a file name. Once the name of the file is entered, the program brings up the
text editor for editing the new text file.

This creates a file with tables using comma separated format. It's recommended to save the file
extension as .csv.

This creates a template for backbone data files: muxloc, bblink, demand, nodeparam, site,
group, graphcoord, owner.

This creates a template for a tariff file. Tariff files include: usercost, usercountrycost.

This creates templates for the following Paragon Planner files: fixlink, linkdist, nodeweight,
rsvbwfile.

This creates templates for new report files. You can add five types of report files: Paragon
Planner report master, main only, main and row detail, main and column detail, and main and
cell detail. The Paragon Planner report master is similar to the Report Manager in that it allows
you to view more than one report in an organized structure. Main only report files show only
the main table, while the other reports show both the main table and detailed information of
each row, column, or cell.

File Manager Spec File

The Spec File submenu contains all functions related to the specification files. From this submenu, you

can choose options to load, modify, or create new specification files. The following selections are

available:

Spec File > New

Spec

Allows you to create a new specification file. This basically means you are
creating a new network from scratch. To use this option, first close any the
currently open specification files.



Spec File > Load
Spec

Spec File > Modify
Spec

Spec File
Generation
Window
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Loads the currently highlighted specification file into the system. Once a
specification file is loaded, the network topology window also appears.

Allows you to change the runcode, data directory, rate directory, and network
files of the specification file. After modifying the options and clicking Finish, you
can load the network.

Once you select the New Spec or Modify Spec option, the specification file
generation window appears. From this window you can specify properties for the
specification file, dparam file, and various other specific input files necessary for a
network to be properly loaded and displayed.

Figure 10: Spec File Generation Window General Tab

Spec File Generation
Spec File Directary: fubwandliidatalexamplet! | Browse...
General EEEHEETETEEEN N ER TR EE:
Runcode: | |
Spec File: | |
Data Directary: | | Erowse.
Rate Directory: fuwandlidbiratesidetault ] ==
[+l et = Cancel Help

The specification file is a text file that specifies all the network input files to be loaded for the active
session as well as the runcode (extension), data directory datadir, and rate directory ratedir.



Table 5: Spec File Generation Window General Tab Fields

Fields

Runcode

Spec File

Data
Directory

Rate
Directory

Description

This is the file extension used to distinguish different networks and different sessions. Output
files and reports are appended with the specified runcode file extension. Runcodes may consist
of any combination of alphanumeric characters. This field is saved with the keyword runcode in
the specification file.

Specifies the name of the specification file. By default this is spec.<runcode> where <runcode> is
replaced by the network file extension.

The data directory datadir represents the path to the default directory in which your data files are
searched for. If a particular file is located in the specified data directory, its absolute path need
not be provided when defining that file. For example, if the data directory for a design run is
specified as /user/test and the file muxloc.test is located in that directory, you can simply specify
muxloc.test, rather than /user/test/muxloc.test, when prompted for the location of the muxloc

file. To specify the specification file directory as the data directory, the character “” (period) can
be used as a shortcut. This field is saved with the keyword datadir in the specification file.

The rate directory is used to specify the path of the directory where the tariff database files are
read. In most cases, the default path /u/wandl/db/rates/default does not need to be changed. If
you want to use you own tariffs, reference them from a directory other than /u/wandl/db/rates/
default. This field is saved with the keyword ratedir in the specification file.
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The dparam file specifies design and simulation parameters, hardware vendor, link bandwidth/overhead,
size and various other network parameters.

Figure 11: Spec File Generation Window Design Parameters Tab

Spec File Generation ol N E
Spec File Directary: [fexportfhomelimplsviewsdatalexample | Browse...
\Generalll Desion Farameters || igtiorkFiles|
Design Parameters File:
dpararm.ex] Browse...
Reset
Hardware Tvpe! | poUTER -
Maximum Mumber of Modes: 100
Maximum Mumber of Links: 1500
Finish Cancel Help
Table 6: Spec File Generation Window Design Parameters Tab Fields
Fields Description
Design Specifies the file name of the dparam file.
Parameters File
Hardware Type Allows you to choose the hardware type of the network. This field is saved with the

keyword hwvendor in the dparam file.



Table 6: Spec File Generation Window Design Parameters Tab Fields (Continued))

Fields Description

Maximum The Maximum Number of Nodes helps the program decide how much memory to allocate
Number of Nodes = and can only be modified when the network is closed:

The Maximum Number of Nodes (saved as maxnodenumber in the dparam file) represents
the maximum number of nodes that may be entered for a particular network. The number
entered should be no smaller than the number of nodes planned and no larger than the
node_limit in your license file. The default value is 100.

Maximum The Maximum Number of Links helps the program decide how much memory to allocate
Number of Links and can only be modified when the network is closed:

The Maximum Number of Links (saved as maxlink in the dparam file) represents the
maximum number of links for a particular network. Once the limit is reached during a
design, the program does not continue to add links. The number entered should be no
smaller than the number of links planned. The default value is 1500.

The default link bandwidth, link overhead and per circuit bandwidth overhead calculations vary for
different vendors. Because of device-specific characteristics (routing algorithm, rerouting, buffer size,
gueuing, etc.) the same network data may yield different results when comparing switch models.

The Network Files tab contains references to data files that should be loaded in. Each reference are
saved in the specification file with a separate entry.

You can read in files from the Network Files tab. The files in this tab are categorized as described in
Table 7 on page 26.

Table 7: Spec File Generation Window Network File Categories

Type of File File Names

Backbone Files bblink, demand, domainfile, facility, graphcoord, group, muxloc, newdemand,
nodeparam, owner, site, srvcprofile, srvctype

Cost Files custrate, usercost

Control Files admincost, fixlink, linkdist, nodeweight, rsvbwfile



Table 7: Spec File Generation Window Network File Categories (Continued)

Type of File File Names
Traffic Files devicedir, egress, ingress, t_trafficload, trafdir, trafficload, tunneltrafdir
Access Design Files chanbank, offckt, offgraphcoord, offloc, offsitek

Discrete Event simulation = tfxdata, tfxpattern

Device-Specific Files aclist, bgplink, bgpnode, bgpobj, intfmap, junospolicy, policymap, route, tbit, tunnel,
vpn

Figure 12: Spec File Generation Window Network Files Tab

Spec File Generatian

Spec File Directary: |Iexpnrtfhnme.fmplsviewﬁsampleirnuterﬁﬂsh-new | Browse...

\\Geristal | Desiai Parametefsl| Netvork Fles
&2

=l Backbone Files
bhlink none B
demand nong i
darmainfile nore [
facilityfile nane
graphcoord nane
group naonge
muxloc narne
neswdermand narne
nodeparam nane
ovner naonge
site narne -

Bhlink contains backhone link information far the netwark, Each link entry is defined by a
link name [optional], From_Location, To_Location, Yendor, number of trunks, and trunk
type.

| b a5 Browse... Reset

Finish Cancel Help




Network backbone files specify how the network is represented. Backbone files include the bblink,

demand, domainfile, facilityfile, graphcoord, group, muxloc, newdemand, nodeparam, owner, site,
srvcprofile, and srvctype files.

Table 8: Spec File Generation Window Network Files List

File

bblink

demand

domainfile

facility

graphcoord

Description

The bblink file contains backbone link information for the network. Each link entry is defined by
a link name [optional], From_Location, To_Location, Vendor, number of trunks, and trunk type.
The vendor may be specified as DEF (default) if it is not known. See BBLINK (bblink=filename)in
"Backbone Data" on page 426.

The demand file contains user traffic requirements. A demand is defined by an ID,
From_Location, To_Location, Bandwidth, Type, Priority, and Preempt Priority. See DEMAND
(demand=filename).

The domainfile contains the definitions for domain elements. Domain elements are defined by
ID, name, and color to be used in the Map window. If OSPF is present in the network, this file is
used to define OSPF areas. See DOMAIN (domain=filename).

A facility is a set of nodes and links likely to fail together. The facility file defines the links and/or
nodes associated with a facility. In this file, the first field defines the facility name. The
subsequent fields specify the node IDs or link names associated with that facility, delimited by
tabs, spaces, or commas. All elements associated with a facility should be specified on the same
line. Whenever more than one line is needed to specify the elements, a backslash, '\, must be
used to indicate that the element list is continued on the next line.

The facility feature does not check the validity of the nodes and/or links listed in the facility file.
Duplicate links and/or nodes are also duplicated in the facility. Nodes may be specified either by
their node ID or node name. If both are used in the same facility, then that node is duplicated.
Nodes which are not in the mux file and links not in the bblink file are ignored. See FACILITY
(facility=filename).

The graphcoord file is used to position nodes at coordinates different from their true geographic
location. This is often times helpful when multiple nodes have the same NPANXX location or are
located in close proximity to each other. Nodes may be moved by first selecting them and then
dragging them to the new location. Note that pricing information is not changed since only the
graphical representation has been modified rather than the geographical. See FACILITY
(facility=filename) .



Table 8: Spec File Generation Window Network Files List (Continued)

File

group

muxloc

newdemand

nodeparam

owner

site

service profile

service type

Description

The group file defines the grouping of nodes in the network topology. Discs are painted on the
Standard map around grouped nodes. See GROUP (group=filename).

Muxloc specifies the file containing switch information such as name, ID, NPA, NXX, latitude,
longitude, vertical, or horizontal. This information is used to determine location placement in the
map window as well as for link pricing. See MUXLOC (muxloc=filename).

The newdemand file allows you to specify an additional file containing user traffic requirements
besides the demand file. The purpose is to reduce your effort in manually modifying the existing
demand file, and/or having multiple versions. In addition, the newdemand file is often used in
theoretical "What if..." situations in determining capacity planning for the current network state.
See DEMAND (demand=filename).

The nodeparam file allows you to define specific information on a per-node basis such as the
hardware type, vendor, or model. See NODEPARAM (nodeparam=filename).

The owner file facilitates identifying the ownership of nodes and demands. Ownership should be
specified in either the muxloc or demand files. See OWNER (ownerfile=filename).

The site file specifies site information. The site file is used to define nodes in the same physical
location such as a building or campus.

The service profile file lists the service types and the percentage that are in each service profile..

The service type file lists service types (for example, FTP, TELNET) and their descriptions (for
example, owner, min. and max. bandwidth, type, pri, pre).

Cost and control files are used to assign tariffs and implement link controls. Examples of cost and control
files are: custrate, usercost, admincost, fixlink, linkdist, nodeweight, and rsvbwfile.



Table 9: Cost and Control Files

File

custrate

usercost

admincost

fixlink

linkdist

nodeweight

Description

The custrate file is used to assign tariffs for links used in the network to approximate the total cost
of the network. You can specify the parameters from which these tariffs are calculated using the
modify custom rate and custom rate class windows. See CUSTRATE (custrate=filename).

The usercost file is used to define the cost for links according to the end nodes, vendor, and trunk
type. See USERCOST (usercost=filename).

The admincost file contains rules to set each link default admin weight/metric according to
attributes such as trunk type, mileage, and the hardware type and sites of the endpoints.

The fixlink file specifies information for links that cannot be removed from the backbone topology.
For varying reasons, a customer might have a group of links in the backbone that cannot be
removed (even if it is optimal to do so). In this case, during the optimization phase of the design,
links from the fixlink file are not modified. Note that the bblink file might be used for the fixlink
file if the current topology cannot be changed. See FIXLINK (fixlink=filename).

The linkdist file is used to define link distance values on a node pair basis. Link distances can be
used to bias path routing by assigning either a higher or lower weight to a node pair. If a linkdist
file is not specified or a particular link’s metric is not defined, and the Admin Weight routing
method is specified in the design options of the Path Placement tab, the default link distance value
is assigned. See LINKDIST (linkdist=filename).

The nodeweight file is used to restrict the creation of links at particular nodes during design by
assigning to the node a penalty for adding links or the maximum bandwidth capacity for links. This
file can also be used to restrict the transit demand bandwidth at a node if the hardware model
supports path configuration for demands.

Every entry in the nodeweight file consists of four fields: node ID or name, node weight (link
penalty for design), maximum bandwidth capacity (to carry links), and transit demand bandwidth
limit. Fields are separated by spaces or tabs. A node weight is required if maximum link bandwidth
capacity is to be specified. See NODEWEIGHT (nodeweight=filename).



Table 9: Cost and Control Files (Continued)

File Description

rsvbwfile The rsvbwfile is used to define reserved bandwidth for links between specific node pairs. Reserved
bandwidth is specified as a fixed bandwidth (fixfat) plus a percentage of the link bandwidth (fatpct).
See RSVBWHFILE (rsvbwhile=filename) for the file format.

e For node pairs not defined in this file, reserved bandwidth specification is derived from the
fixfat and fatpct global parameters defined by selecting Tools > Options > Design in the
Reserved Bandwidth options pane.

e Reserved bandwidth is not used by during path assignment and backbone design if the
hardware supports path configuration. The reservation constraints, however, are ignored by the
simulation and failure analysis routines.

NOTE: In Table 9 on page 30, an asterisk (*) specifies files used for a feature that is license
dependent.

For more information regarding these files, refer to the Design Menu chapter.
Access Design Files
Examples of access design files include: chanbank, offckt, offgraphcoord, offloc, and offsite.

Examples of traffic files include: devicedir, egress, ingress, t_trafficload, trafdir, trafficload, and
tunneltrafdir.

Table 10: Traffic Files

File Description

egress The egress file contains egress traffic of the network interfaces load. Egress traffic specifies
traffic that is going out of the network interfaces. This data is used for calculating link
utilization and load.

ingress The ingress file contains ingress traffic of the network interfaces load. Ingress traffic
specifies traffic that is going into the network interfaces. This data is used for calculating link
utilization and load.



Table 10: Traffic Files (Continued)

File Description

trafdir, The trafdir file identifies the location of the interface traffic daily directories repository.

tunneltrafdir
The tunneltrafdir file identifies the location of the tunnel traffic daily directories repository.

trafficload, The trafficload file allows you to import measured bandwidth utilizations based on data
t_trafficload collected from the network. Traffic loads for each PVC can be specified over the time
intervals for which the data was collected.

The t_trafficload file (IP/MPLS only) is similar to the trafficload file, but for LSP tunnels (layer
2 instead of layer 3)

Examples of the discrete event simulation files include: tfxdata, tfxpattern

Table 11: Discrete Event Simulation

File Description

tfxdata For discrete event simulation only. The trafficdata file allows you to define each demand by
specifying multiple packets and packet sizes. Although this requires you to have a reasonable
knowledge of the traffic, more accurate network simulation results can be obtained in this manner.
Refer to TRAFFICDATA (TRAFFICDATA=filename) for further details.

tfxpattern | For discrete event simulation only. The trafficpattern file allows you to define several class types
based on traffic characteristics. Each traffic type may be specified in terms of four parameters:
number of messages, duration (seconds), message size (bits), and frame size (bytes). Refer to
TRAFFICPATTERN (TRAFFICPATTERN=filename) for further details.

Device specific files contain the definitions for various types of devices. Examples of device specific files
include: aclist, bgplink, bgpnode, bgpobj, intfmap, policymap, tbit, tunnel, and vpn.

Table 12: Device-Specific Files

File Description

aclist The aclist file (Router only) contains information about access rules such as access lists, distribute
lists, and filter lists.



Table 12: Device-Specific Files (Continued))

File

bgplink

bgpnode

bgpobj

intfmap

policymap

thit

tunnel

vpn

rtd

hpnni

Description

The bgplink file (Router only) contains the definitions for BGP neighbors. See note for bgpobj. See
note for bgpobj.

The bgpnode file (Router only) contains the definitions for BGP speakers. See note for bgpobj.

The bgpobj file (Router only)contains information about BGP neighbors and is stored in binary
format to speed up performance. Note: If you want to manually edit bgpnode and bgplink, comment
out this entry before reloading the network.

The intfmap file (Router only) contains information about router interfaces, including the node,
interface, IP address, status, bandwidth, VPN-list, and other details.

The policymap file (Router only) contains information about CoS Policies on each router

The tbit file (Router only) stores names for the tunnel attributes (otherwise referred to as admin
group for Juniper Networks).

The tunnel file (Router only) contains information about LSP tunnels.

The vpn file (Router only) contains information about Virtual Private Network details such as vrf,
route distinguisher, route target, and protocols.

The routing table descriptor (rtd) file (ATM/PNNI only) is used for PNNI networks to read routing
table descriptor information. This file is generated by Paragon Planner after you saved the network’s
RTDs.

The hpnni file (ATM/PNNI only) is used for PNNI networks to describe PNNI information for nodes
and logical group nodes in the network. It also contains hierarchical information which allows
Paragon Planner to group the network’s nodes accordingly.

The Report Viewer allows you to view reports that are generated by the system. The report viewer
provides quick access and a uniformed and organized way of viewing these reports. To view a report,



you must select a file that is in Paragon Planner report format. To customize the columns displayed,
right-click on the column header and select the Select Columns... option.

Figure 13: Report Viewer Window
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Due to the length of some reports, the Report Viewer only displays a portion of the report in the viewer
window. You may set how many lines to display in the Page Setup. With the jump-to buttons, you can
jump to the beginning and end of the report. You can also move forward or back. Clicking the Search
button searches the current table for the queried text. Clicking the Advanced Search button opens a
new window for more complex searches. The query is entered in the text field at the top of the window.
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The panels on the bottom are provided for convenience in selecting keys, relations, and boolean
operators.

Figure 14: Report Viewer Toolbar

Coarch Advanced Fage

/ Search /Setup
Filter|* B 48 K 4 »r »# 0 of 0 displayed

Figure 15: Advanced Filter Window
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The Report Master allows you to view multiple reports in the Report Master window. The Report Master
is similar to the Report Manager which provides quick access and a uniformed and organized way of



viewing multiple reports without having to open a network first. To open a report master, you must

select a file that is in report master format.

Figure 16: Report Master Window
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The Report Master files do not contain any actual reports. Instead, the Report Master files reference
existing reports and place them into an organized tree structure. The format of a Report Master file is

described below.

# Paragon Planner Report Master

1st_item First.report

2nd_item

3rd_item {

3-1_item /export/home/data/3-1.report

3-2_item 3-2.report

3-3_item {

3-3-1_item 3-3-1.report
3-3-2_item 3-3-2.report

../../other_path/2nd.report

36



The Report Editor allows you to perform basic editing functionality on csv files. Click on a cell to edit the
value. Right-click on a cell to for more options to edit rows and columns.

Figure 17: Report Editor Window
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Table 13: Report Editor Window File Manager View

Show Hidden Files | This option displays all hidden files in the directory

Large Icons This option displays files and directories listed in the File Manager’s right pane as large icons
in columns.

Small Icons This option displays files and directories listed in the File Manager’s as small icons in
columns.

List This option displays files and directories listed in the File Manager's in list form.

Details This option gives a detailed view of the files displayed in File Manager including information

such as file permission, file owner, file size, and last modified date. (Note: Each column can
be sorted by clicking on the column header.)

Directory View This toggles the left pane between the Directories view and Common Actions / Favorite
Link view.



Text Editor

The text editor allows you to edit any text file found on the system via a graphical interface. When a file
such as a log file or Paragon Planner network file is double-clicked, the text editor is launched. When a
text file is opened in the text editor, the file name is displayed across the top.

Figure 18: The Text Editor

M B fuiwandlizampledPAishispec. mpls-fish @ =l 7 S P
H & 3 % Sa @ #A 2 =Ecotn Bchowline# [ 9 2 [H  FortSize 12w

#datadir = /howme/wandl/iponplsview/sanple/IP/fish aj
runcode = mpls-fish

# ratedir = fuifwandl/db/rates/defanlt

wxloc = maxloc.mpls-£fish # mwre< location file

odeparam = nodeparam.upls-£fish # max type and constraints file
#3ite = none

hlink = bblink.mpls-fish # backbone link file
turmneltenplate=u/wandl /data/tenplates
graphcoord = graphcoord.mplzs-fish # definhes graphics coordinates of nodes
graphcoordaux = graphcoordaud.mpls-£ish # defines aux graphics coordinates of nodes

# Files used in L23W wvlan design:
# Files used by bbdagn:

demand = demand.mpls-fish # circuit definition file
#newdenand = none
trafficload = trafficload.mpls-fish

[ knowmtrafficload = none
tunnelfile = tunnel.uwpls-fish # Tunnel definition file
dparam = dparam.mpls-fish # parameters
#usercost = none # user defined link cost file
#linkdist = none # user defined link distance file
#fixlink = none

| Line: 1139 | |

Table 14: Text Editor Window Functions

Function Description

Save Save the file.



Table 14: Text Editor Window Functions (Continued)

Function Description

Save As Save the file under a different name and/or directory.

Print Print the current file to a printer.

Cut Cuts the selected text being edited.

Copy Copies the selected text being edited.

Paste Pastes any cut or copied text.

Find/Replace Search for or replace a specified string.

Select All Select and highlight all the text.

Go To Jump to a certain line in the file.

Show/Hide Line# Toggles displaying the line numbers.

Filter Line Displays only the lines with a text match. Supports regular expression. The filter is case
sensitive.

Restore to Original Text | Removes any filters and displays the original text.

Font Size Change the text font size.



Figure 19: The Find and Replace Dialog Box
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Table 15: Text Editor Window Find and Replace Functions

Function

Find Text

Replace With

Find Next

Replace

Replace All

Match Case

Find Backward

Description

Specify the text to be searched.

Specify the replacement text.

Click this button to search for the next occurrence of the text.

Click this button to replace the highlighted text.

Click this button to replace all occurrences of the text.

Toggles the text search to be case sensitive or insensitive.

Sets the Find/Replace function to search for the text in reverse order toward the beginning of
the file.

NOTE: If you open a file that is larger than 4 MB in size, then Paragon Planner will launch the
text editor in read-only mode. This is to prevent memory over-usage for the system.
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Config Editor (Router and Switch)

Paragon Planner provides a convenient and easy-to-use config editor for editing router configuration
files. This editor functions similarly to other text editors, but contains some special operations and built-
in recognition of configuration file keywords to facilitate the editing of config files. Supported router
configs include Cisco (I0S, XR, CatOS, Nexus), Foundry, Juniper Networks (Junos OS, EX, ERX),
Riverstone (RapidOS, ROS-X), Tellabs, Alcatel, Extreme, Huawei, Redback, Starent, and Zyxel.

To access, simply double-click on a configuration file within the File Manager. Alternatively, if your
network model was built up from config files via File > Import Network Wizard, you can also right-click
on the router in the Map window or the Network Info window Nodes view and select Show Config File.
This will open up your config file in the Config Editor as shown in Figure 20 on page 42.

NOTE: For those using the Online module of Paragon Planner, if you have opened the Live
network, right-clicked on a node in the Map, and selected Show Config File, the config editor will



Figure 20: Config Editor Window

only allow you to view the configs, and not edit them. This is because they represent the actual
state of the configurations in the network.
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To edit, simply modify by inserting or deleting characters in the text area. Then, press the Save icon. To
close a file, select Actions > File > Close. To open a config file from your local machine rather than the
server, select Actions > File > Open Local. Editing tools can be found in the toolbar, in the right-click
menu that appears in the left pane, and in the Actions menu.

Most of the editor functionality is self-explanatory or standard. The following lists some specific

capabilities of the Config Editor:

o Config Editor Open Multiple Files

e Compare Two Files
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e Keep Track of Revisions Made to a File
o Navigate the Config File Quickly With the Outline

e Find and Replace , including ability to search globally within all configuration files in your current
network model

e Collect and Refresh Configuration Files (Paragon Planner Online Module Only)
e Insert an Entire Text File
o Set Color-Coding and Other Options

To open a config file located on the server, press the Openicon on the toolbar. Or select Actions > File >
Open. To open a config file located on your local machine, select Actions > File > Open Local.

A new tab is created in the left pane of the Config Editor for each file that is opened.

You can perform side by side comparison of config files by opening a config file in a new window. To do
so, first select the tab of the desired config file. Right-click somewhere over the config’s pane and select
Open in New Window. A new instance of the Config Editor will appear and the selected config is moved
from the original window over to the new window.

Compare Two Files

To compare two files, select Actions > Tools > Compare > Two Files. You are prompted to specify two
files located on the server machine, as shown in Figure 21 on page 44. Use the “Browse” buttons to
navigate to the desired file. Then, press “OK". The File Diff window will appear showing the side-by-side
results of the “diff".

Note that these same comparison capabilities are also available via the Revision Manager. You can
access the Revision Manager directly through the Config Editor via Actions > Tools > Revision Manager.



If you have already set up revision information for the current network, you can compare two files using
Actions > Tools > Compare > With Revision.

Figure 21: Select Two Files for Comparison

Enter two file names to compare

File 1 | || Browse..

File 2 | || EBrowse..
1 Cancel

Figure 22: File Diff Side-by-Side Comparison
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Entries in GREEN indicate that a line was added. BLUE indicates a line was removed. RED indicates the
line has changed. The green, blue, and red markers on the right bar of the window can help you quickly
scroll to the points where differences have been detected.

Keep Track of Revisions Made to a File

You can use track changes made to a file, using Actions > Tools > Revision Manager. After the initial
setup of the revision system, you can “Check In” your config file to create a new revision/version
number.



Navigate the Config File Quickly With the Outline

The Config Editor divides each router configuration file into blocks. In Junos OS, for example, blocks are
clearly defined by brackets. For other hardware, the Config Editor divides blocks based on certain major
commands. The Outline section of the Config Editor, located in the upper right hand side of the window,
lists a high-level “outline” of these major commands. Click on any point in the outline to immediately
jump to that section of the config file. Press the “+” and “-” boxes to the left of an entry to expand and
collapse the entry, respectively. You can also hide or show the Outline Pane using the toggling menu
options Actions > Hide Outline Pane and Actions > Show Outline Pane.

Figure 23: How to Use the Outline
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e Clicking on an entry in the Outline pane will cause the Config Editor to jump to that section of the
config file, highlight the first line of that section, and expand that block. In Figure 22, Tunnel7 is
expanded in the left pane.
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Right-clicking within the left pane reveals three Outlining options. If your mouse cursor is placed
somewhere in the config file text in the left pane, and you select Toggle Outline, then the section
containing the cursor will expand if currently collapsed, or collapse if currently expanded. You can
accomplish the same thing by clicking directly on the “+” and “-” boxes to the left of each config
section. “Collapse All Outline” and “Expand All Outline” will collapse or expand all sections, or blocks,
in the current config file view. Note that these operations are also available via the Config Editor’s
Actions menu on the window’s top menu bar.

Holding your mouse cursor over a “+" box to the left of a collapsed block in the config file will pop up
a tooltip showing the contents of that section.

Find and Replace

The Actions > Search submenu contains the following features:

Find and Replace: This is a standard Find and Replace editor function.
Find on this File: This opens the Find function in the Config Editor toolbar.

Find in Configuration Files: This function allows you to perform a global search on all config files
associated with the currently opened network model, not just the config files that are opened in the
Config Editor. Results are displayed in a table, as shown in Figure 24. Within this table, you can
double-click on an entry or press the “Show in Editor” button. The corresponding config file is
displayed in the Config Editor (or opened if you have not yet opened it) and the occurrence of the
word is highlighted.



e Go To: Jump to a specific line in the file.

Figure 24: Find in Configuration Files
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Figure 25: Find in Configuration Files Results
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Collect and Refresh Configuration Files (Paragon Planner Online Module Only)

This feature is located in Actions > Tools > Collect and Refresh Configuration. It is available for Paragon
Planner only, and accessible only if you are in online, or live, mode (select File > Open Live Network ).
This option applies to just the config that is currently being viewed in the Config Editor. It allows you
retrieve the router’s configuration file from the live network and update your copy within the Config
Editor.

Insert an Entire Text File

If you have config file statements in another file that you wish to insert at a particular point of the
current config file, select Actions > Edit > Insert Text File. Browse for a text file that is located on the
server. If your text file is located on your local machine, select Actions > Edit > Insert Local Text File
instead.

Set Color-Coding and Other Options



You can set Config Editor color coding, font, and general preferences via Actions > Options. Note that
you can also access these preferences by selecting Tools > Options > General from the software’s main
menu bar. In the Options window, click on Config Editor.

Figure 26: General Config Editor Options
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Function Description

Enable auto-completion | If this is enabled, then as you type within the Config Editor, Auto-completion will
suggest the complete word based on its database of keywords for the particular
hardware. Only major keywords for certain hardware models are supported.

Show outline and If this is unchecked, then the Outline and Property panes of the Config Editor is
property pane hidden, providing more room for the main config editing panel.

Show output/integrity If this is enabled, then the Config Editor displays a list of items found from Integrity
check list Checks report.



(Continued)

Function

Use memory-efficient

alternative editor

Description

If you click this option, then the next time you open a config file, it is opened in

Paragon Planner’s standard editor. That is, the configuration file will not be outlined in
blocks, there is no color-coding of keywords, auto-completion, etc.

Figure 27: Config Editor Color Options Example
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Figure 28: Config Color Options
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Foreground, Foreground is the text color. Background is the color of the page.
Background
Selection Whatever text that is selected is highlighted in this color. Select text by dragging the
mouse.
Caret The cursor
Bracket Match For config files that use brackets, when you select an open bracket (‘{'), the matching

close bracket (‘') will also be highlighted.



(Continued)

Item

Keyword 1,2,3

Literal

Comment

IP Address

Description

These are colors assigned to different levels of config file keywords. These keywords are
pre-defined by the Config Editor, and selected based on both importance and how well
they facilitate readability of the file. In general, Keyword 1 = major commands, Keyword
2 = sub-major commands, Keyword 3 = commands with “negative” meaning (for
example, “shutdown”, “disable”, “inactive”, etc.).

e Note: In a future release, these will also be editable.

Any user-specified string, such as an interface description, often in double quotes.

Comments

All instances of IP addresses
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Topology Window Overview

The topology (map) window is the main work area for any network model you load into the system.
Multiple links displayed between nodes uses “line bending" to avoid hidden trunks in the topology. The
topology incorporates node aggregation collapsible views. You can also view node locations via their
geographic coordinates on the world map, NPA/NXX, or automatic layouts.

The topology window displays important link and node properties. Links are color-coded according to
utilization. Alternatively, you can view links by other properties such as media, trunk type, vendor or
domain/area. Nodes are color-coded by symbols, icons, or vendor types.

Path analysis can be performed in the topology window. The path function displays detailed path
information between any two nodes found in the network based on factors such as routing method
used, reserved and actual bandwidth allocation, link distance, or oversubscription.

The topology window is divided into three areas: Left Pane Legend for changing the setting of the
topology view; Center Pane Map displaying the network; and Right Pane Toolbar. Right clicking on the
map opens a pop-up menu for more functions. Move the map by holding the left mouse button and
dragging. Zoom in and out by using the mouse scroll wheel. Figure 29 on page 53 shows the topology
window.

Figure 29: The Topology View Window
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Table 16: Topology Map Pane Areas

Area Description Reference
Center Pane The Topology Map Area is the middle portion of the Topology @ See "Center Pane Map" on
Map Map. In this area, you can select and move nodes around on page 54

the map.
Left Pane The left pane of the topology window contains drop-down See "Left Pane Legend" on
Legend boxes for the following functions: Filters, Network Elements, page 56

Utilization Legends, and Subviews.

Right Pane The toolbar at the right of the topology window provides See "Right Pane Toolbar" on
Toolbar shortcuts to functions in the Popup Menu. page 76
Pop-Up Menu The popup menu is accessed by right-clicking within the See "Map Popup Menus" on

Topology Map Area. Right-clicking over a node, link, or group page 82
results in a popup menu for that element.

Center Pane Map

The topology map is a graphical representation of the baseline network. Paragon Planner can display the
topology in several views depending on the network: BGP, LSP tunnels, Layer 3. You can select these
views from the Network menu in the Main Window.

Features

¢ When the cursor is positioned over a network element in topology window, a description of the
network element appears in the description bar at the bottom of the topology window. That
description can be customized from the popup menu. Right-click on the map and select Labels >
Bottom Bar menu.

e Double-click to get full detailed information about the element.
e Right-click on an element to view more options for that element.
¢ Hold the left mouse button to drag the map around.

e Use the mouse scroll wheel to zoom in and out on the map.



Selecting Multiple Nodes and Links

You can select nodes and links in the topology map in the following ways:

Use the Selection Tool and drag a rectangle around the nodes and links you want to select.

<Ctrl>-click or <Shift>-click on nodes and links.

Right-click on a node and use Select options.

Right-click on a link and use Select options.
Moving Nodes

When moving nodes in the map area, you are changing the graphical coordinates rather than the
geographical coordinates. Graphical coordinates are the positions of the nodes in the topology window.
Geographical coordinates are positions of the nodes according to actual physical locations (for example,
latitude and longitude). To set the current positions as geographical positions, right-click over the map
area and select Layout > Set Lat/Lon from Map.

Saving Map Settings

Topology information that gets saved to each client include the following:

e Map Preferences Settings See "Right Pane Toolbar" on page 76.

Topology information that gets saved to each network includes the following:

o group file: Groupings of network devices are saved in the group file.

o graphcoord file: Graphical coordinates of network devices are saved in the graphcoord file.
e graphcoordaux file: Auxiliary map settings below.

The graphcoordaux file stores the following map settings data:

e Legends: Node and link color settings, link utilization color bar settings, line styles, most checkboxes
in Subviews > Protocols, checkboxes in Filters > Type.

o Labels: Which node/link labels were turned on, labeling preferences for the bottom bar.
e Background Image: See "Map Popup Menus" on page 82.

o Country Maps: See "Map Popup Menus" on page 82.

e Groups: Which groups were collapsed and which groups were expanded.

Multiple map views can be saved for the same network using the Map Views feature. Each view is saved
on the server in a userSettings directory consisting of group (grouping), graphcoord (graphical
coordinates), and graphcoordaux files. For more information, see "Map Popup Menus" on page 82



Left Pane Legend

Filters

For these items, see "Map Filters" on page 59 for more information.

Table 17: Left Pane Legend

Item Description

Protocols Allows you to view your network by different categories such as by
protocol.

Types Allows you to show or label certain categories of nodes (for

example, by hardware type) and links (for example, by trunk type)

Routing Instances Displays routing instances/OSPF process IDs associated with each
link/interface by the color in the legend, which can be customized
using Set Color... in the right-click popup menu. Refer to the Paragon
Planner User Guide chapter titled Routing Instances for more details.

Advanced Includes options to hide certain elements such as nodes (AS’s) or
links (low utilization links)

Network Elements

For these items, see "Map Elements" on page 65 for more information.

Iltem Description

Nodes Includes a list of the nodes in your network. Clicking on a node will
highlight it on the map.

Links Includes a list of links for the selected subview. Clicking on a link will
highlight it on the map.

Facilities Includes a list of facilities in the network. A facility is a set of nodes
and links likely to fail together.



Utilization Legends

For these items, see "Utilization Legends" on page 68 for more information.

Item

Utilization

Peak Util

Planned Node Load

Measured Node Load

Measured Link Util

Demand CoS Util

Subviews

Item

AS

Access/Domain

Description

Displays the planned link utilization using colors of the color bar.
Planned utilization is the percentage of the link used by the
demands you input into the network.

The Peak Util display feature is used after running a failure
simulation script to view the highest (or worst case) link utilization
loading experienced by each link, depending on the rerouting of
demand/flow traffic after any single failure.

Displays the planned traffic on a node by a color bar. For further
information.

Displays the measured interface traffic on a node by a color bar.

Displays the measured interface traffic load by CoS, as an alternative
to Traffic > Traffic Load, Interface.

Displays the normal and peak utilization calculated based on
demand routing, as an alternative to Traffic > Traffic Load.

Description

Displays Autonomous Systems (AS's) by color. Each respective AS
and their colors are shown in the left pane as a legend. The color can
be customized using Set Color... in the right-click popup menu.

Displays the domain or area (for example, OSPF area) by color. Each
respective area and its colors are shown in the left pane legend. The
color can be customized using Set Color... in the right-click popup
menu.



(Continued)

Item

Attributes/AdminGroup

Link Status

Media

Multicast Tree

OSPF Area

P2MP

Protocols

Description

(MPLS-TE module). View links by logical combinations of RSVP
resource colors (Cisco attribute or Juniper Networks admin group).
The logical combinations available include all, any, and not. See the
Paragon Planner User Guide for more information.

(Router module). Displays operational statuses of links and virtual
trunks using colors or line styles. Operational Statuses for links
include Down, Passive, and Other. Operational statuses for virtual
trunks include VT (for an operational virtual trunk) and VT Down for
a non-operational virtual trunk. .

Displays link media types using colors or line styles. Valid link media
attributes include: TERRES (terrestrial), SAT (satellite), MCWAVE
(microwave), FIBER, and ENCRYPT (encrypted). These media
descriptors are used in route biasing of demands using criteria such
as preferred, preferred not, and required. The color and style of
these links can be customized by right-clicking on the icon in the left
pane and selecting Set Color or Set Line Style.

Includes multicast groups in the network. Selecting one will highlight
the distribution tree on the map.

The OSPF Areas list assigns a color, for purposes of representation
on the topology map, for each OSPF area configured in the network.
NONE shows the color assigned to routers with no OSPF area
configured.

Displays a list of configured P2MP groups. Clicking on a group in the
list shows the relevant tunnels in the topology map.

Allows you to view your network by different categories such as by
protocol. See "Map Filters" on page 59.



(Continued)

Item

Routing Instances

Types

Vendors

Map Filters

IN THIS SECTION

Filters > Protocols | 60
Filters > Types | 62
Filters > Routing Instances | 63

Filters > Advanced | 64

Description

Displays routing instances/OSPF process IDs associated with each
link/interface by the color in the legend, which can be customized
using Set Color... in the right-click popup menu. This is the same
view you see when you select Filters > Routing Instances. See "Map
Filters" on page 59. Refer to the Paragon Pathfinder User Guide for
additional details.

Displays types of nodes (for example, by hardware vendor) and links
(for example, by trunk type). See "Subviews > Types" on page 71
for display customization options.

Displays link vendors using colors or line styles. Possible values for
vendors include those that are specific to a certain country or
region, and are listed in the tariff database. If a vendor is not
specified, the vendor is set to the default DEF. To represent in-house
fiber links with zero cost, the vendor should be set to NET. The color
and style of these links can be customized by right-clicking on the
icon in the left pane and selecting Set Color or Set Line Style.



Using the options in the left pane, you can modify your view of the network based on the protocols in
the network, the types of nodes and links, or routing instances. There are also advanced options
available from the left pane that enable custom filtering of network elements in the topology map.

Filters > Protocols

The Filters > Protocols pane offers the ability to display subsets of the available network routing
protocols in the network using logical operations like AND, OR, NOT, and EQUAL. The selections
available will vary according to the protocols in the open network



The bottom of the pane contains the number of nodes, pseudo-nodes, groups, and links that are
currently displayed out of the total number. The number displayed is less than the total when objects are
hidden due to selections either in this pane or other Filters panes.

Figure 30: Filters > Protocols View
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Selecting Show by itself for a protocol displays all network elements supporting the protocol. Selecting
Show and Not together for a protocol displays all network elements that do not support the protocol.

Logical Operations (=, &, and or)

You can perform logical operations on the protocol list selections. The equal operation (=) specifies that
only the currently selected subview is shown. Only one selection is allowed for this operation. The AND
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operation (&) specifies that the intersection of the protocol subviews is displayed. The OR operation (or)
specifies that the union of the protocol subviews is displayed. lists the logical operations.

Logical Op = Protocols Interpretation
= OSPF Filters the display to show OSPF enabled links.
& OSPF: “Show” MPLS-TE: Filters the display to show all links with OSPF enabled but without
“Show Not” MPLS enabled
or QOSPF: “Show” ISIS: “Show” Filters the display to show all links with either OSPF or ISIS
enabled.

Filters > Types

With the Types function, you can choose to display or hide network element symbols in the topology
map depending on the type of node or link (for example, hardware vendor, or trunk type) by selecting or
deselecting the corresponding check box. Use Show All or None to toggle on or off the display of all
element types.

Figure 31: Types

Types -
[¥] | 23 BROCADE

7 | ¥ | CIsco
W | &B uniPer
[#] Groups | Discs

@[ —]ocs

Shiow @ I'E]

This is the same display you see when you select Subviews > Types. See "Subviews > Types" on page
71 for display customization options.




Filters > Routing Instances

With the Routing Instances filter function, you can choose to display or hide links depending upon the
routing instance or OSPF process ID it belongs to by selecting or deselecting the corresponding check
box. Use Show All or None to toggle on or off the display of all routing instances.

Figure 32: Routing Instances
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Click a color box to change the legend color. Alternatively, right-click a box and select Set Color. Right-
click on the color box and select Highlight. These Items to highlight links of this routing instance.



Filters > Advanced

Figure 33: Advanced Filter
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Option Description
Recorded Selection > You can select some nodes/links on the map and then click Record to take a
Show Only Recorded snapshot of the selection. After the recording is made, selecting the checkbox

shows only the recorded selection.

Recorded Selection > You can select some nodes/links on the map and then click Record to take a
Hide Recorded snapshot of the selection. After the recording is made, selecting the checkbox hides
the recorded selection from the map.

AS > Show Only Selected = Allows you to show only selected autonomous systems (ASs) in the topology map.
ASs Click Select to specify which ASs to show.



(Continued)

Option

Intragroup Links > Hide
All

Intragroup Links > Hide

Tier 2

Advanced Filter

Hide Isolated Points

Hide Isolated Points in

Subview

Hide AS Nodes/Links

Hide Backup

Hide VT

Hide Intergroup Links

Map Elements

IN THIS SECTION

Description

Intragroup Links connect nodes within a group. If there are several layers of groups,
selecting Intragroup Links > Hide All hides all links within the top-level groups and
selecting Intragroup Links > Hide Tier 2 hides all links within groups that are two
group levels down.

Click Set... for one of the three categories (Node, Group, or Link) to create an
advanced filter statement. Then click the checkbox to turn the filter on or off.

Hides nodes and groups that are disconnected from all other nodes and groups in
every subview in the map.

Hides nodes and groups that are disconnected from all other nodes and groups in
the current subview.

Hides ASNODE(s) and the link(s) and/or LANs that connect the ASNODE(s) to the
rest of the network. (ASNODES represent ASs outside the network with EBGP
peering relationships with BGP speakers of the network.)

Hides back-up routes in the topology

Hides virtual trunks in the topology.

Hides intergroup links connecting different groups.

Network Elements > Nodes | 66



Network Elements > Links | 67

Network Elements > Facilities | 67

The network elements you can view on the topology map and customize in the left pane include nodes/
groups, links, and facilities. Nodes and links you click in the left pane are highlighted in the topology
map. Facilities are sets of nodes and links that are likely to fail together.

Network Elements > Nodes

When this option is selected, the groups/nodes in the network are displayed in a tree view in the left
pane. Selecting a node or collapsed group in the list highlights it on the map display. The groups, if
defined in the network, are displayed with group elements indented underneath. To expand or collapse a
group, click on the hinge icon to the left of it. You can add an element into a group by selecting the
element name, dragging it and dropping it over the group’s name. Figure 34 on page 66 shows the
nodes/groups.

Figure 34: Network Elements > Nodes List with Pop-up Menu
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Network Elements > Links

When selected from the drop-down menu, this function displays all links associated with the protocol
selected in the Subviews > Protocols menu. For example, if you select Frame-Relay protocol in the
Subviews > Protocols menus, then the Links list displays only the links associate with Frame Relay.

The link names are displayed in a list view in the left pane. Selecting a link name in the list highlights it in
the topology window. Clicking on the links on the topology map highlights them on the links list. Figure
35 on page 67 shows an example of the links list.

Figure 35: Links List with Pop-up Menu
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Network Elements > Facilities

A facility is a group of links and/or nodes that are likely to fail together. It is used in failure simulations
where accurate modeling requires the simultaneous failure of specific links and/or nodes. For instance, if
several links travel over the same fiber, a fiber cut will break all of them at once. In this case, one can
define a facility to represent the SRLG (Shared Risk Link Group) containing those links. Another example
is the set of switches on one floor of a large data center, together with all the links going into or out of
that floor.



Figure 36 on page 68 shows an example of a facilities list in the left pane.

Figure 36: Facility List
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Utilization Legends

e The Utilization displays the planned utilization rate of links resulting from the demands in the
network model.

e The Peak Util displays the links according to the peak utilization reached on that link in a failure
simulation.

e The Measured Link Util displays the measured link utilization, up to 24 periods. A slider bar can be
used to check the utilization at different periods. The data comes from the ingress (interfaceLoad_in)
or egress (interfaceLoad_out) files. For the live network this is named Interface CoS Util and uses
the /u/wandl/data/.network/interface.traffic and interfacei.traffic files.




e The Demand CoS Util displays the normal and peak utilization per CoS calculated based on demand
routing. In this case, it is based off of both the demand and trafficload file. The trafficload file is used
to display up to 24 periods. A slider bar can be used to check the utilization at different periods.

Figure 37: Utilization Legend
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Edit Color This will open a color palette that allows you to choose a color for the section selected
on the color slider.
Add Divider This will add a new divider on the color bar at the location of the right-mouse-click.
Change Max This will change the maximum utilization percentage on the color slider to the specified

value in the New Max window.

Change Viewing Range @ Use this to zoom into a particular percentage range, for example, 0.00-10.00% for
greater granularity.



(Continued)

Menu Item

Show Selected Color

Show All

Show None

Reset to Defaults

Description

Selecting this option shows links that have the selected color. Note that when
deselecting a color, a link is hidden only if the colors of both of its interfaces are
deselected.

Shows links of any colors.

Hides all links.

This will reset the Prov Util color bar to the original default setting of dividers and

colors.

For the Planned Node Load and Measured Node Load panes, there is a color legend that colors the
nodes according to the node load. The colors and divider locations can be modified in this legend.

The Planned Node Load pane allows you to view the planned load on each node based on the
bandwidth of demands originating (Out), terminating (In) or passing through (Transit) each node.

The Measured Node Load pane allows you to view the measured load of traffic going in or out of the
network. This option shows traffic derived from measurements at the incoming and outgoing interfaces.
To use this feature, you should indicate in the specification file the location of the following files that



specify the traffic going in/out of the node from interfaces: interfaceLoad_in (ingress), interfaceLoad_out

(egress). See the Paragon Planner User Guide for more details about these two panes.

Figure 38: Planned Node Load
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The Node Load legend draws each node as a circle. The bigger the traffic going in/out of the node, the
bigger the circle is, so you can easily see which nodes have the most traffic to the outside world. For

Measured Node Load, there is also a slider to choose one of up to 24 periods to display.

For MPLS-enabled networks, you will see a different view depending upon whether Layer 2 or Layer 3 is
selected from the top menu bar of the main window. Selecting Layer 2 allows you to view the planned

load of LSP Tunnels.

Subviews > Types

The Types pane displays categories of devices found in the currently opened network. These devices

include routers, types of links, and any user-defined network element groups found in the network.
Different types of devices are associated with different icons. When putting the mouse over one of




these icons, a tool tip will indicate how many items of the corresponding category are represented on
the map.

Figure 39: Types Subview
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Customizing Nodes and Links

The right-click popup menu for an icon includes the following options:

e Set This Icon: Choose an icon

¢ Highlight These Items: Highlight nodes of this type

The right-click popup menu for a link supports the following options:

e Set Color: Brings up a color chooser to customize the color

¢ Set Line Width: Choose a line width (the larger the number, the thicker the link width)
e Set Line Style: Choose a style (for example, dotted lines)

¢ Highlight These Items: Highlight links of this type

Customizing Node Type Icons
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You set icons by right clicking on the node type or group and selecting Set This Icon. In the Icon chooser,
you may select an icon and press OK to use a preexisting icon. The description of an icon can be found
by hovering the pointer over the icon.

Figure 40: Icon Chooser
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Alternatively, an icon can be uploaded by selecting Upload New Icon and selecting the image file (PNG,
JPG, GIF) in the Choose Icon window. Once the image is selected, select the scale and/or width and
height in the Icon Sizing Tool window.

Uploaded icons can be deleted by right-clicking on the type and selecting Set This Icon and then clicking
the Delete Icon button. Upon deleting the icon, nodes of that type will revert to the original icon used
for that type.

Additional Notes on Icon Import

e Icons uploaded in one session will automatically appear in the "lcon Chooser" window in later
sessions.



e Paragon Planner's default icons are flat and two-dimensional, and you can set their colors by clicking
on the buttons in the Type Legend. By contrast, it is not possible to change the color of an imported
icon.

e Maps with icons cannot be exported to Visio 2002 and earlier (*.csv export). They can be exported to
Visio 2003 and later (*.vdx export).

e When a map is exported to SVG, the *.svg file refers to the icons by their names in the local cache
directory. Before sharing the SVG files with a second user on another machine, it is necessary to edit
the *.svg file to use the icons' names on the second user's machine.

Customizing Line Style



You can modify the line style used to represent specific link types, such as OC3, OC12, STM3, Gigabit
Ethernet, etc. Similar to customizing node type icons, to customize link type line styles, right click on the
link in the type legend and select one of the menu options.

Figure 41: Link Styles
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NOTE: The Export to Visio feature supports dotted line styles, as long as the dotted line is limited
to one color. Solid lines can be exported in up to two colors ( for example, to show the utilization



in both directions on a link). However, it is not possible to export a link in two colors to show the
utilization, and have it be dotted at the same time.

Right Pane Toolbar

Located on the right side of the topology window is the map toolbar. The toolbar provides quick access
to some functions that are also available when right-clicking on the map.

Figure 42: The Topology Toolbar
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Item

Selection Tool

Show/Hide Left
Control Pane

Show Node List

Group Selected

Ungroup Selected

Undo Move
Node(s)

Redo Move Node(s)

Reset to default

Navigator

Zoom In

Zoom Out

Description

Toggles the selection tool to select multiple nodes and links. When ON, holding the left
mouse draws a rectangular selection box. When OFF, holding the left mouse drags the
map around.

Shows or hides the left pane of the map window.

Shows the nodes list in the left pane of the map window.

To create a group, select a set of nodes and/or other groups in the topology map. Then
click this button in the toolbar and specify a name for the group. The selected nodes and
groups are combined and displayed as a group icon. Multilevel group hierarchies can be
created if several groups are organized together into a single higher-level group.

This function will ungroup any group(s) chosen by you. Collapse a group, select it, and click
on the Ungroup Selected Groups button. This permanently removes the group from the
system.

This function allows you to undo up to 10 node movements/re-layouts.

This function allows you to redo up to 10 node movements/re-layouts.

Resets the nodes to their initial position on the map.

The navigator map provides you with a scaled down version of the topology. After
zooming in to the level you prefer, a box will appear in the navigator map that you can
move to view other areas at the same zoom level. For further details, refer to Navigator.

This function allows you to zoom in on a particular area of the topology map by drawing a
box around the target area.

This function allows you to zoom out of the topology map.



(Continued)

Iltem Description

Zoom to Fit This function allows you to quickly fit the entire network topology into the topology
window. The system only fits the network elements that are visible.

Drag/ Rotate Tool e You can create a rectangular box on the map by holding down the left mouse button at
a point and dragging the mouse to another point and then letting go of the mouse to
create a box.

e After creating that rectangle, you can stretch and rotate the nodes in that rectangle.

Path e With the Paths button, you can perform path analysis in the topology window. This is

the same Path function found in the Network Elements > Nodes list and in the pop-up
menu in the topology map.

e The path analysis function displays graphically the path between any two nodes found
in the network based on factors such as routing method used, reserved and actual
bandwidth allocation, link distance, oversubscription. Paths are displayed as a solid
yellow line. Detailed information about the path is displayed in the console window.

Map Preferences Opens the Tools > Options > Map Preferences window for you to customize the map
display (for example, background color, font size, and display of parallel links as curves).

Map Help Opens the online help.

Navigator

When the Navigator button is clicked, it displays the navigational map with an outlined box inside it
showing which part of the map is in the current view. By clicking and dragging this box, you can pan



across the topology map. This function is ideal for use when you have zoomed in to one section of the
topology, and would like to easily move to other regions at the same zoom level.

Figure 43: Navigator

Drag/Rotate Tool

The purpose of the tool is to choose some nodes or collapsed groups within a rectangular region, and
then stretch or shrink the rectangle, move, or rotate it.

To use the tool, press the Drag/Rotate button. Drag a rectangle on the map around nodes/groups that
you wish to move. You may hold down the <Shift> key to constrain the rectangle to be a square. If no
nodes/groups are selected (highlighted in yellow), the rectangle will remember all the nodes and
collapsed groups inside it. Otherwise, if some of the nodes/groups in the rectangle are selected
(highlighted in yellow), then the rectangle will remember only the selected nodes/groups in the
rectangle. This is useful if you only want to move selected nodes in a rectangle.

When you stop dragging, the rectangle turns green, meaning active. Then you can perform one of the
following actions:

e To stretch or shrink the region, drag one of the eight square handles.

e To move the region, put the mouse inside the green rectangle and drag the rectangle to another
location.

¢ To rotate the points inside the green rectangle, rotate the mouse wheel. If you don't have a mouse
wheel, hold down <Alt> and click the left mouse button to rotate in one direction. To rotate in the
other direction, hold down the <Alt> and <Shift> buttons and left-click. If you have a middle mouse
button, click the middle mouse button to rotate them one way, and <Ctrl> or <Shift>-click the middle
button to rotate the other way. (The rotation is along ellipses inside the rectangle, so if you want true
circular rotation, make sure the rectangle is a square by using shift-drag when you create it.)

There are two ways to end the drag/rotate operation: click outside the green rectangle, or click on the
Drag/Rotate button to turn it off.

Paths



This function allows you to view the path between any two nodes in the topology map. To view detailed
path information, click the Paths button in the toolbar (or from the drop-down menu). A cross-hair will
appear. Then select a starting node and drag the cross-hair to a destination node and click on it. The
paths information will appear in the console window giving detailed information about the paths such
the route of the path between these two nodes. The following is an example of the detailed path
information between two nodes:

Bandwidth initialized to 8000

x % % NT(XN1) - N2(XN2): bw= 8.0K * x %

new N1 N2 8.0K R,A2Z 02,02 N1--N2

(Adm_Weight) Route-cost=100. Max_Path_Bw= 40.704M

Node Popup Menus
The following options are accessible when right-clicking a node or set of nodes.
¢ View > Selected Nodes: Displays detailed information about the currently selected nodes.

¢ View > Nodes under Pointer: Displays detailed information about the node(s)/switch(es) at the place
where you clicked. If there are multiple nodes at the place where you clicked, then all are displayed.

¢ View > Demands on/thru Node: Displays all demands that originate or pass through this node. In the
resulting window.

¢ View > Equipment View: Displays node, card, port information.
e View > SRLGs on Node: Displays information about the SRLGs at a node.

e View > Interfaces at Node: Displays information about the interfaces at a node, including but not
limited to IP address, name, bandwidth, and status.

e View > Links at Node: Displays detailed information about all links originating from this node.

e View > Summary at Node: Displays a summary information window for this selected node.
Information such as total number and bandwidth of originating, terminating, transit, and local
demands are all displayed in this summary.

¢ Modify > Selected Nodes: Allows modification of selected nodes.

o Delete Selected Nodes: Deletes the selected nodes. Connecting links may also be deleted in this
process.

e Resize Demands > At Selected Nodes: Enter in a percentage by which to multiply the bandwidth of
the demands that originate or terminate at the node(s) you right-clicked over. For example, enter in
200% to double the bandwidth of the demands at the nodes right-clicked over.



Fail Selected Nodes: Fails selected (highlighted) nodes. The failure simulation will take place when
you click the Run button. This option is available only when the Interactive Simulation window is
open.

Show Config File: This option will open the configuration file for the node if available.

Show Collected File: This will open the Run CLI Command windows which lists data collected by the
Task Manager. The categories available are: ARP, Equipment CLI, Interface, MPLS Topology, Multicast
Path, OAM, OSPF Neighbors, Switch CLI, Transit Tunnel, and Tunnel Path. This option is available
only for Live networks.

Internet Map at Node: Brings up a third party map from the Internet using the specified node’s
latitude and longitude coordinates.

Link Popup Menus

View > Selected Links: Displays detailed information about the link(s) that were highlighted when you
selected this option.

View > Links under Pointer: Displays detailed information about the link(s) at the place where you
clicked.

View > Demands on/thru Link: Displays the demand that are going through the link. You can view all
of them, all of them in one direction, all that start or end at an endpoint of the link, or all demands
that pass through the link that do not start or end at an endpoint of the link.

View > SRLGs on Link: View the SRLGs that this link is part of.

View > Interfaces on Link: View the interfaces on this link.

View > Tunnels on/thru Link: Similar to Demands on/thru Link but for tunnels.
Delete Selected Links: Deletes selected links from the network

Fail Selected Links: Fails highlighted links. The simulation will take place when you click the Run
button. This option is available only when the Interactive Simulation window is open.

Collapse/Expand Multiple Links: This will collapse or expand multiple curved links into one drawn
between two nodes. When you mouse-over a collapsed multi-link, the bottom information bar
displays **1 of x** where ‘X’ is the number of links collapsed



Map Popup Menus

IN THIS SECTION

Map Views | 82
Grouping Popup Menus | 84
Selection Options | 86
Custom URLs | 87

Labels Menu | 88

Layout | 91

Internet Map at Click | 92
Line Widths | 93
Background Image | 93
Country Maps | 94

Find | 95

Refresh | 95

Zoom | 95

Print | 96

Export | 96

The following menu options are general options available in the map’s right-click menu.

Map Views

For each offline network, you can save multiple map views, corresponding to different graphical
locations and groupings of network devices. Map settings such as zoom, color legend sliders, and applied
filters are also saved. For each map view that is saved, there is a subdirectory which contains map-
related files for that view, including graphcoord, group, and graphcoordaux files.

e Click Save Map and enter a Name and optional Description to save a new map view. Local is for
offline networks. Private and Shared are for Live networks.

e Local saves map settings to the network spec directory in subdirectory /userSettings



e Private saves map settings to your home directory in subdirectory /wandinetworks/
livenetwork_output_directory/userSettings/livenetwork/

e Shared saves map settings to the Live network directory /u/wandl/data/userSettings/

livenetwork/
e Select a map view and click Load Map to load a previously saved map view.

e To overwrite an existing map view, select an entry, click Save Map, and use the same Name.

Figure 44: Map Views
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For the Live Network (File > Open Live Network), you can specify a default private view. Administrators
can create shared views that will appear in everyone’s map view list. Administrators can also set one as
the default shared view. To set your personal default view, select the radio button under the Default

column.

NOTE: Administrators must set one default shared view by selecting the radio button under the
Shared Default column. The Shared Default is the view every user will see when opening the Live
Network and used by the Web for group reports and features. If you have selected a different




Default view, your view has higher priority than the Shared Default and it is loaded when
opening the Live Network.

Figure 45: Live Network Map Views
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Grouping Popup Menus

The Grouping menu contains functions for creating network elements groups in the topology map. In
this menu, you can find options for specifying groups within the topology. These functions are especially
helpful when the network is large and contain many devices and elements.

e Group Selected: The Group Selected Nodes button merges a set of nodes into a single group on the
topology map. This is useful if you want to partition the network into groups or hierarchies.

e Ungroup Selected: This function will ungroup any groups you have selected in the topology window.
This permanently removes the group from the system. A group must be collapsed and then selected
before this function can be accessed.

e Ungroup All: This function permanently ungroups all groups in the topology map.

e Collapse Containing Group: This function will collapse the group containing the selected node,
displaying it as a small group symbol with its contents hidden.



Collapse All: This function will collapse any groups, displaying them as small group symbols with their
contents hidden.

Expand All: This function will expand any collapsed group in the topology. The groups are displayed
as circular discs and the contents are visible.

Expand Selected: This function will expand selected groups.

Modify Parent Group of Selected: Moves the selected node from one group to another group of your
choice.

AutoGroup: This function will allow the program to use its node-grouping algorithm to auto-group
nodes. Nodes can be grouped by AS, area, lat/lon, access domain, tree, LAN, hardware type, regular
expression, and/or NPA/NXX, depending on what type of network it is. (Options may vary depending
upon the hardware type.) You can create more than one grouping levels. If selecting more than one
level, the first selection will create the top-most (parent) groups. The second level will subdivide the
nodes in a group further into sub-groups, and so forth. For more details, refer to the AutoGroup
section.

Sibling Mesh: When this option is selected, a fully-meshed set of lines is drawn among the members
of each expanded group. Different groups get different colors.

AutoGroup

Select the nodes that you want to autogroup. Next, right-click over the nodes and select Grouping >
AutoGroup for the following first level groups. Click AutoGroup only selected instead of all nodes. if you
wish to autogroup only the selected nodes.

To create flexible grouping, the “Regexp” button can be used to group according to a regular expression.

Look in the field: Indicates the field to use for the match criteria (for example, Node ID, Node Name,
IP Address)

Find the first match for: Indicates the regular expression that should match in order to form a group.

(Optional) Substitute it into: Specifies a name for the new group(s). To create different groups based
on the pattern being matched, you can save a part of the expression being matched for into a buffer
by surrounding it in parentheses in the “Find the first match for” textbox. Then in the “Substitute it
into” textbox, the buffer number can be accessed by preceding it with the ‘¢’ symbol. Note that you
can have more than one buffer. To create a buffer, surround the expression with a left and right
parenthesis. The first buffer in the expression is accessible using $1, the second is accessible using
$2, and so forth.

Case-sensitive: Specifies whether the string to match is case-sensitive

AutoGroup Examples



Suppose you have routers with the following IDs: P1_ATL, P2_ATL, P3_ATL, P1_NYC, P2_NYC, P3_NYC,
P1_CHI, P2_CHI, P3_CHI. Entering either of the criteria in the table below would create the following
groups: ATL, NYC, and CHI, each containing 3 routers.

Look in the field Find the first match for Substitute it into
ID F_([A-Z]%) $1
ID (i) $1

If you wish to group the devices only by the first two characters of the ID, the following criteria could be
used.

Look in the field Find the first match for Substitute it into

Note that local area networks (LANs) not matching the criteria is given a group of their own, such as
GROUPO. To move these LANs into the same group as their attached router, select Network Elements >
Nodes in the Standard map. Right-click the GROUPO containing the LANs, and select
Grouping>Ungroup this Group. Then right-click the map and select Grouping>Move LANSs to Siblings’
Groups.

Selection Options

o Select > All Points: This function will select all network elements on the topology map.
o Select > Neighbors: Highlights all neighbors of the node that was right-clicked over.
o Select > Nodes on Selected Links: Highlights the two endpoints of every selected link.

e Select > Single-End Neighbors: When you right click on a node, there is an option to select single-
end neighbors. Selecting this will highlight any peripheral nodes (single-ended nodes, attached to
only one link) that are connected to the selected node. The selected node will remain highlighted.
Typically, the selected node is a router, and the nodes that are subsequently highlighted are
loopbacks and single-ended LANSs.

o Select > Tree: Available when you right-click on a node, this option will find the largest tree in the
network that contains the selected node and highlight all nodes in that tree. A tree is defined as any



group of nodes that are connected to each other in such a way that there exists only one available
path between any two nodes in the group. (Note: in selecting the tree, this option will stop once it
hits a node that belongs to a cycle.)

e Cut Selection: This allows you to cut from the network all currently selected nodes and any links that
(both) originate and terminate at the selected nodes. This action is reflected in the topology map. The
cut elements are stored in the clipboard and can be pasted back into the network (multiple times if
desired) at a location specified by you.

e Copy Selection: Clicking this when one or more nodes are selected will copy to the clipboard the
selected nodes and any links that (both) originate and terminate at the selected nodes.

e Paste: This will paste the most recently cut or copied elements onto the topology map. Once pasted
onto the map, the elements can be dragged around with the mouse and positioned at an appropriate
location. Numerical characters are appended to the names of each pasted element in an ascending
order to maintain an unique identity for each element. Any XML router-config data associated with
the pasted nodes are carried over as well.

Custom URLs

Custom menu items can be added to the main map’s right-click menu that pop up a browser going to a
user-defined URL. The URL can be specified as a function of the node, group, or link that is right-clicked
over. To create custom menu items, create a server-side file /u/wandl/data/custom/menuitems.txt. This
file should be saved as Unicode UTF-16 format. Each line should have two comma-separated items:

menultem,URLtoView

where menultem is substituted with the text that you will see in the right-click popup menu and
URLtoView is the URL that the browser will request. A specific value can be inserted into the URL
depending upon the node, link, or group that is right-clicked over. To specify a node’s field, use the
syntax ${Node.key}, substituting key with the attribute of interest, which can be found through the
node’s Advanced Filter. For example, putting ${Node.ID} in a URLtoView will insert the ID field of the
node right-clicked over into the URL. Similarly, use the syntax ${Link.key} and ${Group.key} to indicate a
link or group attribute, where key is one of the available attributes available through Advanced Filter for
links or groups, respectively. The following is an example file:

Explain Node Type,http://en.wikipedia.com/wiki/${Node.Type}
Search Link Name,http://www.google.com/search?q=${Link.Name}
JUNIPER,https://www. juniper.net



Labels Menu

When selecting one of the menu options below, you are prompted to choose what to label and with

what text.

¢ Node Labels: Allows you to turn on or off labels for nodes displayed in the topology map.

e Group Labels: Allows you to turn on or off labels for groups displayed in the topology map.

e Link Labels: Allows you to turn on or off labels for links displayed in the topology map.

What to Label

Option

All

None

Only Current Selection

Add Current Selection

Remove Current
Selection

Label Text

Explanation

Displays the label for all elements in the given category

Removes the label for all elements in the given category

Displays the label only for selected elements in the given category, removes labels
for nonselected elements

Adds label(s) for selected elements in the given category, preserves pre-existing
labels of nonselected elements

Removes label(s) for selected elements in the given category, preserves pre-existing
labels of nonselected elements

A list of typical attributes that are used to label the item are given in the right-hand side of the table. For
the node and link labels, you also have the option to customize the label in such a way that it includes
other properties or more than one property. This option is available by selecting Customize... under the
What Text? section and results in Customizing Labels.

By selecting Bottom Bar, you can also customize the map window bottom bar display this is shown

when you hover the mouse over a map element such as a node or link.

Bottom Bar

Description



Nodes: Customize...

Nodes: Reset to Defaults

Links: Customize...

Links: Reset to Defaults

Customizing Labels

Allows you to customize the label shown in the bottom bar when the pointer is over a
node

Resets the node information given in the bottom bar to the default values.

Allows you to customize the label shown in the bottom bar when the pointer is over a
link

Resets the link information given in the bottom bar to the default values.

Figure 46: Set Labels... Window
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Options Description

Add/Remove = Add moves selected key from left hand side to the right hand side list

Up/Down Moves a selected field up and down to change the field order

arrows

Output In the list of Output Formats, the Key is taken from the titles listed in the top panel, and the
Format Value is the specific value for any particular Key.

e For example, if you select for link label text the following keys: Name, Used_BW_AZ, and
Used_BW_ZA and the following output format: Key=value; Key=value; ..., you could get the
following results:

e Name=Link2; Used_BW_AZ=84M; Used_BW_ZA=40M

e Note that for the link labels, you can select not only link properties to display but also
properties of the source and destination nodes by double-clicking on NodeA or NodeZ.

Show/Hide Message

Toggles on or off any messages or text that are displayed in the topology map. Messages that are
displayed in the map usually include total link cost.

International Map Labels

Each node, link, and group on the map can have one label in any language, defined in a single server-side
file /u/wandl/data/custom/intllabel.txt, which must be saved in Unicode UTF-16 format. Each line of the
file should have three items separated by commas:

LetterCode,ElementID,intllLabel

e LetterCode is either N (for node), G (for group), or L (for link)

e ElementlD is either the nodelD field from the muxloc file (first column), link name from the bblink file,
or group name from the group file.

e intlLabel is the foreign text in Unicode.

Once this file is created, and the network is reopened, this label can then be displayed on the map by
opening the Labels Menu, selecting Customize..., and then selecting the IntlLabel key. This label can also
be displayed in the Network window node and link view panes by right-clicking the table header,



selecting Table Options... and then adding the IntiLabel column. Finally, the IntlLabel attribute can also
be used for advanced filters for nodes and links.

Layout

This function allows you to lay out the display of network elements in the topology map.

¢ Circle Selected Nodes: When selected, the cursor becomes a cross hair. You should click once on the
map to pick the center of a circle, and click a second time to choose the radius of the circle. All the
points that are currently selected (highlighted) are moved onto the circumference of the circle at
equally spaced intervals.

o Distribute Selected Points: When selected, the cursor becomes a crosshair. You should click once on
the map to pick the center of a circle, and click a second time to choose the radius of the circle. All
the points that are currently selected (highlighted) are laid out on the map in a way that's easier to
see. They are fitted inside the circle that you chose. If any of the points are collapsed groups, the
groups are expanded, will have their contents distributed, and are collapsed again, and so on
recursively.

¢ Distribute Selected Points Within Groups: This option is available in the Layout menu only after
selecting collapsed groups. For each selected group, the points are distributed for that group, and if
multiple groups are selected, they are distributed in a way such that there is little overlap between
the groups when they are expanded.

o Straighten Selected Nodes: This feature is like Circle Nodes, but puts the selected points onto a
horizontal line, equally spaced. (Rotate it with the Drag/Rotate tool to align the selected points
vertically instead of horizontally.)

o Flip: This feature flips the entire layout vertically or horizontally depending on your selection.

o Stiffen: When there are multiple links between two nodes but some of the links are hidden from
view, the parallel links may be spread apart too wide or unevenly or all to one side. In this case,
selecting Stiffen Visible Curves will bring the parallel links closer together and center them. Select
Unstiffen All to undo this stiffening. Option is only relevant when Draw Multiple Links as Curves is
turned on in the Map Preferences.

o Reset by Lat/Lon: Selecting this option will reset the network topology to its original geographical
layout (provided that the LAT/LON coordinates are used in the network). This function is useful
when you want to view the network in its geographical layout according to previously specified
Lat/Lon values.



e Set Lat/Lon From Map: Selecting this option will assign Lat/Lon values to all selected nodes based on
their current location on the Map. This function is useful if you have manually moved nodes on the
map to desired locations and wishes to save these locations for future sessions.

¢ Quick Layout: Recomputes the X, Y coordinates of all the points using the program's algorithms to try
to lay them out clearly. This is the same algorithm used when a Topology View is opened and no
saved coordinates are available. If latitude/longitude coordinates are available, they are used to
position the nodes, and nodes with the same Lat/Lon are laid out at the city’s location in a small
radius around the city center. The full recalculation could take a long time for large networks.

¢ Detail Layout: This topology layout algorithm attempts to distribute the nodes and links as a planar
graph. Meaning the topology is drawn in such a way that links intersect only at nodes, or no links
cross each other. This layout is useful to create a topology to display a minimal amount of links
crossing over each other while keeping node groups together. Various parameters relating to the
geographical Lat/Lon position, distance proximity to other nodes, link length, and groups can have
their cost weights adjusted. Adjusting these weights will impact the algorithm’s topology display.

o Grid Layout: This topology layout algorithm lays out nodes on a grid. The “Intersect Weight” field can
be used to reduce line crossing-- the higher the value, the lower the number of line crossings. If you
would like to rerun the calculation from the previous iteration’s layout, select the Continue from
previous layout if possible checkbox. For Layout, Geographical Group places the groups at the mean
lat/long position of the nodes within the group and rearranges the nodes within in a radius
determined by the distance to the nearest neighbor. Abstract Group treats the network hierarchically
and lays the groups out in a grid as "nodes" - then lays the nodes within the groups out within a
radius determined by the distance to the nearest neighbor. "Abstract” will calculate the layout
ignoring any group information. “Geographic Group” and “Abstract Group” will consider group
information. Search Breadth: With a narrow search breadth, changes that make the solution worse
are more likely to be rejected. At the end of the iterations, only changes that make the answer better
are accepted. However, at the beginning, you can go backwards -- the probabilities of accepting an
answer change as the iteration progresses. For the Iterations, specify the number of iterations to run
for the optimization problem, for example, 500.

Internet Map at Click

When you right-click a point on the map and select this option, a third party Internet map opens,
displaying the particular latitude/longitude point that you right-clicked.



| Line Widths

o Auto-assign Widths: Assigns widths based on trunk type. For example, a T3 is wider than a T1 and an
ET1G is wider than an ET100M.

e Reset Widths to Default: Restores widths to the default where all link widths are the same.

Alternatively, to manually set the widths, right-click on the link and select Set Line Width... from the
Legends menu, Type submenu of the map window'’s left pane.

Background Image

This allows you to choose a background image from your local or server machine to display on the Map
window.

Figure 47: Selecting a Background Image
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You can:

e Select the folder where your images are stored (Look in:).

e Select the file type to list (.jpg, .png, and so on).

e Click an image to view a preview in the right pane.

Click Open to complete your selection. The image appears in your topology window.

Once you have a background image in place, right-click the image in the topology window and select
Background Image to access the following options:

Load a different image (Load an Image File from Client).
o Clear the background image so there isn't one displayed.

o Select Fixed, Fit Whole Window, Fit Horizontally, or Fit Vertically which specifies how the image is to
be displayed in the window.

e Resize Fixed Location, which allows you to resize the image by clicking and dragging the sizing
handles that appear.

Country Maps

Figure 48: The Country Maps Menu
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When you select this option, a dialog box appears. This option allows you to select the level of map
detail to display on the background of the topology window, where the settings are remembered from
session to session. For example, using this option, you can select a combination of Continents,
Countries, and U.S. states to be displayed.

Find

This function searches for any node, link, or group and highlights the element on the topology.

Figure 49: Find Box
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Refresh

When selected, this function removes certain temporary interface labels and addresses, clears all
highlighted network elements, and deselects all selected network elements.

Zoom

The Zoom menu contains functions for focusing in on a particular area of the topology map.

e Zoom In: This function allows you to zoom in on a particular area of the topology map. To zoom in on
the topology, click the Zoom In button and then click and drag a desired area in the topology map.
Another method to select the zoom in area is to <Shift>-drag the rectangle. It will always match the
aspect ratio of the map.

e Zoom Out: This function allows you to zoom out from a particular area of the topology map.

e Zoom To Fit: This function allows you to quickly fit the entire network topology in the topology
window. Items hidden by the Subview or Label/Show panes are not included.

e Zoom To Fit Selection: This makes the map zoom to fit the items that are selected.

e Zoom to Region: Allows you to zoom to a specific geographic region in the topology. The regions
which you can zoom to include the following: World, United States, Europe, Asia, and China.



Print

When this function is selected, the program will allow you to print the current on-screen topology. You
will first be asked which part to print (the entire topology window (Whole window) or just the topology
map (Map only)). Next, you are given printer options.

Export

This function allows you to save the topology window as a graphics file in several formats.

Figure 50: Export Map
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For non-Visio file types, selecting the Legends option will export the entire topology window and
deselecting it will export only the map.

For Visio file types (VDX, CSV), the customizable Title and Comment fields, as well as the Legends and

Date and Time can be included in the resulting Visio file.

Export Map to Visio




In the Export dialog, the last three options can be used to export to a file that can be imported into Visio
and then edited or printed from Visio.

e For Visio 2003, it is recommended that you export to a VDX file by selecting Visio 2003 and Later
(VDX).

e For Visio 2002 and earlier, it is recommended that you export to a .CSV file by selecting Visio 2002
and Earlier (CSV). After importing the .CSV file into Visio 2002, you can save the resulting Visio file as
a Visio drawing (VSD) file. Note that opening the .CSV format in Visio requires extra steps to put the
Paragon Planner stencils where Visio can find it.

e The “Block Diagram for Visio 2003 and later” option is designed to be run after running Layout >
Recalculate Grid Layout as described in the Layout section earlier in this topic.

Export Map to Mapinfo

Maplnfo requires two files, myMap.mif with the xy-coordinates, colors, and other graphical info, and
myMap.mid with data per node or link for display in mouse-overs, tables, and reports.

After selecting a filename and this export option, you are prompted with a chooser to select a
combination of node and link data to put into the mid file. After selecting the data to put into the mid
file, click OK to create the .mif and .mid files for import into Maplnfo.

Export Map to SVG

SVG can be exported from the map right-click menu item Export, or from File > Export to Web. Note
that the exported SVG file depends upon existing settings in the topology map. These settings include
whether the world map should be displayed, the boundaries of the world map, and whether node and
link labels should be displayed.

When exporting to SVG, the resulting file can be viewed from a web browser such as Mozilla FirefoxTM,
Microsoft Edge, or Google Chrome. We recommend that you use the latest version of the web browser
to view the SVG file.

Scheduling or Scripting an SVG Export

A CLI version of the SVG export, also used by the Web Report task in the Task Manager, can be found
in /u/wandl/util/svg.sh. Since this SVG map may be generated when the network is closed, a
configuration file is needed to specify SVG-related parameters. The syntax for calling this script is as
follows:

/u/wandl/util/svg.sh <spec_file> <output_svg_file>
To customize the settings of this SVG export, edit the /u/wandl/util/svg/svg.cfg file. Variables include:
o CANVASWIDTH, CANVASHEIGHT: Width and height of the map

e TITLE: The title of the map



e SHOWSPEC, SHOWDATE, SHOWLEGEND: Whether to show or hide the specification file path,
creation date/time, and node & link legend

¢ REMOVEASNODES,REMOVEETHERNETNODES,REMOVEISOLATEDNODES: Whether or not to
hide AS pseudonodes, Ethernet pseudonodes, and/or isolated nodes. This can be used to reduce
clutter on the map.

e CURVEDLINKS: Whether or not to show links as curved or overlapping on a straight line

o COLLAPSEGROUP: Whether or not to collapse groups into a single node

e NODELABEL: How to label the node (for example, by NAME and/or IP)

e LINKLABEL: How to label the link (for example, by NAME and/or TYPE).

e INTFLABEL: How to label the interface (for example, by NAME and/or by UTIL).

o UTILPERIOD: Which trafficload period to use to label the interface utilization

e TITLEFONTSIZE, LEGENDFONTSIZE, NODEFONTSIZE, LINKFONTSIZE, INTFFONTSIZE: Font sizes

e TITLEFONTCOLOR,LEGENDFONTCOLOR,NODEFONTCOLOR,LINKFONTCOLOR,IN
TFFONTCOLOR: Font colors

e COLORLINKBY: Links can be colored by type or utilization

e UTILCOLOR = <NUMBER> = <COLOR>: To model the map utilization legend, specify in ascending
order the utilization percentages and associated color between that number and the next number.

Upon scheduling the Web Report task, the resulting map(s) can then be viewed from http://
serverip:8091/ (substitute serverip with your application server’s IP address). Select Reports >Network
Reports. Then click on the link to the desired network, and click on “Standard Topology.” Icons are
available for zoom in, zoom out, and zoom to fit (reset). Once zooming in, the map can be panned by
clicking the map and dragging it in the desired direction. Additionally, link and node details can be seen
by hovering the mouse over the link or node.
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File Menu Functions

Table 18 on page 100 lists the file menu functions.

Table 18: File Menu Functions

Function

Create Network

Open Network
Browser

Open File
Manager

Import Network
Wizard

Load Network
Files

Close

Save

Description

o The submenu Create Network > From Collected Data allows you to create a new network
based on data such as router configuration and interface files. For more information, refer
to the Paragon Planner User Guide.

e The submenu Create Network > Paper Model allows you to create a new network model
and specify the Paragon Planner files that define the network, such as the muxloc (node),
bblink (backbone links), and demand files.

Opens the Network Browser window where you can load previously saved networks, and
organize networks by labels and comments. For more information, refer to "File > Open
Network Browser" on page 101.

Opens the File Manager where you can browse through directories and files to create and/or
load a network specification file, view files, or perform basic file operations such as cut, copy,
paste, and delete. For more information, see "The File Manager Window" on page 15.

Opens the Import Network Wizard, allowing you to import data files that are converted into
the Paragon Planner network model. Here, you can specify the import input and output
directories and select other options for parsing a set of data files. For more information, see
"Import Network Wizard" on page 112.

Opens the Load Network Files window from which you can read in, or load, various network
files into the network. See "File > Load Network Files" on page 104.

Closes the current network that is loaded. After closing the current session, you can open
another network model or exit the program.

Saves all files for the current network.



Table 18: File Menu Functions (Continued)

Function

Save As...

Save Network
File

Recent Specs
Shortcuts

Exit

Description

Saves all files for the current network into a different directory or as a different runcode. The
Save As option also allows you to add Comments or Labels to help describe and categorize
the network.

The Save Network option allows you to save the current network. The Save Network File
option allows you to save one network file without saving the entire network. See File > Save
Network Filein "Saving a File" on page 105.

The File menu provides shortcuts for the most recently opened specs. You may also use the
mnemonic keys (1-5) to access these specification files.

This option will close the current network and exit the program. Be sure to save the network
environment to avoid losing changes when exiting.

File > Open Network Browser

Each time a network project is saved, it is recorded in the Network Browser window. Each network
project is uniquely identified in the Network Browser by its Path and Runcode. The Network Browser also
provides additional details for each network project such as the user, the last modified date/time,
descriptive comments about the network, and user-defined labels.

Filter the projects by user-defined labels by selecting a label from the Labels list in the left hand pane, or
by typing a custom string in the Filter text box and pressing <Enter> or <Return>. A label is a user-
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created descriptive tag which can be applied to one or more networks. For example, the label OSPF was
created in the example below to tag all networks which have the OSPF protocol.

Figure 51: Network Browser
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12 of 12 displayed

Action Buttons

e Open: To open a network project from the list, double-click an entry from the table.

¢ Modify: To modify the labels of a network project, double-click an entry in the Labels column from
the table. Labels can be tagged to the network and comments can be added. Check off the labels you




would like to be associated with your network. If the label does not exist, click Create and enter a
new label. Then make sure to check off the new label and click Apply.

Figure 52: Add Comments and Labels
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o Delete: To delete a network project, right-click an entry from the table and select Delete. This will tag
the network with the “Recycle Bin” label.

e Restore: To restore a network project from the “Recycle Bin" before it is permanently deleted, click
the “Recycle Bin” label, right-click an entry from the table and select Restore.

¢ Permanent Delete: To delete a network project permanently, click the “Recycle Bin” label, right-click
an entry from the table and select Delete. This will delete the network project files from the hard
disk. A backup copy of the network is zipped and placed in the “trashbin” folder of the network

owner.



File > Load Network Files

The Load Network Files window allows you to read in, or load, individual files into the current network

project.

Figure 53: Loading Files Window
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The bhblink file contains backbone link information for the netwark, Each link entry is defined by a link
name [opkional], From_Locakion, To_Location, Yendor, number of trunks, and trunlk bype,

’ L ” é H Browse. .. ] Reset
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Locating a File Type

To locate the file type to load, either search by one of the categories above by clicking the Arrange by
Category button, or search by alphabetical order by clicking the Sort Alphabetically button. By default,
only the modifiable file types are displayed. To show all file types, select the Filter not modifiable button.

Loading a File

To read in a new file, type in the file location or click Browse to choose a file location from the File

Chooser window. Then click the Load button to load the file into the current network.
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Note that if a file type is not modifiable, the text “[Not Modifiable]” is displayed in red and you will not
be able to modify the file path. To edit these fields, close the current network, right click in the File
Manager, and select Spec File > Modify Spec or Edit.

Removing a File

To unload a file, select Remove.

Saving a File

The File > Save As option saves the network project and all associated reports and files with it. The files
include: spec, bblink, muxloc, and dparam files.

You can save a network model to the file system or to the Paragon Planner database. Files saved in the
archives are read-only. However, you can edit and reuse network models later if you save them in the
database. You can access the files thus saved in the database from the Networks in Database tab in the
Network Browser window.

This option opens the following dialog window:

Figure 54: Save Network Dialog
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To save the network, select the directory in which to save the network and type in the runcode (file
name extension) that will identify the network. Optionally add a descriptive comment and/or labels to



organize the networks, as described in "File > Open Network Browser" on page 101. Then click the OK
button. The network is saved to a set of files with this runcode, which are organized together by a
specification file of the same runcode.

Directory Selection

To select a directory, click Browse... Then type in the directory in the Look In field and press the <Enter>
or <Return> key. The contents of that directory will then be shown in list format. The up arrow can be
used to navigate to the parent directory and double-clicking a directory from the list will open a
directory. The following directory shortcuts are also available from the Look In drop-down list:

e Spec Dir: The directory containing the last opened specification file.

e Output Dir: The directory where output files (such as trace files or reports) are saved and stored. This
directory can only be changed before a network spec is launched. Once a network spec is opened,
the Output Path remains fixed for the remainder of the session. By default, the output directory/path
is set equivalent to the spec directory. Certain output files are generated and given the runcode
extension you have defined in the specification file.

e Home Dir: Your Unix administrative home directory

o Current Path: The current path in the File Manager

File > Save Network File

This option allows you to save only certain files separately without having to save all the network files.

These files can later be read into a network project through File > Load Network Files. Note that unlike
the Save option, saving a single file to a new location will not automatically update the specification file
to reflect the new location of the input file.

The available files that can be individually saved include the demand file, the bblink (links) file, the
graphcoord (topology coordinates) file, the graphcoordaux (topology window settings) file, and the group
(logical grouping for the topology map) file. If you have moved the network elements around on the map
and would like to save their new positions, be sure to save the graphcoord file.

Save Network Models to the Paragon Planner Database | 107



Save Network Models to the Paragon Planner
Database

IN THIS SECTION

Benefits of Saving Network Models to the Database | 107

Starting with Paragon Automation Release 21.2, you can securely store network models by saving them
in an access-controlled database. Storing network models in the database helps you secure them though
attribute-based access control, and retrieve them in case of an accidental data loss. You can access the
saved network models from the Networks in Database tab in the Network Browser window.

Access to the network models stored in the database is controlled through attribute-based access
control. The ability to edit or save network models from the Networks in Database tab depends on the
permissions assigned to you. After you save a network, you can assign edit or view-only permissions to
users. From the Archives tab, you can access networks that are saved in the database by the network
archive tasks, however, you cannot edit network models. That is, the networks listed in the Archives tab
are read-only. From the Networks in Database tab, you can save network models, including those saved
in the file system, to the database.

Benefits of Saving Network Models to the Database

e You can retrieve and reuse the stored network models from the database later.

e The database constitutes an additional repository for saving network models. You can retrieve
network models from the database in case of data loss on the hard drive where the archive files are
stored.

e Unlike files saved in the file system, which are available to all users, files saved in the database are
secured through access control.

Saving a File | 105



Manage Network Models Stored in the Database

IN THIS SECTION

Save a Network Model to the Database | 108
Open a Network Model from the Database | 109
Delete a Network Model from the Database | 109

Share a Network Model with Users | 109

Starting with Paragon Automation release 21.2, you can store network models in the database, in
addition to saving them in the file system. While the network models saved in the file system are
accessible to all users, the files saved in the database are access-controlled and more secure. You can
access the network models you saved in the database, modify them, or share with other users and
assign permissions to the users.

To access network models saved in the database, click File > Open Network Browser and select the
Networks in Database tab.

Save a Network Model to the Database

To save a network model to database:

1. Click File > Save As, when you are ready to save the network model.

The Save Network window appears.
2. Select the Save to Database check box and enter the required information.
3. Click OK.

You receive a confirmation message stating that the file has been saved to the file system.
4, Click OK.

You receive a confirmation message stating that the file has been saved to the database.
5. Click OK to finish.

The network model is now saved to the database.



Open a Network Model from the Database

To open a network model from database:

1. Click File > Open Network Browser.
2. From the Network Browser window, select the Networks in Database tab.
Network Browser displays the networks available in the database.

3. Right-click the network you want to open, and select Open. Alternatively, you can double-click the
network.

The network model opens in the Map (Standard) window.

Delete a Network Model from the Database

Deleting a network model from the database does not remove the file system. To delete a network
model from the database:

1. Click File > Open Network Browser.

2. From the Network Browser window, select the Networks in Database tab.
Network Browser displays the networks available in the database.

3. Right-click the network you want to delete, and select Delete.

The network is deleted from the database.

NOTE: A network model thus deleted is removed only from the database. The file will still be
available in the file system.

Share a Network Model with Users

You can share the network models with users by applying attribute-based access control. You can
specify which type of users can access the network model files. You can assign the following attributes
to the files:

1. Rich-click the network model file and select Share.
The Share Network window appears.

2. Specify the type of access you want to provide to the users to access the files.



o View Users: Can open the network but cannot overwrite the original database entry. However,
View Users can edit a network model and save it as a new file in the database. Specify the users
that you want to provide view-only access.

e Edit Users: Can open the network models and overwrite the original database entry.

o All Other Users: Assign this attribute to users who cannot be explicitly assigned view or edit
permissions. You can choose not to share the files with any other users.

The permissions you assign here apply only to the files that you store in the database.
3. Click OK.

SEE ALSO

Save Network Models to the Paragon Planner Database | 107
Saving a File | 105
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Import Network Wizard
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The Network Data Import Wizard is accessed from the main menu File > Import Network Wizard. This
feature allows you to import different types of network configuration data into the software. In the
process, a corresponding network project specification file is created, saved into the user-specified
output directory and automatically loaded into the program.
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I Introduction

"Import Network Wizard" on page 112 shows the initial Import Network Wizard window.

Figure 55: Import Network Wizard
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The following buttons apply to most pages of the import wizard.

Table 19: Import Network Wizard Functions

Function Description

< Back Goes back to the previous page of the wizard.

Next > Goes to the next page of the wizard.



114

Table 19: Import Network Wizard Functions (Continued))

Function Description
Cancel Cancels the import action and closes the wizard without saving.
Help Accesses the reference page of this window in the help document.

Select the type of the data you want to import and the directory where the data files are stored.

Figure 56: Import Network Wizard Specifying Import Directory and Type
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Table 20: Import Network Wizard Import Types and Directories

Function Description

Import Type Click to see the drop-down selection box to select the appropriate data type for import
and conversion.

Use Saved Settings This allows user to load an import template to automatically map fields and settings
based on previous import runs.

Default Input The directory shown here displays the current import directory source. This field should
Directory specify the directory in which data files are stored. For certain import types, this field is
used to indicate an import file instead of a directory.

Output Directory Select where the Paragon Planner specification file are created

Runcode Specify a file name extension for the specification file and related project files

Depending on which data type is being imported, the next pages of the wizard will guide you through a
different set of tabs and required parameters to be entered.

The Data Import feature supports the data file types described in the sections that follow.

Routers and Switches (IP/MPLS only)

This section only provides a high-level summary of the router config import. See the Paragon Planner
User Guide for details on importing router configuration files.

Default Tab This tab provides additional import options to the standard Configuration files. You
can import Interface, VLAN Discovery, Switch CLI, Tunnel Path, Transit Tunnel,
Equipment CLI, and Equipment SNMP files.

Bandwidth This tab provides options for deriving the interface bandwidth. You can specify

Options supplementary sources such as the MPLS Topology file or rules to use to derive the
bandwidth.

Network This tab allows you to specify an already-defined network file that should be

Options

preserved during the import. Additionally, you can specify VPN and BGP options.



Misc Options Miscellaneous options are provided here, such as ignoring the private IP address.

Paragon Planner Config File

You may create and import your own user-defined configuration file using Paragon Planner Config file
format. Using any text editor, save your file extension as .cfg and follow the syntax example below:

## WANDL CONFIG

HOSTNAME=ROUTER®1

HWTYPE=JUNIPER

IP=1.2.3.4

INTERFACE=ge-1/0/0.1 IP=1.2.3.4/30 BW=1G

The keyword ## WANDL CONFIG must be in the file to identify it as a Paragon Planner configuration file.
Select Import Type>Routers and Switches to import these configuration files.

OSPF Database

The OSPF Database import supports Cisco, Juniper Networks, and Alcatel-Lucent and accepts a file with
output from the following commands. In case more than one commands are mandatory, combine the
outputs in the same file.

Cisco 10S

e show ip ospf database router (mandatory)

e show ip ospf database network (mandatory)

e show ip ospf database opaque-area (optional for RSVP TE information)

e show ip ospf database summary (optional to create virtual link between ABR and node in another area --
Only available in text mode using -igpsummary)

Cisco I0S-XR
e show ospf database router (mandatory)
e show ospf database network (mandatory)

e show ospf database opaque-area (optional for RSVP TE information)



e show ospf database summary (optional to create virtual link between ABR and node in another area --
Only available in text mode using -igpsummary)

Juniper Networks Junos OS

e show ospf database extensive (includes both ospf and TE)

Alcatel-Lucent

e show router ospf database detail (mandatory)

e show router ospf opaque-database detail (optional for RSVP TE information)
Options

o DNS Lookup or /etc/hosts Lookup: Use the text mode -igpdns flag

e Import Multiple Files: Use the text mode -ospfdir flag instead of -ospf

e Only Import Links of Specified Area: -igparea <a.b.c.d> : If specified, only bblink with the specified
area are reported, and the igpsummary are disabled.</a.b.c.d>

ISIS Database

ISIS Database import supports Cisco and Juniper Networks and accepts files with output from the
following commands:

Cisco 10S and IOS-XR

e show isis database verbose

Juniper Networks Junos OS

e show isis database extensive

Options

o DNS Lookup or /etc/hosts Lookup: Use the text mode -igpdns flag

e Import Multiple Files: Use the text mode -isisdir flag instead of -isis

Marconi CLI

The Default Tab provides the following:



o Select Output Directory: Select where the Paragon Planner specification file is created
¢ Specify Runcode: Specify a file name extension for the specification file and related project files
¢ Specify Old Runcode: Specify the runcode of the original specification file, if any

The Advanced Tab provides the following:

Table 21: Marconi CLI Advanced Tab

Option Description

Select External Link This option allows you to select a link file to include in the import to complete the
File topology. These links are typically WAN links connecting through an external carrier's
ATM backbone.

Generate psuedo If selected, the import will generate pseudo nodes for all unknown link destination
nodes addresses.
Match paths The import program will attempt an ad-hoc virtual path matching algorithm to generate

link and demand connectivity. This should only be used in cases where either PNNI info is
missing, signaling has been turned off on the ports, or encryptors exist between links.

Suppress logical This is another option that should only be used when there are encryptors between links
links that short-circuit the topology.
Nortel PND

The Default Tab provides the following:

e Select Output Directory: Select where the Paragon Planner specification file is created

¢ Specify Runcode: Specify a file name extension for the specification file and related project files
¢ Specify Old Runcode: Specify the runcode of the original specification file, if any

The Advanced Tab provides the following:

o Select EPIC SPVC Data File: The PND extracted data does not include SPVC info. This info, along
with UNI addresses should be queried and logged via EPIC. This options allows you to specify the file
that contains the additional EPIC data.



Nortel Virtual Router

The Nortel Virtual Router import type has the same option tabs as Router Configuration, but it is
tailored for importing Nortel passport configuration files to extract virtual router information. As with
Router Configuration import, the Nortel VR import uses getipconf on the backend, so it can accept
multi-vendor router configs. Refer to the Paragon Planner User Guide for more details.

Tunnel Path Extraction

The tunnel path extraction feature shows the exact network view of tunnel paths. It helps to simulate
the impact of tunnel set up on IGP routing by taking into account Explicit Tunnel Routing, Affinity and
Trunk attributes. This is useful if the LSPs can be dynamic (as opposed to explicit). Paragon Planner
displays the current status and routing of the LSP tunnels within the defined network.

The MPLS Tunnel Extraction feature retrieves the actual placement of the tunnel and the status (up or
down) of the LSP paths by parsing the output of the following Juniper Networks Junos OS command:

show mpls 1lsp statistics extensive

The same is true for the following Cisco I0S command:

show mpls traffic-eng tunnels

To use this feature, you must have a network open and then specify a directory that contains the output
of these commands. There should be one file per router. On the second page of the Import Wizard,
select Tunnel Path in the Import Type selection box. Then click on the Browse button above to open the
Import Directory Chooser window.

Navigate to the directory that contains the files and press Select. Click.Next > to continue.

This should generate an Paragon Planner format file of the tunnel paths and status called
tunnelpath.runcode, where runcode is the file extension used for your network model. This will
automatically be loaded into the network model.
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Network Menu Overview

The Network menu from the main menu bar provides access to network information for all types of

network elements. The most basic of these are nodes, links, and demands. Other types of network

information are available depending on the hardware type of your network.

You can also access network information by right-clicking the mouse over a network object in the Map

window. For example, to view node information, right-click the mouse over a node and select View >

Node in the pop-up menu to display the properties for that node.

Table 22 on page 121 shows the network menu options that are available.

Table 22: Network Menu Options

Feature

Summary

Maps

Nodes

Links

Interfaces

Reference

Provides general information about the network under review. The Network Summary
window displays statistics about the various network elements in the network,
including nodes, links, and demands.

The demand statistics indicate the average and maximum hops of demands and the
number of placed, unplaced, and deactivated demands. Placed demands are demands
that were routed over the network. Unplaced demands were demands that failed to
route over the network. Deactivated demands are demands that are not routed over
the network, for example, demands from a node to itself.

Select Network > Maps to display additional maps such as the BGP, Events, and IP VPN
maps if available.

Select Network > Maps > Copy Map Layout to take the layout of one of the maps and
copy it onto another open map. When the network is saved, the layout of the main map
is also saved, but not that of other maps.

See "Network Menu: Nodes" on page 130

Displays link information. The number of tabs and type of information displayed in the
Link window depend on the hardware type of the network model.

See "Network Menu: Interfaces" on page 146



Table 22: Network Menu Options (Continued)

Feature

Demands

Tunnels

Sites

SRLGs

Owners

Element Templates

User Parameters

VPN

VLAN

Access Domains

BGP

Multicast

OSPF Areas

OSPF/ISIS Routing
Instance

Static Route Table

Reference

See "Network Menu: Demands" on page 150

See Tunnels

See "Network Menu: Sites" on page 179

See "Network Menu: SRLG" on page 181

See "Network Menu: Owners" on page 182

See "Network Menu: Templates" on page 182

See "Network Menu: Demands" on page 150.

See Virtual Private Networks in the Paragon Planner User Guide.

See Virtual Local Area Networks in the Paragon Planner User Guide.

See Virtual Local Area Networks chapter in the Paragon Planner User Guide.

See Border Gateway Protocolin the Paragon Planner User Guide.

See Multicastin the Paragon Planner User Guide.

See "Network Menu: OSPF Areas/Domains" on page 185.

See Routing Instances in the Paragon Planner User Guide.

See Static Routesin the Paragon Planner User Guide.



Table 22: Network Menu Options (Continued)

Feature Reference

QoS Manager See "Network Menu: QoS Manager" on page 186
Admin Weight See "Network Menu: Admin Weight" on page 188
Service Type See "Network Menu: Service Type" on page 187

Path & Capacity See "Network Menu: Path and Capacity" on page 189

Network Menu: Summary

IN THIS SECTION

Filter | 125

Search by Property | 125
Advanced Search | 126
Navigation Page Setup | 128
Table Options | 128

To obtain general information about the network under review, select Summary from the Network
menu. The Network Summary window will appear displaying statistics about the various network
elements in the network, including nodes, links, and demands. The demand statistics indicate the
average and maximum hops of demands and the number of placed, unplaced, and deactivated demands.
Placed demands are demands that were routed over the network. Unplaced demands were demands



that failed to route over the network. Deactivated demands are demands that are not routed over the
network, for example, demands from a node to itself.

Figure 57: Network Summary Window (Options May Vary)
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In some windows such as the Nodes window, you can find a text field labeled Filter and icons labeled
Search by Property, Advanced Search, and Filter from Map. These allow you to search for and display a
subset of the network elements that match your filter or search criteria. This section uses the Nodes
window as an example.

NOTE: The search functionality for the Filter and Advanced Search is not case-sensitive. For
example, ID = abc also matches ABC. The filter searches all entries within the current table.

The following sections provide more information on the options available.



I Filter

In the Nodes window, type the text you wish to perform a search on in the Filter box. To reset the list of

elements, clear the text field.

Figure 58: Filter Text Box
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I Search by Property

In the Nodes window, type the text you wish to perform a search on in the Filter box. To reset the list of

elements, clear the text field.

Figure 59: Filter Text Box
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Advanced Search

The Advanced Search offers more filtering options. In the Advanced Filter window, a basic query
statement consists of a keyword, followed by a relation, and then a value (for example,
“Hardware=ETHERNET"). More complicated queries can be formed by joining statements using the and,
or, and not conjunctions. Left and right parentheses can be used to override the order of precedence
(the “and” operator takes precedence over the “or” operator).

Figure 60: Advanced Filters for Nodes
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You can type your query directly in the Enter a query text box. Or use the lists for Keys, Relations,
Current Values, and And/Or. To insert text into the query text box from one of the lists, select the
desired item from the list, and then click Insert. The Current Values list will automatically populate with
valid values for the selected Key. You can choose a value from the Current Values list, or simply type in
your own. Once you have specified your query in the Enter a query text box, click OK to apply the

search filter.

Table 23: Advanced Search Preference Options

Option Description

Exact Match The query matches a value if the two strings match exactly




Table 23: Advanced Search Preference Options (Continued))

Option Description

Match Substring (Default) The query matches if it is a substring of the value. For instance, "id = S" matches
BOSTON as well as SEATTLE.

Wildcards * and ? When the "*" character is used in the query, it matches any text. The "?" character matches
any one character.

Regular Expressions | Allows regular expressions in the query. This is like regular expressions in Unix.

Here is an advanced filter node example. To find all devices that have an ID beginning with N1 but not N11,
together with Ethernet and token ring, all east of the Mississippi River in the U.S., select Wildcards *
and ? for the search preference and type:

(ID = N1* and not ID = N11* or type=ethernet or type=tokenring) and lon > -90 and lon < -60 and
Country = US

Here is an advanced filter link example. To find all OC3 links that either belong to area AREAO or have
an endpoint whose IP address begins with 10.0. but not 10.0.113.1, select Wildcards * and ? for the
search preference and type:

Trunk = OC3 and ( Area = AREAO or IP_A = 10.0* or IP_Z = 10.0* and not (IP_A = 10.0.113.1 or IP_Z =
10.0.113.1))

To save a query as favorite, select Favorites > Add to Favorite and enter in a name for the query. The
Favorites menu displays the favorite queries by name, followed by a list of most recent queries. Select
Favorites > Organize to reorder, rename, or delete queries. Note that the favorites settings are saved on
the client machine.

Figure 61: Search Favorites
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I Navigation Page Setup

For the Interfaces, Demands, and Tunnel tables, the default display is 1000 entries per page and the
Filter text box is disabled to enhance performance. Click the Navigation Page Setup icon to change
these settings.

Figure 62: Navigation Page Setup
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I Table Options

Many tables can be customize by right-clicking on a column header in the table. The following options
may be available:

o Sort Ascending/Descending: Sorts the column entries in ascending or descending order. You can also
sort a column directly by left-clicking the respective column header.

¢ Alignment Left/Right/Center: Positions the text within a column on the left side, right side, or center
of the cell.

e Best Fit: Sizes each column to fit the longest text in each column.
e Best Fit (all columns): Sizes all columns to fit the longest text for each column.

¢ Filter Checkbox: Filters the table based on the entry selections of the column. Select All checks all
entries and Clear All de-selects all entries
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¢ Table Options: Opens a window that allows you to select which columns should be displayed. These
settings are saved on the client.

Figure 63: Right-Click Table Columns
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e Use image icons or a checkbox if applicable: Some fields can be displayed with an image icon or text
(for example, certain hardware types). For these fields, if this checkbox is checked, the image icon is
displayed. Otherwise, the corresponding text is displayed.

e AutoFit to Window: Adjusts the columns to fit inside the width of the table. Columns are given equal
width. This option is useful if there are not too many columns.

e Selected Item(s): You can select the desired columns to display in the table by moving them from the
Available Item(s) list to the Selected Item(s) list. To do so, select the item in the Available Item(s) list
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and click Add. Select one or more items in the Selected Item(s) list and use the Up / Down Arrows to
rearrange the column order. For multiple selection, use <Ctrl >-click or <Shift>-click.</Shift></Ctrl>

Figure 64: Table Options
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Network Menu: Nodes

Select Network > Elements > Nodes from the main menu bar to view node information. You can add,
modify, or delete nodes in the Nodes window. You can also view and modify node information
interactively by:

e Double-clicking on a particular node in the Map window.
e Right-clicking on a specific node in the Map window and selecting View or Modify options.

You can filter the nodes that are displayed using the Filter window at the bottom of the Summary
section of the display. Enter the search criteria into the Filter field and either press Enter or click the
magnifying glass icon. To reset the list of elements, clear the text field.
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The number of tabs and type of information displayed in the Node window depend on the hardware
type of the network model. Click on the up and down arrow to view the additional tabs.

Figure 65: Nodes Window General Tab
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Table 24: Nodes Window General Tab Fields

Field Description

ID The user-assigned identifier for a node.

Name The user-assigned name associated with a node.

IP Address* The IP address of the node (if applicable). Specified in the nodeparam file:

IPADDR=ip_address

Mgmt IP Address = The management IP address is the IP address that was used from the router profile to collect
information for this router.

Hardware Defines the switch hardware being used.



Table 24: Nodes Window General Tab Fields (Continued)

Field

Country

NPA

NXX

LATA

Latitude

Longitude

Vand H
Coordinates

Description

This field specifies the country location of the switch. Country designations are in the form
of two letter abbreviations (i.e. UK = United Kingdom)

The number planning area (NPA) code for the node. This field is required for locations in the
United States and Canada. Latitude and longitude coordinates are determined from NPA
information and are used in graphical display and pricing. For locations elsewhere, the set the
NPA field to 999.

The NXX code for the node. In the North American direct, distance-dialing numbering plan,
the NXX code represents either the central office code or a given 10,000-line unit of
subscriber lines. This field is required for locations in the United States and Canada. Latitude
and longitude coordinates are determined from NXX information and used in graphical
display and pricing. For locations elsewhere, set the NXX field to 999.

The local access transport area (LATA) for the node. This only applies to locations inside the
United States.

This field specifies the latitude coordinates for a switch location. The latitude can be
described using either a floating point number between -90 and 90, or a string in the format
ddmmssN or ddmmssS where dd stands for degree, mm stands for minute, and ss stands for
seconds. N means North, and S means South. It is required for locations outside of the U.S.
and Canada.

This field specifies the longitude coordinates for a switch location. The longitude can be
described using a floating point number between -180 and 180, a string in the format
dddmmssE or dddmmssW. In that latter form, ddd stands for degree, mm stands for minute,
ss stands for seconds, E means East, and W means West. It is required for locations outside
of the U.S. and Canada.

Vertical and Horizontal projection system used by Telcos and is mapped to LATA and NPA
NXX. If NPA NXX is given, V and H coordinates can be calculated.



Table 24: Nodes Window General Tab Fields (Continued)

Field

Eand N
Coordinates

Comment

Description

The UK easting and northing fields only apply when the country is set to “UK”. These fields
correspond to the UK Ordnance Survey grid and uses a point of origin near Scilly Isles. The
field should be specified with 3 digits for each field. Note: For these fields to be saved, the
country code should be the UK and the “saveUKENcoord” variable should be set to 1 inside
the network model’s dparam file.

The comment field can be used to add miscellaneous notes and messages about a node. You
should note that comments are not used in any part of the modification, design, or simulation
of the program and are merely provided as a convenience.

Table 25: Nodes Window General Advanced Tab Fields

Field

Delay

Site ID

Colocation

Hierarchy Level

Misc

CanFail

Description

The delay (in ms) associated with this node.

The site with which a particular node is associated. Sites are used to represent node elements
that reside in the same room, building, or general area.

Allows you to specify whether a particular node is collocated at an IXC POP. The reason for
doing this is to save on the local loop (LL) charges, however a collocation rental fee may be
charged for the equipment. Note that collocation applies only to U.S. locations.

You may specify whether a node is a core, regular, single-ended, or feeder node in this field.
Core nodes are nodes residing in the center of the backbone and that receive the heaviest
traffic. Regular nodes are non-core nodes. Single-End nodes only connect to one other node (it
is a node with a single neighbor). Feeder nodes only connect to one other node, and only
through one link (no parallel links to its single neighbor).

Miscellaneous fields. For example, Shortcut specifies whether the node is enabled for
forwarding equivalence class.

Indicates if the element can fail during exhaustive failure simulation.



Table 26: Nodes Window General Design Tab Fields

Field

Max. Trunk BW

Max. Transit
Demand Count

Node Weight

Block from adding
new trunks

Max. Transit
Demand BW

Gateway*

Area/Domain*

Accessible Area
List*

Description

During a design, a link will not be added to the node if adding the link will exceed the
node’s capacity for links specified here. The default value is infinity. This value can also be
specified from the nodeweight file.

Allows you to specify the number of demands that pass through this node, which does not
include any demands originating or terminating at this node.

During a design, the node weight acts as a penalty for purchasing links at a node if the
value is <100000. This parameter can also be used to disallow pass-through traffic. If set to
PASSTHRU, it is not allowed in the design mode. If set to BLOCK, it is not allowed in the
design and simulation modes. The default value is zero.

During a design, this setting will prevent the program from adding new links from or to this
node.

Allows you to specify the maximum total bandwidth of demands that pass through this
node, which does not include any demands originating or terminating at this node.

This field allows you to specify whether a node is a gateway. Gateway nodes are used as
entry/exit points when using multiple domains. Selecting this will activate the Accessible
Area List parameter.

This field allows you to specify the area/domain association for the node. Areas/domains
allow you to effectively partition the backbone topology into smaller networks for purposes
such as facilitating network administration as well as overcoming physical hardware
limitations.

Specifies the constraint of areas that this node can become a gateway to. This parameter is
used for design purposes. The areas should be separated by commas. The gateway
checkbox must be selected in order for this field to be editable.

Fields identified with an * are for device-specific models.



Table 27: Nodes Window General Protocol Tab Fields

Field

Description

OSPF Reference BW OSPF reference bandwidth value if the default value or metric is not used

OSPF Overload Bit

ISIS Reference BW

ISIS Overload Bit

ISIS Area

AS

Confederation ID

BGP Speaker

Route Reflector

Multicast

SPT Threshold

RP

RP Address

Identifies if the node has OSPF overload bit set

IS-IS reference bandwidth value if the default value or metric is not used

Identifies if the node is using the overload bit in IS-IS

The IS-IS area

Autonomous system (AS) number of the node

BGP Confederation ID of the node

Identifies if the node is a BGP speaker

Identifies if the node is a route reflector

Identifies if the node is configured with multicast

The shortest path tree switch-over threshold value

Identifies if the node is a rendezvous point

The rendezvous point address

Table 28: Nodes Window General BGP Tab Fields

Field

AS

Description

Displays the AS number that this node belongs to.



Table 28: Nodes Window General BGP Tab Fields (Continued))

Field Description

BGP Speaker Marks whether this node is a BGP speaker. A BGP speaker is a router configured to support
BGP.

Router Refl. Marks whether this node is a route reflector in this AS.

Confederation ID | Displays the confederation ID for this node.

To add a new node, press the Add button in the Nodes window. The Add Node window will appear.
Specify the properties for the new node and click Add. Note that the Add Node window remains open

to allow you to continue adding nodes if desired.

NOTE: If you plan to add many nodes with similar properties to your network, the use of
templates can speed up the process. Node templates can be defined by selecting Network >
Elements > Templates > Node. Once defined, templates can be specified via the Apply Template
drop-down box in the Add Node window. This will automatically populate many of the fields in
the window. For example, the node template also supports autonumbering of the Node ID and
Node Name fields.

Specifying Node Location

Based on the location selection method chosen by you, certain parameters in the location tab are

activated.

The Add Node window contains the following options for selecting the node location.

Mouse: This method allows the mouse to be used for the specification of the location for a new
node. You should first check the box marked Mouse in the Location tab and then move the cursor to
the map window. When the cursor is in an area of the map window where a location can be selected,
it will change to a white crosshair pointer. Move this pointer to the desired location for the new node
and left click. The corresponding latitude and longitude coordinates will automatically appear in the
Location tab.

City, Country: This method allows you to specify a node location by country and city. For remote
locations not in the database, you may need to either specify a larger city within close proximity to
the desired location or use the Mouse method.

When the City, Country option is selected, the country and city text fields become active. You must
first select a valid country from the drop-down combo box labeled 'Country'. A corresponding city



name should then be entered in the city text field. City names may also be searched by entering a
partial name and clicking on the Search button. Names of cities in the specified country that contain
the search string is displayed in the drop-down combo box labeled 'City".

o NPANXX: This method is used to specify a node location using the number planning area or area
code (NPA) and the local exchange (NXX). Note that this method can only be used for defining
locations in the United States and Canada. When the NPANXX option is selected, the NPANXX field
in the Location tab becomes active. You should enter the desired location's NPANXX code and click
Add. Information in the city, latitude, longitude, vertical, and horizontal text fields will then be
updated.

e Lat/Lon: This method is used to specify a node location using latitude and longitude coordinates.
When this option is selected, the corresponding latitude and longitude fields in the Location tab
become active.

Latitude can be described using either a floating point number between -90 and 90 or a string in the
format ddmmssN or ddmmssS where dd, mm, ss, N, and S respectively stand for degree, minute,
seconds, North, and South.

Longitude can be described using a floating point number between -180 and 180 or a string in the
format dddmmssE or dddmmssW. In this format, ddd, mm, ss, E, and W stand for degree, minute,
seconds, East, and West respectively.

Moadify Nodes

To modify one or more nodes, first select or highlight these nodes in the Nodes window. Then, click the
Modify button. In the Modify Nodes window, current values can be modified by changing the
corresponding text field.

When more than one node is selected for modification, certain fields such as ID and Name are disabled
and cannot be modified. If no change is made to a particular field (i.e. the field is left blank), then that
property will not be touched or modified for any of the selected nodes.

Network Menu: Links

IN THIS SECTION

Links: General Tab | 139
Links: Location Tab | 141

Links: Capacity Tab | 142



Links: MPLS/TE Tab | 142
Links: Protocols Tab | 143
Links: Attributes Tab | 144
Links: CoS Policy Tab | 144
Adding Links | 144
Modifying Links | 145

Right-Click Menu Options | 145

Link information can be displayed from the main menu by selecting Network > Elements > Link. Or
select the link(s) from the map and right-click select View> Selected Links from the popup menu to open
the Links window.

The number of tabs and type of information displayed in the Link window depend on the hardware type
of the network model. Click on the up and down arrow to view the additional tabs

Figure 66: Links Window General Tab
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The following sections provide additional information about the options available.
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Links: General Tab

Field

Name

Trunk

Vendor

Cost

Fixed

CanFail

BW

Ovhd

Delay

Description

The user-assigned name for a link. If a name is not assigned, references to that link are made
using the node pair representing its origination and termination ends.

This field specifies the type of trunk being used. The trunk type is subsequently used in
determining link pricing and bandwidth availability.

The vendor field allows you to specify the vendor to be associated with the particular link.
Possible values for vendors include those that are specific to a certain country or region, and are
listed in the tariff database. If a vendor is not specified, the vendor is set to the default DEF. To
represent in-house fiber links with zero cost, the vendor should be set to NET.

This field allows you to specify the cost for a particular link. If this field is specified, the link price
is based on this value, rather than one from the tariff database.

This field allows you to specify whether a link is to be considered permanent in the backbone
topology. If this field is checked, the particular link will not be considered for removal during the
optimization phases of design and/or diversity design.

Indicates if the element can fail during exhaustive failure simulation.

Defines the bandwidth in each direction if it is different from the default bandwidth.

Defines the bandwidth reserved for signaling. The default value is used if not specified.

This field is used only if the routing method is set to Delay Metric. When the program performs
path placement and is trying to find the best route for a call, delay metrics are examined to
determine the desirability/undesirability of a link. Two delay metrics are supported, one for each
direction of the trunk. If asymmetric delay metrics are not supported by the hardware, the
second delay is marked as -’ If a delay metric is not defined for a trunk, a default delay is
calculated based on propagation delay and serialization delay. Units are in milliseconds.



(Continued)

Field Description

Metric When the program performs path placement, link metrics are examined to determine the least
cost path. Two metrics are supported, one for each direction of the trunk. If asymmetric metrics
are not supported by the hardware, the second metric is marked as '-. For the metric to be used,

an appropriate routing method should be set in the Tools > Options > Design, Path Placement

options pane.
DIST= number
DISTA2Z= number

DISTZ2A= number

Tunnel Metric = (IP/MPLS only) Link metric as seen by tunnels. Defaults to IGP metric if not specified.
TDIST= number
TDISTA2Z= number

TDISTZ2A= number

Op Status Indicates the operating status of the link. This field reflects the current status of the link. Valid
status include: Unknown, Install, Live, Active, Order, Planned.

Admin Status | This parameter reflects the current status of the link. Valid states include: Unknown, Install,
Active, Live, Order, and Planned.

Service This field specifies the service type of the trunk. Current service types include ATM and Frame.
This field specifies the type of traffic switches support, either frame or cell. If a service type is
not explicitly set by you, a default value will automatically be set based on the hardware switch
being used.

Media The media field allows you to assign attributes to a link. Valid media attributes include: TERRES
(terrestrial), SAT (satellite), MCWAVE (microwave), FIBER, and ENCRYPT (encrypted). These
media descriptors are used in route biasing of calls using criteria such as preferred, preferred not,
and required.



(Continued)
Field Description

Misc This field is used to display special characteristics of a link.

The miscellaneous field contains media and link overhead, distance, cost, delay specifications for
links. If more than one specification qualifier is needed for a link in the media type field, these
specifications should be separated by commas (,) without any spaces.

Comments Comments attached to the trunk definition. You should note that comments are not used in any
part of the modification, design, or simulation of the program and are merely provided as a

convenience.

Links: Location Tab

Field Description

Area/Domain The “Area” field will appear only when the OSPF protocol is used. The “Domain”
field will appear only for networks with multiple domains.

Node A, Node Z Displays the source and destination of the link. It is important that you be able to
clearly distinguish between Node A and Node Z, especially in defining one-way
demands.

Card A, Port A, Shelf A, These indicate the card, port, and shelf numbers of the originating and destination

Card Z, Port Z, Shelf Z nodes. These fields are useful for identifying the source and destination of the link.

These fields are only available for certain hardware types.

Interface A, Z This indicates the interface at node A and node Z that this link comes out of.

IP/Mask A, Z This indicates the IP address and mask of node A and node Z.



Links: Capacity Tab

In general, the Capacity tab of the Links windows is used to display link utilization information, derived
from the bandwidth of demands (for example, PVCs or flows) routed over the link and the link’s total
bandwidth. The upper half shows summary information and the lower half gives a breakdown by

partition.

Field

Dir

Total BW

Avail

Used

Util

Rsv

Description

The Direction of the link, either “A2Z” or “Z2A".

The total bandwidth of the link.

The amount of bandwidth still available on the link.

The amount of bandwidth used on the link by demands (or tunnels)

The utilization percentage of the link, as calculated from the Used and Total BW values.

The amount of reserved bandwidth on the link. This affects routing design. Reserved bandwidth is
often used to let you “save” bandwidth for scenarios such as network growth or potential outage.
Note that the maximum usable bandwidth for routing is set to Total BW - Rsv. To change the
reserved bandwidth value, select Tools > Options > Design and switch to the Design>Reserved
Bandwidth options pane. For more information, see Reserved Bandwidth.

Links: MPLS/TE Tab

Field

FRRA

Description File Format

no/yes: specifies if there is a fast reroute backup tunnel for the Node | bblink file

A to Node Z direction.
FRR_A= backuptunnel

If yes, specify the fast reroute backup tunnel.



(Continued)

Field

FRRZ

GLB Pool /
RSVP

SUB Pool / GB

Description

no/yes: specifies if there is a fast reroute backup tunnel for the Node
A to Node Z direction.

If yes, specify the fast reroute backup tunnel.

Tunnels cannot route over a link unless there is available bandwidth in
the global pool.

“Guaranteed bandwidth” tunnels cannot route over a link unless there
is available bandwidth in the subpool.

Links: Protocols Tab

File Format

bblink file

FRR_Z= backuptunnel

bblink file (for Cisco)
GLBPOOL= bw
GLBPOOLA2Z= bw
GLBPOOLZ2A= bw
(for Juniper Networks)
RSVP= bw
RSVPA2Z= bw

RSVPZ2A= pw

bblink file (for Cisco)
SUBPOOL= bw
SUPOOLA2Z= bw
SUBPOOLZ2A= bw
(for Juniper Networks)
GB= bw

GBA2Z= bw

GBZ2A= bw

The following protocols can be viewed in the Protocol tab: MPLS, OSPF, ISIS, EIGRP, IGRP, RIP, LDP,
TDP. The corresponding metric (if applicable) is displayed underneath the A-Z Metric and Z-A Metric



columns, such as the tunnel metric for MPLS-TE and the cost for OSPF, ISIS1 and ISIS2. The metric for a
given IGP protocol is used for routing the demands if the default routing protocol is set to that protocol.

Note that there are two additional entries, Metric Bandwidth and (E)IGRP delay that can also used to
influence the routing metric. The Metric Bandwidth is an informational and routing parameter
corresponding to the “bandwidth” statements for Cisco and Juniper Networks interfaces. The (E)IGRP
delay corresponds to the “delay” statement for Cisco interfaces.

EIGRP and IGRP metrics can be influenced by changing the Metric Bandwidth or EIGRP Delay fields. To
change the K-values from the text file before opening the network, the following line can be added to or
edited in the dparam file: IGRP_param1= TOS:0,K1:1,K2:0,K3:1,K4:0,K5:0

For OSPF, the Metric Bandwidth is used to calculate the routing metric only if no cost is specified. The
reference bandwidth can be changed by modifying the Node.

Links: Attributes Tab

Tunnels can be prevented from routing over particular links if the link attributes, tunnel mask, and tunnel
affinity are set.

Links: CoS Policy Tab

Specify the CoS policy attached to the interface of node A (source) or node Z (destination).

Adding Links

Click the Add button in the Links window to open the Add Link window. The required information (in
blue) includes the trunk type (T3, OC3, etc.) and the link’s end nodes (on the Location tab.) The end
nodes of the link may be chosen by referencing the Node ID or by using the mouse.

¢ By Mouse: Select node A and node B from the display map by using the mouse. When the nodes are
selected, the node IDs are displayed in the node A and node B fields of the Location tab.

e Node ID: Select node A and node B by browsing through the node list by each field.

For router networks the interface and IP address can be specified. To specify an interface, click the
search icon to see available choices. Other hardware types may have fields for the card and port number
instead of the interface and IP address.



Clicking Add submits the new link to the network model. The Add Link window remains open to allow
adding additional links if desired.

Apply Template

This pull-down selection allows you to apply a link template that was created by selecting the “Link
Template” window as detailed in Link Templates. This can serve as a shortcut to automatically filling in
fields that are in common amongst many links.

Auto Add on Mouse Clicks

When this checkbox is selected, you may automatically add new links from the map by choosing node A
and node Z. The properties of the new link should be specified on the properties tab of the “Add Link”
window before adding the link with the mouse.

Modifying Links

To modify one or more link, first select or highlight these links in the Links window. Then, click the
Modify button. In the Modify Links window, current values can be modified by changing the
corresponding text field.

When more than one link is selected for modification, certain fields are disabled and cannot be modified.
If no change is made to a particular field (i.e. the field is left blank), then that property will not be
touched or modified for any of the selected links.

Right-Click Menu Options

o Traffic Chart: Traffic charts include the traffic load per period derived from the trafficload file and
measured interface traffic from the interfacelLoad_in(ingress) and interfaceload_out (egress) files. For
router hardware, options vary depending upon the chosen layer (Layer 2 or Layer 3) indicated in the
toolbar.

¢ Node Detail A, Node Detail Z: Switches to a view displaying information on the source node (Node
A) or destination node (Node Z)

e Show Config A, Show Config Z: (Router only). Displays the configuration file for the source node
(Node A) or destination node (Node Z)

e Demands on/thru Link: Displays a list of demands routed over this link.

e SRLGs on Link: Displays a list of facilities containing the selected link



¢ [Interfaces on Link: View the interfaces used for the selected link.

e Nodes on Link: Displays NodeA and NodeZ on the link.

¢ Tunnels on/thru Link: Displays a list of tunnels that routes through the link.

¢ Tunnel Table on/thru Link: Displays a list of tunnels that routes through the link in a table.

e CLI - Show Interfaces: (Live Network only). Opens the Run CLI window and runs the show interface

command on the interfaces of the link.

¢ Live Link Status Check: (Live Network only). Opens the Live Status window and runs queries to check
the operation and admin status of the link.

Network Menu: Interfaces

The interface window is available from Network > Elements > Interfaces

Figure 67: Interfaces Window
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General Tab

Field Description

Interface Name The interface name

IP Address/Mask The IP address and mask of the interface

Bandwidth The allocated bandwidth

Layer Layer 3 (IP) or Layer 2 (switches)

Node The node which contains the interface

Link The link which uses the interface

Oper Status The operational status of the interface (active, passive, planned, down, unknown)
Admin Status The administration status of the interface (active passive, planned, down)

Advanced Tab - Layer 3

Field Description

VCI/DLCI The virtual circuit identifier or the data link connection identifier for ATM frame relay
VPN The VPN being used on the interface

VRF The virtual routing and forwarding instance name

VRouter The virtual router name

HSRP The hot standby routing protocol



(Continued)

Field

Encapsulation

Multipoint

APS Group

APS Protected Address

APS Protected Node

VLAN ID

Aggregated Interface

Description

The interface encapsulation type

The multipoint interface

The automatic protection switching group

The automatic protection switching address

The automatic protection switching node

The VLAN associated with this interface, if any

The aggregated interface (for example, ae0, ae1 for Juniper Networks) associated with
this interface.

To associate an interface with a link, modify the link’s Location tab. Click on the search button next to
each Interface text box to bring up the Select Interface window. Highlight the interface you wish to
associate with that end of the link and click OK.

Advanced Tab - Layer 2

Field

Encapsulation

VLAN ID

Redundant Trunk Group

Aggregated Interface

Description

The interface encapsulation type

The VLAN associated with this interface, if any

Redundant trunk groups can be configured on EX-series switches so that when the
active link in the group fails, a secondary link will start forwarding data traffic.

The aggregated interface (for example, ae0, ael for Juniper Networks) associated with
this interface.



(Continued)

Field Description
Port Mode Access (SW_ACCESS) or Trunk (SW_TRUNK)
Tagging Specifies the tagging type (For Juniper Networks, VLAN_TAGGING is for single

tagging, STACKED_TAGGING is for double tagging, and FLEX_TAGGING can be
configured on the physical interface to support different tagging types on different
logical interfaces of the same physical interface).

Right-Click Menu Options

o Live Interface Load (Live Network only): Indicates the traffic load collected by Paragon Planner using
the Traffic Collection Manager.

e Show Related Interface(s): Opens a table of related subinterface(s) of a physical interface, aggregate
link (for example, ae link) to which this interface belongs, if applicable, and connected interface(s).
The Relation column indicates the nature of the relationship (Physical/Main Interface, Sibling,
Connected, Self, Subinterface, etc.) When selecting a link of this table, the bottom pane indicates the
relationship. For example, for WAS3640.Ethernet0/1.6, the Physical/Main Interface is
WAS3640.Ethernet0/1, a Sibling interface is WAS3640.Ethernet0/1.2, and a Connected interface is
J3.ge-0/0/1.6 (there is a link between WAS3640 and J3).

Add Interfaces

To add an interface, click Add to open the Add Interface window. Then specify an Interface Name, IP
Address/Mask, Bandwidth, and select a Node from the drop-down box.

Modify Interfaces
To modify an interface, select an interface and click Modify to make the desired changes.

To associate an interface with a link, go to the Links window and click Modify. In the Location tab, click
on search button next to each Interface text box to bring up the Select Interface window. Highlight the
interface you wish to associate with that end of the link and click “OK".



Network Menu: Demands

IN THIS SECTION

Demands: Properties Tab | 151
Demands: Paths Tab | 153

Adding a Single Demand | 154

Demand Type Parameter Generation | 159
Adding Multiple Demands | 161
Adding One Hop | 163

Modifying a Single Demand | 164
Modifying Multiple Demands | 165
Right-Click Menu Options | 166

Notes on Priority and Preemption | 167
Demand Statistics View | 168

Traffic Load | 168

End-to-End Delay | 169

Find Demands Filter | 171

From the main menu select Network > Elements > Demands to open the Demands window. “Demands”
is a generic terminology used in Paragon Planner. It is equivalent to “PVCs” in ATM networks or end to

end “flows” in router networks.



I Demands: Properties Tab

Figure 68 on page 151 shows the Properties Tab under Demands. Table 29 on page 151 describes the
fields in the Properties tab.

Figure 68: Demands Window Properties Tab
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Table 29: Demands: Properties Tab Field Descriptions

Field Description

Demand The demand name specified by you when the demand was added.

Node A, Node Z IP Displays the source node (Node A) and termination node (Node Z) of the demand and
A, IPZ IPvé6 A, IPv6 their IP addresses (router model only).
Z

BW This is the bandwidth required by the demand. Demand overhead is automatically
calculated by the program.
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Table 29: Demands: Properties Tab Field Descriptions (Continued)

Field

pri,pre

Type

Owner

Service

Path Config Options

On Pref Rt (On
Preferred Route)

Comment

Description

The priority and preempt fields of the demand specification consists of two numbers
separated by a comma (,). The first number defines the priority of the demand, and the
second number the preempt priority of the demand. The preempt priority should be at
the same or lower priority as the priority of the demand. It is assumed that this demand
can bump any of the demands with priority lower than the preempt priority.

Indicates the type of the demand, whether it is a data demand or voice demand.

Displays the name of the owner of this demand. Owner groups can be defined using the
Owners section in the Modify menu.

Indicates the user-defined service type of the demand (for example, FTP, VOIP) as
described in "Network Menu: Service Type" on page 187.

For the optical transport model, this will indicate if the demand is a 1+1 demand

Indicates whether or not the path is routed on the primary configured route. ‘yes’ means
the path is routed on the primary configured route ‘no’ means the path is routed but not
on the primary configured route -’ means there is no configured route ‘not routed’ means
the path failed to be placed

User-entered comments



Demands: Paths Tab

Field

Current
Route

Configured
Paths

Secondary

Description

This is the current route/path of the demand. This path is calculated by the program according to
the metric, partitions, etc. as specified by you in the Design options.

e The route consists of a sequence of node IDs or names separated by “--". Different delimiters
are used to mark the distance relationship between nodes. A listed configured route for a
demand would be something like “ATL--WDC--HOU--NYC". This means the path of the
demand begins at node Atlanta, goes to Washington DC, Houston, and terminates at node
New York City.

e Use the Report Options window (Tools > Options > Report) to decide whether to display the
path using the linkname or only the nodes along the path.

This field displays the user-configured route/path for this demand. This route is specified by you
in the Add/Modify Single Demand window.

e The route consists of a sequence of node IDs or names separated by “--". Different delimiters
are used to mark the distance relationship between nodes. A listed configured route for a
demand would be something like “ATL--WDC--HOU--NYC". This means the path of the
demand begins at node Atlanta, goes to Washington DC, Houston, and terminates at node
New York City.

e Use the Report Options window (Tools > Options > Report) to decide whether to display the

path using the linkname or only the nodes along the path.

Displays all secondary routes/paths of the demand. Secondary routes are also specified by you in
the Add/Modify Single Demand window.



Adding a Single Demand

To add a single demand, click the Add > One demand button. Enter in the source (Node A), destination
(Node Z), bandwidth (BW) and a demand identifier (Demand ID). For an explanation of the parameters in
this window refer to the table below.

Figure 69: Add Demand Window
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Properties
Field Description

Demand ID | The Demand identifier as specified by you.

Owner/VPN | Displays the name of the owner of this demand. Owner groups can be defined using the Owners
section in the Modify menu. In router models, this shows the VPN in which the demand belongs.

Node A Originating node of the demand.

Node Z Destination node of the demand.

BW The bandwidth required by the demand. Overhead is automatically calculated by the program.



(Continued)

Field Description
Type Indicates the type of the demand. (varies with different hardware types)
comment Comments attached to the demand definition. You should note that comments are not used in any

part of the modification, design, or simulation of the program and are merely provided as a
convenience.

Advanced
Field Description
pri,pre The priority and preempt (or holding priority) fields of the demand specification consists of two
numbers separated by a comma (,), or a forward-slash (/). The first number defines the call priority
of the circuit, and the second number the preempt priority or holding priority of the circuit. The
preempt priority or holding priority should be at the same or lower priority as the call priority of the
circuit.
o  Whether the second number is the preempt or holding priority depends on the hardware. Most
hardware vendors use holding priority. Note the subtle difference between the two types: A
circuit can bump any circuit with call priority lower than the preempt priority. A circuit can only
be bumped by a circuit with call priority higher than the holding priority.
Service Indicates the service type of the demand. The available service types can be found in the Service
Type window as detailed in "Network Menu: Service Type" on page 187.
Path Displays the path configuration options used to mark current routes as configured paths or to
Config. remove configured paths. Options available are: Config, Div. Sec. and Div. Stdby.
Options

e Div. Sec. and Div. Stdby options are applicable only for ATM PVCs and LSP tunnels. When
specified, Paragon Planner will create a secondary or standby path entry, respectively, for the
PVC/tunnel.

e Specifying Config will cause the Configured Route to be set equivalent to the Current Route.

Location



NOTE: An asterisk (*) denotes a hardware specific field.

Field

Node A

IP A

IPvé A*

Node Z

IP B*

IPvé6 B*

Paths

Field

Pathname

Opt

Description

Displays the source node of the demand.

Displays the IP address of node A.

Displays the IPv6 address of node A.

Displays the destination node of the demand.

Displays the IP address of node B.

Displays the IPv6 address of node B.

Description

This is the user-specified name of the route for this demand. This pathname is specified by you
in the Add/Modify Single Demand window.

This field indicates the priority of this path/route in the “Opt” field. In the “Opt” field, the
program will select the smallest number to be the primary route. For example, you may specify
an Opt 2 for route “Backup1” and Opt 5 for “Backup2”. The program will sort these two routes
and select Backup1 to be the primary route since its Opt is smaller.



(Continued)

Field Description
Configured This field displays the user-configured route/path for this demand. This route is specified by you
Path in the Add/Modify Single Demand window.

e The route consists of a sequence of node IDs or names separated by “--". Different
delimiters are used to mark the distance relationship between nodes. A listed configured
route for a demand would be something like “ATL--WDC--HOU--NYC". This means the path
of the demand begins at node Atlanta, goes to Washington DC, Houston, and terminates at
node New York City.

Configuring the Demand Path

When adding a demand, you can configure a path or route for the demand.

NOTE: This feature applies for connection-oriented networks like ATM where a path can be
preferred or required. (For IP/MPLS networks, configuring the demand path applies only for
tunnels, not for demands.)

To configure the path, underneath the “Demands / Paths associated with this demand” section, first
double-click the Pathname field to change the pathname so that it is no longer “Dynamic”. There are
multiple ways to configure the path through the graphical interface.

e One way is to select Click links/nodes on map, then right-click in table next to where it says “To
choose paths.” Then, <Ctrl>-click all the links along the path, right-click the relevant row entry in this
table, and then select Use Map Sel'n.

e Another way is to select Click consecutive nodes starting at node A next to where it says “To choose
paths.” Then click the nodes from source to destination to automatically populate the Configured
Route. Because this method is based on nodes only rather than including the links, this method
cannot be used to select a particular link when there are parallel links between two nodes.

o Finally, another method is to right-click an entry and select Edit Route to open a window where you
are given options for each next hop until the destination is received.

Edit Route



Field

Current Node

Circuit ID / Flow ID

Next Available Hop(s) /
Available Nodes

Add to Path

Delete from Path

Show Path

Clear Selections

Hop Disp Opt

Defined Path

User Parameters

Description

Displays the current originating node from which the path of this demand is to be
specified.

Displays the name of the demand as specified by you.

Here, you can select three methods to choose the next hop or path for this demand.
The Node ID/Name option allows you to select the next hop by choosing the next
node of the path. The Link Name option allows you to select the path of the demand by

choosing the links on which the demand will traverse. Lastly, with the Loose Route
option, the program displays a list of routes calculated

Clicking on this button will add the highlighted hop or path to the path list.

Deletes the highlighted path from the current path list.

Selecting this button displays the path in the topology map. The path is displayed in a
think yellow line.

This will clear the list of chosen paths from the current paths section of this window.

Allows you to set the next available hop using the IP address or node ID/name.

As you defines and adds to the path for the demand, this field will progressively display
the path as specified by you.

User parameters allow you to define their own parameters for network elements such as nodes, links

and demands, and then to associate values to these parameters for the individual network elements.



Demand Type Parameter Generation

Click the Type button in the Add or Modify Demands window to access additional demand settings.
Clicking OK causes the Type field to be populated with the corresponding keywords. Note that different

parameters will appear for different hardware device models.

Field

Max Delay

Max Hop

Max Cost

Frame Size

Diversity

Guaranteed BW

Full Duplex

Policy Class

Multicast

Description

Specify a maximum delay constraint (default in
milliseconds).

Specify a maximum hop constraint

Specify a maximum end-to-end cost of the path ( for
example, sum of the metrics/admin weights)

Used to calculate overhead.

Specify the name of a group of demands this demand

belongs to. When performing diverse path design, the
program will try to design the paths of the demands in
this group to be diverse.

Specifies that the demand should route over a
Guaranteed Bandwidth (for example, subpool) tunnel

If this checkbox is selected, the flow is routed along the
same route in both directions.

CoS Policy

If this checkbox is selected, specify the destination IP in
the adjacent select menu.

File Format

MAXDELAY=x
(optional unit ‘s’ or ‘ms’ for seconds
and milliseconds)

Hcnt

MAXCOST=x

BF size

Ddivgroupname where
divgroupnameis the name of a
group of paths

GB,

DUPLEX,

COS=policyname, where
policynameis substituted by the
CoS policy name

MCip-address, where jp-addressis
substituted by the destination IP
address



(Continued)

Field

PIM Mode

Admin Status

ECMP

Description
The following Protocol Independent Multicast modes
can be specified:

e PIM-DM (dense mode) PIM-SM (sparse mode)
o PIM-SM (sparse mode)
e Bidir-PIM

e SSM

These are labels for status classification that can be
applied to a demand or tunnel.

e LIVE, MOD, NEW, and PLAN labels have no impact
on routing and is used for identification purposes.

e |f SHUTDOWN label is used, the demand becomes
unplaced.

Specify that this demand can be load-balanced to Equal
Cost Multiple Paths: specify a number in the adjacent
textbox to specify the number of sub-flows that the
flow can be broken down into

File Format

pim-mode, where pim-modeis
substituted by the multicast mode
(for example, PIM-DM)

LIVE is live

MOD is modified

NEW is new

PLAN is planned
SHUTDOWN is shutdown

ECMP= n, where nis substituted
by an integer



Adding Multiple Demands

Select Add > Multiple Demands to add multiple demand definitions to the network at one time. A list
box is used to indicate the origin (Node A) and destination (Node Z) locations. Meshed demands are
created between all locations listed in Node A and Node Z.

Figure 70: The Add Multiple Demands Window
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Field Description

Apply Template Specifies the circuit identifier assigned by you to the demand.

Demand ID (Prefix
and #)

Specifies the demand suffix number assigned for multiple demands. This number will
automatically increment.



(Continued)

Field

Owner

Count

BW

Type

Pri,Pre

Service

Path Config.
Options

Comment

Populate
Destination IP

Description

Specify the name of the owner of this demand or the VPN in which this demand belongs.
Owner groups can be defined using the Owners section in the Modify menu. VPN can be
defined using the Add/Modify IP VPN window in the Modify menu.

Specifies the number of demands to be added between node pairs.

This is the bandwidth required by the demand. Demand overhead is automatically
calculated by the program.

Indicates the type of the demand, whether it is a data demand or voice demand. This field
also indicates parameters for QoS networks. See "Demand Type Parameter Generation"
on page 159.

The priority and preempt priority (or holding priority) fields of the demand specification
consists of two numbers separated by a comma (,), or a forward-slash (/). The first number
defines the call priority of the circuit, and the second number the preempt priority (or
holding priority) of the circuit. The preempt priority should be at the same or lower
priority as the call priority of the circuit.

Indicates the service type of the demand. The available service types can be found in the
Service Type window. For more information on service types, see "Network Menu: Service
Type" on page 187.

Specifies the path configuration option, which can be Config, Div.Stdby, or Div.Sec.

Displays any comments you may be inclined to enter.

Specifies that the destination IP Address of each new demand should be automatically
populated.

e Filter: Opens the Find Nodes window in order to add nodes to the Node A and Node Z lists.

¢ Filter From Map: Adds nodes to the Node A and Node Z lists that are highlighted on the topology

map.



e Remove: Remove the selected node from the Node A or Node Z list.

o Copy A-> Z: Copies the nodes that are on the Node A list to the Node Z list.

Adding One Hop

The Add > One Hop option allows you to create two demands per link, one in each direction. Because
these demands have adjacent source and destination nodes, they are referred here as “one hop
demands.” For example, for a link connecting ATL to DAL, the program can create two one-hop
demands, one from ATL to DAL and one from DAL to ATL.

The purpose of this feature is to allow you to analyze the network to find out which demands are routed
over the direct link and which are routed over a detour path. The detour path may be taken, for example,
if the metric of the direct link is higher than that of the detour path. You can then check to see whether
the detour path was intended or not.

Upon opening the following window, you should perform a Filter... or Filter From Map to select the links
for which to add one-hop demands. Then enter a bandwidth and bandwidth unit for the demands to be
added, for example, 1M for 1Mbps, and click “OK”.

Figure 71: Add One Hop Demands
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NOTE: For information on the Add One Hop Tunnels feature, see the Paragon Planner User
Guide. Whereas for demands, the routing is left dynamic in order to allow discovery of multi-hop
paths, for tunnels, an explicit tunnel path over the selected link is given to force the tunnel over
the direct link. There are also additional options to label the added tunnels with a tunnel user

parameter for the tunnel ID group.

Modifying a Single Demand

When you select Modify > Selected... for only one entry in the Network Info window Demands view
pane, the following window is opened. You must first select a set of demands to modify in the table.

Figure 72: Modifying a Single Demand (Options May Vary)
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Paths Tab

e Path Table: When selected, a table will appear displaying each configured or calculated path that
originates at the source node of this demand. Note that these paths are not necessarily associated
with the demand, and are not to be confused with the configured or current path taken by the

demand.

e Show Route: When selected, this button displays the highlighted path in the detailed demand

information window.

o Show All Paths: This option displays all paths listed in the detailed demand information window.




Modifying Multiple Demands

When you select Modify > Selected... for multiple entries in the Network Info window's Demands view

pane, the following window is displayed.

Figure 73: Modifying Multiple Demands (Options may vary)
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Field Description

New Demand
ID

Multiply BW
by

This option can be used to change multiple demands to have the same Demand ID. In most
cases Demand IDs are unique and this option will not be needed. However, for certain features,
the same demand ID may be used for different demands in order to group them together. These
features include multicast demands (ATM or router hardware) and virtual concatenation groups
(optical transport only).

When this checkbox is selected, the program will perform a bandwidth multiplication by the
percentage specified here. The bandwidth of every demand selected for modification is
multiplied by this percentage.



(Continued)

Field Description

Remove When this checkbox is selected, the program will remove the current route for the demands
Current Route | being modified. Accordingly, those demands are unplaced and the Current_Route column of the
demand window is cleared for those demand entries.

e You can then have those demands routed when updating the network state or exiting from
modify mode by answering “Yes” to the dialog prompt to update the demand routing tables.
Alternatively, you may perform tuning for unplaced paths only from Design > Demands >
Route Paths > Unplaced Paths.

Right-Click Menu Options

e Show Path: Displays the path of the demand in the topology map, if it is routed. If multiple demands
are selected, their paths are highlighted on the topology map, and the demand currently selected in
the path window is highlighted with a slightly different color.

¢ Highlight All: Displays on the Standard map the source to destination pairs of all demands listed in
this window.

¢ Bottlenecks: Displays the location of the bottleneck in the console when a demand is unplaced.

e BW_Ovhd: Displays the bandwidth used by the demand and also the actual bandwidth allocated to
the demand. This information is displayed in the console window.

¢ All Configured Routes: This option displays on the map the configured routes for this demand. If the
path is dynamic rather than configured, you should use the Show Path option instead.

e Path Table: When selected, a table will appear displaying each configured or calculated path that
originates at the source node of this demand. Note that these paths are not necessarily associated
with the demand, and are not to be confused with the configured or current path taken by the
demand.

¢ End-to-End Delay: View a chart of the end-to-end delay per period as described in "End-to-End
Delay" on page 169

e Show Traffic Load: View a chart of the traffic load per period in the network as described in "Traffic
Load" on page 168"Traffic Load" on page 168.



e Show Site Demands: Display site-to-site demands on topology map, with a legend to indicate the
load between each site pair. See "Network Menu: Show Site Demands" on page 193 for more
information.

o Aggregate Demands: View the total bandwidth between each node pair in table format. See
"Network Menu: Aggregate Demands/Tunnels" on page 194 for more information.

Notes on Priority and Preemption

The Priority and Preempt Priority (or “pri,pre”) values of a demand (or MPLS LSP tunnel in Router
models) influences routing order and placement. Note that although Paragon Planner uses the term
“preempt priority” throughout its graphical interface, for a majority of hardware types, if supported, this
value actually maps to a demand’s Holding Priority. Paragon Planner will mimic the behavior of the
hardware device.

Note that Holding Priority and Preempt Priority differ subtly in meaning. A demand with a holding
priority of some value x indicates that “any demand with a priority higher than x can preempt this
demand.” A demand with a preempt priority of some value x indicates that “this demand can preempt
any demand that has a lower priority.” Net.com Promina hardware, for example, uses “preempt priority”.
The majority of supported ATM and router hardware, however, use a “holding priority” implementation
(for the routers, this applies to MPLS LSP tunnels, as opposed to demands).

Also, for the majority of supported hardware models, a lower number indicates a higher priority. For a
few hardware types, however, it is the reverse. Refer to your hardware’s documentation to check for the
proper numbering scheme. Paragon Planner will mimic the hardware’s behavior.

For example, suppose a demand has a pri,pre value of (7,0). Assume the lower value receives a higher
priority. So, a “0" holding priority is already the highest priority and indicates that no demand is able to
preempt this particular demand. The “7” priority value is used to determine routing order. If demands are
placed with higher priority demands first (the default), then this demand will not be routed until after the
demands of priorities O through 6 are routed.

NOTE: The preempt priority, or holding priority, should always be set to a higher priority than the
priority value. To illustrate, assume that we are dealing with holding priorities, as defined earlier,
and that the lower value receives a higher priority. Then, a pri,pre value of (7,8) is invalid. To
understand why, imagine if you had two such demands with pri,pre values of (7,8). One demand,
of holding priority 8, could be preempted by the other demand, whose priority is 7. The
preempting demand could then become preempted by the original demand, causing an oscillating
scenario.



Demand Statistics View

The statistics view can be obtained by right-clicking a demand and selecting View > Statistics View. The
tabs are explained below:

Field Description

General The General demand information tab displays the total amount of placed and unplaced voice and
data demands found in the network in terms of bandwidth.

Pri Load The Priority Load tab sorts the demands found in the network by their defined priority and
displays them in a table form in the demand information window.

BW & Ovhd ' The BW & Ovhd tab provides summary information on the bandwidth and overhead of the
demands shown in the Demands window. The program calculates the bandwidth of the demands
including the overhead calculation and summarizes this data in this tab.

Note: This tab is only activated when you are viewing demands on/thru a specific link. (Right-click
on a link; select View > Demands On/Thru Link.)

N Hop Path | The NHop Path tab categorizes the demands found in a network by the total number of hops in
each demand's route.

Traffic Load

As a prerequisite, you should load in the trafficload file, which details the period by period bandwidth
utilization.

Right-click a demand from the Network Info window’s demand view pane and select Show Traffic Load
to view the traffic load for a single demand or Show All Traffic Load to view the sum total traffic load for
all demands. This displays the Traffic Load window, displaying the traffic load in either barchart or line
form.
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In the traffic load graph show below, the Y-axis displays the traffic load in megabits per second. One bar
is displayed on the barchart for each of up to 24 time periods. The first two bars display the planned or
normal bandwidth ("N") and the worst or peak traffic load ("W") which occurred during those periods.

Figure 74: The Traffic Load Graph

|£| Traffic Load : flow? = | = 23'.
Flaw (- =2 TaI:nIel

flow2 (ATL -> CHI)
e e
700,000 -
G50,000 -
G00,000 -
550,000
500,000
450,000
400,000 -
350,000 -
300,000 A
250,000 -
200,000
150,000 A
100,000 -
50,000 -
o

o
o

F_03
10

=+ [Iy]
[} L}
o o

P_O&
P_O7
P_0O8
P_08

Worst

=
a
c
c
]
o

Period

B Load

[ Bar [ Line ” Prinkt... ” Save ] [ lose ][ Help ]

I End-to-End Delay

Right-click a demand from the Network Info window’s demand view pane and select End-to-End Delay
to view the period to period end-to-end delay for a single demand or All End-to-End Delay to view the
average of the end to end delays for all demands in the networks. This displays the Traffic Load window,
displaying the traffic load in either bar chart or line form.
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The End-to-End Delay graph displays the delay experienced by the demands in the network. In the
graph, the end-to-end delay is shown in milliseconds. The delay found in the planned and peak
bandwidths are shown as the first two bars in the graph.

Figure 75: End-to-End Delay
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Find Demands Filter

Click the Search by Property button in the Demands window to open the Find Demands window. The
Find Demands window is a utility for filtering demands by matching the fields entered. Fields that are
left blank are ignored.

Figure 76: Find Demands Window
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The From fields indicate the starting Node, Site, Lata, Group, or Area. For example, if you select Group
this will find all the demands originating at a node in the selected topology group. Select Flow ID to
indicate a specific demand.

The Status section can be used to narrow down on the demands of a particular status. For example, to
view only the Unplaced demands, deselect the checkboxes for Placed and Deactivated.

The Type field is used to hold many specific demand type parameters, separated by commas. Pressing on
the Type button will open the Demand Type Parameter Generation window, which can be used to help
you automatically populate the Type field.

The Type field is used to hold many specific demand type parameters, separated by commas. Pressing on
the Type button will open the Demand Type Parameter Generation window, which can be used to help
you automatically populate the Type field.



After you have entered any demand properties in the Find Demands window, the program will match
the properties entered and return a list of demands matching those properties. For example, if you want
to search for all demands that have a bandwidth of 5 megabytes both way, you would enter an “5M” in
the A->Z and Z->A fields. Then click on the OK button to retrieve the list of demands.

Network Menu: Tunnels

IN THIS SECTION

Properties Tab | 173

Paths Tab | 174

Right-Click Menu Options in the Tunnels Window | 175
Tunnel Type Parameter Generation | 176

Virtual Trunk Tab | 179
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From the main menu select Network > Elements > Tunnels to open the Tunnels window.

Figure 77: Tunnels Window Properties Tab
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Table 30 on page 173 describes the fields available in the Properties tab.

Table 30: Properties Tab of the Tunnels Window

Field Description

BWW This is the bandwidth required by the tunnel.

Indicates the type of the tunnel as specified in the Tunnel Attributes window. You may edit

TypeW
this field by right-clicking on the table and selecting Edit Type.



Table 30: Properties Tab of the Tunnels Window (Continued)

Field

Affinity/Mask ©

IncludeAll/
Exclude/
IncludeAny )

Pri,Prel))

Comment?

Paths Tab

Description

Allows you to set the affinity/mask of the tunnel for Cisco, or the include all, exclude, and
include-any settings for Juniper Networks admin groups to prohibit particular tunnels from
routing on trunks with particular attributes (admin-groups). Trunk attributes effectively color
the trunk, whereas a tunnel’s affinity/mask or include-all, exclude, and include-any settings
determine which color trunks the tunnel is permitted to be placed upon. You may edit this
field by right-clicking on the table and selecting Edit Affinity/Mask for Cisco or Edit Include-
All/Exclude/Include-Any for Juniper Networks.

The priority field of the circuit specification consists of two numbers separated by a comma
(,), or a back-slash (/). The first number defines the setup priority of the circuit, and the
second number the holding priority of the circuit. The holding priority should be at the same
or lower priority as the setup priority of the tunnel. It is assumed that this tunnel can only be
bumped by a tunnel with a setup priority higher than its holding priority.

Displays any comments you may wish to enter.

Table 31 on page 174 describes the fields available in the Paths tab.

Table 31: Paths Tab of the Tunnels Window

Field Description

This is the user-specified name of the route for this tunnel. If “Dynamic” is specified, the route is
chosen dynamically and you should not configure a path in that entry. Otherwise, you can specify a
different path.

Opt This field indicates the priority of this path/route in the “Opt” field. In the “Opt” field, Paragon
Planner will select the smallest number to be the primary route. For example, you may specify an
Opt 2 for route “Backupl” and Opt 5 for “Backup2”. Paragon Planner will sort these two routes and
select Backup1l to be the primary route since its Opt is smaller.



Table 31: Paths Tab of the Tunnels Window (Continued)

Field Description

Configured = This field displays the user-configured route/path for this tunnel.

e The route consists of a sequence of node IDs or names separated by “--". Different delimiters
are used to mark the distance relationship between nodes. A listed configured route for a tunnel
would be something like “ATL--WDC--HOU--NYC". This means the path of the tunnel begins at
node Atlanta, goes to Washington DC, Houston, and terminates at node New York City.

Right-Click Menu Options in the Tunnels Window

Right-click in the Tunnels window to access the following options:

¢ Show Path: Displays the current route and the defined routes (for example, primary and backup) of
the given tunnel in the topology map. If multiple tunnels are selected, their primary paths are
highlighted on the topology map, and the tunnel currently selected in the path window is highlighted
with a slightly different color.

o Highlight All: Displays on the Standard map the source to destination pairs of all tunnels listed in this
window.

¢ Bottlenecks: Displays the location of the bottleneck in the console when a tunnel is unplaced.

e BW_Ovhd: Displays the bandwidth used by the tunnel and also the actual bandwidth allocated to the
tunnel. This information is displayed in the console window.

o Show Traffic Load: View a chart of the traffic load per period in the network as described in "Traffic
Load" on page 168.

e Path Table: When selected, a table will appear displaying each configured or calculated path that
originates at the source node of this tunnel. Note that these paths are not necessarily associated
with the tunnel, and are not to be confused with the configured or current path taken by the tunnel.

¢ All Configured Routes: This option displays on the map the configured routes for this tunnel. If the
path is dynamic rather than configured, you should use the Show Path option instead. If there are
multiple paths

o Aggregate Tunnels: View the total planned tunnel bandwidth between each node pair in table format.
See"Network Menu: Aggregate Demands/Tunnels" on page 194 for more information.



Tunnel Type Parameter Generation

Click Type in the Add or Modify Demands window to access additional demand settings. Clicking OK
causes the Type field to be populated with the corresponding keywords. Note that different parameters
appear for different hardware device models. Tables Table 32 on page 176 and Table 33 on page 177
describe the fields displayed in the General and Design tabs, including the file format.

Table 32: Fields in the General Tab

Field Description File Format
Tunnel Metric A tunnel metric (absolute, relative or don't care) used by IGP if = ABS=absolute_metric
Autoroute Announce is checked. REL=relative_metric

Absolute: Use tunnel metric as is

Relative: Set tunnel metric relative to IGP Metric (for example,
10 would mean tunnel metric = IGP metric + 10)

Don't Care: Tunnel metric defaults to IGP metric.

Tunnel Option Specifies whether the tunnel is primary, secondary, or standby.
This option can be configured for a tunnel originating at a
Juniper Networks router by selecting Edit Type from the right-
click menu of the bottom half of the Add Tunnel or Modify
Tunnel window.

Autoroute Announces the presence of the tunnel by the routing protocol. = NOAA (No Autoroute
Announce When Autoroute announce is enabled, the IGP will include the = Announce) corresponds
tunnel in its shortest path calculation when the tunnel is up to not selecting this
checkbox
GRE Generic Router Encapsulation GRE
Zero Backup Cisco feature. During reroute, the tunnel bandwidth is O. If this ' OBW
Bandwidth is a backup tunnel, then selecting this option would mean that

bandwidth will not be reserved from the link(s) for this tunnel.

Policy Class If there was a policy class established and applied to this
tunnel, it would appear here. You can click on the down arrow
and review all policies that apply to the tunnel.



Table 32: Fields in the General Tab (Continued)

Field

Guaranteed

Bandwidth-TE

CCC

No BD

No CSPF

IGP

Auto-
Reoptimization

Template

Description

GB Tunnels can only be routed on trunks with available
bandwidth in the SubPool.

Circuit cross-connect. This means that this tunnel is cross-
connecting between two interfaces using CCC

No Border Flag. This is an artificial parameter used for design.

When set, routing will not follow OSPF constraints. That is, the

whole network is treated like a flat network.

Indicates that administrative groups/link attributes are ignored
by this tunnel.

If checked, the tunnel is routed using the current Interior
Gateway Protocol’s metric rather than the tunnel metric. The
current routing method can be found in the Design Options,
Path Placement options pane.

Indicates that the LSP can be automatically reoptimized if the
existing path becomes suboptimal.

Specifies a configlet template in the $WANDL_HOME/data/
templates or /u/wandl/data/templates directory. This option
allows you to select a manually-generated template to be used
for the configlet generation process. Select the directory in
which this template file is saved.

Table 33: Fields in the Design Tab

Field

Max Delay

Description

The maximum delay allowed for this tunnel. The max delay is
calculated either from the delay inputted on the links, or else the
value set in the Delay Parameters section of the Design Options
window (by default, 1ms per 100 miles).

File Format

NOBD

NOCSPF

IGP

REOPT

TMLT=templatename

File Format

MAXDELAY=<delay>



Table 33: Fields in the Design Tab (Continued)

Field

Max Hop

Max Cost

Diverse Level

Diversity
Group

Tertiary
Diverse

Symmetric
Pair Group

Description

The maximum number of hops allowed for this tunnel.

The maximum total admin cost (sometimes referred to as
“distance” or “admin weight”) allowed for this tunnel. That is, the
total admin cost of all the links that the tunnel traverses should not
exceed this value.

Allows you to specify path diversity requirements for tunnels with
standby or secondary paths. Select the desired level of diversity
NODEDIV for node disjoint paths

LINKDIV for link disjoint paths

FACDIV for facility/SRLG disjoint paths

If SITEDIV is selected, the program will pair tunnels with the same
originating and terminating sites. Paired tunnels are routed
diversely.

e This field can also be used to specify the name of a group of
tunnels this tunnel belongs to. When performing diverse path
design, the program will try to design the paths of the tunnels
in this group to be diverse.

Indicates that if there is a third path for this tunnel (for example, in
the case of one primary plus two secondary paths), that all three
paths should be designed to be diverse.

You should add an entry for the second and third path and then
design the path by selecting Design>Diverse Path Design for
Paragon Planner to design this path.

When there are two tunnels with the same end nodes but in
opposite directions, the path routing will use the same set of links.
Example, Tunnell source to destination is NodeA to NodeZ, and
Tunnel2 source to destination is NodeZ to NodeA. Selecting
Tunnell-Tunnel2 as a symmetric pair group will place both tunnels
along the same set of links. In the tunnel file, the keyword is
PAIR=groupname in the type field. Tunnels in the same group are
paired based on the source and destination node.

File Format

H<hopcount>

MAXCOST=<value>

NODEDIV
LINKDIV
FACDIV

DSITEDIV
Ddivgroupname where
divgroupnameis the name
of a group of tunnels for
which diverse paths is
desired

3DIV



Virtual Trunk Tab

The Virtual Trunk tab is used to indicate traffic engineering tunnels advertised as links in an IGP network
(OSPF or ISIS) and to indicate the corresponding metric assigned. Select the Virtual Trunk checkbox in
order to configure the relevant protocol, area, and/or metric for which the virtual trunk will apply.

For Cisco, the corresponding statement would be “show mpls traffic-eng forwarding-adjacency”.

For Juniper Networks, the corresponding statement would be the “label-switched-path name metric
metric’ statement under the hierarchy level [edit protocols ospf area area-id] or “label-switched-path
name” under the hierarchy level [edit protocols isis].

If a tunnel is marked as a virtual trunk, it is known to other routers and its metric and available
bandwidth information is broadcast to other routers as if it were a link. Just as a link has interfaces
defined on both ends, two tunnels (one in each direction) must be defined as virtual trunks for this
setting to take effect. Otherwise, the virtual trunk is perceived as being “down”. The file format is VT or
VT _areanumber.

This Area option is the OSPF area assigned to the Virtual Trunk. This applies only if Virtual Trunk is
selected and the network uses OSPF routing (as opposed to ISIS routing, for example). A tunnel that is
marked as a virtual trunk is advertised as a link to other routers. If those routers perform OSPF area
routing, they need to know what area this virtual trunk belongs to. Select the area from the pull-down
menu.

Network Menu: Sites

The Site window allows you to get more detailed information about currently defined sites in the
network. Sites represent node associations. These associations are typically by physical location. If
several nodes are located in the same area, such as in a building, small campus, or in the same calling



area, you may want to logically group these together by site. This grouping is not necessarily related to

the hardware design of a network.

Figure 78: Sites Window
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¢ Node Details: Jumps to the Nodes view and displays nodes that belong to the selected site.

e Create Group: Creates a group based on the nodes of the selected site. Opens an input name dialog

window for the new group.

e Add: Opens a Add Site dialog window for inputting the name of the new site, and values of

customized site user parameters.

e Modify: Modify a site or the site user parameters

e Delete: Deletes the selected site from the network.

Assigning Nodes to a Site

Nodes may be added to a site from the Nodes window by using either Add Node or Modify Node
functions. In the Add or Modify window, select the site from the Site ID drop down menu.

User Parameters

User parameters allow you to define their own parameters for sites. Before entering in values for site
user parameters, these parameters must first be created under Modify > User Parameters, in the Site

tab.
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Network Menu: SRLG

The SRLG window provides a method of grouping links and/or nodes that are likely to fail together if
they fail at all. The facility definition is used in failure simulations where accurate modeling requires the
simultaneous failure of specific links and/or nodes. It can also be used for diverse path design where
primary and backup paths for tunnels (Router model) or 1+1 demands (SONET model) are required to be

routed on facility-diverse paths.

Facilities can be used to model SRLGs (shared risk link groups) when only specifying a group of links. If
several links travel over the same fiber, so that a fiber cut will break all of them at once, it's good to
define a facility containing those links. Facilities can also be used to group together links on the same
card. Another example of a facility is the set of switches on one floor of a large data center, together

with the links going into or out of that floor.

Figure 79: SRLG Window
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e Add: Opens the Add Facility window which allows you to add a new facility and select the nodes and

links that belong to the facility.

¢ Modify: Opens the Modify Facility window which allows you to modify the facility groupings. Use the
mouse to highlight elements you desire to be in the selected facility. Deselect those elements to be
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removed from the facility. There are multiple ways to select elements. You can select nodes and/or
links directly from the list provided. Click the first element and then <Shift>-click the last element to
select a range of elements. <Ctrl>-click an element to toggle the selection of a particular element in
the facility. Alternatively, to add elements from the map, highlight the nodes and links on the map
(for example, selected by <Ctrl>-click or by drawing a box around a group of nodes and links) and
then click.Add from Map. Another method is to clickAdd Links from Filter and then enter in advanced
filtering criteria as described in the section Advanced Search in "Network Menu: Summary" on page
123.

e Delete: Deletes the selected facility group.

Network Menu: Owners

The Owners feature accessed by selecting Network > Elements > Owners allows you to display detailed
circuit information for the currently defined owner groups. By right-clicking an Owner and selecting
View Demands, information for the demands associated with the currently selected owner can be
displayed.

This feature is useful for link ownership identification. By defining an owner and associating certain
demands with that owner, the task of bandwidth reconciliation is simplified. Service providers that carry
the traffic of several companies use the owner feature to quickly determine the distribution of traffic in
the network. For example, a business owner demands 1.544 megabits/second bandwidth over a
network. That business owner owns that 1.544 megabit demand. The Owners information window
allows you to see how bandwidth in a network is allocated to all such business owners.

¢ View Demands: Selecting this button displays the View Demands window. This window will appear
only if the selected owner group has been assigned to a demand.

e Add: Opens the Add Owner dialog box which allows you to specify the name of the new owner.

o Delete: Deletes the selected owner group.

Network Menu: Templates

Node Templates

The Node Template window accessed from Network > Elements > Element Templates > Node, allows
you to create sets of default values to expedite the addition of nodes. Templates may be created and
modified by you and then used while in the Add Node window.



e Add: Opens an Add Node Template window that allows you to add a new template.

¢ Madify: Opens the Modify Node Template window that allows you to modify the selected template.

Field Description

Template Name The name identifying the template. Template names must be unique.

Auto-Generate node Generate the node ID using the specified prefix and number to create a unique node

ids ID.

Prefix Defined prefix for generating node IDs.

Start # Number from which to start numbering generated node IDs. Example: If Prefix is set to
"COR" and Start# "1", autogenerate node ID would create node ID "COR1", "COR2",
"COR3", etc.

Auto-Generate node Generate the node name using the specified prefix and number to create a unique

names node name.

Prefix Defined prefix for generating node names.

Start # Number from which to start numbering generated node names. Example: If Prefix is

set to "NODE" and Start# "1", autogenerate node names would create node ID
"NODE1", "NODE2", "NODEZ3", etc.

Link Templates

The Link Templates accessed from Network > Elements > Element Templates > Link, allow you to create
sets of default values to aid in the addition or modification of links. Templates may be created and
modified by you and then used in the Add Link window. When saving the network environment, link
templates are saved into the file linktemplate. <runcode>.

e Add: Opens an Add Link Template window that allows you to add a new template.

e Moadify: Opens the Modify Link Template window to allow you to make modifications to the selected
template. You should select the desired template for modification from the Template list found on the
right of the Link Templates window.



Field Description

Template Name The name identifying the template. Template names must be unique.

Auto Generate Link Generate the link name using the specified prefix and number to create a unique
names link name.

Prefix Defined prefix for generating link names.

Start # Number from which to start numbering generated link names. Example: If Prefix is

set to "LINK" and Start# "1", autogenerate node names would create node ID
"LINK1", "LINK2", "LINK3", etc.

Demand Templates

The Demand Templates accessed from Network > Elements > Element Templates > Demand, allows you
to create sets of default values to aid in the addition or modification of demands. Templates may be
created and modified by you and then used in the Add Multiple Demands windows.

e Add: Opens an Add Demand Template window that allows you to add a new template.

¢ Moadify: Opens the Modify Demand Template window that allows you to modify the selected
template.

Field Description

Template Name = The name identifying the template. Template names must be unique.

Owner Select a owner for this demand. Ownership is defined in the Owners option of the Modify
menu.

Count Specifies the count of the demand.

BW Specify the bandwidth required by the demand. Demand overhead is automatically calculated

by the program.

Type Indicates the type of the demand.



(Continued)

Field Description

pri,pre The priority field of the circuit specification consists of two numbers separated by a comma (,),
or a forward-slash (/). The first number defines the call priority of the circuit, and the second
number the preempt priority of the circuit. The preempt priority should be at the same or
lower priority as the call priority of the circuit. It is assumed that this circuit can bump any of
the circuit with call priority lower than the preempt priority.

comment Specify any comments you may wish to enter.

Tunnel Templates

The Tunnel Templates accessed from Network > Elements > Element Templates > Tunnel, allows you to
create sets of default values to aid in the addition or modification of tunnels. Templates may be created
and modified by you and then used in the Add Multiple Tunnels windows. The tunnel template is similar
to the demand template, but includes some tunnel-specific properties in the Type field. Refer to the
Paragon Planner User Guide for more details on these settings.

Network Menu: OSPF Areas/Domains

The OSPF Areas/Domains option allows you to view existing area or domain definitions. Depending on
the hardware type, this option will appear as either “area” or “domain”. They both have the same
options, so for the sake of simplicity in this document, we will refer to “area” only. Keep in mind that it
also applies to domains.

Areas are network partitions designed to make the network more scalable. Network summary
information is exchanged between two areas through gateways.

When you select Network > Protocols> OSPF Areas, the Areas information window will appear. The first
table displays the current area definitions while the second table lists the nodes and links in the
currently selected area.

¢ Node Details: When this menu is selected, the Nodes view will appear and display information
regarding the nodes in the selected domain/area.

e Link Details: When this menu is selected, the Links view window will appear and display information
regarding the links in the selected domain/area.

e Create Group: This menu will create a group for the nodes in the selected area.



e Add: Opens dialog at the top of the window which allows you to add a new domain/area.
o Delete: Deletes the selected area in this window.
Link OSPF Settings

To enable OSPF for a link and to specify an area for a link, modify a link from the Links window by
selecting Modify > Links. In the Protocols tab, set OSPF to “yes” and select an Area.

Network Menu: QoS Manager

The Quality of Service Manager displays CoS Forwarding Classes, CoS Policies, and Rate Limit Policies in
the network. Use the left-panel to navigate through the tree view structure. The Summary view displays
the total number of forwarding classes, CoS policies, nodes with CoS policies, rate limit policies, and
nodes with rate limit polices. For more details on using Class of Service see the Paragon Planner User
Guide.

NOTE: The maximum number of supported CoS classes is eight.

The Forwarding Class displays a list of the classes, CoS alias, primary classes, EXP bits, IP Prec bits, and
DSCP bits.

The CoS Policy displays a list, grouped by policy name or grouped by node, of the nodes, policy names,
policy types, and class mapping status. The Properties tab displays the class weight or bandwidth, PIR,
and Queue size of the node. The Interfaces tab displays the interfaces with the polices of the node.

The Rate Limit Policy displays a list, grouped by policy name or grouped by node, of the policy name,
node name, classifier, number of interfaces, CIR, BC, PIR, BE, conformed action, exceed action, and



violate action. The Interfaces tab displays the interfaces with the policies of the node. The Configlet tab
displays the policy statements in the configuration file of the node.

Figure 80: QoS Manager
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Network Menu: Service Type

The Service Type window accessed from the main menu Network > More > Service Type displays a list
of service types defined by you. Service types are defined by you to be used as a template when
demands are created or modified. Once a service type is created, you can select it to populate all the
demand parameter fields when creating demands.

e Add: Opens the Add Service Type window to create a new service type.
¢ Modify: Opens the Modify Service Type window to modify the selected existing service type.

o Delete: Deletes the selected service type from the network model.
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Field

Name

Owner

Min, Max BW

BW

Type

pri,pre

Misc

Comment

Services

Description

Displays the name of the service type. This name is specified by you.

Displays the owner for this demand. Owners are defined by selecting Modify > Owners.

These fields are only used with the Demand Generation feature (Traffic > Demand Generation >
General), during which newly generated demands of the given service type are ensured to have a
bandwidth between Min BW and Max BW. That is, a very large generated demand is split into
smaller pieces with a maximum bandwidth of Max BW.

Displays the bandwidth required by the demand. Demand overhead is automatically calculated
by the program.

Indicates the type of the demand for this service type.

The priority field of the circuit specification consists of two numbers separated by a comma (,), or
a forward-slash (/). The first number defines the call priority of the circuit, and the second
number the holding priority of the circuit.

Miscellaneous information that might be included in the service type file.

Comments regarding this service type.

This section displays all service types that have been defined by you.

Network Menu: Admin Weight

The Admin Weight window accessed from the main menu Network > More > Admin Weight displays
rules that can be used to set the default administrative weight (or link metric) for links to influence
routing. Note that the specification of administrative weights in this window is overridden by distances
explicitly set in the bblink file or linkdist file.

1. You must first specify criteria to match a desired set of links, such as protocol and end node types.



2. Then, you should specify the values of the weight variables. The fixed and variable weights determine
how the link’s administrative weight is calculated. The formula is: Admin Weight = Fixed Weight +
(Link Mileage * Variable Weight)

where Link Mileage is calculated by Paragon Planner and is always in miles. Link Mileage is based
upon the “airline mileage”, or geographical distance between two points. The distance between two
nodes is calculated based upon the coordinates in the muxloc file. The coordinates may be derived
from the NPA NXX values (for the United States and Canada) or latitude and longitude values.

NOTE: If the muxloc file does not contain any coordinates, this will lead to unpredictable results
in the Admin Weight calculations.

e Add: Opens the Add Admin Weight window which allows you to add a new administrative weight
rule to the network. the selected administrative weight rule(s).

¢ Madify: Opens the Modify Admin Weight window which allows you to modify the selected
administrative weight rule(s).

e Delete: Deletes the selected administrative weight rule(s) from the network.

Network Menu: Path and Capacity

The Path and Capacity feature allows you to quickly determine whether sufficient bandwidth exists in
the network to place additional user demands. The program can determine both straight path placement
and diversity path placement for mission-critical traffic. When the Path & Capacity option is selected
from the Network menu, the following submenu is displayed.

Field Description

Path This option is used to determine if there is enough bandwidth for a circuit to be routed
between a given pair of nodes. These nodes can be selected by using the drop-down combo
boxes in the Demand Path window or by clicking the left mouse button on two nodes in the
map window. To see if a path exists, click on the Show Path button. If BW is not specified, then
the default BW is 8000



(Continued)

Field

Paths AZ + ZA
(Router-only)

Diverse Path

Site Path

Site Diverse
Path

Equivalent
Path

Description

This option, available for Router networks, displays a round-trip path between a given pair of
nodes. The paths from Node A to Z and from Node Z to A may differ because of asymmetric
link costs/metrics, which may or may not be desirable. Select the end nodes by using the drop-
down selection boxes in the Demand Paths AZ + ZA window or by clicking the left mouse
button on two nodes in the map window. Use the Round Trip Paths window to zoom into a
segment of the path in either direction.

This option is used to find out if there is enough bandwidth to route two circuits in node
disjoint paths between a given pair of nodes. These nodes can be selected by using the drop-
down combo boxes in the Demand Path window or by clicking the left mouse button on two
nodes in the map window. If it cannot find node disjoint paths, the program will look for edge
disjoint paths. If it fails to find edge disjoint paths, it will search for paths with a minimum
number of common nodes or edges.

This option is used to find out if there is sufficient bandwidth to route a path between two
selected sites. You will first be prompted to select two nodes. These nodes can be selected by
using the drop-down combo boxes in the Demand Path window or by clicking the left mouse
button on two nodes in the map window. It will then check to see if there is enough bandwidth
to place a path between the sites where the two nodes are located.

This option is used to determine if two node disjoint paths exist between sites.

This option sets each virtual circuit, as well as its assigned QoS, bandwidth, and calculated
equivalent capacity. This option is only available for router networks.



Selecting any of the Path & Capacity options displays a window similar to the following which will allow
you to select two nodes for the program to demand sufficient bandwidth between them.

Figure 81: Window for Viewing Capacity
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Field Description
Node A and Z Source and destination endpoints of the path analysis
IP Address A and Z Source and destination IPv4 addresses. You should enter an IP address that corresponds

to one of the node’s IP addresses or its interface’s IP addresses

IPv6 Address A and Source and destination IPv6 addresses.
Z*
Owner Selecting an owner or VPN allows you to limit the nodes that are in the Node A and

Node B combo boxes to those with the selected owner/VPN.

BW Specifies the bandwidth of the demand. The program will check if there is sufficient
capacity to route a demand of this size.

Note: For ATM networks, the bandwidth should only include the payload (not the
overhead).



192

(Continued)
Field Description
Type The type field is a field from the demand file. Clicking the Type button will bring a
window to select specific options. Options vary by hardware.
pri,pre Priority and preempt priority values for the demand
Highlight Nodes Highlights the selected nodes A and Z on the topology map.
Highlight All Highlights all of the nodes in the network on the topology map.
Show Path Checks the path of a demand from node A to node B with the specified demand

properties and opens a Path Table showing each hop of the demand'’s path.

The following window appears after performing a path analysis, indicating details about each step of the
path:

Figure 82: Paths Window
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o Select Hide Unrelated Nodes to show on the map only those nodes and links along the path.
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o Select Highlight Single Path and select Clear Path Highlights to turn off the path highlight on the
map.

e The Console displays information from the path analysis.

e The Map displays the path route.

Network Menu: Show Site Demands

The Show Site Demands option is available from Network > Elements > Demands. Right-click on a
demand and select Show Site Demands to display the site-to-site demands on the map. The program
calculates the total demand between two nodes and draws a line connecting them according to the
colors described in the “BBload-Kbits” legend, which is displayed in one of the tab menus in the left
pane of the topology window.

Figure 83: Viewing Site Demands
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This view of the topology map is useful since it provides the use a visual picture of the demands found in
the network. The utilization of each demand in displayed according to the color found in the legend.



Network Menu: Aggregate Demands/Tunnels

The Aggregate Demands feature is accessible through Network > Elements > Demands. Right-click on a
demand and select Aggregate Demands. For each pair of nodes A and Z in the network, the Aggregate
Demands function adds up the total bandwidth of all the demands starting at originating nodes A and
destination nodes Z. Aggregate Demands then presents a table with one row for each node pair,
showing A, Z, and the total bandwidth. The demands are sorted by bandwidth, the largest at the top.

NOTE: For MPLS-enabled networks, there is a similar Aggregate Tunnels feature, accessible by
selecting Network > Elements > Tunnels. Right-click on a tunnel and select Aggregate Tunnels.
While reading this section, simply replace each occurrence of “demand” with “tunnel”.

Field Description

Combine A-Z with Z- When this option is checked, the row for A-Z includes the demands from Z to A as well
A as A to Z. If it is not checked, there is one row for A-Z and one for Z-A.

Place demands only When this option is checked, Aggregate Demands will only add up demands that have
been placed by the program in the current network model.

Show at most A network can have hundreds of thousands of node pairs. This option lets you see a
manageable number of the heaviest pairs of nodes.

After specifying the Aggregate Demands parameters, the aggregated demand bandwidth is presented in
a table form.

o Highlight All: This function highlights all node pairs in this table on the topology map.

e Report: This function saves the aggregate demands in a report on the server and client machines.
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Design Menu Overview

The Design menu allows you to access functions related to the backbone topology of the network. You

can perform demand and tunnel path design, rerouting, sizing; and network resizing, optimization and
analysis.

For information about FRR Design, Tunnel Sizing, T-Solve, and Auto Tunnel Design see the Paragon
Planner User Guide.

Design Menu: Backbone Design

IN THIS SECTION

Resize | 196

Route Paths | 198

Resize

The Design > Backbone > Resize option may be used to tune and optimize the current backbone
topology. Links can be resized based on normal link utilization or peak link utilization based on failure
simulation results. When the resize option is performed, Paragon Planner replaces links in the network
based on the Link Type Candidate in the Tools > Options > Resize window.

e Types in Tariff: Valid link types are taken from the current tariff table
e AGGR(xGb): Valid link types are based on multiples of 1G with default set to 10G.

Once you have selected the valid link types for the resize, you can choose to resize based on
e The peak link utilizations of the latest failure simulation performed

e The current link utilization when not under failure



e You can also automatically run exhaustive failure simulation for nodes, links, and SRLGs, and then
resize the links accordingly.

Figure 84: Resize Options
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Make your selection (or select Quit to cancel). Then click the OK button. The following window will
provide resize recommendations based on the previously selected Resize options.

Figure 85: Resize Recommendations
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The choices are as follows:
e No Action

¢ Update All Links: Update all links’ trunk types based on recommendations



¢ Update Overloaded Links Only: Update only the links’ trunk types which have utilization above
100%. In other words, trunk types will only be upgraded to higher bandwidths and not downgraded.

¢ View Changes or Update Selected Links: Manually select which links are to be resized.

e Remove All Changes resets the links trunk types back to their original size.

Figure 86: Resize Links
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The Resize Links windows allows manually selecting the links to be resized. Once a row is selected, the
columns at right are activated so that the trunk type (NewType) and count (NewCount) can be modified
if necessary. Then select Resize Selected Links. In the subsequent window, click Quit to exit from the
main menu. The trunk types of the selected links are then resized.

Route Paths

Route From Scratch

The Design > Demands > Route Paths > Route From Scratch option removes demand path placements
from the network and reroutes all the demands from scratch in sequential order. The Design > TE
Tunnels > Route Paths > Route From Scratch option works similarly but for TE Tunnels.

Tuning

With the current paths remaining in place, the Tuning option performs a local optimization of path
placement on the network. If there is sufficient bandwidth, path placement is performed on the network
for the selected paths:

Tune All Paths



The program will try to place unplaced demands and improve on already placed paths.
Tune Unplaced Paths

The program will try to place only unplaced demands.

Restore

Resets the paths of demands as specified in the input demand file.

Remove

Removes all placed demands from the network.

Remove Configured Paths

Removes all configured paths (Path Select, Path Required) and reroutes them dynamically.

Design Menu: Net Groom

Due to the dynamic rerouting of demands/designs during node or link failures, demand placement in the
network may gradually become sub-optimal. The Design > Demands > Net Groom and Design > TE
Tunnels > Net Groom option finds the best path for each demand (or tunnel) using existing network



bandwidth (without preemption) and displays these demands. Net Groom reroutes paths to minimize the
distance metric of the paths using available bandwidth in the network.

Figure 87: Net Groom - Fetch Demands Window
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e Filter: Opens the Find Nodes window which allows user to select nodes based on various parameters
and add them to the list of nodes for net groom.

e Filter From Map: Adds the selected nodes from the Map window to the list of nodes for net groom.
e Remove: Removes the selected node(s) from the list of nodes for net groom.

e Read From File: Allows user to import a list of source nodes for the demands from a file on the
server. The format of this file is simply a list of node IDs - one per line.

e Set Routing Method: Brings up the console and allows you to specify which variables to use when
calculating optimal placement of demands.

e OK: Applies the current settings and brings up the Net Groom window.
e Close: Closes the window and discards all settings.

e Help: Directs you to the online help documents for this window.



Field

Demand Type

Max BW

Max Priority

Use links of this status when finding
new routes

Min AW gain needed to use new
route

Release BW on current route before
finding new route

Sort demands in report by

Description

Specifies the type of demand to optimize

Specifies the maximum bandwidth of demands to optimize

Specifies maximum priority of demands to optimize

Selects which types of links to use when optimizing demands.

Any demands that will not achieve a gain in admin weight larger than this
value when optimized will not be optimized

Specifies whether or not the original path of the demand being
optimized is factored into the network when optimizing a demand

Specifies how the demands are sorted when a report is generated on the
optimized demands.



Figure 88: Net Groom Window After Optimization
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e Optimize Selected Demands: Optimizes the selected demands.

e Optimize All: Optimizes all demands in the table, including those not shown on the current page.

¢ View Paths: View the original, best, and new (if demand is optimized) paths of the selected demand

¢ View Report: Brings up a report window detailing the optimized demand weights and paths.

e Close: Closes the window.

e Help: Directs you to the help documents for this window.

Field

Name

Node A

Node Z

BW

Description

The name of the demand

The source node of the demand

The destination node of the demand

Total bandwidth of the demand




(Continued)

Field Description
Orig AW The admin weight of the demand prior to optimization
Best AW The best possible admin weight for the demand if there were no other demands in the network

Best AW Gain | The difference between Orig AW and Best AW

New AW The optimal admin weight for the demand, taking into account the other demands in the
network.

AW Gain The difference between Orig AW and New AW

Orig Path The original path of the demand

Best Path The best possible path of the demand if there were no other demands in the network.

New Path The optimal path for the demand, taking into account the other demands in the network.

After a Net Groom session has been performed and the network has been saved, the following
parameters are added into the network’s dparam file:

e netgroom_demandtype
e netgroom_maxpriority
e netgroom_minawgain

e netgroom_linkstatus

e netgroom_releasebw

e netgroom_reportorder



Path Diversity Design

204

Use Path Diversity Design by selecting Design > Demands > Path Design or Design > TE Tunnels > Path
Design to automatically configure two paths to be on diverse routes. This feature is available for demand
paths in ATM networks and Optical Transport networks, as well as LSP tunnel paths in MPLS-enabled

networks.

For MPLS-enabled networks, refer to the Path Diversity Design chapter of the Router Feature Guide for
Paragon Planner for more information on adding diverse standby and secondary paths.

After selecting Design > Demands > Path Design or Design >TE Tunnels > Path Design, the Diverse
Paths window is opened with a list of demands (for ATM/optical networks) or tunnels (for IP/MPLS

networks) that have diversity requirements.

Figure 89: Diverse Paths Window
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e To perform a diversity design, either select Tune > All Paths to design on all entries, or Tune >

Selected Paths to tune the diversity for only selected entries.

e A sort can be performed on the Actual Div Level column to tune only entries that are not at the
desired diversity level. A new placement is considered better than an old placement if either of the

following conditions is true:

e The new placement is at a higher diversity level than the old placement, or



e The new placement is at the same diversity level as the old placement, but the total length of the
new path is less than the total length of the old path.

Figure 90: Diverse Path Design Window
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Field Description
Default Indicate the default level of path diversity to aim for. Available options include facility, link, or site
Diversity (“divgrouplevel” in the dparam file). Note: For IP/MPLS networks, the targeted diversity level can
Level be set on a per-tunnel basis by modifying the Tunnel Type Parameter window, Diversity tab, and

will override the default for those particular tunnels.



(Continued)

Field

Backup Path
Config
Options

Path Config.
Options

Description

(Router only) Indicate how many backup paths you want to add by selecting Add if missing for the
backup paths you would like to add. Additionally, select the type of backup path to add (standby
or secondary) and whether it should be Dynamic (loose) or Explicit (strict/nailed-down routing).

o Selecting Add if missing creates new backup paths and modify existing backup paths.
Selecting Change only existing backup only modifies existing backup paths.

e Select Preserve secondary/standby settings of existing tunnels to prevent existing backup
paths from changing the backup path type from secondary to standby or from standby to
secondary. This option should usually be checked, in which case the backup path type settings
only applies to added backup paths.

To specify a requirement for tertiary diverse paths, select Add if missing and Explicit for both
Backup Path #1 and Backup Path #2.

Options may vary according to hardware type.
o Remove configured paths before tuning:

Select this in order to allow modification of already existing paths. If a path is set to required,
the program will not attempt to find a path satisfying diversity even if that path does not
already satisfy diversity. If you change the current paths from Required to Preferred, the
program can change the path, if necessary to satisfy diversity.

e Mark new paths as configured:

After the paths are designed, the resulting path are marked as path required (corresponds to
PR flag in the demand type field). Recall that a required path, as opposed to a “preferred” path,
will only route on the specified path. If that path is not available, the demand/tunnel is not
placed.

e Mark new paths as preferred:

After the paths are designed, paths are marked as path preferred (corresponds to PS flag in the
demand type field).

NOTE: If you do not mark a secondary path configured or preferred, the current path specification
will not be recorded when you save the demand/tunnel file or network environment. If you
choose not to mark it configured or preferred at this time, you can still do so afterwards through
the Design > TE Tunnels > Route Paths > Interactive Mode menu (option Update Preferred Path
Setting, 3. Use current routes as preferred/required routes). (On the contrary, the current path
specification with standby paths are recorded even if not configured because they are given
separate demand/tunnel entries of their own.)



Figure 91: Advanced Options
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Field Description
Backup Path The backup path’s bandwidth can be configured as a percentage of the primary path
Bandwidth bandwidth plus a fixed bandwidth,
Link Reservation This specifies how much bandwidth is already reserve as a percentage of the link’s
Parameters bandwidth (fat %) plus a fixed bandwidth (fatpct and fixfat in the dparam file). This

information is for reference only. To modify it, select Tools > Options > Design, Reserved
Bandwidth options pane.

Path Placement MPLS-Enabled Mode sets all links to be mpls enabled or uses the current mpls settings
Options defined on each link.

e Option to allow path intersections at No FAIL nodes and links to be considered diverse.
The No FAIL flag on nodes and links can be set in Modify mode by setting Fail=0
tolrue.

Modify Options



To modify tunnel backup paths or diversity requirements, select Modify > All Paths or Modify > Selected
Paths.

Figure 92: Path Design: Tunnel Modification
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Field Description
General Path Use the Configured Diversity Level menu to specify per tunnel diversity level
Options requirements. This will override the Default Diversity Level.

e Select Replace Explicit with Dynamic to change the primary tunnel from an explicit to
a dynamic route.

Diversity Group Demands or tunnels in the same Diversity Group are paired off and then designed for
Configuration diversity. Select a name for the Div Group.
Options

e The special Div Group SITEPAIR is a reserved group. For demands or tunnels in the
group SITEPAIR, those sharing the same source and destination sites are paired
together.



(Continued)

Field Description

Backup Path The “Max # Backup Paths” specifies can be used to limit the number of backup paths. For
Configuration example, specifying a Max # Backup Paths of O will delete all the backup paths for the
Options existing tunnel.

e Use the “Backup Path Type” option to specify per tunnel backup path type
requirements (for example, Standby vs. Secondary). This will override the Default
Backup Type.

e Use the “Tertiary Path Option” to specify tertiary diversity requirements (Add 3DIV or
Remove 3DIV)

View/Tune Paths Window

After designing or tuning the paths in the Diverse Path Table, click on any of the following buttons to
view details regarding the current diversity status for the selected demand (or tunnel):

e Show Paths: A Path window will open to highlight in different colors on the map the two diverse
paths, if any (or three diverse paths, in the case of 3DIV).

e View Path Details: Opens up the Demand or Tunnel window to view details on the selected demand/
tunnel. Select the Paths tab of the first entry to display the details of the diverse paths, if any,
including secondary/standby paths.

¢ Filter button: A text filter and advanced filter option are provided to filter out only desired entries of
the table based on user-defined criteria. Use the previous or next page to navigate if there are more
than 100 entries. Note that when performing a text filter as opposed to the Advanced Filter, each
result is a successive filter. Use “*” to refresh the table before performing a new search.

e Action > Report: Saves the Diverse Paths table to a comma-separated file.

o Action > LSP Delta Wizard: Provides a shortcut to the LSP Delta Wizard to generate LSP delta
configlets (offline module) or create a provisioning order (provisioning module only)

e Action > Import DivPath Definition file: The DivGroup settings exported by selecting File > Save
Network File > Tunnels to usertunneldef.runcode can be imported from this option.

The file format is as follows:

#NodeName TunnelName DivGroupName
BOS, RBOSWDC, test
WDC,RWDCBOS, test



ATL,RATLCHI, test
HOU, RHOUWDC, test

Additional Notes for the Router Module

When selecting View Path Details, if you designed for standby paths, they are displayed as additional
demands/tunnels and STANDBY are listed in the type field of the new demand/tunnel.

If you designed for secondary paths, this information is displayed in the same tunnel entry as the
primary path. The Secondary field will give the pathname of the new path. However, a path name may
not be created for you. In that case, click on the Details button for a demand/tunnel. Your secondary
path are listed in the paths associated with the demand/tunnel. If you enter a path name in modify
mode, the name is displayed under the Secondary field. A secondary path’s path specification will only
be displayed if the path is preferred or required.

You can also see the new paths from the Report Manager. Select Network Reports > Demand Reports >
Demand Path & Diversity (or Tunnel Layer Reports > Tunnel Reports > Tunnel Path & Diversity. In this
report, each path has its own entry. The type field will say SECONDARY or STANDBY if present. It will
say PR(path_specification) or PS(path_specification) where path_specification is replaced by an actual
path specification (nodes separated by dashes), if the path was set to be required or preferred (PR for
path required, PS for path select).

Below are the possible columns in this table. Column names may vary depending on the hardware
model. If a column name is missing, right-click on the column header, select Table Options, and select
which columns to display.

Field Description

Group Name Name of the group of paths which should be designed to be diverse. For IP/MPLS networks
with Standby/Secondary paths, the tunnel name is used for the group name.

Path1 Name Names up to three paths that form the diverse group, which the program will try to route
along diverse paths

Path2 Name

Path3 Name

Div Type Indicates the group type. For example, secondary/standby (router only), 1+1, VCAT (transport

only), or DivGroup (for a user-defined diverse group)
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Field

Div Level

Actual Div Level

Config Div Level

3Div

NodeA, NodeZ,
Site A, SiteZ,
BW, PriPre

Current Path

Config Path

Description

Indicates current level of diversity satisfied (for example, NO_DIVERSITY, SITE, LINK) or if
the path is unplaced. Note that the Actual Div Level considers also access nodes.

NOTE: Only one type of diversity is listed. If one includes the other, the more inclusive
category is listed (for example, site diversity implies link diversity, so it is sufficient to indicate
site diversity). In the case where both are satisfied but one does not include the other, still
only one is listed. For example, if site and facility diversity are satisfied, only site diversity is
listed.

(IP/MPLS only). Indicates the configured target diversity level if configured on a per tunnel
basis, for example, through the Tunnel Type Parameter Generation window, Diverse Level
drop-down box.

Indicates if tertiary diversity is desired. For IP/MPLS networks, to design a tunnel to have one
primary and 2 secondary paths that are all diverse, this setting should be set for the tunnel
and an entry should be created for each path for the program to configure during the Path
Design.

For Path1, Path2, and Path3 are indicated the source and destination nodes, sites containing
source and destination nodes, primary bandwidth, and priority/preempt setting. Not all of
these fields are displayed by default. Right-click the table column header and select Table
Options... to turn on the display of these columns.

The current paths of the demands/tunnels for Path1, Path2, and Path3

The configured paths of the two demands/tunnels for Path1, Path2, and Path3

Design Menu: Configlets/Delta

LSP Delta Wizard (IP/MPLS only)

The LSP Delta Wizard is used to compare LSP configurations in the baseline network with LSP
configurations in the current network, and to create CSV and XML reports of the differences. Refer to
the LSP Delta Wizard chapter of the Paragon Planner User Guide for further details.



LSP/VPN/Switch Configlet (IP/MPLS only)

LSP, VPN, and switch configlets can be generated based on modifications made to LSP tunnels, VPNSs,
and switches in the software. The configlet generation is available in the Design action mode. Refer to
the LSP Generation and Virtual Private Networks chapters of the Paragon Planner User Guide for
further details.

Design Menu: Metric Optimization

NOTE: Metric Optimization is available for router networks.

The Design > Metric Optimization option attempts to optimize the link metrics to remove
congestion from the network. Upon selecting this option, a wizard guides you to select the
candidate links that can be changed and an algorithm to use for optimizing their metrics. Once
the operation is complete, the metric changes are reported in METRICBAL.runcode, where
runcode is the file extension used by your network project specification file. The report indicates
the number of links whose metrics have been changed, the old and new worst case utilization,
and the old and new metric values for modified links. You have the option to review the link
changes and rerouted demands and to accept or discard the new metric changes. After accepting
the new metric changes, you can save the metrics by saving the entire network or saving only
the bblink file using File > Save Network File > Links. If you wish to revert back to your original
link metrics, simply read in the original bblink file using the File > Load Network Files window.
Click on the “Network Files” tab, and then press the bblink button to browse for the original link
file.

For further details, refer to the Paragon Planner User Guide.

Design Menu: P2MP Tree Design Window

To define a P2MP tree, grouping, and diversity level, perform the following procedure before opening
the P2MP Tree Design window:

1. Select all the sub-LSPs of a tree in the Network Info window (hold down the Ctrl key to select
multiple LSPs).

2. Click Modify and select Selected to edit all the selected LSPs simultaneously.



The Modify Tunnels window is displayed.
3. In the Properties tab, click Type.
The Tunnel Type Parameter Generation window is displayed.
4. In the General tab, populate the P2MP field with the tree name.
5. In the Design tab, populate the Diversity Group field with the group name.
6. In the Diversity Group field, select the tree diversity using the drop-down menu.
7. Click OK to save the settings.
Confirm that the changes were successfully made for all the selected LSPs.
8. Click Update and select Update Display to update the network model.
Repeat this procedure for each tree. P2MP tree names must be unique within a diversity group.

Use the P2MP Tree Design window to design the paths of the sub-LSPs of a tree to minimize the
number of shared elements (shown in the # Crossed column) and the total path length (shown in the
Length column) to another tree within the same group. The type of shared element is determined by the
Diversity Level (site, link, facility) of the sub-LSPs of the tree. The total path length is the path metric of
the tree.

To use the P2MP Tree Design feature effectively, there should be at least two trees defined within the
same group. A P2MP tree requires that the head ends of all the sub-LSPs begin at the same node and
have the same bandwidth value.

Once you define the P2MP trees, you can view them on the topology map. In the topology map window,
use the drop-down menu at the top of the left pane (RSVP Util) to select Subviews>P2MP. The P2MP
window is displayed where you can select one or more trees that you want to see on the topology map.



In the Paragon Planner main window, select Design > P2MP Tree Design. The P2MP Tree Design
window is displayed as shown in Figure 93 on page 214.

Figure 93: P2MP Tree Design Window
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To display a selected tree in the topology map window, click Show Tree.

To display a selected sub-LSP path in the topology map window, click Show Paths. The paths are
highlighted and animated in the topology map window.

To display detailed information about the selected sub-LSP in the Network Info window, click View Path
Details.

214



To design a P2MP tree, select a multicast tree and click Design Tree. The Design Options window is
displayed as shown in Figure 94 on page 215.

Figure 94: Design Options Window for P2MP Trees
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In the Design Options window, enter the number of iterations to run, select whether to remove

configured paths before running the design, and select whether to mark the new paths as configured.
Click OK to run the design.

The results of the design are displayed in the P2MP Tree Design window. Look for improvements to the
number of shared elements (# Crossed should be less than or equal after the design) and diversity level

of the sub-LSPs (Div Level).

Figure 95 on page 215 shows the design results and improvements. The Length increased for tree2
because improving shared elements and diversity has higher precedence.

Figure 95: P2MP Tree Design Window After Design
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Simulation Menu Overview

The Simulation menu is used to run various failure scenarios. You can perform simulations on both new
and existing designs to determine resiliency in the backbone. By default, Paragon Planner simulation
mimics the actual hardware. However, you can also adjust simulation parameters for experimentation
and “what-if” purposes.

In Failure Analysis, path provisioning simulates the hardware's implementation of bandwidth allocation
and demand routing on the existing topology. You can run interactive simulations or simulation scripts
(predefined or user-created). In addition, you can try simulating path placement for several iterations to
see what impact demand path placement and demand routing order have on the network.

By default, Paragon Planner failure simulation will mimic the actual hardware ( for example, in routing,
max hop, etc.). However, you can adjust simulation parameters for experimentation purposes.

These can be accessed by selecting Tools > Options > Failure Simulation, and are described in detail in
"Tools: Options Menu" on page 404. In addition to Path Placement controls, these options also control
certain aspects of the Failure Analysis and Reporting.

Failure analysis reports can be generated for the following cases:

Single Line Failure Report - simulation report for each single line failure
e Link Failure Report - simulation report for each link failure
e Node Failure Report - simulation report for each single node failure at every site for each vendor

e Random Daily Failure Report - simulation report for randomly generated multi-link or multi-vendor
failure scenarios

e Replay Up-Down Sequences Report - simulation report for any link/node/vendor up or down
sequence

Simulation Menu: Predefined Scenarios

IN THIS SECTION

Scripts | 218

Report Options | 221



Advanced Options | 222

Interactive Scenarios | 223

Scripted simulations are predefined simulation scenarios, which provide a quick and easy way for you to
test the network's resiliency to various failures. For each script, a failure report is automatically
generated.

NOTE: Before running a scripted, or batch simulation, be sure to review your failure simulation
option settings. These can be accessed by selecting Tools > Options > Failure Simulation, and are
described in detail in "Tools: Options Menu" on page 404. By default, an exhaustive failure
simulation will fail all elements one for each simulation. To specify not to fail certain nodes or
links, first modify the node (Design Properties tab) or link (Properties tab) and set FAIL=0 to true.

Scripts

Exhaustive Single Element Failures

The exhaustive single failure scripts fail all network elements of a given type, one at a time.

Figure 96: Single Failure Simulation Window
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Exhaustive Node Failure: Exhaustively fails every single node in the network.
Exhaustive Link Failure: Exhaustively fails every single trunk in the network.

Exhaustive Site Failure: Exhaustively fails all sites in the network. A site file is required to define
nodes within the same site. Nodes that are not grouped within a site are considered sites by
themselves.

Exhaustive Slot Failure: Exhaustively fails all slots that are defined in the network (router networks
only).

Exhaustive Card Failure: Exhaustively fails all cards that are defined in the network. For all ATM
networks, cards can be specified in the definition of links. Go to the Links detail tab and select the
Location tab. For certain router models, cards can be defined through the Equipment View feature.
Select Inventory > Hardware Inventory, or right-click on a node and select View > Equipment View.

Exhaustive SRLG/Facility Failure: Fails all facilities. A facility file is required to define node and trunk
facility associations. Trunks that are not associated with a facility are considered to be facilities by
themselves.

Exhaustive Parallel Links Failure: Exhaustively fails all trunks between all node pairs.

Exhaustive Voice Trunk Group Failure: Exhaustively fails all voice trunk groups defined in the
network. Select Network > Voice > Trunk Group to examine the trunk groups in your network.
Addition of trunk groups through the Java user interface is not supported at this time, although
modification is supported. To define trunk groups, the trunk group file should be edited through a
text editor.

Reports

The Peak Link Utilization Report (Simulation Reports > Network Statistics > Peak Link Utilization)
records the maximum trunk utilization for each trunk during the period of all the selected simulations
and the element whose failure triggered this maximum utilization. Peak utilization is reset each time
predefined scenarios are run. See "Report Manager: Simulation Reports" on page 389 for details on
this report. The resulting peak utilizations can also be viewed graphically on the Standard map by
selecting Utilization Legends > Peak Util.

PeakSimLink: The PeakSimLink report contains detailed information on oversubscribed links after the
exhaustive failure simulation.

PeakSimRoute:The PeakSimRoute report contains detailed information of failed demands or tunnels.

PeakSimReroute: The PeakSimReroute report contains detailed information for rerouted demands or
tunnels. To generate this report, select Generate Detailed Reroute Report from the Options tab.

PeakSimSummary: The PeakSimSummary report contains a summary of all exhaustive failure
simulations performed.



Exhaustive Multiple Element Failures

Figure 97: Multiple Failure Simulation Window
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To run an exhaustive failure script for the simultaneous failure of 2 or 3 elements, select the Multiple
Failure tab. Select the number of elements to be failed together (Double or Triple), select the Exhaustive
radio button, and then select the element type to be failed (node, link, etc.) for the Failures Type. For
example, selecting Double, Exhaustive Failure, for the Failure Types: Node and Link and then clicking the
Run button will result in an exhaustive failure simulation of node & node, node & link, and link & link

combinations.

To randomly simulate a specified number of double or triple failures, rather than all possible failure
combinations exhaustively, select “Cases to Simulate” instead of Exhaustive Failure, and enter the

number of cases to simulate.



Report Options

Figure 98: Report Options
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Include Simulation Events for all Periods: In the Peak Link Utilization report, information is provided
regarding the event triggering the peak link utilization, indicating which failure type triggered the
peak link simulation (for example, node, link, or facility) and the name of the element. With this
option unchecked, the simulation event is reported only for the planned period (based on the
demand file) and worst failure scenario among the periods of the trafficload file. If this option is
checked, the simulation event is also displayed for all of the individual periods (up to 24).

Generate Demand Over Tunnel Utilization Report: This option will generate the Demand Traffic on
Tunnel report in the Tunnel layer reports.

Generate Peak Group Transit Statistics: Records the maximum number and bandwidth of demands
transiting through a topology group. This information is displayed in the Group > Group Demand
Bandwidth Distribution report of the Report Manager. These statistics can also be turned on by first
setting CheckTransitDemandLimit=2 in the dparam file before opening the specification file.

Generate SRLG and Up-Down Sequence for Upper Layer: Selecting this option will generate a report,
UPDOWN.runcode, which lists the demands or tunnels that went down during the simulation. This
report is often used as an Up-Down Sequence File in an upper layer network in which the demands
of the lower layer network are translated into links in the upper layer network. Thus, the demands
that are reported as being down in the UPDOWN.runcode report can be read in as downed links in a
custom failure simulation script for an upper layer network. Additionally, an SRLG file is created,
based on the set of demands of the lower layer (links of the upper layer) which go down together.

Generate Detailed Reroute Information: Report detailed information on demands that rerouted
during the failure simulation.



Advanced Options

Figure 99: Advanced Options
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Fast Reroute Options

(Router networks only): See the Fast Reroute chapter of the Paragon Planner User Guide for more
information.

Replay Up-Down Sequence

Use a custom failure simulation script. The file name of the script must be specified. An example of a
custom failure simulation script is provided below:

Link1 down
Link2 down
RESET

Link3 down
Link4 down
RESET LINK
Link5 down
Link6 down
WAIT

Nodel1 down
Node2 down
RESET



Before you run an up-down sequence simulation, you must first specify whether to simulate Every Event
or to simulate When WAIT/RESET is Encountered. Assuming the latter, in the above example, Link1 and
Link2 is brought down first.

At the RESET line, the program will attempt to route all unplaced demands in the network (and generate
the appropriate reports), after which all links are brought back up and all demands are placed back in
their original paths. The program will then fail Link3 and Link4. Upon seeing the RESET LINK line, the
program will again attempt to route all affected and unplaced demands in the network (and append the
appropriate reports), after which all links are brought back up.

However, this time, the demands will not be placed back in their original paths; instead, the demands
will remain routed according to the paths found while Link3 and Link4 were down. The program will
then go on to fail Link5 and Linké. At the WAIT line, the program will attempt to route all unplaced
demands (and append the appropriate reports), but will not bring up any links afterwards. Node1 and
Node2 are then failed, and at the next RESET line the program will attempt to route all unplaced
demands in the network while Link5, Linké, Node1, and Node2 are all down (and append the
appropriate reports), after which all links and nodes are brought back up and all demands are assigned to
their original paths.

After the program has finished running through the script, you may view the appropriate failure
simulation reports for information recorded at each of the RESET, RESET LINK, and WAIT lines.

If you choose to simulate Every Event, then the program will run a simulation after every network
failure. In the above example, Link1 is taken down first, and the unplaced demands are rerouted and the
appropriate reports generated. Then, Link2 is taken down (Link1 is still down) and the unplaced demands
are rerouted. When RESET is encountered, all links are brought back up and all demands are placed back
in their original paths.

Interactive Scenarios

Interactive Simulation allows you to specify the nodes, trunks, and/or facilities that he wants to fail for
the simulation run. Subsequent failures can also be performed by continuing the simulation using a
different set of failed elements.

NOTE: Before running an interactive simulation, review your failure simulation option settings
via Tools > Options > Failure Simulation, and are described in detail in "Tools: Options Menu" on
page 404.

Fail Link



Fails selected trunks in the network. In the Fail Links tab, a list of all trunks is displayed. To fail a link,
simply select the row for a link. The link is grayed out on the map and marked with a red ‘F’ symbol to
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indicate its failure. To bring a trunk back up, select the failed trunk. 'Reset All' will bring all failed trunks

up. Use the View Changes option to see how the failure impacts link utilization, and demand/tunnel

routing.

Figure 100: Fail Links Window
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Fail Interface

The purpose of this tab is to study the failure of a physical interface, which can have multiple logical
links. For example, failing fe-0/1/2 on router ATL_TEST will cause 3 logical links associated with

fe-0/1/2.0, fe-0/1/2.211, fe-0/1/242 to fail. Select the row for a physical interface to bring down or up

the physical interface and associated logical links. ‘Reset All' will bring all failed interfaces up. Use the
View Changes option to see how the failure impacts link utilization, and demand/tunnel routing.

Fail Node



Fail selected nodes in the network. Use the View Changes option to see how the failure impacts link

utilization, and demand/tunnel routing.

Figure 101: Fail Nodes Window
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Fail Facility

Fail selected facilities in the network. A facility file must be defined and loaded in order to use this

feature.

Use the View Changes option to see how the failure impacts link utilization, and demand/tunnel routing.

Run, Step, Stop

e Run is used to run a simulation with the given failures.

e Step is used to step through a simulation. A step consists of the rerouting of a single demand. For
each step, a Paths window appears indicating the rerouted path (if any) and the disconnected path.
This feature is applicable only when a running simulation has been stopped.

e Stop is used to stop a running simulation.

View Changes

The following changes can be viewed after performing the interactive simulation:

¢ View Link Changes: View changes to the link utilization and RSVP utilization

¢ View Demand Changes: View changes to the demand placement, number of hops, and delay (ms)
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¢ View Tunnel Changes: View changes to the tunnel placement, number of hops, and delay (ms)
Reset Simulation

Reset the simulation to the initial network state. All trunks and nodes are set to active and all demands
are routed according to the state at which the simulation mode was entered.

Simulation Menu: Time-Based Simulation

Time-based simulation is used to simulate bandwidth calendaring. By Scheduling LSPs with specific time
windows, you can simulate circumstances in a live network where peak periods of bandwidth utilization
are created by LSPs with overlapping start and end times. This allows you to predict whether planned
LSPs would actually be placed. You can add exhaustive failure simulation to the scenario as well, and
finally, you can generate a report that details the results of the simulation.

The Paragon Planner follows some rules when performing the routing and failure portions of this type of
simulation. For the routing simulation:

e Only LSPs that are active during the simulation period are considered and placed into the time line;
inactive LSPs are ignored.

e The Paragon Planner advances the time line to route each LSP based on its scheduled start time.
For the failure simulation:
e Qutage simulation can be time consuming, so the Paragon Planner performs it only at specific times.

e The times selected are just prior to the time the LSPs are scheduled to disconnect. This is when the
highest impact is expected.

To simulate bandwidth calendaring, perform the following procedure.
1. Provision scheduled LSPs in the Paragon Pathfinder UL.

2. Set the network time by navigating to Tools > Options > General.



3. In the Simulation Scenarios window, click Time Based Simulation as shown in Figure 102 on page
227.

Figure 102: Simulation Scenarios Window Time Based Simulation

P )

| £+ Simulation Scenarios EE@

Single Failure Multiple Failures  Report Options  Advanced Options | Time Based Simulation |

[] Enable Time-Based Simulation

StartTime: |2017-11-26 21:05:24 - | [
EndTime: 3017-11-27 21:05:24 %+ | [
Reports... Map Run Close Help

4. Click the check box that enables time-based simulation and select the simulation start and end times.

5. If you also want to include exhaustive failure simulation, click Single Failure in the Simulation
Scenarios window and select the type(s) of outage you want to include (link, SRLG, node, and so on).

6. In the Simulation Scenarios window, click Report Options. Click the check box corresponding to the
type of results report you want to generate. For bandwidth calendaring simulation, the following
reports provide very useful information:

e |2 PeakSimReroute
e L2 PATHDELAY
e |2 PeakSimRoute

These reports provide information about LSPs that are (not_routed) or (time_expired). You can then
use the Ul to research the exact reason why an LSP is (not_routed). Right-click on an unplaced LSP
and select Bottleneck Analysis to learn why the LSP was not placed. One common reason is
insufficient RSVP bandwidth.
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Traffic Menu Overview

This chapter explains how to use the various traffic features in the Traffic Menu. The addendum at the

end of this chapter also explain how to access and interpret the basic traffic charts available in the
Paragon Planner Desktop application.

Figure 103 on page 230 shows the Traffic Menu on the top menu bar.

Figure 103: Traffic Menu
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Traffic Menu: Traffic Load

Select Traffic Load to open the Load/Util window. The window options may vary depending on the
hardware type. The most basic window will contain the Normal and Peak radio buttons and the slider
bar. Router modules will have an additional option for live interface (for Layer 3) or tunnel (for Layer 2)
traffic and the option to fetch historical traffic from the database from a selected starting period and at a



selected time interval. The link utilizations on the map will reflect planned traffic, worst-case traffic, or a
certain time period of traffic (up to 24) by moving the horizontal slider.

Figure 104: Traffic Load Window (Options May Vary)

I )

|| Laad Uil e R T
@ Nu:urmai i Peak () Inkerface
@ Utilization 7) GDelay () Drop %
CoS Classes : | All -
[
el el el el el el el el el el el el
Ty ] I I I I I I I 1 I I
=] [a1) ] ] ] (] [ ] ] ] ] —_
= o — ra k] -+ o [n4] | [mu] o =
&
Selected Period:  Planned Traffic
Start From: | 0&f01f2014 15:03 = (B
(Refers server time, Click to see server time)
Interval (AL least & minukes): |5 minukes
Fetch | Fum | | Close | | Help |

e The Planned period reflects the loading based on the bandwidth specified for each demand in the
demand file (this can be set to the peak payload per demand for a specified time interval, measured
and extracted by the hardware device's management platform).

e The Worst period (for the Normal traffic load option, based on the trafficload file) provides the traffic
loading supposing each demand is at its worst period (maximum value) among the 24 periods in the
traffic load file, even though these could actually occur at different times. For router modules, with
actual measured interface traffic, the Worst period (for the Interface or Tunnel option), will show the
highest value of the 24 periods.

¢ Following the Planned and Worst periods are up to 24 periods based on the “trafficload” file that is
referenced to from the specification file.

The program will follow the hardware's implementation of demand routing and bandwidth allocation as
in the Path Provisioning mode of simulation. Once the demand path is established, traffic load
information for each demand is then loaded onto the network model. By using measured traffic,
snapshots of actual trunk utilization can be analyzed and a better understanding of the impacts under
failure conditions can be gained.



Field Description

Normal Displays link utilizations based upon the routing of specified demand/flow traffic. In the
specification file, traffic input is read in from the “trafficload” file. Note: For the Router module with
MPLS enabled features, if Layer 2 (tunnel layer) is selected, then selecting Normal in the Load/Util
window displays the link utilizations based upon the routing of tunnel traffic that is specified in the
“tunnel trafficload”, or “T_trafficload” file in the specification file. This file has a format similar to that
of the “trafficload” file.

Peak This option is only applicable after you have run a failure simulation scenario (and has checked the
Include Traffic Load box in the Simulation Script Options). Peak represents the highest (or worst) link
utilization loading experienced by each link, depending on the rerouting of the demand/flow traffic
after any single failure. If 24 periods of traffic are specified in the “trafficload” file, then the peak
utilization will represent the worst loading on that link during each of the 24 periods.

Utilization | Displays the results as link utilization on the topology map. This is the default.

QDelay Displays the results as queuing delay (in milliseconds) on the topology map according to a custom
map legend.

Drop Displays the results as drop percentage on the topology map according to a custom map legend.

Run Starts running the animation that is reflected on the topology map. Begins with Planned, Worst, and

is followed by the periods of traffic.

Router-Specific options



Field

Interface

Tunnel

CoS

Start
From...
Interval
and Fetch

Description

This option appears if you are in the Layer 3 (Demand) view and displays link utilization based on
traffic actually measured at the interface. This differs from the “Normal” option which displays the
utilization based on the routing of traffic associated with end to end flows. Interface traffic can be
read from two sources:

1. User-supplied “ingress” or “egress” files, also referred to in the specification file as
“interfaceLoad_in" and “interfaceLoad_out”.

2. Traffic saved in a database when performing a traffic collection in the Live Network using the
Traffic Collection Manager.

After selecting a start date and time interval, click Fetch to fetch the data from the database.
Subsequently, you can replay the historical traffic using the Run button or view the traffic in chart
format via the Traffic Load > Measured Interface Traffic menu.

This option appears if you are in the Layer 2 (Tunnel) view and displays tunnel traffic at an
interface. Tunnel traffic can be read from two sources:

1. Traffic data from a tunnel trafficload file (referred to as “T_trafficload” in the specification file)

2. Traffic saved in a database when performing a traffic collection in the Live Network using the
Traffic Collection Manager.

After selecting a start date and time interval, click Fetch to fetch the data from the database.
Subsequently, you can replay the historical traffic using the Run button or view the traffic in chart
format via the Traffic Load > Tunnel Traffic on Link menu.

By choosing a particular Class of Service (CoS), the traffic statistics associated with that CoS can be
displayed. This information is based on demands, as opposed to measured data.

This panel is only applicable for router modules if you have run traffic data collection live, using the
Traffic Collection Manager, which stores the traffic data into a database. You should first select a
starting date and then an interval between the periods, and then click ‘Fetch’ to load the
summarized traffic data. After the status message says “Traffic Ready,” then, click on ‘Run’ or open
the appropriate traffic chart (Traffic Load > Measured Interface Traffic for interface traffic or Traffic
Load > Tunnel Traffic on Link for tunnel traffic.



Traffic Menu: Trending

IN THIS SECTION

Network Files | 234
Other Files | 236

The Trending feature takes as input several periods of traffic data or other data. It then performs a
“trending” by extrapolating future growth of the data based on a number of user-supplied parameters
such as the type of regression to use, the number of points to extrapolate, and so on. The Trending data
input file can be any one of four different Network Files. Alternatively, you can specify a separate input
file by choosing Trending > Other Files. The file formats for all these input files are described briefly
below.

Network Files

Interface Traffic (Ingress or Egress)

To use Paragon Planner interface files as the trending input, select Traffic > Trending > Network Files >
Interface Traffic (Ingress) or Interface Traffic (Egress). These files list period-by-period ingress or egress
traffic per interface.

In order to use these files, they must first have been loaded into your network project. To do so, select
File > Load Network Files, select the Traffic tab, and press the ingress or egress buttons, respectively.
Typically a user only specify one of these.

The file format is as follows:

NodeID Interface Direction - Periodl Period2 ... PeriodN
MYNODE1 POS@/1 A2Z © 100200112 100601536 100400624 100601536



An alternative file format for interface traffic is:

LinkName Direction - Periodl Period2 ... PeriodN
MYLINK1 A2Z - 100200112 100601536 100400624 100601536
MYLINKT Z2A - 5003683 5003822 5284499 683344

The units for the period data should be in bits per second.

NOTE: The NodelD must match the ID or name of one of the nodes in the muxloc file.

Trafficload (Demand, NCP, ...)

To use Paragon Planner trafficload files as the trending input, select Traffic > Trending > Network Files >
Demand Trafficload. These files list period-by-period traffic per demand.

In order to use these files, they must first have been loaded into your network project. To do so, select
File > Load Network Files, Traffic tab, and press the “trafficload” button.

The file format is as follows:

DemandID Direction - Periodl Period2 etc..
MYDMD A27 - 100200112 100601536 100400624 100601536

Or, for those with Node-Card-Port (NCP) data:

FromNodeCardPort Direction - Periodl Period2 etc..
ToNodeCardPort Direction - Periodl Period2 etc..
MYNODE.P3C5 A2Z - 100200112 100601536 100400624 100601536

Tunnel Trafficload (IP/MPLS only)

To use Paragon Planner tunnel trafficload files as the trending input, select Traffic > Trending > Network
Files > Tunnel Trafficload. These files list period-by-period traffic per LSP tunnel.

In order to use these files, they must first have been loaded into your network project. To do so, select
File > Load Network Files, Device Specific tab, and press the trafficload button.

The file format is as follows:

NodeID:TunnelName Direction - Periodl Period?2 etc..
MYNODET :MYTUNNEL290 A2Z - 100200112 100601536 100400624 100601536



Peak Link Traffic

To use peak link traffic load files as the trending input, run an exhaustive single element failure from
Simulation > Predefined Scenarios on a network with a trafficload file, which contains the period-by-
period traffic per demand. For example, the sample fish network (/u/wandl/sample/IP/fish/spec.mpls-
fish) could be used to generate a peak link traffic load since the specification file references a trafficload
file with the period-by-period traffic per demand. After the failure simulation is complete, a file named
PeakLinkLoad.< runcode> is created, which indicates for a particular link and a particular period, what
was the worst link load experienced for that link, taking into consideration all of the single element
failure simulations that were simulated on the network.

The file format is as follows:

Node, Interface,Dir,Peak_1,Peak_2,Peak_3,Peak_4,Peak_5,Peak_6,Peak_7,Peak_8,Peak_9,Peak_10,
ATL,LINK1,A2Z,25952066,31141680,36327296,36327296,41518908,46707684,46707684,36327296,31141680, 25
952066,

Load the file using Traffic > Trending > Network Files > Peak Link Traffic.

Other Files

You can also load trending input from any file, as long as the file has the proper file format. To load this
file, select Traffic > Trending > Other Files. You are prompted to specify the location of the trending file.
The recommended name for this file is trending.trending. <runcode>..The file should contain the
<COLUMNS>, <START>, and </START> tags and have the following comma-separated format:

<COLUMN>
TextColName1,TextColName2, ..., TextColNameN,DataColName1,DataColName2, . ..,DataCol
NameM

<START>

MYDATUM1,Chicago, 100200112,100601536,100400624,100601536

MYDATUM2, Jersey, 20045634,20135645,22411224,21044335 # This is a comment
</START>

NOTE: Files in this comma-separated format can be opened automatically in Report Viewer. Go
to the File Manager window, right-click on the file, and choose “Open in Report Viewer” from the



drop-down menu. The <COLUMN>, <START>, and </START> tags enable the file to be read by
the Report Viewer.

Trending Window

Once the data is read in, Paragon Planner will filter out any entries with too many “Undetermined
Values” such as negative numbers. How many undetermined values is too many? In Paragon Planner, for
a polynomial of degree k, the data should have no more than k undetermined values. For linear or
exponential, the data should have no more than one undetermined value. Otherwise, the data is omitted
from the analysis.

NOTE: For traffic files generated by the Paragon Planner, a “-1” is often used for a period lacking
traffic data. In Trending, a “0” zero value is also ignored so that the projection from the non-zero
values are more accurate.

Figure 105: “Bad” or “Undetermined” Data Points are Discarded
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Figure 106: Trending Window
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Column

Node, Intf (gray)

Pdn (white)

Pdntrend (red)

RSq (green)

GoodDataCt (blue)

Description

The node and interface to which the traffic data points and trending data points in that row
correspond. Link indicates the corresponding link name and Type indicates the trunk type.
Note that other fields may be present in this gray section, depending on the.input data.

These columns contain the period data based on your Paragon Planner data file or
trending.<runcode> input file.

These columns contain the forecasted data. The number of trending data points is based on
the specified # to Forecast.

The coefficient of determination. It is a value between 0 and 1, where 1 indicates that the
curve fitting matched the data perfectly.

The number of good data points included in the trending analysis. Bad data points (typically
values of "-1" or “0”) are automatically omitted.



Figure 107: Trending Chart for a Particular Interface
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Field Description
# to Forecast The number of data points to forecast. Press <Enter> after specifying a value. The trending
table will then automatically update.

Linear / The type of regression to be performed.
Exponential /
Polynomial
Data Data can be viewed and processed in two forms: either Raw (raw traffic data numbers) or

Util (Raw/BW) (the traffic utilization on each trunk). The Util view is the more useful and
interesting.



(Continued)

Field

Moving Average

Adv Filter

Show Chart

Highlight All

Exclude Pds

Save

Save as bblink

To Traffic Matrix

Description

This number is used to “smooth out” any outliers in the data. If the value is set to “3”, then
each data point is the arithmetic average of the traffic value in the previous, current and
next time interval of the original data. If the value is set to “5” then each data point is the
average of the values of the two previous, the current, and the two following time intervals
in the original data.

Allows you to display only selected rows in the table. For example, if your Data value is set
to Util (Raw/BW), then you might query for Pd5trend > 1.0 to identify where traffic may
exceed trunk capacity five periods in the future.

Displays a line chart of the raw and trending data points corresponding to the selected row
in the trending table. See Figure 107 on page 239 .

Highlights all entries on the Map. Highlight all nodes in the table, all nodes and links in the
table, or all links in the table along with their end nodes.

Allows you to exclude selected periods of data from the regression.

Saves the current table into a TRENDING. <runcode> file.

Creates a link file (in bblink format), called TRENDING_BBLINK. <runcode>, from the rows
currently displayed in the table.

Generates the corresponding traffic matrix input file, TRENDING_TMATRIX.<runcode>, for
the specified trending period. Use this file as an input to the Traffic Matrix feature,
accessible via Design > T-Solve in a multitude of traffic engineering studies.

For more information on this feature, see "Traffic Menu: Growth" on page 241.



Traffic Menu: Growth

The Growth option in the Traffic menu can be used as a simple way of projecting future network growth.
This tool allows you to model the existing network in terms of projected future growth.

This network growth feature is not cumulative; the percentage growth is always applied to the original
demand bandwidths. If the growth feature is invoked twice, each time with 200 percent, for example,
the result after the second increase is still a doubling, rather than a quadrupling, of the original demand
bandwidth.

Figure 108: Adjusting the Network Growth Factor
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You can use the slide rule in the Growth Options window to increase the bandwidth of existing demands
in the network as a way to project future network growth. Using the slide rule, the current demands in
network can be multiplied by a factor anywhere from O percent to 1000 percent.

Traffic Menu: Traffic Aggregation

IN THIS SECTION

Performance Data Indices Used for Aggregated Queries | 242
Generate Options | 243

Range Options | 244

Series Options | 244

Statistic Options | 244

Interval Options | 245



Output Directory and Output Runcode | 245
Load New Data | 246

The Traffic Aggregation function allows extraction of performance data from the analytics database for
use in modeling, simulation and trending. You can extract different types of performance traffic into
their relative files using a variety of timeframes and traffic statistics.

Make your selections in the Traffic Aggregation window and click OK. The traffic aggregation process on
the server requests the analytics database to aggregate the performance data according to the
selections you provided, and the data are stored to the corresponding traffic files (interface, T_trafficload
and trafficload). When complete, the window remains open. You can close it by clicking Cancel or via the
window actions used by the interface for the operating system.

The information in the following sections should help you define a traffic aggregation that suits your
purpose.

Performance Data Indices Used for Aggregated Queries

The analytics database stores performance data in a series of indices. The default index for a
measurement contains each measurement to a granularity of 5 minutes. High frequency measurements
collected through Telemetry are stored in a special index used mostly for real-time traffic graphs. The
high-speed (raw) index is then recorded as an average into the default index. The default index has a
configurable retention period which is initially set to 90 days with this setting.

The measurements are then rolled up hourly with average and 90 percentile aggregations, and this
rolled-up index is used for more scalable queries on the performance data. In addition to the hourly
index, the default index is also rolled up into daily, weekly and monthly indices to support queries over
longer time frames. The rollup indices are initially set to 1000 days.

The performance data indices are summarized in Table 34 on page 243.



Table 34: Performance Data Indices

Index Interval Purpose Retention
Raw Same as collection for high ¢  Temporary storage for Hard set to 1 day
frequency measurements traffic graphing

such as Telemetry (30

seconds, for example). e Averaged aggregation over
five minute periods into the
default index

Default = Measurement frequency or | o Base for rollup indices In northstar.cfg:
five minutes, whichever is es_log_retention_days = 90
less. o Used for extended period
traffic graphs
Rollup Rolled up on an hourly, Produces increased In northstar.cfg:
daily, weekly, and monthly performance and reduced es_log_rollups_retention_days =
basis. storage needs for traffic 1000

reporting and modeling.

Generate Options

The generate options are:

Interface Traffic

Interface CoS Traffic

Tunnel Traffic

Demand and trafficloads

Click the check boxes to select as many of these options as you want, except that Interface Traffic and
Interface CoS Traffic are mutually exclusive. They use the same interface traffic files for output, so you
can only have one or the other. If selected, Demands only returns values if demands have been collected
via Paragon Pathfinder task collection.



Range Options

Click any one of the radio buttons to select that range. Begin Time and End Time formats are a little
different, depending on what you choose for the Series:

If Series = hour of day aggregation, the Begin Time and End Time are specified as just the date
because all hours of the specified days are used.

If Series = time series, the Begin Time and End Time are specified as date and time.

Series Options

Two options are available for Series:

Hour of day aggregation

In this type of series, all measurements are aggregated by hour of day, potentially across multiple
days. For example, by specifying “last week”, you would get the average or 90 percentile traffic for 9
- 10 PM. All measurements between 9 and 10 PM from all seven days would be considered in the
calculation of the statistics. This is useful for calculating a typical day across a date range. Each
parameter would have 24 values in the resultant traffic file, corresponding to each hour in the typical
day. The usefulness of this series type diminishes as the time range becomes longer because the
impacts of traffic trend over the time range would skew the statistic to represent either the time
range mid-point or end-point for average and 90 percentile statistics, respectively.

Time Series

This is a typical series which will have a data point for each interval between the selected start and
end times. There is a maximum of 168 data points that can be utilized in simulation. For example, you
could do hourly statistic calculations for seven days (24 x 7 = 168), but if you were interested in a
time series for a month of data, you would need to use a courser interval such as daily or weekly.
This should be a consideration if the data is to later be trended as a forward projection, to ensure the
projected data does not result in exceeding the maximum of 168 data points per parameter. The
system does give you an error message if you enter settings that would result in more than 168 data
points.

Statistic Options

Use the drop-down menu to select from the two traffic statistics options offered. The two options
enable different objectives in modeling:



e Average: Provides a representation of the typical traffic during a period.
e 90 percentile: Provides a representation of peak traffic during a period.

For recent time ranges (last day or week), there may not be a large difference in these values for hourly
interval time series or hour of day aggregation. For daily or larger intervals, 90 percentile might be a
better choice for capacity planning and average might be a better choice for trending.

Interval Options

Use the drop-down menu to select an Interval. Based on the Series type, data points will represent the
selected interval as shown in Table 35 on page 245.

Table 35: Data Points by Series Type and Interval

Interval Series Type: Hour of day aggregation Series Type: Time series
1 hour v v
1 day v
1 week v
1 month v

For example, a one-week interval applies to Time series, but not to Hour of day aggregation. Recall that
a maximum of 168 values per parameter can be retrieved in a time series. Hourly data must be used for
hour of day aggregation.

Output Directory and Output Runcode

The output directory defaults to the directory where the model is stored on the server. Click Browse to
select an alternate directory.



NOTE: Do not extract traffic aggregations to directories used by the Paragon Pathfinder (/opt/
northstar/data).

The output runcode defaults to the current model’s runcode.

Load New Data

If selected, the extracted performance files are read into the current model.

Using the Generated Trafficload File

The status window will indicate when the traffic files are successfully processed and aggregated.
Generating the interface/tunnel traffic files should be very quick, in a matter of minutes or less.
Corresponding Paragon Planner format ingress and egress interface traffic files or tunnel traffic files are
generated and loaded into the system if you check the Load traffic data checkbox. Once completed, click
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on the Finish button. Select Traffic > Traffic Load to display the Load/Util window. For MPLS-enabled
networks, the proper layer (Layer 2 or Layer 3) should be selected.

Figure 109: Interface Traffic Load Files Generated
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In the Load/Util window, select the Interface radio button (or Tunnel for tunnel traffic in MPLS-enabled
networks). Then, click the Run button for an animated 24-period link utilization display. The 24 periods
represent 24 hourly values. The slider can also be dragged to a particular period, to view the




corresponding link utilization on the topology map. The second “tick” on the slider shows the Peak
period. Peak represents the highest value of the 24 periods.

Figure 110: View the Utilization on the Map over 24 Periods
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Right-clicking on a link will also display the 24-hour interface traffic bar chart.

e To display the corresponding traffic bar chart for interface traffic, select Traffic Load > Measured
Interface Traffic from the popup menu.

¢ To display the corresponding traffic bar chart for tunnel traffic, select Traffic Load > Tunnel Traffic on
Link from the popup menu.



To display a detailed report of the traffic and utilization for each interface for each 24 hour period, click
on Interface Traffic Reports > Interface Traffic Report in the Report Manager.

Figure 111: 24-period Aggregate Data on a Link
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This section describes how to use the Paragon Planner conversion utilities.

Paragon Planner takes selected types of traffic data as input and converts them into a concise binary
format, organized by “daily directories”, that is suitable for rapid aggregation using any of a choice of
statistical computation methods. For example, it allows you to "roll-up" a week's worth of data into 24
hourly periods and display the hourly utilization based on the 95th percentile.
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The following explains the structure of the daily directories. These directories have names in date format
such as:

MAR19.01
MAR20. 01

In each of these daily directories is a number of files- one file per device for which traffic was collected
on that particular day.

For example,

>1s MAR19.01
ROUTER1T ROUTER2 ROUTER3

Thus, if interface traffic for Router1 was collected on all three days, there is a binary file for Routerl
under each of the three daily directories.

Related Spec File Parameters

To save the imported traffic from a particular network scenario, select File > Save As, for example, to
save any new configurations to the specification file.

To view the text version of the spec file in the File Manager, right click on the newly created (or
refreshed) specification file and select Spec File > Modify Spec, or Edit from the popup menu .

The traffic-related specification file parameters are described here.

Interface Traffic Description
Parameters
ingress 24-period incoming, or ingress traffic measured on the interface. This corresponds to the

ingress file. When importing traffic, the ingress file is automatically named
interfacei.runcode and placed in the trafdir.

egress 24-period outgoing, or egress traffic measured on the interface. This corresponds to the
egress file. When importing traffic, the egress file is automatically named interface.runcode
and placed in the trafdir.

trafdir The location of the interface traffic daily directories repository. This is also called trafdir.



Tunnel traffic Description

Parameters

t_trafficload 24-period tunnel traffic file. This corresponds to the tunnel trafficload parameter in the
Device Specific tab. When importing traffic, the tunnel traffic file is automatically named
tunneltraf.runcode and placed in the tunnelrafdir.

tunneltrafdir The location of the tunnel traffic daily directories repository. This corresponds to the

tunneltrafdir parameter in the Device Specific tab.

Addendum: Traffic Data Input Files

This section contains information on the traffic-related input files and their format. Many of these files
are very similar: each line begins with some element ID, such as that for a demand, tunnel or interface.
This is followed by a series of numbers representing the measured or estimated traffic statistics over
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that network element across many periods (for example, 24 hourly periods of traffic measurements
collected on an interface.)

Figure 112: File > Load Network Files Window

Read Files - gE [z
Spec File Directory: |I5pa|:eMandIIaampleIrnuterIﬂahI | Browise...
\\Generall| | Desigr Parameters)| Network Files
Lel 2
T T AR TTL LU T a4
offloc nane —
- offsite nane
= Traffic Files
devicedir nane
egress interface.mpls-fish
ingress interfacei.mpls-fizh
t_trafficload nane
trafiir Ispacetwandlisamplelrouterifishi
trafficload trafficload.mpls-fish
= tunneltrafdir nane
= Discrete Event Simulation Files
thedata nane
~ ffepattern nane
El Ciowico Snocific Filoo i
The egress file containg edress traffic ofthe network's interface load. Egress traffic
specifies traffic that is going out of the netwark's interfaces.
interface.mpls-fish & .ﬁ. Browse... Resat
Close Help
Spec File > Load Network Files dparam equivalent Description
trafficload trafficload= Demand traffic file
trafdir trafdir= Location/path of ingress and egress files

ingress interfaceLoad_in= Interface traffic file



(Continued)

Spec File > Load Network Files dparam equivalent Description

egress interfaceLoad_out= Interface traffic file

Sample Demand Traffic Input (“trafficload” File)

The following shows a sample of a trafficload file containing 24-period traffic load data for a demand
with demand ID RNodeltoNode3 originating from Nodel. Note that the “UNIT=1" line is important
because it establishes the unit of all other numbers in the file. In this case, the unit is 1 bit per second.
Some may want to change this to “UNIT=8" depending on the data.

UNIT = 1 # bit per second
Nodel:RNodeltoNode3 A2Z - 5.000M 5.5M 5.833M 2.222M 1.0M 300K 400K 2.0M 6.0M 8.0M 11.25M 15.5M
14.054M 9.053M 6.8M 3.1M 2.0M 1.8M 500K 400K 400K 800K 1.9M 3.1M

The format for each demand entry is:

NodeID:DemandID Direction FrameSize P_01 P_02 P_03 P_04 P_05 P_06 P_07 P_08 P_09 P_10 P_11 P_12
P_13
P_14 P_15 P_16 P_17 P_18 P_19 P_20 P_21 P_22 P_23 P_24

Sample Interface Traffic Input (“interface” Files)

The following is an example of an interface egress file. The ingress file has the same format.

UNIT = 1 # bit per second

LDN2600 Ethernet@/@ A2Z @ 7669 7580 7555 7567 7495 7582 7608 7533 7533 7283 6841 -1 -1 -1 -1 -1
-1 -1 -1

-1 -1 -1 -1 -1

LDN2600 Seriale/e A2Z @ 58 58 58 58 58 58 61 58 58 58 58 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1



The format for each ingress or egress entry is:

NodeID Interface Direction Framesize P_01 P_02 P_03 P_04 P_05 P_06 P_07 P_08 P_09 P_10 P_11 P_12
P_13
P_14 P_15 P_16 P_17 P_18 P_19 P_20 P_21 P_22 P_23 P_24

Note that a “-1” can be used as a placeholder indicating that no traffic was measured on the interface for
that particular period.

Note that special unit characters such as “K” and “M” are not supported in the interface files at this time.

Also note that the Paragon Planner will use egress values if they are available. In situations where there
is no egress value for a particular period, the software will check the measured ingress values and use
the corresponding value. For example, for a link from Node A -> Node Z, if no value was measured for
the egress traffic from Node A on the interface from Node A to Node Z, then the Paragon Planner will
check the ingress value at Node Z along the same link and use that as an approximate value.

Addendum: Accessing Traffic Charts

Viewing Traffic on a Link

There are many ways to access traffic charts. To view the traffic on a particular link, you can right-click
on the link in the Map window and choose an option from the Traffic Load submenu.

NOTE: For MPLS-enabled networks, there is a very similar Tunnel Traffic menu in Layer 2. The
descriptions are identical to those of Demand Traffic; simply replace “Demand” with “Tunnel” in
the table below.

Field Description

Demand Traffic on Link Brings up chart of Demand Traffic load on this link (takes into account all
demands routed on this link)

Demand Traffic Load by CoS Brings up Demand Traffic load chart that partitions the traffic by Class of
(Router only) Service (CoS) for viewing.
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Field Description

Demand Traffic Load/BW Ratio Brings up the Load/BW Ratio Charts that shows Demand Traffic load over

Link BW.

Measured Interface Traffic Brings up Interface Traffic Load chart for this link.

Interface vs Demand Brings up chart that compares Interface and Demand Traffic loads on this
link.

Alternatively, you can open the Links window by selecting Network > Elements > Links. Right-click a
given link. From the popup menu you can then select Traffic Chart > Measured Interface Traffic or
Demand Traffic Load by CoS if you have a router network. Otherwise, you can select the Demand Traffic
on Link chart.

Viewing Traffic on a Demand

To view the traffic on a demand, select Network > Elements > Demands. Select the Demands you wish
to view. Right-click and select either Show Traffic Load or End to End Delay.

Field Description

Show Traffic Load for Single Demand = Shows the traffic load chart for the selected demand in the Demands

window.
Show Traffic Load for All Demands Shows the sum of the traffic load for all demands for each period.
E2E Delay for Single Demand Shows the computed end-to-end delay for the selected demand in the

Demands window.

E2E Delay for All Demands Shows the average end-to-end delay for all demands for each period.
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Addendum: Interpreting the Traffic Charts

In the Computed Load from Demand Traffic window. the computed load is the traffic load on the link
determined by the load on the demands that are routed over the link. The load on each demand for each
of a number of periods is read from the trafficload file. Paragon Planner computes the placement of the
demands, and then reads the trafficload file to determine the traffic load on any particular link. If there
are multiple demands traversing a link, then the Link Traffic Chart displays the sum of the demand loads.

Figure 113: Traffic Load on a Link
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e Planned: The first column represents the total bandwidth of the demands (from the demand file) that
are routed over the link.

o  Worst: The second column represents the highest link load among the following periods.



¢ Load: Represents the link load (up to 24 periods) based on the information given in the trafficload
file.

e Peak: If failure simulation is performed, peak is the highest link load during failure.

Customizing the Traffic Chart

e The style of the chart can be toggled between a Bar chart and a Line chart, by pressing Bar/Line.
o The colorof the traffic chart can be edited by right-clicking on the graph and selecting Properties.

e The period names at the bottom of the chart (excluding those for the Planned and Worst) can be
customized for just the demand traffic charts by editing the optional “FORMAT” line in the original
trafficload file. The “FORMAT” line looks similar to the following, and should be placed above the
first line of actual traffic data:

FORMAT DIR FRAMESIZE Per1 Per2 Hour3 Hour4 5 6
Fo001 A2Z - 6852 2083 1372 2749 1183 1242
FOOO1 Z2A - 18795 11703 4578 5065 4748 6155

Understanding Planned Load

The planned value is the sum of the bandwidth allocated on the link for every demand of the demand
file. In the router environment, it is the same as the sum of the demand bandwidths. For ATM networks,
it is the sum of the CAC. If an overbooking factor is set, the CAC value is modified. Planned bandwidth is
the bandwidth from the router’s or switch's routing point of view.

Understanding Worst Load

The worst load is simply the worst traffic load experienced on the link over all periods for which traffic
load data is supplied.

Understanding Peak Load

The peak is displayed only after performing a failure simulation. Peak load is based on the maximum
utilization of a link resulting from the latest failure scenario.

After running a failure simulation script, Peak load values become available in the traffic charts. Each
simulated failure results in the rerouting of demands around that failure. The new routes, carrying each
demand'’s traffic load, are reflected in the peak load values on the links. Paragon Planner will compute
the worst-case or peak load experienced on every link over each period over the course of the entire
failure simulation sequence.

The Peak load in the Worst (second) column, reflects the value of the period with the highest peak load.
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The peak planned load is also higher than the normal planned load because of the additional bandwidth
required for demands rerouting over the link.

Figure 114: Traffic Statistics on Link After Running a Failure Simulation
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Load/BW Ratio Charts

The Load/BW Ratio chart is accessed by right-clicking on a link and choosing Traffic Load > Demand
Traffic Load/BW Ratio from the popup menu.

Period (X-Axis)

e P stands for planned and indicates the load based on demand bandwidths, as defined in the demand
file.

o W represents the load during the worst period based on demand traffic load values from the
trafficload file.



Periods represent the load information based on demand traffic load values from the trafficload file.

Ratio (Y-Axis)

Load/BW: Normal Load/Total Demand Bandwidth

Load Util: Normal Load/Link Bandwidth; The utilization of the link for a particular period based on
the traffic load of those demands routed over it, as given in the trafficload file.

Peak/BW: Peak Load/Total Demand Bandwidth (experienced during Failure Sim)

Peak Util: Peak Load/Link Bandwidth; The peak utilization is the highest bandwidth utilization
obtained at the chosen link during the failure simulation. It will only be displayed after running a
failure simulation, such as a scripted exhaustive node failure.

Figure 115: Load/BW Ratio Chart After Failure Simulation
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Measured Interface Traffic Chart




The Interface Traffic chart can be accessed either by selecting Traffic Chart > Measured Interface Traffic
from the right-click menu of the Netlnfo window Link tab, or by right-clicking on a link in the Map and
selecting Traffic Load > Measured Interface Traffic.

This chart displays the measured interface load from the interfacelLoad _in (ingress) or interfacelLoad_out
(egress) files. Note that this is different from the traffic load of demands routed over a link, where the
load is derived based on the load on the demands routed over the link for a particular period. Rather, it
represents the actual load measured at the link interface.
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Inventory Menu Overview
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Importing CLI Output Commands | 263

Importing and Saving | 264

The Hardware Model, accessed through Inventory > Hardware Inventory, allows you to view details
about the equipment in a network. There are two ways to view Hardware Model information: through
the Hardware Inventory window, or through the Equipment Cost window. The Hardware Model feature
can be very helpful to the network planner who is concerned about equipment cost and availability. This
feature can also be used to keep track of equipment in an existing network, including information such
as number of available ports, operating system versions, part numbers, serial numbers, and other
inventory related operations. Link and card failure simulations can also be launched.

Components of the Hardware Model

e Hardware Inventory deals with detailed equipment reporting, equipment utilization view, hardware
capacity management, and hardware CapEx.

e Hardware Equipment Costs is used to associate costs with specific hardware equipment, and is the
major financial input table for the Hardware Inventory Capex report. For information on how to
assign costs to hardware, refer to "Hardware Equipment Cost" on page 303.

Collecting Hardware Inventory

Hardware inventory information can be derived from CLI commands, which can be either automated in
from the Network Config Data Collection task or Scheduling Live Network Collection task, or collected
through a third-party tool.



Importing CLI Output Commands

Hardware information can be imported from text files containing CLI output commands. The following is
a partial list of currently supported CLI output commands:

Juniper Networks Junos OS

e show version

o show chassis hardware

Cisco I10S

e show version

show hardware

show diag

e show env all

show idprom backplane
Cisco XR

e show version

¢ show hardware

e show diag

Cisco Catalyst

e show module

Nortel Passport

e show config

Alcatel SR

e show mda

Riverstone

o show version

Configs Collected by Rancid

e Cisco IOS



e Juniper Networks Junos OS

e Tellabs

Importing and Saving

Hardware information from a live network can also be imported on-demand via real-time SNMP and CLI
outputs. Previously saved SNMP, CLI, and CSV data can also be imported for an offline network. To do
this, open the Hardware Inventory window by selecting Inventory > Hardware Inventory. Then, at the
bottom of the window, there is a toolbar with Load and Save buttons.

Clicking on the Load button displays several options.

Field Description

Collect Inventory Collect real-time SNMP and CLI data from a live network.
SNMP Output Load previously saved SNMP output.

CLI Output Load previously saved CLI output.

Node/Shelf/Card Descriptions Load previously saved CSV data.

Clicking on the Actions > Save button displays several options.

Field Description

Current Report This saves the current report displayed in the right pane. Different reports
can be selected via the tree in the left pane.

All Node/Shelf/Card Descriptions = Saves node/shelf/card descriptions for all devices in the network to a CSV
file.

All Hardware Information for Save the current complete hardware profile for future comparison.
Comparison

Hardware Inventory File Format



When using CLI to collect the hardware information, the raw data files are saved into directory /u/
wandl|/data/collection/.LiveNetwork/equipment_cli. The file naming convention is “<Router Profile
Name>.equipment_cli”.

When using SNMP to collect the hardware information, the raw data files are saved into directory /u/
wandl|/data/collection/.LiveNetwork/equipment. The file naming convention is “<IP>.iftable” and
“<IP>.snmp”.

From the raw data, hardware inventory files are generated into XML format in directory /u/wandl/data/
livenetwork_output_directory/swconf.x. The file naming convention is “<hostname>.xml”". Each
collection method may have slightly different raw data values which is dependent on the device vendor.
Also, SNMP may not be able to collect certain data fields that CLI can collect and vice versa. If both
SNMP and CLI collection methods are used, the combined data collected will compliment each other in
the hardware inventory files.

From the hardware inventory files, hardware inventory reports in CSV format can be generated by
running Task Manager > Hardware Inventory Reports. The output directory of the reports can be
specified along with options to timestamp the file names and save the reports to the Web. The CSV
reports created are listed in the table below.

Filename Description

ROUTER_LIST Device, IP, Vendor, OS, Chassis, Hardware ID, Boot Image, ROM, Memory,
Processor

CARD_LIST Card ID, Part #, Serial #, Port count

INTF_LIST Interface, IP, Status, Physical Address

TRANSCEIVER_LIST Transceiver

MISC_PART_LIST Miscellaneous parts: power supply, fan, display

HW_CAPEX_REPORT Cost, Part Type, Component Name grouped by Device

HW_PARTS_REPORT Cost, Part Type, Component Name grouped by Part Type

HW_DEVICE_USAGE_REPORT Card Usage, Port Usage grouped by Device



(Continued)

Filename Description

HW_LINECARD_USAGE_REPORT | Card Usage, Port Usage grouped by Card

HW_IC_REPORT Integrity Check report for unknown or unsupported data

Inventory Menu: Hardware Inventory

IN THIS SECTION

Hardware Inventory Summary | 267
Devices List | 267

Line Cards | 271

Physical Interfaces | 274
Transceivers | 276

Miscellaneous Parts | 279
Extensive Parts List | 281
Hardware Integrity | 281

Device Usage | 282

Line Card Usage | 284

Customer Usage | 285

When a network is loaded, the Hardware Inventory window can be opened by selecting Inventory >
Hardware Inventory. This window contains reports and information about the hardware at each
individual node in the network. When viewing hardware information at a specific node, the Hardware
Inventory window is split into two panes. The left pane displays a tree listing all existing hardware
(routers) and summary reports. The right pane displays the content of the item selected in the left pane.



I Hardware Inventory Summary

When the Hardware Inventory window is opened, the right pane will show a summary of all the
equipment in the network. This provides a quick tally of the number and types of devices and interfaces

in the entire network.

Figure 116: Hardware Inventory Summary
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Devices List

Selecting Devices in the left pane displays a Device List report in the right pane. The saved report’s
filename starts with “ROUTER_LIST.” Clicking on the small icon to the left of Devices in the left pane will
expand the tree to show a list of routers in the left pane. These devices can then be individually selected

267



to display a detailed Equipment View in the right pane for the selected router. See "Equipment View" on

page 289 for more information

Figure 117: Device List
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Various actions can be executed by right clicking on a row and selecting an item from the popup menu.
The items in this popup menu are available for many reports in the Hardware Inventory window, though

not all reports will contain all items.

o Node Detail: Brings up a Node window with detailed information about the node in the selected row.

¢ Highlight: Highlights the relevant node in the Map window.

¢ Show Config: Opens the router configuration file for the relevant node if such a file is available.

e Show Equipment: This will open the Equipment View window for the relevant node.
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The Table Options window can be opened by right clicking on a row in a report and selecting Table
Options. This is useful for customizing the type of information displayed in the report.

Figure 118: Hardware Inventory Table Options
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Selecting Use image icons or checkbox if applicable displays image icons in vendor and status cells that
make the reports more visually pleasing and easier to comprehend at a glance. The Autofit to window
option will, when selected, automatically resize the column widths to fit the width of the report window.
In the bottom half of the Table Options window, specific columns can be either included are excluded
from the report.

Columns Description
Name Device name converted into Paragon Planner format
Hostname Device hostname

Vendor Device vendor (for example, Cisco, Juniper Networks)
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Columns

IP Address

Source

Chassis Type

OS Version

Contact*

Description

Location*

System Name*

Boot Image

Configuration Memory

Configuration Memory in Use*

Configuration Register*

Hardware Id

Hardware Version

Last Update by CLI

Description

Loopback IP address of the Device, typically the first one listed

Filename of collected configuration file

The type of chassis, for example, WS-C6509-E (similar to SNMP chassisType)

Operating System Version, for example, 12.2(53)SE

SNMP sysContact

Device description

SNMP syslLocation

SNMP sysName

The boot image, e.g, a string starting with flash:, bootflash:, diskO:

Non-volatile configuration memory (bytes)

Non-volatile configuration memory in use (bytes) SNMP nvRAMUsed

SNMP configRegister, for the configuration register value

Equivalent of SNMP chassisld, which defaults to the chassis serial number

Equivalent of SNMP chassisVersion, which defaults to the chassis hardware
revision level

The last time this file was updated by CLI collection
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Columns Description
Memory Equivalent of SNMP processorRam, based on RAM available to CPU (bytes)
Mgmt IP Addr The Management IP Address is the IP addressed used by Paragon Planner to

discover the device.

Model The Hardware model can provide additional detail not known from the vendor,
for example, by distinguishing JUNIPER and JUNIPER_EX

OS Family The operating system family (for example, 10S, Junos OS)

Processor The device processor, for example, PowerPC405

ROM System Version* SNMP romSysVersion, which contains the ROM system software version
ROM Version SNMP romVersion, which contains the ROM monitor version

NOTE: SNMP fields will not be populated if hardware inventory is collected by CLI.

Line Cards

Selecting Line Cards in the left pane displays a Card List with information on all the cards in the network.
The saved report name starts with CARD_LIST. This list is useful for managing aspects of a network related
to card capacity, such as keeping track of how many ports of a specific type are available in the network.



The Table Options (right-click a table header for this menu option) can be used to add additional

columns such as the Version.

Figure 119: Hardware Inventory: Line Cards

# Hardware Inwventory

j Hardware Inventary
t- Tl Devices

- i@ Physical Interfaces
- gl Transceivers

&; Misc, Parts

-4 Extensive Parts Lisk
% Hardware Integrity
% Device Usage

% Line Card Usage
% Customer Usage
[+ % Hardware CapEx

Card List

Mame Device Mame  Hostname  Device Wendor  CardId  Connes
10xGE ports{auto-assign by port)  [WMX00 w00 0o 10 -
10xGE ports{auto-assign by port)  [WMX00 w00 071 10 3
2x10GE ports{auto-assign by part) (WMX00 w00 0z 2

2x10GE ports{auto-assign by port) (VMX00 w00 03 2 E
10xGE ports{auto-assign by port)  [WMx10 w10 0o 10

10xGE ports{auto-assign by port)  [WMx10 w10 01 10 8
Zx10EE ports{auto-assign by port) (WMx10 w10 0z z

Zx10GE ports{auto-assign by port) (WMX10 w10 03 z

10xGE ports{auto-assign by port)  [WMXZ0 wmxZ0 0o 10

10xGE ports{auto-assign by port)  [WMXZ0 wmxZ0 071 10
Z2x10GE ports{auto-assign by port) (WMHZ0 wmxZ0 02 2

Zx10GE ports{auto-assign by port) (WMKZ0 wmxZ0 03 2

10xGE ports{auto-assign by port)  [WMX30 w30 0Jo 10

10xGE portsauto-assign by port)  WME30 w30 o1 10
Zx10GE ports{auto-assign by port) WME30 w30 oz z =

i P ; ; B | ' 3

Filter: |*

-

Seatch ][ F\d\;' Filter. ..

] 40 of 40 displayed

Actions » ]| Load » ” Ewents » H =5 Prirt... “ Refresh ] [ Close H Help ]

Column

Hostname

Name

Device Name

Device

Card Id

Connected

Description

Device hostname

Line card name, for example, WS-X6704-10GE

Device name converted into Paragon Planner format

Vendor Hardware vendor (Cisco, Juniper Networks)

Slot information, for example, S-0/1

Ports Number of ports that (a) have a corresponding
link in the model, (b) are operationally up, or (c) have
an |IP address defined on the interface
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(Continued)

Column

No. of Ports

Part

S/N

Version

Controller Mem.*

Cost (Estimated)

Description

Device IP Addr.

Device Mgmt IP Addr.

FRU Line Card FRU
Packet Mem.

FRU Route Mem.

L3 Engine

L3 Engine Type

Reserved Ports

Description

Number of physical ports

Line Card Part number

Line Card Serial number

Line Card Version information, for example, rev AO
ver 4

Controller memory (Cisco-specific field)

Estimated hardware cost

Line Card Description

Loopback IP address of the Device, typically the first
one listed

The Management IP Address is the IP addressed
used by Paragon Planner to discover the device.

Details related to the Field Replacement Unit (Cisco)

Details related to the L3 Engine (Cisco)

Number of Reserved ports, based on customizable
keywords found in the description.



(Continued)

Physical Interfaces

Column

Shutdown Ports

Description

Ports that have operational or admin status down

Top Assembly Number (Cisco ordering number)

NOTE: NMP fields will not be populated if hardware inventory is collected by CLI.

Selecting Physical Interfaces in the left pane displays an Interface List report listing all interfaces, their
status, and additional information in the right pane. The saved report’s filename starts with “INTF_LIST.”
The rows in the report can be sorted by clicking on the column header for the property to sort by.

Figure 120: Hardware Inventory: Physical Interfaces

P

# Hardware Inventony

i£| Hardware Inventory

=5

[+ Tl Devices

-2 Line Cards

B - BPhiysical Interfaces
-~ gl Transceivers

&,:, Misc, Parts

-4fp Extensive Parts Lisk
4% Hardware Integrity
4% Device Usage

4% Line Card Usage
4% Customer sage
[+ 75 Hardware CapEx

Inkerface List

Mame Device Mame  Hostname Admin Status  IP Address Physical Ad...
ge-0/0j0 WMKO0 w00 H 00:00:5E:00:53. |
ge-0/0f1 YIMXO0 ] ] 00:00:5E:00:53. | ]
ge-0/052 WIK00 w00 ] 00:00:5E:00:53.
ge-0/043 WIK00 w00 ] 00:00.5E:00:53.
ge-0/074 WIK00 w00 ] 00:00.5E:00:53.
ge-0/0)5 WIK00 w00 L] 00:00;5E:00:53.
ge-0/016 WIK00 w00 L] 00:00;5E;00:53.
ge-0/0)7 WIK00 w00 L] 00:00;5E:00:53.
ge-0/0)E WIK00 w00 L] 00:00;5E;00:53.
ge-0/0/9 W00 w00 =] 00:00:5E:00:53.
ge-0/1)0 W00 w00 =] 00:00:5E:00:53.
ge-0/111 W00 w00 =] 00:00:5E:00:53.
ge-0/1)2 WYHMO0 w00 =] 00:00:5E:00:53.
ge-0/1)3 WYHMO0 w00 =] 00:00:5E:00:53.
ge-0/1)4 WYHMO0 w00 =] 00:00:5E:00:53.
ge-0/1)5 W00 w00 =] 00:00:5E:00:53. | »
Filter: |* [ Search ][ Adw Filter. .. ] 240 of 240 displayed

| Actions k ]| Load » ][ Ewents » H & Prirt... ][ Refresh ] [ Close H Help ]
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Column

Name

Hostname

Device Name

Device Vendor

Card Id

Description

IP Address

Device IP Addr.

Device Mgmt IP Addr.

Admin Status

Physical Address

Aggregated Link

Bandwidth T

IPvé

MTU

Description

Physical Interface Name, for example, TenGigEQ/2/0/2

Device hostname

Device name converted into Paragon Planner format

Hardware vendor (Cisco, Juniper Networks)

Slot information, for example, S-0/1

Physical interface description

IP address of physical interface, if assigned

Loopback IP address of the Device, typically the first one listed

The Management IP Address is the IP addressed used by Paragon Planner to discover
the device.

Interface Administrative status (active, down, or unknown)

The address of the physical interface, based on intfmap Paragon Planner file.

Any associated aggregated link, such as PortChannel or Bundle-Ether

he physical interface bandwidth, for example, 100.0M

IPv6 address information (based on Paragon Planner intfmap file)

MTU information (based on Paragon Planner intfmap file)



(Continued)

Column Description

Media Type The Physical interface media type, for example,

ATM,BRI,BVI,Cable,Channelized
E1,DS,E1,Ethernet,FE,GE,0C3/STM1,T1,T3

Operational Status Interface Operational Status (active, down, or unknown)

Switchport Mode Switchport mode for layer 2 interfaces, for example, access or trunk

VLAN List of VLAN’s for this physical interface, for example, “22 100-102 105-108"
Transceivers

Selecting Transceivers in the left pane displays a Transceivers List with information on all the
transceivers or small form-factor modules of devices in the network. This report can be filtered and



sorted by clicking on the appropriate column headers. The saved report’s filename starts with

TRANSCEIVER_LIST_LIST.

Figure 121: Hardware Inventory: Transceivers

27 Hardware Inventary

= §E| Hardware Inventory
™ Devices
& Line Cards
& Physical Interfaces
& Transceivers
W, Misc. Parts
& Hardware Integrity
& Device Usage
& Line Card Usage
& Customer Usage
= Hardware CapEx

Mame

Cevice Vendor =
A

Transceivers

Part

HEMPAK-SR

T40-012045

HEMPAK-SR

T40-012045

SFP-5X

T40-011613

SFP-5X

T40-011613

SFP-T

T40-013111

SFP-T

T40-013111

SFP-T

T40-013111

SFP-5X

T40-011613

SFP-5X

T40-011613

SFP-5X

T40-011613

SFP-5X

T40-011613

SFP-T

T40-013111

SFP-T

T40-013111

SFP-T

T40-013111

SFP-T

T40-013111

HEMPAK-SR

T40-012045

HEMPAK-SR

T40-012045

Adv Filter...

17 of 17 displayed

Actions »

=5 Print

Refresh

Close

Help

Column

Name

Hostname

Device Name

Device Vendor

Description

Device hostname

Transceiver name, for example, SFP-10GBase-ER

Device name converted into Paragon Planner format

Hardware vendor (Cisco, Juniper Networks)




(Continued)

Column Description

Device IP Addr. Loopback IP address of the Device, typically the first one listed
Index Slot information, for example, S-0/1

Part Part number

S/N Serial number

Cost (Estimated) Estimated hardware cost
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I Miscellaneous Parts

Selecting Misc Parts in the left pane displays a Miscellaneous Parts List with information on all the

power supplies and fans of devices in the network. This report can be filtered and sorted by clicking on

the appropriate column headers. The saved report’s filename starts with MISC_PART_LIST.

Figure 122: Hardware Inventory: Misc Parts

27 Hardware Inventory
B 3] Hardware Inventory
™ Devices Mame Device YVendor Part Description
= Line Cards CBO = 710-009115 WM320 Control Board -
& Physical Interfaces CB1 710-009115 320 Control Board
& Transceivers CIP 710-005926 M320 CIP
% Misc. Parts FPM Dizplay 710-009351 M320 FPM Display
% Hardware Integrity FFPM GBUS 710-005928 M320 Board
& Device Usage 13MB A 710-016681 M320 E3-FPC 13 Mez Board
4 Line Card Usage 13MB A 710-016681 M320 E3-FPC 13 Mez Board
% Customer Usage 13MB A 710-016681 WM320 E3-FPC I3 Mez Board
= Hardware CapEx I3MB A 710-016681 M320 E3-FPC 13 Mez Board
13MB B 710-016681 M320 E3-FPC 13 Mez Board
I3MB B 710-016681 M320 E3-FPC I3 Mez Board
13MB B 710-016681 M320 E3-FPC 13 Mez Board
Midplane 710-009120 320 Midplane
FPEM O 740-009148 DC Power Entry Module
PEM 1 740-009148 DC Power Entry Module
PEM 2 740-009148 DC Power Entry Module
FPEM 3 740-009148 DC Power Entry Module
Routing Engine 0 740-014082 RE-A-2000 |
Routing Engine 1 740-014082 RE-A-2000 -
Filter: |* ” Search H AdvFilter. | 23 0f23 displayed
| Actions ¥ | ‘ Load » ‘ ‘ Save r | ‘ 5 Print | | Refresh | | Close ‘ ‘ Help |
Column Description
Name Name of miscellaneous part, for example, “Power Supply 1”
Hostname Device hostname

Device Name

Device Vendor

Device name converted into Paragon Planner format

Hardware vendor (Cisco, Juniper Networks)



(Continued)

Column Description

Device IP Addr. Loopback IP address of the Device, typically the first one listed
Description Description of miscellaneous part

Part Part number

S/N Serial number

Cost (Estimated) Estimated hardware cost



I Extensive Parts List

Selecting Extensive Parts List in the left pane displays a report listing all parts along with the part
number, serial number, description, and the device it belongs to in the right pane. The rows in the report

can be sorted by clicking on the column header for the property to sort by.

Figure 123: Hardware Inventory: Extensive Parts List

# Hardware Inwventory

E_iﬂ Hardware Inwentory
[#-770 Devices

B3 Line Cards

- i@l Physical Interfaces
- g Transceivers

'&. Misc, Parts
xl ive Parts Lisk
4% Hardware Inkegrity
- Device Usage

4% Line Card Usage
4% Customer Usage
[+ % Hardware CapEx

Marne Device N...  Hosktname Device We,,, Part SN Descripkion
10%GE part,,, [¥MX00 w00 = .
10xGE port... (WMx00 w00 E
2x10GE po,., [WMRO0 <00
2x10GE po,., [¥MxOO 00 -
10%GE port,,, [¥e10 w10 1
10xGE port,,, ¥Mx10 w10
2x10GE po... [¥Mx10 w10 | &
2x10GE po.., [WMx10 wrnx 10
10xGE port... [WMx20 winx20
10xGE port... [WMx20 wrnx20
2x10GE pa.., [WMx20 wrnx20
2x10GE pa.., [WMx20 wrnx20
10xGE port... [WMx30 wrnx 30
10xGE port... WM=30 e 30
2x10GE po... [vMx30 30
2x10GE po... [vMx30 30 =

Filter: | * [ Search ][ ady Filter... ] 40 of 40 displayed

Actions » ] | Load » ] l Ewents » ] [ =5 Prirt... ] l Refresh ] [ Close ] [ Help ]

Hardware Integrity

The Hardware Integrity report window provides a summary check of possible errors in the hardware

configuration as represented by the Hardware Model. This report can be sorted by clicking on the

281



282

appropriate column headers. This report is useful when, for example, checking to make sure that all links
have connected interfaces. The saved report’s filename starts with “HW_IC_REPORT.”

Figure 124: Hardware Inventory: Hardware Integrity

27 Hardweare Inventory
El 3| Hardware Inventary RIEIYE I IERLLY
T Devices Device Marne | Severity [ Description
= Cards MY Wiarning Lnrecognized interface name syntax "ATW4/0 2"
B Physical Interfaces MY Warning Unrecognized interface name syntax "ATh4/0"
& Hardware Inteority MY Warning Unrecognized interface name syntax "ATM4/0.1"
& Device Usage MY Yiarning Unrecognized interface name syntax "ATM4/0.3"
< Line Card Usage MY Wiarning Unrecognized interface name syntax "ATM4/0.4"
= Hardware CapEx FHI Infio Card "0/0" has multiple links to the device WDC
Filter: [* | search | aavFiter. | 606 displayed
Actions » | ‘ Load * ‘ ‘ Save » ‘ ‘ &Print | | Refresh | | Close | | Help ‘
Column Description
Device Name Device name converted into Paragon Planner format
Severity Severity level of integrity check: Info,Severity,Warning
Description Description of the integrity check finding

Device Usage

The Device Usage report provides an estimate of the degree to which all the cards and ports in the
nodes of the network are being utilized. The report lists total numbers of cards and ports side by side
with the number of utilized cards and ports, sorted by node, to give you an idea of where the network



stands in terms of hardware capacity and usage at each node. You can also choose to show interface
usage through the table options window (by right-clicking on the column headers). The saved report’s

filename starts with “HW_DEVICE_USAGE_REPORT”

Figure 125: Router Inventory Reports: Device Usage

P

# Hardware Inventony

ESHETE Y

(=48] Hardware Inwentory
k- T Devices Device Ma... Hoskname Mo, of Lin...  A&wailable ... Total Slots  Connecte... Mo, of Parts
ESEine Cards Y00 w00 4 0 1 24 24
W Physical Interfaces WM T 4 0 1 =4 24
M Tenseaiei W20 ] 4 0 1 74 74
o Misc. Rarts W30 T 4 0 1 4 24
-4fp Extensive Parts Lisk YHAT p— 3 o 1 =4 o
~4@ Hardware Integrity WIMHED T 4 0 1 4 24
igCc e Usane WMAED VInE0 4 0 1 24 24
~@ Line Card Usage WD p—r 4 0 1 4 24
4@ Customer Usage WMRED r— 4 0 1 24 24
G- & Hardware CapEx WIHG0 - 4 0 1 4 24
Total 0 40 0 10 240 240
Filter: | * [ Search ” Ady Filter... l 10 of 10 displayed
Actions k ] | Load k ] [ Ewents » ] [ & Prirt... ] [ Refresh ] [ Close ] [ Help ]
Column Description
Hostname Device hostname

Device Name

Occupied Line Cards

Available Line Cards

Total Line Cards

Connected Ports

Device name converted into Paragon Planner format

Number of line cards which are used

Number of line cards which are empty

Total number of line cards

Number of ports that (a) have a corresponding link in the model, (b) are operationally up,
or (c) have an IP address defined on the interface
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(Continued)

Column
No. of Ports
Reserved Ports

Shutdown Ports

Line Card Usage

Description

Total Number of physical ports

Ports that have operational or admin status down

Number of Reserved ports, based on customizable keywords found in the description.

The Line Card Usage report lists all the cards in the network sorted by card type and provides usage
information for these cards. This is useful when searching for capacity information, such as the number
of port vacancies in a particular type of card in the network. The saved report’s filename starts with
“HW_LINECARD_USAGE_REPORT”

Figure 126: Hardware Inventory: Line Card Usage

# Hardware Inwventory

.ﬂ Hardware Inventary
[Tl Devices

23 Line Cards

- K Physical Interfaces
- @@ Transceivers

&:, Misc, Parts

-4 Extensive Parts Lisk
% Hardware Integrity
% Device Usage

e -dLine Card Lsags
% Customer Usage
[+ 7 Hardware CapEx

Line Card Usage (Estimated)

Filter: |*

[ Search ][ Advy Filter. ..

Card Mame Device Mame Car... Con... Shut.. Res... Hho
10xGE ports{auto-assign by portd  |WIME00 0o 10 ] ] 10| &
10xGE ports{auto-assign by porty  |WIMx00 0/1 10 ] ] 10|
2x10GE ports{auto-assign by port) WIMx00 0z z ] ] r
2x10GE ports{auto-assign by port) (WIME00 03 i ] ] 2l|l=
10xGE ports{auto-assign by porty  |WME10 070 10 ] ] 10][ ™
10xGE ports{auto-assign by port)  |WME10 0r1 10 ] ] 10
Zx10GE ports{auto-assign by port) (WME10 0z z ] ] 2.
Zx10GE ports{auto-assign by port) (WME10 03 z ] ] z
10xGE ports{auto-assign by port)  |WIM=Z0 070 10 ] 0 10
10xGE ports{auto-assign by port)  |WM=Z0 0r1 10 ] 0 10
2x10GE ports{auto-assign by port) WMRZ0 0z 2 ] 0 2z
Zx10GE ports{auto-assign by port) [VMEZ0 03 z a} i} z
10x%GE portsiauko-assign by port)  |WME30 0,0 10 a} i} ]
10x%GE portsiauko-assign by port)  |WME30 o/l 10 a} i} 10
Zx10GE ports{auko-assign by port) |VME30 05z z a} i} z
2x10i:E ports{auto-assign by part) WIME30 03 z ] 0 Z2[i=
|

40 of 40 displayed

Actions » ]| Load k ” Events b H =5 Prirt... “ Refresh l [ Close H Help ]
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Column Description

Card Name Name of line card
Device Name Corresponding device name converted into Paragon Planner format
Card Id Slot information, for example, S-0/1

Connected Ports | Number of ports that (a) have a corresponding link in the model, (b) are operationally up, or (c)
have an IP address defined on the interface

No. of Ports Total Number of physical ports
Reserved Ports Number of Reserved ports, based on customizable keywords found in the description.

Shutdown Ports = Ports that are operationally or administratively down

Customer Usage

The Customer Usage report displays network usage on a per customer basis. Customer names are
parsed from the interface comments in the imported configuration files. The regular expression used to
parse the customer names can be customized by selecting a device from the Hardware Inventory
window, going to the Logical View panel, selecting Actions > Options, and going to the Misc tab. There,
you will see a section called Customer Identifier with a field called Use regular-expression in interface
description. Enter your custom regular expression here.

The parser looks for customer names within parenthesis. For example, to match a number sequence in
interface comments of the format, cust###. .., use the expression, cust([0-91+).* There is currently no



way to define customers other than parsing them from interface comments in the imported

configuration files.

Figure 127: Hardware Inventory: Customer Usage

# Hardware Inwventory

.ﬂ Hardware Inventary
[#- T Devices

23 Line Cards

- i@ Physical Interfaces
- gl Transceivers

@;, Misc, Parts

-4 Extensive Parts Lisk
% Hardware Integrity
% Device Usage
% Line Card Usage
B A _ustamer Lsage
[+ % Hardware CapEx

Custamer Lsage (Estimated)

Marne Devices Tatal Units EMikbps) Shutdowned Shutdowned. ..

alpha 3| 3 3000000| 0| 0
Filter: | * [ Search ][ Ady Filker. .. ] 1 of 1 displayed

Actions » ] | Load » ] l Ewents » ] [ =5 Prirt... I I Refresh ] [ Close ] [ Help ]

Hardware Capex

The Hardware Capex report window displays the hardware costs associated with the network grouped
by node. A similar cost report grouped by parts is also available, as is explained below. To expand or
collapse a group in the Hardware Capex report, click on the small icon to the left of the node name. To
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expand or collapse all groups in the Hardware Capex report, simply right click anywhere in the report

and select Expand All or Collapse All. The saved report filename starts with HW_CAPEX_REPORT.

Figure 128: Hardware Cost

# Hardware Inventary

IEi-"é__-J Hardware Inventory Hardware CapEx:
[Tl Devices Device Tvpe Index Carmpaonent Mame Cost (..,
~Eltine Cords =1 00 460,00,..
B - ) thsicalllnterfaces Chas<is MroE0
' Tr.anscewers Card n/o 10%GE ports{auto-assign by part) 240,00..,
-8 Misc, Pfarts ) Card 01 10%GE ports{auto-assign by part) 240,00,
<y Extensive Parts.Llst Card 0z 2x10GE parts{auto-assign by part)
i Haru.jware Integrity Card 0/3 2x10GE parts{auto-assign by part)
- @ DouiceUhag vmx10 480,00...,
% Line Card Usage T 480,00,
3 w3l 480,00,..
= T 480,00..,
wmxs0 450,00, ,,
wmxE0 450,00, ,,
w0 450,00, ,,
vzal 450,00...
w20 450,00...
Total 4,500,...
Actions » ] [ Load » ] [ Ewents » ] [ = Prirt... ] [ Refresh ] [ Close ] [ Help ]
Column Description
Device Device hostname
Type Type of component (for example, Chassis, Card, or Scvr)
Index Slot information, for example, S-0/1

Component Name

Cost (Estimated)

Name of the component, for example, 26xGE

Estimated Cost of component
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The information contained in the Categorized by Parts sub-report is related to that of the default
Hardware Capex report. However, the grouping of the costs is different, as this report lists costs based

on the component type rather than for each node. The saved report’s filename starts with HW_PARTS_REPORT.

Figure 129: Hardware Inventory: Hardware Costs Categorized by Parts

# Hardware Inventony

E=RECHS

=:'---‘='j Hardware Inventory

t- Tl Devices

-3 Line Cards

- K Physical Interfaces

- il Transceivers

é, Misc, Parts

-+ Extensive Parts List

% Hardware Integrity

&% Device Usage

4% Line Card Usage

4% Customer Usage

=1 Hardware CapEx
- 4 _ategorized by Parts

Cateqgorized by Parts (Estimated)

Type Component Mame Counkt Cosk (E...
Card 10xGE ports{auto-assign by port) Z0| 4,500,0...
Card Zx10GE ports{auto-assign by port) 0
Chassis M= 360 10

Filter: | * [ Search ][ Adv Filker. ., ] 3 of 3 displaved
Actions k ] | Load » l [ Events » ] [ =5 Print... I I Refresh l [ Close ] [ Help ]
Column Description
Type Type of component (for example, Chassis, Card, or Scvr)

Component Name

Count

Cost (Estimated)

Name of the component, for example, 26xGE

Count of such components in the device

Estimated Cost of component
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Equipment View

The Equipment View window provides detailed information on the chassis, cards, ports, and interfaces
on any given router. It can be accessed by right clicking on a node in the Map window and selecting
View > Equipment View. There are two types of views in Equipment View, accessible by clicking on the
appropriate tabs at the top of the window: Logical View and Tabular View.

Logical View

Logical View provides a schematic representation of the hardware at the node. Empty, occupied, and
designated template slots are distinguished by different colors which can be customized as described
later in this chapter.

Connected and disconnected ports are distinguished by the symbols next to the port name. Connected
ports have a colored bar in the circle, whose color can be customized in the Options window. A port is
considered connected here if there is a link in the bblink file associated with this port (Network >



Elements > Links). Left clicking on a port will popup a translucent window showing detailed information

about the port.

Figure 130: Equipment View for a Specific Router: Logical View

[£) WrAXOD

Lagical Yiew | Tabular visw |

Shelf 0: 1 slat, 24 parts (Tokal BW: 60.0G, Tokal Traffic: 155,296

[Propertis M

Ovepyiew

ge-0,/0,/3
no ip address Aot 1 11l
hairpin to ge-0,0/
Bandwidth 1000.0M o | ard detail =
Live Load Egress: 19.50K jit_al‘ JE103
Ingress: 36.09K =lat -
Utilization Egress: 0.0019599 % ' b
Ingress: 0.0036096 Mo
Connected To 20 connections Card Id:0/3
Dezcription
Fortl s3: 3
xe-0/3/0
Status:
operational ==
IP address:
A Addr:
00:00:5E:00:53.
-5 =
4 |__r_rr__ _| 3
[ = Logical View Made |[ & Actions ] [ Close ][ Help l

-

Additional detailed port information can be displayed by right clicking on the port and selecting an
option from the table below. The available options may vary depending on the network model:

Field Description
Show Demand Selecting this will open the Demands window to display all demands going through the
port.

Show Link Selecting this will open the Links window to display all links connected to the port.
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(Continued)

Field

Show Demands in Card

Show Links in Card

Card Connections View

Display Card Details

Display Port Details

Description

Selecting this will open the Demands window to display all demands going through the
card.

Selecting this will open the Links window to display all links connected to the card.

This displays ca view of the card along with all the links attached to the card and the
nodes on the other end of those links.

This displays details about the card in the Properties pane to the right.

This displays details about the port in the Properties pane to the right.
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Figure 131: Card Connections View

-

(2] Hou oo ==

: Logical Wiew || Tabular yiew | ad
CveEryism

Slak -1 {Total BW: 466,560, Tokal Demand: 249, 28M)

Junipgr

Mode detail | Card detail

ATL Card Id:
Drescription:
Port(s):

DAL OC3 (to ATL)
Status: operational
[F address:

s0G Connected to: ATL
OC3 (to DALY
Status: operational
[P address:
Connected to: DAL
OC3 (to 3DGY

Status: operational  ~

 Logical View Mode [ Close ][ Help l

Logical View Mode Button

| 3

m

Clicking on the Logical View Mode button will open a menu through which you may customize the

window.
Menu Item Description
Show Color Legend This displays the color legend used for this window.
Show Fullname This displays the full names of the ports in each slot

Hide Metrics This causes only the port name to be displayed next to each port.
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Menu Item

Show Demand Egress,
Ingress

Show Utilizations

Show Empty Slots

Show Pre-planned Slots

Slot Orientation

Slot Ordering

Logical Port Connections

Highlight VLAN ID

Highlight VRF Membership

Highlight VR Membership

Tabular View

Description

This causes the total egress and ingress demand bandwidth to be displayed next
to each port.

This causes a horizontal bar graph representing total port utilization to be
displayed next to each port.

Selecting this displays all unused slots. De-selecting this will hide all unused slots.

If template slots have been defined, selecting this displays these slots.

This controls how slots or displayed. Vertical displays slots on top of each other,
while Horizontal displays slots side by side.

This controls how slots are ordered. Ascending will order slots from lowest index
to highest index, while Descending will order slots from highest index to lowest
index.

This displays VLANSs that are connected to the card.

This item is available only if there are VLANs connected to the card, and will
highlight the VLANS if they exist.

This item is available only if there are VRF Memberships defined on the card, and
will highlight the relevant ports.

This item is available only if there are VR Memberships defined on the card, and
will highlight the relevant ports.

Tabular View can be accessed by clicking on the Tabular View tab at the top of the Equipment View
window. This displays the Hardware Model information for the node in tabular form. The top pane of



Tabular View displays a summary of interface types and bandwidth information. The bottom pane lists
all ports and interfaces in a sortable table along with their attributes and related information.

Figure 132: Equipment View for a Specific Router: Tabular View

(£ HOU

(=[5 &

Logical Wiews | Tabular Wigw

Phrysical Interfaces Summary

X

Cvepyiew

JUniper

ETWOIRES

Mode detail | port dekail

Type Up Do Plantied  Bandwidth  Egress Ingress
Total 0 0 0 ffa tifa ffa
Total possible bandwidth = nfa
Total demand = nfa
Estitnated total hiw cost = ndfa
Parks
Slat Mo, Interface  Admin5... OperSt...  IP Addr, Bandwidth Connec...
Unassigned [2C3 (ta ... =] 155.52M|ATL
QC3 (ko £l 155.52M|Dal
O3 (ko 5. = 155.52M |50

MNameHOUTSTON
Node [DeHOU
Drescription:

Chassis Type: Juniper
Drevice

4 Logical Wiew Mode

[ Close ][ Help l

-

You can use the Actions button to bring up a menu through which various Hardware Model related
actions can be carried out. These actions are useful when you are interested in viewing additional
information about the particular node or modifying various properties on the node.

Menu Item Description

Node Detail
information.

Highlight

Highlights the node in the Map window.

Opens up the standard Node window for the current node to display additional
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Menu Item Description
Show Config Open the config file for the current node in a text editor.
Save As Template This allows you to save the Hardware Model for the current node as a Template in a client

side xml file. This Template can later be imported and applied to additional nodes.

Hardware Template = Opens the Hardware Modeling Template window through which you may apply an
existing template to the current node.

Print Prints a report of the current hardware information.

Report Saves a text report of the current Hardware Model information for the current node to
the client.

Refresh using Refreshes the Hardware Model information of the current node using SNMP data. You

SNMP must be connected to the device and have the necessary login information to use this

option.
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Menu Item Description

Refresh using CLI Refreshes the Hardware Model information of the current node using CLI data from Cisco
and Juniper Networks hardware. You must be connected to the device and have the
necessary login information to use this option. The commands issued during CLI refresh
are as follows:

Cisco hardware:

e show version

e show diag

e show envall

e show idprom backplane
e show module

Juniper Networks hardware:

e show chassis hardware

e show version

Hide Properties Hides the Properties Pane normally displayed on the right side of the Equipment View
Pane window.
Options Opens an Options window that allows you to set various options related to how

Hardware Model information is visually presented in the Equipment View window.

Various options related to how information is visually displayed in the Equipment View window can be
customized in the Hardware Modeling Options window, accessible through the Actions button in the
Equipment View window by selecting Options.

General Tab

In the General tab of the Hardware Modeling Options window, you may choose how optical ports are
represented in the Equipment View by selecting an option in the Optical Port Representation field. In
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the bottom half of the window, you can customize what type of information is displayed in the bottom
table of Tabular View.

Figure 133: Hardware Modeling Options: General
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View Tab

Figure 134: Hardware Modeling Options: View
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The View tab of the Hardware Modeling Options window allows you to customize various color, font
and text position properties in Logical View. To change the color of a property, simply click on the color
bar and a new window will pop up from which a new color for property can be chosen. The font used to
display information in Logical View can also be changed here by clicking the Edit button. The position of
the card label in Logical View can be customized to be shown either on the top or bottom of the card.

Device Specific Tab

Cisco 10S XR, Ignore preconfigured ports in Hardware Model: An interface that does not yet exist may
be configured using the “interface preconfigure” command. Those interfaces are included by default with
status “planned”. If this Ignore option is selected, those interfaces will not be displayed and the port
counts may decrease as a result.



Template Tab

Figure 135: Template Tab
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Apply Template: Here you can also specify the default state to be used when applying card templates.



Identifiers Tab

Figure 136: Hardware Modeling Options: Identifiers
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Reserved Port Identifier: For the Device Usage Report, if the interface description contains one of the
strings in this comma separated list, that interface is interpreted as a reserved port. Note that the
Reserved Ports column can be added to the report display by right-clicking the table header and
selecting Table Options.

Reserved Port Identifier: For the Device Usage Report, if the interface description contains one of the
strings in this comma separated list, that interface is interpreted as a reserved port. Note that the
Reserved Ports column can be added to the report display by right-clicking the table header and
selecting Table Options.

Customer Identifier: For the Customer Usage report, interfaces are associated with customers based
on the interface description field. For example, to match a number sequence in interface comments
of the format, cust###t. .., use the expression, cust([0-9]+).*

User Defined Port Identifier: Suppose you want to count the number of interfaces in a line card
containing a particular keyword in its description. Add the desired strings in a comma-separated list,



each surrounded by quotations marks, similar to the Reserved Port Identifier format. Select the Line
Cards report, right-click the table header, and select Table Options to add a column for each
keyword, to see the number of interfaces containing that keyword.

The Properties Pane

The Properties Pane is displayed on the right side of the Equipment View window and contains useful
information about the card and ports in the chassis. It provides an overview of the hardware, node
details, and card details. The Properties Pane can be closed by clicking the [x] button on the top right
and shown through clicking the Actions button and selecting Show Properties Pane.

Event View

The Hardware Inventory window is capable of displaying hardware related event counts from the Live
Network. This requires opening the Event Map before opening the Hardware Inventory window. Click
the Events button and select the desired view. The event count appears in the left panel under Devices.

e Show node event count always displays the total number of events.

e Show updated event count only displays the number of new events since refreshing the hardware
inventory window. Selecting a device will clear the counter.

e Hide event count hides the event counters.

The number of events on each node are displayed against a background colored according to the Event
Map severity legend. Note that some of the event counters are followed by a “+' symbol. In this case, the
counter represents the number of events belonging to the worst severity category used for the
background color and the “+' symbol indicates that there are additional events of lower severity not
factored into this counter.

If a physical port goes down, the port icon will flash.
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When new events occur, a lightning bolt icon will appear. Clicking on the icon opens a new window
similar to Event Browser with the related events.

Figure 137: Hardware Inventory Device Events View
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Right-clicking in the Logical View panel opens a pop-up menu to Show Events by node, card, or port.

This opens a new window similar to Event Browser with only the events relevant to the device selected.

Figure 138: Hardware Inventory Device Show Events
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Hardware Equipment Cost

NOTE: This feature applies to router networks only.

For pricing purposes, you can specify the cost for certain ports, cards or chassis within the Hardware
Model. Cost data can be set either:

e Globally, by selecting from the main menu Inventory > Hardware Equipment Costs.
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¢ Individually, per device. In the Equipment View for a particular device, select the Logical View tab.
Within the Logical View, you may right click on a card and select Modify Properties > Chassis or
Modify Properties > Card from the popup menu. The price for that specific Chassis or Card can then

be entered into the price field.

e By editing the cardcost file as described in Hardware Equipment Cost File.

The hardware equipment costs window displays the costs of all equipment that has been defined. It
allows you to add, modify and delete cards from its list. This list includes per port costs, which are used
when no matching cards can be found, as explained above.

Three sets of equipment costs can be defined using this window. They are chassis, card and port costs.
Port costs are also used if a particular card is not defined in the equipment costs table.

Figure 139: Hardware Equipment Cost
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Note that the initial costs indicated in the Hardware Equipment Cost window are arbitrary values to help
you get started. To add an item to the Hardware Equipment Cost window, simply click the Add button,
and a new window will popup allowing you to enter the necessary values. To modify an item, select the

item and click the Modify button. To delete an item, select the item or multiple items and click the

Delete button.



Note that the hardware equipment costs are saved on a per-network base. You may import a custom
Hardware Equipment Cost list by clicking the Import button and browsing to the appropriate file.

For cards, the Component Name can be substituted with the Part Number of the card. The Hardware
CapEx report will associate the cost of the card to the part number. The Part Number can be found in
the Hardware Inventory window Devices or Line Card views.

e If no price is specified in the price field in Equipment View, then the program calculates a default
price based on the information in the Hardware Equipment Cost window as follows:

e If the name of the card in Equipment View matches a card name in the Hardware Equipment Cost
window, the cost of the card in the Hardware Equipment Cost window is used for the card in
Equipment View.

¢ If no exact match can be found based on card name, then the program will search for a match based
on the type and number of ports on the card. If an appropriate card can be found in the Hardware
Equipment Cost window that matches the specifications of the card in Equipment View, then the
price of that card in the Hardware Equipment Cost window is applied to the card in Equipment View.

e If no appropriate card in the Hardware Equipment Cost window can be found that matches the
specifications of the card in Equipment View, then a price based on default per port pricing as
defined in the Hardware Equipment Cost window is calculated for the card in Equipment View.

Hardware Equipment Cost File

When you modify or add to the Hardware Equipment Cost window and saves the network, a
cardcost.runcode file is created which contains the Hardware Equipment Cost information for that specific
network. The cardcost file is referenced from the specification file using the keyword “cardcost” . The
format of this file can be used to create a custom file that can be imported into the Hardware Equipment
Cost window as described above. Some sample lines along with field descriptions are provided below.

Specific Card Cost

# Vendor, Name, 'card', Cost, Number of Ports, Media, Description
Cisco, LC-40C3/P0S-SM, card, 39000.0, 4, 0C3/STM1, "4port 0C3/STM1 Card"

Generic Port Cost

# Vendor, Name, Media, Cost per port
Juniper, -, 0C12/STM4, 29000.0

Depending on the format used, the program will recognize the cost as a specific card cost or a generic
port cost.



Templates

The Templates are an advanced feature used to map individual hardware components with a specific
brand and type ( for example, Cisco 12816 or Juniper Networks M40).

Figure 140: Hardware Model Workflow
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There are two levels of templates in the Hardware Model feature: Chassis and Card. A Chassis Template
defines the number of slots on the chassis and can also designate a slot to be occupied by a card
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template if so desired. A Card Template defines the number of ports on the card as well as the media
type of the ports. When a Chassis Template is applied to a node, that node receives all the properties of
the Chassis Template. To view the list of available templates, click on the Tools menu and select
Hardware Model Template.

Figure 141: Hardware Model Templates
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Template Actions

When clicking on the Actions button in the templates window, the following options are available:

Action Description

New Chassis Template This opens the Chassis Template Builder window, allowing you to create a
new chassis template.



(Continued)

Action

New Card Template

Import from Spreadsheet

Import from Hardware Equipment
Cost

Export

Organizing Templates

Description

This opens the Card Template Builder window, allowing you to create a new
chassis template.

Import templates from a CSV formatted spreadsheet.

Import templates from the Hardware Equipment Cost window.

Saves the current template information in a CSV formatted spreadsheet file.

When right-clicking in the templates window, the following options are available:

Action Description

Create Category Creates a new folder in which to organize templates. Note that templates can be
dragged and dropped into this new folder.

Create Alias Creates an alias for the selected template.
Duplicate Creates a duplicate of a template.
View/Modify Opens a template to be viewed and modified
Rename Renames a template

Apply Selected Template = Opens the Apply Template window, allowing you to select a set of nodes to which the
selected template is applied.

Delete Removes a template from the template library
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Chassis Template Builder

Figure 142: Chassis Template Builder
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In this window, you can specify the following fields:

e Vendor/model (select a generic vendor if the desired vendor is unspecified)
e Chassis name

e Part number

¢ Number of shelves: Currently, only switches are allowed to have more than one shelf. In the future,
the program will support multiple shelves for standard routers as well as switches.

e Description

¢ Slot number starts from 1: This options specifies whether the slot number starts at 1 (or 0).



e Shelf name
e Number of slots
e Shelf layout

Once you select the number of shelves, you can select a particular shelf to specify the shelf layout by
using the Shelf Index’s previous and next buttons. For a particular shelf name, you can specify the
number of slots on that shelf using the up and down arrows next to No. of Slots..

To customize the shelf layout using the available cards, you should select the slot(s) in the shelf layout to
which the card is applied. To select a range of shelves, you can click the first shelf and <Shift>-click the
last shelf. To select shelves one by one, you can also <Ctrl>-click each additional shelf. Once the shelves
have been selected, you should select a card from the Available Card(s) list. If the desired card does not
exist, you can create a new card by right clicking in the Available Card(s) list and selecting New Card
Template. When both the shelves and the card have been selected, clicking the Set button will assign the
selected card to the selected shelves.

Shelf Layout Options
Action Description
Set Moves selected card into selected slots
Clear Erases the cards in selected slots
Select All Selects all slots
Deselect All Deselects all slots

Chassis Template Builder Options

Action Description

Import Imports template information from an XML file

Apply When in modify mode, this option is used to apply the template to specific nodes in the network.

Save Saves the chassis template information in the template library
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Action Description
Save As

Help

Saves the chassis template information as an XML file on the client machine

Brings up the online help for the hardware model chapter

Applying the Template

A selected template can be applied to nodes by pressing the Apply button.

Figure 143: Apply Template
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The template is applied to the nodes selected by you in the Router list. To select one at a time, you can
click the checkboxes to the left of those nodes. You can also select a range of rows by clicking the first
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row and shift-clicking the last row. Then you can select or de-select those entries from the right-click
menu. Click Apply to have the template applied to selected nodes.

o Select All: Selects all rows

e Mark as Selected: Marks selected rows
o Clear: Clears selected rows

o Clear All: Clears all rows

Card Template Builder

Figure 144: Card Template Builder

Card Termplate Builder

Apply this template to

Cisco Device

Card Mame: [CardTemplate-1 Ahhreviation:
Part Mumber:
Mo, of adapters: 1}% Max Mo, of ports:
Description:

[] Thiz iz a CPUProcessar card

~FPorts in Card: ~Selected Port Detail:

Fortl

Paortl
Por? Adapter Nl:u.:|nIa

Part3 Fort Mo/ 0

Fart Name:|F'urtEl

Elandwidth:|

FPort Media:

Remoue Apply Changes

Save As..

You should specify the following fields
e Apply this template to: Select the vendor here ] ]

e Card Name: Required field



e Abbreviation

e Part Number

e No. of adapters

e Max No. of Ports

e Description

e CPU/Processor card
e Portsin Card
Modifying Ports

When a new card is created, the ports are all unassigned. It is up to you to assign specific media types to
each port. This is done by selecting the desired ports in the box labeled Ports in Card, specifying the
proper settings to the right, and clicking the Change button to apply the settings to the selected ports.
Below is a list of the settings available for a port.

e Port Name

e Adapter No.

e Port No.

e Bandwidth (bps)

¢ Port Media: Selecting the Port Media automatically populates the Bandwidth (bps) field

Card Template Builder Options

Action Description

Import Imports template information from an XML file

Save Saves the slot/card template in the template library

Save As Saves the template information into an XML file on the client machine for later import.

Vendor Hardware Support for Templates

A specific vendor can be specified during chassis or card template creation. The Hardware Model
template module supports the following vendors: Cisco, Juniper Networks, Riverstone, Alcatel, Nortel,
Tellabs. For all other vendors, this field can be set to Generic.
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Report Manager Window Overview

IN THIS SECTION
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List of Simulation Reports | 332
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Customized Reports | 336

The Report Manager window is split into two panes, where the left pane displays the available reports in
a tree view, and the right pane, or Results Pane, displays the contents of the selected report. The reports
are categorized into the following categories:

o Network Reports: These are the main network reports, including path, utilization, and cost reports.
These reports are dynamically generated, meaning the report is always up to date, reflecting the
current state of your network model. Each time that the Report Manager is opened, upon the first
click of a report, the report is generated and saved to the Report folder of the network model. For all
other subsequent clicks on that report, the report is read from the cache unless you close and reopen
the Report Manager, or chooses to regenerate the report, an option described in the next page.

¢ Tunnel Layer Network Reports: These are the tunnel layer related network reports, including tunnel
path and diversity, tunnel traffic, FRR, and tunnel RSVP BW reports.

¢ Simulation Reports: These reports provide information on the performance of the network after
running failure simulation. Certain reports are only available after running specific failure simulations.

¢ Tunnel Layer Simulation Reports: These reports provide information on the performance of the
network relating to the tunnel layer after running failure simulation.

e Configuration Reports (Router only): These reports are generated when you import network
configuration files into your network model (via File > Import Data).
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o Customized Reports: The customized reports are user-customized reports, where you select columns
of interest from an existing Node, Link, Interface, Demand, and Tunnel report.

Figure 145: Report Manager Window - Report View
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Some report windows contain a filter mechanism which allows you to search for any expression.

Field Description

Explanation Provides an explanation of the currently selected report.

Multiple Sort Allows two consecutive sorting methods to be applied to the current report.

Restore Displays the report in its original form prior to any sorting or searching.

Select Columns Opens a Column Selection window, allowing you to select which columns to display in the
report.

Re-Generate Refreshes the currently selected report.

Script This creates a file for filtering the report in text mode. The filter is based on the query

specified in the Advance Filter window.



(Continued)

Field Description

Actions drop down | The actions available include setting columns to display, saving the report, and printing.

LoadBw drop down = When there are multiple periods in the report, this allows you to select a specific time

period.
Filter Performs the search as specified in the Filter field.
Advance Filter Opens an Advanced Filter window, allowing you to search by exact match, substring

match, wildcards, and regular expressions.

Go to page Displays the page entered here. Enter the page number and click “Go” or click <Enter>.

Lines Per Page Sets the number of lines that are shown on each page or the viewer. Enter the number of
lines to show per page and click “Set” or click <Enter>.

Some reports are displayed simply as text output without tables.

Figure 146: Report Manager Window - Text View
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Additional Report Manager Actions



The following actions can be performed on the column headers in report view in the right pane. Some
actions are available by right-clicking on the column header.

¢ Sort: The information displayed in the right pane of the Report Manager can be sorted. Click on the
column header to sort in an alphabetical order. To reverse sort, click the header again.

¢ Select Columns: This function will open up a Columns Selection window allowing you to select the
columns to display in the report if applicable. The ordering of the column headers can be set in this
window or by dragging the column header in the report view.

e Show All Columns: Selecting this option displays all available columns for this report in the right-
pane.

o Reset the column order: If the column order has been changed, selecting this option will reset it to its
default order.

e Auto Fit This Column: Only the selected column is resized to fit the longest text entry.

o Auto Fit All Columns: All columns are resized to fit the longest text entry.

¢ Freeze Column: The column(s) are frozen for horizontal scrolling.

The following actions can be performed by right-clicking on the report entry in the left pane.

e Re-generate Report: When this option is selected, the program will regenerate the report and update
any fields that might need updating.

o Save Whole Report to Client: Any available reports in the Report Manager can be exported to a
Comma-Separated Values (CSV) file. Selecting this option will open up a directory chooser window
and allow you to save the report to the desired location. This will save the entire report ignoring any
filters applied.

¢ Save Filtered Report to Client: If you have used any of the filter functions on the report, then only
the filtered results are saved.

e Convert Report: Saves the report into the desired format. Choose from XML, Comma-Separated
Values (CSV), or Hyper-Text Markup Language (HTML). Indicate an Output File name on the server in
which to save the report. The report is saved into the Output Path as indicated in the File Manager
window. To change the path, press the “Browse” button and navigate to the desired directory. You
can also save a copy of the report to your local client, by marking the “Copy to client” checkbox.
Press the “Browse” button to navigate to the desired location on your local machine.

o Generate Filter Script: This allows you to generate an advanced filtering shell script in your UNIX
server environment. Once created, this script enables you to create customized reports from existing
network project reports at a later time, without having to launch the Paragon Planner client. This is
useful for the advanced user who may wish to run batch processes for efficiency purposes, especially



if he or she always needs to customize the generated reports using specific filters. Filter Scripts are
described in detail in Advanced Filter Script Utility.

Report Options

Options that influence the output of these reports can be set in the Report Options window of the Tools
> Options > Report menu. These settings include node and link references, bandwidth and distance

units, and currency.

Figure 147: Report Options Window
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See "Simulation Menu: Predefined Scenarios" on page 217 for an explanation of additional items.

Advanced Filter Script Utility

The Advanced Filter Script utility allows you to create and then to apply a filtering shell script in the
Unix environment on reports that have been generated by the tool. This is a convenient way to produce
filtered reports without the need to launch the client. The shell script can also be called by other scripts
that are used for automated daily batch report generation, for instance. The following figure, showing



the Report Manager's Path & Diversity Report, is used to illustrate how to use the Advanced Filter Script

in the following steps.

NOTE: In the Report Manager, the Script utility is only available for reports that are in Comma
Separated Values (CSV) format, a format that is viewable in many programs such as Microsoft
Excel. If you do not see the Script button, select Tools > Options > Report and make sure that the
Report Style is set to CSV. Once that is done, go back to the Report Manager, right-click on the
report file name you are trying to view and select Re-Generate Report from the popup menu. If
CSV format is supported for the report, it will then be re-displayed in a table format.

Figure 148: Demand Path and Diversity Report
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1. First click on the Advanced Filter button to bring up the Advanced Filter window. Suppose we want
to only look at certain demands, such as demands starting from ATL. One way to do this is to use the

query, “From_Node# = ATL".
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2. Click OK to apply the filter.

Figure 149: Define a Query in the Advanced Filter Window

Enter a quety

£ Adwanced Filter-

-Table

From_Mode# = ATL|

= e

Example: (DemandID=F* and not DemandID=PE™* or From_Area=*core™) and From_Area=I13; Example uses Wildcards Search Preference

Keys Relations (Aand/or)
Insert 1 Insert 1
and
or
ok
Geo_DistMile
OnPrefRt
Search Preference
() Exact Match @ Match Substring () Wildcards * and ? () Regular Expressions
[ Ok, I I Cancel ] [ Help I

3. Next, click on the Script button in the Report Manager to bring up the Advanced Filtering Script
window, as shown in the following figure. You may change the script file name or the filtered report
output file name by editing the Script File Name and Output File Name text boxes, respectively. You
can also choose to regenerate the original report in full (in this case, the Path and Diversity Report)
before the filter is performed on it. To do so, mark the Generate New Report checkbox. Once you
have finished with any changes, click on the Generate button and a shell script is created in the
output path. In this example, PATHRPT.mpls-fish.sh is generated.

NOTE: The Generate New Report option works for most reports. However, it will not
regenerate certain reports, such as Simulation and Configuration (Router-only) reports, which
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are only created once during the corresponding failure simulation, or configuration import
operation, respectively.

Figure 150: Advanced Filtering Script window
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4. Next, log onto your server and navigate to the output directory. (You can do this via Tools > Connect
to Server.) Then, to execute the Advanced Filter shell script, simply type the name of the script file at
the command prompt, as shown in the following figure.

Figure 151: Run the Advanced Filter shell script
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- Input Report: fexportfhomefmandlfSll_DBDSISSmplefIPIfisthepDrtfPATHRPT_mpls—fish

- Output Besult: fexportfhomefmandlfﬁll_ﬂ805fsamplefIPffish!RepDrt!PATHRPT_mpls—fish_Dut
- Query String: From_Node# = ATL

- Bearch Preference: Match Substring

5. Once the shell script has been run, the filtered report is generated, as indicated by the “Output
Result” line as shown in the figure above. The following figure shows the filtered report displayed in
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the Report Viewer (in the File Manager, right click on the file name and select Open With > Report
Viewer.

Figure 152: Filtered Path and Diversity Report
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List of Network Reports

Depending on the network type, the Report Manager displays a different set of reports. The following
table lists the available reports. Reports marked with (Router) are device-specific reports and will only
appear for the corresponding network type. All other reports are general and should appear for all

networks.
Demand Reports File Description
Demand Path & PATHRPT Lists details of all user demand requirements in the network. See
Diversity "Simulation Menu: Predefined Scenarios" on page 217.

CoS Demands (Router) = DEMANDCOS Displays the worst propagation and queuing delays for each
demand. See CoS Demands Report .



(Continued)

Demand Reports

Demand Route Cost

Equal Cost Multi-Path
(Router)

Demand Link

Link Reports

Planned Link Utilization

Planned Physical Interface

Utilization

Per Node Pair (Measured)

Measured Link Util (based

on trafficload)

Demand Traffic vs Interface

Traffic

Demand Traffic vs Physical

Interface Traffic

Provides utilization costs according to demand routes. See Demand

Route Cost Report.

Lists equal cost multiple paths that exist in the network for nodes in

the same AS and same OSPF area, and also for inter-area and inter-
VPN demands. See Equal Cost Multi-Path Report.

File Description
CKTCOST_RT
EQPATHRPT
DEMAND_LINK
sequence.
File
LKUTIL
PHYUTIL
MEASUREDLKBWRPT
L3LINKUTIL

L3LINKUTILCOMPARE

L3PHYUTILCOMPARE

Displays the demand path through links by interface out and in

Description

Provides demand bandwidth utilization information for
each link in the network. See "Report Manager: Network
Reports" on page 343.

Provides demand bandwidth utilization information for
each physical interface in the network. See Planned
Physical Interface Utilization.

Shows link utilization by period from the interface
ingress and egress traffic files between connecting
nodes.

Shows the measured traffic by link based on the
trafficload file.

Shows the comparison between planned and measured
traffic. See Demand Traffic Versus Interface Traffic.

Shows the comparison between planed and measured
traffic on physical interfaces.



(Continued)

Link Reports File Description

CoS Links* (Router) LINKCOS, L2_LINKCOS ' Displays the worst propagation and queuing delays for
each CoS class on each link. See CoS Links Report.

Link Cost LKCOST Provides detailed link pricing information.

RSVP Bandwidth LKPART Displays link partitions and their capacity allocation.

Allocation (Router)

Interface Traffic File
Interface Traffic IntfUtil
(Router)

Interface CoS Traffic INTFCOS
(Router)

Interface Multicast INTFMULTICAST
Traffic (Router)

AS Traffic (Router) ASTraffic

Inter-AS Traffic InterASTraffic
(Router)

Description

Displays interface load and utilization information. See /nterface
Traffic Report.

Displays interface Traffic by Class of Service.

Displays interface Multicast Traffic.

Displays traffic information for interfaces at different AS'’s. See AS
Traffic Report

Displays traffic information between different AS'’s. See /nter-AS
Traffic Report.



(Continued)

Interface Traffic File Description
Inbound/Outbound NWKTRAF

Network Traffic

(Router)

Group File

Group Demand Summary GROUPDEMANDSUMMARY

by Group Pair

Group Demand Detail by
Group Pair

Group Demand Traffic on
Link Summary

Group Demand Traffic on
Link Detail

Group Interface Load
Summary (Router)

Group Interface Load
Detail (Router)

For each node, displays an aggregate outbound and aggregate

inbound value, corresponding to the sum of traffic originating and

terminating at a node respectively - but only on interfaces that do

not correspond to any links in the network model ( for example,

customer-facing interfaces, PE-CE interfaces when CE configuration

files are missing from the network model). This information is derived

from the measured traffic on the interfaces (interface “egress” and

“ingress” traffic files in the File > Load Network Files window). One

purpose for this file is for use in the Traffic Matrix tool, as described

in the Paragon Planner User Guide.

GROUPDEMANDDETAIL

GROUPLINKSUMMARY

GROUPLINKDETAIL

GROUPINTFSUMMARY

GROUPINTFDETAIL

Description

Shows summarized information for demands that
are requested within a group or between two
different groups.

Shows detailed information for demands that are
requested within a group or between two different
groups.

Shows summarized information for links that exist
within a group or between two different groups.

Shows detailed information for links that exist
within a group or between two different groups.

Shows summarized information for interface load
of links within a group or between two different
groups.

Shows detailed information for interface load of
links within a group or between two different
groups.



(Continued)

Group

Group Demand Bandwidth

Distribution

Node

Demand Traffic Per
Node

Measured Interface
Traffic Per Node
(Router)

Node Link Port

VPN

VPN Interface Traffic
(Router)

VPN Interface CoS
Traffic (Router)

VPN Interface Multicast
Traffic (Router)

VPN Export-Import
(Router)

Layer3 (Router)

File

File

SWITCHCONN

MEASNODELOAD

NodeLinkPort

File

VPNINTFTRAF

L3GROUPLOAD

Description

Shows traffic statistics for groups such as source,
destination, transit, and intra-group traffic.

Description

Shows statistical information on demands that originate, pass
through or terminate at each node in the network.

Displays up to 24 periods of total incoming and outgoing traffic
from each node based on the measured interface traffic data.
Note that only interfaces corresponding to links in the network
model are considered.

Displays the number of ports on a node by link type.

Description

Reports the ingress and egress traffic on VPN
interfaces for each traffic load period.

VPNINTFCOS Reports VPN interface traffic broken down into CoS
classes.

VPNINTFMULTICAST Reports on the VPN interface multicast traffic load.

VPNEXPORTIMPORT Displays the route target export/import relationships
that exist between VPNs in the network.

VPNREPORT_LAYER3 Displays the details of Layer 3 VPN's in the network.
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VPN

Layer2 Martini (Router)

Layer2 Kompella*
(Router)

Layer2 CCC (Router)

VPLS-LDP

VPLS-BGP

Protocols

Route Instance (Router) *

Subnet (Router) *

BGP > BGP * (Router)

OSPF > Inter Area Load
Distribution* (Router)

File

VPNREPORT_LAYER2

VPNREPORT_L2KOMPELLA

VPNREPORT_L2CCC

VPNREPORT_VPLS

Description

Displays the details of Layer 2 Martini VPN’s in the
network. See Layer2 Martini Report .

Displays the details of Layer 2 Kompella VPN's in the
network. See Layer3/Layer2 Kompella Report

Displays the details of Layer 2 circuit cross-connect
VPN’s in the network.

Shows LDP based VPLS information

VPNREPORT_VPLS_JUNIPER ' Shows BGP based VPLS information. Juniper

File

RTINSTRPT

SUBNETRPT

BGPRPT

INTDOMLOAD

Networks only.

Description

Reports on Routing Instances for OSPF or IS-IS. For
more information, see the Paragon Planner User Guide,
Routing Instances chapter.

Displays all subnets in the network model

Also called the BGP Integrity Checks Report. It contains
four sections (select Application > Options > Report)
including Unbalanced BGP Neighbor Check, IBGP Mesh
Connectivity Check, Local/Neighbor AS Specification,
and Route Reflector Statistics. See "Report Manager:
Network Reports" on page 343

Displays the load distribution between areas in the
network



(Continued)

Protocols

OSPF > Inter Area Paths*
(Router)

OSPF > Area Pass through
Paths* (Router)

OSPF > OSPF Area
Summary* (Router)

OSPF > OSPF Area Detail*
(Router)

(Continued)

OSPF > ABR Bordering Area*

(Router)

File Description

INTDOMPATH Displays information regarding paths between two user-
specified areas

DOMPASSTHRU Generates information regarding demands passing

through an area in the network

OSPFSUMMARYRPT | Shows summarized information for each OSPF area See

OSPF Area Summary

OSPFDETAILRPT Shows detailed information for all routers in each OSPF

area. See OSPF Area Detail Report

ABRBORDERRPT ' Displays the bordering areas for each ABR. See ABR

Bordering Area Report.

List of Tunnel Layer Network Reports

Tunnel Reports

Tunnel Path & Diversity

Tunnel Route Cost

Demand Traffic on Tunnel

Tunnel Traffic

File

TUNNELRPT

L2_CKTCOST_RT

TUTIL

TUTRAFRPT

Description

Displays details of all tunnels in the network and their paths. .

Provides utilization costs according to tunnel routes.

Displays comprehensive tunnel information in the network. See
"Simulation Menu: Predefined Scenarios" on page 217.

Displays tunnel load and utilization information.



(Continued)

Tunnel Reports

Tunnel-Link

Tunnel Layer Link Reports

Tunnel RSVP BW on Link

Tunnel RSVP BW on Node
Pair

Measured Link Util (based
on T_trafficload)

Tunnel Layer Per Node Pair
(Measured)

Tunnel Traffic vs Interface
Traffic

RSVP Bandwidth Allocation

Tunnel Layer Group

Group Tunnel Summary by
Group Pair

L2_MEASUREDLKUTIL

L2_MEASUREDLKBWRPT

LINKUTILCOMPARE

Displays information for each interface segment of each tunnel’s

Description

Provides tunnel bandwidth utilization information for
each link in the network

File Description
TUNNEL_LINK
path.
File
L2_LKUTIL
L2_LKBWRPT

Provides tunnel bandwidth utilization information for
grouped links (links that have the same endpoints)

Shows tunnel traffic on the link by period from the
T_trafficload or tunnel.traffic file for Live networks.

Shows tunnel traffic between connecting nodes by
period from the T_trafficload or tunnel.traffic file for
Live networks.

Compares aggregate tunnel traffic load versus the
measured interface traffic.

L2_LKPART Displays partitions of the link bandwidth (RSVP and
GB=Guaranteed Bandwidth, GlobalPool and SubPool,
or CT partitions for DiffServ-TE) and shows the
tunnel bandwidth for each partition.

File Description
GROUPTUNNELSUMMARY | Shows summarized information for tunnels that

are requested within a group or between two
different groups.



(Continued)

Tunnel Layer Group

Group Tunnel Detail by
Group Pair

Group Tunnel Bandwidth
Distribution

Node

Planned Tunnel RSVP BW Per
Node

Measured Tunnel Traffic Per
Node

File

GROUPTUNNELDETAIL

GROUPLOAD

File

TUNNELSTAT

L2_MEASNODELOAD

List of Simulation Reports

Description

Shows detailed information for tunnels that are
requested within a group or between two
different groups.

Shows total ingress, egress, and transit tunnel
traffic through the groups.

Description

Shows statistical information on tunnels that originate,
pass through or terminate at each node in the network.

Shows ingress and egress tunnel traffic tunnel traffic
through the nodes.

All simulation reports are pre-generated. That is, they are generated after performing the associated
simulation script. The Report Manager provides a quick, organized way of accessing these reports,
though the reports can also be opened directly via the File Manager.

Simulation Report Icons

Because the Simulation Reports are pre-generated, at the time a simulation report is viewed, it may not
accurately correlate with the current state of the network. For example, in the interim you may have



modified the network, adding or removing network elements like nodes, links or demands. Special icons
are used to quickly allow you to distinguish newer reports from older reports that may be out of date:

Figure 153: Report Icons
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¢ Faded Gray: Indicates that the report is not available. The associated simulation script has not yet

been run.

¢ White: Indicates that the report was generated during the current network session. This does not
guarantee that the report reflects the current state of the network model. It is just an indicator that
the report is relatively new.

o Dark Gray: Indicates that the report was generated during a previous network session.

Associated Simulation Scripts

The following table lists the simulation script corresponding to each report. The scripts are accessed
from the main menu Simulation > Simulation Scenarios. For more detail about the variety of simulations,
see "Report Manager: Simulation Reports" on page 389.
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Report File

Peak Link Util DVSIM
Interactive SIMRPT

Failure

Exhaustive PeakSimSummary
Failure PinkSimLink

PeakSimRoute

Daily Sequence DAILYSEQ

Path Delay PATHDELAY
Information

Up-Down UPDOWN
Sequence

Shared Risk Link = SRLG
Groups

Associated Simulation

Displays link and bandwidth information under normal and peak
conditions obtained from failure simulation runs

Tools > Options > Failure Simulation; In Failure Report Tab, ensure that
the “Yes” checkbox for Trace File is marked. Then, perform an interactive
failure sequence by failing nodes/links via the map right-click menus or
via Simulation > Interactive Scenarios. Run or Step through the
simulation. See /nteractive Failure (SIMRPT) Reports.

Simulation > Simulation Scenarios

This file is generated when a Random Daily Failure simulation is run. To
perform this simulation, select Simulation > Simulation Scenarios, select
Multiple Failures, select Double or Triple failure, and enter in a number
of Cases to Simulate.

e This file records the random daily failure sequence into an up-down
sequence file that can be replayed with the Replay Up-Down
Sequence simulation.

This report is generated with almost every simulation script that you
run. It indicates the worst path delay experienced by each demand, as
well as the failure event that caused the worst-case scenario. Note that
the report is overwritten each time.

Under Simulation > Simulation Scenarios, select Generate Up-Down
Sequence for use in Upper Layer option in addition to the simulation
script to be run.

This file is generated during an Up-Down Sequence simulation, for use
in Upper Layer. It basically creates a facility file that groups the failed
demands corresponding to each network element failure just simulated
in the current layer. These demands correspond to links in a higher
network layer, where you can proceed to run an Exhaustive Facility
Failure. In this way, you can see the impact of the network failure at a
higher network level.
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Report File

Replay Up-Down | REPFAIL

Sequence

Associated Simulation

Under Simulation > Simulation Scenarios > Advanced Options, select

Replay Up-Down Sequence, then specify the up-down sequence file.
The DAILYSEQ file generated from Random Daily Failure can be used

here.

List of Configuration Reports (Router Only)

All configuration reports are “pre-generated”. That is, they are generated after you import configuration
files into the network model by selecting File > Import Data. The Report Manager provides a quick,
organized way of accessing these reports, though the reports can also be opened directly from the File

Manager.

For more information on configuration import, see the router data extraction chapter of the Paragon

Planner User Guide.

Report

Integrity Checks

Integrity Checks
Summary

ISIS Config

OSPF Config

CoS Config

File

configlLog

Integrity_Summary_rpt

ISISReport

OSPFReport

ConfigCoS

Description

Displays detailed integrity checks. See "Report Manager:
Configuration Reports" on page 392.

Displays a summary of the integrity checks. This report
can also be accessed directly by pressing the
Stethoscope icon on the main menu bar.

Displays the details of I1S-IS configuration. See /5/S
Reports.

Displays the details of OSPF configuration

Displays the details of CoS configuration
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Report

Config Files Status

VLAN Detail

Duplicated IP

Address

Node Discovery

File

ConfigFileStatus

VLANReport

ConfigDuplicateAddress

BridgeVLAN

ConfigCoS
ConfigElementDiscovery
ConfigFileStatus

ConfigintegrityChecks

ConfigintegrityChecksSummary

ConfiglSIS

ConfigOSPF

Customized Reports

Description

Displays the file properties of collected configuration
files.

Displays details of the VLAN's collected from switches
via SNMP.

Displays duplicate IP address(es) found in the
configuration files.

Displays the names of devices (nodes) added to or
removed from the network after completion of a
Scheduling Live Data Collection task or Network Config
Data Collection task. To generate the Node Discovery
report, Paragon Planner compares the device differences
between the previous network and the current network,
and lists any devices that have been added or removed.

The customized reports feature allows you to create a customized report by selecting certain columns of

interest from an existing Node, Link, Interface, Demand, and Tunnel report.



1. To create a customized report, right-click over Customized Reports in the Report Manager and

choose Add a new Report from the menu.

Figure 154: Adding a New Customized Report

| £ Report MManager

[=-{ % Metwork Reports
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-3 Link Reports
- Interface Traffic
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-3 Node
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Add a new Report
Irmport Template
Export Template
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The Customized Report Editor Wizard then appears, as shown in the following figure. Click Next to
continue.

Figure 155: Customized Report Wizard

Repaort Editar Wizard

Welcome to the Customized Report Wizard | e r -
Customized Report Wizard Overview "

NETWORKS

This Wizard will quide you through the process of creating a cuskomized report,
You will be able ko specify the columns From the selected repart,

This process consists of three steps:

Skep 1: Specify report name and descripkion,

Step 2: Choose the byvpe of customized repart to create.,

Step 3: Select columns and define the ordering.

= Back et = | [ Cancel “ Help




. Specify the report name, file name, and a description, and click Next to continue.

Figure 156: Define Report Name, File Name, and Description

Report Editor Wizard

Step 1: Define General Information
Specify report name and description.

General Information

Report Mame:
File Mare:

Descripkion:

juniPper

METWORKS

cuskomized_

= Back ][ Mext = ] [ Cancel ][

Help
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3. Choose the type of report from which to derive a customized report. After choosing the report type,
click Next to continue.

Figure 157: Choose the Report Type

Repaort Editar Wizard

|
Step 2: Select the Main Information | I I I | ,e r ’
Select the information from which part you wantto use. "

NETWORKS

Main Information

Pode

Link,

Interface
Demand
Tunnel

VPN

VLA GEneral)
WLAM{STE)

= Back ” et = | [ Cancel “ Help

4. Select the columns of interest for the customized report by highlighting rows from the Available
Columns list and clicking on the -> button. For each column selected for the customized report, you
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may choose a new name for an existing column name by clicking on the text box in the New name
column and typing in a new string.

Figure 158: Choose Columns of Interest

Repaort Editar Wizard
Step 3: Select Columns U n | De r |
Choose Columns from the selected reports and re-arrange their order, "
MNETWORKS

Columns Selection

Main Info. Marme Mew name i

Link, Mare

Available Columns Mode A

Attributes - ; [Mode Z

fvail B EAZ) § [Metric

fovail BY (Z8) = Bandwidth (A2}

Bandwidth (42 = Bandwidth (ZA)

Bandwidth (Z4) | 2

ZanFail

Zo5 Policy &

o35 Policy 2

Zarmment

Zosk

DEMAND TRAFFIC
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5. Click on Finish to create the customized report, which is placed into the Customized Reports folder.

Figure 159: A Customized Report Derived from the Link Report

|| Report hManager EE@
¢|1_j Neseior Reporks Explanation... [z Multiple Sort... =) Restore  EE Select Columns... & Re-Generate | - Script., =
{1 Tunnel Layer Metwork Reports - = -
3 Simulation Reports Mame  Mode & Mode Z Metric Type Lt ¢AZ) Lt (28
: £ Tunnel Layer Simulation Reports | || gy Hou 1438/1438 o3 0,1548 0,0057 A
i S CONOuaon Boparcs LINKIE [ATL LAz 30003000 0C3 0.4628 0.9275 §
- Custamized Reports LMKz |ATL WDC 683]653 oc3 11162 0. 7564
BN Liri: Feport [INKF |BOS CET 1396/1398 [ 0,4264 0,5107
LMK+ [BOS MYC 382/362 0c3 02254 01295 3
LINKS  |CH DAL 12551255 oc3 0.2810 0.6807 3
LINKE  |CH DEM 7213i2213 [ 0,4350 0,4367
LINK7  |CHE DET 477477 0c3 0,6459 0,5792
LINKE  |cHI WD 1798{1798 oc3 0.5403 0.6029 4
LINKa DAL HOU 433433 oc3 0.2421 0.6254
LINK1O |DEM SFO ] 0c3 0,2505 0,2341
LINKI1 |HoU S0G 7813/2813 oc3 01744 0.3975
LINK1Z LA S0G 263)263 oc3 0.5537 034940 -
Filker: * [IEs} | P M4 » M # 18 of 13 displayed

6. After a customized report has been created, you may export it as a template. This template may then
be imported by a different network spec, and the same customized report could be generated for
that network.

Figure 160: Exporting/Importing a Customized Report Template

| £| Report kanager

[l Metwork Reparts

EILJ Tunnel Layer Metwork Reports
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EILJ Configuration Reports
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S| ] Link Repaort Add a new Report
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Report Manager: Network Reports

IN THIS SECTION

Demand Reports | 343

Link Reports | 351

Interface Traffic Reports | 361
Group Reports | 365

Node Reports | 375

VPN Reports | 378

Protocols Reports | 379

BGP Reports | 385

The following sections describe the types of network reports that are available:

Demand Reports

Demand Path & Diversity Report



The Demand Path & Diversity Report lists all user demand requirements in the network, with demand
ID, origination, destination, bandwidth, type, priority, preempt priority, path routing, and distance
metrics. The output file that is written to the output directory is called “PATHRPT.runcode”.

Figure 161: The Path and Diversity Report in a Frame Relay Network

|_| Report Manager

B Metwork Reports
B Dermand Reports
[} Demand Path & Di
[ cos Dermands
[ Demand Route Co
[} Equal Cost Multi-P

] Link Reports

21 Interface Traffic

20 Group

1 Mode

CawPN

CawLan

21 Pratocals
(20 waice over IP

23 simulation Repaorts

1 Configuration Reports
21 customized Repors

Explanation.. 3 B} Multiple Sort. Restore [TT) Select Columns... o Re-Generate [l Script.. v @)

FlowlD |From_Rode..| To_MNode_name |Bandwidthivbit)| Type |"Pri,PrePri| Actual_Path |Route_Cost| Delay |Geo_DistiMile)|:

flowl  ATLANTA BOSTOM 0.73 R A2Z (02,02 ATL-WDC--CHI--DET--BOS 4354 19.671 [1967.173 =

flow? | ATLANTA CHICAGD 0.73 RA2ZZ (02,02 ATL-HOU--DAL--CHI 3126 17.204 [1720.419 g |

fowd  (ATLANTA DALLAS 0.418 RA2ZZ|02,02 ATL--HOU--DAL 1871 9.148 |914.808

Mowed | ATLANTA DENYER 0.52 RAZZ|02,02 ATL--HOU--DAL--CHI--DEM 5339 26.398 |2639.809

flowd | ATLANTA DETROT 0.418 RAZZ|02,02 ATL--WDC--CHE-DET--B0S--D... 57450 25,862 |2586.211

flowd | ATLANTA HOUSTOM 0.418 RA2ZZ (02,02 ATL--HOU 1438 5.993 [699.382

flow? | ATLANTA LOSANGELES  |0.52 RA2ZZ (02,02 ATL--LAX agoo 19.326 [1932.611

Mol (ATLANTA MEWYORK 20.45 RAZZ|02,02 ATL-WDC--PHI-MYC 1060 TABY |T4B.715

Mowd  ATLAMTA FHILADELFHIA |0.52 RAZ7 02,02 ATL--WDC--PHI 404 F.654 |f65.469

flowll | ATLANTA SANDIEGD 0.418 RAZZ|02,02 ATL--LAX--5DG 3263 20.345 |2034.588

flowll | ATLANTA SANFRANCGISCO |0.52 RA2ZZ (02,02 ATL--LAK--5JC-5F 0 aran 22798 (2279.812

Mow12 (ATLANTA SANJOSE 0.73 RAZZ|02,02 ATL--LAX-5JC 3690 22,481 (22458171

Mo 3 (ATLANTA WASHDC 27.978 RAZZ|02,02 ATL--WDC 693 5.351 (535121 |
EOSTOM CHICAGO 0.87 RAZ7 02,02 BOS--DET--CHI 1873 8467 |B46.716 |

[]

e Ty | @& = =] 182 of 182 displayed
Field Description
FlowID/PVCID The ID of the demand. (Column name varies with hardware modules.)

From_Node_Name

From_Domain/
From_Area

From_Node#

From_Country

Card

Port

The full name of the origination node of the demand.

The domain at which the demand originates, if any.

The ID of the origination node of the demand.

The country in which the origination node resides.

The name of the card which the demand is connected to; the card slot position that

the demand/flow uses.

The port number of the card which the demand is connected to; the port associated

with the card the demand/flow uses




(Continued)

Field

To_Node_Name

To_Domain/To_Area

To_Node#

To_Country

Card

Port

Bandwidth

Type

Terrestrial

Fiber

Encrypted

Description

The full name of the destination node of the demand.

The domain at which the demand is destined for, if any.

The ID of the destination node of the demand.

The country in which the destination node resides.

The name of the card which the demand is connected to; the card slot position that
the demand/flow uses

The port number of the card which the demand is connected to; the port associated
with the card the demand/flow uses

The amount of bandwidth allocated to the selected demand.

The type of the demand, whether it is a data demand (R) or voice demand (V), and
the direction of the demand (A-Z, Z-A).

The demand's preference for terrestrial media. Valid entries include: Don't Care,
Required, Prefer, Prefer Not, and Avoid. Note that this parameter is used in route
biasing and may not actually reflect true media characteristics.

The demand's preference for fiber media. Valid entries include: Don't Care, Required,
Prefer, Prefer Not, and Avoid. Note that this parameter is used in route biasing and
may not actually reflect true media characteristics.

The demand's preference for encryption media. Valid entries include: Don't Care,
Required, Prefer, Prefer Not, and Avoid. Note that this parameter is used in route
biasing and may not actually reflect true media characteristics.
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Field

Pri, PrePri

Actual_Path

Route_Cost

Delay

Geo_Dist(Mile)

#Hop

OnPrefRt/Path_Violation

Media_Error

Comment

DivLevel/DivGroup

Description

The priority field of the demand specification consists of two numbers separated by
a comma (,), or a forward-slash (/). The first number defines the call priority of the
demand, and the second number the preempt priority of the demand. The preempt
priority should be at the same or lower priority as the call priority of the demand. It is
assumed that this demand can bump any of the demand with call priority lower than
the preempt priority.

The current path (routing) of the demand.

This field displays the sum of the metrics (administrative weights) of the links that the
demand traverses. For asymmetric demands, two separate rows are used to show the
metric, one for each direction. Note that the default metric of a link depends upon
the routing method set in the Tools > Options > Design window, Design>Path
Placement options pane.

When the program performs path placement and is trying to find the best route for a
call, delay metrics are examined to determine the desirability/undesirability of a link.
Two delay metrics are supported, one for each direction of the trunk. If asymmetric
delay metrics are not supported by the hardware, the second delay is marked as '-' If
a delay metric is not defined for a trunk, a default delay is calculated based on
propagation delay and serialization delay.

Specifies the sum of the actual mileage distance of links in the current path.

Specifies the total number of hops of the current path.

Specifies if the demand could not be routed on the specified path.

Specifies if the demand could not be routed on the specified media (terrestrial, fiber,
encrypted).

Any user-specified comments.

Group name for demands that are to be diverse from each other.



CoS Demands Report

The CoS Demands Report provides information on interface load and queuing delays for the demands of
the selected CoS class in the network. See the Paragon Planner User Guide for details on the Class of
Service feature.

The output file that is written to the output directory is called “DEMANDCOS. runcode’.

Figure 162: The CoS Demands Report

|| Report Manager

B[] Network Reparts Calculation Method: Analvtical
B 1 Demand Reporis
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[ Demand Route Co
o ERESEZLﬁESl T Explanation.. 4 B Multiple Sort... Restore [T Select Columns... &2 Re-Generate =] Scripl.. v @)
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21 Node Woipl 7 g WDC o 5DG 0.469 RAZ. VOIP A2Z 25552 3 INIA ]
C3wPN Woip1 80 SJC SFO 4.783 RAZ.. VOIP AZZ 2328 1 [
[0 wLan Woip181 ‘WDC o |5FO0 0.681 RAZ. VOIP AZL |29.736 4 NIA
3 Protocols Woip182 WDC [5G 1.118 RAZ. VOIP AZZ 27511 3 A
21 voice over IP Intranet ATL BOS RAZ..|INTRANET AZZ |9.451 4 INIA
1 Sirmulation Repors Intranet2 ATL CHI RAZ.|INTRANET AZZ|11.302 2 [
[Z1 configuration Reparts Intranet3 ATL DAL FAZ.INTRANET AZZ 9151 2 NIA
1 customized Reparts Intranetd ATL DEM FAZ. | INTRANET AZZ 20,496 3 A 7
Intranets ATL CET RAZ..|INTRANET A2Z 15647 g i |
INTEAMET A 6,995 1 [ ‘ |1
‘] 5

[ I» Filter:

" | @ = [ = 200 of 1212 displaved (page 1/7)

¢ Normal or Peak: Normal traffic means the network does not experience any failure/outages. Peak
means that failure simulation reports are going to be used.

e CoS Classes: Select all or one specific class of traffic. Reports can be issued for all classes of traffic or
for a particular one (for example, the priority class).

e Period: Select planned, worst, all, or a specific time period (from traffic load files). Planned means the
report is generated using the interface load calculated based on the demand file values. Worst means
that the report is generated using the interface load calculated based on the worst traffic load.

Field Description
DemandName The name of the demand.
NodeA The originating node of the demand.

NodeZ The terminating node of the demand.
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Field

BW

Type

Policy Class

Dir

PropDelay(ms)

#Hop

CodecPktDelay

Planned Load

Planned QDelay(ms)

Planned DropBW

Planned Jitter

Worst Load

Worst QDelay

Worst DropBW

Description

The bandwidth of the demand.

The type of the demand, whether it is a data demand (R) or voice demand (V), and the
direction of the demand (A-Z, Z-A).

The policy class to which the demand belongs.

The direction of the demand: A2Z, Z2A.

The sum of node delay and link propagation delay for nodes and links in the path. Delay at
the first node is not included.

Specifies the total number of hops of the current path.

Specifies the Codec Packet Delay

The bandwidth defined in the demand’s bandwidth field. The amount of bandwidth
planned for this demand.

The queuing delay based on the planned load and CoS policies.

The planned drop bandwidth for this demand

The jitter as defined by the standard deviation of the total path delay.

The highest bandwidth among the load in all the traffic periods.

The highest queuing delay value among all the traffic periods.

The highest dropped bandwidth among all the traffic periods.
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Field

1,2, ..

1,2, ..

1,2, ..

Load

QDelay

DropBW

Description

The bandwidth of the demand in the specified time period.

The queuing delay in the specified time period.

The dropped bandwidth in the specified time period.

Demand Route Cost Report

The Demand Route Cost Report provides cost information for each demand based on the demand'’s

route. Each entry is a demand in the network. The report specifies details of each demand, its total cost,
and the breakdown of the cost by each link that it passes through.

The output file that is written to the output directory is called “CKTCOST_RT.runcodeé’.

Figure 163: The Demand Route Cost Report
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1 Rl [»]
Filter: * | & = [DCI=] 200 of 1212 displayed (page 1/7)

AR RHEHE R R R
# COST REPORT FOR DEMANDS File=CKTCOST_RT.x
FHRHHRHHEHEHEEEHRHREHHRRHEHE R R R R

##

# Currency= DL(American Dollar), DistUnit=mile
Ratedir = /u/wandl/db/rates/default
# Calculation Method: utilization cost according to demand routes
# i.e. Demand cost = Sum of (bandwidth/link_cap)*(link cost)




# for links in the path
#

Equal Cost Multi-Path Report

The Equal Cost Multi-Path Report displays all the equal cost multiple-paths in the network. It lists each
set of equal cost paths, displaying the originating and destinating nodes, and the hop-by-hop paths. See
the Paragon Planner User Guide for details on the ECMP feature. The output file that is written to the
output directory is called “EQPATHRPT.runcode’.

Figure 164: The Equal Cost Multi-Path Report

| Report Manager

B Metwork Reports = _ = e
o 1 Demand Reparts = [4 d5|Goto [E]Showline# & Re-Generate @) FontSize: ﬂ B 1 ~178(11)
[ Demand Path & Diversity =
¥ CoS Demands EQU_PATH WY CHI 8.0K R,AZZ 00,00 NYC--PHI--WDC--CHI #!delay=7.36%ms —
Y Demand Route Cost EQU_PATH W¥e CHI 8.0K R,A2Z 00,00 NYC--B0S--DET--CHI #!delay=10.33%ms
[ [Equal Cost Multi-Fath
21 Link Reparts _
(1 Interface Traffic EQU_PATH LAX DAL 8.0K R,AZZ 00,00 LAX--3DG--HOU--DAL #!delay=16.128ns |
1 Group EQU_PATH LAX DAL 8.0K R,AZZ 00,00 LAX--ATL--HOU--DAL #!delay=28.474ns
B Node
-0 WP
Cavian EQU_PATH NYC DAL 8.0K R,A42Z 00,00 MNYC--PHI--WDC--CHI--DAL #'delay=16.025ms
% Protocols EQU_PATH wYc DAL &.0K R,AZZ 00,00 NYC--BOS--DET--CHI--DAL #'delay=18.394ns
Waice aver [P
21 girmulation Reports
| SO TR EQU_PATH sac DAL 8.0K R,A2Z 00,00 SJC--LAX--ATL--HOU--DAL #!delay=31. 59903
1 Customized Reparts
P EQU_PATH sc DAL 8.0K R,A2Z 00,00 $7C--LAX--SDG--HOU--DAL #'delay=19.Z254us E|

NOTE: ECMP paths are calculated based on IGP routing, but the actual path placement will also
take into consideration MPLS Traffic Engineering Tunnels.

* Notations:
* & : Same site
* - : Intra-LATA or Intra-Country

% -- : Inter-LATA or Inter-Country
* = : Intra-LATA or Intra-Country, Second vendor or linktype
* == : Inter-LATA or Inter-Country, Second vendor or linktype.

* @ : Intra-LATA or Intra-Country, Inter-domain
* @@ : Inter-LATA or Inter-country, Inter-domain

* -x- : Link missing or not enough bandwidth



Link Reports

Planned Link Utilization Report

The Planned Utilization Report lists comprehensive link and bandwidth information for the network. The
output file that is written to the output directory is called “LKUTIL.runcode”.

Figure 165: The Planned Link Utilization Report, LKUTIL
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[»] | Filter: |* | @ o = 40 of 40 displayed
Field Description
Linkname The name of the link.
dir The direction of the link.
Anode The origination node of the link.
Znode The destination node of the link.
Type The type of trunk being used. The trunk type is subsequently used in determining link pricing

and bandwidth availability.

TrunkBw The total bandwidth of the link from nodes A to Z. This is also the sum of the AvailBW,
UsedBW and Ovhd values.



(Continued)

Field Description

AvailBW The available amount of unutilized bandwidth between nodes A and Z.

UsedBW The amount of bandwidth actually used by the demand requirements between nodes A and Z.
Ovhd The amount of reserved bandwidth for overhead. (TotalBw = AvailBw + UsedBw + Ovhd)
UtilPct The utilization of this link calculated by (UsedBW+QOvhd)/TotalBW.

nDemand/ncall | The number of demands routed on or through the link.

Planned Physical Interface Utilization

The Planned Physical Interface Utilization Report provides utilization statistics for each physical
interface in the network. The output file that is written to the output directory is called
“PHYUTIL.runcode’.

Figure 166: Planned Physical Interface Utilization
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Demand Traffic Versus Interface Traffic

The Demand Traffic vs Interface Traffic report merges together the Measured Link Utilization and the
Interface Traffic reports and compares them.

In Layer 3, the Compared Link Utilization report is used to compare the link utilizations computed from
the traffic load versus that computed from the interface traffic. For each of the 24 periods, the
difference between the link utilization computed from the interface traffic and from the traffic load is



calculated and displayed in the Diff (intf - Demand) columns for each period and for the worst period
and the average of the periods.

In Layer 2, the Compared Link Utilization report is used to compare the link utilizations computed from
the tunnel traffic load versus that computed from the interface traffic.

Figure 167: Compared Link Utilization Report
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CoS Links Report



The CoS Links Report provides information on interface load and queuing delays for links of the selected
CoS class(es). See the Paragon Planner User Guide for details on this feature. The output file that is
written to the output directory is called “LINKCOS.runcode”.

Figure 168: The CoS Links Report
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¢ Normal or Peak: Normal traffic means the network does not experience any failure/outages. Peak
means that failure simulation reports are going to be used.

e CoS Classes: Select all or one specific class of traffic. Reports can be issued for all Classes of Traffic or
for a particular one (for example, the Priority class)

e Period: Select planned, worst, all, or a specific time period (from interface load files). Planned means
the report is generated using the interface load calculated based on the demand file values. Worst
means that the report is generated using the interface load calculated based on the worst traffic load.

Field

LinkName

TrunkType

Bandwidth

Node

Description

The name of the link.

The type of the link, for example, OC3 or STM1

The bandwidth of the link.

One of the link’s endpoints. This specifies the direction of traffic described in this row.



(Continued)

Field Description

Interface The interface on the node that the link is connected to.
Policy Name The CoS policy specified for the link.

Policy-Class The CoS class of traffic.

Policy Bandwidth Bandwidth reserved for the policy class.

PIR The Peak Information Rate

Class The class name used in demands' CoS definition.

Match The "IP precedence" or "MPLS EXP bits" used as matching conditions for the specified
class.

PropDelay The propagation delay on the link.

Planned Load The amount of bandwidth planned for demands on the link.

Planned Util Percentage of the trunk bandwidth that is used.

Planned PolicyUtil Percentage of the bandwidth reserved for the policy class that is used.

Planned QDelay(ms) = The queuing delay on the link.

Planned DropBW The dropped bandwidth planned on this link.

Planned Jitter The standard deviation of the total path delay.

Worst Load The highest bandwidth among the load in all the traffic periods.



(Continued)

Field Description
Worst QDelay The highest queuing delay value among all the traffic periods.
Worst DropBW The highest dropped bandwidth among all the traffic periods.
1,2, ... Load The load of the link in the specified time period.
1, 2, ... QDelay The queuing delay in the specified time period.
1, 2, ... DropBW The dropped bandwidth in the specified time period.

Link Cost Report

The Link Cost Report provides detailed link pricing information. Each link in the network is listed by its
source and destination nodes, Vendor, Type, Monthly Cost, and Non-Recurring Charge. Link grouping is
done by LEC and IXC vendor.



The output file that is written to the output directory is called “LKCOST.runcode”.

Figure 169: The Link Cost Report
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Remark 1: vendor/cost marked with x are default specified in usercost file
Remark 2: vendor/cost marked with # are default specified in bblink file
Remark 3: cost marked with @ are calculated from usercountrycost file
Remark 4: cost marked with * are estimated from default specified in usercost
file

Special characters (such as #, *, @, *) appended to a vendor or cost value is used to indicate how the
pricing was calculated. For example, a vendor or cost value marked with a '#' means that default values
specified in the bblink file were used. Press the Exp button in the report window for an explanation.

If the report is saved in CSV format or is viewed through the Paragon Planner client, there are question
marks ('??') in the Monthly and NRC columns indicating that pricing for this link cannot be determined.
This usually occurs if the service type is not supported in the tariff database. In this case, you can:

o Specify the desired link cost directly in the bblink file, or



Use the usercost file to define the default vendor and cost for various service types between
particular node pairs.

Use the custrate file to create pricing tables between defined classes of nodes. Note that this the
custrate feature is an unbundled add-on feature.

Field Description

Linkname Identifier of the link

CntryA/NXX | The NPA/NXX location of where the link originates.

NodeA The name of the node where the link originates.
CardA Any information regarding the card found at the origin node of the link.
InterfaceA The name of the interface at the origin node of the link.

CntryZ/NXX | The NPA/NXX location of the destination of the link.

NodeZ The name of the destination node where the link terminates.

Cardz Any information regarding the card found at the destination node of the link.

InterfaceZ The name of the interface at the destination node of the link.

Vendor The vendor associated with this link. Possible values for vendors include those that are specific to

a certain country or region, and are listed in the tariff database. If a vendor is not specified, this
value is set to the default value DEF.

# The number of links from node A to node Z.
Type The type of link being used. The link type is used in determining link pricing and bandwidth
availability.

Monthly Link/circuit cost expressed a monthly billed amount.
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Field Description
NRC Non-Recurring Charge also known as installation charge.
Dist (mile) The distance between the two nodes (in miles).

AdminDist The administrative weight or distance of the link. AdminDistA for A-Z direction; AdminDistZ for

Z-A direction.

Delay The delay of the link in each direction. DelayA=delay for A-Z; DelayZ=delay for Z-A.

CLASS The custom rate class that the nodes belong to. CLASSA=class for node A; CLASSZ=class for
node Z.

SITE The site that the nodes belong to. SITEA=site for node A; SITEZ=site for node Z.

HWTYPE The hardware type of the nodes. HWTYPEA=hw type for node A; HWTYPEZ=hw type for node
Z

RSVP Bandwidth Allocation Report

The RSVP Bandwidth Allocation Report displays detailed link partition information for each link in the
network. This report displays the same detailed information in the capacity tab menu of the Links
window found in the Network menu.



The output file that is written to the output directory is called “LKPART.runcode’.

Figure 170: The Link Partition Report in a Router Network
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Measured Link Utilization Report

The Measured Link Utilization report displays the computed link utilization based on the routed traffic
load in the network. For live network models, this report can be viewed after opening the live network
and switching to Offline mode.

In Layer 3, the traffic load could be either the measured end-to-end traffic load, which can be read in as
a trafficload file in the Load Network Files window, or the end-to-end demands. If a trafficload file is
read in, then up to 24 periods of traffic data could be available. For each period, load and utilization
information are displayed in two columns. Worst and average statistics are also shown (for example,
Average Load and Average Util columns).



In Layer 2, the link utilization is based on the tunnel traffic load in the network. The tunnel traffic load
can be read in as a t_trafficload file in the Load Network Files window.

Figure 171: Measured Link Utilization Report
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Interface Traffic Reports

The Interface Traffic Reports detail the measured traffic on each link over a set of time periods, if data is
provided. In order to access these reports, traffic should have first been collected (either using the
offline traffic collection features in Paragon Planner or other traffic sources) and imported into the
software using the offline traffic import feature. For more on Offline Traffic Import, see the Paragon
Planner User Guide.

Processed interface traffic data is saved in a file that is referenced by the specification file in the lines,
“interfaceLoad_out” (egress traffic) and “interfaceLoad_in" (ingress traffic). The Interface Traffic Report,
AS Traffic Report and Inter-AS Traffic Report are derived from these files. Up to 24 periods of traffic data
could be available. For each period, load and utilization information are displayed in two columns. Worst
and average statistics are also shown (for example, Average Load and Average Util columns). The report
is the same in Layer 3 as in Layer 2.



NOTE: If the outgoing traffic measurements cannot be found (going out from Node A to Node B)

in the egress traffic file, then Paragon Planner will use the numbers from the ingress traffic file
(going into Node B from Node A) if available.

Figure 172: Interface Traffic Report
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Interface Traffic Report

The Interface Traffic Report is generated when you perform an offline traffic import.

Field Description

LinkName

NodeA/Z

InterfaceA/Z

Bandwidth

Trunk Type

Worst Load

Worst Util

The name of the link.

The total bandwidth of the link.

The link type (for example, T1, OC3, ATM10M)

The worst load experienced over all time periods.*

The link utilization correlating to the Worst Load.

The source (A) and destination (Z) endpoints of the link.

The originating (A) and terminating (Z) interfaces on Node A and Z respectively.




(Continued)

Field Description

Average Load ' The average of the loads experienced over all time periods.*

Average Util | The link utilization correlating to the Average Load.

periodl...n The load experienced during period1, period2, ... periodn.*

Util(%) The link utilization correlating to the load measured each period. There should be a “Util(%)”
column immediately after each “period” column.

To determine the units (for example, Kbps), press the Explanation button at the top of the report.
AS Traffic Report

The Autonomous System (AS) Traffic Report details the traffic measured over links whose endpoints are
located in two different ASs.

Field Description

AS1 The AS number of the source AS for the link.
nodelD1 The node ID of the source node of the link.
interfacel The link interface at the source node.

AS2 The AS number of the destination AS for the link.
nodelD2 The node ID of the destination node of the link.
interface2 The link interface at the destination node.

bandwidth The bandwidth of the link.



(Continued)

Field

Average-in

Average-out

Description

The average incoming traffic measured on the link in the AS2->AS1 direction.

The average outgoing traffic measured on the link in the AS1->AS2 direction.

Inter-AS Traffic Report

The Inter-AS Traffic Report details the aggregated average traffic measured on all links between two
different Autonomous Systems (AS).

Field

AS1

AS2

AS1 Name

AS2 Name

Total BW

Average-in

Average-out

Description

The AS number of the source AS.

The AS number of the destination AS.

The AS name corresponding to AS1. By default, the AS names are derived from the file,
$WANDL_HOME/db/misc/ASNames.

The AS name corresponding to AS2.

The Total Bandwidth of all links between these two ASs.

The average traffic load measured on all links between AS1 and AS2 in the AS2->AS1 direction.

The average traffic load measured on all links between AS1 and AS2 in the AS1->AS2 direction.

Inbound/Outbound Network Traffic

This report displays an aggregate outbound and aggregate inbound value for each node, corresponding
to the sum of traffic originating and terminating at a node respectively - but only on interfaces that do
not correspond to any links in the network model (for example, customer-facing interfaces, PE-CE
interfaces when CE configuration files are missing from the network model). This information is derived
from the measured traffic on the interfaces (interface “egress” and “ingress” traffic files in the File > Load
Network Files window).



One purpose for this file is for use in the Traffic Matrix tool, as described in the Paragon Planner User
Guide.

Figure 173: Inbound/Outbound Network Traffic
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Group Reports

This set of group reports in the Report Manager displays information about groups in the network
model. This information includes link and demand summaries and details within and between groups.
When you have categorized nodes into groups, these reports show the amount of links and traffic that
exists within a certain group or between two different groups. After a failure simulation run, you can
also choose to view network group information in peak conditions.

These reports can be generated in Layer 2 of an IP/MPLS network regarding tunnel information
between groups, as well as in an ATM network containing PNNI groups. To view information between
PNNI groups, select this option in the Group Type selection box.



Group Demand Summary by Group Pair Report

Figure 174: Group Demand Summary Report
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The output file that is written to the output directory is called “GROUPDEMANDSUMMARY.runcodeé’.

e Normal, Peak: Select Normal to display network information under normal conditions. After having

run a failure simulation, selecting “Peak” will show peak utilization information.

e Group Type: The default selection is user-defined groups. If this network contains PNNI groups, then
the selection box will also allow you to choose PNNI groups for viewing.

e Period: Based on the traffic load file, the report can display traffic load information in the selected

time period(s).

Field Description

Group A, Z This row contains summarized information for demands that originate at group A and terminate
at group Z.

# Demand The total number of requested demands (placed and unplaced) from group A to group Z.

BW The sum of the demands’ bandwidth.

WorstLd The sum of the traffic load for these demands in the worst case out of all the time periods. (Data

taken from traffic load file.)

WorstLd/BW | The ratio of worst load and the sum of the demands’ bandwidth.




(Continued)

Field Description

P_01,P_02,.. The sum of the traffic load for these demands in period 1 (P_01), period 2 (P_02), etc. (Data
taken from traffic load file.)

Group Demand Detail by Group Detail Report
The output file that is written to the output directory is called GROUPDEMANDDETAIL.runcode.

¢ Normal, Peak: Select Normal to display network information under normal conditions. After having
run a failure simulation, select Peak to show peak utilization information.

e Group Type: The default selection is user-defined groups. If this network contains PNNI groups, then
the selection box also allows you to choose PNNI groups for viewing.

¢ Period: Based on the traffic load file, the report can display traffic load information in the selected
time period(s).

Field Description

Node A, Z This row describes a demand that originates at node A and terminates at node Z.

Group A, Z Group A is the group in which node A resides. Group Z is the group in which node Z resides.

BW The bandwidth of the demand.

WorstLd The worst load of this demand out of all the time periods. (Data taken from traffic load file.)

WorstLd/BW | The ratio of worst load and the bandwidth of the demand.

P_01,P_02,... | The load of this demand from node A to node Z in period 1 (P_01), period 2 (P_02), etc. (Data
taken from traffic load file.)

Group Demand Traffic on Link Summary Report



The output file that is written to the output directory is called “GROUPLINKSUMMARY.runcode’.

Figure 175: Group Demand Traffic on Link Summary Report
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e Normal, Peak: Select Normal to display network information under normal conditions. After having

run a failure simulation, select Peak to display peak utilization information.

e Group Type: The default selection is user-defined groups. If this network contains PNNI groups, then
the selection box also allows you to choose PNNI groups for viewing.

e Period: Based on the traffic load file, the report can display traffic load information in the selected

time period(s).

Field Description

Group A, Z This row contains summarized information for links in the network whose first endpoint is in
group A and other is in group Z.

TotalBW The sum of the bandwidth of links between group A and group Z.

ProvBW The sum of the amount of bandwidth in the links planned for demands that are routed on or
pass through the links.

# Link The number of links between group A and group Z.

# Calls The number of demands routed on or through the links between group A and group Z.




(Continued)

Field Description

WorstLd The sum of the links' traffic load in the worst case out of all the time periods. (Data taken
from traffic load file.)

WorstLd/TotalBW | The ratio of worst load and sum of the bandwidth of the links.

P_01,P_02,.. The sum of the links' traffic load in period 1 (P_01), period 2 (P_02), etc. (Data taken from
traffic load file.)

Group Demand Traffic on Link Detail Report
The output file that is written to the output directory is called “GROUPLINKDETAIL.runcode”.

¢ Normal, Peak: Select Normal to display network information under normal conditions. After having
run a failure simulation, select Peak to displaypeak utilization information.

¢ Group Type: The default selection is user-defined groups. If this network contains PNNI groups, then
the selection box will also allow you to choose PNNI groups for viewing.

e Period: Based on the traffic load file, the report can display traffic load information in the selected
time period(s).

Field Description

Node A, Z This row describes a link in the network whose endpoints are at node A and node Z.

Group A, Z Group A is the group in which node A resides. Group Z is the group in which node Z resides.
TotalBW The bandwidth of the link.

ProvBW The amount of bandwidth in the link planned for demands that are routed on the link or

pass through the link.



(Continued)

Field Description
# Calls The number of demands routed on or through the link.
Note: This can be verified by right-clicking on the link in the map and selecting View >

Demands On/Thru Link.

WorstlLd The link’s traffic load in the worst case out of all the time periods. (Data taken from traffic
load file.)

WorstlLd/TotalBW ' The ratio of worst load and the link’s bandwidth.

P 01,P_02,.. The traffic load in the link in period 1 (P_01), period 2 (P_02), etc. (Data taken from traffic
load file.)

Group Interface Load Summary Report

The output file that is written to the output directory is called “GROUPINTFSUMMARY.runcode’.

NOTE: To display interface load information in these reports, the interface load files must first be
read into the network model.

Figure 176: Group Interface Summary Report
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e Group Type: The default selection is user-defined groups. If this network contains PNNI groups, then
the selection box will also allow you to choose PNNI groups for viewing.




e Period: Based on the traffic load file, the report can display traffic load information in the selected
time period(s).

Field Description

Group A, Z This row contains summarized information for traffic that originate at the interfaces of nodes that
belong in group A and terminate at the interfaces of nodes that belong in group Z.
Group A is the group in which node A resides. Group Z is the group in which node Z resides.

Bandwidth The sum of the bandwidth of links between group A and group Z.

WorstLoad The interface traffic load of the links from group A to group Z in the worst case out of all the time
periods. (Data taken from interface traffic load files.)

Averageload = The average interface load of the links from group A to group Z in all the time periods. (Data
taken from interface traffic load files.)

Group Interface Load Detail Report

The output file that is written to the output directory is called “GROUPINTFDETAIL.runcode’.

Figure 177: Group Interface Detail Report
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¢ Group Type: The default selection is user-defined groups. If this network contains PNNI groups, then
the selection box will also allow you to choose PNNI groups for viewing.

e Period: Based on the interface traffic load file, the report can display traffic load information in the
selected time period(s).



Field

LinkName

Node A, Z

Interface A, Z

Group A,Z

Bandwidth

Trunk Type

Worst Load

Average Load

Description

The name of a link whose end points are at node A and node Z. If the link does not have a link
name, then it will appear as [nodeA]-[nodeZ].

This row describes a link in the network whose endpoints are at node A and node Z.

This row gives interface A,Z that corresponds to node A,Z.

The groups that nodes A and Z belong to, respectively.

This corresponds to the bandwidth of interface A

The link trunk type.

The interface load of the link from interface A to interface Z in the worst case out of all the time
periods. (Data taken from interface load files.)

The average interface load of the link from interface A to interface Z in all the time periods. (Data
taken from interface load files.)

Group Demand Bandwidth Distribution Report

As described in VPN reports section in "Report Manager: Network Reports" on page 343, the Group

Demand Bandwidth Distribution Report provides summarized traffic statistics. The output file is saved
to the LAGROUPLOAD file. The source, destination, transit, and intra-group traffic is reported for each
group, in terms of the number of demands and the bandwidth of those demands. Note that the source

and destination traffic for a group do not include intra-group traffic.



Two additional columns #Transit(Max) and TransitBW(Max) may appear after running an exhaustive
failure simulation script from Simulation>Scripts with the Generate Peak Group Transit Statistics
checkbox selected or by setting CheckTransitDemandLimit=2 in the dparam file.

Figure 178: The Group Bandwidth Distribution Report
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Field Description

Group The name of the group whose traffic load is being analyzed.

For nodes not belonging to any group, they are categorized together as “No Group”

VPN The VPN, if any, whose traffic is being analyzed. For networks with multiple VPNs, select a
specific owner under the Owner dropdownmenu to view only statistics for a particular VPN.
Alternatively, select owner “All” to view a breakdown into statistics for each VPN. followed by
the sum total.

e If Total appears in this column, all traffic at this group is factored in, including traffic for
each VPN and traffic not in any VPN.

e Traffic that is not using any VPN is categorized under No VPN.

#Src(Inter) Total number of demands and bandwidth of demands that originate at this group and visit at
SrcBW(Inter) least one other group.

Note: This category includes local inter-group traffic but not local intra-group traffic. For the
total bandwidth originating at this group, add Src(Inter)+Local(Intra).

#Src(Placed) Number of routed demands and total bandwidth of routed demands that originate at this
SrcBW(Placed) group and visit at least one other group. Unlike Src(Inter), Src(Placed) excludes unplaced
demands.




(Continued)

Field

#Dest(Inter)
DestBW(Inter)

#Dest(Placed)
DestBW(Placed)

#Transit
TransitBW

#Local

LocalBW

#Local(Intra)
LocalBW (Intra)

#Local(Inter)
LocalBW (Inter)

#Transit(Max)
TransitBW(Max)

Description

Total number of demands and bandwidth of demands that terminate at this group and visit at
least one other group

Note: This category includes local inter-group traffic but not local intra-group traffic. For the
total bandwidth terminating at this group, add Dest(Inter)+Local(Intra).

Total number of routed demands and bandwidth of routed demands that terminate at this
group after visiting at least one other group. Unlike Dest(Inter), Dest(Placed) excludes
unplaced demands.

Number of demands and total bandwidth of demands that pass through this group without
originating or terminating at it

Note: If a demand transits through a group more than once, it is counted multiple times.

Total number of demands and bandwidth of demands that originate and terminate at the same
group, subdivided below into Local(Intra) and Local(Inter).

Demands that originate and terminate at the same group which never go outside the group.

Demands that originate and terminate at the same group but transit through at least one
other group. These demands are also counted under Src(Inter) and Dest(Inter).

Max number and bandwidth of transit demands at this group during peak failure simulation

To view the details of the demands included in each category: Src(Inter), Dest(Inter), Transit, and
Local(Inter), Local(Intra), access the text mode either from the command line using /u/wandl/bin/bbdsgn
followed by the specification file path. Detailed info can be found under the menu item: 3. Network
Information > 4.Path > 13.Group. Upon entering the group name, you can select which category of
demands to view. For example, the following indicates the demands transiting through Group 1.

Enter group name: groupl
Group Demands Menu (GROUP1):
1. ALL 2. Src (Inter) 3. Dest (Inter) 4. Transit



5. Local (Intra) 6. Local (Inter)

Select: 4

Demands Passing Through GROUP1:

* Bandwidth Unit = bit

Demand Node Node Bandwidth Type Pri/Pre path

flow1@ ATL SDG 418017 R,A2Z 02,02 ATL--LAX--SDG

flow52 DEN SDG 402000 R,A2Z 02,02 DEN--SFO-SJC--LAX--SDG
flow78 NYC SDG 4801220 R,A2Z 02,02
NYC--PHI--WDC--ATL--LAX--SDG

flow82 PHI SDG 1216020 R,A2Z 02,02 PHI--WDC--ATL--LAX--SDG
flow88 SDG WDC 662011 R,A2Z 02,02 SDG--LAX--ATL--WDC
xflow10 SDG ATL 452011 R,A2Z 02,02 SDG--LAX--ATL

xflow52 SDG DEN 452011 R,A2Z 02,02 SDG--LAX--SJC-SFO--DEN
xflow78 SDG NYC 662011 R,A2Z 02,02
SDG--LAX--ATL--WDC--PHI--NYC

xflow82 SDG PHI 452011 R,A2Z 02,02 SDG--LAX--ATL--WDC--PHI
xflow88 WDC SDG 4689230 R,A2Z 02,02 WDC--ATL--LAX--SDG

--- 10 demands, Total bandwidth = 14.207M

Node Reports

Demand Traffic Per Node Report

The Demand Traffic Per Node Report contains summary traffic statistics for each node, including the
amount of source, destination, and transit traffic reported either as a number of demands or as the
combined bandwidth of those demands. Note that local demands (demands that originate and end at
the same node) are not included in the source or destination traffic statistics.



The output file that is written to the output directory is called “SWITCHCONN.runcode’.

Figure 179: The Node Traffic Summary Report
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Field Description
NodeName The name of the node.
#Demand(Src) Number of demands and total bandwidth of demands that originate at this node and

DemandBW(Src) terminate elsewhere (outgoing)

#Demand(Dest) Number of demands and total bandwidth of demands that terminate at this node and
DemandBW(Dest) = originate elsewhere (incoming)

#Demand(Total) #Demand(Total)= #Demand(Src) + #Demand(Dest)
DemandBW(Total) = DemandBW(Total)J=DemandBW(Src) + DemandBW(Dest)

#TransitDemand Number of demands and total bandwidth of demands that pass through this node without
TransitBW originating or terminating at it




(Continued)

Field Description

#TransitDmd(Max) | Max number and bandwidth of transit demands at this node during peak failure simulation
TransitBW(Max)

For ATM models, the headings for the report are shown in the following table.

Field Description
NodeName The name of the node.
#LocalDmd The number of local demands at the node. Local demands are ones that originate and

terminate at the node.

LocalBW The bandwidth of local demands at the node.

#NonLocalDmd(Src) = The number of non-local demands that originate from the node.

NonLocalBW(Src) The bandwidth of non-local demands that originate from the node.
#NonlLocalDmd Total number of non-local demands originating/terminating at the node.
NonLocalBW Total bandwidth of non-local demands originating/terminating at the node. For asymmetric

demands, the bandwidth of a demand is set to the larger value.

#TransitDmd The number of transit demands at the node. Transit demands are ones that pass through
the node, neither originating or terminating at the node.

#TransitDmd(Max) The maximum number of transit demands at the node during peak failure simulation.



VPN Reports

The VPN Reports in the Report Manager display information about Layer3/Layer2 Kompella VPNs as
well as Layer2 Martini VPNs.

Layer3/Layer2 Kompella Report

Field Description

Node The name of the node

VPN Name The VPN name

VRF The virtual routing and forwarding instance name

RD The route distinguisher - used to determine which VPN a route belongs to
Route Target Export Target VPN community that routes are exported to
Route Target Import Target VPN community that routes are imported from
Protocols The VPN protocol used

Interface The interfaced used by the VPN

IP address The VPN’s IP Address

Bandwidth The allocated bandwidth

Layer2 Martini Report

Field Description

VPNName The name of the VPN



(Continued)

Field Description

Node A, Z The end points of the VPN and the nodes at which the circuits reside. Circuit A resides in
node A, and circuit Z resides in node Z

VCID The (unique) virtual circuit identifiers
circuit A, Z The circuits at nodes A and Z that the VPN is connected to
Encapsulation ID | The interface encapsulation type

BW The amount of bandwidth allocated to the VPN

Protocols Reports

Inter Area Load Distribution Report

The Inter Domain Load Distribution Report displays information on the load distribution between
domains/areas in the network and is saved as “INTDOMLOAD.runcode".

Demand Info: --- Total --- --- Placed --- - Not Placed - - Deactivated
- Area -> Area Count Bandwidth Count Bandwidth Count Bandwidth Count Bandwidth
AREA1 ->AREAQ 10 4.864M 10 4.864M 0 0 0 O
AREA1 ->AREA3 15 3.712M 15 3.712M 0 0 0@ @
AREAQ ->AREA1 10 4.864M 10 4.864M 0 0 0 O
AREAQ ->AREA3 20 1.280M 20 1.280M 0 0 0 @
AREA2 ->AREA1 24 32.544M 0 0 24 32.544M 0 0
AREA2 ->AREA@ 16 21.696M @ @ 16 21.696M 0 0
AREA2 ->AREA3 8 10.848M 0 0 8 10.848M 0 @
AREA3 ->AREA1 12 2.176M 12 2.176M 0 0 0 0
AREA3 ->AREAQ 20 1.280M 20 1.280M 0 0 @ @
ALL ->ALL 135 83.264M 87 18.176M 48 65.088M 0 @
--- Inter-Domain Traffic from DOMAIN-EAST to DOMAIN-WEST
Demand1,DOMAIN_EAST,N1,,,XN1,US,DOMAIN_WEST,6N2,,,XN2,US,



900000, "R,A2Z,CBR",Don't Care,Don't Care,Don't Care,"00,00",N1@@N2,684,25,n0,no,

’

PVC Info: --- Total --- --- Placed --- - Not Placed - - Deactivated-

Domain -> Domain Count Bandwidth Count Bandwidth Count Bandwidth Count Bandwidth
DOMAIN-EAST->DOMAIN-WEST 1 900.000K 1 900.000K 0 0 0

0

--- Inter-Domain Traffic from DOMAIN-EAST to TEST

--- Inter-Domain Traffic from DOMAIN-WEST to NONE

--- Inter-Domain Traffic from DOMAIN-WEST to DOMAIN-EAST
Demand1,DOMAIN_EAST,N1,,,XN1,US,DOMAIN_WEST,N2,,,XN2,US,
900000, "R, Z2A,CBR",Don't Care,Don't Care,Don't Care,"00,00",N1@@N2,684,25,n0,no,

’

PVC Info: --- Total --- --- Placed --- - Not Placed - - Deactivated-Domain -> Domain Count
Bandwidth Count Bandwidth Count Bandwidth Count Bandwidth

DOMAIN-WEST->DOMAIN-EAST 1 900.000K 1 900.000K 0 0 0

0

--- Inter-Domain Traffic from DOMAIN-WEST to TEST
Demand2,DOMAIN_WEST,N2,,,XN2,US,TEST,N3,,,XN3,US, 750000, "R,A2Z,CBR",Don't
Care,Don't Care,Don't Care,"00,00" ,N2@@N3,684,21,n0,n0, ,

PVC Info: --- Total --- --- Placed --- - Not Placed - - Deactivated-
Domain -> Domain Count Bandwidth Count Bandwidth Count Bandwidth Count Bandwidth
DOMAIN-WEST->TEST 1 750.000K 1 750.000K 0 @ 0

0
Field Description
Count The number of demands/PVCs between the two areas.
Bandwidth The amount of bandwidth used by the demands/PVCs.

Total All demands/PVCs between the two areas: placed + not placed + deactivated.
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Field Description

Placed The demands/PVCs between the areas that are routed.

Not Placed The demands/PVCs between the areas that are not routed.
Deactivated The demands/PVCs between the areas that are not activated.

Inter Area Paths Report

The Inter Domain Paths Report displays information regarding paths between two user-specified areas/
domains. The output file that is written to the output directory is called “INTDOMPATH. runcode’.

Field Description

Count The number of demands/PVCs between the two areas.

Bandwidth The amount of bandwidth used by the demands/PVCs.

Total All demands/PVCs between the two areas: placed + not placed + deactivated.
Placed The demands/PVCs between the areas that are routed.

Not Placed The demands/PVCs between the areas that are not routed.

Deactivated The demands/PVCs between the areas that are not activated.

Area Pass Through Paths Report

The Area Pass Through Paths Report, or the Domain Pass Through Paths Report, generates information
regarding demands passing through an area or domain in the network. This report is only available for
networks defined with multiple areas or domains and demands to and from each domain. The output file
that is written to the output directory is called “DOMPASSTHRU. runcode’.



Following is a sample text file of the Domain Pass Through Paths Report from an ATM network:

Demands passing through domain AREAQ:

RN1N15,0.0.0.3,N1,,,XN1,US,0.0.0.1,N15,,,XN15,US, 768000, "R,BR1.0M,BM768K,BB200K,RT",Don"t
Care,Don't

Care,Don't Care,"02,02" ,N1-N10@E@N17--N4--N7@QN8--N15,600,23,n0,n0, |,
RNIN15,0.0.0.3,N1,,,XN1,US,0.0.0.1,N15,,,XN15,US, 768000,"R,BR1.0M,BM768K,BB200K,RT",Don't
Care,Don't

Care,Don't Care,"02,02",N1-N10@@N5--N6--N7@@N8--N15,600,22,n0,no0, |,
RN2N3,0.0.0.3,N2,,,XN2,US,0.0.0.1,N3,,,XN3,US, 512000, "R,Z2A,UBR+",Don't Care,Don't Care,Don't
Care,"02,02" ,N2--N10@EN17--N4@@N3,400,16,n0,no0, ,
RN2N3,0.0.0.3,N2,,,XN2,US,0.0.0.1,N3,,,XN3,US, 512000, "R,Z2A,UBR+",Don't Care,Don't Care,Don't
Care,"02,02" ,N2--N10@EN17--N4@@N3,400,16,n0,no0, ,
RN2N3,0.0.0.3,N2,,,XN2,US,0.0.0.1,N3,,,XN3,US, 512000, "R,Z2A,UBR+",Don't Care,Don't Care,Don't
Care,"02,02" ,N2--N10@EN17--N4@@N3,400,16,n0,no0, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't Care,Don't
Care,"02,02" ,N2--N10@EN11--N6@@N13,400,13,n0,n0, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't Care,Don't
Care,"02,02" ,N2--N10@EN11--N6@@N13,400,13,n0,n0, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't Care,Don't
Care,"02,02" ,N2--N10@EN11--N6@@N13,400,13,n0,n0, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't Care,Don't
Care,"02,02" ,N2--N10@EN11--N6@@N13,400,13,n0,n0, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't Care,Don't
Care,"02,02" ,N2--N10@EN11--N6@@N13,400,13,n0,n0, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't Care,Don't
Care,"02,02" ,N2--N10@EN5- -

N6@eN13,400,12,n0,n0, ,RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't
Care,Don't Care,Don't

Care,"02,02" ,N2--N10@@N11--N6@EeN13,400,13,n0,n0, |,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't Care,Don't
Care,"02,02" ,N2--N10@@N5--N6@eN13,400,12,n0,n0,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't Care,Don't
Care,"02,02" ,N2--N10@eN11--N6@EN13,400,13,n0,no0, ,
RN2N13,0.0.0.3,N2,,,XN2,US,0.0.0.1,N13,,,XN13,US, 64000,"R,RT",Don't Care,Don't Care,Don't
Care,"02,02" ,N2--N10@eN11--N6@EN13,400,13,n0,n0, ,

-- 15 PVC(s)(bw=3.712M) pass through domain AREA@

OSPF Area Summary Report



The Area Reports in the Report Manager display information about areas in the network model. This
section includes a description of the OSPF area summary and detail reports, as well as the ABR border

area report.

Figure 180: The OSPF Area Summary Report
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Field

AS Number

OSPF Area

# of ABRs

# Internals

# Routers

ASno_Area

Description

The AS number of the area

The name of the OSPF area

The number of routers in the OSPF area that aren’t defined as ABRs

The total number of routers in the area (equivalent to # of ABRs + # Internals)

A unigue name created by concatenating the AS number and the area name

The number of nodes that are defined as Area Border Routers (gateway routers)
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OSPF Area Detail Report

Figure 181: The OSPF Area Detail Report
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Field Description

AS Number The AS number of the OSPF area that the router is located in
OSPF Area The name of the OSPF area that the router is located in
Router Name The name of the router

Router IP The router’s IP Address

ABR Is this router defined as an Area Border Router

ABR Bordering Area Report

Field Description

AS Number The AS number of the area that the ABR is located in

ABR The name of the ABR
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Field Description

Bordering Area(s) A list of all the areas that the router is bordering

BGP Reports

When the client session is opened for the first time, the BGP Report should be checked to make sure
that the network has no obvious BGP configuration errors. The output file that is written to the output
directory is called “BGPRPT.runcode".

BGP Integrity Check Report:

BGP statistics - This section shows:

e The total number of BGP speakers in the network
e The total number of neighbors

e The total number of policies

e The list of all ASs and the number of their BGP speakers

* BGP Integrity Check Report
KKK KKKAKRKKAKR AR AR AKRAKR AR AR AKRAKRAKRAKRAXRAKRAXRARAXRARAXRA XA XA )A%
-- 17 BGP speakers,89 neighbors,283 members,183 policies
-- 3 local AS:
ASno 65222: 9 routers
ASno 65111: 7 routers
ASno 65534: 1 routers

Neighbor AS Specification Error Check Report

This section shows any errors about ASs that are not specified correctly. For example, router A declares
that its neighbor, router B, is in AS65243, but router B is actually in AS65312.

* * * * x Neighbor AS Specification Error Check Report
AS Location Nbr_AS Nbr_IP_Addr Nbr-Location ValidAS Comments



65243 X39 65224 10.49.226.34 Q39 65312
**%% 1 AS specification errors

In the example, the Neighbor AS Specification Error Check Report shows that there is an error in the
node (Location) X39.

The neighbor node(Nbr-Location) is Q39 and the neighbor AS (Nbr_AS) is 65224, which should be
65312 as shown in the ValidAS field.

Unbalanced BGP Neighbor Check Report

The BGP protocol requires that if router A declares router B to be its neighbor, then router B also has to
declare that router A is its neighbor. If not, then an unbalanced neighbor occurs. This section reports any
unbalanced neighbors between BGP speakers within the network.

* % % * % Unbalanced BGP Neighbor Check Report
# Unbalanced BGP Neighbor = 2

AS Location Nbr_AS Nbr-Location

65111 S39 65111 X39

65111 W39 65111 X39

The Unbalanced BGP Neighbor Check Report shows that there are two unbalanced neighbors. On the
first record S39 declares that X39 is its neighbor but X39 does not declare that S39 is its neighbor. The
second record shows a similar error.

IBGP Mesh Connectivity Check Report

All IBGP speakers within an AS have to be fully meshed, unless route reflectors or confederation are
used. This section shows if any AS is not fully meshed.

A full mesh for both IPV4 and VPNV4 address families are checked.

* %k %k % %

IBGP Mesh Connectivity Check Report

AS65222: #IPV4 IBGP neighbor=0. Check mesh definition for VPNV4 address family
AS 65222: passed mesh connectivity checking

---- VPNV4 AS65111: S39 is not defined as X39's neighbor

IPV4 VPNV4 AS65111: W39 is not defined as X39's neighbor

AS65111: 2 neighbor definition missing

AS65333: IPV4, VPNV4, L2VPN IBGP neighbors are not defined

AS 65534: passed mesh connectivity checking* * * * %

The IBGP Mesh Connectivity Check Report shows the following



o AS65222 is fully meshed for the VPNV4 address family but no IBGP neighbors exist for IPV4 address
family.

e AS65111 is not fully meshed for IPV4 and VPNVA4. For the VPNV4 address family, S39 and W39 are
not defined as X39's neighbors. For the IPV4 address family, W39 is not defined as X39’s neighbor.

e AS65534 passes the mesh connectivity check for both IPV4 and VPNV4.,
e AS65333 is missing IBGP neighbors for the IPV4, VPNV4, and L2VPN address families.
IPV4/VPNV4/L2VPN Route Reflector Statistics

These three sections indicate the route reflector statistics, including number of route reflectors, number
of route reflector clients, and hierarchical route reflector information. Route reflector clients with only
one route reflector are listed as a warning that they do not have redundant route reflectors defined. The
following is an example of the IPV4 route reflector statistics:

IPV4 Route Reflector Statistics: 200 BGP Speakers, 8 Route Reflectors, 100 Route
Reflector Clients

Redundant Route Reflectors are not defined at 2 RR Clients

1. WDC1, RR= PHI1

2. WDC2, RR= PHI1

#Route Reflector Hierarchy Level= 3
Top Level: 4RR(s)

1. NYCT,

2. NYC2,

3. BOST,

4. B0S2,

Level 2: 3RR(s)

1. PHIT, RR= NYC1 NYC2
1. PHI2, RR= NYC1 NYC2
2. BOS3, RR= BOS1 B0S2
Level 3: 1RR(s)

1. TRE1, RR= PHI1 PHI2

VPNV4 and L2VPN route reflector statistics are similarly provided.

It is recommended that all errors reported in the BGP Report file get fixed before carrying on further
analysis. One way to do it is to correct the errors on the configuration files and then run through
getipconf again.



Report Manager: Tunnel Reports

Demand Traffic on Tunnel Report

The Demand Traffic on Tunnel provides comprehensive tunnel bandwidth information. Switch to the
Tunnel layer before opening the Report Manager to see the tunnel layer reports. See the Paragon
Planner User Guide for details on viewing and modifying tunnels. The output file that is written to the
output directory is called TUTIL.runcodé’.

Figure 182: The Demand Traffic on Tunnel Report
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Field Description
TunnelName The name of the tunnel.
FromNode The originating node of the tunnel.
ToNode The terminating node of the tunnel.
Bandwidth The total bandwidth of the tunnel.
#Flow The number of flows or demands that are routed on this tunnel.

FlowBW The amount of bandwidth used by the demands on the tunnel.




(Continued)

Field Description

BW_Diff The difference between the flow bandwidth and the total bandwidth. This value is calculated by
FlowBW - Bandwidth.

BW_Diff_Ratio ' If the tunnel’s bandwidth is O, then this value is the FlowBW. If the tunnel’s bandwidth is
greater than O, then this value is calculated by dividing BW_Diff by the total andwidth.

RoutePath This is the actual routed path of the tunnel.

Report Manager: Simulation Reports

Link Utilization Reports

The Link Utilization Report displays the link and bandwidth information under normal and peak
conditions obtained from failure simulation runs. Thus, before opening this report, you must first run a
failure simulation script (Simulation > Simulation Scenarios). The results depend on the settings of the
failure simulation.

Figure 183: The Link Peak Utilization Report
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Field

Linkname

Anode

Aloc

ACountry

Znode

Zloc

ZCountry

Vdr

Type

TotalBw

UsedBw

PeakBw

UtilPct

PeakUtilPct

Description

The name of the link.

The ID of the source node where the link originates.

The name of the source node where the link originates.

The country where the source node is located.

The ID of the destination node where the link terminates.

The name of the destination node where the link terminates.

The country where the destination node is located.

The vendor associated with this link. Possible values for vendors include those that are
specific to a certain country or region, and are listed in the tariff database. If a vendor
is not specified, this value is set to the default value DEF.

The type of trunk being used. The trunk type is subsequently used in determining link
pricing and bandwidth availability.

The total bandwidth of the link from node A to Z.

The amount of bandwidth used on this interface by the demand requirements from the
demand file.

The peak (maximum) bandwidth used by the demand requirements between node A
and Z during failure simulation.

The percentage of total bandwidth used by demands prior to the failure simulation.

The peak percentage of total bandwidth used during failure simulation.

This is calculated as PeakBW divided by TotalBW.



(Continued)

Field

#Demand

PeakCnt

#0OverSubCnt

LoadBW_n

PeakLoadBw_n

SimType / SimEvent

Cnt_SimType /
Cnt_SimEvent

Description

The number of demands carried by the link in the normal mode

The peak number of demands carried by the link during failure simulation.

The number of failures that caused the used bandwidth to exceed (1-fatpct)*TotalBw.

The amount of bandwidth used on this interface by the demand requirements during
period n of the trafficload file.

The peak (maximum) bandwidth used during failure simulation for this period n of the
trafficload file.

The type of simulation event (for example, NDFAIL stands for node failure) that
triggered the worst traffic load on either end of the link, and the associated event
detail (for example, name of failed network element).

The type of simulation event that triggered the worst demand count on the link (for
example, NDFAIL stands for node failure), and the associated event detail (for example,
name of failed network element).

Interactive Failure (SIMRPT) Reports

The Interactive Failure report is a trace file that records statistics during an interactive failure simulation.
To create the report, you must enable the Trace option in the Failure Report tab of the Failure Simulation
Options (Tools > Options > Failure Simulation). Then, perform an interactive failure sequence by failing
nodes/links via the map right-click menus or via Simulation > Fail Link/Node/Facility. When you run or
step through the simulation, results are appended onto the Interactive Failure report.

The Interactive Failure report is typically used for quick analysis. The report is usually used following
another failure simulation. For example, you might first perform an Exhaustive Link Failure, during which
a few problem links are identified. You may then want to analyze those link failures further by
performing an interactive failure simulation in which just those links are brought down and up.

NOTE: If you change any failure simulation options via Tools > Options > Failure Simulation and
press “OK”, the SIMRPT is overwritten (that is, cleared). Note that for every network session



(each time you open a network project or specification file), you will need to set the failure
simulation options, as they are not saved.

Because this is a running trace file, you should not delete the SIMRPT file during a network
session. The results of an interactive failure simulation may not be saved in this event.

Report Manager: Configuration Reports

Integrity Checks Reports

When router configuration files are read into Paragon Planner, a configuration integrity checks report is
generated which lists possible errors found by the program while parsing the router configuration files.
To access this report, you must first import configurations files using the Import Data Wizard from File >



Import Data. Once the configuration files have been imported, you can bring up the Configuration
Reports in Report Manager.

Figure 184: Integrity Checks
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Filter:

*

B 2 EHEEE=

40 of 40 displayed

Field

Error Source

Description

This field indicates the source of the error. This will usually be a configuration file name, or may

sometimes be a description when more than one configuration file is involved.

Line

Severity

Message

Config Files Status Reports

This field gives the line in the configuration file where the error was found.

This field indicates the severity of the error. The levels include High, Medium, Low, and Warning.

This field provides a description of the error and may contain references to specific configuration
files or host names when more than one configuration file is involved.
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This report displays the config files used for the configuration integrity check reports.

Figure 185: Config File Status
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3] | Fitter|* R 2 EHEEE: 21 of 21 displayed
Field Description
file This field specifies the directory path and filename of the node’s configuration.
timeStamp This field is the last modified date and time of the config file.
size This field is the Byte size of the config file.

ISIS Reports
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The ISIS Report displays the details of IS-IS configuration as a result of parsing a set of configuration files
from a network. Click on a row to see the ISIS attributes associated with the router. The output file that
is written to the output directory is called “ISISReport.runcode’.

Figure 186: The ISIS Report
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Field Description

Router The router name.

Interface The interface of the router.
address/mask The IP address and mask of the interface.
Type The IS-IS router type.

Level 1 Metric The IS-IS cost for this interface in level 1.
Level 2 Metric The IS-IS cost for this interface in level 2.

Detail A portion of the configuration file that applies to its IS-IS configuration.
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Accessing the User Administration Window

To access the User Administration window, you must log in to the client with the user account used to
install the server. Other users will not see the User Administration window.

There are three types of users:

o Full Access users who can log into the client and optionally the web, which are mapped to a Unix
User. Any Full Access user created through the User Administration window must map to an existing
Unix user on the Paragon Planner server. The login name used to log in to Paragon Planner should be
the same as the Unix user name. The corresponding password is the same as the password for the
corresponding Unix user account. The only exception is the “admin” user which is mapped to the
Unix account of the user that installed the application. Authentication is done through an LDAP
server that is installed on the same server machine of Paragon Planner.

e Web Portal users who are restricted to the web only.

e Web VPN users who are restricted to the web VPN view. These users can be assigned access to view
only certain VPN customers.



Creating User Groups and Permissions

An admin user can create any number of Paragon Planner user groups and assign to each of these group
a custom set of permissions. Select the group type and enter in the group name.

Figure 187: User Groups Tab of the User Administration Window
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Setting Permissions

Once a user group has been created, you can assign permissions to that user group. Some features allow
both View/Enable and Modify permissions, while others are turned completely on or off with just the
View/Enable permission.

Note that enabling some features may require additional features to be enabled as well. This is because
certain features are dependent on other features to be enabled before they can be accessed. When
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selecting the check box for such a feature, the checkbox(es) of the additional required feature(s) will
automatically be checked as well.

To select all View/Enable or Modify items within a category, check the corresponding checkbox in the
gray row indicating a category. Click the gray checkbox again to deselect all items under that category.
Individual items within a category can also be turned on and off.

Changes made to a user group’s permission checkboxes are saved when clicking “Apply” or “OK.
Regional Permissions

For the live network view, Full Access and Web Portal users can be restricted to being able to directly
access the routers only for particular region(s). For devices outside of the permitted regions, which are
grouped into the OUTSIDE_REGION group, view-only access is provided, and features such as ping,
traceroute, show config, and hardware inventory are disabled. To limit the region(s), first define the
regions in the top Regions tab. Note that you need to have run a live network task in order to define
regions based on routers collected in the task.

Defining Regions

Figure 188: Defining Network Regions
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Select the routers to add to a region from the left pane and then click Add to New Region to create a
new region with these selected routers. Alternatively, click Add New Region in the right pane and then
select multiple routers (using <Shift> and <Ctrl> keys), and drag them from the left pane to the right
pane. Note that you must drag them over a group name and not over a group member to add them to a
group. To move a router from one group to another, select the router, and drag it to another group. To
remove the router from the group, drag it outside of the right pane. Click Apply to save your changes.

Setting Regional Permissions

Once the region has been added, select the User Groups tab.at the bottom of the right pane and select
the Regions tab. Here, you can limit the permissions for accessing the router live by unchecking the All
Regions checkbox and then checking the corresponding region(s) to which the user can have access.

Figure 189: Setting Regional Permissions
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Creating Users / Assigning Users to Groups

Once user groups have been setup with the desired permissions, you can create users and assign them
to user groups. To create a user, click on Add User icon button on the bottom of the Users tab of the
User Administration window.

Figure 190: Users Tab of the User Administration Window
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Type a login name next to Name. Next, choose the radio button for the appropriate group type (Full
Access, Web Portal, or Web VPN). Then select one of the available groups for that group type.

e For Full Access users, please choose a valid Unix User ID to map the new Paragon Planner user to.
This should be the same as the login name. (Note: To add a new user ID, you must access the server
via telnet or ssh window, switch to root user, and either run “admintool” (requires display of the
desktop) or use the “useradd” command (for example, “useradd -g staff -d /export/home/wandl|
wandl” would add user wandl in group staff with home directory /export/home/wandl).
Subsequently, you may create a password for that user using the command “passwd userid’
substituting userid with the Unix User ID. Note that you can similarly modify or delete a Unix user ID
as root user using the commands “usermod” and “userdel”)

e For Web Portal and Web VPN users, enter in a password to log in to the web interface.

Optionally specify additional contact information such as Email, Phone, IM, and a Description for this
new user.




Max Logins can be configured to control the maximum number of times a specific user can be logged
into the Paragon Planner server.

Access level (Full Control, Browsing, Restricted, or Blocked) can be configured to further control the
access level of a user.

e Full Control Access: The Full Control user can modify, perform design and simulation on the network
model in Paragon Planner.

e Browsing Access: The Browsing user can only open a network model in Paragon Planner for viewing,
but is not allowed to perform any modification, design, or simulation on the network model.

e Restricted Access: The Restricted user has Browsing privileges, but with even stricter limitations to
view only certain networks, files and directories: Once logged in, the Restricted user can only
navigate to the Home Directory and its child directories. Only spec.* and newdemand.* network files
are displayed in the File Manager. The user cannot access "Hidden" files. All Report Manager reports
are read-only, and are not regenerated before displaying in the Report Manager. Certain menus are
disabled.

o Block Access: The user is blocked from opening a network model in Paragon Planner. The length of
time a user is blocked from accessing the system is defined by the Block Period in the Update GUI
Login Policy section.

Once a Paragon Planner user name has been added, that user name will also appear in the User Groups
tab of the User Administration window under the group to which it belongs. To modify an existing user,
select the user in the Users tab, and click the Modify Icon button at the bottom of the window. To delete
an existing user, select the user and click the Delete Icon button.

If the user name has been mapped to a valid Unix User ID, the new user should be able to log in to the
Paragon Planner client and interface, when assigned the appropriate privileges, using either the user
name and the corresponding password for this Unix User ID.

License File Manager

The License File Manager allows you to view the current license installed for Paragon Planner. It
contains entries for the modules supported, maximum number of users, and expiration date. The License
File Manager also allows you to upload a license file to the server. This will replace any existing license
file.
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Tools Menu Overview

The Tools menu contains the following general tools:
¢ VPN Traffic Generation

You can add demands within the VPNs using the VPN Traffic Generation tool. See the Paragon
Planner User Guide, Virtual Private Networks chapter for more details.

e Add-ons
Any add-ons available to you are listed for your selection.
e Options

See "Tools: Options Menu" on page 404 to learn about the various options that can be configured for
Paragon Planner.

Tools: Options Menu

IN THIS SECTION

General Options | 405

Config Editor Options | 405
Path Placement Options | 407
Failure Simulation Options | 415
Resize Options | 417

Map Preferences | 419

Report Options | 422

Depending on the hardware type, the Options windows may look different and contain additional fields
than what is described below. For description of hardware-specific fields, see the hardware-specific
guides.



General Options

¢ Show progress monitor while opening a network: The progress monitor when opening a network

displays the current status, whether it be loading the network or creating the map.

¢ Show and notify other user’s login/logout activities: This option can be used to pop up a status
message in Paragon Planner when another user has logged into Paragon Planner, including details

such as the user name, client PC name and client PC IP address.

o Keep Alive Message: The server and client send keep-alive messages to make sure that the

connection stays up. This value sets the message interval time in seconds.

o Use SSL for Web Access: If this option is selected, then when Paragon Planner redirects users to the
Web Portal, it will direct them to a link prefixed with https using port 8443 rather than http on port
8091. By default this is determined by the Server Default setting, USE_SSL, in /u/wandl/bin/

mplsenvsetup.sh.

Figure 191: General Options
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Config Editor Options

The Config Editor Options window is used to set options for the Configuration Editor, which is a text

editor enhanced for configuration files. There are also two sub-options windows which allow you to




modify the colors and fonts used in the editor. For information on how to access the Config Editor, see
"Config Editor (Router and Switch)" on page 41.

Figure 192: Config Editor Options
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o Enable auto-completion: Selecting this option enables the intelligent auto-completion of commonly-
used configuration commands as you type.

e Show outline and property pane: Selecting this option displays two extra panes on the right-hand
side of the editor. The Config Editor divides each config file into blocks, based on significant
keywords. The outline pane provides an outline view of the config file based on these blocks and
allows you to quickly jump to a specific section of the config file. The property pane reveals
information regarding the router and associated config file, such as IP address, vendor, version
number, as well as the location of the config file.

e Show output/integrity check list: Selecting this option displays the results of the integrity checks in a
separate pane within the editor.

¢ Use memory-efficient alternative editor: Selecting this option disables the configuration-enhanced
text editor and uses the standard text editor when you open a router configuration file.

¢ Config Editor > Fonts: select to configure the font used by the config editor.

o Config Editor > Colors: select to configure the colors used by the config editor. See Set Color-Coding
and Other Options for more details.



Path Placement Options

Depending on the hardware type, this option may contain additional fields than what is described below.
For a description of those hardware-specific fields, see the hardware-specific guides.

Figure 193: Path Placement Options
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Field Description

New Link Prefix

The link prefix that gets used to generate the link name for newly added links. By default, this

is set to “NONE” which means no link name is generated.

Max Hop

The maximum number of hops allowed for a demand path




(Continued)

Field

Routing Method

Frame Size

Description

This specifies the method Paragon Planner will use to determine a demand’s path placement:
for example, Constant Distance, Actual Mileage, Delay, Admin. Weight, OSPF, ISIS, IGRP, or
EIGRP.

Constant Distance: Each link in the network has the same distance metric. When a
demand is to be placed, the program finds a minimum distance path. Since each link has
the same metric, this effectively translates into finding a shortest hop path.

Actual Mileage: The distance metric for each link in the network is based on its airline
mileage. In determining a path, the program will search for a minimum distance path.
Note that because of various tariff regulations, the shortest distance path may not always
be the least cost as well.

Admin. Weight: This distance metric for each link in the network is assigned by you in the
bblink file miscellaneous field. If a metric is not assigned for a particular link, the linkdist
file node-to-node distance is used. Otherwise, the linkdistunit parameter in the dparam
file is used. The program will attempt to find the minimum distance path.

Delay: The delay metric for each link in the network is used to compute the shortest path,
not to exceed the Max Delay value. If the delay metric for a trunk is not assigned in the
bblink file, a default value is given based on the propagation delay and serialization delay.

OSPF: The distance metric for each link is based on the OSPF distance formula. For the
router module, this may be a configured OSPF metric, a configured OSPF reference
bandwidth/trunk bandwidth or 1078 / trunk bandwidth. In a Frame Relay or ATM
environment, it is set to 10”8 / available trunk bandwidth.

ISIS: Uses the ISIS distance metric.
IGRP: Uses the IGRP distance metric. This is a Cisco proprietary protocol.
EIGRP: Uses the enhanced IGRP distance metric. This is also a Cisco proprietary protocol.

CDV: The distance metric is based on the cell delay variation (CDV) for a trunk. The
program will find the minimum distance path based on the CDV for each type of trunk.

This defines the average frame size, in bytes, used in overhead calculation for traffic
utilization estimation and delay calculation.



(Continued)

Field

Link Balancing

Node Delay

Propagation
Delay

Advanced

Description
If there are parallel links between two nodes, this option is used to decide which link is used
to route a demand/tunnel. The following options are supported:

e Best Fit: This is used in layer3/layer2 multi-layer simulation for the router model. If there
are multiple tunnels between two nodes, the "bestfit" algorithm is used to select which
tunnel to use for traffic between those two nodes.

e Default: This uses the default algorithm implemented by the hardware.
e First Fit: This selects the first link encountered in the routing algorithm.

e Load Balance: This option will try to place the demands proportionally among the equal-
cost paths, by selecting the link with minimum traffic load.

e Random: This randomly selects a link; this is the default option for routers.

Sets the delay for the node. Delay is in milliseconds (ms).

Sets the propagation delay. Propagation delay is determined using the assumption that every
100 miles equals one millisecond of delay.



Field

Placement Order

Description

This parameter affects the placement order of demands. Possible values are:

High-Priority First: Input Order: Place high-priority demands before low-priority
demands. For demands with the same priority, sort by the order of the demands in the
input file.

High-Priority First: Scramble: Place high-priority demands before low-priority demands.
For demands with the same priority, sort randomly. This is the default used in Paragon
Planner.

High-Priority, High BW Demands First: Input Order: Place high-priority demands before
low-priority demands. For demands with the same priority, place high bandwidth
demands before low bandwidth demands. For demands with the same priority and
bandwidth, sort by the order of the demands in the input file.

High-Priority, High BW Demands First: Scramble: Place high-priority demands before
low-priority demands. For demands with the same priority, place high bandwidth
demands before low bandwidth demands. For demands with the same priority and
bandwidth, sort randomly.

Scramble Randomly: Sort all demands together randomly and place them accordingly.

Low Bandwidth Demands First: Scramble: Place low-bandwidth demands before high-
bandwidth demands. Among same-bandwidth demands, sort randomly. If there are
multiple links between two nodes, less demands can usually be routed if this option is
used. It is provided for worst-case study.

High Bandwidth Demands First: Scramble: Place high-bandwidth demands before low-
bandwidth demands. Among same-bandwidth demands, sort randomly.

Input Order: Route demands only by the order in the input file.



(Continued)

Field

Path Selection
Method

Force PBR Check

Ignore
Multiprocess

Ignore Max Delay

Allow Negative
Available
Capacity in Layer
3

Description

This parameter influences path selection when more than one shortest path is found to
route a demand. Possible values are:

e Hardware Implementation: Select among the shortest paths based on the existing
hardware’s implementation.

e Shortest Path Encountered First: (For experimentation) Among the shortest paths, use
the first one the program discovers, regardless of whether the hardware would select
that path. This feature might be useful in simulating a hardware device that uses a
different routing algorithm than the existing hardware.

e Select Randomly Among Best Candidates :(For experimentation) Randomly choose a
path among the paths with the shortest paths, regardless of whether the hardware
would select that path. This feature might be useful in simulating a hardware device that
uses a different routing algorithm than the existing hardware.

When set to True, this forces the program to check demands against Policy Based Routing
(PBR) even if there is no destination IP address defined on the demand. When set to false,
demands that do not have destination IP address defined are not checked against PBR.
Demands that do have destination IP address defined are checked against PBR regardless of
how this option is set.

Only interfaces of the same OSPF process/routing instance are allowed to exchange routing
tables and send traffic to one another. For what-if studies, however, this parameter can be
set to true to ignore this requirement and to see how traffic would route if they were in the
same OSPF process. For more details, refer to the Paragon Planner User Guide chapter,
Routing Instances.

If this option is selected, demands are placed even if they exceed the max delay constraint
property specified for the demand.

This selection specifies whether the available bandwidth of trunks will or will not be
checked during path placement. When Yes is selected, it is not checked. When No is
selected, it is checked. Hardware default selection will depend on the hardware
specification.



(Continued)

Field

Include Node’s
Admin Weight in
Path Length
Calculation

BGP

Field

IGP Override

Check IBGP
Policy

Use Live BGP
Table If
Available*

ECMP

Description

By default False, any admin weight on the node itself is not included in the path length
calculation. If set to True, then the admin weight on the node is added to the path length
calculation.

Description

When both a BGP and IGP path are available between two ASs, by default the BGP protocol is
treated as having the higher administrative distance/preference. If this option, IGP Override, is
set to true, then the IGP route is used instead of the BGP route. If this option is set to false, the
BGP route is used, as is usually the default in most networks. In the dparam file, set this
parameter to true by setting IGPoverride=1.

IBGP Policies may be used to change the BGP next hop info when passing BGP tables from one
speaker to another using IBGP neighbor definitions. To turn on IBGP policy checking, set this to
true. For performance reasons, you may want to change this flag to false for a network without
IBGP policies.

In the dparam file, set this parameter to true by setting chkIBGPflag=1 (O to skip IBGP policy
checking).

Live BGP routing tables can be used to create a live BGP table object file that can be loaded into
the program to route according to the live BGP routing table by specifying the livebgprtblobj file
in the specification file. The live BGP routing table may have additional information about the
BGP next hop to external IP addresses that is otherwise unavailable through the config files.
Select True to route according to the live BGP routing table specified in the specification file.
Select False to have the program route according to the BGP routing table information
generated from the config files and any additional BGP protocol parameters that were entered
into the BGP subnet file. In the dparam file, set this parameter to true by setting
useliveBGPrtbl=1.



Field Description

Max. ECMP Count This number specifies the maximum number of ECMP sub-flows that can be split from
one original flow.

Min. ECMP Flow BW | This bandwidth value specifies the minimum bandwidth a flow must have in order to split
it into sub-flows.

Hardware

This window allows you to specify the bandwidth of each type of trunk in the network, a limit on the
length of paths, and the demand priority scheme. The hardware type of the network is displayed for you,
but cannot be changed in this particular window.

Field Description

Hardware Type The current hardware type may be selected from the Hardware Options window. Note that
the available list of device models is based on the switch libraries that have been licensed
from Juniper Networks.

Reverse Priority The reversepri parameter determines which demand priority scheme should be used by
Paragon Planner.

"No" for larger numbers that have higher priority (1=lowest priority) and
"Yes" if smaller numbers have higher priority (1=highest priority).

Physical Hop This number specifies the hop limit of the actual hardware and is used only in simulation
Limit mode, primarily during the Simulate Path Placement function.

This parameter is not to be confused with the max hop parameter which is used during
design aspects of Paragon Planner.

Bandwidth, The bandwidth and overhead fields indicate the trunk values which the program uses, by

Overhead default, for the selected Hardware Type. If, for any reason, these values are inconsistent with
your expected values, this Hardware Options window is the place to modify them.
Bandwidth and link overhead are used in the routing and rerouting algorithms when
determining demand placement.

Multicast



Field Description

Enable PIM This option allows you to enable or disable all links as PIM-enabled.
PIM Mode This specifies the PIM mode for the multicast feature.

MPLS TE
Field Description

MPLS-Enabled
Mode

Tunnel Parameters:
Reuse ID of Deleted
Tunnels

Bandwidth Model

GlbPool/RSVP

SubPool/GB

This option allows you to enable all links as MPLS-enabled, or have them set as specified
per link in the Protocols tab of the Link window.

This specifies whether or not IDs of deleted tunnels should be reused. This applies to
Tunnel ID groups that are used to rename tunnel IDs to Cisco'’s default tunnel ID format.
When a tunnel that has been assigned a tunnel ID is deleted, whether or not its ID is
reused is determined by this option.

This determines how bandwidth for multiple classes is displayed in the Link window. User
can choose between Maximum Allocation Model (MAM) and Russian Doll Model (RDM).
Refer to the Paragon Planner User Guide, chapter DiffServ Traffic Engineering Tunnels for
further details on the RAM and MAM bandwidth models.

This defines the percentage of bandwidth reserved on a link for global pool / RSVP. This
setting is the default global setting for the entire network.

This defines the percentage of bandwidth reserved on a link for sub pool / GB
(Guaranteed Bandwidth). This setting is the default global setting for the entire network.

MPLS TE LSP Tunnel Attributes

Type over the bitxx to a name you want to be associated with your attributes on the Tunnels and links.

Reserved Bandwidth



Field

Reserve Bandwidth

File

Ethernet Fat (%)

Default Fat (%)

Default Fixed Fat

Description

The Reserve Bandwidth File field indicates the path of the reserved bandwidth file that is
being used, if any. To incorporate the reserved bandwidth file into the network model,
you can import it using the File > Read, Network Files tab, Control Files category,
rsvbwfile.

The file specifies reserved bandwidth information for specific trunks.

Global parameter that indicates the default percentage of bandwidth to be reserved for
ethernet trunks. This parameter can be overridden in the rsvbwfile.

Global parameter that indicates the default percentage of bandwidth to be reserved for all
trunks. This parameter can be overridden in the rsvbwfile.

Global parameter that indicates the default amount of bandwidth to be reserved for all
trunks. Fixed fat is specified in either bits or kilobits. This parameter can be overridden in
the rsvbwfile.

Failure Simulation Options

Figure 194: Failure Simulation Options
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Field Description

Include Never CanFail trunks | This field specifies whether “CanFail = 0” trunks should be included in link failure
in failure simulations simulations. A link marked as “CanFail = 0” represents a link that will never fail. A
link marked as “CanFail = 1" represents a link that will fail.

Exclude Currently Unplaced This field specifies whether unplaced demands should be included in the failure
Demands simulation. Note that unless specified in this option, unplaced demands are listed
along with failed demands in the node, link, and single line failure simulations.

Include AS Node/Link If set to Yes, AS nodes and AS links are failed in the exhaustive node and link
simulations, respectively. To exclude the AS nodes and AS links from the
exhaustive simulations, set this option to No.

Drop all Demands/Tunnels During node failure simulation, demands and tunnels that are lower than the
with Priority lower than defined value are automatically dropped and will not be rerouted in the
<value> when a Node Fails simulation results.
Drop all Demands/Tunnels During link failure simulation, demands and tunnels that are lower than the
with Priority lower than defined value are automatically dropped and will not be rerouted in the
<value> when a Link Fails simulation results.

FRR

This window defines the default FRR mode used during failure simulation batch scripts. If no FRR mode
is specified in failure simulation batch scripts, the script will use the FRR mode specified in this window
by default. The FRR modes are explained in the table below:

|n

Normal Simulates the “normal” tunnel reroute. Does not consider the effect of the FRR detours during

the simulation. Peak utilization reflects that during the “normal” situation.

FRR only Simulates only the FRR detour. The resulting link peak utilization report reveals just the peak
utilization experienced during the detour.

FRR + Normal ' Simulates the FRR detour first followed by the normal primary tunnel reroute as established at
the head-end router. The resulting link peak utilization report identifies the worst utilization, or
max value of the transient detour and normal modes.

NOTE: A primary tunnel being detoured is marked down if it cannot be rerouted.



Failure Report

Verbose Mode

Sequential Mode

Trace File

Display Paths at
Failed Nodes

Exclude Path
Required Demands
in Failure Statistics

Report Tunnel
Utilization

Resize Options

Specifies whether output results should be in detailed (verbose) or summary format. When
in verbose mode, the program will draw colored lines representing failed and rerouted
demands on the topology map during interactive failure simulations. When verbose mode
is disabled, no such lines are drawn on the map during interactive failure simulations.

This option allows you to sequentially step through a given simulation run. You can
advance to the next simulation by clicking the left mouse button. If sequential mode is set
to “No”, the simulation will automatically run to completion.

This option specifies whether a trace file should be used to record simulation output
results.

Specifies whether paths that originate or terminate at a failed node should be displayed in
the simulation output. All such demands will obviously be brought down in a node failure.

Specifies whether demands that failed because of path required criteria should be
excluded in the simulation. If a demand is defined with a path required field and that path
is not available for some reason, the demand will fail. The program will not attempt to
reroute the demand on an alternate path.

When running an exhaustive failure simulation in layer 3 and selecting Generate Peak
Utilization Report, the Tunnel Peak Utilization report generation can be turned off by
setting this to No.

The Resize Options may be used to tune and optimize the current backbone topology. Accessed from

Design > Backbone > Resize, this design feature will modify the current link bandwidths to maximize

utilization. Three resize options can be chosen: based on the current peak simulation results, based on
normal utilization, or based on exhaustive node/link/SRLG failure simulation results. This analysis and
modification presume that there might be unnecessary bandwidth in certain links and also take into

account the additional bandwidth necessary during demand rerouting. When the resize option is

performed, Paragon Planner replaces links in the network in accordance with the Link Type Candidate

selected in the Design Options window.



Field

Additional Trunk
Penalty

Types in Tariff

AGGR

Description

Added penalty during Resize for replacing large trunks with multiple trunks of smaller

size.

Valid link types are taken from the current tariff table

For the aggregate link type, valid link types are based on multiples of a specified unit,
for example, if the unit is 10G, then the resize will choose multiples of 10G, for
example, AGGR10G, AGGR20G, etc.



I Map Preferences

The color scheme and display options of the topology map may be changed in the Map Preferences

window. Click on any color to change it. You may also change options related to the display of the
network topology.

Figure 195: Map Preferences Window
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Field Description
Background This selects the color for the background on the topology window.

Foreground Text

This selects the color for text labels and other foreground items.

419
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Field

Grouping Discs

Selected Objects

Failed Elements

Backup Links

Virtual Trunks

Country Borders

Mouse Drag Lines

Font Size

Paint Discs

Draw multiple links as
curves

Show utilization max
instead of average within
bundle

Description

This selects the color for any groups in the topology defined by you. A group is a
region that can be set by you.

This is the color for any user-selected objects in the topology window.

This is the color for failed elements (links, nodes, facilities, etc.)

Allows you to set the color for back-up links.

Allows you to set the color for virtual trunks.

This selects the color of country borders when the country map is displayed in the
Topology window.

Specifies the color of the lines shown when you click and drag the mouse in the
topology window.

You may increase or decrease the font size of text (such as node labels, link labels,
etc.) that appear in the Topology window.

Allows you to select a method for painting discs for groups on the topology map.
The choices are: translucent, quick rings, opaque and none. On some machines,
choosing quick rings or opaque may improve performance.

When checked, the program will draw multiple links between a given node pair as
curves for better display of the paths.

If Draw multiple links as curves is not checked, then multiple links are drawn as one
bundled link.

When Show max is not checked, the utilization displayed from mouse-over in the
bottom bar of the map is the Average utilization of the multiple links.

When Show max option is checked, the utilization displayed from mouse-over in the
bottom bar of the map is the Highest utilization of the multiple links.



(Continued)

Field

Animate Distribute Points

Animate Paths

Group by LAN in default
layout

Show VT as normal

Automatically save
graphcoordaux file when
closing a network

Reset

Defaults

Apply

OK

Cancel

Help

Description

When checked, this option will animate the Distribute Points function in the
Topology window. Refer to the Topology chapter for more information.

This option will animate the path between two points in the topology, showing the
direction the path is flowing. Turning off the animation will improve the
performance of the system.

Selecting this option will cause the initial layout when opening a network to attempt
to layout nodes in such a way that minimizes LAN link lengths as much as possible.
Since this only affects the initial layout when opening a network, changes made to
this option will not have any effect until a new network is opened.

This option should be turned off if nodes connected by ethernet can be separated

by longer distances.

Displays virtual trunks as regular trunks. When this option is not checked, virtual
trunks are always displayed in the color chosen above.

By default, the graphcoordaux file is automatically saved when closing a network to
avoid losing auxiliary changes made to the map, such as map legend settings.
Uncheck to disable this feature.

Resets options to the previous settings.

Sets options to the system default settings.

Applies new settings immediately without closing the Map Preferences window.

Applies new settings and closes the dialog window.

Cancels the any changes.

Opens the help documentation.



Report Options

The Report Options window is used to customize the format of reports generated through Paragon
Planner.

Figure 196: Report Options
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Field Description
Runcode The runcode is the filename extension appended to the end of each output file generated in a

particular run of Paragon Planner. It allows you to distinguish amongst several sessions using the
same data set. To specify a runcode, you should type the desired input in the Runcode text box
of the Report Options window. This runcode may consist of a combination of alphanumeric
characters. Subsequently, any report files generated is in the format filename.runcode. It is

important to use unique runcodes. Otherwise, there is a danger of accidentally overwriting

existing files with the same names.
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Field

Owner

Path
Reference

Node
Reference

Link
Reference

Report Style

Bandwidth
Unit

Distance Unit

Description

You can choose to view report data related only to the specified owner(s).

This option sets the display preference for paths in the report.

In report files, nodes may be referred to by either node name, node ID, or hostname.

In report files, links may be referred to by using one of two conventions. The standard method is
to represent a link by the node pair that defines it. An alternative method is to associate a user-
defined link name with that link. If a link name is not defined for a link, the node pair naming
convention is used. To use either method, select the appropriate box in the Link Reference
section. Note: This option applies not just to report files, but also to some console messages, for
example, those displayed during an Exhaustive Single Line Failure.

You may specify the file format of subsequent reports in the Report Options section. Three
formats are supported: Formatted Text, CSV, and HTML. Formatted Text is simply standard
ASCII output that may be viewed in any text viewer without additional preprocessing. Comma
delimited format (CSV) outputs text so that a comma is used as a separator for each distinct field
in the report. This is most often used to import report files into spreadsheet applications, and
can be viewed using the Report Viewer. Finally, Hypertext Markup Language format (HTML)
outputs reports in HTML-compliant format so that the report files can be directly viewed by
web page browsers.

The bandwidth unit used in reports may be selected in the Bandwidth Unit section of the Report
Options menu. The Best Fit option can be used when there is a large number of different
bandwidth types being used. Reports generated with the Best Fit option may contain Bits,
Kilobits, or Megabits depending on the available field space. Note that cells may only be
selected for ATM hardware devices. In the ATM case, values entered in bits are converted to the
appropriate number of cells using a conversion formula. Decimal Places is the number of digits
to the right of the decimal point displayed in reports.

The distance unit used in report files may be specified in the Report Options menu. To specify a
distance unit, go to the Distance Unit section and select an appropriate one. The available
options are miles and kilometers (km).



(Continued)

Field Description

Currency Sets the currency unit for Paragon Planner. To specify a currency, first go to the Currency
section. Then, select a country from the drop-down combo box listing the available countries.
Once this is done, the selected country's associated currency unit is used in subsequent
monetary values.

NOTE: For the EURO currency used in various European countries, select ER EURO from the
country list. The Euro unit is displayed as ER.
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Spec File

The specification file contains a list of the files that characterize a network. Each line specifying a file
location should be in the format, keyword=filename, where keyword is the file type name and filename is
the file path (either absolute or relative to the path specified in the datadir variable). Note that both
keyword and filename are case-sensitive. Following are a list of keywords.

Type Description

Backbone data files = bblink, demand, domain*, facility*, graphcoord, group, muxloc, newdemand, nodeparam,

owner*, site
Cost Files custrate*, intlratespec*, ratespec, usercost, usercountrycost
Control Files fixlink, linkdist, nodeweight, rsvbwfile

A specification file also includes the following keywords:

runcode default file extension when saving files

datadir default input file directory prefix

ratedir tariff database directory

dparam file containing design parameters

For keywords for hardware-specific files, please see the appropriate document.

Backbone Data

MUXLOC (muxloc=filename)
Description: Node File

General format (United States and Canada locations):

#nodeID name npa nxx[MISC]
NO1 NYC(5WTC) 212 392



General format (International locations):
#nodeID name npa nxx countrycode lat long [MISC]
N33 LEED 999 999 UK 534959N 0013459W

BBLINK (bblink=filename)

Description: Link File

#[LinkName] NodeA NodeZ Vendor # BwType [Misc]
N2 N6 ATT 3 T3
LINKT N3 N4 DEF 1 0C3

DEMAND (demand=filename)

Description: Demand File

#DemandID NodeA NodeZ bw Type_field Pri,Pre [Path]
T000123A NO1 N@2 256000 R2 12,10 NO1-N@5-N02

To add more demands without modifying the original demand file, use the

NEWDEMAND file (newdemand=filename)

NODEPARAM (nodeparam=filename)

Description: Node Hardware Type File

#nodeID/name hwtype [MISC]
Y36 MUX

SITE (site=filename)
Description: Site Definition File (useful for diversity design, simulation, path placement, pricing)

Purpose: The site file is used to define sites as logical groupings of nodes. The site definitions are used
for the purpose of failure simulation, diversity design, and diverse path placement. By default, if a node
is not included in a user-defined site definition, it is treated as being in a site of its own for these
purposes. Site information can also be used to facilitate pricing specifications, as in the usercost
file.Purpose: The site file is used to define sites as logical groupings of nodes. The site definitions are
used for the purpose of failure simulation, diversity design, and diverse path placement. By default, if a
node is not included in a user-defined site definition, it is treated as being in a site of its own for these
purposes. Site information can also be used to facilitate pricing specifications, as in the usercost file.



Usage: Each line entry in the site file uses the following syntax to indicate the nodes in a site:

#sitename=nodel=node2=. . .=nodeN
mysite@1=No8

mysite@2=N46=N86 = N71 = N72 \
= N73 = N74

A node can be indicated by ID or name. If you need multiple lines to define a site, use a back slash
character (\) to continue the entry from one line to the next. Choose site names that differ from node
names to avoid potential confusion in the input data.

GROUP (group=filename)

Description: Topology Groups File (useful for visual grouping; unlike the site file, this file does not
influence diversity design, simulation, path placement, or pricing)

# Group_name Members
GROUPA N1, N2, N3

Grouping is a topology feature used to group nodes together. If you save your specification file with
groups, the next time you open it up, nodes in a group is grouped together under one group symbol.

GRAPHCOORD (graphcoord=filename)

Description: Topology Window Definition and Node Coordinates (useful for display only; to be
distinguished from latitude & longitude coordinates and geographical V & H coordinates)

window 1228 158 2114 1515

#first line defines the window size, Only locations and #line segments within
the window coordinates are displayed.

#node npa nxx graph_v graph_h

NOO1 212 406 4919 1447

NO®2 212 406 4933 1570

NOO3 212 406 5154 1394

END

Graphics coordinates for backbone nodes may be changed by moving locations around on the topology
map and using the Map Views feature. Note that changing the graphical coordinates does not change
geographical information which is stored in the muxloc file.

DOMAIN (domain=filename)



Description: Domain File

#domain_ID domain_name color
1 REDNET MAGENTA

V2 BLUENET BLUE

TRANSIT=V2

This file is needed only for large networks that are to be partitioned into different areas (domains). In it
you can specify the ID, name, and color of domain regions. Nodes in different domains may only
communicate with each other through gateway nodes. The domain file allows for node/link coloring by
domain and for the specification of a transit domain.

For the Domain_ID, the format Dd, where d is a number, is reserved to signify a domain with domain
number of d. For domains using this format, leading zeros are ignored, so D5, D05, and DOO5 are all
treated as the same domain identifier.

NOTE: This file can also be used for OSPF areas instead of domains. Depending on the hardware
vendor specified in the dparam file (hwvendor=hardware_vendor), the domain file is interpreted
to contain domains or OSPF areas.

OWNER (ownerfile=filename)

Description: Owner File

#OwnerID Name Color
G1 wandl blue
G5 wandl2 red

The purpose of this file is to facilitate the identification of node and demand ownership. By defining an
owner and associating certain demands with that owner, service providers that carry traffic of several
companies can use the owner feature to quickly determine the distribution of traffic in the network.

To associate a demand with an owner, the type field of the demand's entry in the demand file should
include ownerID where ownerID is substituted by the corresponding ownerID in the owner file. To
associate a node with an owner, specify OWNER=ownerID in the miscellaneous field of the muxloc file.
Owner names defined in the muxloc and/or demand files are automatically added to the owner list if
they are not defined in the owner file.

Valid Color Values: Red, Green, Cyan, Blue, White, Magenta, Yellow.

FACILITY (facility=filename)



Description: Facility Definition File (useful for diversity design, simulation)

#Facility_name net_elementl [net_element2 J*
FACT L2N2N3 L3N2N3

FAC2 L2N4N5 L3N4N5 L4N4N5 \

L5N4N5

The facility file is used to define facilities as logical groupings of nodes and links. The facility definitions
are used for the purpose of failure simulation and diversity design.

Each entry of the facility file should be a separate line containing a facility name followed by the
associated node ID (or node name) or link name.

The network elements should be delimited by tabs, spaces, or commas. If you need multiple lines to
define a facility, use a back slash character (\) to continue the entry from one line to the next.

The facility feature does not check the validity of the nodes and/or links listed in the facility file.
Duplicate links and/or nodes will also be duplicated in the facility. If both are used in the same facility,
then that node is duplicated. Nodes that are not in the muxloc file and links not in the bblink file are
ignored.

TRAFFIC LOAD (trafficload=filename)

Description: Peak Load by Period

#Facility_name net_element1

The format for the traffic load file is shown below:
# --Peak load in bits--

#DmdID Dir AvgFrameSize Periodl Period2 etc..

Vooo1 - 20 12800 12800 12800 12800

FO001 A2Z 87 6852 2083 1372 2749

FOOO1 Z2A 456 18795 11703 4578 5065

For each demand, peak load information can be recorded in this file for various time periods. Data
collected from the network or user-defined data can be stored in this file. Upon reading this data, the
program can then calculate link bandwidth utilization at different times based on this information. This
feature is applicable to ATM, Frame Relay, or Router networks.

e DmdID must correspond to a demand ID defined in the demand file. The direction of the demand
may be specified using one of the following three identifiers: "-" for Two-way, "A2Z" for One-way
from Origination switch to Destination switch, or "Z2A" for One-way from Destination switch to
Origination switch.

e Alternatively, The FromNodeCardPort or ToNodeCardPort can be specified instead of the DemandID.



e AvgFrameSize indicates the average frame size of the demand. It may be specified using a number or
a dash. It is assumed that overhead is already included in the interval definition.

e "# bytes_in_frame": Traffic load specified is adjusted based on whether it is being routed over a
frame or cell trunk.

e The remaining columns (Period 1, Period 2, etc.) indicate the traffic load (bits) measured during the
corresponding interval. A maximum of 24 intervals may be specified per PVC.

e The field "unit = number" may be placed before the actual traffic data for demands or tunnels. The
default unit value is 1 bit. All the traffic data in the traffic load file is interpreted as kilobits if the value
of unit is specified as 1000. The data unit is interpreted as byte if unit = 8 is specified.

TRAFFICPATTERN (TRAFFICPATTERN=filename)

NOTE: This file is for discrete event simulation only.

#traname #msg Duration Msg size framsize
# second bits bytes

PATTERN1 1.0 2.0 160000 1500

PATTERN2 3.0 1.0 2000000 256

PATTERN3 4.0 3.0 500000 1000

PATTERN4 1.0 1.0 1000000 1000

The traffic pattern file allows you to define several class types based on traffic characteristics. Each
traffic type may be specified in terms of four parameters: number of messages, duration (seconds),
message size (bits), and frame size (bytes).

In the example above, PATTERN1 is defined as 1 message lasting 2.0 seconds, with a message size of
160,000 bits and a frame size of 1,500 bytes. PATTERN2 is defined as 3 messages lasting 1 second, with
a message size of 2,000,000 bits and a frame size of 256 bytes. PATTERNS is defined as 4 messages
with a duration of 3 seconds, a message size of 500,000 bits and a frame size of 1,000 bytes.
PATTERN4 is defined as 1 message lasting 1 second, with a message size of 1,000,000 bits and a frame
size of 1,000 bytes.

TRAFFICDATA (TRAFFICDATA=filename)



NOTE: This file is for discrete event simulation only.

#format = unit unit_size

#interval = x (number of seconds)

#pvcname direction #unit unit_size #unit2 unit_size2
format line may be one of the following:

packet size

byte size

bit size

size packet

size byte

H O oH H O H O HF =

size bit

format = packet size

interval = 300

PVC1 A2Z 16,48,30,512,35,256,20,512
PVC1 Z2A 10,48,20,512,30,256

PVC2 A2Z 20,48,50,512

PVC2 Z2A 20,48,50,512

The traffic data file allows you to define each demand by specifying multiple packets and packet sizes.
Although this requires you to have a reasonable knowledge of the traffic, more accurate simulation
results can be obtained in this manner. For each PVC, up to 10 pairs (#unitx and unit_size) may be
specified in defining the demand. Note that although the PVC definition entries in the example above
are delimited by commas, you may also use spaces and tabs to separate entries.

This file specifies an interval of 300 seconds (5 minutes), and defines a traffic distribution for two PVCs.
In this example, the PVCs are full duplex (both A2Z and Z2A directions are defined). To define a simplex
PVC, specify either A2Z or Z2A for the direction field. The direction field assumes that a demand from
the first node to the second node is marked as A2Z, and the reverse direction as Z2A. During the 5
minute interval, 16 packets of 48 bytes, 30 packets of 512 bytes, 35 packets of 256 bytes, and 20
packets of 512 bytes were sent in the A2Z direction of PVC1. Similarly, 10 packets of 48 bytes, 20
packets of 512 bytes, and 30 packets of 256 bytes were sent in the Z2A direction of PVC1. In PVC2
from the A2Z direction, 20 packets of 48 bytes, and 50 packets of 512 bytes were sent. The identical
distribution is present for PVC2 in the Z2A direction because they have identical traffic entries.



Control Files

FIXLINK (fixlink=filename)

The format of the fixlink file is exactly the same as that of the bblink file. This file is used to tell Paragon
Planner that the links specified in this file should not be deleted during backbone link design.

LINKDIST (linkdist=filename)

#from to dist
NO1 NO2 5
NO1 NO3 1

This file contains default distances (admin weights) that can be assigned between backbone nodes. If the
hopdist design parameter (in the dparam file) is set to Adm_Weight, then the distances in the linkdist file
may be used to calculate the lengths of the demand paths during path placement. The only way to
override this admin weight is to use the admin weight specified in the miscellaneous field of the bblink
file for a particular link between two nodes. In the bblink file, use "DIST=x" (symmetric), "DISTA2Z=x", or
"DISTZ2A=x" (asymmetric), where x is substituted by a number.

For a link between a node pair not listed in the linkdist file, the admin weight defaults to the linkdistunit
parameter in the dparam file. This parameter can be specified in the "User-Defined Link Distance"
function of the "Read Files" menu in the text version of BBDsgn. If linkdistunit is positive, that value is
the default admin weight for all links. If linkdistunit is negative, the default admin weight for all links is
calculated as the airline distance between each pair of nodes divided by the absolute value of
linkdistunit and rounded up to the nearest integer. For example, if linkdistunit=-50, the user-defined
distance for links from 1 to 50 miles is 1. Similarly, for links from 51 to 100 miles, the user-defined
distance is set to 2.

NODEWEIGHT (nodeweight=filename)

#nodeID/name nodeweight trunk-bandwidth-limit transit-bandwidth-limit
NO0O7 100 500M 1000M

Noo11 -1 10808000

NO@10 BLOCK

¢ Node weight, or Link Penalty for Design: A penalty at a node for purchasing links at it during a
design. Use a number less than 100000. If 200000 or higher, this value has another meaning: no
pass-through demands are allowed in design mode.



e Trunk-bandwidth-limit: a maximum trunk bandwidth capacity at a node that gets used during design,
and For example, if the trunk-bandwidth-limit is set to 5M (5Mbps) and the link type being designed
foris a T1, then only 3 T1s (each ~1.5 Mbps) can be added since 4 T1s would exceed this limit.

e Transit-bandwidth-limit: a maximum transit demand bandwidth capacity for a node that gets used for
path placement. For example, specifying a limit of O will prevent pass-through demands at a node.

NOTE: A node weight is required if maximum link bandwidth capacity is to be specified. The
default Node Weight is O and the Default Maximum Link Bandwidth Capacity is infinity.

RSVBWEFILE (rsvbwfile=filename)

#node1 node2 fixfat fatpct
NO1 NO2 128000 0.1
No5 N10 256000 0

The fixfat and fatpct parameters in the dparam file are used to globally define reserved bandwidth for all
links in the network. To define reserved bandwidth for specific node pairs, the rsvbwfile should be used.
Reserved bandwidth is calculated based on values in the rsvbwfile. For node pairs not defined in this file,
reserved bandwidth is calculated based on the fixfat and fatpct global parameters. To follow the
reservation constraints, BBDsgn will avoid using reserved bandwidth during path assignment and

backbone design. In failure analysis/failure simulation routines, however, these reservation constraints
are ignored.

Cost Files

CUSTRATE (custrate=filename)

Description: Customized Tariff File

DIST= MILE #DIST= Unit of measure; KM or mile

COUNTRY= IT #Specifies the Country Rate

INCR_DIST=0.1 MILE #Incremental unit:@.1 MILE (default=1 M)
#service class1 class2 NRC [tomile fix rate_per_incdist]#*
0C3 ALL ALL 1000 9999 270000 600
T3 CA CB 1000 100 300 30 9999 1000 20

The custrate file is used to define tariff rates for links that cannot be priced out using the tariff database.



For any link, the rate depends on the service used and the class of the nodes of the link's endpoints. The
service field denotes a trunk type like OC3 or T3. The fields class1 and class2 are logical groupings of
nodes. These classes are defined by adding a CLASS=classname in the miscellaneous field of the muxloc
file.

The pricing method used is the band method. For a given link, the non-recurring charge is NRC and the
recurring charge depends on the mileage band it falls under.

Following the first four fields are a set of three numbers representing the first mileage band. Subsequent
triplets represent subsequent mileage bands. The field tomile indicates the end of the mileage band.

The recurring charge is determined using a fixed rate plus a rate per incremental distance. That is:
Recurring charge = fixed_rate+(rate_per_inc_dist/inc_dist)*link_airline_distance

Example: Suppose we have a 200 mile T3 link between a node in class CA and a node in class CB. Using
the custrate file specified above, the link would fall within the second mileage band. The non-recurring
charge would be 1000. The recurring charge would be 1000+(20/0.1)*200=41000.

USERCOST (usercost=filename)

The usercost file is used to define the cost for links according to the end nodes, vendor, and trunk type.
The format of the usercost file is as following:

#from to vendor type [cost/mo.]
NO1 N@2 ATT T1 1000.00

NO1 NO2 ATT FT56K 300.00

NO1 N@2 WTG FT56K 250.00

N@3 NO4 USS T1

site2 site3 USS T1 2000.00

NO5 site3 USS T1 2000.00

NO5 site3 ATT T1 2200.00

The from and to fields should specify a node ID, node name, or site name. If a site name is entered, the
assignment applies to all locations in that site. You should ensure that site names are different from node
names in order to prevent pricing inconsistencies.

If more than one vendor is assigned to the same type for the same node pair, then the least cost vendor
is treated as the default vendor. In the example above, the default vendor for a FT56K link between NO1
and NO2 is WTG. If ATT is selected as the vendor for a FT56K between NO1 and NO2, the cost of that
link is calculated as $300.

If site names are specified in the from/to fields, then the price and default vendor assignments apply to
all the locations in the site specified. The default intra-site cost is O.



USERCOUNTRYCOST (usercountrycost=filename)

#CountryCodeA CountryCodeZ vendor type [cost/mo.]
FR GE DEF FT64K 1000.00

The only difference is that the from and to fields are replaced by two-letter country codes rather than
node Ids.
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Exact Match Strings

This appendix describes the search preferences available in Paragon Planner and examples of how
strings are matched. This applies to the Find and Advanced Filter windows of the Paragon Planner client
(for example, Find Node, Find Link) and to the AutoGroup by Regular Expression (Regexp) option in the
topology map.

String Matches Does Not Match
foo foo food, Foo
foo foo, food, afoot fox, Foo
foo foo food, Foo
foo* foo, food afoot
*foo* foo, food, afoot

foo? food foo, foods
foo foo, food, afoot fox, Foo
fo foo, fox fo

pa*t pt, pat, paaat paa

pa+ pa, paa, paaa p

pa?t pt, pat paat
[NI]pat Npat, Ipat Jpat, npat

~pat pat, patty ipat



(Continued)

String

pat$

pa{2}

pa{2,}

pa{2,3}t

\d

\D

\s

\S

\w

\W

Matches

pat, ipat

ipaat

paa, paaa

paat, paaat

any digit

any non-digit

any white space character

any non-white space character

any alphanumeric character

any non-alphanumeric character

Pa, papa, papapa

banana

Does Not Match

patty

pa

pa

pat, paaaat
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