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About this Guide

• Objectives on page xv

• Audience on page xvi

• Conventions on page xvi

• List of Technical Publications on page xvii

• Requesting Technical Support on page xviii

Objectives

Network and Security Manager (NSM) is a software application that centralizes control

andmanagementof your JuniperNetworksdevices.WithNSM, JuniperNetworksdelivers

integrated, policy-based security and network management for all security devices.

NOTE: NSM supports only the domestic version of JUNOS on J Series and
SRX Series platforms.

This guide provides the information you need to understand, configure, andmaintain J

Series Services Routers and SRX Series Services Gateways using NSM. The J Series and

SRX Series device configuration features that are detailed in this guide are as follows:

• User Authentication

• Chassis

• USBModem Interfaces

• Policy Options

• Routing Options

• Protocols

• Integrated Convergence Services

• SNMP

• DHCP

• Class of Service

• Application Layer Gateway (ALG)

• Unified Threat Management (UTM)
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NOTE: Because the NSM device-side configuration guides are not updated
on the same release schedule as the JUNOS releases, consult the JUNOS

Software Documentation for information about configuration settings that

might occur in NSM and not in the device-side configuration guides or vice
versa.

Audience

This guide is for the system administrator responsible for configuring J Series Services

Routers and SRX Series Services Gateways.

Conventions

Table 1 on page xvi defines notice icons used in this guide.

Table 1: Notice Icons

DescriptionMeaningIcon

Indicates important features or instructions.Informational note

Indicates a situation that might result in loss of data or hardware damage.Caution

Alerts you to the risk of personal injury or death.Warning

Alerts you to the risk of personal injury from a laser.Laser warning

Table 2 on page xvi defines text conventions used in this guide.

Table 2: Text Conventions

ExamplesDescriptionConvention

• Issue the clock source command.

• Specify the keyword exp-msg.

• ClickUser Objects

• Represents commands and keywords
in text.

• Represents keywords

• Represents UI elements

Bold typeface like this

user inputRepresents text that the user must type.Bold typeface like this
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Table 2: Text Conventions (continued)

ExamplesDescriptionConvention

host1# 

show ip ospf
Routing Process OSPF 2 with Router
 ID 5.5.0.250
Router is an area Border Router 
(ABR)

Represents information as displayed on
the terminal screen.

fixed-width font

Ctrl + dIndicates that youmust press two ormore
keys simultaneously.

Key names linkedwith a plus (+) sign

• The product supports two levels of
access, user and privileged.

• clusterID, ipAddress.

• Emphasizes words

• Identifies variables

Italics

Object Manager > User Objects > Local
Objects

Indicates navigation paths through the UI
by clicking menu options and links.

The angle bracket (>)

Table 3 on page xvii defines syntax conventions used in this guide.

Table 3: Syntax Conventions

ExamplesDescriptionConvention

terminal lengthRepresent keywordsWords in plain text

mask, accessListNameRepresent variablesWords in italics

diagnostic | lineRepresent a choice to select one keyword or
variable to the left or right of this symbol. The
keywordor variable canbeoptional or required.

Words separated by the pipe ( | )
symbol

[ internal | external ]Represent optional keywords or variables.Words enclosed in brackets ( [ ] )

[ level1 | level2 | 11 ]*Represent optional keywords or variables that
can be enteredmore than once.

Words enclosed in brackets followed
by and asterisk ( [ ]*)

{ permit | deny } { in | out } { clusterId
| ipAddress }

Represent required keywords or variables.Words enclosed in braces ( { } )

List of Technical Publications

Table 4 on page xviii lists the manuals supporting Network and Security Manager and

JUNOS software for J Series and SRX Series platforms. All documents are available at

http://www.juniper.net/techpubs/.
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Table 4: Technical Documentation for NSM and J Series Services Routers and SRX Series
Services Gateways

Details the steps to install the NSMmanagement system on
a single server or on separate servers. It also includes
information on how to install and run the NSM user interface.
This guide is intended for IT administrators responsible for the
installation and/or upgrade of NSM.

Network and Security Manager Installation Guide

Describes how touseandconfigure keymanagement features
in the NSM. It provides conceptual information, suggested
workflows, and examples where applicable. This guide is best
used in conjunctionwith the NSMOnline Help, which provides
step-by-step instructions for performing management tasks
in the NSMUI.

This guide is intended for application administrators or those
individuals responsible for owning the server and security
infrastructure and configuring the product for multi-user
systems. It is also intended for device configuration
administrators, firewall and VPN administrators, and network
security operation center administrators.

Network and Security Manager Administration Guide

Describes NSM features that relate to device configuration
andmanagement. It also explains how to configure basic and
advanced NSM functionality, including deploying new device
configurations, managing Security Policies and VPNs, and
general device administration.

Network and Security Manager Configuring Firewall/VPN
Devices Guide

Provides task-oriented procedures describing how to perform
basic tasks in the NSM user interface. It also includes a brief
overview of the NSM system and a description of the GUI
elements.

Network and Security Manager Online Help

Explains how to configure SRX Series and J Series interfaces
for basic IP routing with standard routing protocols, ISDN
service, firewall filters (access control lists), and
class-of-service (CoS) traffic classification.

JUNOS Software Interfaces and Routing Configuration Guide

ExplainshowtoconfigureandmanageSRXSeries and JSeries
security services such as stateful firewall policies, IPsec VPNs,
firewall screens, Network Address Translation (NAT), Public
KeyCryptography, chassis clusters,ApplicationLayerGateways
(ALGs), and Intrusion Detection and Prevention (IDP).

JUNOS Software Security Configuration Guide

Shows how tomonitor SRX Series and J Series devices and
routingoperations, firewall andsecurity services, systemalarms
and events, and network performance. This guide also shows
how to administer user authentication and access, upgrade
software, and diagnose common problems.

JUNOS Software Administration Guide

Requesting Technical Support

Technical product support is available through the JuniperNetworksTechnicalAssistance

Center (JTAC). If you are a customer with an active J-Care or JNASC support contract,
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or are covered under warranty, and need post-sales technical support, you can access

our tools and resources online or open a case with JTAC.

• JTAC policies—For a complete understanding of our JTAC procedures and policies,

review the JTAC User Guide located at

http://www.juniper.net/us/en/local/pdf/resource-guides/7100059-en.pdf.

• Product warranties—For product warranty information, visit

http://www.juniper.net/support/warranty/.

• JTAC hours of operation—The JTAC centers have resources available 24 hours a day,

7 days a week, 365 days a year.

Self-Help Online Tools and Resources

For quick and easy problem resolution, Juniper Networks has designed an online

self-service portal called the Customer Support Center (CSC) that provides youwith the

following features:

• Find CSC offerings: http://www.juniper.net/customers/support/

• Search for known bugs: http://www2.juniper.net/kb/

• Find product documentation: http://www.juniper.net/techpubs/

• Find solutions and answer questions using our Knowledge Base: http://kb.juniper.net/

• Download the latest versions of software and review release notes:

http://www.juniper.net/customers/csc/software/

• Search technical bulletins for relevant hardware and software notifications:

https://www.juniper.net/alerts/

• Join and participate in the Juniper Networks Community Forum:

http://www.juniper.net/company/communities/

• Open a case online in the CSC Case Management tool: http://www.juniper.net/cm/

Toverify serviceentitlementbyproduct serial number, useourSerialNumberEntitlement

(SNE) Tool: https://tools.juniper.net/SerialNumberEntitlementSearch/

Opening a Casewith JTAC

You can open a case with JTAC on theWeb or by telephone.

• Use the Case Management tool in the CSC at http://www.juniper.net/cm/.

• Call 1-888-314-JTAC (1-888-314-5822 toll-free in the USA, Canada, and Mexico).

For international or direct-dial options in countries without toll-free numbers, see

http://www.juniper.net/support/requesting-support.html.
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PART 1

Getting Started

• Understanding J Series Services Router and SRX Series Services Gateway

Configuration on page 3

• J Series Services Routers and SRX Series Services Gateways and NSM Installation and

Integration Overview on page 7
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CHAPTER 1

Understanding J Series Services Router
and SRX Series Services Gateway
Configuration

• NSM and Device Management Overview on page 3

• Communication Between NSM and a Device Overview on page 3

• Device Configurations Supported in NSM for the J Series Services Router and SRX

Series Services Gateway on page 5

NSM and DeviceManagement Overview

NSM is the Juniper Networks network management tool that allows distributed

administration of network appliances. You can use the NSM application to centralize

status monitoring, logging, and reporting, and to administer device configurations.

WithNSMyoucanmanageandadminister adevice fromasinglemanagement interface.

In addition, NSM lets youmanagemost of theparameters that you can configure through

the device’s admin console. The configuration screens rendered throughNSMare similar

to the screens in the device’s admin console.

NSM incorporates a broad configuration management framework that allows

co-management using othermethods. Tomanage the device configuration, you canalso

use the XML files import and export feature, or you canmanage from the device’s admin

console.

Related
Documentation

Communication Between NSM and a Device Overview on page 3•

• Device Configurations Supported in NSM for the J Series Services Router and SRX

Series Services Gateway on page 5

Communication Between NSM and a Device Overview

The NSM application and a device communicate through the Device Management

Interface (DMI). DMI is a collection of schema-driven protocols that run on a common

transport (that is, TCP). DMI is designed to work with Juniper Networks platforms to
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make device management consistent across all administrative realms. Supported DMI

protocols include:

• NetConf (for inventory management, XML-based configuration, text-based

configuration, alarmmonitoring, and device specific commands)

• Structured syslog

• Threat flow for network profiling

DMI supports third-party network management systems that incorporate the DMI

standard; however, only one DMI-based agent per device is supported.

The device’s configuration is represented as a hierarchical tree of configuration items.

This structure is expressed in XML and can bemanipulated with NetConf. NetConf is a

networkmanagement protocol that uses XML. DMI usesNetConf’s generic configuration

management capability to allow remote configuration of the device.

ToallowNSMtomanage thedeviceusing theDMIprotocol,NSMmust import theschema

andmetadata files from the Juniper Networks Schema Repository, a publicly accessible

resource that is updatedwitheachdevice release. Inaddition todownloading thedevice’s

current schema, NSMmay also download upgraded software.

The Schema Repository enables access to XSD and XML files defined for each device,

model, and software version.

Before attempting to communicate with NSM, youmust first complete the initial

configuration of the device. Initial configuration includes network interface settings, DNS

settings, licensing, and password administration.

If you have several devices thatwill be configured in a clustering environment, the cluster

abstractionmust first becreated in theNSMClusterManager. Thenyoucanadd individual

nodes.

After you have completed the initial network configuration, you can configure the device

to communicate with NSM using the appropriate network information. Once the device

hasbeenconfigured tocommunicatewithNSM, thedevicecontactsNSMandestablishes

a DMI session through an initial TCP handshake.

All communicationsbetween thedeviceandNSMoccuroverSSHtoensuredata integrity.

After the device initially contacts NSM and a TCP session is established, interaction

between the device and NSM is driven from NSM, which issues commands to get

hardware, software, and license details of the device. NSM connects to the Schema

Repository to download the configuration schema that is specific to the device.

NSM then issues a command to retrieve configuration information from the device. If

NSM is contacted bymore than one device as amember of a cluster, information from

only one of the cluster devices is gathered. NSM attempts to validate the configuration

received from the device against the schema from Juniper Networks.

Once the device and NSM are communicating, the device delivers syslog and event

information to NSM.
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AfterNSMand thedeviceareconnected, youcanmakeanyconfigurationchangesdirectly

on the device, bypassing NSM. NSM automatically detects these changes and imports

thenewconfigurationdata.Changes todeviceclustermemberswill similarlybedetected

by NSM.

When youmake changes to the device’s configuration through NSM, youmust push the

changes to the device by performing an Update Device operation.

Whenyoudouble-click thedevice icon in theDeviceManagerandselect theConfiguration
tab, the configuration tree appears in the main display area in the same orientation as

items appear on the device’s admin console.

Related
Documentation

NSM and Device Management Overview on page 3•

• Device Configurations Supported in NSM for the J Series Services Router and SRX

Series Services Gateway on page 5

Device Configurations Supported in NSM for the J Series Services Router and SRX
Series Services Gateway

NSM supports the following services for J Series Services Router and SRXSeries services

gateway platforms:

• Inventorymanagement service—Enablesmanagementof the software, hardware, and

licensing details for the J Series Services Router and the SRX Series services gateway.

Adding or deleting licenses andupgrading or downgrading software are not supported.

• Status monitoring service—Allows the status of the J Series Services Router and the

SRX Series services gateway to be obtained, including name, domain, OS version,

synchronization status, connection details, and current alarms.

• Logging service—Allows logs to be obtained in a time-generated order for the J Series

Services Router and the SRX Series services gateway device. Logging configuration

details that are set on the J SeriesServicesRouter and theSRXSeries services gateway

will apply to NSM.

• XML-based configuration management service—Enables NSM tomanage the

configuration of the J Series Services Router and the SRX Series services gateway.

NSM uses the same XML schema as the J Series Services Router and the SRX Series

services gateway, so you can troubleshoot NSM using XML files downloaded from

either device.

NOTE: NSM supports only the domestic version of JUNOS on J Series and
SRX Series platforms.

The following device configurations are not supported:

• Editing licensing information, although licenses can be viewed

• Packaging log files or debug files for remote analysis
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Related
Documentation

• NSM and Device Management Overview on page 3

• Communication Between NSM and a Device Overview on page 3
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CHAPTER 2

J Series Services Routers and SRX Series
Services Gateways and NSM Installation
and Integration Overview

• JSeriesServicesRouterandSRXSeriesServicesGateway InstallationandConfiguration

Overview on page 7

• NSM Installation Overview on page 8

• Adding J Series Services Routers or SRX Series Services Gateways in NSM

Overview on page 8

• Adding J Series Services Router Clusters and SRX Series Services Gateway Clusters

Overview on page 8

• Adding J Series Services Router Clusters and SRX Series Services Gateway Virtual

Chassis Clusters Overview on page 9

• Using Templates and Configuration Groups in NSMOverview on page 10

JSeriesServicesRouterandSRXSeriesServicesGateway InstallationandConfiguration
Overview

NOTE: For important safety information, read the Juniper Networks Security
Products Safety Guide.

Before you can add either a J Series Services Router or an SRX Series services gateway

to NSM, the device must be installed and configured, and logon credentials for an NSM

administrator must be configured for it. Follow these steps:

1. Connect the device to the network and configure one of the interfaces so that the

device can reach the NSM device server.

2. Add a user for NSM that has full administrative rights.

For complete details on installing and configuring J Series Services Routers, see the

corresponding Hardware Guide for your device.

For complete details on installing and configuring SRX Series services gateway, see the

corresponding Hardware Guide for your device.
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Related
Documentation

NSM Installation Overview on page 8•

• NSM and Device Management Overview on page 3

• Communication Between NSM and a Device Overview on page 3

NSM Installation Overview

NSM is a software application that enables you to integrate and centralizemanagement

of your JuniperNetworksenvironment.Youneed to install twomainsoftwarecomponents

to run NSM: the NSMmanagement system and the NSM user interface (UI).

See the Network Security Manager Installation Guide for the steps to install the NSM

management systemonasingle server or on separate servers. It also includes information

onhowto install and run theNSMuser interface.TheNetworkSecurityManager Installation

Guide is intended for IT administrators responsible for installing or upgrading NSM.

Related
Documentation

JSeriesServicesRouterandSRXSeriesServicesGateway InstallationandConfiguration

Overview on page 7

•

• NSM and Device Management Overview on page 3

Adding J Series Services Routers or SRX Series Services Gateways in NSMOverview

Before NSM canmanage devices, youmust first add those devices to the management

system using the NSMUI. To add a device, you create an object in the UI that represents

the physical device, and then create a connection between theUI object and the physical

deviceso that their information is linked.Whenyoumakeachange to theUIdeviceobject,

you can push that information to the real device so the two remain synchronized. You

can add a single device at a time or addmultiple devices all at once.

For completedetails onadding JSeriesServicesRoutersorSRXSeries servicesgateways,

see the Network and Security Manager Administration Guide.

Related
Documentation

NSM and Device Management Overview on page 3•

• Communication Between NSM and a Device Overview on page 3

• Device Configurations Supported in NSM for the J Series Services Router and SRX

Series Services Gateway on page 5

• Adding J Series Services Router Clusters and SRX Series Services Gateway Clusters

Overview on page 8

Adding J Series Services Router Clusters and SRX Series Services Gateway Clusters
Overview

A cluster consists of multiple devices joined together in a high availability configuration

toensurecontinuednetworkuptime.Thedeviceconfigurationsaresynchronized,meaning
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all cluster members share the same configuration settings, enabling a device to handle

traffic for another if one device fails.

Adding a cluster is a two-stage process:

• Add the cluster device object.

• Add themembers of the cluster to the cluster device object.

For complete details on adding J Series Services Router clusters or SRX Series services

gateway clusters, see the Network and Security Manager Administration Guide.

Related
Documentation

NSM and Device Management Overview on page 3•

• Communication Between NSM and a Device Overview on page 3

• Device Configurations Supported in NSM for the J Series Services Router and SRX

Series Services Gateway on page 5

• Adding J Series Services Routers or SRX Series Services Gateways in NSMOverview

on page 8

Adding J Series Services Router Clusters and SRX Series Services Gateway Virtual
Chassis Clusters Overview

Network andSecurityManager (NSM) supports a single connection between twocluster

members of SRX Series Services Gateway cluster through the fxp0 interface on the

device. These clusters are represented by a virtual chassis.

Adding an SRX Series Services Gateway virtual chassis cluster is similar to adding an

SRX Series Services Gateway chassis cluster. In NSM, select the Virtual Chassis check

box when you add a device either through an unreachable workflow or while modeling

the device.

For complete information about how to add J Series Services Router clusters or SRX

Series Services Gateway virtual chassis clusters, see the Network and Security Manager

Administration Guide.

Related
Documentation

NSM and Device Management Overview on page 3•

• Communication Between NSM and a Device Overview on page 3

• Device Configurations Supported in NSM for the J Series Services Router and SRX

Series Services Gateway on page 5

• Adding J Series Services Routers or SRX Series Services Gateways in NSMOverview

on page 8

• Adding J Series Services Router Clusters and SRX Series Services Gateway Clusters

Overview on page 8
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Using Templates and Configuration Groups in NSMOverview

Use templates todefineacommondeviceconfigurationand then reuse that configuration

information across multiple devices. In a template, you need to define only those

configuration parameters that you want to set; you do not need to specify a complete

device configuration.

Templates provide these benefits:

• You can configure parameter values for a device by referring to one or more templates

when configuring the device.

• When you change a parameter value in a template and save the template, the value

alsochanges forall deviceconfigurations that refer to that template, unless specifically

overridden in the device object.

For completedetails onusingdevice templatesandconfigurationgroups, see theNetwork

and Security Manager Administration Guide.

Related
Documentation

• Adding J Series Services Routers or SRX Series Services Gateways in NSMOverview

on page 8

• Adding J Series Services Router Clusters and SRX Series Services Gateway Clusters

Overview on page 8
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PART 2

Configuring J Series Services Routers and
SRX Series Services Gateways

NOTE: Because the NSM device-side configuration guides are not updated
on the same release schedule as the JUNOS releases, consult the JUNOS

Software Documentation for information about configuration settings that

might occur in NSM and not in the device-side configuration guides or vice
versa.

• Configuring Access in J Series Services Routers and SRX Series Services

Gateways on page 13

• Configuring Access Profile in J Series Services Routers and SRX Series Services

Gateways on page 31

• Configuring Accounting Options in J Series Services Routers and SRX Series Services

Gateways on page 33

• Configuring Applications in J Series Services Routers and SRX Series Services

Gateways on page 41

• Configuring User Authentication in J Series Services Routers and SRX Series Services

Gateways on page 43

• Configuring Chassis in J Series Services Routers and SRX Series Services

Gateways on page 53

• ConfiguringUSBModem Interfaces in JSeriesServicesRouters andSRXSeriesServices

Gateways on page 67

• Configuring Policy Options in J Series Services Routers and SRX Series Services

Gateways on page 73

• Configuring Routing Options in J Series Services Routers and SRX Series Services

Gateways on page 81

• Configuring Protocols for J Series Services Routers and SRX Series Services

Gateways on page 107

• Configuring Security for J Series Services Routers and SRX Series Services

Gateways on page 177

• Configuring Services for J Series Services Routers and SRX Series Services

Gateways on page 221
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• Configuring SNMP for Network Management in J Series Services Routers and SRX

Series Services Gateways on page 247

• Configuring System for J Series Services Routers and SRX Series Services

Gateways on page 277

• Configuring J Series Services Routers and SRX Series Services Gateways for

DHCP on page 311

• Configuring Class of Service in J Series Services Routers and SRX Series Services

Gateways on page 315

• Configuring Event Options in J Series Services Routers and SRX Series Services

Gateways on page 341

• Configuring Firewall in J Series Services Routers and SRX Series Services

Gateways on page 349

• Configuring Application Layer Gateways in J Series Services Routers and SRX Series

Services Gateways on page 361

• ConfiguringUnified ThreatManagement Features in J Series Services Routers andSRX

Series Services Gateways on page 375

• Configuring Network Address Translation in J Series Services Routers and SRX Series

Services Gateways on page 393

• Configuring Bridge Domains in J Series Services Routers and SRX Series Services

Gateways on page 397

• Configuring Forwarding Options in J Series Services Routers and SRX Series Services

Gateways on page 403

• Configuring Interfaces in J Series Services Routers and SRX Series Services

Gateways on page 421

• Configuring Multicast Snooping Options in J Series Services Routers and SRX Series

Services Gateways on page 451
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CHAPTER 3

Configuring Access in J Series Services
Routers and SRX Series Services
Gateways

• Configuring Address Assignment (NSM Procedure) on page 13

• Configuring an Address Pool (NSM Procedure) on page 18

• Configuring a Group Profile (NSM Procedure) on page 19

• Configuring LDAP Options (NSM Procedure) on page 20

• Configuring the LDAP Server (NSM Procedure) on page 22

• Configuring a SecurID Server (NSM Procedure) on page 23

• Configuring RADIUS Options (NSM Procedure) on page 24

• Configuring a RADIUS Server (NSM Procedure) on page 24

• Configuring Firewall Authentication (NSM Procedure) on page 26

Configuring Address Assignment (NSMProcedure)

The address assignment feature allows you to configure the neighbor discovery router

advertisement and the pool address.

To configure address assignment:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the address assignment feature.

3. Click the Configuration tab. In the configuration tree, select Access > Address

Assignment.

4. Enter a comment for the address assignment in Comment.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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• Apply—Applies the address assignment parameters.

• Configuring Neighbor Discovery Router Advertisement on page 14

• Configuring Pool on page 14

Configuring Neighbor Discovery Router Advertisement

To configure neighbor discovery router advertisement (NDRA):

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the NDRA feature.

3. Click the Configuration tab. In the configuration tree, select Access > Address

Assignment > Neighbor Discovery Router Advertisement.

4. Add or modify settings as specified in Table 5 on page 14.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the NDRA settings.

Table 5: Neighbor Discovery Router Advertisement Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the NDRA.Comment

Enter the NDRA pool name.Specifies the designated NDRA pool name.Ndra Name

Configuring Pool

To configure the address pool feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the address pool feature.

3. Click the Configuration tab. In the configuration tree, select Access > Address

Assignment > Pool.

4. Click + to configure address pool settings.

5. Enter an address pool name, in the Name field.

6. Enter a comment for the address pool in Comment.

7. Enter an address pool link name in Link.

8. In the configuration tree, select Access > Address Assignment > Pool > pool > Family.

9. Click Enable Feature to configure the address pool family details.
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10. Add or modify settings as specified in Table 6 on page 15.

11. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the address pool settings.

Table 6: Pool Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the address
pool.

Comment

pool > Family > Inet

Select the option.Specifies that neither inet nor inet6 is chosen.None

pool > Family > inet > Inet

(Optional) Enter a comment.Suppliesadescriptivecomment for the Inetaddress
pool.

Comment

Enter the Inet network address.Specifies the Inet network address.Network

pool > Family > inet > Inet > Dhcp Attributes

(Optional) Enter a comment.Suppliesadescriptivecomment for the InetDynamic
Host Configuration Protocol (DHCP) attributes.

Comment

Select the maximum lease time from the
list.

Specifies the maximum lease time advertised to
clients.

Maximum Lease Time

Enter the server IP address value.Specifies the server IP address value.Server Identifier

Select the grace period time. Range: 0
through 4,294,967,295.

Specifies the grace period for the leases.Grace Period

Enter the domain name.Specifies the domain name advertised to clients.Domain Name

Enter the boot filename.Specifies the boot filename advertised to clients.Boot File

Enter the boot server name.Specifies the boot server advertised to clients.Boot Server

Enter the TFTP server name.Specifies the Trivial File Transfer Protocol (TFTP)
server advertised to clients.

Tftp Server

Select the NetBIOS node type from the list.Specifies the type of Network Basic Input/Output
System (NetBIOS) node advertised to clients.

Netbios Node Type

Enter the SIP server domain name.Specifies theSession InitiationProtocol (SIP) server
domain name available to clients.

Sip Server Domain Name
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Table 6: Pool Configuration Details (continued)

Your ActionFunctionOption

pool > Family > inet > Inet > Dhcp Attributes > Dns Server

Enter the DNS server IPv4 address name.Specifies the Domain Name System (DNS) server’s
Internet Protocol Version 6 (IPv4) address.

Name

(Optional) Enter a comment.Supplies a descriptive comment for the DNS server
IPv4 name.

Comment

pool > Family > inet > Inet > Dhcp Attributes > Name Server

Enter the DNS server IPv4 address name.Specifies theDNS server’s Internet Protocol Version
4 (IPv4) address.

Name

(Optional) Enter a comment.Supplies a descriptive comment for the DNS server
IPv4 name.

Comment

pool > Family > inet > Inet > Dhcp Attributes > Option

Select the DHCP option identifier code.
Range: 0 through 4,294,967,295.

Specifies the DHCP option identifier code.Name

(Optional) Enter a comment.Supplies a descriptive comment for the option.Comment

pool > Family > inet > Inet > Dhcp Attributes > Option > Flag

Select and enter flag option settings from
the list.

Specifies the flag option setting.Flag

pool > Family > inet > Inet > Dhcp Attributes > Option Match

(Optional) Enter a comment.Supplies a descriptive comment for the option
match.

Comment

pool > Family > inet > Inet > Dhcp Attributes > Option Match > Option 82 > Circuit Id

Enter the circuit identifier name.Specifies the circuit identifier name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the circuit
identifier.

Comment

Enter the range name for the circuit
identifier.

Specifies the range name for the circuit identifier.Range

pool > Family > inet > Inet > Dhcp Attributes > Option Match > Option 82 > Remote Id

Enter the remote identifier name.Specifies the remote identifier name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the remote
identifier.

Comment
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Table 6: Pool Configuration Details (continued)

Your ActionFunctionOption

Enter the range name for the remote
identifier.

Specifies the range name for the remote identifier.Range

pool > Family > inet > Inet > Dhcp Attributes > Router

Enter the device IPv4 address name.Specifies thenameof the IPv4addressof thedevice.Name

(Optional) Enter a comment.Supplies a descriptive comment for the device.Comment

pool > Family > inet > Inet > Dhcp Attributes > Sip Server Address

Enter the SIP server’s IPv4 address name.Specifies the SIP server’s IPv4 address name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the SIP server’s
IPv4 address.

Comment

pool > Family > inet > Inet > Dhcp Attributes >Wins Server

Enter theWINSserver’s IPv4addressname.Specifies theWindows Internet Name Service
(WINS) server’s IPv4 address name.

Name

(Optional) Enter a comment.Supplies a descriptive comment for theWINS
server’s IPv4 address.

Comment

pool > Family > inet > Inet > Host

Enter the hostname.Specifies the hostname.Name

(Optional) Enter a comment.Supplies a descriptive comment for the host.Comment

Enter the hardware address.Specifies the hardware address.Hardware Address

Enter the reserved address.Specifies the reserved address.Ip Address

pool > Family > inet > Inet > Range

Enter the range name.Specifies the range name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the range.Comment

Enter the lower limit of the address range.Specifies the lower limit of the address range.Low

Enter the upper limit of the address range.Specifies the upper limit of the address range.High

pool > Family > inet6 > Inet6 > Dhcp Attributes

Follow the similar procedure of configuring Inet DHCP attributes (Table 6 on page 15) to configure the Inet DHCP attributes
too.
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Table 6: Pool Configuration Details (continued)

Your ActionFunctionOption

pool > Family > inet6 > Inet6 > Range

Enter the IPv6 range name.Specifies the IPv6 range name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the IPv6 range.Comment

Enter the lower limit of the IPv6 address
range.

Specifies the lower limit of the IPv6 address range.Low

Enter the upper limit of the IPv6 address
range.

Specifies the upper limit of the IPv6 address range.High

Choose the IPv6 delegated prefix length.
Range: 1 through 128.

Specifies the IPv6 delegated prefix length.Prefix Length

Related
Documentation

Configuring an Address Pool (NSM Procedure) on page 18•

• Configuring a Group Profile (NSM Procedure) on page 19

• Configuring LDAP Options (NSM Procedure) on page 20

Configuring an Address Pool (NSMProcedure)

You can configure an address pool.

To configure an address pool:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the address pool feature.

3. Click the Configuration tab. In the configuration tree, select Access > Address Pool.

4. Click + to configure the address pool options as specified in Table 7 on page 18.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the address pool parameters.

Table 7: Address Pool Configuration Details

Your ActionFunctionOption

Enter a name for the address pool.Specifies the address pool name.Name

Enter the primary DNS name.Specifies theprimaryDomainNameSystem(DNS)
server name.

Primary Dns

Copyright © 2013, Juniper Networks, Inc.18

Configuring J Series Services Routers and SRX Series Services Gateways Guide



Table 7: Address Pool Configuration Details (continued)

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the address
pool.

Comment

Enter the secondary DNS name.Specifies the secondary DNS server name.Secondary Dns

Enter the primaryWINS server name.Specifies the primaryWINS server.PrimaryWins

Enter the secondaryWINS server name.Specifies the secondaryWINS server.SecondaryWins

Related
Documentation

Configuring Address Assignment (NSM Procedure) on page 13•

• Configuring a Group Profile (NSM Procedure) on page 19

• Configuring LDAP Options (NSM Procedure) on page 20

Configuring a Group Profile (NSMProcedure)

You can configure a group profile to define the Point-to-Point Protocol (PPP) attributes.

To configure a group profile:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the group profile feature.

3. Click the Configuration tab. In the configuration tree, select Access > Group Profile.

4. Click + to configure the group profile options as specified in Table 8 on page 19.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the group profile parameters.

Table 8: Group Profile Configuration Details

Your ActionFunctionOption

Enter a name for the group profile.Specifies the group profile name.Name

(Optional) Enter a comment.Suppliesadescriptive comment for thegroupprofile.Comment

group-profile > Ppp

Select the check box to enable the feature.Specifies that you can enable this feature to
configure the PPP.

Enable Feature

(Optional) Enter a comment.Supplies a descriptive comment for the PPP.Comment

19Copyright © 2013, Juniper Networks, Inc.

Chapter 3: Configuring Access in J Series Services Routers and SRX Series Services Gateways



Table 8: Group Profile Configuration Details (continued)

Your ActionFunctionOption

Select an option from the list.Specifies theaddresspool used toassignanaddress
for the user.

Framed Pool

Enter the idle timeout value.

Range: 1 - 4,294,967,295.

Specifies the idle timeout before termination of the
session.

Idle Timeout

Enter the PPP keepalive interval time.

Range: 1 - 32,767.

Specifies the PPP keepalive interval.Keepalive

Enter the primary DNS server name.Specifies the primary Domain Name System (DNS)
server name.

Primary Dns

Enter the secondary DNS server name.Specifies the secondary DNS server name.Secondary Dns

Enter the primaryWINS server name.Specifies theprimaryWindows InternetNameService
(WINS) server name.

PrimaryWins

Enter the secondaryWINS server name.Specifies the secondaryWINS server name.SecondaryWins

Enter an encapsulation overhead value.
Range: -63 through 64.

Specifies the encapsulation overhead for class of
service calculation.

EncapsulationOverhead

Select the check box to enable this feature.Specifies the ATM cell overhead for the class of
service calculation.

Cell Overhead

Enter the interface identifier.Specifies the interface identifier to lookup thesession
information.

Interface Id

Related
Documentation

Configuring Address Assignment (NSM Procedure) on page 13•

• Configuring an Address Pool (NSM Procedure) on page 18

• Configuring LDAP Options (NSM Procedure) on page 20

Configuring LDAPOptions (NSMProcedure)

You can configure Lightweight Directory Access Protocol (LDAP) authentication options.

To configure LDAP options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the LDAP options.

3. Click the Configuration tab. In the configuration tree, select Access > Ldap Options.

4. Enter a comment for the LDAP option in Comment.

Copyright © 2013, Juniper Networks, Inc.20

Configuring J Series Services Routers and SRX Series Services Gateways Guide



5. Enter theamountof time that elapsesbefore theprimary server is contacted, if backup

server is being used in Revert Interval.

6. Enter a distinguished name (DN) in Base Distinguished Name .

NOTE:

The base distinguished name can be used in one of the following ways:

• If you are using the assemble statement so that the user's distinguished
name is being assembled, the base distinguished name is appended to
a username to generate the user's distinguished name. The resulting
distinguished name is used in the LDAP bind call.

• If you are using the search statement so that the user's distinguished
name is found by a search, the search is restricted to the subtree of the
base distinguished name.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the LDAP option parameters.

• Configuring Assemble on page 21

Configuring Assemble

To configure an assemble:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the assemble feature.

3. Click the Configuration tab. In the configuration tree, select Access > Ldap Options >

Assemble.

4. Select an option to configure the assemble feature.

5. Add or modify settings as specified in Table 9 on page 21.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the assemble settings.

Table 9: Assemble Configuration Details

Your ActionFunctionOption

Ldap Options > Assemble > assemble
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Table 9: Assemble Configuration Details (continued)

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the assemble
option.

Comment

Enter a common name.Specifies theprefix for theuserdistinguishedname.Common Name

Ldap Options > Assemble > search

(Optional) Enter a comment.Supplies a descriptive comment for the search
option.

Comment

Enter the search filter.Specifies the filter to use in the search.Search Filter

Ldap Options > Assemble > search > Admin Search

Select the check box to enable the
feature.

Specifies configuration of the admin search.Enable Search

(Optional) Enter a comment.Supplies a descriptive comment for the admin
search.

Comment

Enter the administrator’s distinguished
name.

Specifies the administrator’s distinguished name.Distinguished Name

Enter the password.Specifies the administrator password.Password

Related
Documentation

Configuring an Address Pool (NSM Procedure) on page 18•

• Configuring a Group Profile (NSM Procedure) on page 19

• Configuring Address Assignment (NSM Procedure) on page 13

Configuring the LDAP Server (NSMProcedure)

You can configure the Lightweight Directory Access Protocol (LDAP) server, using the

LDAP Server option.

To configure LDAP server:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Access.

4. Select Ldap Server.

5. Add or modify settings as specified in Table 10 on page 23.

6. Click one:

• OK—Saves the changes.
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• Cancel—Cancels the modifications.

Table 10: LDAP Server Configuration Details

Your ActionTask

1. Click Add new entry next to Ldap Server.

2. In the Name box, enter the name of the server.

3. In the Comment box, enter the comment.

4. From thePort list, select the port number onwhich to contact
the RADIUS server (LDAP server)

5. In the Source Address box, enter a valid IPv4 address
configuredononeof the router interfaces.OnMSeries routers
only, the source address can be an IPv6 address and the UDP
source port is 514.

6. From the Routing Instances list, select the routing instance
name.

7. From the Retry list, select the number of times that the router
is allowed to attempt to contact a RADIUS server.

Range: 1 through 10

Default: 3

8. From theTimeout list, select the amount of time that the local
router waits to receive a response from a RADIUS server.

Range: 3 through 90

Default: 5

Configure the LDAP server.

Related
Documentation

Configuring LDAP Options (NSM Procedure) on page 20•

Configuring a SecurID Server (NSMProcedure)

You can configure a securID server to authenticate clients for remote virtual private

network (VPN) access.

To configure a securID server:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the securID server feature.

3. Click the Configuration tab. In the configuration tree, select Access > Securid Server.

4. Click + to configure the securID server options as specified in Table 11 on page 24.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the securID server parameters.
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Table 11: SecurID Server Configuration Details

Your ActionFunctionOption

Enter a securID server name.Specifies the name of the securID server.Name

(Optional) Enter a comment.Supplies a descriptive comment for the securID
server.

Comment

Enter the path to the securID server
configuration file.

Specifies thepath to thesecurIDserver configuration
file.

Configuration File

Related
Documentation

Configuring an Address Pool (NSM Procedure) on page 18•

• Configuring a Group Profile (NSM Procedure) on page 19

• Configuring the LDAP Server (NSM Procedure) on page 22

Configuring RADIUSOptions (NSMProcedure)

You can configure RADIUS options.

To configure RADIUS options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the RADIUS options feature.

3. Click the Configuration tab. In the configuration tree, select Access > Radius Options.

4. Enter a comment that describes the RADIUS options in Comment.

5. Enter theamountof time for the router towaitafter theserverhasbecomeunreachable

in Revert Interval.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the RADIUS options parameters.

Related
Documentation

Configuring a RADIUS Server (NSM Procedure) on page 24•

• Configuring Firewall Authentication (NSM Procedure) on page 26

• Configuring a SecurID Server (NSM Procedure) on page 23

Configuring a RADIUS Server (NSMProcedure)

You can configure RADIUS server.
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To configure a RADIUS server:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the RADIUS server feature.

3. Click the Configuration tab. In the configuration tree, select Access > Radius Server.

4. Click + to configure RADIUS server options as described in Table 12 on page 25.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the RADIUS server parameters.

Table 12: RADIUS Server Configuration Details

Your ActionFunctionOption

Enter a RADIUS server IP address name.Specifies the RADIUS server internet protocol (IP)
address name.

Name

(Optional) Enter a comment.Supplies a descriptive comment about the RADIUS
sever.

Comment

Set the RADIUS server authentication port
number.

Range: 1 through 65535.

Specifies the RADIUS server authentication port
number.

Port

Set the accounting port number.

Range: 1 through 65535.

Specifies the port number for sending the RADIUS
server messages.

Accounting Port

Enter the shared secret password value.Specifies thesharedsecretpasswordwith theRADIUS
server.

Secret

Set the timeout period.

Range: 1 through 90.

Specifies the request timeout period.Timeout

Set the retry attempts.

Range: 1 through 10.

Specifies the number of retry attempts.Retry

Enter the source address for theRADIUS server.Specifies the source address of the RADIUS server.Source Address

Select the routing instance from the list.Specifies thecollectionof routing tablesused to send
RADIUS packets to the RADIUS server.

Routing Instance

Related
Documentation

Configuring RADIUS Options (NSM Procedure) on page 24•

• Configuring Firewall Authentication (NSM Procedure) on page 26
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• Configuring a SecurID Server (NSM Procedure) on page 23

Configuring Firewall Authentication (NSMProcedure)

You can configure the firewall authentication for pass-through, traceoptions, andWeb

authentication options.

To configure firewall authentication:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the firewall authentication feature.

3. Click the Configuration tab. In the configuration tree, select Access > Firewall

Authentication.

4. Enter a comment for the firewall authentication in Comment.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the firewall authentication parameters.

• Configuring Pass-Through on page 26

• Configuring Traceoptions on page 27

• ConfiguringWeb Authentication on page 28

Configuring Pass-Through

To configure pass-through:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the pass-through feature.

3. Click the Configuration tab. In the configuration tree, select Access > Firewall

Authentication > Pass Through.

4. Enter a comment for pass-through in Comment.

5. Select the name of the profile used if it is not used in the policy in Default Profile.

6. Add or modify settings as specified in Table 13 on page 27.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the pass-through settings.
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Table 13: Pass-Through Configuration Details

Your ActionFunctionOption

Firewall Authentication > Pass Through > Ftp / Http / Telnet

(Optional) Enter a comment.Supplies a descriptive comment for the pass-through
firewall user authentication for FTP/HTTP/Telnet.

Comment

Firewall Authentication > Pass Through > Ftp / Http / Telnet > Banner

(Optional) Enter a comment.Supplies a descriptive comment for the banner session
for FTP/HTTP/Telnet.

Comment

Enter an appropriate login message.Specifies the message that will be displayed before
login.

Login

Enter an appropriate message for a
successful login.

Specifies the message that will be displayed on
successful login.

Success

Enter an appropriate message for a failed
user login.

Specifies themessage thatwill bedisplayedafter failed
user login.

Fail

Configuring Traceoptions

To configure traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the traceoptions.

3. Click the Configuration tab. In the configuration tree, select Access > Firewall

Authentication > Traceoptions.

4. Enter a comment for the traceoptions in Comment.

5. Select the check box to disable remote tracing in No Remote Trace.

6. Add or modify settings as specified in Table 14 on page 27.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the traceoptions settings.

Table 14: Traceoptions Configuration Details

Your ActionFunctionOption

Firewall Authentication > Traceoptions > File

(Optional) Enter a comment.Supplies a descriptive comment for the file
traceoptions.

Comment
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Table 14: Traceoptions Configuration Details (continued)

Your ActionFunctionOption

Enter a filename for the trace information.Specifies the name of the file in which to write the
trace information.

Filename

Enter the maximum trace file size.Specifies the maximum trace file size.Size

Set the number of trace files.

Range: 2 through 1000.

Specifies the maximum number of trace files.Files

Select the option.Specifies that the executables are readable by any
user.

world-reachable

Select the option.Specifies that the executables are not readable by
any user.

no-world-reachable

Enter the regular expression.Specifies the regular expression for the lines to be
logged.

Match

Firewall Authentication > Traceoptions > Flag

Select a flag name from the list.Specifies the flag name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the flag option.Comment

ConfiguringWeb Authentication

To configureWeb authentication:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure theWeb authentication.

3. Click the Configuration tab. In the configuration tree, select Access > Firewall

Authentication >WebAuthentication.

4. Enter a comment for theWeb authentication in Comment.

5. Select the name of the profile used if it is not used in the policy in Default Profile.

6. Add or modify settings as specified in Table 15 on page 29.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies theWeb authentication settings.
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Table 15:Web Authentication Configuration Details

Your ActionFunctionOption

Firewall Authentication >Web Authentication > Banner

(Optional) Enter a comment.Supplies a descriptive comment for the banner.Comment

Enter an appropriate message for a
successful login.

Specifies the message that will be displayed on a
successful login.

Success

Related
Documentation

• Configuring a RADIUS Server (NSM Procedure) on page 24

• Configuring RADIUS Options (NSM Procedure) on page 24

• Configuring a SecurID Server (NSM Procedure) on page 23
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CHAPTER 4

Configuring Access Profile in J Series
Services Routers and SRX Series Services
Gateways

• Configuring the Access Profile (NSM Procedure) on page 31

Configuring the Access Profile (NSMProcedure)

To configure the access profile in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, select Access Profile.

4. Add or modify settings as specified in Table 16 on page 31.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 16: Access Profile Configuration Details

Your ActionTask

1. In the Comment box, enter the comment.

2. In the Name box, enter the name of the access profile.

Configuring the access profile.

Related
Documentation

• Configuring Access Profiles for L2TP or PPP Parameters (NSM Procedure)

• Configuring the RADIUS Parameters (NSM Procedure)
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CHAPTER 5

ConfiguringAccountingOptions in J Series
Services Routers and SRX Series Services
Gateways

• Configuring Accounting Options (NSM Procedure) on page 33

Configuring Accounting Options (NSMProcedure)

An accounting profile represents common characteristics of collected accounting data.

You can configuremultiple accountingprofiles using this option. See the following topics:

• Configuring Class Usage Profiles (NSM Procedure) on page 33

• Configuring a Log File (NSM Procedure) on page 34

• Configuring the Filter Profile (NSM Procedure) on page 35

• Configuring the Interface Profile (NSM Procedure) on page 36

• Configuring the Policy Decision Statistics Profile (NSM Procedure) on page 37

• Configuring the MIB Profile (NSM Procedure) on page 38

• Configuring the Routing Engine Profile (NSM Procedure) on page 39

Configuring Class Usage Profiles (NSMProcedure)

You can configure the class usage profile to collect statistics for particular source and

destination classes.

To configure class usage profiles in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Accounting Options.

4. Select Class Usage Profile.

5. Add or modify the settings as specified in Table 17 on page 34.

6. Click one:

• OK—Saves the changes.

33Copyright © 2013, Juniper Networks, Inc.



• Cancel—Cancels the modifications.

Table 17: Class Usage Profile Configuration Details

Your ActionTask

1. Click Add new entry next to Class Usage Profile.

2. Expand class-usage-profile.

3. In theNamebox, enter thenameof thedestinationclassprofile.

4. In the Comment box, enter the comment for the class usage
profile.

5. In the File box, enter the name of the log file.

6. From the Interval list, select the amount of time between each
collection of statistics.

Range: 1 through 1048576minutes

Default: 30minutes

7. ClickDestinationClassesnext to class-usage-profile andselect
one of the following:

• destination-classes—To configure the class usage profile to
filter by source classes.

• source-classes—To configure the class usage profile to filter
by destination classes.

8. In the Name box, enter the name of the source classes or the
destination classes.

9. In the Comment box, enter the comment.

Configure the class usage
profile.

Configuring a Log File (NSMProcedure)

An accounting profile specifies what statistics should be collected and written to a log

file. You can configure an accounting-data log file using this option.

To configure a log file in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Accounting Options.

4. Select File.

5. Add or modify the settings as specified in Table 18 on page 35.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Copyright © 2013, Juniper Networks, Inc.34

Configuring J Series Services Routers and SRX Series Services Gateways Guide



Table 18: Log File Configuration Details

Your ActionTask

1. Click Add new entry next to File.

2. In the Name box, enter the filename.

3. In the Comment box, enter the comment for the file.

4. In the Size box, enter the maximum size of each log file in the
range from 262144 through 1073741824 bytes.

5. From the Files list, select the maximum number of files.

Range: 1 through 1000

Default : 10

6. From the Transfer Interval list, select the time the file remains
open and receives new statistics before it is closed and
transferred to an archive site.

Range: 5 through 2880minutes

Default: 30minutes

7. In the Start Time box, enter the start time for transfer of an
accounting-data log file in the format yyyy-mm-dd.hh:mm

Configure an
accounting-data log file.

1. Click Add new entry next to Archive Sites.

2. In the Name box, enter the site name.

3. In the Comment box, enter the comment.

4. In the Password box, enter the password.

Configure archive sites.

Configuring the Filter Profile (NSMProcedure)

A filter profile specifies error and statistics information collected and written to a file. A

filter profile must specify counter names for which statistics are collected.

To configure the filter profile in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Accounting Options.

4. Select Filter Profile.

5. Add or modify the settings as specified in Table 19 on page 36.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 19: Filter Profile Configuration Details

Your ActionTask

1. Click Add new entry next to Filter Profile.

2. Expand filter-profile.

3. In the Name box, enter the filename.

4. In the Comment box, enter the comment for the file.

5. In the File box, enter the name of the file.

6. From the Interval list, select the amount of time between each
collection of statistics.

Range: 1 through 1048576minutes

Default: 30minutes

Configure a filter profile.

1. Click Counters next to filter-profile.

2. Click Add new entry next to Counters.

3. In the Name box, enter the site name.

4. In the Comment box, enter the comment.

Configure the counters.

Configuring the Interface Profile (NSMProcedure)

An interface profile specifies the information collected and written to a log file. You can

configure a profile to collect error and statistic information for input and output packets

on a particular physical or logical interface.

To configure the interface profile in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Accounting Options.

4. Select Interface Profile.

5. Add or modify the settings as specified in Table 20 on page 37.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 20: Interface Profile Configuration Details

Your ActionTask

1. Click Add new entry next to Interface Profile.

2. Expand interface-profile.

3. In the Name box, enter the name of the log file.

4. In the Comment box, enter the comment for the interface
profile.

5. In the File box, enter the name of the log file.

6. From the Interval list, select the amount of time between each
collection of statistics.

Range: 1 through 2880minutes

Default: 30minutes

Configure an interface
profile.

1. Click Fields next to interface-profile.

2. In the Comment box, enter the comment.

3. Select the corresponding field name:

• Input Bytes—Input bytes

• Output Bytes—Output bytes

• Input Packets—Input packets

• Output Packets—Output packets

• Input Errors—Generic input error packets

• Output Errors—Generic output error packets

• Input Multicast—Input packets arriving by multicast

• Output Multicast—Output packets sent by multicast

• Input Unicast—Input unicast packets

• Output Unicast—Output unicast packets

• Unsupported Protocol—Log Packets of unsupported
protocols

• Rpf Check Bytes—Number of bytes that have failed the RPF
check

• Rpf Check Packets—Number of packets that have failed the
RPF check

• RpfCheck6Bytes—Log number of bytes that have failed the
IPv6 reverse-path-forwarding check

• RpfCheck6Packets—Lognumberofpackets thathave failed
the IPv6 reverse-path-forwarding check

Configure the statistics tobe
collected in an
accounting-data log file for
an interface.

Configuring the Policy Decision Statistics Profile (NSMProcedure)

The policy decision statistics profile collects the statistical records and formats for the

local policy decision function (L-PDF) and logs them to specified file. The aacl-fields

under the policy decision statistics profile specifies the files according to which the

statistics will be collected.

To configure the policy decision statistics profile in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.
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3. Click the Configuration tab. In the configuration tree, expand Accounting Options.

4. Select Policy Decision Statistics Profile.

5. Add or modify the settings as specified in Table 21 on page 38.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 21: Policy Decision Statistics Profile Configuration Details

Your ActionTask

1. Click Add new entry next to Policy Decision Statistics Profile.

2. Expand policy-decision-statistics-profile.

3. In theNamebox, enter thenameof thepolicydecisionstatistics
profile.

4. In theCommentbox, enter thecomment for thepolicydecision
statistics profile.

5. In the File box, enter the name of the log file.

Configure policy decision
statistics profile.

1. Click Application Awareness Access List next to
policy-decision-statistics-profile.

2. Select the name of the field:

• address—Address of subscriber

• application—Application

• application-group—Application group

• input-bytes—Input bytes

• input-interface—Interface of subscriber

• input-packets—Input packets

• mask—Mask of subscriber

• output-bytes—Output bytes

• output-packets—Output packets

• subscriber-name—Name of subscriber

• timestamp—Timestamp of statistics record

• vrf-name—VRF where subscriber resides

Configure application
awareness access list.

Configuring theMIB Profile (NSMProcedure)

The MIB profile collects MIB statistics and logs them to a file. The MIB profile specifies

the SNMP operation and MIB object names for which statistics are collected.

To configure the MIB profile in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Accounting Options.

4. SelectMIB Profile.
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5. Add or modify the settings as specified in Table 22 on page 39.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 22: MIB Profile Configuration Details

Your ActionTask

1. Click Add new entry next to Mib Profile.

2. Expandmib-profile.

3. In the Name box, enter the name of the MIB statistics profile.

4. In the Comment box, enter the comment for the MIB profile.

5. In the File box, enter the name of the log file.

6. From the Interval list, select the amount of time between each
collection of statistics.

Range: 1 through 2880minutes

Default: 30minutes

7. From theOperation list, select thenameof theoperation to use.
You can select a get, get-next, or walk operation.

Default: walk

Configure mib profile.

1. ClickObject Names next to mib-profile.

2. In theNamebox, enter thenameofaMIBobject. Youcanspecify
more than one MIB object name.

3. In the Comment box, enter the comment.

Configure the name of the
MIB objects for which MIB
statistics are collected for
an accounting-data log file.

Configuring the Routing Engine Profile (NSMProcedure)

The Routing Engine profile collects Routing Engine statistics and logs them to a file. The

Routing Engine profile specifies the fields for which statistics are collected

To configure the Routing Engine profile in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Accounting Options.

4. Select Routing Engine Profile.

5. Add or modify the settings as specified in Table 23 on page 40.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 23: Routing Engine Profile Configuration Details

Your ActionTask

1. Click Add new entry next to Routing Engine Profile.

2. Expand routing-engine-profile.

3. In theNamebox, enter thenameof theRoutingEnginestatistics
profile.

4. In the Comment box, enter the comment for the routing engine
profile.

5. In the File box, enter the name of the log file.

6. From the Interval list, select the amount of time between each
collection of statistics.

Range: 1 through 2880minutes

Default: 30minutes

Configure Routing Engine
profile.

1. Click Fields next to routing-engine-profile.

2. In the Comment box, enter the comment.

3. Select the name of the field:

• host-name—Hostname for the router.

• date—Date, in yyyymmdd format.

• time-of-day—Time of day, in hhmmsss format.

• uptime—Time since last reboot, in seconds.

• cpu-load-1—Average system load over the last 1 minute.

• cpu-load-5—Average system load over the last 5 minutes.

• cpu-load-15—Average system load over the last 15 minutes.

• Memory Usage—Memory usage in bytes.

• Total Cpu Usage—Amount of CPU time used.

Configure the statistics to
collect in an
accounting-data log file for
a Routing Engine.
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CHAPTER 6

Configuring Applications in J Series
Services Routers and SRX Series Services
Gateways

• Configuring the Application and Application Set (NSM Procedure) on page 41

Configuring the Application and Application Set (NSMProcedure)

You can define application protocols for the stateful firewall and Network Address

Translation (NAT) services to use in match condition rules. An application protocol, or

application layer gateway (ALG), defines application parameters using information from

network Layer 3 and above. You can configure properties of an application and whether

to include it in an application set using the application option. You can configure one or

more applications to include in an application set using the application set option.

To configure an application set in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Applications.

4. Add or modify settings as specified in Table 24 on page 42.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

NOTE: Application and application set are configurable, only if the device is
in the in-device policy mode.
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Table 24: Applications Configuration Details

Your ActionTask

1. Click Application next to Applications.

2. Click Add new entry next to Application.

3. In the Name box, enter the identifier of the application.

4. In the Comment box, enter the comment.

5. From the Application Protocol list, select the name of the
protocol.

6. From the Protocol list, select the networking protocol type.

7. From the Source Port list, select the identifier for the port.

8. From theDestinationPort list, select the Identifier for the port.

9. From the Snmp Command list, select the SNMP command
format.

10. From the Icmp Type list, select the ICMP packet type value.

11. From the Icmp Code list, select the Internet Control Message
Protocol (ICMP) code value.

12. From the Ttl Threshold list, select the TTL threshold value.

13. In the Rpc Program number box, enter the Remote procedure
call (RPC)orDistributedComputingEnvironment (DCE)value.

Range: 100,000 through 400,000

14. In the Uuid box, enter the Universal Unique Identifier (UUID)
for DCE RPC objects.

15. From the Inactivity Timeout list, select the length of time the
application is inactive before it times out.

16. Select the LearnSipRegister check box to activate SIP register
to accept potential incoming SIP calls.

17. From the Sip Call Hold Timeout list select the length of time
the application holds a SIP call open before it times out.

Default: 7200 seconds

Range: 0 through 36,000 seconds (10 hours)

18. Select one of the following:

• do-not-translate-AAAA-query-to-A-query—To control the
translation of AAAA query to A query.

• do-not-translate-A-query-to-AAAA—To control the
translation of A query to AAAA query.

Configure properties of an
application and whether to
include it in an application
set.

1. Click Application Set next to Applications.

2. Click Add new entry next to Application Set.

3. Expand application-set.

4. In the Name box, enter the identifier of an application set.

5. In the Comment box, enter the comment.

6. Click Application next to application-set.

7. Click Add new entry next to Application.

8. From the Name list, select the identifier of the application.

9. In the Comment box, enter the comment.

Configuring application sets.
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CHAPTER 7

ConfiguringUserAuthentication in J Series
Services Routers and SRX Series Services
Gateways

• Configuring RADIUS Authentication (NSM Procedure) on page 43

• Configuring TACACS+ Authentication (NSM Procedure) on page 44

• Configuring Authentication Order (NSM Procedure) on page 45

• Configuring User Access (NSM Procedure) on page 46

• Configuring Template Accounts (NSM Procedure) on page 49

Configuring RADIUS Authentication (NSMProcedure)

TouseRADIUSauthentication, youmustconfigureat leastoneRADIUSserver.Configuring

RADIUS authentication involves identifying the RADIUS server, specifying the secret

(password) of the RADIUS server, and setting the source address of the device's RADIUS

requests to the loopback address of the device.

To configure RADIUS authentication:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to
configure RADIUS authentication.

3. Click the Configuration tab. In the configuration tree, select System > Radius Server.

4. Add or modify Radius settings as specified in Table 25 on page 44.

5. Click one:

• New—Adds a new RADIUS server.

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 25: RADIUS Authentication Configuration Details

Your ActionFunctionOption

Enter the IP address of the
RADIUS server.

Specifies the IP address of the RADIUS server.Name

Enter the shared secret of the
RADIUS server.

Specifies the shared secret (password) of the
RADIUS server. The secret is stored as an
encrypted value in the configuration database.

Secret

Enter the loopbackaddressof
the device.

Specifies the source address to be included in
the RADIUS server requests by the device. In
most cases, you can use the loopback address
of the device.

Source
Address

Related
Documentation

Configuring TACACS+ Authentication (NSM Procedure) on page 44•

• Configuring Authentication Order (NSM Procedure) on page 45

• Configuring User Access (NSM Procedure) on page 46

Configuring TACACS+ Authentication (NSMProcedure)

To use TACACS+ authentication, youmust configure at least one TACACS+ server.

ConfiguringTACACS+authentication involves identifying theTACACS+server, specifying

the secret (password) of the TACACS+ server, and setting the source address of the

device's TACACS+ requests to the loopback address of the device.

To configure TACACS+ authentication:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to
configure TACACS+ authentication.

3. Click theConfiguration tab. In theconfiguration tree, selectSystem>TACACS+Server.

4. Add or modify TACACS+ settings as specified in Table 26 on page 44.

5. Click one:

• New—Adds a new TACACS+ server.

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 26: TACACS+ Authentication Configuration Details

Your ActionFunctionOption

Enter the IP address of the
TACACS+ server.

Specifies the IP address of the TACACS+ server.Name
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Table 26: TACACS+ Authentication Configuration Details (continued)

Your ActionFunctionOption

Enter the shared secret of the
TACACS+ server.

Specifies the shared secret (password) of the
TACACS+ server. The secret is stored as an
encrypted value in the configuration database.

Secret

Enter the loopbackaddressof
the device.

Specifies the source address to be included in
the TACACS+ server requests by the device. In
most cases, you can use the loopback address
of the device.

Source
Address

Related
Documentation

Configuring RADIUS Authentication (NSM Procedure) on page 43•

• Configuring Authentication Order (NSM Procedure) on page 45

• Configuring User Access (NSM Procedure) on page 46

Configuring Authentication Order (NSMProcedure)

You can configure the device so that user authentication occurs with the local password

first, then with the RADIUS server, and finally with the TACACS+ server.

To configure authentication order:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to
configure authentication order.

3. Click the Configuration tab. In the configuration tree, select System > Authentication

Order.

4. In the Authentication Order workspace, click theNew button. The New

authentication-order list appears.

5. To add RADIUS authentication to the authentication order, select radius from the

New authentication-order list.

6. To add TACACS+ authentication to the authentication order, select tacplus from the

New authentication-order list.

7. To add Password authentication to the authentication order, select password from
the New authentication-order list.

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Related
Documentation

Configuring RADIUS Authentication (NSM Procedure) on page 43•

• Configuring TACACS+ Authentication (NSM Procedure) on page 44

• Configuring User Access (NSM Procedure) on page 46
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Configuring User Access (NSMProcedure)

This section includes the following topics:

• Configuring Login Classes on page 46

• Configuring User Accounts on page 48

Configuring Login Classes

Youcandefineanynumberof login classesand thenapplyone login class toan individual

user account. All users who can log in to the router must be in a login class. With login

classes, you define the following:

• Access privileges users have when they are logged in to the router

• Commands and statements that users can and cannot specify

• How long a login session can be idle before it times out and the user is logged out

To configure login classes:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to
configure a login class.

3. Click the Configuration tab. In the configuration tree, select System>Login>Class .

4. Add or modify login class settings as specified in Table 27 on page 46.

5. Click one:

• New—Adds a new login class.

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Search—Search a login class.

Table 27: Login Class Authentication Configuration Details

Your ActionFunctionOption

Class

Enter a name for the login class.Specifies a name for the login
class.

Name

Enter a comment.Specifies the comment added
to the class.

Comment

Enter the start time for remote
access in hh:mm format.

Specifies the start time for
remote access.

Access Start

Enter the end time for remote
access in hh:mm format.

Specifies the end time for
remote access.

Access End
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Table 27: Login Class Authentication Configuration Details (continued)

Your ActionFunctionOption

Enter the maximum idle time
before logout in minutes.

Specifies the maximum idle
time before logout.

Idle Timeout

–Displays the system alarms
when logging in.

Login Alarms

–Executes the login-script when
logging in.

Login Script

–Displays tips when logging in.Login Tip

Enter the command name
enclosed in quotation marks. For
example, “request system reboot”.

Specifies theoperationalmode
commands that members of a
login class can use.

Allow Commands

Enter the command name
enclosed in quotation marks. For
example, "(show system
statistics)|(show bgp summary)".

Specifies the regular expression
for commands to deny
explicitly.

Deny Commands

Enter the configuration in
quotation marks. For example,
“regular expression 1”.

Specifies the regular expression
for configure to be allowed
explicitly.

Allow Configuration

Enter the configuration in
quotation marks. For example,
“system services”.

Specifies the regular expression
for configure to be denied
explicitly.

Deny Configuration

The options available are:

• none

• audit-administrator

• crypto-administrator

• ids-administrator

• security-administrator

Specifies the common criteria
for security role.

Security Roles

Login > Class > Allow Configuration Regexps

Enter a regular expression string.
For example, “interfaces .*
description .*” “interfaces .* unit .*
description .*” "interfaces .* unit .*
family inet address .* “interfaces .*
disable” .

Specifies the object path
regular expressions to be
allowed.

Allow Configuration
Regexps

Login > Class > Allowed Days

Select the day(s) from the drop
down box. For example,Monday.

Specifies the day(s) of week
when access is allowed.

Allowed Days

Login > Class > Deny Configuration Regexps
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Table 27: Login Class Authentication Configuration Details (continued)

Your ActionFunctionOption

Enter the regular expression string.
For example, “system” “protocols”
.

Specifies the object path
regular expressions to be
denied.

Deny Configuration
Regular Expressions

Login > Class > Permissions

Enter a new permission.Configures the login access
privileges to be provided on the
device.

Permissions

Configuring User Accounts

User accounts provide one way for users to access the device. (Users can access the

routerwithoutaccounts if youconfiguredRADIUSorTACACS+servers.) For eachaccount,

define the login name for the user and, optionally, information that identifies the user.

After you have created an account, a home directory is created for the user.

To configure user accounts:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to
configure login class.

3. Click the Configuration tab. In the configuration tree, select System > Login > User.

4. Add or modify login class settings as specified in Table 28 on page 48.

5. Click one:

• New—Adds a new user account.

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Search—Search the available login classes.

Table 28: User Authentication Configuration Details

Your ActionFunctionOption

Enter a unique name for the
user.

Identifies the user with a unique name.Name

Enter a comment.Specifies the comment added to the
login class.

Comment

Enter the full name.Specifies the full name of the user.Full Name

Enter an user ID. For example,
100...64000.

Specifies the user identifier.Uid
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Table 28: User Authentication Configuration Details (continued)

Your ActionFunctionOption

Select the class name.Specifies the user's login class.Class

Login > User > Authentication

Enter theplain textpassword for
the user.

Specifies the user’s password.Plain Text
Password Value

Login > User > Authentication > Ssh DSA

Enter a DSA public key string.Specifies the secure shell (ssh) DSA
public key string.

Ssh DSA

Enter an unique name for the
DSA public string.

Specifies the name of the DSA public
string.

Name

Enter a comment.Specifies thecommentadded to thessh
data.

Comment

–Specifies the pattern-list of hosts
allowed.

From

Login > User > Authentication > Ssh Rsa

Enter a RSA public key string.Specifies the secure shell (ssh) RSA
public key string.

Ssh RSA

Enter an unique name for the
RSA public string.

Specifies the name of the RSA public
string.

Name

Enter a comment.Specifies the comment added to the
RSA data.

Comment

–Specifies the pattern-list of hosts
allowed.

From

Related
Documentation

Configuring RADIUS Authentication (NSM Procedure) on page 43•

• Configuring TACACS+ Authentication (NSM Procedure) on page 44

• Configuring Authentication Order (NSM Procedure) on page 45

Configuring Template Accounts (NSMProcedure)

You can create template accounts that are shared by a set of users when you are using

RADIUSorTACACS+authentication.Whenauser is authenticatedbya templateaccount,
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the CLI username is the login name, and the privileges, file ownership, and effective user

ID are inherited from the template account.

To configure template accounts, follow these procedures:

• Creating a Remote Template Account on page 50

• Creating a Local Template Account on page 51

Creating a Remote Template Account

You can create a remote template that is applied to users authenticated by RADIUS or

TACACS+ that do not belong to a local template account.

By default, Junos OSwith enhanced services uses the remote template account when:

• The authenticated user does not exist locally on the Services Router.

• The authenticated user's record in the RADIUS or TACACS+ server specifies local user,

or the specified local user does not exist locally on the device.

The followingprocedurecreatesasampleusernamed remote thatbelongs to theoperator

login class.

To create a remote template account:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to
create a remote template account.

3. Click the Configuration tab. In the configuration tree, select System > Login > User.

4. Add or modify login class settings as specified in Table 29 on page 50.

5. Click one:

• New—Creates a new remote template account.

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 29: Remote Template Account Details

Your ActionFunctionOption

Enter the user name. For example, type
remote.

Specifies a name for the user name.Name

Enter the number associated with the
login account.

Specifies the user identifier for a
login account.

Uid

Select the login class. For example, select
operator.

Specifies the login class for the user.Class
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Creating a Local Template Account

You can create a local template that is applied to users authenticated by RADIUS or

TACACS+ that are assigned to the local template account. You use local template

accounts when you need different types of templates. Each template can define a

different set of permissions appropriate for the group of users who use that template.

The following procedure creates a sample user named admin that belongs to the

superuser login class.

To create a local template account:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to
create a local template account.

3. Click the Configuration tab. In the configuration tree, select System > Login > User.

4. Add or modify login class settings as specified in Table 30 on page 51.

5. Click one:

• New—Creates a new local template account.

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 30: Local Template Account Details

Your ActionFunctionOption

Enter the user name. For example, type
admin.

Specifies a name for the user name.Name

Enter the number associated with the
login account.

Specifies the user identifier for a
login account.

Uid

Select the login class. For example, select
superuser.

Specifies the login class for the user.Class

Related
Documentation

• Configuring RADIUS Authentication (NSM Procedure) on page 43

• Configuring TACACS+ Authentication (NSM Procedure) on page 44

• Configuring Authentication Order (NSM Procedure) on page 45
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CHAPTER 8

Configuring Chassis in J Series Services
Routers and SRX Series Services
Gateways

• Configuring Aggregated Devices (NSM Procedure) on page 53

• Configuring Chassis Alarms (NSM Procedure) on page 54

• Configuring Chassis FPC (NSM Procedure) on page 55

• Configuring a T640 Router on a Routing Matrix (NSM Procedure) on page 60

• Configuring Routing Engine Redundancy (NSM Procedure) on page 65

• Configuring a Routing Engine to Reboot or Halt on Hard Disk Errors (NSM

Procedure) on page 66

Configuring Aggregated Devices (NSMProcedure)

The Junos OS supports the aggregation of physical devices into the defined virtual links,

suchas the link aggregation of Ethernet interfaces definedby the IEEE802.3ad standard.

Youcanconfigure theproperties for Ethernet andsonet aggregateddeviceson the router.

To configure the aggregated devices on the router:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Chassis > Aggregated

Devices.

4. Add or modify the settings as specified in Table 31 on page 54.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 31: Aggregated Devices Configuration Details

Your ActionTask

1. Click Ethernet next to Aggregated Devices.

2. Enter the number of aggregated logical devices available to
the router.

Range: 1 through 256 devices

3. Click Lacp next to Ethernet.

4. In the SystemPriority box, enter the priority for the aggregated
Ethernet system.

5. Click Link Protection next to Lacp.

6. Select the Non Revertive check box if you want to disable the
ability to switch to abetter priority link (if one is available) once
a link is established as active and a collection or distribution is
enabled.

Configure properties for
Ethernet aggregated
devices.

1. Click Sonet next to Aggregated Devices.

2. From the Device Count list, select the number of aggregated
logical devices available to the router.

Range: 1 through 16 Devices

Configure properties for
sonet aggregated devices.

Related
Documentation

Configuring Chassis Alarms (NSM Procedure) on page 54•

• Configuring a T640 Router on a Routing Matrix (NSM Procedure) on page 60

• Configuring Routing Engine Redundancy (NSM Procedure) on page 65

• Configuring a Routing Engine to Reboot or Halt on Hard Disk Errors (NSM Procedure)

on page 66

Configuring Chassis Alarms (NSMProcedure)

You can configure the chassis alarms for an interface type to trigger a red or yellow alarm

or to ignoreanalarm.Various conditions related to thechassis components trigger yellow

and red alarms.

To configure chassis alarm on the router:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Chassis > Alarm.

4. Add or modify the alarm settings as specified in Table 32 on page 55.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 32: Chassis Alarms Configuration Details

Your ActionTask

1. Select the interface type listed next to Alarm.

2. Select the alarm type for the chassis condition for each
interface type.

Configuring the alarm type.

Related
Documentation

Configuring Aggregated Devices (NSM Procedure) on page 53•

• Configuring Chassis FPC (NSM Procedure) on page 55

• Configuring Routing Engine Redundancy (NSM Procedure) on page 65

Configuring Chassis FPC (NSMProcedure)

For MX Series routers, there is a one-to-onemapping of the Packet Forwarding Engines

and thePICs.Therefore, youcanoverride theport-mirroring instanceproperties configured

at theDPC level andconfigureaPIC-level port-mirroring instance. Tobindaport-mirroring

instance to a specific Packet Forwarding Engine and its associated ports, you can use

this option.

You can also configure aggregate ports, maximum queue per interface, and tunneling

services for PICs.

To configure chassis FPC in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Chassis > Fpc.

4. Add or modify settings as specified in Table 33 on page 55.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 33: FPC Configuration Details

Your ActionTask

1. Click Add new entry next to Fpc.

2. From the Name list, select the slot number of the DPC.

3. From the Power list, configure the Flexible PIC Concentrator
(FPC) to stay offline or to come online automatically.

Configure a port-mirroring
instance for the DPC and its
corresponding Packet
Forwarding Engines.
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Table 33: FPC Configuration Details (continued)

Your ActionTask

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. From the Name list, select the slot number of the DPC.

5. In the Comment box, enter the comment.

6. From the Framing list, select the framing type.

7. From the Vtmapping list, select one of the virtual tributary
mapping.

• klm—KLM standard.

• itu-t—International Telephony Union standard.

8. Select the No Concatenate check box to not concatenate
(multiplex) the output of a SONET/SDHPIC (an interfacewith
a name so-fpc/pic/port).

9. Select the Aggregate Ports check box if you want to aggregate
multiple ports on a PIC as a single port.

10. Select the Sparse Dlcis check box to support a full data-link
connection identifier (DLCI) range (1 through 1022).

11. FromtheMlfrUniNniBundles list, select thenumberofmultilink
frame relay user-to-network interface network-to-network
interface (UNI-NNI) (FRF.16) bundles to allocate on a link
services PIC.

Range: 1 through 255

12. From theMaxQueues Per Interface list, select the required
egress queues on IQ interfaces.

Configure aggregate port,
maximum queues per
interface and port mirroring
instances for the PICs.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. Click Adaptive Services next to pic.

5. Select Adaptive Services to enable a service package on
adaptive services interfaces.

Enableaservicepackageon
adaptive services interfaces.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to pic.

4. Click Ce1 next to pic.

5. In the Comment box, enter the comment.

6. Click E1 next to Ce1.

7. Click Add new entry next to E1.

8. From the Name list, select the port number.

9. In the Comment box, enter the comment.

10. Click Channel Group next to e1.

11. Click Add new entry next to Channel Group.

12. From the Name list, select the channel number.

13. In the Comment box, enter the comment.

14. In the Timeslots box, enter the actual time slot number.

Configure channelized E1
port and channel
specifications.
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Table 33: FPC Configuration Details (continued)

Your ActionTask

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. Click Ct3 next to pic.

5. In the Comment box, enter the comment.

6. Click Port next to Ct3.

7. Click Add new entry next to Port.

8. From the Name list, select the port number.

9. In the Comment box, enter the comment.

10. Click T1 next to Port.

11. Click Add new entry next to T1.

12. From the Name list, select the link number.

13. In the Comment box, enter the comment.

14. Click Channel Group next to t1.

15. Click Add new entry next to Channel Group.

16. From the Name list, select the channel number.

17. In the Comment box, enter the comment.

18. In the Timeslots box, enter the actual time slot number.

Configure channelized T3
port and channel
specifications.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. Click Hash Key next to pic.

5. In the Comment box, enter the comment.

6. Click Family next to Hash Key.

7. In the Comment box, enter the comment.

Configure data used in a
hash key for a protocol
family.

1. Click Inet next to Family.

2. In the Comment box, enter the comment.

3. Click Layer 3 next to Inet.

4. In the Comment box, enter the comment.

5. Select the Destination Address check box to compute
symmetrical hashing based on the destination address.

6. Click Layer 4 next to Inet.

7. In the Comment box, enter the comment.

8. Click Symmetric Hash next to Inet.

9. In the Comment box, enter the comment.

10. Select the Complement check box to include the complement
of the symmetric hash in the hash key.

Configure data used in a
hash key for the inet
protocol family when
configuring PIC-level
symmetrical load balancing
on an 802.3ad link
aggregation group.
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Table 33: FPC Configuration Details (continued)

Your ActionTask

1. ClickMultiservice next to Family.

2. In the Comment box, enter the comment.

3. Select theSourceMaccheckbox to includesourceMACaddress
in the hash key.

4. Select the DestinationMac check box to include destination
MAC address in the hash key.

5. Click Payload next to Multiservice.

6. Click IP next to Payload.

7. In the Comment box, enter the comment.

8. Select the Layer 4 check box to include Layer 4 IP information
in the hash key.

9. Click Layer 3 next to IP.

10. Select one of the following:

• source-ip-only—To include source IP only in hash-key.

• destination-ip-only—To include destination IP only in
hash-key.

11. Click Symmetric Hash next to Multiservice.

12. In the Comment box, enter the comment.

13. Select the Complement check box to include the complement
of the symmetric hash in the hash key.

Configure data used in a
hashkey for themultiservice
protocol family when
configuring PIC-level
symmetrical hashing for
load balancing on an
802.3ad link aggregation
group.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. Click Port next to pic.

5. From the Name list, select the port number.

6. In the Comment box, enter the comment.

7. From the Framing list, select the framing type.

Configure the channelized
T3 port number on the PIC.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. ClickQPic Large Buffer next to pic.

5. In the Comment box, enter the comment.

Configure delay buffers.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. ClickPortMirror Instance next to pic and perform the following:

• Add—Adds the selected port-mirroring instances from the
Nonmember list to the Members list.

• Remove—Removes the selected port-mirroring instances
from the Members list.

• Add All—Adds all the port-mirroring instances from the
Non-members list to the Members list.

• Remove All—Removes all the port-mirroring instances from
the Members list.

Configure port-mirroring
instances.
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Table 33: FPC Configuration Details (continued)

Your ActionTask

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. Click Traffic Manager next to pic.

5. From the Ingress Shaping Overhead list, select the number of
CoS shaping overhead bytes to add to the packets on the
ingress sideof theL2TPtunnel todetermine theshapedsession
packet length.

Range: 0 through 255

6. From the Egress Shaping Overhead list, select the number of
CoSshapingoverheadbytes toadd to thepacketson theegress
interface.

Range: 0 through 255

7. From theMode list, select the mode of shaping.

Enable shaping on an L2TP
session.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. Click Tunnel Service next to pic.

5. From the Bandwidth list, select the bandwidth of 1 Gbps or 10
Gbps on the Packet Forwarding Engine connected to a Gigabit
Ethernet 40-port DPC.

Configure the amount of
bandwidth for tunnel
services.

1. Click Add new entry next to Fpc.

2. ClickPortMirror Instance next to fpc andperform the following:

• Add—Adds the selected port-mirroring instances from the
Nonmember list to the Members list.

• Remove—Removes the selected port-mirroring instances
from the Members list.

• Add All—Adds all the port-mirroring instances from the
Non-members list to the Members list.

• Remove All—Removes all the port-mirroring instances from
the Members list.

Configure Port-Mirroring
Instances.

1. Click Add new entry next to Fpc.

2. Click Sampling Instances next to fpc.

3. Click Add new entry next to Sampling Instances.

4. From the Name list, select the sampling instance name.

5. In the Comment box, enter the comment.

Associate a sampling
instance.

Related
Documentation

Configuring Aggregated Devices (NSM Procedure) on page 53•

• Configuring Chassis Alarms (NSM Procedure) on page 54

• Configuring a T640 Router on a Routing Matrix (NSM Procedure) on page 60
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Configuring a T640 Router on a RoutingMatrix (NSMProcedure)

To configure a T640 router on a routing matrix in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Chassis > Lcc.

4. Add or modify settings as specified in Table 34 on page 60.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 34: Lcc Configuration Details

Your ActionTask

1. Click Add new entry next to Lcc.

2. From the Name list, select the number that specifies a T640
router on a routing matrix.

Range: 0 through 3

3. In the Comment box, enter the comment.

4. Select one of the following:

• online-expected—On a TXMatrix router, configures a T640
router so that if it does not come online, an alarm is sent to
the TXMatrix router. On a TXMatrix Plus router, configure a
T1600 router so that if it does not come online, an alarm is
sent to the TXMatrix Plus router.

• offline—On a TXMatrix router, configures a T640 router so
that it is not part of the routing matrix. On a TXMatrix Plus
router, configure a T1600 router so that it is not part of the
routing matrix.

Configure the T640 routing
node.

1. Click Fpc next to Lcc.

2. Click Add new entry next to Fpc.

3. From the Name list, select the slot number of the DPC.

4. From the Power list, configure the Flexible PIC Concentrator
(FPC) to stay offline or to come online automatically.

Configure a port-mirroring
instance for the DPC and its
corresponding Packet
Forwarding Engines.
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Table 34: Lcc Configuration Details (continued)

Your ActionTask

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to PIC.

4. From the Name list, select the slot number of the DPC.

5. In the Comment box, enter the comment.

6. From the Framing list, select the framing type.

7. From the Vtmapping list, select one of the virtual tributary
mapping.

• klm—KLM standard.

• itu-t—International Telephony Union standard.

8. Select the No Concatenate check box to not concatenate
(multiplex) the output of a SONET/SDHPIC (an interfacewith
a name so-fpc/pic/port).

9. Select the Aggregate Ports check box if you want to aggregate
multiple ports on a PIC as a single port.

10. Select the Sparse Dlcis check box to support a full data-link
connection identifier (DLCI) range (1 through 1022).

11. FromtheMlfrUniNniBundles list, select thenumberofmultilink
frame relay user-to-network interface network-to-network
interface (UNI-NNI) (FRF.16) bundles to allocate on a Link
Services PIC.

Range: 1 through 255

12. From theMaxQueues Per Interface list, select the required
egress queues on IQ interfaces.

Configures aggregate port,
maximum queues per
interface andport-mirroring
instances for the PICs.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. Click Adaptive Services next to pic.

5. Choose Adaptive Services to enable a service package on
adaptive services interfaces.

Enableaservicepackageon
adaptive services interfaces.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to pic.

4. Click Ce1 next to pic.

5. In the Comment box, enter the comment.

6. Click E1 next to Ce1.

7. Click Add new entry next to E1.

8. From the Name list, select the port number.

9. In the Comment box, enter the comment.

10. Click Channel Group next to e1.

11. Click Add new entry next to Channel Group.

12. From the Name list, select the channel number.

13. In the Comment box, enter the comment.

14. In the Timeslots box, enter the actual time slot number.

Configure channelized E1
port and channel
specifications.
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Table 34: Lcc Configuration Details (continued)

Your ActionTask

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. Click Ct3 next to pic.

5. In the Comment box, enter the comment.

6. Click Port next to Ct3.

7. Click Add new entry next to Port.

8. From the Name list, select the port number.

9. In the Comment box, enter the comment.

10. Click T1 next to Port.

11. Click Add new entry next to T1.

12. From the Name list, select the link number.

13. In the Comment box, enter the comment.

14. Click Channel Group next to t1.

15. Click Add new entry next to Channel Group.

16. From the Name list, select the channel number.

17. In the Comment box, enter the comment.

18. In the Timeslots box, enter the actual time slot number.

Configure channelized T3
port and channel
specifications.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. Click Hash Key next to pic.

5. In the Comment box, enter the comment.

6. Click Family next to Hash Key.

7. In the Comment box, enter the comment.

Configure data used in a
hash key for a protocol
family.

1. Click Inet next to Family.

2. In the Comment box, enter the comment.

3. Click Layer 3 next to Inet.

4. In the Comment box, enter the comment.

5. Select the Destination Address check box to compute
symmetrical hashing based on the destination address.

6. Click Layer 4 next to Inet.

7. In the Comment box, enter the comment.

8. Click Symmetric Hash next to Inet.

9. In the Comment box, enter the comment.

10. Select the Complement check box to include the complement
of the symmetric hash in the hash key.

Configure data used in a
hash key for the inet
protocol family when
configuring PIC-level
symmetrical load balancing
on an 802.3ad link
aggregation group.
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Table 34: Lcc Configuration Details (continued)

Your ActionTask

1. ClickMultiservice next to Family.

2. In the Comment box, enter the comment.

3. Select theSourceMaccheckbox to includesourceMACaddress
in the hash key.

4. Select the DestinationMac check box to include destination
MAC address in the hash key.

5. Click Payload next to Multiservice.

6. Click IP next to Payload.

7. In the Comment box, enter the comment.

8. Select the Layer 4 check box to include Layer 4 IP information
in the hash key.

9. Click Layer 3 next to IP.

10. Select one of the following:

• source-ip-only—To include source IP only in hash-key.

• destination-ip-only—To include destination IP only in
hash-key.

11. Click Symmetric Hash next to Multiservice.

12. In the Comment box, enter the comment.

13. Select the Complement check box to include the complement
of the symmetric hash in the hash key.

Configure data used in a
hash key for themultiservice
protocol family when
configuring PIC-level
symmetrical hashing for
load balancing on an
802.3ad link aggregation
group.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. Click Port next to pic.

5. From the Name list, select the port number.

6. In the Comment box, enter the comment.

7. From the Framing list, select the framing type.

Configure the channelized
T3 port number on the PIC.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. ClickQPic Large Buffer next to pic.

5. In the Comment box, enter the comment.

Configure delay buffers.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. ClickPortMirror Instance next to pic and perform the following:

• Add—Adds the selected port-mirroring instances from the
Nonmember list to the Members list.

• Remove—Removes the selected port-mirroring instances
from the Members list.

• Add All—Adds all the port-mirroring instances from the
Non-members list to the Members list.

• Remove All—Removes all the port-mirroring instances from
the Members list.

Configure port-mirroring
instances for PIC.
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Table 34: Lcc Configuration Details (continued)

Your ActionTask

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. Click Traffic Manager next to pic.

5. From the Ingress Shaping Overhead list, select the number of
CoS shaping overhead bytes to add to the packets on the
ingress sideof theL2TPtunnel todetermine theshapedsession
packet length.

Range: 0 through 255

6. From the Egress Shaping Overhead list, select the number of
CoSshapingoverheadbytes toadd to thepacketson theegress
interface.

Range: 0 through 255

7. From theMode list, select the mode of shaping.

Enable shaping on an L2TP
session.

1. Click Add new entry next to Fpc.

2. Click Pic next to fpc.

3. Click Add new entry next to Pic.

4. Click Tunnel Service next to pic.

5. From the Bandwidth list, select the bandwidth of 1 Gbps or 10
Gbps on the Packet Forwarding Engine connected to a Gigabit
Ethernet 40-port DPC.

Configure the amount of
bandwidth for tunnel
services.

1. Click Add new entry next to Fpc.

2. ClickPortMirror Instance next to fpc andperform the following:

• Add—Adds the selected port-mirroring instances from the
Nonmember list to the Members list.

• Remove—Removes the selected port-mirroring instances
from the Members list.

• Add All—Adds all the port-mirroring instances from the
Non-members list to the Members list.

• Remove All—Removes all the port-mirroring instances from
the Members list.

Configure port-mirroring
instances for FPC.

1. Click Add new entry next to Fpc.

2. Click Sampling Instances next to fpc.

3. Click Add new entry next to Sampling Instances.

4. From the Name list, select the sampling instance name.

5. In the Comment box, enter the comment.

Associate a sampling
instance.

Related
Documentation

Configuring Aggregated Devices (NSM Procedure) on page 53•

• Configuring Routing Engine Redundancy (NSM Procedure) on page 65

• Configuring a Routing Engine to Reboot or Halt on Hard Disk Errors (NSM Procedure)

on page 66
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Configuring Routing Engine Redundancy (NSMProcedure)

You can configure redundancy properties for routers that havemultiple Routing Engines

or these multiple switching control boards: Switching and Forwarding Modules (SFMs),

System and Switch Boards (SSBs), Forwarding Engine Boards (FEBs), or Compact

Forwarding Engine Boards (CFEBs).

To configure routing engine redundancy in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, select Chassis > Redundancy.

4. Add or modify settings as specified in Table 35 on page 65.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 35: Chassis Redundancy Configuration Details

Your ActionTask

1. In the Comment box, enter the comment.

2. From the keepalive list, select the time before the backup
router takes mastership when it detects loss of the keepalive
signal.

Range: 2 through 10,000

Configure redundancy
options.

1. Click Failover next to Redundancy.

2. In the Comment box, enter the comment.

3. Select the type of failover.

Instruct the backup router to
take mastership if it detects
hard disk errors or a loss of a
keepalive signal from the
master Routing Engine.

1. Click Graceful Switchover next to Redundancy.

2. In the Comment box, enter the comment.

For routing platforms with
two Routing Engines,
configure a master Routing
Engine to switch over
gracefully to a backup
Routing Engine without
interruption to packet
forwarding.
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Table 35: Chassis Redundancy Configuration Details (continued)

Your ActionTask

1. Click Routing Engine next to Redundancy.

2. From the Name list, select the slot number.

3. In the Comment box, enter the comment.

4. Select the functionof theRoutingEngine for the specified slot.

5. Select one of the following:

• master—To configure the routing engine to be themaster.

• backup—To configure the routing engine to be the backup.

• disabled—To disable the routing engine.

Sets the function of the
Routing Engine for the
specified slot. By default, the
RoutingEngine in slot0 is the
master Routing Engine and
the Routing Engine in slot 1 is
the backup Routing Engine.

Related
Documentation

Configuring Aggregated Devices (NSM Procedure) on page 53•

• Configuring a T640 Router on a Routing Matrix (NSM Procedure) on page 60

• Configuring a Routing Engine to Reboot or Halt on Hard Disk Errors (NSM Procedure)

on page 66

Configuring a Routing Engine to Reboot or Halt on Hard Disk Errors (NSMProcedure)

You can configure a Routing Engine to halt or reboot automatically when a hard disk

error occurs. A hard disk error may cause a Routing Engine to enter a state in which it

responds to local pings and interfaces remain up, but no other processes are responding.

To Configure Routing Engine to reboot or halt:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, select Chassis > Routing Engine.

4. Add or modify Routing Engine settings as specified in Table 36 on page 66.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 36: Chassis Routing Engine Configuration Details

Your ActionOption

From the Disk Failure Action list, select the action to instruct the
router on detecting the hard disk errors on the Routing Engine.

On disk failure.

Related
Documentation

• Configuring Aggregated Devices (NSM Procedure) on page 53

• Configuring a T640 Router on a Routing Matrix (NSM Procedure) on page 60

• Configuring Routing Engine Redundancy (NSM Procedure) on page 65
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CHAPTER 9

Configuring USB Modem Interfaces in J
Series Services Routers and SRX Series
Services Gateways

• Configuring a USBModem Interface (NSM Procedure) on page 67

• Configuring a Dialer Interface (NSM Procedure) on page 68

• Configuring Dial-in Options on a Dialer Interface (NSM Procedure) on page 69

• Configuring a CHAP Access Profile on a Dialer Interface (NSM Procedure) on page 70

Configuring a USBModem Interface (NSMProcedure)

To configure a USBmodem interface for the device:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to

configure the USBmodem interface.

3. Click theConfiguration tab. In the configuration tree, select Interfaces> Interfaces List.

4. Add or modify interface settings as specified in Table 37 on page 67.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 37: USBModem Interface Configuration Details

Your ActionFunctionOption

Enter a name for the new
interface.

Specifies the nameof the new
interface.

Name

Dialer Options > Pool
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Table 37: USBModem Interface Configuration Details (continued)

Your ActionFunctionOption

Enter a name for the dialer
pool.

Specifies the name of the
dialer pool configured on the
dialer interface you want to
use for USBmodem
connectivity.

Name

Set the dialer pool priority.Specifies the dialer pool
priority.

Priority

ModemOptions

Enter themodem initialization
commandstring. Forexample,
enter ATSO=2.

Configures the modem to
automatically answer calls
after a specified number of
rings.

Init Command String

Related
Documentation

Configuring a Dialer Interface (NSM Procedure) on page 68•

• Configuring Dial-in Options on a Dialer Interface (NSM Procedure) on page 69

Configuring a Dialer Interface (NSMProcedure)

To configure a dialer interface for the device:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to

configure the dialer interface.

3. Click theConfiguration tab. In the configuration tree, select Interfaces> Interfaces List.

4. Add or modify interface settings as specified in Table 38 on page 68.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 38: Dialer Interface Configuration Details

Your ActionFunctionOption

Enter a name for the new
interface.

Specifies the nameof the new
interface.

Name

Enter adescription for thenew
interface.

Differentiates between
different dialer interfaces.

Description

Select PPP from the
encapsulation list.

Specifies the encapsulation.Encapsulation
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Table 38: Dialer Interface Configuration Details (continued)

Your ActionFunctionOption

Unit

Enter the unit number.Specifies the logical unit.Unit

Unit > Dialer Options

Enter the name of the dialer
pool.

Specifies the name of the
dialer pool to use for USB
modem connectivity.

Pool

Unit > Family > Inet > Address

Enter the source IP address.Specifies thesource IPaddress
for the dialer interface.

Name

Enter the destination IP
address.

Specifies the destination IP
address for thedialer interface.

Destination

Related
Documentation

Configuring a USBModem Interface (NSM Procedure) on page 67•

• Configuring Dial-in Options on a Dialer Interface (NSM Procedure) on page 69

Configuring Dial-in Options on a Dialer Interface (NSMProcedure)

To configure dial-in options on a dialer interface:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to

configure dial-in options.

3. Click theConfiguration tab. In the configuration tree, select Interfaces> Interfaces List.

4. Select the dialer interface and add or modify interface settings as specified in Table

39 on page 69.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 39: Dialer Interface for Dial-in Configuration Details

Your ActionFunctionOption

Unit > Dialer Options > IncomingMap

• Select accept-all to accept
all incoming calls.

• Select caller to accept calls
from a specific caller ID.

Specifies the incomingmap
options for thedialer interface.

Caller
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Table 39: Dialer Interface for Dial-in Configuration Details (continued)

Your ActionFunctionOption

Caller

Enter the caller ID.Specifies the caller ID to be
accepted on the dialer
interface.

Name

Related
Documentation

Configuring a Dialer Interface (NSM Procedure) on page 68•

• Configuring a USBModem Interface (NSM Procedure) on page 67

Configuring a CHAP Access Profile on a Dialer Interface (NSMProcedure)

To configure a CHAP access profile on a dialer interface:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to

configure CHAP.

3. Click the Configuration tab. In the configuration tree, select Access > Profile to define

a CHAP access profile.

4. Add or modify CHAP access settings as specified in Table 40 on page 70.

5. Click the Configuration tab. In the configuration tree, select Interfaces > Interfaces List

to configure CHAP on the dialer interface.

6. Select the appropriate dialer interface level, and add or modify interface settings as

specified in Table 41 on page 71.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 40: CHAP Access Profile Configuration Details

Your ActionFunctionOption

Enter a name for the profile.Specifies a name for the
profile.

Name

Client

Enter a name for the client.Specifiesaname for theclient.Name

Enter the CHAP secret.

NOTE: Enter the client name
and CHAP secret for each
client to be included in the
CHAP profile.

Specifies the CHAP secret.Chap Secret
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Table 41: CHAP Dialer Interface Configuration Details

Your ActionFunctionOption

Unit

Enter the unit number.Specifies the logical unit.Unit

Unit > PppOptions > Chap

Enter a unique profile name
containing a client list and
access parameters.

Specifies the profile name.Access profile

Related
Documentation

• Configuring a Dialer Interface (NSM Procedure) on page 68

• Configuring a USBModem Interface (NSM Procedure) on page 67
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CHAPTER 10

Configuring Policy Options in J Series
Services Routers and SRX Series Services
Gateways

• Configuring an AS Path Group in a BGP Routing Policy (NSM Procedure) on page 73

• Configuring a Community for use in BGP Routing Policy Conditions (NSM

Procedure) on page 74

• Configuring a BGP Export Policy Condition (NSM Procedure) on page 75

• Configuring Flap Damping to Reduce the Number of BGP Update Messages(NSM

Procedure) on page 76

• Configuring a Routing Policy Statement (NSM Procedure) on page 78

• Configuring Prefix List (NSM Procedure) on page 79

Configuring an AS Path Group in a BGP Routing Policy (NSMProcedure)

Autonomous System (AS) path group consists of multiple AS paths. You can define

match conditions based on the AS path groups. You can create named AS paths under

an AS path group and then include the AS path group in a routing policy.

To configure an AS path group for a BGP routing policy in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Policy Options.

5. Select As Path Group.

6. Add or modify the parameters as specified in Table 42 on page 74.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the protocol settings.
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NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 42: AS Path Group Configuration Details

Your ActionFunctionOption

Enter a name.Specifies thenameof theASpathgroup.Name

Enter a comment.Specifies the comment for the AS path
group.

Comment

1. Select As Path.

2. Click the Newbutton or select an AS
path and click the Edit button.

3. Specify the name, comment and
path.

4. ClickOK, then clickOK again.

Specifies an AS path to be included in
the AS path group. Specifies the name
and comment for the AS path and
specifies thepathasanASpathnumber.

As Path

Configuring a Community for use in BGP Routing Policy Conditions (NSMProcedure)

A community is a group of destinations that share a common property. You can define

a community for use in a BGP routing policy match condition.

To configure a community for a BGP routing policy in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Policy Options.

5. Select Community.

6. Add or modify the parameters as specified in Table 43 on page 75.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the protocol settings.
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NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 43: Community Configuration Details

Your ActionFunctionOption

Enter the name.Specifies the name of the community.Name

Enter the comment.Specifies the comment for the
community.

Comment

Select the check-box if you want to
invert the results. Clear the check-box if
you do not want to invert the results.

Enables you to invert the results for the
community expression.

Invert Match

1. SelectMembers.

2. Click the New button or select a
member and click the Edit button.

3. Enter the member community.

4. ClickOK, then clickOK again.

Specifies one or more community
members.

Members

Configuring a BGP Export Policy Condition (NSMProcedure)

You can define a routing policy condition based on the existence of routes in specific

tables for use in a BGP export policy.

To configure condition in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Policy Options.

5. Select Condition.

6. Add or modify the parameters as specified in Table 44 on page 76.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the protocol settings.
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NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 44: Condition Configuration Details

Your ActionFunctionOption

Enter a name.Specifies the name of the condition.Name

Enter a comment.Specifies thecomment for thecondition.Comment

1. Select Route Active On.

2. Select one:

• None—No policy condition based
on routes need to be specified.

• if-route-exists—Specify the policy
condition based on the routes.
Enter the comment, route and the
corresponding routing table.

3. ClickOK.

Enables you to specify the policy
condition based on the existing routes
and the corresponding route tables.

Route Active On

Configuring Flap Damping to Reduce the Number of BGPUpdateMessages(NSM
Procedure)

To advertise network reachability information, BGP systems send an excessive number

ofupdatemessages.Youcanuse flapdamping to reduce thenumberofupdatemessages

sent between BGP peers, thereby reducing the load on these peers without adversely

affecting the route convergence time. Damping reduces the number of updatemessages

by marking these routes as ineligible, so that they cannot be selected as active or

preferable routes. Applying damping leads to some delay, or suppression, in the

propagation of route information, but the result is increased network stability. You can

define actions by creating a named set of damping parameters and including the set in

a routing policy.

To configure damping for a BGP routing policy in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Policy Options.

5. Select Damping.
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6. Add or modify the parameters as specified in Table 45 on page 77.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the protocol settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 45: Damping Configuration Details

Your ActionFunctionOption

Enter a name.Specifies the name of the damping
parameter setting.

Name

Enter a comment.Specifies the comment for the damping
parameter setting.

Comment

Select the check-box to disable
damping. Clear the check-box to enable
damping.

Enables you to disable damping on a
per-prefix basis. Any damping state that
is present in the routing table for a prefix
is deleted if damping is disabled.

Disable

Enter the time limit in minutes or select
it from the list.

Indicates the time in minutes interval
after which the accumulated
figure-of-merit value is reduced by half
if the route remains stable.
Figure-of-merit values correlate to the
probability of future instability of a
device. Routes with higher
figure-of-merit values are suppressed
for longer periods of time.

Half Life

Enter the value or select it from the list.Indicates the figure-of-merit valuebelow
which a suppressed route can be used
again.

Reuse

Enter the value or select it from the list.Indicates the figure-of-merit valueabove
which a route is suppressed for use or
inclusion in advertisements.

Suppress

1. Enter the time limit or select it from
the list.

2. ClickOK.

Indicates themaximum time inminutes
that a route can be suppressed no
matter how unstable it has been.

Max Suppress
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Configuring a Routing Policy Statement (NSMProcedure)

You can configure policy statements for routing policies. Each policy statement is

composed of from criteria, to criteria and then criteria. The from and to criteria comprise

a set of match conditions for the routing policy. The then criteria specify the action to be

taken when the from and to criteria are matched and when they are not matched.

To configure a routing policy statement in NSM :

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Policy Options.

5. Select Policy statement.

6. Add/Modify the parameters as specified in Table 46 on page 78.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply — To apply the protocol settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 46: Configuring Policy Statement Fields

Your ActionFunctionOption

1. Click the New button or select a
policy statement and click Edit
button.

2. Select policy-statement .

3. Specify the name.

Specifies the name of the policy
statement.

Name

1. Click the New button or select a
policy statement and click Edit
button.

2. Select policy-statement .

3. Specify the comment.

Specifies the comment for the policy
statement.

Comment
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Table 46: Configuring Policy Statement Fields (continued)

Your ActionFunctionOption

1. Click the New button or select a
policy statement and click Edit
button.

2. Expand policy-statement tree and
select From.

3. Enter the From criteria.

4. Expand From tree and specify the
match conditions.

Enables you todefine the criteria that an
incoming route must match. You can
specify one ormorematch conditions. If
youspecifymore thanone, all conditions
must match the route for a match to
occur.

From

1. Click the New button or select a
policy statement and click Edit
button.

2. Expand policy-statement tree and
select Term.

3. Click theNewbuttonor select a term
and click Edit button.

4. Enter the term name, comment and
thematch conditions and actions.

Indicates the term to be configured for
the routing policy. You can create one or
more terms for a routing policy. Each
termcomprisesofmatchconditionsand
the corresponding actions.

Term

1. Click the New button or select a
policy statement and click Edit
button.

2. Expand policy-statement tree and
select Then.

3. Specify the parameters for Then
criteria.

4. Expand Then tree and specify the
actions for eachmatch condition.

Enables you to define the action to be
taken in the case of a match or
mismatch between the packets and
From and To conditions.

Then

1. Click the New button or select a
policy statement and click Edit
button.

2. Expand policy-statement tree and
select To.

3. Enter the To criteria.

4. Expand To tree and specify the
match conditions.

Enables you todefine the criteria that an
outgoing route must match. You can
specify one ormorematch conditions. If
youspecifymore thanone, all conditions
must match the route for a match to
occur.

To

Configuring Prefix List (NSMProcedure)

Aprefix list is a named list of IP addresses. You can specify an exactmatchwith incoming

routesandapplyacommonaction toallmatchingprefixes in the list. This featureenables

you to create a named prefix list and include it in a routing policy.

To configure prefix list in NSM:
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1. In the navigation tree select DeviceManager > Devices and select the device from the

list.

2. In the configuration tree, expand Policy Options.

3. Select Prefix List.

4. Add/Modify the parameters as specified in Table 47 on page 80.

5. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply — To apply the protocol settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. SeeUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 47: Configuring Prefix List Fields

Your ActionFunctionField

1. Click the New button or select a
prefix list and click Edit button.

2. Select prefix-list.

3. Specify the name.

Specifies the name of the prefix list.Name

1. Click the New button or select a
prefix list and click Edit button.

2. Select prefix-list.

3. Specify the comment.

Specifies the comment for theprefix list.Comment

1. Click the New button or select a
prefix list and click Edit button.

2. Select prefix-list.

3. Specify the path.

Indicates that the prefix list should
include all IP prefixes pointed to by a
defined path.

Apply Path

1. Click the New button or select a
prefix list and click Edit button.

2. Expand prefix-list tree and select
Prefix List Item.

3. Specify the name and comment.

Specifies the prefix list item.Prefix List Item
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CHAPTER 11

Configuring Routing Options in J Series
Services Routers and SRX Series Services
Gateways

• Configuring Maximum Prefixes (NSM Procedure) on page 81

• Configuring Multicast (NSM Procedure) on page 83

• Configuring Multipath (NSM Procedure) on page 86

• Configuring Options (NSM Procedure) on page 87

• Configuring Route Resolution (NSM Procedure) on page 88

• Configuring Routing Table Groups (NSM Procedure) on page 89

• Configuring Routing Tables (NSM Procedure) on page 91

• Configuring Source Routing (NSM Procedure) on page 93

• Configuring Static Routes (NSM Procedure) on page 94

• Configuring Generated Routes (NSM Procedure) on page 95

• Configuring Graceful Restart (NSM Procedure) on page 96

• Configuring Forwarding Table (NSM Procedure) on page 97

• Configuring Flow Route (NSM Procedure) on page 99

• Configuring Fate Sharing (NSM Procedure) on page 101

• Configuring Martian Addresses (NSM Procedure) on page 102

• Configuring Interface Routes (NSM Procedure) on page 104

• Configuring Instance Export (NSM Procedure) on page 105

• Configuring Instance Import (NSM Procedure) on page 105

ConfiguringMaximumPrefixes (NSMProcedure)

You can configure a limit for the number of routes installed in a routing table based upon

the number of route prefixes in the table. .

To configure maximum prefixes limit in NSM:
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1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. SelectMaximumPrefixes.

6. Enter the parameters as specified in Table 48 on page 82.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 48: ConfiguringMaximumPrefixes Fields

Your ActionFunctionOption

Enter the comment.Specifies thecomment for themaximum
prefix limit.

Comment

Enter limit value or select from the list.Indicates themaximumnumberof route
prefixes. If this limit is reached, awarning
is triggered and additional routes are
rejected.

Limit

Enter the log interval valueor select from
the list.

Indicates the minimum time interval (in
seconds) between log messages.

Log Interval

1. Expand theMaximumPrefixes tree
and select Threshold.

2. Select the option button.

Specifies what is to be done when the
routing table reaches the maximum
prefix value. The options are:

• None—No action is to be taken.

• threshold—You can configure a
percentage for themaximumnumber
of prefixes, which when installed,
triggers the warning.

• log-only—Sets the prefix limit as an
advisory limit. An advisory limit
triggersonly awarning, andadditional
routes are not rejected.

Threshold
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ConfiguringMulticast (NSMProcedure)

You can configure generic multicast properties for routing instances. A routing instance

is a collection of routing tables, interfaces, and routing protocol parameters. The routing

protocol parameters control the information in the routing tables.

To configure generic multicast properties for routing instance in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. SelectMulticast.

6. Add or modify the parameters as specified in Table 49 on page 83.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 49: ConfiguringMulticast Fields

Your ActionFunctionOption

Enter the comment.Specifies thecomment for themulticast
configuration.

Comment

1. Expand theMulticast tree and select
Backup Pe Group.

2. Click the New button or select a
group and click the Edit button.

3. Configure the PE group name, local
address, and backup address.

Enables you to configure a backup
provider edge (PE) group for ingress PE
device redundancy when
point-to-multipoint label-switched
paths (LSPs) are used for multicast
distribution.

Backup Pe Group
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Table 49: ConfiguringMulticast Fields (continued)

Your ActionFunctionOption

1. Expand theMulticast tree and select
FlowMap.

2. Click theNewbutton or select a flow
map and click the Edit button.

3. Configure the following tocreateand
define a flowmap:

• Enter the flowmap name and
comment.

• Bandwidth—Specify the
bandwidth property of the
multicast flowmap.

• Forwarding Cache—Specify the
forwarding cache properties of
entries definedbya flowmap. You
can specify a timeout of never to
make the forwarding entries
permanent, or you can specify a
timeout from 1 through 720
minutes.

• Policy—Specify the flowmap
policies.

• Redundant Sources—Specify the
addresses for use as backup
sources for multicast flows
defined by a flowmap.

Enables you to set upmulticast flow
maps to manage a subset of multicast
forwarding table entries. For example,
you can specify that certain forwarding
cache entries be permanent or have a
different timeout value than those of
other multicast flows that are not
associated with this flowmap .

FlowMap

1. Expand theMulticast tree and select
Forwarding Cache.

2. Configure the timeout and threshold
values.

Enables you to configure multicast
forwarding cache properties. These
properties include thresholdsuppression
and reuse limits, and timeout values.

You can specify a value for the threshold
to suppress newmulticast forwarding
cache entries and an optional reuse
value for the threshold at which the
device begins to create newmulticast
forwardingcacheentries. If youconfigure
both reuse and suppression values,
configure a reuse value that is less than
the suppression value. The suppression
value ismandatory. If you do not specify
the optional reuse value, then the
number of multicast forwarding cache
entries is limited to the suppression
value. A new entry is created as soon as
the number of multicast forwarding
cacheentries fallsbelowthesuppression
value. You can also specify a timeout
value for all multicast forwarding cache
entries.

Forwarding Cache
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Table 49: ConfiguringMulticast Fields (continued)

Your ActionFunctionOption

1. Expand theMulticast tree and select
Interface.

2. Configure the interface and the
bandwidth.

Enables you to configure the interfaces
for multicast properties on which you
plan to manage themaximum
bandwidth.

Interface

1. Expand theMulticast tree and select
Rpf Check Policy.

2. Click the New button or select a
policy and click the Edit button.

3. Enter the RPF check policy name.

Multicast reversepath forwarding (RPF)
checks are used to prevent multicast
routing loops. Routing loops are
particularly debilitating in multicast
applications because packets are
replicated with each pass around the
routing loop.

You can apply policies for disabling
reverse-path forwarding (RPF) checks
on arriving multicast packets.

Rpf Check Policy

1. Expand theMulticast tree and select
Scope.

2. Configure thescopeandthe interface
for the multicast.

Enables you to configure multicast
scoping to limit multicast traffic by
configuring it to an administratively
defined topological region. Multicast
scoping controls the propagation of
multicast messages—bothmulticast
group joins upstream toward a source
and data forwarding downstream.
Scoping can relieve stress on scarce
resources, such as bandwidth, and
improve privacy or scaling properties.

Scope

1. Expand theMulticast tree and select
Scope Policy.

2. Specify the scope policy for the
multicast group.

Enables you to configure multicast
scoping policy. A multicast scope policy
contains a set of device interfaces on
which you are configuring scoping and
the scope's address range configured as
a series of device filters.

Scope Policy

1. Expand theMulticast tree and select
SsmGroups.

2. Click the New button or select a
group and click the Edit button.

3. Specify theaddress rangeof theSSM
group.

Enables you toconfigure source- specific
multicast (SSM)groups.SSM isaservice
model that identifies session traffic by
both source and group address. Using
SSM, a client can receive multicast
traffic directly from the source. To
deploy SSM successfully, you need an
end-to-endmulticast-enabled network
and applications that use an Internet
Group Management Protocol version 3
(IGMPv3).

Ssm Groups
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Table 49: ConfiguringMulticast Fields (continued)

Your ActionFunctionOption

1. Expand theMulticast tree and select
SsmMap.

2. Click the New button or select an
SSMmap and click the Edit button.

3. Specify the SSM policy for the SSM
map and the source address.

SSMmapping translate IGMPv1 or
IGMPv2membership reports to an
IGMPv3 report allowing you to support
an SSM network without requiring all
hosts to support IGMPv3.

SsmMap

1. Expand theMulticast tree and select
the Traceoptions tab.

2. Set up the file and flag parameters.

Defines tracing options for themulticast
group. You can also set up the file
management and access control
parameters .

Traceoptions

ConfiguringMultipath (NSMProcedure)

You can configure protocol-independent load balancing for Layer 3 virtual private

networks (VPNs) with load sharing amongmultiple external BGP paths andmultiple

internal BGP paths. You can use forwarding next hops for both the active route and

alternative paths for load balancing.

To configure multipath load balancing in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. SelectMultipath.

6. Enter the parameters as specified in Table 50 on page 87.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.
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Table 50: ConfiguringMultipath Fields

Your ActionFunctionOption

Enter the comment.Specifies thecomment for themultipath
configuration.

Comment

1. Expand theMultipath treeand select
Vpn Unequal Cost.

2. Enter the comment for the vpn
unequal cost configuration and
specify whether both external and
internal BGP paths should be
selected for the multipath
configuration by selecting the Equal
External Internal check box.

Applies protocol-independent load
balancing to VPN routes.

Vpn Unequal Cost

Configuring Options (NSMProcedure)

Youcanconfigure the typesof system loggingmessages sentabout the routingprotocols

process to thesystem logmessage file. Thesemessagesarealsodisplayedon thesystem

console. You can log messages at a particular level or up to and including a particular

level.

To configure options in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. SelectOptions.

6. Enter the parameters as specified in Table 51 on page 88.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.
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Table 51: Configuring Options Fields

Your ActionFunctionOption

Enter the comment.Specifies the comment for themessage
option.

Comment

Enter the mark value or select from the
list.

Specifies the mark for the option.Mark

1. Expand theOptions tree and select
Syslog.

2. Select the severity levels for system
logmessages.

Enables you to configure the generation
of system logmessages for a particular
severity level and all higher levels.

Syslog

Configuring Route Resolution (NSMProcedure)

You can configure a routing table to accept routes from specific routing tables to enable

the device to manage and route the traffic effectively between a source host and

destination host. You can configure a routing table to use specific import policies to

produce a route resolution table to resolve routes.

To configure a route resolution table in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Resolution.

6. Add or modify the parameters as specified in Table 52 on page 89.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.
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Table 52: Route Resolution Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the route
resolution.

Comment

1. Expand the Resolution tree and
select Rib.

2. Click the New button or select a
routing table and click the Edit
button.

3. Enter thenameandcomment for the
routing table and specify the route
import policies and the resolution
routes.

Specifies the name of the routing table
for which the import policies and the
resolution routes are configured.

Rib

1. Expand the Resolution tree and
select Tracefilter.

2. Specify the filter policies for the
routing table.

Specifies the filter policy for the
resolution routes.

Tracefilter

1. Expand the Resolution tree and
select Traceoptions.

2. Expand theTraceoptions treeandset
up the file and flag parameters.

Defines tracing options for route
resolution.

Traceoptions

Configuring Routing Table Groups (NSMProcedure)

You can group together one or more routing tables to form a routing table (RIB) group.

Within agroup, a routingprotocol can import routes intoall the routing tables in thegroup

and can export routes from a single routing table. Each routing table group contains one

or more routing tables that the Junos OS uses when importing routes. In the same way,

each routing table group optionally contains one routing table that the Junos OS uses

when exporting routes to the routing protocols. You can also specify the import and the

export route tables and the import policies for the routing table group.

To configure routing table groups in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Rib Groups.

6. Add or modify the parameters as specified in Table 53 on page 90.

7. Click one:

• OK—To save the changes.
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• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 53: Rib Group Fields

Your ActionFunctionOption

1. Expand theRoutingOptions tree and
select Rib Group.

2. Click the New button or select a
routing table groupand click theEdit
button.

3. Enter the name for the routing table
group.

Specifies theuniquenamefor the routing
table group.

Name

1. Expand theRoutingOptions tree and
select Rib Group.

2. Click the New button or select a
routing table groupand click theEdit
button.

3. Enter the comment for the routing
table group.

Specifies the comment for the routing
table group.

Comment

1. Expand theRoutingOptions tree and
select Rib Group.

2. Click the New button or select a
routing table groupand click theEdit
button.

3. Enter the name of the routing table.

Specifies the routing table fromwhich
the Junos OS exports routing
information.

Export Rib

1. Expand the rib-group tree and select
Import Policy.

2. Set up the import policies for the
routing table group.

Enables you to apply one or more
policies to routes imported into the
routing table group.

Import Policy
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Table 53: Rib Group Fields (continued)

Your ActionFunctionOption

1. Expand the rib-group tree and select
Import Policy.

2. Enter the name of the routing table.

Specifies the name of the routing table
into which the Junos OS is to import
routing information. The first routing
table name you enter is the primary
routing table. Any additional names you
enter identify secondary routing tables.
When a protocol imports routes, it
imports them into the primary and any
secondary routing tables.

Import Rib

Configuring Routing Tables (NSMProcedure)

This feature enables you to configure routing tables. You can also configure the static,

martians, aggregate,maximumpaths,maximumprefixes,multipath, or generated routes

to the routing table. If you are not adding any of those routes, then the creation of the

routing table is optional. The Junos OS uses its default routing tables, which are inet.0

for IPv4 unicast routes, inet6.0 for IPv6 unicast routes, inet.1 for the IPv4multicast

forwarding cache, and inet.3 for IPv4 MPLS.

To configure a routing table in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Rib.

6. Add or modify the parameters as specified in Table 54 on page 92.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.
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Table 54: Rib Fields

Your ActionFunctionOption

1. Expand theRoutingOptions tree and
select Rib.

2. Click the New button or select a
routing table and click the Edit
button.

3. Enter the name for the routing table.

Specifies theuniquenamefor the routing
table.

Name

1. Expand theRoutingOptions tree and
select Rib.

2. Click the New button or select a
routing table and click the Edit
button.

3. Enter the comment for the routing
table.

Specifies the comment for the route
resolution.

Comment

1. Expand the Rib tree and select
Aggregate.

2. Select the global aggregate route
options in Defaults and individual
aggregate route options in Route.

Enables you to configure the aggregate
routes for the routing table. Aggregation
allows you to combine groups of routes
with common addresses into a single
entry in the routing table. This decreases
the size of the routing table as well as
thenumberof routeadvertisementssent
by the router.

Aggregate

1. Expand the Rib tree and select
Generate.

2. Select the default route to the
destination address in Defaults and
individually generated route options
in Route.

Enables you to configure generated
routes, which are used as routes of last
resort in the routing table.

Generate

1. Expand the Rib tree and select
Martian.

2. Enter the martian addresses.

Enables you to configure martian
addresses in the routing table.

Martians

1. Expand the Rib tree and select
MaximumPaths.

2. Enter theMaximumPaths and the
Threshold.

Enables you to configure a limit for the
number of routes installed in a routing
table.

Maximum Paths

1. Expand the Rib tree and select
MaximumPrefixes.

2. Setup theMaximumPrefixesand the
Threshold.

Enables you to configure a limit for the
number of routes installed in a routing
table.

Maximum Prefixes
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Table 54: Rib Fields (continued)

Your ActionFunctionOption

1. Expand the Rib tree and select
Multipath.

2. Enter the multipath options.

Enables you to configure the multipath
option in the routing table for load
sharing between external BGP and
internal BGP.

Multipath

1. Expand theRib treeandselectStatic.

2. Enter the global static route in
Defaults and destination address of
the static route in Route.

Enables you to configure static routes to
be installed in the routing table.

Static

Configuring Source Routing (NSMProcedure)

You can configure source routing to specify IP addresses of the devices along the path,

that you want an IP packet to take on its way to its destination.

To configure source routing in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Source Routing.

6. Enter the parameters as specified in Table 55 on page 93.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 55: Source Routing Fields

Your ActionFunctionOption

Enter the comment.Specifies the comment for the source
routing configuration.

Comment
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Table 55: Source Routing Fields (continued)

Your ActionFunctionOption

Select the check box.Specifies the IPv4/IPv6 addressing
family for source routing.

IP

Configuring Static Routes (NSMProcedure)

You can configure static routes for a routing table group. A router uses static routes in

the following scenarios:

• When it does not have a route to a destination that has a better (lower) preference

value.

• When it cannot determine the route to a destination.

• When it is forwarding unroutable packets.

A static route is installed in the routing table only when the route is active; that is, the list

of next-hop routers configured for that route contains at least one next hop on an

operational interface.

To configure static routes for a routing table group in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Static.

6. Add or modify the parameters as specified in Table 56 on page 95.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.
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Table 56: Static Fields

Your ActionFunctionOption

Enter the comment.Specifies the comment for the static
route.

Comment

Enter the name.Specifies the routing table group name
for which the static route is configured.

Rib Group

1. Expand the Static tree and select
Defaults.

2. Enter the default route to the
destination address.

Enables you to configure the global
static route options. These options only
set the global defaults and apply to all
the configured static routes.

Defaults

1. Expand the Static tree and select
Route.

2. Enter the individual route.

Enables you to configure the individual
static routes options. These options
apply to the individual destination only
and override any options configured in
the Defaults section.

Route

Configuring Generated Routes (NSMProcedure)

Generated routes are used as routes of last resort. A packet is forwarded to the route of

last resort when the routing tables have no information about how to reach that packet’s

destination. One use of route generation is to create a default route to use if the routing

table containsa route fromapeer onaneighboringbackbonenetwork. Agenerated route

becomes active when it has one or more contributing routes. A contributing route is an

active route that is a specific match for the generated destination.

For example, for the destination 128.100.0.0/16, routes to 128.100.192.0/19 and

128.100.67.0/24 are contributing routes, but routes to 128.0.0.0./8, 128.0.0.0/16, and

128.100.0.0/16 are not. A route can contribute only to a single generated route. However,

anactivegenerated routecan recursively contribute toa less specificmatchinggenerated

route. For example, a generated route to the destination 128.100.0.0/16 can contribute

to a generated route to 128.96.0.0/13. By default, when generated routes are installed in

the routing table, the next hop device selects from the primary contributing route.

To configure generated routes in NSM:

1. In the navigation tree, select DeviceManager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Generate.

6. Add or modify the parameters as specified in Table 57 on page 96.

7. Click one:
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• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 57: Generated Routes Fields

Your ActionFunctionOption

Enter a comment.Specifies thecomment for thegenerated
route.

Comment

1. Expand the Generate tree and select
Defaults.

2. Configure the default route options.

Enables you to specify globally
generated route options. These are
treated as global defaults and apply to
all the generated routes you configure.

Defaults

1. Expand the Generate tree and select
Route.

2. Configure the individual route
options.

Enables you to configure individually
generated routes. Youcanalsoconfigure
globally generated route options. These
options apply to the individual
destinationonlyandoverrideanyoptions
you configured in Defaults.

Route

Configuring Graceful Restart (NSMProcedure)

Graceful restart allows a device undergoing a restart to inform its adjacent neighbors

andpeers of its condition. The restartingdevice requests agraceperiod fromtheneighbor

or peer, which can then cooperate with the restarting device. With a graceful restart, the

restarting device can still forward traffic during the restart period, and convergence in

the network is not disrupted. The restart is not visible to the rest of the network, and the

restarting device is not removed from the network topology.

The graceful restart request occurs only if the following conditions are met:

• The network topology is stable.

• The neighbor or peer cooperates.

• The restartingdevice is notalreadycooperatingwithanother restart already inprogress.

• The grace period does not expire.

To configure graceful restart in NSM:
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1. In the navigation tree, select DeviceManager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Graceful Restart.

6. Enter the parameters as specified in Table 58 on page 97.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 58: Graceful Restart Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the graceful
restart.

Comment

• Select the check box to disable
graceful restart.

• Clear thecheckbox toenablegraceful
restart.

Specifies whether graceful restart is
enabled for the device.

Disable

Enter a value for the duration or select a
value from the list.

Specifies thedurationof thegraceperiod
for the device to restart.

Restart Duration

Configuring Forwarding Table (NSMProcedure)

A forwarding table contains the routes actually used to forward packets through the

device to their next-hop destination. This feature enables you to configure forwarding

table in NSM.

To configure forwarding table in NSM:

1. In the navigation tree, select DeviceManager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.
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4. In the configuration tree, expand Routing Options.

5. Select Forwarding Table.

6. Add or modify the parameters as specified in Table 59 on page 98.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 59: Forwarding Table Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the
forwarding table.

Comment

Select the option button.Specifies that no next- hop parameter
is to be added to the forwarding table.

None

Select the option button to enable
indirect-next- hop.

Specifies that the forwarding table
supports indirectly connectednexthops.

indirect-next-hop

Select the option button to enable
no-indirect-next- hop.

Specifies that the forwarding table does
not support indirectly connected next
hops.

no-indirect-next-hop

Select thepath from thedrop-down list.Enables you to check path validity to
protect the network from IP spoofing. A
unicast reverse-path-forwarding (RPF)
check performs a routing table lookup
on an IP packet’s source address and
checks the incoming interface. The
device determines whether the packet
is arriving from a path that the sender
woulduse to reach thedestination. If the
packet is from a valid path, the device
forwards the packet to the destination
address. If it is not from a valid path, the
device discards the packet.

Unicast Reverse Path

1. Expand the Forwarding Table tree
and select Export.

2. Enter the export policies.

Enables you to apply one or more
policies to routes being exported from
the routing table into the forwarding
table.

Export
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Configuring Flow Route (NSMProcedure)

Flow routes provide traffic filtering and rate-limiting capabilitiesmuch like firewall filters.

You can propagate flow routes across different autonomous systems. A flow route is an

aggregation of match conditions for IP packets. Flow routes are propagated through the

network using flow-specific network-layer reachability information (NLRI) messages

and aremaintained in the flow routing table. Packets can travel through flow routes only

if specific match conditions are met. Flow routes and firewall filters are similar in that

they filter packets based on packet components and perform an action on the packets

that match.

To configure a flow route in NSM:

1. In the navigation tree, select DeviceManager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Flow.

6. Add or modify the parameters as specified in Table 60 on page 99.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 60: Flow Route Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the flow
route.

Comment

Route
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Table 60: Flow Route Fields (continued)

Your ActionFunctionOption

1. Expand the Flow tree and select
Route.

2. Click theNewbutton or select a flow
route and click the Edit button.

3. Enter the flow route name.

Specifies the name of the flow route.Name

1. Expand the Flow tree and select
Route.

2. Click theNewbutton or select a flow
route and click the Edit button.

3. Enter the comment for the flow
route.

Specifies the comment for the flow
route.

Comment

1. Expand the Route tree and select
Match.

2. Enter a comment for Comment, a
destination address for Destination,
and a source address for Source.

3. Configure the match conditions.

Specifies the conditions that the packet
must match for the packet to be
included in flow route. Match conditions
are:

• Destination Port

• DSCP

• Fragment

• Icmp Code

• Icmp Type

• Packet Length

• Port

• Protocol

• Source Port

• Tcp Flag

Match

1. Expand the Route tree and select
Then.

2. Configure the then conditions for the
packet.

Enables you to specify theaction to take
if thepacketmatches theconditions you
have configured in the flow route.

Then

Validation

1. Expand the Flow tree and select
Validation.

2. Enter thecomment for the validation
procedure.

Specifies a comment for the validation
procedure. Flow routes are installed into
the flow routing table only if they have
been validated using the validation
procedure.

Comment

1. Expand theValidation treeandselect
Traceoptions.

2. Expand the Traceoptions tree and
configure the file and flag
parameters, and the tracing policy.

Enables you todefine tracingoperations
that track all routing protocol
functionality in the device and specify
that tracing results be saved in a log file.
You can configure the tracing flag, filter,
and the tracing policy.

Traceoptions
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Configuring Fate Sharing (NSMProcedure)

Fate sharingallows you to createadatabaseof information that the constrained shortest

path first (CSPF) algorithm uses to compute one or more backup routing paths to use

in case the primary path becomes unstable. The database describes the relationships

between elements of the network. Through fate sharing, you can configure backup paths

that minimize the number of shared links and fiber optic cables, to ensure that in the

event of damage to a fiber optic cable, only theminimumamount of data is lost and that

a path still exists to the destination. For a backup path to work optimally, it must not

share links or physical fiber optic cables with the primary path. This ensures that a single

point of failure will not affect the primary and backup paths at the same time.

This feature enables you to specify groups of objects that share characteristics resulting

in backup paths to be used if primary paths fail. All objects are treated as /32 host

addresses. You can specify one or more objects within a group. The objects can be LAN

interfaces, device IDs, or point-to-point links.

To configure fate sharing in NSM:

1. In the navigation tree, select DeviceManager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Fate Sharing.

6. Add or modify the parameters as specified in Table 61 on page 101.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 61: Fate Sharing Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the fate
sharing.

Comment

Group
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Table 61: Fate Sharing Fields (continued)

Your ActionFunctionOption

1. Expand the Fate Sharing tree and
select Group.

2. Click the New button or select a
group and click the Edit button.

3. Enter the group name.

Specifies the name of the fate sharing
group.

Name

1. Expand the Fate Sharing tree and
select Group.

2. Click the New button or select a
group and click the Edit button.

3. Enter the comment.

Specifies the comment for the fate
sharing group.

Comment

1. Expand the Fate Sharing tree and
select Group.

2. Click the New button or select a
group and click the Edit button.

3. Enter the cost or select a value from
the list.

Specifies the configurable cost
attributed to each group, which
represents the level of impact this group
has on CSPF computations. The higher
the cost, the less likely a backup path
will share any objects in the group with
the primary path.

Cost

1. Expand the Group tree and select
From.

2. Click the New button or select a
group and click the Edit button.

3. Specify the From address.

Specifies the from address and to
address for point-to-point link objects.

From

ConfiguringMartian Addresses (NSMProcedure)

Martian addresses are host or network addresses about which all routing information is

ignored. They commonly are sent by improperly configured systems on the network and

have destination addresses that are obviously invalid. You can configure a particular

martian address or a range of martian addresses as allowed or disallowed. You can use

thematch criteria to configure a range of martian addresses.

To configure a martian address in NSM:

1. In the navigation tree, select DeviceManager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. SelectMartians.

6. Add or modify the parameters as specified in Table 62 on page 103.

7. Click one:
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• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 62: ConfiguringMartian Address Fields

Your ActionFunctionOption

1. Click the New button or select a
martian address and click the Edit
button.

2. Enter the address.

Specifies the martian address or the
destination prefix of a series of martian
addresses that are to be allowed or
disallowed.

Address

1. Click the New button or select a
martian address and click the Edit
button.

2. Enter the comment for the martian
address.

Specifies the comment for the martian
address.

Comment

1. Click the New button or select a
martian address and click the Edit
button.

2. Select the check box to allow the
disallowed address. Selecting the
allow option deletes a particular
martian address from the range of
martian addresses.

3. Clear the check box to disallow the
addresses andmark them as a
martian address.

Enables you to explicitly allow a subset
of a range of addresses that are to be
disallowed.

Allow

1. Click the New button or select a
martian address and click the Edit
button.

2. Expand theMartian tree and select
Exact.

3. Enter the match criteria.

Specifies match criteria for the route’s
mask length with the martian address.
The criteria are:

• Exact

• Longer

• Orlonger

• Upto

• Through

• Prefix Length Range

Exact
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Configuring Interface Routes (NSMProcedure)

You can associate a routing table group with the device’s interfaces and specify routing

tables into which interface routes are imported. To define the routing tables into which

interface routes are imported, you create a routing table group and associate it with the

device’s interfaces.

To configure interface routes in NSM:

1. In the navigation tree, select DeviceManager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Interface Routes.

6. Add or modify the parameters as specified in Table 63 on page 104.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 63: Interface Routes Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the interface
route.

Comment

1. Expand the InterfaceRoutes treeand
select Family.

2. Click the New button or select a
family name and click the Edit
button.

3. Enter the familynameandcomment.

4. Set up the export policy and import
policy.

Specifies the address family as IPv4 or
IPv6.

Family
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Table 63: Interface Routes Fields (continued)

Your ActionFunctionOption

1. Expand the InterfaceRoutes treeand
select Rib Group.

2. Enter the comment and Inet.

Specifies the routing table groups to
which interface routes are imported.

Rib Group

Configuring Instance Export (NSMProcedure)

Current configurations that use routing table groups define a policy to select routes in

an IGP export policy. However, no policy controls the export process itself. You can

configure the instance export policy to control the export process. The policy model

supports both interinstance route export and IGP export.

To configure an instance export policy in NSM:

1. In the navigation tree, select DeviceManager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Routing Options.

5. Select Instance Export and specify the export policies for routes being exported from

a routing instance.

6. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Configuring Instance Import (NSMProcedure)

You can apply one or more policies to routes being imported into a routing instance.

To configure instance import in NSM:

1. In the navigation tree, select DeviceManager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.
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4. In the configuration tree, expand Routing Options.

5. Select Instance Import and specify the import policies to be applied to the routes that

are imported to a routing instance.

6. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the routing option settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.
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CHAPTER 12

Configuring Protocols for J Series Services
Routers and SRX Series Services
Gateways

• Configuring BGP (NSM Procedure) on page 107

• Configuring 802.1X Authentication (NSM Procedure) on page 110

• Configuring GVRP (NSM Procedure) on page 112

• Configuring IGMP (NSM Procedure) on page 113

• Configuring MPLS (NSM Procedure) on page 115

• Configuring MSDP (NSM Procedure) on page 144

• Configuring MSTP (NSM Procedure) on page 154

• Configuring OSPF (NSM Procedure) on page 156

• Configuring RIP (NSM Procedure) on page 160

• Configuring RIPng (NSM Procedure) on page 162

• Configuring Router Advertisement (NSM Procedure) on page 168

• Configuring Router Discovery (NSM Procedure) on page 171

• Configuring VSTP (NSM Procedure) on page 173

• Configuring VRRP (NSM Procedure) on page 175

Configuring BGP (NSMProcedure)

Border Gateway Protocol (BGP) is used for exchanging routing information between

gateway hosts/internet service providers. The routing information refers to the routing

tables containing information about the list of known devices, the addresses they can

reach, andacostmetric associatedwith thepath toeachdevice so that thebest available

route is chosen. The primary function of a BGP speaking system is to exchange network

reachability information with other BGP systems. This feature enables you to configure

BGP peering sessions.

To configure BGP in NSM:
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1. In the navigation tree select DeviceManager > Devices and select the device from the

list.

2. In the configuration tree, expand Protocols.

3. Select BGP.

4. Add/Modify the parameters under the respective tabs as specified in Table 64 on

page 108.

5. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply — To apply the protocol settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See Updating
Devices for more information.

Table 64: BGP Configuration Fields

Your ActionFunctionField

1. Expand the Protocol tree.

2. Select BGP and select General tab.

3. Specify the general parameters like
comment, description, local address,
hold time, etc.

The general parameters to be set up for
applying BGP.

General

1. Expand the Protocol tree.

2. SelectBGPand selectPathSelection
tab.

3. Setup thepathselectionparameters
andmed plus IGP.

Enables you tospecify thepathselection
criteria.

Path Selection

1. Expand the Protocol tree.

2. Select BGP and select Traceoptions
tab.

3. Set up the file and flag parameters.

Defines trace options for IGMP
monitoring.

Traceoptions

1. Expand the Protocol tree.

2. SelectBGPandselectMetricOut tab.

3. Setupthemetricvalueandminimum
IGP.

Enables you to specify the metric value
to add to the routes transmitted to the
neighbor.

Metric Out
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Table 64: BGP Configuration Fields (continued)

Your ActionFunctionField

1. Expand the Protocol tree.

2. Select BGP and selectMultihop tab.

3. Set up the comment, Ttl and specify
whether the next hop has to be
changed.

If an EBGP peer is more than one hop
away from the local router, you must
specify the next hop to the peer so that
the two systems can establish a BGP
session. This type of session is called a
multihop BGP session.

Multihop

1. Expand the Protocol tree.

2. Select BGP and select Advertise tab.

3. Specify whether Advertise has to be
inactivated and set up the Advertise
Peer As.

Enables you to specify whether BGP
should advertise the best route even if
the routing table did not select it to be
an active route.

Advertise

1. Expand the Protocol tree.

2. Select BGP and select Import tab.

3. Specify theexportpoliciesconfigured
on the peer.

Enables you toapplyoneormore routing
policies to routes being imported into
the Junos OS routing table from BGP .

Import

1. Expand the Protocol tree.

2. Select BGP and select Family tab.

3. Specify the Family and Inet
parameters.

4. Expand the Inet tree and set up the
parameters.

Enables you to configureprotocol family
information for the logical interface.

Family

1. Expand the Protocol tree.

2. SelectBGPandselectAuthentication
Settings tab.

3. Specify the authentication key,
algorithm and key chain.

Enables you to specify the
authentication settings for BGP.

Authentication Settings

1. Expand the Protocol tree.

2. Select BGP and select Export tab.

3. Specify theexportpoliciesconfigured
on the peer.

Enables you toapplyoneormore routing
policies to routes being exported from
the Junos OS routing table from BGP .

Export

1. Expand the Protocol tree.

2. Select BGP and select Local As tab.

3. Enter the comment, as number, loop
and specify whether it is private.

Enables you to configure BGPwith a
different local autonomoussession (AS)
number for each BGP session

Local As
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Table 64: BGP Configuration Fields (continued)

Your ActionFunctionField

1. Expand the Protocol tree.

2. Select BGP and select Graceful
Restart tab.

3. Specify the graceful restart
parameters.

Enables you to specify the graceful
restart parameters.

Graceful Restart

1. Expand the Protocol tree.

2. Select BGP and select Bfd Liveness
Detection tab.

3. Specify the Bfd Liveness Detection
parameters, Detection Time and
Transmit Interval.

Enables you to configure bidirectional
forwarding detection (BFD) timers.

Bfd Liveness Detection

1. Expand the Protocol tree.

2. Select BGP and select Group tab.

3. Click the New button or select a
group and click Edit button.

4. Enter all the group parameters.

Enables you to configure BGP group.Group

Configuring 802.1X Authentication (NSMProcedure)

IEEE 802.1X authentication provides network edge security, protecting Ethernet LANs

from denial-of-service (DoS) attacks and preventing unauthorized user access.

802.1X works by using an Authenticator Port Access Entity (the device) to block all traffic

to and from a supplicant (client) at the interface until the supplicant's credentials are

presented andmatched on the Authentication server (a RADIUS server). When

authenticated, the switch stops blocking and opens the interface to the supplicant.

To configure 802.1X authentication:

• Specify 802.1X interface settings on the switch.

• Specify the 802.1X exclusion list, used to specify which supplicants can bypass 802.1X

authentication and be automatically connected to the LAN.

1. Configuring 802.1X Interface Settings on page 111

2. Configuring Static MAC Bypass on page 112
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Configuring 802.1X Interface Settings

To configure 802.1X interface settings:

1. In the navigation tree, select Device Manager > Devices. In Device Manager, select the

device for which you want to configure 802.1X settings.

2. In the Configuration tree, expand Protocols > Dot1x.

4. Select Authenticator > Interface.

5. Click the Add icon.

6. Add/modify member settings for the interface as specified in Table 65 on page 111.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See Updating
Devices for more information.

Table 65: 802/1X Authentication for an Interface

Your ActionFunctionOption

Enter the nameSpecifies the name for the profile.Authentication Profile
Name

Select Interface.

Click the Add icon.

Specifies the interface for which 802.1X authentication is
being configured.

Interface

Enter the interface name.Specifies the interface name.Name

Select to disable authentication.Disables 802.1X authentication on the interface.Disable

Select the required mode.Specifies the mode to be adopted for supplicants:

• Single — allows only one host for authentication.

• Multiple—allowsmultiple hosts for authentication. Each
host is checked before being admitted to the network.

• Singleauthentication formultiplehosts—Allowsmultiple
hosts but only the first is authenticated.

Supplicant

Select a value from the list.Maximum number of retriesRetries

Select a value from the list.Specifies the port waiting time after an authentication
failure.

Quiet Period

Select a value from the list.Specifies the retransmit interval.Transmit Period

Select a value from the list.Port timeout value for the response from the supplicant.Supplicant Timeout
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Table 65: 802/1X Authentication for an Interface (continued)

Your ActionFunctionOption

Select a value from the list.Port timeout value for the response from theRADIUSserverServer Timeout

Select a value from the list.Specifies themaximumnumber of authentication requests
to bemade to the server.

Maximum Requests

Enter the VLAN name.Specifies the guest VLAN tomove the interface to in case
of an authentication failure.

Guest Vlan

Select Reauthentication.

Select one:

• none

• reauthentication

• no-reauthentication

Specifies enabling reauthentication on the selected
interface.

Reauthentication

Configuring Static MAC Bypass

Configure any MAC addresses, supplicants, or interfaces to be excluded from 802.1X

authentication—that is, they will be authenticated.

To configure the 802.1X exclusion:

1. Specify a MAC address to be excluded from 802.1X authentication in the field Name.

2. Specify the interface for the supplicant to bypass authentication if connected through

that interface.

3. Specify the VLAN tomove the supplicant to once it is authenticated.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See Updating
Devices for more information.

Configuring GVRP (NSMProcedure)

As a network expands and the number of clients and VLANs increases, VLAN

administrationbecomescomplex,and the taskofefficientlyconfiguringVLANsonmultiple

switches becomes increasingly difficult. To automate VLAN administration, you can

enable GARP VLAN Registration Protocol (GVRP) on the network.

GVRP learns VLANs on a particular 802.1Q trunk port, and adds the corresponding trunk

port to theVLAN if theadvertisedVLAN ispreconfiguredor existingalreadyon the switch.

For example, a VLAN named “sales” is advertised to trunk port 1 on the GVRP-enabled

device. The device adds trunk port 1 to the sales VLAN if the sales VLAN already exists

on the switch.
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As individual ports become active and send a request to join a VLAN, the VLAN

configuration is updated and propagated among the switches. Limiting the VLAN

configuration to active participants reduces the network overhead. GVRP also provides

the benefit of pruning VLANs to limit the scope of broadcast, unknown unicast, and

multicast (BUM) traffic to interested devices only.

To configure GVRP:

1. In the navigation tree, select DeviceManager > Devices. In Device Manager, select the

device.

2. In the configuration tree, expand Protocols.

3. Select GVRP.

4. Click the Add icon.

5. Add/modify GVRP settings for the interface as specified in Table 66 on page 113.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See Updating
Devices for more information.

Table 66: GVRP Configuration Fields

Your ActionFunctionOption

Click to select.Select this option to disable GVRP on the interface.Disable

Select a value.Specifies themaximumnumberofmilliseconds the interfaceswait before
sending VLAN advertisements.

Join Timer

Select a value.Specifies thenumberofmillisecondsan interfacemustwait after receiving
a leavemessage to remove the interface from the VLAN specified in the
message.

Leave Times

Select a value.Specifies the interval at which Leave All messages are sent on interfaces.
Leave All messages help to maintain current GVRP VLANmembership
information in the network.

Leaveall Times

Configuring IGMP (NSMProcedure)

Internet GroupManagement Protocol (IGMP) is an Internet protocol that provides away

for an IP host to report its multicast groupmembership to adjacent devices. This feature

enables you to associate the IGMPwith an interface and allocate it to amulticast group.

To configure IGMP in NSM:

1. In the navigation tree select DeviceManager > Devices .

2. In the Devices list, double click the device to select it.
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3. Click the Configuration tab.

4. In the configuration tree, expand Protocols and select IGMP.

5. Add/Modify the parameters as specified in Table 67 on page 114.

6. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply — To apply the protocol settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See Updating
Devices for more information.

Table 67: IGMP Configuration Fields

Your ActionFunctionOption

IGMP

Enter a comment.Specifies the comment for IGMP.Comment

Select the query interval.Defines how often the device sends
general host-query messages. .

Query Interval

Enter the query response interval.Defines how long the query
router/switchwaits to receivea response
to a host-query message from a host.

Query Response Interval

Enter the query last member interval.Defines how often the device sends
group-specific query messages.

Query Last Member Interval

Select the robust count.Defines the number of intervals the
devicewaitsbefore removingamulticast
group from themulticast forwarding
table.

Robust Count

Select to enable accounting.Specifieswhether accounting is enabled
for IGMP.

Accounting
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Table 67: IGMP Configuration Fields (continued)

Your ActionFunctionOption

1. Expand the IGMP tree and select
Interfaces.

2. Click the New button or select an
interface and click Edit button.

3. SelectDisable todisable IGMPon the
interface.

4. Select the version.

5. Specify the SsmMap.

6. Youcanenable ImmediateLeaveand
PromiscuousMode.

7. You can enable accounting on the
interface.

8. Select the option Interface > Static
to configure the multicast group to
be associated with the interface.

Specifies the interfaceand themulticast
group that has to be associated with
IGMP.

Interfaces

1. Expand IGMP tree and select
Traceoptions.

2. Enter a comment for traceoptions.

3. Expand the Traceoptions tree, select
File and set up the file parameters.

4. In the Traceoptions tree select Flag
andsetupor edit the fileparameters.

Defines trace options for IGMP .Traceoptions

ConfiguringMPLS (NSMProcedure)

• Configuring MPLS (NSM Procedure) on page 116

• Configuring Auto Policing (NSM Procedure) on page 118

• Configuring Bandwidth (NSM Procedure) on page 119

• Configuring Differentiated Services Traffic Engineering (NSM Procedure) on page 119

• Configuring Interfaces (NSM Procedure) on page 120

• Configuring Label Switched Path (NSM Procedure) on page 122

• Configuring Log Updown (NSM Procedure) on page 133

• Configuring OAM (NSM Procedure) on page 134

• Configuring Path (NSM Procedure) on page 137

• Configuring Path MTU (NSM Procedure) on page 138

• Configuring Static Label Switched Path (NSM Procedure) on page 139

• Configuring Statistics (NSM Procedure) on page 142

• Configuring Traceoptions (NSM Procedure) on page 143
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ConfiguringMPLS (NSMProcedure)

You can configure an MPLS protocol.

To configure MPLS:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure MPLS.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls.

4. Click + to configure MPLS options as described in Table 68 on page 116.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the MPLS parameters.

Table 68: MPLS Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the MPLS protocol.Comment

Select the check box to enable this
feature.

Specifies that MPLS can be disabled.Disable

Select an option from the list.Specifies the protocols to perform traffic engineering.Traffic Engineering

Set the advertisement hold time.

Range: 0 through 65535.

Specifies the time that an LSP downmessage will be
delayed.

Advertisement Hold
Time

Set the RSVP path error hold time.

Range: 0 through 240.

Specifies the time that the Resource Reservation Protocol
(RSVP) path error will be remembered.

Rsvp Error Hold Time

Select the check box to enable this
feature.

Specifies that anaggressive optimizationalgorithmcanbe
run based on the Interior Gateway Protocol (IGP) metric
only.

Optimize Aggressive

Set the smart optimize timer value.

Range: 0 through 65535.

Specifies the path optimization interval link forwhen a link
traversed by the path goes down.

NOTE: Whena link fails and traffic ismoved toanalternate
path, thesmartoptimize timerwaits for thespecifiedperiod
of time and then switches the traffic back to the original
path (if that path is back up). If the original path fails again,
the traffic is shifted to an alternate path and the smart
optimization timer is disabled for one hour.

SmartOptimizeTimer
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Table 68: MPLS Configuration Details (continued)

Your ActionFunctionOption

Select the check box to enable this
feature.

Specifies the time-to-live (TTL) propagation from IP to
MPLS (on push) and MPLS to IP (on pop).

No Propagate Ttl

Select the check box to enable this
feature.

Specifies that the EXPLICIT_NULL label can be advertised
when the device is the egress.

Explicit Null

Select the check box to enable this
feature.

Specifies that the MPLS label-switched-paths to be used
for tunneling IPv6 traffic are allowed.

Ipv6 Tunneling

Select the check box to enable this
feature.

Specifies that the MPLS label-switched-paths to be used
for tunneling Internet Control Message Protocol (ICMP)
error packets are allowed.

Icmp Tunneling

Set the revert time.

Range: 0 through 65535.

Specifies the range within which you can revert to the
primary path.

Revert Timer

Select the check box to enable this
feature.

Specifies useofConstraintShortestPathFirst (CSPF)path
computation to expand loose hops.

Expand Loose Hop

Set the class-of-service value.

Range: 0 through 7.

Specifies the class-of-service value.Class Of Service

Select the check box to enable this
feature.

Specifies that you cannot decrement the TTL within an
LSP.

No Decrement Ttl

Set the maximum number of device
hops.

Range: 2 through 255.

Specifies the maximum number of device hops allowed.Hop Limit

Select the check box to enable this
feature.

Specifies thatyoucandisableautomaticpathcomputation.No Cspf

Select the check box to enable this
feature.

Specifies that youcansetGeneralizedMulti-Protocol Label
Switching (GMPLS) label-switched-path to the
administratively down state.

Admin Down

Set the reoptimization time.

Range: 0 through 65535.

Specifies the periodical path reoptimization.Optimize Timer

Set the preference value.

Range: 0 through 4,294,967,295.

Specifies the preference value.Preference

Select the option.Specifieswhether an LSPshould actively record the routes
in the path or not.

record / no-record
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Table 68: MPLS Configuration Details (continued)

Your ActionFunctionOption

Select the check box to enable this
feature.

Specifies whether to keep backup paths in continuous
standbymode.

Standby

Related
Documentation

Configuring an Admin Group (NSM Procedure) on page 124•

• Configuring Auto Policing (NSM Procedure) on page 118

• Configuring Bandwidth (NSM Procedure) on page 119

Configuring Auto Policing (NSMProcedure)

You can enable the automatic policing of all the MPLS layered service providers on the

device or logical system.

To configure automatic policing:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure automatic policing.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Auto

Policing.

4. Enter a descriptive comment for the automatic policing in Comment.

5. In the configuration tree, select Protocols >Mpls > Auto Policing > Class.

6. Click + to configure automatic policing as described in Table 69 on page 118.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the automatic policing parameters.

Table 69: Auto Policing Configuration Details

Your ActionFunctionOption

Enter an automatic policing class name.Specifies the automatic policing class name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the automatic
policing class.

Comment

Select the option.Specifies all the packets to be dropped.drop

Select the option.Specifies that a packet has high loss priority.loss-priority-high

Select the option.Specifies that a packet has low loss priority.loss-priority-low
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Related
Documentation

Configuring Bandwidth (NSM Procedure) on page 119•

• Configuring Differentiated Services Traffic Engineering (NSM Procedure) on page 119

• Configuring an Admin Group (NSM Procedure) on page 124

Configuring Bandwidth (NSMProcedure)

You can set bandwidth constraints.

To configure bandwidth requirements:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure bandwidth requirements.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls >

Bandwidth.

4. Add or modify settings as described in Table 70 on page 119.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the bandwidth parameters.

Table 70: Bandwidth Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the bandwidth.Comment

Enter the bandwidth for reserving a traffic
class.

Specifies the bandwidth for reserving a traffic class.Per Traffic Class
Bandwidth

Enter a bandwidth.Specifies the bandwidth for traffic class 0.Ct0

Enter a bandwidth.Specifies the bandwidth for traffic class 1.Ct1

Enter a bandwidth.Specifies the bandwidth for traffic class 2.Ct2

Enter a bandwidth.Specifies the bandwidth for traffic class 3.Ct3

Related
Documentation

Configuring an Admin Group (NSM Procedure) on page 124•

• Configuring MPLS (NSM Procedure) on page 116

Configuring Differentiated Services Traffic Engineering (NSMProcedure)

You can configure Differentiated Services (DiffServ) traffic engineering.
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To configure differentiated services traffic engineering:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure differentiated services traffic engineering.

3. Click theConfiguration tab. In the configuration tree, selectProtocols>Mpls>Diffserv

Te.

4. Enter a descriptive comment for the differentiated services traffic engineering in

Comment.

5. Select the supported bandwidth constraint model in BandwidthModel.

6. In the configuration tree, select Protocols >Mpls > Diffserv Te > Te Class Matrix.

7. Enter a descriptive comment for the traffic engineering class matrix in Comment.

8. Add or modify the traffic engineering class matrix for a multiclass layered service

provider or a differentiated services-aware traffic engineering layered service provider

as described in Table 71 on page 120.

9. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the differentiated services traffic engineering parameters.

Table 71: Traffic Engineering Configuration Details

Your ActionFunctionOption

Te0 / Te1 / Te2 / Te3 / Te4 / Te4 / Te5 / Te6 / Te7

(Optional) Enter a comment.Supplies a descriptive comment for the traffic
engineering.

Comment

Select the traffic class from the list.Specifies the traffic class.Traffic Class

Set the preemption priority for the traffic class.

Range: 0 through 7.

Specifies thepreemptionpriority for the selected
traffic class.

Priority

Related
Documentation

Configuring Interfaces (NSM Procedure) on page 120•

• Configuring Bandwidth (NSM Procedure) on page 119

• Configuring Auto Policing (NSM Procedure) on page 118

Configuring Interfaces (NSMProcedure)

You can configure information about MPLS-enabled interfaces.
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To configure interfaces:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure interfaces.

3. Click theConfiguration tab. In theconfiguration tree, selectProtocols>Mpls> Interface.

4. Click + to configure an MPLS-enabled interface feature.

5. Add or modify settings as described in Table 72 on page 121.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the interface parameters.

Table 72: Interface Configuration Details

Your ActionFunctionOption

Enter a name for the interface.Specifies the interface name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the interface.Comment

Select the check box to enable this
feature.

Specifies that you can disable MPLS on this interface.Disable

Select the check box to enable this
feature.

Allows you to switch a layered service provider away
from a network node using a bypass layered service
provider.

Always Mark Connection
Protection Tlv

Select the check box to disable layered
service providers.

Allows you to switch away protected layered service
providers to their bypass layered service providers.

Switch Away Lsps

Protocols > Mpls > Interface > Admin Group

Enter a new administrative group name.Specifies the new administrative group name.New admin-group

Protocols > Mpls > Interface > Static

(Optional) Enter a comment.Suppliesadescriptivecomment for thestatic interface.Comment

Set the protection revert time.

Range: 0 through 65535.

Specifies the amount of time that a static layered
service provider must wait before traffic reverts from
the bypass path to the original path.

Protection Revert Time

Related
Documentation

Configuring Auto Policing (NSM Procedure) on page 118•

• Configuring Differentiated Services Traffic Engineering (NSM Procedure) on page 119

• Configuring Label Switched Path (NSM Procedure) on page 122
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Configuring Label Switched Path (NSMProcedure)

You can configure a label-switched path to use in a dynamic MPLS.

To configure label-switched paths:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure label-switched paths.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Label

Switched Path.

4. Click + to configure label-switched paths.

5. Add or modify settings as described in Table 73 on page 122.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the label-switched path parameters.

Table 73: Label-Switched Path Configuration Details

Your ActionFunctionOption

Enter a path name.Specifies the path name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the label-switched
path.

Comment

Select the check box to enable this
feature.

Specifies that youcandisableMPLS label-switchedpath.Disable

Select the check box to enable this
feature.

Specifies that you cannot install host route to address
into the routing tables.

No Install to Address

Select the check box to enable this
feature.

Specifies to use a label-switched path for Interior
Gateway Protocol (IGP) backup.

Backup

Enter the address of an ingress device.Specifies the address of an ingress device.From

Set the metric value.

Range: 1 through 16777215.

Specifies a metric value.Metric

Select the check box to enable this
feature.

Specifies that the LDP is allowed to use this a
label-switched path for tunneling.

Ldp Tunneling

Select the check box to enable this
feature.

Specifies to attempt make-before-break service while
preempting this a label-switched path.

Soft Preemption
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Table 73: Label-Switched Path Configuration Details (continued)

Your ActionFunctionOption

Set the retry timer.

Range: 1 through 600.

Specifies the time before retrying the primary path.Retry Timer

Set the retry limit.

Range: 0 through 10000.

Specifies the maximum number of times to retry the
primary path.

Retry Limit

Set the revert timer.

Range: 0 through 65535.

Specifies the hold-down window before reverting to the
primary path.

Revert Timer

Set the class-of-service value.

Range: 0 through 7.

Specifies the class-of-service value.Class of Service

Select the check box to enable this
feature.

Specifies that you cannot decrement the time to live
(TTL) within a label-switched path.

No Decrement Ttl

Set the hop limit.

Range: 2 through 255.

Specifies the maximum allowed device hops.Hop Limit

Select the check box to enable this
feature.

Specifies that theConstrainedShortestPathFirst (CSPF)
path computation is disabled.

No Cspf

Select the check box to enable this
feature.

Specifies that theGeneralizedMPLS label-switchedpath
is set to the administratively down state.

Admin Down

Set the periodical path reoptimization
value.

Range: 0 through 65535.

Specifies the periodical path reoptimizations.Optimize Timer

Set the preference value.

Range: 0 through 4,294,967,295.

Specifies the preference value.Preference

Select one option.Specifies whether a label-switched path should actively
record the routes in the path or not.

record / no-record

Select the check box to enable this
feature.

Specifies that the path remains up at all times to provide
instant switchover if connectivity problems occur.

Standby

Select an option.Specifies the preferred path when several equal-cost
candidate paths to a destination exist, and prefers the
path with the highest available bandwidth (with the
largest minimum available bandwidth ratio).

random / least-fill /
most-fill

Enter a description.Specifies the description for the label switch.Description
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Table 73: Label-Switched Path Configuration Details (continued)

Your ActionFunctionOption

Select the option.Specifies that you can enable link protection on the
specified label-switched path.

link-protection

Select the option.Specifies that you can enable link protection on the
specified interface.

node-link-protection

Select the check box to enable this
feature.

Specifies the interdomain label-switched path.Inter Domain

Select the check box to enable this
feature.

Specifies that the label-switched path can smoothly cut
over to the new routes.

Adaptive

Select the check box to enable this
feature.

Specifies that youcanassociate this label-switchedpath
with backup-pe groups.

Associate Backup Pe
Groups

Select the check box to enable this
feature.

Specifies that you can use this label-switched path for
egress protection data transport.

Egress Protection

Configuring Label-Switched Path includes the following topics:

• Configuring an Admin Group (NSM Procedure) on page 124

• Configuring Auto Bandwidth (NSM Procedure) on page 125

• Configuring Fast Reroute (NSM Procedure) on page 126

• Configuring Install (NSM Procedure) on page 127

• Configuring P2MP (NSM Procedure) on page 128

• Configuring Policing (NSM Procedure) on page 128

• Configuring Primary (NSM Procedure) on page 129

• Configuring Priority (NSM Procedure) on page 131

• Configuring Secondary (NSM Procedure) on page 131

• Configuring Traceoptions (NSM Procedure) on page 132

Configuring an Admin Group (NSMProcedure)

You can configure an administrative group for MPLS.

To configure an administrative group:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure an administrative group.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Admin

Group.

4. Enter a descriptive comment for the administrative group in Comment.
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5. An administrative group is typically named with a color and a numeric value, and is

applied to theMPLS interface for the appropriate links. You can enter links in Exclude,

or Include All, or Include Any.

6. To configure administrative groups, in the configuration tree, select Protocols >Mpls

> Admin Groups.

7. Click + to configure administrative groups as described in Table 74 on page 125.

8. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the administrative group and administrative groups parameters.

Table 74: Admin Groups Configuration Details

Your ActionFunctionOption

Enter the name for the administrative groups.Specifies the name for the administrative groups.Name

(Optional) Enter a comment.Supplies a descriptive comment for the
administrative groups.

Comment

Set the group value.

Range: 0 through 31.

Specifies the group bit position.Group Value

Configuring Auto Bandwidth (NSMProcedure)

To configure automatic bandwidth:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure an automatic bandwidth.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Label

Switched Path > Auto Bandwidth.

4. Select the Enable Feature check box to configure automatic bandwidth.

5. Add or modify settings as described in Table 75 on page 126.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the automatic bandwidth parameters.
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Table 75: Auto Bandwidth Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the automatic
bandwidth.

Comment

Set the adjust interval time.

Range: 300 through 4,294,967,295.

Specifies the time interval for adjusting the
label-switched path bandwidth.

Adjust Interval

Set the adjust threshold value.

Range: 0 through 50.

Specifies the change in average label-switchedpath
utilization to trigger automatic adjustment.

Adjust Threshold

Enter the minimum label-switched path
bandwidth.

Specifies the minimum label-switched path
bandwidth.

Minimum Bandwidth

Enter the maximum label-switched path
bandwidth.

Specifies the maximum label-switched path
bandwidth.

Maximum Bandwidth

Select the check box to enable this feature.Specifies that you canmonitor label-switched path
bandwidth without adjustments.

Monitor Bandwidth

Set the adjust threshold overflow limit.

Range: 1 through 65535.

Specifies the number of consecutive overflow
samples to trigger automatic adjustment.

Adjust Threshold
Overflow Limit

Configuring Fast Reroute (NSMProcedure)

To configure a fast reroute:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a fast reroute.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Label

Switched Path > Fast Reroute.

4. Enter a descriptive comment for the reroute in Comment.

5. Set the maximum allowed hop routes in Hop Limit.

6. Add or modify settings as described in Table 76 on page 127.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the fast reroute parameters.
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Table 76: Fast Reroute Configuration Details

Your ActionFunctionOption

label-switched-path > Fast Reroute > Bandwidth

Select the option.Specifies the bandwidth for the reroute path.bandwidth

Select the option.Specifies the percentage of bandwidth to reserve for the
detour path in case the primary path fails for a traffic
engineered label-switched path or a multiclass
label-switched path.

bandwidth-percent

label-switched-path > Fast Reroute > Exclude

Enter an administrative group name
to exclude for a label-switched path
ofaprimarypathora secondarypath.

Specifies the administrative groups to exclude for a
label-switched path of a primary path or a secondary path.

exclude

Select the option.Specifies the administrative groups to exclude for a fast
reroute.

no-exclude

label-switched-path > Fast Reroute > Include All

Select the option and enter the
administrative group name.

Specifies that the label-switchedpath is required to traverse
links that include all the defined administrative groups.

include-all

Select the option.Specifies that you can disable administrative group
inclusion.

no-include-all

label-switched-path > Fast Reroute > Include Any

Select the option.Specifies that you can define any administrative group to
include for a label-switched path of a primary path and a
secondary path.

include-any

Select the option.Specifies that you can disable any administrative group
inclusion.

no-include-any

Configuring Install (NSMProcedure)

To configure an install:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure an install.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Label

Switched Path > Install.

4. Enter a name for the install in Name.

5. Enter a descriptive comment for the install in Comment.
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6. Select the Active check box to install a prefix into the forwarding table.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the install parameters.

Configuring P2MP (NSMProcedure)

You can configure a Point-to-Multipoint (P2MP) label-switched path.

To configure a P2MP label-switched path:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the P2MP label-switched path.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Label

Switched Path > P2mp.

4. Select the check box to enable the feature in Enable Feature.

5. Enter a descriptive comment for the P2MP label-switched path in Comment.

6. Enter a name for the P2MP label-switched path in Path_name.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the P2MP parameters.

Configuring Policing (NSMProcedure)

You can configure policing (also known as rate limiting) to limit the amount of traffic

that passes into or out of an interface.

To configure policing:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure policing.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Label

Switched Path > Policing.

4. Enter a descriptive comment for the policing in Comment.

5. Select the name of the filter used for policing the label-switched path traffic in Filter.
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6. Enable the check box to turn off automatic policing for this label-switched path inNo

Auto Policing.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the policing parameters.

Configuring Primary (NSMProcedure)

You can configure the primary path to use for a label-switched path.

To configure a primary label-switched path:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a primary label-switched path.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Label

Switched Path > Primary.

4. Click + to configure the primary label-switched path.

5. Add or modify settings as described in Table 77 on page 129.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the primary parameters.

Table 77: Primary LSP Configuration Details

Your ActionFunctionOption

Enter a primary path name.Specifies the name of the primary path.Name

(Optional) Enter a comment.Supplies a descriptive comment for the
primary path label-switched path.

Comment

Set the class-of-service value.

Range: 0 through 7.

Specifies the class-of-service value.Class of Service

Select the check box to enable this
feature.

Specifies that you cannot decrement the
TTL within a label-switched path.

No Decrement Ttl

Set the maximum allowed device
hops.

Range: 2 through 255.

Specifies the maximum allowed device
hops.

Hop Limit
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Table 77: Primary LSP Configuration Details (continued)

Your ActionFunctionOption

Select the check box to enable this
feature.

Specifies that the automatic path
computation is disabled.

No Cspf

Select the check box to enable this
feature.

Specifies that the Generalized MPLS
(GMPLS) label-switched path is set to
administrative down state.

Admin Down

Set theperiodicalpath reoptimization
value.

Range: 0 through 65535.

Specifies the periodical path
reoptimization.

Optimize Timer

Set the preference value.

Range: 0 through 4,294,967,295.

Specifies the preference value.Preference

Select one option.Specifies whether a label-switched path
should actively record the routes in the
path or not.

record / no-record

Select the check box to enable this
feature.

Specifies that the path remains up at all
times to provide instant switchover if
connectivity problems occur.

Standby

Select the check box to enable this
feature.

Specifies that the Resource Reservation
Protocol (RSVP) uses the shared explicit
(SE) reservation styles and assists in
smooth transition during rerouting.

Adaptive

Select an option from the list.Specifies a way of selection. You cannot
specify both options.

Select

label-switched-path > Primary > Admin Group

To configure an administrative group, see “Configuring an Admin Group (NSM Procedure)” on page 124.

label-switched-path > Primary > Bandwidth

To configure a bandwidth, see “Configuring Bandwidth (NSM Procedure)” on page 119.

label-switched-path > Primary > Oam

label-switched-path > Primary > Priority

Select the check box to enable this
feature.

Specifies that youcanconfigure thepriority
settings.

Enable Feature

(Optional) Enter a comment.Supplies a descriptive comment for the
priority settings.

Comment
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Table 77: Primary LSP Configuration Details (continued)

Your ActionFunctionOption

Set the setup priority value.

Range: 0 through 7.

Specifies the setup priority that is set.Setup Priority

Set the reservation priority value.

Range: 0 through 7.

Specifies the reservation priority which is
used tokeepa reservationafter it hasbeen
set up.

Reservation Priority

Configuring Priority (NSMProcedure)

When there is insufficient bandwidth to establish amore important label-switchedpath,

youmight want to tear down a less important existing label-switched path to free the

bandwidth, by setting priorities.

To configure a priority:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a priority.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Label

Switched Path > Priority.

4. Select the check box to configure priority in Enable Feature.

5. Enter a descriptive comment for the priority setting in Comment.

6. Specifywhether a new label-switched path that preempts an existing label-switched

path needs to be established in Setup Priority. Range: 0 through 7.

7. Specify the degree to which a label-switched path holds onto its session reservation

after the label-switched path has been set up successfully in Reservation Priority.

Range: 0 through 7.

8. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the priority parameters.

Configuring Secondary (NSMProcedure)

You can configure a secondary path to use for a label-switched path.

To configure a secondary label-switched path:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a secondary label-switched path.
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3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Label

Switched Path > Secondary.

4. Click + to configure the secondary label-switched path.

5. To configure administrative groups, see “Configuring an Admin Group (NSM

Procedure)” on page 124.

6. To configure bandwidth, see “Configuring Bandwidth (NSM Procedure)” on page 119.

7. To configure priority, see “Configuring Priority (NSM Procedure)” on page 131.

8. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the secondary parameters.

Configuring Traceoptions (NSMProcedure)

You can configure traceoptions.

To configure traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure traceoptions.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Label

Switched Path > Traceoptions.

4. Enter a descriptive comment for the traceoption.

5. Add or modify settings as described in Table 78 on page 132.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the traceoption parameters.

Table 78: Traceoptions Configuration Details

Your ActionFunctionOption

label-switched-path > Traceoptions > File

(Optional) Enter a comment.Supplies a descriptive comment for the file
traceoption.

Comment

Enter the filename.Specifies the name of the file in which to write the
trace information.

Filename

Enter the trace file size.Specifies the maximum trace file size.Size
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Table 78: Traceoptions Configuration Details (continued)

Your ActionFunctionOption

Set the maximum number of trace files.

Range: 2 through 1000.

Specifies the maximum number of trace files.Files

Select the option.Specifies unrestricted file access.world-readable

Select the option.Specifies that file access is restricted to the owner
only.

no-world-readable

label-switched-path > Traceoptions > Flag

Enter a flag name.Specifies the flag name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the flag
traceoption.

Comment

Related
Documentation

Configuring Interfaces (NSM Procedure) on page 120•

• Configuring MPLS (NSM Procedure) on page 116

Configuring Log Updown (NSMProcedure)

You can log amessage whenever a BGP peer makes a state transition.

To configure log updown:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure log updown.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Log

Updown.

4. Click + to configure log updown as described in Table 79 on page 134.

5. Select Protocols >Mpls > Log Updown > Trap.

6. Configure settings as described in Table 79 on page 134.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the log updown parameters.
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Table 79: Log Updown Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the log updown.Comment

Select an option.Specifies whether to log or not log amessage to the
system log file.

• syslog—Logs amessage to the system log file.

• no-syslog—Does not log amessage to the system log
file.

syslog / no-syslog

Select the check box to enable this
feature.

Specifies to send SNMP traps when a path goes down.Trap Path Down

Select the check box to enable this
feature.

Specifies to send SNMP traps when a path goes up.Trap Path Up

Mpls > Log Updown > Trap

Select an option.Specifies whether to send SNMP trap or not.

• trap—Sends an SNMP trap.

• no-trap—Does not send an SNMP trap.

trap / no-trap

Mpls > Log Updown > Trap > No Trap

(Optional) Enter a comment.Supplies a descriptive comment for path that does not
send an SNMP trap.

Comment

Select the check box to enable this
feature.

Specifies not to sendMPLS label switch path up or down
traps.

Mpls Lsp Traps

Select the check box to enable this
feature.

Specifies not to send RFC3812 traps.Rfc3812 Traps

Related
Documentation

Configuring OAM (NSM Procedure) on page 134•

• Configuring Path (NSM Procedure) on page 137

• Configuring Path MTU (NSM Procedure) on page 138

Configuring OAM (NSMProcedure)

You can configure Operation, Administration, and Maintenance (OAM) for devices.

To configure OAM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure OAM.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls >Oam.
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4. Enter a description for OAM in Comment.

5. Enter a time interval between LSP ping messages in Lsp Ping Interval. Range value is

from 30 through 3600.

6. Configure OAM settings as described in Table 80 on page 135.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the OAM parameters.

Table 80: OAMConfiguration Details

Your ActionFunctionOption

Mpls > Oam>Bfd Liveness Detection

(Optional) Enter a comment.Supplies a descriptive comment of Bidirectional
Forwarding Detection (BFD) protocol detection.

Comment

Select a value from the list.Specifies the BFD protocol version number.Version

Enter a minimum interval value. Range
vary from 1 through 255,000.

Specifies theminimum transmit and receive interval.Minimum Interval

Enter a minimum receive interval value.
Range vary from 1 through 255,000.

Specifies the minimum receive interval.Minimum Receive Interval

Enter themultiplier value.Rangevary from
1 through 255.

Specifies the detection timemultiplier.Multiplier

Select the check box to enable this
feature.

Specifies to disable adaptation.No Adaptation

Mpls > Oam>Bfd Liveness Detection > Detection Time

(Optional) Enter a comment.Supplies a descriptive comment of BFD protocol
detection time.

Comment

Enter a threshold value. Range vary from
0 through 4,294,967,295.

Specifies the high detection time triggering a trap.Threshold

Mpls > Oam>Bfd Liveness Detection > Failure Action

(Optional) Enter a comment.Supplies a descriptive comment of BFD protocol
failure action.

Comment

Mpls > Oam>Bfd Liveness Detection > Failure Action > Teardown
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Table 80: OAMConfiguration Details (continued)

Your ActionFunctionOption

Select an option.Specifies the route path options.

• teardown—When a BFD session fails for an RSVP
label switchpath, theassociated label switchpath
is taken down and resignaled immediately.

• make-before-break—When a BFD session fails for
an RSVP label switch path, an attempt is made to
signal anew label switchpathbefore tearingdown
the old label switch path.

teardown /
make-before-break

Mpls > Oam>Bfd Liveness Detection > Failure Action > Teardown >Make Before Break

(Optional) Enter a comment.Supplies a descriptive comment of BFD teardown.Comment

Enter a teardown timeout value. Range
vary from 0 through 30.

Specifies the time to wait before teardown.Teardown Timeout

Mpls > Oam>Bfd Liveness Detection > Transmit Interval

(Optional) Enter a comment.Supplies a descriptive comment of the transmit
interval.

Comment

Enter a minimum interval value. Range
vary from 1 through 255,000.

Specifies theminimum transmit and receive interval.Minimum Interval

Enter a threshold value. Range vary from
0 through 4,294,967,295.

Specifies high transmit interval triggering a trap.Threshold

Mpls > Oam> Traceoptions

(Optional) Enter a comment.Supplies a descriptive comment of the traceoption.Comment

Select the check box to enable this
feature.

Specifies to disable remote tracing.No remote Trace

Mpls > Oam> Traceoptions > File

(Optional) Enter a comment.Supplies a descriptive comment of the file
traceoption.

Comment

Enter the filename.Specifies the name of file in which to write trace
information.

Filename

Enter the maximum trace file size.Specifies the maximum trace file size.Size

Enter themaximum number of trace files.Specifies the maximum number of trace files.Files

Select an option.Specifies file restriction access.

• no-world-readable—Restricts file access to owner.

• world-readable—Enables unrestricted file access.

world-readable /
no-world-readable

Enter the match criteria.Specifies the regular expression for lines tobe logged.Match
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Table 80: OAMConfiguration Details (continued)

Your ActionFunctionOption

Mpls > Oam> Traceoptions > Flag

Enter a name for the flag traceoption.Specifies the name of the flag traceoption.Name

(Optional) Enter a comment.Supplies a descriptive comment of the flag
traceoption.

Comment

Related
Documentation

Configuring Path (NSM Procedure) on page 137•

• Configuring Static Label Switched Path (NSM Procedure) on page 139

• Configuring Path MTU (NSM Procedure) on page 138

Configuring Path (NSMProcedure)

To configure a path:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure path.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Path.

4. Click + to configure path as described in Table 81 on page 137.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the path parameters.

Table 81: Path Configuration Details

Your ActionFunctionOption

Mpls > Oam>Path

Enter a name for the label switch
path.

Specifies the name of label switch path.Name

(Optional) Enter a comment.Supplies a descriptive comment for the label switch path.Comment

Mpls > Oam>Path > Path List

Enter the name of the next path
list.

Specifies the name of the next systemwhich is in the path.Name

(Optional) Enter a comment.Supplies a descriptive comment for the next path list.Comment
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Table 81: Path Configuration Details (continued)

Your ActionFunctionOption

Select an option.Specifies the source route option to direct traffic along a specific
path.

• loose—Each incoming packet's source address is tested against
the forwarding table. The packet is dropped only if the source
address is not reachable via any interface on that device.

• strict—Each incoming packet is tested against the forwarding
table. If the incoming interface is not the best reverse path, the
packet check will fail.

loose / strict

Related
Documentation

Configuring Path MTU (NSM Procedure) on page 138•

• Configuring Static Label Switched Path (NSM Procedure) on page 139

• Configuring OAM (NSM Procedure) on page 134

Configuring PathMTU (NSMProcedure)

You can configure a path MTU (maximum transmission unit) which prevents

fragmentation.

To configure a path MTU :

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a path MTU.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Path

Mtu.

4. To configure path MTU, select Enable Feature.

5. Enter a descriptive comment about the path MTU in Comment.

6. To fragment IP before encapsulating in MPLS, select Allow Fragmentation.

7. Select Protocols >Mpls > PathMtu > Rsvp.

8. To configure this feature, select Enable Feature.

9. Enter a descriptive comment about RSVP in Comment.

10. To enable RSVP path MTU signaling, selectMtu Signaling.

11. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the path MTU or RSVP parameters.
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Related
Documentation

Configuring Static Label Switched Path (NSM Procedure) on page 139•

• Configuring Path (NSM Procedure) on page 137

• Configuring Statistics (NSM Procedure) on page 142

Configuring Static Label Switched Path (NSMProcedure)

To configure a static label switched path:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a static label switched path.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls > Static

Label Switched Path.

4. Click + to configure a static label switched path as described in Table 82 on page 139.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the static label switch path parameters.

Table 82: Static Label Switched Path Configuration Details

Your ActionFunctionOption

Mpls > Static Label Switched Path

Enter a path name.Specifies the path name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the path.Comment

Mpls > Static Label Switched Path > Bypass

Select an option.Specifies the label switched path session status.

• bypass—Sessions for bypass label switched
paths.

• transit—Sessions that transit through thisdevice.

• ingress—Sessions thatoriginate fromthisdevice.

bypass / transit / ingress

Mpls > Static Label Switched Path > Bypass > bypass

(Optional) Enter a comment.Supplies a descriptive comment for bypass.Comment

Enter the bandwidth.Specifies the bandwidth to reserve.Bandwidth

Enter a description.Specifies the text description of the bypass label
switched path.

Description
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Table 82: Static Label Switched Path Configuration Details (continued)

Your ActionFunctionOption

Enter an address or interface.Specifies the address or interface of next-hop
device.

Next Hop

Enter the push value. Rage vary from 0
through 1,048,575.

Specifies the label to push.Push

Enter an address of the egress device.Specifies the address of the egress device.To

Mpls > Static Label Switched Path > Bypass > transit

Set the name as a value. Range vary from
1,000,000 through 1,048,575.

Specifies the name for transit.Name

(Optional) Enter a comment.Supplies a descriptive comment for transit.Comment

Enter the bandwidth.Specifies the bandwidth to reserve.Bandwidth

Enter a description.Specifies the text description of the transit label
switched path.

Description

Enter an address or interface.Specifies the address or interface of next-hop
device.

Next Hop

Mpls > Static Label Switched Path > Bypass > transit > Link Protection

(Optional) Enter a comment.Supplies a descriptive comment for transit link
protection.

Comment

Enter a bypass label switched path name.Specifies the bypass label switched path name.Bypass Name

Mpls > Static Label Switched Path > Bypass > transit > Node Protection

(Optional) Enter a comment.Supplies a descriptive comment for transit node
protection.

Comment

Enter a bypass label switched path name.Specifies the bypass label switched path name.Bypass Name

Enter the next next label value. Rage vary
from 0 through 1,048,575.

Specifies the label expected by next-next-hop
device.

Next Next Label

Mpls > Static Label Switched Path > Bypass > transit > Swap

Select an option.

NOTE: If you select swap, enter a swap
value. range vary from 0 through 1,048,575.

Specifies the virtual LAN tag operations.swap / pop

Mpls > Static Label Switched Path > Bypass > ingress

(Optional) Enter a comment.Suppliesadescriptive comment forbypass ingress.Comment

Enter the bandwidth.Specifies the bandwidth to reserve.Bandwidth
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Table 82: Static Label Switched Path Configuration Details (continued)

Your ActionFunctionOption

Enter the Class of Service value. Range vary
from 0 through 7.

Specifies the Class of Service value.Class Of Service

Enter a description.Specifies the text description of the ingress label
switched path.

Description

Enter the metric value. Range vary from 0
through 16,777,215.

Specifies the metric value.Metric

Enter an address or interface.Specifies the address or interface of next-hop
device.

Next Hop

Select the check box to enable this feature.Specifies not to install host route to address into
routing tables.

No Install To Address

Enter the preference value. Range vary from
0 through 4,294,967,295.

Specifies the preference value.Preference

Enter an address of the egress device.Specifies the address of the egress device.To

Enter the push value. Rage vary from 0
through 1,048,575.

Specifies the label to push.Push

Mpls > Static Label Switched Path > Bypass > Ingress > Install

Enter the name for the destination prefix.Specifies the name of the destination prefix.Name

(Optional) Enter a comment.Supplies a descriptive comment for ingress install.Comment

Select the check box to enable this feature.Specifies that you can install prefix into forwarding
tables.

Active

Mpls > Static Label Switched Path > Bypass > Ingress > Link Protection

(Optional) Enter a comment.Supplies a descriptive comment for ingress link
protection.

Comment

Enter a bypass name.Specifies the bypass label switch path name.Bypass Name

Mpls > Static Label Switched Path > Bypass > Ingress > Node Protection

(Optional) Enter a comment.Supplies a descriptive comment for ingress node
protection.

Comment

Enter a bypass name.Specifies the bypass label switch path name.Bypass Name

Enter the next-next label value. Rage vary
from 0 through 1,048,575.

Specifies the label expected by next-next-hop
device.

Next Next Label

Mpls > Static Label Switched Path > Bypass > Ingress > Policing
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Table 82: Static Label Switched Path Configuration Details (continued)

Your ActionFunctionOption

(Optional) Enter a comment.Suppliesadescriptivecomment for ingresspolicing.Comment

Select an option from the list.Specifies the nameof filter to use for policing label
switch paths.

Filter

Select the check box to enable this feature.Specifies to turnoff automaticpolicing for this label
switch path.

No Auto Policing

Related
Documentation

Configuring Path MTU (NSM Procedure) on page 138•

• Configuring Statistics (NSM Procedure) on page 142

• Configuring Path (NSM Procedure) on page 137

Configuring Statistics (NSMProcedure)

To configure statistics:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure statistics.

3. Click theConfiguration tab. In theconfiguration tree, selectProtocols>Mpls>Statistics.

4. Enter a comment for the statistics in Comment.

5. Enter the time (in seconds) to collect statistics in Interval.

6. Select Auto Bandwidth to enable auto bandwidth allocation.

7. Configure file statistics as described in Table 83 on page 142.

8. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the statistics parameters.

Table 83: File Statistics Configuration Details

Your ActionFunctionOption

Mpls > Statistics > File

(Optional) Enter a comment.Supplies a descriptive comment for the file traceoption.Comment

Enter the filename.Specifies the name of a file in which to write trace
information.

Filename

Enter the maximum trace file size.Specifies the maximum trace file size.Size
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Table 83: File Statistics Configuration Details (continued)

Your ActionFunctionOption

Enter the maximum number of trace
files.

Specifies the maximum number of trace files.Files

Select an option.Specifies file restriction access.
no-world-readable—restricts file access to owner.
world-readable—enables unrestricted file access.

world-readable /
no-world-readable

Related
Documentation

Configuring Static Label Switched Path (NSM Procedure) on page 139•

• Configuring Traceoptions (NSM Procedure) on page 143

• Configuring Path MTU (NSM Procedure) on page 138

Configuring Traceoptions (NSMProcedure)

To configure traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure traceoptions.

3. Click the Configuration tab. In the configuration tree, select Protocols >Mpls >

Traceoptions.

4. Enter a comment for the traceoptions in Comment.

5. Configure traceoptions as described in Table 84 on page 143.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the traceoptions parameters.

Table 84: Traceoptions Configuration Details

Your ActionFunctionOption

Mpls > Traceoptions > File

(Optional) Enter a comment.Supplies a descriptive comment for the file traceoption.Comment

Enter the filename.Specifies the name of a file in which to write trace
information.

Filename

Enter the maximum trace file size.Specifies the maximum trace file size.Size

Enter the maximum number of trace
files.

Specifies the maximum number of trace files.Files
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Table 84: Traceoptions Configuration Details (continued)

Your ActionFunctionOption

Select an option.Specifies file restriction access.
no-world-readable—restricts file access to owner.
world-readable—enables unrestricted file access.

world-readable /
no-world-readable

Mpls > Traceoptions > Flag

Enter a flag traceoption name.Specifies the flag traceoption name.Name

(Optional) Enter a comment.Supplies adescriptive comment for the flag traceoption.Comment

Related
Documentation

Configuring Statistics (NSM Procedure) on page 142•

• Configuring Static Label Switched Path (NSM Procedure) on page 139

• Configuring Path MTU (NSM Procedure) on page 138

ConfiguringMSDP (NSMProcedure)

The Multicast Source Discovery Protocol (MSDP) is used to connect multicast routing

domains. It typically runson the same router as theProtocol IndependentMulticast (PIM)

sparse-mode rendezvous point (RP). Each MSDP device establishes adjacencies with

internal and external MSDP peers similar to the Border Gateway Protocol (BGP).

To configure MSDP:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure MSDP.

3. Click the Configuration tab. In the configuration tree, select Protocols >Msdp.

4. Enter a comment for MSDP in Comment.

5. Select a value from the list, Data Encapsulation to set encapsulation of data packets.

6. SelectMSDP to disable MSDP.

7. Enter the local address of MSDP in Local Address.

8. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the MSDP parameters.

This topic includes the following sub topics:

• Configuring Active Source Limit (NSM Procedure) on page 145

• Configuring Export (NSM Procedure) on page 145

Copyright © 2013, Juniper Networks, Inc.144

Configuring J Series Services Routers and SRX Series Services Gateways Guide



• Configuring Group (NSM Procedure) on page 146

• Configuring Import (NSM Procedure) on page 150

• Configuring Peer (NSM Procedure) on page 150

• Configuring RIB Group (NSM Procedure) on page 152

• Configuring Source (NSM Procedure) on page 153

• Configuring Traceoptions (NSM Procedure) on page 153

Configuring Active Source Limit (NSMProcedure)

To configure active source limit:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure an active source limit.

3. Click the Configuration tab. In the configuration tree, select Protocols >Msdp > Active

Source Limit.

4. Enter a comment for the active source limit in Comment.

5. Enter themaximum number of active sources adapted inMaximum. Range vary from

1 through 1,000,000.

6. Enter the threshold for active source acceptance in Threshold. Range vary from 1

through 1,000,000.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the active source limit parameters.

Configuring Export (NSMProcedure)

To export members:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

export members.

3. Click theConfiguration tab. In the configuration tree, selectProtocols>Msdp> Export.

4. Select the non-members from Non-members.

5. Click Add or Remove to add/remove non-members to members andmembers to

non-members.
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NOTE: Select all (required) records and click Add All or Remove Allwhich

will add the selected records tomembers or remove the selected records
to non-members.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the export parameters.

Configuring Group (NSMProcedure)

To configure groups:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure groups.

3. Click the Configuration tab. In the configuration tree, select Protocols >Msdp >Group.

4. Click + to configure groups as described in Table 85 on page 146

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the groups parameters.

Table 85: Groups Configuration Details

Your ActionFunctionOption

Msdp > Group

Enter a peer group name.Specifies the MSDP peer group name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the peer
group.

Comment

Select an option from the list.Specifies the MSDP group source-active
flooding mode.

Mode

Select the check box to enable this feature.Specifies to disable MSDP.Disable

Enter the local address of the peer group.Specifies the local address of the peer group.Local Address

Msdp > Group > Export
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Table 85: Groups Configuration Details (continued)

Your ActionFunctionOption

Click Add or Remove to add / remove
non-members to members andmembers to
non-members.

NOTE: Select all (required) records and click Add
All or Remove Allwhich will add the selected
records to members or remove the selected
records to non-members.

Adds or removes non-members to or from
members list.

Non-members /
Members

Msdp > Group > Import

Click Add or Remove to add / remove
non-members to members andmembers to
non-members.

NOTE: Select all (required) records and click Add
All or Remove Allwhich will add the selected
records to members or remove the selected
records to non-members.

Adds or removes non-members to or from
members list.

Non-members /
Members

Msdp > Group > Peer

Enter a peer address name.Specifies the peer address name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the peer
group.

Comment

Select the check box to enable this feature.Specifies to disable MSDP.Disable

Enter the local address of the peer group.Specifies the local address of the peer group.Local Address

Select the check box to enable this feature.Specifies to disable default Reverse Path
Forwarding (RPF) peer.

Default Peer

Enter the MD5 authentication key.Specifies the MD5 authentication key.Authentication Key

Msdp > Group > Peer > Active Source Limit

(Optional) Enter a comment.Supplies a descriptive comment for the active
source limit.

Comment

Enter the maximum value. Range vary from 1
through 1,000,000.

Specifies the maximum number of active
sources accepted.

Maximum

Enter the threshold value. Range vary from 1
through 1,000,000.

Specifies the threshold for active source
acceptance.

Threshold

Msdp > Group > Peer > Export
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Table 85: Groups Configuration Details (continued)

Your ActionFunctionOption

Click Add or Remove to add / remove
non-members to members andmembers to
non-members.

NOTE: Select all (required) records and click Add
All or Remove Allwhich will add the selected
records to members or remove the selected
records to non-members.

Adds or removes non-members to or from
members list.

Non-members /
Members

Msdp > Group > Peer > Import

Click Add or Remove to add / remove
non-members to members andmembers to
non-members.

NOTE: Select all (required) records and click Add
All or Remove Allwhich will add the selected
records to members or remove the selected
records to non-members.

Adds or removes non-members to or from
members list.

Non-members /
Members

Msdp > Group > Peer > Traceoptions

(Optional) Enter a comment.Supplies a descriptive comment for the
traceoptions.

Comment

Msdp > Group > Peer > Traceoptions > File

(Optional) Enter a comment.Supplies a descriptive comment for file
traceoptions.

Comment

Enter the filename.Specifies the nameof file inwhich towrite trace
information.

Filename

Enter the maximum trace file size.Specifies the maximum trace file size.Size

Enter the maximum number of trace files.Specifies the maximum number of trace files.Files

Select an option.Specifies file restriction access.
no-world-readable—restricts file access to
owner.world-readable—enables unrestricted
file access.

world-readable /
no-world-readable

Msdp > Group > Peer > Traceoptions > Flag

Enter a flag traceoption name.Specifies the flag traceoptions name.Name

(Optional) Enter a comment.Supplies a descriptive comment for flag
traceoptions.

Comment

Select the check box to enable this feature.Specifies to enable the trace transmitted
packets.

Send

Select the check box to enable this feature.Specifies to enable the trace received packets.Receive
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Table 85: Groups Configuration Details (continued)

Your ActionFunctionOption

Select the check box to enable this feature.Specifies to enable the trace detailed
information.

Detail

Select the check box to enable this feature.Specifies to disable the trace flag.Disable

Msdp > Group > Traceoptions

(Optional) Enter a comment.Supplies a descriptive comment for
traceoptions.

Comment

Msdp > Group > Traceoptions > File

(Optional) Enter a comment.Supplies a descriptive comment for file
traceoptions.

Comment

Enter the filename.Specifies the nameof file inwhich towrite trace
information.

Filename

Enter the maximum trace file size.Specifies the maximum trace file size.Size

Enter the maximum number of trace files.Specifies the maximum number of trace files.Files

Select an option.Specifies file restriction access.
no-world-readable—restricts file access to
owner.world-readable—enables unrestricted
file access.

world-readable /
no-world-readable

Msdp > Group > Traceoptions > Flag

Enter a flag traceoption name.Specifies the flag traceoptions name.Name

(Optional) Enter a comment.Supplies a descriptive comment for flag
traceoptions.

Comment

Select the check box to enable this feature.Specifies to enable the trace transmitted
packets.

Send

Select the check box to enable this feature.Specifies to enable the trace received packets.Receive

Select the check box to enable this feature.Specifies to enable the trace detailed
information.

Detail

Select the check box to enable this feature.Specifies to disable the trace flag.Disable
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Configuring Import (NSMProcedure)

To import members:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

import members.

3. Click theConfiguration tab. In the configuration tree, selectProtocols>Msdp> Import.

4. Select the non-members from Non-members.

5. Click Add or Remove to add / remove non-members to members andmembers to

non-members.

NOTE: Select all (required) records and click Add All or Remove Allwhich

will add the selected records tomembers or remove the selected records
to non-members.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the import parameters.

Configuring Peer (NSMProcedure)

To configure peers:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure peers.

3. Click the Configuration tab. In the configuration tree, select Protocols >Msdp > Peer.

4. Click + to configure peers as described in Table 86 on page 150.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the peer parameters.

Table 86: Peer Configuration Details

Your ActionFunctionOption

Msdp > Peer

Enter a peer name.Specifies the peer name.Name
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Table 86: Peer Configuration Details (continued)

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for peer.Comment

Select the check box to enable this feature.Specifies to disable MSDP.Disable

Enter the local address of the peer.Specifies the local address of the peer.Local Address

Select the check box to enable this feature.Specifies to enable default RPF peer.Default Peer

Enter the MD5 authentication key.Specifies the MD5 authentication key.Authentication Key

Msdp > Peer > Active Source Limit

(Optional) Enter a comment.Supplies a descriptive comment for the peer
active source limit.

Comment

Enter the maximum value. Range vary from 1
through 1,000,000.

Specifies the maximum number of active
sources accepted.

Maximum

Enter the threshold value. Range vary from 1
through 1,000,000.

Specifies the threshold for active source
acceptance.

Threshold

Msdp > Peer > Export

Click Add or Remove to add / remove
non-members to members andmembers to
non-members.

NOTE: Select all (required) records and click Add
All or Remove Allwhich will add the selected
records to members or remove the selected
records to non-members.

Adds or removes non-members to or from
members list.

Non-members /
Members

Msdp > Peer > Import

Click Add or Remove to add / remove
non-members to members andmembers to
non-members.

NOTE: Select all (required) records and click Add
All or Remove Allwhich will add the selected
records to members or remove the selected
records to non-members.

Adds or removes non-members to or from
members list.

Non-members /
Members

Msdp > Peer > Traceoptions

(Optional) Enter a comment.Supplies a descriptive comment for the peer
traceoptions.

Comment

Msdp > Peer > Traceoptions > File

(Optional) Enter a comment.Supplies a descriptive comment for the file
traceoption.

Comment
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Table 86: Peer Configuration Details (continued)

Your ActionFunctionOption

Enter the filename.Specifies thenameof file inwhich towrite trace
information.

Filename

Enter the maximum trace file size.Specifies the maximum trace file size.Size

Enter the maximum number of trace files.Specifies the maximum number of trace files.Files

Select an option.Specifies file restriction access.
no-world-readable—restricts file access to
owner.world-readable—enables unrestricted
file access.

world-readable /
no-world-readable

Msdp > Peer > Traceoptions > Flag

Enter a flag traceoption name.Specifies the flag traceoptions name.Name

(Optional) Enter a comment.Supplies a descriptive comment for flag
traceoptions.

Comment

Select the check box to enable this feature.Specifies to enable the trace transmitted
packets.

Send

Select the check box to enable this feature.Specifies to enable the trace received packets.Receive

Select the check box to enable this feature.Specifies to enable the trace detailed
information.

Detail

Select the check box to enable this feature.Specifies to disable the trace flag.Disable

Configuring RIB Group (NSMProcedure)

ARIB (routing information base) group is away to have a routing protocol, inmost cases,

place information in multiple route tables.

To configure a RIB group:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure RIB groups.

3. Click the Configuration tab. In the configuration tree, select Protocols >Msdp > Rib

Group.

4. Enter a comment for the RIB group in Comment.

5. Enter a name for the routing table group in Ribgroup Name.

6. Click one:

• OK—Saves the changes.
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• Cancel—Cancels the modifications.

• Apply—Applies the RIB group parameters.

Configuring Source (NSMProcedure)

To configure source:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure source.

3. Click theConfiguration tab. In the configuration tree, selectProtocols>Msdp>Source.

4. Click + to configure source as described in Table 87 on page 153.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the source parameters.

Table 87: Source Configuration Details

Your ActionFunctionOption

Msdp > Source

Enter the source address name.Specifies the source address name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the source.Comment

Msdp > Source > Active Source Limit

(Optional) Enter a comment.Supplies a descriptive comment for the source.Comment

Enter the maximum value. Range vary from 1
through 1,000,000.

Specifies themaximumnumber of active sources
accepted.

Maximum

Enter the threshold value. Range vary from 1
through 1,000,000.

Specifies the threshold for active source
acceptance.

Threshold

Configuring Traceoptions (NSMProcedure)

To configure traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure traceoptions.

3. Click the Configuration tab. In the configuration tree, select Protocols >Msdp >

Traceoptions.

4. Enter a comment for the traceoptions in Comment.
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5. Configure traceoptions as described in Table 88 on page 154.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the traceoptions parameters.

Table 88: Traceoptions Configuration Details

Your ActionFunctionOption

Msdp > Traceoptions > File

(Optional) Enter a comment.Suppliesadescriptivecomment for the file traceoption.Comment

Enter the filename.Specifies the name of file in which to write trace
information.

Filename

Enter the maximum trace file size.Specifies the maximum trace file size.Size

Enter the maximum number of trace files.Specifies the maximum number of trace files.Files

Select an option.Specifies file restriction access.
no-world-readable—restricts file access to owner.
world-readable—enables unrestricted file access.

world-readable /
no-world-readable

Msdp > Traceoptions > Flag

Enter a flag traceoption name.Specifies the flag traceoptions name.Name

(Optional) Enter a comment.Supplies a descriptive comment for flag traceoptions.Comment

Select the check box to enable this feature.Specifies to enable the trace transmitted packets.Send

Select the check box to enable this feature.Specifies to enable the trace received packets.Receive

Select the check box to enable this feature.Specifies to enable the trace detailed information.Detail

Select the check box to enable this feature.Specifies to disable the trace flag.Disable

Related
Documentation

Configuring Statistics (NSM Procedure) on page 142•

• Configuring Static Label Switched Path (NSM Procedure) on page 139

• Configuring Path MTU (NSM Procedure) on page 138

ConfiguringMSTP (NSMProcedure)

MultipleSpanningTreeProtocol (MSTP) isused tocreatea loop-free topology innetworks

using multiple spanning tree regions, each region containing multiple spanning-tree
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instances (MSTIs). MSTIs provide different paths for different VLANs. This functionality

facilitates better load sharing across redundant links.

MSTP supports up to 64 regions, each one capable of supporting 4094MSTIs.

To configure MSTP:

1. In the navigation tree, select DeviceManager > Devices. In Device Manager, select the

device for which you want to configure a port mirror analyzer.

2. In the Configuration tree, expand Protocols >MSTP.

3. Add/modify MSTP settings as specified in Table 89 on page 155.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See Updating
Devices for more information.

Table 89: MSTP Configuration Fields

Your ActionFunctionOption

Click to select the option.Specifies whether MSTPmust be
disabled on the port.

Disable

Type a name.Specifies the configuration name.Configuration Name

Select a value.Specifies theconfiguration revision level.Revision Level

Select a value.Specifies the number of hops in a region
before the BPDU is discarded.

Max Hops

Select a value.Specifies the maximum-aging time for
all MST instances. Themaximum aging
time is the number of seconds a switch
waits without receiving spanning-tree
configuration messages before
attempting a reconfiguration.

Max Age

Select a value.Specifies the hello time for all MST
instances.

Hello time

Select a value.Specifies the number of seconds a port
waits before changing from its
spanning-tree learning and listening
states to the forwarding state.

Forward Delay

Enter a value.Specifies the bridge priority.Bridge Priority

Select to enable the feature.Specifies whether Bpdu blocks must be
processed.

Bpdu Block on Edge
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Table 89: MSTP Configuration Fields (continued)

Your ActionFunctionOption

1. Click the expand icon.

2. Specify the interface name.

3. Specify the port priority.

4. Specify thepathcost.MSTPuses the
pathcostwhenselectingan interface
to place into the forwarding state. A
lower path cost represents
higher-speed transmission.

5. Specify the mode. The link type can
be shared or point-to-point.

6. Select Edge to enable the feature.

7. Select No root port if it is not
specified.

8. ClickOK.

9. Specify the Bpdu timeout action:

• Block

• Alarm

Specifies MSTP settings for the
interface.

Interface

1. Specify the Msti ID.

2. Enter a comment.

3. Specify the bridge priority.

4. ClickOK.

Specifies MST instances settings for an
interface or VLAN.

Msti

Configuring OSPF (NSMProcedure)

OSPF uses the shortest path first (SPF) algorithm to determine the route to reach each

destination. All devices in an area run this algorithm in parallel, storing the results in their

individual topological databases. Devices with interfaces to multiple areas runmultiple

copies of the algorithm.

To configure OSPF in NSM:

1. In the navigation tree select DeviceManager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Protocols and selectOSPF.

5. Add/Modify the parameters under the respective tabs as specified in Table 90 on

page 157.

6. Click one:

• OK—To save the changes.
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• Cancel—To cancel the modifications.

• Apply — To apply the protocol settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See Updating
Devices for more information.

Table 90: OSPF Configuration Fields

Your ActionFunctionOption

OSPF
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Table 90: OSPF Configuration Fields (continued)

Your ActionFunctionOption

1. Enter the comment.Specifies the comment for OSPF.Comment

1. Specifywhether to enable or disable
OSPF.

• To enable OSPF, clear the check
box.

• To disable OSPF, select the check
box.

Specifies whether to disable the OSPF
configuration.

Disable

1. Enter the prefix export limit or select
from the list.

Configure a limit to the number of
prefixes to be exported.

Prefix Export Limit

1. Select rib group from the list.Specifies the routing table group.Rib Group

1. Select route type community from
the list.

Specifies an extended community value
to encode the OSPF route type

Route Type Community

1. Enter the domain VPN tag or select
from the list.

Virtual private network (VPN) tag for
OSPFv2 external routes generated by
the provider edge (PE) router.

Domain VPN Tag

1. Enter the preference or select from
the list.

Specifies the route preference for OSPF
internal routes.

Preference

1. Enter the external route preference
or select from the list.

Specifies the external route preference.External Preference

1. Enter the reference bandwidth.Specifies the reference bandwidth used
in calculating the default interface cost.

Reference Bandwidth

1. Specify whether to configure RFC
1583.

• To enable compatibility with RFC
1583, clear the check box.

• To disable compatibility with RFC
1583, select the check box.

Disable compatibility with RFC 1583.
Disabling compatibility with RFC 1583
can prevent routing loops.

No RFC 1583

1. Specify whether NSSA ABR has to
be configured.

• To enable NSSA ABR, clear the
check box.

• To disable NSSA ABR, select the
check the check box.

Disable compatibility with NSSA ABR.No NSSA ABR

1. Expand theOSPF tree and select
Area.

2. Set up the area range, interface,
sham link remote, stub and virtual
link.

Enables you to set up the area details
for OSPF.

Area
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Table 90: OSPF Configuration Fields (continued)

Your ActionFunctionOption

1. Expand theOSPF tree and select
Domain ID.

2. Specify the domain ID.

Enables you to configure domain ID for
the OSPF.

Domain ID

1. Expand theOSPF tree and select
Export.

2. Specify the export policies.

Enablesyou tospecify theexportpolicies
to be configured on the peer.

Export

1. Expand theOSPF tree and select
Graceful Restart.

2. Set up the graceful restart
parameters.

Enables you to specify the graceful
restart parameters for OSPF.

Graceful Restart

1. Expand theOSPF tree and select
Import.

2. Specify the import policies.

Enables you to specify the import
policies to be configured on the peer.

Import

1. Expand theOSPF tree and select
Overload.

2. Specify the comment and timeout.

Enables you to configure the local router
so that it appears to be overloaded. You
might do this when you want the router
to participate in OSPF routing, but do
not want it to be used for transit traffic.

Overload

1. Expand theOSPF tree and select
Sham Link.

2. Enable the feature and specify the
comment and local address.

Enables you to configure the local
endpoint of a sham link.

Sham Link

1. Expand theOSPF treeandselectSPF
Options.

2. Specify the comment, delay,
holddown and rapid runs.

Enables you to configure options for
running the shortest-path-first (SPF)
algorithm. You can configure a delay for
when to run the SPF algorithm after a
network topology change is detected,
themaximum number of times the SPF
algorithm can run in succession, and a
holddown interval after the SPF
algorithm runs themaximumnumber of
times.

SPF Options

1. Expand theOSPF tree and select
Traceoptions.

2. Expand theTraceoptions treeandset
up the file and flag parameters.

Enables you to configure OSPF protocol
level tracing options.

Traceoptions
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Configuring RIP (NSMProcedure)

Routing Information Protocol (RIP) is an interior gateway protocol (IGP) typically used

in small, homogeneous networks. RIP uses distance-vector routing to route information

through IP networks. Distance-vector routing requires that each device simply informs

its neighbors of its routing table. For each network path, the receiving device picks the

neighbor advertising the lowest metric, then adds this entry into its routing table for

readvertisement. Any host that uses RIP is assumed to have interfaces to one or more

networks. These networks are considered to be directly connected networks. RIP relies

on access to certain information about each of these networks. Themost important

information is the network's metric. RIP uses the hop count as the metric (also known

as cost) to compare the value of different routes. The hop count is the number of devices

that data packets must traverse between RIP networks.

To configure RIP in NSM:

1. In the navigation tree select DeviceManager > Devices .

2. In the Devices list, double click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand Protocols and select Rip.

5. Add/Modify the parameters under the respective tabs as specified in Table 91 on

page 160.

6. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply — To apply the protocol settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See Updating
Devices for more information.

Table 91: RIP Configuration Fields

Your ActionFunctionOption

RIP
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Table 91: RIP Configuration Fields (continued)

Your ActionFunctionOption

1. Enter the comment.Specifies the comment for RIP.Comment

1. Specify the metric to add incoming
routes.

Specifies the metric to add to incoming
routes when advertising into RIP routes
that were learned from other protocols.

Metric In

1. Enter themessagesizeor select from
the list.

Specifies the number of route entries to
be included in every RIP update
message.

Message Size

1. Enter the hold down value or select
from the list.

Timeperiod theexpired route is retained
in the routing table before being
removed.

Hold Down

1. Enter the route timeout or select
from the list.

Specifies the route timeout interval for
RIP.

Route Timeout

1. Enter the update interval or select
from the list.

Enables you to configureanupdate time
interval to periodically send out routes
learned by RIP to neighbors.

Update Interval

1. Select authentication type from the
list.

The type of authentication for RIP route
queries received on an interface.

Authentication Type

1. Enter the authentication key.Authentication key for RIP route queries
received on an interface.

Authentication Key

1. Expand the RIP tree and select
Graceful Restart.

2. Enable the feature and set up the
graceful restart parameters.

Enables you to specify the graceful
restart parameters for RIP.

Graceful Restart

1. ExpandtheRIP treeandselectGroup.

2. Click the New button or select a
group and click Edit button.

3. Set up the Bfd Liveness Detection ,
Export, Import and Neighbor for RIP.

RIPneighbors that shareanexportpolicy
andmetric. Theexportpolicyandmetric
govern what routes to advertise to
neighbors in a given group.

Group

1. Expand the RIP tree and select
Import.

2. Specify the import policies.

Enables you to specify the import
policies to be configured on the peer.

Import

1. Expand the RIP tree and select
Receive.

2. Specify the receive options.

Enables you to configure RIP receive
options.

Receive
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Table 91: RIP Configuration Fields (continued)

Your ActionFunctionOption

1. Expand the RIP tree and select Rib
Group.

2. Specify the comment and ribgroup
name.

The routing table group.RIB Group

1. Expand theRIP tree and selectSend.

2. Specify the send options.

Enables you to configure RIP send
options.

Send

1. Expand the RIP tree and select
Traceoptions.

2. Expand theTraceoptions treeandset
up the file and flag parameters.

Enables you to configure RIP protocol
level tracing options.

Traceoptions

Configuring RIPng (NSMProcedure)

TheRouting InformationProtocol next generation (RIPng) is an interior gatewayprotocol

(IGP) that uses a distance-vector algorithm to determine the best route to a destination,

using the hop count as the metric. RIPng is a routing protocol that exchanges routing

information used to compute routes and is intended for Internet Protocol version 6

(IPv6)-based networks.

To configure RIPng:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure RIPng.

3. Click the Configuration tab. In the configuration tree, select Protocols > Ripng.

4. Configure settings as described in Table 92 on page 162.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the RIPng parameters.

Table 92: RIPng Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the RIPng
protocol.

Comment

Enter themetric value.Rangevary from1 through
15.

Specifies the metric value to add to incoming
routes.

Metric In
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Table 92: RIPng Configuration Details (continued)

Your ActionFunctionOption

Enter the hold-down time. Range vary from 10
through 180.

Specifies theestimated time towaitbeforemaking
updates to the routing table.

Holddown

Enter the route time out. Range vary from 30
through 360.

Specifies the delay before routes time out.Route Timeout

Enter the update interval time. Range vary from
10 through 60.

Specifies the interval between regular route
updates.

Update Interval

This topic includes the following sub topics:

• Configuring Graceful Restart (NSM Procedure) on page 163

• Configuring Groups (NSM Procedure) on page 164

• Configuring Import (NSM Procedure) on page 166

• Configuring Receive (NSM Procedure) on page 166

• Configuring Send (NSM Procedure) on page 167

• Configuring Traceoptions (NSM Procedure) on page 167

Configuring Graceful Restart (NSMProcedure)

To configure graceful restart:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure graceful restart.

3. Click theConfiguration tab. In theconfiguration tree, selectProtocols>Ripng>Graceful

Restart.

4. SelectEnableFeature toenable thecheckbox. This allows toconfiguregraceful restart.

5. Enter a descriptive comment for the graceful restart in Comment.

6. Select Disable to disable graceful restart.

7. Enter the time after which RIPng is declared out of restart in Restart Time. Range vary

from 1 through 600.

8. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the graceful restart parameters.

163Copyright © 2013, Juniper Networks, Inc.

Chapter 12: Configuring Protocols for J Series Services Routers and SRX Series Services Gateways



Configuring Groups (NSMProcedure)

To configure groups:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure groups.

3. Click theConfiguration tab. In the configuration tree, selectProtocols>Ripng>Group.

4. Click + to configure groups as described in Table 93 on page 164.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the groups parameters.

Table 93: Groups Configuration Details

Your ActionFunctionOption

Ripng > Group

Enter the group name.Specifies the group name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the
RIPng group.

Comment

Enter the route time out value. Range vary from 30
through 360.

Specifies delay before routes time out.Route Timeout

Enter the update interval time. Range vary from 10
through 60.

Specifies the interval between regular route
updates.

Update Interval

Enter the preference. Range vary from 0 through
4,294,967,295.

Specifies the preference of route learned
from this group.

Preference

Enter the metric out value. Range vary from 1 through
15.

Specifies the default route of exported
routes.

Metric Out

Ripng > Group > Export

Click Add or Remove to add/remove non-members to
members andmembers to non-members.

NOTE: Select all (required) records and click Add All
or Remove Allwhich will add the selected records to
members or remove the selected records to
non-members.

Adds or removes non-members to or from
members list.

Non-members /
Members

Ripng > Group > Import
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Table 93: Groups Configuration Details (continued)

Your ActionFunctionOption

Click Add or Remove to add/remove non-members to
members andmembers to non-members.

NOTE: Select all (required) records and click Add All
or Remove Allwhich will add the selected records to
members or remove the selected records to
non-members.

Adds or removes non-members to or from
members list.

Non-members /
Members

Ripng > Group > Neighbor

Enter the neighbor interface name.Specifies the neighbor interface name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the
neighbor interface name.

Comment

Enter the route time out value. Range vary from 30
through 360.

Specifies delay before routes time out.Route Timeout

Enter the update interval time. Range vary from 10
through 60.

Specifies the interval between regular route
updates.

Update Interval

Enter the metric value. Range vary from 1 through 15.Specifies the metric value to add to
incoming routes.

Metric In

Ripng > Group > Neighbor > Import

Click Add or Remove to add/remove non-members to
members andmembers to non-members.

NOTE: Select all (required) records and click Add All
or Remove Allwhich will add the selected records to
members or remove the selected records to
non-members.

Adds or removes non-members to or from
members list.

Non-members /
Members

Ripng > Group > Neighbor > Receive

(Optional) Enter a comment.Supplies a descriptive comment for the
neighbor receive update.

Comment

Select the check box to enable this feature.Specifies not to receive any RIPng packets.None

Ripng > Group > Neighbor > Send

(Optional) Enter a comment.Supplies a descriptive comment for the
neighbor send update.

Comment

Select the check box to enable this feature.Specifies not to send any RIPng packets.None
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Configuring Import (NSMProcedure)

To import members:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

import members.

3. Click theConfiguration tab. In the configuration tree, selectProtocols>Ripng> Import.

4. Select the non-members from Non-members.

5. Click Add or Remove to add/remove non-members to members andmembers to

non-members.

NOTE: Select all (required) records and click Add All or Remove Allwhich

will add the selected records tomembers or remove the selected records
to non-members.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the import parameters.

Configuring Receive (NSMProcedure)

To configure receive RIPng packets:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure receive RIPng packets.

3. Click theConfiguration tab. In theconfiguration tree, selectProtocols>Ripng>Receive.

4. Enter a descriptive comment for receiving RIPng packets in Comment.

5. Select None to not to receive any RIPng packets.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the receive parameters.
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Configuring Send (NSMProcedure)

To configure send RIPng packets:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure send RIPng packets.

3. Click the Configuration tab. In the configuration tree, select Protocols > Ripng > Send.

4. Enter a descriptive comment for sending RIPng packets in Comment.

5. Select None to not to send any RIPng updates.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the send parameters.

Configuring Traceoptions (NSMProcedure)

To configure traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure traceoptions.

3. Click the Configuration tab. In the configuration tree, select Protocols > Ripng >

Traceoptions.

4. Enter a comment for the traceoptions in Comment.

5. Configure traceoptions as described in Table 94 on page 167.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the traceoptions parameters.

Table 94: Traceoptions Configuration Details

Your ActionFunctionOption

Msdp > Traceoptions > File

(Optional) Enter a comment.Suppliesadescriptivecomment for the file traceoption.Comment

Enter the filename.Specifies the name of file in which to write trace
information.

Filename

Enter the maximum trace file size.Specifies the maximum trace file size.Size
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Table 94: Traceoptions Configuration Details (continued)

Your ActionFunctionOption

Enter the maximum number of trace files.Specifies the maximum number of trace files.Files

Select an option.Specifies file restriction access.
no-world-readable—restricts file access to owner.
world-readable—enables unrestricted file access.

world-readable /
no-world-readable

Msdp > Traceoptions > Flag

Enter a flag traceoption name.Specifies the flag traceoptions name.Name

(Optional) Enter a comment.Supplies a descriptive comment for flag traceoptions.Comment

Select the check box to enable this feature.Specifies to enable the trace transmitted packets.Send

Select the check box to enable this feature.Specifies to enable the trace received packets.Receive

Select the check box to enable this feature.Specifies to enable the trace detailed information.Detail

Select the check box to enable this feature.Specifies to disable the trace flag.Disable

Related
Documentation

Configuring MSDP (NSM Procedure) on page 144•

• Configuring Static Label Switched Path (NSM Procedure) on page 139

• Configuring Path MTU (NSM Procedure) on page 138

Configuring Router Advertisement (NSMProcedure)

To configure router advertisement:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure router advertisement.

3. Click the Configuration tab. In the configuration tree, select Protocols > Router

Advertisement.

4. Enter a descriptive comment for the router advertisement in Comment.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the router advertisement parameters.
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Table 95: Router Advertisement Configuration Details

Your ActionFunctionOption

Router Advertisement > Interface

Enter a router advertisement
interface name.

Specifies the router advertisement interface name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the router
advertisement interface.

Comment

Enter the maximum
advertisement interval time.
Range vary from4 through 1,800.

Specifies the maximum advertisement interval.Max Advertisement Interval

Enter theminimumadvertisement
interval time. Range vary from 3
through 1,350.

Specifies the minimum advertisement interval.Min Advertisement Interval

Select an option.Specifies whether to enable the host to use a stateful
auto configuration protocol for address auto
configuration, along with any stateless auto
configuration already configured or not.

• managed-configuration—Enableshost touse stateful
auto configuration.

• no-managed-configuration—Disableshost fromusing
stateful auto configuration.

managed-configuration /
no-managed-configuration

Select an option.Specifieswhether to enable auto configuration of other
non address-related information or not.

• other-stateful-configuration—Enables auto
configuration of other non address-related
information.

• no-other-stateful-configuration—Disables auto
configuration of other non address-related
information.

other-stateful-configuration /
no-other-stateful-configuration

Select an option.Specifieswhether to include themaximumtransmission
unit (MTU) option in router advertisement messages
or not.

• link-mtu—Includes the MTU option in router
advertisements.

• no-link-mtu—Does not include the MTU option in
router advertisements.

link-mtu / no-link-mtu

Enter the reachable time. Range
vary from 0 through 3,600,000.

Specifies the length of time that a node considers a
neighbor reachable, until another reachability
confirmation is received from that neighbor.

Reachable Time

Enter the retransmit time. Range
vary from 0 through
4,294,967,295.

Specifies the retransmission frequency of neighbor
solicitation messages.

Retransmit Timer
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Table 95: Router Advertisement Configuration Details (continued)

Your ActionFunctionOption

Select the check box to enable
this feature.

Specifies that router advertisements are sent only for
virtual router redundancy protocol (VRRP) IPv6 groups
configured on the interface (if the groups are in the
master state.

Virtual Router Only

Enter the current hop limit value.
Range vary from 0 through 255.

Specifies thedefault valueplaced in the hop count field
of the IP header for outgoing packets.

Current Hop Limit

Enter a default lifetime value.
range vary from0 through 9,000.

Specifies the lifetime associated with a default router.Default Lifetime

Router Advertisement > Interface > Prefix

Enter a prefix name.Name of the prefix to be advertised.Name

(Optional) Enter a comment.Supplies a descriptive comment for the prefix router
advertisement.

Comment

Enter the valid lifetime value.
Range vary from 0 through
4,294,967,295.

Specifies how long the prefix remains valid for on-link
determination.

Valid Lifetime

Select an option.Specifies whether to enable prefixes to be used for
on-link determination or not.

• on-link—Enables prefixes to be used for on-link
determination.

• no-on-link—Disables prefixes from being used for
on-link determination.

on-link / no-on-link

Enter the preferred lifetime value.
Range vary from 0 through
4,294,967,295.

Specifies the duration of the prefix generated by
stateless auto configuration that remains preferred.

Preferred Lifetime

Select an option.Specifies whether prefixes in the router advertisement
messages are used for stateless address auto
configuration or not.

• autonomous—Uses prefixes for address auto
configuration.

• no-autonomous—Does not use prefixes for address
auto configuration.

autonomous / no-autonomous

Router Advertisement > Traceoptions

(Optional) Enter a comment.Supplies a descriptive comment for the traceoption.Comment

Router Advertisement > Traceoptions > File

(Optional) Enter a comment.Suppliesadescriptivecomment for the file traceoption.Comment

Enter the filename.Specifies the name of file in which to write trace
information.

Filename

Copyright © 2013, Juniper Networks, Inc.170

Configuring J Series Services Routers and SRX Series Services Gateways Guide



Table 95: Router Advertisement Configuration Details (continued)

Your ActionFunctionOption

Enter themaximumtrace file size.Specifies the maximum trace file size.Size

Enter the maximum number of
trace files.

Specifies the maximum number of trace files.Files

Select an option.Specifies file restriction access.
no-world-readable—restricts file access to owner.
world-readable—enables unrestricted file access.

world-readable /
no-world-readable

Router Advertisement > Traceoptions > Flag

Enter a flag traceoption name.Specifies the flag traceoption name.Name

(Optional) Enter a comment.Suppliesadescriptivecomment for the flag traceoption.Comment

Related
Documentation

Configuring MSDP (NSM Procedure) on page 144•

• Configuring RIPng (NSM Procedure) on page 162

Configuring Router Discovery (NSMProcedure)

Router discovery uses Internet Control Message Protocol (ICMP) router advertisements

and router solicitationmessages to allowa host to discover the addresses of operational

routers on the subnet. Hosts must discover routers before they can send IP datagrams

outside their subnet. Router discovery allows a host to discover the addresses of

operational routers on the subnet.

To configure router discovery:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure router discovery.

3. Click theConfiguration tab. In theconfiguration tree, selectProtocols>RouterDiscovery.

4. Enter a descriptive comment for the router discovery in Comment.

5. Select Disable to disable router discovery.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the router discovery parameters.
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Table 96: Router Discovery Configuration Details

Your ActionFunctionOption

Router Discovery > Address

Enter the IP address name.Specifies the Internet Protocol (IP) addresses to
include in router advertisements.

Name

(Optional) Enter a comment.Supplies a descriptive comment for the router
discovery address.

Comment

Select the check box to enable this feature.Specifies to advertise the IP address.Advertise

Select the check box to enable this feature.Specifies not to advertise the IP address.Ignore

Select the check box to enable this feature.Specifies to include IP address only in broadcast
advertisements.

Broadcast

Select the check box to enable this feature.Specifies to include IP address only in multicast
advertisements.

Multicast

Select the check box to enable this feature.Specifies that the IP address can never become a
default router.

Ineligible

Enter the preference level. Range vary from
-2,147,483,648 through 2,147,483,648.

Specifies thepreferenceof the IPaddress tobecome
a default router.

Priority

Router Discovery > Interface

Enter the interface name.Specifies the interface name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the router
discovery interface.

Comment

Enter the maximum advertisement interval
time. Range vary from 4 through 1,800.

Specifies the maximum time before sending
advertisements.

Max Advertisement
Interval

Enter the minimum advertisement interval
time. Range vary from 3 through 1,800.

Specifies the minimum time before sending
advertisements.

Min Advertisement
Interval

Enter the time duration until the addresses in
advertisements are valid. Range vary from 3
through 9,000.

Specifies how long the addresses in advertisements
are valid.

Lifetime

Router Discovery > Traceoptions

(Optional) Enter a comment.Supplies a descriptive comment for the traceoption.Comment

Router Discovery > Traceoptions > File

(Optional) Enter a comment.Supplies a descriptive comment for the file
traceoption.

Comment

Enter the filename.Specifies the name of file in which to write trace
information.

Filename
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Table 96: Router Discovery Configuration Details (continued)

Your ActionFunctionOption

Enter the maximum trace file size.Specifies the maximum trace file size.Size

Enter the maximum number of trace files.Specifies the maximum number of trace files.Files

Select an option.Specifies file restriction access.
no-world-readable—restricts file access to owner.
world-readable—enables unrestricted file access.

world-readable /
no-world-readable

Router Discovery > Traceoptions > Flag

Enter a flag traceoption name.Specifies the flag traceoption name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the flag
traceoption.

Comment

Related
Documentation

Configuring Router Advertisement (NSM Procedure) on page 168•

• Configuring RIPng (NSM Procedure) on page 162

Configuring VSTP (NSMProcedure)

VLAN Spanning Tree Protocol (VSTP) is a spanning tree protocol which creates a

loop-free topology in VLANs. VSTPmaintains a separate spanning tree instance for each

VLAN. Different VLANs can use different spanning tree paths and VSTP can support up

to 4094 different spanning tree topologies.

To configure VSTP in NSM:

1. In the navigation tree select DeviceManager > Devices and select the device from the

list.

2. In the configuration tree, expand Protocols.

3. Select VSTP.

4. Add/Modify the parameters under the respective tabs as specified in Table 97 on

page 174.

5. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply — To apply the protocol settings.
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NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See Updating
Devices for more information.

Table 97: VSTP Configuration Fields

Your ActionFunctionField

VSTP

1. Expand the Protocol tree and select
VSTP.

2. Enter the comment.

Specifies comment for OSPF.Comment

1. Expand the Protocol tree and select
VSTP.

2. Specify whether to disable VSTP.

Specifies whether to disable the VSTP
configuration.

Disable

1. Expand the Protocol tree and select
VSTP.

2. Enter the bridge priority.

The bridge priority determines which
bridge is electedas the rootbridge. If two
bridges have the same path cost to the
root bridge, the bridge priority
determines which bridge becomes the
designated bridge for a LAN segment.

Bridge Priority

1. Expand the Protocol tree and select
VSTP.

2. Enter themax age or select from the
list.

Specifies the maximum age of received
protocol BPDUs.

Max Age

1. Expand the Protocol tree and select
VSTP.

2. Enter the hello time or select from
the list.

The time interval atwhich the rootbridge
transmits configuration BPDUs.

Hello Time

1. Expand the Protocol tree and select
VSTP.

2. Enter the forward delay time or
select from the list.

Specifies how long a bridge interface
remains in the listening and learning
states before transitioning to the
forwarding state.

Forward Delay

1. Expand the Protocol tree.

2. Select VSTP and expand the tree.

3. Select Interfaces.

4. Set up the priority, cost, mode, edge
andspecifywhether the interfacehas
to be disabled.

Specifies the interface to be associated
with VSTP.

Interface
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Table 97: VSTP Configuration Fields (continued)

Your ActionFunctionField

1. Expand the Protocol tree.

2. Select VSTP and expand the tree.

3. Select Traceoptions.

4. Set up the file and flag parameters.

Enables you to configure VSTP level
tracing options.

Traceoptions

Configuring VRRP (NSMProcedure)

Virtual Router Redundancy Protocol (VRRP) prevents loss of network connectivity to

end hosts if the static default IP gateway fails. By implementingVRRP, you candesignate

a number of routers as backup routers in the event that the default master router fails.

VRRPfully supportsVirtual LocalAreaNetworks (VLANs)andstackedVLANs(S-VLANs).

In case of a failure, VRRP dynamically shifts the packet-forwarding responsibility to a

backup router. VRRP creates a redundancy schemewhich enables hosts to keep a single

IP address for the default gateway butmaps the IP address to awell-known virtual MAC

address. VRRP provides this redundancy without user intervention or additional

configuration at the end hosts.

To configure VRRP in NSM:

1. In the navigation tree select DeviceManager > Devices and select the device from the

list.

2. In the configuration tree, expand Protocols.

3. Select VRRP.

4. Add/Modify the parameters under the respective tabs as specified in Table 98 on

page 175.

5. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply — To apply the protocol settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See Updating
Devices for more information.

Table 98: VRRP Configuration Fields

Your ActionFunctionField

VRRP
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Table 98: VRRP Configuration Fields (continued)

Your ActionFunctionField

1. Expand the Protocol tree and select
VRRP.

2. Enter the comment.

Specifies comment for VRRP.Comment

1. Expand the Protocol tree and select
VRRP.

2. Enter the startup silent period or
select from the list

Enables the system to ignore theMaster
Down Event when an interface
transitions fromthedisabledstate to the
enabled state. It avoidsan incorrect error
alarm caused by delay or interruption of
incoming VRRP advertisement packets
during the interface startup phase.

Startup Silent Period

1. Expand the Protocol tree.

2. Select VRRP and expand the tree.

3. Select Traceoptions.

4. Set up the file and flag parameters.

Enables you to configure VRRP level
tracing options.

Traceoptions
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CHAPTER 13

Configuring Security for J Series Services
Routers and SRX Series Services
Gateways

• Configuring Certificates (NSM Procedure) on page 177

• Configuring Firewall Authentication (NSM Procedure) on page 180

• Configuring a Flow (NSM Procedure) on page 181

• Configuring Forwarding Options (NSM Procedure) on page 187

• Configuring IKE (NSM Procedure) on page 188

• Configuring IPsec (NSM Procedure) on page 195

• Configuring a PKI (NSM Procedure) on page 201

• Configuring NAT (NSM Procedure) on page 206

Configuring Certificates (NSMProcedure)

The certificates feature allows you to configure the certification authority and local

certificate.

To configure certificates feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the certificates feature.

3. Click the Configuration tab. In the configuration tree, select Security > Certificates.

4. Configure the options as specified in Table 99 on page 178.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the certificates parameters.
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Table 99: Certificates Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the
certificates.

Comment

Set the maximum length of the certificate
path. Range: 0 - 15.

Specifies the maximum length of the certificate
path.

Path Length

Set the maximum number of certificates.
Range: 64 - 4,294,967,295.

Specifies themaximumnumber of certificates to
cache.

Maximum Certificates

Enter the cache size.Specifies the maximum size of certificate cache.Cache Size

Set the time to cache negative responses.
Range: 10 - 4,294,967,295.

Specifies (in seconds) the time to cache negative
responses.

Cache Timeout Negative

Set the number of retries. Range: 0 - 1080.Specifies the number of retry attempts for an
enrollment request.

Enrollment Retry

• Configuring Certification Authority (NSM Procedure) on page 178

• Configuring the Local Certificate (NSM Procedure) on page 179

Configuring Certification Authority (NSMProcedure)

To configure the certification authority feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the certification authority feature.

3. Click the Configuration tab. In the configuration tree, select Security > Certificates >

Certification Authority.

4. Add or modify settings as specified in Table 100 on page 178.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the certification authority settings.

Table 100: Certification Authority Configuration Details

Your ActionFunctionOption

Enter the certification authority profile name.Specifies the certification authority profile name.Name

Enter a comment.Supplies a descriptive comment for the certification
authority. This is optional.

Comment

Enter the certification authority name.Specifies the certification authority name.Ca Name
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Table 100: Certification Authority Configuration Details (continued)

Your ActionFunctionOption

Enter the path and the filename.Specifies the file fromwhich to read the certificate.File

Enter the path and the CRL filename.Specifies the file to read the CRL.Crl

Enter the enrollment URL.Specifies the enrollment URL.Enrollment Url

Enter the LDAP URL.Specifies the LDAP URL.Ldap Url

Select the encoding type from the list.Specifies the encoding to be used for the certificate or
CRL on disk.

Encoding

Configuring the Local Certificate (NSMProcedure)

To configure the local certificate feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the local certificate feature.

3. Click the Configuration tab. In the configuration tree, select Security > Certificates >

Local.

4. Add or modify settings as specified in Table 101 on page 179.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the local settings.

Table 101: Local Configuration Details

Your ActionFunctionOption

Enter a name.Specifies the name of the certificate.Name

(Optional) Enter a comment.Supplies a descriptive comment for the certificate.Comment

Enter a private key for the certificate.Specifies the certificate and the private key.Certificate

Related
Documentation

Configuring Firewall Authentication (NSM Procedure) on page 180•

• Configuring a Flow (NSM Procedure) on page 181

• Configuring Forwarding Options (NSM Procedure) on page 187
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Configuring Firewall Authentication (NSMProcedure)

To configure firewall authentication feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the firewall authentication feature.

3. Click the Configuration tab. In the configuration tree, select Security > Firewall

Authentication.

4. Enter a comment in the Firewall Authenticationworkspace that describes the firewall

authentication.

5. In the configuration tree, select Security > Firewall Authentication > Traceoptions.

6. Enter a comment in the Traceoptions workspace that describes the traceoptions.

7. In the configuration tree, select Security > Firewall Authentication > Traceoptions >

Flag.

8. Add or modify settings as specified in Table 102 on page 180.

9. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the traceoptions settings.

Table 102: Firewall Authentication Configuration Details

Your ActionFunctionOption

Select a flag name from the list.Specifies the trace flag name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the trace flag.Comment

Select the option.Specifies that the flag options does not belong to any of the
other options type such as terse, detail, or extensive.

None

Select the option.Specifies brief traceoptions information.Terse

Select the option.Specifies detailed traceoptions information.Detail

Select the option.Specifies extensive traceoptions information.Extensive

Related
Documentation

Configuring Certificates (NSM Procedure) on page 177•

• Configuring a Flow (NSM Procedure) on page 181

• Configuring Forwarding Options (NSM Procedure) on page 187
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Configuring a Flow (NSMProcedure)

The flow featureallows you to configurebridge, TCPMSS,TCPsession, and traceoptions.

To configure the flow feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the flow options.

3. Click the Configuration tab. In the configuration tree, select Security > Flow.

4. Configure the options as specified in Table 103 on page 181.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the flow parameters.

Table 103: Flow Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the flow
feature.

Comment

Select theAllowDns reply check box to enable
this feature.

Allowsunmatched incomingDNS replypackets.Allow Dns Reply

Set the timeout value for the route change.
Range: 6 - 1800.

Specifies the timeout value for route change to
nonexistence route.

Route Change Timeout

Select thesynchronized floodprotectionmode
from the list.

Specifies theTCPsynchronized flood-protection
mode.

Syn Flood Protection Mode

You can configure the following options:

• Configuring a Bridge (NSM Procedure) on page 181

• Configuring the TCPMSS Option (NSM Procedure) on page 182

• Configuring the TCP Session Option (NSM Procedure) on page 183

• Configuring Traceoptions (NSM Procedure) on page 184

Configuring a Bridge (NSMProcedure)

To configure a bridge option:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a bridge option.
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3. Click the Configuration tab. In the configuration tree, select Security > Flow > Bridge.

4. Configure the options as specified in Table 104 on page 182.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the bridge settings.

Table 104: Bridge Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Suppliesadescriptivecomment for thebridgeoption.Comment

Select the Block Non IP All check box to
enable this feature.

Specifies that all non-IP and non-ARP traffic,
includingbroadcastandmulticast trafficareblocked.

Block Non IP All

Select the Bypass Non IP Unicast check box
to enable this feature.

Allows all non-IP traffic that includes unicast traffic.Bypass Non IP Unicast

Bridge > No Packet Flooding

Select Enable Feature to enable this feature.Allows toenable the featureof setting theNoPacket
Flooding.

Enable Feature

(Optional) Enter a comment.Supplies a descriptive comment for the packet
flooding option.

Comment

Select the No Trace Route check box to
enable this feature.

Specifies that the ICMPmust not be sent to trigger
MAC learning.

No Trace Route

Configuring the TCPMSSOption (NSMProcedure)

To configure the TCPMSS option:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the TCPMSS option.

3. Click the Configuration tab. In the configuration tree, select Security > Flow > TcpMss.

4. Configure the options as specified in Table 105 on page 183.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the TCPMSS settings.
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Table 105: TCPMSS Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for TCPMSS.Comment

TcpMss > All Tcp

(Optional) Enter a comment.Supplies a descriptive comment for the all TCP
options.

Comment

Set the MSS value. Range: 64 - 65535.Specifies the maximum segment size for all TCP
options.

Mss

TcpMss > Gre In

Select theEnableFeature checkbox to enable
this feature.

Enables the received Generic Routing Encapsulation
(GRE) feature.

Enable Feature

(Optional) Enter a comment.Suppliesadescriptive comment for the receivedGRE.Comment

Set the MSS value. Range: 64 - 65535.Specifies themaximumsegment size for the received
GREs.

Mss

TcpMss > Gre Out

Select theEnableFeature checkbox to enable
this feature.

Enables the sent Generic Routing Encapsulation
(GRE) feature.

Enable Feature

(Optional) Enter a comment.Supplies a descriptive comment for the sent GREs.Comment

Set the MSS value. Range: 64 - 65535.Specifies the maximum segment size for the sent
GREs.

Mss

TcpMss > IPsec Vpn

Select theEnableFeature checkbox to enable
this feature.

Enables the IPsec VPN feature.Enable Feature

(Optional) Enter a comment.Supplies a descriptive comment for the IPsec VPN.Comment

Set the MSS value. Range: 64 - 65535.Specifies themaximumsegment size for IPsecVPNs.Mss

Configuring the TCP Session Option (NSMProcedure)

To configure the TCP session option:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the TCP session option.

3. Click the Configuration tab. In the configuration tree, select Security > Flow > Tcp

Session.

183Copyright © 2013, Juniper Networks, Inc.

Chapter 13: Configuring Security for J Series Services Routers and SRX Series Services Gateways



4. Configure the options as specified in Table 106 on page 184.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the TCP session settings.

Table 106: TCP Session Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the TCP
session.

Comment

Select the Rst Invalidate Session check box to
enable this feature.

Specifies that the session ends immediately on
receipt of the reset segment.

Rst Invalidate Session

Select the Rst Sequence Check check box to
enable this feature.

Enables checking of the sequence number in
the reset segment.

Rst Sequence Check

Select theNoSynCheck checkbox toenable this
feature.

Disables the creation-time synchronized flag
check.

No Syn Check

Select the Strict Syn Check check box to enable
this feature.

Enables the strict synchronized check.Strict Syn Check

Select the No Syn Check In Tunnel check box to
enable this feature.

Disables creation-time synchronized flag check
for tunnel packets.

No Syn Check In Tunnel

Select the No Sequence Check check box to
enable this feature.

Disables sequence-number checking.No Sequence Check

Set the timeout period when the initialization
fails. Range: 20 through 300.

Specifies the timeoutperiod for theTCPsession
when initialization fails.

Tcp Initial Timeout

Configuring Traceoptions (NSMProcedure)

The traceoptions feature allows you to configure file and flag options.

To configure the traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the traceoptions.

3. Click the Configuration tab. In the configuration tree, select Security > Flow >

Traceoptions.

4. Configure the options as specified in Table 107 on page 185.

5. Click one:

• OK—Saves the changes.
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• Cancel—Cancels the modifications.

• Apply—Applies the traceoptions settings.

Table 107: Traceoptions Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the
traceoptions.

Comment

Select the No Remote Trace check box to enable
this feature.

Disables remote tracing.No Remote Trace

Set the incoming rate for trace messages. Range:
0 - 4,294,967,295.

Specifies the limit for the incoming rateof trace
messages.

Rate Limit

You can now configure the following options:

• Configuring File Options (NSM Procedure) on page 185

• Configuring Flag Options (NSM Procedure) on page 186

• Configuring Packet Filter Options (NSM Procedure) on page 186

Configuring File Options (NSMProcedure)

To configure file options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the file options.

3. Click the Configuration tab. In the configuration tree, select Security > Flow >

Traceoptions > File.

4. Configure the file options as specified in Table 108 on page 185.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the file settings.

Table 108: File Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the filename.Comment

Enter a filename.Specifies the filename to write the traceoptions.Filename

Enter the maximum file size.Specifies the maximum size of the trace file.Size

Set themaximumnumberof the trace files.
Range: 2 - 1000.

Specifies the maximum number of the trace files.Files
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Table 108: File Configuration Details (continued)

Your ActionFunctionOption

Select the option.Specifies that neither theworld-readable nor the
no-world-readable option is enabled.

None

(Optional) Select the option.Allows any user to read the log file.world-readable

(Optional) Select the option.Prevents any user from reading the log file.no-world-readable

Enter the match expression.Specifies the regular expression for the lines to be
logged.

Match

Configuring Flag Options (NSMProcedure)

To configure flag options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the flag options.

3. Click the Configuration tab. In the configuration tree, select Security > Flow >

Traceoptions > Flag.

4. Add or modify settings as specified in Table 109 on page 186.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the flag settings.

Table 109: Flag Configuration Details

Your ActionFunctionOption

Select a name from the list.Specifies the trace flag name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the trace flag.Comment

Configuring Packet Filter Options (NSMProcedure)

To configure packet filter options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the packet filter options.

3. Click the Configuration tab. In the configuration tree, select Security > Flow >

Traceoptions > Packet Filter.
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4. Add or modify settings as specified in Table 110 on page 187.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the packet filter settings.

Table 110: Packet Filter Configuration Details

Your ActionFunctionOption

Enter a name.Specifies the trace packet filter name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the packet
filter.

Comment

Select the protocol type from the list.Specifies the match IP protocol type.Protocol

Enter the source IPv4 address prefix.Specifies the source IPv4 address prefix.Source Prefix

Enter the destination IPv4 address prefix.Specifies the destination IPv4 address prefix.Destination Prefix

Select the source port from the list.Specifies the match TCP/UDP source port.Source Port

Select the destination port from the list.Specifies the match TCP/UDP destination port.Destination Port

Select the interface from the list.Specifies the logical Interface.Interface

Related
Documentation

Configuring Certificates (NSM Procedure) on page 177•

• Configuring Firewall Authentication (NSM Procedure) on page 180

• Configuring Forwarding Options (NSM Procedure) on page 187

Configuring Forwarding Options (NSMProcedure)

To configure forwarding options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure forwarding options.

3. Click the Configuration tab. In the configuration tree, select Security > Forwarding

Options.

4. Enter a comment in the ForwardingOptionsworkspace that describes the forwarding

options.

5. In the configuration tree, select Security > Forwarding Options > Family.

6. Enter a comment in the Family workspace that describes the family.
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7. Configure the options as specified in Table 111 on page 188.

8. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the forwarding options.

Table 111: Forwarding Options Configuration Details

Your ActionFunctionOption

Family > Inet6

(Optional) Enter a comment.Supplies a descriptive comment for the IPv6 traffic.Comment

Select the forwarding mode from the list.Specifies the IPv6 traffic forwarding mode.Mode

Family > Iso

(Optional) Enter a comment.Supplies a descriptive comment for the Intermediate
System-to-Intermediate System (IS-IS) protocol
traffic.

Comment

Select the forwarding mode from the list.Specifies the iso forwarding mode.Mode

Family >Mpls

(Optional) Enter a comment.Supplies a descriptive comment for the MPLS.Comment

Select the forwarding mode from the list.Specifies the MPLS forwarding mode.Mode

Related
Documentation

Configuring Certificates (NSM Procedure) on page 177•

• Configuring Firewall Authentication (NSM Procedure) on page 180

• Configuring a Flow (NSM Procedure) on page 181

Configuring IKE (NSMProcedure)

The InternetKeyExchange (IKE) featureallowsyou toconfiguregateway, policy, proposal,

respond to bad SPI, and traceoptions.

To configure the IKE feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure IKE options.

3. Click the Configuration tab. In the configuration tree, select Security > Ike.

Copyright © 2013, Juniper Networks, Inc.188

Configuring J Series Services Routers and SRX Series Services Gateways Guide



4. Enter a comment in the IKE workspace that describes the IKE.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the IKE parameters.

You can now configure the following options:

• Configuring a Gateway (NSM Procedure) on page 189

• Configuring a Policy (NSM Procedure) on page 191

• Configuring a Respond Bad SPI (NSM Procedure) on page 193

• Configuring Traceoptions (NSM Procedure) on page 193

Configuring a Gateway (NSMProcedure)

To configure the gateway option:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the gateway option.

3. Click the Configuration tab. In the configuration tree, select Security > Ike > Gateway.

4. Add or modify settings as specified in Table 112 on page 189.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the gateway settings.

Table 112: Gateway Configuration Details

Your ActionFunctionOption

gateway

Enter the gateway name.Specifies the gateway name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the
gateway.

Comment

Select the IKE policy from the list.Specifies the name of the IKE policy.Ike Policy

Select the NoNat Traversal check box to enable this
feature.

Disables the IPsec NAT traversal.No Nat Traversal

Set the time interval. Range: 1 - 300.Specifies the time interval to send the
keepalives.

Nat Keepalive
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Table 112: Gateway Configuration Details (continued)

Your ActionFunctionOption

Enter the external interface for the IKE negotiations.Specifies the external interface for the IKE
negotiations.

External Interface

gateway > Address

Select the option and add or modify the address.Specifies the address of the gateway.address

1. Select the option.

2. Select Dynamic and update the following:

• Comment—Supplies a descriptive comment.

• Connections limit—Specifies the maximum
number of users connected to the gateway.
Range: 0 - 4,294,967,295.

• Ike User Type—Specifies the IKE ID type.

3. Select Dynamic > Distinguished Name and select
any of the following:

• None—Specifies that neither distinguished name
nor hostname nor inet nor user-at-hostname is
specified.

• distinguished-name—Specifies the distinguished
namefor thegateway.Select theoptionandenter
the following:
• Comment—Supplies a descriptive comment
for the distinguished name.

• Container—Specifies the container text.

• Wildcard—Specifies the wildcard text.

• hostname—Specifies the hostname for the
gateway. Select the option and enter the
hostname.

Specifies a dynamic IPsec for gateway.dynamic

gateway > Dead Peer Detection

Select the Enable Feature check box to enable this
feature.

Enables the dead peer detection (DPD)
feature.

Enable Feature

(Optional) Enter a comment.Suppliesadescriptivecomment for theDPD.Comment

Select theAlwaysSendcheckbox toenable this feature.Specifies that the DPDmessages are sent
periodically, regardless of the traffic.

Always Send

Set the time interval tosend theDPDmessages.Range:
10 - 60.

Specifies the time interval to send the DPD
messages.

Interval

Set the threshold for DPD transmissions. Range: 1 - 5.Specifies the maximum number of DPD
transmissions.

Threshold

gateway > Local Identity
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Table 112: Gateway Configuration Details (continued)

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the
gateway local identity.

Comment

gateway > Local Identity > Inet

Select the option.Specifies that inet, hostname,
user-at-hostname, and distinguished-name
are not enabled.

None

Select the option.Specifies IPv4 traffic.inet

Select the option.Specifies the hostnamehostname

Select the option.Specifies the e-mail address.user-at-hostname

Select the option.Specifies the distinguished name.distinguished-name

gateway > Xauth

(Optional) Enter a comment.Supplies a descriptive comment for the
gateway authentication.

Comment

Select the access profile from the list.Specifies theaccessprofile that contains the
authentication information.

Access Profile

Configuring a Policy (NSMProcedure)

To configure the policy option:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the policy option.

3. Click the Configuration tab. In the configuration tree, select Security > Ike > Policy.

4. Add or modify settings as specified in Table 113 on page 191.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the policy settings.

Table 113: Policy Configuration Details

Your ActionFunctionOption

Policy

Enter the policy name.Specifies the name of the policy.Name
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Table 113: Policy Configuration Details (continued)

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the policy.Comment

Select the mode from the list.Defines the IKEmode for phase 1.Mode

Enter a Description.Specifies a text description for the IKE policy.Description

Select the proposal set from the list.Specifies the type of the default IKE proposal set.Proposal Set

Policy > Certificate

(Optional) Enter a comment.Supplies a descriptive comment for the certificate.Comment

Enter the local certificate identifier.Specifies the local certificate identifier.Local Certificate

Select the certificate type from the list.Specifies thepreferred typeof certificate frompeer.Peer Certificate Type

Policy > Certificate > Trusted Ca

(Optional) Enter a comment.Supplies a descriptive comment for the trusted
certification authority.

Comment

Policy > Certificate > Trusted Ca > Ca index

Select the option.Specifies thatneither theca-indexnoruseall option
is enabled.

None

Select the option and set the certificate
authority ID. Range: 0 - 4,294,967,295.

Specifies the preferred certificate authority ID for
the device to use.

ca-index

Select the option.Specifies that the device uses all configured CAs.use-all

Policy > Pre Shared Key

(Optional) Enter a comment.Supplies a descriptive comment for the preshared
key.

Comment

Policy > Pre Shared Key > Ascii Text

Select the option.Specifies thatneither theascii-textnorhexadecimal
key is enabled.

None

Select theoptionandenter theASCII text key.Enables the ASCII text key.ascii-text

Select the option and enter the hexadecimal
text key.

Enables the hexadecimal text key.hexadecimal

Policy > Proposals
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Table 113: Policy Configuration Details (continued)

Your ActionFunctionOption

Select the proposals from the nonmembers
list. Then click Add to move them to the
members list.

Specifies the members added as proposals.Proposals

Configuring a Respond Bad SPI (NSMProcedure)

To configure the respond bad SPI options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the respond bad SPI option.

3. Click the Configuration tab. In the configuration tree, select Security > Ike > Respond

Bad Spi.

4. Select the Enable Feature check box.

5. Configure the options as specified in Table 114 on page 193.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the respond bad SPI parameters.

Table 114: Respond Bad SPI Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the bad SPI.Comment

Set themaximumnumber of times to respond.
Range: 1 - 30.

Specifies the maximum number of times to
respond.

Max Responses

Configuring Traceoptions (NSMProcedure)

The traceoptions feature allows you to configure file and flag options.

To configure traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the traceoptions.

3. Click the Configuration tab. In the configuration tree, select Security > Ike >

Traceoptions.

4. Configure the options as specified in Table 115 on page 194.

5. Click one:
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• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the traceoptions settings.

Table 115: Traceoptions Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the
traceoptions.

Comment

Select the No Remote Trace check box.Disables remote tracing.No Remote Trace

You can now configure the following options:

• Configuring the File Options (NSM Procedure) on page 194

• Configuring Flag Options (NSM Procedure) on page 195

Configuring the File Options (NSMProcedure)

To configure file options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the file options.

3. Click theConfiguration tab. In theconfiguration tree, selectSecurity> Ike>Traceoptions

> File.

4. Configure the file options as specified in Table 116 on page 194.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the file settings.

Table 116: File Configuration Details

Your ActionFunctionOption

Enter a comment.Supplies a descriptive comment for the filename.Comment

Enter a filename.Specifies the filename to write the traceoptions.Filename

Enter the maximum file size.Specifies the maximum size of the trace file.Size

Set the maximum number of trace files.
Range: 2 - 1000.

Specifies the maximum number of trace files.Files

Select the option.Specifies that neither theworld-readable nor the
no-world-readable option is enabled.

None
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Table 116: File Configuration Details (continued)

Your ActionFunctionOption

(Optional) Select the option.Allows any user to read the log file.world-readable

(Optional) Select the option.Prevents any user from reading the log file.no-world-readable

Enter the match expression.Specifies the regular expression for the lines tobe logged.Match

Configuring Flag Options (NSMProcedure)

To configure flag options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the flag options.

3. Click theConfiguration tab. In theconfiguration tree, selectSecurity> Ike>Traceoptions

> Flag.

4. Add or modify setting as specified in Table 117 on page 195.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the flag settings.

Table 117: Flag Configuration Details

Your ActionFunctionOption

Select a name from the list.Specifies the trace flag name.Name

Enter a comment.Supplies a descriptive comment for the trace flag.Comment

Related
Documentation

Configuring IPsec (NSM Procedure) on page 195•

• Configuring a PKI (NSM Procedure) on page 201

• Configuring NAT (NSM Procedure) on page 206

Configuring IPsec (NSMProcedure)

The Internet Protocol Security (IPsec) feature allows you to configure policy, proposal,

traceoptions, VPN, and VPNmonitor options.

195Copyright © 2013, Juniper Networks, Inc.

Chapter 13: Configuring Security for J Series Services Routers and SRX Series Services Gateways



To configure the IPsec feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the IPsec feature.

3. Click the Configuration tab. In the configuration tree, select Security > IPsec.

4. Enter a comment in the IPsec workspace that describes the IPsec.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the IPsec parameters.

You can now configure the following options:

• Configuring a Policy (NSM Procedure) on page 196

• Configuring Traceoptions (NSM Procedure) on page 197

• Configuring a VPN (NSM Procedure) on page 198

• Configuring VPNMonitor Options (NSM Procedure) on page 200

Configuring a Policy (NSMProcedure)

To configure the policy option:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the policy option.

3. Click the Configuration tab. In the configuration tree, select Security > IPsec > Policy.

4. Add or modify settings as specified in Table 118 on page 196.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the policy settings.

Table 118: Policy Configuration Details

Your ActionFunctionOption

policy

Enter the policy name.Specifies the name of the policy.Name

(Optional) Enter a comment.Supplies a descriptive comment for the policy.Comment

Enter a description.Specifies a text description for the IPsec policy.Description
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Table 118: Policy Configuration Details (continued)

Your ActionFunctionOption

Select the proposal set from the list.Specifies the type of default IPsec proposal set.Proposal Set

policy > Perfect Forward Secrecy

Enter a comment.Supplies a descriptive comment for the perfect
forward secrecy option. This is optional.

Comment

Select the perfect forward Secrecy key from
the list.

Defines the Diffies-Hellman group.Keys

policy > Proposals

Select the proposals from the nonmembers
list. Then click Add to move them to the
members list.

Specifies the members added as proposals.Proposals

Configuring Traceoptions (NSMProcedure)

To configure traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the traceoptions.

3. Click the Configuration tab. In the configuration tree, select Security > IPsec >

Traceoptions.

4. Add or modify settings as specified in Table 119 on page 197.

5. Enter a comment in the Traceoptions workspace that describes the traceoptions.

6. In theConfiguration tab. In the configuration tree, selectSecurity> IPsec>Traceoptions

> Flag.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the traceoptions.

Table 119: Traceoptions Configuration Details

Your ActionFunctionOption

Select a name from the list.Specifies the trace flag name.Name

Enter a comment.Supplies a descriptive comment for the trace flag.Comment
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Configuring a VPN (NSMProcedure)

To configure a VPN:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a VPN.

3. Click the Configuration tab. In the configuration tree, select Security > IPsec > Vpn.

4. Add or modify settings as specified in Table 120 on page 198.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the VPN settings.

Table 120: VPN Configuration Details

Your ActionFunctionOption

vpn

Enter a name.Specifies the VPN name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the VPN.Comment

Enter the interface name.Specifies the bind to tunnel interface (route-based
VPN).

Bind Interface

Select the option from the list.Specifies how to handle the don’t fragment bit.Df Bit

Select the option from the list.Defines the criteria to establish tunnels.Establish Tunnels

vpn >Manual >manual > Authentication

(Optional) Enter a comment.Supplies a descriptive comment for the
authentication option.

Comment

Select the Algorithm from the drop-down
box.

Defines the authentication algorithm.Algorithm

vpn >Manual >manual > Authentication > Key

(Optional) Enter a comment.Specifies a descriptive comment for the
authentication key.

Comment

vpn >Manual >manual > Authentication > Key > Ascii Text

Select the option.Specifies that neither the ascii-text nor the
hexadecimal key is enabled.

None
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Table 120: VPN Configuration Details (continued)

Your ActionFunctionOption

Select the option and enter the ASCII text
key.

Enables the ASCII text key.ascii-text

Select theoptionandenter thehexadecimal
text key.

Enables the hexadecimal text key.hexadecimal

vpn >Manual >manual > Encryption

(Optional) Enter a comment.Supplies a descriptive comment for the encryption
option.

Comment

Select the Algorithm from the list.Defines the encryption algorithm.Algorithm

vpn >Manual >manual > Encryption > Key

(Optional) Enter a comment.Specifiesadescriptive comment for theencryption
key.

Comment

vpn >Manual >manual > Encryption > Key > Ascii Text

Select the option.Specifies that neither the ascii-text or hexadecimal
key is enabled.

None

Select the option and enter the ASCII text
key.

Enables the ASCII text key.ascii-text

Select theoptionandenter thehexadecimal
text key.

Enables the hexadecimal text key.hexadecimal

vpn >Manual > ike

Enter a comment.Specifies a descriptive comment for the IKE.Comment

Select the gateway from the list.Specifies the remote gateway name.Gateway

Set the idle time. Range: 60 - 999999.Specifies the idle time to remove Secure
Authentication (SA).

Idle Time

Select the No Anti Replay check box.Disable the snit-reply check.No Anti Replay

Select the IPsec policy from the list.Specifies the name of the IPsec policy.IPsec Policy

Set the duration of the installation. Range: 1
- 10.

Delays the installation of re-entered outboundSAs
on the initiator.

Install Interval

vpn >Manual > ike > Proxy identity

Select the Enable Feature check box to
enable this feature.

Enables the proxy identity feature.Enable Feature
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Table 120: VPN Configuration Details (continued)

Your ActionFunctionOption

(Optional) Enter a comment.Specifies a descriptive comment for the proxy
identity option.

Comment

Enter the IP address.Specifies the local IP address.Local

Enter the IP address.Specifies the remote IP address.Remote

Select the service from the list.Specifies the name of the service.Service

vpn > VpnMonitor

Select the Enable Feature check box to
enable this feature.

Allows to configure Vpnmonitor.Enable Feature

(Optional) Enter a comment.Specifies a descriptive comment for the VPN
monitor.

Comment

Select theOptimized check box to enable
this feature.

Specifies that the VPNmonitor is optimized for
scalability.

Optimized

Enter the source interface.Specifies source interface for monitor messages.Source Interface

Enter the destination IP address.Specifies destination IP address for monitor
messages.

Destination IP

Configuring VPNMonitor Options (NSMProcedure)

To configure VPNmonitor options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the VPNmonitor options.

3. Click the Configuration tab. In the configuration tree, select Security > IPsec > Vpn

Monitor Options.

4. Select the Enable Feature check box from the Vpn Monitor Options workspace.

5. Add or modify settings as specified in Table 121 on page 201.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the VPNmonitor options.
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Table 121: VPNMonitor Options Configuration Details

Your ActionFunctionOption

Enter a comment.Supplies a descriptive comment for the for the VPN
monitor options.

Comment

Set the interval duration. Range: 1 - 3600.Specifies (in seconds) the duration of monitoring
interval.

Interval

Set the threshold to determine connectivity.
Range: 1 - 65536.

Specifies the number of consecutive failures to
determine connectivity.

Threshold

Related
Documentation

Configuring IKE (NSM Procedure) on page 188•

• Configuring Forwarding Options (NSM Procedure) on page 187

• Configuring a Flow (NSM Procedure) on page 181

Configuring a PKI (NSMProcedure)

The Public Key Infrastructure (PKI) feature allows you to configure automatic

re-enrollment, Certificate Authority (CA) certificate, CA profile, certificate revocation list

(CRL), local certificate, and traceoptions.

To configure the PKI feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the PKI feature.

3. Click the Configuration tab. In the configuration tree, select Security > Pki.

4. Select the Enable Feature check box to enable this feature.

5. Enter a comment in the Pki workspace that describes the PKI.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the PKI parameters.

You can now configure the following options:

• Configuring Auto Re-enrollment (NSM Procedure) on page 202

• Configuring a CA Profile (NSM Procedure) on page 202

• Configuring Traceoptions (NSM Procedure) on page 204
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Configuring Auto Re-enrollment (NSMProcedure)

To configure the auto re-enrollment feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the auto re-enrollment feature.

3. Click the Configuration tab. In the configuration tree, select Security > Pki > Auto Re

Enrollment.

4. Enter a comment in the Auto Re Enrollment workspace that describes the auto

re-enrollment feature.

5. In the configuration tree, select Security > Pki > Auto Re Enrollment > Certificate Id.

6. Add or modify settings as specified in Table 122 on page 202.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the auto re-enrollment parameters.

Table 122: Auto Re-enrollment Configuration Details

Your ActionFunctionOption

Enter the name of the certificate ID.Specifies the name of the certificate ID.Name

Enter a comment.Specifies a descriptive comment for the certificate
ID.

Comment

Select the CA profile name from the list.Specifies the name of the CA profile.Ca Profile Name

Enter the password.Specifies the password used by the CA for
enrollment and revocation.

Challenge Password

Set the re-enrollment trigger time. Range:
1 - 99.

Specifies (in percentage) the re-enrollment trigger
time before the expiration.

Re Enroll Trigger Time
Percentage

Select the Re Generate Keypair check box
to enable this feature.

Generatesanewkeypair foranauto re-enrollment.Re Generate Keypair

Configuring a CA Profile (NSMProcedure)

The CA Profile feature allows you to configure the administrator, enrollment and

revocation list.
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To configure the CA profile:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the CA profile.

3. Click the Configuration tab. In the configuration tree, select Security > Pki > CaProfile.

4. Add or modify settings as specified in Table 123 on page 203.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the CA profile parameters.

Table 123: CA Profile Configuration Details

Your ActionFunctionOption

ca-profile

Enter the name of the CA profile.Specifies the name of the CA profile.Name

(Optional) Enter a comment.Supplies a descriptive comment for the CA profile.Comment

Enter the CA identifier.Specifies the CA identifier.Ca Identity

ca-profile > Administrator

(Optional) Enter a comment.Supplies a descriptive comment for the CA profile
administrator.

Comment

Enter the e-mail address.Specifies theadministratorsemail addresswhere the
certificate requests are sent.

Email Address

ca-profile > Enrollment

(Optional) Enter a comment.Supplies a descriptive comment for the CA profile
enrollment.

Comment

Enter the enrollment URL of the certificate
CA.

Specifies the enrollment URL of the certificate CA.Url

Set the permissible retry attempts. Range:
0 - 1080.

Specifies (in seconds) the number of permissible
enrollment retry attempts before terminating.

Retry

Set the enrollment retry interval. Range: 0 -
3600.

Specifies the amount of time between enrollment
retries.

Retry Interval

ca-profile > Revocation Check
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Table 123: CA Profile Configuration Details (continued)

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the revocation
check.

Comment

Select the Disable check box to disable this
feature.

Disables a revocation check.Disable

ca-profile > Revocation Check > Crl

(Optional) Enter a comment.Supplies a descriptive comment for the CRL.Comment

Set the CRL refresh interval. Range: 0
through 8784.

Specifies the CRL refresh interval.Refresh Interval

ca-profile > Revocation Check > Crl > Disable

(Optional) Enter a comment.Suppliesadescriptivecomment fordisabling theCRL.Comment

Select theOnDownload Failure check box
to enable this feature.

Disables the revocation check for the CRL download
failure.

On Download Failure

ca-profile > Revocation Check > Crl > Url

Enter the URL or CRL distribution point for
the CA.

Specifies theURLorCRLdistributionpoint for theCA.Name

Enter a comment. (Optional)Supplies a descriptive comment for the URL or CRL
distribution point for CA.

Comment

Enter the password.Specifies the password for authentication with the
server.

Password

Configuring Traceoptions (NSMProcedure)

The traceoptions feature allows you to configure the file and the flag options.

To configure traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the traceoptions.

3. Click the Configuration tab. In the configuration tree, select Security > Pki >

Traceoptions.

4. Configure the options as specified in Table 124 on page 205.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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• Apply—Applies the traceoptions settings.

Table 124: Traceoptions Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the
traceoptions.

Comment

Select the No Remote Trace check box to enable
this feature.

Disables remote tracing.No Remote Trace

You can now configure the following options:

• Configuring the File Options (NSM Procedure) on page 205

• Configuring Flag Options (NSM Procedure) on page 206

Configuring the File Options (NSMProcedure)

To configure the file options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the file options.

3. Click theConfiguration tab. In theconfiguration tree, selectSecurity>Pki>Traceoptions

> File.

4. Configure the file options as specified in Table 125 on page 205.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the file settings.

Table 125: File Configuration Details

Your ActionFunctionOption

Enter a comment.Supplies a descriptive comment for the filename.Comment

Enter a filename.Specifies the filename to write the traceoptions.Filename

Enter the maximum file size.Specifies the maximum size of the trace file.Size

Set the maximum number of trace files.
Range: 2 through 1000.

Specifies the maximum number of trace files.Files

Select the option.Specifies that neither theworld-readable nor the
no-world-readable option is enabled.

None

(Optional) Select the option.Allows any user to read the log file.world-readable
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Table 125: File Configuration Details (continued)

Your ActionFunctionOption

(Optional) Select the option.Prevents any user from reading the log file.no-world-readable

Enter the match expression.Specifies the regular expression for the lines tobe logged.Match

Configuring Flag Options (NSMProcedure)

To configure flag options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the flag options.

3. Click theConfiguration tab. In theconfiguration tree, selectSecurity>Pki>Traceoptions

> Flag.

4. Add or modify settings as specified in Table 126 on page 206.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the flag settings.

Table 126: Flag Configuration Details

Your ActionFunctionOption

Select a name from the list.Specifies the trace flag name.Name

Enter a comment.Supplies a descriptive comment for the trace flag.Comment

NOTE: You can also configure CA Certificates, CRLs, and Local Certificates
in PKI configuration.

Related
Documentation

Configuring IPsec (NSM Procedure) on page 195•

• Configuring IKE (NSM Procedure) on page 188

• Configuring NAT (NSM Procedure) on page 206

Configuring NAT (NSMProcedure)

The Network Address Translation (NAT) feature allows you to configure destination,

source NAT, destination NAT, interface, proxy ARP, source, static, and traceoptions.
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To configure the NAT feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the NAT.

3. Click the Configuration tab. In the configuration tree, select Security > Nat.

4. Enter a comment in the NATworkspace that describes the NAT.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the NAT settings.

You can now configure the following options:

1. Configuring a Destination (NSM Procedure) on page 207

2. Configuring Destination NAT (NSM Procedure) on page 208

3. Configuring the Interface (NSM Procedure) on page 210

4. Configuring a Proxy Address Resolution Protocol (NSM Procedure) on page 212

5. Configuring a Source (NSM Procedure) on page 213

6. Configuring the Source Nat (NSM Procedure) on page 216

7. Configuring the Static Nat (NSM Procedure) on page 217

8. Configuring Traceoptions (NSM Procedure) on page 218

Configuring a Destination (NSMProcedure)

To configure destination:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the destination.

3. Click theConfiguration tab. In theconfiguration tree, selectSecurity>Nat>Destination.

4. Configure the options as specified in Table 127 on page 207.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the destination parameters.

Table 127: Traceoptions Configuration Details

Your ActionFunctionOption

Destination > General
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Table 127: Traceoptions Configuration Details (continued)

Your ActionFunctionOption

(Optional) Enter a comment.Suppliesadescriptivecomment for thedestination.Comment

Destination > Pool > General

Enter a name.Specifies the name of the destination pool.Name

(Optional) Enter a comment.Suppliesadescriptive comment for thedestination
pool.

Comment

Destination > Pool > Routing Instance

(Optional) Enter a comment.Suppliesadescriptive comment for thedestination
pool.

Comment

Select the Ri Name from the list..Specifies the routing instance (RI) name.Ri Name

Destination > Pool > Address > IP Address

(Optional) Enter a comment.Suppliesadescriptive comment for thedestination
IP address.

Comment

Enter the IP address or an address range.Specifies the IP address or address range of the
destination pool.

IP Address

Destination > Pool > Address > To Range/Port

Select the option.Specifies that neither the destination address nor
the port option is selected.

None

Select the option and enter the following:

• Comment—A descriptive comment about
the destination address.

• To Address—The upper limit of the address
range.

Specifies the upper limit of the address range.To Address

Select the option and set the port. Range: 0 -
65535.

Specifies the port.port

Configuring Destination NAT (NSMProcedure)

To configure destination NAT:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the destination NAT.

3. Click theConfiguration tab. In the configuration tree, selectSecurity>Nat>Destination

Nat.
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4. Add or modify settings as specified in Table 128 on page 209.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the destination NAT settings.

Table 128: Destination NAT Configuration Details

Your ActionFunctionOption

destination-nat

Enter a name.Specifies a name for the destination
NAT.

Name

destination-nat > From

Select an option.Specifies the zone, routing instance or
the interface selected for the
destination NAT.

Zone/RI/Interface

Match

Select the option and enter the following:

• Comment—Descriptive comment for the destination
address.

• Prefix—Address prefix.

• Port—Port number.

Low—Lower limit of the address range.

High—Higher limit of the address range.

Specifies the source address for the
destination NAT.

Source Address

Select the option and enter the following:

• Comment—Descriptive comment for the address range.

• Address Object—Address object pushed to the global
address book.

• Port—Port number.

Low—Lower limit of the address range.

High—Higher limit of the address range.

Specifies the source address name of
the destination NAT.

Source Address Name

Either Destination Address or Destination Address Name
can be used for an instance.

Specifies thedestinationaddressof the
destination NAT.

Destination Address

Either Destination Address or Destination Address Name
can be used for an instance.

Specifies thedestinationaddressname
of the destination NAT.

Destination Address
Name

• Port—Port number.

Low—Lower limit of the address range.

High—Higher limit of the address range.

Destination Port

209Copyright © 2013, Juniper Networks, Inc.

Chapter 13: Configuring Security for J Series Services Routers and SRX Series Services Gateways



Table 128: Destination NAT Configuration Details (continued)

Your ActionFunctionOption

• None—Specifies that no option is selected.

• OFF—Specifies that the option is disabled.

• Pool—Specifies the NAT pool.

• Interface—Specifies the outgoing option.

Action

—Specifies the device on which the
rulebase is installed.

Install On

Configuring the Interface (NSMProcedure)

To configure the interface:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the interface feature.

3. Click the Configuration tab. In the configuration tree, select Security > Nat > Interface.

4. Add or modify the interface settings as specified in Table 129 on page 210.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the interface parameters.

Table 129: Interface Configuration Details

Your ActionFunctionOption

interface

Select the name from the drop-down list.Specifies the name of the interface.Name

(Optional) Enter a comment.Supplies a descriptive comment for the interface.Comment

Select the Allow Incoming check box to
enable this feature.

Allows the interface pool to support the incoming
traffic.

Allow Incoming

interface > Proxy Arp

(Optional) Enter a comment.Supplies a descriptive comment for the proxy
Address Resolution Protocol (ARP).

Comment

interface > Proxy Arp > Address

Enter the address prefix.Specifies the address prefix.Name

Copyright © 2013, Juniper Networks, Inc.210

Configuring J Series Services Routers and SRX Series Services Gateways Guide



Table 129: Interface Configuration Details (continued)

Your ActionFunctionOption

Enter a comment.Supplies a descriptive comment for the address
prefix. This is optional.

Comment

interface > Proxy Arp > Address Range

Enter the lower limit of the address range.Specifies the lower limit of the address range.Low

Enter the upper limit of the address range.Specifies the upper limit of the address range.High

(Optional) Enter a comment.Supplies a descriptive comment for the address
range.

Comment

interface > Source Nat

(Optional) Enter a comment.Supplies a descriptive comment for the source NAT.Comment

interface > Source Nat > Pool > pool

Enter the pool name.Specifies the pool name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the source NAT
pool.

Comment

Enter the lower limit of the host address.Specifies the lower limit of the host address.Host Address Low

Select the No Port Translation check box to
enable this feature.

Specifies that the port translation is not performed.No Port Translation

Select the Allow Incoming check box to
enable this feature.

Allows the pool to support incoming traffic.Allow Incoming

interface > Source Nat > Pool > pool > Address

Enter the address prefix.Specifies the address prefix.Name

(Optional) Enter a comment.Supplies a descriptive comment for the address.Comment

interface > Source Nat > Pool > pool > Address Range

Enter the lower limit of the address range.Specifies the lower limit of the address range.Low

Enter the upper limit of the address range.Specifies the upper limit of the address range.High

(Optional) Enter a comment.Supplies a descriptive comment for the address
range.

Comment

interface > Source Nat > Pool > pool >Overflow Pool
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Table 129: Interface Configuration Details (continued)

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the overflow
pool.

Comment

interface > Source Nat > Pool > pool >Overflow Pool > Pool Name

Select the option.Specifies thatneither thepool-nameor the interface
options are enabled.

None

Select the option and enter the pool name.Specifies the overflow pool name.pool-name

Select the option.Specifies the overflow pool interface.interface

interface > Static Nat

Enter the mapped address.Specifies the name of the static NAT.Name

(Optional) Enter a comment.Supplies a descriptive comment for the static NAT.Comment

Enter the host address.Specifies the host address.Host

Select the virtual router from the list.Specifies the virtual router to search route to host
address.

Virtual Router

Configuring a Proxy Address Resolution Protocol (NSMProcedure)

To a configure proxy Address Resolution Protocol (ARP):

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a proxy ARP.

3. Click theConfiguration tab. In the configuration tree, select Security>Nat> ProxyArp.

4. Configure the options as specified in Table 130 on page 212.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the proxy ARP options.

Table 130: Proxy ARP Configuration Details

Your ActionFunctionOption

General

(Optional) Enter a comment.Supplies a descriptive comment for the proxy ARP.Comment
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Table 130: Proxy ARP Configuration Details (continued)

Your ActionFunctionOption

Interface > interface

Enter the proxy ARP interface name.Specifies the proxy ARP interface name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the proxy ARP
interface.

Comment

Interface > interface > Address

Enter the proxy ARP interface address or
address range.

Specifies the proxy ARP address.Name

(Optional) Enter a comment.Supplies a descriptive comment for the proxy ARP
interface address.

Comment

Interface > interface > Address > To

(Optional) Enter a comment.Supplies a descriptive comment for the upper limit
of the address range.

Comment

Enter the upper limit of the address range.Specifies the upper limit of the address range.IPaddr

Configuring a Source (NSMProcedure)

To configure a source:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the source.

3. Click the Configuration tab. In the configuration tree, select Security > Nat > Source.

4. Configure the options as specified in Table 131 on page 213.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the source options.

Table 131: Source Configuration Details

Your ActionFunctionOption

General

(Optional) Enter a comment.Supplies a descriptive comment for source
configuration.

Comment

213Copyright © 2013, Juniper Networks, Inc.

Chapter 13: Configuring Security for J Series Services Routers and SRX Series Services Gateways



Table 131: Source Configuration Details (continued)

Your ActionFunctionOption

Select the Address Persistent check box to
enable this feature.

Allows the source address to maintain the same
translation.

Address Persistent

General > Pool Utilization Alarm

(Optional) Enter a comment.Supplies a descriptive comment for the pool
utilization alarm.

Comment

Set the threshold. Range: 50 - 100.Raises the threshold for the pool utilization alarm.Raise Threshold

Set the threshold. Range: 40 - 100.Specifies the threshold for the pool utilization
alarm.

Clear Threshold

General > Port Randomization

(Optional) Enter a comment.Supplies a descriptive comment for port
randomization.

Comment

Select the Disable check box to enable this
feature.

Disables the source NAT port randomization.Disable

General > Interface

(Optional) Enter a comment.Supplies a descriptive comment for the port
overloading interface.

Comment

Select theOff checkbox to enable this feature.Turns off the interface port overloading.Off

Pool > General

Enter the pool name.Specifies the pool name.Name

Enter a comment.Supplies a descriptive comment for the pool. This
is optional.

Comment

Pool > Routing Instances

(Optional) Enter a comment.Supplies a descriptive comment for the routing
instances.

Comment

Select the name from the list.Specifies the name of the routing instance.Ri Name

Pool > Address > IP Address

Enter the IP address or address range.Specifies the IP address or address range.IP Address

(Optional) Enter a comment.Supplies adescriptive comment for the IPaddress.Comment

Pool > Address > End of Range
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Table 131: Source Configuration Details (continued)

Your ActionFunctionOption

Enter a comment.Supplies adescriptive comment for the upper limit
of the address range. This is optional.

Comment

Enter the upper limit of the address range.Specifies the upper limit of the address range.IPaddr

Pool > Host Address Base

(Optional) Enter a comment.Supplies a descriptive comment for the host
address base.

Comment

Enter the base IP address.Specifies the base IP address.IPaddr

Pool > Port Translation > General

(Optional) Enter a comment.Supplies a descriptive comment for the port
translation.

Comment

Pool > Port Translation > No Translation > General

Select the No Translation check box to enable
this feature.

Specifies that the port translation is not enabled.No Translation

Pool > Port Translation > No Translation > Translation

Enter the following:

• Comment—A descriptive comment for the
lower limit of the port range.

• Low—The lower limit of the port range.
Range: -2147483648 - 2147483647.

Specifies the lower limit of the port range.From

Enter the following:

• Comment—A descriptive comment for the
upper limit of the port range.

• High—Specifies the upper limit of the port
range. Range: -2147483648 - 2147483647.

Specifies the upper limit of the port range.To

Pool >Overflow Pool > General

Enter a comment.Supplies a descriptive comment for the overflow
pool.

Comment

Pool >Overflow Pool > Pool Name

Select the option.Specifies that neither the pool-name nor the
interface option is enabled.

None

Select the option and enter the pool name.Specifies the overflow pool name.pool-name
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Table 131: Source Configuration Details (continued)

Your ActionFunctionOption

Select the option.Specifies the interface for the overflow pool.interface

Configuring the Source Nat (NSMProcedure)

To configure source NAT:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the source NAT.

3. Click the Configuration tab. In the configuration tree, select Security > Nat > Source

Nat.

4. Add or modify settings as specified in Table 128 on page 209.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the source NAT settings.

Table 132: Source NAT Configuration Details

Your ActionFunctionOption

source-nat

Enter a name.Specifies a name for the source NAT.Name

source-nat > From

Select an option.Specifies the zone, routing instanceor the
interface selected for the source NAT.

Zone/RI/Interface

Select the option and enter the following:

• Comment—Descriptive comment for the destination
address.

• Prefix—Address prefix.

• Port—Port number.

Low—Lower limit of the address range.

High—Higher limit of the address range.

Specifies source address of the
destination NAT.

Source Address
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Table 132: Source NAT Configuration Details (continued)

Your ActionFunctionOption

Select the option and enter the following:

• Comment—Descriptivecomment for theaddress range.

• Address Object—Address object pushed to the global
address book.

• Port—Port number.

Low—Lower limit of the address range.

High—Higher limit of the address range.

Specifies source address name of the
destination NAT.

Source Address Name

source-nat > To

Select an option.Specifies the zone, routing instanceor the
interface selected for the destination
NAT.

Zone/RI/Interface

Either destination address or destination address name
can be used for an instance.

Specifies destination address of the
destination NAT.

Destination Address

Either destination address or destination address name
can be used at an instance.

Specifies destination address name of
the destination NAT.

Destination Address
Name

The port options are:

• Low—Lower limit of the address range.

• High—Higher limit of the address range.

Specifies destination port number.Destination Port

• None—Specifies that no option is selected.

• OFF—Specifies that the option is disabled.

• Pool—Specifies the NAT pool.

• Interface—Specifies the outgoing option.

Action

—Specifies thedeviceonwhich the rulebase
is installed.

Install On

Configuring the Static Nat (NSMProcedure)

To configure the static NAT:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the static NAT.

3. Click theConfiguration tab. In the configuration tree, selectSecurity>Nat>StaticNat.

4. Add or modify settings as specified in Table 128 on page 209.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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• Apply—Applies the static NAT settings.

Table 133: Static NAT Configuration Details

Your ActionFunctionOption

static-nat

Enter a name.Specifies a name for the static NAT.Name

Select an option.Specifies the zone, routing instance or
the interfaceselected for thedestination
NAT.

Zone/RI/Interface

EitherDestinationAddressorDestination
Address Name can be used for an
instance.

Specifies the destination address of the
destination NAT.

Destination Address

EitherDestinationAddressorDestination
Address Name can be used for an
instance.

Specifies the destination address name
of the destination NAT.

Destination Address Name

Action

–Specifies the prefix address.Prefix

–Specifies the prefix name.Prefix Name

–Specifies the device on which the
rulebase is installed.

Install On

Configuring Traceoptions (NSMProcedure)

The traceoptions feature allows you to configure the file and the flag options.

To configure traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the traceoptions.

3. Click the Configuration tab. In the configuration tree, select Security > Nat >

Traceoptions.

4. Configure the options as specified in Table 134 on page 219.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the traceoptions settings.
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Table 134: Traceoptions Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the
traceoptions.

Comment

Select theNoRemote Trace check box to enable
this feature.

Disables the remote tracing.No Remote Trace

You can now configure the following options:

• Configuring the File Options (NSM Procedure) on page 219

• Configuring Flag Options (NSM Procedure) on page 220

Configuring the File Options (NSMProcedure)

To configure file options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the file options.

3. Click the Configuration tab. In the configuration tree, select Security > Nat >

Traceoptions > File.

4. Configure the file options as specified in Table 135 on page 219.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the file settings.

Table 135: File Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the filename.Comment

Enter a filename.Specifies the filename to write the traceoptions.Filename

Enter the maximum file size.Specifies the maximum size of the trace file.Size

Set the maximum number of trace files.
Range: 2 through 1000.

Specifies the maximum number of trace files.Files

Select the option.Specifies that neither theworld-readable nor the
no-world-readable option is enabled.

None

(Optional) Select the option.Allows any user to read the log file.world-readable

(Optional) Select the option.Prevents any user from reading the log file.no-world-readable
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Table 135: File Configuration Details (continued)

Your ActionFunctionOption

Enter the match expression.Specifies the regular expression for the lines to be
logged.

Match

Configuring Flag Options (NSMProcedure)

To configure flag options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure flag options.

3. Click the Configuration tab. In the configuration tree, select Security > Nat >

Traceoptions > Flag.

4. Add or modify setting as specified in Table 136 on page 220.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the flag settings.

Table 136: Flag Configuration Details

Your ActionFunctionOption

Select a name from the list.Specifies the trace flag name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the trace flag.Comment

Select the Syslog check box to enable this
feature.

Specifies that the NAT flow trace files are recorded
to the system log.

Syslog

Related
Documentation

• Configuring IKE (NSM Procedure) on page 188

• Configuring IPsec (NSM Procedure) on page 195

• Configuring a PKI (NSM Procedure) on page 201
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CHAPTER 14

Configuring Services for J Series Services
Routers and SRX Series Services
Gateways

• Configuring Captive Portal (NSM Procedure) on page 221

• Configuring Mobile IP (NSM Procedure) on page 226

• Configuring RPM (NSM Procedure) on page 237

• Configuring Service Interface Pools (NSM Procedure) on page 243

• Configuring Unified Access Control (NSM Procedure) on page 244

Configuring Captive Portal (NSMProcedure)

The captive portal feature allows you to configure custom options, interface, and

traceoptions.

To configure the captive portal feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the captive portal feature.

3. Click the Configuration tab. In the configuration tree, select Services > Captive Portal.

4. Configure the options as specified in Table 137 on page 221.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the captive portal parameters.

Table 137: Captive Portal Configuration Details

Your ActionFunctionOption

Enter a comment.Supplies a descriptive comment for the captive portal.
This is optional.

Comment
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Table 137: Captive Portal Configuration Details (continued)

Your ActionFunctionOption

Select an authentication profile name
from the list.

Specifies the access profile name used for
authentication.

Authentication Profile
Name

Select secure authentication from the
list.

Specifies either secure authentication (using encrypted
HTTPS) or nonsecure authentication (using plain-text
HTTP).

Secure Authentication

You can configure the following options with captive portal:

• Configuring CustomOptions (NSM Procedure) on page 222

• Configuring the Interface (NSM Procedure) on page 223

• Configuring Traceoptions (NSM Procedure) on page 224

Configuring CustomOptions (NSMProcedure)

This section provides information about configuring custom options for captive portal.

To configure custom options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the custom options feature.

3. Click the Configuration tab. In the configuration tree, select Services > Captive Portal

> CustomOptions.

4. Select the Enable Feature check box.

5. Enter the parameters as specified in Table 138 on page 222.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the custom option parameters.

Table 138: CustomOptions Configuration Details

Your ActionFunctionOption

Enter a comment.Supplies a descriptive comment for the custom
option. This is optional.

Comment

Enter thepathwith a file typeof JPG,
JPEG, GIF, or PNG.

Specifies the path for the header logo.Header Logo

Enter the header color.Specifies the header background color.Header Bgcolor

Enter a message.Specifies the header message.Header Message
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Table 138: CustomOptions Configuration Details (continued)

Your ActionFunctionOption

Enter a message.Specifies the termsandconditionsofusagemessage.Banner Message

Enter a message.Specifies the login form header message.Form Header Message

Enter the form header color.Specifies the login form header background color.Form Header Bgcolor

Enter a label.Specifies the label for submitting the form.Form Submit Label

Enter a label.Specifies the label for resetting the form.Form Reset Label

Enter a message.Specifies the footer message.Footer Message

Enter the footer color.Specifies the footer background color.Footer Bgcolor

Enter a URL.Specifies the post authentication redirection URL.Post Authentication Url

Configuring the Interface (NSMProcedure)

This sectionprovides informationabout configuring the interfaceoption for captiveportal.

To configure the interface:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the interface feature.

3. Click the Configuration tab. In the configuration tree, select Services > Captive Portal

> Interface.

4. Add or modify the interface settings as specified in Table 139 on page 223.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 139: Interface Configuration Details

Your ActionFunctionOption

Select a name from the list.Specifies the name of the interface.Name

Enter a comment.Supplies a descriptive comment for the interface.Comment

Select a supplicant from the list.Specifies the supplicant mode for this interface.Supplicant

Set the number of retries. Range: 1 through
10.

Specifies the number of retries after which the port
enters a wait state.

Retries
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Table 139: Interface Configuration Details (continued)

Your ActionFunctionOption

Set thequietperiod.Range:0 through65535.Specifies the duration towait after an authentication
failure.

Quiet Period

Set the server timeout. Range: 1 through 60.Specifies the timeout interval for the authentication
server.

Server Timeout

Set the session expiration period. Range: 1
through 65535.

Specifies the timeout period before session
expiration..

Session Expiry

Configuring Traceoptions (NSMProcedure)

The traceoptions feature allows you to configure file and flag options.

To configure traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure traceoptions.

3. Click the Configuration tab. In the configuration tree, select Services > Captive Portal

> Traceoptions.

4. Enter a comment in the traceoptions workspace that describes the traceoptions.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the traceoptions settings.

You can now configure the following options:

• Configuring File Options (NSM Procedure) on page 224

• Configuring Flag Options (NSM Procedure) on page 225

Configuring File Options (NSMProcedure)

To configure file options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure file options.

3. Click the Configuration tab. In the configuration tree, select Services > Captive Portal

> Traceoptions > File.

4. Configure the file options as specified in Table 140 on page 225.

5. Click one:
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• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the file settings.

Table 140: File Configuration Details

Your ActionFunctionOption

Enter a comment.Supplies a descriptive comment for the filename.Comment

Enter a filename.Specifies the filename to write the traceoptions.Filename

Select the Replace check box.Specifieswhether the trace filesmust be replaced instead
of appended.

Replace

Enter the maximum file size.Specifies the maximum size of the trace file.Size

Set themaximum number of trace files.
Range: 2 through 1000.

Specifies the maximum number of trace files.Files

Select the No Stamp check box.Specifies that youdonotwant to timestamp the trace file.No Stamp

Select the option.Specifies that neither theworld-readable or
no-world-readable option is enabled.

None

Select the option.Allows any user to read the log file. (Optional)world-readable

Select the option.Prevents any user from reading the log file. (Optional)no-world-readable

Configuring Flag Options (NSMProcedure)

To configure flag options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure flag options.

3. Click the Configuration tab. In the configuration tree, select Services > Captive Portal

> Traceoptions > Flag.

4. Configure the flag options as specified in Table 141 on page 226.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the flag settings.
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Table 141: Flag Configuration Details

Your ActionFunctionOption

Select a name from the list.Specifies the trace flag name.Name

Enter a comment.Supplies a descriptive comment for the trace flag.Comment

Select the Disable check box.Disables the trace flag.Disable

ConfiguringMobile IP (NSMProcedure)

The Mobile IP feature allows you to configure the following options: access type,

authenticate, dynamic home assignment, home agent, peer, and traceoptions.

To configure the Mobile IP feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the Mobile IP feature.

3. Click the Configuration tab. In the configuration tree, select Services >Mobile IP.

4. Select the Enable Feature check box.

5. Enter a comment in the Mobile IP workspace that describes the Mobile IP.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the Mobile IP settings.

You can now configure the following options:

• Configuring Access Type (NSM Procedure) on page 226

• Configuring the Authenticate Mechanism (NSM Procedure) on page 227

• Configuring Dynamic Home Assignment (NSM Procedure) on page 228

• Configuring the Home Agent (NSM Procedure) on page 229

• Configuring the Peer (NSM Procedure) on page 231

• Configuring Traceoptions (NSM Procedure) on page 234

Configuring Access Type (NSMProcedure)

This section provides information about configuring access type for Mobile IP.

To configure access type:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the access type option.
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3. Click the Configuration tab. In the configuration tree, select Services >Mobile IP >

Access Type.

4. Enter a comment in the Access Type workspace that describes the access type.

5. Configure the access type options as specified in Table 142 on page 227.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the access type options.

Table 142: Access Type Configuration Details

Your ActionFunctionOption

Access Type >Wimax

Select the option.Specifies that neither thewimaxorgenericenvironment
is specified for the access type..

None

Select the option and enter a Comment in the
comment field.

EnablesWorldwide Interoperability for Microwave
Access (WiMAX) environment.

wimax

Select the option and enter a Comment in the
comment field.

Enables non-WiMAX environment.generic

Configuring the Authenticate Mechanism (NSMProcedure)

This section provides information about configuring authenticatemechanism for Mobile

IP.

To configure the authenticate mechanism :

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the authenticate mechanism.

3. Click the Configuration tab. In the configuration tree, select Services >Mobile IP >

Authenticate.

4. Configure the authenticate options as specified in Table 143 on page 228.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the authenticate options.
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Table 143: Authenticate Configuration Details

Your ActionFunctionOption

Enter a comment.Supplies a descriptive comment for the authenticate option.
This is optional.

Comment

Select an order from the list.Specifies the order in which to use the authenticate
mechanism.

Order

Configuring Dynamic Home Assignment (NSMProcedure)

This section provides information about configuring access dynamic home assignment

for Mobile IP.

To configure dynamic home assignment:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure dynamic home assignment.

3. Click the Configuration tab. In the configuration tree, select Services >Mobile IP >

Dynamic Home Assignment.

4. Enter a comment in the Dynamic Home Assignment workspace that describes the

dynamic home assignment.

5. In the configuration tree, select Services >Mobile IP > Dynamic Home Assignment >

Home Agent.

6. Enter a comment in the Home Agent workspace that describes the home agent.

7. In the configuration tree, select Services >Mobile IP > Dynamic Home Assignment >

Home Agent > Nai.

8. Add or modify settings as specified in Table 144 on page 228.

9. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the Nai options.

Table 144: Dynamic Home Assignment Configuration Details

Your ActionFunctionOption

Enter a name in the following format:

• @domain.com

• user@domain.com

Specifies aname for thenetwork address identifiers
(NAI).

Name

Enter a comment.Supplies a descriptive comment for the NAI.Comment

Enter the IP address.Specifies the IP address of the home agent.Home Agent
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Configuring the Home Agent (NSMProcedure)

The home agent feature allows you to configure enable service, pool match order, and

virtual network.

To configure home agent feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the home agent feature.

3. Click the Configuration tab. In the configuration tree, select Services >Mobile IP >

Home Agent.

4. Enter a comment in the Home Agent workspace that describes the home agent.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the home agent options.

You can now configure the following options:

• Configuring Enable Service (NSM Procedure) on page 229

• Configuring Pool Match Order (NSM Procedure) on page 230

• Configuring the Virtual Network (NSM Procedure) on page 230

Configuring Enable Service (NSMProcedure)

This section provides information about configuring the enable service for home agent.

To configure the enable service mechanism:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the enable service mechanism.

3. Click the Configuration tab. In the configuration tree, select Services >Mobile IP >

Home Agent > Enable Service.

4. Add or modify settings as specified in Table 145 on page 230.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the enable service options.
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Table 145: Enable Service Configuration Details

Your ActionFunctionOption

Enter the interface name. Value: gigabit, fast ethernet
or a 10-gigabit ethernet interface.

Specifies the interface name.Name

Enter a comment.Specifies the comment for the interface.Comment

Configuring Pool Match Order (NSMProcedure)

This section provides information about configuring pool match order for home agent.

To configure the pool match order:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the pool match order.

3. Click the Configuration tab. In the configuration tree, select Services >Mobile IP >

Home Agent > Pool Match Order.

4. Add or modify settings as specified in Table 146 on page 230.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the pool match order options.

Table 146: Pool Match Order Configuration Details

Your ActionFunctionOption

Select the name from the list.Specifies the name of the pool match order.Name

Enter a comment.Suppliesadescriptivecomment for thepoolmatchorder.Comment

Configuring the Virtual Network (NSMProcedure)

This section provides information about configuring virtual network for home agent.

To configure the virtual network:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the virtual network.

3. Click the Configuration tab. In the configuration tree, select Services >Mobile IP >

Home Agent > Virtual Network .

4. Enter a comment in theVirtualNetworkworkspace that describes the virtual network.
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5. Add or modify the settings as specified in Table 147 on page 231.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the virtual network options.

Table 147: Virtual Network Configuration Details

Your ActionFunctionOption

Virtual Network >Home Agent Address

Enter the IP address.Specifies the loopback IP address of the home
agent.

Name

Enter a comment.Specifies the comment for the home agent.Comment

Set the maximum registration life time.
Range: 7 through 65535.

Specifies the maximum registration lifetime.Registration Lifetime

Set the maximum timestamp tolerance.
Range: 1 through 255.

Specifies the maximum timestamp tolerance.Timestamp Tolerance

Enter the IP address.Specifies the starting IP address of the pool.Starting IP Address

Enter the IP address.Specifies the ending IP address of the pool.Ending IP Address

Select the check box.Enables registration revocation.

NOTE: This is a mandatory field.

Revocation Required

Configuring the Peer (NSMProcedure)

This section provides information about configuring a peer for Mobile IP.

To configure Peer:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the peer feature.

3. Click theConfiguration tab. In the configuration tree, selectServices>Mobile IP>Peer.

4. Enter a comment in the Peer workspace that describes the peer.

5. Add or modify the settings as specified in Table 148 on page 232.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 148: Peer Configuration Details

Your ActionFunctionOption

Peer > IP Address

Enter the IP address.Specifies the peer IP address.Name

Enter a comment.Supplies a descriptive comment for the IP address.Comment

Peer > IP Address > Spi

Enter the SPI value in hexadecimal format.
For example, 0–9, a-f, A-F.

Specifies the Security Parameter Index (SPI) value.Name

Enter a comment.Specifies the comment for the SPI value.Comment

Peer > IP Address > Spi > Algorithm

Enter a comment.Specifies the comment for the algorithm.Comment

Select the option.Specifies that neither the hmac-md5ormd5option
is specified for the algorithm.

none

Select the option.Specifies hash algorithm that authenticates packet
data.

hmac-md5

Select the option.Produces a 128-bit digest.md5

Peer > IP Address > Spi > Entity Type

Enter a comment,Specifies the comment for the entity type.Comment

Select the option.Specifies that neither thehost or themobility-agent
entity type is enabled.

none

Select the option.Enables the host entity type.host

Select the option.Enables the mobility-agent entity type.mobility-agent

Peer > IP Address > Spi > Key

Enter a comment.Specifies the comment for the key.Comment

Peer > IP Address > Spi > Key > Hex

Select the option.Specifies that neither the HEX or ASCII key is
enabled.

None

1. Select the option.

2. Enter a comment and a hexadecimal
value.

Enables hexadecimal text key.hex
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Table 148: Peer Configuration Details (continued)

Your ActionFunctionOption

1. Select the option.

2. Enter a comment and ASCII value.

Enables ASCII text key.ascii

Peer > IP Address > Spi > ReplayMethod

Enter a comment.Specifies the comment for the replay method.Comment

Peer > IP Address > Spi > ReplayMethod > Timestamp

Select the option.Specifies that the timestamp option is not enabledNone

1. Select the option.

2. Enter a comment for the timestamp.

3. Enter the timestamp receive duration.

Range: 1 through 255.

Enables the timestamp option.timestamp

Select the option.Specifies that the configuration option is not
selected.

none (configuration)

Peer > Nai

Enter a name in the following format:

• @domain.com

• user@domain.com

Specifies the name for the NAI.Name

Enter a comment.Specifies the comment for the NAI.Comment

Peer > Nai > Spi

Enter the SPI value in hexadecimal format.
(0–9, a-f, A-F).

Specifies the SPI value.Name

Enter a comment.Specifies the comment for the SPI value.Comment

Peer > Nai > Spi > Algorithm

Enter a comment.Specifies the comment for the algorithm.Comment

Select the option.Specifies that neither the hmac-md5ormd5option
is specified for the algorithm.

none

Select the option.Specifies hash algorithm that authenticates packet
data.

hmac-md5

Select the option.Produces a 128-bit digest.md5

Peer > Nai > Spi > Entity Type
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Table 148: Peer Configuration Details (continued)

Your ActionFunctionOption

Enter a comment.Specifies the comment for the entity type.Comment

Select the option.Specifies that neither thehost or themobility-agent
entity type is enabled.

none

Select the option.Enables the host entity type.host

Select the option.Enables the mobility-agent entity type.mobility-agent

Peer > Nai > Spi > Key

Enter a comment.Specifies the comment for the key.Comment

Peer > Nai > Spi > Key > Hex

Select the option.Specifies that neither the HEX or ASCII key is
enabled.

None

1. Select the option.

2. Enter a comment and a hexadecimal
value.

Enables hexadecimal text key.hex

1. Select the option.

2. Enter a comment and an ASCII value.

Enables ASCII text key.ascii

Peer > Nai > Spi > ReplayMethod

Enter a comment.Specifies the comment for the replay method.Comment

Peer > Nai > Spi > ReplayMethod > Timestamp

Select the option.Specifies that the timestamp option is not enabledNone

1. Select the option.

2. Enter a comment for the timestamp.

3. Enter the duration within which the
timestampmust be received.

Range: 1 through 255.

Enables the timestamp option.timestamp

Select the option.Specifies that the configuration option is not
selected.

none (configuration)

Configuring Traceoptions (NSMProcedure)

The traceoptions feature allows you to configure file and flag options.
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To configure traceoptions feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure traceoptions.

3. Click the Configuration tab. In the configuration tree, select Services >Mobile IP >

Traceoptions.

4. Configure the options as specified in Table 149 on page 235.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the traceoptions settings.

Table 149: Traceoptions Configuration Details

Your ActionFunctionOption

Enter a comment.Suppliesadescriptivecomment for the traceoptions.Comment

Select the No Remote Trace check box.Disables the remote tracing option.No Remote Trace

Select the level.Specifies the level of debugging output.Level

You can configure the following options under traceoptions:

• Configuring File (NSM Procedure) on page 235

• Configuring Flag (NSM Procedure) on page 236

Configuring File (NSMProcedure)

To configure file options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the traceoptions file feature.

3. Click the Configuration tab. In the configuration tree, select Services >Mobile IP >

Traceoptions > File.

4. Configure the file options as specified in Table 150 on page 236.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the file options.
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Table 150: File Configuration Details

Your ActionFunctionOption

Enter a comment.Specifies the comment for the filename.Comment

Enter a filename.Specifies the filename to write the traceoptions.Filename

Enter the maximum file size.Specifies the maximum size of the trace file.Size

Set the maximum number of trace files.
Range: 2 through 1000.

Specifies the maximum number of trace files.Files

Select the option.Specifies that neither theworld-readable or
no-world-readable option is enabled.

None

Select the option.Allows any user to read the log file. (Optional)no-world-readable

Select the option.Prevents any user from reading the log file. (Optional)world-readable

Enter the match expression.Specifies the regular expression for lines to be logged.Match

Configuring Flag (NSMProcedure)

To configure flag options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure flag options.

3. Click the Configuration tab. In the configuration tree, select Services >Mobile IP >

Traceoptions > Flag.

4. Add or modify the settings as specified in Table 151 on page 236.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the flag options.

Table 151: Flag Configuration Details

Your ActionFunctionOption

Select a name from the drop-down list.Specifies the flag name.Name

Enter a comment.Specifies the comment for the flag.Comment

Copyright © 2013, Juniper Networks, Inc.236

Configuring J Series Services Routers and SRX Series Services Gateways Guide



Configuring RPM (NSMProcedure)

Real-time PerformanceMonitoring (RPM) includes the Border Gateway Protocol (BGP),

probe, and probe server.

To configure the RPM feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the RPM feature.

3. Click the Configuration tab. In the configuration tree, select Services > Rpm.

4. Select the Enable Feature check box.

5. Configure the RPM options as specified in Table 152 on page 237.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the RPM options.

Table 152: RPMConfiguration Options

Your ActionFunctionOption

Enter a comment.Supplies a descriptive comment for RPM. This is
optional.

Comment

Set theprobe limit. Range: 1 through500.Specifies the maximum number of concurrent probes
allowed.

Probe Limit

You can configure the following RPM options:

• Configuring BGP (NSM Procedure) on page 237

• Configuring Probe (NSM Procedure) on page 239

• Configuring Probe Server (NSM Procedure) on page 242

Configuring BGP (NSMProcedure)

This section provides information about configuring Border Gateway Protocol (BGP) for

RPM.

To configure BGP:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the BGP feature.

3. Click the Configuration tab. In the configuration tree, select Services > Rpm > Bgp.
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4. Configure the options as specified in Table 153 on page 238.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the BGP parameters.

Table 153: BGP Configuration Options

Your ActionFunctionOption

Enter a comment.Supplies a descriptive comment for BGP. This is
optional.

Comment

Select the probe request type.Specifies the RPM-BGP probe request type.Probe Type

Set the probe count. Range: 1 through 15.Specifies the total number of probes per test.Probe Count

Set the probe interval. Range: 1 through 255.Specifies the amount of time between probes.Probe Interval

Set the test interval. Range: 0 through 86400.Specifies the amount of time between tests.Test Interval

Set the destination port number. Range: 7
through 65535.

Specifies the TCP/UDP port number.Destination Port

Set the history size. Range: 0 through 255.Specifies the number of stored history entries.History Size

Set the moving average size. Range: 0 through
255.

Specifies the average number of samples to use
for the moving average.

Moving Average Size

Set the data size. Range: 0 through 65507.Specifies the size of the data portion of the probe.Data Size

Enter the content in hexadecimal format (0-9,
a-f, A-F).

Defines content for thedataportion of theprobes.Data Fill

BGP allows you to configure routing instance options.

• Configuring Routing Instances (NSM Procedure) on page 238

Configuring Routing Instances (NSMProcedure)

This section provides information about configuring routing instances for BGP.

To configure routing instances:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the BGP routing instances options.

3. Click the Configuration tab. In the configuration tree, select Services > Rpm > Bgp >

Routing Instances.

Copyright © 2013, Juniper Networks, Inc.238

Configuring J Series Services Routers and SRX Series Services Gateways Guide



4. Add or modify the settings as specified in Table 154 on page 239.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the routing instances options.

Table 154: Routing Instance Configuration Options

Your ActionFunctionOption

Enter a name.Specifies the routing instance name.Name

Enter a comment.Specifies the comment for the routing instance.Comment

Configuring Probe (NSMProcedure)

This section provides information about configuring probe options for RPM.

To configure probe options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the probemechanism.

3. Click the Configuration tab. In the configuration tree, select Services > Rpm > Probe.

4. Add or modify settings as specified in Table 155 on page 239.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the probe options.

Table 155: Probe Configuration Options

Your ActionFunctionOption

Enter a name.Specifies the name of the owner.Name

Enter a comment.Specifies the comment for the probe.Comment

probe > test

Enter a name.Specifies the name of the test.Name

Enter a comment.Specifies a comment for the test.Comment

Select the probe request type.Specifies the probe request type.Probe Type
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Table 155: Probe Configuration Options (continued)

Your ActionFunctionOption

Enter the value or select it from the list.

Range: 1 through 15.

Specifies the total number of probes per count.Probe Count

Enter the value or select it from the list.

Range: 1 through 255.

Specifies the amount of time between the probes.Probe Interval

Enter the value or select it from the list.

Range: 0 through 86400.

Specifies the amount of time between the tests.Test Interval

Enter the value or select it from the list.

Range: 7 through 65535.

Specifies the TCP/UDP port number.Destination Port

Enter the source address.Specifies the source address for probes.Source Address

Select the routing instance.Specifies the routing instance used by probes.Routing Instance

Enter the value or select it from the list.

Range: 0 through 255.

Specifies the number of stored history entries.History Size

Enter the value or select it from the list.

Range: 0 through 255.

Specifies the average number of samples to use
for the moving average.

Moving Average Size

Select the DSCP code points.Specifies the Differentiated Services (DiffServ)
code point bits or alias.

Dscp Code Points

Enter the value or select it from the list.

Range: 0 through 65507

Specifies the size of the data portion of the probes.Data Size

Enter the content in hexadecimal format (0-9,
a-f, A-F).

Defines the content of the data portion of the
probes.

Data Fill

Enter the name of the output interface for
probes.

Specifies the name of the output interface for
probes.

Destination Interface

Select the check box.Specifies that the Packet Forwarding Engine
updates the timestamp.

Hardware Timestamp

Select the check box.Enables hardware timestamps for one-way
measurements.

OneWay Hardware
Timestamp

probe > test > Target

Enter a comment.Specifies a comment for the target.Comment
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Table 155: Probe Configuration Options (continued)

Your ActionFunctionOption

probe > test > Target > Address

Select the option.Specifies that neither the IP address nor the URL
of the remote server that is being probed by the
RPM test is specified.

none

Select the option and enter the address.Specifies the IP address of the remote server that
is being probed by the RPM test.

address

Select the option and enter the URL.Specifies theURLof the remote server that is being
probed by the RPM test.

url

probe > test > Thresholds

Enter a comment.Specifies a comment for the threshold.Comment

Enter the value or select it from the list.

Range: 0 through 15.

Specifies the number of successive probe losses,
which indicates successive failure.

Successive Loss

Enter the value or select it from the list.

Range: 0 through 15.

Specifies total number of probe losses, which
indicates test failure.

Total Loss

Enter the value or select it from the list.

Range: 0 through 60000000.

Specifies themaximum round-trip time per probe.Rtt

Enter the value or select it from the list.

Range: 0 through 60000000.

Specifies the maximum jitter per test.Jitter Rtt

Enter the value or select it from the list.

Range: 0 through 60000000.

Specifies themaximumstandarddeviationper test.Std Dev Rtt

Enter the value or select it from the list.

Range: 0 through 60000000.

Specifiesmaximumsource-to-destination timeper
probe.

Egress Time

Enter the value or select it from the list.

Range: 0 through 60000000.

Specifiesmaximumdestination-to-source timeper
probe.

Ingress Time

Enter the value or select it from the list.

Range: 0 through 60000000.

Specifiesmaximumdestination-to-source jitter per
test.

Jitter Ingress

Enter the value or select it from the list.

Range: 0 through 60000000.

Specifiesmaximumsource-to-destination jitter per
test.

Jitter Egress
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Table 155: Probe Configuration Options (continued)

Your ActionFunctionOption

Enter the value or select it from the list.

Range: 0 through 60000000.

Specifiesmaximumdestination-to-sourcestandard
deviation per test.

Std Dev Ingress

Enter the value or select it from the list.

Range: 0 through 60000000.

Specifiesmaximumsource-to-destinationstandard
deviation per test.

Std Dev Egress

probe > test > Traps

Select a trap.Specifies the test traps.New Traps

Configuring Probe Server (NSMProcedure)

This section provides information about configuring probe server options for RPM.

To configure probe server options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure probe server options.

3. Click the Configuration tab. In the configuration tree, select Services > Rpm > Probe

Server.

4. In the Probe Server workspace, enter a comment for the probe server.

5. Configure the options as specified in Table 156 on page 242.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the probe server settings.

Table 156: Probe Server Configuration Details

Your ActionFunctionOption

Probe Server > Icmp

Enter a comment.Specifies the comment for probe ICMP.Comment

Enter the name of the destination interface.Specifies the name of the output interface for
probes.

Destination Interface

Probe Server > Tcp

Enter a comment.Specifies the comment for TCP.Comment
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Table 156: Probe Server Configuration Details (continued)

Your ActionFunctionOption

Set theportnumber.Range:0 through65535.Specifies the TCP port number.Port

Enter the name of the destination interface.Specifies the name of the output interface for
probes.

Destination Interface

Probe Server > Udp

Enter a comment.Specifies the comment for UDP.Comment

Set theportnumber.Range:0 through65535.Specifies the UDP port number.Port

Enter the name of the destination interface.Specifies the name of the output interface for
probes.

Destination Interface

Configuring Service Interface Pools (NSMProcedure)

To configure service interface pool options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the service interface pool options.

3. Click theConfiguration tab. In theconfiguration tree, expandServices>Service Interface

Pools.

4. In the Service Interface Pools workspace, enter a comment for the service interface

pool.

5. In the configuration tree, select Services > Service Interface Pools > Pool.

6. Add or modify settings as specified in Table 157 on page 243.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the service interface pool options.

Table 157: Service Interface Pools Configuration Details

Your ActionFunctionOption

Enter a name.Specifies the service interface pool name.Name

Enter a comment.Specifies the comment for the service interface pool.Comment

pool > Interface

Enter a name.Specifies the services interface name.Name
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Table 157: Service Interface Pools Configuration Details (continued)

Your ActionFunctionOption

Enter a comment.Specifies the comment for the services interface.Comment

Related
Documentation

Configuring Captive Portal (NSM Procedure) on page 221•

• Configuring Mobile IP (NSM Procedure) on page 226

• Configuring RPM (NSM Procedure) on page 237

• Configuring Unified Access Control (NSM Procedure) on page 244

Configuring Unified Access Control (NSMProcedure)

Unified Access Control (UAC) includes configuring infranet controllers and traceoptions.

To configure the UAC feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the UAC feature.

3. Click the Configuration tab. In the configuration tree, select Services > Unified Access

Control.

4. Configure the options as specified in Table 158 on page 244.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the UAC options.

Table 158: UAC Configuration Details

Your ActionFunctionOption

Enter a comment.Specifies the comment for the UAC.Comment

Enter the timeout in seconds. Range: 2
through 4,294,967,295.

Specifies (in seconds) the timeout for the idle infranet
controller link.

Timeout

Enter the heartbeat interval in seconds.
Range: 1 through 4,294,967,295.

Specifies (in seconds) the heartbeat interval from the
infranet controller.

Interval

Select the timeout action.Specifies the action to be performedwhen an infranet
controller timeout occurs.

Timeout Action
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Table 158: UAC Configuration Details (continued)

Your ActionFunctionOption

Select the check box.Allows all traffic and log enforcement result.Test Only Mode

UAC includes configuring the following topics:

• Configuring Infranet Controller (NSM Procedure) on page 245

• Configuring Traceoptions (NSM Procedure) on page 246

Configuring Infranet Controller (NSMProcedure)

This section describes how to configure infranet controller for UAC.

To configure infranet controller options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure infranet controller options.

3. Click the Configuration tab. In the configuration tree, select Services > Unified Access

Control > Infranet Controller.

4. Add or modify the settings as specified in Table 159 on page 245.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the infranet controller options.

Table 159: Infranet Controller Configuration Details

Your ActionFunctionOption

Enter a name.Specifies the name of the infranet controller.Name

Enter a comment.Specifies the comment for the infranet controller.Comment

Enter the IP address.Specifies the infranet controller IP address.Address

Enter the port number. Range: 1 through
65535.

Specifies the infranet controller port.Port

Enter an interface.Specifies the outgoing interface.Interface

Enter the password.Specifies the infranet controller server password.Password

Enter the server certificate subject.Specifies the subject nameof the infranet controller
certificate to match.

Server Certificate
Subject

infranet-controller > Ca Profile
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Table 159: Infranet Controller Configuration Details (continued)

Your ActionFunctionOption

Select the required profile from the
Non-members list and click Add to move the
profiles to the Members list.

Specifies the certification authority profile.Ca Profile

Configuring Traceoptions (NSMProcedure)

This section describes how to configure traceoptions for UAC.

To configure traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the traceoptions feature.

3. Click the Configuration tab. In the configuration tree, select Services > Unified Access

Control > Traceoptions.

4. In the Traceoptions workspace, enter a comment for the traceoptions.

5. In the configuration tree, select Services > Unified Access Control > Traceoptions >

Flag.

6. Add or modify settings as specified in Table 160 on page 246.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 160: Traceoptions Configuration Details

Your ActionFunctionOption

Select a name.Specifies the flag name.Name

Enter a comment.Specifies the comment for the flag.Comment
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CHAPTER 15

Configuring SNMP for Network
Management in J Series Services Routers
and SRX Series Services Gateways

• Configuring Basic System Identification for SNMP (NSM Procedure) on page 247

• Configuring SNMP Communities (NSM Procedure) on page 248

• Configuring SNMP Trap Groups (NSM Procedure) on page 250

• Configuring SNMP Views (NSM Procedure) on page 252

• Configuring Client Lists (NSM Procedure) on page 253

• Configuring the SNMP Local Engine ID (NSM Procedure) on page 255

• Configuring SNMP Health Monitoring (NSM Procedure) on page 256

• Configuring the Interfaces onWhich SNMP Requests Can Be Accepted (NSM

Procedure) on page 258

• Configuring the SNMP Commit Delay Timer (NSM Procedure) on page 259

• Configuring SNMP RMON Alarms and Events (NSM Procedure) on page 260

• Enabling SNMP Access over Routing Instances (NSM Procedure) on page 264

• Configuring Tracing of SNMP Activity (NSM Procedure) on page 266

• Configuring SNMP Trap Options (NSM Procedure) on page 268

• Configuring SNMPv3 (NSM Procedure) on page 270

Configuring Basic System Identification for SNMP (NSMProcedure)

To configure basic system identification information for SNMP:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to

configure basic system identification information.

3. Click the Configuration tab. In the configuration tree, select Snmp.

4. Add or modify basic system identification information as specified in Table 161 on

page 248.

5. Click one:
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• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 161: Basic System Identification Details

Your ActionFunctionOption

Enter the system name as a free-form
text string.

Specifies a system name for the
device.

System Name

Enter a description for the system. For
example, type J4350with 4 PIMs.

Provides a description for the
system.

Description

Enter the system location information
(such as a lab name and a rack name).

Specifies the system location
information.

Location

Enter the system contact information
(such as a name and a phone number).

Specifies the contact information
for the system.

Contact

Snmp > Engine Id

Select this option.Sets the engine ID to use theMAC
address.

Use Mac Address

Related
Documentation

Configuring SNMP Communities (NSM Procedure) on page 248•

• Configuring SNMP Trap Groups (NSM Procedure) on page 250

• Configuring SNMP Views (NSM Procedure) on page 252

Configuring SNMPCommunities (NSMProcedure)

Youcanconfigure anSNMPcommunity toauthorize access to theSNMPserver bySNMP

clients, basedon the source IPaddress of incomingSNMP request packets. A community

alsodefineswhichMIBobjectsareavailableand theoperations (read-onlyor read-write)

allowed on those objects. The SNMP client application specifies an SNMP community

name inGet, GetNext, GetBulk, andSetSNMP requests. If a community is not configured,

all SNMP requests are denied.

To configure SNMP communities in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.

5. Select Community.

6. Click the Add or Edit icon.
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7. Enter the parameters as specified in Table 162 on page 249.

8. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 162: Configuring Community Fields

Your ActionFunctionOption

Enter a name for the community.Specifies the name of the community.Name

Enter a comment.Specifies the comment for the
community.

Comment

Enter a name for the view.Specifies the view associated with the
community.

View

Select an access type for the
community:

• None—No requests are enabled.

• read-only—Enable Get, GetNext, and
GetBulk requests. This option is
enabled by default.

• read-write—Enable all requests,
including Set requests.

Youmust configure a view to enable
Set requests.

Specifies the type of access granted to
the community. Access is authorized for
SNMP Get, GetBulk, GetNext, and Set
requests.

Authorization

1. Expand the Community tree and
select Client List Name.

2. Select a name.

Specifies a client list or prefix list to be
assigned to an SNMP community.

Client List Name
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Table 162: Configuring Community Fields (continued)

Your ActionFunctionOption

1. Expand the Community tree and
select Routing Instance.

2. Click the New button or select an
entry and click the Edit button.

3. Configure the following tocreateand
define a routing instance:

• Name—Enter a name for the
routing instance.

NOTE: On routers, to configurea routing
instancewithin a logical system, specify
the logical systemname followedby the
routing instance name. Use a slash ( / )
to separate the twonames. To configure
the default routing instance on a logical
system, specify the logical systemname
followed by “default.”

• Comment—Enter a comment for
the routing instance.

Specifies a routing instance for a
community.

Routing Instance

Related
Documentation

Configuring Client Lists (NSM Procedure) on page 253•

Configuring SNMP Trap Groups (NSMProcedure)

You can create and name a group of one or more types of SNMP traps and then define

which systems receive the group of SNMP traps. The trap groupmust be configured for

SNMP traps to be sent. The trap group name can be any string and is embedded in the

community name field of the trap. To configure your own trap group port, use the

Destination Port option. The default destination port is port 162. For each trap group that

you define, specify:

• At least one system as the recipient of the SNMP traps in the trap group

• The types of traps the trap group can receive

• Routing instance used by the trap group

To configure trap groups in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.

5. Select Trap Group.

6. Select the Enable Feature check box.
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7. Enter the parameters as specified in Table 163 on page 251.

8. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.

Table 163: Configuring SNMP Trap Group Fields

Your ActionFunctionOption

Enter a name for the trap group.Specifies a name for the trap group.Name

Select the version number for the SNMP
trap group from the list.

Specifies the version number of the
SNMP trap group.

Version

Enter a trap group port number.Specifies the SNMP trap group port
number.

Destination Port

Enter the name of the routing instance.Specifies a routing instance for trap
targets.

Routing Instance

1. Expandthe trap-group treeandselect
Categories.

2. Select the trap type.

NOTE: If youdonotconfigurecategories,
all trap types are included in trap
notifications.

3. On routers, chooseanOtnAlarmand
a Sonet Alarm for your trap category.

Defines the types of traps that are sent
to the targets of the named trap group.

Categories

1. Expandthe trap-group treeandselect
Targets.

2. Click theNewbuttonor select anOID
and click the Edit button.

3. Enter the IPv4 or IPv6 addresses of
the system (do not enter
hostnames).

Specifies the IPv4 or IPv6 address of the
systems to receive traps.

Targets

Related
Documentation

Configuring Basic System Identification for SNMP (NSM Procedure) on page 247•

• Configuring SNMP Communities (NSM Procedure) on page 248

• Configuring SNMP Views (NSM Procedure) on page 252
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Configuring SNMPViews (NSMProcedure)

By default, an SNMP community grants read access and denies write access to all

supported MIB objects, including communities configured for read-write authorization.

To restrict or grant read or write access to a set of MIB objects, configure a MIB view and

associate the view with a community. Each MIB object of a view has a common object

identifier (OID) prefix. Each OID represents a subtree of the MIB object hierarchy. The

subtree can be represented either by a sequence of integers separated by periods (such

as 1.3.6.1.2.1.2) or by its subtree name (such as interfaces). Use a view to specify a group

ofMIBobjectsonwhich todefineaccess. Youcanalsouse thewildcardcharacter asterisk

(*) to include OIDs that match a particular pattern in the SNMP view. To enable a view,

associate it with a community.

To configure SNMP views in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.

5. Select View.

6. Select the Enable Feature check box.

7. Enter the parameters as specified in Table 164 on page 252.

8. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.

Table 164: Configuring SNMPView Fields

Your ActionFunctionOption

Enter a name for the view.Specifies a name for the view.Name

1. Expand the View tree and select oid.

2. Click theNewbuttonor select anOID
and click the Edit button.

Specifies an OID used to represent a
subtree of MIB objects.

Oid

Enter the OID of the MIB in either
dotted-integer format or subtree-name
format.

Specifies the MIB for the view.Name
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Table 164: Configuring SNMPView Fields (continued)

Your ActionFunctionOption

Select exclude to exclude the subtree of
MIBobjects representedby the specified
OID.

Select include to include the subtree of
MIBobjects representedby the specified
OID.

Specifies whether the view includes or
excludes the set of MIB objects.

Include or Exclude

Related
Documentation

Configuring Basic System Identification for SNMP (NSM Procedure) on page 247•

• Configuring SNMP Communities (NSM Procedure) on page 248

• Configuring SNMP Trap Groups (NSM Procedure) on page 250

Configuring Client Lists (NSMProcedure)

You can configure a group of SNMP clients as a client list by providing either the IPv4 or

IPv6 addresses for the individual clients that you want to assign to this client list. You

can then specify that the members of the list be authorized to use a particular SNMP

community. See “Configuring SNMP Communities (NSM Procedure)” on page 248 for

information about adding a client to a community. If a community is not configured with

such specific client addresses in client lists as authorized, then all SNMP clients using

this community string are authorized by default to access the device.

To configure client lists in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.

5. Select Client List.

6. Click the Add or Edit icon.

7. Enter the parameters as specified in Table 165 on page 254.

8. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.
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NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 165: Configuring Client List Fields

Your ActionFunctionOption

Enter a name for the client list.Specifies thenamesof theclient list that
youareconfiguring tohaveSNMPaccess
privileges.

Any SNMP requests entering the device
from client lists other than the ones
listed for the community are discarded.

Name

Enter the comment.Specifies thecomment for theclient list.Comment

1. Click the New button or select a
client address and click the Edit
button.

2. Configure the following tocreateand
define a client address list:

• Name—Enter an IPv4 or IPv6
address for each client.

• Comment—Enter a comment for
the IPv4 or IPv6 address you
specified.

• Restrict—Select this check box to
deny thespecifiedSNMPclient list
access to the device. If you leave
the Restrict check box cleared by
default, access is permitted for
this particular client list.

Specifies theaddressesofSNMPclients
that areauthorized toaccess this device.

Client Address List

Related
Documentation

Configuring SNMP Communities (NSM Procedure) on page 248•
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Configuring the SNMP Local Engine ID (NSMProcedure)

You can configure a local engine identifier (engine ID) as the administratively unique ID

of an SNMPv3 engine. The local engine ID is used only for identifying an SNMPv3 engine

andnot for addressing the engine. Anengine IDhas twoparts: prefix and suffix. Theprefix

is formatted according to the specifications defined in RFC 3411, An Architecture for

DescribingSimpleNetworkManagement Protocol (SNMP)Management Frameworks. You

can specify the suffix to be generated from themedia access control (MAC) address of

the management interface.

NOTE: SNMPv3 authentication and encryption keys are generated based on
the associated passwords and the engine ID. If you configure or change the
engine ID, youmust commit the newengine ID before you configure SNMPv3
users. Otherwise the keys generated from the configured passwords are
based on the previous engine ID.

To configure a local engine ID for an SNMPv3 engine in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.

5. Select Engine Id.

6. Enter the parameters as specified in Table 166 on page 255.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 166: Configuring Engine Id Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment
for the engine ID.

Comment
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Table 166: Configuring Engine Id Fields (continued)

Your ActionFunctionOption

1. Expand the Engine Id tree and select UseMac Address.

2. Select an option for engine ID generation:

• None—The SNMP engine ID does not use the MAC address.

• use-mac-address—The SNMP engine ID is generated from the
MAC address of the management interface on the device.

• use-default-ip-address—The engine ID suffix is generated from
the default IP address of the management interface.

• local—Theengine ID suffix is generated fromthe local IPaddress
of the management interface.

For theengine ID,we recommendusing the IPaddressof thedevice
or using theMACaddress of fxp0orme0 if the device has only one
Routing Engine.

Specifies whether or not
the SNMP engine ID is
generated from the MAC
address of the
management interface
on the device.

Use Mac Address

Related
Documentation

Configuring SNMPv3 (NSM Procedure) on page 270•

Configuring SNMPHealth Monitoring (NSMProcedure)

YoucanuseSNMPhealthmonitoring tominimizeuser configuration requirements.Health

monitoring is anotification systemthat extends theRMONalarm infrastructure toprovide

predefinedmonitoring for a selected set of object instances (for file system usage, CPU

usage,andmemoryusage)and includessupport forunknownordynamicobject instances

(such as JUNOS Software processes).

To configure health monitoring for SNMP in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.

5. Select Health Monitor.

6. Select the Enable Feature check box.

7. Enter the parameters as specified in Table 167 on page 257.

8. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.
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NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 167: Configuring Health Monitor Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the health
monitoring configuration.

Comment

Specify the interval between samples,
in seconds. You can enter a value from
1 through 2147483647. The default is
300.

Specifies the interval. The interval
represents theperiodof time, in seconds,
over which the object instance is
sampled. The sample value is then
compared with the rising and falling
threshold values.

Interval

Enter the rising threshold value. You can
enter a value from 1 through 100. The
default value is 90.

Specifies the upper threshold as a
percentage of the maximum possible
value for the monitored variable. When
thecurrent sampledvalue isgreater than
or equal to this threshold and the value
at the last sampling interval is less than
this threshold, a single event is
generated. A single event is also
generated if the first sample after this
entry becomes valid is greater than or
equal to this threshold. After a rising
event is generated, another rising event
is not generated until the sampled value
falls below this threshold and reaches
the falling threshold.

Rising Threshold

Enter the falling threshold value. Youcan
enter a value from 0 through 100. The
default value is 80.

Specifies the lower threshold as a
percentage of the maximum possible
value for the monitored variable. When
the current sampled value is less than
or equal to this threshold and the value
at the last sampling interval is greater
than this threshold, a single event is
generated. A single event is also
generated if the first sample after this
entry becomesvalid is less thanor equal
to this threshold. After a falling event is
generated, another falling event is not
generated until the sampled value rises
above this threshold and reaches the
rising threshold.

Falling Threshold
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Table 167: Configuring Health Monitor Fields (continued)

Your ActionFunctionOption

1. Expand the Health Monitor tree and
select Idp.

2. Click the New button or select an
interface and click the Edit button.

3. Enter the comment, interval, and the
rising and falling threshold values.

Specifies that theenterprise-specific IDP
MIB extends SNMP support to the key
monitoringandthreshold-crossing traps.

Idp

Related
Documentation

Configuring SNMP RMON Alarms and Events (NSM Procedure) on page 260•

Configuringthe InterfacesonWhichSNMPRequestsCanBeAccepted(NSMProcedure)

You can limit the access of SNMP requests through specific interfaces by configuring the

interfaces on which SNMP requests can be accepted. If you do not configure specific

interfaces, SNMP requests entering the device through any interface are accepted,

because by default, all device interfaces have SNMP access privileges.

To configure interfaces on which SNMP requests can be accepted in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.

5. Select Interface.

6. Enter the parameters as specified in Table 168 on page 259.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.
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Table 168: Configuring Interface Fields

Your ActionFunctionOption

1. Click the New button or select an
interface and click the Edit button.

2. Enter the names of one or more
logical interfaces.

Specifies the name for the specific
interface configuration.

Interface

Related
Documentation

Configuring SNMP Communities (NSM Procedure) on page 248•

Configuring the SNMPCommit Delay Timer (NSMProcedure)

You can configure the SNMP commit delay timer to specify the length of time between

when a device first receives an SNMP nonvolatile Set request and when the commit is

requested for the candidate configuration. If the device receives newSNMPSet requests

within this time, the commit delay timer resets to the configured time. If the device does

not receive new SNMP Set requests within this time, the candidate configuration is

committed and the JUNOScript session closes (the configuration lock is released). If the

device receives a new SNMP Set request while the candidate configuration is being

committed, the SNMP Set request is rejected and an error notification is generated.

To configure the SNMP commit delay timer for nonvolatile requests in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.

5. Select Nonvolatile.

6. Enter the parameters as specified in Table 169 on page 260.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.
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Table 169: Configuring Nonvolatile Fields

Your ActionFunctionOption

Enter a comment.Specifies the comment for the
nonvolatile commit delay configuration.

Comment

Specify the delay time, in seconds. The
default value is 5.

Specifies the delay time between an
affirmativeSNMPSet replyand thestart
of commit.

Commit Delay

Related
Documentation

Configuring the InterfacesonWhichSNMPRequestsCanBeAccepted(NSMProcedure)

on page 258

•

Configuring SNMPRMONAlarms and Events (NSMProcedure)

You can configure SNMP remotemonitoring (RMON) alarms and events to monitor

integer-valued MIB objects, standard or enterprise-specific, on the device. You can set

the alarm values against thresholds and trigger events when the thresholds are crossed.

To configure the SNMP RMON alarms and events in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.

5. Select Rmon.

6. Enter the parameters as specified in Table 170 on page 261.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.
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Table 170: Configuring Rmon Fields

Your ActionFunctionOption

Enter the comment.Specifies the comment
for the RMON
configuration.

Comment
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Table 170: Configuring Rmon Fields (continued)

Your ActionFunctionOption

1. Expand the Rmon tree and select Alarm.

2. Click the New button or select a client address and click the Edit
button.

3. Configure the following to create anddefine anRMONalarmentry:

• Name—Enter a name for the alarm entry.

• Comment—Enter a comment for the alarm entry.

• Description—Enter a text description for the alarm entry.

• Interval—Enter the interval (in seconds) overwhich data is sampled
and compared with the rising and falling thresholds.

• Falling Threshold Interval—Enter the interval (in seconds) between
sampleswhen the rising threshold is crossed.After thealarmcrosses
the falling threshold, the regular sampling interval is used. You can
enter a value from 1 through 2,147,483,647. The default is 60.

• Variable—Enter the variable with which youwish to identify theMIB
object that is being monitored.

• Sample Type—Choose the sample type to identify the method of
sampling the selected variable and calculating the value to be
compared against the thresholds:

• none

• absolute-value—The value of the selected variable is compared
directly with the thresholds at the end of the sampling interval.

• delta-value—The value of the selected variable at the last sample
is subtracted from the current value, and the difference is
compared with the thresholds.

• Request Type—Specify the scope of the RMON alarm:

• get-request—Monitor a specific object instance.

• walk-request—Monitor all object instances belonging to a MIB
branch.

• get-next-request—Monitor the next object instance after the
instance specified in the configuration.

• StartupAlarm—Specify the typeof alarm that canbe sentwhen this
entry is first activated:

• falling-alarm—First sample after the alarm entry becomes active
is less than or equal to the falling threshold.

• rising-alarm—First sample after the alarm entry becomes active
is greater than or equal to the rising threshold.

• rising-or-falling-alarm—First sampleafter thealarmentrybecomes
active satisfies either of the corresponding thresholds.

Specifies theattributesof
theRMONalarmentry.An
alarm entry monitors the
value of a MIB variable.
You can configure how
often the value is
sampled, the type of
sampling to perform, and
what event to trigger if a
threshold is crossed.

Alarm

Copyright © 2013, Juniper Networks, Inc.262

Configuring J Series Services Routers and SRX Series Services Gateways Guide



Table 170: Configuring Rmon Fields (continued)

Your ActionFunctionOption

• Rising Threshold—Specify the upper threshold for the sampled
variable. When the current sampled value is greater than or equal
to this threshold and the value at the last sampling interval is less
than this threshold, a single event is generated. A single event is also
generated if the first sample after this entry becomes valid is greater
than or equal to this threshold and the associated startup alarm is
equal to the falling alarmor the rising-or-falling alarm. After a rising
event is generated, another rising event cannot be generated until
the sampled value falls below this threshold and reaches the falling
threshold. You can enter a value from -2,147,483,648 through
2,147,483,647.

• Falling Threshold—Specify the lower threshold for the sampled
variable. When the current sampled value is less than or equal to
this threshold and the value at the last sampling interval is greater
than this threshold, a single event is generated. A single event is also
generated if the first sample after this entry becomes valid is less
than or equal to this threshold and the associated startup alarm is
equal to the falling alarmor the rising-or-falling alarm.After a falling
event is generated, another falling event cannot be generated until
the sampled value rises above this threshold and reaches the rising
threshold. You can enter a value from -2,147,483,648 through
2,147,483,647. The default is 20 percent less than the rising
threshold.

• Rising Event Index—Specify the event entry that is triggered when a
rising threshold is crossed. You can enter a value from 0 through
65,535. The default is 0.

• Falling Event Index—Specify the event entry that is triggered when
a falling threshold is crossed. You can enter a value from 0 through
65,535. The default is 0.

• Syslog Subtag—Specify the tag to be added to the system log
message. You can specify a string of not more than 80 uppercase
characters as the system log tag.
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Table 170: Configuring Rmon Fields (continued)

Your ActionFunctionOption

1. Expand the Rmon tree and select Event.

2. Click the New button or select a client address and click the Edit
button.

3. Configure the following to create and define an RMONevent entry:

• Name—Enter a name for the event entry.

• Comment—Enter a comment for the event entry.

• Description—Enter a text description for the event entry.

• Type—Specify the type of notification generated and where the
event is to be logged when a threshold is crossed:

• none

• log—Adds the event entry to the logTable.

• log-and-trap—Sends an SNMP trap and creates a log entry.

• snmptrap—Sends an SNMP trap.

• Community—Specify the trap group that is used when generating a
trap. If that trap group has the rmon-alarm trap category configured,
a trap is sent to all the targets configured for that trap group. The
community string in the trapmatches the name of the trap group.
If nothing is configured, traps are sent to each group with the
rmon-alarm category set.

Specifies theattributesof
theRMONevententry.An
event entry generates a
notification for an alarm
entry when its rising or
falling threshold is
crossed. You can
configure the type of
notification that is
generated.

Event

Related
Documentation

Configuring SNMP Trap Groups (NSM Procedure) on page 250•

• Example: Configuring SNMP Trap Groups

Enabling SNMPAccess over Routing Instances (NSMProcedure)

You can enable SNMPmanagers in routing instances other than the default routing

instance to access SNMP information. You can use the SNMP routing instance access

feature to create access lists to allow or deny SNMP clients in routing instances access

to SNMP information. Specify the routing instance name to allow the SNMP client in a

routing instance to access SNMP information. To deny the SNMP client in a routing

instance access to SNMP information, restrict the routing instance name in the access

list. If access rights are not configured, JUNOSSoftware does not allowSNMPmanagers

from routing instances other than the default routing instance to access SNMP

information.

To configure access lists for SNMP access over routing instances in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.
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5. Select Routing Instance Access.

6. Select the Enable Feature check box.

7. Enter the parameters as specified in Table 171 on page 265.

8. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 171: Configuring Routing Instance Access Fields

Your ActionFunctionOption

Enter a comment.Specifiesthecomment
for the routing instance
access configuration.

Comment

1. Expand the Routing Instance Access tree and select Access List.

2. Click the New button or select an entry and click the Edit button.

3. Configure the following to create and define an access list entry for a
routing instance:

• Name—Enter a name for the access list entry.

• Comment—Enter a comment for the access list entry.

• Restrict—Select this check box to deny the specified SNMP client list
access to the routing instance. If you leave the Restrict check box
cleared by default, access is permitted for this particular list.

Specifies addresses of
client members in the
access lists.

Access List

Related
Documentation

Configuring SNMP Communities (NSM Procedure) on page 248•
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Configuring Tracing of SNMPActivity (NSMProcedure)

You can configure the traceoptions feature to track the activities of SNMP agents and

record the information in log files. The logged error descriptions provide information you

can use to solve problems faster. If this feature is not configured, JUNOS Software does

not trace SNMP activities. The default tracing behavior is outlined below:

• Important activities are logged in files located in the /var/log directory. You cannot

change the directory in which trace files are located. You can only customize other

settings. Each log is named after the SNMP agent that generates it.

• When a trace file named filename reaches its maximum size, it is renamed filename.0,

then filename.1, and so on, until the maximum number of trace files is reached. Then

the oldest trace file is overwritten. You can set the file size to be of any size from 10 KB

through 1 gigabyte (GB). When the size of the trace file reaches the maximum value,

it is renamed to the next consequential name. This process repeats until themaximum

file number limit is reached. Then the oldest file is overwritten by the newest file. This

way, new files are created once the size of each file exceeds the specified maximum

file size value. The number of files can be from 2 through 1000.

• Log files can be accessed only by the user who configures the tracing operation.

To configure SNMP tracing activity in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.

5. Select Traceoptions.

6. Enter the parameters as specified in Table 172 on page 267.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.
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Table 172: Configuring Traceoptions Fields

Your ActionFunctionOption

Enter a comment.Specifies thecomment
for the tracing
configuration.

Comment

Select the No Remote Trace check box to force local tracing for this
configuration.

Specify whether or not
this tracing
configuration iswritten
on the remote host.

JUNOS Software
supports system-wide
remote tracing, by
which traces are
written to files on the
remote host To
override the
system-wide remote
tracing configuration
for aparticular process,
When the No Remote
Trace check box is
enabled, the process
does local tracing.

No Remote Trace

1. Expand the Traceoptions tree and select File.

2. Configure the following to create and define a tracing file entry:

• Comment—Enter a comment for the tracing file.

• Size—Specify the size limit for the trace file.

• Files—Specify the maximum trace file versions to be created.

• Access—Specify access permissions for the tracing file:

• None

• world-readable—Allows any user to read all log files.

• no-world-readable—Allows log files to beaccessedonly by the user
who configures the tracing operation.

• Match—Specify a regular expression (regex) to bematched in the
trace operation output.

Specifies the limits on
the number and size of
trace files.

File
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Table 172: Configuring Traceoptions Fields (continued)

Your ActionFunctionOption

1. Expand the Traceoptions tree and select Flag.

2. Click the New button or select a tracing flag and click the Edit button.

3. Configure the following to create and define a tracing flag entry:

• Name—Specify the tracing flag to be used:

• timer—Log internally generated events.

• protocol-timeouts—Log SNMP response timeouts.

• pdu—Log SNMP request and response packets.

• varbind-error—Log variable binding errors.

• routing-socket—Log routing socket calls.

• interface-stats—Log physical and logical interface statistics.

• subagent—Log subagent restarts.

• general—Log general events.

• nonvolatile-sets—Log nonvolatile SNMP set request handling.

• all—Log all SNMP events.

• Comment—Enter a comment for the tracing flag.

Specifies which trace
operations are to be
logged. If this is not
configured, only
importantactivities are
logged by default.

Flag

Related
Documentation

Configuring SNMP Communities (NSM Procedure) on page 248•

Configuring SNMP Trap Options (NSMProcedure)

You can configure the SNMP trap options feature to recognize the duplicate traps and

to distinguishSNMPv1 traps basedon the outgoing interface. This feature is helpfulwhen

some SNMP traps that come from the same device leave the device through a different

outgoing interface, causing each such SNMP trap packet to have a different source

address. You can set the source address of every SNMP trap packet sent by a device to

be the same, regardless of the outgoing interface. You can also set the agent address of

each SNMPv1 trap.

To configure the SNMP trap options in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.

5. Select Trap Options.

6. Select the Enable Feature check box.

7. Enter the parameters as specified in Table 173 on page 269.

8. Click one:

• OK—To save the changes.
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• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 173: Configuring Trap Options Fields

Your ActionFunctionOption

Enter the comment.Specifies the comment for
the SNMP trap option.

Comment

Choose the agent address:

• None

• outgoing-interface—Sets the agent address of each SNMPv1 trap to
the address of the outgoing interface of that trap.

Specifies the agent address
of all SNMPv1 traps
generated by this device.

Agent Address

1. Expand the Trap Options tree and select Logical System.

2. Click the New button or select a routing instance and click the Edit
button.

3. Configure the following to create and define a logical systementry:

• Name—Specify the name of the logical system.

• Comment—Enter a comment for the logical system.

• Routing Instance—Configure the following to create and define
a routing instance entry:

Lo0—Choose one of the following as the source address for the
trap packets:

• lo0—The source address of the SNMP trap packets is set to
the lowest loopback address configured on the interface lo0.

• address—The source address of the SNMP trap packets is set
to the address you specify. Enter a valid IPv4 address
configured on one of the device interfaces.

On routers only, specifies
the name of the logical
systemfor thisSNMPclient.
The logical systemperforms
a subset of theactionsof its
parent physical device and
have its own interfaces,
policies, and routing
instances.

Logical System

1. Expand the Trap Options tree and select Routing Instances.

2. Click the New button or select a routing instance and click the Edit
button.

3. Configure the following to create and define a routing instance
entry:

• Name—Specify the name of the routing instance.

• Comment—Enter a comment for the routing instance.

Specifies the routing
instances for SNMPv1 and
SNMPv2 trap targets. All
targets configured in the
trapgroupuse these routing
instances.

Routing Instances
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Table 173: Configuring Trap Options Fields (continued)

Your ActionFunctionOption

1. Expand the Trap options tree and select Routing Instances.

2. Expand the Routing Instances tree and select Source Address, or
expand the Trap options tree and select Source Address directly.

3. Configure the following tocreateanddefineasourceaddressentry:

• Comment—Enter a comment for the source address.

• Lo0—Choose one of the following as the source address for the
trap packets:

• lo0—The source address of the SNMP trap packets is set to
the lowest loopback address configured on the interface lo0.

• address—The source address of the SNMP trap packets is set
to the address you specify. Enter a valid IPv4 address
configured on one of the device interfaces.

Specifies thesourceaddress
of every SNMP trap packet
sent by this device. You can
set a valid interface address
as the source address for
SNMP traps regardless of
theoutgoing interface. If the
source address is not
specified, theaddressof the
outgoing interface is used
as the source address.

Source Address

Configuring SNMPv3 (NSMProcedure)

You can configure SNMP version 3 (SNMPv3) for message security and access control.

You can configure the entries for the user-based security model (USM) that SNMPv3

uses formessagesecurityandtheview-basedaccesscontrolmodel (VACM)thatSNMPv3

uses for access control. USM specifies authentication and encryption. USM uses the

conceptof auser forwhich security parameters (levels of security, authentication, privacy

protocols, and keys) are configured for both the agent and themanager. VACM specifies

access-control rules.

To configure the SNMPv3 options in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. Click the Configuration tab.

4. In the configuration tree, expand SNMP.

5. Select V3.

6. Enter the parameters as specified in Table 174 on page 271.

7. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.

• Apply—To apply the SNMP settings.
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NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You canupdatemultiple devices at one time. See theUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 174: Configuring V3 Fields

Your ActionFunctionOption

Enter a comment.Specifies thecomment
for the SNMPv3
configuration.

Comment

1. Expand the V3 tree and select Notify.

2. Click the New button or select an entry and click the Edit button.

3. Configure the following to create and define an entry:

• Name—Specify the name for the notification.

• Comment—Enter the comment for the notification.

• Type—Choose the notification type:

• trap—Unconfirmed notifications

• inform—Confirmed notifications

• Tag—Specify a tag. Notifications are sent to all targets configured
with this tag.

Specifies the
management targets
for notificationsaswell
as the type of
notifications.
Notifications can be
either traps or informs.

Notify

1. Expand the V3 tree and select Notify Filter.

2. Click the New button or select an entry and click the Edit button.

3. Configure the following to create and define an entry:

• Name—Specify the name for the notification filter.

• Comment—Enter the comment for the notification filter.

• OID—Specify an object identifier (OID) to represent a subtree of MIB
objects. All MIB objects represented by this ID have the specified OID
as a prefix. Specify theOID using either a sequence of dotted integers
or a subtree name.

• None

• include—Include the subtree of MIB objects represented by the
specified OID.

• exclude—Exclude the subtree of MIB objects represented by the
specified OID.

Lists the group of MIB
objects on which
access is to be defined.
The notify filter limits
the type of traps or
informs sent to the
Network Security
Management (NMS).

Notify Filter
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Table 174: Configuring V3 Fields (continued)

Your ActionFunctionOption

1. Expand the V3 tree and select SNMPCommunity.

2. Configure the following to create and define an entry:

• Name—Specify the name for the SNMP community.

• Comment—Enter the comment for the community.

• Community Name—Enter the community string for the SNMPv1 or
SNMPv2 community. If you do not enter a name, it is the same as the
community index. Ensure that community names are unique.

• Security Name—Enter the name you want to use for access control.
This is done to associate the community string to a security name.

• Context—Specify the context in which the community string is to be
used.

• Tag—Specify the addresses of managers that are allowed to use this
community string.

Lists the SNMP
communities
authorizingtheSNMPv1
orSNMPv2clients.The
access privileges
associated with the
configured security
namedefinewhichMIB
objects are available
and the operations
(notify, read, or write)
allowed on those
objects.

SNMP Community

1. Expand the V3 tree and select Target Address.

2. Click the New button or select an entry and click the Edit button.

3. Configure the following to create and define an entry:

• Name—Specify the name to be assigned to the target address.

• Comment—Enter a comment for the target address.

• Address—Enter the IPv4 or the IPv6 address of the device to receive
traps or informs.

NOTE: Specify an address, not a hostname.

• Port—Enter the UDP port number for the SNMP target.

• Timeout—Specify the number of seconds to wait for an inform
acknowledgment. If noacknowledgment is receivedwithin the timeout
period, the inform is retransmitted. The default timeout period is 15
seconds.

• Retry Count—Specify the maximum number of times the inform is
transmitted if no acknowledgment is received. If no acknowledgment
is received after the inform is transmitted themaximum number of
times, the informmessage is discarded. The default count is 3 times.

• Tag List—Specify an SNMP tag list to be used to define sets of target
addresses.

• AddressMask—Specifyanaddressmask toverify thesourceaddresses
for this group of target addresses. An address mask, combined with
the address, defines a range of addresses.

• Routing Instance—Specify a routing instance for this SNMPv3 target
address.

• Logical System—On routers only, specify the logical system group for
this SNMPv3 target address.

• Target Parameters—Specify the message processing and security
parameters to be used in sending notifications to a particular
management target.

Specifies the
management
application’s address
and parameters to be
used in sending
notifications.

Target Address
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Table 174: Configuring V3 Fields (continued)

Your ActionFunctionOption

1. Expand the V3 tree and select Target Parameters.

2. Click the New button or select an entry and click the Edit button.

3. Configure the following to create and define an entry:

• Name—Specify the name to be assigned to this group of target
parameters.

• Comment—Enter a comment for this group of target parameters.

• Notify Filter—Specify the notify filter to be used by this specific set of
target parameters.

• Parameters—Configure the entries for this specific set of target
parameters:

Message ProcessingModel—Specify the message processing model:

• None

• v1—SNMPv1 message process model

• v2c—SNMPv2cmessage process model

• v3—SNMPv3message process model

Security Model—Specify this group’s security model:

• None

• usm—SNMPv3 security model

• v1—SNMPv1 message process model

• v2c—SNMPv2cmessage process model

Security Level—Specify this group’s security level:

• authentication—Authentication but no encryption.

• none—Authentication and no encryption.

• privacy—Authentication and encryption.

• Security Name—The user name (if USM is used) or the SNMP
community name (if SNMPv1 or SNMPv2c security models are
used) when generating the notification.

Specifies the message
processingandsecurity
parameters to be used
in sendingnotifications
to a particular
management target.

Target Parameters
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Table 174: Configuring V3 Fields (continued)

Your ActionFunctionOption

1. Expand the V3 tree and select Usm.

2. Configure the following to create and define an entry:

• Comment—Enter a comment for this USM set.

• Local Engine—Specify the local-engine information for USM. Assign
a user associated with an SNMPv3 group. Specify the authentication
type for the SNMPv3 user as MD5 or SHA.

Assign the encryption algorithm:

• Advanced Encryption Standard (privayc-aes128)

• Triple Data Encryption Standard (privacy-3des)

• Data Encryption Standard (privacy-des)

Configure the password used to generate the key used for encryption.

• RemoteEngine—Enter theengine ID for theSNMPagenton the remote
device where the user resides for the USM. Youmust do this to send
informmessages to an SNMPv3 user on a remote device. The engine
ID is used to compute the security digest for authenticating and
encrypting packets sent to a user on the remote host. Assign a user
associated with an SNMPv3 group.

Assign the authentication type:

• MD5—Sets the message digest algorithm (MD5) as the
authentication type.

• SHA—Sets the secure hash algorithm (SHA) as the authentication
type.

Assign the encryption algorithm:

• Advanced Encryption Standard (privayc-aes128)

• Triple Data Encryption Standard (privacy-3des)

• Data Encryption Standard (privacy-des)

Configure the plain-text password used to generate the key used for
encryption meeting these requirements on a device:

• The passwordmust be at least eight characters long.

• The password can include alphabetic, numeric, and special
characters, but not control characters.

Specifies USM
information.

Usm
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Table 174: Configuring V3 Fields (continued)

Your ActionFunctionOption

1. Expand the V3 tree and select Vacm.

2. Configure the following to create and define an entry:

• Comment—Enter a comment for this VACM set.

• Access—Assign the security name toagroupofSNMPsecurity names
thatbelong to thesameanSNMPaccesspolicyanddefine theaccess
privileges for this group. Users belonging to a particular SNMP group
inherit all access privileges granted to that group. Specify a context
prefix for this group or a default context prefix for all VACM entries by
configuring the context security model and entering a comment for
the context security model.

Specify this group’s security model:

• Any

• usm—SNMPv3 security model

• v1—SNMPv1 message process model

• v2c—SNMPv2cmessage process model

Specify this group’s security level:

• authentication—Provides authentication but no encryption.

• none—No authentication and no encryption.

• privacy—Provides authentication and encryption.

Designate the level of security view access.

• Read View—Provides read access.

• Write View—Provides write access.

• Notify View—Provides notify access, in which a list of notifications
is sent to each user in this group.

• Security To Group—Configure the group to which a specific security
name belongs. Assign the security name to a group of SNMP security
names that belong to the same SNMP access policy and define the
access privileges for this group. Users belonging to a particular SNMP
group inherit all access privileges granted to that group.

Specify this group’s security model:

• usm—SNMPv3 security model.

• v1—SNMPv1 message process model

• v2c—SNMPv2cmessage process model.

Specifies the VACM
information.

Vacm

Related
Documentation

• Configuring SNMP Trap Groups (NSM Procedure) on page 250
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CHAPTER 16

Configuring System for J Series Services
Routers and SRX Series Services
Gateways

• Configuring Accounting (NSM Procedure) on page 278

• Configuring Archival (NSM Procedure) on page 281

• Configuring ARP (NSM Procedure) on page 282

• Configuring Authentication Order (NSM Procedure) on page 283

• Configuring Auto Configuration (NSM Procedure) on page 284

• Configuring a Backup Router (NSM Procedure) on page 285

• Configuring a Commit (NSM Procedure) on page 286

• Configuring Diag Port Authentication (NSM Procedure) on page 287

• Configuring a Domain Search (NSM Procedure) on page 287

• Configuring Extensions (NSM Procedure) on page 288

• Configuring an Inet6 Backup Router (NSM Procedure) on page 291

• Configuring Internet Options (NSM Procedure) on page 292

• Configuring Location (NSM Procedure) on page 294

• Configuring Login (NSM Procedure) on page 296

• Configuring a Name Server (NSM Procedure) on page 301

• Configuring PIC Console Authentication (NSM Procedure) on page 302

• Configuring Ports (NSM Procedure) on page 302

• Configuring RADIUS Options (NSM Procedure) on page 303

• Configuring RADIUS Server (NSM Procedure) on page 304

• Configuring Root Authentication (NSM Procedure) on page 305

• Configuring Static Host Mapping (NSM Procedure) on page 306

• Configuring TACACS+ Options (NSM Procedure) on page 307

• Configuring TACACS+ Server (NSM Procedure) on page 308
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Configuring Accounting (NSMProcedure)

The accounting feature directs the voice daemon to generate and collect call records,

write them to a file, and store them in an archive.

To configure the accounting feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the accounting feature.

3. Click the Configuration tab. In the configuration tree, select System > Accounting.

4. Enter a comment in the Accounting workspace that describes the accounting.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the accounting parameters.

You can configure the following options with accounting feature:

• Configuring Destination on page 278

• Configuring Events on page 280

• Configuring Traceoptions on page 280

Configuring Destination

To configure destination:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the destination.

3. Click the Configuration tab. In the configuration tree, select System > Accounting >

Destination.

4. Select the Enable Feature check box to enable this feature.

5. Enter a comment in the Destination workspace that describes the destination.

6. Add or modify settings as specified in Table 175 on page 279.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the destination settings.
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Table 175: Destination Configuration Details

Your ActionFunctionOption

System > Accounting > Destination > Radius

Select the Enable Feature check box to enable
this feature.

Enables to configure the radius feature of the
destination option.

Enable Feature

(Optional) Enter a comment.Supplies a descriptive comment for the radius.Comment

System > Accounting > Destination > Radius > Server

Enter the radius server address name.Specifies the radius server address name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the radius
server.

Comment

Set the radius server authenticationport number.
Range: 1 - 65535.

Specifies the radius server authentication port
number.

Port

Set the radius server accounting port number.
Range: 1 - 65535.

Specifies the radiusserveraccountingportnumber.Accounting Port

Enter the password for the secretwith the radius
server.

Specifies the shared secret with the radius server.Secret

Set the request timeout period of the radius
server. Range: 1 - 90.

Specifies the request timeout period of the radius
server.

Timeout

Set the retry attempts. Range: 1 - 10.Specifies the number of retry attempts.Retry

Enter a source address for the radius.Specifies the source address of the radius.Source Address

System > Accounting > Destination > Tacplus

Select the Enable Feature check box to enable
this feature.

Enables to configure the tacplus feature of the
destination option.

Enable Feature

(Optional) Enter a comment.Supplies a descriptive comment for the tacplus.Comment

System > Accounting > Destination > Tacplus > Server

Enter the TACACS+ authentication server
address name.

Specifies the TACACS+ authentication server
address name.

Name

(Optional) Enter a comment.Supplies a descriptive comment for the TACACS+
authentication server.

Comment

Set the TACACS+ authentication server port
number. Range: 1 - 65535.

Specifies the TACACS+authentication server port
number.

Port

Enter the password for the secret with the
authentication server.

Specifies thesharedsecretwith theauthentication
server.

Secret
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Table 175: Destination Configuration Details (continued)

Your ActionFunctionOption

Set the request timeout period of the
authentication server. Range: 1 - 90.

Specifies the request time period of the
authentication server.

Timeout

Enable theSingleConnectioncheckbox toenable
this feature.

Specifies the attempts that the optimize TCP
connection tries.

Single Connection

Enter a source address for the authentication
server.

Specifies thesourceaddressof theauthentication
server.

Source Address

Configuring Events

To configure events:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the events.

3. Click the Configuration tab. In the configuration tree, select System > Accounting >

Events.

4. Click + to add a new event.

5. Select the available event from the list.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the event settings.

Configuring Traceoptions

The traceoptions feature allows you to configure file and flag options.

To configure traceoptions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the traceoptions.

3. Click the Configuration tab. In the configuration tree, select System > Accounting >

Traceoptions.

4. Enter a comment for the traceoptions.

5. Select the No Remote Trace check box to enable remote tracing.

6. Add or modify settings as specified in Table 176 on page 281.

7. Click one:
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• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the traceoptions settings.

Table 176: File and Flag Configuration Details

Your ActionFunctionOption

System > Accounting > Traceoptions > File

(Optional) Enter a comment.Supplies a descriptive comment for the filename.Comment

Enter a filename.Specifies the filename to write the traceoptions.Filename

Enter the maximum file size.Specifies the maximum size of the trace files.Size

Set the maximum number of trace files.
Range: 2 - 1000.

Specifies the maximum number of trace files.Files

Select the option.Specifies that neither theworld-readable nor the
no-world-readable option is enabled.

None

(Optional) Select the option.Allows any user to read the log file.world-readable

(Optional) Select the option.Prevents any user from reading the log file.no-world-readable

System > Accounting > Traceoptions > Flag

Enter a trace flag name.Specifies the trace flag name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the trace flag.Comment

Related
Documentation

Configuring Archival (NSM Procedure) on page 281•

• Configuring ARP (NSM Procedure) on page 282

• Configuring Auto Configuration (NSM Procedure) on page 284

Configuring Archival (NSMProcedure)

To configure the archival feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the archival feature.

3. Click the Configuration tab. In the configuration tree, select System > Archival.

4. Enter a comment in the Archival workspace that describes the archival feature.

5. In the configuration tree, select System > Archival > Configuration.
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6. Enter a comment in the Configuration workspace that describes the configuration of

the archival feature.

7. Add or modify settings as specified in Table 177 on page 282.

8. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the archival configuration settings.

Table 177: Archival Configuration Details

Your ActionFunctionOption

System > Archival > Configuration > Archive Sites

Enter a flag name.Specifies the URLs to receive the configuration files.Name

(Optional) Enter a comment.Supplies a descriptive comment for the archive site.Comment

Enter the password.Specifies the password to login into the archive site.Password

System > Archival > Configuration > Transfer Interval

Set the transfer interval time. Range: 0
- 2880.

Specifies (in minutes) the interval between data
transfers.

transfer-interval

Select the transfer-on-commitcheckbox
to enable this feature.

Configures the router to transfer its currently active
configuration to an archive site each time you commit
a candidate configuration.

transfer-on-commit

Related
Documentation

Configuring Accounting (NSM Procedure) on page 278•

• Configuring ARP (NSM Procedure) on page 282

• Configuring Auto Configuration (NSM Procedure) on page 284

Configuring ARP (NSMProcedure)

The address resolution protocol (ARP) is a protocol that is used to identify the hardware

address of a network host. To configure ARP:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the ARP.

3. Click the Configuration tab. In the configuration tree, select System > Arp.

4. Select Enable Feature to enable this feature.
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5. Add or modify settings as specified in Table 178 on page 283.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the ARP configuration settings.

Table 178: Arp Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the ARP.Comment

Set the aging timer value. Range: 1 - 240.Specifies the change in the ARP aging time value.Aging Timer

Select thePassiveLearningcheckbox toenable
this feature.

Specifies the ARP passive learning.Passive Learning

Select the Purging check box to enable this
feature.

Specifies that the ARP purges when the link goes
down.

Purging

Select the Gratuitous Arp On Ifup check box to
enable this feature.

Specifies the gratuitous ARP announcement on
the interface up.

Gratuitous Arp On Ifup

Set the gratuitous ARP delay value. Range:
-2147483648 - 2147483647.

Specifies the delay in the gratuitous Arp request.Gratuitous Arp Delay

System > Arp > Interfaces

(Optional) Enter a comment.Supplies a descriptive comment for the interface.Comment

System > Arp > Interfaces > Arp Interface

Enter an ARP interface name.Specifies the logical interface name for the ARP
interface.

Name

(Optional) Enter a comment.Supplies a descriptive comment for the ARP
interfaces.

Comment

Set the aging timer value. Range: 1 - 240.Specifies the change in the ARP aging time value.Aging Timer

Related
Documentation

Configuring Archival (NSM Procedure) on page 281•

• Configuring Accounting (NSM Procedure) on page 278

• Configuring Auto Configuration (NSM Procedure) on page 284

Configuring Authentication Order (NSMProcedure)

You can configure the device so that user authentication occurs with the local password

first, then with the RADIUS server, and finally with the TACACS+ server.
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To configure authentication order:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to
configure authentication order.

3. Click the Configuration tab. In the configuration tree, select System > Authentication

Order.

4. In the Authentication Order workspace, click theNew button. The New

authentication-order list appears.

5. To add RADIUS authentication to the authentication order, select radius from the

New authentication-order list.

6. To add TACACS+ authentication to the authentication order, select tacplus from the

New authentication-order list.

7. To add Password authentication to the authentication order, select password from
the New authentication-order list.

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Related
Documentation

Configuring RADIUS Authentication (NSM Procedure) on page 43•

• Configuring TACACS+ Authentication (NSM Procedure) on page 44

• Configuring User Access (NSM Procedure) on page 46

Configuring Auto Configuration (NSMProcedure)

To configure the auto configuration feature:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the auto configuration feature.

3. Click theConfiguration tab. In theconfiguration tree, selectSystem>AutoConfiguration.

4. Select Enable Feature check box to enable this feature.

5. Enter a comment in the Auto Configuration workspace that describes the auto

configuration.

6. Add or modify settings as described in Table 179 on page 285.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the auto configuration parameters.
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Table 179: Auto Configuration Traceoptions Details

Your ActionFunctionOption

System > Auto Configuration > Traceoptions

(Optional) Enter a comment.Supplies adescriptive comment for the traceoptions.Comment

Select the No remote Trace check box to
enable this feature.

Specifies that the remote tracing is disabled, upon
selecting the check box.

No Remote Trace

Select an option from the list.Specifies the level of debugging output.Level

System > Auto Configuration > Traceoptions > File

(Optional) Enter a comment.Supplies a descriptive comment for the filename.Comment

Enter the filename.Specifies the filename in which to write the trace
information.

Filename

Enter the maximum trace file size.Specifies the maximum trace file size.Size

Set the maximum number of trace files.
Range: 2 - 1000.

Specifies the maximum number of trace files.Files

Select the option.Specifies that neither theworld-readable nor the
no-world-readable option is enabled.

None

(Optional) Select the option.Allows any user to read the log file.world-readable

(Optional) Select the option.Prevents any user from reading the log file.no-world-readable

Enter the regular expression for the lines to
be logged.

Specifies the regular expression for the lines to be
logged.

Match

System > Auto Configuration > Traceoptions > Flag

Enter a trace flag name.Specifies the trace flag name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the trace flag.Comment

Related
Documentation

Configuring ARP (NSM Procedure) on page 282•

• Configuring Archival (NSM Procedure) on page 281

• Configuring Accounting (NSM Procedure) on page 278

Configuring a Backup Router (NSMProcedure)

During the time that the router is booting, the routing protocol process (RPD) is not

running; therefore, the router has no static or default routes. When the routing protocol
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process fails to start properly, it stops the router from booting. To allow the router to

boot and also to ensure that the router is reachable over the network, you configure a

backup router. A backup router is a router that is directly connected to the local router

(that is, on the same subnet).

To configure a backup router:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the backup router.

3. Click the Configuration tab. In the configuration tree, select System > Backup Router.

4. Enter a comment in the Backup Router workspace that describes the backup router.

5. Enter an address in the Backup Router workspace for the backup router to use while

booting.

6. In the configuration tree, select System > Backup Router > Destination.

7. Click + to enter a new destination address for the backup router.

8. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the backup router configuration settings.

Related
Documentation

Configuring Authentication Order (NSM Procedure) on page 45•

• Configuring Auto Configuration (NSM Procedure) on page 284

• Configuring a Commit (NSM Procedure) on page 286

Configuring a Commit (NSMProcedure)

You can configure a commit to automatically result in a commit and synchronize the

actions between dual routing engines within the same chassis.

To configure a commit:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the commit.

3. Click the Configuration tab. In the configuration tree, select System > Commit.

4. Enter a comment in the Commit workspace that describes the commit.

5. Select theSynchronizecheckbox in theCommitworkspace, to synchronize thecommit

on both the routing engines.

6. Click one:
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• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the commit settings.

Related
Documentation

Configuring Diag Port Authentication (NSM Procedure) on page 287•

• Configuring a Domain Search (NSM Procedure) on page 287

• Configuring a Backup Router (NSM Procedure) on page 285

Configuring Diag Port Authentication (NSMProcedure)

You can configure passwords for performing diagnostics on the router's System Control

Board(SCB),SystemandSwitchBoard(SSB),SwitchingandForwardingModule (SFM),

orForwardingEngineBoard(FEB)ports.Thispasswordprovidesanextra levelof security.

To configure diag port authentication:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the diag port authentication.

3. Click the Configuration tab. In the configuration tree, select System > Diag Port

Authentication.

4. In the Diag Port Authentication workspace, enter a plain text password value.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the diag port authentication settings.

Related
Documentation

Configuring a Domain Search (NSM Procedure) on page 287•

• Configuring a Backup Router (NSM Procedure) on page 285

• Configuring Extensions (NSM Procedure) on page 288

Configuring a Domain Search (NSMProcedure)

You can configure the nameof the domain inwhich the clients search for a dynamic host

configurationprotocol (DHCP)server host. Thedomainname isappended tohostnames

that are not fully qualified. If you do not configure a domain name, the default is the

client’s current domain. The domain search sets the order in which the clients append

domain nameswhen searching for the IP address of a host. You can include one ormore

domain names in the list.
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To configure a domain search:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the domain search.

3. Click the Configuration tab. In the configuration tree, select System > Domain Search.

4. Click + to enter a new domain search name.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the domain search settings.

Related
Documentation

Configuring a Backup Router (NSM Procedure) on page 285•

• Configuring Extensions (NSM Procedure) on page 288

• Configuring Diag Port Authentication (NSM Procedure) on page 287

Configuring Extensions (NSMProcedure)

The extensions feature allows you to configure the providers and the resource limits.

To configure extensions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the extensions feature.

3. Click the Configuration tab. In the configuration tree, select System > Extensions.

4. Select Enable Feature check box to enable this feature.

5. Enter a comment for the extensions feature.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the extensions parameters.

• Configuring Providers on page 289

• Configuring Resource Limits on page 289
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Configuring Providers

To configure providers:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the providers.

3. Click the Configuration tab. In the configuration tree, select System > Extensions >

Providers.

4. Add or modify settings as specified in Table 180 on page 289.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the provider settings.

Table 180: Provider Configuration Details

Your ActionFunctionOption

Enter a provider name.Specifies the provider name.Name

(Optional) Enter a comment.Suppliesadescriptivecomment for theprovider.Comment

Enter a new deployment scope name.Specifies the deployment scope.New deployment-scope

Configuring Resource Limits

To configure resource limits:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the resource limits.

3. Click the Configuration tab. In the configuration tree, select System > Extensions >

Resource Limits.

4. Enter a comment for the resource limits.

5. Add or modify settings as specified in Table 181 on page 290.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the resource limits settings.
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NOTE: You can configure a package or a process resource limit feature from
the below table.

Table 181: Resource Limits Configuration Details

Your ActionFunctionOption

Enter a name.Specifies thenameof thepackageor theprocess resource
limit.

Name

(Optional) Enter a comment.Supplies a descriptive comment for the package or the
process resource limit.

Comment

package/process > Resources

Select the Enable Feature check box to
enable this feature.

Specifies that you can enable the package or the process
resources configuration feature.

Enable Feature

(Optional) Enter a comment.Supplies a descriptive comment for the package or the
process resources.

Comment

package/process > Resources > Cpu

(Optional) Enter a commentSupplies a descriptive comment for the CPU.Comment

Set the priority value. Range:
-2147483648 - 2147483647.

Specifies the highest priority level that the process can
run.

Priority

Set theCPUtime.Range:0 -2147483647.Specifies themaximumamount of CPU time that can be
accumulated.

Time

package/process > Resources > File

(Optional) Enter a comment.Supplies a descriptive comment for the file.Comment

Enter the file size.Specifies the maximum size of a file that can be created.Size

Set the number of open files. Range: 0 -
2147483647.

Specifies the maximum number of simultaneous open
files.

Open

Enter the core file size.Specifies the maximum size of a core file that can be
created.

Core Size

package/process > Resources > Memory

(Optional) Enter a comment.Supplies a descriptive comment for the memory.Comment

Enter the data size.Specifies the maximum size of the data segment.Data Size

Enter the locked in size.Specifies the maximum bytes that the memory can lock
into it.

Locked In
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Table 181: Resource Limits Configuration Details (continued)

Your ActionFunctionOption

Enter the resident set size.Specifies the maximum amount of private physical
memory at any givenmoment.

Resident Set Size

Enter the memory size for the socket
buffers.

Specifies themaximumamount of physicalmemory that
may be dedicated to the socket buffers.

Socket Buffers

Enter the stack segment size.Specifies the maximum size of the stack segment.Stack Size

Related
Documentation

Configuring a Domain Search (NSM Procedure) on page 287•

• Configuring Diag Port Authentication (NSM Procedure) on page 287

• Configuring a Commit (NSM Procedure) on page 286

Configuring an Inet6 Backup Router (NSMProcedure)

You can configure a backup router running Internet Protocol Version 6 (IPv6). This is to

use while the local router or switch (running IPv6) is booting and if the routing protocol

processes fail to start. The Junos OS removes the route to this router or switch as soon

as the software starts.

To configure an Inet6 backup router:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the Inet6 backup router.

3. Click the Configuration tab. In the configuration tree, select System > Inet6 Backup

Router.

4. Add or modify the settings as described in Table 182 on page 291.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the Inet6 backup router settings.

Table 182: Inet6 Backup Router Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment of the Inet6 backup
router.

Comment

Enter an address name for the router.Specifies the address of the router to usewhile booting.Address

Enter the destination name for the router.Specifies the destination network that is reachable
through the router.

Destination
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Related
Documentation

Configuring Internet Options (NSM Procedure) on page 292•

• Configuring Location (NSM Procedure) on page 294

• Configuring Login (NSM Procedure) on page 296

Configuring Internet Options (NSMProcedure)

Youcanconfigure the system InternetProtocol (IP)options toprotect the systemagainst

certain types of Denial of Service (DoS) attacks.

To configure internet options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the internet options.

3. Click theConfiguration tab. In the configuration tree, select System> InternetOptions.

4. Add or modify the settings as specified in Table 183 on page 292.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the internet options configuration settings.

Table 183: Internet Options Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the
internet option.

Comment

Select an option.

• path-mtu-discovery-Path MTU discovery is
enabled.

• no-path-mtu-discovery-PathMTUdiscovery is
disabled.

• None-Path MTU discovery is neither enabled
nor disabled.

Specifies that you can determine the
Maximum Transmission Unit (MTU) size
on thenetworkpathbetween two IPhosts.

None / path-mtu-discovery /
no-path-mtu-discovery

Select an option.

• gre-path-mtu-discovery-GRE path MTU
discovery is enabled.

• no-gre-path-mtu-discovery-GRE path MTU
discovery is disabled.

• None-GRE path MTU discovery is neither
enabled nor disabled.

Specifies that you can configure a path
MTU discovery for outgoing Generic
Routing Encapsulation (GRE) tunnel
connections.

None /
gre-path-mtu-discovery /
no-gre-path-mtu-discovery
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Table 183: Internet Options Configuration Details (continued)

Your ActionFunctionOption

Select an option.

• ipip-path-mtu-discovery-IP-IP path MTU
discovery is enabled.

• no-ipip-path-mtu-discovery-IP-IP path MTU
discovery is disabled.

• None-IP-IP path MTU discovery is neither
enabled nor disabled.

Specifies that you canconfigure pathMTU
discovery for outgoing IP-IP tunnel
connections.

None /
ipip-path-mtu-discovery /
no-ipip-path-mtu-discovery

Select an option:

• source-quench-The JunosOS ignores the ICMP
source quenchmessages.

• no-source-quench-The Junos OS does not
ignore the ICMP source quenchmessages.

• None-ICMP source quenchmessage is neither
enabled nor disabled.

Specifies that you can configure how the
Junos OSwould handle the Internet
Control Message Protocol (ICMP) source
quenchmessages.

None / source-quench /
no-source-quench

Select TcpDrop Synfin Set to enable this feature.Specifies that the TCP packets that have
both SYN and FIN flags can be dropped.

Tcp Drop Synfin Set

Select No Tcp Rfc1323 to enable this feature.Specifies that you can configure the Junos
OS to disable RFC 1323 TCP extensions.

No Tcp Rfc1323

Select No Tcp Rfc1323 Paws to enable this
feature.

Specifies that you can configure the Junos
OS to disable the RFC 1323 Protection
Against Wrapped Sequence (PAWS)
number extension.

No Tcp Rfc1323 Paws

Select an option.

• ipv6-reject-zero-hop-limit-Rejection of
incoming IPv6 packets that have a zero
hop-limit value is enabled.

• no-ipv6-reject-zero-hop-limit-Rejection of
incoming IPv6 packets that have a zero
hop-limit value is disabled.

• None-Rejectionof incoming IPv6packets that
have a zero hop-limit value is neither enabled
nor disabled.

Specifies that you can enable and disable
rejection of incoming IPv6 packets that
have a zero hop-limit value in their header.

None /
ipv6-reject-zero-hop-limit /
no-ipv6-reject-zero-hop-limit

Set the number of attempts. Range: 0 -
4,294,967,295. Default value is 3.

Specifies the number of attempts for IPv6
duplicate address detection that can be
controlled.

IPv6DuplicateAddrDetection
Transmits
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Table 183: Internet Options Configuration Details (continued)

Your ActionFunctionOption

Select an option.

• ipv6-path-mtu-discovery-IPv6 path MTU
discovery is enabled.

• no-ipv6-path-mtu-discovery-IPv6 path MTU
discovery is disabled.

• None-IPv6 path MTU discovery is neither
enabled nor disabled.

Specifies that you canconfigure pathMTU
discovery for IPv6 packets.

None /
ipv6-path-mtu-discovery /
no-ipv6-path-mtu-discovery

Set the IPv6pathMTUdiscovery timeout.Range:
0 - 4,294,967,295. Default value is 10.

Specifies the IPv6 path MTU discovery
timeout.

IPv6 Path Mtu Discovery
Timeout

Select an option from the list.Specifies not to send the reset RST TCP
packet for packets sent to non-listening
ports.

No Tcp Reset

Internet Options > Icmpv4 Rate Limit / Icmpv6 Rate Limit

(Optional) Enter a comment.Supplies a descriptive comment for the
ICMPv4/ICMPv6 rate limit.

Comment

Set the packet rate value. Range: 0 -
4,294,967,295. Default value is 1,000.

Specifies the ICMP rate-limiting packets
earned per second.

Packet Rate

Set the bucket size value. Range: 0 -
4,294,967,295. Default value is 5.

Specifies themaximumbucket size for the
ICMP rate limit.

Bucket Size

Internet Options > Source Port

(Optional) Enter a comment.Supplies a descriptive comment for the
source port.

Comment

Set the upper limit value. Range: 5,000 -65,535.
Default value is none.

Specifies the upper limit of the sourceport
selection range.

Upper Limit

Related
Documentation

Configuring an Inet6 Backup Router (NSM Procedure) on page 291•

• Configuring Extensions (NSM Procedure) on page 288

• Configuring a Name Server (NSM Procedure) on page 301

Configuring Location (NSMProcedure)

To configure location:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a location.
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3. Click the Configuration tab. In the configuration tree, select System > Location.

4. Add or modify the settings as specified in Table 184 on page 295.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the location settings.

Table 184: Location Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the location.Comment

Enter the country code for the location.Specifies the two letter country code for the location.Country Code

Enter the zip code or the postal code of the
location.

Specifies the zip code or the postal code for the
location.

Postal Code

Enter the phone number (area code with the
exchange number).

Specifies the first six digits of the phone number
(area code with the exchange number).

Npa Nxx

Enter the latitude of the location.Specifies the latitude in degree format.Latitude

Enter the longitude of the location.Specifies the longitude in degree format.Longitude

Set the altitude of the location. Range:
-2147483648 - 2147483647.

Specifies (in degrees) the altitude (feet above or
below the sea level).

Altitude

Enter a longdistance serviceareaof the location.Specifies the long distance service area.Lata

Enter a Bellcore vertical coordinate value.Specifies theBellcorevertical coordinate information.Vcoord

Enter a Bellcore horizontal coordinate value.Specifies the Bellcore horizontal coordinate
information.

Hcoord

Enter the building name.Specifies the building name.Building

Enter the floor of the building.Specifies the floor of the building.Floor

Enter the rack number.Specifies the rack number.Rack

Location > Lcc

Set a name for the LCC number. Range: 0 - 3.Specifies the name for the LCC number.Name

(Optional) Enter a comment.Supplies a descriptive comment for the LCC.Comment

Enter the floor of the building.Specifies the floor of the building.Floor
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Table 184: Location Details (continued)

Your ActionFunctionOption

Enter the rack number.Specifies the rack numberRack

Related
Documentation

Configuring an Inet6 Backup Router (NSM Procedure) on page 291•

• Configuring Internet Options (NSM Procedure) on page 292

• Configuring a Name Server (NSM Procedure) on page 301

Configuring Login (NSMProcedure)

By default, no login message is displayed. A system login message appears before the

user logs in. A system login announcement appears after the user logs in.

To configure the login message:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the login message.

3. Click the Configuration tab. In the configuration tree, select System > Login.

4. Enter a comment in the Login workspace that describes the system login.

5. Enter an announcement in the Login workspace that describes the system

announcement message.

6. Enter a message in the Login workspace that describes the system login message.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the login parameters.

You can configure the following options while configuring a system login:

• Configuring Class on page 297

• Configuring Password on page 298

• Configuring Retry Options on page 299

• Configuring User on page 300
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Configuring Class

To configure class:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the class.

3. Click the Configuration tab. In the configuration tree, select System > Login > Class.

4. Add or modify settings as specified in Table 185 on page 297.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the class settings.

Table 185: Class Configuration Details

Your ActionFunctionOption

System > Login > Class > class

Enter the login class name.Specifies the login class name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the class.Comment

Enter the start time in hh:mm format.Specifies the start time for the remote access.Access Start

Enter the end time in hh:mm format.Specifies the end time for the remote access.Access End

Set the maximum idle time. Range: 0 -
4,294,967,295.

Specifies themaximum idle time before logging out.Idle Timeout

Enable the Login Alarms check box to
enable this feature.

Specifies the display system alarms when logging
in.

Login Alarms

Enter a login script.Specifies that you can execute this login script while
logging in.

Login Script

Enable the Login Tip check box to enable
this feature.

Specifies the display login tip when logging in.Login Tip

Enter the allow commands.Specifies the regular expression for commands to
allow explicitly.

Allow Commands

Enter the deny commands.Specifies the regular expression for commands to
deny explicitly.

Deny Commands

Enter the allow configure commands.Specifies the regular expression for configuring the
class to allow explicitly.

Allow Configuration
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Table 185: Class Configuration Details (continued)

Your ActionFunctionOption

Enter the deny configure commands.Specifies the regular expression for configuring the
class to deny explicitly.

Deny Configuration

System > Login > Class > class > Allowed Days

Select a day of the week from the list.Specifies the day of the week that is allowed to
configure the class.

New allowed-days

System > Login > Class > class > Permissions

Enter the permission.Specifies the permission required to configure the
class.

New permissions

Configuring Password

To configure password:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the password.

3. Click theConfiguration tab. In the configuration tree, selectSystem> Login>Password.

4. Add or modify settings as described in Table 186 on page 298

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the password settings.

Table 186: Password Configuration Details

Your ActionFunctionOption

System > Login > Password

(Optional) Enter a comment.Supplies adescriptive comment for thepassword.Comment

Set the minimum password length size. Range:
6 - 20.

Specifies the minimum password length size for
all users.

Minimum Length

Set the maximum password length size. Range:
20 - 128.

Specifies the maximum password length size for
all users.

Maximum Length
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Table 186: Password Configuration Details (continued)

Your ActionFunctionOption

Select an option from the list.

• character-sets-The total number of character
sets used.

• set-transitions-The total number of character
set changes.

Specifies whether the password is checked for
either character-sets or set-transitions.

Change Type

Set the minimum changes required for the
password.

Specifies howmany character sets or character
set changes are required for the password.

Minimum Changes

Select eithermd5, or sha1, ordes fromthe list. The
default format ismd5.

Specifies the hash algorithm (md5, sha1 or des)
for authenticating plain-text passwords.

Format

Configuring Retry Options

The retryoptionallowsyou tocalculate themaximumnumberof timesauser canattempt

to enter a password while logging in through SSH or Telnet, before being disconnected.

To configure retry options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the retry options.

3. Click the Configuration tab. In the configuration tree, select System > Login > Retry

Options.

4. Add or modify settings as specified in Table 187 on page 299

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the retry options settings.

Table 187: Retry Options Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the retry options.Comment

Set the maximum number of times a
user is allowed to attempt to enter a
password. Range: 1 - 10.

Specifies the maximum number of times a user is allowed
to attempt to enter a password to log in through SSH or
Telnet.

Tries Before
Disconnect

Set the backoff threshold value. Range:
1 - 3.

Specifies the threshold for the number of failed login
attempts before the user experiences a delay when
attempting to reenter a password.

Backoff Threshold
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Table 187: Retry Options Configuration Details (continued)

Your ActionFunctionOption

Set the backoff factor value. Range: 5 -
10.

Specifies the lengthofdelayafter each failed loginattempt.Backoff factor

Set the minimum time. Range: 20 - 60.Specifies the minimum length of time that the connection
remains open while the user is attempting to enter a
password to log in.

Minimum Time

Set themaximumtime.Range: 20-300.Specifies themaximum length of time that the connection
remainsopen for theuser toenterausernameandpassword
to log in.

Maximum Time

Configuring User

The user configuration feature allows you to configure access permission for individual

users.

To configure a user:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the user.

3. Click the Configuration tab. In the configuration tree, select System > Login > User.

4. Add or modify settings as specified in Table 188 on page 300

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the user settings.

Table 188: User Configuration Details

Your ActionFunctionOption

System > Login > User > user

Enter the user name.Specifies the user name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the user.Comment

Enter the complete name.Specifies the complete name of the user.Full Name

Set theuser identifier. Range: 100 -64000.Specifies the user identifier for a login account.Uid

Select a login class name from the list.Specifies the login class name.Class
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Table 188: User Configuration Details (continued)

Your ActionFunctionOption

System > Login > User > user > Authentication

Enter a plain text password.Specifies theplain textpassword.Theuser interface
(UI) prompts for the password and encrypts it.

Plain Text Password Value

System > Login > User > user > Authentication > Ssh Dsa / Ssh Rsa

Enter a name.Specifies the ssh Dsa or ssh Rsa name.Name

(Optional) Enter a comment.Supplies a descriptive comment for the ssh..Comment

Enter the pattern-list of allowed hosts.Specifies the pattern list of allowed hosts.From

Related
Documentation

Configuring Location (NSM Procedure) on page 294•

• Configuring Internet Options (NSM Procedure) on page 292

• Configuring a Name Server (NSM Procedure) on page 301

Configuring a Name Server (NSMProcedure)

You can configure one or more domain name system (DNS) name servers, to have the

router resolve the host names into addresses.

To configure a DNS name server:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure the DNS name server.

3. Click the Configuration tab. In the configuration tree, select System > Name Server.

4. Click + to add a new name server.

5. Enter a DNS name server address in the name-server workspace.

6. Enter a comment for the DNS name server in the name-server workspace.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the name server settings.

Related
Documentation

Configuring Login (NSM Procedure) on page 296•

• Configuring Location (NSM Procedure) on page 294

• Configuring Internet Options (NSM Procedure) on page 292
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Configuring PIC Console Authentication (NSMProcedure)

You can configure console access to Physical Interface Cards (PICs).

To configure a PIC console authentication:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click theDeviceTree tab. Thendouble-click thedevice forwhich youwant to configure

the PIC console authentication.

3. Click the Configuration tab. In the configuration tree, select System > Pic Console

Authentication.

4. Enter a plain text password in the PIC Console Authentication workspace.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the PIC console authentication settings.

Related
Documentation

Configuring a Name Server (NSM Procedure) on page 301•

• Configuring Login (NSM Procedure) on page 296

• Configuring Location (NSM Procedure) on page 294

Configuring Ports (NSMProcedure)

The router's craft interface has two ports for connecting terminals to the router such as

auxiliary and console ports.

To configure ports:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click theDeviceTree tab. Thendouble-click thedevice forwhich youwant to configure

the ports.

3. Click the Configuration tab. In the configuration tree, select System > Ports.

4. Enter a comment in the Ports workspace that describes the ports.

5. Add or modify the settings as specified in Table 189 on page 303.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the port configuration settings.
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NOTE: You can either set auxiliary or console ports from the below table
descriptions.

Table 189: Port Configuration Details

Your ActionFunctionOption

Ports > Auxiliary/Console

(Optional) Enter a comment.Supplies a descriptive comment of the
auxiliary/console port.

Comment

Select the LogOutOnDisconnect check box to
enable this feature.

Specifies that theconsolesession logsoutwhen the
cable is unplugged.

LogOutOnDisconnect

Select the Disable check box to enable this
feature.

Specifies that the auxiliary/console port is disabled.Disable

Select the Insecure check box to enable this
feature.

Specifies that the super user access is not allowed.Insecure

Select a terminal type from the list.Specifies the terminal type of the auxiliary/console
port.

Type

Related
Documentation

Configuring PIC Console Authentication (NSM Procedure) on page 302•

• Configuring a Name Server (NSM Procedure) on page 301

• Configuring Login (NSM Procedure) on page 296

Configuring RADIUSOptions (NSMProcedure)

You can configure Remote Authentication Dial In User Service (RADIUS) options for the

NAS-IP address for outgoing RADIUS packets and password protocol used in RADIUS

packets.

To configure RADIUS options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click theDeviceTree tab. Thendouble-click thedevice forwhich youwant to configure

radius options.

3. Click the Configuration tab. In the configuration tree, select System > Radius Options.

4. Enter acomment in theRadiusOptionsworkspace thatdescribes theRADIUSoptions.

5. Select a password protocol in the Radius Options workspace that specifies the

password protocol used in the RADIUS packets.

303Copyright © 2013, Juniper Networks, Inc.

Chapter 16: Configuring System for J Series Services Routers and SRX Series Services Gateways



6. Add or modify settings as specified in the Table 190 on page 304.

7. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the radius option settings.

Table 190: Radius Option Configuration Details

Your ActionFunctionOption

Enter a comment.Supplies a descriptive comment of the attributes.Comment

Enter the NAS-IP address.Specifies thevalueofNAS-IPaddress inoutgoingRADIUS
packets.

Nas IP Address

Related
Documentation

Configuring Ports (NSM Procedure) on page 302•

• Configuring PIC Console Authentication (NSM Procedure) on page 302

• Configuring a Name Server (NSM Procedure) on page 301

Configuring RADIUS Server (NSMProcedure)

A Remote Authentication Dial-In User Service (RADIUS) server is a type of server that

allows you to centralize authentication and accounting for remote users.

To configure a RADIUS server:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click theDeviceTree tab. Thendouble-click thedevice forwhich youwant to configure

the RADIUS server.

3. Click the Configuration tab. In the configuration tree, select System > Radius Server.

4. Add or modify settings as specified in the Table 191 on page 304.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the RADIUS server settings.

Table 191: RADIUS Server Configuration Details

Your ActionFunctionOption

Enter the RADIUS server address name.Specifies the RADIUS server address name.Name

(Optional) Enter a comment.Supplies a descriptive comment of the RADIUS server.Comment
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Table 191: RADIUS Server Configuration Details (continued)

Your ActionFunctionOption

Set the RADIUS server authentication port
number. Range: 1 - 65535.

Specifies the RADIUS server authentication port number.Port

Set the RADIUS server accounting port
number. Range: 1 - 65535.

Specifies the RADIUS server accounting port number.Accounting Port

Enter the sharedsecretpassword tousewith
the RADIUS server.

Specifies thepassword tousewith theRADIUSserver. The
secret password used by the local routermustmatch that
used by the server.

Secret

Enter the request time out period. Range: 1 -
90.

Specifies the amount of time that the local router waits to
receive a response from a RADIUS server.

Timeout

Set the retry attempts. Range: 1 - 10.Specifies the number of times that the router is allowed
to attempt to contact a RADIUS authentication or
accounting server.

Retry

Enter the source address.Specifies the source address for each configured RADIUS
server.

Source Address

Related
Documentation

Configuring Ports (NSM Procedure) on page 302•

• Configuring RADIUS Options (NSM Procedure) on page 303

• Configuring a Name Server (NSM Procedure) on page 301

Configuring Root Authentication (NSMProcedure)

You can configure the authentication methods for the root-level user, whose username

is "root."

To configure root authentication:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click theDeviceTree tab. Thendouble-click thedevice forwhich youwant to configure

root authentication.

3. Click the Configuration tab. In the configuration tree, select System > Root

Authentication.

4. Enter a plaintext password in the Plain text Password Value.

NOTE: You can specify only one plain text password.

5. Add or modify settings as described in Table 192 on page 306

6. Click one:
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• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the root authentication settings.

Table 192: Root Authentication Configuration Details

Your ActionFunctionOption

System > Login > User > user > Authentication > Ssh Dsa / Ssh Rsa

Enter a name.Specifies the ssh Dsa or ssh Rsa nameName

(Optional) Enter a commentSupplies a descriptive comment for the ssh.Comment

Enter the pattern-list of allowed hosts.Specifies the pattern list of allowed hosts.From

Related
Documentation

Configuring RADIUS Server (NSM Procedure) on page 304•

• Configuring RADIUS Options (NSM Procedure) on page 303

• Configuring a Name Server (NSM Procedure) on page 301

Configuring Static Host Mapping (NSMProcedure)

You canmapahostname to one ormore IP addresses and aliases, and you can configure

an International Organization for Standardization (ISO) system identifier (system ID).

To configure static host mapping:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click theDeviceTree tab. Thendouble-click thedevice forwhich youwant to configure

static host mapping.

3. Click the Configuration tab. In the configuration tree, select System > Static Host

Mapping.

4. Click the plus sign (+) to add static host mapping.

5. Add or modify settings as specified in the Table 193 on page 306.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the static host mapping settings.

Table 193: Static Host Mapping Configuration Details

Your ActionFunctionOption

Enter the name of the system.Specifies the fully qualified nameof the system.Name
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Table 193: Static Host Mapping Configuration Details (continued)

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment of the system.Comment

Enter the system identifier address.

NOTE: We recommend to use the host’s IP address
represented in binary-coded decimal (BCD) format.

Specifies the ISO system ID. This is the 6-byte
portion of the Intermediate
System-to-IntermediateSystem(IS-IS)network
service access point (NSAP).

Sysid

static-host-mapping > Alias/Inet/Inet6

Click + to enter any one of the following:

• Alias—Specifies the alias for the hostname.

• Inet—Specifies one ormore IP addresses for the host.

• Inet6—Specifies the 6 byte IP address for the host.

Specifies the hostname information.New

Related
Documentation

Configuring Root Authentication (NSM Procedure) on page 305•

• Configuring RADIUS Server (NSM Procedure) on page 304

• Configuring RADIUS Options (NSM Procedure) on page 303

Configuring TACACS+Options (NSMProcedure)

Youcanconfigure theTACACS+options for authenticationandaccountingon thesystem.

To configure TACACS+ options:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click theDeviceTree tab. Thendouble-click thedevice forwhich youwant to configure

TACACS+ options.

3. Click the Configuration tab. In the configuration tree, select System > Tacplus options.

4. Add or modify settings as specified in the Table 194 on page 307.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the TACACS+ options settings.

Table 194: TACACS+Options Configuration Details

Your ActionFunctionOption

(Optional) Enter a comment.Supplies a descriptive comment for the TACACS+ option.Comment

Enter the TACACS+ service name.Specifies the TACACS+ service name.Service Name
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Table 194: TACACS+Options Configuration Details (continued)

Your ActionFunctionOption

Select the None check box to enable
this feature.

Specifies hostname information.None

Select the no-cmd-attribute-value
check box to enable this feature.

Specifies the command attribute value to an empty string
in the start and stop request for TACACS+ accounting.
This option enables logging of accounting records in the
correct log file on a TACACS+ server.

no-cmd-attribute-value

Select theexclude-cmd-attributecheck
box to enable this feature.

Specifies to exclude the command attribute value
completely from start and stop accounting records. This
optionenables loggingof accounting records in thecorrect
log file on a TACACS+ server.

exclude-cmd-attribute

Related
Documentation

Configuring Root Authentication (NSM Procedure) on page 305•

• Configuring RADIUS Server (NSM Procedure) on page 304

• Configuring Static Host Mapping (NSM Procedure) on page 306

Configuring TACACS+ Server (NSMProcedure)

To configure a TACACS+ server:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click theDeviceTree tab. Thendouble-click thedevice forwhich youwant to configure

the TACACS+ server.

3. Click the Configuration tab. In the configuration tree, select System > Tacplus Server.

4. Add or modify settings as specified in the Table 195 on page 308.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

• Apply—Applies the TACACS+ server settings.

Table 195: TACACS+ Server Configuration Details

Your ActionFunctionOption

Enter the TACACS+ authentication server
address name.

Specifies the TACACS+ authentication server address.Name

(Optional) Enter a comment.Supplies a descriptive comment of the TACACS+ server.Comment

Set the TACACS+ authentication server port
number. Range: 0 - 65535.

Specifies the TACACS+ authentication server port
number.

Port
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Table 195: TACACS+ Server Configuration Details (continued)

Your ActionFunctionOption

Enter the secret password.

NOTE: The secret password used by the local
router must match that used by the server.

Specifies the password to usewith the TACACS+ server.Secret

Set the timeout for the response from the
TACACS+ server. Range: 1 - 90.

Specifies the amount of time that the local router waits
to receive a response from the TACACS+ server.

Timeout

Select the Single Connection check box to
enable this feature.

Specifies the number of attempts needed to connect to
a TACACS+ server.

NOTE: The software maintains one open TCP
connection to the server for multiple requests, rather
thanopeningaconnection for eachconnectionattempt.

SingleConnection

Enter the source address name.Specifies the source address for the TACACS+ server.Source Address

Related
Documentation

• Configuring TACACS+ Options (NSM Procedure) on page 307

• Configuring RADIUS Server (NSM Procedure) on page 304

• Configuring Static Host Mapping (NSM Procedure) on page 306
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CHAPTER 17

Configuring J Series Services Routers and
SRX Series Services Gateways for DHCP

• Configuring the Device as a DHCP Server (NSM Procedure) on page 311

• Configuring the Device as a DHCP Client (NSM Procedure) on page 313

Configuring the Device as a DHCP Server (NSMProcedure)

TheDynamicHostConfigurationProtocol (DHCP)serverprovidesa framework forpassing

configuration information to client hosts (such as PCs) on a TCP/IP network. A router or

interface that acts as a DHCP server can allocate network IP addresses and deliver

configuration settings to client hosts without user intervention. DHCP access service

minimizes the overhead required to add clients to the network by providing a centralized,

server-based setup. You do not have to manually create andmaintain IP address

assignments for clients.

To configure the device as a DHCP server for a subnet and a single client:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to

configure a DHCP server.

3. Click the Configuration tab. In the configuration tree, select System>Services > Dhcp.

4. Add or modify DHCP settings as specified in Table 196 on page 311.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 196: DHCP Server Configuration Details

Your ActionFunctionOption

Select the maximum lease
time.

Specifies themaximumlength
of time in seconds for which a
client can request and hold a
lease on a DHCP server.

Maximum Lease Time
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Table 196: DHCP Server Configuration Details (continued)

Your ActionFunctionOption

Select the default lease time.Specifies the length of time in
seconds thataclientholds the
lease for an IP address
assigned by a DHCP server.
This setting is used if a lease
time is not requested by the
client.

Default Lease Time

Enter the domain name.Specifies the name of the
domain inwhichclients search
for a DHCP server host. This is
the default domain name that
is appended to hostnames
that are not fully qualified.

Domain Name

Enter the location of the boot
file on the boot server. The
filename can include a path
name.

Specifies the boot file
advertised to DHCP clients.
After the client receives an IP
address and the boot file
location fromtheDHCPserver,
the client uses the boot image
stored in the boot file to
complete DHCP setup.

Boot File

Enter the address of a boot
server. Youmust specify an
IPv4address, not a hostname.

Specifies thenameof theboot
server advertised to DHCP
clients. The client uses a boot
file located on the boot server
to complete DHCP setup.

Boot Server

Enter the IPv4 address of the
server. This address must be
accessiblebyall clients served
within a specified range of
addresses (based on an
addresspoolor staticbinding).

Specifies the server identifier.
This is an optional setting that
canbeused to identify aDHCP
server in a DHCPmessage.

Server Identifier

Dhcp > Pool

Enter the IP address pool
range.

Specifies the logical subnet
address or netmask.

Name

Enter the IP address.Specifies lowest IP address in
the pool that is available for
dynamic address assignment.

Low

Enter the IP address.Specifies highest IP address in
the pool that is available for
dynamic address assignment.

High

Dhcp > Domain Search

Copyright © 2013, Juniper Networks, Inc.312

Configuring J Series Services Routers and SRX Series Services Gateways Guide



Table 196: DHCP Server Configuration Details (continued)

Your ActionFunctionOption

Enter the listofdomainnames
to search. The list can contain
up to 6 domain names, with a
total of up to 256 characters.

Specifies the domain search
suffixes to be used by the
clients.

Name

Dhcp > Name Server

Enter the address of the name
server. To configure multiple
nameservers, includemultiple
address options.

Defines a Domain Name
System (DNS) name server.

Name

Dhcp >Option

Select the ID number.Specifies the ID number that
indexes the option andmust
be unique across a DHCP
server.

Name

Select the option type.Specifies the option type.Flag

Dhcp > Static Binding

Enter the MAC address of the
client.

Specifies the MAC address of
the client. This is a hardware
address that uniquely
identifies a client on the
network.

Name

Dhcp > Static Binding > Fixed Address

Enter the fixed IP address.Specifies the fixed IP address
assigned to the client.
Typically a client has one
address assigned, but you can
assign more.

Name

Related
Documentation

Configuring the Device as a DHCP Client (NSM Procedure) on page 313•

Configuring the Device as a DHCP Client (NSMProcedure)

A device can act as a DHCP client, receiving its TCP/IP settings and the IP address for

any physical interface in any security zone from an external DHCP server. The device can

also act as a DHCP server, providing TCP/IP settings and IP addresses to clients in any

zone.

To configure the device as a DHCP client:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab and then double-click the device for which you want to

configure a DHCP client.

313Copyright © 2013, Juniper Networks, Inc.

Chapter 17: Configuring J Series Services Routers and SRX Series Services Gateways for DHCP



3. Click the Configuration tab. In the configuration tree, select Interfaces.

4. Select the interface on which you want to configure DHCP client information, and

select Unit > Family > Inet > Dhcp.

5. Click Enable next to Dhcp, and add or modify DHCP settings as specified in Table 197

on page 314.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 197: DHCP Client Configuration Details

Your ActionFunctionOption

Enter the DHCP lease time in
seconds.

Specifies theDHCP lease time
in seconds.

Lease Time

Enter the number of attempts
allowed to retransmit a DHCP
packet.

Specifies the number of
attempts allowed to
retransmit a DHCP packet.

Retransmission Attempt

Enter the interval allowed
between retransmission
attempts in seconds.

Specifies the interval allowed
between retransmission
attempts in seconds.

Retransmission Interval

Enter the IPv4 address of the
preferred DHCP server.

Specifies the IPv4 address of
the preferred DHCP server.

Server Address

Enter the vendor class ID.Specifies the vendor class ID
for the DHCP client.

Vendor Id

Dhcp > Client Identifier

Select the DHCP client
identifier, and type the ASCII
or hexadecimal value.

Specifies the DHCP client
identifier as either an ASCII or
hexadecimal value.

Ascii

Related
Documentation

• Configuring the Device as a DHCP Server (NSM Procedure) on page 311
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CHAPTER 18

Configuring Class of Service in J Series
Services Routers and SRX Series Services
Gateways

• Configuring CoS Classifiers (NSM Procedure) on page 316

• Configuring CoS Code Point Aliases (NSM Procedure) on page 318

• Configuring CoS Drop Profile (NSM Procedure) on page 319

• Configuring CoS Forwarding Classes (NSM Procedure) on page 321

• Configuring CoS Forwarding Policy (NSM Procedure) on page 323

• Configuring CoS Fragmentation Maps (NSM Procedure) on page 324

• Configuring CoS Host Outbound Traffic (NSM Procedure) on page 325

• Configuring CoS Interfaces (NSM Procedure) on page 326

• Configuring CoS Rewrite Rules (NSM Procedure) on page 332

• Configuring CoS Schedulers (NSM Procedure) on page 335

• Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 336

• Configuring CoS Traffic Control Profiles (NSM Procedure) on page 338
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Configuring CoS Classifiers (NSMProcedure)

Packet classification associates incoming packets with a particular class-of-service

(Cos) servicing level. Classifiers associatepacketswitha forwarding classand losspriority

and, based on the associated forwarding class, assign packets to output queues. Junos

OS supports two general types of classifiers:

• Behavior aggregate or CoS value traffic classifiers—Examines the CoS value in the

packet header. The value in this single field determines the CoS settings applied to the

packet. BA classifiers allow you to set the forwarding class and loss priority of a packet

based on the Differentiated Services code point (DSCP) value, IP precedence value,

and IEEE 802.1p value. The default classifier is based on the DSCP value.

• Multifield traffic classifiers—Examinesmultiple fields in the packet such as source and

destination addresses and source and destination port numbers of the packet. With

multifield classifiers, you set the forwarding class and loss priority of a packet based

on firewall filter rules.

To configure and apply behavior aggregate classifiers for the switch:

1. In the navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure and apply behavior aggregate classifiers.

3. Click the Configuration tab. In the configuration tree expand Class of Service.

4. Select Classifiers.

5. Add or modify settings as specified in Table 198 on page 316.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See theNetwork
and Security Manager Administration Guide for more information.

Table 198: Configuring and Applying Behavior Aggregate Classifiers

ActionTask

1. Click Add new entry next to Dscp.

2. In the Name box, type the name of the behavior aggregate classifier—for example,
ba-classifier.

3. In the Import box, type the name of the default DSCPmap.

Configure behavior aggregate
classifiers for DiffServ CoS.
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Table 198: Configuring and Applying Behavior Aggregate Classifiers (continued)

ActionTask

1. Click Add new entry next to Forwarding class.

2. In theClassnamebox, type thenameof thepreviously configuredbest-effort forwarding
class—for example, be-class.

3. Click Add new entry next to Loss priority.

4. From the Loss val list, select high.

5. Click Add new entry next to Code points.

6. In the Value box, type the value of the high-priority code point for best-effort traffic—for
example, 00001.

7. ClickOK three times.

Configure a best-effort
forwarding class classifier.

1. Click Add new entry next to Forwarding class.

2. In the Class name box, type the name of the previously configured expedited
forwarding—for example, class-ef-class.

3. Click Add new entry next to Loss priority.

4. From the Loss val list, select high.

5. Click Add new entry next to Code points.

6. In the Value box, type the value of the high-priority code point for expedited forwarding
traffic—for example, 101111.

7. ClickOK three times.

Configure an expedited
forwarding class classifier.

1. Click Add new entry next to Forwarding class.

2. In theClassnamebox, type thenameof thepreviously configuredassured forwarding—for
example, class-af-class.

3. Click Add new entry next to Loss priority.

4. From the Loss val list, select high.

5. Click Add new entry next to Code points.

6. In the Value box, type the value of the high-priority code point for assured forwarding
traffic—for example, 001100.

7. ClickOK three times.

Configure an assured forwarding
class classifier.

1. Click Add new entry next to Interfaces.

2. In the Interface name box, type the name of the interface—for example, ge-0/0/0.

3. Click Add new entry next to Unit.

4. In the Unit number box, type the logical interface unit number—for example, 0.

5. Click Configure next to Classifiers.

6. In the Classifiers box, under Dscp, type the name of the previously configured behavior
aggregate classifier—for example, ba-classifier.

7. ClickOK.

Apply the behavior aggregate
classifier to an interface.
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Related
Documentation

Configuring CoS Code Point Aliases (NSM Procedure) on page 318•

• Configuring CoS Drop Profile (NSM Procedure) on page 319

• Configuring CoS Forwarding Classes (NSM Procedure) on page 321

• Configuring CoS Interfaces (NSM Procedure) on page 326

• Configuring CoS Rewrite Rules (NSM Procedure) on page 332

• Configuring CoS Schedulers (NSM Procedure) on page 335

• Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 336

Configuring CoS Code Point Aliases (NSMProcedure)

You can use code-point aliases to streamline the process of configuring CoS features on

your device. A code-point alias assigns a name to a pattern of code-point bits. You can

use this name instead of the bit patternwhen you configure other CoS components such

as classifiers, drop-profile maps, and rewrite rules.

To configure code-point aliases:

1. In the navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure CoS code point aliases.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select Code Point Aliases.

5. Add or modify the settings as specified in Table 199 on page 319

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See theNetwork
and Security Manager Administration Guide for more information.
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Table 199: Configuring Code Point Aliases

ActionTask

1. In the Configuration tree, expand Code Point Aliases.

2. Select Dscp.

3. Click the Add New icon.

4. In theNamebox, type thealias that youwant to assign to the codepoint—for example,
my1.

5. In the Bits box, type the code point—for example, 110001.

6. ClickOK.

Assign an alias to the dscp code
point.

Related
Documentation

Configuring CoS Classifiers (NSM Procedure) on page 316•

• Configuring CoS Drop Profile (NSM Procedure) on page 319

• Configuring CoS Forwarding Classes (NSM Procedure) on page 321

• Configuring CoS Interfaces (NSM Procedure) on page 326

• Configuring CoS Rewrite Rules (NSM Procedure) on page 332

• Configuring CoS Schedulers (NSM Procedure) on page 335

• Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 336

Configuring CoS Drop Profile (NSMProcedure)

Drop profiles provide a congestion management mechanism that enables a switch or

routing platform to drop the arriving packets when queue buffers become full or begin

to overflow. Drop profiles define themeanings of loss priorities.When you configure drop

profiles you are essentially setting the value for queue fullness. The queue fullness

represents the percentage of the memory used to store packets in relation to the total

amount of memory that has been allocated for that specific queue. The queue fullness

defines the delay-buffer bandwidth, which provides packet buffer space to absorb burst

traffic up to the specified duration of delay. Once the specified delay buffer becomes

full, packets with 100 percent drop probability are dropped from the tail of the buffer.

Youspecifydropprobabilities in thedropprofile sectionof theCoSconfigurationhierarchy

and reference them in each scheduler configuration. By default, if you do not configure

anydropprofile then thedropprofile that is in effect functions as theprimarymechanism

for managing congestion. In the default tail drop profile, when the fill level is 0 percent,

the drop probability is 0 percent. When the fill level is 100 percent, the drop probability

is 100 percent.

To configure drop profiles in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure drop profiles.
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3. Click the Configuration tab. In the configuration tree expand Class of Service.

4. Select Drop Profiles.

5. Add or modify the drop profiles as specified in Table 200 on page 320.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. SeeUpdating
Devices section in theNetwork andSecurityManager AdministrationGuide for
more information.

Table 200: Drop Profile Configuration Fields

Your ActionFunctionOption

Drop Profile

1. Click the New button or Edit button
in the Drop Profile interface.

2. Enter the drop profile name in the
Name box.

Specifies the drop profile name.Name

1. Click the New button or Edit button
in the Drop Profile interface.

2. Enter the comment for the drop
profile in the Comment box.

Specifies the comment for the drop
profile.

Comment

Fill Level

1. On Drop Profile interface click the
New button or select a profile and
click the Edit button.

2. Expand the Drop Profile tree and
select Fill Level.

3. Click the New button or select a fill
level and click the Edit button.

4. Select a value from Name list.

Specifies the fill level for thedropprofile.Name
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Table 200: Drop Profile Configuration Fields (continued)

Your ActionFunctionOption

1. On theDropProfile interfaceclick the
New button or select a profile and
click the Edit button.

2. Expand the Drop Profile tree and
select Fill Level.

3. Click the New button or select a fill
level and click the Edit button.

4. Enter a comment in the Comment
box.

Specifies the comment for the fill levelComment

Related
Documentation

Configuring CoS Classifiers (NSM Procedure) on page 316•

• Configuring CoS Code Point Aliases (NSM Procedure) on page 318

• Configuring CoS Forwarding Classes (NSM Procedure) on page 321

• Configuring CoS Interfaces (NSM Procedure) on page 326

• Configuring CoS Rewrite Rules (NSM Procedure) on page 332

• Configuring CoS Schedulers (NSM Procedure) on page 335

• Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 336

Configuring CoS Forwarding Classes (NSMProcedure)

Forwarding classes allow you to group packets for transmission. Based on forwarding

classes, you assign packets to output queues.

By default, four categories of forwarding classes are defined: best effort, assured

forwarding, expedited forwarding, and network control.

NOTE: EX Series switches support up to 16 forwarding classes.

To configure CoS forwarding classes:

1. In the navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure CoS forwarding classes.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select Forwarding Classes.

5. Add or modify settings as specified in Table 201 on page 322.

6. Click one:

• OK—Saves the changes.
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• Cancel—Cancels the modifications.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See theNetwork
and Security Manager Administration Guide for more information.

Table 201: Assigning Forwarding Classes to Output Queues

ActionTask

1. SelectQueue and click Add new entry.

2. In the Queue num box, type 0.

3. In the Class name box, type the previously configured name of the best-effort
class—for example, be-class.

4. ClickOK.

Assign best-effort traffic to queue 0.

1. SelectQueue and click Add new entry.

2. In the Queue num box, type 1.

3. In the Class name box, type the previously configured name of the expedited
forwarding class—for example, ef-class.

4. ClickOK.

Assign expedited forwarding traffic to
queue 1.

1. SelectQueue and click Add new entry.

2. In the Queue num box, type 3.

3. In the Class name box, type the previously configured name of the assured
forwarding class—for example, af-class.

4. ClickOK.

Configure an assured forwarding class
classifier.

Related
Documentation

Configuring CoS Classifiers (NSM Procedure) on page 316•

• Configuring CoS Code Point Aliases (NSM Procedure) on page 318

• Configuring CoS Drop Profile (NSM Procedure) on page 319

• Configuring CoS Interfaces (NSM Procedure) on page 326

• Configuring CoS Rewrite Rules (NSM Procedure) on page 332

• Configuring CoS Schedulers (NSM Procedure) on page 335

• Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 336
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Configuring CoS Forwarding Policy (NSMProcedure)

Class-of-service (CoS)-based forwarding (CBF)enablesyou tocontrol next-hopselection

based on a packet’s class of service and, in particular, the value of the IP packet’s

precedence bits.

You can specify a particular interface or next hop to carry high-priority traffic while all

best-effort traffic takes some other path. When a routing protocol discovers equal-cost

paths, it can pick a path at randomor load-balance across the paths through either hash

selection or round robin. CBF allows path selection based on class.

To configure CoS forwarding policy in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select Forwarding Policy.

5. Add or modify forwarding policy settings as specified in Table 202 on page 323.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 202: Forwarding Policy Configuration Details

Your ActionTask

1. Click Add new entry next to Class.

2. In the Name box, enter the name of forwarding class.

3. Click Classification Override next to Class.

4. In the Forwarding Class box, enter the name of the forwarding
class.

Specify the name of
forwarding class and
override the incoming
packet classification.
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Table 202: Forwarding Policy Configuration Details (continued)

Your ActionTask

1. Click Add new entry next to Next Hop Map.

2. In the Name box, enter the map that defines next-hop routes.

3. Click Forwarding Class next to next-hop-map.

4. Click Add new entry next to Forwarding Class.

5. In the Name box, enter the name of the forwarding class.

6. Select the Non LSPNext Hop check box to use a non-LSP next
hop for traffic sent to the forwarding class next-hopmap of
the forwarding policy.

7. Select the Discard check box to discard the traffic sent to the
forwarding class for the next-hopmap referenced by the
forwarding policy.

8. Click Lsp Next Hop next to forwarding-class.

9. Click New button next to Lsp Next Hop.

10. In the New Lsp-next-hop dialog box, enter the LSP regular
expression to which to map the forwarded traffic.

11. Click Next Hop next to forwarding-class.

12. In the New next-hop dialog box, enter the next-hop name or
address to which to map forwarded traffic.

Specify the map for CoS
forwarding routes.

Related
Documentation

Configuring CoS Classifiers (NSM Procedure) on page 316•

• Configuring CoS Routing Instances (NSM Procedure)

• Configuring Tracing Operations (NSM Procedure)

Configuring CoS FragmentationMaps (NSMProcedure)

For AS PIC link services IQ (lsq-) interfaces only, you can configure fragmentation

properties on a particular forwarding class. You can set a per-forwarding class

fragmentation thresholdusing fragment-thresholdoption. This option sets themaximum

size of eachmultilink fragment. You can also set traffic on a particular forwarding class

tobe interleaved rather than fragmented.Anextra fragmentationheader is notprepended

to the packets received on this queue and that static link load balancing is used to ensure

in-order packet delivery. You can also change the resequencing interval for each

fragmentation class.

To configure CoS fragmentation maps in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure CoS Fragmentation Maps.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select FragmentationMaps.

5. Add or modify settings as specified in Table 203 on page 325.

6. Click one:
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• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 203: FragmentationMaps Configuration Details

Your ActionTask

1. Click Add new entry next to Fragmentation Maps.

2. In the Name box, enter the name of the fragmentation map.

3. Click Forwarding Class next to fragmentation-maps.

4. Click Add new entry next to Forwarding Class.

5. In the Name box, enter the name of the forwarding class.

6. From theMultilink Class, select the multilink class to be
assigned to the forwarding class.

Range: 0 through 7

7. From the Drop Timeout list, select the sequencing timeout
interval for each forwarding class of a multiclass MLPPP.

Range: 0 through 2000

Defines fragmentation
properties for individual
forwarding classes.

1. Click Add new entry next to Fragmentation Maps.

2. Click Forwarding Class next to fragmentation-maps.

3. Click Add new entry next to Forwarding Class.

4. Click Fragment Threshold next to forwarding-class.

5. Set the fragmentation threshold for an individual forwarding
class.

Range: 64 through 9192 bytes

Set the fragmentation
threshold for an individual
forwarding class for only AS
PIC link services IQ interfaces
(lsq).

Related
Documentation

Configuring CoS Forwarding Policy (NSM Procedure) on page 323•

• Configuring CoS Schedulers (NSM Procedure) on page 335

• Configuring CoS Traffic Control Profiles (NSM Procedure) on page 338

Configuring CoS Host Outbound Traffic (NSMProcedure)

You canmodify the default queue assignment (forwarding class) and Differentiated

Services Code Point (DSCP) bits used in the Type Of Service (ToS) field of packets

generated by the Routing Engine.

To configure CoS Host Outbound Traffic in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure Class-of-Service Host Outbound Traffic.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select Host Outbound Traffic.

5. Add or modify settings as specified in Table 204 on page 326.

6. Click one:
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• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 204: Host Outbound Traffic Configuration Details

Your ActionFunctionOption

In the Forwarding Class box,
enter the name for the
forwarding class.

Defines a forwarding class
name.

Forwarding Class

From the Dscp Code Point list,
select the DSCP code point
value.

Sets the value of the DSCP
code point in the ToS field of
the packet generated by the
Routing Engine (host).

Dscp Code Point

Related
Documentation

Configuring CoS Forwarding Classes (NSM Procedure) on page 321•

• Configuring CoS Fragmentation Maps (NSM Procedure) on page 324

• Configuring CoS Traffic Control Profiles (NSM Procedure) on page 338

• Configuring CoS Interfaces (NSM Procedure) on page 326

Configuring CoS Interfaces (NSMProcedure)

An interface is configured for optimal performance in a high-traffic network. This feature

enables you to configure interface-specific CoS properties for incoming packets.

To configure CoS interfaces in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure CoS interfaces.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select Interfaces.

5. Add or modify the interfaces as specified in Table 205 on page 327.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See theNetwork
and Security Manager Administration Guide for more information.
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Table 205: Interfaces Configuration Fields

Your ActionFunctionOption

Interface

1. Expand the Interfaces tree
and select Interface.

2. Click the New button or
select an interface and
click the Edit button in
Interface.

3. Enter the interface name
in the Name box.

Specifies the interface name.Name

1. Expand the Interfaces tree
and select Interface.

2. Click the New button or
select an interface and
click the Edit button in
Interface.

3. Enter the comment for the
interface in the Comment
box.

Specifies thecomment for the
interface.

Comment

1. Expand the Interfaces tree
and select Interface.

2. Click the New button or
select an interface and
click the Edit button in
Interface.

3. Select the scheduler map
from the list.

Specifies the scheduler
configuration mapped to the
forwarding class.

Scheduler Map

1. Expand the Interfaces tree
and select Interface.

2. Click the New button or
select an interface and
click the Edit button in
Interface.

3. Select the scheduler map
chassis from the list.

Specifies the scheduler
configuration mapped to the
forwarding class for the
particular chassis in the
chassis queue.

Scheduler Map Chassis
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Table 205: Interfaces Configuration Fields (continued)

Your ActionFunctionOption

1. Click the New button or
select an interface and
click the Edit button in
Interface.

2. Expand the Interface tree
and select Input Traffic
Control Profile.

3. Specify the comment and
the profile name.

4. ClickOk.

Applies an input traffic
schedulingandshapingprofile
to the logical interface.

Input Traffic Control Profile

1. Click the New button or
select an interface and
click the Edit button in
Interface.

2. Expand the Interface tree
and select Input Traffic
Control Profile Remaining.

3. Specify a comment and a
profile name.

4. ClickOk.

Applies an input traffic
schedulingandshapingprofile
for remaining traffic to the
logical interface.

Input Traffic Control Profile
Remaining

1. Click the New button or
select an interface and
click the Edit button in
Interface.

2. Expand the Interface tree
and selectOutput Traffic
Control Profile.

3. Specify a comment and a
profile name.

4. ClickOk.

Applies an output traffic
schedulingandshapingprofile
to the logical interface.

Output Traffic Control Profile

1. Click the New button or
select an interface and
click the Edit button in
Interface.

2. Expand the Interface tree
and selectOutput Traffic
Control Profile Remaining.

3. Specify a comment and a
profile name.

4. ClickOk.

Applies an output traffic
schedulingandshapingprofile
for remaining traffic to the
logical interface.

Output Traffic Control Profile
Remaining
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Table 205: Interfaces Configuration Fields (continued)

Your ActionFunctionOption

1. Click the New button or
select an interface and
click the Edit button in
Interface.

2. Expand Interface tree and
select Shaping Rate.

3. Specify the comment and
the rate

4. ClickOk.

Shapes the output of the
physical interface, so that the
interface transmits less traffic
than it is physically capable of
carrying.

Shaping Rate

1. Click the New button or
select an interface and
click the Edit button in
Interface.

2. Expand Interface tree and
select Unit.

3. Specify the Unit,
Classifiers, Output Traffic
Control Profile and
Shaping Rate.

4. ClickOk.

Sets the units that need to be
allocated to the specific
forwarding class and
scheduling map.

Unit

Interface Set

1. Expand the Interfaces tree
and select Interface Set.

2. Click the New button or
select an interface set and
click the Edit button.

3. Select the name from the
list.

Specifies the interface set
name.

Name

1. Expand the Interfaces tree
and select Interface Set.

2. Click the New button or
select an interface set and
click the Edit button.

3. Enter the comment.

Specifies thecomment for the
interface.

Comment

1. Expand the Interfaces tree
and select Interface Set.

2. Click the New button or
select an interface set and
click the Edit button.

3. Set the internal node.

Sets the scheduler node as
internal, allowing resource
scheduling to be applied
equally to interface sets that
include child nodes and those
that do not include child
nodes.

Internal Node
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Table 205: Interfaces Configuration Fields (continued)

Your ActionFunctionOption

1. Expand the Interfaces tree
and select Interface Set.

2. Click the New button or
select an interface set and
click the Edit button.

3. Expand interface—set tree
and select Excess
Bandwidth Share.

4. Specify the comment and
proportion.

5. ClickOk.

Sets the excess bandwidth
sharing value.

Excess Bandwidth Share

1. Expand the Interfaces tree
and select Interface Set.

2. Click the New button or
select an interface set and
click the Edit button.

3. Expand interface—set tree
and select Input Excess
Bandwidth Share.

4. Specify the comment and
proportion.

5. ClickOk.

Sets the excess input
bandwidth sharing value.

Input Excess Bandwidth Share

1. Expand the Interfaces tree
and select Interface Set.

2. Click the New button or
select an interface set and
click the Edit button.

3. Expand interface—set tree
and select Input Traffic
Control Profile.

4. Specify the comment and
profile name.

5. ClickOk.

Applies an input traffic
schedulingandshapingprofile
to the logical interface.

Input Traffic Control Profile
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Table 205: Interfaces Configuration Fields (continued)

Your ActionFunctionOption

1. Expand the Interfaces tree
and select Interface Set.

2. Click the New button or
select an interface set and
click the Edit button.

3. Expand interface—set tree
and select Input Traffic
Control Profile Remaining.

4. Specify the comment and
profile name.

5. ClickOk.

Applies an input traffic
schedulingandshapingprofile
for remaining traffic to the
logical interface.

Input Traffic Control Profile
Remaining

1. Expand the Interfaces tree
and select Interface Set.

2. Click the New button or
select an interface set and
click the Edit button.

3. Expand interface—set tree
and selectOutput Traffic
Control Profile.

4. Specify the comment and
profile name.

5. ClickOk.

Applies an output traffic
schedulingandshapingprofile
to the logical interface.

Output Traffic Control Profile

1. Expand the Interfaces tree
and select Interface Set.

2. Click the New button or
select an interface set and
click the Edit button.

3. Expand interface—set tree
and selectOutput Traffic
Control Profile Remaining.

4. Specify the comment and
profile name.

5. ClickOk.

Applies an output traffic
schedulingandshapingprofile
for remaining traffic to the
logical interface.

Output Traffic Control Profile
Remaining

Related
Documentation

Configuring CoS Classifiers (NSM Procedure) on page 316•

• Configuring CoS Code Point Aliases (NSM Procedure) on page 318

• Configuring CoS Drop Profile (NSM Procedure) on page 319

• Configuring CoS Forwarding Classes (NSM Procedure) on page 321

• Configuring CoS Rewrite Rules (NSM Procedure) on page 332

• Configuring CoS Schedulers (NSM Procedure) on page 335
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• Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 336

Configuring CoS Rewrite Rules (NSMProcedure)

You configure rewrite rules to alter CoS values in outgoing packets on the outbound

interfaces of a device to match the policies of a targeted peer. Policy matching allows

the downstream router in a neighboring network to classify each packet into the

appropriate service group.

In addition, you often need to rewrite a givenmarker such as IP precedence, DSCP, or

IEEE802.1pat the switch's inbound interfaces toaccommodatebehavior aggregate (BA)

classification by core devices.

You do not need to explicitly apply rewrite rules to interfaces. By default, rewrite rules

are applied to routed packets.

To configure CoS rewrite rules:

1. In the navigation tree, select DeviceManager > Devices

2. Click the Device Tree tab, and then double-click the device for which you want to

configure CoS rewrite rules.

3. Click the Configuration tab. In the configuration tree, expand Class of Service

4. Select Rewrite Rules.

5. Add or modify settings as specified in Table 206 on page 332.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See theNetwork
and Security Manager Administration Guide for more information.

Table 206: Configuring and Applying Rewrite Rules

ActionTask

1. Click Configure next to Rewrite Rules.

2. Click Add new entry next to Dscp.

3. In the Name box, type the name of the rewrite rules—for example,
rewrite-dscps.

Configure rewrite
rules for DiffServ CoS.
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Table 206: Configuring and Applying Rewrite Rules (continued)

ActionTask

1. Click Add new entry next to Forwarding class.

2. In the Queue num box, type 1.

3. In the Class name box, type the name of the previously configured
best-effort forwarding class—for example, be-class.

4. Click Add new entry next to Loss priority.

5. From the Loss val list, select low.

6. In the Code point box, type the value of the low-priority code point
for best-effort traffic—for example, 000000.

7. ClickOK.

8. Click Add new entry next to Loss priority.

9. From the Loss val list, select high.

10. In the Code point box, type the value of the high-priority code point
for best-effort traffic—for example, 000001.

11. ClickOK twice.

Configure best-effort
forwarding class
rewrite rules.

1. Click Add new entry next to Forwarding class.

2. In the Class name box, type the name of the previously configured
expedited forwarding class—for example, ef-class.

3. Click Add new entry next to Loss priority.

4. From the Loss val list, select low.

5. In the Code point box, type the value of the low-priority code point
for expedited forwarding traffic—for example, 101110.

6. ClickOK.

7. Click Add new entry next to Loss priority.

8. From the Loss val list, select high.

9. In the Code point box, type the value of the high-priority code point
for expedited forwarding traffic—for example, 101111.

10. ClickOK twice.

Configure expedited
forwarding class
rewrite rules.
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Table 206: Configuring and Applying Rewrite Rules (continued)

1. ClickAddnewentrynext toForwardingclass.

2. In theClass namebox, type the nameof the
previously configured expedited forwarding
class—for example, af-class.

3. Click Add new entry next to Loss priority.

4. From the Loss val list, select low.

5. In the Code point box, type the value of the
low-priority code point for assured
forwarding traffic—for example, 001010.

6. ClickOK.

7. Click Add new entry next to Loss priority.

8. From the Loss val list, select high.

9. In the Code point box, type the value of the
high-priority code point for assured
forwarding traffic—for example, 001100.

10. ClickOK twice.

Configure assured forwarding class rewrite
rules.

1. Click Add new entry next to Interfaces.

2. In the Interface namebox, type the nameof
the interface—for example, ge-0/0/0.

3. Click Add new entry next to Unit.

4. In the Unit number box, type the logical
interface unit number—for example, 0.

5. Click Configure next to Rewrite rules.

6. In the Rewrite rules name box, under Dscp,
type the name of the previously configured
rewrite rules—for example, rewrite-dscps.

7. ClickOK.

Apply rewrite rules to an interface.

Related
Documentation

Configuring CoS Classifiers (NSM Procedure) on page 316•

• Configuring CoS Code Point Aliases (NSM Procedure) on page 318

• Configuring CoS Drop Profile (NSM Procedure) on page 319

• Configuring CoS Forwarding Classes (NSM Procedure) on page 321

• Configuring CoS Interfaces (NSM Procedure) on page 326

• Configuring CoS Schedulers (NSM Procedure) on page 335

• Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 336

Copyright © 2013, Juniper Networks, Inc.334

Configuring J Series Services Routers and SRX Series Services Gateways Guide



Configuring CoS Schedulers (NSMProcedure)

Using schedulers, you can assign attributes to queues and thereby provide congestion

control for a particular class of traffic. These attributes include the amount of interface

bandwidth, memory buffer size, transmit rate, and schedule priority.

To configure CoS schedulers:

1. In the navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure CoS schedulers.

3. Click the Configuration tab. In the configuration tree expand Class of Service.

4. Select Schedulers.

5. Add or modify the settings as specified in Table 207 on page 335.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See theNetwork
and Security Manager Administration Guide for more information.

Table 207: Configuring Schedulers

ActionTask

1. Click the Add New icon.

2. Expand Buffer Size.

3. Select Percent.

4. Under Percent, select the appropriate option:

• To specify no buffer size, select None.

• To specify buffer size as a percentage of the total buffer, select percent and type an integer
from 1 through 100.

• To specify buffer size as the remaining available buffer, select remainder.

5. ClickOK.

Specify the buffer size.
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Table 207: Configuring Schedulers (continued)

ActionTask

1. Click the Add New icon.

2. Select drop-profile-map.

3. In the Loss Priority box, select the required loss priority—for example, high.

4. In the Protocol box, select the type of protocol—for example, any.

5. In the Drop Profile box, select the previously configured drop profile.

6. ClickOK.

Configure drop profile
map.

1. Click the Add New icon.

2. Expand Transmit Rate.

3. Select Rate.

4. Under Rate, select the appropriate option:

• To not specify transmit rate, select None.

• To enforce a specific transmission rate, select rate and type the transmission rate that you
want to enforce.

• To specify a percentage of transmission capacity, select percent and type an integer from 1
through 100.

• To specify the remaining transmission capacity, select remainder.

5. ClickOK.

Specify the transmit rate.

Related
Documentation

Configuring CoS Classifiers (NSM Procedure) on page 316•

• Configuring CoS Code Point Aliases (NSM Procedure) on page 318

• Configuring CoS Drop Profile (NSM Procedure) on page 319

• Configuring CoS Forwarding Classes (NSM Procedure) on page 321

• Configuring CoS Interfaces (NSM Procedure) on page 326

• Configuring CoS Rewrite Rules (NSM Procedure) on page 332

• Configuring CoS and Applying Scheduler Maps (NSM Procedure) on page 336

Configuring CoS and Applying Scheduler Maps (NSMProcedure)

You associate the schedulers with forwarding classes by means of scheduler maps. You

can thenassociate each schedulermapwithan interface, thereby configuring thequeues

and packet schedulers that operate according to this mapping.

To configure CoS and apply scheduler maps:

1. In the navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure CoS and apply scheduler maps.
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3. Click the Configuration tab. In the configuration tree expand Class of Service.

4. Select Scheduler Maps.

5. Add or modify settings as specified in Table 208 on page 337.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

NOTE: After youmakechanges toadeviceconfiguration, youmustpush that
updateddeviceconfiguration to thephysical securitydevice for thosechanges
to take effect. You can updatemultiple devices at one time. See theNetwork
and Security Manager Administration Guide for more information.

Table 208: Assigning Forwarding Classes to Output Queues

ActionTask

1. Click Add new entry.

2. In the Name box, type the name of the scheduler map—for example,
diffserv-cos-map.

Configure a scheduler map for
DiffServ CoS.

1. Select Forwarding Class and click Add new entry.

2. In the Name box, type the name of the previously configured best-effort forwarding
class—for example, be-class.

3. Select the previously configured best-effort scheduler—for example, be-scheduler.

4. ClickOK.

Configure a best-effort forwarding
class and scheduler.

1. Select Forwarding Class and click Add new entry.

2. In the Name box, type the name of the previously configured expedited forwarding
class—for example, ef-class.

3. Select the previously configured expedited forwarding scheduler—for example,
ef-scheduler.

4. ClickOK.

Configure an expedited forwarding
class and scheduler.

1. Select Forwarding Class and click Add new entry.

2. In the Name box, type the name of the previously configured assured forwarding
class—for example, af-class.

3. Select the previously configured assured forwarding scheduler—for example,
af-scheduler.

4. ClickOK.

Configureanassured forwardingclass
and scheduler.
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Table 208: Assigning Forwarding Classes to Output Queues (continued)

ActionTask

1. Select Interfaces > Interface and click Add new entry.

2. In the Interface name box, type the name of the interface—for example, ge-0/0/0.

3. Select Unit and click Add new entry.

4. In the Unit name box, select the logical interface unit number—for example, 0.

5. In the Scheduler map box, type the name of the previously configured scheduler
map—for example, diffserv-cos-map.

6. ClickOK.

Apply the scheduler map to an
interface.

Related
Documentation

Configuring CoS Classifiers (NSM Procedure) on page 316•

• Configuring CoS Code Point Aliases (NSM Procedure) on page 318

• Configuring CoS Drop Profile (NSM Procedure) on page 319

• Configuring CoS Forwarding Classes (NSM Procedure) on page 321

• Configuring CoS Interfaces (NSM Procedure) on page 326

• Configuring CoS Rewrite Rules (NSM Procedure) on page 332

• Configuring CoS Schedulers (NSM Procedure) on page 335

Configuring CoS Traffic Control Profiles (NSMProcedure)

You can configure traffic shaping and scheduling profiles for Gigabit Ethernet IQ,

Channelized IQ PICs, and AS PIC FRF.16 LSQ interfaces.

To configure CoS Traffic Control Profiles in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure CoS Restricted Queues.

3. Click the Configuration tab. In the configuration tree, expand Class of Service.

4. Select Traffic Control Profiles.

5. Add or modify settings as specified in Table 209 on page 339.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 209: Traffic Control profile Configuration Details

Your ActionTask

1. In the Name box, enter the name of the
traffic-control profile.

2. Select the scheduler map.

3. Expand traffic-control-profiles.

4. Select the following:

• Select Delay Buffer Rate as default value
and set the delay buffer rate.

• Select Guaranteed Rate if you do not
configure delay buffer rate. The delay
buffer rate calculation is based on the
guaranteed rate.

NOTE: On LSQ interfaces, you can configure
the guaranteed rate as a percentage from 1
through 100.

On IQ and IQ2 interfaces, you can configure the
guaranteed rate as an absolute rate from 1000
through 160,000,000,000 bits per second.

• Select Shaping Rate if you do not
configure delay buffer rate or guaranteed
rate. The delay buffer rate calculation is
based on the shaping rate.

Configure traffic shapingandschedulingprofiles
for Gigabit Ethernet IQ, Channelized IQ PICs,
and AS PIC FRF.16 LSQ interfaces.

Related
Documentation

• Configuring CoS Drop Profile (NSM Procedure) on page 319

• Configuring CoS Host Outbound Traffic (NSM Procedure) on page 325

• Configuring CoS Routing Instances (NSM Procedure)

• Configuring CoS Translation Table (NSM Procedure)
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CHAPTER 19

Configuring Event Options in J Series
Services Routers and SRX Series Services
Gateways

• Configuring Event Script (NSM Procedure) on page 341

• Generating Internal Events (NSM Procedure) on page 342

• Configuring Event Policy (NSM Procedure) on page 343

• Configuring Event Policy Tracing Operations (NSM Procedure) on page 346

Configuring Event Script (NSMProcedure)

Event scriptsallowyou toautomatenetwork troubleshootingandnetworkmanagement.

To configure event scripting in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Event Options > Event

Script.

4. Select Event Script.

5. Add or modify settings as specified in Table 210 on page 341.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 210: Event Script Configuration Details

Your ActionTask

1. Click File next to Event Script.

2. Click Add new entry next to File.

3. In the Name box, enter the filename.

4. In the Comment box, enter the comment.

Specify the name of an Extensible
Stylesheet Language Transformations
(XSLT) or Stylesheet Language
Alternative Syntax (SLAX) file
containing an event script.
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Table 210: Event Script Configuration Details (continued)

Your ActionTask

1. Click Checksum next to file.

2. In the Comment box, enter the comment.

3. In theMd5 box, enter the MD5 checksum.

4. In the Sha1 box, enter the SHA-1 checksum.

5. In the Sha 256 box, enter the SHA-256 checksum.

Calculate the checksum.

1. Click Remote Execution next to file.

2. Click Add new entry next to Remote Execution.

3. In the Name box, enter the filename.

4. In the Comment box, enter the comment.

5. In the Username box, enter the username for the remote machine.

6. In the Passphrase box, enter the passphrase for the remote machine.

Configure the username and
passphrase for a remote machine.

1. Click Traceoptions next to Event Script.

2. In the Comment box, enter the comment.

3. Expand traceoptions.

4. Click File next to Traceoptions.

5. In the Comment box, enter the comment.

6. In the Filename box, enter the name of the file to receive the output of the tracing
operation.

7. In the Size box, enter the maximum trace file size.

8. From the Files list, select the maximum number of trace files.

9. Select one of the following:

• no-world-readable—To restrict the file access to owner.

• world-readable—To enable unrestricted access.

10. Click Flag next to traceoptions.

11. Click Add new entry next to Flag.

12. From the Name list, select the flag to perform the trace operation.

13. In the Comment box, enter the comment for the flag.

Define tracing operations for event
scripts.

Related
Documentation

Configuring Destinations for File Archiving (NSM Procedure)•

• Generating Internal Events (NSM Procedure) on page 342

• Configuring Event Policy (NSM Procedure) on page 343

• Configuring Event Policy Tracing Operations (NSM Procedure) on page 346

Generating Internal Events (NSMProcedure)

To generate an internal event, based on a time interval or the time of day, you can use

the generate event option.

To generate internal events in NSM:
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1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Event Options.

4. Select Generate Event.

5. Add or modify settings as specified in Table 211 on page 343.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 211: Generate Event Details

Your ActionTask

1. In the Name box, enter the name of an internally generated
event

2. In theCommentbox, enter thecomment for thegenerateevent.

3. Click Time of Day next to generate-event and select one of the
following:

• time-of-day—Toconfigure a timeof day atwhich to generate
a particular event.

• time-interval—Toconfigure a frequency atwhich to generate
a particular event.

Generate an internal event,
based on a time interval or
the time of day.

Related
Documentation

Configuring Destinations for File Archiving (NSM Procedure)•

• Configuring Event Script (NSM Procedure) on page 341

• Configuring Event Policy (NSM Procedure) on page 343

• Configuring Event Policy Tracing Operations (NSM Procedure) on page 346

Configuring Event Policy (NSMProcedure)

Event policies can listen for specific events, create log files, invoke Junos OS commands,

and invoke event scripts.

To configure an event policy in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Event Options.

4. Select Policy.

5. Add or modify settings as specified in Table 212 on page 344.

6. Click one:
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• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 212: Configure Event Policy Details

Your ActionTask

1. Click Add new entry next to Policy.

2. In the Name box, enter the policy name.

3. In the Comment box, enter the comment for the policy.

Define an event policy to be
processed by the event
process (eventd) process.

1. Click Add new entry next to Attributes Match.

2. In the From Event Attribute box, enter the first attribute to
compare.

3. From the Condition list, select the match condition for the
attributes.

4. In the To Event Attribute Value box, enter another attribute.

5. In the Comment box, enter the comment for the
attributes-match.

Execute the policy only if the
attributes of two events are
correlated or if the attribute
of one event matches a
regular expression.

1. Click Add new entry next to Events.

2. In the New events dialog box, enter the name of the event.

Create a list of events that
trigger this policy. If one or
more of the listed events
occurs, thepolicy is executed.

1. Click Then next to policy.

2. In the comment box, enter the comment.

3. Select the Ignore check box to define a policy that ignores
particular events.

4. Select the Raise Trap check box to define a policy that raises
a Simple Network Management Protocol (SNMP) trap in
response to an event.

Define actions to take if an
eventoccurs. For eachpolicy,
you can configure multiple
actions.

1. Expand Then and select Event Script.

2. Click Add new entry next to Event Script.

3. In the Name box, enter the filename.

4. In the comment box, enter the comment for the event script.

5. From the Username list, select the user associated with an
action in an event policy.

6. In theOutput Filename box, enter the filename to which to
write command or script output for the specified commands
or script.

7. From theOutput Format list, select the format for the output
of the specified commands.

Specify operational mode
commands to be issued, the
format of the command
output, and a name and
destination for the output
file.
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Table 212: Configure Event Policy Details (continued)

Your ActionTask

1. Expand event-script.

2. Click Arguments next to event-script.

3. Click Add new entry next to Arguments.

4. In the Name box, enter the arguments to the script as name.

5. In the comment box, enter the comment.

6. In the Value box, enter the variables in the argument values to
allow data from the triggering event to be automatically
included in the argument.

7. Click Destination next to event-script.

8. From the Name list, select the location to which to upload
command or script output for the specified policy.

9. In the Comment box, enter the comment.

10. From theTransferDelay list, select the delay in seconds before
transferring files.

11. Expand Destinations and select Retry Count next to it.

12. In the Comment box, enter the comment for the retry count.

13. From the Retry list, select the number of retries.

14. From the Retry Interval list, select the length of time to wait
between retries.

Include command-line
arguments to the script for
Junos OS op scripts and
assign a location to which to
upload command or script
output for the specified
policy.

1. Expand Execute Commands.

2. Click Commands.

3. In the Name box, enter the command.

4. Click Destination next to Execute Commands.

5. See Configuring Destinations for File Archiving (NSM
Procedure)

Specify operational mode
commands to be issued, the
format of the command
output, and a name and
destination for theoutput file
on receipt of an event.

1. Click Upload next to Event Script.

2. In the Filename box, enter the name of the file to be uploaded.

3. From the Destination list, select the name of a destination.

4. From the User Name list, select the username.

5. From the transfer relay list, select the delay before transferring
files.

Specify a file to be uploaded
to a destination on receipt of
an event.
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Table 212: Configure Event Policy Details (continued)

Your ActionTask

1. Click Add new entry next toWithin.

2. ExpandWithin.

3. From the Name list, select the interval between events.

4. Click Events next to within.

5. Click Add new entry next to Events.

6. In theNew events dialog box, enter the events that trigger this
policy.

7. Expand Not.

8. Click Events next to Not.

9. In theNewevents dialog box, enter the events that trigger this
policy.

10. Click Trigger next to Not.

11. In the Comment box, enter the comment.

12. Select one of the following:

a. until—if the policy is to be executed each time amatching
event is received and stops being executed when the
number of matching events received equals number.

b. on—if the policy is executedwhen the number ofmatching
events received equals number.

c. after—if the policy is executed when the number of
matching events received equals number + 1.

13. From theCount list, select the number of times an event or set
of events should occur within a specified time period.

Create a list of events that
must (or must not) occur
within a specified time
interval for the policy to be
triggered.

Related
Documentation

Configuring Destinations for File Archiving (NSM Procedure)•

• Configuring Event Script (NSM Procedure) on page 341

• Generating Internal Events (NSM Procedure) on page 342

• Configuring Event Policy Tracing Operations (NSM Procedure) on page 346

Configuring Event Policy Tracing Operations (NSMProcedure)

Event policy tracing operations track all event policy operations and record them in a log

file. The loggederror descriptionsprovidedetailed information tohelp you solveproblems

faster.

To configure event policy tracing operations in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Event Options.

4. Select Traceoptions.
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5. Add or modify settings as specified in Table 213 on page 347.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 213: Event Options Traceoptions Configuration Details

Your ActionTask

1. In the Comment box, enter the comment for the traceoptions.

2. Select theNoRemoteTracecheckbox todisable remote tracing
globally or for a specific tracing operation.

Define tracing operations for
event policy.

1. Click File next to Traceoptions.

2. In the Comment box, enter the comment for the file.

3. In the Filename box, enter the name of the file to receive the
output of the tracing operation.

4. In the Size box, enter the maximum size of each trace file, in
kilobytes (KB), megabytes (MB), or gigabytes (GB).

5. From the Files list, select the maximum number of trace files.

Range: 2 through 1000.

6. Select one of the following:

• world-readable—To enable unrestricted file access.

• no-world-readable—To restrict file access to owner. This is
the default setting.

7. In theMatch box, enter the regular expression.

Specify the name of the file
to receive the output of the
tracing operation and the
maximum number of trace
files.

1. Click Flag next to Traceoptions.

2. Click Add new entry next to Flag.

3. From the Name list, select the flag.

4. In the Comment box, enter the comment for the flag.

Specify the tracingoperation
to perform.

Related
Documentation

• Configuring Destinations for File Archiving (NSM Procedure)

• Configuring Event Script (NSM Procedure) on page 341

• Generating Internal Events (NSM Procedure) on page 342

• Configuring Event Policy (NSM Procedure) on page 343
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CHAPTER 20

Configuring Firewall in J Series Services
Routers and SRX Series Services
Gateways

• Configuring the Firewall Filter for Any Family Type (NSM Procedure) on page 349

• Configuring the Firewall Filter for Bridge Family Type (NSM Procedure) on page 351

• Configuring the Firewall Filter for Ccc Family Type (NSM Procedure) on page 353

• Configuring Filters for inet Family Type (NSM Procedure) on page 355

Configuring the Firewall Filter for Any Family Type (NSMProcedure)

You can specify any to filter packets based upon protocol-independent fields.

To configure firewall filter in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Firewall > Family > Any.

4. Add or modify settings as specified in Table 214 on page 350.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 214: Firewall Filter Configuration Details

Your ActionTask

1. Expand Any.

2. In the Comment box, enter the comment for Any.

3. Click Filter next to Any.

4. Click Add new entry next to Filter.

5. In the name box, enter the name that identifies the filter.

6. In the Comment box, enter the comment for the filter.

7. Expand Filter.

8. Click Term next to Filter.

9. Click Add new entry next to Term.

10. Expand Term.

11. In the Name box, enter the name that identifies the term.

12. In the Comment box, enter the comment for the term.

13. Expand From.

14. Fromthe listedprotocol-independentmatchconditions, select
the filters defined for the any family type.

The protocol-independent match conditions are Forwarding
Class, Interface, Interface Set, Loss Priority, and Packet Length.

15. Expand Then.

16. In the Comment box, enter the comment for then.

17. In the Count box, enter the number of packets.

18. From the Loss Priority list, set the packet loss priority (PLP) to
low, medium-low, medium-high, or high.

19. In the Forwarding Class box, enter the packet forwarding class
name.

20.Click Accept next to Then.

21. Select one of the following:

• Accept—To accept a packet.

• Discard—To discard a packet silently, without sending an
ICMPmessage.

• Next—To evaluate the next term in the firewall filter.

22. Click Policer next to Then.

23. Select one of the following:

• policer—To configure a new policer for each filter and select
the policer name.

• three-color-policer—To configure a tricolor marking policer.
a. Expand Three Color Policer.

b. Click Single Rate next to Three Color Policer.

c. Select one of the following:
• single-rate—if thenamed tricolorpolicer is a single-rate
policer.

• two-rate—if the named tricolor policer is a two-rate
policer.

Configure firewall filters for
protocol-independent
match conditions.

Related
Documentation

Configuring the Firewall Filter for Bridge Family Type (NSM Procedure) on page 351•
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• Configuring the Firewall Filter for Ccc Family Type (NSM Procedure) on page 353

• Configuring Filters for inet Family Type (NSM Procedure) on page 355

Configuring the Firewall Filter for Bridge Family Type (NSMProcedure)

On the MX Series router, you can filter Layer 2 packets in a bridging environment using

this option.

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click theConfiguration tab. In the configuration tree, expand Firewall>Family>Bridge.

4. Add or modify settings as specified in Table 215 on page 351.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 215: Bridge Filter Configuration Details

Your ActionTask

1. Click Filter next to Bridge.

2. Click Add new entry next to Filter.

3. Expand Filter.

4. In the name box, enter the name that identifies the filter.

5. In the Comment box, enter the comment.

6. Select Interface Specific to configure interface-specific names
for firewall counters.

Configure firewall filters for
Layer 2packets thatarepart
of bridging domain for MX
series routers.

1. Click Accounting Profile next to filter.

2. In the New accounting-profilewindow, enter the name to be
assigned to the accounting profile.

Configure accounting for
firewall filter.
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Table 215: Bridge Filter Configuration Details (continued)

Your ActionTask

1. Click Add new entry next to Term.

2. Expand Term.

3. In the Name box, enter the name that identifies the term.

4. In the Comment box, enter the comment for the term.

5. From the Filter list, select the name that identifies the filter.

6. Expand From.

7. In the Comment box, enter the comment.

8. In the Tcp Flags box, enter the Tcp flags.

9. Fromthe listedprotocol-independentmatchconditions, select
the filters defined for the Bridge family type.

The protocol-independent match conditions are Destination
Mac Address, Destination port, DSCP, Ether Type, Forwarding
Class, ICMP Code, ICMP Type, Interface Group, IP Address, IP
Destination Address, IP Precedence, IP Protocol, IP Source
Address, Learn Vlan 1p Priority, Learn Vlan Id, Loss priority, Port,
Source Mac Address, Source Port, Traffic Type, User Vlan 1p
Priority, User Vlan Id, and Vlan Ether Type.

10. Expand Then.

11. In the Comment box, enter the comment for then.

12. In the Count box, enter the number of packets.

13. From the Loss Priority list, set the packet loss priority (PLP) to
low, medium-low, medium-high, or high.

14. In the Forwarding Class box, enter the packet forwarding class
name.

15. Select Port Mirror check box to port mirror the packets.

16. Click Accept next to Then.

• Select Accept to accept a packet.

• Select Discard to discard a packet silently, without sending
an ICMPmessage.

• Select Next to evaluate the next term in the firewall filter.

17. Click Policer next to Then.

18. Select one of the following:

• Policer—To configure a new policer for each filter and select
the policer name.

• three-color-policer—To configure a tricolor marking policer,
a. Expand Three Color Policer.

b. Click Single Rate next to Three Color Policer.

c. Select one of the following:
• single-rate—if thenamed tricolorpolicer is a single-rate
policer.

• two-rate—if the named tricolor policer is a two-rate
policer.

Define a firewall filter term.

Related
Documentation

Configuring the Firewall Filter for Any Family Type (NSM Procedure) on page 349•

• Configuring the Firewall Filter for Ccc Family Type (NSM Procedure) on page 353
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• Configuring Filters for inet Family Type (NSM Procedure) on page 355

• Configuring Filters for inet6 Family Type (NSM Procedure)

• Configuring the Firewall Filter for MPLS Family Type (NSM Procedure)

Configuring the Firewall Filter for Ccc Family Type (NSMProcedure)

On the MX Series router, you can filter Layer 2 packets in a bridging environment using

this option.

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Firewall > Family > Ccc.

4. Add or modify settings as specified in Table 216 on page 353.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 216: Ccc Filter Configuration Details

Your ActionTask

1. Click Filter next to Ccc.

2. Click Add new entry next to Filter.

3. Expand Filter.

4. In the name box, enter the name that identifies the filter.

5. In the Comment box, enter the comment.

6. Select the Interface Specific check box to configure
interface-specific names for firewall counters.

Configure firewall filters for
Layer 2 switching
cross-connects.

1. Click Accounting Profile next to filter.

2. Click Add new entry next to Accounting Profile.

3. In the New accounting-profilewindow, enter the name to be
assigned to the accounting profile.

Configure accounting for
firewall filter.
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Table 216: Ccc Filter Configuration Details (continued)

Your ActionTask

1. Click Term next to Accounting Profile.

2. Click Add new entry next to Term.

3. Expand Term.

4. In the Name box, enter the name that identifies the term.

5. In the Comment box, enter the comment for the term.

6. From the Filter list, select the name that identifies the filter.

7. Expand From.

8. In the Comment box, enter the comment.

9. Fromthe listedprotocol-independentmatchconditions, select
the filters defined for the Ccc family type.

The protocol-independent match conditions are Forwarding
Class, InterfaceGroup, Vlan 1p property, Loss Priority, andUser
Vlan-1p Priority.

10. Expand Then.

11. In the Comment box, enter the comment for then.

12. In the Count box, enter the number of packets.

13. From the Loss Priority list, set the packet loss priority (PLP) to
low, medium-low, medium-high, or high.

14. In the Forwarding Class box, enter the packet forwarding class
name.

15. Click Accept next to Then.

16. Select one of the following:

• Accept—To accept a packet.

• Discard—To discard a packet silently, without sending an
ICMPmessage.

• Next—To evaluate the next term in the firewall filter.

17. Click Policer next to Then.

18. Select one of the following:

• Policer—To configure a new policer for each filter and select
the policer name.

• three-color-policer—To configure a tricolor marking policer,
a. Expand Three Color Policer.

b. Click Single Rate next to Three Color Policer.

c. Select one of the following:
• single-rate—if the named tricolor policer is a
single-rate policer.

• two-rate—if the named tricolor policer is a two-rate
policer.

Define a firewall filter term.

Related
Documentation

Configuring the Firewall Filter for Bridge Family Type (NSM Procedure) on page 351•

• Configuring the Firewall Filter for MPLS Family Type (NSM Procedure)

• Configuring the Firewall Filter for VPLS Family Type (NSM Procedure)
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Configuring Filters for inet Family Type (NSMProcedure)

You can configure filters, prefix-actions, service filters, and simple filters for Inet using

the following options. See the following topics:

• Configuring Firewall Filter for inet Family Type (NSM Procedure) on page 355

• Configuring Prefix-specific Actions (NSM Procedure) on page 357

• Configuring Service Filters (NSM Procedure) on page 358

• Configuring Simple Filters (NSM Procedure) on page 359

Configuring Firewall Filter for inet Family Type (NSMProcedure)

You can configure a firewall filter for inet family type.

To configure the firewall filter in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Firewall > Family > Inet.

4. Select Filter.

5. Add or modify settings as specified in Table 217 on page 355.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 217: Firewall Filter Configuration Details

Your ActionTask

1. Expand Inet.

2. Click Filter next to Inet.

3. Click Add new entry next to Filter.

4. Expand Filter.

5. In the name box, enter the name that identifies the filter.

6. In the Comment box, enter the comment.

7. Select the Interface Specific check box to configure
interface-specific names for firewall counters.

Configure a firewall filter to
filter IPv4 packets.

1. Click Accounting Profile next to filter.

2. Click Add new entry next to Accounting Profile.

3. In the New accounting-profilewindow, enter the name to be
assigned to the accounting profile.

Configure accounting for
firewall filters.
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Table 217: Firewall Filter Configuration Details (continued)

Your ActionTask

1. Click Term next to Accounting Profile.

2. Click Add new entry next to Term.

3. Expand Term.

4. In the Name box, enter the name that identifies the term.

5. In the Comment box, enter the comment for the term.

6. From the Filter list, select the name that identifies the filter.

7. Expand From.

8. In the Comment box, enter the comment.

9. Select the Is Fragment check box if the packet is a trailing
fragment.

10. Select the First Fragment check box if it matches the first
fragment of a fragmented packet.

11. In the Fragment Flags box, enter the IP fragmentation flags.

12. Select theTcp Initial checkbox if itmatches the first TCPpacket
of a connection.

13. Select the Tcp established check box if it matches the TCP
packets other than the first packet of a connection.

14. In the Tcp Flags box, enter the TCP flags.

15. Fromthe listedprotocol-independentmatchconditions, select
the filters defined for the Inet family type.

The protocol-independent match conditions are Address, Ah
Spi, Destination Address, Destination Class, Destination port,
Destination prefix List, Dscp, Esp Spi, Forwarding Class,
Fragment offset, Icmp Code, Icmp Type, Interface, Interface
Group, Interface Set, IP Options, Loss Priority, Packet Length,
Port, Precedence, prefix List, Protocol, Source Address, Source
Port, Source Prefix List and Ttl.

16. Expand Then.

17. In the Comment box, enter the comment for then.

18. In the Count box, enter the number of packets.

19. Select the Log check box to store the header information of a
packet on the Routing Engine.

20.Select Syslog to log an alert for the packet.

21. Select the Sample check box to sample the packet traffic.

22. Select the Port Mirror check box to port-mirror the packets.

23. From the Loss Priority list, set the packet loss priority (PLP) to
low, medium-low, medium-high, or high.

24. In the Forwarding Class box, enter the packet forwarding class
name.

25. From the Prefix Action list, select the prefix specific action.

Define firewall filter term.
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Table 217: Firewall Filter Configuration Details (continued)

Your ActionTask

26. Click Accept next to Then.

• Select Accept to accept a packet.

• Select Discard to discard a packet silently, without sending
an ICMPmessage.

• Select Next to evaluate the next term in the firewall filter.

• Select Routing instance to specify a routing table to which
packets are forwarded.

• Select IPsec Sa to specify an IP Security (IPsec) security
association (SA) for the packet.

• Select Reject to discard a packet, and send an ICMP
destination unreachable message.

27. Click Policer next to Then.

28.Select one of the following:

• Select Policer to configure a new policer for each filter and
select the policer name.

• Select three-color-policer to configure a tricolor marking
policer,
a. Expand Three Color Policer.

b. Click Single Rate next to Three Color Policer.

c. Select one of the following:
• single-rate—If thenamed tricolor policer is a single-rate
policer.

• two-rate—If the named tricolor policer is a two-rate
policer.

Configuring Prefix-specific Actions (NSMProcedure)

Prefix-specific actionsallowyou toconfigurepolicersandcounters for specific addresses

or ranges of addresses. This allows you to essentially create policers and counters on a

per-prefix level.

To configure the prefix-specific actions in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Firewall > Family > Inet.

4. Click Prefix Action.

5. Add or modify settings as specified in Table 218 on page 358.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 218: Prefix Actions Details

Your ActionTask

1. Click Prefix Action next to Inet.

2. In the Name box, enter the action name.

3. From the Policer list, select the actions to be taken.

4. Select theCountcheckbox to includecountas theactionmodifier.

5. Select the Filter Specific check box to configure a policer to act
as a filter-specific policer.

6. From theSubnetPrefix Length list, select the subnet prefix length.

Range: 0 to 32

7. Click Source Prefix Length next to prefix-action.

8. Select source-prefix-length to configure the source address range
specified for a prefix-specific policer or counter and select the
source prefix length.

9. Select destination-prefix-length to configure the destination
address range specified for a prefix-specific policer or counter
and select the destination prefix length.

Configure prefix-specific
actions.

Configuring Service Filters (NSMProcedure)

A service filter identifies packets on which one or more services are to be applied, and

which PIC performs the service.

To configure the service filters for inet in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Firewall > Family > Inet.

4. Click Prefix Action.

5. Add or modify settings as specified in Table 219 on page 358.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 219: Service Filter Configuration Details

Your ActionTask

1. Click Service Filter next to Inet.

2. Click Add new entry next to Service Filter.

3. Expand service-filter.

4. In the Name box, enter the name that identifies the service
filter.

Configure service filter.
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Table 219: Service Filter Configuration Details (continued)

Your ActionTask

1. Click Term next to service-filter.

2. Click Add new entry next to Term.

3. Expand Term.

4. In the Name box, enter the name that identifies the term.

5. In the Comment box, enter the comment for the term.

6. Expand From.

7. In the Comment box, enter the comment.

8. Check the Is Fragment check box if the packet is a trailing
fragment.

9. Check the First Fragment check box if it matches the first
fragment of a fragmented packet.

10. In the Fragment Flags box, enter the IP fragmentation flags.

11. Fromthe listedprotocol-independentmatchconditions, select
the filters defined for the Inet family type.

The protocol-independent match conditions are Address, Ah
Spi, Destination Address, Destination port, Destination prefix
List, Esp Spi, Fragment offset, Interface Group, , IP Options,
LossPriority, Port, Prefix List, Protocol, SourceAddress, Source
Port, and Source Prefix List.

12. Click Then next to From.

13. In the Comment box, enter the comment for then.

14. In the Count box, enter the number of packets.

15. Select the Log check box to store the header information of a
packet on the Routing Engine.

16. Select the Sample check box to sample the packet traffic.

17. Select the Port Mirror check box to port-mirror the packets.

18. Select Service to direct packets for stateful-firewall service.

19. Select Skip to let packets bypass stateful-firewall service.

Define firewall filter term.

Configuring Simple Filters (NSMProcedure)

Simple filters are used to support Ethernet IQ2PICs. A simple filter is a subset of a firewall

filter with the following limitations:

• The next-term action is not supported.

• The except and protocol-exceptmatch conditions are not supported.

• Noncontiguous masks are not supported.

• Only one source-address and one destination-address prefix are allowed for each filter

term.
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To configure the simple filters for inet in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Firewall > Family > Inet.

4. Select Simple Filters.

5. Add or modify settings as specified in Table 220 on page 360.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 220: Simple Filter Details

Your ActionTask

1. Click Simple Filter next to Inet.

2. Click Add new entry next to Simple Filter.

3. In the Name box, enter the name that identifies the simple
filter.

Configure simple filter.

1. Click Term next to simple-filter.

2. Click Add new entry next to Term.

3. Expand Term.

4. In the Name box, enter the name that identifies the term.

5. In the Comment box, enter the comment.

6. Expand From.

7. Fromthe listedprotocol-independentmatchconditions, select
the filters defined for the Inet family type.

The protocol-independent match conditions are Destination
Address, Destination port, Forwarding Class, Protocol, Source
Address, and Source Port.

8. Click Then next to From.

9. In the Comment box, enter the comment.

10. From the LossPriority list, select the packet loss priority (PLP)
level to set it as low, medium-low, medium-high, or high.

11. In the ForwardingClass box, enter the packet forwarding class
name.

Define a term.
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CHAPTER 21

Configuring Application Layer Gateways
in JSeriesServicesRouters andSRXSeries
Services Gateways

• Configuring H.323 ALG (NSM Procedure) on page 361

• Configuring SIP ALG (NSM Procedure) on page 363

• Configuring SCCP ALG (NSM Procedure) on page 366

• Configuring MGCP ALG (NSM Procedure) on page 368

• Enabling or Disabling ALGs (NSM Procedure) on page 371

Configuring H.323 ALG (NSMProcedure)

The H.323 standard is a legacy VoIP protocol defined by the ITU-T. H.323 consists of a

suite of protocols (such as H.225.0 and H.245) that are used for call signaling and call

control for VoIP.

To configure H.323 ALG:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure H.323 ALG.

3. Click the Configuration tab. In the configuration tree, select Security > Alg > H323.

4. Add or modify settings as specified in Table 221 on page 361.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 221: H.323 ALG Configuration Details

Your ActionFunctionOption

Enter a value between 10 and 50,000
seconds.

Controls how long entries
remain in the NAT table.

Endpoint Registration
Timeout
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Table 221: H.323 ALG Configuration Details (continued)

Your ActionFunctionOption

Select this option to enable traffic
from any port number.

Allowsmedia traffic from
any port number. By
default, this feature is
disabled. When disabled,
the device allows a
temporary opening, or
pinhole, in the firewall as
needed for media traffic.

Media Source Port Any

Enter the value for themessage flood
gatekeeper threshold.

Limits the rate per second
at which RAS requests to
the gatekeeper are
processed. Messages
exceeding the threshold
are dropped. This feature
is disabled by default.

Threshold

Select this option to permit
unidentified H.323messages. By
default, unknown (unsupported)
messages are dropped.

Specifies how unidentified
H.323messages are
handled by the device.
Permitting unknown
messagescancompromise
security and is not
recommended. However,
in a secure test or
production environment,
this statement can be
useful for resolving
interoperability issueswith
disparate vendor
equipment. By permitting
unknown H.323
(unsupported) messages,
you can get your network
operational and later
analyze your VoIP traffic to
determine why some
messages were being
dropped.

This statement applies
only to received packets
identified as supported
VoIP packets. If a packet
cannot be identified, it is
alwaysdropped. If apacket
is identified as a supported
protocol, the message is
forwarded without
processing.

Permit NAT Applied
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Table 221: H.323 ALG Configuration Details (continued)

Your ActionFunctionOption

Select this option.Specifies that unknown
messages be allowed to
pass if the session is in
Route mode. (Sessions in
Transparent mode are
treated as Route mode.)

Permit Routed

Related
Documentation

Configuring SIP ALG (NSM Procedure) on page 363•

• Configuring SCCP ALG (NSM Procedure) on page 366

• Configuring MGCP ALG (NSM Procedure) on page 368

• Enabling or Disabling ALGs (NSM Procedure) on page 371

Configuring SIP ALG (NSMProcedure)

SIP is an IETF-standard protocol for initiating, modifying, and terminating multimedia

sessions over the Internet. Such sessions might include conferencing, telephony, or

multimedia, with features such as instant messaging and application-level mobility in

network environments.

To configure SIP ALG:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure SIP ALG.

3. Click the Configuration tab. In the configuration tree, select Security > Alg > Sip.

4. Add or modify settings as specified in Table 222 on page 363.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 222: SIP ALG Configuration Details

Your ActionFunctionOption

Select a value between 3 and 10
minutes. The default is 3.

Specifies the INVITE
transaction timeout at the
proxy, in minutes. Because
the SIP ALG is in the
middle, insteadofusing the
INVITE transaction timer
value B (which is (64 * T1)
=32 seconds), theSIPALG
gets its timer value from
the proxy.

C Timeout
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Table 222: SIP ALG Configuration Details (continued)

Your ActionFunctionOption

Select a value between 10 and 2,550
seconds. The default is 120 seconds.

Specifies the maximum
lengthof time(in seconds)
a call can remain active
without anymedia (RTPor
RTCP) traffic within a
group. Each timeanRTPor
RTCPpacket occurswithin
a call, this timeout resets.
When the period of
inactivity exceeds this
setting, the temporary
openings (pinholes) in the
firewallSIPALGopened for
media are closed. Note
that upon timeout, while
resources for media
(sessionsandpinholes)are
removed, the call is not
terminated.

Inactive Media Timeout

Select a value between 3 and 7,200
minutes. The default is 720minutes.

Sets the absolute
maximum length of a call.
When a call exceeds this
parameter setting, the SIP
ALG tears down the call
and releases the media
sessions.

Maximum Call Duration

Select a value between 500 and
5,000milliseconds.Thedefault is500
milliseconds.

Specifies the roundtrip
timeestimate(in seconds)
of a transaction between
endpoints. Becausemany
SIP timers scale with the
T1-Interval (asdescribed in
RFC 3261), when you
change the value of the
T1-Interval timer, thoseSIP
timers also are adjusted.

T1 Interval

Select a value between 5 and 10
seconds. The default is 5 seconds.

Specifies the maximum
timeamessage remains. in
the network. Because
manySIP timers scalewith
the T4-Interval (as
described in RFC 3261),
whenyouchangethevalue
of the T4-Interval timer,
those SIP timers also are
adjusted.

T4 Interval

Select thisoption toenable translation
of host IP address in the call-ID
header. By default, translation is
enabled.

Enables or disables
translation of the host IP
address in the call-ID
header. Translation is
enabled by default.

Disable
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Table 222: SIP ALG Configuration Details (continued)

Your ActionFunctionOption

Select this option toenable thedevice
to retain media stream resources
when themedia stream is on hold. By
default, media stream resources are
released when themedia stream is
held.

Specifies whether the
device frees media
resources for a SIP ALG,
evenwhenamedia stream
is placed on hold.

Retain Hold Resource

Enter a value between 1 and 3,600
seconds.

Specifies the amount of
time (in seconds) to make
an attack table entry for
each INVITE,which is listed
in the application screen.

Timeout

Select None, destination-ip, or all. If
you select destination-ip, enter or
select an IP address.

Protects servers against
INVITE attacks. Configure
the SIP application screen
to protect the server at
some or all destination IP
addresses against INVITE
attacks. Youcan includeup
to 16 destination IP
addresses of servers to be
protected.

Destination Ip
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Table 222: SIP ALG Configuration Details (continued)

Your ActionFunctionOption

Select this option to permit
unidentifiedSIPmessages. Bydefault,
unknown (unsupported) messages
are dropped.

Specifies how unidentified
SIPmessages are handled
by the device. Permitting
unknownmessages can
compromise security and
is not recommended.
However, in a secure test
orproductionenvironment,
this statement can be
useful for resolving
interoperability issueswith
disparate vendor
equipment. By permitting
unknown SIP
(unsupported) messages,
you can get your network
operational and later
analyze your VoIP traffic to
determine why some
messages were being
dropped.

This statement applies
only to received packets
identified as supported
VoIP packets. If a packet
cannot be identified, it is
alwaysdropped. If apacket
is identified as a supported
protocol, the message is
forwarded without
processing.

Permit NAT Applied

Select this option.Specifies that unknown
messages be allowed to
pass if the session is in
Route mode. (Sessions in
Transparent mode are
treated as Route mode.)

Permit Routed

Related
Documentation

Configuring SCCP ALG (NSM Procedure) on page 366•

• Configuring H.323 ALG (NSM Procedure) on page 361

• Configuring MGCP ALG (NSM Procedure) on page 368

• Enabling or Disabling ALGs (NSM Procedure) on page 371

Configuring SCCP ALG (NSMProcedure)

SCCP is a protocol for call signaling. Skinny is based on a call-agent-based call-control

architecture. The control protocol uses binary-coded frames encoded on TCP frames
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sent to well-known TCP port number destinations to set up and tear down RTPmedia

sessions.

To configure SCCP ALG:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure SCCP ALG.

3. Click the Configuration tab. In the configuration tree, select Security > Alg > Sccp.

4. Add or modify settings as specified in Table 223 on page 367.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 223: SCCP ALG Configuration Details

Your ActionFunctionOption

Select a value between 10 and 600
seconds.

Indicates the maximum
lengthof time(in seconds)
a call can remain active
without anymedia (RTPor
RTCP) traffic within a
group. Each timeanRTPor
RTCPpacket occurswithin
a call, this timeout resets.
When the period of
inactivity exceeds this
setting, the SCCP ALG the
gatesopened formediaare
closed.

Inactive Media Timeout

Select a value for call flood threshold
from 2 to 1,000.

Protects SCCP ALG clients
from flood attacks by
limiting thenumberof calls
they attempt to process.

Threshold
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Table 223: SCCP ALG Configuration Details (continued)

Your ActionFunctionOption

Select this option to permit
unidentified SCCPmessages. By
default, unknown (unsupported)
messages are dropped.

Specifies how unidentified
SCCPmessages are
handled by the device.
Permitting unknown
messagescancompromise
security and is not
recommended. However,
in a secure test or
production environment,
this statement can be
useful for resolving
interoperability issueswith
disparate vendor
equipment. By permitting
unknown SCCP
(unsupported) messages,
you can get your network
operational and later
analyze your VoIP traffic to
determine why some
messages were being
dropped.

This statement applies
only to received packets
identified as supported
VoIP packets. If a packet
cannot be identified, it is
alwaysdropped. If apacket
is identified as a supported
protocol, the message is
forwarded without
processing.

Permit NAT Applied

Select this option.Specifies that unknown
messages be allowed to
pass if the session is in
Route mode. (Sessions in
Transparent mode are
treated as Route mode.)

Permit Routed

Related
Documentation

Configuring SIP ALG (NSM Procedure) on page 363•

• Configuring H.323 ALG (NSM Procedure) on page 361

• Configuring MGCP ALG (NSM Procedure) on page 368

• Enabling or Disabling ALGs (NSM Procedure) on page 371

ConfiguringMGCPALG (NSMProcedure)

MGCP is a text-based Application Layer Protocol used for call setup and call control

between themedia gateway and themedia gateway controller (MGC).
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To configure MGCP ALG:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure MGCP ALG.

3. Click the Configuration tab. In the configuration tree, select Security > Alg >Mgcp.

4. Add or modify settings as specified in Table 224 on page 369.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 224: MGCP ALG Configuration Details

Your ActionFunctionOption

Select a value between 10 and 2,550
seconds. The default is 120 seconds.

Specifies the maximum
lengthof time(in seconds)
a call can remain active
without anymedia (RTPor
RTCP) traffic within a
group. Each timeanRTPor
RTCPpacket occurswithin
a call, this timeout resets.
When the period of
inactivity exceeds this
setting, the temporary
openings (pinholes) in the
firewallMGCPALGopened
for media are closed. Note
that upon timeout, while
resources for media
(sessionsandpinholes)are
removed, the call is not
terminated.

Inactive Media Timeout

Enter a value from 3 to 50 seconds.Specifies a timeout value
for MGCP transactions. A
transaction is a signaling
message, for example, a
NTFY from the gateway to
the call agent or a 200 OK
from the call agent to the
gateway. The Juniper
Networks device tracks
these transactions, and
clears themwhen they
time out.

Transaction Timeout
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Table 224: MGCP ALG Configuration Details (continued)

Your ActionFunctionOption

Select a value between 3 and 7,200
minutes. The default is 720minutes.

Sets the absolute
maximum length of a call.
When a call exceeds this
parameter setting, the
MGCP ALG tears down the
call and releases themedia
sessions.

Maximum Call Duration

Enter a value from 2 to 10,000.Limits the number of new
connection requests
allowed per media
gateway per second.

Connection Flood
Threshold

Enter a value from 2 to 50,000
seconds per media gateway. By
default, this feature is disabled.

Limits the rate per second
atwhichmessage requests
to the media gateway are
processed. Messages
exceeding the threshold
are dropped by the MGCP
ALG.

Message Flood Threshold

Select this option to permit
unidentified MGCPmessages. By
default, unknown (unsupported)
messages are dropped.

Specifies how unidentified
MGCPmessages are
handled by the Juniper
Networks device.
Permitting unknown
messagescancompromise
security and is not
recommended. However,
in a secure test or
production environment,
this statement can be
useful for resolving
interoperability issueswith
disparate vendor
equipment. By permitting
unknownMGCP
(unsupported) messages,
you can get your network
operational and later
analyze your VoIP traffic to
determine why some
messages were being
dropped.

This statement applies
only to received packets
identified as supported
VoIP packets. If a packet
cannot be identified, it is
alwaysdropped. If apacket
is identified as a supported
protocol, the message is
forwarded without
processing.

Permit NAT Applied
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Table 224: MGCP ALG Configuration Details (continued)

Your ActionFunctionOption

Select this option.Specifies that unknown
messages be allowed to
pass if the session is in
Route mode. (Sessions in
Transparent mode are
treated as Route mode.)

Permit Routed

Related
Documentation

Configuring SCCP ALG (NSM Procedure) on page 366•

• Configuring SIP ALG (NSM Procedure) on page 363

• Configuring H.323 ALG (NSM Procedure) on page 361

• Enabling or Disabling ALGs (NSM Procedure) on page 371

Enabling or Disabling ALGs (NSMProcedure)

All ALGs are enabled by default.

To enable or disable ALGs:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

enable or disable ALGs.

3. Click the Configuration tab. In the configuration tree, select Security > Alg.

4. Select the check box next to an ALG as specified in Table 225 on page 371.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 225: ALG Configuration Options

Your ActionFunctionOption

Multimedia Application Protocols

Select theDisablecheckbox todisable
the RTSP ALG.

Provides an ALG for the
Real-Time Streaming
Protocol.

RTSP

Basic Internet Protocols

Select theDisablecheckbox todisable
the DNS ALG.

Provides an ALG for the
DomainNameSystem.The
DNS ALGmonitors DNS

DNS

query and reply packets
and closes session if the

371Copyright © 2013, Juniper Networks, Inc.

Chapter 21: Configuring Application Layer Gateways in J Series Services Routers and SRX Series Services Gateways



Table 225: ALG Configuration Options (continued)

Your ActionFunctionOption

DNS flag indicates the
packet is a reply message.

Select theDisablecheckbox todisable
the FTP ALG.

ProvidesanALG for theFile
Transfer Protocol. The FTP
ALGmonitors PORT, PASV
and 227 commands. It
performs NAT of IP/port in
the message and gate
opening on the device as
necessary. The FTP ALG
supports FTP put and FTP
get command blocking.
When FTP_NO_PUT or
FTP_NO_GET is set in the
policy, the FTP ALG sends
back a blocking command
and closes the associated
opened gate when either
theFTPSTORorFTPRETR
command is observed.

FTP

Select theDisablecheckbox todisable
the TFTP ALG.

Provides an ALG for the
Trivial File Transfer
Protocol. The TFTP ALG
processes a TFTP packet
that initiates the request
and opens a gate to allow
return packets from the
reversedirection to theport
that sends the request.

TFTP

Select theDisablecheckbox todisable
the TALK ALG.

Provides an ALG for the
TALK Protocol. The TALK
protocol usesUDPport 517
and port 518 for control
channel connections. The
talk program consists of a
server and a client. The
server handles client
notifications and helps to
establish talk sessions.
There are two types of talk
servers: ntalk and talkd.
The TALK ALG processes
packets of both ntalk and
talkd formats. It also
performs NAT and gate
opening as necessary.

TALK
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Table 225: ALG Configuration Options (continued)

Your ActionFunctionOption

Select theDisablecheckbox todisable
the RSH ALG.

Provides an ALG for the
Remote Shell. The RSH
ALG handles TCP packets
destined for port 514 and
process the RSH port
command. The RSH ALG
performs NAT on the port
in the port command and
opens gates as necessary.

RSH

Select theDisablecheckbox todisable
the PPTP ALG.

Provides an ALG for the
Point-to-Point Tunneling
Protocol. The PPTP is a
Layer 2 protocol that
tunnels PPP data across
TCP/IP networks. The
PPTP client is freely
available onWindows
systems and is widely
deployedforbuildingVPNs.

PPTP

Database and Network Support Protocols

Select theDisablecheckbox todisable
the SQL ALG.

Provides an ALG for the
Structured Query
Language. The SQLNET
ALGprocessesanSQLTNS
response frame from the
server side. It parses the
packet and looks for
(HOST=ipaddress),
(PORT=port) pattern, and
performs NAT and gate
opening on the client side
for the TCP data channel.

SQL

Related
Documentation

• Configuring H.323 ALG (NSM Procedure) on page 361

• Configuring SIP ALG (NSM Procedure) on page 363

• Configuring SCCP ALG (NSM Procedure) on page 366

• Configuring MGCP ALG (NSM Procedure) on page 368
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CHAPTER 22

Configuring Unified Threat Management
Features in J Series Services Routers and
SRX Series Services Gateways

• Configuring Server-Based Antispam (NSM Procedure) on page 375

• Configuring Local List Antispam (NSM Procedure) on page 376

• Configuring Antivirus Protection (NSM Procedure) on page 379

• Configuring Content Filtering (NSM Procedure) on page 384

• ConfiguringWeb Filtering (NSM Procedure) on page 387

Configuring Server-Based Antispam (NSMProcedure)

Antispam filtering allows you to use both a third-party server-based spam block list

(SBL) and to optionally create your own local whitelists (benign) and blacklists

(malicious) for filtering against e-mail messages. The antispam feature is not meant to

replace your antispam server, but to complement it.

To configure server-based antispam:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure server-based antispam.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Feature

Profile > Anti Spam.

4. Select Symantec Sbl and enable the feature.

5. Expand Symantec Sbl and select Profile.

6. Add or modify antispam profile settings as specified in Table 226 on page 376.

7. Click one:

• New—Adds a new profile.

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 226: Server-Based AntispamProfile Settings

Your ActionFunctionOption

Enter a unique name for the antispam
profile.

Specifies a name for the
antispam profile.

Name

Select sbl-default-server if youareusing
the default server. Otherwise, select
None.

Specifies whether the Symantec
SBL server is used.

sbl-default-server

Select one of the following: tag-subject
(of e-mail), block (e-mail), tag-header
(of e-mail).

Specifies the action to be taken
by the device when spam is
detected.

Spam Action

Enter a custom string for identifying a
messageasspam.Bydefault, thedevice
uses ***SPAM***.

Specifies the string used for
identifying amessage as spam.

CustomTagString

Related
Documentation

Configuring Local List Antispam (NSM Procedure) on page 376•

• Configuring Antivirus Protection (NSM Procedure) on page 379

• Configuring Content Filtering (NSM Procedure) on page 384

Configuring Local List Antispam (NSMProcedure)

This section includes the following topics:

• ConfiguringWhitelist and Blacklist Entries on page 376

• Configuring a Custom URL Category List CustomObject on page 377

• Configuring Server-Based Antispam on page 377

• Configuring a UTM Policy for SNMP on page 378

ConfiguringWhitelist and Blacklist Entries

To configure local whitelist and blacklist custom objects:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure whitelist and blacklist custom objects.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Custom

Objects.

4. Select Url Pattern and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. Enter a value for the URL pattern for whitelist or blacklist antispam filtering.
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NOTE: For URL pattern wildcard support, the wildcard rule is as follows:
\*\.[]\?* and youmust precede all wildcard URLs with http://. You can
only use an asterisk (*) if it is at the beginning of the URL and is followed
by a dot (.). You can only use a questionmark (?) at the end of the URL.

The following wildcard syntax is supported: http://*.juniper.net,
http://www.juniper.ne?, http://www.juniper.n??. The following wildcard
syntax isnot supported: *.juniper.net ,www.juniper.ne?,http://*juniper.net,
http://*.

8. ClickOK to save the changes.

Configuring a CustomURL Category List CustomObject

To configure a custom URL category list custom object:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure URL category list custom objects.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Custom

Objects.

4. Select CustomUrl Category and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. Enter the name of the URL pattern list you created for bypassing scanning.

8. ClickOK to save the changes.

Configuring Server-Based Antispam

Antispam filtering allows you to use both a third-party server-based spam block list

(SBL) and to optionally create your own local whitelists (benign) and blacklists

(malicious) for filtering against e-mail messages. The antispam feature is not meant to

replace your antispam server, but to complement it.

To configure server-based antispam:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure server-based antispam.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Feature

Profile > Anti Spam.

4. Select Symantec Sbl and enable the feature.

5. Expand Symantec Sbl and select Profile.

377Copyright © 2013, Juniper Networks, Inc.

Chapter 22: Configuring Unified Threat Management Features in J Series Services Routers and SRX Series Services Gateways



6. Add or modify antispam profile settings as specified in Table 227 on page 378.

7. Click one:

• New—Adds a new profile.

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 227: Server-Based AntispamProfile Settings

Your ActionFunctionOption

Enter a unique name for the antispam
profile.

Specifies a name for the
antispam profile.

Name

Select sbl-default-server if youareusing
the default server. Otherwise, select
None.

Specifies whether the Symantec
SBL server is used.

sbl-default-server

Select one of the following: tag-subject
(of e-mail), block (e-mail), tag-header
(of e-mail).

Specifies the action to be taken
by the device when spam is
detected.

Spam Action

Enter a custom string for identifying a
messageasspam.Bydefault, thedevice
uses ***SPAM***.

Specifies the string used for
identifying amessage as spam.

CustomTagString

Configuring a UTMPolicy for SNMP

To configure a UTM policy for SNMP:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to a

UTM policy for SNMP.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Utm

Policy.

4. Click New to add a new UTM policy entry.

5. Enter a unique name for the UTM policy.

6. Select Antispam and enter the name of the antispam profile.

7. ClickOK to save the changes.

Once you have configured a UTM policy for SNMP, attach the UTM policy to a security

policy that you create.

Related
Documentation

Configuring Antivirus Protection (NSM Procedure) on page 379•

• Configuring Content Filtering (NSM Procedure) on page 384

• ConfiguringWeb Filtering (NSM Procedure) on page 387
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Configuring Antivirus Protection (NSMProcedure)

This section includes the following topics:

• Configuring a MIME Pattern List CustomObject on page 379

• Configuring a Filename Extension List CustomObject on page 379

• Configuring a URL Pattern List CustomObject on page 380

• Configuring a Custom URL Category List CustomObject on page 380

• Configuring an Antivirus Feature Profile on page 381

• Configuring a UTM Policy for Express Antivirus on page 383

Configuring aMIME Pattern List CustomObject

To configure a MIME pattern list custom object:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a MIME pattern list custom object.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Custom

Objects.

4. SelectMime Pattern and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. Enter a value for the MIME pattern.

8. ClickOK to save the changes.

Configuring a Filename Extension List CustomObject

To configure a filename extension list custom object:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a filename extension list.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Custom

Objects.

4. Select Filename Extension and click New.

5. Enter a unique name for the extension list.

6. Select Value and add a new entry.

7. Enter the extensions in the Value box.

8. ClickOK to save the changes.
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Configuring a URL Pattern List CustomObject

To configure a URL pattern list custom object:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure URL pattern list custom objects.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Custom

Objects.

4. Select Url Pattern and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. In Value, enter the URLs or IP addresses you want added to the list for bypassing

scanning.

NOTE: For URL pattern wildcard support, the wildcard rule is as follows:
\*\.[]\?* and youmust precede all wildcard URLs with http://. You can
only use an asterisk (*) if it is at the beginning of the URL and is followed
by a dot (.). You can only use a questionmark (?) at the end of the URL.

The following wildcard syntax is supported: http://*.juniper.net,
http://www.juniper.ne?, http://www.juniper.n??. The following wildcard
syntax isnot supported: *.juniper.net ,www.juniper.ne?,http://*juniper.net,
http://*.

8. ClickOK to save the changes.

Configuring a CustomURL Category List CustomObject

To configure a custom URL category list custom object:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click theDevice Tree tab, and then double-click the device for which youwant to URL

category list custom objects.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Custom

Objects.

4. Select CustomUrl Category and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. Enter the name of the URL pattern list you created for bypassing scanning.

8. ClickOK to save the changes.
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Configuring an Antivirus Feature Profile

When configuring antivirus protection, youmust first create the antivirus customobjects

you are using. Those custom objects may include the MIME pattern list, MIME exception

list, and the filename extension list. Once you have created your customobjects, you can

configure full antivirus protection, including intelligent prescreening, and content size

limits.

To configure an antivirus feature profile:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure an antivirus feature profile.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Feature

Profile > Antivirus > Kaspersky Lab Engine.

4. Add or modify antivirus profile settings as specified in Table 228 on page 381.

5. Click one:

• New—Adds a new profile.

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 228: Antivirus Feature Profile Settings

Your ActionFunctionOption

Pattern Update

If the URL is not already entered, enter the URL
for the pattern database. Note that the URL is
http://update.juniper-updates.net/AV/SRX210
and you should not change it.

Specifies the URL
for the pattern
database.

Url

Enter the time interval forautomaticallyupdating
the pattern database. The default interval is 60
minutes.

Specifies the time
interval for
automatically
updating the
pattern database.

Interval

Select this option if you want to disable
automatic updates and update the pattern
databasemanually.

Specifies whether
automaticupdates
are disabled.

No Autoupdate

Pattern Update > Email Notify

Enter thee-mail addressesof theadministrators
who should receive e-mail notifications when
updates are made to the pattern file.

Specifies the
e-mail addresses
of the
administrators.

Admin Email

381Copyright © 2013, Juniper Networks, Inc.

Chapter 22: Configuring Unified Threat Management Features in J Series Services Routers and SRX Series Services Gateways



Table 228: Antivirus Feature Profile Settings (continued)

Your ActionFunctionOption

Enter the text to appear in the body of the
notification e-mail.

Specifies the text
that will appear in
the custom
message.

CustomMessage

Enter the text to appear in the subject line of the
notification e-mail.

Specifies the
custommessage
subject.

CustomMessage
Subject

Profile

Enterauniquenamefor theKaspersky labengine
profile.

Specifies the
name of the
Kaspersky lab
engine profile.

Name

Profile > Fallback Options

Select this option to enable fallback options.Enables fallback
options.

Enable Feature

Select log-and-permit or block from the list.Specifies the
fallback options.

The available fallback
options are as follows:

• Default

• Corrupt File

• Password File

• Decompress Layer

• Content Size

• Engine Not Ready

• Timeout

• Out of Resources

• Too Many Requests

Profile > Notification Options

Select this option to enable notification options.Enables
notification
options.

Enable Feature

• CustomMessage—Enter the text to appear in
the body of the notification e-mail.

• CustomMessage Subject—Enter the text to
appear in the subject line of the notification
e-mail.

• notify-mail-sender—Select this option to
notify the sender of the mail.

• Type—Select protocol-only ormessage from
the Type list.

Specifies the
notification
actions for
fallback block,
fallback nonblock,
and virus
detection.

The notification options
that can be configured
are the following:

• Fallback Block

• Fallback Non Block

• Virus Detection

Profile > Scan Options
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Table 228: Antivirus Feature Profile Settings (continued)

Your ActionFunctionOption

Select this option to enable scan options.Enables scan
options.

Enable Feature

Select this option to enable intelligent
prescreening.

Enables intelligent
prescreening.

intelligent-prescreening

Enter content size parameters.Specifies the
content size
parameters. The
content size check
occurs before the
scan request is
sent. The content
size refers to
accumulated TCP
payload size.

Content Size Limit

Enter the scanning timeout parameters.Specifies the
scanning timeout
parameters.

Timeout

Profile > Trickling

Select this option to enable trickling feature.Enables trickling
feature.

Enable Feature

Enter the trickling timeout parameters.Specifies the
trickling timeout
parameters.

Timeout

Antivirus >Mime
Whitelist

Select this option to enable this feature.Enables this
feature.

Enable Feature

Enter the name of the URL whitelist custom
object you created.

Specifies the
name of the URL
whitelist.

List

Configuring a UTMPolicy for Express Antivirus

To configure a UTM policy for express antivirus:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click theDeviceTree tab, and then double-click the device that youwant to configure.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Utm

Policy.

4. Click New to add a new UTM policy entry.
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5. Enter a unique name for the UTM policy.

6. Select Antivirus and enter the name of the antivirus profile.

7. In theHttp, Imap,Pop3, orSmtpprofileboxes, enter thenameof theprofile youcreated

earlier.

8. For Ftp, select the upload and download profiles.

9. ClickOK to save the changes.

Once you have configured a UTM policy for express antivirus, attach the UTM policy to

a security policy that you create.

Related
Documentation

Configuring Local List Antispam (NSM Procedure) on page 376•

• Configuring Content Filtering (NSM Procedure) on page 384

• ConfiguringWeb Filtering (NSM Procedure) on page 387

Configuring Content Filtering (NSMProcedure)

This section includes the following topics:

• Configuring a Protocol Command CustomObject on page 384

• Configuring a Filename Extension List CustomObject on page 385

• Configuring a MIME Pattern List CustomObject on page 385

• Configuring a Content–Filtering Feature Profile on page 385

• Configuring a UTM Policy for Content-Filtering on page 387

Configuring a Protocol Command CustomObject

To configure a protocol command custom object:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a protocol command custom object.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Custom

Objects.

4. Select Protocol Command and click New.

5. Enter a unique name for the protocol command custom object.

6. Select Value and add a new entry.

7. Enter the commands for the protocol in Value.

8. ClickOK to save the changes.
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Configuring a Filename Extension List CustomObject

To configure a filename extension list custom object:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a filename extension list.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Custom

Objects.

4. Select Filename Extension and click New.

5. Enter a unique name for the extension list.

6. Select Value and add a new entry.

7. Enter the extensions in the Value box.

8. ClickOK to save the changes.

Configuring aMIME Pattern List CustomObject

To configure a MIME pattern list custom object:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a MIME pattern list custom object.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Custom

Objects.

4. SelectMime Pattern and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. Enter a value for the MIME pattern.

8. ClickOK to save the changes.

Configuring a Content–Filtering Feature Profile

To configure a content-filtering feature profile:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure a content-filtering feature profile.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Feature

Profile > Content Filering > Profile.

4. Add ormodify content-filtering profile settings as specified in Table 229 on page 386.

5. Click one:
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• New—Adds a new profile.

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 229: Content–Filtering Feature Profile Settings

Your ActionFunctionOption

Profile

Enter a unique name for this profile.Specifies the name of the
content-filtering profile.

Name

Enter the protocol command custom
object you created for permitting
commands from the list.

The permit protocol command
list is intended to act as an
exception list for the block
protocol command list.

Permit Command

Enter the protocol command custom
object you created for blocking
commands from the list.

Specifies the block command.Block Command

Enter the file extension list custom
object you created for blocking
extensions from the list.

Specifies theextensions thatare
blocked.

Block Extension

Profile > Block Content Type

Select one or more of the content
types to be blocked.

Specifies the content types that
can be blocked.

The content types
that can be blocked
are the following:

• Activex

• Java Applet

• Exe

• Zip

• Http Cookie

Profile > BlockMime

Select this option to configure block
MIME features.

Enables configuration of block
MIME features.

Enable Feature

Enter the MIME list custom object you
created for blocking MIME patterns.

Specifies the MIME list custom
object.

List

Enter the exception MIME list custom
object you created for MIME patterns
that will not be blocked.

Specifies theexceptionMIME list
custom object.

Exception

Profile > Notification Options

Select thisoption toenablenotification
options.

Enables notification options.Enable Feature
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Table 229: Content–Filtering Feature Profile Settings (continued)

Your ActionFunctionOption

Selectmessage as the type of
notification that is sentwhena fallback
option of block is triggered.

Specifies the notification type.Type

Select this option to notify the sender
of the mail.

Specifies that notificationwill be
sent to the sender.

notify-mail-sender

Enter the text to appear in the body of
the notification e-mail.

Specifies thenotificationactions
for fallback block, fallback
nonblock, and virus detection.

CustomMessage

Configuring a UTMPolicy for Content-Filtering

To configure a UTM policy for content filtering:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click theDeviceTree tab, and then double-click the device that youwant to configure.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Utm

Policy.

4. Click New to add a new UTM policy entry.

5. Enter a unique name for the UTM policy.

6. Select Content Filtering and enter the name of the profile you had created.

7. In theHttp, Imap,Pop3, orSmtpprofileboxes, enter thenameof theprofile youcreated

earlier.

8. For Ftp, select the upload and download profiles.

9. ClickOK to save the changes.

Once you have configured a UTM policy for content filtering, attach the UTM policy to a

security policy that you create.

Related
Documentation

Configuring Local List Antispam (NSM Procedure) on page 376•

• Configuring Antivirus Protection (NSM Procedure) on page 379

• ConfiguringWeb Filtering (NSM Procedure) on page 387

ConfiguringWeb Filtering (NSMProcedure)

This section includes the following topics:

• Configuring a URL Pattern List CustomObject on page 388

• Configuring a Custom URL Category List CustomObject on page 388
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• Configuring aWeb Filtering Feature Profile on page 389

• Configuring a UTM Policy for Web Filtering on page 391

Configuring a URL Pattern List CustomObject

To configure a URL pattern list custom object:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure URL pattern list custom objects.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Custom

Objects.

4. Select Url Pattern and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.

7. In Value, enter the URLs or IP addresses that you want to be added to the list for

bypassing scanning.

NOTE: For URL pattern wildcard support, the wildcard rule is as follows:
\*\.[]\?* and youmust precede all wildcard URLs with http://. You can
only use an asterisk (*) if it is at the beginning of the URL and is followed
by a dot (.). You can only use a questionmark (?) at the end of the URL.

The following wildcard syntax is supported: http://*.juniper.net,
http://www.juniper.ne?, http://www.juniper.n??. The following wildcard
syntax isnot supported: *.juniper.net ,www.juniper.ne?,http://*juniper.net,
http://*.

8. ClickOK to save the changes.

Configuring a CustomURL Category List CustomObject

To configure a custom URL category list custom object:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure whitelist and blacklist custom objects.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Custom

Objects.

4. Select CustomUrl Category and click New.

5. Enter a unique name for the list.

6. Select Value and add a new entry.
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7. Enter the name of the URL pattern list you created for bypassing scanning.

8. ClickOK to save the changes.

Configuring aWeb Filtering Feature Profile

To configure aWeb filtering feature profile:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure aWeb filtering feature profile.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Feature

Profile >Web Filtering.

4. Add or modify Web filtering feature profile settings as specified in Table 230 on

page 389.

5. Click one:

• New—Adds a new profile.

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 230:Web Filtering Feature Profile Settings

Your ActionFunctionOption

Enter the name of the customURL list you
created. This is the first filtering category
that both integrated and redirect Web
filtering use. If there is nomatch, the URL
is sent to the SurfControl server.

Specifies the URL whitelist.Url Whitelist

Enter the name of the customURL list you
created. This is the first filtering category
that both integrated and redirect Web
filtering use. If there is nomatch, the URL
is sent to the SurfControl server.

Specifies the URL blacklist.Url Blacklist

Select surf-control-integrated from the list.Specifies the type ofWeb
filtering.

Type

Surf Control Integrated > Cache

Select this option to enable cache options.Enables cache options.Enable Feature

Enter a timeout limit inminutes for expiring
cache entries. (The default is 24 hours and
themaximum allowed life span.)

Specifies the timeout limit for
cache entries.

Timeout

Enter a size limit for the cache in kilobytes.
(The default is 500 KB.)

Specifies the size limit for the
cache.

Size
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Table 230:Web Filtering Feature Profile Settings (continued)

Your ActionFunctionOption

Surf Control Integrated > Server

Select this option to enable server options.Enables server options.Enable Feature

Enter the Surf Control server name or IP
address.

Specifies the Surf Control
server address.

Host

Enter the port number for communicating
with the Surf Control server. (Default ports
are 80, 8080, and 8081.)

Specifies theport number for
communicatingwith theSurf
Control server.

Port

Surf Control Integrated > Profile

Enter a unique name for this profile.Specifies a name for the
Web-filtering profile.

Name

Select log-and-permit,permit, orblock from
the list.

Specifies the default action
for this profile for requests
that experience errors.

Default

Enter a custommessage to be sent when
HTTP requests are blocked.

Specifies the custom
message.

Custom Block
Message

Enter a value in seconds. Once this limit is
reached, failmodesettingsareapplied.The
default setting is 10 seconds.

Specifies the timeout limit.Timeout

Surf Control Integrated > Profile > Fallback Settings

Select this option to enable fallback
options.

Enables fallback options.Enable Feature

Select log-and-permitorblock from the list.Specifies the fallbackoptions.The available
fallback options
are as follows:

• Default

• Server
Connectivity

• Timeout

• Too Many
Requests

Surf Control Integrated > Profile > Category

Enter the name of the custom URL
category list custom object you created.

Specifies the name of the
category.

Name

Select log-and-permit,permit, orblock from
the list.

Specifies the action to be
taken.

Action
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Configuring a UTMPolicy forWeb Filtering

To configure a UTM policy for Web filtering:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click theDeviceTree tab, and then double-click the device that youwant to configure.

3. Click the Configuration tab. In the configuration tree, select Security > Utm > Utm

Policy.

4. Click New to add a new UTM policy entry.

5. Enter a unique name for the UTM policy.

6. SelectWeb Filtering and enter the name ofWeb filtering profile you created earlier in

Http Profile.

7. In the Http profile box, enter the name of the profile you created earlier.

8. ClickOK to save the changes.

Once you have configured a UTM policy for Web filtering, attach the UTM policy to a

security policy that you create.

Related
Documentation

• Configuring Local List Antispam (NSM Procedure) on page 376

• Configuring Content Filtering (NSM Procedure) on page 384

• Configuring Antivirus Protection (NSM Procedure) on page 379
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CHAPTER 23

Configuring Network Address Translation
in JSeriesServicesRouters andSRXSeries
Services Gateways

• Configuring Source NAT Objects on JUNOSOS (NSM Procedure) on page 393

Configuring Source NATObjects on JUNOSOS (NSMProcedure)

Network and Security Manager (NSM) allows you to configure Network Address

Translation (NAT) objects running on JUNOS devices using the NAT rulebase.

To configure source NAT objects on JUNOSOS:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device for which you want to

configure NAT running on JUNOSOS.

3. Click the Configuration tab. In the configuration tree, select Security > Nat > Source >

Pool.

4. Add or modify settings as specified in Table 231 on page 393.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 231: JUNOS Source NAT Configuration Details

Your ActionFunctionOption

Pool

1. Click the New button.

2. Enter a name and comment.

3. ClickOK.

Specifies the name of the new pool.Name

Specifies the comment for the new pool. This
is optional.

Comment

Pool > Address
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Table 231: JUNOS Source NAT Configuration Details (continued)

Your ActionFunctionOption

1. Click the New button.

2. Enter the comment and the starting range of
the IP address.

3. Click the End of Range tab.

4. Enter the commentand theending rangeof the
IP address.

5. ClickOK.

Specifies the starting range of the IP address.IP Address

Specifies the ending range of the IP address.Ipaddr

Pool > Host Address Base

1. Enter a comment.

2. Enter the IP address of the host.

3. ClickOK.

Specifies the host IP address.Ipaddr

Pool >Overflow Pool > Pool Name

1. Enter a comment.

2. Select one of the following options:

• None

• pool-name

• interface

3. If you select pool-name, enter a pool name.

4. ClickOK.

Specifies that no pool name is selected.None

Specifies the pool name.pool-name

Specifies the interface name for the pool.interface

Pool > Port Translation

1. Enter a comment.

2. For No Translation, select the No Translation
check box.

3. ClickOK.

Specifies that no port is selected.No Translation

1. Enter the comment and the lower range.

2. Click the To tab.

3. Enter the comment and the higher range.

4. ClickOK.

Specifies the lower and higher ranges of the
port.

Translation

Pool > Routing Instance

1. Enter a comment.

2. Select the routing instance name from the
drop-down list.

3. ClickOK.

Specifies the routing instance name.Ri Name
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Related
Documentation

• NSM and Device Management Overview on page 3

• Communication Between NSM and a Device Overview on page 3
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CHAPTER 24

Configuring Bridge Domains in J Series
Services Routers and SRX Series Services
Gateways

• Configuring Bridge Domains Properties (NSM Procedure) on page 397

Configuring Bridge Domains Properties (NSMProcedure)

You can configure the bridge domain properties using the following options. See the

following topics:

• Configuring Logical Interfaces (NSM Procedure) on page 397

• Configuring Multicast Monitoring Options (NSM Procedure) on page 398

• Configuring VLAN ID (NSM Procedure) on page 401

Configuring Logical Interfaces (NSMProcedure)

You can specify the logical interfaces to include in the bridge domain, VPLS instance, or

virtual switch.

To configure logical interfaces in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Bridge Domains.

4. Select Domain.

5. Add or modify settings as specified in Table 232 on page 398.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 232: Logical Interface Configuration Details

Your ActionTask

1. Click Add new entry next to Domain.

2. Click Interface.

3. ClickAdd new entry next to Interface.

4. From the Name list, select the name of a logical interface.

5. In the Comment box, enter the comment.

Configure logical interface
to include in the bridge
domain, VPLS instance, or
virtual switch.

ConfiguringMulticast Monitoring Options (NSMProcedure)

Multicastmonitoring is away for a Layer 2device tomonitor at the Layer 3packet content

to determine which actions are to be taken to process or forward a frame. There are

specific forms of monitoring, such as IGMPmonitoring or PIMmonitoring. In all cases,

monitoring involves a device configured to function at Layer 2 having access to Layer 3

(packet) information. monitoring makes multicasting more efficient in these devices.

To configure Multicast Monitoring:

1. In the navigation tree select DeviceManager > Devices.

2. In the Devices list, double-click the device to select it.

3. In the Configuration tab, expand Bridge Domains.

4. Select Domain.

5. Add or modify the settings as specified in Table 233 on page 399.

6. Click one:

• OK—saves the changes

• Cancel—cancels the modifications
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Table 233: Multicast Monitoring Options Configuration Details

Your ActionTask

Establish multicast
monitoring option values.

1. Click Add new entry next to Domain.

2. ClickMulticastmonitoring Options next to domain.

Establish a list of flood
group addresses for
multicast monitoring.

1. Click Flood Groups next to Multicast Monitoring Options.

2. Click Add new entry next to Flood Groups.

3. In the dialog box, enter the IP addresses.

Configure multicast
forwardingcacheproperties.

1. Click Forwarding Cache next to Multicast Monitoring Options.

2. In the Comment box, enter the comments.

3. Expand Forwarding Cache.

4. Click Threshold next to Forwarding Cache.

5. In the Comment box, enter the comments.

6. From the Suppress list, select the threshold value for a
forwarding cache.

Range: 1 through 200,000

7. From the Reuse list, select the reuse value for the threshold.
The reuse value must be less than the suppression threshold
value.

Range: 1 through 200,000

Establish the graceful
restart duration for
multicast monitoring.

1. Click Graceful Restart next to Multicast Monitoring Options.

2. In the Comment box, enter the comments.

3. From the Restart Duration list, select the duration for graceful
restart.
Range: 0 to 300 seconds

Default : 180 seconds
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Table233:MulticastMonitoringOptionsConfigurationDetails(continued)

Your ActionTask

1. ClickOption next to Multicast Monitoring Options.

2. In the Comment box, enter the comments.

3. ExpandOptions.

4. Click Syslog next to Options.

5. In the Comment box, enter the comments.

6. From the Upto list, select the level up to which severity the
messages are to be system logged.

7. From theMark list, select the time interval in seconds to mark
the trace file.

Range : -2147483647 seconds to 2147483647 Seconds

Default : 0

8. Expand Syslog.

9. Click Level next to Syslog.

10. Select the Level of severity to be logged.

Establish multicast
monitoring option values.

1. Click Traceoptions next to Multicast Monitoring Options.

2. In the Comment box, enter the comments.

3. Expand Traceoptions.

4. Click File next to Trace Options.

5. In the Comment box, enter the comments.

6. In the Filename box, enter the name of the file to receive the
output of the tracing operation. Enclose the namewithin
quotation marks.

7. In the Size box, enter the maximum size of each trace file in
bytes.

Range : 10240 to 4,294,967,295 bytes

8. From the Files list, select the maximum number of files.

9. Select one of the following:

• world-readable—To enable log file access to all users.

• no-world-readable—To prevent all users from reading the
log file.

10. Click Flag next to Trace Options.

11. Click Add new entry next to flag.

12. From the Name list, select a tracing operation to perform.

13. In the Comment box, enter the comments.

Configure tracing options.
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Configuring VLAN ID (NSMProcedure)

You can configure VLAN IDs using the Vlan Id option.

To configure VLAN ID in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Bridge Domains.

4. Select Domain.

5. Add or modify settings as specified in Table 234 on page 401.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 234: VLAN ID Configuration Details

Your ActionTask

1. Click Add new entry next to Domain.

2. Click Vlan Id.

3. Select vlan-id and enter the VLAN ID.

4. Select vlan tag to tag the VLAN interface so that it can be
compared with the normalizing VLAN identifier.

5. In the Comment box, enter the comment.

6. In the Inner box, enter the VLAN identifier.

7. In theOuter box, enter the VLAN identifier.

Configure a VLAN ID
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CHAPTER 25

Configuring ForwardingOptions in J Series
Services Routers and SRX Series Services
Gateways

• Configuring Accounting Options (NSM Procedure) on page 403

• Specifying Address Family for Filters (NSM Procedure) on page 405

• Configuring Load Balancing Using Hash Key (NSM Procedure) on page 406

• Configuring Helpers (NSM Procedure) on page 407

• Configuring Per-Flow and Per-Prefix Load Balancing (NSM Procedure) on page 416

• Configuring Port Mirroring (NSM Procedure) on page 417

Configuring Accounting Options (NSMProcedure)

Youcanconfigureaccounting for trafficpassing through the router, containingaMonitoring

Services PIC or an Adaptive Services PIC. Configuring an accounting option includes

configuring the output flow aggregation and configuring the interface that sends out

monitored information.

To configure an accounting group in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Forwarding Options.

4. Select Accounting.

5. Add or modify the settings as specified in Table 235 on page 404.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 235: Accounting Options Configuration Details

Your ActionTask

1. Click Add new entry next to Accounting.

2. In the Name box, type the name of the accounting group.

Configure an accounting
group.

1. ExpandOutput.

2. In the Comment box, enter the comment for the output.

3. From the Aggregate export Interval list, select the time.

4. From the Flow Inactive Timeout list, select the interval before
a flow is considered inactive.

5. From the Flow Active Timeout list, select the interval before
exporting an active flow.

Configure flow output.

1. Click Add new entry next to cflowd.

2. In the Name box, Enter the IP address or identifier of the host
system (the workstation running the cflowd utility).

3. From the Port list, select the UDP port number on the cflowd
host system.

4. From the Version list, select the version format of the
aggregated flows exported to a cflowd server.

5. From the Autonomous System Type, select the type of AS
numbers that cflowd exports.

• origin—Export origin AS numbers of the packet source
address in the Source Autonomous System cflowd field.

• peer—Export peer AS numbers through which the packet
passed in the Source Autonomous System cflowd field.
Default: origin

6. Click Aggregation next to cflowd.

7. Select Autonomous System check box to aggregate by
autonomous system (AS) type.

8. Select the Protocol Port check box to aggregate by protocol
and port number.

9. Select theSourcePrefixcheckbox toaggregateby sourceprefix.

10. Select the Destination Prefix check box to aggregate by
destination prefix.

11. Expand Aggregation.

12. Click Source Destination Prefix next to Aggregation.

13. Select the Caida Compliant check box to record source and
destinationmask length values in compliancewith the Version
2.1b1 release of the cflowd application from the Cooperative
Association for Internet Data Analysis (CAIDA).

Configure flow aggregation.
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Table 235: Accounting Options Configuration Details (continued)

Your ActionTask

1. ExpandOutput.

2. Click Interface next to Output.

3. Click Add new entry next to Interface.

4. In the Name box, enter the name of the accounting interfaces.

5. In the Comment box, enter the comment for the interface.

6. From the Engine Id list, select the identity of the accounting
interface.

7. From the Engine Type list, select the type of this accounting
interface.

8. In theSourceAddressbox, enter theaddressused for generating
packets.

Configure the output
interface.

Related
Documentation

Configuring the Extended DHCP Agent (NSM Procedure)•

• Specifying Address Family for Filters (NSM Procedure) on page 405

• Configuring Load Balancing Using Hash Key (NSM Procedure) on page 406

Specifying Address Family for Filters (NSMProcedure)

You can specify address family for filters using this option. You can specify inet for IP

version 4 (IPv4), inet6 for IP version 6 (IPv6), mpls for MPLS, or vpls for virtual private

LAN service (VPLS).

To specify the address family for filters in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Forwarding Options >

Family .

4. Add or modify settings as specified in Table 236 on page 405.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 236: Address Family Details

Your ActionTask

1. Click Inet, Inet6, orMpls.

2. Click Filter next to Inet, Inet6, or Mpls.

3. In the Comment box, enter the comment.

4. From the Input list, select the name of the applied filter.

5. From theOutput list, select the name of the applied filter.

Apply a forwarding
table filter to a
forwarding table.
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Table 236: Address Family Details (continued)

Your ActionTask

1. Click Vpls next to Family.

2. Expand Vpls.

3. Click Filter next to Vpls.

4. In the Comment box, enter the comment.

5. From the Input list, select the name of the applied filter.

6. Click Flood next to Vpls.

7. In the Comment box, enter the comment.

8. From the Input list, select the name of the applied filter.

Apply a forwarding
table filter for VPLS.

Related
Documentation

Configuring the Extended DHCP Agent (NSM Procedure)•

• Configuring Per-Flow and Per-Prefix Load Balancing (NSM Procedure) on page 416

• Configuring Port Mirroring (NSM Procedure) on page 417

Configuring Load Balancing Using Hash Key (NSMProcedure)

When there are multiple equal-cost paths to the same destination for the active route,

the Junos OS uses a hash algorithm to choose one of the next-hop addresses to install

in the forwarding table. Whenever the set of next hops for a destination changes in any

way, the next-hop address is rechosen using the hash algorithm.

You can select which packet header data to use for per-flow load balancing using the

hash-key option.

To configure load balancing in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Forwarding Options >

Hash Key.

4. Add or modify settings as specified in Table 237 on page 407.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 237: Load Balance Configuration Details

Your ActionTask

1. Click Inet next to Family.

2. Click Layer 3 next to Inet.

3. In the Comment box, enter the comment.

4. Select the Destination Address check box to include the
destination-address MAC information in the hash key.

5. Click Layer 4 next to Inet.

6. In the Comment box, enter the comment.

Configure layer information
for the load-balancing
specification. Only the IPv4
protocol is supported.

1. ClickMpls next to Family.

2. ExpandMpls.

3. Click Payload next to Mpls.

4. In the Comment box, enter the comment.

5. Click IP next to Payload.

6. In the Comment box, enter the comment.

7. Expand IP.

8. Click Layer 3 Only next to IP.

9. Select layer-3-only to include only Layer 3 IP information.

10. Selectport-data to include the sourceanddestinationport field
information.

a. In the Comment box, enter the comment.

b. Select SourceMsb to Include themost significant byte of
the source port.

c. Select Source Lsb to Include the least significant byte of the
source port.

d. Select DestinationMsb to include themost significant byte
of the destination port.

e. Select Destination Lsb to Include the least significant byte
of the destination port.

Configure load balancing
basedonMPLS labels.Only
the IPv4 protocol is
supported.

1. ClickMultiservice next to Mpls.

2. In the Comment box, enter the comment.

3. Select SourceMac to include the source-address MAC
information in the hash key.

4. SelectDestinationMac to include the destination-addressMAC
information in the hash key.

Configure load balancing
based on Layer 2 media
access control information.

Related
Documentation

Configuring Accounting Options (NSM Procedure) on page 403•

• Configuring Helpers (NSM Procedure) on page 407

• Configuring Per-Flow and Per-Prefix Load Balancing (NSM Procedure) on page 416

Configuring Helpers (NSMProcedure)

You can enable Trivial File Transfer Protocol (TFTP) or Domain Name System (DNS)

request packet forwarding, or configure the router or interface to act as a Dynamic Host
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Configuration Protocol (DHCP) or Bootstrap Protocol (BOOTP) relay agent. You use

only one server address per interface or global configuration. See the following topics:

• ConfiguringaRouteror Interface toActasaBootstrapProtocolRelayAgentonpage408

• Enabling DNS Request Packet Forwarding on page 411

• Configuring a Port for a DHCP or BOOTP Relay Agent on page 413

• Configuring Tracing Operations for BOOTP, DNS, and TFTP Packet

Forwarding on page 415

Configuring a Router or Interface to Act as a Bootstrap Protocol Relay Agent

You can configure a router or interface to act as a Dynamic Host Configuration Protocol

(DHCP) or bootstrap protocol (BOOTP) relay agent using this option.

To configure a BOOTP relay agent in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Forwarding Options >

Helpers > BOOTP.

4. Add or modify settings as specified in Table 238 on page 408.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 238: BOOTP Configuration Details

Your ActionTask

1. In the Comment box, enter the comment.

2. Select the Relay Agent check box to configure router as a
BOOTP relay agent.

3. From theMaximumHop Count list, select the maximum
number of hops allowed.

Default: 4 hops

4. FromtheMinimumWaitTime list, select theminimumtime
allowed.

Default: 3 seconds

5. From theClientResponseTtl list, select the IIP time-to-live
(TTL) value in DHCP response packets sent to a DHCP
client.

Configures a router or interface
to act as aDHCPorBOOTP relay
agent.
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Table 238: BOOTP Configuration Details (continued)

Your ActionTask

1. Click Dhcp Option82 next to Bootp.

2. In the Comment box, enter the comment.

3. Select the Disable check box to disable DHCP option 82
on this VLAN.

4. Click Circuit Id next to Dhcp Option82.

5. In the Comment box, enter the comment.

6. From the Prefix list, select the prefix

• hostname—Set hostname as the prefix.

7. Select the Use Interface Description check box to use
interface description instead of name.

8. Select the Use Vlan Id check box to use vlan id.

9. Click Remote Id next to Dhcp Option82.

10. In the Comment box, enter the comment.

11. From the Prefix list, select the prefix

• none—Set no prefix.

• hostname—Set hostname as the prefix.

• mac—Set chassis MAC as the prefix.

12. Select the Use Interface Description check box to use
interface description instead of name.

13. In theUse String check box, enter the raw string instead of
the default remote ID.

14. Click Vendor Id next to Dhcp Option82.

15. In the Comment box, enter the comment.

16. In theUse String check box, enter the raw string instead of
the default remote ID.

Configure DHCP option 82.
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Table 238: BOOTP Configuration Details (continued)

Your ActionTask

1. Click Interface next to BOOTP.

2. Click Add new entry next to Interface.

3. Expand Interface.

4. In theNamebox, enter the interface foraDHCPandBOOTP
relay agent.

5. In the Comment box, enter the comment.

6. Select the No Listen check box to disable recognition of
DNS requests or stop packets from being forwarded on a
logical interface, a group of logical interfaces, or a router.

7. Select the Broadcast check box to issue the DHCP or
BOOTP request as a broadcast message.

8. In the Descriptions box, enter the description of BOOTP,
DHCP,DomainNameSystem(DNS), orTrivial FileTransfer
Protocol (TFTP) service, or of an interface that is
configured for the service.

9. From theMaximumHop Count list, select the maximum
number of hops allowed.

Default: 4 hops

10. FromtheMinimumWaitTime list, select theminimumtime
allowed.

Default: 3 seconds

11. From theClientResponseTtl list, select the IIP time-to-live
(TTL) value in DHCP response packets sent to a DHCP
client.

Specify the interface for a DHCP
and BOOTP relay agent.
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Table 238: BOOTP Configuration Details (continued)

Your ActionTask

1. Click Server next to Interface.

2. Click Add new entry next to Server.

3. Expand Server.

4. In the Name box, enter the server identifier.

5. In the Comment box, enter the comment.

6. Click Logical System next to Server.

7. Click Add new entry next to Logical System.

8. Expand logical-system.

9. In the Name box, enter the logical system name.

10. In the Comment box, enter the comment.

11. Click Routing Instance next to logical-system.

12. Click Add new entry next to Routing Instance.

13. In the New routing-instance window, enter the routing
instance name.

14. Click Routing Instance next to server.

15. Click Add new entry next to Routing Instance.

16. In the New routing-instancewindow, enter the routing
instance name.

17. Click Server next to BOOTP.

18. Click Add new entry next to Server.

19. Expand Server.

20.Click Logical System next to Server.

21. Click Add new entry next to Logical System.

22. In the Name box, enter the logical system name.

23. In the Comment box, enter the comment.

24. Click Routing Instance next to logical-system.

25. Click Add new entry next to Routing Instance.

26. In the New routing-instance window, enter the routing
instance name.

27. Click Routing Instance next to server.

28.Click Add new entry next to Routing Instance.

29. In the New routing-instancewindow, enter the routing
instance name.

Configure the router to act as a
DHCP and BOOTP relay agent.

Enabling DNS Request Packet Forwarding

You can configure the router to support Domain Name System (DNS) and Trivial File

Transfer Protocol (TFTP) packet forwarding for IPv4 traffic, which allows clients to send

DNS or TFTP requests to the router. The responding DNS or TFTP server recognizes the

client addressandsendsa responsedirectly to that address. Bydefault, the router ignores

DNS and TFTP request packets.

To enable DNS request packet forwarding in NSM:
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1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Forwarding Options >

Helpers > Domain.

NOTE: ForconfiguringTFTP,expandForwardingOptions>Helpers>TFTP.

4. Add or modify settings as specified in Table 239 on page 413.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 239: DNS and TFTP Configuration Details

Your ActionTask

1. In the Comment box, enter the comment.

2. In the Description box, enter the description of BOOTP, DHCP,
Domain Name System (DNS), or Trivial File Transfer Protocol
(TFTP) service, or of an interface that is configured for the
service.

3. Click Interface next to Domain.

4. Click Add new entry next to Interface.

5. Expand Interface.

6. In the Name box, enter the interface for a DHCP and BOOTP
relay agent.

7. In the Comment box, enter the comment.

8. Select the No Listen check box to disable recognition of DNS
requests or stop packets from being forwarded on a logical
interface, a group of logical interfaces, or a router.

9. Select the Broadcast check box to issue the DHCP or BOOTP
request as a broadcast message.

10. In theDescriptionsbox, enter thedescriptionofBOOTP,DHCP,
Domain Name System (DNS), or Trivial File Transfer Protocol
(TFTP) service, or of an interface that is configured for the
service.

11. Click Server next to Interface.

12. In the Comment box, enter the comment.

13. In the Address box, enter the address of the server.

14. Expand Server.

15. Click Logical System next to Server.

16. Select logical-system or routing-instance.

17. Click Server next to Domain.

18. In the Comment box, enter the comment.

19. In the Address box, enter the address of the server.

20.Expand Server.

21. Click Logical System next to Server.

22. Select logical-system or routing-instance.

Specify the interface for
monitoring and forwarding
DNS or TFTP requests.

Configuring a Port for a DHCP or BOOTP Relay Agent

You can a configure port for a DHCP or BOOTP relay agent using this option.

To configure port for a DHCP or BOOTP relay agent in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Forwarding Options >

Helpers.

4. Select Port.
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5. Add or modify settings as specified in Table 240 on page 414.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 240: Port Configuration Details

Your ActionTask

Configuring a Port. 1. From theName list, select the port number.

2. In the Comment box, enter the comment.

3. In theDescription box, enter the description of BOOTP, DHCP,
Domain Name System (DNS), or Trivial File Transfer Protocol
(TFTP) service, or of an interface that is configured for the
service.

4. Expand Port.

5. Click Interface next to Domain.

6. Click Add new entry next to Interface.

7. Expand Interface.

8. In the Name box, enter the interface for a DHCP and BOOTP
relay agent.

9. In the Comment box, enter the comment.

10. Select the No Listen check box to disable recognition of DNS
requests or stop packets from being forwarded on a logical
interface, a group of logical interfaces, or a router.

11. Select the Broadcast check box to issue the DHCP or BOOTP
request as a broadcast message.

12. In theDescriptions box, enter the description of BOOTP, DHCP,
Domain Name System (DNS), or Trivial File Transfer Protocol
(TFTP) service, or of an interface that is configured for the
service.

13. Click Server next to Interface.

14. Expand Server.

15. In the Comment box, enter the comment.

16. In the Address box, enter the address of the server.

17. Click Logical System next to Server.

18. Select the corresponding logical system.

19. Click Server next to Port.

20. In the Comment box, enter the comment.

21. In the Address box, enter the address of the server.

22. Click Logical System next to Server.

23. Select the corresponding logical system.
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Configuring Tracing Operations for BOOTP, DNS, and TFTP Packet Forwarding

Youcan configure tracing operations for BOOTP,DNS, andTFTPpacket forwarding using

this option. BOOTP, DNS, and TFTP forwarding tracing operations track all BOOTP, DNS,

and TFTP operations and record them in a log file. The logged error descriptions provide

detailed information to help you solve problems faster.

To configure tracing operations in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Forwarding Options >

Helpers > TFTP.

4. Select Traceoptions.

5. Add or modify settings as specified in Table 241 on page 415.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 241: Traceoptions Configuration Details

Your ActionTask

1. In the Comment box, enter the comment for the traceoptions.

2. Select the No Remote Trace check box to disable remote
tracing globally or for a specific tracing operation.

3. From the Level list, select the level.

Define tracing operations for
event policy.

1. In the Comment box, enter the comment for the file.

2. In the Filename box, enter the name of the file to receive the
output of the tracing operation.

3. In the Size box, enter the maximum size of each trace file, in
kilobytes (KB), megabytes (MB), or gigabytes (GB).

4. From the Files list, select the maximum number of trace files.

Range: 2 through 1000.

Default: 3

5. Select one of the following:

• world-readable—To enable unrestricted file access

• no-world-readable—To restrict file access to owner. This is
the default setting.

7. In theMatchbox, enter the regular expression.

Specify the name of the file
to receive the output of the
tracing operation and the
maximum number of trace
files.

1. Click Add new entry next to Flag.

2. From the Name list, select the flag.

3. In the Comment box, enter the comment for the flag.

Specify the tracing operation
to perform
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Configuring Per-Flow and Per-Prefix Load Balancing (NSMProcedure)

You can enable per-prefix or per-flow load balancing so that the router elects a next hop

independently of the route selected by other routers.

To configure load balancing in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Forwarding Options >

Load Balance.

4. Add or modify settings as specified in Table 242 on page 416.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 242: Load Balancing Configuration Details

Your ActionTask

1. In the Comment box, enter the comment.

2. Select the IndexedNextHopcheckbox togenerateapermuted
index of next-hopentries for unicast andaggregate next hops.

3. Click Per Flow next to Load Balance.

4. In the Comment box, enter the comment for per-flow.

5. Select the Hash Seed check box to configure based on the
hash value.

Enable per-flow load
balancing based on hash
values.

1. Click Per Prefix next to Load Balance.

2. In the Comment box, enter the comment for per prefix.

3. From the Hash Seed list, select the hash value.

Range: 0 through 65,535

Default: 0

Configure the hash
parameter forper-prefix load
balancing.

Related
Documentation

Configuring Port Mirroring (NSM Procedure) on page 417•

• Configuring Helpers (NSM Procedure) on page 407

• Configuring Load Balancing Using Hash Key (NSM Procedure) on page 406
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Configuring Port Mirroring (NSMProcedure)

On all M Series, T Series, and MX Series routers, you can send a copy of an IPv4 or IPv6

packet from the routers to an external host address or a packet analyzer for analysis.

This is known as port mirroring. In addition, on the M7i, M10i, M120, M320 and MX Series

routers only, you can configure port mirroring for VPLS traffic. VPLS port mirroring is

supported only on M7i and M10i routers with Enhanced CFEB (CFEB-E). In addition, on

M320 routers, VPLS port mirroring is supported only on Enhanced III Flexible PIC

Concentrators (FPCs).

To configure port mirroring in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Forwarding Options >

Port Mirroring.

4. Add or modify settings as specified in Table 243 on page 418.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 243: Port Mirroring Configuration Details

Your ActionTask

1. In theCommentbox, enter thecomment for theportmirroring.

2. Select theMirror Once check box to configure the router to
mirror packets only once.

3. Click Family next to Port Mirroring.

4. Expand Family.

5. Click Inet or Inet6 next to Family.

6. ClickOutput.

7. In the Comment box, enter the comment.

8. Select the No Filter Check check box to disable filter checking
on the port-mirroring interface.

9. Click Interface next to Output.

10. Click Add new entry next to Interface.

11. Expand Interface.

12. In the Name box, enter the name of the interface.

13. In the Comment box, enter the comment.

14. Click Next Hop next to interface.

15. Click Add new entry next to Next Hop.

16. In the Name box, enter the IP address of the next-hop router.

17. In the Comment box, enter the comment.

18. Click Vpls next to Family.

19. In the Comment box, enter the comment.

20.ClickOutput next to Vpls.

21. In the Comment box, enter the comment.

22. In the Interface box, enter the name of the interface.

23. Select the No Filter Check check box to disable filter checking
on the port-mirroring interface.

Configure the address type
family to sample for port
mirroring.

1. In the Comment box, enter the comment for input.

2. From the Rate list, select the ratio of the number of packets
to be sampled. For example, if you specify a rate of 10, every
tenth packet (1 packet out of 10) is sampled.

Range: 1 through 65,535

3. From the Run Length list, select the number of samples
following the initial trigger event. This allows you to sample
packets following those already being sampled.

Range: 0 through 20

Default: 0

Configure input packet
properties for port mirroring.

1. Click Instance next to Port Mirroring.

2. Click Add new entry next to Instance.

3. In theNamebox, enter thenameof theport-mirroring instance.

4. To configure the address type family to sample for port
mirroring, refer Table 243 on page 418.

5. To configure input packet properties for port mirroring, refer
Table 243 on page 418.

Configure a port-mirroring
instance.
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Table 243: Port Mirroring Configuration Details (continued)

Your ActionTask

1. In the Comment box, enter the comment for traceoptions.

2. Click File next to Traceoptions.

3. In the Comment box, enter the comment for the file.

4. In the Filename box, enter the name of the file containing the
trace information.

Default: /var/log/sampled

5. In the Size box, enter the maximum size of each traffic
sampling file or trace log file, in kilobytes (KB), megabytes
(MB), or gigabytes (GB).

Syntax: xk to specify KB, xm to specify MB, or xg to specify GB

Range: 10KB through themaximumfile size supportedonyour
router

Default: 1 MB for sampling data; 128 KB for log information

6. From the Files list, select the maximum number of traffic
sampling or trace log files.

Range: 1 through 100 files

Default: 5 files for sampling output; 10 files for trace log
information

7. Select one of the following:

• world-readable—To enable unrestricted file access.

• no-world-readable—To restrict file access to owner.

Configure traffic sampling
tracing operations.

Related
Documentation

• Configuring Per-Flow and Per-Prefix Load Balancing (NSM Procedure) on page 416

• Configuring Load Balancing Using Hash Key (NSM Procedure) on page 406

• Specifying Address Family for Filters (NSM Procedure) on page 405
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CHAPTER 26

Configuring Interfaces in J Series Services
Routers and SRX Series Services
Gateways

• Configuring Interfaces on the Routing Platform (NSM Procedure) on page 421

• Configuring Interface set on the Routing Platform (NSM Procedure) on page 449

Configuring Interfaces on the Routing Platform (NSMProcedure)

You can configure the interfaces on the router using this option. See the following topics:

• Configuring Interface Properties (NSM Procedure) on page 421

• Damping Interface Transitions (NSM Procedure) on page 423

• Configuring Receive Bucket Properties on Interfaces (NSM Procedure) on page 424

• Configuring Tracing Operations of an Individual Router Interface (NSM

Procedure) on page 424

• Configuring Transmit Leaky Bucket Properties (NSM Procedure) on page 425

• Configuring Logical Interface Properties (NSM Procedure) on page 426

• Configuring Protocol Family Information for the Logical Interface (NSM

Procedure) on page 429

• Configuring the Traffic Shaping Profile (NSM Procedure) on page 447

Configuring Interface Properties (NSMProcedure)

Youcanconfigure interfaceson the router using thisoption.Themanagementand internal

Ethernet interfaces are automatically configured. Youmust configure all other interfaces.

To configure interfaces in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.
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NOTE: You can also configure interfaces through theQuick Configuration
tab. Also, you can configure interfaces in a Config group and apply them
to the interface node.

5. Add or modify settings as specified in Table 244 on page 422.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 244: Interface Properties Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. From the Name list, select the interface name.

4. In the Comment box, enter the comment.

5. In the Description box, enter the text to describe the interface.
If the text includes spaces, enclose the entire text in quotation
marks.

6. From the Accounting Profile list, select the name of the
accounting profile.

7. Select per-unit-scheduler to enable association of scheduler
map names with logical interfaces.

8. Select Hierarchical-scheduler to enable the use of hierarchical
scheduler.

9. From the Native Vlan Id list, select the VLAN ID number.

10. From the Speed list, select the speed.

11. FromtheMtu list, select themaximumtransmissionunit (MTU)
size for the media or protocol.

12. From the Encapsulation list, select the encapsulation type.

13. In the Bandwidth box, enter the peak rate.

14. Select one of the following:

• traps—To enable the sending of Simple Network
Management Protocol (SNMP) notificationswhen the state
of the connection changes.

• no-traps—To disable the sending of Simple Network
Management Protocol (SNMP) notificationswhen the state
of the connection changes.

15. From the Accounting Profile list, select the accounting profile.

Configure Interfaces.
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Damping Interface Transitions (NSMProcedure)

When an interface changes from being up to being down, or from down to up, this

transition isadvertised immediately to thehardwareand the JunosOS. In somesituations

youmight want to damp interface transitions. Thismeans not advertising the interface’s

transition until a certain period of time called the hold time has passed. When you have

damped interface transitions and the interface goes from up to down, the interface is

not advertised to the rest of the system as being down until it has remained down for

thehold-timeperiod.Similarlywhenan interfacegoes fromdowntoup, it is notadvertised

as being up until it has remained up for the hold-time period.

To configure hold time value to use to damp interface transitions:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 245 on page 423.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 245: Hold Time Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Hold Time next to interface.

4. In the Comment box, enter the comment.

5. From the Up list, select the hold time to use when an interface
transitions from down to up.

Range: 0 through 4,294,967,295milliseconds

Default: 0 milliseconds

6. From the Down list, select the hold time to use when an
interface transitions from up to down

Range: 0 through 4,294,967,295milliseconds

Default: 0 milliseconds

Configure hold-time value
to use to damp interface
transitions.
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Configuring Receive Bucket Properties on Interfaces (NSMProcedure)

For all interface types except ATM, Fast Ethernet, Gigabit Ethernet, and channelized IQ

and IQE, you can configure leaky bucket properties, which allow you to limit the amount

of traffic received on a particular interface. You effectively specify what percentage of

the interface’s total capacity can be used to receive packets. Youmight want to set leaky

bucket properties to limit the traffic flow from a link that is known to transmit a high

volume of traffic

To configure receive bucket properties in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 246 on page 424.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 246: Receive Bucket Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Receive Bucket next to interface.

4. In the Comment box, enter the comment.

5. From theOverflow list, select how to handle packets that
exceed the threshold for the receive leaky bucket.

• Select tag to tag, count, and process received packets that
exceed the threshold.

• Select discard to discard received packets that exceed the
threshold.

6. From the Rate list, select the percentage of the interface line
rate that is available to receive or transmit packets.

Range: 0 through 100

7. From the Threshold list, select the maximum size, in bytes, for
traffic bursts.

Range: 0 through 65,535 bytes

Configure receive bucket
properties.

Configuring Tracing Operations of an Individual Router Interface (NSMProcedure)

You can define tracing operations for individual interfaces using this option. To specify

more than one tracing operation, includemultiple flag statements.

To configure tracing operations of an router interface in NSM:
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1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 247 on page 425.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 247: Trace Options Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Traceoptions next to interface.

4. In the Comment box, enter the comment.

5. Expand Traceoptions.

6. Click Flag next to Traceoptions.

7. Click Add new entry next to Flag.

8. From the Name list, select the tracing operation to perform.

9. In the Comment box, enter the comment.

Define tracing operations for
individual interfaces.

Configuring Transmit Leaky Bucket Properties (NSMProcedure)

For all interface types except ATM, channelized E1, E1, Fast Ethernet, Gigabit Ethernet,

and channelized IQ, you can configure leaky bucket properties, which allow you to limit

the amount of traffic transmitted by a particular interface. You effectively specify what

percentage of the interface’s total capacity can be used to transmit packets. Youmight

want to set leaky bucket properties to limit the traffic flow from a link that is known to

transmit a high volume of traffic.

To configure transmit leaky bucket properties in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 248 on page 426.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 248: Transmit Bucket Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Transmit Bucket next to interface.

4. In the Comment box, enter the comment.

5. From theOverflow list, select how to handle packets that
exceed the threshold for the transmit leaky bucket.

• Select discard to discard packets that exceed the threshold
for the transmit leaky bucket.

6. From the Rate list, select the percentage of the interface line
rate that is available to receive or transmit packets.

Range: 0 through 100

7. From the Threshold list, select the maximum size, in bytes, for
traffic bursts.

Range: 0 through 65,535 bytes

Configure transmit bucket
properties.

Configuring Logical Interface Properties (NSMProcedure)

The following sections describes the configuration of logical interface properties:

• Configuring Logical Unit Properties (NSM Procedure) on page 426

• Configuring an IP Demux Underlying Interface (NSM Procedure) on page 427

• Configuring theLogicalDemuxSourceFamilyTypeon the IPDemuxUnderlying Interface

(NSM Procedure) on page 428

• Configuring Epd Threshold for the Logical Interface (NSM Procedure) on page 428

Configuring Logical Unit Properties (NSMProcedure)

To configure logical unit properties in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 249 on page 427.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 249: Logical Unit Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Unit next to interface.

4. Click Add new entry next to Unit.

5. From the Name list, select the interface name.

6. In the Comment check box, enter the comment.

7. Select the Disable check box to disable a physical or a logical
interface, effectively unconfiguring it.

8. Select the Reassemble Packets check box to enable
reassembly of fragmented tunnel packets on generic routing
encapsulation (GRE) tunnel interfaces.

9. In theDescription box, enter the text to describe the interface.
If the text includes spaces, enclose theentire text inquotation
marks.

10. From the Encapsulation list, select the encapsulation type.

11. In the Bandwidth box, enter the peak rate.

12. Select one of the following:

• traps—To enable the sending of Simple Network
ManagementProtocol (SNMP)notificationswhenthestate
of the connection changes.

• no-traps—To disable the sending of Simple Network
ManagementProtocol (SNMP)notificationswhenthestate
of the connection changes.

13. From theAccounting Profile list, select the accounting profile.

Configure logical unit
properties.

Configuring an IP Demux Underlying Interface (NSMProcedure)

You can configure the logical demultiplexing (demux) destination family type on the IP

demux underlying interface.

To configure an IP demux underlying interface in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 250 on page 428.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

427Copyright © 2013, Juniper Networks, Inc.

Chapter 26: Configuring Interfaces in J Series Services Routers and SRX Series Services Gateways



Table 250: IP Demux Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Unit next to interface.

4. Click Add new entry next to Unit.

5. Click Demux Destination next to Unit.

6. Click Add new entry next to Demux Destination.

7. From the New demux-destinationwindow, select the family
type.

Configure the logical
demultiplexing (demux)
destination family type.

Configuring the Logical Demux Source Family Type on the IP Demux Underlying
Interface (NSMProcedure)

Youcanconfigure the logical demultiplexing (demux) source family typeon the IPdemux

underlying interface using this option.

To configure logical demux source family type in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 251 on page 428.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 251: IP Demux Source Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Unit next to interface.

4. Click Add new entry next to Unit.

5. Click Demux Source next to Unit.

6. Click Add new entry next to Demux Source.

7. From the New demux-destinationwindow, select the family
type.

Configure the logical
demultiplexing (demux)
source family type on the IP
demux underlying interface.

Configuring Epd Threshold for the Logical Interface (NSMProcedure)

To configure Epd threshold for the logical interface in NSM:
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1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 252 on page 429.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 252: Epd Threshold Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Unit next to interface.

4. Click Add new entry next to Unit.

5. Click Epd Threshold next to Unit.

6. In the Comment box, enter the comment.

7. In the Epd Threshold plp0 box, enter the early packet discard
threshold value.

8. In the Plp1 box, enter the maximum number of cells.

Range: For 1-port and 2-port OC12 interfaces, 1 through
425,984 cells

Define the EPD threshold on
a virtual circuit (VC).

Configuring Protocol Family Information for the Logical Interface (NSMProcedure)

You can configure the family information for the logical interface for different protocols

using the following options:

1. Configuring Protocol Family (Ccc) Information for the Logical Interface (NSM

Procedure) on page 430

2. Configuring Protocol Family (Inet) Information for the Logical Interface (NSM

Procedure) on page 431

3. Configuring Protocol Family (Inet6) Information for the Logical Interface (NSM

Procedure) on page 437

4. Configuring Protocol Family (ISO) Information for the Logical Interface (NSM

Procedure) on page 444

5. Configuring Protocol Family (MPLS) Information for the Logical Interface (NSM

Procedure) on page 445

6. Configuring Protocol Family (TCC) Information for the Logical Interface (NSM

Procedure) on page 447
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Configuring Protocol Family (Ccc) Information for the Logical Interface (NSM
Procedure)

To configure Ccc family information in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 253 on page 430.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 253: Ccc Family Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Unit next to interface.

4. Click Add new entry next to Unit.

5. Click Family next to Unit.

6. Expand Family.

7. Click Ccc next to Family.

8. In the Comment box, enter the comment.

9. Click Filter next to Ccc.

10. In the Comment box, enter the comment.

11. From the Group list, select the filter group number.

Range: 0 through 255

Apply a filter toan interface.

1. Click Input next to Filter.

2. Select one of the following:

• Input—To configure name of one filter to evaluate when
packets are received on the interface. Enter the input filter
name.

• Input-list—To apply a group of filters to evaluate when
packets are received on an interface.
a. Click Add new entry next to input-list.

b. In theNew input-listwindow, enter the filter names. Up to
16 filters can be included in a filter input list.

Configure input filter.
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Table 253: Ccc Family Configuration Details (continued)

Your ActionTask

1. ClickOutput next to Filter.

2. Select one of the following:

• output—To configure name of one filter to evaluate when
packets are transmitted on the interface. Enter the output
filter name.

• output-list—To apply a group of filters to evaluate when
packets are transmitted on an interface.
a. Click Add new entry next to output-list.

b. In the New output-listwindow, enter the filter names. Up
to 16 filters can be included in a filter input list.

Configure output filter.

1. Click Policer next to Filter.

2. In the Comment box, enter the comment.

3. In the Inputbox, enter the nameof onepolicer to evaluatewhen
packets are received on the interface.

4. In theOutput box, enter the name of one policer to evaluate
when packets are transmitted on the interface.

Apply a policer to an
interface.

Configuring Protocol Family (Inet) Information for the Logical Interface (NSM
Procedure)

To configure inet family information in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 254 on page 432.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 254: Inet Family Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Unit next to interface.

4. Click Add new entry next to Unit.

5. Click Family next to Unit.

6. Expand Family.

7. Click Inet next to Family.

8. In the Comment box, enter the comment.

9. From theMac Validate list, select one of the following:

• strict—Forwards incomingpacketswhenboth the IPsourceaddressand
theMACsource addressmatchoneof the trustedaddress tuples. Drops
packetswhen theMACaddress does notmatch the tuple'sMAC source
address, or when IP source address of the incoming packet does not
match any of the trusted IP addresses.

• loose—Forwards incoming packets when both the IP source address
and the MAC source address match one of the trusted address tuples.
Drops packets when the IP source address matches one of the trusted
tuples, but the MAC address does not match the MAC address of the
tuple. Continues to forward incoming packets when the source address
of the incoming packet does notmatch any of the trusted IP addresses.

10. From theMtu list, select the MTU size.

Range: 0 through 4,294,967,295

11. Select theNoRedirectscheckbox todisable thesendingofprotocol redirect
messages for the entire routing platform.

12. Select the No Arp Learn check box to disable ARPmappings.

13. Select the Primary check box to configure the address to be the primary
address of the protocol on the interface.

Configure Inet
information.

1. Click Accounting next to Inet.

2. In the Comment box, enter the comment.

3. Select the Destination Class Usage check box to enable packet counters
on an interface that count packets that arrive from specific customers and
are destined for specific prefixes on the provider core router.

4. Click Source Class Usage next to Accounting.

5. In the Comment box, enter the comment.

6. Select the Input checkbox to configure at least oneexpected ingresspoint.

7. Select theOutput check box to configure at least one expected egress
point.

Enable IPpacket
counters on an
interface.
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Table 254: Inet Family Configuration Details (continued)

Your ActionTask

1. Click Address next to Inet.

2. Click Add new entry next to Address.

3. Expand address.

4. In the Name box, enter the interface name.

5. In the Comment box, enter the comment.

6. Select the Primary check box to configure this address to be the primary
address of the protocol on the interface. If the logical unit has more than
one address, the primary address is used by default as the source address
when packets originate from the interface and the destination does not
indicate the subnet.

7. Select thePreferred checkbox to configure this address tobe thepreferred
address on the interface. If you configure more than one address on the
same subnet, the preferred source address is chosen by default as the
source address when you originate packets to destinations on the subnet.

Configure the
interface
address.

1. Click Vrrp Group next to address.

2. ClickAdd new entry next to Vrrp Group.

3. In the Name box, enter the interface name.

4. In the Comment box, enter the comment.

5. In the Virtual Link Local Address box, enter the virtual link local address.

6. From the priority list, select the router’s priority for being elected to be the
master router in the VRRP group. A larger value indicates a higher priority
for being elected.

Range: 1 through 255

Default: 100 (for backup routers)

7. Select one of the following:

• accept-data—To enable the interface to accept packets destined for
the virtual IP address.

• no-accept-data—To prevent the interface from accepting packets
destined for the virtual IP address.

8. From the Authentication Type list, select the authentication type.

9. In the Authentication Key box, enter the authentication password.

10. Select Advertise-Interval next to vrrp-group.

11. Select one of the following:

• advertise-interval—To configure the interval between Virtual Router
Redundancy Protocol (VRRP) IPv4 advertisement packets.
Range: 1 through 255 seconds

• fast-interval—To configure the interval, in milliseconds, between Virtual
Router Redundancy Protocol (VRRP) advertisement packets.
Range: 100 through 999milliseconds

• inet6-advertise-interval—Toconfigure the intervalbetweenVirtualRouter
Redundancy Protocol (VRRP) IPv6 advertisement packets
Range: 100 to 40,950milliseconds (ms)

Configure VRRP
IPv4 group.
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Table 254: Inet Family Configuration Details (continued)

Your ActionTask

1. Click Preempt next to vrrp-group.

2. Select preempt to allow themaster router to be preempted.

a. In the Comment box, enter the comment.

b. From the Hold Time list, select the hold time before a higher-priority
backup router preempts the master router.

3. Select no-preempt to prohibit the preemption of the master router.

4. Click Track next to vrrp-group.

5. In the Comment box, enter the comment.

6. From the Priority Hold Time list, select the minimum length of time that
must elapse between dynamic priority changes.

Range: 1 through 3600 seconds

7. Click Interface next to Track.

8. Click Add new entry next to Interface.

9. In the Name box, enter the interface name.

10. In the Comment box, enter the comment.

11. From the Priority Cost list, select the VRRP routers’ priority cost for
becoming themaster default router. The router with the highest priority
within the group becomes themaster.

Range: 1 through 254

Configure a
backup router to
preempt the
master router.
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Table 254: Inet Family Configuration Details (continued)

Your ActionTask

1. Click Bandwidth Threshold next to interface.

2. Click Add new entry next to Bandwidth Threshold.

3. In the Name box, enter the interface name.

4. In the Comment box, enter the comment.

5. From the Priority Cost list, select the VRRP router’s priority cost for
becoming themaster default router. The router with the highest priority
within the group becomes themaster.

Range: 1 through 254

6. Click Route next to Track.

7. In the Route_address box, enter the address.

8. In the Routing Instances box, enter the routing instance in which the route
is to be tracked.

9. From the Priority Cost list, select the VRRP router’s priority cost for
becoming themaster default router. The router with the highest priority
within the group becomes themaster.

10. Click Virtual Address next to vrrp-group.

11. Select one of the following:

• virtual-address—To configure the addresses of the virtual routers in a
Virtual Router Redundancy Protocol (VRRP) IPv4 group. You can
configure up to eight addresses.
a. Click Add new entry and in the New virtual-address window, enter

the addresses of one or more virtual routers.

b. In the New virtual-address window, enter the addresses of one or
more virtual routers.

virtual-inet6-address—To configure the addresses of the virtual routers
in a Virtual Router Redundancy Protocol (VRRP) IPv6 group. You can
configure up to eight addresses.

a. Click Add new entry

b. In the New virtual-address window, enter the addresses of one or
more virtual routers.

Specify the
bandwidth
threshold for
VRRP.

1. Click Input next to Filter.

2. Select one of the following:

• input—To configure name of one filter to evaluate when packets are
received on the interface. Enter the input filter name.

• input-list—To apply a group of filters to evaluate when packets are
received on an interface.
a. Click Add new entry next to input-list.

b. In the New input-listwindow, enter the filter names. Up to 16 filters
can be included in a filter input list.

Configure input
filter.
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Table 254: Inet Family Configuration Details (continued)

Your ActionTask

1. ClickOutput next to Filter.

2. Select one of the following:

• output—To configure name of one filter to evaluate when packets are
transmitted on the interface. Enter the output filter name.

• output–list—To apply a group of filters to evaluate when packets are
transmitted on an interface.
a. Click Add new entry next to output-list.

b. In theNewoutput-listwindow, enter the filter names. Up to 16 filters
can be included in a filter input list.

Configureoutput
filter.

1. Click Policer next to Filter.

2. In the Comment box, enter the comment.

3. In the Input box, enter the name of one policer to evaluate when packets
are received on the interface.

4. In theOutput box, enter the name of one policer to evaluatewhen packets
are transmitted on the interface.

Apply a policer
to an interface.

1. Click Rpf Check next to Inet.

2. In the Comment box, enter he comment.

3. In the Fail Filter box, enter the filter name to evaluate when packets are
received on the interface.

4. ClickMode next to Rpf Check.

5. In the Comment box, enter he comment.

6. Select the loose check box to check whether the packet has a source
address with a corresponding prefix in the routing table.

Check whether
traffic is arriving
on an expected
path.

1. In the Comment box, enter the comment.

2. Select the Input checkbox to configure at least oneexpected ingresspoint.

3. Select theOutput check box to configure at least one expected egress
point.

Configure the
direction of
traffic to be
sampled.
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Table 254: Inet Family Configuration Details (continued)

Your ActionTask

1. Click Service next to Inet.

2. In the Comment box, enter the comment.

3. Click Input next to Service.

4. In the Comment box, enter the comment.

5. In the Post Service Filter box, enter the filter to be applied to traffic after
service processing.

6. Expand Input.

7. Click Service Set next to Input.

8. Click Add new entry next to Service Set.

9. From the Name list, select the service set name.

10. In the Comment box, enter the comment.

11. In the Service Filter box, enter the filter name.

12. ClickOutput next to Service.

13. In the Comment box, enter the comment.

14. Expand Output.

15. Click Service Set next to Output.

16. Click Add new entry next to Service Set.

17. From the Name list, select the service set name.

18. In the Comment box, enter the comment.

19. In the Service Filter box, enter the filter name.

Define one or
more service
sets to be
applied to an
interface.

1. Click Unnumbered Address next to Inet.

2. In the Comment box, enter the comment.

3. In the Source box, enter the secondary IP address of the donor loopback
interface.

Configure an
Ethernet or
demultiplexing
interface to be
unnumbered.

Configuring Protocol Family (Inet6) Information for the Logical Interface (NSM
Procedure)

To configure inet6 family information in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 255 on page 438.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 255: Inet6 Family Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Unit next to interface.

4. Click Add new entry next to Unit.

5. Click Family next to Unit.

6. Expand Family.

7. Click Inet next to Family.

8. In the Comment box, enter the comment.

9. From theMac Validate list, select one of the following:

• strict—Forwards incomingpacketswhenboth the IP source
address and the MAC source address match one of the
trusted address tuples. Drops packets when the MAC
address does not match the tuple's MAC source address,
or when IP source address of the incoming packet does not
match any of the trusted IP addresses.

• loose—Forwards incomingpacketswhenboth the IPsource
address and the MAC source address match one of the
trusted address tuples. Drops packets when the IP source
address matches one of the trusted tuples, but the MAC
address does not match the MAC address of the tuple.
Continues to forward incoming packets when the source
address of the incoming packet does not match any of the
trusted IP addresses.

10. From theMtu list, select the MTU size.

Range: 0 through 4,294,967,295

11. Select the No Redirects check box to disable the sending of
protocol redirect messages for the entire routing platform.

12. Select the No Arp Learn check box to disable arp.

13. Select the Primary check box to configure the address to be
the primary address of the protocol on the interface.

Configure Inet6 information.

1. Click Accounting next to Inet.

2. In the Comment box, enter the comment.

3. Select Destination Class Usage check box to enable packet
counters on an interface that count packets that arrive from
specific customers and are destined for specific prefixes on
the provider core router.

4. Click Source Class Usage next to Accounting.

5. In the Comment box, enter the comment.

6. Select the Input check box to configure at least one expected
ingress point.

7. Select theOutputcheckbox toconfigureat leastoneexpected
egress point.

Enable IPpacket counters on
an interface.
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Table 255: Inet6 Family Configuration Details (continued)

Your ActionTask

1. Click Address next to Inet.

2. Click Add new entry next to Address.

3. Expand address.

4. In the Name box, enter the interface name.

5. In the Comment box, enter the comment.

6. Select the Primary check box to configure this address to be
the primary address of the protocol on the interface. If the
logical unit has more than one address, the primary address
is used by default as the source address when packets
originate from the interface and the destination does not
indicate the subnet.

7. Select the Preferred check box to configure this address to be
the preferred address on the interface. If you configure more
than one address on the same subnet, the preferred source
address is chosen by default as the source address when you
originate packets to destinations on the subnet.

Configure the interface
address.

439Copyright © 2013, Juniper Networks, Inc.

Chapter 26: Configuring Interfaces in J Series Services Routers and SRX Series Services Gateways



Table 255: Inet6 Family Configuration Details (continued)

Your ActionTask

1. Click Vrrp Group next to address.

2. Click Add new entry next to Vrrp Group.

3. In the Name box, enter the interface name.

4. In the Comment box, enter the comment.

5. In theVirtual Link Local Address box, enter the virtual link local
address.

6. From the priority list, select the router’s priority for being
elected to be themaster router in the VRRP group. A larger
value indicates a higher priority for being elected.
Range: 1 through 255
Default: 100 (for backup routers)

7. Select one of the following:

• accept-data—To enable the interface to accept packets
destined for the virtual IP address.

• no-accept-data—To prevent the interface from accepting
packets destined for the virtual IP address.

8. From the Authentication Type list, select the authentication
type.

9. In the Authentication Key box, enter the authentication
password.

10. Select Advertise-Interval next to vrrp-group.

11. Select one of the following:

• advertise-interval—Toconfigure the interval betweenVirtual
Router Redundancy Protocol (VRRP) IPv4 advertisement
packets.
Range: 1 through 255 seconds

• fast-interval—To configure the interval, in milliseconds,
between Virtual Router Redundancy Protocol (VRRP)
advertisement packets.
Range: 100 through 999milliseconds

• inet6-advertise-interval—To configure the interval between
Virtual Router Redundancy Protocol (VRRP) IPv6
advertisement packets
Range: 100 to 40,950milliseconds (ms)

Configure VRRP IPV6 Group.
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Table 255: Inet6 Family Configuration Details (continued)

Your ActionTask

1. Click Preempt next to vrrp-group.

2. Select one of the following:

• preempt—To allow themaster router to be preempted.
a. In the Comment box, enter the comment.

b. From the Hold Time list, select the hold time before a
higher-priority backup router preempts the master
router.
Range: 0 through 3600

• no-preempt—To prohibit the preemption of the master
router.

3. Click Track next to vrrp-group.

4. In the Comment box, enter the comment.

5. From the Priority Hold Time list, select theminimum length of
time that must elapse between dynamic priority changes.

Range: 1 through 3600 seconds

6. Click Interface next to Track.

7. Click Add new entry next to Interface.

8. In the Name box, enter the interface name.

9. In the Comment box, enter the comment.

10. FromthePriorityCost list, select theVRRP router’s priority cost
for becoming themaster default router. The router with the
highest priority within the group becomes themaster.

Range: 1 through 254

Configure a backup router to
preempt the master router.
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Table 255: Inet6 Family Configuration Details (continued)

Your ActionTask

1. Click Bandwidth Threshold next to interface.

2. Click Add new entry next to Bandwidth Threshold.

3. In the Name box, enter the interface name.

4. In the Comment box, enter the comment.

5. FromthePriorityCost list, select theVRRP router’s priority cost
for becoming themaster default router. The router with the
highest priority within the group becomes themaster.

Range: 1 through 254

6. Click Route next to Track.

7. In the Route_address box, enter the address.

8. In theRouting Instancesbox, enter the routing instance inwhich
the route is to be tracked.

9. FromthePriorityCost list, select theVRRP router’s priority cost
for becoming themaster default router. The router with the
highest priority within the group becomes themaster.

10. Click Virtual Address next to vrrp-group.

11. Select one of the following:

• virtual-address—To configure the addresses of the virtual
routers in a Virtual Router Redundancy Protocol (VRRP)
IPv4 group. You can configure up to eight addresses.
a. Click Add new entry and in the New virtual-address

window, enter the addresses of one or more virtual
routers.

• virtual-inet6-address—To configure the addresses of the
virtual routers in a Virtual Router Redundancy Protocol
(VRRP) IPv6group.Youcanconfigureup toeightaddresses.
a. ClickAddnewentryand in theNewvirtual-inet6-address

window, enter the addresses of one or more virtual
routers.

Specify the bandwidth
threshold for VRRP.

1. Click Input next to Filter.

2. Select one of the following:

• Select input to configurenameofone filter toevaluatewhen
packets are received on the interface. Enter the input filter
name.

• Select input-list to apply a group of filters to evaluatewhen
packets are received on an interface.
a. Click Add new entry next to input-list.

b. In the New input-listwindow, enter the filter names. Up
to 16 filters can be included in a filter input list.

Configure input filter.
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Table 255: Inet6 Family Configuration Details (continued)

Your ActionTask

1. ClickOutput next to Filter.

2. Select one of the following:

• Select output to configure name of one filter to evaluate
when packets are transmitted on the interface. Enter the
output filter name.
a. Enter the output filter name.

• Selectoutput-list toapplyagroupof filters toevaluatewhen
packets are transmitted on an interface.
a. Click Add new entry next to output-list.

b. In the New output-listwindow, enter the filter names.
Up to 16 filters can be included in a filter input list.

Configure output filter.

1. Click Policer next to Filter.

2. In the Comment box, enter the comment.

3. In the Input box, enter the name of one policer to evaluate
when packets are received on the interface.

4. In theOutput box, enter the name of one policer to evaluate
when packets are transmitted on the interface.

Apply a policer to an
interface.

1. Click Rpf Check next to Inet.

2. In the Comment box, enter he comment.

3. In the Fail Filter box, enter the filter name to evaluate when
packets are received on the interface.

4. ClickMode next to Rpf Check.

5. In the Comment box, enter the comment.

6. Select the loose check box to check whether the packet has
a source address with a corresponding prefix in the routing
table.

Check whether traffic is
arriving on an expected path.

1. In the Comment box, enter the comment.

2. Select the Input check box to configure at least one expected
ingress point.

3. Select theOutputcheckbox toconfigureat leastoneexpected
egress point.

Configure the direction of
traffic to be sampled.
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Table 255: Inet6 Family Configuration Details (continued)

Your ActionTask

1. Click Service next to Inet.

2. In the Comment box, enter the comment.

3. Click Input next to Service.

4. In the Comment box, enter the comment.

5. In the Post Service Filter box, enter the filter to be applied to
traffic after service processing.

6. Expand Input.

7. Click Service Set next to Input.

8. Click Add new entry next to Service Set.

9. From the Name list, select the service set name.

10. In the Comment box, enter the comment.

11. In the Service Filter box, enter the filter name.

12. ClickOutput next to Service.

13. In the Comment box, enter the comment.

14. ExpandOutput.

15. Click Service Set next to Output.

16. Click Add new entry next to Service Set.

17. From the Name list, select the service set name.

18. In the Comment box, enter the comment.

19. In the Service Filter box, enter the filter name.

Define one or more service
sets to be applied to an
interface.

Configuring Protocol Family (ISO) Information for the Logical Interface (NSM
Procedure)

To configure iso family information in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 256 on page 445.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 256: Iso Family Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Unit next to interface.

4. Click Add new entry next to Unit.

5. Click Family next to Unit.

6. Expand Family.

7. Click Iso next to Family.

8. In the Comment box, enter the comment.

9. From theMtu list, select the MTU size.

Range: 0 through 4,294,967,295

Configure Iso information.

1. Click Address next to Inet.

2. Click Add new entry next to Address.

3. Expand address.

4. In the Name box, enter the interface name.

5. In the Comment box, enter the comment.

Configure the interface
address.

Configuring Protocol Family (MPLS) Information for the Logical Interface (NSM
Procedure)

To configure mpls family information in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 257 on page 446.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.
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Table 257: MPLS Family Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Unit next to interface.

4. Click Add new entry next to Unit.

5. Click Family next to Unit.

6. Expand Family.

7. ClickMPLS next to Family.

8. In the Comment box, enter the comment.

9. From theMtu list, select the MTU size.

Range: 0 through 4,294,967,295

Configure MPLS
information.

1. Click Input next to Filter.

2. Select one of the following:

• input—To configure name of one filter to evaluate when
packets are received on the interface. Enter the input filter
name.

• input-list—To apply a group of filters to evaluate when
packets are received on an interface.
a. Click Add new entry next to input-list.

b. In the New input-list window, enter the filter names. Up
to 16 filters can be included in a filter input list.

Configure input filter.

1. ClickOutput next to Filter.

2. Select one of the following:

• output—To configure name of one filter to evaluate when
packets are transmitted on the interface. Enter the output
filter name.

• output-list—To apply a group of filters to evaluate when
packets are transmitted on an interface.
a. Click Add new entry next to output-list.

b. In theNewoutput-listwindow, enter the filter names. Up
to 16 filters can be included in a filter input list.

Configure output filter.

1. Click Policer next to Filter.

2. In the Comment box, enter the comment.

3. In the Inputbox, enter thenameofonepolicer toevaluatewhen
packets are received on the interface.

4. In theOutput box, enter the name of one policer to evaluate
when packets are transmitted on the interface.

Apply a policer to an
interface.
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Configuring Protocol Family (TCC) Information for the Logical Interface (NSM
Procedure)

To configure tcc family information in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 258 on page 447.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 258: TCC Family Configuration Details

Your ActionTask

Configure tcc information. 1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Unit next to interface.

4. Click Add new entry next to Unit.

5. Click Family next to Unit.

6. Expand Family.

7. Click Tcc next to Family.

8. In the Comment box, enter the comment.

Apply a policer to an
interface.

1. Click Policer next to Tcc.

2. In the Comment box, enter the comment.

3. In the Inputbox, enter thenameofonepolicer toevaluatewhen
packets are received on the interface.

4. In theOutput box, enter the name of one policer to evaluate
when packets are transmitted on the interface.

Configure Ethernet TCC
encapsulation.

1. Click proxy next to TCC.

2. In the Comment box, enter the comment.

3. Click Remote next to TCC.

4. In the Comment box, enter the comment.

Configuring the Traffic Shaping Profile (NSMProcedure)

When you use an ATM encapsulation on ATM1 and ATM2 IQ interfaces, you can define

bandwidth utilization, which consists of either a constant rate or a peak cell rate, with

sustained cell rate and burst tolerance.

To configure traffic shaping profile in NSM:
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1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface.

5. Add or modify settings as specified in Table 259 on page 448.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 259: Traffic Shaping Configuration Details

Your ActionTask

1. Click Add Interface next to Interface.

2. In the Add Interface Dialog box, enter the interface name.

3. Click Unit next to interface.

4. Click Add new entry next to Unit.

5. Click Shaping next to Unit.

6. Expand Shaping.

7. In the Comment box, enter the comment.

8. From theQueue Length list, select the maximum number of
packets the queue can contain.

Range: 1 through 16383 packets

Default: 16383 packets

9. Click Cbr next to Shaping.

10. Select one of the following:

• cbr—To define a constant bit rate bandwidth utilization in
the traffic-shaping profile for ATM encapsulation.
a. In the Comment box, enter the comment

b. In theCbrValuebox, enter the unspecified bit rate (UBR).

• vbr—To define the variable bandwidth utilization in the
traffic-shaping profile for ATM encapsulation.
a. In the Comment box, enter the comment.

b. In the Peak box, enter the peak rate

c. In the Sustained box, enter the sustained rate.

d. In the Burst box, enter the burst length.

• rtvbr—To define the real-time variable bandwidth utilization
in the traffic-shaping profile for ATM2 IQ PICs.
a. In the Comment box, enter the comment.

b. In the Peak box, enter the peak rate.

c. In the Sustained box, enter the sustained rate.

d. In the Burst box, enter the burst length.

Define the traffic-shaping
profile.
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Configuring Interface set on the Routing Platform (NSMProcedure)

You can configure an interface set on the routing platform using this option.

To configure interface set in NSM:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to select it.

3. Click the Configuration tab. In the configuration tree, expand Interfaces.

4. Select Interface Set.

5. Add or modify settings as specified in Table 260 on page 449.

6. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Table 260: Interface Set Configuration Details

Your ActionTask

1. Click Add new entry next to Interface Set.

2. Click interface-set.

3. In the Name box, enter the name for the interface set.

4. In the Comment box, enter the comment.

Define the interface set.

1. Click interface next to interface-set.

2. Click Add new entry next to Interface.

3. In the Name box, enter the interface name.

4. In the Comment box, enter the comment.

5. Click Unit next to interface.

6. Click Add new entry next to Unit.

7. From the Name list, select the number of the logical unit.

Range: 0 through 16,385

8. In the Comment box, enter the comment.

9. Click Vlan Tags Outer next to Interface.

10. Click Add new entry next to Vlan tags Outer.

11. From the Name list, select the outer VLAN ID.

12. In the Comment box, enter the comment.

Apply the interface set to
interfaces.

Related
Documentation

• Configuring Interfaces on the Routing Platform (NSM Procedure) on page 421

• Configuring Trace Options on the Routing Platform (NSM Procedure)
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CHAPTER 27

Configuring Multicast Snooping Options
in JSeriesServicesRouters andSRXSeries
Services Gateways

• Configuring Multicast Monitoring Options (NSM Procedure) on page 451

ConfiguringMulticast Monitoring Options (NSMProcedure)

Multicast is a way for a Layer 2 device to monitor at the Layer 3 packet content to

determinewhich actions are to be taken to process or forward a frame. There are specific

forms of , such as IGMP or PIM . In all cases, monitoring involves a device configured to

function at Layer 2 having access to Layer 3 (packet) information. Monitoring makes

multicasting more efficient in these devices.

To configure multicast monitoring in NSM:

1. In the navigation tree select DeviceManager > Devices.

2. In the Devices list, double click the device to select it.

3. In the Configuration tab, expandMulticast Monitoring Options.

4. Add or modify the settings as specified in Table 261 on page 452.

5. Click one:

• OK—To save the changes.

• Cancel—To cancel the modifications.
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Table 261: Multicast Monitoring Options Configuration Details

Your ActionTask

Establish a list of flood
group addresses for
multicast monitoring.

1. Click Flood Groups next to Multicast Monitoring Options.

2. Click Add new entry next to Flood Groups.

3. In the dialog box, enter the IP addresses.

Configure multicast
forwardingcacheproperties.

1. Click Forwarding Cache next to Multicast Monitoring Options.

2. In the Comment box, enter the comments.

3. Expand Forwarding Cache.

4. Click Threshold next to Forwarding Cache.

5. In the Comment box, enter the comments.

6. From the Suppress list, select the threshold value for a
forwarding cache.

Range: 1 through 200,000

7. From the Reuse list, select the reuse value for the threshold.
The reuse value must be less than the suppression threshold
value.

Range: 1 through 200,000

Establish the graceful
restart duration for
multicast monitoring.

1. Click Graceful Restart next to Multicast Monitoring Options.

2. In the Comment box, enter the comments.

3. From the Restart Duration list, select the duration for graceful
restart.

Range: 0 to 300 seconds

Default : 180 seconds

Establish multicast
monitoring option values.

1. ClickOption next to Multicast Monitoring Options.

2. In the Comment box, enter the comments.

3. ExpandOptions.

4. Click Syslog next to Options.

5. In the Comment box, enter the comments.

6. From the Upto list, select the level up to which severity the
messages to be system logged.

7. From theMark list, select the time interval in seconds to mark
the trace file.

Range : -2147483647 seconds to 2147483647 Seconds

Default : 0

8. Expand Syslog.

9. Click Level next to Syslog.

10. Select the Level of severity to be logged.
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Table261:MulticastMonitoringOptionsConfigurationDetails (continued)

Your ActionTask

1. Click Traceoptions next to Multicast Monitoring Options.

2. In the Comment box, enter the comments.

3. Expand Traceoptions.

4. Click File next to Trace Options.

5. In the Comment box, enter the comments.

6. In the Filename box, enter the name of the file to receive the
output of the tracing operation. Enclose the namewithin
quotation marks.

7. In the Size box, enter the maximum size of each trace file in
bytes.

Range : 10240 to 4,294,967,295 bytes

8. From the Files list, select the maximum number of files.

9. Select theworld-readable option to enable log file access to
all users.

10. Select the no-world-readable option to prevent all users from
reading the log file.

11. Click Flag next to Trace Options.

12. Click Add new entry next to flag.

13. From the Name list, select a tracing operation to perform.

14. In the Comment box, enter the comments.

Configure tracing options.

Related
Documentation

• Configuring Interfaces on the Routing Platform (NSM Procedure) on page 421

453Copyright © 2013, Juniper Networks, Inc.

Chapter 27: Configuring Multicast Snooping Options in J Series Services Routers and SRX Series Services Gateways



Copyright © 2013, Juniper Networks, Inc.454

Configuring J Series Services Routers and SRX Series Services Gateways Guide



PART 3

Managing J Series Services Routers and
SRX Series Services Gateways

• Using SystemManagement Features in J Series Services Routers and SRX Series

Services Gateways on page 457

• Topology Manager on page 461

• IDP Management in J Series Services Routers and SRX Series Services

Gateways on page 465
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CHAPTER 28

Using SystemManagement Features in J
Series Services Routers and SRX Series
Services Gateways

• Managing J Series and SRX Series Device Software Versions Overview on page 457

• Viewing and Reconciling Device Inventory Overview on page 457

• Viewing Device Inventory in NSM (NSM Procedure) on page 458

• Removing a J Series or SRX Series Device from NSMManagement (NSM

Procedure) on page 459

Managing J Series and SRX Series Device Software Versions Overview

You can use Network and Security Manager (NSM) to upgrade or adjust the software on

managed J Series and SRX Series devices running JUNOS Release 9.3 or later.

When a software upgrade is applied to a J Series or SRX Series device with dual Routing

Engines, the upgraded software is applied to both Routing Engines. The backup is

upgraded first. The router then reboots and the backup becomes themaster. Then the

former master is upgraded, as is the standard procedure for upgrading J Series and SRX

Series devices with dual Routing Engines.

For steps on updating the device software version, see “Upgrading the Device Software”

in the Network and Security Manager Administration Guide.

Related
Documentation

Viewing Device Inventory in NSM (NSM Procedure) on page 458•

• Viewing and Reconciling Device Inventory Overview on page 457

Viewing and Reconciling Device Inventory Overview

Device inventory management in Network and Security Manager (NSM) allows you to

display information about the hardware, software, and license components of each

device. It also provides features to update the NSM database with the most current

inventory information from the device. In addition, you can use Device Monitor, Device

List, and the device tooltip to view the status of inventory synchronization.
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These inventory management features are available for all J Series and SRX Series

devices, You can use these features to make the NSM databasematch the device

inventory, but you cannot write new inventory information to the device.

Initially, the device inventory in the NSM database is generated when the device is first

imported into NSM. Immediately after import, the device inventory in the NSM database

matches exactly the inventory on the device itself.

If the hardware on the device is changed, the software is upgraded through the J-Web

or CLI, new software packages are installed, and then the inventory on the device is no

longer synchronized with the NSM database.

The Device Monitor, Device List, and tooltip shows the hardware and software inventory

status for each device. Possible states include:

• In Sync—Inventory in the NSM databasematches the device.

• Out of Sync—Inventory in the NSM database does not match the device.

• N/A—Either the device is not yet connected andmanaged by NSM, or the device is a

ScreenOS security device or IDP sensor.

Changes to the device inventory are not automatically updated in the NSM database.

For detailed information about comparing and reconciling device inventory, see the

Network and Security Manager Administration Guide.

Related
Documentation

Viewing Device Inventory in NSM (NSM Procedure) on page 458•

Viewing Device Inventory in NSM (NSMProcedure)

NSM displays the hardware and software inventory for each device according to the

information it has in its database. For a device with dual Routing Engines, NSM collects

the inventory data from themaster Routing Engine. To view the device inventory, the

device must be in the Managed state.

To view the device inventory in NSM:

1. In the navigation tree, select DeviceManager > Devices.

2. Right-click the device whose inventory you want to view.

3. Select View/Reconcile Inventory. The Device Inventory window appears.

4. Select theHardware tab todisplay informationabouthardwaremodules in thedevice,
including the I/Omodule, the Routing Engine, and so on.

5. Select theSoftware tab todisplay information about the softwarepackages installed
in the device, including the installed OS and its version, and any other installed

packages.

Related
Documentation

Viewing and Reconciling Device Inventory Overview on page 457•
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Removing a J Series or SRX Series Device fromNSMManagement (NSMProcedure)

Deleting a device removes all device configuration information from themanagement

system, but might be the best solution if you need to perform extensive troubleshooting

or reconfigure the device locally.

To remove a J Series or SRX Series device from NSMmanagement:

1. In the NSM navigation tree, select DeviceManager> Devices.

2. Click the Device Tree tab and then select the device that you want to remove from

NSMmanagement.

3. Right-click and selectDelete, or click theDeletebutton. TheDeletedialogboxappears.

If the device is referenced in a firewall rule, this dialog box displays the rules that

reference it. You can click the links that appear to display the security policies to view

or edit those references.

4. Remove the device by clicking Next. The Delete dialog box displays the progress of

the deletion.

5. After NSM finishes, click Finish to close the dialog box.

Related
Documentation

• Adding J Series Services Routers or SRX Series Services Gateways in NSMOverview

on page 8
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CHAPTER 29

Topology Manager

• Overview of the NSM Topology Manager on page 461

• Requisites for a Topology Discovery Overview on page 461

• Understanding the NSM Topology Manager Toolbar on page 462

Overview of the NSMTopologyManager

The Network and Security Manager (NSM) Topology Manager is a tool provided in the

NSM user interface (UI) to discover andmanage the physical topology of a network of

devices connected to a Juniper Networks EX-series switch. These include networking

devices such as the J Series,M-series,MX-series, and EX-series, aswell as ScreenOSand

IDP devices, IP phones, desktops, printers, and servers. The Topology Manager also

provides details about connections between a device and the EX-series switch.

Formore informationabout theTopologyManager, see theNetworkandSecurityManager

Administration Guide.

Related
Documentation

Requisites for a Topology Discovery Overview on page 461•

• Understanding the NSM Topology Manager Toolbar on page 462

Requisites for a Topology Discovery Overview

To use the Topology Manager, first add one or more devices to the Device Manager in

NSM.Youcan thenuseanaddeddeviceasa seeddevice in initiatinga topologydiscovery.

Alternatively, if therearenodevicesaddedormanaged inNSM, youcan initiatea topology

discovery by configuring preferred subnets. All the IP addresses in the included subnets

range are discovered. Therefore, you need to have either seed devices and/or preferred

subnets to initiate topology discovery. You also need:

• Themanagement IP address of the device that acts as the seed IP address.

• SNMP credentials:

• For SNMPv1 and SNMPv2c: Community string.

• For SNMPv3: Username, security level, authentication type, privacy type, privacy

password, and authentication password.
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• Enabled Layer 2 protocols like LLDP, STP, RSTP in the switched network, because

network discovery depends on these as well as on the Address Forwarding Table

information.

For more information about the Topology Manager, see the Network and Security

Manager Administration Guide.

Related
Documentation

Overview of the NSM Topology Manager on page 461•

• Understanding the NSM Topology Manager Toolbar on page 462

Understanding the NSMTopologyManager Toolbar

You can use the Topology Manager toolbar to perform the following actions:

• Zoom in and Zoomout: Use these tools to view the network topology according to the

detail required. These tools are only of use in the map view.

• Save to file: Use this tool to save the network topology map as an image file and the

devices and links tables as text files from their respective views.

• Print: Use this tool to print a network topology map as an image file and the devices

and links tables as text files from different views.

• Manage Devices: Use this tool to select one ormore devices from a topologymap and

manage them in NSM. This tool is applicable only to map views and not the different

table views. To add a device:

a. Click theManage Devices icon. A dialog box opens.

b. Enter the SSH user name and password.

c. ClickOK.

• Set Preferences: Use this tool to set preferences according to which discovery engine

canperformatopologydiscovery.Youcansetpreferences fordefaultSNMPcredentials,

topology discovery intervals, and subnets to be included or excluded.

• Start and Stop Topology Discovery: Use these tools to initiate and stop a topology

discovery based on the set of seed devices and credentials specified in the topology

preferences.

• Search: You can search for a device, end-point device, link, or port in any of the table

views by providing a string in the search text box. NSM performs a substring match

against all attributes of the particular view and displays the results in the same table.

If you navigate to another tab, your search results are lost. You can save the search

output in a text file as comma-separated values.

The Topology Manager status bar at the bottom of the screen indicates the timestamp

of the last completed topology discovery and whether a discovery is in progress.

Formore informationabout theTopologyManager, see theNetworkandSecurityManager

Administration Guide.
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Related
Documentation

• Overview of the NSM Topology Manager on page 461

• Requisites for a Topology Discovery Overview on page 461
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CHAPTER 30

IDP Management in J Series Services
Routers and SRX Series Services
Gateways

• Updating the NSM Attack Database (NSM Procedure) on page 465

• Loading the IDP Detector Engine on a J Series or SRX Series Device (NSM

Procedure) on page 466

• Updating the Deep Inspection Attack Database on a J Series or SRX Series Device

(NSM Procedure) on page 466

Updating the NSMAttack Database (NSMProcedure)

Youmust update the attack object database before you can use IDP functionality. To

update the IDPanddeep inspection(DI)databasesandthe IDPdetectorengine,download

new attack objects from the attack object database server to the NSMGUI server.

To update the IDP and DI attack object databases on the NSMGUI server:

1. From the Tools menu in the NSMUI, click View/Update NSMAttack Database. The

Attack Update Manager wizard appears.

2. Click Next to proceed. The current attack database version in NSM and the latest

attack database version appear.

3. Click Finish to start downloading the latest attack database version from the server.

The progress and status of the attack update process appear in the Job Information

page.

4. Click one:

• Cancel Job—Cancels the IDP detector engine loading process.

• Refresh—Refreshes the status of the update process.

• Notify Later—Notifies the completion of the update process.

• Close—Closes the Job Information page.

After you have updated the attack object database on the NSMGUI server, you can use

that database to update the attack object database on your managed devices.
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Related
Documentation

Loading the IDP Detector Engine on a J Series or SRX Series Device (NSM Procedure)

on page 466

•

• Updating the Deep Inspection Attack Database on a J Series or SRX Series Device

(NSM Procedure) on page 466

Loading the IDP Detector Engine on a J Series or SRX Series Device (NSMProcedure)

IDP attack objects are loaded onto IDP-capable devices with the IDP rulebase.

To load a new detector engine onto a J Series or SRX Series device:

1. From the Devicesmenu in the NSMUI, select IDPDetector Engine > Load IDPDetector

Engine for JUNOS. The Load JUNOS IDP Detector Engine wizard appears.

2. Click Next to proceed. The available IDP detector engine versions are displayed.

3. Select the JUNOS device to be updated and click Finish. The progress and status of

the IDP detector engine update process appears in the Job Information page.

4. Click one:

• Cancel Job—Cancels the IDP detector engine loading process.

• Refresh—Refreshes the status of the update process.

• Notify Later—Notifies the completion of the update process.

• Close—Closes the Job Information page.

Related
Documentation

Updating the NSM Attack Database (NSM Procedure) on page 465•

• Updating the Deep Inspection Attack Database on a J Series or SRX Series Device

(NSM Procedure) on page 466

Updating theDeep InspectionAttackDatabaseonaJSeriesorSRXSeriesDevice(NSM
Procedure)

To update the deep inspection attack database on a J Series or SRX Series device:

1. From the Devices menu in the NSMUI, select Update Device Attack Database. The

Change Device Signature Package wizard appears.

2. Click Next to proceed. The available deep inspection signature database versions

appear.

3. Select the JUNOS device to be updated and click Finish. The progress and status of

the attack object database update process appears in the Job Information page.

4. Click one:

• Cancel Job—Cancels the attack object database update process.

• Refresh—Refreshes the status of the update process.
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• Notify Later—Notifies the completion of the update process.

• Close—Closes the Job Information page.

Related
Documentation

• Updating the NSM Attack Database (NSM Procedure) on page 465

• Loading the IDP Detector Engine on a J Series or SRX Series Device (NSM Procedure)

on page 466
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PART 4

Monitoring J Series Services Routers and
SRX Series Services Gateways

• Real Time Monitoring of J Series Services Routers and SRX Series Services

Gateways on page 471
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CHAPTER 31

Real Time Monitoring of J Series Services
Routers and SRX Series Services
Gateways

• Realtime Monitor Overview on page 471

• Viewing Device Status on page 471

• Viewing Device Monitor Alarm Status (NSM Procedure) on page 474

• Configuring the Polling Interval for Device AlarmStatus (NSMProcedure) on page 475

RealtimeMonitor Overview

TheRealtimeMonitormodule inNSM includesviews that youcanuse tomonitor real-time

statusandstatisticsaboutall themanagedsecuritydevices,VPNtunnels,NSRPclusters,

IDP sensors, and IDP clusters in your network. You can also use the Realtime Monitor to

identify problems, track security events, and discover trends across multiple geographic

regions and functional areas from a central management location.

The Realtime Monitor can also help you quickly identify potential device, network, and

system-level problems, such as:

• Configuration status—At the device level, you canmonitor the changing status of one

or more security devices in real time.

• Connection status—At the network level, you canmonitor problems that could lead

to failed devices.

The Realtime Monitor does the work of a management expert by first gathering

information about specific processes and network activity, and then color-coding each

event to organize problems.

Related
Documentation

Viewing Device Status on page 471•

Viewing Device Status

Table 262 on page 472 lists and describes device information that you can view through

the Device Monitor.
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Table 262: Device Status Information

DescriptionColumn

Unique name assigned to the device in NSM.Name

Domain in NSM in which the device is managed.Domain

Model number of the device.Platform

Operating system firmware version running on the device.OS Version

Current configuration status of the device in NSM:

• None—No state has been set (does not show in Device Monitor).

• Modeled—The device exists in NSM, but a connection to the device has
not yet been established.

• RMA—Equivalent to bringing the device into the Modeled state. RMA
results fromanadministrator selection in theUIwhenadevicegoesdown.

• Waiting for 1st connect—NSM is waiting for the device to connect. You
must enter a command on the device to make it connect to NSM.

• Import Needed—Youmust import the configuration of the device into
NSM.When you add a device for the first time, verify that your status
indicates “ImportNeeded”before youattempt to import thedevice.During
migration, this state indicates that import of the security device
configuration is still required.

• OS Version Adjustment Needed—The firmware version detected running
on the device is different fromwhatwas previously detected in NSM. This
could happen in the event that the automatic adjustment option was
cleared during a change device firmware directive or an Update Device
directive was issued to an IDP device with a firmware version mismatch.

• PlatformMismatch—The device platform selected when adding the DMI
device in NSM does not match the device itself. A device in this state
cannot connect to NSM.

• Device FirmwareMismatch—TheOS version selectedwhen adding a DMI
device does not match the OS version running on the device itself.

• Device Type Mismatch—The type of device specified when adding the
device in NSM does not match the device itself. The device typemight
indicate whether the device is part of a vsys device, part of a cluster, or
part of a virtual chassis. A device in this state cannot connect to NSM.

• Detected duplicate serial number—The device has the same sequence
numberasanothermanageddevice.Adevice in this state cannot connect
to NSM.

• Update Needed—An update to this device is required.

• Managed—The device is currently being managed by NSM.

• Managed, In Sync—The physical device configuration is synced with the
modeled configuration in NSM.

Config Status
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Table 262: Device Status Information (continued)

DescriptionColumn

• Managed, Device Changed—The physical device configuration is out of
sync with the modeled configuration in NSM. Changes were made to the
physical device configuration (the configuration on the physical device is
newer than themodeled configuration).

• Managed, NSM Changed—Themodeled device configuration is out of
sync with the physical device configuration. Changes were made to the
modeled configuration (the configuration on the NSM is newer than the
physical device configuration).

• Managed,NSMandDeviceChanged—Bothdeviceconfigurations(physical
andmodeled) are out of sync with each other. Changes were made to
the physical device configuration and to the modeled configuration.

• Managed, Sync Pending—Completion of the Update Device directive is
suspended andwaiting for the device to reconnect. This state occurs only
forScreenOSdevices thathave theUpdateWhenDeviceConnectsoption
selected during the device update.

Config Status
(continued)

Connection status of the device in NSM:

• Up—Device is currently connected to NSM.

• Down—Device is not currently connected to NSM but has connected in
the past.

• Never Connected—Device has never connected to NSM.

The Device Server checks the connection status of each device every 120
seconds by default. You can change this behavior by editing the value for
the devDaemon.deviceHeartbeatTimeout parameter in the Device Server
configuration file. Refer to the Network and Security Manager Installation
Guide for more information on editing configuration files.

NOTE: If the network connection goes down for a period longer than six to
eightminutes, thedevice connectionwill permanently timeout. If this occurs
and the device goes down for any reason, the device still appears as Up in
the Device Monitor.

Connection
Status

Displays the current alarm status for each device in NSM:

• If devicehasanyalarms, themost severealarmseverity isdisplayed(either
Major or Minor).

• None—The device has no alarms.

• Unknown—The device status is unknown. For example, the device might
not be connected.

• N/A—The device's alarm is not pollable or discoverable, for example, this
column shows "N/A" for ScreenOS and IDP devices.

• Alarm is colored:

• Red for Major.

• Orange for Minor.

• Green for Ignore, None, Unknown, or N/A.

Alarm
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Table 262: Device Status Information (continued)

DescriptionColumn

Displays the inventory status for hardware on the device:

• In Sync—The inventory information in the NSM database is synchronized
with the information on the device.

• Out Of Sync—The inventory information in the NSM database is not
synchronized with the information on the device.

• N/A—The connected device is a ScreenOS or IDP device, or the device is
not connected and imported.

H/W Inventory
Status

Displays the inventory status for software on the device:

• In Sync—The inventory information in the NSM database is synchronized
with the software on the device.

• Out Of Sync—The inventory information in the NSM database is not
synchronized with the software on the device.

• N/A—The connected device is a ScreenOS or IDP device, or the device is
not connected and imported.

S/W Inventory
Status

Displays the inventory status for software on the device:

• In Sync—The inventory information in the NSM database is synchronized
with the licenses on the device.

• Out Of Sync—The inventory information in the NSM database is not
synchronized with the licenses on the device.

• N/A—The connected device is a ScreenOS or IDP device, or the device is
not connected and imported.

License Inventory
Status

The first time the security device connected to the NSM Device Server.First Connect

The last time the security device connected to the NSM Device Server.Latest Connect

The last time the security device disconnected from the NSMDevice Server.LatestDisconnect

Related
Documentation

Viewing Device Monitor Alarm Status (NSM Procedure) on page 474•

• Configuring the Polling Interval for Device AlarmStatus (NSMProcedure) on page 475

Viewing DeviceMonitor Alarm Status (NSMProcedure)

Alarms refresh automatically through periodic polling.

To view the alarm status and time:

1. FromDeviceMonitor, right-click thedevice rowentryandselect theViewAlarmoption.

The device Alarm Status dialog box displays the alarm list and polling time for the

device.

2. Retrieve the current alarm status in the device by clicking the Refresh button.
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The poll time is derived from the device server time.

Related
Documentation

Viewing Device Status on page 471•

• Configuring the Polling Interval for Device AlarmStatus (NSMProcedure) on page 475

Configuring the Polling Interval for Device Alarm Status (NSMProcedure)

The default polling interval is 900 seconds (15 minutes). To configure polling intervals

for alarm Status:

1. In the NSM navigation tree, select DeviceManager > Devices.

2. Click the Device Tree tab, and then double-click the device to set the polling interval.

3. Click the Info tab, and select Device Admin.

4. Set the polling interval for the device. Theminimum polling interval is 60 seconds.

Themaximum interval is 2,147,483,647 seconds. You cannot disable polling.

5. Click one:

• OK—Saves the changes.

• Cancel—Cancels the modifications.

Related
Documentation

• Viewing Device Status on page 471

• Viewing Device Monitor Alarm Status (NSM Procedure) on page 474
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Index

• Index on page 479
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