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Introduction

Juniper Networks EX Series Ethernet Switches are shipped with the Juniper Networks Junos operating
system (Junos OS) installed.

Junos OS has the following primary user interfaces:

e Juniper Web Device Manager (J-Web) GUI

e Junos OS CLI

You can use these interfaces to access, configure, and manage your EX Series switch.

This topic provides an overview of the newly re-designed J-Web interface.
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Supported EX Series Switches

In Junos OS Release 21.2A1, the J-Web interface supports EX4650 switches as standalone switches,
EX2300, EX2300-C, EX2300-MP, EX3400, EX4300, EX4300-MP, and EX4600 switches which are
supported from earlier releases.

NOTE: You cannot connect to and perform initial configuration of EX4600 and EX4650 switches
by using the EZSetup procedure from the J-Web interface; you must use EZSetup from the
switch console.

To obtain more information about the components that are supported on each switch, and the special
compatibility guidelines for the release, see the Hardware Guide for the switch.

To determine the features supported on EX Series switches in this release, use the Juniper Networks
Feature Explorer, a Web-based application that helps you to explore and compare Junos OS feature

information to find the right software release and hardware platform for your network. Find Feature
Explorer at https:/apps.juniper.net/feature-explorer/.


https://apps.juniper.net/feature-explorer/
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Distribution Model
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For Junos OS Release 14.1X53-D10 and later, the J-Web interface is available in two packages:
e Platform package—Provides basic features of J-Web and is installed as part of Junos OS.

The Platform package of J-Web is installed as part of Junos OS that is shipped with your EX Series
switch. The Platform package provides the basic features of the J-Web interface. The Platform
package enables you to configure and maintain your switch.

e Application package—Provides all features of J-Web and is a separately installable package.

The Application package is not installed by default on your switch. You must download it and install it
over the Platform package on your switch. The Application package provides all the features of the J-
Web interface that enable you to configure, monitor, maintain, and troubleshoot your switch.

For information about installing the Application package, see "Upgrading to J-Web Application Package"
on page 7.

The Platform package, which is installed as part of the Junos OS that is shipped with your switch,
follows the Junos OS release cycle. However, the Application packages have their own release cycle
which is independent of the Junos OS release cycle. This separate release cycle helps you get the latest
features of J-Web by installing the latest version of the Application package, without waiting for Junos
OS releases.

NOTE:

e The J-Web Application package is hot-pluggable. You can install it on top of the current Junos
OS installation, and you need not reboot the switch after the installation.



e To determine which J-Web package you are currently using, click Help > About. The About
window appears. If you are using a Platform package, only the Platform package details are
displayed. If you are using an Application package, both the Platform package and Application
package details are displayed.

If your current J-Web package is: Then you can:
Platform package Upgrade to the Application package.
Application package Update to a latest version of the Application

package available on the Juniper Networks server
that is compatible with the Junos OS on your
switch.

NOTE: If you upgrade Junos OS on your switch, the current J-Web package is replaced with the
J-Web Platform package that is associated with the upgraded Junos OS release. You can then
install the latest Application package that is associated with the main release of the upgraded
Junos OS, over the Platform package.

Release Compatibility

The Application packages of J-Web have their own release cycles (A1, A2, A3, and so on), which are
independent of the Junos OS release cycle. An Application package is compatible only with the
corresponding major release of Junos OS.

Table 1 on page 3 lists the release compatibility.

Table 1: J-Web Release Compatibility Matrix

Junos OS Release Associated J-Web Application Package Release

14.1X53-D10 through 14.1X53-D46 Application package 14.1X53-A2



Table 1: J-Web Release Compatibility Matrix (Continued))

Junos OS Release

14.1X53-D47 and later

15.1R1

15.1R3

15.1X53-D50

16.1R1

17.1R1

17.2R1

17.3R1

15.1X53-D57

17.4R1

18.1R1

18.1R2

18.2R1

Associated J-Web Application Package Release

Application package 14.1X53-A3

Application package 15.1A1

Application package 15.1A2

Application package 15.1A3

Application package 15.1X53-A1

NOTE: This release is only for EX2300, EX2300-

C, and EX3400 switches.

Application package 16.1A1

Application package 17.1A1

Application package 17.2A1

Application package 17.3A1

Application package 15.1X53-A2

Application package 17.4A1

Application package 18.1A1

Application package 18.1A2

Application package 18.2A1



Table 1: J-Web Release Compatibility Matrix (Continued))

Junos OS Release

18.2R1 and later and all service releases of
18.2R1 and later

18.3R1

18.4R1

18.4R1 and later and all service releases of
18.4R1 and later

19.1R1

19.2R1

19.3R1

19.3R1 and later and all service releases of

19.4R1

20.1R1

20.1R1

20.2R1

20.3R1

20.4R1

Associated J-Web Application Package Release

Application package 18.2A2

Application package 18.3A1

Application package 18.4A1

Application package 18.4A2

Application package 19.1A1

Application package 19.2A1

Application package 19.3A1

Application package 19.3A2

Application package 19.4A1

Application package 20.1A1

Application package 20.1A2

Application package 20.2A1

Application package 20.3A1

Application package 20.4A1



Table 1: J-Web Release Compatibility Matrix (Continued)

Junos OS Release Associated J-Web Application Package Release
21.1R1 Application package 21.1A1
21.2R1 Application package 21.2A1

Any available later version of the Application package for a Junos OS release supersedes the earlier
version. We recommend that you install the latest available version of the Application package.

‘ New and Changed Features | 6

New and Changed Features

IN THIS SECTION

What's New in J-Web Application Package Release 21.2A1 | 7
Upgrading to J-Web Application Package | 7

Software Compatibility | 8

This section describes the features and enhancements in J-Web Application Package Release 21.2A1.



What'’s New in J-Web Application Package Release
21.2A1

J-Web Application package releases support the EX4650 switches as standalone switches, EX2300,
EX2300-C, EX2300-MP, EX3400, EX4300, EX4300-MP, and EX4600 switches which are supported
from earlier releases.

NOTE: You cannot connect to and perform initial configuration of EX4600 and EX4650 switches
by using the EZSetup procedure from the J-Web interface; you must use EZSetup from the
switch console.

Upgrading to J-Web Application Package

There are two ways in which you can download and install the J-Web Application package:

e Manual update
e CLI procedure

There is a prescribed order for the installation tasks for updating to the Application package from an
earlier version or from the Platform package. See Table 2 on page 8 to determine the prescribed order
of tasks for your installation.



Table 2: Installation Outline

Mode of Installation Installation Outline

Manual Update To manually check and install the latest J-Web
Application package:

1. Go to Maintain > Update J-Web in the side
pane, and click Select Application Package.

2. Select Local File in the Update J-Web window,
enter authentication details download the file
to your local system, select the file, and click
Update.

CLI Procedure 1. Download the J-Web Application package and
save it in the switch.

2. Login to the CLI and enter the operational
mode.

3. Install the package using the CLI command
request system software add <application
package file name>.

Software Compatibility

To access the J-Web interface for the switch, your management device requires the following software:
e Supported browsers—Microsoft Internet Explorer versions 9 or 10, Mozilla Firefox version 24

through 38, and Google Chrome version 27 through 43.

NOTE: We recommended a screen resolution of 1440 X 900 pixels.

e Language support—English-version browsers.
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This section lists the known issues in the J-Web Application package Release 21.2A1.

Known Issues

Table 3 on page 10 lists the PR numbers and its description that are known issues in the J-Web
Application package Release 21.2A1.



Table 3: Known Issues

PR Number Problem Description

NA Adobe Flash Player support ended on December
31, 2020. Therefore:

e For Junos OS Release 20.3R1 and earlier
releases, the following pages will not load
correctly:

e Monitor > System View > Process Details
e Monitor > Interfaces

e Monitor > Power over Ethernet

e Monitor > Service > DHCP > Server

e Monitor > Service- > DHCP > Relay

e Monitor > Switching > IGMP Snooping

e Monitor > Virtual Chassis

e Monitor > Security > Port Security

e Monitor > Routing > OSPF Information

e For Junos OS Release 20.4R1 and later
releases, the following pages will not be
supported:

e Monitor > System View > Process Details

Monitor > Power over Ethernet

e Monitor > Service- > DHCP > Relay
e Monitor > Switching > IGMP Snooping
e Monitor > Virtual Chassis

e Monitor > Security > Port Security



Table 3: Known Issues (Continued)

PR Number Problem Description

e Monitor > Routing > OSPF Information

e For Junos OS Release 20.4R1 and later
releases, the following pages will be
supported. However, the Flash components
are removed.

e Monitor > Interfaces

e Monitor > Service > DHCP > Server

959505 On EX4300 switches, the structured-data format
for system log messages is not supported in the
J-Web interface. If system log messages are
configured to be written in structured data, the
event logs in J-Web is not populated, and you are
unable to view them using Monitor > Events and
Alarms > View Events.

Workaround: Use the show log operational mode
command for viewing structured-data format
files.



Table 3: Known Issues (Continued)

PR Number Problem Description

1029736 In the Maintain > Update J-Web page, Select
Application package > Update J-Web, local file
does not work in Microsoft IE9 and later releases,
because of the default security options set on
these browsers. As a workaround, increase the
security level:

Method 1:

1. Navigate to Internet Options > Security.
2. Select the zone Local intranet.

3. Click the custom level button.

4. Disable the option Include local directory Path
when uploading file to the server in the
Settings > miscellaneous section.

5. Repeat Step 3 and Step 4 for the zone
Internet.

Method 2:

Navigate to Internet Options > Security >
Custom level... and set Reset custom settings to
Medium-High or High. This automatically
disables the option /nclude local directory Path
when uploading file to the server under Settings
> miscellaneous section.

Known Limitations

Table 4 on page 13 lists the PR numbers and its description that are known limitations in the J-Web
Application package Release 21.2A1.



Table 4: Known Limitations

PR Number

1513612

777372

604595

Problem Description

For Junos OS release 18.X and 19.X and its
service releases, the auto update option is not
supported.

Where X is R1, R2, R3, and R4.

NOTE: To disable the auto update information,
go to Maintain > Update J-Web page and clear
the Check for updates automatically on every
login check box under Update Preference.

To manually check and install the latest J-Web
Application package:

1. Go to Maintain > Update J-Web in the side
pane, and click Select Application Package.

2. Select Local File in the Update J-Web window,
enter authentication details, download the file
to your local system, select the file, and click
Update.

If a Virtual Chassis contains more than six
members, the Support Information page
(Maintain > Customer Support > Support
information) might not load. This is a known
software limitation.

The J-Web interface does not support role-based
access control; it supports only users in the
super-user authorization class. Therefore, a user
who is not in the superuser class, such as a user
with view-only permission, is able to launch the
J-Web interface and is allowed to configure
everything, but the configurations fail on commit,
and the switch displays access permission errors.
This is a known software limitation.



Table 4: Known Limitations (Continued)

PR Number

1026308

1006208

915069

Problem Description

If you uninstall the J-Web Platform package by
using CLI, reinstalling the Application package
will not restore J-Web.

Workaround: Reinstall Junos OS software.

J-Web software does not compare for
appropriateness of the Application package or
restrict you from installing inappropriate
Application package on top of a Platform or
Application package.

Workaround: Install the appropriate J-Web
package.

The J-Web interface does not display CLI
generated certificates in the Certificate section in
the Management Access Configuration page
(Configure > System Properties > Management
Access). Using J-Web interface you cannot create
or edit certificates.

Workaround: Use the CLI interface for accessing
certificate related configurations.



Table 4: Known Limitations (Continued)

PR Number

400814

425693

866976
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Problem Description

In the J-Web interface, you cannot commit some
configuration changes in the Ports Configuration

page or the VLAN Configuration page because of
the following limitations for port-mirroring ports

and port-mirroring VLANS:

e A port configured as the output port for an
analyzer cannot be a member of any VLAN
other than the default VLAN.

o A VLAN configured to receive analyzer output
can be associated with only one interface.

This is a known software limitation.

Workaround: None.

In the J-Web interface, the Ethernet Switching
Monitor page (Monitor > Switching > Ethernet
Switching) might not display monitoring details if
the switch has more than 13,000 MAC entries.
This is a known software limitation.

When you try to commit your changes to the
switch from your laptop by using the EZsetup
procedure, the status of the commit operation is
displayed as Success, even if the laptop is
disconnected from the switch.

Workaround: Reconnect your laptop to the
switch and commit the changes again.
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