Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

 

Simulation Menu: Predefined Scenarios

 

Scripted simulations are predefined simulation scenarios, which provide a quick and easy way for you to test the network's resiliency to various failures. For each script, a failure report is automatically generated.

Note

Before running a scripted, or batch simulation, be sure to review your failure simulation option settings. These can be accessed by selecting Tools > Options > Failure Simulation, and are described in detail in Tools: Options Menu. By default, an exhaustive failure simulation will fail all elements one for each simulation. To specify not to fail certain nodes or links, first modify the node (Design Properties tab) or link (Properties tab) and set FAIL=0 to true.

Scripts

Exhaustive Single Element Failures



The exhaustive single failure scripts fail all network elements of a given type, one at a time.

Figure 1: Single Failure Simulation Window
Single Failure Simulation Window
  • Exhaustive Node Failure: Exhaustively fails every single node in the network.

  • Exhaustive Link Failure: Exhaustively fails every single trunk in the network.

  • Exhaustive Site Failure: Exhaustively fails all sites in the network. A site file is required to define nodes within the same site. Nodes that are not grouped within a site are considered sites by themselves.

  • Exhaustive Slot Failure: Exhaustively fails all slots that are defined in the network (router networks only).

  • Exhaustive Card Failure: Exhaustively fails all cards that are defined in the network. For all ATM networks, cards can be specified in the definition of links. Go to the Links detail tab and select the Location tab. For certain router models, cards can be defined through the Equipment View feature. Select Inventory > Hardware Inventory, or right-click on a node and select View > Equipment View.

  • Exhaustive SRLG/Facility Failure: Fails all facilities. A facility file is required to define node and trunk facility associations. Trunks that are not associated with a facility are considered to be facilities by themselves.

  • Exhaustive Parallel Links Failure: Exhaustively fails all trunks between all node pairs.

  • Exhaustive Voice Trunk Group Failure: Exhaustively fails all voice trunk groups defined in the network. Select Network > Voice > Trunk Group to examine the trunk groups in your network. Addition of trunk groups through the Java user interface is not supported at this time, although modification is supported. To define trunk groups, the trunk group file should be edited through a text editor.



Reports



  • The Peak Link Utilization Report (Simulation Reports > Network Statistics > Peak Link Utilization) records the maximum trunk utilization for each trunk during the period of all the selected simulations and the element whose failure triggered this maximum utilization. Peak utilization is reset each time predefined scenarios are run. See Report Manager: Simulation Reports for details on this report. The resulting peak utilizations can also be viewed graphically on the Standard map by selecting Utilization Legends > Peak Util.

  • PeakSimLink: The PeakSimLink report contains detailed information on oversubscribed links after the exhaustive failure simulation.

  • PeakSimRoute:The PeakSimRoute report contains detailed information of failed demands or tunnels.

  • PeakSimReroute: The PeakSimReroute report contains detailed information for rerouted demands or tunnels. To generate this report, select Generate Detailed Reroute Report from the Options tab.

  • PeakSimSummary: The PeakSimSummary report contains a summary of all exhaustive failure simulations performed.



Exhaustive Multiple Element Failures



Figure 2: Multiple Failure Simulation Window
Multiple Failure Simulation Window

To run an exhaustive failure script for the simultaneous failure of 2 or 3 elements, select the Multiple Failure tab. Select the number of elements to be failed together (Double or Triple), select the Exhaustive radio button, and then select the element type to be failed (node, link, etc.) for the Failures Type. For example, selecting Double, Exhaustive Failure, for the Failure Types: Node and Link and then clicking the Run button will result in an exhaustive failure simulation of node & node, node & link, and link & link combinations.

To randomly simulate a specified number of double or triple failures, rather than all possible failure combinations exhaustively, select “Cases to Simulate” instead of Exhaustive Failure, and enter the number of cases to simulate.

Report Options

Figure 3: Report Options
Report Options
  • Include Simulation Events for all Periods: In the Peak Link Utilization report, information is provided regarding the event triggering the peak link utilization, indicating which failure type triggered the peak link simulation (for example, node, link, or facility) and the name of the element. With this option unchecked, the simulation event is reported only for the planned period (based on the demand file) and worst failure scenario among the periods of the trafficload file. If this option is checked, the simulation event is also displayed for all of the individual periods (up to 24).

  • Generate Demand Over Tunnel Utilization Report: This option will generate the Demand Traffic on Tunnel report in the Tunnel layer reports.

  • Generate Peak Group Transit Statistics: Records the maximum number and bandwidth of demands transiting through a topology group. This information is displayed in the Group > Group Demand Bandwidth Distribution report of the Report Manager. These statistics can also be turned on by first setting CheckTransitDemandLimit=2 in the dparam file before opening the specification file.

  • Generate SRLG and Up-Down Sequence for Upper Layer: Selecting this option will generate a report, UPDOWN.runcode, which lists the demands or tunnels that went down during the simulation. This report is often used as an Up-Down Sequence File in an upper layer network in which the demands of the lower layer network are translated into links in the upper layer network. Thus, the demands that are reported as being down in the UPDOWN.runcode report can be read in as downed links in a custom failure simulation script for an upper layer network. Additionally, an SRLG file is created, based on the set of demands of the lower layer (links of the upper layer) which go down together.

  • Generate Detailed Reroute Information: Report detailed information on demands that rerouted during the failure simulation.

Advanced Options

Figure 4: Advanced Options
Advanced Options

Fast Reroute Options

(Router networks only): See the Fast Reroute chapter of the Paragon Planner User Guide for more information.

Replay Up-Down Sequence

Use a custom failure simulation script. The file name of the script must be specified. An example of a custom failure simulation script is provided below:

Before you run an up-down sequence simulation, you must first specify whether to simulate Every Event or to simulate When WAIT/RESET is Encountered. Assuming the latter, in the above example, Link1 and Link2 is brought down first.

At the RESET line, the program will attempt to route all unplaced demands in the network (and generate the appropriate reports), after which all links are brought back up and all demands are placed back in their original paths. The program will then fail Link3 and Link4. Upon seeing the RESET LINK line, the program will again attempt to route all affected and unplaced demands in the network (and append the appropriate reports), after which all links are brought back up.

However, this time, the demands will not be placed back in their original paths; instead, the demands will remain routed according to the paths found while Link3 and Link4 were down. The program will then go on to fail Link5 and Link6. At the WAIT line, the program will attempt to route all unplaced demands (and append the appropriate reports), but will not bring up any links afterwards. Node1 and Node2 are then failed, and at the next RESET line the program will attempt to route all unplaced demands in the network while Link5, Link6, Node1, and Node2 are all down (and append the appropriate reports), after which all links and nodes are brought back up and all demands are assigned to their original paths.

After the program has finished running through the script, you may view the appropriate failure simulation reports for information recorded at each of the RESET, RESET LINK, and WAIT lines.

If you choose to simulate Every Event, then the program will run a simulation after every network failure. In the above example, Link1 is taken down first, and the unplaced demands are rerouted and the appropriate reports generated. Then, Link2 is taken down (Link1 is still down) and the unplaced demands are rerouted. When RESET is encountered, all links are brought back up and all demands are placed back in their original paths.

Interactive Scenarios

Interactive Simulation allows you to specify the nodes, trunks, and/or facilities that he wants to fail for the simulation run. Subsequent failures can also be performed by continuing the simulation using a different set of failed elements.

Note

Before running an interactive simulation, review your failure simulation option settings via Tools > Options > Failure Simulation, and are described in detail in Tools: Options Menu.

Fail Link



Fails selected trunks in the network. In the Fail Links tab, a list of all trunks is displayed. To fail a link, simply select the row for a link. The link is grayed out on the map and marked with a red ‘F’ symbol to indicate its failure. To bring a trunk back up, select the failed trunk. 'Reset All' will bring all failed trunks up. Use the View Changes option to see how the failure impacts link utilization, and demand/tunnel routing.

Figure 5: Fail Links Window
Fail Links Window


Fail Interface



The purpose of this tab is to study the failure of a physical interface, which can have multiple logical links. For example, failing fe-0/1/2 on router ATL_TEST will cause 3 logical links associated with fe-0/1/2.0, fe-0/1/2.211, fe-0/1/242 to fail. Select the row for a physical interface to bring down or up the physical interface and associated logical links. ‘Reset All’ will bring all failed interfaces up. Use the View Changes option to see how the failure impacts link utilization, and demand/tunnel routing.



Fail Node



Fail selected nodes in the network. Use the View Changes option to see how the failure impacts link utilization, and demand/tunnel routing.

Figure 6: Fail Nodes Window
Fail Nodes Window


Fail Facility



Fail selected facilities in the network. A facility file must be defined and loaded in order to use this feature.

Use the View Changes option to see how the failure impacts link utilization, and demand/tunnel routing.



Run, Step, Stop



  • Run is used to run a simulation with the given failures.

  • Step is used to step through a simulation. A step consists of the rerouting of a single demand. For each step, a Paths window appears indicating the rerouted path (if any) and the disconnected path. This feature is applicable only when a running simulation has been stopped.

  • Stop is used to stop a running simulation.



View Changes



The following changes can be viewed after performing the interactive simulation:

  • View Link Changes: View changes to the link utilization and RSVP utilization

  • View Demand Changes: View changes to the demand placement, number of hops, and delay (ms)

  • View Tunnel Changes: View changes to the tunnel placement, number of hops, and delay (ms)



Reset Simulation



Reset the simulation to the initial network state. All trunks and nodes are set to active and all demands are routed according to the state at which the simulation mode was entered.

Related Documentation